Sepi - Moteur de script orienté objet pour Delphi

Sepi

Sepi
Class Tree
Index
Previous
Next

Name
Sepi

Description
Moteur de script orienté objet pour Delphi
Sepi est un moteur de script orienté objet pour Delphi.

Author
Sébastien Doeraene

Units
Unit | Description
CompilerContext | Contexte de compilation
CompilerOptions | Options de compilation
ComponentExplorer | Cadre montrant les informations d'un meta
ExplorerConsts | Constantes de l'explorateur
ExplorerOptions | Options de l'explorateur
GeneratorOptions | #No TAG found in source code#
GeneratorUtils | Utilitaires de génération du parser
ImporterConsts | Constantes de l'importeur
ImporterContext | Contexte d'importation
ImporterOptions | Options de l'importeur
ImporterProducer | Producteur d'importeur d'unité native dans Sepi
ImporterTemplates | Processeur de template simple
Imports | #No TAG found in source code#
Imports | Importe toutes les unités que Sepi importe en standard
MembersInfo | Informations sur les membres Sepi
RunOptions | Options d'exécution
ScClasses | Extension de Classes
ScCompilerMagic | Propose une série d'alias aux routines cachées de System
ScConsoleUtils | Utilitaires de gestion d'un programme en console
ScConsts | Définit les différentes constantes de la SCL
ScCoroutines | Classes de gestion de coroutines
ScDateTimeUtils | Définit quelques routines de dates et heures
ScDelphiLanguage | Définit des routines en lien avec le langage Delphi lui-même
ScEnumerators | Classes d'énumérateurs fonctionnant en coroutine
ScIntegerSets | Ensemble d'entiers
ScInterfaces | #No TAG found in source code#
ScLists | Définit des classes de listes diverses
ScLOGFile | Définit une classe de gestion d'un fichier LOG
ScMaths | Définit des classes et routines de mathématiques avancées
ScMD5 | Gestion de hashes MD5
ScNoSecretWindow | Empêche la création par Delphi de sa fenêtre secrète
ScPipes | Classes de gestion de pipes (tuyaux)
ScSerializer | Routines de sérialisation de données non classes
ScStrUtils | Définit quelques routines de gestion de chaînes
ScSyncObjs | Définit des classes de synchronisations entre threads
ScTypInfo | Étend les informations et les routines proposées par l'unité TypInfo
ScUtils | Définit quelques routines usuelles
ScWindows | Types et routines dépendant de la plate-forme Windows
ScXML | #No TAG found in source code#
ScZLib | Définit deux routines de compression et décompression avec ZLib
SdAbout | Boîte de dialogue À propos
SDCConsts | Constantes du projet SepiDelphiCompiler
SdDialogs | Définit des routines et composants utilisant des boîtes de dialogue
SdNumber | Boîte de dialogue demandant un nombre à l'utilisateur
SdPassword | Boîte de dialogue de saisie de mot de passe
SepiAbout | Définit le composant « À propos » de Sepi
SepiArrayTypes | Définit les classes de gestion des types tableau
SepiAsmInstructions | Instructions assembleur Sepi
SepiCompiler | Compilateur Sepi
SepiCompilerConsts | Constantes utilisées dans un compilateur Sepi
SepiCompilerErrors | Gestion des erreurs de compilation Sepi
SepiCompilerUtils | #No TAG found in source code#
SepiConsts | Définit les constantes générales de Sepi
SepiCore | Définit les classes coeur de Sepi
SepiDelphiCompiler | Classes de compilation d'une unité Delphi dans Sepi
SepiDelphiCompilerConsts | Constantes pour la compilation d'unité unité Delphi en Sepi
SepiDelphiLexer | Analyseur lexical d'une unité Delphi
SepiDelphiLikeCompilerUtils | Utilitaires pour les compilateurs Sepi de langages ressemblant à Delphi
SepiDelphiParser | #No TAG found in source code#
SepiDisassembler | Désassembleur Sepi
SepiExecution | Exécution d'une unité Sepi
SepiExplorerMain | Fiche principale de l'explorateur
SepiExpressions | Expressions Sepi
SepiInCalls | Gestion des appels entrant dans Sepi
SepiInstructions | Instructions de haut niveau Sepi
SepiLexerUtils | Utilitaires d'analyse lexicale Sepi
SepiLL1Grammars | #No TAG found in source code#
SepiLL1ParserUtils | Utilitaires d'analyse syntaxique LL(1) pour Sepi
SepiMembers | Définit les classes de gestion des types composites
SepiOpCodes | Types et constantes définissant les OpCodes de Sepi
SepiOrdTypes | Définit les classes de gestion des types ordinaux
SepiParserUtils | Utilitaires d'analyse syntaxique Sepi
SepiParseTrees | Arbres syntaxiques Sepi
SepiPSCompiler | Compilateur d'unité Sepi-PS
SepiPSCompileTime | Liaison Sepi-PS à la compilation
SepiPSExecuter | Exécuteur d'unité Sepi-PS
SepiPSLoader | Chargeur d'unité Sepi-PS
SepiPSRunTime | Liaison Sepi-PS à l'exécution
SepiPSUtils | Utilitaires pour les liaisons Sepi-PS
SepiReflectionConsts | Définit les constantes du package SepiBinaries
SepiReflectionCore | Définit les classes de gestion des meta-unités
SepiRuntime | Interpréteur Sepi
SepiRuntimeOperations | Opérations sur les variables à l'exécution
SepiStdCompilerNodes | Classes de compilation standard d'une unité Sepi
SepiStrTypes | Définit les classes de gestion des types chaîne
SepiSystemUnit | Définit les classes de gestion de l'unité System
SvEdits | Composants de type Edit
SvImages | Composants de type Image
SvLabels | Composants de type Label
TypesInfo | Informations sur les types Sepi

Sepi
Class Tree
Index
Previous
Next

Copyright (c) 2006-2010 Sébastien Doeraene
Created with DelphiCodeToDoc. To obtain the latest revision, please visit http://dephicodetodoc.sourceforge.net/


Sepi

Sepi
Previous (Sepi)
Next

Name
_ClassHierarchy

Class Hierarchy

#ROOT#

TObject

* TCompilerContext

* TImporterContext

* TSepiImporterProducer

* TTemplate

* TExplorerOptions

* TOutputWriter

* TGenerator

* TLL1Conflict

* TParsingTable

* TGramSymbol

* TTerminal

* TNonTerminal

* TChoiceEnd

* TChoice

* TGrammar

* TSepiExecution

* TCommandLineOption

* TOptionAlias

* TCommandLineSwitch

* TIntegerOption

* TStringOption

* TEnumOption

* TCommandLine

* TOptions

* TOptions

* TGeneratorOptions

* TSepiRunOptions

* TCustomCoroutine

* TCoroutine

* TCustomEnumerator

* TCustomIntegerEnumerator

* TIntegerEnumerator

* TScIntegerSetEnumerator

* TScIntegerSet

* TSepiLocalVarLife

* TPremSet

* TSuivSet

* TChooseIfSet

* StringsOps

* TCustomValueBucketList

* TValueBucketList

* TScLogFile

* TPolynom

* TPolynomList

* TScTask

* TScCustomMethodTask

* TScMethodTask

* TScCustomMessageTask

* TScMessageTask

* TSepiUnitLoadTask

* TSepiAsmCallParam

* TSepiAsmCallParams

* TSepiInstructionRef

* TSepiInstruction

* TSepiAsmInstr

* TSepiAsmNope

* TSepiAsmJump

* TSepiAsmCondJump

* TSepiAsmCall

* TSepiAsmAddressCall

* TSepiAsmRefCall

* TSepiAsmStaticCall

* TSepiAsmDynamicCall

* TSepiAsmLoadAddress

* TSepiAsmMove

* TSepiAsmConvert

* TSepiAsmOperation

* TSepiAsmCompare

* TSepiAsmGetRunInfo

* TSepiAsmIsClass

* TSepiAsmAsClass

* TSepiAsmRaise

* TSepiAsmReraise

* TSepiAsmTryExcept

* TSepiAsmTryFinally

* TSepiAsmMultiOn

* TSepiAsmSetIncludeExclude

* TSepiAsmSetIn

* TSepiAsmSetElem

* TSepiAsmSetRange

* TSepiAsmSetCompare

* TSepiAsmSetOperation

* TSepiAsmSetExpand

* TSepiAsmValueToIntStdFunction

* TSepiAsmStrSetLength

* TSepiAsmDynArraySetLength

* TSepiAsmStrCopy

* TSepiAsmDynArrayCopy

* TSepiInstructionList

* TSepiNamedLabel

* TSepiIfThenElse

* TSepiCaseOf

* TSepiWhile

* TSepiFor

* TSepiTryExcept

* TSepiTryFinally

* TSepiAssignment

* TSepiExecuteExpression

* TSepiRaise

* TSepiReraise

* TSepiMultiOn

* TSepiSpecialJump

* TSepiContinue

* TSepiBreak

* TSepiExit

* TSepiAsmInstrList

* TSepiLocalVar

* TSepiLocalVariables

* TSepiTempVarsLifeManager

* TSepiLanguageRules

* TSepiDelphiLanguageRules

* TSepiCompilerBase

* TSepiMethodCompiler

* TSepiUnitCompiler

* TSepiMemoryReference

* TSepiJumpDest

* TSepiLocalVarVertex

* TSepiLocalVarGraph

* TSepiCompilerError

* TSepiMemberBuilder

* TSepiPropertyBuilder

* TSepiOperator

* TSepiCaseOfClause

* TSepiLexerBookmark

* TSepiBaseLexerBookmark

* TSepiCompositeLexerBookmark

* TSepiCustomLexer

* TSepiBaseLexer

* TSepiCustomManualLexer

* TSepiDelphiBaseLexer

* TSepiCustomCompositeLexer

* TSepiDelphiLexer

* TSepiDelphiInterfaceLexer

* TSepiLL1ParsingStack

* TTryTag

* TSepiCustomParser

* TSepiCustomLL1Parser

* TSepiDelphiParser

* TSepiParseTreeNode

* TSepiTerminal

* TSepiNonTerminal

* TSepiParseTreeRootNode

* TDelphiRootNode

* TSepiHiddenNonTerminal

* TPreProcIfConditionNode

* TSepiFakeNonTerminal

* TSepiChildThroughNonTerminal

* TSepiUsesNode

* TSepiQualifiedIdentNode

* TSepiInitializationExpressionNode

* TDelphiInitializationExpressionNode

* TDelphiArrayInitializationNode

* TDelphiRecordInitializationNode

* TDelphiGUIDInitializationNode

* TDelphiOtherInitializationNode

* TDelphiInterfaceGUIDNode

* TSepiExpressionNode

* TSepiSameAsChildExpressionNode

* TSepiConstExpressionNode

* TDelphiConstOrTypeNode

* TSepiValueNode

* TSepiBinaryOpTreeNode

* TSepiUnaryOperationNode

* TSepiLiteralConstNode

* TSepiConstIntegerNode

* TSepiConstFloatNode

* TSepiConstStringNode

* TSepiIdentifierExpressionNode

* TSepiNilValueNode

* TSepiSetValueNode

* TSepiSetOrOpenArrayBuilderNode

* TSepiInheritedExpressionNode

* TSepiPureInheritedExpressionNode

* TSepiExpressionWithModifiersNode

* TDelphiSingleExprNode

* TSepiExpressionModifierNode

* TSepiUnaryOpModifierNode

* TSepiParametersNode

* TSepiDelphiLikeParametersNode

* TDelphiParametersNode

* TSepiArrayIndicesModifierNode

* TSepiFieldSelectionModifierNode

* TSepiBinaryOpNode

* TSepiDelphiLikeBinaryOpNode

* TDelphiBinaryOpNode

* TSepiInSetOperationNode

* TSepiIsOperationNode

* TSepiAsOperationNode

* TSepiAssignmentOpNode

* TSepiUnaryOpNode

* TSepiDelphiLikeUnaryOpNode

* TDelphiUnaryOpNode

* TSepiDereferenceOpNode

* TSepiAddressOfOpNode

* TSepiIdentifierDeclarationNode

* TSepiUncheckedIdentifierDeclNode

* TSepiParamNameNode

* TSepiIdentifierDeclListNode

* TSepiChangeVisibilityNode

* TSepiClassFieldNode

* TSepiClassMemberDefinitionNode

* TSepiSignatureBuilderNode

* TSepiSignatureKindNode

* TSepiPropertyKindNode

* TSepiCallingConventionNode

* TSepiParamNode

* TSepiSignatureReturnTypeNode

* TSepiPropertyBuilderNode

* TSepiPropRedefineMarkerNode

* TSepiPropReadAccessNode

* TSepiPropWriteAccessNode

* TSepiPropIndexNode

* TSepiPropDefaultValueNode

* TSepiPropStorageNode

* TSepiPropDefaultMarkerNode

* TSepiParamKindNode

* TSepiParamIsArrayMarkerNode

* TSepiMethodDeclarationNode

* TSepiMethodLinkKindNode

* TSepiAbstractMarkerNode

* TSepiOverloadMarkerNode

* TSepiStaticMarkerNode

* TSepiForwardMarkerNode

* TSepiPropertyNode

* TSepiIntfMethodRedirectorNode

* TSepiTypeNode

* TSepiTypeNameNode

* TSepiTypeDefinitionNode

* TDelphiTypeCloneNode

* TDelphiRangeOrEnumTypeNode

* TDelphiRangeTypeNode

* TDelphiEnumTypeNode

* TDelphiFakeEnumTypeNode

* TDelphiSetTypeNode

* TDelphiStringTypeNode

* TDelphiPointerTypeNode

* TDelphiArrayTypeNode

* TDelphiPackedArrayTypeNode

* TDelphiRecordTypeNode

* TDelphiPackedRecordTypeNode

* TDelphiClassTypeNode

* TDelphiInterfaceTypeNode

* TDelphiMethodRefTypeNode

* TSepiMaybeIdentAndTypeNode

* TSepiExceptionVarAndTypeNode

* TSepiRecordContentsNode

* TSepiRecordCaseHeaderNode

* TSepiRecordFieldNode

* TSepiMethodImplementationNode

* TSepiMethodImplHeaderNode

* TSepiMethodBodyNode

* TSepiLocalVarNameNode

* TSepiForControlVarNode

* TSepiLocalVarNode

* TSepiInstructionNode

* TSepiNoInstructionNode

* TSepiInstructionListNode

* TSepiBeginEndBlockNode

* TSepiMultiOnElseClauseNode

* TSepiIfThenElseInstructionNode

* TSepiCaseOfInstructionNode

* TSepiCaseOfClauseNode

* TSepiWhileInstructionNode

* TSepiDoWhileInstructionNode

* TSepiRepeatUntilInstructionNode

* TSepiForInstructionNode

* TSepiTryInstructionNode

* TSepiExceptFinallyClauseNode

* TSepiExceptClauseNode

* TSepiFinallyClauseNode

* TSepiMultiOnNode

* TSepiOnClauseNode

* TSepiRaiseInstructionNode

* TSepiExecuteExpressionInstructionNode

* TSepiWithInstructionNode

* TSepiForToDownToNode

* TSepiForToNode

* TSepiForDownToNode

* TDelphiInterfaceNode

* TDelphiImplementationNode

* TDelphiTypeDeclNode

* TDelphiConstantDeclNode

* TDelphiVariableDeclNode

* TDelphiFakeEnumValueNode

* TDelphiOfObjectMarkerNode

* TSepiDisassembler

* TSepiRuntimeUnit

* TSepiRuntimeMethod

* TSepiRuntimeContext

* TSepiParam

* TSepiSignature

* TSepiComponent

* TSepiType

* TSepiUntypedType

* TSepiContainerType

* TSepiRecordType

* TSepiInheritableContainerType

* TSepiInterface

* TSepiClass

* TSepiShortStringType

* TSepiStringType

* TSepiCompilerTransientType

* TSepiEmptySetType

* TSepiAccessTypeInfoRef

* TSepiArrayType

* TSepiStaticArrayType

* TSepiDynArrayType

* TSepiOpenArrayType

* TSepiMetaClass

* TSepiMethodRefType

* TSepiVariantType

* TSepiTextFileType

* TSepiOrdType

* TSepiIntegerType

* TSepiCharType

* TSepiBooleanType

* TSepiEnumType

* TSepiFakeEnumType

* TSepiInt64Type

* TSepiFloatType

* TSepiSetType

* TSepiPointerType

* TSepiMember

* TSepiVariable

* TSepiField

* TSepiMethodBase

* TSepiMethod

* TSepiOverloadedMethod

* TSepiProperty

* TSepiRoot

* TSepiRootFork

* TSepiUnit

* TSepiUnitAlias

* TSepiSystemUnit

* TSepiTypeAlias

* TSepiConstant

* TSepiNamespace

* TSepiLazyLoadData

IInterface

* IDynamicallyLinkable

* ISepiExpressionPart

* ISepiExecutable

* ISepiValue

* ISepiTypeForceableValue

* ISepiTypeForceableSetValue

* ISepiSetBuilder

* ISepiReadableValue

* ISepiIdentifierTestPseudoRoutine

* ISepiWritableValue

* ISepiAddressableValue

* ISepiProperty

* ISepiOpenArrayValue

* ISepiOpenArrayBuilder

* ISepiWantingParams

* ISepiComponentExpression

* ISepiTypeExpression

* ISepiSetOrOpenArrayBuilder

* ISepiExpression

No parent

* TJmpInstruction

* TCDeclCallInfo

* TIntegerInterval

* TDynamicInterface

* TComplexRec

* TMD5Digest

* TMD5Context

* TManagedField

* TRecordTypeData

* TArrayTypeData

* T3DPoint

* TSepiAsmOnClause

* TLocalInitInfo

* TSepiAddressDerefAndOpRec

* TSepiSourcePosition

* TSepiSetBuilderRange

* TMessageHandlerRec

* TCMNotifyTypeCreated

* TCDMMinEnumSize

* TCDMAlign

* TLocalParam

* TCompilingContext

* TSepiParamCallInfo

* TSepiPropertyAccess

* TSepiPropertyStorage

* TSepiInterfaceEntry

* TSepiIntfMethodRedirector

* TInitInfo

* TInitTable

* TFieldInfo

* TFieldTable

* TMethodInfo

* TMethodTable

* TSepiFakeEnumValue

* TSepiTypeParamBehavior

* TSepiLazyLoadChildData

* TSepiSystemTypes

#OrphanClass#

* EBDSVersionNotInstalled

* TFrameComponentExplorer

* TExplorerForm

* TAbsoluteMemoryStream

* TMeasureStream

* TMethodThread

* ECommandLineException

* ECommandLineParsingException

* ECoroutineError

* ECoroutineTerminating

* EDynamicIntfError

* TDynamicallyLinkedObject

* TSepiCustomExpressionPart

* TSepiCustomDirectValue

* TSepiTrueConstValue

* TSepiLiteralValue

* TSepiIntegerLiteralValue

* TSepiFloatLiteralValue

* TSepiStringLiteralValue

* TSepiErroneousValue

* TSepiVariableValue

* TSepiLocalVarValue

* TSepiCastOperator

* TSepiDereferenceValue

* TSepiArrayItemValue

* TSepiRecordFieldValue

* TSepiObjectFieldValue

* TSepiCustomComputedValue

* TSepiMetaClassValue

* TSepiConvertOperation

* TSepiArithmeticLogicOperation

* TSepiUnaryOperation

* TSepiBinaryOperation

* TSepiInSetOperation

* TSepiIsAsOperation

* TSepiIsOperation

* TSepiAsOperation

* TSepiSetOperation

* TSepiSetBuilder

* TSepiAddressOfValue

* TSepiStringLengthValue

* TSepiArrayBoundValue

* TSepiStrCopyExpression

* TSepiDynArrayCopyExpression

* TSepiTypeOperationValue

* TSepiDefinedDeclaredPseudoRoutine

* TSepiCustomExecutable

* TSepiStrSetLengthExpression

* TSepiDynArraySetLengthExpression

* TSepiAssignmentOperation

* TSepiPureInheritedCall

* TSepiCustomWithParams

* TSepiCustomCallable

* TSepiMethodCall

* TSepiMethodRefCall

* TSepiPropertyValue

* TSepiValueBackedPseudoRoutine

* TSepiOneParamValueBackedPseudoRoutine

* TSepiTypeOperationPseudoRoutine

* TSepiCastPseudoRoutine

* TSepiCastOrConvertPseudoRoutine

* TSepiCopyPseudoRoutine

* TSepiExecutableBackedPseudoRoutine

* TSepiSetLengthPseudoRoutine

* TSepiOpenArrayFromArrayValue

* TSepiOpenArrayBuilder

* TSepiNilValue

* TSepiComponentExpression

* TSepiTypeExpression

* TSepiSetOrOpenArrayBuilder

* TSepiInstructionExpression

* TSepiSpecialJumpPseudoRoutine

* TDynamicIntfController

* TSepiExpression

* EIntListError

* TCompareStrings

* TScStrings

* TScList

* TIntegerList

* TUnsignedIntList

* TExtendedList

* TComplexList

* TScWaitingQueue

* TScWaitingObjectQueue

* EMathsError

* EDivisionError

* ERootError

* EDegreeError

* ENotDegreeZeroError

* EIntegerError

* ENotIntegerError

* ENaturalError

* ENotNaturalError

* EEvalError

* EWrongExpressionError

* EWrongCharacterError

* EOperationError

* EOpNotExistsError

* EOpRequestsError

* EOpRequestsDegreeZeroError

* EOpRequestsIntegerError

* EOpRequestsNaturalError

* EOpRequestsCorrectIndexError

* EDivisionOpError

* ERootOpError

* EBracketsError

* ETooManyBracketsError

* EEquationError

* ECannotSolveEquationError

* EDegreeTooHighError

* EDegreeTooLowError

* ETransformationStreamError

* TTransformationStream

* TCoroutineTransformationStream

* TThreadTransformationStream

* ESerializerError

* TProtectedStringHash

* TScCustomTaskQueue

* TScTaskQueue

* TSepiAsynchronousRootManager

* TSdAboutForm

* TSdPasswordDialog

* TSdAboutDialog

* TSdNumberDialog

* TSdNumberForm

* TSdPasswordForm

* ESepiCompilerError

* ESepiLabelError

* ESepiMemoryReferenceError

* ESepiSealedMemoryReference

* ESepiInvalidMemoryReference

* ESepiInvalidJumpDest

* ESepiInvalidParamsError

* ESepiInvalidDataSizeError

* ESepiCompilerFatalError

* TSepiCompilerErrorList

* ESepiLL1ParserError

* TSepiAboutDialog

* ESepiError

* ESepiUnsupportedFeatureException

* ESepiComponentAlreadyCreated

* ESepiComponentNotFoundError

* ESepiUnitNotFoundError

* ESepiIncompatibleUsedUnitError

* ESepiBadConstTypeError

* ESepiAlreadyCompleted

* ESepiLexicalError

* ESepiInvalidOpCode

* TProtectedPSExec

* TSepiComponentList

* TSvCustomNumberEdit

* TSvNumberEdit

* TSvDropImage

* TSvCustomURLLabel

* TSvURLLabel

Sepi
Class Tree
Index
Previous (Sepi)
Next


Sepi

Sepi
Previous
Next (CompilerOptions)

Name
CompilerContext

Parent
Sepi

Description
Contexte de compilation

Author
sjrd

Version
1.0

Classes
Class | Description
TCompilerContext (+) | Contexte de compilation

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (CompilerOptions)


Sepi

Sepi
Previous
Next

Name
TCompilerContext

Parent
CompilerContext

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Contexte de compilation

Members
Fields
Field | Description
FDirectoryConsts (-) | Constantes représentant des répertoires
FErrors (-) | Gestionnaire d'erreurs
FOutputDir (-) | Dossier de destination des unités compilées
FSepiBrowsingPath (-) | Chemin de recherche Sepi
FSourceBrowsingPath (-) | Chemin de recherche des sources

Methods
Method | Description
Create (+) | Crée le contexte de compilation
Destroy (+) | [@inheritDoc]
LoadEnvironmentStrings (-) | Charge les variables d'environnement
ReplaceMacros (+) | Remplace toutes les macros par leurs valeurs
SearchFile (+) | Cherche un fichier dans un chemin de recherche
SearchSepiFile (+) | Cherche un fichier dans le chemin de recherche Sepi
SearchSourceFile (+) | Cherche un fichier dans le chemin de recherche des sources

Properties
Property | Description
DirectoryConsts (+) | Constantes représentant des répertoires
Errors (+) | Gestionnaire d'erreurs
OutputDir (+) | Dossier de destination des unités compilées
SepiBrowsingPath (+) | Chemin de recherche Sepi
SourceBrowsingPath (+) | Chemin de recherche des sources

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FErrors)

Name
FDirectoryConsts

Parent
TCompilerContext

Visibility
PRIVATE

Description
Constantes représentant des répertoires

Source code
FDirectoryConsts : TStrings

Sepi
Class Tree
Index
Previous
Next (FErrors)


Sepi

Sepi
Previous (FDirectoryConsts)
Next (FOutputDir)

Name
FErrors

Parent
TCompilerContext

Visibility
PRIVATE

Description
Gestionnaire d'erreurs

Source code
FErrors : TSepiCompilerErrorList

Sepi
Class Tree
Index
Previous (FDirectoryConsts)
Next (FOutputDir)


Sepi

Sepi
Previous (FErrors)
Next (FSepiBrowsingPath)

Name
FOutputDir

Parent
TCompilerContext

Visibility
PRIVATE

Description
Dossier de destination des unités compilées

Source code
FOutputDir : TFileName

Sepi
Class Tree
Index
Previous (FErrors)
Next (FSepiBrowsingPath)


Sepi

Sepi
Previous (FOutputDir)
Next (FSourceBrowsingPath)

Name
FSepiBrowsingPath

Parent
TCompilerContext

Visibility
PRIVATE

Description
Chemin de recherche Sepi

Source code
FSepiBrowsingPath : string

Sepi
Class Tree
Index
Previous (FOutputDir)
Next (FSourceBrowsingPath)


Sepi

Sepi
Previous (FSepiBrowsingPath)
Next

Name
FSourceBrowsingPath

Parent
TCompilerContext

Visibility
PRIVATE

Description
Chemin de recherche des sources

Source code
FSourceBrowsingPath : string

Sepi
Class Tree
Index
Previous (FSepiBrowsingPath)
Next


Sepi

Sepi
Previous
Next (Errors)

Name
DirectoryConsts

Parent
TCompilerContext

Visibility
PUBLIC

Description
Constantes représentant des répertoires

Source code
property DirectoryConsts : TStrings read FDirectoryConsts

Read Access
FDirectoryConsts

Sepi
Class Tree
Index
Previous
Next (Errors)


Sepi

Sepi
Previous (DirectoryConsts)
Next (OutputDir)

Name
Errors

Parent
TCompilerContext

Visibility
PUBLIC

Description
Gestionnaire d'erreurs

Source code
property Errors : TSepiCompilerErrorList read FErrors

Read Access
FErrors

Sepi
Class Tree
Index
Previous (DirectoryConsts)
Next (OutputDir)


Sepi

Sepi
Previous (Errors)
Next (SepiBrowsingPath)

Name
OutputDir

Parent
TCompilerContext

Visibility
PUBLIC

Description
Dossier de destination des unités compilées

Source code
property OutputDir : TFileName read FOutputDir write FOutputDir

Read Access
FOutputDir

Write Access
FOutputDir

Sepi
Class Tree
Index
Previous (Errors)
Next (SepiBrowsingPath)


Sepi

Sepi
Previous (OutputDir)
Next (SourceBrowsingPath)

Name
SepiBrowsingPath

Parent
TCompilerContext

Visibility
PUBLIC

Description
Chemin de recherche Sepi

Source code
property SepiBrowsingPath : string read FSepiBrowsingPath write FSepiBrowsingPath

Read Access
FSepiBrowsingPath

Write Access
FSepiBrowsingPath

Sepi
Class Tree
Index
Previous (OutputDir)
Next (SourceBrowsingPath)


Sepi

Sepi
Previous (SepiBrowsingPath)
Next

Name
SourceBrowsingPath

Parent
TCompilerContext

Visibility
PUBLIC

Description
Chemin de recherche des sources

Source code
property SourceBrowsingPath : string read FSourceBrowsingPath write FSourceBrowsingPath

Read Access
FSourceBrowsingPath

Write Access
FSourceBrowsingPath

Sepi
Class Tree
Index
Previous (SepiBrowsingPath)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TCompilerContext

Visibility
PUBLIC

Description
Crée le contexte de compilation

Source code
constructor Create ( AErrors : TSepiCompilerErrorList )

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | Gestionnaire d'erreurs à utiliser

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (LoadEnvironmentStrings)

Name
Destroy

Parent
TCompilerContext

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (LoadEnvironmentStrings)


Sepi

Sepi
Previous (Destroy)
Next (ReplaceMacros)

Name
LoadEnvironmentStrings

Parent
TCompilerContext

Visibility
PRIVATE

Description
Charge les variables d'environnement

Source code
procedure LoadEnvironmentStrings

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (ReplaceMacros)


Sepi

Sepi
Previous (LoadEnvironmentStrings)
Next (SearchFile)

Name
ReplaceMacros

Parent
TCompilerContext

Visibility
PUBLIC

Description
Remplace toutes les macros par leurs valeurs

Source code
function ReplaceMacros ( const Str : string ) : string

Parameters
Parameter | Description
Str : STRING | Chaîne source

Return
Types | Description
STRING | Str dans laquelle chaque $(X) est remplacé par la valeur de X

Sepi
Class Tree
Index
Previous (LoadEnvironmentStrings)
Next (SearchFile)


Sepi

Sepi
Previous (ReplaceMacros)
Next (SearchSepiFile)

Name
SearchFile

Parent
TCompilerContext

Visibility
PUBLIC

Description
Cherche un fichier dans un chemin de recherche
Le chemin de recherche peut contenir des constantes de la forme $(X) où X est
un nom parmi les noms de DirectoryConsts.

Source code
function SearchFile ( const FileName : TFileName ; const BrowsingPath : string ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier à chercher
BrowsingPath : STRING | Chemin de recherche

Return
Types | Description
TFileName | Nom du fichier complet trouvé, où une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (ReplaceMacros)
Next (SearchSepiFile)


Sepi

Sepi
Previous (SearchFile)
Next (SearchSourceFile)

Name
SearchSepiFile

Parent
TCompilerContext

Visibility
PUBLIC

Description
Cherche un fichier dans le chemin de recherche Sepi

Source code
function SearchSepiFile ( const FileName : TFileName ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier à chercher

Return
Types | Description
TFileName | Nom du fichier complet trouvé, où une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (SearchFile)
Next (SearchSourceFile)


Sepi

Sepi
Previous (SearchSepiFile)
Next

Name
SearchSourceFile

Parent
TCompilerContext

Visibility
PUBLIC

Description
Cherche un fichier dans le chemin de recherche des sources

Source code
function SearchSourceFile ( const FileName : TFileName ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier à chercher

Return
Types | Description
TFileName | Nom du fichier complet trouvé, où une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (SearchSepiFile)
Next


Sepi

Sepi
Previous (CompilerContext)
Next (ComponentExplorer)

Name
CompilerOptions

Parent
Sepi

Description
Options de compilation

Author
sjrd

Version
1.0

Classes
Class | Description
TOptions (+) | Compiler coptions

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (CompilerContext)
Next (ComponentExplorer)


Sepi

Sepi
Previous
Next

Name
TOptions

Parent
CompilerOptions

Class Hierarchy
TCommandLine

Visibility
PUBLIC

Description
Compiler coptions

Members
Fields
Field | Description
FFileNames (-) | Noms des fichiers à traiter
FOutputDir (-) | Dossier de destination des unités compilées
FSepiBrowsingPath (-) | Chemin de recherche Sepi
FSourceBrowsingPath (-) | Chemin de recherche des sources
FWaitWhenFinished (-) | Indique s'il faut attendre quand terminé

Methods
Method | Description
AfterConstruction (+) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
Destroy (+) | [@inheritDoc]

Properties
Property | Description
FileNames (+) | Noms des fichiers à traiter
OutputDir (+) | Dossier de destination des unités compilées
SepiBrowsingPath (+) | Chemin de recherche Sepi
SourceBrowsingPath (+) | Chemin de recherche des sources
WaitWhenFinished (+) | Indique s'il faut attendre quand terminé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FOutputDir)

Name
FFileNames

Parent
TOptions

Visibility
PRIVATE

Description
Noms des fichiers à traiter

Source code
FFileNames : TStrings

Sepi
Class Tree
Index
Previous
Next (FOutputDir)


Sepi

Sepi
Previous (FFileNames)
Next (FSepiBrowsingPath)

Name
FOutputDir

Parent
TOptions

Visibility
PRIVATE

Description
Dossier de destination des unités compilées

Source code
FOutputDir : TFileName

Sepi
Class Tree
Index
Previous (FFileNames)
Next (FSepiBrowsingPath)


Sepi

Sepi
Previous (FOutputDir)
Next (FSourceBrowsingPath)

Name
FSepiBrowsingPath

Parent
TOptions

Visibility
PRIVATE

Description
Chemin de recherche Sepi

Source code
FSepiBrowsingPath : string

Sepi
Class Tree
Index
Previous (FOutputDir)
Next (FSourceBrowsingPath)


Sepi

Sepi
Previous (FSepiBrowsingPath)
Next (FWaitWhenFinished)

Name
FSourceBrowsingPath

Parent
TOptions

Visibility
PRIVATE

Description
Chemin de recherche des sources

Source code
FSourceBrowsingPath : string

Sepi
Class Tree
Index
Previous (FSepiBrowsingPath)
Next (FWaitWhenFinished)


Sepi

Sepi
Previous (FSourceBrowsingPath)
Next

Name
FWaitWhenFinished

Parent
TOptions

Visibility
PRIVATE

Description
Indique s'il faut attendre quand terminé

Source code
FWaitWhenFinished : Boolean

Sepi
Class Tree
Index
Previous (FSourceBrowsingPath)
Next


Sepi

Sepi
Previous
Next (OutputDir)

Name
FileNames

Parent
TOptions

Visibility
PUBLIC

Description
Noms des fichiers à traiter

Source code
property FileNames : TStrings read FFileNames

Read Access
FFileNames

Sepi
Class Tree
Index
Previous
Next (OutputDir)


Sepi

Sepi
Previous (FileNames)
Next (SepiBrowsingPath)

Name
OutputDir

Parent
TOptions

Visibility
PUBLIC

Description
Dossier de destination des unités compilées

Source code
property OutputDir : TFileName read FOutputDir

Read Access
FOutputDir

Sepi
Class Tree
Index
Previous (FileNames)
Next (SepiBrowsingPath)


Sepi

Sepi
Previous (OutputDir)
Next (SourceBrowsingPath)

Name
SepiBrowsingPath

Parent
TOptions

Visibility
PUBLIC

Description
Chemin de recherche Sepi

Source code
property SepiBrowsingPath : string read FSepiBrowsingPath

Read Access
FSepiBrowsingPath

Sepi
Class Tree
Index
Previous (OutputDir)
Next (SourceBrowsingPath)


Sepi

Sepi
Previous (SepiBrowsingPath)
Next (WaitWhenFinished)

Name
SourceBrowsingPath

Parent
TOptions

Visibility
PUBLIC

Description
Chemin de recherche des sources

Source code
property SourceBrowsingPath : string read FSourceBrowsingPath

Read Access
FSourceBrowsingPath

Sepi
Class Tree
Index
Previous (SepiBrowsingPath)
Next (WaitWhenFinished)


Sepi

Sepi
Previous (SourceBrowsingPath)
Next

Name
WaitWhenFinished

Parent
TOptions

Visibility
PUBLIC

Description
Indique s'il faut attendre quand terminé

Source code
property WaitWhenFinished : Boolean read FWaitWhenFinished

Read Access
FWaitWhenFinished

Sepi
Class Tree
Index
Previous (SourceBrowsingPath)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AfterConstruction

Parent
TOptions

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AfterConstruction)
Next (Destroy)

Name
Create

Parent
TOptions

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next

Name
Destroy

Parent
TOptions

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (CompilerOptions)
Next (ExplorerConsts)

Name
ComponentExplorer

Parent
Sepi

Description
Cadre montrant les informations d'un meta

Author
sjrd

Version
1.0

Types
Type | Description
TGetRuntimeMethodEvent (+) | #No TAG found in source code#

Classes
Class | Description
TFrameComponentExplorer (+) | Cadre montrant les informations d'un meta

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (CompilerOptions)
Next (ExplorerConsts)


Sepi

Sepi
Previous
Next

Name
TFrameComponentExplorer

Parent
ComponentExplorer

Class Hierarchy
TFrame

Visibility
PUBLIC

Description
Cadre montrant les informations d'un meta

Members
Fields
Field | Description
FOnGetRuntimeMethod (-) | Événement déclenché pour demander la méthode run-time d'une méthode Sepi
FSepiComponent (-) | Le meta affiché
MemoInfo (*) | #No TAG found in source code#

Methods
Method | Description
PrintMethodCode (-) | Affiche le code d'une méthode, quand c'est possible
SetSepiComponent (-) | Modifie le meta affiché

Properties
Property | Description
OnGetRuntimeMethod (+) | Événement déclenché pour demander la méthode run-time d'une méthode Sepi
SepiComponent (+) | Le meta affiché

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FSepiComponent)

Name
FOnGetRuntimeMethod

Parent
TFrameComponentExplorer

Visibility
PRIVATE

Description
Événement déclenché pour demander la méthode run-time d'une méthode Sepi

Source code
FOnGetRuntimeMethod : TGetRuntimeMethodEvent

Sepi
Class Tree
Index
Previous
Next (FSepiComponent)


Sepi

Sepi
Previous (FOnGetRuntimeMethod)
Next (MemoInfo)

Name
FSepiComponent

Parent
TFrameComponentExplorer

Visibility
PRIVATE

Description
Le meta affiché

Source code
FSepiComponent : TSepiComponent

Sepi
Class Tree
Index
Previous (FOnGetRuntimeMethod)
Next (MemoInfo)


Sepi

Sepi
Previous (FSepiComponent)
Next

Name
MemoInfo

Parent
TFrameComponentExplorer

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
MemoInfo : TMemo

Sepi
Class Tree
Index
Previous (FSepiComponent)
Next


Sepi

Sepi
Previous
Next (SepiComponent)

Name
OnGetRuntimeMethod

Parent
TFrameComponentExplorer

Visibility
PUBLIC

Description
Événement déclenché pour demander la méthode run-time d'une méthode Sepi

Source code
property OnGetRuntimeMethod : TGetRuntimeMethodEvent read FOnGetRuntimeMethod write FOnGetRuntimeMethod

Read Access
FOnGetRuntimeMethod

Write Access
FOnGetRuntimeMethod

Sepi
Class Tree
Index
Previous
Next (SepiComponent)


Sepi

Sepi
Previous (OnGetRuntimeMethod)
Next

Name
SepiComponent

Parent
TFrameComponentExplorer

Visibility
PUBLIC

Description
Le meta affiché

Source code
property SepiComponent : TSepiComponent read FSepiComponent write SetSepiComponent

Read Access
FSepiComponent

Write Access
SetSepiComponent

Sepi
Class Tree
Index
Previous (OnGetRuntimeMethod)
Next


Sepi

Sepi
Previous
Next (SetSepiComponent)

Name
PrintMethodCode

Parent
TFrameComponentExplorer

Visibility
PRIVATE

Description
Affiche le code d'une méthode, quand c'est possible

Source code
procedure PrintMethodCode ( Strings : TStrings ; SepiMethod : TSepiMethod )

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes destination
SepiMethod : TSepiMethod | Méthode dont afficher le code

Sepi
Class Tree
Index
Previous
Next (SetSepiComponent)


Sepi

Sepi
Previous (PrintMethodCode)
Next

Name
SetSepiComponent

Parent
TFrameComponentExplorer

Visibility
PRIVATE

Description
Modifie le meta affiché

Source code
procedure SetSepiComponent ( Value : TSepiComponent )

Parameters
Parameter | Description
Value : TSepiComponent | Nouveau meta à afficher

Sepi
Class Tree
Index
Previous (PrintMethodCode)
Next


Sepi

Sepi
Previous
Next

Name
TGetRuntimeMethodEvent

Parent
ComponentExplorer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
TGetRuntimeMethodEvent = function ( SepiMethod : TSepiMethod ) : TSepiRuntimeMethod of object ;

Parameters
Parameter | Description
SepiMethod : TSepiMethod | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiRuntimeMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ComponentExplorer)
Next (ExplorerOptions)

Name
ExplorerConsts

Parent
Sepi

Description
Constantes de l'explorateur

Author
sjrd

Version
1.0

Constants
Constant | Description
CompiledIntfExt (+) | #No TAG found in source code#
CompiledUnitExt (+) | #No TAG found in source code#
IniExt (+) | #No TAG found in source code#
MaxSizeBeforeLazyLoad (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ComponentExplorer)
Next (ExplorerOptions)


Sepi

Sepi
Previous
Next (CompiledUnitExt)

Name
CompiledIntfExt

Parent
ExplorerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
CompiledIntfExt = '.sci'

Sepi
Class Tree
Index
Previous
Next (CompiledUnitExt)


Sepi

Sepi
Previous (CompiledIntfExt)
Next (IniExt)

Name
CompiledUnitExt

Parent
ExplorerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
CompiledUnitExt = '.scu'

Sepi
Class Tree
Index
Previous (CompiledIntfExt)
Next (IniExt)


Sepi

Sepi
Previous (CompiledUnitExt)
Next (MaxSizeBeforeLazyLoad)

Name
IniExt

Parent
ExplorerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
IniExt = '.ini'

Sepi
Class Tree
Index
Previous (CompiledUnitExt)
Next (MaxSizeBeforeLazyLoad)


Sepi

Sepi
Previous (IniExt)
Next

Name
MaxSizeBeforeLazyLoad

Parent
ExplorerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
MaxSizeBeforeLazyLoad = 100 * 1024

Sepi
Class Tree
Index
Previous (IniExt)
Next


Sepi

Sepi
Previous (ExplorerConsts)
Next (GeneratorOptions)

Name
ExplorerOptions

Parent
Sepi

Description
Options de l'explorateur

Author
sjrd

Version
1.0

Classes
Class | Description
TExplorerOptions (+) | Options enregistrées de l'explorateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ExplorerConsts)
Next (GeneratorOptions)


Sepi

Sepi
Previous
Next

Name
TExplorerOptions

Parent
ExplorerOptions

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Options enregistrées de l'explorateur

Members
Fields
Field | Description
FAliases (-) | Alias d'unité
FBrowsingPath (-) | Chemin de recherche des unités Sepi
FFileName (-) | Nom du fichier où sont sockées les options

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
BeforeDestruction (+) | [@inheritDoc]
Create (+) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
LoadFromFile (-) | Charge les options depuis le fichier d'options
ResolveAlias (+) | Résoud un alias d'unités
SaveToFile (-) | Enregistre les options dans le fichier d'options
SearchFile (+) | Recherche un fichier dans un chemin de recherche

Properties
Property | Description
Aliases (+) | Alias d'unité
BrowsingPath (+) | Chemin de recherche des unités Sepi
FileName (#) | Nom du fichier où sont sockées les options

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FBrowsingPath)

Name
FAliases

Parent
TExplorerOptions

Visibility
PRIVATE

Description
Alias d'unité

Source code
FAliases : TStrings

Sepi
Class Tree
Index
Previous
Next (FBrowsingPath)


Sepi

Sepi
Previous (FAliases)
Next (FFileName)

Name
FBrowsingPath

Parent
TExplorerOptions

Visibility
PRIVATE

Description
Chemin de recherche des unités Sepi

Source code
FBrowsingPath : string

Sepi
Class Tree
Index
Previous (FAliases)
Next (FFileName)


Sepi

Sepi
Previous (FBrowsingPath)
Next

Name
FFileName

Parent
TExplorerOptions

Visibility
PRIVATE

Description
Nom du fichier où sont sockées les options

Source code
FFileName : TFileName

Sepi
Class Tree
Index
Previous (FBrowsingPath)
Next


Sepi

Sepi
Previous
Next (BrowsingPath)

Name
Aliases

Parent
TExplorerOptions

Visibility
PUBLIC

Description
Alias d'unité

Source code
property Aliases : TStrings read FAliases

Read Access
FAliases

Sepi
Class Tree
Index
Previous
Next (BrowsingPath)


Sepi

Sepi
Previous (Aliases)
Next (FileName)

Name
BrowsingPath

Parent
TExplorerOptions

Visibility
PUBLIC

Description
Chemin de recherche des unités Sepi

Source code
property BrowsingPath : string read FBrowsingPath write FBrowsingPath

Read Access
FBrowsingPath

Write Access
FBrowsingPath

Sepi
Class Tree
Index
Previous (Aliases)
Next (FileName)


Sepi

Sepi
Previous (BrowsingPath)
Next

Name
FileName

Parent
TExplorerOptions

Visibility
PROTECTED

Description
Nom du fichier où sont sockées les options

Source code
property FileName : TFileName read FFileName

Read Access
FFileName

Sepi
Class Tree
Index
Previous (BrowsingPath)
Next


Sepi

Sepi
Previous
Next (BeforeDestruction)

Name
AfterConstruction

Parent
TExplorerOptions

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (BeforeDestruction)


Sepi

Sepi
Previous (AfterConstruction)
Next (Create)

Name
BeforeDestruction

Parent
TExplorerOptions

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Create)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Destroy)

Name
Create

Parent
TExplorerOptions

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (LoadFromFile)

Name
Destroy

Parent
TExplorerOptions

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (LoadFromFile)


Sepi

Sepi
Previous (Destroy)
Next (ResolveAlias)

Name
LoadFromFile

Parent
TExplorerOptions

Visibility
PRIVATE

Description
Charge les options depuis le fichier d'options

Source code
procedure LoadFromFile

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (ResolveAlias)


Sepi

Sepi
Previous (LoadFromFile)
Next (SaveToFile)

Name
ResolveAlias

Parent
TExplorerOptions

Visibility
PUBLIC

Description
Résoud un alias d'unités

Source code
function ResolveAlias ( const Alias : string ; out Names : TStringDynArray ) : Boolean

Parameters
Parameter | Description
Alias : STRING | Alias à résoudre
Names : TStringDynArray | En sortie : tableau des unités référencées

Return
Types | Description
BOOLEAN | True si Alias était bien un alias, False sinon

Sepi
Class Tree
Index
Previous (LoadFromFile)
Next (SaveToFile)


Sepi

Sepi
Previous (ResolveAlias)
Next (SearchFile)

Name
SaveToFile

Parent
TExplorerOptions

Visibility
PRIVATE

Description
Enregistre les options dans le fichier d'options

Source code
procedure SaveToFile

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ResolveAlias)
Next (SearchFile)


Sepi

Sepi
Previous (SaveToFile)
Next

Name
SearchFile

Parent
TExplorerOptions

Visibility
PUBLIC

Description
Recherche un fichier dans un chemin de recherche

Source code
function SearchFile ( const FileName : TFileName ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier recherché

Return
Types | Description
TFileName | Nom complet du fichier, ou une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (SaveToFile)
Next


Sepi

Sepi
Previous (ExplorerOptions)
Next (GeneratorUtils)

Name
GeneratorOptions

Parent
Sepi

Description
#Pas de TAG trouvé dans le code source#

Author
#Pas de TAG trouvé dans le code source#

Version
#Pas de TAG trouvé dans le code source#

Classes
Class | Description
TGeneratorOptions (+) | Options du générateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ExplorerOptions)
Next (GeneratorUtils)


Sepi

Sepi
Previous
Next

Name
TGeneratorOptions

Parent
GeneratorOptions

Class Hierarchy
TCommandLine

Visibility
PUBLIC

Description
Options du générateur

Members
Fields
Field | Description
FDestDir (-) | Nom du dossier de destination
FLanguageName (-) | Nom du langage à compiler
FSourceFileName (-) | Nom du fichier source

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
Create (+) | Crée les options du générateur

Properties
Property | Description
DestDir (+) | Nom du dossier de destination
LanguageName (+) | Nom du langage à compiler
SourceFileName (+) | Nom du fichier source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FLanguageName)

Name
FDestDir

Parent
TGeneratorOptions

Visibility
PRIVATE

Description
Nom du dossier de destination

Source code
FDestDir : TFileName

Sepi
Class Tree
Index
Previous
Next (FLanguageName)


Sepi

Sepi
Previous (FDestDir)
Next (FSourceFileName)

Name
FLanguageName

Parent
TGeneratorOptions

Visibility
PRIVATE

Description
Nom du langage à compiler

Source code
FLanguageName : string

Sepi
Class Tree
Index
Previous (FDestDir)
Next (FSourceFileName)


Sepi

Sepi
Previous (FLanguageName)
Next

Name
FSourceFileName

Parent
TGeneratorOptions

Visibility
PRIVATE

Description
Nom du fichier source

Source code
FSourceFileName : TFileName

Sepi
Class Tree
Index
Previous (FLanguageName)
Next


Sepi

Sepi
Previous
Next (LanguageName)

Name
DestDir

Parent
TGeneratorOptions

Visibility
PUBLIC

Description
Nom du dossier de destination

Source code
property DestDir : TFileName read FDestDir

Read Access
FDestDir

Sepi
Class Tree
Index
Previous
Next (LanguageName)


Sepi

Sepi
Previous (DestDir)
Next (SourceFileName)

Name
LanguageName

Parent
TGeneratorOptions

Visibility
PUBLIC

Description
Nom du langage à compiler

Source code
property LanguageName : string read FLanguageName

Read Access
FLanguageName

Sepi
Class Tree
Index
Previous (DestDir)
Next (SourceFileName)


Sepi

Sepi
Previous (LanguageName)
Next

Name
SourceFileName

Parent
TGeneratorOptions

Visibility
PUBLIC

Description
Nom du fichier source

Source code
property SourceFileName : TFileName read FSourceFileName

Read Access
FSourceFileName

Sepi
Class Tree
Index
Previous (LanguageName)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AfterConstruction

Parent
TGeneratorOptions

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AfterConstruction)
Next

Name
Create

Parent
TGeneratorOptions

Visibility
PUBLIC

Description
Crée les options du générateur

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next


Sepi

Sepi
Previous (GeneratorOptions)
Next (ImporterConsts)

Name
GeneratorUtils

Parent
Sepi

Description
Utilitaires de génération du parser

Author
sjrd

Version
1.0

Methods
Method Description

Classes
Class | Description
TGenerator (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (GeneratorOptions)
Next (ImporterConsts)


Sepi

Sepi
Previous
Next

Name
TGenerator

Parent
GeneratorUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
ChoiceCount (+) | #No TAG found in source code#
ClassesToSimplify (+) | #No TAG found in source code#
DestFileName (+) | #No TAG found in source code#
FirstNonTerminal (+) | #No TAG found in source code#
InitNodeNames (+) | #No TAG found in source code#
InitPushChoiceProcs (+) | #No TAG found in source code#
LanguageName (+) | #No TAG found in source code#
LastNonTerminal (+) | #No TAG found in source code#
NonTerminalConsts (+) | #No TAG found in source code#
ParsingTable (+) | #No TAG found in source code#
PushChoiceProcs (+) | #No TAG found in source code#
PushChoiceProcsDecls (+) | #No TAG found in source code#
Source (+) | #No TAG found in source code#

Methods
Method | Description
Create (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#
Generate (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ClassesToSimplify)

Name
ChoiceCount

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ChoiceCount : Integer

Sepi
Class Tree
Index
Previous
Next (ClassesToSimplify)


Sepi

Sepi
Previous (ChoiceCount)
Next (DestFileName)

Name
ClassesToSimplify

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ClassesToSimplify : TScIntegerSet

Sepi
Class Tree
Index
Previous (ChoiceCount)
Next (DestFileName)


Sepi

Sepi
Previous (ClassesToSimplify)
Next (FirstNonTerminal)

Name
DestFileName

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
DestFileName : TFileName

Sepi
Class Tree
Index
Previous (ClassesToSimplify)
Next (FirstNonTerminal)


Sepi

Sepi
Previous (DestFileName)
Next (InitNodeNames)

Name
FirstNonTerminal

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
FirstNonTerminal : Integer

Sepi
Class Tree
Index
Previous (DestFileName)
Next (InitNodeNames)


Sepi

Sepi
Previous (FirstNonTerminal)
Next (InitPushChoiceProcs)

Name
InitNodeNames

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
InitNodeNames : TStrings

Sepi
Class Tree
Index
Previous (FirstNonTerminal)
Next (InitPushChoiceProcs)


Sepi

Sepi
Previous (InitNodeNames)
Next (LanguageName)

Name
InitPushChoiceProcs

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
InitPushChoiceProcs : TStrings

Sepi
Class Tree
Index
Previous (InitNodeNames)
Next (LanguageName)


Sepi

Sepi
Previous (InitPushChoiceProcs)
Next (LastNonTerminal)

Name
LanguageName

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
LanguageName : string

Sepi
Class Tree
Index
Previous (InitPushChoiceProcs)
Next (LastNonTerminal)


Sepi

Sepi
Previous (LanguageName)
Next (NonTerminalConsts)

Name
LastNonTerminal

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
LastNonTerminal : Integer

Sepi
Class Tree
Index
Previous (LanguageName)
Next (NonTerminalConsts)


Sepi

Sepi
Previous (LastNonTerminal)
Next (ParsingTable)

Name
NonTerminalConsts

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
NonTerminalConsts : TStrings

Sepi
Class Tree
Index
Previous (LastNonTerminal)
Next (ParsingTable)


Sepi

Sepi
Previous (NonTerminalConsts)
Next (PushChoiceProcs)

Name
ParsingTable

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ParsingTable : TStrings

Sepi
Class Tree
Index
Previous (NonTerminalConsts)
Next (PushChoiceProcs)


Sepi

Sepi
Previous (ParsingTable)
Next (PushChoiceProcsDecls)

Name
PushChoiceProcs

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
PushChoiceProcs : TStrings

Sepi
Class Tree
Index
Previous (ParsingTable)
Next (PushChoiceProcsDecls)


Sepi

Sepi
Previous (PushChoiceProcs)
Next (Source)

Name
PushChoiceProcsDecls

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
PushChoiceProcsDecls : TStrings

Sepi
Class Tree
Index
Previous (PushChoiceProcs)
Next (Source)


Sepi

Sepi
Previous (PushChoiceProcsDecls)
Next

Name
Source

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Source : TStrings

Sepi
Class Tree
Index
Previous (PushChoiceProcsDecls)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( const ALanguageName : string ; const ADestFileName : TFileName )

Parameters
Parameter | Description
ALanguageName : STRING | #Pas de TAG trouvé dans le code source#
ADestFileName : TFileName | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Generate)

Name
Destroy

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Generate)


Sepi

Sepi
Previous (Destroy)
Next

Name
Generate

Parent
TGenerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Generate

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (GeneratorUtils)
Next (ImporterContext)

Name
ImporterConsts

Parent
Sepi

Description
Constantes de l'importeur

Author
sjrd

Version
1.0

Constants
Constant | Description
CompiledIntfExt (+) | #No TAG found in source code#
DefaultCacheDir (+) | #No TAG found in source code#
DefaultOutputDir (+) | #No TAG found in source code#
DefaultResourcesDir (+) | #No TAG found in source code#
DefaultTemplatesDir (+) | #No TAG found in source code#
MaxSizeBeforeLazyLoad (+) | #No TAG found in source code#
PascalExt (+) | #No TAG found in source code#
RCExt (+) | #No TAG found in source code#
SBadlyFormedOverloadFile (+) | #No TAG found in source code#
SBDSVendorVersionNotInstalled (+) | #No TAG found in source code#
SBDSVersionNotInstalled (+) | #No TAG found in source code#
SCantCompileRCFile (+) | #No TAG found in source code#
SCantFindProgram (+) | #No TAG found in source code#
SCantFindSourceFile (+) | #No TAG found in source code#
SCantOpenDestFile (+) | #No TAG found in source code#
SCantOpenSourceFile (+) | #No TAG found in source code#
SOneOrMoreFileNamesRequired (+) | #No TAG found in source code#
SOverloadHasMoreLinesThanOriginal (+) | #No TAG found in source code#
SSepiInternalError (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (GeneratorUtils)
Next (ImporterContext)


Sepi

Sepi
Previous
Next (DefaultCacheDir)

Name
CompiledIntfExt

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
CompiledIntfExt = '.sci'

Sepi
Class Tree
Index
Previous
Next (DefaultCacheDir)


Sepi

Sepi
Previous (CompiledIntfExt)
Next (DefaultOutputDir)

Name
DefaultCacheDir

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
DefaultCacheDir = 'Cache\'

Sepi
Class Tree
Index
Previous (CompiledIntfExt)
Next (DefaultOutputDir)


Sepi

Sepi
Previous (DefaultCacheDir)
Next (DefaultResourcesDir)

Name
DefaultOutputDir

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
DefaultOutputDir = 'Output\'

Sepi
Class Tree
Index
Previous (DefaultCacheDir)
Next (DefaultResourcesDir)


Sepi

Sepi
Previous (DefaultOutputDir)
Next (DefaultTemplatesDir)

Name
DefaultResourcesDir

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
DefaultResourcesDir = 'Resources\'

Sepi
Class Tree
Index
Previous (DefaultOutputDir)
Next (DefaultTemplatesDir)


Sepi

Sepi
Previous (DefaultResourcesDir)
Next (MaxSizeBeforeLazyLoad)

Name
DefaultTemplatesDir

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
DefaultTemplatesDir = 'Templates\'

Sepi
Class Tree
Index
Previous (DefaultResourcesDir)
Next (MaxSizeBeforeLazyLoad)


Sepi

Sepi
Previous (DefaultTemplatesDir)
Next (PascalExt)

Name
MaxSizeBeforeLazyLoad

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
MaxSizeBeforeLazyLoad = 100 * 1024

Sepi
Class Tree
Index
Previous (DefaultTemplatesDir)
Next (PascalExt)


Sepi

Sepi
Previous (MaxSizeBeforeLazyLoad)
Next (RCExt)

Name
PascalExt

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
PascalExt = '.pas'

Sepi
Class Tree
Index
Previous (MaxSizeBeforeLazyLoad)
Next (RCExt)


Sepi

Sepi
Previous (PascalExt)
Next (SBadlyFormedOverloadFile)

Name
RCExt

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
RCExt = '.rc'

Sepi
Class Tree
Index
Previous (PascalExt)
Next (SBadlyFormedOverloadFile)


Sepi

Sepi
Previous (RCExt)
Next (SBDSVendorVersionNotInstalled)

Name
SBadlyFormedOverloadFile

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBadlyFormedOverloadFile = 'Fichier d''overloading mal formé'

Sepi
Class Tree
Index
Previous (RCExt)
Next (SBDSVendorVersionNotInstalled)


Sepi

Sepi
Previous (SBadlyFormedOverloadFile)
Next (SBDSVersionNotInstalled)

Name
SBDSVendorVersionNotInstalled

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBDSVendorVersionNotInstalled = 'La version %1:s de BDS de %0:s n''est pas installée'

Sepi
Class Tree
Index
Previous (SBadlyFormedOverloadFile)
Next (SBDSVersionNotInstalled)


Sepi

Sepi
Previous (SBDSVendorVersionNotInstalled)
Next (SCantCompileRCFile)

Name
SBDSVersionNotInstalled

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBDSVersionNotInstalled = 'La version %s de BDS n''est pas installée'

Sepi
Class Tree
Index
Previous (SBDSVendorVersionNotInstalled)
Next (SCantCompileRCFile)


Sepi

Sepi
Previous (SBDSVersionNotInstalled)
Next (SCantFindProgram)

Name
SCantCompileRCFile

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantCompileRCFile = 'Ne peut compiler le fichier de ressources %s'

Sepi
Class Tree
Index
Previous (SBDSVersionNotInstalled)
Next (SCantFindProgram)


Sepi

Sepi
Previous (SCantCompileRCFile)
Next (SCantFindSourceFile)

Name
SCantFindProgram

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantFindProgram = 'Ne peut trouver le programme externe %s'

Sepi
Class Tree
Index
Previous (SCantCompileRCFile)
Next (SCantFindSourceFile)


Sepi

Sepi
Previous (SCantFindProgram)
Next (SCantOpenDestFile)

Name
SCantFindSourceFile

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantFindSourceFile = 'Le fichier source %s n''existe pas'

Sepi
Class Tree
Index
Previous (SCantFindProgram)
Next (SCantOpenDestFile)


Sepi

Sepi
Previous (SCantFindSourceFile)
Next (SCantOpenSourceFile)

Name
SCantOpenDestFile

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantOpenDestFile = 'Impossible de créer le fichier de sortie %s'

Sepi
Class Tree
Index
Previous (SCantFindSourceFile)
Next (SCantOpenSourceFile)


Sepi

Sepi
Previous (SCantOpenDestFile)
Next (SOneOrMoreFileNamesRequired)

Name
SCantOpenSourceFile

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantOpenSourceFile = 'Impossible de créer le fichier source %s'

Sepi
Class Tree
Index
Previous (SCantOpenDestFile)
Next (SOneOrMoreFileNamesRequired)


Sepi

Sepi
Previous (SCantOpenSourceFile)
Next (SOverloadHasMoreLinesThanOriginal)

Name
SOneOrMoreFileNamesRequired

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOneOrMoreFileNamesRequired = 'Un argument ou plus requis'

Sepi
Class Tree
Index
Previous (SCantOpenSourceFile)
Next (SOverloadHasMoreLinesThanOriginal)


Sepi

Sepi
Previous (SOneOrMoreFileNamesRequired)
Next (SSepiInternalError)

Name
SOverloadHasMoreLinesThanOriginal

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOverloadHasMoreLinesThanOriginal = 'L''overload contient plus de lignes que l''original : les numéros de ' + 'ligne des erreurs seront probablement faussés.'

Sepi
Class Tree
Index
Previous (SOneOrMoreFileNamesRequired)
Next (SSepiInternalError)


Sepi

Sepi
Previous (SOverloadHasMoreLinesThanOriginal)
Next

Name
SSepiInternalError

Parent
ImporterConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiInternalError = 'Erreur interne : %s'

Sepi
Class Tree
Index
Previous (SOverloadHasMoreLinesThanOriginal)
Next


Sepi

Sepi
Previous (ImporterConsts)
Next (ImporterOptions)

Name
ImporterContext

Parent
Sepi

Description
Contexte d'importation

Author
sjrd

Version
1.0

Constants
Constant | Description
BDSRootKeyFmt (+) | Format de la clef racine de BDS dans la base de registres
OverloadDirBase (+) | Format du dossier des overloads

Classes
Class | Description
EBDSVersionNotInstalled (+) | #No TAG found in source code#
TImporterContext (+) | Contexte d'importation

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ImporterConsts)
Next (ImporterOptions)


Sepi

Sepi
Previous
Next (TImporterContext)

Name
EBDSVersionNotInstalled

Parent
ImporterContext

Class Hierarchy
Exception

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TImporterContext)


Sepi

Sepi
Previous (EBDSVersionNotInstalled)
Next

Name
TImporterContext

Parent
ImporterContext

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Contexte d'importation

Members
Fields
Field | Description
FBDSBrowsingPath (-) | Chemin de recherche BDS
FBDSRootDir (-) | Dossier racine de BDS
FBDSVendor (-) | Nom du revendeur de BDS dans la BdR
FBDSVersion (-) | Version de BDS dans la BdR
FCacheDir (-) | Dossier de cache
FDirectoryConsts (-) | Constantes représentant des répertoires
FErrors (-) | Gestionnaire d'erreurs
FExcludeRoutines (-) | Exclure les routines
FOutputDir (-) | Dossier de destination
FOverloadDir (-) | Dossier des overloads pour les fichiers lus
FProduceLazyLoad (-) | Produire du code lazy-load
FResourcesDir (-) | Dossier de destination des ressources
FSepiBrowsingPath (-) | Chemin de recherche Sepi
FSkipIfNotExists (-) | Ignorer les unités non trouvées

Methods
Method | Description
Create (+) | Crée le contexte de compilation
Create (+) | Crée le contexte de compilation
Destroy (+) | [@inheritDoc]
FindVendor (-) | Trouve le revendeur d'une version de BDS donnée
LoadEnvironmentStrings (-) | Charge les variables d'environnement
LoadFromRegistry (-) | Lit les infos sur BDS depuis la base de registres
ReplaceMacros (+) | Remplace toutes les macros par leurs valeurs
SearchBDSFile (+) | Cherche un fichier dans le chemin de recherche BDS
SearchFile (+) | Cherche un fichier dans un chemin de recherche
SearchSepiFile (+) | Cherche un fichier dans le chemin de recherche Sepi

Properties
Property | Description
BDSBrowsingPath (+) | Chemin de recherche BDS
BDSRootDir (+) | Dossier racine de BDS
BDSVendor (+) | Nom du revendeur de BDS dans la BdR
BDSVersion (+) | Version de BDS dans la BdR
CacheDir (+) | Dossier de cache
DirectoryConsts (+) | Constantes représentant des répertoires
Errors (+) | Gestionnaire d'erreurs
ExcludeRoutines (+) | Exclure les routines
OutputDir (+) | Dossier de destination
OverloadDir (+) | Dossier des overloads pour les fichiers lus
ProduceLazyLoad (+) | Produire du code lazy-load
ResourcesDir (+) | Dossier de destination des ressources
SepiBrowsingPath (+) | Chemin de recherche Sepi
SkipIfNotExists (+) | Ignorer les unités non trouvées

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EBDSVersionNotInstalled)
Next


Sepi

Sepi
Previous
Next (FBDSRootDir)

Name
FBDSBrowsingPath

Parent
TImporterContext

Visibility
PRIVATE

Description
Chemin de recherche BDS

Source code
FBDSBrowsingPath : string

Sepi
Class Tree
Index
Previous
Next (FBDSRootDir)


Sepi

Sepi
Previous (FBDSBrowsingPath)
Next (FBDSVendor)

Name
FBDSRootDir

Parent
TImporterContext

Visibility
PRIVATE

Description
Dossier racine de BDS

Source code
FBDSRootDir : string

Sepi
Class Tree
Index
Previous (FBDSBrowsingPath)
Next (FBDSVendor)


Sepi

Sepi
Previous (FBDSRootDir)
Next (FBDSVersion)

Name
FBDSVendor

Parent
TImporterContext

Visibility
PRIVATE

Description
Nom du revendeur de BDS dans la BdR

Source code
FBDSVendor : string

Sepi
Class Tree
Index
Previous (FBDSRootDir)
Next (FBDSVersion)


Sepi

Sepi
Previous (FBDSVendor)
Next (FCacheDir)

Name
FBDSVersion

Parent
TImporterContext

Visibility
PRIVATE

Description
Version de BDS dans la BdR

Source code
FBDSVersion : string

Sepi
Class Tree
Index
Previous (FBDSVendor)
Next (FCacheDir)


Sepi

Sepi
Previous (FBDSVersion)
Next (FDirectoryConsts)

Name
FCacheDir

Parent
TImporterContext

Visibility
PRIVATE

Description
Dossier de cache

Source code
FCacheDir : TFileName

Sepi
Class Tree
Index
Previous (FBDSVersion)
Next (FDirectoryConsts)


Sepi

Sepi
Previous (FCacheDir)
Next (FErrors)

Name
FDirectoryConsts

Parent
TImporterContext

Visibility
PRIVATE

Description
Constantes représentant des répertoires

Source code
FDirectoryConsts : TStrings

Sepi
Class Tree
Index
Previous (FCacheDir)
Next (FErrors)


Sepi

Sepi
Previous (FDirectoryConsts)
Next (FExcludeRoutines)

Name
FErrors

Parent
TImporterContext

Visibility
PRIVATE

Description
Gestionnaire d'erreurs

Source code
FErrors : TSepiCompilerErrorList

Sepi
Class Tree
Index
Previous (FDirectoryConsts)
Next (FExcludeRoutines)


Sepi

Sepi
Previous (FErrors)
Next (FOutputDir)

Name
FExcludeRoutines

Parent
TImporterContext

Visibility
PRIVATE

Description
Exclure les routines

Source code
FExcludeRoutines : Boolean

Sepi
Class Tree
Index
Previous (FErrors)
Next (FOutputDir)


Sepi

Sepi
Previous (FExcludeRoutines)
Next (FOverloadDir)

Name
FOutputDir

Parent
TImporterContext

Visibility
PRIVATE

Description
Dossier de destination

Source code
FOutputDir : TFileName

Sepi
Class Tree
Index
Previous (FExcludeRoutines)
Next (FOverloadDir)


Sepi

Sepi
Previous (FOutputDir)
Next (FProduceLazyLoad)

Name
FOverloadDir

Parent
TImporterContext

Visibility
PRIVATE

Description
Dossier des overloads pour les fichiers lus

Source code
FOverloadDir : TFileName

Sepi
Class Tree
Index
Previous (FOutputDir)
Next (FProduceLazyLoad)


Sepi

Sepi
Previous (FOverloadDir)
Next (FResourcesDir)

Name
FProduceLazyLoad

Parent
TImporterContext

Visibility
PRIVATE

Description
Produire du code lazy-load

Source code
FProduceLazyLoad : Boolean

Sepi
Class Tree
Index
Previous (FOverloadDir)
Next (FResourcesDir)


Sepi

Sepi
Previous (FProduceLazyLoad)
Next (FSepiBrowsingPath)

Name
FResourcesDir

Parent
TImporterContext

Visibility
PRIVATE

Description
Dossier de destination des ressources

Source code
FResourcesDir : TFileName

Sepi
Class Tree
Index
Previous (FProduceLazyLoad)
Next (FSepiBrowsingPath)


Sepi

Sepi
Previous (FResourcesDir)
Next (FSkipIfNotExists)

Name
FSepiBrowsingPath

Parent
TImporterContext

Visibility
PRIVATE

Description
Chemin de recherche Sepi

Source code
FSepiBrowsingPath : string

Sepi
Class Tree
Index
Previous (FResourcesDir)
Next (FSkipIfNotExists)


Sepi

Sepi
Previous (FSepiBrowsingPath)
Next

Name
FSkipIfNotExists

Parent
TImporterContext

Visibility
PRIVATE

Description
Ignorer les unités non trouvées

Source code
FSkipIfNotExists : Boolean

Sepi
Class Tree
Index
Previous (FSepiBrowsingPath)
Next


Sepi

Sepi
Previous
Next (BDSRootDir)

Name
BDSBrowsingPath

Parent
TImporterContext

Visibility
PUBLIC

Description
Chemin de recherche BDS

Source code
property BDSBrowsingPath : string read FBDSBrowsingPath write FBDSBrowsingPath

Read Access
FBDSBrowsingPath

Write Access
FBDSBrowsingPath

Sepi
Class Tree
Index
Previous
Next (BDSRootDir)


Sepi

Sepi
Previous (BDSBrowsingPath)
Next (BDSVendor)

Name
BDSRootDir

Parent
TImporterContext

Visibility
PUBLIC

Description
Dossier racine de BDS

Source code
property BDSRootDir : string read FBDSRootDir

Read Access
FBDSRootDir

Sepi
Class Tree
Index
Previous (BDSBrowsingPath)
Next (BDSVendor)


Sepi

Sepi
Previous (BDSRootDir)
Next (BDSVersion)

Name
BDSVendor

Parent
TImporterContext

Visibility
PUBLIC

Description
Nom du revendeur de BDS dans la BdR

Source code
property BDSVendor : string read FBDSVendor

Read Access
FBDSVendor

Sepi
Class Tree
Index
Previous (BDSRootDir)
Next (BDSVersion)


Sepi

Sepi
Previous (BDSVendor)
Next (CacheDir)

Name
BDSVersion

Parent
TImporterContext

Visibility
PUBLIC

Description
Version de BDS dans la BdR

Source code
property BDSVersion : string read FBDSVersion

Read Access
FBDSVersion

Sepi
Class Tree
Index
Previous (BDSVendor)
Next (CacheDir)


Sepi

Sepi
Previous (BDSVersion)
Next (DirectoryConsts)

Name
CacheDir

Parent
TImporterContext

Visibility
PUBLIC

Description
Dossier de cache

Source code
property CacheDir : TFileName read FCacheDir write FCacheDir

Read Access
FCacheDir

Write Access
FCacheDir

Sepi
Class Tree
Index
Previous (BDSVersion)
Next (DirectoryConsts)


Sepi

Sepi
Previous (CacheDir)
Next (Errors)

Name
DirectoryConsts

Parent
TImporterContext

Visibility
PUBLIC

Description
Constantes représentant des répertoires

Source code
property DirectoryConsts : TStrings read FDirectoryConsts

Read Access
FDirectoryConsts

Sepi
Class Tree
Index
Previous (CacheDir)
Next (Errors)


Sepi

Sepi
Previous (DirectoryConsts)
Next (ExcludeRoutines)

Name
Errors

Parent
TImporterContext

Visibility
PUBLIC

Description
Gestionnaire d'erreurs

Source code
property Errors : TSepiCompilerErrorList read FErrors

Read Access
FErrors

Sepi
Class Tree
Index
Previous (DirectoryConsts)
Next (ExcludeRoutines)


Sepi

Sepi
Previous (Errors)
Next (OutputDir)

Name
ExcludeRoutines

Parent
TImporterContext

Visibility
PUBLIC

Description
Exclure les routines

Source code
property ExcludeRoutines : Boolean read FExcludeRoutines write FExcludeRoutines

Read Access
FExcludeRoutines

Write Access
FExcludeRoutines

Sepi
Class Tree
Index
Previous (Errors)
Next (OutputDir)


Sepi

Sepi
Previous (ExcludeRoutines)
Next (OverloadDir)

Name
OutputDir

Parent
TImporterContext

Visibility
PUBLIC

Description
Dossier de destination

Source code
property OutputDir : TFileName read FOutputDir write FOutputDir

Read Access
FOutputDir

Write Access
FOutputDir

Sepi
Class Tree
Index
Previous (ExcludeRoutines)
Next (OverloadDir)


Sepi

Sepi
Previous (OutputDir)
Next (ProduceLazyLoad)

Name
OverloadDir

Parent
TImporterContext

Visibility
PUBLIC

Description
Dossier des overloads pour les fichiers lus

Source code
property OverloadDir : TFileName read FOverloadDir write FOverloadDir

Read Access
FOverloadDir

Write Access
FOverloadDir

Sepi
Class Tree
Index
Previous (OutputDir)
Next (ProduceLazyLoad)


Sepi

Sepi
Previous (OverloadDir)
Next (ResourcesDir)

Name
ProduceLazyLoad

Parent
TImporterContext

Visibility
PUBLIC

Description
Produire du code lazy-load

Source code
property ProduceLazyLoad : Boolean read FProduceLazyLoad write FProduceLazyLoad

Read Access
FProduceLazyLoad

Write Access
FProduceLazyLoad

Sepi
Class Tree
Index
Previous (OverloadDir)
Next (ResourcesDir)


Sepi

Sepi
Previous (ProduceLazyLoad)
Next (SepiBrowsingPath)

Name
ResourcesDir

Parent
TImporterContext

Visibility
PUBLIC

Description
Dossier de destination des ressources

Source code
property ResourcesDir : TFileName read FResourcesDir write FResourcesDir

Read Access
FResourcesDir

Write Access
FResourcesDir

Sepi
Class Tree
Index
Previous (ProduceLazyLoad)
Next (SepiBrowsingPath)


Sepi

Sepi
Previous (ResourcesDir)
Next (SkipIfNotExists)

Name
SepiBrowsingPath

Parent
TImporterContext

Visibility
PUBLIC

Description
Chemin de recherche Sepi

Source code
property SepiBrowsingPath : string read FSepiBrowsingPath write FSepiBrowsingPath

Read Access
FSepiBrowsingPath

Write Access
FSepiBrowsingPath

Sepi
Class Tree
Index
Previous (ResourcesDir)
Next (SkipIfNotExists)


Sepi

Sepi
Previous (SepiBrowsingPath)
Next

Name
SkipIfNotExists

Parent
TImporterContext

Visibility
PUBLIC

Description
Ignorer les unités non trouvées

Source code
property SkipIfNotExists : Boolean read FSkipIfNotExists write FSkipIfNotExists

Read Access
FSkipIfNotExists

Write Access
FSkipIfNotExists

Sepi
Class Tree
Index
Previous (SepiBrowsingPath)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TImporterContext

Visibility
PUBLIC

Description
Crée le contexte de compilation

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; const ABDSVendor , ABDSVersion : string ) ; overload

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | Gestionnaire d'erreurs à utiliser
ABDSVendor : STRING | Nom du revendeur de BDS dans la BdR
ABDSVersion : STRING | Version de BDS

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TImporterContext

Visibility
PUBLIC

Description
Crée le contexte de compilation
Dans cette variante, le nom du revendeur de BDS est détecté automatiquement
d'après la version

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; const ABDSVersion : string ) ; overload

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | Gestionnaire d'erreurs à utiliser
ABDSVersion : STRING | Version de BDS

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (FindVendor)

Name
Destroy

Parent
TImporterContext

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (FindVendor)


Sepi

Sepi
Previous (Destroy)
Next (LoadEnvironmentStrings)

Name
FindVendor

Parent
TImporterContext

Visibility
PRIVATE

Description
Trouve le revendeur d'une version de BDS donnée

Source code
class function FindVendor ( Errors : TSepiCompilerErrorList ; const BDSVersion : string ) : string

Parameters
Parameter | Description
Errors : TSepiCompilerErrorList | Gestionnaire d'erreurs
BDSVersion : STRING | Version de BDS

Return
Types | Description
STRING | Revendeur de cette version

Sepi
Class Tree
Index
Previous (Destroy)
Next (LoadEnvironmentStrings)


Sepi

Sepi
Previous (FindVendor)
Next (LoadFromRegistry)

Name
LoadEnvironmentStrings

Parent
TImporterContext

Visibility
PRIVATE

Description
Charge les variables d'environnement

Source code
procedure LoadEnvironmentStrings

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (FindVendor)
Next (LoadFromRegistry)


Sepi

Sepi
Previous (LoadEnvironmentStrings)
Next (ReplaceMacros)

Name
LoadFromRegistry

Parent
TImporterContext

Visibility
PRIVATE

Description
Lit les infos sur BDS depuis la base de registres

Source code
procedure LoadFromRegistry

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (LoadEnvironmentStrings)
Next (ReplaceMacros)


Sepi

Sepi
Previous (LoadFromRegistry)
Next (SearchBDSFile)

Name
ReplaceMacros

Parent
TImporterContext

Visibility
PUBLIC

Description
Remplace toutes les macros par leurs valeurs

Source code
function ReplaceMacros ( const Str : string ) : string

Parameters
Parameter | Description
Str : STRING | Chaîne source

Return
Types | Description
STRING | Str dans laquelle chaque $(X) est remplacé par la valeur de X

Sepi
Class Tree
Index
Previous (LoadFromRegistry)
Next (SearchBDSFile)


Sepi

Sepi
Previous (ReplaceMacros)
Next (SearchFile)

Name
SearchBDSFile

Parent
TImporterContext

Visibility
PUBLIC

Description
Cherche un fichier dans le chemin de recherche BDS

Source code
function SearchBDSFile ( const FileName : TFileName ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier à chercher

Return
Types | Description
TFileName | Nom du fichier complet trouvé, où une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (ReplaceMacros)
Next (SearchFile)


Sepi

Sepi
Previous (SearchBDSFile)
Next (SearchSepiFile)

Name
SearchFile

Parent
TImporterContext

Visibility
PUBLIC

Description
Cherche un fichier dans un chemin de recherche
Le chemin de recherche peut contenir des constantes de la forme $(X) où X est
un nom parmi les noms de DirectoryConsts.

Source code
function SearchFile ( const FileName : TFileName ; const BrowsingPath : string ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier à chercher
BrowsingPath : STRING | Chemin de recherche

Return
Types | Description
TFileName | Nom du fichier complet trouvé, où une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (SearchBDSFile)
Next (SearchSepiFile)


Sepi

Sepi
Previous (SearchFile)
Next

Name
SearchSepiFile

Parent
TImporterContext

Visibility
PUBLIC

Description
Cherche un fichier dans le chemin de recherche Sepi

Source code
function SearchSepiFile ( const FileName : TFileName ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier à chercher

Return
Types | Description
TFileName | Nom du fichier complet trouvé, où une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (SearchFile)
Next


Sepi

Sepi
Previous
Next (OverloadDirBase)

Name
BDSRootKeyFmt

Parent
ImporterContext

Visibility
PUBLIC

Description
Format de la clef racine de BDS dans la base de registres

Source code
BDSRootKeyFmt = '\Software\%s\BDS\%s\'

Sepi
Class Tree
Index
Previous
Next (OverloadDirBase)


Sepi

Sepi
Previous (BDSRootKeyFmt)
Next

Name
OverloadDirBase

Parent
ImporterContext

Visibility
PUBLIC

Description
Format du dossier des overloads

Source code
OverloadDirBase = 'OvldSource\'

Sepi
Class Tree
Index
Previous (BDSRootKeyFmt)
Next


Sepi

Sepi
Previous (ImporterContext)
Next (ImporterProducer)

Name
ImporterOptions

Parent
Sepi

Description
Options de l'importeur

Author
sjrd

Version
1.0

Classes
Class | Description
TOptions (+) | Options en ligne de commande de l'importeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ImporterContext)
Next (ImporterProducer)


Sepi

Sepi
Previous
Next

Name
TOptions

Parent
ImporterOptions

Class Hierarchy
TCommandLine

Visibility
PUBLIC

Description
Options en ligne de commande de l'importeur

Members
Fields
Field | Description
FBDSVersion (-) | Version de BDS utilisée
FCacheDir (-) | Dossier de cache
FExcludeRoutines (-) | Exclure les routines
FFileNames (-) | Noms des fichiers à traiter
FOutputDir (-) | Dossier de destination
FProduceLazyLoad (-) | Produire du code lazy-load
FResourcesDir (-) | Dossier de destination des ressources
FSkipIfNotExists (-) | Ignorer les unités non trouvées
FWaitWhenFinished (-) | Indique s'il faut attendre quand terminé

Methods
Method | Description
AfterConstruction (+) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
Destroy (+) | [@inheritDoc]

Properties
Property | Description
BDSVersion (+) | Version de BDS utilisée
CacheDir (+) | Dossier de cache
ExcludeRoutines (+) | Exclure les routines
FileNames (+) | Noms des fichiers à traiter
OutputDir (+) | Dossier de destination
ProduceLazyLoad (+) | Produire du code lazy-load
ResourcesDir (+) | Dossier de destination des ressources
SkipIfNotExists (+) | Ignorer les unités non trouvées
WaitWhenFinished (+) | Indique s'il faut attendre quand terminé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FCacheDir)

Name
FBDSVersion

Parent
TOptions

Visibility
PRIVATE

Description
Version de BDS utilisée

Source code
FBDSVersion : string

Sepi
Class Tree
Index
Previous
Next (FCacheDir)


Sepi

Sepi
Previous (FBDSVersion)
Next (FExcludeRoutines)

Name
FCacheDir

Parent
TOptions

Visibility
PRIVATE

Description
Dossier de cache

Source code
FCacheDir : TFileName

Sepi
Class Tree
Index
Previous (FBDSVersion)
Next (FExcludeRoutines)


Sepi

Sepi
Previous (FCacheDir)
Next (FFileNames)

Name
FExcludeRoutines

Parent
TOptions

Visibility
PRIVATE

Description
Exclure les routines

Source code
FExcludeRoutines : Boolean

Sepi
Class Tree
Index
Previous (FCacheDir)
Next (FFileNames)


Sepi

Sepi
Previous (FExcludeRoutines)
Next (FOutputDir)

Name
FFileNames

Parent
TOptions

Visibility
PRIVATE

Description
Noms des fichiers à traiter

Source code
FFileNames : TStrings

Sepi
Class Tree
Index
Previous (FExcludeRoutines)
Next (FOutputDir)


Sepi

Sepi
Previous (FFileNames)
Next (FProduceLazyLoad)

Name
FOutputDir

Parent
TOptions

Visibility
PRIVATE

Description
Dossier de destination

Source code
FOutputDir : TFileName

Sepi
Class Tree
Index
Previous (FFileNames)
Next (FProduceLazyLoad)


Sepi

Sepi
Previous (FOutputDir)
Next (FResourcesDir)

Name
FProduceLazyLoad

Parent
TOptions

Visibility
PRIVATE

Description
Produire du code lazy-load

Source code
FProduceLazyLoad : Boolean

Sepi
Class Tree
Index
Previous (FOutputDir)
Next (FResourcesDir)


Sepi

Sepi
Previous (FProduceLazyLoad)
Next (FSkipIfNotExists)

Name
FResourcesDir

Parent
TOptions

Visibility
PRIVATE

Description
Dossier de destination des ressources

Source code
FResourcesDir : TFileName

Sepi
Class Tree
Index
Previous (FProduceLazyLoad)
Next (FSkipIfNotExists)


Sepi

Sepi
Previous (FResourcesDir)
Next (FWaitWhenFinished)

Name
FSkipIfNotExists

Parent
TOptions

Visibility
PRIVATE

Description
Ignorer les unités non trouvées

Source code
FSkipIfNotExists : Boolean

Sepi
Class Tree
Index
Previous (FResourcesDir)
Next (FWaitWhenFinished)


Sepi

Sepi
Previous (FSkipIfNotExists)
Next

Name
FWaitWhenFinished

Parent
TOptions

Visibility
PRIVATE

Description
Indique s'il faut attendre quand terminé

Source code
FWaitWhenFinished : Boolean

Sepi
Class Tree
Index
Previous (FSkipIfNotExists)
Next


Sepi

Sepi
Previous
Next (CacheDir)

Name
BDSVersion

Parent
TOptions

Visibility
PUBLIC

Description
Version de BDS utilisée

Source code
property BDSVersion : string read FBDSVersion

Read Access
FBDSVersion

Sepi
Class Tree
Index
Previous
Next (CacheDir)


Sepi

Sepi
Previous (BDSVersion)
Next (ExcludeRoutines)

Name
CacheDir

Parent
TOptions

Visibility
PUBLIC

Description
Dossier de cache

Source code
property CacheDir : TFileName read FCacheDir

Read Access
FCacheDir

Sepi
Class Tree
Index
Previous (BDSVersion)
Next (ExcludeRoutines)


Sepi

Sepi
Previous (CacheDir)
Next (FileNames)

Name
ExcludeRoutines

Parent
TOptions

Visibility
PUBLIC

Description
Exclure les routines

Source code
property ExcludeRoutines : Boolean read FExcludeRoutines

Read Access
FExcludeRoutines

Sepi
Class Tree
Index
Previous (CacheDir)
Next (FileNames)


Sepi

Sepi
Previous (ExcludeRoutines)
Next (OutputDir)

Name
FileNames

Parent
TOptions

Visibility
PUBLIC

Description
Noms des fichiers à traiter

Source code
property FileNames : TStrings read FFileNames

Read Access
FFileNames

Sepi
Class Tree
Index
Previous (ExcludeRoutines)
Next (OutputDir)


Sepi

Sepi
Previous (FileNames)
Next (ProduceLazyLoad)

Name
OutputDir

Parent
TOptions

Visibility
PUBLIC

Description
Dossier de destination

Source code
property OutputDir : TFileName read FOutputDir

Read Access
FOutputDir

Sepi
Class Tree
Index
Previous (FileNames)
Next (ProduceLazyLoad)


Sepi

Sepi
Previous (OutputDir)
Next (ResourcesDir)

Name
ProduceLazyLoad

Parent
TOptions

Visibility
PUBLIC

Description
Produire du code lazy-load

Source code
property ProduceLazyLoad : Boolean read FProduceLazyLoad

Read Access
FProduceLazyLoad

Sepi
Class Tree
Index
Previous (OutputDir)
Next (ResourcesDir)


Sepi

Sepi
Previous (ProduceLazyLoad)
Next (SkipIfNotExists)

Name
ResourcesDir

Parent
TOptions

Visibility
PUBLIC

Description
Dossier de destination des ressources

Source code
property ResourcesDir : TFileName read FResourcesDir

Read Access
FResourcesDir

Sepi
Class Tree
Index
Previous (ProduceLazyLoad)
Next (SkipIfNotExists)


Sepi

Sepi
Previous (ResourcesDir)
Next (WaitWhenFinished)

Name
SkipIfNotExists

Parent
TOptions

Visibility
PUBLIC

Description
Ignorer les unités non trouvées

Source code
property SkipIfNotExists : Boolean read FSkipIfNotExists

Read Access
FSkipIfNotExists

Sepi
Class Tree
Index
Previous (ResourcesDir)
Next (WaitWhenFinished)


Sepi

Sepi
Previous (SkipIfNotExists)
Next

Name
WaitWhenFinished

Parent
TOptions

Visibility
PUBLIC

Description
Indique s'il faut attendre quand terminé

Source code
property WaitWhenFinished : Boolean read FWaitWhenFinished

Read Access
FWaitWhenFinished

Sepi
Class Tree
Index
Previous (SkipIfNotExists)
Next


Sepi

Sepi
Previous (ImporterOptions)
Next (ImporterTemplates)

Name
ImporterProducer

Parent
Sepi

Description
Producteur d'importeur d'unité native dans Sepi

Author
sjrd

Version
1.0

Constants
Constant Description

Methods
Method | Description
ProduceImporter (+) | Produit un importeur pour une unité Sepi

Classes
Class | Description
TSepiImporterProducer (+) | Producteur d'importeur d'unité native dans Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ImporterOptions)
Next (ImporterTemplates)


Sepi

Sepi
Previous
Next

Name
TSepiImporterProducer

Parent
ImporterProducer

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Producteur d'importeur d'unité native dans Sepi

Members
Fields
Field | Description
LazyLoad (-) | Indique si l'unité devrait être chargée en lazy
MethodCount (-) | Nombre de méthodes avec adresse
ProducedUnitName (-) | Surcharge du nom de l'unité produite
SepiRoot (-) | Racine Sepi
SepiUnit (-) | Unité Sepi
TemplateDir (-) | Dossier des templates
TypeCount (-) | Nombre de types avec RTTI
UsesList (-) | Liste des uses dans l'importeur produit
VariableCount (-) | Nombre de variables

Methods
Method | Description
Create (+) | Crée un producteur d'importeur d'unité Sepi
Destroy (+) | [@inheritDoc]
HandleClassType (-) | Produit l'importation d'un type classe
HandleMethod (-) | Produit l'importation d'une méthode de classe
HandleRoutine (-) | Produit l'importation d'une routine
HandleType (-) | Produit l'importation d'un type
HandleVariable (-) | Produit l'importation d'une routine
IdentifierFor (-) | Produit un identificateur pour un composant donné depuis un autre composant
MakeSignature (-) | Produit une représentation chaîne d'une signature
NextMethodID (-) | Détermine l'ID de méthode suivant
NextTypeID (-) | Détermine l'ID de type suivant
NextVariableID (-) | Détermine l'ID de variable suivant
PrepareClassMethodTags (-) | Prépare les tags des méthodes d'une classe
Produce (-) | Méthode de production principale
ProduceImporter (+) | Produit un importeur pour une unité Sepi
ProduceUsesList (-) | Produit la liste des uses
RequireUnit (-) | Requiert qu'une unité soit dans les uses
ResolveOverloadedMethod (-) | Résoud l'importation d'une méthode overload
ResolvePropertyMethod (-) | Résoud l'importation d'une méthode via une propriété

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (MethodCount)

Name
LazyLoad

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Indique si l'unité devrait être chargée en lazy

Source code
LazyLoad : Boolean

Sepi
Class Tree
Index
Previous
Next (MethodCount)


Sepi

Sepi
Previous (LazyLoad)
Next (ProducedUnitName)

Name
MethodCount

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Nombre de méthodes avec adresse

Source code
MethodCount : Integer

Sepi
Class Tree
Index
Previous (LazyLoad)
Next (ProducedUnitName)


Sepi

Sepi
Previous (MethodCount)
Next (SepiRoot)

Name
ProducedUnitName

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Surcharge du nom de l'unité produite

Source code
ProducedUnitName : string

Sepi
Class Tree
Index
Previous (MethodCount)
Next (SepiRoot)


Sepi

Sepi
Previous (ProducedUnitName)
Next (SepiUnit)

Name
SepiRoot

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Racine Sepi

Source code
SepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (ProducedUnitName)
Next (SepiUnit)


Sepi

Sepi
Previous (SepiRoot)
Next (TemplateDir)

Name
SepiUnit

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Unité Sepi

Source code
SepiUnit : TSepiUnit

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (TemplateDir)


Sepi

Sepi
Previous (SepiUnit)
Next (TypeCount)

Name
TemplateDir

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Dossier des templates

Source code
TemplateDir : TFileName

Sepi
Class Tree
Index
Previous (SepiUnit)
Next (TypeCount)


Sepi

Sepi
Previous (TemplateDir)
Next (UsesList)

Name
TypeCount

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Nombre de types avec RTTI

Source code
TypeCount : Integer

Sepi
Class Tree
Index
Previous (TemplateDir)
Next (UsesList)


Sepi

Sepi
Previous (TypeCount)
Next (VariableCount)

Name
UsesList

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Liste des uses dans l'importeur produit

Source code
UsesList : TStrings

Sepi
Class Tree
Index
Previous (TypeCount)
Next (VariableCount)


Sepi

Sepi
Previous (UsesList)
Next

Name
VariableCount

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Nombre de variables

Source code
VariableCount : Integer

Sepi
Class Tree
Index
Previous (UsesList)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiImporterProducer

Visibility
PUBLIC

Description
Crée un producteur d'importeur d'unité Sepi

Source code
constructor Create ( ASepiUnit : TSepiUnit ; const AProducedUnitName : string = '' ; ALazyLoad : Boolean = False )

Parameters
Parameter | Description
ASepiUnit : TSepiUnit | Unité Sepi
AProducedUnitName : STRING | Surcharge du nom de l'unité produite
ALazyLoad : BOOLEAN | L'unité Sepi sera chargée en lazy-load

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (HandleClassType)

Name
Destroy

Parent
TSepiImporterProducer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (HandleClassType)


Sepi

Sepi
Previous (Destroy)
Next (HandleMethod)

Name
HandleClassType

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit l'importation d'un type classe

Source code
procedure HandleClassType ( Template : TTemplate ; SepiClass : TSepiClass )

Parameters
Parameter | Description
Template : TTemplate | Template de l'importeur d'unité
SepiClass : TSepiClass | Classe à importer

Sepi
Class Tree
Index
Previous (Destroy)
Next (HandleMethod)


Sepi

Sepi
Previous (HandleClassType)
Next (HandleRoutine)

Name
HandleMethod

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit l'importation d'une méthode de classe

Source code
procedure HandleMethod ( DeclTemplate , ImplTemplate : TTemplate ; SepiClass : TSepiClass ; Method : TSepiMethod )

Parameters
Parameter | Description
DeclTemplate : TTemplate | Template de la déclaration de la classe
ImplTemplate : TTemplate | Template de l'implémentation de la classe
SepiClass : TSepiClass | Classe Sepi
Method : TSepiMethod | Méthode à importer

Sepi
Class Tree
Index
Previous (HandleClassType)
Next (HandleRoutine)


Sepi

Sepi
Previous (HandleMethod)
Next (HandleType)

Name
HandleRoutine

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit l'importation d'une routine

Source code
procedure HandleRoutine ( Template : TTemplate ; Routine : TSepiMethod )

Parameters
Parameter | Description
Template : TTemplate | Template de l'importeur d'unité
Routine : TSepiMethod | Routine à importer

Sepi
Class Tree
Index
Previous (HandleMethod)
Next (HandleType)


Sepi

Sepi
Previous (HandleRoutine)
Next (HandleVariable)

Name
HandleType

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit l'importation d'un type

Source code
procedure HandleType ( Template : TTemplate ; SepiType : TSepiType )

Parameters
Parameter | Description
Template : TTemplate | Template de l'importeur d'unité
SepiType : TSepiType | Type à importer

Sepi
Class Tree
Index
Previous (HandleRoutine)
Next (HandleVariable)


Sepi

Sepi
Previous (HandleType)
Next (IdentifierFor)

Name
HandleVariable

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit l'importation d'une routine

Source code
procedure HandleVariable ( Template : TTemplate ; Variable : TSepiVariable )

Parameters
Parameter | Description
Template : TTemplate | Template de l'importeur d'unité
Variable : TSepiVariable | Variable à importer

Sepi
Class Tree
Index
Previous (HandleType)
Next (IdentifierFor)


Sepi

Sepi
Previous (HandleVariable)
Next (MakeSignature)

Name
IdentifierFor

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit un identificateur pour un composant donné depuis un autre composant
En plus de cela, cette méthode ajoute les uses nécessaires.

Source code
function IdentifierFor ( ForComponent , FromComponent : TSepiComponent ) : string

Parameters
Parameter | Description
ForComponent : TSepiComponent | Composant destination
FromComponent : TSepiComponent | Composant à partir duquel le référencer

Return
Types | Description
STRING | Identificateur pour ce composant

Sepi
Class Tree
Index
Previous (HandleVariable)
Next (MakeSignature)


Sepi

Sepi
Previous (IdentifierFor)
Next (NextMethodID)

Name
MakeSignature

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit une représentation chaîne d'une signature

Source code
function MakeSignature ( Signature : TSepiSignature ; From : TSepiComponent ; const MethodName : string = '' ) : string

Parameters
Parameter | Description
Signature : TSepiSignature | Signature
From : TSepiComponent | Component depuis lequel on regarde
MethodName : STRING | Nom de la méthode (défaut = '')

Return
Types | Description
STRING | Représentation chaîne de la signature

Sepi
Class Tree
Index
Previous (IdentifierFor)
Next (NextMethodID)


Sepi

Sepi
Previous (MakeSignature)
Next (NextTypeID)

Name
NextMethodID

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Détermine l'ID de méthode suivant

Source code
function NextMethodID : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Prochain ID de méthode

Sepi
Class Tree
Index
Previous (MakeSignature)
Next (NextTypeID)


Sepi

Sepi
Previous (NextMethodID)
Next (NextVariableID)

Name
NextTypeID

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Détermine l'ID de type suivant

Source code
function NextTypeID : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Prochain ID de type

Sepi
Class Tree
Index
Previous (NextMethodID)
Next (NextVariableID)


Sepi

Sepi
Previous (NextTypeID)
Next (PrepareClassMethodTags)

Name
NextVariableID

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Détermine l'ID de variable suivant

Source code
function NextVariableID : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Prochain ID de variable

Sepi
Class Tree
Index
Previous (NextTypeID)
Next (PrepareClassMethodTags)


Sepi

Sepi
Previous (NextVariableID)
Next (Produce)

Name
PrepareClassMethodTags

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Prépare les tags des méthodes d'une classe

Source code
function PrepareClassMethodTags ( SepiClass : TSepiClass ) : Boolean

Parameters
Parameter | Description
SepiClass : TSepiClass | Classe Sepi

Return
Types | Description
BOOLEAN | True s'il faut prévoir une importation pour la classe, False sinon

Sepi
Class Tree
Index
Previous (NextVariableID)
Next (Produce)


Sepi

Sepi
Previous (PrepareClassMethodTags)
Next (ProduceImporter)

Name
Produce

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Méthode de production principale

Source code
function Produce : string

Parameters
Parameter Description

Return
Types | Description
STRING | Code de l'importeur

Sepi
Class Tree
Index
Previous (PrepareClassMethodTags)
Next (ProduceImporter)


Sepi

Sepi
Previous (Produce)
Next (ProduceUsesList)

Name
ProduceImporter

Parent
TSepiImporterProducer

Visibility
PUBLIC

Description
Produit un importeur pour une unité Sepi

Source code
class function ProduceImporter ( SepiUnit : TSepiUnit ; const ProducedUnitName : string = '' ; LazyLoad : Boolean = False ) : string

Parameters
Parameter | Description
SepiUnit : TSepiUnit | Unité Sepi
ProducedUnitName : STRING | Surcharge du nom de l'unité produite
LazyLoad : BOOLEAN | L'unité Sepi sera chargée en lazy-load

Return
Types | Description
STRING | Code de l'importeur

Sepi
Class Tree
Index
Previous (Produce)
Next (ProduceUsesList)


Sepi

Sepi
Previous (ProduceImporter)
Next (RequireUnit)

Name
ProduceUsesList

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Produit la liste des uses

Source code
function ProduceUsesList : string

Parameters
Parameter Description

Return
Types | Description
STRING | Liste des uses

Sepi
Class Tree
Index
Previous (ProduceImporter)
Next (RequireUnit)


Sepi

Sepi
Previous (ProduceUsesList)
Next (ResolveOverloadedMethod)

Name
RequireUnit

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Requiert qu'une unité soit dans les uses

Source code
procedure RequireUnit ( const UnitName : string )

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité à mettre dans les uses

Sepi
Class Tree
Index
Previous (ProduceUsesList)
Next (ResolveOverloadedMethod)


Sepi

Sepi
Previous (RequireUnit)
Next (ResolvePropertyMethod)

Name
ResolveOverloadedMethod

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Résoud l'importation d'une méthode overload

Source code
function ResolveOverloadedMethod ( Template : TTemplate ; Method : TSepiMethod ; const AClassName : string = '' ) : string

Parameters
Parameter | Description
Template : TTemplate | Template de l'importeur d'unité
Method : TSepiMethod | Méthode à résoudre
AClassName : STRING | Nom de la classe de la méthode (vide pour une routine)

Return
Types | Description
STRING | Nom d'import de la méthode

Sepi
Class Tree
Index
Previous (RequireUnit)
Next (ResolvePropertyMethod)


Sepi

Sepi
Previous (ResolveOverloadedMethod)
Next

Name
ResolvePropertyMethod

Parent
TSepiImporterProducer

Visibility
PRIVATE

Description
Résoud l'importation d'une méthode via une propriété

Source code
function ResolvePropertyMethod ( Template : TTemplate ; Method : TSepiMethod ; const AClassName : string = '' ) : string

Parameters
Parameter | Description
Template : TTemplate | Template de l'importeur d'unité
Method : TSepiMethod | Méthode à résoudre
AClassName : STRING | Nom de la classe de la méthode

Return
Types | Description
STRING | Nom d'import de la méthode

Sepi
Class Tree
Index
Previous (ResolveOverloadedMethod)
Next


Sepi

Sepi
Previous
Next

Name
ProduceImporter

Parent
ImporterProducer

Visibility
PUBLIC

Description
Produit un importeur pour une unité Sepi

Source code
function ProduceImporter ( SepiUnit : TSepiUnit ; const ProducedUnitName : string = '' ; LazyLoad : Boolean = False ) : string

Parameters
Parameter | Description
SepiUnit : TSepiUnit | Unité Sepi
ProducedUnitName : STRING | Surcharge du nom de l'unité produite
LazyLoad : BOOLEAN

Return
Types | Description
STRING | Code de l'importeur

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ImporterProducer)
Next (Imports)

Name
ImporterTemplates

Parent
Sepi

Description
Processeur de template simple

Author
sjrd

Version
1.0

Classes
Class | Description
TTemplate (+) | Simple template processor

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ImporterProducer)
Next (Imports)


Sepi

Sepi
Previous
Next

Name
TTemplate

Parent
ImporterTemplates

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Simple template processor

Members
Fields
Field | Description
Contents (-) | Contents of the template file
ParamNames (-) | Names of the parameters
ParamValues (-) | Values of the parameters

Methods
Method | Description
AddToParam (+) | Adds a string to a parameter
AddToParam (+) | Adds a TStrings to a parameter
Clear (+) | Clears all parameters
Create (+) | Creates a new template
Destroy (+) | [@inheritDoc]
Process (+) | Processes the template
SetParam (+) | Sets up an enumerated or set parameter
SetParam (+) | Sets up a TStrings parameter
SetParam (+) | Sets up a string parameter
SetParam (+) | Sets up a boolean parameter
SetParam (+) | Sets up an integer parameter

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ParamNames)

Name
Contents

Parent
TTemplate

Visibility
PRIVATE

Description
Contents of the template file

Source code
Contents : string

Sepi
Class Tree
Index
Previous
Next (ParamNames)


Sepi

Sepi
Previous (Contents)
Next (ParamValues)

Name
ParamNames

Parent
TTemplate

Visibility
PRIVATE

Description
Names of the parameters

Source code
ParamNames : TStrings

Sepi
Class Tree
Index
Previous (Contents)
Next (ParamValues)


Sepi

Sepi
Previous (ParamNames)
Next

Name
ParamValues

Parent
TTemplate

Visibility
PRIVATE

Description
Values of the parameters

Source code
ParamValues : array of string

Sepi
Class Tree
Index
Previous (ParamNames)
Next


Sepi

Sepi
Previous
Next (AddToParam)

Name
AddToParam

Parent
TTemplate

Visibility
PUBLIC

Description
Adds a string to a parameter

Source code
procedure AddToParam ( const ParamName , ParamValue : string ) ; overload

Parameters
Parameter | Description
ParamName : STRING | Parameter name
ParamValue : STRING | Parameter value

Sepi
Class Tree
Index
Previous
Next (AddToParam)


Sepi

Sepi
Previous (AddToParam)
Next (Clear)

Name
AddToParam

Parent
TTemplate

Visibility
PUBLIC

Description
Adds a TStrings to a parameter

Source code
procedure AddToParam ( const ParamName : string ; ParamValue : TStrings ) ; overload

Parameters
Parameter | Description
ParamName : STRING | Parameter name
ParamValue : TStrings | Parameter value

Sepi
Class Tree
Index
Previous (AddToParam)
Next (Clear)


Sepi

Sepi
Previous (AddToParam)
Next (Create)

Name
Clear

Parent
TTemplate

Visibility
PUBLIC

Description
Clears all parameters

Source code
procedure Clear

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddToParam)
Next (Create)


Sepi

Sepi
Previous (Clear)
Next (Destroy)

Name
Create

Parent
TTemplate

Visibility
PUBLIC

Description
Creates a new template

Source code
constructor Create ( const FileName : TFileName )

Parameters
Parameter | Description
FileName : TFileName | Name of the template file

Sepi
Class Tree
Index
Previous (Clear)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Process)

Name
Destroy

Parent
TTemplate

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Process)


Sepi

Sepi
Previous (Destroy)
Next (SetParam)

Name
Process

Parent
TTemplate

Visibility
PUBLIC

Description
Processes the template

Source code
function Process : string

Parameters
Parameter Description

Return
Types | Description
STRING | The template processed

Sepi
Class Tree
Index
Previous (Destroy)
Next (SetParam)


Sepi

Sepi
Previous (Process)
Next (SetParam)

Name
SetParam

Parent
TTemplate

Visibility
PUBLIC

Description
Sets up an enumerated or set parameter

Source code
procedure SetParam ( const ParamName : string ; const ParamValue ; TypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
ParamName : STRING | Parameter name
ParamValue : Untyped | Parameter value
TypeInfo : PTypeInfo

Sepi
Class Tree
Index
Previous (Process)
Next (SetParam)


Sepi

Sepi
Previous (SetParam)
Next (SetParam)

Name
SetParam

Parent
TTemplate

Visibility
PUBLIC

Description
Sets up a TStrings parameter

Source code
procedure SetParam ( const ParamName : string ; ParamValue : TStrings ) ; overload

Parameters
Parameter | Description
ParamName : STRING | Parameter name
ParamValue : TStrings | Parameter value

Sepi
Class Tree
Index
Previous (SetParam)
Next (SetParam)


Sepi

Sepi
Previous (SetParam)
Next (SetParam)

Name
SetParam

Parent
TTemplate

Visibility
PUBLIC

Description
Sets up a string parameter

Source code
procedure SetParam ( const ParamName , ParamValue : string ) ; overload

Parameters
Parameter | Description
ParamName : STRING | Parameter name
ParamValue : STRING | Parameter value

Sepi
Class Tree
Index
Previous (SetParam)
Next (SetParam)


Sepi

Sepi
Previous (SetParam)
Next (SetParam)

Name
SetParam

Parent
TTemplate

Visibility
PUBLIC

Description
Sets up a boolean parameter

Source code
procedure SetParam ( const ParamName : string ; ParamValue : Boolean ) ; overload

Parameters
Parameter | Description
ParamName : STRING | Parameter name
ParamValue : BOOLEAN | Parameter value

Sepi
Class Tree
Index
Previous (SetParam)
Next (SetParam)


Sepi

Sepi
Previous (SetParam)
Next

Name
SetParam

Parent
TTemplate

Visibility
PUBLIC

Description
Sets up an integer parameter

Source code
procedure SetParam ( const ParamName : string ; ParamValue : Integer ) ; overload

Parameters
Parameter | Description
ParamName : STRING | Parameter name
ParamValue : INTEGER | Parameter value

Sepi
Class Tree
Index
Previous (SetParam)
Next


Sepi

Sepi
Previous (Imports)
Next (MembersInfo)

Name
Imports

Parent
Sepi

Description
Importe toutes les unités que Sepi importe en standard
Importe toutes les unités que Sepi importe en standard

Author
sjrd
sjrd

Version
1.0
1.0

Methods
Method | Description
LoadAll (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (Imports)
Next (MembersInfo)


Sepi

Sepi
Previous
Next

Name
LoadAll

Parent
Imports

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure LoadAll ( SepiRoot : TSepiRoot )

Parameters
Parameter | Description
SepiRoot : TSepiRoot | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (Imports)
Next (RunOptions)

Name
MembersInfo

Parent
Sepi

Description
Informations sur les membres Sepi

Author
sjrd

Version
1.0

Methods
Method | Description
PrintFieldInfo (+) | #No TAG found in source code#
PrintMethodInfo (+) | #No TAG found in source code#
PrintPropertyInfo (+) | #No TAG found in source code#
PrintSignature (+) | #No TAG found in source code#

Classes
Class | Description
TOutputWriter (+) | Écrivain dans une liste de chaînes

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (Imports)
Next (RunOptions)


Sepi

Sepi
Previous
Next

Name
TOutputWriter

Parent
MembersInfo

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Écrivain dans une liste de chaînes

Members
Fields
Field | Description
FCurStr (-) | Current string
FStrings (-) | Liste de chaînes de sortie

Methods
Method | Description
BeforeDestruction (+) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
WRITE (+) | #No TAG found in source code#
WriteLn (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FStrings)

Name
FCurStr

Parent
TOutputWriter

Visibility
PRIVATE

Description
Current string

Source code
FCurStr : string

Sepi
Class Tree
Index
Previous
Next (FStrings)


Sepi

Sepi
Previous (FCurStr)
Next

Name
FStrings

Parent
TOutputWriter

Visibility
PRIVATE

Description
Liste de chaînes de sortie

Source code
FStrings : TStrings

Sepi
Class Tree
Index
Previous (FCurStr)
Next


Sepi

Sepi
Previous
Next (Create)

Name
BeforeDestruction

Parent
TOutputWriter

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (BeforeDestruction)
Next (WRITE)

Name
Create

Parent
TOutputWriter

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( AStrings : TStrings )

Parameters
Parameter | Description
AStrings : TStrings | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (WRITE)


Sepi

Sepi
Previous (Create)
Next (WriteLn)

Name
WRITE

Parent
TOutputWriter

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Write ( const Str : string = '' )

Parameters
Parameter | Description
Str : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (WriteLn)


Sepi

Sepi
Previous (WRITE)
Next

Name
WriteLn

Parent
TOutputWriter

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure WriteLn ( const Str : string = '' )

Parameters
Parameter | Description
Str : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WRITE)
Next


Sepi

Sepi
Previous
Next (PrintMethodInfo)

Name
PrintFieldInfo

Parent
MembersInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintFieldInfo ( Output : TOutputWriter ; Field : TSepiField )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Field : TSepiField | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (PrintMethodInfo)


Sepi

Sepi
Previous (PrintFieldInfo)
Next (PrintPropertyInfo)

Name
PrintMethodInfo

Parent
MembersInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintMethodInfo ( Output : TOutputWriter ; Method : TSepiMethod )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Method : TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrintFieldInfo)
Next (PrintPropertyInfo)


Sepi

Sepi
Previous (PrintMethodInfo)
Next (PrintSignature)

Name
PrintPropertyInfo

Parent
MembersInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintPropertyInfo ( Output : TOutputWriter ; Prop : TSepiProperty )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Prop : TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrintMethodInfo)
Next (PrintSignature)


Sepi

Sepi
Previous (PrintPropertyInfo)
Next

Name
PrintSignature

Parent
MembersInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintSignature ( Output : TOutputWriter ; Signature : TSepiSignature ; const Name : string = '' ; const Brackets : string = '()' )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Signature : TSepiSignature | #Pas de TAG trouvé dans le code source#
NAME : STRING | #Pas de TAG trouvé dans le code source#
Brackets : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrintPropertyInfo)
Next


Sepi

Sepi
Previous (MembersInfo)
Next (ScClasses)

Name
RunOptions

Parent
Sepi

Description
Options d'exécution

Author
sjrd

Version
1.0

Constants
Constant | Description
SOneUnitNameRequired (+) | #No TAG found in source code#

Classes
Class | Description
TSepiRunOptions (+) | Options de lancement d'un programme Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (MembersInfo)
Next (ScClasses)


Sepi

Sepi
Previous
Next

Name
TSepiRunOptions

Parent
RunOptions

Class Hierarchy
TCommandLine

Visibility
PUBLIC

Description
Options de lancement d'un programme Sepi

Members
Fields
Field | Description
FBrowsingPath (-) | Chemin de recherche
FUnitName (-) | Unité à exécuter
FUseDebugger (-) | Indique s'il faut utiliser un debugger
FWaitWhenFinished (-) | Indique s'il faut attendre quand terminé

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
Create (+) | Crée les options de lancement et les charge depuis la ligne de commande

Properties
Property | Description
BrowsingPath (+) | Chemin de recherche
MainUnitName (+) | Unité à exécuter
UseDebugger (+) | Indique s'il faut utiliser un debugger
WaitWhenFinished (+) | Indique s'il faut attendre quand terminé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FUnitName)

Name
FBrowsingPath

Parent
TSepiRunOptions

Visibility
PRIVATE

Description
Chemin de recherche

Source code
FBrowsingPath : string

Sepi
Class Tree
Index
Previous
Next (FUnitName)


Sepi

Sepi
Previous (FBrowsingPath)
Next (FUseDebugger)

Name
FUnitName

Parent
TSepiRunOptions

Visibility
PRIVATE

Description
Unité à exécuter

Source code
FUnitName : string

Sepi
Class Tree
Index
Previous (FBrowsingPath)
Next (FUseDebugger)


Sepi

Sepi
Previous (FUnitName)
Next (FWaitWhenFinished)

Name
FUseDebugger

Parent
TSepiRunOptions

Visibility
PRIVATE

Description
Indique s'il faut utiliser un debugger

Source code
FUseDebugger : Boolean

Sepi
Class Tree
Index
Previous (FUnitName)
Next (FWaitWhenFinished)


Sepi

Sepi
Previous (FUseDebugger)
Next

Name
FWaitWhenFinished

Parent
TSepiRunOptions

Visibility
PRIVATE

Description
Indique s'il faut attendre quand terminé

Source code
FWaitWhenFinished : Boolean

Sepi
Class Tree
Index
Previous (FUseDebugger)
Next


Sepi

Sepi
Previous
Next (MainUnitName)

Name
BrowsingPath

Parent
TSepiRunOptions

Visibility
PUBLIC

Description
Chemin de recherche

Source code
property BrowsingPath : string read FBrowsingPath

Read Access
FBrowsingPath

Sepi
Class Tree
Index
Previous
Next (MainUnitName)


Sepi

Sepi
Previous (BrowsingPath)
Next (UseDebugger)

Name
MainUnitName

Parent
TSepiRunOptions

Visibility
PUBLIC

Description
Unité à exécuter

Source code
property MainUnitName : string read FUnitName

Read Access
FUnitName

Sepi
Class Tree
Index
Previous (BrowsingPath)
Next (UseDebugger)


Sepi

Sepi
Previous (MainUnitName)
Next (WaitWhenFinished)

Name
UseDebugger

Parent
TSepiRunOptions

Visibility
PUBLIC

Description
Indique s'il faut utiliser un debugger

Source code
property UseDebugger : Boolean read FUseDebugger

Read Access
FUseDebugger

Sepi
Class Tree
Index
Previous (MainUnitName)
Next (WaitWhenFinished)


Sepi

Sepi
Previous (UseDebugger)
Next

Name
WaitWhenFinished

Parent
TSepiRunOptions

Visibility
PUBLIC

Description
Indique s'il faut attendre quand terminé

Source code
property WaitWhenFinished : Boolean read FWaitWhenFinished

Read Access
FWaitWhenFinished

Sepi
Class Tree
Index
Previous (UseDebugger)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AfterConstruction

Parent
TSepiRunOptions

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AfterConstruction)
Next

Name
Create

Parent
TSepiRunOptions

Visibility
PUBLIC

Description
Crée les options de lancement et les charge depuis la ligne de commande

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next


Sepi

Sepi
Previous
Next

Name
SOneUnitNameRequired

Parent
RunOptions

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOneUnitNameRequired = 'Un et un seul nom d''unité à exécuter requis'

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (RunOptions)
Next (ScCompilerMagic)

Name
ScClasses

Parent
Sepi

Description
Extension de Classes

Author
sjrd

Version
1.0

Types
Type | Description
TThreadedMethod (+) | Prototype d'une méthode d'exécution d'un thread

Classes
Class | Description
TAbsoluteMemoryStream (+) | Flux travaillant dans la mémoire vive de façon absolue
TMeasureStream (+) | Flux virtuel qui ne lit/enregistre rien, mais retient la taille requise
TMethodThread (+) | Thread dont on fournit la méthode d'exécution en externe

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (RunOptions)
Next (ScCompilerMagic)


Sepi

Sepi
Previous
Next (TMeasureStream)

Name
TAbsoluteMemoryStream

Parent
ScClasses

Class Hierarchy
TStream

Visibility
PUBLIC

Description
Flux travaillant dans la mémoire vive de façon absolue

Members
Fields
Field | Description
FPosition (-) | #No TAG found in source code#

Methods
Method | Description
Create (+) | Crée un nouveau flux de mémoire vive
GetSize (#) | [@inheritDoc]
READ (+) | [@inheritDoc]
Seek (+) | [@inheritDoc]
WRITE (+) | [@inheritDoc]

Properties
Property | Description
PointerPos (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TMeasureStream)


Sepi

Sepi
Previous
Next

Name
FPosition

Parent
TAbsoluteMemoryStream

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FPosition : Pointer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
PointerPos

Parent
TAbsoluteMemoryStream

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property PointerPos : Pointer read FPosition write FPosition

Read Access
FPosition

Write Access
FPosition

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetSize)

Name
Create

Parent
TAbsoluteMemoryStream

Visibility
PUBLIC

Description
Crée un nouveau flux de mémoire vive

Source code
constructor Create ( APosition : Pointer = nil )

Parameters
Parameter | Description
APosition : Pointer | Adresse initiale

Sepi
Class Tree
Index
Previous
Next (GetSize)


Sepi

Sepi
Previous (Create)
Next (READ)

Name
GetSize

Parent
TAbsoluteMemoryStream

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetSize : Int64 ; override

Parameters
Parameter Description

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (READ)


Sepi

Sepi
Previous (GetSize)
Next (Seek)

Name
READ

Parent
TAbsoluteMemoryStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Read ( var Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetSize)
Next (Seek)


Sepi

Sepi
Previous (READ)
Next (WRITE)

Name
Seek

Parent
TAbsoluteMemoryStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Seek ( Offset : Longint ; Origin : Word ) : Longint ; override

Parameters
Parameter | Description
OFFSET : LONGINT | #Pas de TAG trouvé dans le code source#
Origin : WORD | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (READ)
Next (WRITE)


Sepi

Sepi
Previous (Seek)
Next

Name
WRITE

Parent
TAbsoluteMemoryStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Write ( const Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Seek)
Next


Sepi

Sepi
Previous (TAbsoluteMemoryStream)
Next (TMethodThread)

Name
TMeasureStream

Parent
ScClasses

Class Hierarchy
TStream

Visibility
PUBLIC

Description
Flux virtuel qui ne lit/enregistre rien, mais retient la taille requise
TMeasureStream peut être utilisé pour mesurer a priori la taille requise
par une méthode qui écrit dans un flux.

Members
Fields
Field | Description
FPosition (-) | Position
FSize (-) | Taille

Methods
Method | Description
GetSize (#) | [@inheritDoc]
READ (+) | #No TAG found in source code#
Seek (+) | [@inheritDoc]
SetSize (#) | [@inheritDoc]
WRITE (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TAbsoluteMemoryStream)
Next (TMethodThread)


Sepi

Sepi
Previous
Next (FSize)

Name
FPosition

Parent
TMeasureStream

Visibility
PRIVATE

Description
Position

Source code
FPosition : Int64

Sepi
Class Tree
Index
Previous
Next (FSize)


Sepi

Sepi
Previous (FPosition)
Next

Name
FSize

Parent
TMeasureStream

Visibility
PRIVATE

Description
Taille

Source code
FSize : Int64

Sepi
Class Tree
Index
Previous (FPosition)
Next


Sepi

Sepi
Previous
Next (READ)

Name
GetSize

Parent
TMeasureStream

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetSize : Int64 ; override

Parameters
Parameter Description

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (READ)


Sepi

Sepi
Previous (GetSize)
Next (Seek)

Name
READ

Parent
TMeasureStream

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Read ( var Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetSize)
Next (Seek)


Sepi

Sepi
Previous (READ)
Next (SetSize)

Name
Seek

Parent
TMeasureStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Seek ( const Offset : Int64 ; Origin : TSeekOrigin ) : Int64 ; override

Parameters
Parameter | Description
OFFSET : INT64 | #Pas de TAG trouvé dans le code source#
Origin : TSeekOrigin | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (READ)
Next (SetSize)


Sepi

Sepi
Previous (Seek)
Next (WRITE)

Name
SetSize

Parent
TMeasureStream

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetSize ( const NewSize : Int64 ) ; override

Parameters
Parameter | Description
NewSize : INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Seek)
Next (WRITE)


Sepi

Sepi
Previous (SetSize)
Next

Name
WRITE

Parent
TMeasureStream

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Write ( const Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetSize)
Next


Sepi

Sepi
Previous (TMeasureStream)
Next

Name
TMethodThread

Parent
ScClasses

Class Hierarchy
TThread

Visibility
PUBLIC

Description
Thread dont on fournit la méthode d'exécution en externe

Members
Fields
Field | Description
FExecuteMethod (-) | Méthode d'exécution du thread
FOnDoTerminate (-) | Appelé dans le contexte du thread lorsque celui-ci se termine

Methods
Method | Description
Create (+) | Crée l'objet thread
DoTerminate (#) | [@inheritDoc]
Execute (#) | [@inheritDoc]

Properties
Property | Description
OnDoTerminate (+) | Appelé dans le contexte du thread lorsque celui-ci se termine
ReturnValue (+) | #No TAG found in source code#
Terminated (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TMeasureStream)
Next


Sepi

Sepi
Previous
Next (FOnDoTerminate)

Name
FExecuteMethod

Parent
TMethodThread

Visibility
PRIVATE

Description
Méthode d'exécution du thread

Source code
FExecuteMethod : TThreadedMethod

Sepi
Class Tree
Index
Previous
Next (FOnDoTerminate)


Sepi

Sepi
Previous (FExecuteMethod)
Next

Name
FOnDoTerminate

Parent
TMethodThread

Visibility
PRIVATE

Description
Appelé dans le contexte du thread lorsque celui-ci se termine

Source code
FOnDoTerminate : TNotifyEvent

Sepi
Class Tree
Index
Previous (FExecuteMethod)
Next


Sepi

Sepi
Previous
Next (ReturnValue)

Name
OnDoTerminate

Parent
TMethodThread

Visibility
PUBLIC

Description
Appelé dans le contexte du thread lorsque celui-ci se termine

Source code
property OnDoTerminate : TNotifyEvent read FOnDoTerminate write FOnDoTerminate

Read Access
FOnDoTerminate

Write Access
FOnDoTerminate

Sepi
Class Tree
Index
Previous
Next (ReturnValue)


Sepi

Sepi
Previous (OnDoTerminate)
Next (Terminated)

Name
ReturnValue

Parent
TMethodThread

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ReturnValue

Sepi
Class Tree
Index
Previous (OnDoTerminate)
Next (Terminated)


Sepi

Sepi
Previous (ReturnValue)
Next

Name
Terminated

Parent
TMethodThread

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Terminated

Sepi
Class Tree
Index
Previous (ReturnValue)
Next


Sepi

Sepi
Previous
Next (DoTerminate)

Name
Create

Parent
TMethodThread

Visibility
PUBLIC

Description
Crée l'objet thread

Source code
constructor Create ( AExecuteMethod : TThreadedMethod ; CreateSuspended : Boolean = False )

Parameters
Parameter | Description
AExecuteMethod : TThreadedMethod | Méthode d'exécution du thread
CreateSuspended : BOOLEAN | True commence en état suspendu (défaut = False)

Sepi
Class Tree
Index
Previous
Next (DoTerminate)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
DoTerminate

Parent
TMethodThread

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure DoTerminate ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (DoTerminate)
Next

Name
Execute

Parent
TMethodThread

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Execute ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DoTerminate)
Next


Sepi

Sepi
Previous
Next

Name
TThreadedMethod

Parent
ScClasses

Visibility
PUBLIC

Description
Prototype d'une méthode d'exécution d'un thread

Source code
TThreadedMethod = procedure ( Thread : TMethodThread ) of object ;

Parameters
Parameter | Description
Thread : TMethodThread | Objet thread qui contrôle le thread de la méthode

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ScClasses)
Next (ScConsoleUtils)

Name
ScCompilerMagic

Parent
Sepi

Description
Propose une série d'alias aux routines cachées de System
Ces routines sont celles connues sous le nom de "compiler magic".

Author
sjrd

Version
1.0

Methods
Method | Description
AbstractError (+) | Déclenche une erreur abstraite - alias de @AbstractError
AddRef (+) | Ajoute une référence à une variable - alias de @AddRefArray
CopyArray (+) | Copie un tableau statique - alias de @CopyArray
CopyRecord (+) | Copie un record - alias de @CopyRecord
DereferenceJump (+) | Déréférence un JUMP dans un code x86, le plus loin possible
DynArrayAsg (+) | Assigne un tableau dynamique
DynArrayCopy (+) | Copie un tableau dynamique - alias de @DynArrayCopy
DynArrayCopyRange (+) | Copie une partie d'un tableau dynamique - alias de @DynArrayCopyRange
DynArrayHigh (+) | Borne haute d'un tableau dynamique
DynArrayLength (+) | Longueur d'un tableau dynamique
Finalize (+) | Finalise une variable - alias de @FinalizeArray
Initialize (+) | Initialise une variable - alias de @InitializeArray
LStrFromUStr (+) | Assigne une chaîne Unicode à une chaîne Ansi
SetContained (+) | Teste si un set est contenu dans un autre
SetElem (+) | Construit un set singleton
SetEquals (+) | Teste si deux sets sont égaux
SetExpand (+) | Étend un set "packed" en set étendu sur 32 octets
SetIntersect (+) | Calcule l'intersection de deux sets
SetRange (+) | Construit un set intervalle
SetSub (+) | Calcule la soustraction de deux sets
SetUnion (+) | Calcule l'union de deux sets

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScClasses)
Next (ScConsoleUtils)


Sepi

Sepi
Previous
Next (AddRef)

Name
AbstractError

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Déclenche une erreur abstraite - alias de @AbstractError

Source code
procedure AbstractError

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (AddRef)


Sepi

Sepi
Previous (AbstractError)
Next (CopyArray)

Name
AddRef

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Ajoute une référence à une variable - alias de @AddRefArray

Source code
procedure AddRef ( var Value ; TypeInfo : PTypeInfo ; Count : Cardinal = 1 )

Parameters
Parameter | Description
Value : Untyped | Variable à laquelle ajouter une référence
TypeInfo : PTypeInfo | RTTI du type de la variable
Count : CARDINAL | Nombre d'éléments dans la variable

Sepi
Class Tree
Index
Previous (AbstractError)
Next (CopyArray)


Sepi

Sepi
Previous (AddRef)
Next (CopyRecord)

Name
CopyArray

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Copie un tableau statique - alias de @CopyArray

Source code
procedure CopyArray ( Dest , Source , TypeInfo : Pointer ; Count : Integer )

Parameters
Parameter | Description
Dest : Pointer | Pointeur sur le tableau destination
Source : Pointer | Pointeur sur le tableau source
TypeInfo : Pointer | RTTI du type des éléments du tableau
Count : INTEGER | Nombre d'éléments dans le tableau

Sepi
Class Tree
Index
Previous (AddRef)
Next (CopyRecord)


Sepi

Sepi
Previous (CopyArray)
Next (DereferenceJump)

Name
CopyRecord

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Copie un record - alias de @CopyRecord

Source code
procedure CopyRecord ( Dest , Source , TypeInfo : Pointer )

Parameters
Parameter | Description
Dest : Pointer | Pointeur sur le record destination
Source : Pointer | Pointeur sur le record source
TypeInfo : Pointer | RTTI du type record

Sepi
Class Tree
Index
Previous (CopyArray)
Next (DereferenceJump)


Sepi

Sepi
Previous (CopyRecord)
Next (DynArrayAsg)

Name
DereferenceJump

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Déréférence un JUMP dans un code x86, le plus loin possible

Source code
function DereferenceJump ( Code : Pointer ) : Pointer

Parameters
Parameter | Description
Code : Pointer | Pointeur sur le code du JUMP

Return
Types | Description
Pointer | Pointeur sur le code de la routine réelle

Sepi
Class Tree
Index
Previous (CopyRecord)
Next (DynArrayAsg)


Sepi

Sepi
Previous (DereferenceJump)
Next (DynArrayCopy)

Name
DynArrayAsg

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Assigne un tableau dynamique

Source code
procedure DynArrayAsg ( var Dest : Pointer ; Src : Pointer ; TypeInfo : Pointer )

Parameters
Parameter | Description
Dest : Pointer | Destination
Src : Pointer | Source
TypeInfo : Pointer | RTTI du type tableau dynamique

Sepi
Class Tree
Index
Previous (DereferenceJump)
Next (DynArrayCopy)


Sepi

Sepi
Previous (DynArrayAsg)
Next (DynArrayCopyRange)

Name
DynArrayCopy

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Copie un tableau dynamique - alias de @DynArrayCopy

Source code
procedure DynArrayCopy ( Source : Pointer ; TypeInfo : Pointer ; var Dest : Pointer )

Parameters
Parameter | Description
Source : Pointer | Tableau source sous forme de pointeur
TypeInfo : Pointer | RTTI du type tableau dynamique
Dest : Pointer | Tableau destination sous forme de pointeur

Sepi
Class Tree
Index
Previous (DynArrayAsg)
Next (DynArrayCopyRange)


Sepi

Sepi
Previous (DynArrayCopy)
Next (DynArrayHigh)

Name
DynArrayCopyRange

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Copie une partie d'un tableau dynamique - alias de @DynArrayCopyRange

Source code
procedure DynArrayCopyRange ( Source : Pointer ; TypeInfo : Pointer ; Index , Count : Integer ; var Dest : Pointer ) ; assembler

Parameters
Parameter | Description
Source : Pointer | Tableau source sous forme de pointeur
TypeInfo : Pointer | RTTI du type tableau dynamique
INDEX : INTEGER | Index du premier élément à copier
Count : INTEGER | Nombre d'éléments à copier
Dest : Pointer | Tableau destination sous forme de pointeur

Sepi
Class Tree
Index
Previous (DynArrayCopy)
Next (DynArrayHigh)


Sepi

Sepi
Previous (DynArrayCopyRange)
Next (DynArrayLength)

Name
DynArrayHigh

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Borne haute d'un tableau dynamique

Source code
function DynArrayHigh ( const DynArray ) : Integer

Parameters
Parameter | Description
DynArray : Untyped | Tableau dynamique

Return
Types | Description
INTEGER | Borne haute du tableau DynArray

Sepi
Class Tree
Index
Previous (DynArrayCopyRange)
Next (DynArrayLength)


Sepi

Sepi
Previous (DynArrayHigh)
Next (Finalize)

Name
DynArrayLength

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Longueur d'un tableau dynamique

Source code
function DynArrayLength ( const DynArray ) : Integer

Parameters
Parameter | Description
DynArray : Untyped | Tableau dynamique

Return
Types | Description
INTEGER | Longueur du tableau DynArray

Sepi
Class Tree
Index
Previous (DynArrayHigh)
Next (Finalize)


Sepi

Sepi
Previous (DynArrayLength)
Next (Initialize)

Name
Finalize

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Finalise une variable - alias de @FinalizeArray

Source code
procedure Finalize ( var Value ; TypeInfo : PTypeInfo ; Count : Cardinal = 1 )

Parameters
Parameter | Description
Value : Untyped | Variable à finaliser
TypeInfo : PTypeInfo | RTTI du type de la variable
Count : CARDINAL | Nombre d'éléments dans la variable

Sepi
Class Tree
Index
Previous (DynArrayLength)
Next (Initialize)


Sepi

Sepi
Previous (Finalize)
Next (LStrFromUStr)

Name
Initialize

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Initialise une variable - alias de @InitializeArray

Source code
procedure Initialize ( var Value ; TypeInfo : PTypeInfo ; Count : Cardinal = 1 )

Parameters
Parameter | Description
Value : Untyped | Variable à initialiser
TypeInfo : PTypeInfo | RTTI du type de la variable
Count : CARDINAL | Nombre d'éléments dans la variable

Sepi
Class Tree
Index
Previous (Finalize)
Next (LStrFromUStr)


Sepi

Sepi
Previous (Initialize)
Next (SetContained)

Name
LStrFromUStr

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Assigne une chaîne Unicode à une chaîne Ansi

Source code
procedure LStrFromUStr ( var Dest : AnsiString ; const Source : UnicodeString ; CodePage : Word )

Parameters
Parameter | Description
Dest : ANSISTRING | Destination
Source : UnicodeString | Source
CodePage : WORD | Code page de la destination

Sepi
Class Tree
Index
Previous (Initialize)
Next (SetContained)


Sepi

Sepi
Previous (LStrFromUStr)
Next (SetElem)

Name
SetContained

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Teste si un set est contenu dans un autre

Source code
function SetContained ( const SubSet , ContainingSet ; Size : Byte ) : Boolean

Parameters
Parameter | Description
SubSet : Untyped | Sous-set
ContainingSet : Untyped | Set contenant
Size : BYTE | Taille en octets des sets

Return
Types | Description
BOOLEAN | True si SubSet est contenu dans ContainingSet, False sinon

Sepi
Class Tree
Index
Previous (LStrFromUStr)
Next (SetElem)


Sepi

Sepi
Previous (SetContained)
Next (SetEquals)

Name
SetElem

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Construit un set singleton

Source code
procedure SetElem ( var Dest ; Elem , Size : Byte )

Parameters
Parameter | Description
Dest : Untyped | Set destination
Elem : BYTE | Valeur ordinale (normalisée sur la MinValue) de l'élément
Size : BYTE | Taille en octets du set destination

Sepi
Class Tree
Index
Previous (SetContained)
Next (SetEquals)


Sepi

Sepi
Previous (SetElem)
Next (SetExpand)

Name
SetEquals

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Teste si deux sets sont égaux

Source code
function SetEquals ( const Set1 , Set2 ; Size : Byte ) : Boolean

Parameters
Parameter | Description
Set1 : Untyped | Premier opérande
Set2 : Untyped | Second opérande
Size : BYTE | Taille en octets des sets

Return
Types | Description
BOOLEAN | True si les sets sont égaux, False sinon

Sepi
Class Tree
Index
Previous (SetElem)
Next (SetExpand)


Sepi

Sepi
Previous (SetEquals)
Next (SetIntersect)

Name
SetExpand

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Étend un set "packed" en set étendu sur 32 octets

Source code
procedure SetExpand ( const PackedSet ; var ExpandedSet ; Lo , Hi : Byte )

Parameters
Parameter | Description
PackedSet : Untyped | Set source "packed"
ExpandedSet : Untyped | Set destination "étandu", sur 32 octets
Lo : BYTE | Byte bas du packed set
Hi : BYTE | Byte haut du packed set

Sepi
Class Tree
Index
Previous (SetEquals)
Next (SetIntersect)


Sepi

Sepi
Previous (SetExpand)
Next (SetRange)

Name
SetIntersect

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Calcule l'intersection de deux sets

Source code
procedure SetIntersect ( var Dest ; const Source ; Size : Byte )

Parameters
Parameter | Description
Dest : Untyped | Set destination et opérande de gauche
Source : Untyped | Set opérande de droite
Size : BYTE | Taille en octets des sets

Sepi
Class Tree
Index
Previous (SetExpand)
Next (SetRange)


Sepi

Sepi
Previous (SetIntersect)
Next (SetSub)

Name
SetRange

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Construit un set intervalle

Source code
procedure SetRange ( var Dest ; Lo , Hi , Size : Byte )

Parameters
Parameter | Description
Dest : Untyped | Set destination
Lo : BYTE | Valeur ordinale (normalisée sur la MinValue) de la borne basse
Hi : BYTE | Valeur ordinale (normalisée sur la MinValue) de la borne haute
Size : BYTE | Taille en octets du set destination

Sepi
Class Tree
Index
Previous (SetIntersect)
Next (SetSub)


Sepi

Sepi
Previous (SetRange)
Next (SetUnion)

Name
SetSub

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Calcule la soustraction de deux sets

Source code
procedure SetSub ( var Dest ; const Source ; Size : Byte )

Parameters
Parameter | Description
Dest : Untyped | Set destination et opérande de gauche
Source : Untyped | Set opérande de droite
Size : BYTE | Taille en octets des sets

Sepi
Class Tree
Index
Previous (SetRange)
Next (SetUnion)


Sepi

Sepi
Previous (SetSub)
Next

Name
SetUnion

Parent
ScCompilerMagic

Visibility
PUBLIC

Description
Calcule l'union de deux sets

Source code
procedure SetUnion ( var Dest ; const Source ; Size : Byte )

Parameters
Parameter | Description
Dest : Untyped | Set destination et opérande de gauche
Source : Untyped | Set opérande de droite
Size : BYTE | Taille en octets des sets

Sepi
Class Tree
Index
Previous (SetSub)
Next


Sepi

Sepi
Previous (ScCompilerMagic)
Next (ScConsts)

Name
ScConsoleUtils

Parent
Sepi

Description
Utilitaires de gestion d'un programme en console

Author
sjrd

Version
1.0

Types
Type | Description
TCommandLineOptionMultiplicity (+) | Multiplicité d'une option de ligne de commande

Constants
Constant Description

Methods
Method | Description
FindCmdLineOption (+) | Trouve la position d'une option en ligne de commande
FindCmdLineOption (+) | Trouve la position d'une option en ligne de commande

Classes
Class | Description
ECommandLineException (+) | Erreur liée à a la ligne de commande
ECommandLineParsingException (+) | Erreur de parsing de la ligne de commande
TCommandLine (+) | Classe de gestion de la ligne de commande
TCommandLineOption (+) | Option de ligne de commande
TCommandLineSwitch (+) | Commutateur en ligne de commande
TEnumOption (+) | Option de ligne de commande d'un type énuméré
TIntegerOption (+) | Option de ligne de commande entière
TOptionAlias (+) | Alias d'une option en ligne de commande
TStringOption (+) | Option de ligne de commande chaîne

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScCompilerMagic)
Next (ScConsts)


Sepi

Sepi
Previous
Next (ECommandLineParsingException)

Name
ECommandLineException

Parent
ScConsoleUtils

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Erreur liée à a la ligne de commande

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ECommandLineParsingException)


Sepi

Sepi
Previous (ECommandLineException)
Next (TCommandLine)

Name
ECommandLineParsingException

Parent
ScConsoleUtils

Class Hierarchy
ECommandLineException

Visibility
PUBLIC

Description
Erreur de parsing de la ligne de commande

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ECommandLineException)
Next (TCommandLine)


Sepi

Sepi
Previous (ECommandLineParsingException)
Next (TCommandLineOption)

Name
TCommandLine

Parent
ScConsoleUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe de gestion de la ligne de commande

Members
Fields
Field | Description
FCaseSensitive (-) | True si les recherches sont case-sensitive
FCharsTable (-) | Table des versions courtes des options
FNameTable (-) | Table des noms des options
FOptions (-) | Liste des options recensées
FParameters (-) | Paramètres stockés
FSwitchChars (-) | Caractères marquant une option

Methods
Method | Description
AddOption (+) | Recense une nouvelle option
Create (+) | Crée un gestionnaire de ligne de commande
Create (+) | Crée un gestionnaire de ligne de commande
Destroy (+) | [@inheritDoc]
FindOptionByChar (+) | Trouve une option depuis sa version courte
FindOptionByName (+) | Trouve une option depuis sont nom
GetCount (-) | Nombre de paramètres en ligne de commande
GetOptionCount (-) | Nombre d'options recensées
GetOptions (-) | Tableau zero-based des options recensées
GetParameters (-) | Tableau zero-based des paramètres en ligne de commande
IndexOf (+) | Cherche un paramètre
Parse (+) | Analyse la ligne de commande

Properties
Property | Description
CaseSensitive (+) | True si les recherches sont case-sensitive
Count (+) | Nombre de paramètres en ligne de commande
OptionCount (+) | Nombre d'options recensées
Options (+) | Tableau zero-based des options recensées
Parameters (+) | Tableau zero-based des paramètres en ligne de commande
SwitchChars (+) | Caractères marquant une option

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ECommandLineParsingException)
Next (TCommandLineOption)


Sepi

Sepi
Previous
Next (FCharsTable)

Name
FCaseSensitive

Parent
TCommandLine

Visibility
PRIVATE

Description
True si les recherches sont case-sensitive

Source code
FCaseSensitive : Boolean

Sepi
Class Tree
Index
Previous
Next (FCharsTable)


Sepi

Sepi
Previous (FCaseSensitive)
Next (FNameTable)

Name
FCharsTable

Parent
TCommandLine

Visibility
PRIVATE

Description
Table des versions courtes des options

Source code
FCharsTable : array [ Char ] of TCommandLineOption

Sepi
Class Tree
Index
Previous (FCaseSensitive)
Next (FNameTable)


Sepi

Sepi
Previous (FCharsTable)
Next (FOptions)

Name
FNameTable

Parent
TCommandLine

Visibility
PRIVATE

Description
Table des noms des options

Source code
FNameTable : TStrings

Sepi
Class Tree
Index
Previous (FCharsTable)
Next (FOptions)


Sepi

Sepi
Previous (FNameTable)
Next (FParameters)

Name
FOptions

Parent
TCommandLine

Visibility
PRIVATE

Description
Liste des options recensées

Source code
FOptions : TObjectList

Sepi
Class Tree
Index
Previous (FNameTable)
Next (FParameters)


Sepi

Sepi
Previous (FOptions)
Next (FSwitchChars)

Name
FParameters

Parent
TCommandLine

Visibility
PRIVATE

Description
Paramètres stockés

Source code
FParameters : TStrings

Sepi
Class Tree
Index
Previous (FOptions)
Next (FSwitchChars)


Sepi

Sepi
Previous (FParameters)
Next

Name
FSwitchChars

Parent
TCommandLine

Visibility
PRIVATE

Description
Caractères marquant une option

Source code
FSwitchChars : TSysCharSet

Sepi
Class Tree
Index
Previous (FParameters)
Next


Sepi

Sepi
Previous
Next (Count)

Name
CaseSensitive

Parent
TCommandLine

Visibility
PUBLIC

Description
True si les recherches sont case-sensitive

Source code
property CaseSensitive : Boolean read FCaseSensitive

Read Access
FCaseSensitive

Sepi
Class Tree
Index
Previous
Next (Count)


Sepi

Sepi
Previous (CaseSensitive)
Next (OptionCount)

Name
Count

Parent
TCommandLine

Visibility
PUBLIC

Description
Nombre de paramètres en ligne de commande

Source code
property Count : Integer read GetCount

Read Access
GetCount

Sepi
Class Tree
Index
Previous (CaseSensitive)
Next (OptionCount)


Sepi

Sepi
Previous (Count)
Next (Options)

Name
OptionCount

Parent
TCommandLine

Visibility
PUBLIC

Description
Nombre d'options recensées

Source code
property OptionCount : Integer read GetOptionCount

Read Access
GetOptionCount

Sepi
Class Tree
Index
Previous (Count)
Next (Options)


Sepi

Sepi
Previous (OptionCount)
Next (Parameters)

Name
Options

Parent
TCommandLine

Visibility
PUBLIC

Description
Tableau zero-based des options recensées

Source code
property Options [ Index : Integer ] : TCommandLineOption read GetOptions

Read Access
GetOptions

Sepi
Class Tree
Index
Previous (OptionCount)
Next (Parameters)


Sepi

Sepi
Previous (Options)
Next (SwitchChars)

Name
Parameters

Parent
TCommandLine

Visibility
PUBLIC

Description
Tableau zero-based des paramètres en ligne de commande

Source code
property Parameters [ Index : Integer ] : string read GetParameters ; default

Read Access
GetParameters

Sepi
Class Tree
Index
Previous (Options)
Next (SwitchChars)


Sepi

Sepi
Previous (Parameters)
Next

Name
SwitchChars

Parent
TCommandLine

Visibility
PUBLIC

Description
Caractères marquant une option

Source code
property SwitchChars : TSysCharSet read FSwitchChars

Read Access
FSwitchChars

Sepi
Class Tree
Index
Previous (Parameters)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AddOption

Parent
TCommandLine

Visibility
PUBLIC

Description
Recense une nouvelle option

Source code
procedure AddOption ( Option : TCommandLineOption )

Parameters
Parameter | Description
Option : TCommandLineOption | à recenser

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AddOption)
Next (Create)

Name
Create

Parent
TCommandLine

Visibility
PUBLIC

Description
Crée un gestionnaire de ligne de commande

Source code
constructor Create ( const ASwitchChars : TSysCharSet ; ACaseSensitive : Boolean = True ) ; overload

Parameters
Parameter | Description
ASwitchChars : TSysCharSet | Caractères marquant les options
ACaseSensitive : BOOLEAN | True pour effectuer des comparaisons case-sensitive

Sepi
Class Tree
Index
Previous (AddOption)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TCommandLine

Visibility
PUBLIC

Description
Crée un gestionnaire de ligne de commande
Les caractères marquant les options sont définis d'après SysUtils.SwitchChars.

Source code
constructor Create ( ACaseSensitive : Boolean = True ) ; overload

Parameters
Parameter | Description
ACaseSensitive : BOOLEAN | True pour effectuer des comparaisons case-sensitive

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (FindOptionByChar)

Name
Destroy

Parent
TCommandLine

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (FindOptionByChar)


Sepi

Sepi
Previous (Destroy)
Next (FindOptionByName)

Name
FindOptionByChar

Parent
TCommandLine

Visibility
PUBLIC

Description
Trouve une option depuis sa version courte

Source code
function FindOptionByChar ( OptChar : Char ) : TCommandLineOption

Parameters
Parameter Description
OptChar : CHAR

Return
Types | Description
TCommandLineOption | Option correspondante

Sepi
Class Tree
Index
Previous (Destroy)
Next (FindOptionByName)


Sepi

Sepi
Previous (FindOptionByChar)
Next (GetCount)

Name
FindOptionByName

Parent
TCommandLine

Visibility
PUBLIC

Description
Trouve une option depuis sont nom

Source code
function FindOptionByName ( const Name : string ) : TCommandLineOption

Parameters
Parameter | Description
NAME : STRING | Nom de l'option recherchée

Return
Types | Description
TCommandLineOption | Option correspondante

Sepi
Class Tree
Index
Previous (FindOptionByChar)
Next (GetCount)


Sepi

Sepi
Previous (FindOptionByName)
Next (GetOptionCount)

Name
GetCount

Parent
TCommandLine

Visibility
PRIVATE

Description
Nombre de paramètres en ligne de commande

Source code
function GetCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de paramètres en ligne de commande

Sepi
Class Tree
Index
Previous (FindOptionByName)
Next (GetOptionCount)


Sepi

Sepi
Previous (GetCount)
Next (GetOptions)

Name
GetOptionCount

Parent
TCommandLine

Visibility
PRIVATE

Description
Nombre d'options recensées

Source code
function GetOptionCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'options recensées

Sepi
Class Tree
Index
Previous (GetCount)
Next (GetOptions)


Sepi

Sepi
Previous (GetOptionCount)
Next (GetParameters)

Name
GetOptions

Parent
TCommandLine

Visibility
PRIVATE

Description
Tableau zero-based des options recensées

Source code
function GetOptions ( Index : Integer ) : TCommandLineOption

Parameters
Parameter | Description
INDEX : INTEGER | Index d'une option

Return
Types | Description
TCommandLineOption | Option à cet index

Sepi
Class Tree
Index
Previous (GetOptionCount)
Next (GetParameters)


Sepi

Sepi
Previous (GetOptions)
Next (IndexOf)

Name
GetParameters

Parent
TCommandLine

Visibility
PRIVATE

Description
Tableau zero-based des paramètres en ligne de commande

Source code
function GetParameters ( Index : Integer ) : string

Parameters
Parameter | Description
INDEX : INTEGER | Index d'un paramètre (0 pour le premier, pas comme ParamStr)

Return
Types | Description
STRING | Paramètres à cet index

Sepi
Class Tree
Index
Previous (GetOptions)
Next (IndexOf)


Sepi

Sepi
Previous (GetParameters)
Next (Parse)

Name
IndexOf

Parent
TCommandLine

Visibility
PUBLIC

Description
Cherche un paramètre

Source code
function IndexOf ( const Str : string ) : Integer

Parameters
Parameter | Description
Str : STRING | Paramètre recherché

Return
Types | Description
INTEGER | Position de ce paramètre, ou -1 si non trouvé

Sepi
Class Tree
Index
Previous (GetParameters)
Next (Parse)


Sepi

Sepi
Previous (IndexOf)
Next

Name
Parse

Parent
TCommandLine

Visibility
PUBLIC

Description
Analyse la ligne de commande

Source code
procedure Parse ( UnparsedParams : TStrings = nil )

Parameters
Parameter | Description
UnparsedParams : TStrings | List dans laquelle stocker les paramètres non analysés

Sepi
Class Tree
Index
Previous (IndexOf)
Next


Sepi

Sepi
Previous (TCommandLine)
Next (TCommandLineSwitch)

Name
TCommandLineOption

Parent
ScConsoleUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Option de ligne de commande

Members
Fields
Field | Description
FChars (-) | Caractères acceptés en option courte (-c)
FHasDefaultValue (-) | Indique si l'option a une valeur par défaut
FMultiplicity (-) | Multiplicité
FName (-) | Nom canonique de l'option (--name)
FPresent (-) | Indique si l'option est présente
FPresentVar (-) | Pointeur sur le booléen où indiquer si présente
FRequired (-) | Indique l'option comme requise
FRightMostArgument (-) | Argument sauvegardé pour omRightMost
FVariable (-) | Pointeur sur la variable où stocker le résultat

Methods
Method | Description
Create (+) | Crée l'option de ligne de commande
Finit (+) | Finalise l'option à la fin de l'analyse
GetNeedArgument (#) | Indique si l'option requiert un argument
Init (+) | Initialise l'option au démarrage de l'analyse
InternalParse (#) | Analyse interne
Parse (+) | Analye l'argument de l'option
UseDefaultValue (#) | Utilise la valeur par défaut

Properties
Property | Description
Chars (+) | Caractères acceptés en option courte (-c)
HasDefaultValue (+) | Indique si l'option a une valeur par défaut
Multiplicity (+) | Multiplicité
NAME (+) | Nom canonique de l'option (--name)
NeedArgument (+) | Indique si l'option requiert un argument
Present (+) | Indique si l'option est présente
Required (+) | Indique l'option comme requise
Variable (#) | Pointeur sur la variable où stocker le résultat

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCommandLine)
Next (TCommandLineSwitch)


Sepi

Sepi
Previous
Next (FHasDefaultValue)

Name
FChars

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Caractères acceptés en option courte (-c)

Source code
FChars : TSysCharSet

Sepi
Class Tree
Index
Previous
Next (FHasDefaultValue)


Sepi

Sepi
Previous (FChars)
Next (FMultiplicity)

Name
FHasDefaultValue

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Indique si l'option a une valeur par défaut

Source code
FHasDefaultValue : Boolean

Sepi
Class Tree
Index
Previous (FChars)
Next (FMultiplicity)


Sepi

Sepi
Previous (FHasDefaultValue)
Next (FName)

Name
FMultiplicity

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Multiplicité

Source code
FMultiplicity : TCommandLineOptionMultiplicity

Sepi
Class Tree
Index
Previous (FHasDefaultValue)
Next (FName)


Sepi

Sepi
Previous (FMultiplicity)
Next (FPresent)

Name
FName

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Nom canonique de l'option (--name)

Source code
FName : string

Sepi
Class Tree
Index
Previous (FMultiplicity)
Next (FPresent)


Sepi

Sepi
Previous (FName)
Next (FPresentVar)

Name
FPresent

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Indique si l'option est présente

Source code
FPresent : Boolean

Sepi
Class Tree
Index
Previous (FName)
Next (FPresentVar)


Sepi

Sepi
Previous (FPresent)
Next (FRequired)

Name
FPresentVar

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Pointeur sur le booléen où indiquer si présente

Source code
FPresentVar : PBoolean

Sepi
Class Tree
Index
Previous (FPresent)
Next (FRequired)


Sepi

Sepi
Previous (FPresentVar)
Next (FRightMostArgument)

Name
FRequired

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Indique l'option comme requise

Source code
FRequired : Boolean

Sepi
Class Tree
Index
Previous (FPresentVar)
Next (FRightMostArgument)


Sepi

Sepi
Previous (FRequired)
Next (FVariable)

Name
FRightMostArgument

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Argument sauvegardé pour omRightMost

Source code
FRightMostArgument : string

Sepi
Class Tree
Index
Previous (FRequired)
Next (FVariable)


Sepi

Sepi
Previous (FRightMostArgument)
Next

Name
FVariable

Parent
TCommandLineOption

Visibility
PRIVATE

Description
Pointeur sur la variable où stocker le résultat

Source code
FVariable : Pointer

Sepi
Class Tree
Index
Previous (FRightMostArgument)
Next


Sepi

Sepi
Previous
Next (HasDefaultValue)

Name
Chars

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Caractères acceptés en option courte (-c)

Source code
property Chars : TSysCharSet read FChars

Read Access
FChars

Sepi
Class Tree
Index
Previous
Next (HasDefaultValue)


Sepi

Sepi
Previous (Chars)
Next (Multiplicity)

Name
HasDefaultValue

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Indique si l'option a une valeur par défaut

Source code
property HasDefaultValue : Boolean read FHasDefaultValue

Read Access
FHasDefaultValue

Sepi
Class Tree
Index
Previous (Chars)
Next (Multiplicity)


Sepi

Sepi
Previous (HasDefaultValue)
Next (NAME)

Name
Multiplicity

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Multiplicité

Source code
property Multiplicity : TCommandLineOptionMultiplicity read FMultiplicity

Read Access
FMultiplicity

Sepi
Class Tree
Index
Previous (HasDefaultValue)
Next (NAME)


Sepi

Sepi
Previous (Multiplicity)
Next (NeedArgument)

Name
NAME

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Nom canonique de l'option (--name)

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (Multiplicity)
Next (NeedArgument)


Sepi

Sepi
Previous (NAME)
Next (Present)

Name
NeedArgument

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Indique si l'option requiert un argument

Source code
property NeedArgument : Boolean read GetNeedArgument

Read Access
GetNeedArgument

Sepi
Class Tree
Index
Previous (NAME)
Next (Present)


Sepi

Sepi
Previous (NeedArgument)
Next (Required)

Name
Present

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Indique si l'option est présente

Source code
property Present : Boolean read FPresent

Read Access
FPresent

Sepi
Class Tree
Index
Previous (NeedArgument)
Next (Required)


Sepi

Sepi
Previous (Present)
Next (Variable)

Name
Required

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Indique l'option comme requise

Source code
property Required : Boolean read FRequired

Read Access
FRequired

Sepi
Class Tree
Index
Previous (Present)
Next (Variable)


Sepi

Sepi
Previous (Required)
Next

Name
Variable

Parent
TCommandLineOption

Visibility
PROTECTED

Description
Pointeur sur la variable où stocker le résultat

Source code
property Variable : Pointer read FVariable

Read Access
FVariable

Sepi
Class Tree
Index
Previous (Required)
Next


Sepi

Sepi
Previous
Next (Finit)

Name
Create

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Crée l'option de ligne de commande

Source code
constructor Create ( const AName : string ; const AChars : TSysCharSet ; AVariable : Pointer ; AMultiplicity : TCommandLineOptionMultiplicity ; ARequired : Boolean = True ; APresentVar : PBoolean = nil ; AHasDefaultValue : Boolean = False )

Parameters
Parameter | Description
AName : STRING | Nom canonique de l'option
AChars : TSysCharSet
AVariable : Pointer | Variable où stocker le résultat
AMultiplicity : TCommandLineOptionMultiplicity
ARequired : BOOLEAN | Indique si l'option est requise
APresentVar : PBoolean | Variable où stocker la présence de l'option
AHasDefaultValue : BOOLEAN

Sepi
Class Tree
Index
Previous
Next (Finit)


Sepi

Sepi
Previous (Create)
Next (GetNeedArgument)

Name
Finit

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Finalise l'option à la fin de l'analyse

Source code
procedure Finit ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetNeedArgument)


Sepi

Sepi
Previous (Finit)
Next (Init)

Name
GetNeedArgument

Parent
TCommandLineOption

Visibility
PROTECTED

Description
Indique si l'option requiert un argument

Source code
function GetNeedArgument : Boolean ; virtual

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si l'option requiert un argument, False si elle n'en prend pas

Sepi
Class Tree
Index
Previous (Finit)
Next (Init)


Sepi

Sepi
Previous (GetNeedArgument)
Next (InternalParse)

Name
Init

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Initialise l'option au démarrage de l'analyse

Source code
procedure Init ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetNeedArgument)
Next (InternalParse)


Sepi

Sepi
Previous (Init)
Next (Parse)

Name
InternalParse

Parent
TCommandLineOption

Visibility
PROTECTED

Description
Analyse interne
Cette méthode est appelée par Parse après avoir vérifié la multiplicité
et modifié l'état de présence. Pour omRightMost, c'est Finit qui
appellera cette méthode.

Source code
procedure InternalParse ( const Argument : string ) ; virtual ; abstract

Parameters
Parameter | Description
Argument : STRING | Argument (ou chaîne vide si ne prend pas d'argument)

Sepi
Class Tree
Index
Previous (Init)
Next (Parse)


Sepi

Sepi
Previous (InternalParse)
Next (UseDefaultValue)

Name
Parse

Parent
TCommandLineOption

Visibility
PUBLIC

Description
Analye l'argument de l'option

Source code
procedure Parse ( const Argument : string ) ; virtual

Parameters
Parameter | Description
Argument : STRING | Argument de l'option (chaîne vide si pas d'argument)

Sepi
Class Tree
Index
Previous (InternalParse)
Next (UseDefaultValue)


Sepi

Sepi
Previous (Parse)
Next

Name
UseDefaultValue

Parent
TCommandLineOption

Visibility
PROTECTED

Description
Utilise la valeur par défaut
L'implémentation par défaut dans TCommandLineOption ne fait rien, ce qui
suffit pour toutes les options qui utilisent comme valeur par défaut la
valeur déjà présente dans Variable^.

Source code
procedure UseDefaultValue ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Parse)
Next


Sepi

Sepi
Previous (TCommandLineOption)
Next (TEnumOption)

Name
TCommandLineSwitch

Parent
ScConsoleUtils

Class Hierarchy
TCommandLineOption

Visibility
PUBLIC

Description
Commutateur en ligne de commande

Members
Methods
Method | Description
Create (+) | Crée le switch
GetNeedArgument (#) | [@inheritDoc]
InternalParse (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCommandLineOption)
Next (TEnumOption)


Sepi

Sepi
Previous
Next (GetNeedArgument)

Name
Create

Parent
TCommandLineSwitch

Visibility
PUBLIC

Description
Crée le switch

Source code
constructor Create ( const AName : string ; const AChars : TSysCharSet ; AVariable : PBoolean )

Parameters
Parameter | Description
AName : STRING | Nom canonique du switch
AChars : TSysCharSet | Caractères de la version courte du switch
AVariable : PBoolean | Pointeur sur la variable booléenne où stocker le résultat

Sepi
Class Tree
Index
Previous
Next (GetNeedArgument)


Sepi

Sepi
Previous (Create)
Next (InternalParse)

Name
GetNeedArgument

Parent
TCommandLineSwitch

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetNeedArgument : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (InternalParse)


Sepi

Sepi
Previous (GetNeedArgument)
Next

Name
InternalParse

Parent
TCommandLineSwitch

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InternalParse ( const Argument : string ) ; override

Parameters
Parameter | Description
Argument : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNeedArgument)
Next


Sepi

Sepi
Previous (TCommandLineSwitch)
Next (TIntegerOption)

Name
TEnumOption

Parent
ScConsoleUtils

Class Hierarchy
TCommandLineOption

Visibility
PUBLIC

Description
Option de ligne de commande d'un type énuméré

Members
Fields
Field | Description
FEnumTypeInfo (-) | RTTI du type énuméré
FPrefix (-) | Préfixe à appliquer devant l'argument

Methods
Method | Description
Create (+) | Crée l'option
InternalParse (#) | [@inheritDoc]

Properties
Property | Description
EnumTypeInfo (+) | RTTI du type énuméré
Prefix (+) | Préfixe à appliquer devant l'argument

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCommandLineSwitch)
Next (TIntegerOption)


Sepi

Sepi
Previous
Next (FPrefix)

Name
FEnumTypeInfo

Parent
TEnumOption

Visibility
PRIVATE

Description
RTTI du type énuméré

Source code
FEnumTypeInfo : PTypeInfo

Sepi
Class Tree
Index
Previous
Next (FPrefix)


Sepi

Sepi
Previous (FEnumTypeInfo)
Next

Name
FPrefix

Parent
TEnumOption

Visibility
PRIVATE

Description
Préfixe à appliquer devant l'argument

Source code
FPrefix : string

Sepi
Class Tree
Index
Previous (FEnumTypeInfo)
Next


Sepi

Sepi
Previous
Next (Prefix)

Name
EnumTypeInfo

Parent
TEnumOption

Visibility
PUBLIC

Description
RTTI du type énuméré

Source code
property EnumTypeInfo : PTypeInfo read FEnumTypeInfo

Read Access
FEnumTypeInfo

Sepi
Class Tree
Index
Previous
Next (Prefix)


Sepi

Sepi
Previous (EnumTypeInfo)
Next

Name
Prefix

Parent
TEnumOption

Visibility
PUBLIC

Description
Préfixe à appliquer devant l'argument

Source code
property Prefix : string read FPrefix

Read Access
FPrefix

Sepi
Class Tree
Index
Previous (EnumTypeInfo)
Next


Sepi

Sepi
Previous
Next (InternalParse)

Name
Create

Parent
TEnumOption

Visibility
PUBLIC

Description
Crée l'option

Source code
constructor Create ( const AName : string ; const AChars : TSysCharSet ; AVariable : Pointer ; AEnumTypeInfo : PTypeInfo ; const APrefix : string = '' ; ARequired : Boolean = True ; APresentVar : PBoolean = nil ; AHasDefaultValue : Boolean = False ) ; overload

Parameters
Parameter | Description
AName : STRING | Nom canonique
AChars : TSysCharSet | Caractères de la version courte
AVariable : Pointer | Pointeur sur la variable enum où stocker le résultat
AEnumTypeInfo : PTypeInfo | RTTI du type énuméré
APrefix : STRING | Préfixe à appliquer devant l'argument
ARequired : BOOLEAN | Indique si l'option est requise
APresentVar : PBoolean | Pointeur sur une variable booléenne de présence
AHasDefaultValue : BOOLEAN | Indique si cette option a une valeur par défaut

Sepi
Class Tree
Index
Previous
Next (InternalParse)


Sepi

Sepi
Previous (Create)
Next

Name
InternalParse

Parent
TEnumOption

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InternalParse ( const Argument : string ) ; override

Parameters
Parameter | Description
Argument : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TEnumOption)
Next (TOptionAlias)

Name
TIntegerOption

Parent
ScConsoleUtils

Class Hierarchy
TCommandLineOption

Visibility
PUBLIC

Description
Option de ligne de commande entière

Members
Fields
Field | Description
FMaxValue (-) | Valeur maximale acceptée
FMinValue (-) | Valeur minimale acceptée
FOrdType (-) | Type d'ordinal de l'entier stocké

Methods
Method | Description
Create (+) | Crée l'option avec le type Integer
Create (+) | Crée l'option
CreateInt64 (+) | Crée l'option avec le type Int64
CreateTypeInfo (+) | Crée l'option avec un type défini par ses RTTI
InternalParse (#) | [@inheritDoc]
ParseValue (#) | Analyse l'argument sous forme d'entier
StoreValue (#) | Stocke la valeur
ValidateValue (#) | Valide une valeur

Properties
Property | Description
MaxValue (+) | Valeur maximale acceptée
MinValue (+) | Valeur minimale acceptée
OrdType (+) | Type d'ordinal de l'entier stocké

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TEnumOption)
Next (TOptionAlias)


Sepi

Sepi
Previous
Next (FMinValue)

Name
FMaxValue

Parent
TIntegerOption

Visibility
PRIVATE

Description
Valeur maximale acceptée

Source code
FMaxValue : Int64

Sepi
Class Tree
Index
Previous
Next (FMinValue)


Sepi

Sepi
Previous (FMaxValue)
Next (FOrdType)

Name
FMinValue

Parent
TIntegerOption

Visibility
PRIVATE

Description
Valeur minimale acceptée

Source code
FMinValue : Int64

Sepi
Class Tree
Index
Previous (FMaxValue)
Next (FOrdType)


Sepi

Sepi
Previous (FMinValue)
Next

Name
FOrdType

Parent
TIntegerOption

Visibility
PRIVATE

Description
Type d'ordinal de l'entier stocké

Source code
FOrdType : TOrdType

Sepi
Class Tree
Index
Previous (FMinValue)
Next


Sepi

Sepi
Previous
Next (MinValue)

Name
MaxValue

Parent
TIntegerOption

Visibility
PUBLIC

Description
Valeur maximale acceptée

Source code
property MaxValue : Int64 read FMaxValue

Read Access
FMaxValue

Sepi
Class Tree
Index
Previous
Next (MinValue)


Sepi

Sepi
Previous (MaxValue)
Next (OrdType)

Name
MinValue

Parent
TIntegerOption

Visibility
PUBLIC

Description
Valeur minimale acceptée

Source code
property MinValue : Int64 read FMinValue

Read Access
FMinValue

Sepi
Class Tree
Index
Previous (MaxValue)
Next (OrdType)


Sepi

Sepi
Previous (MinValue)
Next

Name
OrdType

Parent
TIntegerOption

Visibility
PUBLIC

Description
Type d'ordinal de l'entier stocké

Source code
property OrdType : TOrdType read FOrdType

Read Access
FOrdType

Sepi
Class Tree
Index
Previous (MinValue)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TIntegerOption

Visibility
PUBLIC

Description
Crée l'option avec le type Integer

Source code
constructor Create ( const AName : string ; const AChars : TSysCharSet ; AVariable : Pointer ; AMinValue , AMaxValue : Int64 ; ARequired : Boolean = True ; APresentVar : PBoolean = nil ; AHasDefaultValue : Boolean = False ) ; overload

Parameters
Parameter | Description
AName : STRING | Nom canonique
AChars : TSysCharSet | Caractères de la version courte
AVariable : Pointer | Pointeur sur la variable entière où stocker le résultat
AMinValue : INT64 | Valeur minimale acceptée
AMaxValue : INT64 | Valeur maximale acceptée
ARequired : BOOLEAN | Indique si l'option est requise
APresentVar : PBoolean | Pointeur sur une variable booléenne de présence
AHasDefaultValue : BOOLEAN | Indique si cette option a une valeur par défaut

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (CreateInt64)

Name
Create

Parent
TIntegerOption

Visibility
PUBLIC

Description
Crée l'option

Source code
constructor Create ( const AName : string ; const AChars : TSysCharSet ; AVariable : Pointer ; AOrdType : TOrdType ; AMinValue , AMaxValue : Int64 ; ARequired : Boolean = True ; APresentVar : PBoolean = nil ; AHasDefaultValue : Boolean = False ) ; overload

Parameters
Parameter | Description
AName : STRING | Nom canonique
AChars : TSysCharSet | Caractères de la version courte
AVariable : Pointer | Pointeur sur la variable entière où stocker le résultat
AOrdType : TOrdType | Type de la variable entière
AMinValue : INT64 | Valeur minimale acceptée
AMaxValue : INT64 | Valeur maximale acceptée
ARequired : BOOLEAN | Indique si l'option est requise
APresentVar : PBoolean | Pointeur sur une variable booléenne de présence
AHasDefaultValue : BOOLEAN | Indique si cette option a une valeur par défaut

Sepi
Class Tree
Index
Previous (Create)
Next (CreateInt64)


Sepi

Sepi
Previous (Create)
Next (CreateTypeInfo)

Name
CreateInt64

Parent
TIntegerOption

Visibility
PUBLIC

Description
Crée l'option avec le type Int64

Source code
constructor CreateInt64 ( const AName : string ; const AChars : TSysCharSet ; AVariable : Pointer ; AMinValue , AMaxValue : Int64 ; ARequired : Boolean = True ; APresentVar : PBoolean = nil ; AHasDefaultValue : Boolean = False )

Parameters
Parameter | Description
AName : STRING | Nom canonique
AChars : TSysCharSet | Caractères de la version courte
AVariable : Pointer | Pointeur sur la variable entière où stocker le résultat
AMinValue : INT64 | Valeur minimale acceptée
AMaxValue : INT64 | Valeur maximale acceptée
ARequired : BOOLEAN | Indique si l'option est requise
APresentVar : PBoolean | Pointeur sur une variable booléenne de présence
AHasDefaultValue : BOOLEAN | Indique si cette option a une valeur par défaut

Sepi
Class Tree
Index
Previous (Create)
Next (CreateTypeInfo)


Sepi

Sepi
Previous (CreateInt64)
Next (InternalParse)

Name
CreateTypeInfo

Parent
TIntegerOption

Visibility
PUBLIC

Description
Crée l'option avec un type défini par ses RTTI

Source code
constructor CreateTypeInfo ( const AName : string ; const AChars : TSysCharSet ; AVariable : Pointer ; ATypeInfo : PTypeInfo ; ARequired : Boolean = True ; APresentVar : PBoolean = nil ; AHasDefaultValue : Boolean = False )

Parameters
Parameter | Description
AName : STRING | Nom canonique
AChars : TSysCharSet | Caractères de la version courte
AVariable : Pointer | Pointeur sur la variable entière où stocker le résultat
ATypeInfo : PTypeInfo | RTTI du type de l'option
ARequired : BOOLEAN | Indique si l'option est requise
APresentVar : PBoolean | Pointeur sur une variable booléenne de présence
AHasDefaultValue : BOOLEAN | Indique si cette option a une valeur par défaut

Sepi
Class Tree
Index
Previous (CreateInt64)
Next (InternalParse)


Sepi

Sepi
Previous (CreateTypeInfo)
Next (ParseValue)

Name
InternalParse

Parent
TIntegerOption

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InternalParse ( const Argument : string ) ; override

Parameters
Parameter | Description
Argument : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateTypeInfo)
Next (ParseValue)


Sepi

Sepi
Previous (InternalParse)
Next (StoreValue)

Name
ParseValue

Parent
TIntegerOption

Visibility
PROTECTED

Description
Analyse l'argument sous forme d'entier

Source code
function ParseValue ( const Argument : string ) : Int64 ; virtual

Parameters
Parameter | Description
Argument : STRING | Argument à analyser

Return
Types | Description
INT64 | Valeur entière correspondante

Sepi
Class Tree
Index
Previous (InternalParse)
Next (StoreValue)


Sepi

Sepi
Previous (ParseValue)
Next (ValidateValue)

Name
StoreValue

Parent
TIntegerOption

Visibility
PROTECTED

Description
Stocke la valeur

Source code
procedure StoreValue ( Value : Int64 ) ; virtual

Parameters
Parameter | Description
Value : INT64 | Valeur à stocker

Sepi
Class Tree
Index
Previous (ParseValue)
Next (ValidateValue)


Sepi

Sepi
Previous (StoreValue)
Next

Name
ValidateValue

Parent
TIntegerOption

Visibility
PROTECTED

Description
Valide une valeur

Source code
procedure ValidateValue ( Value : Int64 ) ; virtual

Parameters
Parameter | Description
Value : INT64 | Valeur à valider

Sepi
Class Tree
Index
Previous (StoreValue)
Next


Sepi

Sepi
Previous (TIntegerOption)
Next (TStringOption)

Name
TOptionAlias

Parent
ScConsoleUtils

Class Hierarchy
TCommandLineOption

Visibility
PUBLIC

Description
Alias d'une option en ligne de commande

Members
Fields
Field | Description
FArgument (-) | Argument pour l'option
FOption (-) | Option dont c'est un alias

Methods
Method | Description
Create (+) | Crée un alias d'une option
GetNeedArgument (#) | [@inheritDoc]
InternalParse (#) | [@inheritDoc]

Properties
Property | Description
Argument (+) | Argument pour l'option
Option (+) | Option dont c'est un alias

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TIntegerOption)
Next (TStringOption)


Sepi

Sepi
Previous
Next (FOption)

Name
FArgument

Parent
TOptionAlias

Visibility
PRIVATE

Description
Argument pour l'option

Source code
FArgument : string

Sepi
Class Tree
Index
Previous
Next (FOption)


Sepi

Sepi
Previous (FArgument)
Next

Name
FOption

Parent
TOptionAlias

Visibility
PRIVATE

Description
Option dont c'est un alias

Source code
FOption : TCommandLineOption

Sepi
Class Tree
Index
Previous (FArgument)
Next


Sepi

Sepi
Previous
Next (Option)

Name
Argument

Parent
TOptionAlias

Visibility
PUBLIC

Description
Argument pour l'option

Source code
property Argument : string read FArgument

Read Access
FArgument

Sepi
Class Tree
Index
Previous
Next (Option)


Sepi

Sepi
Previous (Argument)
Next

Name
Option

Parent
TOptionAlias

Visibility
PUBLIC

Description
Option dont c'est un alias

Source code
property Option : TCommandLineOption read FOption

Read Access
FOption

Sepi
Class Tree
Index
Previous (Argument)
Next


Sepi

Sepi
Previous
Next (GetNeedArgument)

Name
Create

Parent
TOptionAlias

Visibility
PUBLIC

Description
Crée un alias d'une option

Source code
constructor Create ( const AName : string ; const AChars : TSysCharSet ; AOption : TCommandLineOption ; const AArgument : string = '' )

Parameters
Parameter | Description
AName : STRING | Nom de l'alias
AChars : TSysCharSet | Caractères de version courte de l'alias
AOption : TCommandLineOption | Option dont c'est un alias
AArgument : STRING | Argument à transmettre à l'option

Sepi
Class Tree
Index
Previous
Next (GetNeedArgument)


Sepi

Sepi
Previous (Create)
Next (InternalParse)

Name
GetNeedArgument

Parent
TOptionAlias

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetNeedArgument : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (InternalParse)


Sepi

Sepi
Previous (GetNeedArgument)
Next

Name
InternalParse

Parent
TOptionAlias

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InternalParse ( const Argument : string ) ; override

Parameters
Parameter | Description
Argument : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNeedArgument)
Next


Sepi

Sepi
Previous (TOptionAlias)
Next

Name
TStringOption

Parent
ScConsoleUtils

Class Hierarchy
TCommandLineOption

Visibility
PUBLIC

Description
Option de ligne de commande chaîne

Members
Methods
Method | Description
Create (+) | Crée l'option
InternalParse (#) | [@inheritDoc]
ParseValue (#) | Analyse l'argument sous forme de chaîne de caractère
StoreValue (#) | Stocke la valeur
ValidateValue (#) | Valide une valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TOptionAlias)
Next


Sepi

Sepi
Previous
Next (InternalParse)

Name
Create

Parent
TStringOption

Visibility
PUBLIC

Description
Crée l'option

Source code
constructor Create ( const AName : string ; const AChars : TSysCharSet ; AVariable : PString ; ARequired : Boolean = True ; APresentVar : PBoolean = nil ; AHasDefaultValue : Boolean = False ) ; overload

Parameters
Parameter | Description
AName : STRING | Nom canonique
AChars : TSysCharSet | Caractères de la version courte
AVariable : PString | Pointeur sur la variable entière où stocker le résultat
ARequired : BOOLEAN | Indique si l'option est requise
APresentVar : PBoolean | Pointeur sur une variable booléenne de présence
AHasDefaultValue : BOOLEAN | Indique si cette option a une valeur par défaut

Sepi
Class Tree
Index
Previous
Next (InternalParse)


Sepi

Sepi
Previous (Create)
Next (ParseValue)

Name
InternalParse

Parent
TStringOption

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InternalParse ( const Argument : string ) ; override

Parameters
Parameter | Description
Argument : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (ParseValue)


Sepi

Sepi
Previous (InternalParse)
Next (StoreValue)

Name
ParseValue

Parent
TStringOption

Visibility
PROTECTED

Description
Analyse l'argument sous forme de chaîne de caractère

Source code
function ParseValue ( const Argument : string ) : string ; virtual

Parameters
Parameter | Description
Argument : STRING | Argument à analyser

Return
Types | Description
STRING | Valeur chaîne correspondante

Sepi
Class Tree
Index
Previous (InternalParse)
Next (StoreValue)


Sepi

Sepi
Previous (ParseValue)
Next (ValidateValue)

Name
StoreValue

Parent
TStringOption

Visibility
PROTECTED

Description
Stocke la valeur

Source code
procedure StoreValue ( const Value : string ) ; virtual

Parameters
Parameter | Description
Value : STRING | Valeur à stocker

Sepi
Class Tree
Index
Previous (ParseValue)
Next (ValidateValue)


Sepi

Sepi
Previous (StoreValue)
Next

Name
ValidateValue

Parent
TStringOption

Visibility
PROTECTED

Description
Valide une valeur

Source code
procedure ValidateValue ( const Value : string ) ; virtual

Parameters
Parameter | Description
Value : STRING | Valeur à valider

Sepi
Class Tree
Index
Previous (StoreValue)
Next


Sepi

Sepi
Previous
Next

Name
TCommandLineOptionMultiplicity

Parent
ScConsoleUtils

Visibility
PUBLIC

Description
Multiplicité d'une option de ligne de commande
- omSingle : L'option ne peut pas être présente plus d'une fois ;
- omMultiple : L'option peut être présente plusieurs fois ;
- omLeftMost : Conserve uniquement la première occurrence ;
- omRightMost : Conserve uniquement la dernière occurrence.

Source code
TCommandLineOptionMultiplicity = ( omSingle , omMultiple , omLeftMost , omRightMost ) ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FindCmdLineOption)

Name
FindCmdLineOption

Parent
ScConsoleUtils

Visibility
PUBLIC

Description
Trouve la position d'une option en ligne de commande

Source code
function FindCmdLineOption ( const Option : string ; IgnoreCase : Boolean = True ) : Integer ; overload

Parameters
Parameter | Description
Option : STRING | Option recherchée
IgnoreCase : BOOLEAN | Ignorer la casse (défaut = True)

Return
Types | Description
INTEGER | Position de l'option, ou 0 si non trouvée

Sepi
Class Tree
Index
Previous
Next (FindCmdLineOption)


Sepi

Sepi
Previous (FindCmdLineOption)
Next

Name
FindCmdLineOption

Parent
ScConsoleUtils

Visibility
PUBLIC

Description
Trouve la position d'une option en ligne de commande

Source code
function FindCmdLineOption ( const Option : string ; const Chars : TSysCharSet ; IgnoreCase : Boolean = True ) : Integer ; overload

Parameters
Parameter | Description
Option : STRING | Option recherchée
Chars : TSysCharSet | Caractères identifiant une option
IgnoreCase : BOOLEAN | Ignorer la casse (défaut = True)

Return
Types | Description
INTEGER | Position de l'option, ou 0 si non trouvée

Sepi
Class Tree
Index
Previous (FindCmdLineOption)
Next


Sepi

Sepi
Previous (ScConsoleUtils)
Next (ScCoroutines)

Name
ScConsts

Parent
Sepi

Description
Définit les différentes constantes de la SCL

Author
sjrd

Version
1.0

Constants
Constant | Description
SAlreadyHasController (+) | #No TAG found in source code#
sApril (+) | #No TAG found in source code#
SArgumentForbidden (+) | #No TAG found in source code#
SArgumentRequired (+) | #No TAG found in source code#
sAugust (+) | #No TAG found in source code#
SCantLoadXMLDocument (+) | #No TAG found in source code#
sDecember (+) | #No TAG found in source code#
SDuplicateLongOption (+) | #No TAG found in source code#
SDuplicateShortOption (+) | #No TAG found in source code#
sFebruary (+) | #No TAG found in source code#
SHasNoController (+) | #No TAG found in source code#
SInvalidTypeInfo (+) | #No TAG found in source code#
SInvalidValue (+) | #No TAG found in source code#
sJanuary (+) | #No TAG found in source code#
sJuly (+) | #No TAG found in source code#
sJune (+) | #No TAG found in source code#
sMarch (+) | #No TAG found in source code#
sMay (+) | #No TAG found in source code#
SNonOptionParamForbidden (+) | #No TAG found in source code#
sNovember (+) | #No TAG found in source code#
sOctober (+) | #No TAG found in source code#
SOptionValueOutOfRange (+) | #No TAG found in source code#
SRequiredOptionNotFound (+) | #No TAG found in source code#
sScAbout (+) | #No TAG found in source code#
sScAuthor (+) | #No TAG found in source code#
sScColon (+) | #No TAG found in source code#
sScDelimMustDifferentThanNotIn (+) | #No TAG found in source code#
sScErrorBrackets (+) | #No TAG found in source code#
sScErrorDegree (+) | #No TAG found in source code#
sScErrorDivByZero (+) | #No TAG found in source code#
sScErrorDivision (+) | #No TAG found in source code#
sScErrorEval (+) | #No TAG found in source code#
sScErrorInteger (+) | #No TAG found in source code#
sScErrorMaths (+) | #No TAG found in source code#
sScErrorNatural (+) | #No TAG found in source code#
sScErrorNotDegreeZero (+) | #No TAG found in source code#
sScErrorNotInteger (+) | #No TAG found in source code#
sScErrorNotNatural (+) | #No TAG found in source code#
sScErrorOperation (+) | #No TAG found in source code#
sScErrorOpIsNotBinary (+) | #No TAG found in source code#
sScErrorOpIsNotUnary (+) | #No TAG found in source code#
sScErrorOpNotExists (+) | #No TAG found in source code#
sScErrorOpRequestsCorrectIndex (+) | #No TAG found in source code#
sScErrorOpRequestsDegreeZero (+) | #No TAG found in source code#
sScErrorOpRequestsInteger (+) | #No TAG found in source code#
sScErrorOpRequestsNatural (+) | #No TAG found in source code#
sScErrorRoot (+) | #No TAG found in source code#
sScErrorTooManyBrackets (+) | #No TAG found in source code#
sScErrorWrongCharacter (+) | #No TAG found in source code#
sScErrorWrongExpression (+) | #No TAG found in source code#
sScIndexOutOfRange (+) | #No TAG found in source code#
sScLanguage (+) | #No TAG found in source code#
sScListIsNotEmpty (+) | #No TAG found in source code#
sScNo (+) | #No TAG found in source code#
sScNotInMustPairsOfChars (+) | #No TAG found in source code#
sScSemiColon (+) | #No TAG found in source code#
sScSetOf (+) | #No TAG found in source code#
sScVersion (+) | #No TAG found in source code#
sScWrongBase (+) | #No TAG found in source code#
sScWrongChar (+) | #No TAG found in source code#
sScWrongCharSet (+) | #No TAG found in source code#
sScWrongEnumSet (+) | #No TAG found in source code#
sScWrongFloat (+) | #No TAG found in source code#
sScWrongInteger (+) | #No TAG found in source code#
sScWrongIntSize (+) | #No TAG found in source code#
sScWrongLongWord (+) | #No TAG found in source code#
sScWrongPassword (+) | #No TAG found in source code#
sScWrongString (+) | #No TAG found in source code#
sScYes (+) | #No TAG found in source code#
sSeptember (+) | #No TAG found in source code#
SSingleOptionFoundMultipleTimes (+) | #No TAG found in source code#
sSjrdErrorAbortDivision (+) | #No TAG found in source code#
SUnknownLongOption (+) | #No TAG found in source code#
SUnknownShortOption (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScConsoleUtils)
Next (ScCoroutines)


Sepi

Sepi
Previous
Next (sApril)

Name
SAlreadyHasController

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SAlreadyHasController = 'Cet objet a déjà un contrôleur'

Sepi
Class Tree
Index
Previous
Next (sApril)


Sepi

Sepi
Previous (SAlreadyHasController)
Next (SArgumentForbidden)

Name
sApril

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sApril = 'avril'

Sepi
Class Tree
Index
Previous (SAlreadyHasController)
Next (SArgumentForbidden)


Sepi

Sepi
Previous (sApril)
Next (SArgumentRequired)

Name
SArgumentForbidden

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SArgumentForbidden = 'L''option %s ne prend pas de paramètre'

Sepi
Class Tree
Index
Previous (sApril)
Next (SArgumentRequired)


Sepi

Sepi
Previous (SArgumentForbidden)
Next (sAugust)

Name
SArgumentRequired

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SArgumentRequired = 'L''option %s requiert un paramètre'

Sepi
Class Tree
Index
Previous (SArgumentForbidden)
Next (sAugust)


Sepi

Sepi
Previous (SArgumentRequired)
Next (SCantLoadXMLDocument)

Name
sAugust

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sAugust = 'août'

Sepi
Class Tree
Index
Previous (SArgumentRequired)
Next (SCantLoadXMLDocument)


Sepi

Sepi
Previous (sAugust)
Next (sDecember)

Name
SCantLoadXMLDocument

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantLoadXMLDocument = 'Erreur lors du chargement du document XML'

Sepi
Class Tree
Index
Previous (sAugust)
Next (sDecember)


Sepi

Sepi
Previous (SCantLoadXMLDocument)
Next (SDuplicateLongOption)

Name
sDecember

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sDecember = 'décembre'

Sepi
Class Tree
Index
Previous (SCantLoadXMLDocument)
Next (SDuplicateLongOption)


Sepi

Sepi
Previous (sDecember)
Next (SDuplicateShortOption)

Name
SDuplicateLongOption

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDuplicateLongOption = 'Nom d''option %s dupliqué'

Sepi
Class Tree
Index
Previous (sDecember)
Next (SDuplicateShortOption)


Sepi

Sepi
Previous (SDuplicateLongOption)
Next (sFebruary)

Name
SDuplicateShortOption

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDuplicateShortOption = 'Version courte d''option %s dupliquée'

Sepi
Class Tree
Index
Previous (SDuplicateLongOption)
Next (sFebruary)


Sepi

Sepi
Previous (SDuplicateShortOption)
Next (SHasNoController)

Name
sFebruary

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sFebruary = 'février'

Sepi
Class Tree
Index
Previous (SDuplicateShortOption)
Next (SHasNoController)


Sepi

Sepi
Previous (sFebruary)
Next (SInvalidTypeInfo)

Name
SHasNoController

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SHasNoController = 'Cet objet n''a pas de contrôleur'

Sepi
Class Tree
Index
Previous (sFebruary)
Next (SInvalidTypeInfo)


Sepi

Sepi
Previous (SHasNoController)
Next (SInvalidValue)

Name
SInvalidTypeInfo

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidTypeInfo = 'RTTI invalides'

Sepi
Class Tree
Index
Previous (SHasNoController)
Next (SInvalidValue)


Sepi

Sepi
Previous (SInvalidTypeInfo)
Next (sJanuary)

Name
SInvalidValue

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidValue = 'Valeur ''%s'' invalide pour l''option %s'

Sepi
Class Tree
Index
Previous (SInvalidTypeInfo)
Next (sJanuary)


Sepi

Sepi
Previous (SInvalidValue)
Next (sJuly)

Name
sJanuary

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sJanuary = 'janvier'

Sepi
Class Tree
Index
Previous (SInvalidValue)
Next (sJuly)


Sepi

Sepi
Previous (sJanuary)
Next (sJune)

Name
sJuly

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sJuly = 'juillet'

Sepi
Class Tree
Index
Previous (sJanuary)
Next (sJune)


Sepi

Sepi
Previous (sJuly)
Next (sMarch)

Name
sJune

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sJune = 'juin'

Sepi
Class Tree
Index
Previous (sJuly)
Next (sMarch)


Sepi

Sepi
Previous (sJune)
Next (sMay)

Name
sMarch

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sMarch = 'mars'

Sepi
Class Tree
Index
Previous (sJune)
Next (sMay)


Sepi

Sepi
Previous (sMarch)
Next (SNonOptionParamForbidden)

Name
sMay

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sMay = 'mai'

Sepi
Class Tree
Index
Previous (sMarch)
Next (SNonOptionParamForbidden)


Sepi

Sepi
Previous (sMay)
Next (sNovember)

Name
SNonOptionParamForbidden

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SNonOptionParamForbidden = 'Tous les paramètres doivent être des options'

Sepi
Class Tree
Index
Previous (sMay)
Next (sNovember)


Sepi

Sepi
Previous (SNonOptionParamForbidden)
Next (sOctober)

Name
sNovember

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sNovember = 'novembre'

Sepi
Class Tree
Index
Previous (SNonOptionParamForbidden)
Next (sOctober)


Sepi

Sepi
Previous (sNovember)
Next (SOptionValueOutOfRange)

Name
sOctober

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sOctober = 'octobre'

Sepi
Class Tree
Index
Previous (sNovember)
Next (SOptionValueOutOfRange)


Sepi

Sepi
Previous (sOctober)
Next (SRequiredOptionNotFound)

Name
SOptionValueOutOfRange

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOptionValueOutOfRange = 'La valeur de l''option %s doit être comprise dans les bornes %d à %d'

Sepi
Class Tree
Index
Previous (sOctober)
Next (SRequiredOptionNotFound)


Sepi

Sepi
Previous (SOptionValueOutOfRange)
Next (sScAbout)

Name
SRequiredOptionNotFound

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SRequiredOptionNotFound = 'L''option requise %s n''a pas été fournie'

Sepi
Class Tree
Index
Previous (SOptionValueOutOfRange)
Next (sScAbout)


Sepi

Sepi
Previous (SRequiredOptionNotFound)
Next (sScAuthor)

Name
sScAbout

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScAbout = 'À propos'

Sepi
Class Tree
Index
Previous (SRequiredOptionNotFound)
Next (sScAuthor)


Sepi

Sepi
Previous (sScAbout)
Next (sScColon)

Name
sScAuthor

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScAuthor = 'Auteur'

Sepi
Class Tree
Index
Previous (sScAbout)
Next (sScColon)


Sepi

Sepi
Previous (sScAuthor)
Next (sScDelimMustDifferentThanNotIn)

Name
sScColon

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScColon = ' :'

Sepi
Class Tree
Index
Previous (sScAuthor)
Next (sScDelimMustDifferentThanNotIn)


Sepi

Sepi
Previous (sScColon)
Next (sScErrorBrackets)

Name
sScDelimMustDifferentThanNotIn

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScDelimMustDifferentThanNotIn = 'Delim et NotIn ne peuvent contenir un même caractère'

Sepi
Class Tree
Index
Previous (sScColon)
Next (sScErrorBrackets)


Sepi

Sepi
Previous (sScDelimMustDifferentThanNotIn)
Next (sScErrorDegree)

Name
sScErrorBrackets

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorBrackets = 'Erreur de parenthèses'

Sepi
Class Tree
Index
Previous (sScDelimMustDifferentThanNotIn)
Next (sScErrorDegree)


Sepi

Sepi
Previous (sScErrorBrackets)
Next (sScErrorDivByZero)

Name
sScErrorDegree

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorDegree = 'Erreur avec le degré %s'

Sepi
Class Tree
Index
Previous (sScErrorBrackets)
Next (sScErrorDivByZero)


Sepi

Sepi
Previous (sScErrorDegree)
Next (sScErrorDivision)

Name
sScErrorDivByZero

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorDivByZero = 'Division par 0 de %s impossible'

Sepi
Class Tree
Index
Previous (sScErrorDegree)
Next (sScErrorDivision)


Sepi

Sepi
Previous (sScErrorDivByZero)
Next (sScErrorEval)

Name
sScErrorDivision

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorDivision = 'Impossible de diviser %s par %s'

Sepi
Class Tree
Index
Previous (sScErrorDivByZero)
Next (sScErrorEval)


Sepi

Sepi
Previous (sScErrorDivision)
Next (sScErrorInteger)

Name
sScErrorEval

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorEval = 'Erreur lors de l''évaluation de l''expression %s :' + # 10

Sepi
Class Tree
Index
Previous (sScErrorDivision)
Next (sScErrorInteger)


Sepi

Sepi
Previous (sScErrorEval)
Next (sScErrorMaths)

Name
sScErrorInteger

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorInteger = 'Erreur d''entier avec le nombre %f'

Sepi
Class Tree
Index
Previous (sScErrorEval)
Next (sScErrorMaths)


Sepi

Sepi
Previous (sScErrorInteger)
Next (sScErrorNatural)

Name
sScErrorMaths

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorMaths = 'Erreur de mathématiques :' + # 10

Sepi
Class Tree
Index
Previous (sScErrorInteger)
Next (sScErrorNatural)


Sepi

Sepi
Previous (sScErrorMaths)
Next (sScErrorNotDegreeZero)

Name
sScErrorNatural

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorNatural = 'Erreur de naturel avec le nombre %d'

Sepi
Class Tree
Index
Previous (sScErrorMaths)
Next (sScErrorNotDegreeZero)


Sepi

Sepi
Previous (sScErrorNatural)
Next (sScErrorNotInteger)

Name
sScErrorNotDegreeZero

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorNotDegreeZero = '%s n''est pas de degré 0'

Sepi
Class Tree
Index
Previous (sScErrorNatural)
Next (sScErrorNotInteger)


Sepi

Sepi
Previous (sScErrorNotDegreeZero)
Next (sScErrorNotNatural)

Name
sScErrorNotInteger

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorNotInteger = '%f n''est pas un nombre entier'

Sepi
Class Tree
Index
Previous (sScErrorNotDegreeZero)
Next (sScErrorNotNatural)


Sepi

Sepi
Previous (sScErrorNotInteger)
Next (sScErrorOperation)

Name
sScErrorNotNatural

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorNotNatural = '%d n''est pas un nombre naturel'

Sepi
Class Tree
Index
Previous (sScErrorNotInteger)
Next (sScErrorOperation)


Sepi

Sepi
Previous (sScErrorNotNatural)
Next (sScErrorOpIsNotBinary)

Name
sScErrorOperation

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOperation = 'Erreur avec l''opérateur %s'

Sepi
Class Tree
Index
Previous (sScErrorNotNatural)
Next (sScErrorOpIsNotBinary)


Sepi

Sepi
Previous (sScErrorOperation)
Next (sScErrorOpIsNotUnary)

Name
sScErrorOpIsNotBinary

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOpIsNotBinary = 'L''opérateur %s n''est pas un opérateur binaire'

Sepi
Class Tree
Index
Previous (sScErrorOperation)
Next (sScErrorOpIsNotUnary)


Sepi

Sepi
Previous (sScErrorOpIsNotBinary)
Next (sScErrorOpNotExists)

Name
sScErrorOpIsNotUnary

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOpIsNotUnary = 'L''opérateur %s n''est pas un opérateur binaire'

Sepi
Class Tree
Index
Previous (sScErrorOpIsNotBinary)
Next (sScErrorOpNotExists)


Sepi

Sepi
Previous (sScErrorOpIsNotUnary)
Next (sScErrorOpRequestsCorrectIndex)

Name
sScErrorOpNotExists

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOpNotExists = 'L''opérateur %s n''existe pas'

Sepi
Class Tree
Index
Previous (sScErrorOpIsNotUnary)
Next (sScErrorOpRequestsCorrectIndex)


Sepi

Sepi
Previous (sScErrorOpNotExists)
Next (sScErrorOpRequestsDegreeZero)

Name
sScErrorOpRequestsCorrectIndex

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOpRequestsCorrectIndex = 'L''opérateur %s requiert un index de liste correct (%d n''est pas valable)'

Sepi
Class Tree
Index
Previous (sScErrorOpNotExists)
Next (sScErrorOpRequestsDegreeZero)


Sepi

Sepi
Previous (sScErrorOpRequestsCorrectIndex)
Next (sScErrorOpRequestsInteger)

Name
sScErrorOpRequestsDegreeZero

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOpRequestsDegreeZero = 'L''opérateur %s requiert un monome de degré 0 (%s est de degré %d)'

Sepi
Class Tree
Index
Previous (sScErrorOpRequestsCorrectIndex)
Next (sScErrorOpRequestsInteger)


Sepi

Sepi
Previous (sScErrorOpRequestsDegreeZero)
Next (sScErrorOpRequestsNatural)

Name
sScErrorOpRequestsInteger

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOpRequestsInteger = 'L''opérateur %s requiert un entier (%f n''est pas un entier)'

Sepi
Class Tree
Index
Previous (sScErrorOpRequestsDegreeZero)
Next (sScErrorOpRequestsNatural)


Sepi

Sepi
Previous (sScErrorOpRequestsInteger)
Next (sScErrorRoot)

Name
sScErrorOpRequestsNatural

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorOpRequestsNatural = 'L''opérateur %s requiert un naturel (%d n''est pas un naturel)'

Sepi
Class Tree
Index
Previous (sScErrorOpRequestsInteger)
Next (sScErrorRoot)


Sepi

Sepi
Previous (sScErrorOpRequestsNatural)
Next (sScErrorTooManyBrackets)

Name
sScErrorRoot

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorRoot = 'Impossible de calculer la racine %s de %s'

Sepi
Class Tree
Index
Previous (sScErrorOpRequestsNatural)
Next (sScErrorTooManyBrackets)


Sepi

Sepi
Previous (sScErrorRoot)
Next (sScErrorWrongCharacter)

Name
sScErrorTooManyBrackets

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorTooManyBrackets = '%d parenthèses %s en trop'

Sepi
Class Tree
Index
Previous (sScErrorRoot)
Next (sScErrorWrongCharacter)


Sepi

Sepi
Previous (sScErrorTooManyBrackets)
Next (sScErrorWrongExpression)

Name
sScErrorWrongCharacter

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorWrongCharacter = 'Caractère non autorisé : %s'

Sepi
Class Tree
Index
Previous (sScErrorTooManyBrackets)
Next (sScErrorWrongExpression)


Sepi

Sepi
Previous (sScErrorWrongCharacter)
Next (sScIndexOutOfRange)

Name
sScErrorWrongExpression

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScErrorWrongExpression = 'Expression erronée'

Sepi
Class Tree
Index
Previous (sScErrorWrongCharacter)
Next (sScIndexOutOfRange)


Sepi

Sepi
Previous (sScErrorWrongExpression)
Next (sScLanguage)

Name
sScIndexOutOfRange

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScIndexOutOfRange = 'Index liste hors bornes (%d)'

Sepi
Class Tree
Index
Previous (sScErrorWrongExpression)
Next (sScLanguage)


Sepi

Sepi
Previous (sScIndexOutOfRange)
Next (sScListIsNotEmpty)

Name
sScLanguage

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScLanguage = 'Français (Belgique)'

Sepi
Class Tree
Index
Previous (sScIndexOutOfRange)
Next (sScListIsNotEmpty)


Sepi

Sepi
Previous (sScLanguage)
Next (sScNo)

Name
sScListIsNotEmpty

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScListIsNotEmpty = 'La liste n''est pas vide'

Sepi
Class Tree
Index
Previous (sScLanguage)
Next (sScNo)


Sepi

Sepi
Previous (sScListIsNotEmpty)
Next (sScNotInMustPairsOfChars)

Name
sScNo

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScNo = 'Non'

Sepi
Class Tree
Index
Previous (sScListIsNotEmpty)
Next (sScNotInMustPairsOfChars)


Sepi

Sepi
Previous (sScNo)
Next (sScSemiColon)

Name
sScNotInMustPairsOfChars

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScNotInMustPairsOfChars = 'NotIn doit contenir des paires de caractères'

Sepi
Class Tree
Index
Previous (sScNo)
Next (sScSemiColon)


Sepi

Sepi
Previous (sScNotInMustPairsOfChars)
Next (sScSetOf)

Name
sScSemiColon

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScSemiColon = ' ;'

Sepi
Class Tree
Index
Previous (sScNotInMustPairsOfChars)
Next (sScSetOf)


Sepi

Sepi
Previous (sScSemiColon)
Next (sScVersion)

Name
sScSetOf

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScSetOf = 'ensemble de %s'

Sepi
Class Tree
Index
Previous (sScSemiColon)
Next (sScVersion)


Sepi

Sepi
Previous (sScSetOf)
Next (sScWrongBase)

Name
sScVersion

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScVersion = 'Version'

Sepi
Class Tree
Index
Previous (sScSetOf)
Next (sScWrongBase)


Sepi

Sepi
Previous (sScVersion)
Next (sScWrongChar)

Name
sScWrongBase

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongBase = 'La base %d est incorrecte'

Sepi
Class Tree
Index
Previous (sScVersion)
Next (sScWrongChar)


Sepi

Sepi
Previous (sScWrongBase)
Next (sScWrongCharSet)

Name
sScWrongChar

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongChar = 'Impossible de convertir "%s" en caractère'

Sepi
Class Tree
Index
Previous (sScWrongBase)
Next (sScWrongCharSet)


Sepi

Sepi
Previous (sScWrongChar)
Next (sScWrongEnumSet)

Name
sScWrongCharSet

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongCharSet = 'Impossible de convertir "%s" en ensemble de caractères'

Sepi
Class Tree
Index
Previous (sScWrongChar)
Next (sScWrongEnumSet)


Sepi

Sepi
Previous (sScWrongCharSet)
Next (sScWrongFloat)

Name
sScWrongEnumSet

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongEnumSet = 'Impossible de convertir "%s" en %s'

Sepi
Class Tree
Index
Previous (sScWrongCharSet)
Next (sScWrongFloat)


Sepi

Sepi
Previous (sScWrongEnumSet)
Next (sScWrongInteger)

Name
sScWrongFloat

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongFloat = 'Impossible de convertir "%s" en valeur à virgule flottante'

Sepi
Class Tree
Index
Previous (sScWrongEnumSet)
Next (sScWrongInteger)


Sepi

Sepi
Previous (sScWrongFloat)
Next (sScWrongIntSize)

Name
sScWrongInteger

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongInteger = 'Impossible de convertir "%s" en entier'

Sepi
Class Tree
Index
Previous (sScWrongFloat)
Next (sScWrongIntSize)


Sepi

Sepi
Previous (sScWrongInteger)
Next (sScWrongLongWord)

Name
sScWrongIntSize

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongIntSize = 'Taille d''entier incorrecte : %d'

Sepi
Class Tree
Index
Previous (sScWrongInteger)
Next (sScWrongLongWord)


Sepi

Sepi
Previous (sScWrongIntSize)
Next (sScWrongPassword)

Name
sScWrongLongWord

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongLongWord = '''%s'' n''est pas une valeur entière non signée correcte'

Sepi
Class Tree
Index
Previous (sScWrongIntSize)
Next (sScWrongPassword)


Sepi

Sepi
Previous (sScWrongLongWord)
Next (sScWrongString)

Name
sScWrongPassword

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongPassword = 'Mot de passe incorrect'

Sepi
Class Tree
Index
Previous (sScWrongLongWord)
Next (sScWrongString)


Sepi

Sepi
Previous (sScWrongPassword)
Next (sScYes)

Name
sScWrongString

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScWrongString = 'Impossible de convertir "%s" en chaîne de caractères'

Sepi
Class Tree
Index
Previous (sScWrongPassword)
Next (sScYes)


Sepi

Sepi
Previous (sScWrongString)
Next (sSeptember)

Name
sScYes

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sScYes = 'Oui'

Sepi
Class Tree
Index
Previous (sScWrongString)
Next (sSeptember)


Sepi

Sepi
Previous (sScYes)
Next (SSingleOptionFoundMultipleTimes)

Name
sSeptember

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sSeptember = 'septembre'

Sepi
Class Tree
Index
Previous (sScYes)
Next (SSingleOptionFoundMultipleTimes)


Sepi

Sepi
Previous (sSeptember)
Next (sSjrdErrorAbortDivision)

Name
SSingleOptionFoundMultipleTimes

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSingleOptionFoundMultipleTimes = 'L''option unique %s a été trouvée plusieurs fois'

Sepi
Class Tree
Index
Previous (sSeptember)
Next (sSjrdErrorAbortDivision)


Sepi

Sepi
Previous (SSingleOptionFoundMultipleTimes)
Next (SUnknownLongOption)

Name
sSjrdErrorAbortDivision

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sSjrdErrorAbortDivision = 'La division de %s par %s semble impossible'

Sepi
Class Tree
Index
Previous (SSingleOptionFoundMultipleTimes)
Next (SUnknownLongOption)


Sepi

Sepi
Previous (sSjrdErrorAbortDivision)
Next (SUnknownShortOption)

Name
SUnknownLongOption

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SUnknownLongOption = 'Option longue %s inconnue'

Sepi
Class Tree
Index
Previous (sSjrdErrorAbortDivision)
Next (SUnknownShortOption)


Sepi

Sepi
Previous (SUnknownLongOption)
Next

Name
SUnknownShortOption

Parent
ScConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SUnknownShortOption = 'Option courte %s inconnue'

Sepi
Class Tree
Index
Previous (SUnknownLongOption)
Next


Sepi

Sepi
Previous (ScConsts)
Next (ScDateTimeUtils)

Name
ScCoroutines

Parent
Sepi

Description
Classes de gestion de coroutines
ScCoroutines propose deux classes principales. TCustomCoroutine est une
classe abstraite gérant des coroutines. Il faut la sucharger à la manière
dont on surcharge TThread pour avoir une coroutine concrète. TCoroutine est
une implémentation de celle-ci qui prend une méthode en paramètre, et exécute
celle-ci comme coroutine.

Author
sjrd

Version
1.0

Types
Type | Description
TCoroutineLoop (+) | Type de boucle de coroutine
TCoroutineMethod (+) | Méthode de contenu d'une coroutine publique

Constants
Constant | Description
SCoroutInternalError (+) | #No TAG found in source code#
SCoroutInvalidOpWhileNotRunning (+) | #No TAG found in source code#
SCoroutInvalidOpWhileRunning (+) | #No TAG found in source code#
SCoroutNotTerminated (+) | #No TAG found in source code#
SCoroutTerminated (+) | #No TAG found in source code#
SCoroutTerminating (+) | #No TAG found in source code#

Classes
Class | Description
ECoroutineError (+) | Erreur liée à l'utilisation d'une coroutine
ECoroutineTerminating (+) | Interruption prématurée d'une coroutine
TCoroutine (+) | Implémentation publique de TCustomCoroutine
TCustomCoroutine (+) | Classe de support des coroutines
TCustomEnumerator (+) | Énumérateur en coroutine

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScConsts)
Next (ScDateTimeUtils)


Sepi

Sepi
Previous
Next (ECoroutineTerminating)

Name
ECoroutineError

Parent
ScCoroutines

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Erreur liée à l'utilisation d'une coroutine

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ECoroutineTerminating)


Sepi

Sepi
Previous (ECoroutineError)
Next (TCoroutine)

Name
ECoroutineTerminating

Parent
ScCoroutines

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Interruption prématurée d'une coroutine

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ECoroutineError)
Next (TCoroutine)


Sepi

Sepi
Previous (ECoroutineTerminating)
Next (TCustomCoroutine)

Name
TCoroutine

Parent
ScCoroutines

Class Hierarchy
TCustomCoroutine

Visibility
PUBLIC

Description
Implémentation publique de TCustomCoroutine

Members
Fields
Field | Description
FExecuteMethod (-) | #No TAG found in source code#

Methods
Method | Description
Create (+) | Crée une coroutine
Execute (#) | [@inheritDoc]
Invoke (+) | [@inheritDoc]
Reset (+) | [@inheritDoc]
Yield (+) | [@inheritDoc]

Properties
Property | Description
CoroutineRunning (+) | #No TAG found in source code#
Loop (+) | #No TAG found in source code#
Terminated (+) | #No TAG found in source code#
Terminating (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ECoroutineTerminating)
Next (TCustomCoroutine)


Sepi

Sepi
Previous
Next

Name
FExecuteMethod

Parent
TCoroutine

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FExecuteMethod : TCoroutineMethod

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Loop)

Name
CoroutineRunning

Parent
TCoroutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property CoroutineRunning

Sepi
Class Tree
Index
Previous
Next (Loop)


Sepi

Sepi
Previous (CoroutineRunning)
Next (Terminated)

Name
Loop

Parent
TCoroutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Loop

Sepi
Class Tree
Index
Previous (CoroutineRunning)
Next (Terminated)


Sepi

Sepi
Previous (Loop)
Next (Terminating)

Name
Terminated

Parent
TCoroutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Terminated

Sepi
Class Tree
Index
Previous (Loop)
Next (Terminating)


Sepi

Sepi
Previous (Terminated)
Next

Name
Terminating

Parent
TCoroutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Terminating

Sepi
Class Tree
Index
Previous (Terminated)
Next


Sepi

Sepi
Previous
Next (Execute)

Name
Create

Parent
TCoroutine

Visibility
PUBLIC

Description
Crée une coroutine

Source code
constructor Create ( AExecuteMethod : TCoroutineMethod ; ALoop : TCoroutineLoop = clNoLoop )

Parameters
Parameter | Description
AExecuteMethod : TCoroutineMethod | Méthode contenu de la coroutine
ALoop : TCoroutineLoop | Type de boucle de la coroutine (défaut : clNoLoop)

Sepi
Class Tree
Index
Previous
Next (Execute)


Sepi

Sepi
Previous (Create)
Next (Invoke)

Name
Execute

Parent
TCoroutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Execute ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Invoke)


Sepi

Sepi
Previous (Execute)
Next (Reset)

Name
Invoke

Parent
TCoroutine

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Invoke

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Execute)
Next (Reset)


Sepi

Sepi
Previous (Invoke)
Next (Yield)

Name
Reset

Parent
TCoroutine

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Reset

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Invoke)
Next (Yield)


Sepi

Sepi
Previous (Reset)
Next

Name
Yield

Parent
TCoroutine

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Yield

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Reset)
Next


Sepi

Sepi
Previous (TCoroutine)
Next (TCustomEnumerator)

Name
TCustomCoroutine

Parent
ScCoroutines

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe de support des coroutines
La méthode Invoke ne peut avoir qu'une seule exécution à la fois. Elle ne
peut ni être appelée dans deux threads différents en même temps ; ni être
appelée depuis Execute (ce qui constitue un appel récursif).
En revanche, elle peut être appelée successivement par deux threads
différents.
La propriété Loop détermine le comportement de bouclage de la coroutine.
Celle-ci peut soit ne pas boucler (clNoLoop) : un appel à Invoke lorsque
Terminated vaut True déclenchera une exception. Soit boucler immédiatement
(clImmediate) : dès que Execute se termine, elle est rappelée sans revenir
à l'appelant. Soit boucler au prochain Invoke : dans ce cas l'appelant
reprend la main entre la fin d'une exécution et le début de la suivante.
La procédure Execute devrait tester l'état de Terminating après chaque
appel à Yield, et se terminer proprement si cette propriété vaut True.
Cette propriété sera positionnée à True lorsque l'objet coroutine devra se
libérer, avant de relancer l'exécution. Si un appel à Yield est fait dans
cet état, une exception de type ECoroutineTerminating assure que celle-ci
se termine immédiatement.

Members
Fields
Field | Description
FCoroutineRunning (-) | True si la coroutine est cours d'exécution
FCoroutineThread (-) | Thread qui exécute la coroutine
FExceptAddress (-) | Adresse de déclenchement de l'exception
FExceptObject (-) | Objet exception déclenchée par la coroutine
FInvokeEvent (-) | Événement déclenché sur Invoke
FLoop (-) | Type de boucle de la coroutine
FTerminated (-) | True si la coroutine est terminée
FTerminating (-) | True si la coroutine doit se terminer
FYieldEvent (-) | Événement déclenché sur Yield

Methods
Method | Description
BeforeDestruction (+) | Appelé juste avant le premier destructeur
Create (+) | Crée une coroutine avec une taille de pile donnée
Destroy (+) | Détruit l'instance
EnterCoroutine (-) | Entre dans la coroutine
Error (+) | Déclenche une erreur ECoroutineError
Error (+) | Déclenche une erreur ECoroutineError
Execute (#) | Coroutine à exécuter
InitCoroutine (-) | Initialise la coroutine avant sa première exécution
Invoke (#) | Exécute la coroutine jusqu'au prochain appel à Yield
LeaveCoroutine (-) | Sort la coroutine
Main (-) | Méthode principale de la coroutine
Reset (#) | Réinitialise complètement la coroutine
Terminate (-) | Termine la coroutine
WaitForNoResult (-) | Attend un événement, sans résultat
Yield (#) | Rend la main à l'appelant - retournera lors du prochain appel à Invoke

Properties
Property | Description
CoroutineRunning (#) | True si la coroutine est cours d'exécution
Loop (#) | Type de boucle de la coroutine
Terminated (#) | True si la coroutine est terminée
Terminating (#) | True si la coroutine doit se terminer

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCoroutine)
Next (TCustomEnumerator)


Sepi

Sepi
Previous
Next (FCoroutineThread)

Name
FCoroutineRunning

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
True si la coroutine est cours d'exécution

Source code
FCoroutineRunning : Boolean

Sepi
Class Tree
Index
Previous
Next (FCoroutineThread)


Sepi

Sepi
Previous (FCoroutineRunning)
Next (FExceptAddress)

Name
FCoroutineThread

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Thread qui exécute la coroutine

Source code
FCoroutineThread : TMethodThread

Sepi
Class Tree
Index
Previous (FCoroutineRunning)
Next (FExceptAddress)


Sepi

Sepi
Previous (FCoroutineThread)
Next (FExceptObject)

Name
FExceptAddress

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Adresse de déclenchement de l'exception

Source code
FExceptAddress : Pointer

Sepi
Class Tree
Index
Previous (FCoroutineThread)
Next (FExceptObject)


Sepi

Sepi
Previous (FExceptAddress)
Next (FInvokeEvent)

Name
FExceptObject

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Objet exception déclenchée par la coroutine

Source code
FExceptObject : TObject

Sepi
Class Tree
Index
Previous (FExceptAddress)
Next (FInvokeEvent)


Sepi

Sepi
Previous (FExceptObject)
Next (FLoop)

Name
FInvokeEvent

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Événement déclenché sur Invoke

Source code
FInvokeEvent : TEvent

Sepi
Class Tree
Index
Previous (FExceptObject)
Next (FLoop)


Sepi

Sepi
Previous (FInvokeEvent)
Next (FTerminated)

Name
FLoop

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Type de boucle de la coroutine

Source code
FLoop : TCoroutineLoop

Sepi
Class Tree
Index
Previous (FInvokeEvent)
Next (FTerminated)


Sepi

Sepi
Previous (FLoop)
Next (FTerminating)

Name
FTerminated

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
True si la coroutine est terminée

Source code
FTerminated : Boolean

Sepi
Class Tree
Index
Previous (FLoop)
Next (FTerminating)


Sepi

Sepi
Previous (FTerminated)
Next (FYieldEvent)

Name
FTerminating

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
True si la coroutine doit se terminer

Source code
FTerminating : Boolean

Sepi
Class Tree
Index
Previous (FTerminated)
Next (FYieldEvent)


Sepi

Sepi
Previous (FTerminating)
Next

Name
FYieldEvent

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Événement déclenché sur Yield

Source code
FYieldEvent : TEvent

Sepi
Class Tree
Index
Previous (FTerminating)
Next


Sepi

Sepi
Previous
Next (Loop)

Name
CoroutineRunning

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
True si la coroutine est cours d'exécution

Source code
property CoroutineRunning : Boolean read FCoroutineRunning

Read Access
FCoroutineRunning

Sepi
Class Tree
Index
Previous
Next (Loop)


Sepi

Sepi
Previous (CoroutineRunning)
Next (Terminated)

Name
Loop

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
Type de boucle de la coroutine

Source code
property Loop : TCoroutineLoop read FLoop write FLoop

Read Access
FLoop

Write Access
FLoop

Sepi
Class Tree
Index
Previous (CoroutineRunning)
Next (Terminated)


Sepi

Sepi
Previous (Loop)
Next (Terminating)

Name
Terminated

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
True si la coroutine est terminée

Source code
property Terminated : Boolean read FTerminated

Read Access
FTerminated

Sepi
Class Tree
Index
Previous (Loop)
Next (Terminating)


Sepi

Sepi
Previous (Terminated)
Next

Name
Terminating

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
True si la coroutine doit se terminer

Source code
property Terminating : Boolean read FTerminating

Read Access
FTerminating

Sepi
Class Tree
Index
Previous (Terminated)
Next


Sepi

Sepi
Previous
Next (Create)

Name
BeforeDestruction

Parent
TCustomCoroutine

Visibility
PUBLIC

Description
Appelé juste avant le premier destructeur
BeforeDestruction assure qu'on n'essaie pas de détruire l'objet coroutine
depuis le code de la coroutine.
Si la coroutine n'a pas terminé son exécution lors du dernier appel à Invoke,
BeforeDestruction tente de la faire se terminer correctement. Si un appel à
Yield survient, une exception ECoroutineTerminating est déclenchée pour
forcer la coroutine à se terminer.

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Destroy)

Name
Create

Parent
TCustomCoroutine

Visibility
PUBLIC

Description
Crée une coroutine avec une taille de pile donnée

Source code
constructor Create ( ALoop : TCoroutineLoop = clNoLoop )

Parameters
Parameter | Description
ALoop : TCoroutineLoop | Type de boucle de la coroutine (défaut : clNoLoop)

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (EnterCoroutine)

Name
Destroy

Parent
TCustomCoroutine

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (EnterCoroutine)


Sepi

Sepi
Previous (Destroy)
Next (Error)

Name
EnterCoroutine

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Entre dans la coroutine

Source code
procedure EnterCoroutine

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (Error)


Sepi

Sepi
Previous (EnterCoroutine)
Next (Error)

Name
Error

Parent
TCustomCoroutine

Visibility
PUBLIC

Description
Déclenche une erreur ECoroutineError

Source code
class procedure Error ( Msg : PResStringRec ; Data : Integer = 0 ) ; overload

Parameters
Parameter | Description
Msg : PResStringRec | Chaîne de ressource de format du message
Data : INTEGER | Paramètre du format

Sepi
Class Tree
Index
Previous (EnterCoroutine)
Next (Error)


Sepi

Sepi
Previous (Error)
Next (Execute)

Name
Error

Parent
TCustomCoroutine

Visibility
PUBLIC

Description
Déclenche une erreur ECoroutineError

Source code
class procedure Error ( const Msg : string ; Data : Integer = 0 ) ; overload ; virtual

Parameters
Parameter | Description
Msg : STRING | Chaîne de format du message
Data : INTEGER | Paramètre du format

Sepi
Class Tree
Index
Previous (Error)
Next (Execute)


Sepi

Sepi
Previous (Error)
Next (InitCoroutine)

Name
Execute

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
Coroutine à exécuter
Surchargez Execute pour donner le code de la coroutine.

Source code
procedure Execute ; virtual ; abstract

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Error)
Next (InitCoroutine)


Sepi

Sepi
Previous (Execute)
Next (Invoke)

Name
InitCoroutine

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Initialise la coroutine avant sa première exécution

Source code
procedure InitCoroutine

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Execute)
Next (Invoke)


Sepi

Sepi
Previous (InitCoroutine)
Next (LeaveCoroutine)

Name
Invoke

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
Exécute la coroutine jusqu'au prochain appel à Yield

Source code
procedure Invoke

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (InitCoroutine)
Next (LeaveCoroutine)


Sepi

Sepi
Previous (Invoke)
Next (Main)

Name
LeaveCoroutine

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Sort la coroutine

Source code
procedure LeaveCoroutine

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Invoke)
Next (Main)


Sepi

Sepi
Previous (LeaveCoroutine)
Next (Reset)

Name
Main

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Méthode principale de la coroutine

Source code
procedure Main ( Thread : TMethodThread )

Parameters
Parameter | Description
Thread : TMethodThread | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LeaveCoroutine)
Next (Reset)


Sepi

Sepi
Previous (Main)
Next (Terminate)

Name
Reset

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
Réinitialise complètement la coroutine
La coroutine doit être terminée pour appeler Reset (Terminated = True).
Reset peut également être appelée si la coroutine s'est terminée à cause
d'une exception.

Source code
procedure Reset

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Main)
Next (Terminate)


Sepi

Sepi
Previous (Reset)
Next (WaitForNoResult)

Name
Terminate

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Termine la coroutine

Source code
procedure Terminate ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Reset)
Next (WaitForNoResult)


Sepi

Sepi
Previous (Terminate)
Next (Yield)

Name
WaitForNoResult

Parent
TCustomCoroutine

Visibility
PRIVATE

Description
Attend un événement, sans résultat
En cas d'erreur, déclenche une exception au lieu de renvoyer un résultat.

Exception
ECoroutineError Erreur lors de l'attente

Source code
procedure WaitForNoResult ( Event : TEvent )

Parameters
Parameter | Description
Event : TEvent | Événement à attendre

Sepi
Class Tree
Index
Previous (Terminate)
Next (Yield)


Sepi

Sepi
Previous (WaitForNoResult)
Next

Name
Yield

Parent
TCustomCoroutine

Visibility
PROTECTED

Description
Rend la main à l'appelant - retournera lors du prochain appel à Invoke

Source code
procedure Yield

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (WaitForNoResult)
Next


Sepi

Sepi
Previous (TCustomCoroutine)
Next

Name
TCustomEnumerator

Parent
ScCoroutines

Class Hierarchy
TCustomCoroutine

Visibility
PUBLIC

Description
Énumérateur en coroutine
Pour obtenir un énumérateur concret, il faut surcharger la méthode Execute
pour définir le code de l'énumérateur. Et redéfinir une méthode Yield
acceptant un paramètre du type des valeurs à énumérer. Cette méthode doit
stocker le paramètre de manière à pouvoir y accéder via une propriété
Current, puis appeler la méthode Yield héritée de TCoroutine.

Members
Methods
Method | Description
MoveNext (+) | Passe à l'élément suivant de l'énumérateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCustomCoroutine)
Next


Sepi

Sepi
Previous
Next

Name
MoveNext

Parent
TCustomEnumerator

Visibility
PUBLIC

Description
Passe à l'élément suivant de l'énumérateur

Source code
function MoveNext : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il y a encore un élément, False si l'énumérateur est terminé

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (TCoroutineMethod)

Name
TCoroutineLoop

Parent
ScCoroutines

Visibility
PUBLIC

Description
Type de boucle de coroutine
- clNoLoop : exécutée une fois, ne boucle pas
- clImmediate : relance immédiatement jusqu'au premier Yield
- clNextInvoke : relance lors du prochain appel à Invoke

Source code
TCoroutineLoop = ( clNoLoop , clImmediate , clNextInvoke ) ;

Sepi
Class Tree
Index
Previous
Next (TCoroutineMethod)


Sepi

Sepi
Previous (TCoroutineLoop)
Next

Name
TCoroutineMethod

Parent
ScCoroutines

Visibility
PUBLIC

Description
Méthode de contenu d'une coroutine publique

Source code
TCoroutineMethod = procedure ( Coroutine : TCoroutine ) of object ;

Parameters
Parameter | Description
Coroutine : TCoroutine | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (TCoroutineLoop)
Next


Sepi

Sepi
Previous
Next (SCoroutInvalidOpWhileNotRunning)

Name
SCoroutInternalError

Parent
ScCoroutines

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCoroutInternalError = 'Erreur interne de la coroutine'

Sepi
Class Tree
Index
Previous
Next (SCoroutInvalidOpWhileNotRunning)


Sepi

Sepi
Previous (SCoroutInternalError)
Next (SCoroutInvalidOpWhileRunning)

Name
SCoroutInvalidOpWhileNotRunning

Parent
ScCoroutines

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCoroutInvalidOpWhileNotRunning = 'Opération invalide lorsque la coroutine n''est pas en exécution'

Sepi
Class Tree
Index
Previous (SCoroutInternalError)
Next (SCoroutInvalidOpWhileRunning)


Sepi

Sepi
Previous (SCoroutInvalidOpWhileNotRunning)
Next (SCoroutNotTerminated)

Name
SCoroutInvalidOpWhileRunning

Parent
ScCoroutines

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCoroutInvalidOpWhileRunning = 'Opération invalide lorsque la coroutine est en exécution'

Sepi
Class Tree
Index
Previous (SCoroutInvalidOpWhileNotRunning)
Next (SCoroutNotTerminated)


Sepi

Sepi
Previous (SCoroutInvalidOpWhileRunning)
Next (SCoroutTerminated)

Name
SCoroutNotTerminated

Parent
ScCoroutines

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCoroutNotTerminated = 'Impossible de réinitialiser : la coroutine n''est pas terminée'

Sepi
Class Tree
Index
Previous (SCoroutInvalidOpWhileRunning)
Next (SCoroutTerminated)


Sepi

Sepi
Previous (SCoroutNotTerminated)
Next (SCoroutTerminating)

Name
SCoroutTerminated

Parent
ScCoroutines

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCoroutTerminated = 'Impossible de continuer : la coroutine est terminée'

Sepi
Class Tree
Index
Previous (SCoroutNotTerminated)
Next (SCoroutTerminating)


Sepi

Sepi
Previous (SCoroutTerminated)
Next

Name
SCoroutTerminating

Parent
ScCoroutines

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCoroutTerminating = 'La coroutine est en train de se terminer'

Sepi
Class Tree
Index
Previous (SCoroutTerminated)
Next


Sepi

Sepi
Previous (ScCoroutines)
Next (ScDelphiLanguage)

Name
ScDateTimeUtils

Parent
Sepi

Description
Définit quelques routines de dates et heures

Author
sjrd

Version
1.0

Methods
Method | Description
GetMonthName (+) | Renvoie le nom d'un mois

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScCoroutines)
Next (ScDelphiLanguage)


Sepi

Sepi
Previous
Next

Name
GetMonthName

Parent
ScDateTimeUtils

Visibility
PUBLIC

Description
Renvoie le nom d'un mois

Source code
function GetMonthName ( Month : Integer ; Maj : Boolean = True ) : string

Parameters
Parameter | Description
Month : INTEGER | Mois basé sur 1
Maj : BOOLEAN | Indique si la première lettre doit être une majuscule

Return
Types | Description
STRING | Le nom du mois Month, avec une majuscule si Maj vaut True

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ScDateTimeUtils)
Next (ScEnumerators)

Name
ScDelphiLanguage

Parent
Sepi

Description
Définit des routines en lien avec le langage Delphi lui-même

Author
sjrd

Version
1.0

Types
Type Description

Variables
Variable Description

Methods
Method | Description
CharRepresToChar (+) | Détermine un caractère à partir de sa représentation Pascal
CharSetToStr (+) | Détermine la représentation Pascal d'un ensemble de caractères (sans les [])
CharToCharRepres (+) | Détermine la représentation Pascal d'un caractère
CharToCharRepres (+) | Détermine la représentation Pascal d'un caractère
ClearBit (+) | Positionne un bit à 0
ClearCDeclCallInfo (+) | S'assure que toutes les informations de routines cdecl sont supprimées
CorrectIdentifier (+) | Vérifie si une chaîne de caractères est un identificateur Pascal correct
EnumSetToStr (+) | Convertit un type ensemble d'éléments d'énumération en chaîne
FreeProcOfMethod (+) | Libère une routine construite avec une des MakeProcOfMethod
GetClassDynamicCode (+) | Trouve le code d'une méthode dynamique, pour une classe
GetClassDynamicMethod (+) | Trouve une méthode dynamique, pour une classe
GetClassVirtualCode (+) | Trouve le code d'une méthode virtuelle, pour une classe
GetClassVirtualMethod (+) | Trouve une méthode virtuelle, pour une classe
GetMethodFromName (+) | Recherche une méthode d'un objet à partir de son nom
GetObjectDynamicCode (+) | Trouve le code d'une méthode dynamique, pour un objet
GetObjectDynamicMethod (+) | Trouve une méthode dynamique, pour un objet
GetObjectVirtualCode (+) | Trouve le code d'une méthode virtuelle, pour un objet
GetObjectVirtualMethod (+) | Trouve une virtuelle dynamique, pour un objet
JmpArgument (+) | Calcule l'argument d'une instruction JMP ou CALL
MakeCall (+) | Construit une instruction CALL
MakeJmp (+) | Construit une instruction JMP
MakeMethod (+) | Construit un record TMethod
MakeProcOfCDeclMethod (+) | Construit une routine équivalente à une méthode cdecl
MakeProcOfPascalMethod (+) | Construit une routine équivalente à une méthode pascal
MakeProcOfRegisterMethod (+) | Construit une routine équivalente à une méthode register
MakeProcOfStdCallMethod (+) | Construit une routine équivalente à une méthode stdcall
SetBit (+) | Positionne un bit à 1
SkipPackedShortString (+) | Renvoie un pointeur vers le champ suivant un ShortString compactée (des RTTI)
StrRepresToStr (+) | Détermine une chaîne à partir de sa représentation Pascal
StrToCharSet (+) | Détermine un ensemble de caractères à partir de sa représentation Pascal
StrToEnumSet (+) | Convertit une chaîne en type ensemble d'éléments d'énumération
StrToStrRepres (+) | Détermine la représentation Pascal d'une chaîne de caractères
TestBit (+) | Teste la valeur d'un bit
ToggleBit (+) | Inverse un bit

Classes
Class | Description
TJmpInstruction (+) | Instruction JMP ou CALL

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScDateTimeUtils)
Next (ScEnumerators)


Sepi

Sepi
Previous
Next

Name
TJmpInstruction

Parent
ScDelphiLanguage

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Instruction JMP ou CALL

Members
Fields
Field | Description
Argument (*) | Destination
OpCode (*) | OpCode

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (OpCode)

Name
Argument

Parent
TJmpInstruction

Visibility
PUBLISHED

Description
Destination

Source code
Argument : Integer

Sepi
Class Tree
Index
Previous
Next (OpCode)


Sepi

Sepi
Previous (Argument)
Next

Name
OpCode

Parent
TJmpInstruction

Visibility
PUBLISHED

Description
OpCode

Source code
OpCode : Byte

Sepi
Class Tree
Index
Previous (Argument)
Next


Sepi

Sepi
Previous
Next (CharSetToStr)

Name
CharRepresToChar

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Détermine un caractère à partir de sa représentation Pascal

Exception
EConvertError Caractère incorrect

Source code
function CharRepresToChar ( Str : string ) : WideChar

Parameters
Parameter | Description
Str : STRING | Chaîne à traiter

Return
Types | Description
WIDECHAR | Caractère représenté par Str en Pascal

Sepi
Class Tree
Index
Previous
Next (CharSetToStr)


Sepi

Sepi
Previous (CharRepresToChar)
Next (CharToCharRepres)

Name
CharSetToStr

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Détermine la représentation Pascal d'un ensemble de caractères (sans les [])

Source code
function CharSetToStr ( const CharSet : TSysCharSet ) : string

Parameters
Parameter | Description
CharSet : TSysCharSet | Ensemble de caractères à traiter

Return
Types | Description
STRING | Représentation Pascal de CharSet

Sepi
Class Tree
Index
Previous (CharRepresToChar)
Next (CharToCharRepres)


Sepi

Sepi
Previous (CharSetToStr)
Next (CharToCharRepres)

Name
CharToCharRepres

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Détermine la représentation Pascal d'un caractère

Source code
function CharToCharRepres ( Chr : AnsiChar ; ExcludedChars : TSysCharSet = [ ] ) : string ; overload

Parameters
Parameter | Description
Chr : AnsiChar | Caractère à traiter
ExcludedChars : TSysCharSet | Ensemble des caractères qu'il faut échapper

Return
Types | Description
STRING | Représentation Pascal de Chr

Sepi
Class Tree
Index
Previous (CharSetToStr)
Next (CharToCharRepres)


Sepi

Sepi
Previous (CharToCharRepres)
Next (ClearBit)

Name
CharToCharRepres

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Détermine la représentation Pascal d'un caractère

Source code
function CharToCharRepres ( Chr : WideChar ; ExcludedChars : TSysCharSet = [ ] ) : string ; overload

Parameters
Parameter | Description
Chr : WIDECHAR | Caractère à traiter
ExcludedChars : TSysCharSet | Ensemble des caractères qu'il faut échapper

Return
Types | Description
STRING | Représentation Pascal de Chr

Sepi
Class Tree
Index
Previous (CharToCharRepres)
Next (ClearBit)


Sepi

Sepi
Previous (CharToCharRepres)
Next (ClearCDeclCallInfo)

Name
ClearBit

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Positionne un bit à 0

Source code
procedure ClearBit ( var Value ; Bit : LongWord )

Parameters
Parameter | Description
Value : Untyped | Valeur à modifier
Bit : LONGWORD | Index du bit à modifier

Sepi
Class Tree
Index
Previous (CharToCharRepres)
Next (ClearCDeclCallInfo)


Sepi

Sepi
Previous (ClearBit)
Next (CorrectIdentifier)

Name
ClearCDeclCallInfo

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
S'assure que toutes les informations de routines cdecl sont supprimées
Cette routine devrait être appelée à la fin de chaque thread susceptible
d'utiliser des routines issues de méthodes cdecl.
Si ce n'est pas possible, ce n'est pas dramatique, mais l'application
s'expose à de légères fuites mémoire en cas d'exception à l'intérieur de
telles méthodes.
Pour le thread principal, ce n'est pas nécessaire, le code de finalisation de
ScDelphiLanguage.pas s'en charge.

Source code
procedure ClearCDeclCallInfo

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ClearBit)
Next (CorrectIdentifier)


Sepi

Sepi
Previous (ClearCDeclCallInfo)
Next (EnumSetToStr)

Name
CorrectIdentifier

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Vérifie si une chaîne de caractères est un identificateur Pascal correct

Source code
function CorrectIdentifier ( const Ident : string ) : Boolean

Parameters
Parameter | Description
Ident : STRING | Chaîne de caractères à tester

Return
Types | Description
BOOLEAN | True si Ident est un identificateur Pascal correct, False sinon

Sepi
Class Tree
Index
Previous (ClearCDeclCallInfo)
Next (EnumSetToStr)


Sepi

Sepi
Previous (CorrectIdentifier)
Next (FreeProcOfMethod)

Name
EnumSetToStr

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Convertit un type ensemble d'éléments d'énumération en chaîne
La représentation est celle du langage Pascal, sans les [].
Cette routine fonctionne également pour les ensembles d'entiers.

Source code
function EnumSetToStr ( const EnumSet ; TypeInfo : PTypeInfo ) : string

Parameters
Parameter | Description
EnumSet : Untyped | Ensemble à convertir
TypeInfo : PTypeInfo | RTTI du type ensemble ou du type énumération

Return
Types | Description
STRING | Chaîne représentant l'ensemble EnumSet

Sepi
Class Tree
Index
Previous (CorrectIdentifier)
Next (FreeProcOfMethod)


Sepi

Sepi
Previous (EnumSetToStr)
Next (GetClassDynamicCode)

Name
FreeProcOfMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Libère une routine construite avec une des MakeProcOfMethod

Source code
procedure FreeProcOfMethod ( Proc : Pointer )

Parameters
Parameter | Description
Proc : Pointer | Routine à libérer

Sepi
Class Tree
Index
Previous (EnumSetToStr)
Next (GetClassDynamicCode)


Sepi

Sepi
Previous (FreeProcOfMethod)
Next (GetClassDynamicMethod)

Name
GetClassDynamicCode

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve le code d'une méthode dynamique, pour une classe

Exception
EAbstractError La classe n'implémente pas la méthode recherchée

Source code
function GetClassDynamicCode ( AClass : TClass ; DMTIndex : Integer ) : Pointer

Parameters
Parameter | Description
AClass : TClass | Classe concernée
DMTIndex : INTEGER | DMT index de la méthode

Return
Types | Description
Pointer | Pointeur sur le code de la méthode

Sepi
Class Tree
Index
Previous (FreeProcOfMethod)
Next (GetClassDynamicMethod)


Sepi

Sepi
Previous (GetClassDynamicCode)
Next (GetClassVirtualCode)

Name
GetClassDynamicMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve une méthode dynamique, pour une classe

Exception
EAbstractError La classe n'implémente pas la méthode recherchée

Source code
function GetClassDynamicMethod ( AClass : TClass ; DMTIndex : Integer ) : TMethod

Parameters
Parameter | Description
AClass : TClass | Classe concernée
DMTIndex : INTEGER | DMT index de la méthode

Return
Types | Description
TMethod | Méthode correspondante

Sepi
Class Tree
Index
Previous (GetClassDynamicCode)
Next (GetClassVirtualCode)


Sepi

Sepi
Previous (GetClassDynamicMethod)
Next (GetClassVirtualMethod)

Name
GetClassVirtualCode

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve le code d'une méthode virtuelle, pour une classe

Source code
function GetClassVirtualCode ( AClass : TClass ; VMTOffset : Integer ) : Pointer

Parameters
Parameter | Description
AClass : TClass | Classe concernée
VMTOFFSET : INTEGER | VMT offset de la méthode

Return
Types | Description
Pointer | Pointeur sur le code de la méthode

Sepi
Class Tree
Index
Previous (GetClassDynamicMethod)
Next (GetClassVirtualMethod)


Sepi

Sepi
Previous (GetClassVirtualCode)
Next (GetMethodFromName)

Name
GetClassVirtualMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve une méthode virtuelle, pour une classe

Source code
function GetClassVirtualMethod ( AClass : TClass ; VMTOffset : Integer ) : TMethod

Parameters
Parameter | Description
AClass : TClass | Classe concernée
VMTOFFSET : INTEGER | VMT offset de la méthode

Return
Types | Description
TMethod | Méthode correspondante

Sepi
Class Tree
Index
Previous (GetClassVirtualCode)
Next (GetMethodFromName)


Sepi

Sepi
Previous (GetClassVirtualMethod)
Next (GetObjectDynamicCode)

Name
GetMethodFromName

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Recherche une méthode d'un objet à partir de son nom
La méthode en question doit être publiée pour pouvoir être trouvée.

Source code
function GetMethodFromName ( Obj : TObject ; const MethodName : ShortString ) : TMethod

Parameters
Parameter | Description
Obj : TObject | L'objet définissant la méthode
MethodName : ShortString | Nom de la méthode

Return
Types | Description
TMethod | Une référence à la méthode recherchée pour l'objet Obj

Sepi
Class Tree
Index
Previous (GetClassVirtualMethod)
Next (GetObjectDynamicCode)


Sepi

Sepi
Previous (GetMethodFromName)
Next (GetObjectDynamicMethod)

Name
GetObjectDynamicCode

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve le code d'une méthode dynamique, pour un objet

Exception
EAbstractError La classe n'implémente pas la méthode recherchée

Source code
function GetObjectDynamicCode ( AObject : TObject ; DMTIndex : Integer ) : Pointer

Parameters
Parameter | Description
AObject : TObject | Objet concerné
DMTIndex : INTEGER | DMT index de la méthode

Return
Types | Description
Pointer | Pointeur sur le code de la méthode

Sepi
Class Tree
Index
Previous (GetMethodFromName)
Next (GetObjectDynamicMethod)


Sepi

Sepi
Previous (GetObjectDynamicCode)
Next (GetObjectVirtualCode)

Name
GetObjectDynamicMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve une méthode dynamique, pour un objet

Exception
EAbstractError La classe n'implémente pas la méthode recherchée

Source code
function GetObjectDynamicMethod ( AObject : TObject ; DMTIndex : Integer ) : TMethod

Parameters
Parameter | Description
AObject : TObject | Objet concerné
DMTIndex : INTEGER | DMT index de la méthode

Return
Types | Description
TMethod | Méthode correspondante

Sepi
Class Tree
Index
Previous (GetObjectDynamicCode)
Next (GetObjectVirtualCode)


Sepi

Sepi
Previous (GetObjectDynamicMethod)
Next (GetObjectVirtualMethod)

Name
GetObjectVirtualCode

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve le code d'une méthode virtuelle, pour un objet

Source code
function GetObjectVirtualCode ( AObject : TObject ; VMTOffset : Integer ) : Pointer

Parameters
Parameter | Description
AObject : TObject | Objet concerné
VMTOFFSET : INTEGER | VMT offset de la méthode

Return
Types | Description
Pointer | Pointeur sur le code de la méthode

Sepi
Class Tree
Index
Previous (GetObjectDynamicMethod)
Next (GetObjectVirtualMethod)


Sepi

Sepi
Previous (GetObjectVirtualCode)
Next (JmpArgument)

Name
GetObjectVirtualMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Trouve une virtuelle dynamique, pour un objet

Source code
function GetObjectVirtualMethod ( AObject : TObject ; VMTOffset : Integer ) : TMethod

Parameters
Parameter | Description
AObject : TObject | Objet concerné
VMTOFFSET : INTEGER | VMT offset de la méthode

Return
Types | Description
TMethod | Méthode correspondante

Sepi
Class Tree
Index
Previous (GetObjectVirtualCode)
Next (JmpArgument)


Sepi

Sepi
Previous (GetObjectVirtualMethod)
Next (MakeCall)

Name
JmpArgument

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Calcule l'argument d'une instruction JMP ou CALL

Source code
function JmpArgument ( JmpAddress , JmpDest : Pointer ) : Integer

Parameters
Parameter | Description
JmpAddress : Pointer | Adresse de l'instruction JMP
JmpDest : Pointer | Destination du JMP

Return
Types | Description
INTEGER | Argument à donner au JMP

Sepi
Class Tree
Index
Previous (GetObjectVirtualMethod)
Next (MakeCall)


Sepi

Sepi
Previous (JmpArgument)
Next (MakeJmp)

Name
MakeCall

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Construit une instruction CALL

Source code
procedure MakeCall ( var Instruction ; Dest : Pointer )

Parameters
Parameter | Description
Instruction : Untyped | Instruction (minimum 5 octets)
Dest : Pointer | Destination du CALL

Sepi
Class Tree
Index
Previous (JmpArgument)
Next (MakeJmp)


Sepi

Sepi
Previous (MakeCall)
Next (MakeMethod)

Name
MakeJmp

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Construit une instruction JMP

Source code
procedure MakeJmp ( var Instruction ; Dest : Pointer )

Parameters
Parameter | Description
Instruction : Untyped | Instruction (minimum 5 octets)
Dest : Pointer | Destination du JMP

Sepi
Class Tree
Index
Previous (MakeCall)
Next (MakeMethod)


Sepi

Sepi
Previous (MakeJmp)
Next (MakeProcOfCDeclMethod)

Name
MakeMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Construit un record TMethod

Source code
function MakeMethod ( Code : Pointer ; Data : Pointer = nil ) : TMethod

Parameters
Parameter | Description
Code : Pointer | Valeur du champ Code
Data : Pointer | Valeur du champ Data

Return
Types | Description
TMethod | Un enregistrement TMethod avec les champs indiqués

Sepi
Class Tree
Index
Previous (MakeJmp)
Next (MakeProcOfCDeclMethod)


Sepi

Sepi
Previous (MakeMethod)
Next (MakeProcOfPascalMethod)

Name
MakeProcOfCDeclMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Construit une routine équivalente à une méthode cdecl
MakeProcOfMethod permet d'obtenir un pointeur sur une routine, construite
dynamiquement, qui équivaut à une méthode. Ce qui signifie que la routine
renvoyée commence par ajouter un paramètre supplémentaire, avant d'appeler
la méthode initiale.
La procédure devra être libérée avec FreeProcOfMethod une fois utilisée.

Source code
function MakeProcOfCDeclMethod ( const Method : TMethod ) : Pointer

Parameters
Parameter | Description
Method : TMethod | Méthode à convertir

Return
Types | Description
Pointer | Pointeur vers le code de la procédure créée

Sepi
Class Tree
Index
Previous (MakeMethod)
Next (MakeProcOfPascalMethod)


Sepi

Sepi
Previous (MakeProcOfCDeclMethod)
Next (MakeProcOfRegisterMethod)

Name
MakeProcOfPascalMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Construit une routine équivalente à une méthode pascal
MakeProcOfMethod permet d'obtenir un pointeur sur une routine, construite
dynamiquement, qui équivaut à une méthode. Ce qui signifie que la routine
renvoyée commence par ajouter un paramètre supplémentaire, avant d'appeler
la méthode initiale.
La procédure devra être libérée avec FreeProcOfMethod une fois utilisée.

Source code
function MakeProcOfPascalMethod ( const Method : TMethod ) : Pointer

Parameters
Parameter | Description
Method : TMethod | Méthode à convertir

Return
Types | Description
Pointer | Pointeur vers le code de la procédure créée

Sepi
Class Tree
Index
Previous (MakeProcOfCDeclMethod)
Next (MakeProcOfRegisterMethod)


Sepi

Sepi
Previous (MakeProcOfPascalMethod)
Next (MakeProcOfStdCallMethod)

Name
MakeProcOfRegisterMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Construit une routine équivalente à une méthode register
MakeProcOfMethod permet d'obtenir un pointeur sur une routine, construite
dynamiquement, qui équivaut à une méthode. Ce qui signifie que la routine
renvoyée commence par ajouter un paramètre supplémentaire, avant d'appeler
la méthode initiale.
La procédure devra être libérée avec FreeProcOfMethod une fois utilisée.
Vous devez déterminer UsedRegCount et MoveStackCount d'après la délcaration de
la *procédure*. UsedRegCount est le nombre de registres utilisés pour la
transmission des paramètres (dans l'ordre EAX, EDX et ECX). Si les trois sont
utilisés, le paramètre MoveStackCount doit renseigner le nombre de "cases" de
pile (de doubles mots) utilisés par les paramètres déclarés *après* le
paramètre transmis dans ECX.

Source code
function MakeProcOfRegisterMethod ( const Method : TMethod ; UsedRegCount : Byte ; MoveStackCount : Word = 0 ) : Pointer

Parameters
Parameter | Description
Method : TMethod | Méthode à convertir
UsedRegCount : BYTE | Nombre de registres utilisés dans l'appel de procédure
MoveStackCount : WORD | Nombre de cases de pile empilées après ECX

Return
Types | Description
Pointer | Pointeur vers le code de la procédure créée

Sepi
Class Tree
Index
Previous (MakeProcOfPascalMethod)
Next (MakeProcOfStdCallMethod)


Sepi

Sepi
Previous (MakeProcOfRegisterMethod)
Next (SetBit)

Name
MakeProcOfStdCallMethod

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Construit une routine équivalente à une méthode stdcall
MakeProcOfMethod permet d'obtenir un pointeur sur une routine, construite
dynamiquement, qui équivaut à une méthode. Ce qui signifie que la routine
renvoyée commence par ajouter un paramètre supplémentaire, avant d'appeler
la méthode initiale.
La procédure devra être libérée avec FreeProcOfMethod une fois utilisée.

Source code
function MakeProcOfStdCallMethod ( const Method : TMethod ) : Pointer

Parameters
Parameter | Description
Method : TMethod | Méthode à convertir

Return
Types | Description
Pointer | Pointeur vers le code de la procédure créée

Sepi
Class Tree
Index
Previous (MakeProcOfRegisterMethod)
Next (SetBit)


Sepi

Sepi
Previous (MakeProcOfStdCallMethod)
Next (SkipPackedShortString)

Name
SetBit

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Positionne un bit à 1

Source code
procedure SetBit ( var Value ; Bit : LongWord )

Parameters
Parameter | Description
Value : Untyped | Valeur à modifier
Bit : LONGWORD | Index du bit à modifier

Sepi
Class Tree
Index
Previous (MakeProcOfStdCallMethod)
Next (SkipPackedShortString)


Sepi

Sepi
Previous (SetBit)
Next (StrRepresToStr)

Name
SkipPackedShortString

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Renvoie un pointeur vers le champ suivant un ShortString compactée (des RTTI)
Cette routine peut être utilisée pour passer « au-dessus » d'une ShortString
compactée, telle qu'on peut en trouver dans les record extra-compactés des
RTTI.

Source code
function SkipPackedShortString ( Value : PShortstring ) : Pointer

Parameters
Parameter | Description
Value : PShortstring | Adresse de la ShortString compactée

Return
Types | Description
Pointer | Adresse du champ suivant

Sepi
Class Tree
Index
Previous (SetBit)
Next (StrRepresToStr)


Sepi

Sepi
Previous (SkipPackedShortString)
Next (StrToCharSet)

Name
StrRepresToStr

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Détermine une chaîne à partir de sa représentation Pascal
Cette représentation est la chaîne encadrée de guillemets simples ('), dont
ces caractères à l'intérieur de la chaîne sont doublés, et dont certains
caractères spéciaux sont échappés au moyen de #.
Cette chaîne peut par exemple être extraite d'un code Pascal.

Exception
EConvertError Chaîne de caractère incorrecte

Source code
function StrRepresToStr ( Str : string ) : string

Parameters
Parameter | Description
Str : STRING | Chaîne à traiter

Return
Types | Description
STRING | Chaîne représentée par Str en Pascal

Sepi
Class Tree
Index
Previous (SkipPackedShortString)
Next (StrToCharSet)


Sepi

Sepi
Previous (StrRepresToStr)
Next (StrToEnumSet)

Name
StrToCharSet

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Détermine un ensemble de caractères à partir de sa représentation Pascal

Exception
EConvertError Ensemble de caractères incorrect

Source code
function StrToCharSet ( Str : string ) : TSysCharSet

Parameters
Parameter | Description
Str : STRING | Chaîne à traiter

Return
Types | Description
TSysCharSet | Ensemble de caractères représenté par CharSet

Sepi
Class Tree
Index
Previous (StrRepresToStr)
Next (StrToEnumSet)


Sepi

Sepi
Previous (StrToCharSet)
Next (StrToStrRepres)

Name
StrToEnumSet

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Convertit une chaîne en type ensemble d'éléments d'énumération
La représentation est celle du langage Pascal, avec ou sans les [].
Cette routine fonctionne également pour les ensembles d'entiers.

Source code
procedure StrToEnumSet ( const Str : string ; TypeInfo : PTypeInfo ; out EnumSet )

Parameters
Parameter | Description
Str : STRING | Chaîne à convertir
TypeInfo : PTypeInfo | RTTI du type ensemble ou du type énumération
EnumSet : Untyped | Ensemble converti en sortie

Sepi
Class Tree
Index
Previous (StrToCharSet)
Next (StrToStrRepres)


Sepi

Sepi
Previous (StrToEnumSet)
Next (TestBit)

Name
StrToStrRepres

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Détermine la représentation Pascal d'une chaîne de caractères
Cette représentation est la chaîne encadrée de guillemets simples ('), dont
ces caractères à l'intérieur de la chaîne sont doublés, et dont certains
caractères spéciaux sont échappés au moyen de #.
Cette chaîne peut alors être par exemple insérée dans un code Pascal.

Source code
function StrToStrRepres ( const Str : string ; ExcludedChars : TSysCharSet = [ ] ) : string

Parameters
Parameter | Description
Str : STRING | Chaîne à traiter
ExcludedChars : TSysCharSet | Ensemble des caractères qu'il faut échapper

Return
Types | Description
STRING | Représentation Pascal de Str

Sepi
Class Tree
Index
Previous (StrToEnumSet)
Next (TestBit)


Sepi

Sepi
Previous (StrToStrRepres)
Next (ToggleBit)

Name
TestBit

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Teste la valeur d'un bit

Source code
function TestBit ( const Value ; Bit : LongWord ) : Boolean

Parameters
Parameter | Description
Value : Untyped | Valeur à tester
Bit : LONGWORD | Index du bit à tester

Return
Types | Description
BOOLEAN | True si le bit est à 1, False sinon

Sepi
Class Tree
Index
Previous (StrToStrRepres)
Next (ToggleBit)


Sepi

Sepi
Previous (TestBit)
Next

Name
ToggleBit

Parent
ScDelphiLanguage

Visibility
PUBLIC

Description
Inverse un bit

Source code
procedure ToggleBit ( var Value ; Bit : LongWord )

Parameters
Parameter | Description
Value : Untyped | Valeur à modifier
Bit : LONGWORD | Index du bit à modifier

Sepi
Class Tree
Index
Previous (TestBit)
Next


Sepi

Sepi
Previous (ScDelphiLanguage)
Next (ScIntegerSets)

Name
ScEnumerators

Parent
Sepi

Description
Classes d'énumérateurs fonctionnant en coroutine

Author
sjrd

Version
1.0

Types
Type | Description
TIntegerEnumeratorMethod (+) | Méthode d'énumérateur d'entier

Classes
Class | Description
TCustomIntegerEnumerator (+) | Enumérateur d'entiers protégé
TIntegerEnumerator (+) | Enumérateur d'entiers

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScDelphiLanguage)
Next (ScIntegerSets)


Sepi

Sepi
Previous
Next (TIntegerEnumerator)

Name
TCustomIntegerEnumerator

Parent
ScEnumerators

Class Hierarchy
TCustomEnumerator

Visibility
PUBLIC

Description
Enumérateur d'entiers protégé

Members
Fields
Field | Description
FCurrent (-) | Valeur courante

Methods
Method | Description
GetCurrent (+) | Valeur courante
Yield (#) | Renvoie une valeur

Properties
Property | Description
Current (+) | Valeur courante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TIntegerEnumerator)


Sepi

Sepi
Previous
Next

Name
FCurrent

Parent
TCustomIntegerEnumerator

Visibility
PRIVATE

Description
Valeur courante

Source code
FCurrent : Integer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Current

Parent
TCustomIntegerEnumerator

Visibility
PUBLIC

Description
Valeur courante

Source code
property Current : Integer read GetCurrent

Read Access
GetCurrent

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Yield)

Name
GetCurrent

Parent
TCustomIntegerEnumerator

Visibility
PUBLIC

Description
Valeur courante

Source code
function GetCurrent : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Valeur courante

Sepi
Class Tree
Index
Previous
Next (Yield)


Sepi

Sepi
Previous (GetCurrent)
Next

Name
Yield

Parent
TCustomIntegerEnumerator

Visibility
PROTECTED

Description
Renvoie une valeur

Source code
procedure Yield ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Valeur à renvoyer

Sepi
Class Tree
Index
Previous (GetCurrent)
Next


Sepi

Sepi
Previous (TCustomIntegerEnumerator)
Next

Name
TIntegerEnumerator

Parent
ScEnumerators

Class Hierarchy
TCustomIntegerEnumerator

Visibility
PUBLIC

Description
Enumérateur d'entiers

Members
Fields
Field | Description
FEnumerateMethod (-) | Méthode exécutante

Methods
Method | Description
Create (+) | Crée une coroutine
Execute (#) | [@inheritDoc]
Yield (+) | [@inheritDoc]

Properties
Property | Description
Terminating (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCustomIntegerEnumerator)
Next


Sepi

Sepi
Previous
Next

Name
FEnumerateMethod

Parent
TIntegerEnumerator

Visibility
PRIVATE

Description
Méthode exécutante

Source code
FEnumerateMethod : TIntegerEnumeratorMethod

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Terminating

Parent
TIntegerEnumerator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Terminating

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Execute)

Name
Create

Parent
TIntegerEnumerator

Visibility
PUBLIC

Description
Crée une coroutine

Source code
constructor Create ( AEnumerateMethod : TIntegerEnumeratorMethod ; ALoop : TCoroutineLoop = clNoLoop )

Parameters
Parameter | Description
AEnumerateMethod : TIntegerEnumeratorMethod | Méthode contenu de la coroutine
ALoop : TCoroutineLoop | Type de boucle de la coroutine (défaut : clNoLoop)

Sepi
Class Tree
Index
Previous
Next (Execute)


Sepi

Sepi
Previous (Create)
Next (Yield)

Name
Execute

Parent
TIntegerEnumerator

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Execute ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Yield)


Sepi

Sepi
Previous (Execute)
Next

Name
Yield

Parent
TIntegerEnumerator

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Yield ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Execute)
Next


Sepi

Sepi
Previous
Next

Name
TIntegerEnumeratorMethod

Parent
ScEnumerators

Visibility
PUBLIC

Description
Méthode d'énumérateur d'entier

Source code
TIntegerEnumeratorMethod = procedure ( Enumerator : TIntegerEnumerator ) of object ;

Parameters
Parameter | Description
Enumerator : TIntegerEnumerator | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ScEnumerators)
Next (ScInterfaces)

Name
ScIntegerSets

Parent
Sepi

Description
Ensemble d'entiers

Author
sjrd

Version
1.0

Types
Type | Description
TIntegerIntervalDynArray (+) | Tableau dynamique d'intervalles fermés d'entiers

Methods
Method | Description
IntInInterval (+) | #No TAG found in source code#

Classes
Class | Description
TIntegerInterval (+) | Intervalle fermé d'entiers
TScIntegerSet (+) | Ensemble d'entiers
TScIntegerSetEnumerator (+) | Énumérateur des valeurs contenues dans un ensemble d'entiers

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScEnumerators)
Next (ScInterfaces)


Sepi

Sepi
Previous
Next (TScIntegerSet)

Name
TIntegerInterval

Parent
ScIntegerSets

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Intervalle fermé d'entiers

Members
Fields
Field | Description
Higher (*) | Borne supérieure
Lower (*) | Borne inférieure

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TScIntegerSet)


Sepi

Sepi
Previous
Next (Lower)

Name
Higher

Parent
TIntegerInterval

Visibility
PUBLISHED

Description
Borne supérieure

Source code
Higher : Integer

Sepi
Class Tree
Index
Previous
Next (Lower)


Sepi

Sepi
Previous (Higher)
Next

Name
Lower

Parent
TIntegerInterval

Visibility
PUBLISHED

Description
Borne inférieure

Source code
Lower : Integer

Sepi
Class Tree
Index
Previous (Higher)
Next


Sepi

Sepi
Previous (TIntegerInterval)
Next (TScIntegerSetEnumerator)

Name
TScIntegerSet

Parent
ScIntegerSets

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Ensemble d'entiers
L'implémentation favorise des intervalles de valeurs, plutôt que des valeurs
isolées. Mais celles-ci ne sont que faiblement pénalisées.

Members
Fields
Field | Description
FIntervalCount (-) | Nombre d'intervalles
FIntervals (-) | Intervalles de valeurs contenues
FModified (-) | Indique si a été modifié

Methods
Method | Description
AddInterval (+) | Inclut toutes les valeurs d'un intervalle (fermé) dans l'ensemble
Assign (+) | Remplace le contenu de cet ensemble par un autre
Clear (+) | Vide l'ensemble
Clone (+) | Crée une copie d'un ensemble d'entiers
Create (+) | Crée un nouvel ensemble d'entiers vide
Create (+) | Crée un nouvel ensemble d'entiers à partir d'un tableau d'entiers
CreateFromStream (+) | Crée un nouvel ensemble d'entiers à partir d'un flux
DeleteIntervals (#) | Retire une plage d'intervalles du tableau interne
Equal (+) | Détermine si deux ensembles sont égaux
Exclude (+) | Retire une valeur de l'ensemble, si elle y était
Exists (+) | Détermine si l'ensemble contient une valeur particulière
FindInterval (#) | Cherche la place de l'intervalle contenant une valeur dans le tableau interne
GetCapacity (-) | Capacité du tableau interne
GetEnumerator (+) | Crée un énumérateur pour les valeurs contenues dans cet ensemble
GetIntervals (-) | Tableau zero-based des intervalles contenus dans l'ensemble
GetIsEmpty (-) | Indique si l'ensemble est vide
Grow (#) | Agrandit le tableau interne
Include (+) | Ajoute une valeur dans l'ensemble, si elle n'y était pas encore
InsertIntervals (#) | Insère des intervalles dans le tableau interne
Intersect (+) | Opérateur * Calcule l'intersection entre deux ensemble
LoadFromStream (+) | Charge l'ensemble depuis un flux
RemoveInterval (+) | Exclut toutes les valeurs d'un intervalle (fermé) de l'ensemble
SaveToStream (+) | Sauvegarde l'ensemble dans un flux
SetCapacity (-) | Modifie la capacité du tableau interne
Subtract (+) | Opérateur - Calcule la soustraction de deux ensemble
Union (+) | Opérateur + Calcule l'union de deux ensemble

Properties
Property | Description
Capacity (+) | Capacité du tableau interne
IntervalCount (+) | Nombre d'intervalles
Intervals (+) | Tableau zero-based des intervalles contenus dans l'ensemble
IsEmpty (+) | Indique si l'ensemble est vide
Modified (+) | Indique si a été modifié

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TIntegerInterval)
Next (TScIntegerSetEnumerator)


Sepi

Sepi
Previous
Next (FIntervals)

Name
FIntervalCount

Parent
TScIntegerSet

Visibility
PRIVATE

Description
Nombre d'intervalles

Source code
FIntervalCount : Integer

Sepi
Class Tree
Index
Previous
Next (FIntervals)


Sepi

Sepi
Previous (FIntervalCount)
Next (FModified)

Name
FIntervals

Parent
TScIntegerSet

Visibility
PRIVATE

Description
Intervalles de valeurs contenues

Source code
FIntervals : TIntegerIntervalDynArray

Sepi
Class Tree
Index
Previous (FIntervalCount)
Next (FModified)


Sepi

Sepi
Previous (FIntervals)
Next

Name
FModified

Parent
TScIntegerSet

Visibility
PRIVATE

Description
Indique si a été modifié

Source code
FModified : Boolean

Sepi
Class Tree
Index
Previous (FIntervals)
Next


Sepi

Sepi
Previous
Next (IntervalCount)

Name
Capacity

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Capacité du tableau interne

Source code
property Capacity : Integer read GetCapacity write SetCapacity

Read Access
GetCapacity

Write Access
SetCapacity

Sepi
Class Tree
Index
Previous
Next (IntervalCount)


Sepi

Sepi
Previous (Capacity)
Next (Intervals)

Name
IntervalCount

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Nombre d'intervalles

Source code
property IntervalCount : Integer read FIntervalCount

Read Access
FIntervalCount

Sepi
Class Tree
Index
Previous (Capacity)
Next (Intervals)


Sepi

Sepi
Previous (IntervalCount)
Next (IsEmpty)

Name
Intervals

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Tableau zero-based des intervalles contenus dans l'ensemble

Source code
property Intervals [ Index : Integer ] : TIntegerInterval read GetIntervals

Read Access
GetIntervals

Sepi
Class Tree
Index
Previous (IntervalCount)
Next (IsEmpty)


Sepi

Sepi
Previous (Intervals)
Next (Modified)

Name
IsEmpty

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Indique si l'ensemble est vide

Source code
property IsEmpty : Boolean read GetIsEmpty

Read Access
GetIsEmpty

Sepi
Class Tree
Index
Previous (Intervals)
Next (Modified)


Sepi

Sepi
Previous (IsEmpty)
Next

Name
Modified

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Indique si a été modifié

Source code
property Modified : Boolean read FModified write FModified

Read Access
FModified

Write Access
FModified

Sepi
Class Tree
Index
Previous (IsEmpty)
Next


Sepi

Sepi
Previous
Next (Assign)

Name
AddInterval

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Inclut toutes les valeurs d'un intervalle (fermé) dans l'ensemble

Source code
procedure AddInterval ( Lower , Higher : Integer )

Parameters
Parameter | Description
Lower : INTEGER | Borne inférieure de l'intervalle
Higher : INTEGER | Borne supérieure de l'intervalle

Sepi
Class Tree
Index
Previous
Next (Assign)


Sepi

Sepi
Previous (AddInterval)
Next (Clear)

Name
Assign

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Remplace le contenu de cet ensemble par un autre

Source code
procedure Assign ( Source : TScIntegerSet )

Parameters
Parameter | Description
Source : TScIntegerSet | Ensemble à recopier

Sepi
Class Tree
Index
Previous (AddInterval)
Next (Clear)


Sepi

Sepi
Previous (Assign)
Next (Clone)

Name
Clear

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Vide l'ensemble

Source code
procedure Clear

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Assign)
Next (Clone)


Sepi

Sepi
Previous (Clear)
Next (Create)

Name
Clone

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Crée une copie d'un ensemble d'entiers

Source code
constructor Clone ( Source : TScIntegerSet )

Parameters
Parameter | Description
Source : TScIntegerSet | Ensemble d'entiers à copier

Sepi
Class Tree
Index
Previous (Clear)
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
Create

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Crée un nouvel ensemble d'entiers vide

Source code
constructor Create ; overload

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (CreateFromStream)

Name
Create

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Crée un nouvel ensemble d'entiers à partir d'un tableau d'entiers
Chaque valeur présente au moins une fois dans le tableau fera partie de
l'ensemble.

Source code
constructor Create ( const Values : array of Integer ) ; overload

Parameters
Parameter | Description
Values : INTEGER | Tableau de valeurs de type entier

Sepi
Class Tree
Index
Previous (Create)
Next (CreateFromStream)


Sepi

Sepi
Previous (Create)
Next (DeleteIntervals)

Name
CreateFromStream

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Crée un nouvel ensemble d'entiers à partir d'un flux

Source code
constructor CreateFromStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux source

Sepi
Class Tree
Index
Previous (Create)
Next (DeleteIntervals)


Sepi

Sepi
Previous (CreateFromStream)
Next (Equal)

Name
DeleteIntervals

Parent
TScIntegerSet

Visibility
PROTECTED

Description
Retire une plage d'intervalles du tableau interne

Source code
procedure DeleteIntervals ( LowerIndex , UpperIndex : Integer )

Parameters
Parameter | Description
LowerIndex : INTEGER | Index bas de l'intervalle à retirer (compris)
UpperIndex : INTEGER | Index supérieur de l'intervalle à retirer (non compris)

Sepi
Class Tree
Index
Previous (CreateFromStream)
Next (Equal)


Sepi

Sepi
Previous (DeleteIntervals)
Next (Exclude)

Name
Equal

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Détermine si deux ensembles sont égaux

Source code
function Equal ( Right : TScIntegerSet ) : Boolean

Parameters
Parameter | Description
Right : TScIntegerSet | Opérande de droite

Return
Types | Description
BOOLEAN | True si les ensembles sont égaux, False sinon

Sepi
Class Tree
Index
Previous (DeleteIntervals)
Next (Exclude)


Sepi

Sepi
Previous (Equal)
Next (Exists)

Name
Exclude

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Retire une valeur de l'ensemble, si elle y était

Source code
procedure Exclude ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Valeur à retirer

Sepi
Class Tree
Index
Previous (Equal)
Next (Exists)


Sepi

Sepi
Previous (Exclude)
Next (FindInterval)

Name
Exists

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Détermine si l'ensemble contient une valeur particulière

Source code
function Exists ( Value : Integer ) : Boolean

Parameters
Parameter | Description
Value : INTEGER | Valeur à tester

Return
Types | Description
BOOLEAN | True si l'ensemble contient Value, False sinon

Sepi
Class Tree
Index
Previous (Exclude)
Next (FindInterval)


Sepi

Sepi
Previous (Exists)
Next (GetCapacity)

Name
FindInterval

Parent
TScIntegerSet

Visibility
PROTECTED

Description
Cherche la place de l'intervalle contenant une valeur dans le tableau interne

Source code
function FindInterval ( Value : Integer ; out Index : Integer ; First : Integer = 0 ; Last : Integer = - 1 ) : Boolean

Parameters
Parameter | Description
Value : INTEGER | Valeur à chercher
INDEX : INTEGER | Index où se trouve, ou où devrait se trouver, l'intervalle
First : INTEGER | Index du premier intervalle à considérer
Last : INTEGER | Index du dernier intervalle à considérer (-1 = dernier)

Return
Types | Description
BOOLEAN | True si l'intervalle a été trouvé, False sinon

Sepi
Class Tree
Index
Previous (Exists)
Next (GetCapacity)


Sepi

Sepi
Previous (FindInterval)
Next (GetEnumerator)

Name
GetCapacity

Parent
TScIntegerSet

Visibility
PRIVATE

Description
Capacité du tableau interne

Source code
function GetCapacity : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Capacité du tableau interne

Sepi
Class Tree
Index
Previous (FindInterval)
Next (GetEnumerator)


Sepi

Sepi
Previous (GetCapacity)
Next (GetIntervals)

Name
GetEnumerator

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Crée un énumérateur pour les valeurs contenues dans cet ensemble

Source code
function GetEnumerator : TScIntegerSetEnumerator

Parameters
Parameter Description

Return
Types | Description
TScIntegerSetEnumerator | Énumérateur des valeurs contenues dans cet ensemble

Sepi
Class Tree
Index
Previous (GetCapacity)
Next (GetIntervals)


Sepi

Sepi
Previous (GetEnumerator)
Next (GetIsEmpty)

Name
GetIntervals

Parent
TScIntegerSet

Visibility
PRIVATE

Description
Tableau zero-based des intervalles contenus dans l'ensemble

Source code
function GetIntervals ( Index : Integer ) : TIntegerInterval

Parameters
Parameter | Description
INDEX : INTEGER | Index d'un intervalle

Return
Types | Description
TIntegerInterval | Intervalle à l'index spécifié

Sepi
Class Tree
Index
Previous (GetEnumerator)
Next (GetIsEmpty)


Sepi

Sepi
Previous (GetIntervals)
Next (Grow)

Name
GetIsEmpty

Parent
TScIntegerSet

Visibility
PRIVATE

Description
Indique si l'ensemble est vide

Source code
function GetIsEmpty : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si l'ensemble est vide, False sinon

Sepi
Class Tree
Index
Previous (GetIntervals)
Next (Grow)


Sepi

Sepi
Previous (GetIsEmpty)
Next (Include)

Name
Grow

Parent
TScIntegerSet

Visibility
PROTECTED

Description
Agrandit le tableau interne

Source code
procedure Grow ( MinCount : Integer = 0 )

Parameters
Parameter | Description
MinCount : INTEGER | Nombre minimum nécessaire (défaut = 0)

Sepi
Class Tree
Index
Previous (GetIsEmpty)
Next (Include)


Sepi

Sepi
Previous (Grow)
Next (InsertIntervals)

Name
Include

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Ajoute une valeur dans l'ensemble, si elle n'y était pas encore

Source code
procedure Include ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Valeur à ajouter

Sepi
Class Tree
Index
Previous (Grow)
Next (InsertIntervals)


Sepi

Sepi
Previous (Include)
Next (Intersect)

Name
InsertIntervals

Parent
TScIntegerSet

Visibility
PROTECTED

Description
Insère des intervalles dans le tableau interne
Le nombre d'intervalles à insérer peut être négatif ; des intervalles sont
alors retirés depuis l'intervalle à Index-1 jusque celui à Index-Abs(Amount)
compris.

Source code
procedure InsertIntervals ( Index : Integer ; Amount : Integer = 1 )

Parameters
Parameter | Description
INDEX : INTEGER | Position où insérer des intervalles
Amount : INTEGER | Nombre d'intervalles à insérer (1 par défaut)

Sepi
Class Tree
Index
Previous (Include)
Next (Intersect)


Sepi

Sepi
Previous (InsertIntervals)
Next (LoadFromStream)

Name
Intersect

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Opérateur * Calcule l'intersection entre deux ensemble

Source code
procedure Intersect ( Values : TScIntegerSet )

Parameters
Parameter Description
Values : TScIntegerSet

Sepi
Class Tree
Index
Previous (InsertIntervals)
Next (LoadFromStream)


Sepi

Sepi
Previous (Intersect)
Next (RemoveInterval)

Name
LoadFromStream

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Charge l'ensemble depuis un flux

Source code
procedure LoadFromStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux source

Sepi
Class Tree
Index
Previous (Intersect)
Next (RemoveInterval)


Sepi

Sepi
Previous (LoadFromStream)
Next (SaveToStream)

Name
RemoveInterval

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Exclut toutes les valeurs d'un intervalle (fermé) de l'ensemble

Source code
procedure RemoveInterval ( Lower , Higher : Integer )

Parameters
Parameter | Description
Lower : INTEGER | Borne inférieure de l'intervalle
Higher : INTEGER | Borne supérieure de l'intervalle

Sepi
Class Tree
Index
Previous (LoadFromStream)
Next (SaveToStream)


Sepi

Sepi
Previous (RemoveInterval)
Next (SetCapacity)

Name
SaveToStream

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Sauvegarde l'ensemble dans un flux

Source code
procedure SaveToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (RemoveInterval)
Next (SetCapacity)


Sepi

Sepi
Previous (SaveToStream)
Next (Subtract)

Name
SetCapacity

Parent
TScIntegerSet

Visibility
PRIVATE

Description
Modifie la capacité du tableau interne

Source code
procedure SetCapacity ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Nouvelle capacité

Sepi
Class Tree
Index
Previous (SaveToStream)
Next (Subtract)


Sepi

Sepi
Previous (SetCapacity)
Next (Union)

Name
Subtract

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Opérateur - Calcule la soustraction de deux ensemble

Source code
procedure Subtract ( Values : TScIntegerSet )

Parameters
Parameter Description
Values : TScIntegerSet

Sepi
Class Tree
Index
Previous (SetCapacity)
Next (Union)


Sepi

Sepi
Previous (Subtract)
Next

Name
Union

Parent
TScIntegerSet

Visibility
PUBLIC

Description
Opérateur + Calcule l'union de deux ensemble

Source code
procedure Union ( Values : TScIntegerSet )

Parameters
Parameter Description
Values : TScIntegerSet

Sepi
Class Tree
Index
Previous (Subtract)
Next


Sepi

Sepi
Previous (TScIntegerSet)
Next

Name
TScIntegerSetEnumerator

Parent
ScIntegerSets

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Énumérateur des valeurs contenues dans un ensemble d'entiers

Members
Fields
Field | Description
FCurrent (-) | Valeur courante
FCurrentInterval (-) | Intervalle courante
FIntegerSet (-) | Ensemble d'entiers à énumérer

Methods
Method | Description
Create (+) | Crée l'énumérateur
GetCurrent (+) | Valeur courante
MoveNext (+) | Avance vers la valeur suivante

Properties
Property | Description
Current (+) | Valeur courante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScIntegerSet)
Next


Sepi

Sepi
Previous
Next (FCurrentInterval)

Name
FCurrent

Parent
TScIntegerSetEnumerator

Visibility
PRIVATE

Description
Valeur courante

Source code
FCurrent : Integer

Sepi
Class Tree
Index
Previous
Next (FCurrentInterval)


Sepi

Sepi
Previous (FCurrent)
Next (FIntegerSet)

Name
FCurrentInterval

Parent
TScIntegerSetEnumerator

Visibility
PRIVATE

Description
Intervalle courante

Source code
FCurrentInterval : Integer

Sepi
Class Tree
Index
Previous (FCurrent)
Next (FIntegerSet)


Sepi

Sepi
Previous (FCurrentInterval)
Next

Name
FIntegerSet

Parent
TScIntegerSetEnumerator

Visibility
PRIVATE

Description
Ensemble d'entiers à énumérer

Source code
FIntegerSet : TScIntegerSet

Sepi
Class Tree
Index
Previous (FCurrentInterval)
Next


Sepi

Sepi
Previous
Next

Name
Current

Parent
TScIntegerSetEnumerator

Visibility
PUBLIC

Description
Valeur courante

Source code
property Current : Integer read FCurrent

Read Access
FCurrent

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetCurrent)

Name
Create

Parent
TScIntegerSetEnumerator

Visibility
PUBLIC

Description
Crée l'énumérateur

Source code
constructor Create ( AIntegerSet : TScIntegerSet )

Parameters
Parameter | Description
AIntegerSet : TScIntegerSet | Ensemble d'entiers à énumérer

Sepi
Class Tree
Index
Previous
Next (GetCurrent)


Sepi

Sepi
Previous (Create)
Next (MoveNext)

Name
GetCurrent

Parent
TScIntegerSetEnumerator

Visibility
PUBLIC

Description
Valeur courante

Source code
function GetCurrent : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Valeur courante

Sepi
Class Tree
Index
Previous (Create)
Next (MoveNext)


Sepi

Sepi
Previous (GetCurrent)
Next

Name
MoveNext

Parent
TScIntegerSetEnumerator

Visibility
PUBLIC

Description
Avance vers la valeur suivante

Source code
function MoveNext : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il y a une nouvelle valeur, False si l'énumération est terminée

Sepi
Class Tree
Index
Previous (GetCurrent)
Next


Sepi

Sepi
Previous
Next

Name
TIntegerIntervalDynArray

Parent
ScIntegerSets

Visibility
PUBLIC

Description
Tableau dynamique d'intervalles fermés d'entiers

Source code
TIntegerIntervalDynArray = array of TIntegerInterval ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
IntInInterval

Parent
ScIntegerSets

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function IntInInterval ( Value : Integer ; const Interval : TIntegerInterval ) : Boolean ; inline

Parameters
Parameter | Description
Value : INTEGER | #Pas de TAG trouvé dans le code source#
Interval : TIntegerInterval | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ScIntegerSets)
Next (ScLists)

Name
ScInterfaces

Parent
Sepi

Description
#Pas de TAG trouvé dans le code source#

Author
#Pas de TAG trouvé dans le code source#

Version
#Pas de TAG trouvé dans le code source#

Classes
Class | Description
EDynamicIntfError (+) | Erreur liée à des interfaces liées dynamiquement
IDynamicallyLinkable (+) | Interface liable dynamiquement à un contrôleur
TDynamicallyLinkedObject (+) | Classe de base pour objets dont les interfaces seront liées dynamiquement
TDynamicInterface (+) | Élément interface dynamique d'un contrôleur
TDynamicIntfController (+) | Classe de base pour contrôleurs d'interfaces dynamiques

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScIntegerSets)
Next (ScLists)


Sepi

Sepi
Previous
Next (IDynamicallyLinkable)

Name
EDynamicIntfError

Parent
ScInterfaces

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Erreur liée à des interfaces liées dynamiquement

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (IDynamicallyLinkable)


Sepi

Sepi
Previous (EDynamicIntfError)
Next (TDynamicallyLinkedObject)

Name
IDynamicallyLinkable

Parent
ScInterfaces

Class Hierarchy
IInterface

Visibility
PUBLIC

Description
Interface liable dynamiquement à un contrôleur
Les objets implémentant cette interface peuvent être liés dynamiquement à
un contrôleur, pour une interface identifiée donnée. Ce contrôleur
implémentera dès ce moment l'interface identifiée, au travers de l'objet
lié.
Les méthodes AttachTo et DetachFrom ne doivent pas être appelées depuis le
code qui utilise de telles interfaces, mais plutôt par l'implémentation de
l'objet contrôleur.
Lorsqu'un objet est liée dynamique à un contrôleur, le compteur de
références de celui-ci doit comprendre le compteur de références de l'objet
lié. Par ailleurs, le contrôleur doit garantir que le compteur de référence
de l'objet lié ne tombera pas à 0 tant qu'il est lié.

Members
Methods
Method | Description
AttachTo (+) | Attache cet objet à un contrôleur
DetachFromController (+) | Détache cet objet de son contrôleur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EDynamicIntfError)
Next (TDynamicallyLinkedObject)


Sepi

Sepi
Previous
Next (DetachFromController)

Name
AttachTo

Parent
IDynamicallyLinkable

Visibility
PUBLIC

Description
Attache cet objet à un contrôleur
Cette méthode doit lier les compteurs de références de l'interface et de
son contrôleur de telle façon que le contrôleur restera en vie tant que
l'objet lié est en vie.

Exception
EDynamicIntfError L'objet a déjà un contrôleur

Source code
procedure AttachTo ( const Controller : IInterface )

Parameters
Parameter | Description
Controller : IInterface | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (DetachFromController)


Sepi

Sepi
Previous (AttachTo)
Next

Name
DetachFromController

Parent
IDynamicallyLinkable

Visibility
PUBLIC

Description
Détache cet objet de son contrôleur

Exception
EDynamicIntfError L'objet n'a pas de contrôleur

Source code
procedure DetachFromController

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AttachTo)
Next


Sepi

Sepi
Previous (IDynamicallyLinkable)
Next (TDynamicInterface)

Name
TDynamicallyLinkedObject

Parent
ScInterfaces

Class Hierarchy
TInterfacedObject,IInterface,IDynamicallyLinkable

Visibility
PUBLIC

Description
Classe de base pour objets dont les interfaces seront liées dynamiquement

Members
Fields
Field | Description
FControlCount (-) | Nombre de fois qu'il est attaché au contrôleur
FController (-) | Référence faible au contrôleur

Methods
Method | Description
AttachTo (#) | [@inheritDoc]
DetachFromController (#) | [@inheritDoc]
GetController (-) | Contrôleur
QueryInterface (#) | [@inheritDoc]
_AddRef (#) | [@inheritDoc]
_Release (#) | [@inheritDoc]

Properties
Property | Description
Controller (#) | Contrôleur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (IDynamicallyLinkable)
Next (TDynamicInterface)


Sepi

Sepi
Previous
Next (FController)

Name
FControlCount

Parent
TDynamicallyLinkedObject

Visibility
PRIVATE

Description
Nombre de fois qu'il est attaché au contrôleur

Source code
FControlCount : Integer

Sepi
Class Tree
Index
Previous
Next (FController)


Sepi

Sepi
Previous (FControlCount)
Next

Name
FController

Parent
TDynamicallyLinkedObject

Visibility
PRIVATE

Description
Référence faible au contrôleur

Source code
FController : Pointer

Sepi
Class Tree
Index
Previous (FControlCount)
Next


Sepi

Sepi
Previous
Next

Name
Controller

Parent
TDynamicallyLinkedObject

Visibility
PROTECTED

Description
Contrôleur

Source code
property Controller : IInterface read GetController

Read Access
GetController

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (DetachFromController)

Name
AttachTo

Parent
TDynamicallyLinkedObject

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachTo ( const Controller : IInterface ) ; virtual

Parameters
Parameter | Description
Controller : IInterface | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (DetachFromController)


Sepi

Sepi
Previous (AttachTo)
Next (GetController)

Name
DetachFromController

Parent
TDynamicallyLinkedObject

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure DetachFromController ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AttachTo)
Next (GetController)


Sepi

Sepi
Previous (DetachFromController)
Next (QueryInterface)

Name
GetController

Parent
TDynamicallyLinkedObject

Visibility
PRIVATE

Description
Contrôleur

Source code
function GetController : IInterface

Parameters
Parameter Description

Return
Types | Description
IInterface | Contrôleur

Sepi
Class Tree
Index
Previous (DetachFromController)
Next (QueryInterface)


Sepi

Sepi
Previous (GetController)
Next (_AddRef)

Name
QueryInterface

Parent
TDynamicallyLinkedObject

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; virtual ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetController)
Next (_AddRef)


Sepi

Sepi
Previous (QueryInterface)
Next (_Release)

Name
_AddRef

Parent
TDynamicallyLinkedObject

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function _AddRef : Integer ; stdcall

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (QueryInterface)
Next (_Release)


Sepi

Sepi
Previous (_AddRef)
Next

Name
_Release

Parent
TDynamicallyLinkedObject

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function _Release : Integer ; stdcall

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (_AddRef)
Next


Sepi

Sepi
Previous (TDynamicallyLinkedObject)
Next (TDynamicIntfController)

Name
TDynamicInterface

Parent
ScInterfaces

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Élément interface dynamique d'un contrôleur

Members
Fields
Field | Description
IID (*) | #No TAG found in source code#
Intf (*) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDynamicallyLinkedObject)
Next (TDynamicIntfController)


Sepi

Sepi
Previous
Next (Intf)

Name
IID

Parent
TDynamicInterface

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
IID : TGUID

Sepi
Class Tree
Index
Previous
Next (Intf)


Sepi

Sepi
Previous (IID)
Next

Name
Intf

Parent
TDynamicInterface

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Intf : IDynamicallyLinkable

Sepi
Class Tree
Index
Previous (IID)
Next


Sepi

Sepi
Previous (TDynamicInterface)
Next

Name
TDynamicIntfController

Parent
ScInterfaces

Class Hierarchy
TInterfacedObject,IInterface

Visibility
PUBLIC

Description
Classe de base pour contrôleurs d'interfaces dynamiques

Members
Fields
Field | Description
FDestroying (-) | #No TAG found in source code#
FInterfaces (-) | Interfaces liées

Methods
Method | Description
Attach (#) | Attache une interface dynamique
BeforeDestruction (+) | [@inheritDoc]
Detach (#) | Détache une interface dynamique identifiée par son ID
Find (-) | Cherche un enregistrement d'interface pour un GUID donné
GetDynamicInterfaces (-) | Tableau zero-based des interfaces dynamiques recensées
GetDynamicIntfCount (-) | Nombre d'interfaces dynamiques recensées
InternalAttach (-) | Attache une interface dynamique
InternalDetach (-) | Détache une interface dynamique identifiée par son index
QueryInterface (#) | [@inheritDoc]
_AddRef (#) | [@inheritDoc]
_Release (#) | [@inheritDoc]

Properties
Property | Description
Destroying (#) | #No TAG found in source code#
DynamicInterfaces (#) | Tableau zero-based des interfaces dynamiques recensées
DynamicIntfCount (#) | Nombre d'interfaces dynamiques recensées

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDynamicInterface)
Next


Sepi

Sepi
Previous
Next (FInterfaces)

Name
FDestroying

Parent
TDynamicIntfController

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FDestroying : Boolean

Sepi
Class Tree
Index
Previous
Next (FInterfaces)


Sepi

Sepi
Previous (FDestroying)
Next

Name
FInterfaces

Parent
TDynamicIntfController

Visibility
PRIVATE

Description
Interfaces liées

Source code
FInterfaces : array of TDynamicInterface

Sepi
Class Tree
Index
Previous (FDestroying)
Next


Sepi

Sepi
Previous
Next (DynamicInterfaces)

Name
Destroying

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Destroying : Boolean read FDestroying

Read Access
FDestroying

Sepi
Class Tree
Index
Previous
Next (DynamicInterfaces)


Sepi

Sepi
Previous (Destroying)
Next (DynamicIntfCount)

Name
DynamicInterfaces

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
Tableau zero-based des interfaces dynamiques recensées

Source code
property DynamicInterfaces [ Index : Integer ] : TGUID read GetDynamicInterfaces

Read Access
GetDynamicInterfaces

Sepi
Class Tree
Index
Previous (Destroying)
Next (DynamicIntfCount)


Sepi

Sepi
Previous (DynamicInterfaces)
Next

Name
DynamicIntfCount

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
Nombre d'interfaces dynamiques recensées

Source code
property DynamicIntfCount : Integer read GetDynamicIntfCount

Read Access
GetDynamicIntfCount

Sepi
Class Tree
Index
Previous (DynamicInterfaces)
Next


Sepi

Sepi
Previous
Next (BeforeDestruction)

Name
Attach

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
Attache une interface dynamique

Source code
procedure Attach ( const IID : TGUID ; const Intf : IDynamicallyLinkable )

Parameters
Parameter | Description
IID : TGUID | ID de l'interface à attacher
Intf : IDynamicallyLinkable | Interface à lier

Sepi
Class Tree
Index
Previous
Next (BeforeDestruction)


Sepi

Sepi
Previous (Attach)
Next (Detach)

Name
BeforeDestruction

Parent
TDynamicIntfController

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Attach)
Next (Detach)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Find)

Name
Detach

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
Détache une interface dynamique identifiée par son ID

Source code
procedure Detach ( const IID : TGUID )

Parameters
Parameter | Description
IID : TGUID | ID de l'interface à détacher

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Find)


Sepi

Sepi
Previous (Detach)
Next (GetDynamicInterfaces)

Name
Find

Parent
TDynamicIntfController

Visibility
PRIVATE

Description
Cherche un enregistrement d'interface pour un GUID donné

Source code
function Find ( const IID : TGUID ) : Integer

Parameters
Parameter | Description
IID : TGUID | ID de l'interface recherchée

Return
Types | Description
INTEGER | True si trouvé, False sinon

Sepi
Class Tree
Index
Previous (Detach)
Next (GetDynamicInterfaces)


Sepi

Sepi
Previous (Find)
Next (GetDynamicIntfCount)

Name
GetDynamicInterfaces

Parent
TDynamicIntfController

Visibility
PRIVATE

Description
Tableau zero-based des interfaces dynamiques recensées

Source code
function GetDynamicInterfaces ( Index : Integer ) : TGUID

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'interface

Return
Types | Description
TGUID | ID de l'interface

Sepi
Class Tree
Index
Previous (Find)
Next (GetDynamicIntfCount)


Sepi

Sepi
Previous (GetDynamicInterfaces)
Next (InternalAttach)

Name
GetDynamicIntfCount

Parent
TDynamicIntfController

Visibility
PRIVATE

Description
Nombre d'interfaces dynamiques recensées

Source code
function GetDynamicIntfCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'interfaces dynamiques recensées

Sepi
Class Tree
Index
Previous (GetDynamicInterfaces)
Next (InternalAttach)


Sepi

Sepi
Previous (GetDynamicIntfCount)
Next (InternalDetach)

Name
InternalAttach

Parent
TDynamicIntfController

Visibility
PRIVATE

Description
Attache une interface dynamique

Source code
procedure InternalAttach ( Index : Integer ; const IID : TGUID ; const Intf : IDynamicallyLinkable )

Parameters
Parameter | Description
INDEX : INTEGER | Index où stocker l'interface dynamique
IID : TGUID | ID de l'interface à attacher
Intf : IDynamicallyLinkable | Interface à lier

Sepi
Class Tree
Index
Previous (GetDynamicIntfCount)
Next (InternalDetach)


Sepi

Sepi
Previous (InternalAttach)
Next (QueryInterface)

Name
InternalDetach

Parent
TDynamicIntfController

Visibility
PRIVATE

Description
Détache une interface dynamique identifiée par son index

Source code
procedure InternalDetach ( Index : Integer )

Parameters
Parameter | Description
INDEX : INTEGER | Index où est sockée l'interface dynamique

Sepi
Class Tree
Index
Previous (InternalAttach)
Next (QueryInterface)


Sepi

Sepi
Previous (InternalDetach)
Next (_AddRef)

Name
QueryInterface

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; virtual ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InternalDetach)
Next (_AddRef)


Sepi

Sepi
Previous (QueryInterface)
Next (_Release)

Name
_AddRef

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function _AddRef : Integer ; stdcall

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (QueryInterface)
Next (_Release)


Sepi

Sepi
Previous (_AddRef)
Next

Name
_Release

Parent
TDynamicIntfController

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function _Release : Integer ; stdcall

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (_AddRef)
Next


Sepi

Sepi
Previous (ScInterfaces)
Next (ScLOGFile)

Name
ScLists

Parent
Sepi

Description
Définit des classes de listes diverses

Author
sjrd

Version
1.0

Types
Type | Description
TValueBucketEvent (+) | Méthode de call-back pour la méthode ForEach de TCustomValueBucketList
TValueBucketProc (+) | Procédure de call-back pour la méthode ForEach de TCustomValueBucketList

Constants
Constant Description

Variables
Variable | Description
AppParams (+) | Liste des paramètres envoyés à l'application

Classes
Class | Description
EIntListError (+) | Exception déclenchée lors d'une erreur de liste d'entiers
StringsOps (+) | Classe utilitaire avec des méthodes avancées de gestion de listes de chaînes
TCompareStrings (+) | Classe purement abstraite rendant publique la méthode CompareStrings
TCustomValueBucketList (+) | Classe de base pour les tables associatives hashées par valeur
TExtendedList (+) | Gère une liste de Extended
TIntegerList (+) | Gère une liste d'entiers signés
TScList (+) | Classe abstraite de base pour la création de listes
TScStrings (+) | Extension de TStringList y ajoutant quelques fonctionnalités
TScWaitingObjectQueue (+) | File d'attente d'objets
TScWaitingQueue (+) | File d'attente
TUnsignedIntList (+) | Gère une liste d'entiers non signés
TValueBucketList (+) | Table associative hashées par valeur générique

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScInterfaces)
Next (ScLOGFile)


Sepi

Sepi
Previous
Next (StringsOps)

Name
EIntListError

Parent
ScLists

Class Hierarchy
EListError

Visibility
PUBLIC

Description
Exception déclenchée lors d'une erreur de liste d'entiers

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (StringsOps)


Sepi

Sepi
Previous (EIntListError)
Next (TCompareStrings)

Name
StringsOps

Parent
ScLists

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe utilitaire avec des méthodes avancées de gestion de listes de chaînes
Propose une série de méthodes pouvant être appliquée à des instances de
TStrings (toutes les méthodes de recherche respectent les règles de
comparaison de la liste concernée)

Members
Methods
Method | Description
AddFrom (+) | Ajoute à une liste de chaînes des chaînes d'une autre liste
AddFromString (+) | Découpe une chaîne en sous-chaînes et ajoute ces sous-chaînes à une liste
CopyFrom (+) | Remplit une liste de chaînes avec des chaînes d'une autre liste
FindAtPos (+) | Recherche une sous-chaîne à une position spécifiée les chaînes d'une liste
FindFirstWord (+) | Recherche un mot en première position d'une chaîne d'une liste
FindText (+) | Recherche un texte à l'intérieur des chaînes d'une liste
FromString (+) | Découpe une chaîne en sous-chaînes et remplit une liste de ces sous-chaînes
IndexOf (+) | Recherche une chaîne dans une liste de chaînes

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EIntListError)
Next (TCompareStrings)


Sepi

Sepi
Previous
Next (AddFromString)

Name
AddFrom

Parent
StringsOps

Visibility
PUBLIC

Description
Ajoute à une liste de chaînes des chaînes d'une autre liste
Ajoute à une liste de chaînes les chaînes d'une autre liste depuis un index et
sur un nombre spécifiés.

Source code
class procedure AddFrom ( Strings : TStrings ; Source : TStrings ; Index : Integer = 0 ; Count : Integer = - 1 )

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes concernée
Source : TStrings | Liste de chaînes à partir de laquelle recopier les chaînes
INDEX : INTEGER | Index où commencer la copie
Count : INTEGER | Nombre de chaînes à copier

Sepi
Class Tree
Index
Previous
Next (AddFromString)


Sepi

Sepi
Previous (AddFrom)
Next (CopyFrom)

Name
AddFromString

Parent
StringsOps

Visibility
PUBLIC

Description
Découpe une chaîne en sous-chaînes et ajoute ces sous-chaînes à une liste
Découpe une chaîne en sous-chaînes délimitées par des caractères spécifiés, et
ajoute ces sous-chaînes à une liste de chaînes.

Exception
EListError NotIn contient un nombre impair de caractères
EListError Delim et NotIn contiennent un même caractère

Source code
class procedure AddFromString ( Strings : TStrings ; const Str , Delim : string ; const NotIn : string = '' )

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes à laquelle ajouter les sous-chaînes
Str : STRING | Chaîne à découper
Delim : STRING | Caractères qui délimitent deux sous-chaînes
NotIn : STRING | Paires de caractères échappant les délimiteurs

Sepi
Class Tree
Index
Previous (AddFrom)
Next (CopyFrom)


Sepi

Sepi
Previous (AddFromString)
Next (FindAtPos)

Name
CopyFrom

Parent
StringsOps

Visibility
PUBLIC

Description
Remplit une liste de chaînes avec des chaînes d'une autre liste
Remplit une liste de chaînes avec les chaînes d'une autre liste depuis un
index et sur un nombre spécifiés.

Source code
class procedure CopyFrom ( Strings : TStrings ; Source : TStrings ; Index : Integer = 0 ; Count : Integer = - 1 )

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes concernée
Source : TStrings | Liste de chaînes à partir de laquelle recopier les chaînes
INDEX : INTEGER | Index où commencer la copie
Count : INTEGER | Nombre de chaînes à copier

Sepi
Class Tree
Index
Previous (AddFromString)
Next (FindAtPos)


Sepi

Sepi
Previous (CopyFrom)
Next (FindFirstWord)

Name
FindAtPos

Parent
StringsOps

Visibility
PUBLIC

Description
Recherche une sous-chaîne à une position spécifiée les chaînes d'une liste
Recherche une sous-chaîne débutant à une position spécifiée dans les chaînes
d'une liste, en débutant et s'arrêtant à des index spécifiés.

Source code
class function FindAtPos ( Strings : TStrings ; const SubStr : string ; Position : Integer = 1 ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes concernée
SubStr : STRING | Sous-chaîne à rechercher
Position : INTEGER | Position dans les chaînes où chercher la sous-chaîne
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne contenant Word, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (CopyFrom)
Next (FindFirstWord)


Sepi

Sepi
Previous (FindAtPos)
Next (FindText)

Name
FindFirstWord

Parent
StringsOps

Visibility
PUBLIC

Description
Recherche un mot en première position d'une chaîne d'une liste
Recherche un mot placé en première position d'une chaîne d'une liste (des
espaces peuvent se trouver devant), en débutant et s'arrêtant à des index
spécifiés.

Source code
class function FindFirstWord ( Strings : TStrings ; const Word : string ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes concernée
WORD : STRING | Mot à rechercher
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne contenant Word, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (FindAtPos)
Next (FindText)


Sepi

Sepi
Previous (FindFirstWord)
Next (FromString)

Name
FindText

Parent
StringsOps

Visibility
PUBLIC

Description
Recherche un texte à l'intérieur des chaînes d'une liste
Recherche un texte à l'intérieur des chaînes d'une liste, en débutant et
s'arrêtant à des index spécifiés.

Source code
class function FindText ( Strings : TStrings ; const Str : string ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes concernée
Str : STRING | Texte à rechercher
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne contenant Str, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (FindFirstWord)
Next (FromString)


Sepi

Sepi
Previous (FindText)
Next (IndexOf)

Name
FromString

Parent
StringsOps

Visibility
PUBLIC

Description
Découpe une chaîne en sous-chaînes et remplit une liste de ces sous-chaînes
Découpe une chaîne en sous-chaînes délimitées par des caractères spécifiés, et
remplit une liste de chaînes avec ces sous-chaînes.

Exception
EListError NotIn contient un nombre impair de caractères
EListError Delim et NotIn contiennent un même caractère

Source code
class procedure FromString ( Strings : TStrings ; const Str , Delim : string ; const NotIn : string = '' )

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes dans laquelle copier les sous-chaînes
Str : STRING | Chaîne à découper
Delim : STRING | Caractères qui délimitent deux sous-chaînes
NotIn : STRING | Paires de caractères échappant les délimiteurs

Sepi
Class Tree
Index
Previous (FindText)
Next (IndexOf)


Sepi

Sepi
Previous (FromString)
Next

Name
IndexOf

Parent
StringsOps

Visibility
PUBLIC

Description
Recherche une chaîne dans une liste de chaînes
Recherche une chaîne dans une liste de chaînes, en débutant et s'arrêtant à
des index spécifiés.

Source code
class function IndexOf ( Strings : TStrings ; const Str : string ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
Strings : TStrings | Liste de chaînes concernée
Str : STRING | Chaîne à rechercher
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne correspondant à Str, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (FromString)
Next


Sepi

Sepi
Previous (StringsOps)
Next (TCustomValueBucketList)

Name
TCompareStrings

Parent
ScLists

Class Hierarchy
TStrings

Visibility
PUBLIC

Description
Classe purement abstraite rendant publique la méthode CompareStrings
Rend publique la méthode CompareStrings afin de pouvoir l'utiliser pour
comparer deux chaînes en respectant les règles de comparaison d'une liste.
Cette classe ne doit pas être utilisée dans une autre optique.

Members
Methods
Method | Description
CompareStrings (+) | Compare deux chaînes de caractères

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (StringsOps)
Next (TCustomValueBucketList)


Sepi

Sepi
Previous
Next

Name
CompareStrings

Parent
TCompareStrings

Visibility
PUBLIC

Description
Compare deux chaînes de caractères

Source code
function CompareStrings ( const S1 , S2 : string ) : Integer ; override

Parameters
Parameter | Description
S1 : STRING | Première chaîne de caractères
S2 : STRING | Seconde chaîne de caractères

Return
Types Description
INTEGER 0 si les chaînes sont équivalente, un nombre positif si la première
est supérieure à la seconde, un nombre négatif dans le cas inverse

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TCompareStrings)
Next (TExtendedList)

Name
TCustomValueBucketList

Parent
ScLists

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe de base pour les tables associatives hashées par valeur
Au contraire de TCustomBucketList, et donc de TBucketList,
TCustomValueBucketList recherche et fait correspondre les clefs et les
données par valeur, et non par pointeur.
Pour cela, elle gère elle-même l'allocation des données en interne, et a
donc besoin des RTTI des types de clef et de données, ou à défaut de leurs
tailles (s'ils ne requièrent pas d'initialisation).

Members
Fields
Field | Description
FBucketCount (-) | Nombre de boîtes de hashage (défaut = 16)
FBuckets (-) | Boîtes de hashage
FClearing (-) | Indique si la liste est en train d'être vidée
FDataInfo (-) | RTTI du type des données (si need-init)
FDataSize (-) | Taille du type des données
FKeyInfo (-) | RTTI du type des clefs (si need-init)
FKeySize (-) | Taille du type des clefs
FListLocked (-) | Indique si la liste est verrouillée

Methods
Method | Description
AddData (#) | Ajoute une paire clef/données
AddItem (#) | Ajoute une paire clef/données dans une boîte donnée
Assign (#) | Copie le contenu d'une liste
AssignCallBack (-) | Call-back de ForEach utilisé par la méthode Assign
BucketFor (#) | Identifie la boîte dans laquelle ranger un élément donné
Clear (#) | Vide la liste
Create (-) | Crée une nouvelle instance de TCustomValueBucketList
Create (+) | Crée une nouvelle instance de TCustomValueBucketList
Create (+) | Crée une nouvelle instance de TCustomValueBucketList
Create (+) | Crée une nouvelle instance de TCustomValueBucketList
Create (+) | Crée une nouvelle instance de TCustomValueBucketList
DeleteItem (#) | Supprime une paire clef/données, identifiée par sa position
Destroy (+) | [@inheritDoc]
Exists (+) | Détermine si un clef est référencée dans la liste
ExtractData (#) | Retire une paire clef/données
ExtractItem (#) | Supprime une paire clef/données, identifiée par sa position
Find (+) | Recherche une clef dans la liste
FindItem (#) | Localise la boîte de hashage et l'index d'une paire par sa clef
ForEach (+) | Appelle une routine de call-back pour chaque paire clef/valeur de la liste
ForEach (+) | Appelle une méthode de call-back pour chaque paire clef/valeur de la liste
GetData (#) | Récupère les données liées à une clef
GetIsEmpty (-) | True si la liste est vide, False sinon
KeyEquals (#) | Détermine si deux clefs sont identiques
RemoveData (#) | Retire une paire clef/données
SetBucketCount (-) | Modifie le nombre de boîtes de hashage
SetData (#) | Modifie les données liées à une clef

Properties
Property | Description
BucketCount (#) | Nombre de boîtes de hashage (défaut = 16)
Buckets (#) | Boîtes de hashage
DataInfo (#) | RTTI du type des données (si need-init)
DataSize (#) | Taille du type des données
IsEmpty (+) | True si la liste est vide, False sinon
KeyInfo (#) | RTTI du type des clefs (si need-init)
KeySize (#) | Taille du type des clefs

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCompareStrings)
Next (TExtendedList)


Sepi

Sepi
Previous
Next (FBuckets)

Name
FBucketCount

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Nombre de boîtes de hashage (défaut = 16)

Source code
FBucketCount : Integer

Sepi
Class Tree
Index
Previous
Next (FBuckets)


Sepi

Sepi
Previous (FBucketCount)
Next (FClearing)

Name
FBuckets

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Boîtes de hashage

Source code
FBuckets : TBucketArray

Sepi
Class Tree
Index
Previous (FBucketCount)
Next (FClearing)


Sepi

Sepi
Previous (FBuckets)
Next (FDataInfo)

Name
FClearing

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Indique si la liste est en train d'être vidée

Source code
FClearing : Boolean

Sepi
Class Tree
Index
Previous (FBuckets)
Next (FDataInfo)


Sepi

Sepi
Previous (FClearing)
Next (FDataSize)

Name
FDataInfo

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
RTTI du type des données (si need-init)

Source code
FDataInfo : PTypeInfo

Sepi
Class Tree
Index
Previous (FClearing)
Next (FDataSize)


Sepi

Sepi
Previous (FDataInfo)
Next (FKeyInfo)

Name
FDataSize

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Taille du type des données

Source code
FDataSize : Integer

Sepi
Class Tree
Index
Previous (FDataInfo)
Next (FKeyInfo)


Sepi

Sepi
Previous (FDataSize)
Next (FKeySize)

Name
FKeyInfo

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
RTTI du type des clefs (si need-init)

Source code
FKeyInfo : PTypeInfo

Sepi
Class Tree
Index
Previous (FDataSize)
Next (FKeySize)


Sepi

Sepi
Previous (FKeyInfo)
Next (FListLocked)

Name
FKeySize

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Taille du type des clefs

Source code
FKeySize : Integer

Sepi
Class Tree
Index
Previous (FKeyInfo)
Next (FListLocked)


Sepi

Sepi
Previous (FKeySize)
Next

Name
FListLocked

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Indique si la liste est verrouillée

Source code
FListLocked : Boolean

Sepi
Class Tree
Index
Previous (FKeySize)
Next


Sepi

Sepi
Previous
Next (Buckets)

Name
BucketCount

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Nombre de boîtes de hashage (défaut = 16)

Source code
property BucketCount : Integer read FBucketCount write SetBucketCount

Read Access
FBucketCount

Write Access
SetBucketCount

Sepi
Class Tree
Index
Previous
Next (Buckets)


Sepi

Sepi
Previous (BucketCount)
Next (DataInfo)

Name
Buckets

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Boîtes de hashage

Source code
property Buckets : TBucketArray read FBuckets

Read Access
FBuckets

Sepi
Class Tree
Index
Previous (BucketCount)
Next (DataInfo)


Sepi

Sepi
Previous (Buckets)
Next (DataSize)

Name
DataInfo

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
RTTI du type des données (si need-init)

Source code
property DataInfo : PTypeInfo read FDataInfo

Read Access
FDataInfo

Sepi
Class Tree
Index
Previous (Buckets)
Next (DataSize)


Sepi

Sepi
Previous (DataInfo)
Next (IsEmpty)

Name
DataSize

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Taille du type des données

Source code
property DataSize : Integer read FDataSize

Read Access
FDataSize

Sepi
Class Tree
Index
Previous (DataInfo)
Next (IsEmpty)


Sepi

Sepi
Previous (DataSize)
Next (KeyInfo)

Name
IsEmpty

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
True si la liste est vide, False sinon

Source code
property IsEmpty : Boolean read GetIsEmpty

Read Access
GetIsEmpty

Sepi
Class Tree
Index
Previous (DataSize)
Next (KeyInfo)


Sepi

Sepi
Previous (IsEmpty)
Next (KeySize)

Name
KeyInfo

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
RTTI du type des clefs (si need-init)

Source code
property KeyInfo : PTypeInfo read FKeyInfo

Read Access
FKeyInfo

Sepi
Class Tree
Index
Previous (IsEmpty)
Next (KeySize)


Sepi

Sepi
Previous (KeyInfo)
Next

Name
KeySize

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Taille du type des clefs

Source code
property KeySize : Integer read FKeySize

Read Access
FKeySize

Sepi
Class Tree
Index
Previous (KeyInfo)
Next


Sepi

Sepi
Previous
Next (AddItem)

Name
AddData

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Ajoute une paire clef/données
Il ne peut pas encore exister de paire clef/données avec cette clef.

Exception
EListError Liste verrouillée lors d'une opération ForEach active
EListError Élément dupliqué

Source code
procedure AddData ( const Key , Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | Données associées à la clef Key

Sepi
Class Tree
Index
Previous
Next (AddItem)


Sepi

Sepi
Previous (AddData)
Next (Assign)

Name
AddItem

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Ajoute une paire clef/données dans une boîte donnée
AddItem ne vérifie pas quue la clef donnée doit effectivement se mettre dans
la boîte spécifiée. Assurez-vous d'appeler AddItem avec des données valides.

Source code
procedure AddItem ( Bucket : Integer ; const Key , Data ) ; virtual

Parameters
Parameter | Description
Bucket : INTEGER | Index de la boîte dans laquelle ajouter la paire
Key : Untyped | Clef
Data : Untyped | Données

Sepi
Class Tree
Index
Previous (AddData)
Next (Assign)


Sepi

Sepi
Previous (AddItem)
Next (AssignCallBack)

Name
Assign

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Copie le contenu d'une liste
La liste source doit avoir le même type d'éléments, sinon une exception
EConvertError sera déclenchée.

Exception
EConvertError La liste source n'a pas le même type d'élément

Source code
procedure Assign ( Source : TCustomValueBucketList ) ; virtual

Parameters
Parameter | Description
Source : TCustomValueBucketList | Liste source

Sepi
Class Tree
Index
Previous (AddItem)
Next (AssignCallBack)


Sepi

Sepi
Previous (Assign)
Next (BucketFor)

Name
AssignCallBack

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Call-back de ForEach utilisé par la méthode Assign

Source code
procedure AssignCallBack ( const Key , Data ; var Continue : Boolean )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | Données associées à la clef
Continue : BOOLEAN | Positionner à False pour interrompre l'énumération

Sepi
Class Tree
Index
Previous (Assign)
Next (BucketFor)


Sepi

Sepi
Previous (AssignCallBack)
Next (Clear)

Name
BucketFor

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Identifie la boîte dans laquelle ranger un élément donné
Les descendants de TCustomValueBucketList surchargent en général BucketFor
pour utiliser au mieux les spécificités du type de données traité, afin
d'avoir un remplissage optimal.
L'implémentation par défauut de BucketFor est de prendre les 4 premiers
octets de la clef, et de prendre le modulo par le nombre de boîtes de
hashage (BucketCount).

Source code
function BucketFor ( const Key ) : Cardinal ; virtual

Parameters
Parameter | Description
Key : Untyped | Clef

Return
Types | Description
CARDINAL | Numéro de la boîte de hashage pour la clef Key

Sepi
Class Tree
Index
Previous (AssignCallBack)
Next (Clear)


Sepi

Sepi
Previous (BucketFor)
Next (Create)

Name
Clear

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Vide la liste

Source code
procedure Clear

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BucketFor)
Next (Create)


Sepi

Sepi
Previous (Clear)
Next (Create)

Name
Create

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Crée une nouvelle instance de TCustomValueBucketList

Source code
constructor Create ( AKeySize : Integer ; AKeyInfo : PTypeInfo ; ADataSize : Integer ; ADataInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
AKeySize : INTEGER | Taille du type des clefs
AKeyInfo : PTypeInfo | RTTI du type des clefs
ADataSize : INTEGER | Taille du type des données
ADataInfo : PTypeInfo | RTTI du type des données

Sepi
Class Tree
Index
Previous (Clear)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TCustomValueBucketList

Source code
constructor Create ( AKeySize , ADataSize : Integer ) ; overload

Parameters
Parameter | Description
AKeySize : INTEGER | Taille du type des clefs
ADataSize : INTEGER | Taille du type des données

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TCustomValueBucketList

Source code
constructor Create ( AKeyInfo : PTypeInfo ; ADataSize : Integer ) ; overload

Parameters
Parameter | Description
AKeyInfo : PTypeInfo | RTTI du type des clefs
ADataSize : INTEGER | Taille du type des données

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TCustomValueBucketList

Source code
constructor Create ( AKeyInfo , ADataInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
AKeyInfo : PTypeInfo | RTTI du type des clefs
ADataInfo : PTypeInfo | RTTI du type des données

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (DeleteItem)

Name
Create

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TCustomValueBucketList

Source code
constructor Create ( AKeySize : Integer ; ADataInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
AKeySize : INTEGER | Taille du type des clefs
ADataInfo : PTypeInfo | RTTI du type des données

Sepi
Class Tree
Index
Previous (Create)
Next (DeleteItem)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
DeleteItem

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Supprime une paire clef/données, identifiée par sa position

Source code
procedure DeleteItem ( Bucket , Index : Integer ) ; virtual

Parameters
Parameter | Description
Bucket : INTEGER | Index de la boîte
INDEX : INTEGER | Index dans la boîte

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (DeleteItem)
Next (Exists)

Name
Destroy

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DeleteItem)
Next (Exists)


Sepi

Sepi
Previous (Destroy)
Next (ExtractData)

Name
Exists

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Détermine si un clef est référencée dans la liste

Source code
function Exists ( const Key ) : Boolean

Parameters
Parameter | Description
Key : Untyped | Clef à rechercher

Return
Types | Description
BOOLEAN | True si la clef est référencée, False sinon

Sepi
Class Tree
Index
Previous (Destroy)
Next (ExtractData)


Sepi

Sepi
Previous (Exists)
Next (ExtractItem)

Name
ExtractData

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Retire une paire clef/données
La paire ne doit pas nécessairement être présente dans la liste.

Exception
EListError Liste verrouillée lors d'une opération ForEach active

Source code
procedure ExtractData ( const Key ; out Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | En sortie : les données de la paire qui est supprimée

Sepi
Class Tree
Index
Previous (Exists)
Next (ExtractItem)


Sepi

Sepi
Previous (ExtractData)
Next (Find)

Name
ExtractItem

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Supprime une paire clef/données, identifiée par sa position

Source code
procedure ExtractItem ( Bucket , Index : Integer ; out Data ) ; virtual

Parameters
Parameter | Description
Bucket : INTEGER | Index de la boîte
INDEX : INTEGER | Index dans la boîte
Data : Untyped | En sortie : les données de la paire qui est supprimée

Sepi
Class Tree
Index
Previous (ExtractData)
Next (Find)


Sepi

Sepi
Previous (ExtractItem)
Next (FindItem)

Name
Find

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Recherche une clef dans la liste

Source code
function Find ( const Key ; out Data ) : Boolean

Parameters
Parameter | Description
Key : Untyped | Clef à rechercher
Data : Untyped | En sortie : données associées à la clef, si elle existe

Return
Types | Description
BOOLEAN | True si la clef a été trouvée, False sinon

Sepi
Class Tree
Index
Previous (ExtractItem)
Next (FindItem)


Sepi

Sepi
Previous (Find)
Next (ForEach)

Name
FindItem

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Localise la boîte de hashage et l'index d'une paire par sa clef

Source code
function FindItem ( const Key ; out Bucket , Index : Integer ) : Boolean ; virtual

Parameters
Parameter | Description
Key : Untyped | Clef à rechercher
Bucket : INTEGER | En sortie : boîte de hashage (même si FindItem renvoie False)
INDEX : INTEGER | En sortie : index dans la boîte (indéterminé si renvoie False)

Return
Types | Description
BOOLEAN | True si la paire a été trouvée, False sinon

Sepi
Class Tree
Index
Previous (Find)
Next (ForEach)


Sepi

Sepi
Previous (FindItem)
Next (ForEach)

Name
ForEach

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Appelle une routine de call-back pour chaque paire clef/valeur de la liste

Source code
function ForEach ( Proc : TValueBucketProc ; Info : Pointer = nil ) : Boolean ; overload

Parameters
Parameter | Description
Proc : TValueBucketProc | Routine de call-back
Info : Pointer | Pointeur libre retransmis dans le paramètre Info de Proc

Return
Types Description
BOOLEAN False si ForEach a été interrompu par le paramètre Continue,
True sinon

Sepi
Class Tree
Index
Previous (FindItem)
Next (ForEach)


Sepi

Sepi
Previous (ForEach)
Next (GetData)

Name
ForEach

Parent
TCustomValueBucketList

Visibility
PUBLIC

Description
Appelle une méthode de call-back pour chaque paire clef/valeur de la liste

Source code
function ForEach ( Event : TValueBucketEvent ) : Boolean ; overload

Parameters
Parameter | Description
Event : TValueBucketEvent | Méthode de call-back

Return
Types Description
BOOLEAN False si ForEach a été interrompu par le paramètre Continue,
True sinon

Sepi
Class Tree
Index
Previous (ForEach)
Next (GetData)


Sepi

Sepi
Previous (ForEach)
Next (GetIsEmpty)

Name
GetData

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Récupère les données liées à une clef

Exception
EListError Élément non trouvé

Source code
procedure GetData ( const Key ; out Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | En sortie : données associées à la clef Key

Sepi
Class Tree
Index
Previous (ForEach)
Next (GetIsEmpty)


Sepi

Sepi
Previous (GetData)
Next (KeyEquals)

Name
GetIsEmpty

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
True si la liste est vide, False sinon

Source code
function GetIsEmpty : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si la liste est vide, False sinon

Sepi
Class Tree
Index
Previous (GetData)
Next (KeyEquals)


Sepi

Sepi
Previous (GetIsEmpty)
Next (RemoveData)

Name
KeyEquals

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Détermine si deux clefs sont identiques
L'implémentation par défaut de KeyEquals teste si le contenu brut pointé
par Key1 et Key2 est équivalent sur KeySize octets.
Ce comportement doit être surchargé pour les types pour lesquels on ne peut
pas se fier qu'au contenu brut (chaînes, tableaux dynamiques, record non
packed avec des trous, etc.)

Source code
function KeyEquals ( const Key1 , Key2 ) : Boolean ; virtual

Parameters
Parameter | Description
Key1 : Untyped | Première clef
Key2 : Untyped | Seconde clef

Return
Types | Description
BOOLEAN | True si les clefs sont identiques, False sinon

Sepi
Class Tree
Index
Previous (GetIsEmpty)
Next (RemoveData)


Sepi

Sepi
Previous (KeyEquals)
Next (SetBucketCount)

Name
RemoveData

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Retire une paire clef/données
La paire ne doit pas nécessairement être présente dans la liste.

Exception
EListError Liste verrouillée lors d'une opération ForEach active

Source code
procedure RemoveData ( const Key )

Parameters
Parameter | Description
Key : Untyped | Clef

Sepi
Class Tree
Index
Previous (KeyEquals)
Next (SetBucketCount)


Sepi

Sepi
Previous (RemoveData)
Next (SetData)

Name
SetBucketCount

Parent
TCustomValueBucketList

Visibility
PRIVATE

Description
Modifie le nombre de boîtes de hashage
BucketCount ne peut être modifié que lorsque la liste est vide

Exception
EListError La liste n'est pas vide

Source code
procedure SetBucketCount ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Nouvelle valeur

Sepi
Class Tree
Index
Previous (RemoveData)
Next (SetData)


Sepi

Sepi
Previous (SetBucketCount)
Next

Name
SetData

Parent
TCustomValueBucketList

Visibility
PROTECTED

Description
Modifie les données liées à une clef
Il doit déjà exister une paire clef/données avec cette clef.

Exception
EListError Élément non trouvé

Source code
procedure SetData ( const Key , Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | Données associées à la clef Key

Sepi
Class Tree
Index
Previous (SetBucketCount)
Next


Sepi

Sepi
Previous (TCustomValueBucketList)
Next (TIntegerList)

Name
TExtendedList

Parent
ScLists

Class Hierarchy
TScList

Visibility
PUBLIC

Description
Gère une liste de Extended

Members
Methods
Method | Description
ADD (+) | Ajoute un élément à la liste
Assign (+) | Copie le contenu d'un autre objet similaire
AssignTo (#) | Copie les propriétés d'un objet dans l'objet destination
Create (+) | Crée une nouvelle instance de TExtendedList
CreateAssign (+) | Crée une nouvelle instance de TExtendedList, copie d'une autre source
Delete (+) | Supprime un élément de la liste
GetItems (-) | Tableau indexé par leurs index des éléments de la liste
Insert (+) | Insert un élément dans la liste à un index spécifié
IsAssignClass (#) | Indique si une classe est une classe d'assignation de la liste
READ (+) | Lit un élément de la liste à la position courante
SetItems (-) | Modifie le tableau indexé par leurs index des éléments de la liste
WRITE (+) | Écrit un élément dans la liste à la position courante

Properties
Property | Description
Items (+) | Tableau indexé par leurs index des éléments de la liste

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCustomValueBucketList)
Next (TIntegerList)


Sepi

Sepi
Previous
Next

Name
Items

Parent
TExtendedList

Visibility
PUBLIC

Description
Tableau indexé par leurs index des éléments de la liste

Source code
property Items [ Index : Integer ] : Extended read GetItems write SetItems ; default

Read Access
GetItems

Write Access
SetItems

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Assign)

Name
ADD

Parent
TExtendedList

Visibility
PUBLIC

Description
Ajoute un élément à la liste

Source code
function Add ( New : Extended ) : Integer

Parameters
Parameter | Description
New : EXTENDED | Élémént à ajouter

Return
Types | Description
INTEGER | Index de l'élément ajouté

Sepi
Class Tree
Index
Previous
Next (Assign)


Sepi

Sepi
Previous (ADD)
Next (AssignTo)

Name
Assign

Parent
TExtendedList

Visibility
PUBLIC

Description
Copie le contenu d'un autre objet similaire
Appelez Assign pour copier les propriétés ou d'autres attributs d'un objet sur
un autre.

Source code
procedure Assign ( Source : TPersistent ) ; override

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier

Sepi
Class Tree
Index
Previous (ADD)
Next (AssignTo)


Sepi

Sepi
Previous (Assign)
Next (Create)

Name
AssignTo

Parent
TExtendedList

Visibility
PROTECTED

Description
Copie les propriétés d'un objet dans l'objet destination

Source code
procedure AssignTo ( Dest : TPersistent ) ; override

Parameters
Parameter | Description
Dest : TPersistent | Objet destination dans lequel copier la liste

Sepi
Class Tree
Index
Previous (Assign)
Next (Create)


Sepi

Sepi
Previous (AssignTo)
Next (CreateAssign)

Name
Create

Parent
TExtendedList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TExtendedList

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AssignTo)
Next (CreateAssign)


Sepi

Sepi
Previous (Create)
Next (Delete)

Name
CreateAssign

Parent
TExtendedList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TExtendedList, copie d'une autre source

Source code
constructor CreateAssign ( Source : TPersistent )

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier

Sepi
Class Tree
Index
Previous (Create)
Next (Delete)


Sepi

Sepi
Previous (CreateAssign)
Next (GetItems)

Name
Delete

Parent
TExtendedList

Visibility
PUBLIC

Description
Supprime un élément de la liste

Source code
function Delete ( Index : Integer ) : Extended

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à supprimer

Return
Types | Description
EXTENDED | L'élément supprimé

Sepi
Class Tree
Index
Previous (CreateAssign)
Next (GetItems)


Sepi

Sepi
Previous (Delete)
Next (Insert)

Name
GetItems

Parent
TExtendedList

Visibility
PRIVATE

Description
Tableau indexé par leurs index des éléments de la liste

Exception
EListError Index de liste hors bornes

Source code
function GetItems ( Index : Integer ) : Extended

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à lire

Return
Types | Description
EXTENDED | Valeur de l'élément à l'index Index

Sepi
Class Tree
Index
Previous (Delete)
Next (Insert)


Sepi

Sepi
Previous (GetItems)
Next (IsAssignClass)

Name
Insert

Parent
TExtendedList

Visibility
PUBLIC

Description
Insert un élément dans la liste à un index spécifié

Source code
function Insert ( Index : Integer ; New : Extended ) : Integer

Parameters
Parameter | Description
INDEX : INTEGER | Index où insérer l'élément
New : EXTENDED | Élémént à insérer

Return
Types | Description
INTEGER | Index de l'élément inséré

Sepi
Class Tree
Index
Previous (GetItems)
Next (IsAssignClass)


Sepi

Sepi
Previous (Insert)
Next (READ)

Name
IsAssignClass

Parent
TExtendedList

Visibility
PROTECTED

Description
Indique si une classe est une classe d'assignation de la liste
Les classes descendantes de TScList peuvent surcharger cette méthode pour
indiquer quelles sont les classes d'assignation de la liste.

Source code
function IsAssignClass ( ScListClass : TScListClass ) : Boolean ; override

Parameters
Parameter | Description
ScListClass : TScListClass | Classe à tester

Return
Types | Description
BOOLEAN | True si ScListClass est une classe d'assignation, False sinon

Sepi
Class Tree
Index
Previous (Insert)
Next (READ)


Sepi

Sepi
Previous (IsAssignClass)
Next (SetItems)

Name
READ

Parent
TExtendedList

Visibility
PUBLIC

Description
Lit un élément de la liste à la position courante

Source code
function Read : Extended

Parameters
Parameter Description

Return
Types | Description
EXTENDED | L'élément lu

Sepi
Class Tree
Index
Previous (IsAssignClass)
Next (SetItems)


Sepi

Sepi
Previous (READ)
Next (WRITE)

Name
SetItems

Parent
TExtendedList

Visibility
PRIVATE

Description
Modifie le tableau indexé par leurs index des éléments de la liste

Exception
EListError Index de liste hors bornes

Source code
procedure SetItems ( Index : Integer ; New : Extended )

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à modifier
New : EXTENDED | Nouvelle valeur de l'élément à l'index Index

Sepi
Class Tree
Index
Previous (READ)
Next (WRITE)


Sepi

Sepi
Previous (SetItems)
Next

Name
WRITE

Parent
TExtendedList

Visibility
PUBLIC

Description
Écrit un élément dans la liste à la position courante

Source code
procedure Write ( New : Extended )

Parameters
Parameter | Description
New : EXTENDED | Élémént à écrire

Sepi
Class Tree
Index
Previous (SetItems)
Next


Sepi

Sepi
Previous (TExtendedList)
Next (TScList)

Name
TIntegerList

Parent
ScLists

Class Hierarchy
TScList

Visibility
PUBLIC

Description
Gère une liste d'entiers signés

Members
Methods
Method | Description
ADD (+) | Ajoute un élément à la liste
Assign (+) | Copie le contenu d'un autre objet similaire
AssignTo (#) | Copie les propriétés d'un objet dans l'objet destination
Create (+) | Crée une nouvelle instance de TIntegerList
CreateAssign (+) | Crée une nouvelle instance de TIntegerList, copie d'une autre source
Delete (+) | Supprime un élément de la liste
GetItems (-) | Tableau indexé par leurs index des éléments de la liste
Insert (+) | Insert un élément dans la liste à un index spécifié
IsAssignClass (#) | Indique si une classe est une classe d'assignation de la liste
MakeItGood (-) | S'assure que Value contient la valeur exacte selon la taille stockée
READ (+) | Lit un élément de la liste à la position courante
SetItems (-) | Modifie le tableau indexé par leurs index des éléments de la liste
WRITE (+) | Écrit un élément dans la liste à la position courante

Properties
Property | Description
Items (+) | Tableau indexé par leurs index des éléments de la liste

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TExtendedList)
Next (TScList)


Sepi

Sepi
Previous
Next

Name
Items

Parent
TIntegerList

Visibility
PUBLIC

Description
Tableau indexé par leurs index des éléments de la liste

Source code
property Items [ Index : Integer ] : Int64 read GetItems write SetItems ; default

Read Access
GetItems

Write Access
SetItems

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Assign)

Name
ADD

Parent
TIntegerList

Visibility
PUBLIC

Description
Ajoute un élément à la liste

Source code
function Add ( New : Int64 ) : Integer

Parameters
Parameter | Description
New : INT64 | Élémént à ajouter

Return
Types | Description
INTEGER | Index de l'élément ajouté

Sepi
Class Tree
Index
Previous
Next (Assign)


Sepi

Sepi
Previous (ADD)
Next (AssignTo)

Name
Assign

Parent
TIntegerList

Visibility
PUBLIC

Description
Copie le contenu d'un autre objet similaire
Appelez Assign pour copier les propriétés ou d'autres attributs d'un objet sur
un autre.

Source code
procedure Assign ( Source : TPersistent ) ; override

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier

Sepi
Class Tree
Index
Previous (ADD)
Next (AssignTo)


Sepi

Sepi
Previous (Assign)
Next (Create)

Name
AssignTo

Parent
TIntegerList

Visibility
PROTECTED

Description
Copie les propriétés d'un objet dans l'objet destination

Source code
procedure AssignTo ( Dest : TPersistent ) ; override

Parameters
Parameter | Description
Dest : TPersistent | Objet destination dans lequel copier la liste

Sepi
Class Tree
Index
Previous (Assign)
Next (Create)


Sepi

Sepi
Previous (AssignTo)
Next (CreateAssign)

Name
Create

Parent
TIntegerList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TIntegerList

Exception
EIntListError Taille d'entier incorrecte

Source code
constructor Create ( IntSize : Integer = 4 )

Parameters
Parameter | Description
IntSize : INTEGER | Taille en octets des entiers (entre 1 et 8 inclus)

Sepi
Class Tree
Index
Previous (AssignTo)
Next (CreateAssign)


Sepi

Sepi
Previous (Create)
Next (Delete)

Name
CreateAssign

Parent
TIntegerList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TIntegerList, copie d'une autre source

Exception
EIntListError Taille d'entier incorrecte

Source code
constructor CreateAssign ( Source : TPersistent ; IntSize : Integer = 4 )

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier
IntSize : INTEGER | Taille en octets des entiers (entre 1 et 8 inclus)

Sepi
Class Tree
Index
Previous (Create)
Next (Delete)


Sepi

Sepi
Previous (CreateAssign)
Next (GetItems)

Name
Delete

Parent
TIntegerList

Visibility
PUBLIC

Description
Supprime un élément de la liste

Source code
function Delete ( Index : Integer ) : Int64

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à supprimer

Return
Types | Description
INT64 | L'élément supprimé

Sepi
Class Tree
Index
Previous (CreateAssign)
Next (GetItems)


Sepi

Sepi
Previous (Delete)
Next (Insert)

Name
GetItems

Parent
TIntegerList

Visibility
PRIVATE

Description
Tableau indexé par leurs index des éléments de la liste

Exception
EListError Index de liste hors bornes

Source code
function GetItems ( Index : Integer ) : Int64

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à lire

Return
Types | Description
INT64 | Valeur de l'élément à l'index Index

Sepi
Class Tree
Index
Previous (Delete)
Next (Insert)


Sepi

Sepi
Previous (GetItems)
Next (IsAssignClass)

Name
Insert

Parent
TIntegerList

Visibility
PUBLIC

Description
Insert un élément dans la liste à un index spécifié

Source code
function Insert ( Index : Integer ; New : Int64 ) : Integer

Parameters
Parameter | Description
INDEX : INTEGER | Index où insérer l'élément
New : INT64 | Élémént à insérer

Return
Types | Description
INTEGER | Index de l'élément inséré

Sepi
Class Tree
Index
Previous (GetItems)
Next (IsAssignClass)


Sepi

Sepi
Previous (Insert)
Next (MakeItGood)

Name
IsAssignClass

Parent
TIntegerList

Visibility
PROTECTED

Description
Indique si une classe est une classe d'assignation de la liste
Les classes descendantes de TScList peuvent surcharger cette méthode pour
indiquer quelles sont les classes d'assignation de la liste.

Source code
function IsAssignClass ( ScListClass : TScListClass ) : Boolean ; override

Parameters
Parameter | Description
ScListClass : TScListClass | Classe à tester

Return
Types | Description
BOOLEAN | True si ScListClass est une classe d'assignation, False sinon

Sepi
Class Tree
Index
Previous (Insert)
Next (MakeItGood)


Sepi

Sepi
Previous (IsAssignClass)
Next (READ)

Name
MakeItGood

Parent
TIntegerList

Visibility
PRIVATE

Description
S'assure que Value contient la valeur exacte selon la taille stockée
Cette procédure remplit les octets non stockés de manière à transformer un
entier stocké sur un nombre quelconque d'octets en Int64 (sur 8 octets)

Source code
procedure MakeItGood ( var Value : Int64 )

Parameters
Parameter | Description
Value : INT64 | Valeur à traiter

Sepi
Class Tree
Index
Previous (IsAssignClass)
Next (READ)


Sepi

Sepi
Previous (MakeItGood)
Next (SetItems)

Name
READ

Parent
TIntegerList

Visibility
PUBLIC

Description
Lit un élément de la liste à la position courante

Source code
function Read : Int64

Parameters
Parameter Description

Return
Types | Description
INT64 | L'élément lu

Sepi
Class Tree
Index
Previous (MakeItGood)
Next (SetItems)


Sepi

Sepi
Previous (READ)
Next (WRITE)

Name
SetItems

Parent
TIntegerList

Visibility
PRIVATE

Description
Modifie le tableau indexé par leurs index des éléments de la liste

Exception
EListError Index de liste hors bornes

Source code
procedure SetItems ( Index : Integer ; New : Int64 )

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à modifier
New : INT64 | Nouvelle valeur de l'élément à l'index Index

Sepi
Class Tree
Index
Previous (READ)
Next (WRITE)


Sepi

Sepi
Previous (SetItems)
Next

Name
WRITE

Parent
TIntegerList

Visibility
PUBLIC

Description
Écrit un élément dans la liste à la position courante

Source code
procedure Write ( New : Int64 )

Parameters
Parameter | Description
New : INT64 | Élémént à écrire

Sepi
Class Tree
Index
Previous (SetItems)
Next


Sepi

Sepi
Previous (TIntegerList)
Next (TScStrings)

Name
TScList

Parent
ScLists

Class Hierarchy
TPersistent

Visibility
PUBLIC

Description
Classe abstraite de base pour la création de listes
Classe de base pour les listes dont les éléments sont de taille homogène
Ne créez pas d'instance de TScList, mais créez plutôt des instances de
ses classes descendantes.
Ne pas utiliser pour des listes de chaînes, de pointeurs ou d'objets ;
dans ces cas, utiliser respectivement TStringList (unité Classes), TList
(unité Classes) et TObjectList (unité Contnrs).

Members
Fields
Field | Description
FItemSize (-) | Taille en octets d'un élément de la liste
FStream (-) | Flux mémoire interne contenant la liste

Methods
Method | Description
Assign (+) | Copie le contenu d'un autre objet similaire
AssignTo (#) | Copie les propriétés d'un objet dans l'objet destination
Clear (+) | Vide la liste
Create (+) | Crée une nouvelle instance de TScList
DefineProperties (#) | Propose une interface pour les méthodes traitant des données non publiées
Destroy (+) | Détruit l'instance
GetCount (-) | Nombre d'éléments de la liste
GetHasMoreValue (-) | Indique s'il y a encore des éléments à lire
GetIndex (-) | Index interne de la liste
IsAssignClass (#) | Indique si une classe est une classe d'assignation de la liste
LoadFromFile (+) | Charge la liste depuis un fichier
LoadFromStream (+) | Charge la liste depuis un flux
Reset (+) | Remet à 0 l'index interne
SaveToFile (+) | Enregistre la liste dans un fichier
SaveToStream (+) | Enregistre la liste dans un flux
SetCount (-) | Modifie le nombre d'éléments de la liste
SetIndex (-) | Modifie l'index interne de la liste
_Add (#) | Ajoute un élément
_Delete (#) | Supprime un élément de la liste
_GetItems (#) | Lit un élément identifié par son index
_Insert (#) | Insert un nouvel élément à une position donnée
_Read (#) | Lit un élément de la liste à la position courante
_SetItems (#) | Modifie un élément identifié par son index
_Write (#) | Écrit un élément dans la liste à la position courante

Properties
Property | Description
Count (+) | Nombre d'éléments de la liste
HasMoreValue (+) | Indique s'il y a encore des éléments à lire
INDEX (+) | Index interne de la liste
ItemSize (#) | Taille en octets d'un élément de la liste

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TIntegerList)
Next (TScStrings)


Sepi

Sepi
Previous
Next (FStream)

Name
FItemSize

Parent
TScList

Visibility
PRIVATE

Description
Taille en octets d'un élément de la liste

Source code
FItemSize : Integer

Sepi
Class Tree
Index
Previous
Next (FStream)


Sepi

Sepi
Previous (FItemSize)
Next

Name
FStream

Parent
TScList

Visibility
PRIVATE

Description
Flux mémoire interne contenant la liste

Source code
FStream : TMemoryStream

Sepi
Class Tree
Index
Previous (FItemSize)
Next


Sepi

Sepi
Previous
Next (HasMoreValue)

Name
Count

Parent
TScList

Visibility
PUBLIC

Description
Nombre d'éléments de la liste

Source code
property Count : Integer read GetCount write SetCount

Read Access
GetCount

Write Access
SetCount

Sepi
Class Tree
Index
Previous
Next (HasMoreValue)


Sepi

Sepi
Previous (Count)
Next (INDEX)

Name
HasMoreValue

Parent
TScList

Visibility
PUBLIC

Description
Indique s'il y a encore des éléments à lire

Source code
property HasMoreValue : Boolean read GetHasMoreValue

Read Access
GetHasMoreValue

Sepi
Class Tree
Index
Previous (Count)
Next (INDEX)


Sepi

Sepi
Previous (HasMoreValue)
Next (ItemSize)

Name
INDEX

Parent
TScList

Visibility
PUBLIC

Description
Index interne de la liste

Source code
property Index : Integer read GetIndex write SetIndex

Read Access
GetIndex

Write Access
SetIndex

Sepi
Class Tree
Index
Previous (HasMoreValue)
Next (ItemSize)


Sepi

Sepi
Previous (INDEX)
Next

Name
ItemSize

Parent
TScList

Visibility
PROTECTED

Description
Taille en octets d'un élément de la liste

Source code
property ItemSize : Integer read FItemSize

Read Access
FItemSize

Sepi
Class Tree
Index
Previous (INDEX)
Next


Sepi

Sepi
Previous
Next (AssignTo)

Name
Assign

Parent
TScList

Visibility
PUBLIC

Description
Copie le contenu d'un autre objet similaire
Appelez Assign pour copier les propriétés ou d'autres attributs d'un objet sur
un autre.

Source code
procedure Assign ( Source : TPersistent ) ; override

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier

Sepi
Class Tree
Index
Previous
Next (AssignTo)


Sepi

Sepi
Previous (Assign)
Next (Clear)

Name
AssignTo

Parent
TScList

Visibility
PROTECTED

Description
Copie les propriétés d'un objet dans l'objet destination

Source code
procedure AssignTo ( Dest : TPersistent ) ; override

Parameters
Parameter | Description
Dest : TPersistent | Objet destination dans lequel copier la liste

Sepi
Class Tree
Index
Previous (Assign)
Next (Clear)


Sepi

Sepi
Previous (AssignTo)
Next (Create)

Name
Clear

Parent
TScList

Visibility
PUBLIC

Description
Vide la liste

Source code
procedure Clear

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AssignTo)
Next (Create)


Sepi

Sepi
Previous (Clear)
Next (DefineProperties)

Name
Create

Parent
TScList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TScList

Source code
constructor Create ( ItemSize : Integer )

Parameters
Parameter | Description
ItemSize : INTEGER | Taille en octets d'un élément de la liste

Sepi
Class Tree
Index
Previous (Clear)
Next (DefineProperties)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
DefineProperties

Parent
TScList

Visibility
PROTECTED

Description
Propose une interface pour les méthodes traitant des données non publiées

Source code
procedure DefineProperties ( Filer : TFiler ) ; override

Parameters
Parameter | Description
Filer : TFiler | Objet lecteur ou écrivain

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (DefineProperties)
Next (GetCount)

Name
Destroy

Parent
TScList

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DefineProperties)
Next (GetCount)


Sepi

Sepi
Previous (Destroy)
Next (GetHasMoreValue)

Name
GetCount

Parent
TScList

Visibility
PRIVATE

Description
Nombre d'éléments de la liste

Source code
function GetCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'éléments de la liste

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetHasMoreValue)


Sepi

Sepi
Previous (GetCount)
Next (GetIndex)

Name
GetHasMoreValue

Parent
TScList

Visibility
PRIVATE

Description
Indique s'il y a encore des éléments à lire

Source code
function GetHasMoreValue : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il y a encore des éléments à lire, False sinon

Sepi
Class Tree
Index
Previous (GetCount)
Next (GetIndex)


Sepi

Sepi
Previous (GetHasMoreValue)
Next (IsAssignClass)

Name
GetIndex

Parent
TScList

Visibility
PRIVATE

Description
Index interne de la liste

Source code
function GetIndex : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Index interne de la liste

Sepi
Class Tree
Index
Previous (GetHasMoreValue)
Next (IsAssignClass)


Sepi

Sepi
Previous (GetIndex)
Next (LoadFromFile)

Name
IsAssignClass

Parent
TScList

Visibility
PROTECTED

Description
Indique si une classe est une classe d'assignation de la liste
Les classes descendantes de TScList peuvent surcharger cette méthode pour
indiquer quelles sont les classes d'assignation de la liste.

Source code
function IsAssignClass ( ScListClass : TScListClass ) : Boolean ; virtual

Parameters
Parameter | Description
ScListClass : TScListClass | Classe à tester

Return
Types | Description
BOOLEAN | True si ScListClass est une classe d'assignation, False sinon

Sepi
Class Tree
Index
Previous (GetIndex)
Next (LoadFromFile)


Sepi

Sepi
Previous (IsAssignClass)
Next (LoadFromStream)

Name
LoadFromFile

Parent
TScList

Visibility
PUBLIC

Description
Charge la liste depuis un fichier
La liste doit avoir été enregistrée au moyen de SaveToFile.

Source code
procedure LoadFromFile ( const FileName : TFileName )

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier depuis lequel lire la liste

Sepi
Class Tree
Index
Previous (IsAssignClass)
Next (LoadFromStream)


Sepi

Sepi
Previous (LoadFromFile)
Next (Reset)

Name
LoadFromStream

Parent
TScList

Visibility
PUBLIC

Description
Charge la liste depuis un flux
La liste doit avoir été enregistrée au moyen de SaveToStream.

Source code
procedure LoadFromStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux depuis lequel lire la liste

Sepi
Class Tree
Index
Previous (LoadFromFile)
Next (Reset)


Sepi

Sepi
Previous (LoadFromStream)
Next (SaveToFile)

Name
Reset

Parent
TScList

Visibility
PUBLIC

Description
Remet à 0 l'index interne

Source code
procedure Reset

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (LoadFromStream)
Next (SaveToFile)


Sepi

Sepi
Previous (Reset)
Next (SaveToStream)

Name
SaveToFile

Parent
TScList

Visibility
PUBLIC

Description
Enregistre la liste dans un fichier
La liste pourra être relue avec LoadFromFile.

Source code
procedure SaveToFile ( const FileName : TFileName )

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier dans lequel enregistrer la liste

Sepi
Class Tree
Index
Previous (Reset)
Next (SaveToStream)


Sepi

Sepi
Previous (SaveToFile)
Next (SetCount)

Name
SaveToStream

Parent
TScList

Visibility
PUBLIC

Description
Enregistre la liste dans un flux
La liste pourra être relue avec LoadFromStream.

Source code
procedure SaveToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel enregistrer la liste

Sepi
Class Tree
Index
Previous (SaveToFile)
Next (SetCount)


Sepi

Sepi
Previous (SaveToStream)
Next (SetIndex)

Name
SetCount

Parent
TScList

Visibility
PRIVATE

Description
Modifie le nombre d'éléments de la liste

Source code
procedure SetCount ( New : Integer )

Parameters
Parameter | Description
New : INTEGER | Nouveau nombre d'éléments de la liste

Sepi
Class Tree
Index
Previous (SaveToStream)
Next (SetIndex)


Sepi

Sepi
Previous (SetCount)
Next (_Add)

Name
SetIndex

Parent
TScList

Visibility
PRIVATE

Description
Modifie l'index interne de la liste

Exception
EListError Index de liste hors bornes

Source code
procedure SetIndex ( New : Integer )

Parameters
Parameter | Description
New : INTEGER | Nouvelle valeur de l'index interne

Sepi
Class Tree
Index
Previous (SetCount)
Next (_Add)


Sepi

Sepi
Previous (SetIndex)
Next (_Delete)

Name
_Add

Parent
TScList

Visibility
PROTECTED

Description
Ajoute un élément

Source code
function _Add ( var Buffer ) : Integer

Parameters
Parameter | Description
Buffer : Untyped | Buffer non typé contenant l'élément à ajouter

Return
Types | Description
INTEGER | Index de l'élément ajouté

Sepi
Class Tree
Index
Previous (SetIndex)
Next (_Delete)


Sepi

Sepi
Previous (_Add)
Next (_GetItems)

Name
_Delete

Parent
TScList

Visibility
PROTECTED

Description
Supprime un élément de la liste

Exception
EListError Index de liste hors bornes

Source code
procedure _Delete ( AIndex : Integer ; var Buffer )

Parameters
Parameter | Description
AIndex : INTEGER | Index de l'élément à supprimer
Buffer : Untyped | Buffer non typé dans lequel enregistré l'élément supprimé

Sepi
Class Tree
Index
Previous (_Add)
Next (_GetItems)


Sepi

Sepi
Previous (_Delete)
Next (_Insert)

Name
_GetItems

Parent
TScList

Visibility
PROTECTED

Description
Lit un élément identifié par son index

Exception
EListError Index de liste hors bornes

Source code
procedure _GetItems ( AIndex : Integer ; var Buffer )

Parameters
Parameter | Description
AIndex : INTEGER | Index de l'élément à lire
Buffer : Untyped | Buffer non typé dans lequel enregistré l'élément lu

Sepi
Class Tree
Index
Previous (_Delete)
Next (_Insert)


Sepi

Sepi
Previous (_GetItems)
Next (_Read)

Name
_Insert

Parent
TScList

Visibility
PROTECTED

Description
Insert un nouvel élément à une position donnée

Exception
EListError Index de liste hors bornes

Source code
function _Insert ( AIndex : Integer ; var Buffer ) : Integer

Parameters
Parameter | Description
AIndex : INTEGER | Index où insérer l'élément
Buffer : Untyped | Buffer non typé contenant l'élément à insérer

Return
Types | Description
INTEGER | Index de l'élément inséré

Sepi
Class Tree
Index
Previous (_GetItems)
Next (_Read)


Sepi

Sepi
Previous (_Insert)
Next (_SetItems)

Name
_Read

Parent
TScList

Visibility
PROTECTED

Description
Lit un élément de la liste à la position courante

Source code
procedure _Read ( var Buffer )

Parameters
Parameter | Description
Buffer : Untyped | Buffer non typé dans lequel enregistrer l'élément lu

Sepi
Class Tree
Index
Previous (_Insert)
Next (_SetItems)


Sepi

Sepi
Previous (_Read)
Next (_Write)

Name
_SetItems

Parent
TScList

Visibility
PROTECTED

Description
Modifie un élément identifié par son index

Exception
EListError Index de liste hors bornes

Source code
procedure _SetItems ( AIndex : Integer ; var Buffer )

Parameters
Parameter | Description
AIndex : INTEGER | Index de l'élément à modifier
Buffer : Untyped | Buffer non typé contenant l'élément à écrire

Sepi
Class Tree
Index
Previous (_Read)
Next (_Write)


Sepi

Sepi
Previous (_SetItems)
Next

Name
_Write

Parent
TScList

Visibility
PROTECTED

Description
Écrit un élément dans la liste à la position courante
Si l'index interne est à la fin de la liste, celle-ci est agrandie pour
acceuillir le nouvel élément.

Source code
procedure _Write ( var Buffer )

Parameters
Parameter | Description
Buffer : Untyped | Buffer non typé contenant l'élément à écrire

Sepi
Class Tree
Index
Previous (_SetItems)
Next


Sepi

Sepi
Previous (TScList)
Next (TScWaitingObjectQueue)

Name
TScStrings

Parent
ScLists

Class Hierarchy
TStringList

Visibility
PUBLIC

Description
Extension de TStringList y ajoutant quelques fonctionnalités
Amélioration de TStringList pour lui ajouter les méthodes de StringsOps
ainsi qu'un index interne permettant de parcourir aisément toutes les
chaînes dans l'ordre

Members
Fields
Field | Description
FIndex (-) | Index interne

Methods
Method | Description
AddFrom (+) | Ajoute à la liste de chaînes des chaînes d'une autre liste
AddFromString (+) | Découpe une chaîne en sous-chaînes et ajoute ces sous-chaînes à la liste
CopyFrom (+) | Remplit la liste de chaînes avec des chaînes d'une autre liste
Create (+) | Crée une nouvelle instance de TScStrings
CreateAssign (+) | Crée une nouvelle instance de TScStrings assignée à partir d'une source
CreateFromFile (+) | Crée une nouvelle instance de TScStrings chargée à partir d'un fichier
CreateFromString (+) | Crée une nouvelle instance de TScStrings à partir d'une chaîne découpée
FindAtPos (+) | Recherche une sous-chaîne à une position spécifiée les chaînes de la liste
FindFirstWord (+) | Recherche un mot en première position d'une chaîne de la liste
FindText (+) | Recherche un texte à l'intérieur des chaînes de la liste
FromString (+) | Découpe une chaîne en sous-chaînes et remplit la liste de ces sous-chaînes
GetHasMoreString (-) | Indique s'il y a encore des chaînes à lire
IndexOfEx (+) | Recherche une chaîne dans la liste de chaînes
NextString (+) | Lit la chaîne suivante dans la liste de chaîne
Reset (+) | Remet à 0 l'index interne
SetIndex (-) | Modifie l'index interne

Properties
Property | Description
HasMoreString (+) | Indique s'il y a encore des chaînes à lire
INDEX (+) | Index interne

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScList)
Next (TScWaitingObjectQueue)


Sepi

Sepi
Previous
Next

Name
FIndex

Parent
TScStrings

Visibility
PRIVATE

Description
Index interne

Source code
FIndex : Integer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (INDEX)

Name
HasMoreString

Parent
TScStrings

Visibility
PUBLIC

Description
Indique s'il y a encore des chaînes à lire

Source code
property HasMoreString : Boolean read GetHasMoreString

Read Access
GetHasMoreString

Sepi
Class Tree
Index
Previous
Next (INDEX)


Sepi

Sepi
Previous (HasMoreString)
Next

Name
INDEX

Parent
TScStrings

Visibility
PUBLIC

Description
Index interne

Source code
property Index : Integer read FIndex write SetIndex

Read Access
FIndex

Write Access
SetIndex

Sepi
Class Tree
Index
Previous (HasMoreString)
Next


Sepi

Sepi
Previous
Next (AddFromString)

Name
AddFrom

Parent
TScStrings

Visibility
PUBLIC

Description
Ajoute à la liste de chaînes des chaînes d'une autre liste
Ajoute à la liste de chaînes les chaînes d'une autre liste depuis un index et
sur un nombre spécifiés.

Source code
procedure AddFrom ( Source : TStrings ; Index : Integer = 0 ; Count : Integer = - 1 )

Parameters
Parameter | Description
Source : TStrings | Liste de chaînes à partir de laquelle recopier les chaînes
INDEX : INTEGER | Index où commencer la copie
Count : INTEGER | Nombre de chaînes à copier

Sepi
Class Tree
Index
Previous
Next (AddFromString)


Sepi

Sepi
Previous (AddFrom)
Next (CopyFrom)

Name
AddFromString

Parent
TScStrings

Visibility
PUBLIC

Description
Découpe une chaîne en sous-chaînes et ajoute ces sous-chaînes à la liste
Découpe une chaîne en sous-chaînes délimitées par des caractères spécifiés, et
ajoute ces sous-chaînes à la liste de chaînes.

Exception
EListError NotIn contient un nombre impair de caractères
EListError Delim et NotIn contiennent un même caractère

Source code
procedure AddFromString ( const Str , Delim : string ; const NotIn : string = '' )

Parameters
Parameter | Description
Str : STRING | Chaîne à découper
Delim : STRING | Caractères qui délimitent deux sous-chaînes
NotIn : STRING | Paires de caractères échappant les délimiteurs

Sepi
Class Tree
Index
Previous (AddFrom)
Next (CopyFrom)


Sepi

Sepi
Previous (AddFromString)
Next (Create)

Name
CopyFrom

Parent
TScStrings

Visibility
PUBLIC

Description
Remplit la liste de chaînes avec des chaînes d'une autre liste
Remplit la liste de chaînes avec les chaînes d'une autre liste depuis un index
et sur un nombre spécifiés.

Source code
procedure CopyFrom ( Source : TStrings ; Index : Integer = 0 ; Count : Integer = - 1 )

Parameters
Parameter | Description
Source : TStrings | Liste de chaînes à partir de laquelle recopier les chaînes
INDEX : INTEGER | Index où commencer la copie
Count : INTEGER | Nombre de chaînes à copier

Sepi
Class Tree
Index
Previous (AddFromString)
Next (Create)


Sepi

Sepi
Previous (CopyFrom)
Next (CreateAssign)

Name
Create

Parent
TScStrings

Visibility
PUBLIC

Description
Crée une nouvelle instance de TScStrings

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CopyFrom)
Next (CreateAssign)


Sepi

Sepi
Previous (Create)
Next (CreateFromFile)

Name
CreateAssign

Parent
TScStrings

Visibility
PUBLIC

Description
Crée une nouvelle instance de TScStrings assignée à partir d'une source

Source code
constructor CreateAssign ( Source : TPersistent )

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier dans la liste de chaînes

Sepi
Class Tree
Index
Previous (Create)
Next (CreateFromFile)


Sepi

Sepi
Previous (CreateAssign)
Next (CreateFromString)

Name
CreateFromFile

Parent
TScStrings

Visibility
PUBLIC

Description
Crée une nouvelle instance de TScStrings chargée à partir d'un fichier

Source code
constructor CreateFromFile ( const FileName : TFileName )

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier à partir duquel charger la liste de chaînes

Sepi
Class Tree
Index
Previous (CreateAssign)
Next (CreateFromString)


Sepi

Sepi
Previous (CreateFromFile)
Next (FindAtPos)

Name
CreateFromString

Parent
TScStrings

Visibility
PUBLIC

Description
Crée une nouvelle instance de TScStrings à partir d'une chaîne découpée

Exception
EListError NotIn contient un nombre impair de caractères
EListError Delim et NotIn contiennent un même caractère

Source code
constructor CreateFromString ( const Str , Delim : string ; const NotIn : string = '' )

Parameters
Parameter | Description
Str : STRING | Chaîne à découper
Delim : STRING | Caractères qui délimitent deux sous-chaînes
NotIn : STRING | Paires de caractères échappant les délimiteurs

Sepi
Class Tree
Index
Previous (CreateFromFile)
Next (FindAtPos)


Sepi

Sepi
Previous (CreateFromString)
Next (FindFirstWord)

Name
FindAtPos

Parent
TScStrings

Visibility
PUBLIC

Description
Recherche une sous-chaîne à une position spécifiée les chaînes de la liste
Recherche une sous-chaîne débutant à une position spécifiée dans les chaînes
de la liste, en débutant et s'arrêtant à des index spécifiés.

Source code
function FindAtPos ( const SubStr : string ; Position : Integer = 1 ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
SubStr : STRING | Sous-chaîne à rechercher
Position : INTEGER | Position dans les chaînes où chercher la sous-chaîne
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne contenant Word, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (CreateFromString)
Next (FindFirstWord)


Sepi

Sepi
Previous (FindAtPos)
Next (FindText)

Name
FindFirstWord

Parent
TScStrings

Visibility
PUBLIC

Description
Recherche un mot en première position d'une chaîne de la liste
Recherche un mot placé en première position d'une chaîne de la liste (des
espaces peuvent se trouver devant), en débutant et s'arrêtant à des index
spécifiés.

Source code
function FindFirstWord ( const Word : string ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
WORD : STRING | Mot à rechercher
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne contenant Word, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (FindAtPos)
Next (FindText)


Sepi

Sepi
Previous (FindFirstWord)
Next (FromString)

Name
FindText

Parent
TScStrings

Visibility
PUBLIC

Description
Recherche un texte à l'intérieur des chaînes de la liste
Recherche un texte à l'intérieur des chaînes de la liste, en débutant et
s'arrêtant à des index spécifiés.

Source code
function FindText ( const Str : string ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
Str : STRING | Texte à rechercher
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne contenant Str, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (FindFirstWord)
Next (FromString)


Sepi

Sepi
Previous (FindText)
Next (GetHasMoreString)

Name
FromString

Parent
TScStrings

Visibility
PUBLIC

Description
Découpe une chaîne en sous-chaînes et remplit la liste de ces sous-chaînes
Découpe une chaîne en sous-chaînes délimitées par des caractères spécifiés, et
remplit la liste de chaînes avec ces sous-chaînes.

Exception
EListError NotIn contient un nombre impair de caractères
EListError Delim et NotIn contiennent un même caractère

Source code
procedure FromString ( const Str , Delim : string ; const NotIn : string = '' )

Parameters
Parameter | Description
Str : STRING | Chaîne à découper
Delim : STRING | Caractères qui délimitent deux sous-chaînes
NotIn : STRING | Paires de caractères échappant les délimiteurs

Sepi
Class Tree
Index
Previous (FindText)
Next (GetHasMoreString)


Sepi

Sepi
Previous (FromString)
Next (IndexOfEx)

Name
GetHasMoreString

Parent
TScStrings

Visibility
PRIVATE

Description
Indique s'il y a encore des chaînes à lire

Source code
function GetHasMoreString : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il y a encore des chaînes à lire, False sinon

Sepi
Class Tree
Index
Previous (FromString)
Next (IndexOfEx)


Sepi

Sepi
Previous (GetHasMoreString)
Next (NextString)

Name
IndexOfEx

Parent
TScStrings

Visibility
PUBLIC

Description
Recherche une chaîne dans la liste de chaînes
Recherche une chaîne dans la liste de chaînes, en débutant et s'arrêtant à
des index spécifiés.

Source code
function IndexOfEx ( const Str : string ; BeginSearchAt : Integer = 0 ; EndSearchAt : Integer = - 1 ) : Integer

Parameters
Parameter | Description
Str : STRING | Chaîne à rechercher
BeginSearchAt : INTEGER | Index à partir duquel chercher
EndSearchAt : INTEGER | Index jusqu'auquel chercher (jusqu'à la fin si -1)

Return
Types | Description
INTEGER | Index de la première chaîne correspondant à Str, ou -1 si non trouvée

Sepi
Class Tree
Index
Previous (GetHasMoreString)
Next (NextString)


Sepi

Sepi
Previous (IndexOfEx)
Next (Reset)

Name
NextString

Parent
TScStrings

Visibility
PUBLIC

Description
Lit la chaîne suivante dans la liste de chaîne

Source code
function NextString : string

Parameters
Parameter Description

Return
Types | Description
STRING | La chaîne suivante

Sepi
Class Tree
Index
Previous (IndexOfEx)
Next (Reset)


Sepi

Sepi
Previous (NextString)
Next (SetIndex)

Name
Reset

Parent
TScStrings

Visibility
PUBLIC

Description
Remet à 0 l'index interne

Source code
procedure Reset

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (NextString)
Next (SetIndex)


Sepi

Sepi
Previous (Reset)
Next

Name
SetIndex

Parent
TScStrings

Visibility
PRIVATE

Description
Modifie l'index interne

Source code
procedure SetIndex ( New : Integer )

Parameters
Parameter | Description
New : INTEGER | Nouvelle valeur de l'index interne

Sepi
Class Tree
Index
Previous (Reset)
Next


Sepi

Sepi
Previous (TScStrings)
Next (TScWaitingQueue)

Name
TScWaitingObjectQueue

Parent
ScLists

Class Hierarchy
TObjectQueue

Visibility
PUBLIC

Description
File d'attente d'objets
TScWaitingObjectQueue ajoute à TObjectQueue une méthode Cancel qui permet
de supprimer un objet de la liste, quel que soit sa position.

Members
Methods
Method | Description
Cancel (+) | Annule un objet de la file, en le supprimant

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScStrings)
Next (TScWaitingQueue)


Sepi

Sepi
Previous
Next

Name
Cancel

Parent
TScWaitingObjectQueue

Visibility
PUBLIC

Description
Annule un objet de la file, en le supprimant

Source code
procedure Cancel ( AObject : TObject )

Parameters
Parameter | Description
AObject : TObject | Objet à supprimer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TScWaitingObjectQueue)
Next (TUnsignedIntList)

Name
TScWaitingQueue

Parent
ScLists

Class Hierarchy
TQueue

Visibility
PUBLIC

Description
File d'attente
TScWaitingQueue ajoute à TQueue une méthode Cancel qui permet de supprimer
un élément de la liste, quelle que soit sa position.

Members
Methods
Method | Description
Cancel (+) | Annule un élément de la file, en le supprimant

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScWaitingObjectQueue)
Next (TUnsignedIntList)


Sepi

Sepi
Previous
Next

Name
Cancel

Parent
TScWaitingQueue

Visibility
PUBLIC

Description
Annule un élément de la file, en le supprimant

Source code
procedure Cancel ( AItem : Pointer )

Parameters
Parameter | Description
AItem : Pointer | Élément à supprimer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TScWaitingQueue)
Next (TValueBucketList)

Name
TUnsignedIntList

Parent
ScLists

Class Hierarchy
TScList

Visibility
PUBLIC

Description
Gère une liste d'entiers non signés

Members
Methods
Method | Description
ADD (+) | Ajoute un élément à la liste
Assign (+) | Copie le contenu d'un autre objet similaire
AssignTo (#) | Copie les propriétés d'un objet dans l'objet destination
Create (+) | Crée une nouvelle instance de TUnsignedIntList
CreateAssign (+) | Crée une nouvelle instance de TUnsignedIntList, copie d'une autre source
Delete (+) | Supprime un élément de la liste
GetItems (-) | Tableau indexé par leurs index des éléments de la liste
Insert (+) | Insert un élément dans la liste à un index spécifié
IsAssignClass (#) | Indique si une classe est une classe d'assignation de la liste
MakeItGood (-) | S'assure que Value contient la valeur exacte selon la taille stockée
READ (+) | Lit un élément de la liste à la position courante
SetItems (-) | Modifie le tableau indexé par leurs index des éléments de la liste
WRITE (+) | Écrit un élément dans la liste à la position courante

Properties
Property | Description
Items (+) | Tableau indexé par leurs index des éléments de la liste

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScWaitingQueue)
Next (TValueBucketList)


Sepi

Sepi
Previous
Next

Name
Items

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Tableau indexé par leurs index des éléments de la liste

Source code
property Items [ Index : Integer ] : LongWord read GetItems write SetItems ; default

Read Access
GetItems

Write Access
SetItems

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Assign)

Name
ADD

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Ajoute un élément à la liste

Source code
function Add ( New : LongWord ) : Integer

Parameters
Parameter | Description
New : LONGWORD | Élémént à ajouter

Return
Types | Description
INTEGER | Index de l'élément ajouté

Sepi
Class Tree
Index
Previous
Next (Assign)


Sepi

Sepi
Previous (ADD)
Next (AssignTo)

Name
Assign

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Copie le contenu d'un autre objet similaire
Appelez Assign pour copier les propriétés ou d'autres attributs d'un objet sur
un autre.

Source code
procedure Assign ( Source : TPersistent ) ; override

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier

Sepi
Class Tree
Index
Previous (ADD)
Next (AssignTo)


Sepi

Sepi
Previous (Assign)
Next (Create)

Name
AssignTo

Parent
TUnsignedIntList

Visibility
PROTECTED

Description
Copie les propriétés d'un objet dans l'objet destination

Source code
procedure AssignTo ( Dest : TPersistent ) ; override

Parameters
Parameter | Description
Dest : TPersistent | Objet destination dans lequel copier la liste

Sepi
Class Tree
Index
Previous (Assign)
Next (Create)


Sepi

Sepi
Previous (AssignTo)
Next (CreateAssign)

Name
Create

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TUnsignedIntList

Exception
EIntListError Taille d'entier incorrecte

Source code
constructor Create ( IntSize : Integer = 4 )

Parameters
Parameter | Description
IntSize : INTEGER | Taille en octets des entiers (entre 1 et 4 inclus)

Sepi
Class Tree
Index
Previous (AssignTo)
Next (CreateAssign)


Sepi

Sepi
Previous (Create)
Next (Delete)

Name
CreateAssign

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Crée une nouvelle instance de TUnsignedIntList, copie d'une autre source

Exception
EIntListError Taille d'entier incorrecte

Source code
constructor CreateAssign ( Source : TPersistent ; IntSize : Integer = 4 )

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier
IntSize : INTEGER | Taille en octets des entiers (entre 1 et 4 inclus)

Sepi
Class Tree
Index
Previous (Create)
Next (Delete)


Sepi

Sepi
Previous (CreateAssign)
Next (GetItems)

Name
Delete

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Supprime un élément de la liste

Source code
function Delete ( Index : Integer ) : LongWord

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à supprimer

Return
Types | Description
LONGWORD | L'élément supprimé

Sepi
Class Tree
Index
Previous (CreateAssign)
Next (GetItems)


Sepi

Sepi
Previous (Delete)
Next (Insert)

Name
GetItems

Parent
TUnsignedIntList

Visibility
PRIVATE

Description
Tableau indexé par leurs index des éléments de la liste

Exception
EListError Index de liste hors bornes

Source code
function GetItems ( Index : Integer ) : LongWord

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à lire

Return
Types | Description
LONGWORD | Valeur de l'élément à l'index Index

Sepi
Class Tree
Index
Previous (Delete)
Next (Insert)


Sepi

Sepi
Previous (GetItems)
Next (IsAssignClass)

Name
Insert

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Insert un élément dans la liste à un index spécifié

Source code
function Insert ( Index : Integer ; New : LongWord ) : Integer

Parameters
Parameter | Description
INDEX : INTEGER | Index où insérer l'élément
New : LONGWORD | Élémént à insérer

Return
Types | Description
INTEGER | Index de l'élément inséré

Sepi
Class Tree
Index
Previous (GetItems)
Next (IsAssignClass)


Sepi

Sepi
Previous (Insert)
Next (MakeItGood)

Name
IsAssignClass

Parent
TUnsignedIntList

Visibility
PROTECTED

Description
Indique si une classe est une classe d'assignation de la liste
Les classes descendantes de TScList peuvent surcharger cette méthode pour
indiquer quelles sont les classes d'assignation de la liste.

Source code
function IsAssignClass ( ScListClass : TScListClass ) : Boolean ; override

Parameters
Parameter | Description
ScListClass : TScListClass | Classe à tester

Return
Types | Description
BOOLEAN | True si ScListClass est une classe d'assignation, False sinon

Sepi
Class Tree
Index
Previous (Insert)
Next (MakeItGood)


Sepi

Sepi
Previous (IsAssignClass)
Next (READ)

Name
MakeItGood

Parent
TUnsignedIntList

Visibility
PRIVATE

Description
S'assure que Value contient la valeur exacte selon la taille stockée
Cette procédure remplit les octets non stockés de manière à transformer un
entier stocké sur un nombre quelconque d'octets en LongWord (sur 4 octets)

Source code
procedure MakeItGood ( var Value : LongWord )

Parameters
Parameter | Description
Value : LONGWORD | Valeur à traiter

Sepi
Class Tree
Index
Previous (IsAssignClass)
Next (READ)


Sepi

Sepi
Previous (MakeItGood)
Next (SetItems)

Name
READ

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Lit un élément de la liste à la position courante

Source code
function Read : LongWord

Parameters
Parameter Description

Return
Types | Description
LONGWORD | L'élément lu

Sepi
Class Tree
Index
Previous (MakeItGood)
Next (SetItems)


Sepi

Sepi
Previous (READ)
Next (WRITE)

Name
SetItems

Parent
TUnsignedIntList

Visibility
PRIVATE

Description
Modifie le tableau indexé par leurs index des éléments de la liste

Exception
EListError Index de liste hors bornes

Source code
procedure SetItems ( Index : Integer ; New : LongWord )

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'élément à modifier
New : LONGWORD | Nouvelle valeur de l'élément à l'index Index

Sepi
Class Tree
Index
Previous (READ)
Next (WRITE)


Sepi

Sepi
Previous (SetItems)
Next

Name
WRITE

Parent
TUnsignedIntList

Visibility
PUBLIC

Description
Écrit un élément dans la liste à la position courante

Source code
procedure Write ( New : LongWord )

Parameters
Parameter | Description
New : LONGWORD | Élémént à écrire

Sepi
Class Tree
Index
Previous (SetItems)
Next


Sepi

Sepi
Previous (TUnsignedIntList)
Next

Name
TValueBucketList

Parent
ScLists

Class Hierarchy
TCustomValueBucketList

Visibility
PUBLIC

Description
Table associative hashées par valeur générique
Au contraire de TBucketList, TValueBucketList recherche et fait
correspondre les clefs et les données par valeur, et non par pointeur.
Pour cela, elle gère elle-même l'allocation des données en interne, et a
donc besoin des RTTI des types de clef et de données, ou à défaut de leurs
tailles (s'ils ne requièrent pas d'initialisation).

Members
Methods
Method | Description
ADD (+) | Ajoute une paire clef/données
Assign (+) | [@inheritDoc]
Clear (+) | Vide la liste
Extract (+) | Retire une paire clef/données
Get (+) | Récupère les données liées à une clef
Put (+) | Modifie les données liées à une clef
REMOVE (+) | Retire une paire clef/données

Properties
Property | Description
BucketCount (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TUnsignedIntList)
Next


Sepi

Sepi
Previous
Next

Name
BucketCount

Parent
TValueBucketList

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
property BucketCount

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Assign)

Name
ADD

Parent
TValueBucketList

Visibility
PUBLIC

Description
Ajoute une paire clef/données
Il ne peut pas encore exister de paire clef/données avec cette clef.

Exception
EListError Liste verrouillée lors d'une opération ForEach active
EListError Élément dupliqué

Source code
procedure Add ( const Key , Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | Données associées à la clef Key

Sepi
Class Tree
Index
Previous
Next (Assign)


Sepi

Sepi
Previous (ADD)
Next (Clear)

Name
Assign

Parent
TValueBucketList

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Assign ( Source : TCustomValueBucketList ) ; override

Parameters
Parameter | Description
Source : TCustomValueBucketList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ADD)
Next (Clear)


Sepi

Sepi
Previous (Assign)
Next (Extract)

Name
Clear

Parent
TValueBucketList

Visibility
PUBLIC

Description
Vide la liste

Source code
procedure Clear

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Assign)
Next (Extract)


Sepi

Sepi
Previous (Clear)
Next (Get)

Name
Extract

Parent
TValueBucketList

Visibility
PUBLIC

Description
Retire une paire clef/données
La paire ne doit pas nécessairement être présente dans la liste.

Exception
EListError Liste verrouillée lors d'une opération ForEach active

Source code
procedure Extract ( const Key ; out Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | En sortie : les données de la paire qui est supprimée

Sepi
Class Tree
Index
Previous (Clear)
Next (Get)


Sepi

Sepi
Previous (Extract)
Next (Put)

Name
Get

Parent
TValueBucketList

Visibility
PUBLIC

Description
Récupère les données liées à une clef

Exception
EListError Élément non trouvé

Source code
procedure Get ( const Key ; out Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | En sortie : données associées à la clef Key

Sepi
Class Tree
Index
Previous (Extract)
Next (Put)


Sepi

Sepi
Previous (Get)
Next (REMOVE)

Name
Put

Parent
TValueBucketList

Visibility
PUBLIC

Description
Modifie les données liées à une clef
Il doit déjà exister une paire clef/données avec cette clef.

Exception
EListError Élément non trouvé

Source code
procedure Put ( const Key , Data )

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | Données associées à la clef Key

Sepi
Class Tree
Index
Previous (Get)
Next (REMOVE)


Sepi

Sepi
Previous (Put)
Next

Name
REMOVE

Parent
TValueBucketList

Visibility
PUBLIC

Description
Retire une paire clef/données
La paire ne doit pas nécessairement être présente dans la liste.

Exception
EListError Liste verrouillée lors d'une opération ForEach active

Source code
procedure Remove ( const Key )

Parameters
Parameter | Description
Key : Untyped | Clef

Sepi
Class Tree
Index
Previous (Put)
Next


Sepi

Sepi
Previous
Next (TValueBucketProc)

Name
TValueBucketEvent

Parent
ScLists

Visibility
PUBLIC

Description
Méthode de call-back pour la méthode ForEach de TCustomValueBucketList

Source code
TValueBucketEvent = procedure ( const Key , Data ; var Continue : Boolean ) of object ;

Parameters
Parameter | Description
Key : Untyped | Clef
Data : Untyped | Données associées à la clef
Continue : BOOLEAN | Positionner à False pour interrompre l'énumération

Sepi
Class Tree
Index
Previous
Next (TValueBucketProc)


Sepi

Sepi
Previous (TValueBucketEvent)
Next

Name
TValueBucketProc

Parent
ScLists

Visibility
PUBLIC

Description
Procédure de call-back pour la méthode ForEach de TCustomValueBucketList

Source code
TValueBucketProc = procedure ( Info : Pointer ; const Key , Data ; var Continue : Boolean ) ;

Parameters
Parameter | Description
Info : Pointer | Retransmission du paramètre AInfo donné à ForEach
Key : Untyped | Clef
Data : Untyped | Données associées à la clef
Continue : BOOLEAN | Positionner à False pour interrompre l'énumération

Sepi
Class Tree
Index
Previous (TValueBucketEvent)
Next


Sepi

Sepi
Previous
Next

Name
AppParams

Parent
ScLists

Visibility
PUBLIC

Description
Liste des paramètres envoyés à l'application

Source code
AppParams : TScStrings

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ScLists)
Next (ScMaths)

Name
ScLOGFile

Parent
Sepi

Description
Définit une classe de gestion d'un fichier LOG

Author
sjrd

Version
1.0

Classes
Class | Description
TScLogFile (+) | Gère un fichier LOG

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScLists)
Next (ScMaths)


Sepi

Sepi
Previous
Next

Name
TScLogFile

Parent
ScLOGFile

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Gère un fichier LOG
Les lignes d'un fichier LOG géré avec cette classe sont de la forme :
[Date et Heure] Titre de l'entrée ; Description de l'entrée
Les descriptions sont toujours optionnelles.

Members
Fields
Field | Description
FFile (-) | Flux interne du fichier LOG

Methods
Method | Description
ADD (+) | Ajoute une entrée au fichier LOG
ADD (+) | Ajoute une entrée au fichier LOG
ADD (+) | Ajoute une entrée au fichier LOG
AddLine (+) | Ajoute une ligne au fichier LOG
Create (+) | Crée une nouvelle instance de TScLogFile
Destroy (+) | Détruit l'instance

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
FFile

Parent
TScLogFile

Visibility
PRIVATE

Description
Flux interne du fichier LOG

Source code
FFile : TFileStream

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ADD)

Name
ADD

Parent
TScLogFile

Visibility
PUBLIC

Description
Ajoute une entrée au fichier LOG

Source code
procedure Add ( const Time , Title , Description : string ) ; overload

Parameters
Parameter | Description
Time : STRING | Représentation en chaîne de l'heure de l'ajout
Title : STRING | Titre de l'entrée de LOG
Description : STRING | Description de l'entrée LOG

Sepi
Class Tree
Index
Previous
Next (ADD)


Sepi

Sepi
Previous (ADD)
Next (ADD)

Name
ADD

Parent
TScLogFile

Visibility
PUBLIC

Description
Ajoute une entrée au fichier LOG

Source code
procedure Add ( Time : TDateTime ; const Title : string ; const Description : string = '' ) ; overload

Parameters
Parameter | Description
Time : TDateTime | Heure de l'ajout
Title : STRING | Titre de l'entrée LOG
Description : STRING | Description de l'entrée LOG

Sepi
Class Tree
Index
Previous (ADD)
Next (ADD)


Sepi

Sepi
Previous (ADD)
Next (AddLine)

Name
ADD

Parent
TScLogFile

Visibility
PUBLIC

Description
Ajoute une entrée au fichier LOG
L'heure de l'ajout est déterminée à partir de l'heure courante

Source code
procedure Add ( const Title : string ; const Description : string = '' ) ; overload

Parameters
Parameter | Description
Title : STRING | Titre de l'entrée LOG
Description : STRING | Description de l'entrée LOG

Sepi
Class Tree
Index
Previous (ADD)
Next (AddLine)


Sepi

Sepi
Previous (ADD)
Next (Create)

Name
AddLine

Parent
TScLogFile

Visibility
PUBLIC

Description
Ajoute une ligne au fichier LOG

Source code
procedure AddLine ( const Line : string )

Parameters
Parameter | Description
Line : STRING | Ligne à ajouter

Sepi
Class Tree
Index
Previous (ADD)
Next (Create)


Sepi

Sepi
Previous (AddLine)
Next (Destroy)

Name
Create

Parent
TScLogFile

Visibility
PUBLIC

Description
Crée une nouvelle instance de TScLogFile

Source code
constructor Create ( const FileName : string ; Append : Boolean = False )

Parameters
Parameter | Description
FileName : STRING | Nom du fichier LOG
Append : BOOLEAN | Si False, le fichier est d'abord vidé

Sepi
Class Tree
Index
Previous (AddLine)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next

Name
Destroy

Parent
TScLogFile

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (ScLOGFile)
Next (ScMD5)

Name
ScMaths

Parent
Sepi

Description
Définit des classes et routines de mathématiques avancées

Author
sjrd

Version
1.0

Types
Type | Description
TComplex (+) | #No TAG found in source code#
TScalarProdFunc (+) | #No TAG found in source code#
TTestIsAbortedProc (+) | #No TAG found in source code#

Constants
Constant | Description
BinaryOperators (+) | #No TAG found in source code#
MinValueEver (+) | #No TAG found in source code#
MonomsChars (+) | #No TAG found in source code#
UnaryOperators (+) | #No TAG found in source code#
VarsListsCount (+) | #No TAG found in source code#

Variables
Variable | Description
ScalarProdFunc (+) | #No TAG found in source code#
VarsLists (+) | #No TAG found in source code#

Methods
Method | Description
AsInteger (+) | #No TAG found in source code#
AsNatural (+) | #No TAG found in source code#
DefaultScalarProd (+) | #No TAG found in source code#
Eval (+) | #No TAG found in source code#
Factorial (+) | #No TAG found in source code#
IntPower (+) | #No TAG found in source code#
IsInteger (+) | #No TAG found in source code#
IsNatural (+) | #No TAG found in source code#
VerifyIsInteger (+) | #No TAG found in source code#
VerifyIsNatural (+) | #No TAG found in source code#

Classes
Class | Description
EBracketsError (+) | #No TAG found in source code#
ECannotSolveEquationError (+) | #No TAG found in source code#
EDegreeError (+) | #No TAG found in source code#
EDegreeTooHighError (+) | #No TAG found in source code#
EDegreeTooLowError (+) | #No TAG found in source code#
EDivisionError (+) | #No TAG found in source code#
EDivisionOpError (+) | #No TAG found in source code#
EEquationError (+) | #No TAG found in source code#
EEvalError (+) | #No TAG found in source code#
EIntegerError (+) | #No TAG found in source code#
EMathsError (+) | #No TAG found in source code#
ENaturalError (+) | #No TAG found in source code#
ENotDegreeZeroError (+) | #No TAG found in source code#
ENotIntegerError (+) | #No TAG found in source code#
ENotNaturalError (+) | #No TAG found in source code#
EOperationError (+) | #No TAG found in source code#
EOpNotExistsError (+) | #No TAG found in source code#
EOpRequestsCorrectIndexError (+) | #No TAG found in source code#
EOpRequestsDegreeZeroError (+) | #No TAG found in source code#
EOpRequestsError (+) | #No TAG found in source code#
EOpRequestsIntegerError (+) | #No TAG found in source code#
EOpRequestsNaturalError (+) | #No TAG found in source code#
ERootError (+) | #No TAG found in source code#
ERootOpError (+) | #No TAG found in source code#
ETooManyBracketsError (+) | #No TAG found in source code#
EWrongCharacterError (+) | #No TAG found in source code#
EWrongExpressionError (+) | #No TAG found in source code#
TComplexList (+) | #No TAG found in source code#
TPolynom (+) | #No TAG found in source code#
TPolynomList (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScLOGFile)
Next (ScMD5)


Sepi

Sepi
Previous
Next (ECannotSolveEquationError)

Name
EBracketsError

Parent
ScMaths

Class Hierarchy
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
CreateBrackets (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ECannotSolveEquationError)


Sepi

Sepi
Previous
Next

Name
CreateBrackets

Parent
EBracketsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateBrackets

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EBracketsError)
Next (EDegreeError)

Name
ECannotSolveEquationError

Parent
ScMaths

Class Hierarchy
EEquationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EBracketsError)
Next (EDegreeError)


Sepi

Sepi
Previous (ECannotSolveEquationError)
Next (EDegreeTooHighError)

Name
EDegreeError

Parent
ScMaths

Class Hierarchy
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Value (+) | #No TAG found in source code#

Methods
Method | Description
CreateDegree (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ECannotSolveEquationError)
Next (EDegreeTooHighError)


Sepi

Sepi
Previous
Next

Name
Value

Parent
EDegreeError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Value : TPolynom

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
CreateDegree

Parent
EDegreeError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateDegree ( AValue : TPolynom )

Parameters
Parameter | Description
AValue : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (CreateDegree)
Next

Name
Destroy

Parent
EDegreeError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateDegree)
Next


Sepi

Sepi
Previous (EDegreeError)
Next (EDegreeTooLowError)

Name
EDegreeTooHighError

Parent
ScMaths

Class Hierarchy
ECannotSolveEquationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EDegreeError)
Next (EDegreeTooLowError)


Sepi

Sepi
Previous (EDegreeTooHighError)
Next (EDivisionError)

Name
EDegreeTooLowError

Parent
ScMaths

Class Hierarchy
ECannotSolveEquationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EDegreeTooHighError)
Next (EDivisionError)


Sepi

Sepi
Previous (EDegreeTooLowError)
Next (EDivisionOpError)

Name
EDivisionError

Parent
ScMaths

Class Hierarchy
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Dividend (+) | #No TAG found in source code#
Divisor (+) | #No TAG found in source code#

Methods
Method | Description
CreateDivision (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EDegreeTooLowError)
Next (EDivisionOpError)


Sepi

Sepi
Previous
Next (Divisor)

Name
Dividend

Parent
EDivisionError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Dividend , Divisor : TPolynom

Sepi
Class Tree
Index
Previous
Next (Divisor)


Sepi

Sepi
Previous (Dividend)
Next

Name
Divisor

Parent
EDivisionError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Dividend , Divisor : TPolynom

Sepi
Class Tree
Index
Previous (Dividend)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
CreateDivision

Parent
EDivisionError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateDivision ( ADividend , ADivisor : TPolynom )

Parameters
Parameter | Description
ADividend : TPolynom | #Pas de TAG trouvé dans le code source#
ADivisor : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (CreateDivision)
Next

Name
Destroy

Parent
EDivisionError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateDivision)
Next


Sepi

Sepi
Previous (EDivisionError)
Next (EEquationError)

Name
EDivisionOpError

Parent
ScMaths

Class Hierarchy
EOperationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Dividend (+) | #No TAG found in source code#
Divisor (+) | #No TAG found in source code#

Methods
Method | Description
CreateDivisionOp (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EDivisionError)
Next (EEquationError)


Sepi

Sepi
Previous
Next (Divisor)

Name
Dividend

Parent
EDivisionOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Dividend , Divisor : TPolynom

Sepi
Class Tree
Index
Previous
Next (Divisor)


Sepi

Sepi
Previous (Dividend)
Next

Name
Divisor

Parent
EDivisionOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Dividend , Divisor : TPolynom

Sepi
Class Tree
Index
Previous (Dividend)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
CreateDivisionOp

Parent
EDivisionOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateDivisionOp ( ADividend , ADivisor : TPolynom )

Parameters
Parameter | Description
ADividend : TPolynom | #Pas de TAG trouvé dans le code source#
ADivisor : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (CreateDivisionOp)
Next

Name
Destroy

Parent
EDivisionOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateDivisionOp)
Next


Sepi

Sepi
Previous (EDivisionOpError)
Next (EEvalError)

Name
EEquationError

Parent
ScMaths

Class Hierarchy
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EDivisionOpError)
Next (EEvalError)


Sepi

Sepi
Previous (EEquationError)
Next (EIntegerError)

Name
EEvalError

Parent
ScMaths

Class Hierarchy
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Expression (+) | #No TAG found in source code#

Methods
Method | Description
ClassType (+) | #No TAG found in source code#
CreateEval (+) | #No TAG found in source code#
CreateEval (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EEquationError)
Next (EIntegerError)


Sepi

Sepi
Previous
Next

Name
Expression

Parent
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Expression : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CreateEval)

Name
ClassType

Parent
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function ClassType : EEvalErrorClass

Parameters
Parameter Description

Return
Types | Description
EEvalErrorClass | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CreateEval)


Sepi

Sepi
Previous (ClassType)
Next (CreateEval)

Name
CreateEval

Parent
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateEval ( AExpression : string ; Format : string ; Args : array of const ) ; overload

Parameters
Parameter | Description
AExpression : STRING | #Pas de TAG trouvé dans le code source#
Format : STRING | #Pas de TAG trouvé dans le code source#
Args : CONST | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ClassType)
Next (CreateEval)


Sepi

Sepi
Previous (CreateEval)
Next

Name
CreateEval

Parent
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateEval ( AExpression : string ; AMessage : string ) ; overload

Parameters
Parameter | Description
AExpression : STRING | #Pas de TAG trouvé dans le code source#
AMessage : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateEval)
Next


Sepi

Sepi
Previous (EEvalError)
Next (EMathsError)

Name
EIntegerError

Parent
ScMaths

Class Hierarchy
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Value (+) | #No TAG found in source code#

Methods
Method | Description
CreateInteger (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EEvalError)
Next (EMathsError)


Sepi

Sepi
Previous
Next

Name
Value

Parent
EIntegerError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Value : Extended

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CreateInteger

Parent
EIntegerError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateInteger ( AValue : Extended )

Parameters
Parameter | Description
AValue : EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EIntegerError)
Next (ENaturalError)

Name
EMathsError

Parent
ScMaths

Class Hierarchy
Exception

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
CreateMaths (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EIntegerError)
Next (ENaturalError)


Sepi

Sepi
Previous
Next

Name
CreateMaths

Parent
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateMaths

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EMathsError)
Next (ENotDegreeZeroError)

Name
ENaturalError

Parent
ScMaths

Class Hierarchy
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Value (+) | #No TAG found in source code#

Methods
Method | Description
CreateNatural (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EMathsError)
Next (ENotDegreeZeroError)


Sepi

Sepi
Previous
Next

Name
Value

Parent
ENaturalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Value : Int64

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CreateNatural

Parent
ENaturalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateNatural ( AValue : Int64 )

Parameters
Parameter | Description
AValue : INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ENaturalError)
Next (ENotIntegerError)

Name
ENotDegreeZeroError

Parent
ScMaths

Class Hierarchy
EDegreeError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
CreateNotDegreeZero (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ENaturalError)
Next (ENotIntegerError)


Sepi

Sepi
Previous
Next

Name
CreateNotDegreeZero

Parent
ENotDegreeZeroError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateNotDegreeZero ( AValue : TPolynom )

Parameters
Parameter | Description
AValue : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ENotDegreeZeroError)
Next (ENotNaturalError)

Name
ENotIntegerError

Parent
ScMaths

Class Hierarchy
EIntegerError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
CreateNotInteger (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ENotDegreeZeroError)
Next (ENotNaturalError)


Sepi

Sepi
Previous
Next

Name
CreateNotInteger

Parent
ENotIntegerError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateNotInteger ( AValue : Extended )

Parameters
Parameter | Description
AValue : EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ENotIntegerError)
Next (EOperationError)

Name
ENotNaturalError

Parent
ScMaths

Class Hierarchy
ENaturalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
CreateNotNatural (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ENotIntegerError)
Next (EOperationError)


Sepi

Sepi
Previous
Next

Name
CreateNotNatural

Parent
ENotNaturalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateNotNatural ( AValue : Int64 )

Parameters
Parameter | Description
AValue : INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ENotNaturalError)
Next (EOpNotExistsError)

Name
EOperationError

Parent
ScMaths

Class Hierarchy
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Operation (+) | #No TAG found in source code#

Methods
Method | Description
CreateOperation (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ENotNaturalError)
Next (EOpNotExistsError)


Sepi

Sepi
Previous
Next

Name
Operation

Parent
EOperationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Operation : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CreateOperation

Parent
EOperationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOperation ( AOperation : string )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EOperationError)
Next (EOpRequestsCorrectIndexError)

Name
EOpNotExistsError

Parent
ScMaths

Class Hierarchy
EOperationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
CreateOpIsNotBinary (+) | #No TAG found in source code#
CreateOpIsNotUnary (+) | #No TAG found in source code#
CreateOpNotExists (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EOperationError)
Next (EOpRequestsCorrectIndexError)


Sepi

Sepi
Previous
Next (CreateOpIsNotUnary)

Name
CreateOpIsNotBinary

Parent
EOpNotExistsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOpIsNotBinary ( AOperation : string )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CreateOpIsNotUnary)


Sepi

Sepi
Previous (CreateOpIsNotBinary)
Next (CreateOpNotExists)

Name
CreateOpIsNotUnary

Parent
EOpNotExistsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOpIsNotUnary ( AOperation : string )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateOpIsNotBinary)
Next (CreateOpNotExists)


Sepi

Sepi
Previous (CreateOpIsNotUnary)
Next

Name
CreateOpNotExists

Parent
EOpNotExistsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOpNotExists ( AOperation : string )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateOpIsNotUnary)
Next


Sepi

Sepi
Previous (EOpNotExistsError)
Next (EOpRequestsDegreeZeroError)

Name
EOpRequestsCorrectIndexError

Parent
ScMaths

Class Hierarchy
EOpRequestsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
INDEX (+) | #No TAG found in source code#

Methods
Method | Description
CreateOpRequestsCorrectIndex (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EOpNotExistsError)
Next (EOpRequestsDegreeZeroError)


Sepi

Sepi
Previous
Next

Name
INDEX

Parent
EOpRequestsCorrectIndexError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Index : Integer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CreateOpRequestsCorrectIndex

Parent
EOpRequestsCorrectIndexError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOpRequestsCorrectIndex ( AOperation : string ; AIndex : Integer )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#
AIndex : INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EOpRequestsCorrectIndexError)
Next (EOpRequestsError)

Name
EOpRequestsDegreeZeroError

Parent
ScMaths

Class Hierarchy
EOpRequestsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Value (+) | #No TAG found in source code#

Methods
Method | Description
CreateOpRequestsDegreeZero (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EOpRequestsCorrectIndexError)
Next (EOpRequestsError)


Sepi

Sepi
Previous
Next

Name
Value

Parent
EOpRequestsDegreeZeroError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Value : TPolynom

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
CreateOpRequestsDegreeZero

Parent
EOpRequestsDegreeZeroError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOpRequestsDegreeZero ( AOperation : string ; AValue : TPolynom )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#
AValue : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (CreateOpRequestsDegreeZero)
Next

Name
Destroy

Parent
EOpRequestsDegreeZeroError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateOpRequestsDegreeZero)
Next


Sepi

Sepi
Previous (EOpRequestsDegreeZeroError)
Next (EOpRequestsIntegerError)

Name
EOpRequestsError

Parent
ScMaths

Class Hierarchy
EOperationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EOpRequestsDegreeZeroError)
Next (EOpRequestsIntegerError)


Sepi

Sepi
Previous (EOpRequestsError)
Next (EOpRequestsNaturalError)

Name
EOpRequestsIntegerError

Parent
ScMaths

Class Hierarchy
EOpRequestsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Value (+) | #No TAG found in source code#

Methods
Method | Description
CreateOpRequestsInteger (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EOpRequestsError)
Next (EOpRequestsNaturalError)


Sepi

Sepi
Previous
Next

Name
Value

Parent
EOpRequestsIntegerError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Value : Extended

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CreateOpRequestsInteger

Parent
EOpRequestsIntegerError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOpRequestsInteger ( AOperation : string ; AValue : Extended )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#
AValue : EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EOpRequestsIntegerError)
Next (ERootError)

Name
EOpRequestsNaturalError

Parent
ScMaths

Class Hierarchy
EOpRequestsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Value (+) | #No TAG found in source code#

Methods
Method | Description
CreateOpRequestsNatural (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EOpRequestsIntegerError)
Next (ERootError)


Sepi

Sepi
Previous
Next

Name
Value

Parent
EOpRequestsNaturalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Value : Int64

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CreateOpRequestsNatural

Parent
EOpRequestsNaturalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateOpRequestsNatural ( AOperation : string ; AValue : Int64 )

Parameters
Parameter | Description
AOperation : STRING | #Pas de TAG trouvé dans le code source#
AValue : INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EOpRequestsNaturalError)
Next (ERootOpError)

Name
ERootError

Parent
ScMaths

Class Hierarchy
EMathsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Degree (+) | #No TAG found in source code#
Radican (+) | #No TAG found in source code#

Methods
Method | Description
CreateRoot (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EOpRequestsNaturalError)
Next (ERootOpError)


Sepi

Sepi
Previous
Next (Radican)

Name
Degree

Parent
ERootError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Degree , Radican : TPolynom

Sepi
Class Tree
Index
Previous
Next (Radican)


Sepi

Sepi
Previous (Degree)
Next

Name
Radican

Parent
ERootError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Degree , Radican : TPolynom

Sepi
Class Tree
Index
Previous (Degree)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
CreateRoot

Parent
ERootError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateRoot ( ADegree , ARadican : TPolynom )

Parameters
Parameter | Description
ADegree : TPolynom | #Pas de TAG trouvé dans le code source#
ARadican : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (CreateRoot)
Next

Name
Destroy

Parent
ERootError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateRoot)
Next


Sepi

Sepi
Previous (ERootError)
Next (ETooManyBracketsError)

Name
ERootOpError

Parent
ScMaths

Class Hierarchy
EOperationError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Degree (+) | #No TAG found in source code#
Radican (+) | #No TAG found in source code#

Methods
Method | Description
CreateRootOp (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ERootError)
Next (ETooManyBracketsError)


Sepi

Sepi
Previous
Next (Radican)

Name
Degree

Parent
ERootOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Degree , Radican : TPolynom

Sepi
Class Tree
Index
Previous
Next (Radican)


Sepi

Sepi
Previous (Degree)
Next

Name
Radican

Parent
ERootOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Degree , Radican : TPolynom

Sepi
Class Tree
Index
Previous (Degree)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
CreateRootOp

Parent
ERootOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateRootOp ( ADegree , ARadican : TPolynom )

Parameters
Parameter | Description
ADegree : TPolynom | #Pas de TAG trouvé dans le code source#
ARadican : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (CreateRootOp)
Next

Name
Destroy

Parent
ERootOpError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateRootOp)
Next


Sepi

Sepi
Previous (ERootOpError)
Next (EWrongCharacterError)

Name
ETooManyBracketsError

Parent
ScMaths

Class Hierarchy
EBracketsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
HowTooMany (+) | #No TAG found in source code#
WhichBracket (+) | #No TAG found in source code#

Methods
Method | Description
CreateTooManyBrackets (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ERootOpError)
Next (EWrongCharacterError)


Sepi

Sepi
Previous
Next (WhichBracket)

Name
HowTooMany

Parent
ETooManyBracketsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
HowTooMany : Integer

Sepi
Class Tree
Index
Previous
Next (WhichBracket)


Sepi

Sepi
Previous (HowTooMany)
Next

Name
WhichBracket

Parent
ETooManyBracketsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
WhichBracket : Char

Sepi
Class Tree
Index
Previous (HowTooMany)
Next


Sepi

Sepi
Previous
Next

Name
CreateTooManyBrackets

Parent
ETooManyBracketsError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateTooManyBrackets ( AHowTooMany : Integer ; AWhichBracket : Char )

Parameters
Parameter | Description
AHowTooMany : INTEGER | #Pas de TAG trouvé dans le code source#
AWhichBracket : CHAR | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ETooManyBracketsError)
Next (EWrongExpressionError)

Name
EWrongCharacterError

Parent
ScMaths

Class Hierarchy
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
Character (+) | #No TAG found in source code#

Methods
Method | Description
CreateWrongCharacter (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ETooManyBracketsError)
Next (EWrongExpressionError)


Sepi

Sepi
Previous
Next

Name
Character

Parent
EWrongCharacterError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
Character : Char

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CreateWrongCharacter

Parent
EWrongCharacterError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateWrongCharacter ( ACharacter : Char )

Parameters
Parameter | Description
ACharacter : CHAR | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EWrongCharacterError)
Next (TComplexList)

Name
EWrongExpressionError

Parent
ScMaths

Class Hierarchy
EEvalError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
CreateWrongExpression (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EWrongCharacterError)
Next (TComplexList)


Sepi

Sepi
Previous
Next

Name
CreateWrongExpression

Parent
EWrongExpressionError

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateWrongExpression

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (EWrongExpressionError)
Next (TPolynom)

Name
TComplexList

Parent
ScMaths

Class Hierarchy
TScList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Methods
Method | Description
ADD (+) | #No TAG found in source code#
Assign (+) | Copie le contenu d'un autre objet similaire
AssignTo (#) | Copie les propriétés d'un objet dans l'objet destination
Create (+) | #No TAG found in source code#
Delete (+) | #No TAG found in source code#
GetItems (-) | #No TAG found in source code#
Insert (+) | #No TAG found in source code#
IsAssignClass (#) | Indique si une classe est une classe d'assignation de la liste
READ (+) | #No TAG found in source code#
SetItems (-) | #No TAG found in source code#
WRITE (+) | #No TAG found in source code#

Properties
Property | Description
Items (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (EWrongExpressionError)
Next (TPolynom)


Sepi

Sepi
Previous
Next

Name
Items

Parent
TComplexList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Items [ Index : Integer ] : TComplex read GetItems write SetItems ; default

Read Access
GetItems

Write Access
SetItems

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Assign)

Name
ADD

Parent
TComplexList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Add ( New : TComplex ) : Integer

Parameters
Parameter | Description
New : TComplex | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Assign)


Sepi

Sepi
Previous (ADD)
Next (AssignTo)

Name
Assign

Parent
TComplexList

Visibility
PUBLIC

Description
Copie le contenu d'un autre objet similaire
Appelez Assign pour copier les propriétés ou d'autres attributs d'un objet sur
un autre.

Source code
procedure Assign ( Source : TPersistent ) ; override

Parameters
Parameter | Description
Source : TPersistent | Objet source à copier

Sepi
Class Tree
Index
Previous (ADD)
Next (AssignTo)


Sepi

Sepi
Previous (Assign)
Next (Create)

Name
AssignTo

Parent
TComplexList

Visibility
PROTECTED

Description
Copie les propriétés d'un objet dans l'objet destination

Source code
procedure AssignTo ( Dest : TPersistent ) ; override

Parameters
Parameter | Description
Dest : TPersistent | Objet destination dans lequel copier la liste

Sepi
Class Tree
Index
Previous (Assign)
Next (Create)


Sepi

Sepi
Previous (AssignTo)
Next (Delete)

Name
Create

Parent
TComplexList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AssignTo)
Next (Delete)


Sepi

Sepi
Previous (Create)
Next (GetItems)

Name
Delete

Parent
TComplexList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Delete ( Index : Integer ) : TComplex

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TComplex | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetItems)


Sepi

Sepi
Previous (Delete)
Next (Insert)

Name
GetItems

Parent
TComplexList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetItems ( Index : Integer ) : TComplex

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TComplex | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Delete)
Next (Insert)


Sepi

Sepi
Previous (GetItems)
Next (IsAssignClass)

Name
Insert

Parent
TComplexList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Insert ( Index : Integer ; New : TComplex ) : Integer

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#
New : TComplex | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetItems)
Next (IsAssignClass)


Sepi

Sepi
Previous (Insert)
Next (READ)

Name
IsAssignClass

Parent
TComplexList

Visibility
PROTECTED

Description
Indique si une classe est une classe d'assignation de la liste
Les classes descendantes de TScList peuvent surcharger cette méthode pour
indiquer quelles sont les classes d'assignation de la liste.

Source code
function IsAssignClass ( ScListClass : TScListClass ) : Boolean ; override

Parameters
Parameter | Description
ScListClass : TScListClass | Classe à tester

Return
Types | Description
BOOLEAN | True si ScListClass est une classe d'assignation, False sinon

Sepi
Class Tree
Index
Previous (Insert)
Next (READ)


Sepi

Sepi
Previous (IsAssignClass)
Next (SetItems)

Name
READ

Parent
TComplexList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Read : TComplex

Parameters
Parameter Description

Return
Types | Description
TComplex | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsAssignClass)
Next (SetItems)


Sepi

Sepi
Previous (READ)
Next (WRITE)

Name
SetItems

Parent
TComplexList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetItems ( Index : Integer ; New : TComplex )

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#
New : TComplex | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (READ)
Next (WRITE)


Sepi

Sepi
Previous (SetItems)
Next

Name
WRITE

Parent
TComplexList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Write ( New : TComplex )

Parameters
Parameter | Description
New : TComplex | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetItems)
Next


Sepi

Sepi
Previous (TComplexList)
Next (TPolynomList)

Name
TPolynom

Parent
ScMaths

Class Hierarchy
TObject

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
FCoefficients (-) | #No TAG found in source code#
FMinDegree (-) | #No TAG found in source code#

Methods
Method | Description
Abs (+) | #No TAG found in source code#
AbsOf (+) | #No TAG found in source code#
ADD (+) | #No TAG found in source code#
Addition (+) | #No TAG found in source code#
ArcCosinus (+) | #No TAG found in source code#
ArcCosinusOf (+) | #No TAG found in source code#
ArcSinus (+) | #No TAG found in source code#
ArcSinusOf (+) | #No TAG found in source code#
ArcTangent (+) | #No TAG found in source code#
ArcTangentOf (+) | #No TAG found in source code#
Assign (+) | #No TAG found in source code#
Cosinus (+) | #No TAG found in source code#
CosinusOf (+) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
CreateAssign (+) | #No TAG found in source code#
CreateFromExtended (+) | #No TAG found in source code#
CreateFromStream (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#
Divide (+) | #No TAG found in source code#
Division (+) | #No TAG found in source code#
Factorial (+) | #No TAG found in source code#
FactorialOf (+) | #No TAG found in source code#
GetAsExtended (-) | #No TAG found in source code#
GetAsInteger (-) | #No TAG found in source code#
GetAsNatural (-) | #No TAG found in source code#
GetCoefficients (-) | #No TAG found in source code#
GetIsExtended (-) | #No TAG found in source code#
GetIsInteger (-) | #No TAG found in source code#
GetIsNatural (-) | #No TAG found in source code#
GetIsZero (-) | #No TAG found in source code#
GetMaxDegree (-) | #No TAG found in source code#
GetMinDegree (-) | #No TAG found in source code#
GetNegDegree (-) | #No TAG found in source code#
GetPosDegree (-) | #No TAG found in source code#
Insert (+) | #No TAG found in source code#
InsertOf (+) | #No TAG found in source code#
LoadFromStream (+) | #No TAG found in source code#
Modulo (+) | #No TAG found in source code#
ModuloOf (+) | #No TAG found in source code#
Multiplication (+) | #No TAG found in source code#
Multiply (+) | #No TAG found in source code#
Oppose (+) | #No TAG found in source code#
OpposedOf (+) | #No TAG found in source code#
Power (+) | #No TAG found in source code#
PowerOf (+) | #No TAG found in source code#
Reverse (+) | #No TAG found in source code#
ReversedOf (+) | #No TAG found in source code#
Root (+) | #No TAG found in source code#
RootOf (+) | #No TAG found in source code#
SaveToStream (+) | #No TAG found in source code#
ScalarProd (+) | #No TAG found in source code#
ScalarProdOf (+) | #No TAG found in source code#
SetAsExtended (-) | #No TAG found in source code#
SetAsInteger (-) | #No TAG found in source code#
SetCoefficients (-) | #No TAG found in source code#
SetToZero (+) | #No TAG found in source code#
Sinus (+) | #No TAG found in source code#
SinusOf (+) | #No TAG found in source code#
Sub (+) | #No TAG found in source code#
Substraction (+) | #No TAG found in source code#
Tangent (+) | #No TAG found in source code#
TangentOf (+) | #No TAG found in source code#
ToString (+) | #No TAG found in source code#

Properties
Property | Description
AsExtended (+) | #No TAG found in source code#
AsInteger (+) | #No TAG found in source code#
AsNatural (+) | #No TAG found in source code#
Coefficients (+) | #No TAG found in source code#
IsExtended (+) | #No TAG found in source code#
IsInteger (+) | #No TAG found in source code#
IsNatural (+) | #No TAG found in source code#
IsZero (+) | #No TAG found in source code#
MaxDegree (+) | #No TAG found in source code#
MinDegree (+) | #No TAG found in source code#
NegDegree (+) | #No TAG found in source code#
PosDegree (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TComplexList)
Next (TPolynomList)


Sepi

Sepi
Previous
Next (FMinDegree)

Name
FCoefficients

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FCoefficients : TExtendedList

Sepi
Class Tree
Index
Previous
Next (FMinDegree)


Sepi

Sepi
Previous (FCoefficients)
Next

Name
FMinDegree

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FMinDegree : Integer

Sepi
Class Tree
Index
Previous (FCoefficients)
Next


Sepi

Sepi
Previous
Next (AsInteger)

Name
AsExtended

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property AsExtended : Extended read GetAsExtended write SetAsExtended

Read Access
GetAsExtended

Write Access
SetAsExtended

Sepi
Class Tree
Index
Previous
Next (AsInteger)


Sepi

Sepi
Previous (AsExtended)
Next (AsNatural)

Name
AsInteger

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property AsInteger : Int64 read GetAsInteger write SetAsInteger

Read Access
GetAsInteger

Write Access
SetAsInteger

Sepi
Class Tree
Index
Previous (AsExtended)
Next (AsNatural)


Sepi

Sepi
Previous (AsInteger)
Next (Coefficients)

Name
AsNatural

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property AsNatural : Int64 read GetAsNatural write SetAsInteger

Read Access
GetAsNatural

Write Access
SetAsInteger

Sepi
Class Tree
Index
Previous (AsInteger)
Next (Coefficients)


Sepi

Sepi
Previous (AsNatural)
Next (IsExtended)

Name
Coefficients

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Coefficients [ Exponent : Integer ] : Extended read GetCoefficients write SetCoefficients ; default

Read Access
GetCoefficients

Write Access
SetCoefficients

Sepi
Class Tree
Index
Previous (AsNatural)
Next (IsExtended)


Sepi

Sepi
Previous (Coefficients)
Next (IsInteger)

Name
IsExtended

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property IsExtended : Boolean read GetIsExtended

Read Access
GetIsExtended

Sepi
Class Tree
Index
Previous (Coefficients)
Next (IsInteger)


Sepi

Sepi
Previous (IsExtended)
Next (IsNatural)

Name
IsInteger

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property IsInteger : Boolean read GetIsInteger

Read Access
GetIsInteger

Sepi
Class Tree
Index
Previous (IsExtended)
Next (IsNatural)


Sepi

Sepi
Previous (IsInteger)
Next (IsZero)

Name
IsNatural

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property IsNatural : Boolean read GetIsNatural

Read Access
GetIsNatural

Sepi
Class Tree
Index
Previous (IsInteger)
Next (IsZero)


Sepi

Sepi
Previous (IsNatural)
Next (MaxDegree)

Name
IsZero

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property IsZero : Boolean read GetIsZero

Read Access
GetIsZero

Sepi
Class Tree
Index
Previous (IsNatural)
Next (MaxDegree)


Sepi

Sepi
Previous (IsZero)
Next (MinDegree)

Name
MaxDegree

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property MaxDegree : Integer read GetMaxDegree

Read Access
GetMaxDegree

Sepi
Class Tree
Index
Previous (IsZero)
Next (MinDegree)


Sepi

Sepi
Previous (MaxDegree)
Next (NegDegree)

Name
MinDegree

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property MinDegree : Integer read GetMinDegree

Read Access
GetMinDegree

Sepi
Class Tree
Index
Previous (MaxDegree)
Next (NegDegree)


Sepi

Sepi
Previous (MinDegree)
Next (PosDegree)

Name
NegDegree

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property NegDegree : Integer read GetNegDegree

Read Access
GetNegDegree

Sepi
Class Tree
Index
Previous (MinDegree)
Next (PosDegree)


Sepi

Sepi
Previous (NegDegree)
Next

Name
PosDegree

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property PosDegree : Integer read GetPosDegree

Read Access
GetPosDegree

Sepi
Class Tree
Index
Previous (NegDegree)
Next


Sepi

Sepi
Previous
Next (AbsOf)

Name
Abs

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Abs

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (AbsOf)


Sepi

Sepi
Previous (Abs)
Next (ADD)

Name
AbsOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function AbsOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Abs)
Next (ADD)


Sepi

Sepi
Previous (AbsOf)
Next (Addition)

Name
ADD

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Add ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AbsOf)
Next (Addition)


Sepi

Sepi
Previous (ADD)
Next (ArcCosinus)

Name
Addition

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function Addition ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ADD)
Next (ArcCosinus)


Sepi

Sepi
Previous (Addition)
Next (ArcCosinusOf)

Name
ArcCosinus

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ArcCosinus

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Addition)
Next (ArcCosinusOf)


Sepi

Sepi
Previous (ArcCosinus)
Next (ArcSinus)

Name
ArcCosinusOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function ArcCosinusOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ArcCosinus)
Next (ArcSinus)


Sepi

Sepi
Previous (ArcCosinusOf)
Next (ArcSinusOf)

Name
ArcSinus

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ArcSinus

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ArcCosinusOf)
Next (ArcSinusOf)


Sepi

Sepi
Previous (ArcSinus)
Next (ArcTangent)

Name
ArcSinusOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function ArcSinusOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ArcSinus)
Next (ArcTangent)


Sepi

Sepi
Previous (ArcSinusOf)
Next (ArcTangentOf)

Name
ArcTangent

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ArcTangent

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ArcSinusOf)
Next (ArcTangentOf)


Sepi

Sepi
Previous (ArcTangent)
Next (Assign)

Name
ArcTangentOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function ArcTangentOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ArcTangent)
Next (Assign)


Sepi

Sepi
Previous (ArcTangentOf)
Next (Cosinus)

Name
Assign

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Assign ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ArcTangentOf)
Next (Cosinus)


Sepi

Sepi
Previous (Assign)
Next (CosinusOf)

Name
Cosinus

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Cosinus

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Assign)
Next (CosinusOf)


Sepi

Sepi
Previous (Cosinus)
Next (Create)

Name
CosinusOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function CosinusOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Cosinus)
Next (Create)


Sepi

Sepi
Previous (CosinusOf)
Next (CreateAssign)

Name
Create

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CosinusOf)
Next (CreateAssign)


Sepi

Sepi
Previous (Create)
Next (CreateFromExtended)

Name
CreateAssign

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateAssign ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (CreateFromExtended)


Sepi

Sepi
Previous (CreateAssign)
Next (CreateFromStream)

Name
CreateFromExtended

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateFromExtended ( Exponent : Integer ; Coefficient : Extended )

Parameters
Parameter | Description
Exponent : INTEGER | #Pas de TAG trouvé dans le code source#
Coefficient : EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateAssign)
Next (CreateFromStream)


Sepi

Sepi
Previous (CreateFromExtended)
Next (Destroy)

Name
CreateFromStream

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateFromStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateFromExtended)
Next (Destroy)


Sepi

Sepi
Previous (CreateFromStream)
Next (Divide)

Name
Destroy

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateFromStream)
Next (Divide)


Sepi

Sepi
Previous (Destroy)
Next (Division)

Name
Divide

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Divide ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (Division)


Sepi

Sepi
Previous (Divide)
Next (Factorial)

Name
Division

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function Division ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Divide)
Next (Factorial)


Sepi

Sepi
Previous (Division)
Next (FactorialOf)

Name
Factorial

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Factorial

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Division)
Next (FactorialOf)


Sepi

Sepi
Previous (Factorial)
Next (GetAsExtended)

Name
FactorialOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function FactorialOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Factorial)
Next (GetAsExtended)


Sepi

Sepi
Previous (FactorialOf)
Next (GetAsInteger)

Name
GetAsExtended

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetAsExtended : Extended

Parameters
Parameter Description

Return
Types | Description
EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FactorialOf)
Next (GetAsInteger)


Sepi

Sepi
Previous (GetAsExtended)
Next (GetAsNatural)

Name
GetAsInteger

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetAsInteger : Int64

Parameters
Parameter Description

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAsExtended)
Next (GetAsNatural)


Sepi

Sepi
Previous (GetAsInteger)
Next (GetCoefficients)

Name
GetAsNatural

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetAsNatural : Int64

Parameters
Parameter Description

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAsInteger)
Next (GetCoefficients)


Sepi

Sepi
Previous (GetAsNatural)
Next (GetIsExtended)

Name
GetCoefficients

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetCoefficients ( Exponent : Integer ) : Extended

Parameters
Parameter | Description
Exponent : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAsNatural)
Next (GetIsExtended)


Sepi

Sepi
Previous (GetCoefficients)
Next (GetIsInteger)

Name
GetIsExtended

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetIsExtended : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCoefficients)
Next (GetIsInteger)


Sepi

Sepi
Previous (GetIsExtended)
Next (GetIsNatural)

Name
GetIsInteger

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetIsInteger : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsExtended)
Next (GetIsNatural)


Sepi

Sepi
Previous (GetIsInteger)
Next (GetIsZero)

Name
GetIsNatural

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetIsNatural : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsInteger)
Next (GetIsZero)


Sepi

Sepi
Previous (GetIsNatural)
Next (GetMaxDegree)

Name
GetIsZero

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetIsZero : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsNatural)
Next (GetMaxDegree)


Sepi

Sepi
Previous (GetIsZero)
Next (GetMinDegree)

Name
GetMaxDegree

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetMaxDegree : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsZero)
Next (GetMinDegree)


Sepi

Sepi
Previous (GetMaxDegree)
Next (GetNegDegree)

Name
GetMinDegree

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetMinDegree : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetMaxDegree)
Next (GetNegDegree)


Sepi

Sepi
Previous (GetMinDegree)
Next (GetPosDegree)

Name
GetNegDegree

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetNegDegree : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetMinDegree)
Next (GetPosDegree)


Sepi

Sepi
Previous (GetNegDegree)
Next (Insert)

Name
GetPosDegree

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetPosDegree : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNegDegree)
Next (Insert)


Sepi

Sepi
Previous (GetPosDegree)
Next (InsertOf)

Name
Insert

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Insert ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetPosDegree)
Next (InsertOf)


Sepi

Sepi
Previous (Insert)
Next (LoadFromStream)

Name
InsertOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function InsertOf ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Insert)
Next (LoadFromStream)


Sepi

Sepi
Previous (InsertOf)
Next (Modulo)

Name
LoadFromStream

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure LoadFromStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InsertOf)
Next (Modulo)


Sepi

Sepi
Previous (LoadFromStream)
Next (ModuloOf)

Name
Modulo

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Modulo ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadFromStream)
Next (ModuloOf)


Sepi

Sepi
Previous (Modulo)
Next (Multiplication)

Name
ModuloOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function ModuloOf ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Modulo)
Next (Multiplication)


Sepi

Sepi
Previous (ModuloOf)
Next (Multiply)

Name
Multiplication

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function Multiplication ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ModuloOf)
Next (Multiply)


Sepi

Sepi
Previous (Multiplication)
Next (Oppose)

Name
Multiply

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Multiply ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Multiplication)
Next (Oppose)


Sepi

Sepi
Previous (Multiply)
Next (OpposedOf)

Name
Oppose

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Oppose

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Multiply)
Next (OpposedOf)


Sepi

Sepi
Previous (Oppose)
Next (Power)

Name
OpposedOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function OpposedOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Oppose)
Next (Power)


Sepi

Sepi
Previous (OpposedOf)
Next (PowerOf)

Name
Power

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Power ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpposedOf)
Next (PowerOf)


Sepi

Sepi
Previous (Power)
Next (Reverse)

Name
PowerOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function PowerOf ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Power)
Next (Reverse)


Sepi

Sepi
Previous (PowerOf)
Next (ReversedOf)

Name
Reverse

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Reverse

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PowerOf)
Next (ReversedOf)


Sepi

Sepi
Previous (Reverse)
Next (Root)

Name
ReversedOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function ReversedOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Reverse)
Next (Root)


Sepi

Sepi
Previous (ReversedOf)
Next (RootOf)

Name
Root

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Root ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ReversedOf)
Next (RootOf)


Sepi

Sepi
Previous (Root)
Next (SaveToStream)

Name
RootOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function RootOf ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Root)
Next (SaveToStream)


Sepi

Sepi
Previous (RootOf)
Next (ScalarProd)

Name
SaveToStream

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SaveToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (RootOf)
Next (ScalarProd)


Sepi

Sepi
Previous (SaveToStream)
Next (ScalarProdOf)

Name
ScalarProd

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ScalarProd ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SaveToStream)
Next (ScalarProdOf)


Sepi

Sepi
Previous (ScalarProd)
Next (SetAsExtended)

Name
ScalarProdOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function ScalarProdOf ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ScalarProd)
Next (SetAsExtended)


Sepi

Sepi
Previous (ScalarProdOf)
Next (SetAsInteger)

Name
SetAsExtended

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetAsExtended ( New : Extended )

Parameters
Parameter | Description
New : EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ScalarProdOf)
Next (SetAsInteger)


Sepi

Sepi
Previous (SetAsExtended)
Next (SetCoefficients)

Name
SetAsInteger

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetAsInteger ( New : Int64 )

Parameters
Parameter | Description
New : INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetAsExtended)
Next (SetCoefficients)


Sepi

Sepi
Previous (SetAsInteger)
Next (SetToZero)

Name
SetCoefficients

Parent
TPolynom

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetCoefficients ( Exponent : Integer ; New : Extended )

Parameters
Parameter | Description
Exponent : INTEGER | #Pas de TAG trouvé dans le code source#
New : EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetAsInteger)
Next (SetToZero)


Sepi

Sepi
Previous (SetCoefficients)
Next (Sinus)

Name
SetToZero

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetToZero

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (SetCoefficients)
Next (Sinus)


Sepi

Sepi
Previous (SetToZero)
Next (SinusOf)

Name
Sinus

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Sinus

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (SetToZero)
Next (SinusOf)


Sepi

Sepi
Previous (Sinus)
Next (Sub)

Name
SinusOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function SinusOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Sinus)
Next (Sub)


Sepi

Sepi
Previous (SinusOf)
Next (Substraction)

Name
Sub

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Sub ( Source : TPolynom )

Parameters
Parameter | Description
Source : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SinusOf)
Next (Substraction)


Sepi

Sepi
Previous (Sub)
Next (Tangent)

Name
Substraction

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function Substraction ( Val1 , Val2 : TPolynom ; ReleaseVals : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Val1 : TPolynom | #Pas de TAG trouvé dans le code source#
Val2 : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseVals : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Sub)
Next (Tangent)


Sepi

Sepi
Previous (Substraction)
Next (TangentOf)

Name
Tangent

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Tangent

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Substraction)
Next (TangentOf)


Sepi

Sepi
Previous (Tangent)
Next (ToString)

Name
TangentOf

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
class function TangentOf ( Value : TPolynom ; ReleaseValue : Boolean = False ) : TPolynom

Parameters
Parameter | Description
Value : TPolynom | #Pas de TAG trouvé dans le code source#
ReleaseValue : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Tangent)
Next (ToString)


Sepi

Sepi
Previous (TangentOf)
Next

Name
ToString

Parent
TPolynom

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function ToString : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (TangentOf)
Next


Sepi

Sepi
Previous (TPolynom)
Next

Name
TPolynomList

Parent
ScMaths

Class Hierarchy
TObject

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
FPolynoms (-) | #No TAG found in source code#

Methods
Method | Description
ADD (+) | #No TAG found in source code#
Clear (+) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
CreateFromFile (+) | #No TAG found in source code#
CreateFromStream (+) | #No TAG found in source code#
Delete (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#
Extract (+) | #No TAG found in source code#
GetCount (-) | #No TAG found in source code#
GetOwnsObjects (-) | #No TAG found in source code#
GetPolynoms (-) | #No TAG found in source code#
Insert (+) | #No TAG found in source code#
LoadFromFile (+) | #No TAG found in source code#
LoadFromStream (+) | #No TAG found in source code#
SaveToFile (+) | #No TAG found in source code#
SaveToStream (+) | #No TAG found in source code#
SetOwnsObjects (-) | #No TAG found in source code#
SetPolynoms (-) | #No TAG found in source code#

Properties
Property | Description
Count (+) | #No TAG found in source code#
OwnsObjects (+) | #No TAG found in source code#
Polynoms (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TPolynom)
Next


Sepi

Sepi
Previous
Next

Name
FPolynoms

Parent
TPolynomList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FPolynoms : TObjectList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (OwnsObjects)

Name
Count

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Count : Integer read GetCount

Read Access
GetCount

Sepi
Class Tree
Index
Previous
Next (OwnsObjects)


Sepi

Sepi
Previous (Count)
Next (Polynoms)

Name
OwnsObjects

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property OwnsObjects : Boolean read GetOwnsObjects write SetOwnsObjects

Read Access
GetOwnsObjects

Write Access
SetOwnsObjects

Sepi
Class Tree
Index
Previous (Count)
Next (Polynoms)


Sepi

Sepi
Previous (OwnsObjects)
Next

Name
Polynoms

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Polynoms [ Index : Integer ] : TPolynom read GetPolynoms write SetPolynoms ; default

Read Access
GetPolynoms

Write Access
SetPolynoms

Sepi
Class Tree
Index
Previous (OwnsObjects)
Next


Sepi

Sepi
Previous
Next (Clear)

Name
ADD

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Add ( New : TPolynom ) : Integer

Parameters
Parameter | Description
New : TPolynom | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Clear)


Sepi

Sepi
Previous (ADD)
Next (Create)

Name
Clear

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Clear

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ADD)
Next (Create)


Sepi

Sepi
Previous (Clear)
Next (CreateFromFile)

Name
Create

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( AOwnsObjects : Boolean = False )

Parameters
Parameter | Description
AOwnsObjects : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clear)
Next (CreateFromFile)


Sepi

Sepi
Previous (Create)
Next (CreateFromStream)

Name
CreateFromFile

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateFromFile ( FileName : string ; AOwnsObjects : Boolean = False )

Parameters
Parameter | Description
FileName : STRING | #Pas de TAG trouvé dans le code source#
AOwnsObjects : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (CreateFromStream)


Sepi

Sepi
Previous (CreateFromFile)
Next (Delete)

Name
CreateFromStream

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateFromStream ( Stream : TStream ; AOwnsObjects : Boolean = False )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#
AOwnsObjects : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateFromFile)
Next (Delete)


Sepi

Sepi
Previous (CreateFromStream)
Next (Destroy)

Name
Delete

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Delete ( Index : Integer )

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateFromStream)
Next (Destroy)


Sepi

Sepi
Previous (Delete)
Next (Extract)

Name
Destroy

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Delete)
Next (Extract)


Sepi

Sepi
Previous (Destroy)
Next (GetCount)

Name
Extract

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Extract ( Polynom : TPolynom ) : TPolynom

Parameters
Parameter | Description
Polynom : TPolynom | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetCount)


Sepi

Sepi
Previous (Extract)
Next (GetOwnsObjects)

Name
GetCount

Parent
TPolynomList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Extract)
Next (GetOwnsObjects)


Sepi

Sepi
Previous (GetCount)
Next (GetPolynoms)

Name
GetOwnsObjects

Parent
TPolynomList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetOwnsObjects : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCount)
Next (GetPolynoms)


Sepi

Sepi
Previous (GetOwnsObjects)
Next (Insert)

Name
GetPolynoms

Parent
TPolynomList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetPolynoms ( Index : Integer ) : TPolynom

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetOwnsObjects)
Next (Insert)


Sepi

Sepi
Previous (GetPolynoms)
Next (LoadFromFile)

Name
Insert

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Insert ( Index : Integer ; New : TPolynom ) : Integer

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#
New : TPolynom | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetPolynoms)
Next (LoadFromFile)


Sepi

Sepi
Previous (Insert)
Next (LoadFromStream)

Name
LoadFromFile

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure LoadFromFile ( FileName : string )

Parameters
Parameter | Description
FileName : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Insert)
Next (LoadFromStream)


Sepi

Sepi
Previous (LoadFromFile)
Next (SaveToFile)

Name
LoadFromStream

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure LoadFromStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadFromFile)
Next (SaveToFile)


Sepi

Sepi
Previous (LoadFromStream)
Next (SaveToStream)

Name
SaveToFile

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SaveToFile ( FileName : string )

Parameters
Parameter | Description
FileName : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadFromStream)
Next (SaveToStream)


Sepi

Sepi
Previous (SaveToFile)
Next (SetOwnsObjects)

Name
SaveToStream

Parent
TPolynomList

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SaveToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SaveToFile)
Next (SetOwnsObjects)


Sepi

Sepi
Previous (SaveToStream)
Next (SetPolynoms)

Name
SetOwnsObjects

Parent
TPolynomList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetOwnsObjects ( New : Boolean )

Parameters
Parameter | Description
New : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SaveToStream)
Next (SetPolynoms)


Sepi

Sepi
Previous (SetOwnsObjects)
Next

Name
SetPolynoms

Parent
TPolynomList

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetPolynoms ( Index : Integer ; New : TPolynom )

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#
New : TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetOwnsObjects)
Next


Sepi

Sepi
Previous
Next (TScalarProdFunc)

Name
TComplex

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
TComplex = type Variant ;

Sepi
Class Tree
Index
Previous
Next (TScalarProdFunc)


Sepi

Sepi
Previous (TComplex)
Next (TTestIsAbortedProc)

Name
TScalarProdFunc

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
TScalarProdFunc = function ( Left , Right : TPolynom ) : Extended ;

Parameters
Parameter | Description
Left : TPolynom | #Pas de TAG trouvé dans le code source#
Right : TPolynom | #Pas de TAG trouvé dans le code source#

Return
Types | Description
EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (TComplex)
Next (TTestIsAbortedProc)


Sepi

Sepi
Previous (TScalarProdFunc)
Next

Name
TTestIsAbortedProc

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
TTestIsAbortedProc = procedure of object ;

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (TScalarProdFunc)
Next


Sepi

Sepi
Previous
Next (MinValueEver)

Name
BinaryOperators

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
BinaryOperators = [ '+' , '-' , '*' , '/' , '%' , '^' , 'r' , 'o' , '|' ]

Sepi
Class Tree
Index
Previous
Next (MinValueEver)


Sepi

Sepi
Previous (BinaryOperators)
Next (MonomsChars)

Name
MinValueEver

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
MinValueEver = 1e-16

Sepi
Class Tree
Index
Previous (BinaryOperators)
Next (MonomsChars)


Sepi

Sepi
Previous (MinValueEver)
Next (UnaryOperators)

Name
MonomsChars

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
MonomsChars = [ '0' .. '9' , '' , 'x' , 'e' , 'E' , ',' , '.' ]

Sepi
Class Tree
Index
Previous (MinValueEver)
Next (UnaryOperators)


Sepi

Sepi
Previous (MonomsChars)
Next (VarsListsCount)

Name
UnaryOperators

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
UnaryOperators = [ '' , 'a' , 's' , 'c' , 't' , 'S' , 'C' , 'T' , '²' , '\' , '!' , 'v' , 'w' ]

Sepi
Class Tree
Index
Previous (MonomsChars)
Next (VarsListsCount)


Sepi

Sepi
Previous (UnaryOperators)
Next

Name
VarsListsCount

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
VarsListsCount = 2

Sepi
Class Tree
Index
Previous (UnaryOperators)
Next


Sepi

Sepi
Previous
Next (VarsLists)

Name
ScalarProdFunc

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ScalarProdFunc : TScalarProdFunc

Sepi
Class Tree
Index
Previous
Next (VarsLists)


Sepi

Sepi
Previous (ScalarProdFunc)
Next

Name
VarsLists

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
VarsLists : array [ 0 .. VarsListsCount - 1 ] of TPolynomList

Sepi
Class Tree
Index
Previous (ScalarProdFunc)
Next


Sepi

Sepi
Previous
Next (AsNatural)

Name
AsInteger

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function AsInteger ( X : Extended ) : Int64

Parameters
Parameter | Description
X : EXTENDED | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AsNatural)


Sepi

Sepi
Previous (AsInteger)
Next (DefaultScalarProd)

Name
AsNatural

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function AsNatural ( X : Int64 ) : Int64

Parameters
Parameter | Description
X : INT64 | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AsInteger)
Next (DefaultScalarProd)


Sepi

Sepi
Previous (AsNatural)
Next (Eval)

Name
DefaultScalarProd

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function DefaultScalarProd ( Left , Right : TPolynom ) : Extended

Parameters
Parameter | Description
Left : TPolynom | #Pas de TAG trouvé dans le code source#
Right : TPolynom | #Pas de TAG trouvé dans le code source#

Return
Types | Description
EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AsNatural)
Next (Eval)


Sepi

Sepi
Previous (DefaultScalarProd)
Next (Factorial)

Name
Eval

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Eval ( Expression : string ; TestIsAborted : TTestIsAbortedProc = nil ) : TPolynom

Parameters
Parameter | Description
Expression : STRING | #Pas de TAG trouvé dans le code source#
TestIsAborted : TTestIsAbortedProc | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TPolynom | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (DefaultScalarProd)
Next (Factorial)


Sepi

Sepi
Previous (Eval)
Next (IntPower)

Name
Factorial

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Factorial ( X : Int64 ) : Int64

Parameters
Parameter | Description
X : INT64 | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Eval)
Next (IntPower)


Sepi

Sepi
Previous (Factorial)
Next (IsInteger)

Name
IntPower

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function IntPower ( Base , Exponent : LongWord ) : LongWord

Parameters
Parameter | Description
Base : LONGWORD | #Pas de TAG trouvé dans le code source#
Exponent : LONGWORD | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGWORD | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Factorial)
Next (IsInteger)


Sepi

Sepi
Previous (IntPower)
Next (IsNatural)

Name
IsInteger

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function IsInteger ( X : Extended ) : Boolean

Parameters
Parameter | Description
X : EXTENDED | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IntPower)
Next (IsNatural)


Sepi

Sepi
Previous (IsInteger)
Next (VerifyIsInteger)

Name
IsNatural

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function IsNatural ( X : Int64 ) : Boolean

Parameters
Parameter | Description
X : INT64 | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsInteger)
Next (VerifyIsInteger)


Sepi

Sepi
Previous (IsNatural)
Next (VerifyIsNatural)

Name
VerifyIsInteger

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure VerifyIsInteger ( X : Extended )

Parameters
Parameter | Description
X : EXTENDED | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsNatural)
Next (VerifyIsNatural)


Sepi

Sepi
Previous (VerifyIsInteger)
Next

Name
VerifyIsNatural

Parent
ScMaths

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure VerifyIsNatural ( X : Int64 )

Parameters
Parameter | Description
X : INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (VerifyIsInteger)
Next


Sepi

Sepi
Previous (ScMaths)
Next (ScNoSecretWindow)

Name
ScMD5

Parent
Sepi

Description
Gestion de hashes MD5

Author
RSA Data Security, Inc.

Version
1.0

Types
Type | Description
PMD5Digest (+) | Pointeur vers un TMD5Digest

Constants
Constant Description

Variables
Variable Description

Methods
Method | Description
MD5Buffer (+) | Calcule le hash MD5 d'un buffer en mémoire
MD5DigestCompare (+) | Compare deux hashes MD5
MD5DigestToStr (+) | Convertit un hash MD5 en chaîne de caractères
MD5File (+) | Calcule le hash MD5 d'un fichier
MD5Stream (+) | Calcule le hash MD5 d'un flux
MD5String (+) | Calcule le hash MD5 d'une chaîne de caractères
StrToMD5Digest (+) | Convertit une chaîne de caractères en hash MD5

Classes
Class | Description
TMD5Digest (+) | Représente un hash MD5

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScMaths)
Next (ScNoSecretWindow)


Sepi

Sepi
Previous
Next

Name
TMD5Digest

Parent
ScMD5

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Représente un hash MD5

Members
Fields
Field | Description
A (*) | #No TAG found in source code#
B (*) | #No TAG found in source code#
C (*) | #No TAG found in source code#
D (*) | #No TAG found in source code#
V (*) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (B)

Name
A

Parent
TMD5Digest

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
A , B , C , D : Longint

Sepi
Class Tree
Index
Previous
Next (B)


Sepi

Sepi
Previous (A)
Next (C)

Name
B

Parent
TMD5Digest

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
A , B , C , D : Longint

Sepi
Class Tree
Index
Previous (A)
Next (C)


Sepi

Sepi
Previous (B)
Next (D)

Name
C

Parent
TMD5Digest

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
A , B , C , D : Longint

Sepi
Class Tree
Index
Previous (B)
Next (D)


Sepi

Sepi
Previous (C)
Next (V)

Name
D

Parent
TMD5Digest

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
A , B , C , D : Longint

Sepi
Class Tree
Index
Previous (C)
Next (V)


Sepi

Sepi
Previous (D)
Next

Name
V

Parent
TMD5Digest

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
V : array [ 0 .. 15 ] of Byte

Sepi
Class Tree
Index
Previous (D)
Next


Sepi

Sepi
Previous
Next

Name
PMD5Digest

Parent
ScMD5

Visibility
PUBLIC

Description
Pointeur vers un TMD5Digest

Source code
PMD5Digest = ^ TMD5Digest ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (MD5DigestCompare)

Name
MD5Buffer

Parent
ScMD5

Visibility
PUBLIC

Description
Calcule le hash MD5 d'un buffer en mémoire

Source code
function MD5Buffer ( const Buffer ; Size : Integer ) : TMD5Digest

Parameters
Parameter | Description
Buffer : Untyped | Adresse du buffer
Size : INTEGER | Taille du buffer

Return
Types | Description
TMD5Digest | Hash MD5 du buffer

Sepi
Class Tree
Index
Previous
Next (MD5DigestCompare)


Sepi

Sepi
Previous (MD5Buffer)
Next (MD5DigestToStr)

Name
MD5DigestCompare

Parent
ScMD5

Visibility
PUBLIC

Description
Compare deux hashes MD5

Source code
function MD5DigestCompare ( const Digest1 , Digest2 : TMD5Digest ) : Boolean

Parameters
Parameter | Description
Digest1 : TMD5Digest | Premier hash MD5
Digest2 : TMD5Digest | Second hash MD5

Return
Types | Description
BOOLEAN | True si les deux hashes sont identiques, False sinon

Sepi
Class Tree
Index
Previous (MD5Buffer)
Next (MD5DigestToStr)


Sepi

Sepi
Previous (MD5DigestCompare)
Next (MD5File)

Name
MD5DigestToStr

Parent
ScMD5

Visibility
PUBLIC

Description
Convertit un hash MD5 en chaîne de caractères

Source code
function MD5DigestToStr ( const Digest : TMD5Digest ) : string

Parameters
Parameter | Description
Digest : TMD5Digest | Hash MD5 à convertir

Return
Types | Description
STRING | Représentation sous forme de chaîne du hash Digest

Sepi
Class Tree
Index
Previous (MD5DigestCompare)
Next (MD5File)


Sepi

Sepi
Previous (MD5DigestToStr)
Next (MD5Stream)

Name
MD5File

Parent
ScMD5

Visibility
PUBLIC

Description
Calcule le hash MD5 d'un fichier

Source code
function MD5File ( const FileName : TFileName ) : TMD5Digest

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier

Return
Types | Description
TMD5Digest | Hash MD5 du fichier FileName

Sepi
Class Tree
Index
Previous (MD5DigestToStr)
Next (MD5Stream)


Sepi

Sepi
Previous (MD5File)
Next (MD5String)

Name
MD5Stream

Parent
ScMD5

Visibility
PUBLIC

Description
Calcule le hash MD5 d'un flux

Source code
function MD5Stream ( const Stream : TStream ) : TMD5Digest

Parameters
Parameter | Description
Stream : TStream | Flux

Return
Types | Description
TMD5Digest | Hash MD5 du flux Stream

Sepi
Class Tree
Index
Previous (MD5File)
Next (MD5String)


Sepi

Sepi
Previous (MD5Stream)
Next (StrToMD5Digest)

Name
MD5String

Parent
ScMD5

Visibility
PUBLIC

Description
Calcule le hash MD5 d'une chaîne de caractères

Source code
function MD5String ( const S : string ) : TMD5Digest

Parameters
Parameter | Description
S : STRING | Chaîne de caractères

Return
Types | Description
TMD5Digest | Hash MD5 de la chaîne S

Sepi
Class Tree
Index
Previous (MD5Stream)
Next (StrToMD5Digest)


Sepi

Sepi
Previous (MD5String)
Next

Name
StrToMD5Digest

Parent
ScMD5

Visibility
PUBLIC

Description
Convertit une chaîne de caractères en hash MD5

Source code
function StrToMD5Digest ( Str : string ) : TMD5Digest

Parameters
Parameter | Description
Str : STRING | Chaîne de caractères à convertir

Return
Types | Description
TMD5Digest | Hash MD5 représenté par la chaîne Str

Sepi
Class Tree
Index
Previous (MD5String)
Next


Sepi

Sepi
Previous (ScMD5)
Next (ScPipes)

Name
ScNoSecretWindow

Parent
Sepi

Description
Empêche la création par Delphi de sa fenêtre secrète
Insérez cette unité en toute première position de la clause uses de l'unité
program (avant Forms). Vous vous débarrasserez ainsi de la fenêtre secrête.

Author
sjrd

Version
1.0

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScMD5)
Next (ScPipes)


Sepi

Sepi
Previous (ScNoSecretWindow)
Next (ScSerializer)

Name
ScPipes

Parent
Sepi

Description
Classes de gestion de pipes (tuyaux)

Author
sjrd

Version
1.0

Types
Type | Description
TTransformStreamMethod (+) | Méthode de transformation d'un flux

Constants
Constant | Description
DefaultBufferSize (+) | Taille de buffer par défaut
SBadBufferSize (+) | #No TAG found in source code#
SBufferIsntThatLarge (+) | #No TAG found in source code#
SInvalidStreamOp (+) | #No TAG found in source code#

Methods
Method | Description
CopyStream (+) | Copie un flux dans un autre
MakeCoroutineTransformStream (+) | Construit un flux par transformations multiples avec des coroutines
MakeThreadTransformStream (+) | Construit un flux par transformations multiples avec des threads
MultiCoroutineTransformStream (+) | Transforme plusieurs fois un flux en contrôlant le flot avec des coroutines
MultiThreadTransformStream (+) | Transforme plusieurs fois un flux en contrôlant le flot avec des threads
MultiThreadTransformStream (+) | Transforme plusieurs fois un flux en contrôlant le flot avec des threads

Classes
Class | Description
ETransformationStreamError (+) | Error de un flux de transformation
TCoroutineTransformationStream (+) | Flux de transformation dont le flot de contrôle est une coroutine
TThreadTransformationStream (+) | Flux de transformation dont le flot de contrôle est un thread
TTransformationStream (+) | Flux créé par transformation à la volée d'un autre flux

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScNoSecretWindow)
Next (ScSerializer)


Sepi

Sepi
Previous
Next (TCoroutineTransformationStream)

Name
ETransformationStreamError

Parent
ScPipes

Class Hierarchy
EInOutError

Visibility
PUBLIC

Description
Error de un flux de transformation

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TCoroutineTransformationStream)


Sepi

Sepi
Previous (ETransformationStreamError)
Next (TThreadTransformationStream)

Name
TCoroutineTransformationStream

Parent
ScPipes

Class Hierarchy
TTransformationStream

Visibility
PUBLIC

Description
Flux de transformation dont le flot de contrôle est une coroutine

Members
Fields
Field | Description
FBuffer (-) | Buffer de données entre les coroutines
FBufferSize (-) | Taille du buffer
FCoroutine (-) | Coroutine interne

Methods
Method | Description
Create (+) | Crée un flux par transformation
Create (+) | Crée un flux par transformation
Destroy (+) | [@inheritDoc]
PrivTransformStream (-) | Méthode d'exécution de la coroutine
READ (+) | [@inheritDoc]
WRITE (+) | [@inheritDoc]

Properties
Property | Description
Coroutine (#) | Coroutine interne

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ETransformationStreamError)
Next (TThreadTransformationStream)


Sepi

Sepi
Previous
Next (FBufferSize)

Name
FBuffer

Parent
TCoroutineTransformationStream

Visibility
PRIVATE

Description
Buffer de données entre les coroutines

Source code
FBuffer : Pointer

Sepi
Class Tree
Index
Previous
Next (FBufferSize)


Sepi

Sepi
Previous (FBuffer)
Next (FCoroutine)

Name
FBufferSize

Parent
TCoroutineTransformationStream

Visibility
PRIVATE

Description
Taille du buffer

Source code
FBufferSize : Integer

Sepi
Class Tree
Index
Previous (FBuffer)
Next (FCoroutine)


Sepi

Sepi
Previous (FBufferSize)
Next

Name
FCoroutine

Parent
TCoroutineTransformationStream

Visibility
PRIVATE

Description
Coroutine interne

Source code
FCoroutine : TCoroutine

Sepi
Class Tree
Index
Previous (FBufferSize)
Next


Sepi

Sepi
Previous
Next

Name
Coroutine

Parent
TCoroutineTransformationStream

Visibility
PROTECTED

Description
Coroutine interne

Source code
property Coroutine : TCoroutine read FCoroutine

Read Access
FCoroutine

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TCoroutineTransformationStream

Visibility
PUBLIC

Description
Crée un flux par transformation
Cette variante de Create doit être utilisée lorsque la méthode
TransformStream est surchargée, au lieu d'utiliser une méthode externe de
transformation.

Source code
constructor Create ( AInput : TStream = nil ; AOwnsInput : Boolean = False ) ; overload

Parameters
Parameter | Description
AInput : TStream | Flux entrant
AOwnsInput : BOOLEAN | True libère le flux d'entrée lors de la destruction

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TCoroutineTransformationStream

Visibility
PUBLIC

Description
Crée un flux par transformation
Cette variante de Create doit être utilisée lorsqu'on veut utiliser une
méthode externe de transformation.

Source code
constructor Create ( ATransformMethod : TTransformStreamMethod ; AInput : TStream ; AOwnsInput : Boolean = False ) ; overload

Parameters
Parameter | Description
ATransformMethod : TTransformStreamMethod | Méthode de transformation du flux
AInput : TStream | Flux entrant
AOwnsInput : BOOLEAN | True libère le flux d'entrée lors de la destruction

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (PrivTransformStream)

Name
Destroy

Parent
TCoroutineTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (PrivTransformStream)


Sepi

Sepi
Previous (Destroy)
Next (READ)

Name
PrivTransformStream

Parent
TCoroutineTransformationStream

Visibility
PRIVATE

Description
Méthode d'exécution de la coroutine

Source code
procedure PrivTransformStream ( Coroutine : TCoroutine )

Parameters
Parameter | Description
Coroutine : TCoroutine | Coroutine

Sepi
Class Tree
Index
Previous (Destroy)
Next (READ)


Sepi

Sepi
Previous (PrivTransformStream)
Next (WRITE)

Name
READ

Parent
TCoroutineTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Read ( var Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrivTransformStream)
Next (WRITE)


Sepi

Sepi
Previous (READ)
Next

Name
WRITE

Parent
TCoroutineTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Write ( const Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (READ)
Next


Sepi

Sepi
Previous (TCoroutineTransformationStream)
Next (TTransformationStream)

Name
TThreadTransformationStream

Parent
ScPipes

Class Hierarchy
TTransformationStream

Visibility
PUBLIC

Description
Flux de transformation dont le flot de contrôle est un thread

Members
Fields
Field | Description
FBuffer (-) | Buffer de données entre les coroutines
FBufferCount (-) | Taille des données valides dans le buffer
FBufferReadPos (-) | Position de lecture dans le buffer
FBufferSize (-) | Taille du buffer
FBufferWritePos (-) | Position dans le buffer
FReadSomethingEvent (-) | Quelque chose a été lu
FTerminated (-) | True lorsque le thread est terminé
FThread (-) | Thread interne
FWritePosition (-) | Position en écriture
FWrittenSomethingEvent (-) | Quelque chose a été écrit

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
BeforeDestruction (+) | [@inheritDoc]
Create (+) | Crée un flux par transformation
Create (+) | Crée un flux par transformation
Destroy (+) | [@inheritDoc]
IncWritePosition (#) | Augmente la variable interne de position en écriture dans le flux
InternalRead (#) | Lit une partie du buffer interne
InternalWrite (#) | Ecrit des données dans le buffer interne
PrivTransformStream (-) | Méthode d'exécution du thread
RaiseFatalException (#) | Déclenche dans le contexte courant l'exception fatale du thread
READ (+) | [@inheritDoc]
Seek (+) | [@inheritDoc]
ThreadTerminated (-) | Gestionnaire de l'événement OnTerminate du thread
WRITE (+) | [@inheritDoc]

Properties
Property | Description
BufferCount (#) | Taille des données valides dans le buffer
BufferSize (#) | Taille du buffer
ReadSomethingEvent (#) | Quelque chose a été lu
Terminated (#) | True lorsque le thread est terminé
Thread (#) | Thread interne
WrittenSomethingEvent (#) | Quelque chose a été écrit

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCoroutineTransformationStream)
Next (TTransformationStream)


Sepi

Sepi
Previous
Next (FBufferCount)

Name
FBuffer

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Buffer de données entre les coroutines

Source code
FBuffer : Pointer

Sepi
Class Tree
Index
Previous
Next (FBufferCount)


Sepi

Sepi
Previous (FBuffer)
Next (FBufferReadPos)

Name
FBufferCount

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Taille des données valides dans le buffer

Source code
FBufferCount : Integer

Sepi
Class Tree
Index
Previous (FBuffer)
Next (FBufferReadPos)


Sepi

Sepi
Previous (FBufferCount)
Next (FBufferSize)

Name
FBufferReadPos

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Position de lecture dans le buffer

Source code
FBufferReadPos : Integer

Sepi
Class Tree
Index
Previous (FBufferCount)
Next (FBufferSize)


Sepi

Sepi
Previous (FBufferReadPos)
Next (FBufferWritePos)

Name
FBufferSize

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Taille du buffer

Source code
FBufferSize : Integer

Sepi
Class Tree
Index
Previous (FBufferReadPos)
Next (FBufferWritePos)


Sepi

Sepi
Previous (FBufferSize)
Next (FReadSomethingEvent)

Name
FBufferWritePos

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Position dans le buffer

Source code
FBufferWritePos : Integer

Sepi
Class Tree
Index
Previous (FBufferSize)
Next (FReadSomethingEvent)


Sepi

Sepi
Previous (FBufferWritePos)
Next (FTerminated)

Name
FReadSomethingEvent

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Quelque chose a été lu

Source code
FReadSomethingEvent : TEvent

Sepi
Class Tree
Index
Previous (FBufferWritePos)
Next (FTerminated)


Sepi

Sepi
Previous (FReadSomethingEvent)
Next (FThread)

Name
FTerminated

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
True lorsque le thread est terminé

Source code
FTerminated : Boolean

Sepi
Class Tree
Index
Previous (FReadSomethingEvent)
Next (FThread)


Sepi

Sepi
Previous (FTerminated)
Next (FWritePosition)

Name
FThread

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Thread interne

Source code
FThread : TMethodThread

Sepi
Class Tree
Index
Previous (FTerminated)
Next (FWritePosition)


Sepi

Sepi
Previous (FThread)
Next (FWrittenSomethingEvent)

Name
FWritePosition

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Position en écriture

Source code
FWritePosition : Int64

Sepi
Class Tree
Index
Previous (FThread)
Next (FWrittenSomethingEvent)


Sepi

Sepi
Previous (FWritePosition)
Next

Name
FWrittenSomethingEvent

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Quelque chose a été écrit

Source code
FWrittenSomethingEvent : TEvent

Sepi
Class Tree
Index
Previous (FWritePosition)
Next


Sepi

Sepi
Previous
Next (BufferSize)

Name
BufferCount

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Taille des données valides dans le buffer

Source code
property BufferCount : Integer read FBufferCount

Read Access
FBufferCount

Sepi
Class Tree
Index
Previous
Next (BufferSize)


Sepi

Sepi
Previous (BufferCount)
Next (ReadSomethingEvent)

Name
BufferSize

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Taille du buffer

Source code
property BufferSize : Integer read FBufferSize

Read Access
FBufferSize

Sepi
Class Tree
Index
Previous (BufferCount)
Next (ReadSomethingEvent)


Sepi

Sepi
Previous (BufferSize)
Next (Terminated)

Name
ReadSomethingEvent

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Quelque chose a été lu

Source code
property ReadSomethingEvent : TEvent read FReadSomethingEvent

Read Access
FReadSomethingEvent

Sepi
Class Tree
Index
Previous (BufferSize)
Next (Terminated)


Sepi

Sepi
Previous (ReadSomethingEvent)
Next (Thread)

Name
Terminated

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
True lorsque le thread est terminé

Source code
property Terminated : Boolean read FTerminated

Read Access
FTerminated

Sepi
Class Tree
Index
Previous (ReadSomethingEvent)
Next (Thread)


Sepi

Sepi
Previous (Terminated)
Next (WrittenSomethingEvent)

Name
Thread

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Thread interne

Source code
property Thread : TMethodThread read FThread

Read Access
FThread

Sepi
Class Tree
Index
Previous (Terminated)
Next (WrittenSomethingEvent)


Sepi

Sepi
Previous (Thread)
Next

Name
WrittenSomethingEvent

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Quelque chose a été écrit

Source code
property WrittenSomethingEvent : TEvent read FWrittenSomethingEvent

Read Access
FWrittenSomethingEvent

Sepi
Class Tree
Index
Previous (Thread)
Next


Sepi

Sepi
Previous
Next (BeforeDestruction)

Name
AfterConstruction

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (BeforeDestruction)


Sepi

Sepi
Previous (AfterConstruction)
Next (Create)

Name
BeforeDestruction

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Create)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Create)

Name
Create

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
Crée un flux par transformation
Cette variante de Create doit être utilisée lorsqu'on veut utiliser une
méthode externe de transformation.

Source code
constructor Create ( ATransformMethod : TTransformStreamMethod ; AInput : TStream ; AOwnsInput : Boolean = False ; ABufferSize : Integer = DefaultBufferSize ) ; overload

Parameters
Parameter | Description
ATransformMethod : TTransformStreamMethod | Méthode de transformation du flux
AInput : TStream | Flux entrant
AOwnsInput : BOOLEAN | True libère le flux d'entrée lors de la destruction
ABufferSize : INTEGER

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
Crée un flux par transformation
Cette variante de Create doit être utilisée lorsque la méthode
TransformStream est surchargée, au lieu d'utiliser une méthode externe de
transformation.

Source code
constructor Create ( AInput : TStream = nil ; AOwnsInput : Boolean = False ; ABufferSize : Integer = DefaultBufferSize ) ; overload

Parameters
Parameter | Description
AInput : TStream | Flux entrant
AOwnsInput : BOOLEAN | True libère le flux d'entrée lors de la destruction
ABufferSize : INTEGER

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (IncWritePosition)

Name
Destroy

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (IncWritePosition)


Sepi

Sepi
Previous (Destroy)
Next (InternalRead)

Name
IncWritePosition

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Augmente la variable interne de position en écriture dans le flux

Source code
procedure IncWritePosition ( const Value : Int64 )

Parameters
Parameter | Description
Value : INT64 | Incrément de position

Sepi
Class Tree
Index
Previous (Destroy)
Next (InternalRead)


Sepi

Sepi
Previous (IncWritePosition)
Next (InternalWrite)

Name
InternalRead

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Lit une partie du buffer interne
InternalRead ne doit être appelé qu'avec une valeur de Count inférieure ou
égale à BufferCount.
Tout appel à InternalRead doit être protégé d'une concurrence avec un appel à
InternalWrite via la section critique CriticSec.

Source code
procedure InternalRead ( Dest : Pointer ; Count : Integer )

Parameters
Parameter | Description
Dest : Pointer
Count : INTEGER | Nombre d'octets à lire

Sepi
Class Tree
Index
Previous (IncWritePosition)
Next (InternalWrite)


Sepi

Sepi
Previous (InternalRead)
Next (PrivTransformStream)

Name
InternalWrite

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Ecrit des données dans le buffer interne
InternalWrite ne doit être appelé qu'avec une valeur de Count inférieure ou
égale à BufferSize-BufferCount.
Tout appel à InternalWrite doit être protégé d'une concurrence avec un appel
à InternalRead via la section critique CriticSec.

Source code
procedure InternalWrite ( Source : Pointer ; Count : Integer )

Parameters
Parameter | Description
Source : Pointer
Count : INTEGER | Nombre d'octets à lire

Sepi
Class Tree
Index
Previous (InternalRead)
Next (PrivTransformStream)


Sepi

Sepi
Previous (InternalWrite)
Next (RaiseFatalException)

Name
PrivTransformStream

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Méthode d'exécution du thread

Source code
procedure PrivTransformStream ( Thread : TMethodThread )

Parameters
Parameter | Description
Thread : TMethodThread | Thread

Sepi
Class Tree
Index
Previous (InternalWrite)
Next (RaiseFatalException)


Sepi

Sepi
Previous (PrivTransformStream)
Next (READ)

Name
RaiseFatalException

Parent
TThreadTransformationStream

Visibility
PROTECTED

Description
Déclenche dans le contexte courant l'exception fatale du thread
En réalité, RaiseFatalException crée une copie grossière de l'exception
générée au départ. En effet, TThread ne permet pas d'indiquer qu'il ne faut
plus libérer FatalException, et l'on ne peut donc pas déclencher cette
exception exactement.

Source code
procedure RaiseFatalException

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PrivTransformStream)
Next (READ)


Sepi

Sepi
Previous (RaiseFatalException)
Next (Seek)

Name
READ

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Read ( var Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (RaiseFatalException)
Next (Seek)


Sepi

Sepi
Previous (READ)
Next (ThreadTerminated)

Name
Seek

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Seek ( const Offset : Int64 ; Origin : TSeekOrigin ) : Int64 ; override

Parameters
Parameter | Description
OFFSET : INT64 | #Pas de TAG trouvé dans le code source#
Origin : TSeekOrigin | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (READ)
Next (ThreadTerminated)


Sepi

Sepi
Previous (Seek)
Next (WRITE)

Name
ThreadTerminated

Parent
TThreadTransformationStream

Visibility
PRIVATE

Description
Gestionnaire de l'événement OnTerminate du thread

Source code
procedure ThreadTerminated ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement

Sepi
Class Tree
Index
Previous (Seek)
Next (WRITE)


Sepi

Sepi
Previous (ThreadTerminated)
Next

Name
WRITE

Parent
TThreadTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Write ( const Buffer ; Count : Longint ) : Longint ; override

Parameters
Parameter | Description
Buffer : Untyped | #Pas de TAG trouvé dans le code source#
Count : LONGINT | #Pas de TAG trouvé dans le code source#

Return
Types | Description
LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ThreadTerminated)
Next


Sepi

Sepi
Previous (TThreadTransformationStream)
Next

Name
TTransformationStream

Parent
ScPipes

Class Hierarchy
TStream

Visibility
PUBLIC

Description
Flux créé par transformation à la volée d'un autre flux

Members
Fields
Field | Description
FInput (-) | Flux entrant
FOwnsInput (-) | Possède le flux entrant
FPosition (-) | Position du flux
FTransformMethod (-) | Méthode de transformation

Methods
Method | Description
Create (+) | Crée un flux par transformation
Create (+) | Crée un flux par transformation
Destroy (+) | [@inheritDoc]
Error (+) | Déclenche une erreur ETransformationStreamError
Error (+) | Déclenche une erreur ETransformationStreamError
IncPosition (#) | Augmente la variable interne de position dans le flux
Seek (+) | [@inheritDoc]
TransformStream (#) | Transforme le flux

Properties
Property | Description
Input (#) | Flux entrant
TransformMethod (#) | Méthode de transformation

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TThreadTransformationStream)
Next


Sepi

Sepi
Previous
Next (FOwnsInput)

Name
FInput

Parent
TTransformationStream

Visibility
PRIVATE

Description
Flux entrant

Source code
FInput : TStream

Sepi
Class Tree
Index
Previous
Next (FOwnsInput)


Sepi

Sepi
Previous (FInput)
Next (FPosition)

Name
FOwnsInput

Parent
TTransformationStream

Visibility
PRIVATE

Description
Possède le flux entrant

Source code
FOwnsInput : Boolean

Sepi
Class Tree
Index
Previous (FInput)
Next (FPosition)


Sepi

Sepi
Previous (FOwnsInput)
Next (FTransformMethod)

Name
FPosition

Parent
TTransformationStream

Visibility
PRIVATE

Description
Position du flux

Source code
FPosition : Int64

Sepi
Class Tree
Index
Previous (FOwnsInput)
Next (FTransformMethod)


Sepi

Sepi
Previous (FPosition)
Next

Name
FTransformMethod

Parent
TTransformationStream

Visibility
PRIVATE

Description
Méthode de transformation

Source code
FTransformMethod : TTransformStreamMethod

Sepi
Class Tree
Index
Previous (FPosition)
Next


Sepi

Sepi
Previous
Next (TransformMethod)

Name
Input

Parent
TTransformationStream

Visibility
PROTECTED

Description
Flux entrant

Source code
property Input : TStream read FInput

Read Access
FInput

Sepi
Class Tree
Index
Previous
Next (TransformMethod)


Sepi

Sepi
Previous (Input)
Next

Name
TransformMethod

Parent
TTransformationStream

Visibility
PROTECTED

Description
Méthode de transformation

Source code
property TransformMethod : TTransformStreamMethod read FTransformMethod

Read Access
FTransformMethod

Sepi
Class Tree
Index
Previous (Input)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TTransformationStream

Visibility
PUBLIC

Description
Crée un flux par transformation
Cette variante de Create doit être utilisée lorsqu'on veut utiliser une
méthode externe de transformation.

Source code
constructor Create ( ATransformMethod : TTransformStreamMethod ; AInput : TStream ; AOwnsInput : Boolean = False ) ; overload

Parameters
Parameter | Description
ATransformMethod : TTransformStreamMethod | Méthode de transformation du flux
AInput : TStream | Flux entrant
AOwnsInput : BOOLEAN | True libère le flux d'entrée lors de la destruction

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TTransformationStream

Visibility
PUBLIC

Description
Crée un flux par transformation
Cette variante de Create doit être utilisée lorsque la méthode
TransformStream est surchargée, au lieu d'utiliser une méthode externe de
transformation.

Source code
constructor Create ( AInput : TStream = nil ; AOwnsInput : Boolean = False ) ; overload

Parameters
Parameter | Description
AInput : TStream | Flux entrant (défaut = nil)
AOwnsInput : BOOLEAN | True libère le flux d'entrée lors de la destruction

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Error)

Name
Destroy

Parent
TTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Error)


Sepi

Sepi
Previous (Destroy)
Next (Error)

Name
Error

Parent
TTransformationStream

Visibility
PUBLIC

Description
Déclenche une erreur ETransformationStreamError

Source code
class procedure Error ( const Msg : string ; Data : Integer = 0 ) ; overload ; virtual

Parameters
Parameter | Description
Msg : STRING | Chaîne de format du message
Data : INTEGER | Paramètre du format

Sepi
Class Tree
Index
Previous (Destroy)
Next (Error)


Sepi

Sepi
Previous (Error)
Next (IncPosition)

Name
Error

Parent
TTransformationStream

Visibility
PUBLIC

Description
Déclenche une erreur ETransformationStreamError

Source code
class procedure Error ( Msg : PResStringRec ; Data : Integer = 0 ) ; overload

Parameters
Parameter | Description
Msg : PResStringRec | Chaîne de ressource de format du message
Data : INTEGER | Paramètre du format

Sepi
Class Tree
Index
Previous (Error)
Next (IncPosition)


Sepi

Sepi
Previous (Error)
Next (Seek)

Name
IncPosition

Parent
TTransformationStream

Visibility
PROTECTED

Description
Augmente la variable interne de position dans le flux

Source code
procedure IncPosition ( const Value : Int64 )

Parameters
Parameter | Description
Value : INT64 | Incrément de position

Sepi
Class Tree
Index
Previous (Error)
Next (Seek)


Sepi

Sepi
Previous (IncPosition)
Next (TransformStream)

Name
Seek

Parent
TTransformationStream

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Seek ( const Offset : Int64 ; Origin : TSeekOrigin ) : Int64 ; override

Parameters
Parameter | Description
OFFSET : INT64 | #Pas de TAG trouvé dans le code source#
Origin : TSeekOrigin | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INT64 | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IncPosition)
Next (TransformStream)


Sepi

Sepi
Previous (Seek)
Next

Name
TransformStream

Parent
TTransformationStream

Visibility
PROTECTED

Description
Transforme le flux

Source code
procedure TransformStream ; dynamic

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Seek)
Next


Sepi

Sepi
Previous
Next

Name
TTransformStreamMethod

Parent
ScPipes

Visibility
PUBLIC

Description
Méthode de transformation d'un flux

Source code
TTransformStreamMethod = procedure ( Input , Output : TStream ) of object ;

Parameters
Parameter | Description
Input : TStream | #Pas de TAG trouvé dans le code source#
Output : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (SBadBufferSize)

Name
DefaultBufferSize

Parent
ScPipes

Visibility
PUBLIC

Description
Taille de buffer par défaut

Source code
DefaultBufferSize = 4096

Sepi
Class Tree
Index
Previous
Next (SBadBufferSize)


Sepi

Sepi
Previous (DefaultBufferSize)
Next (SBufferIsntThatLarge)

Name
SBadBufferSize

Parent
ScPipes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBadBufferSize = 'Taille de buffer incorrecte (%d)'

Sepi
Class Tree
Index
Previous (DefaultBufferSize)
Next (SBufferIsntThatLarge)


Sepi

Sepi
Previous (SBadBufferSize)
Next (SInvalidStreamOp)

Name
SBufferIsntThatLarge

Parent
ScPipes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBufferIsntThatLarge = 'Le buffer ne contient pas %d octets'

Sepi
Class Tree
Index
Previous (SBadBufferSize)
Next (SInvalidStreamOp)


Sepi

Sepi
Previous (SBufferIsntThatLarge)
Next

Name
SInvalidStreamOp

Parent
ScPipes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidStreamOp = 'Opération de flux incorrecte'

Sepi
Class Tree
Index
Previous (SBufferIsntThatLarge)
Next


Sepi

Sepi
Previous
Next (MakeCoroutineTransformStream)

Name
CopyStream

Parent
ScPipes

Visibility
PUBLIC

Description
Copie un flux dans un autre
CopyStream, contrairement à TStream.CopyFrom, ne déplace jamais le curseur de
la source, et ne suppose pas que la propriété Source.Size est accessible.

Source code
procedure CopyStream ( Source , Dest : TStream )

Parameters
Parameter | Description
Source : TStream | Flux source
Dest : TStream | Flux destination

Sepi
Class Tree
Index
Previous
Next (MakeCoroutineTransformStream)


Sepi

Sepi
Previous (CopyStream)
Next (MakeThreadTransformStream)

Name
MakeCoroutineTransformStream

Parent
ScPipes

Visibility
PUBLIC

Description
Construit un flux par transformations multiples avec des coroutines
Les longueurs des tableaux Transformations et StackSizes doivent être
identiques.

Source code
function MakeCoroutineTransformStream ( Input : TStream ; const Transformations : array of TTransformStreamMethod ; FreeInput : Boolean = True ) : TStream

Parameters
Parameter | Description
Input : TStream | Flux d'entrée de la première transformation
Transformations : TTransformStreamMethod | Tableau de transformations à appliquer
FreeInput : BOOLEAN | True libère le flux d'entrée, même en cas d'exception

Return
Types | Description
TStream | Flux de transformations multiples

Sepi
Class Tree
Index
Previous (CopyStream)
Next (MakeThreadTransformStream)


Sepi

Sepi
Previous (MakeCoroutineTransformStream)
Next (MultiCoroutineTransformStream)

Name
MakeThreadTransformStream

Parent
ScPipes

Visibility
PUBLIC

Description
Construit un flux par transformations multiples avec des threads
Les longueurs des tableaux Transformations et BufferSizes doivent être
identiques.

Source code
function MakeThreadTransformStream ( Input : TStream ; const Transformations : array of TTransformStreamMethod ; const BufferSizes : array of Integer ; FreeInput : Boolean = True ) : TStream

Parameters
Parameter | Description
Input : TStream | Flux d'entrée de la première transformation
Transformations : TTransformStreamMethod | Tableau de transformations à appliquer
BufferSizes : INTEGER | Tailles de buffer pour chaque transformation
FreeInput : BOOLEAN | True libère le flux d'entrée, même en cas d'exception

Return
Types | Description
TStream | Flux de transformations multiples

Sepi
Class Tree
Index
Previous (MakeCoroutineTransformStream)
Next (MultiCoroutineTransformStream)


Sepi

Sepi
Previous (MakeThreadTransformStream)
Next (MultiThreadTransformStream)

Name
MultiCoroutineTransformStream

Parent
ScPipes

Visibility
PUBLIC

Description
Transforme plusieurs fois un flux en contrôlant le flot avec des coroutines
Les longueurs des tableaux Transformations et StackSizes doivent être
identiques.

Source code
procedure MultiCoroutineTransformStream ( Input , Output : TStream ; const Transformations : array of TTransformStreamMethod ; FreeInput : Boolean = False )

Parameters
Parameter | Description
Input : TStream | Flux d'entrée de la première transformation
Output : TStream
Transformations : TTransformStreamMethod | Tableau de transformations à appliquer
FreeInput : BOOLEAN | True libère le flux d'entrée, même en cas d'exception

Sepi
Class Tree
Index
Previous (MakeThreadTransformStream)
Next (MultiThreadTransformStream)


Sepi

Sepi
Previous (MultiCoroutineTransformStream)
Next (MultiThreadTransformStream)

Name
MultiThreadTransformStream

Parent
ScPipes

Visibility
PUBLIC

Description
Transforme plusieurs fois un flux en contrôlant le flot avec des threads

Source code
procedure MultiThreadTransformStream ( Input , Output : TStream ; const Transformations : array of TTransformStreamMethod ; BufferSize : Integer = DefaultBufferSize ; FreeInput : Boolean = False ) ; overload

Parameters
Parameter | Description
Input : TStream | Flux d'entrée de la première transformation
Output : TStream
Transformations : TTransformStreamMethod | Tableau de transformations à appliquer
BufferSize : INTEGER | Taille de buffer pour toutes les transformations
FreeInput : BOOLEAN | True libère le flux d'entrée, même en cas d'exception

Sepi
Class Tree
Index
Previous (MultiCoroutineTransformStream)
Next (MultiThreadTransformStream)


Sepi

Sepi
Previous (MultiThreadTransformStream)
Next

Name
MultiThreadTransformStream

Parent
ScPipes

Visibility
PUBLIC

Description
Transforme plusieurs fois un flux en contrôlant le flot avec des threads
Les longueurs des tableaux Transformations et BufferSizes doivent être
identiques.

Source code
procedure MultiThreadTransformStream ( Input , Output : TStream ; const Transformations : array of TTransformStreamMethod ; const BufferSizes : array of Integer ; FreeInput : Boolean = False ) ; overload

Parameters
Parameter | Description
Input : TStream | Flux d'entrée de la première transformation
Output : TStream
Transformations : TTransformStreamMethod | Tableau de transformations à appliquer
BufferSizes : INTEGER | Tailles de buffer pour chaque transformation
FreeInput : BOOLEAN | True libère le flux d'entrée, même en cas d'exception

Sepi
Class Tree
Index
Previous (MultiThreadTransformStream)
Next


Sepi

Sepi
Previous (ScPipes)
Next (ScStrUtils)

Name
ScSerializer

Parent
Sepi

Description
Routines de sérialisation de données non classes

Author
sjrd

Version
1.0

Constants
Constant | Description
SCantSerializeType (+) | #No TAG found in source code#

Methods
Method | Description
ReadDataFromStream (+) | Lit des données depuis un flux
ReadDataFromStream (+) | Lit des données depuis un flux
WriteDataToStream (+) | Écrit des données dans un flux
WriteDataToStream (+) | Écrit des données dans un flux

Classes
Class | Description
ESerializerError (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScPipes)
Next (ScStrUtils)


Sepi

Sepi
Previous
Next

Name
ESerializerError

Parent
ScSerializer

Class Hierarchy
Exception

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SCantSerializeType

Parent
ScSerializer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantSerializeType = 'Impossible de sérialiser le type %s'

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ReadDataFromStream)

Name
ReadDataFromStream

Parent
ScSerializer

Visibility
PUBLIC

Description
Lit des données depuis un flux
ReadDataFromStream relit des données qui ont été écrites avec
WriteDataToStream.

Source code
procedure ReadDataFromStream ( Stream : TStream ; var Data ; TypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
Stream : TStream | Flux source
Data : Untyped | Destination
TypeInfo : PTypeInfo | RTTI du type de données

Sepi
Class Tree
Index
Previous
Next (ReadDataFromStream)


Sepi

Sepi
Previous (ReadDataFromStream)
Next (WriteDataToStream)

Name
ReadDataFromStream

Parent
ScSerializer

Visibility
PUBLIC

Description
Lit des données depuis un flux
ReadDataFromStream relit des données qui ont été écrites avec
WriteDataToStream.

Source code
procedure ReadDataFromStream ( Stream : TStream ; var Data ; Size : Integer ; TypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
Stream : TStream | Flux source
Data : Untyped | Destination
Size : INTEGER
TypeInfo : PTypeInfo | RTTI du type de données

Sepi
Class Tree
Index
Previous (ReadDataFromStream)
Next (WriteDataToStream)


Sepi

Sepi
Previous (ReadDataFromStream)
Next (WriteDataToStream)

Name
WriteDataToStream

Parent
ScSerializer

Visibility
PUBLIC

Description
Écrit des données dans un flux
WriteDataToStream peut sérialiser correctement des chaînes ANSI et Unicode,
des tableaux statiques ou dynamiques, et des record. Cette routine ne peut
pas sérialiser les variants ni les interfaces.

Source code
procedure WriteDataToStream ( Stream : TStream ; const Data ; TypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
Stream : TStream | Flux de destination
Data : Untyped | Source
TypeInfo : PTypeInfo | RTTI du type de données

Sepi
Class Tree
Index
Previous (ReadDataFromStream)
Next (WriteDataToStream)


Sepi

Sepi
Previous (WriteDataToStream)
Next

Name
WriteDataToStream

Parent
ScSerializer

Visibility
PUBLIC

Description
Écrit des données dans un flux
WriteDataToStream peut sérialiser correctement des chaînes ANSI et Unicode,
des tableaux statiques ou dynamiques, et des record. Cette routine ne peut
pas sérialiser les variants ni les interfaces.

Source code
procedure WriteDataToStream ( Stream : TStream ; const Data ; Size : Integer ; TypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
Stream : TStream | Flux de destination
Data : Untyped | Source
Size : INTEGER
TypeInfo : PTypeInfo | RTTI du type de données

Sepi
Class Tree
Index
Previous (WriteDataToStream)
Next


Sepi

Sepi
Previous (ScSerializer)
Next (ScSyncObjs)

Name
ScStrUtils

Parent
Sepi

Description
Définit quelques routines de gestion de chaînes

Author
sjrd

Version
1.0

Types
Type | Description
TCompareStrOption (+) | Option de comparaison de chaînes
TCompareStrOptions (+) | Ensemble d'options de comparaison de chaînes

Methods
Method | Description
CompareStringEx (+) | Compare deux chaînes de caractères avec des options avancées
CompareVersion (+) | Compare deux numéros de version selon les règles de comparaison GNU
ExtractFirstToken (+) | Extrait la première sous-chaîne d'une chaîne et la supprime de l'originale
ExtractLastToken (+) | Extrait la dernière sous-chaîne d'une chaîne et la supprime de l'originale
GetFirstToken (+) | Découpe une chaîne selon un délimiteur et récupère la première sous-chaîne
GetLastToken (+) | Découpe une chaîne selon un délimiteur et récupère la dernière sous-chaîne
GetXToken (+) | Découpe une chaîne selon un délimiteur et récupère la Xème sous-chaîne
GetXWord (+) | Découpe une chaîne en mots et récupère le Xème mot
HashOfStr (+) | Calcule le hash d'une chaîne de caractères selon l'algorithme de TStringHash
NberCharInStr (+) | Calcule le nombre d'occurences d'un caractère dans une chaîne
NberSubStr (+) | Calcule le nombre d'occurences d'une sous-chaîne dans une chaîne
PosWord (+) | Cherche la première occurence d'un mot dans une chaîne
RightPos (+) | Cherche un caractère dans une chaîne à partir de la fin de celle-ci
SplitToken (+) | Découpe une chaîne en deux selon un délimiteur
SplitTokenAll (+) | Découpe une chaîne en morceaux selon un délimiteur

Classes
Class Description

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScSerializer)
Next (ScSyncObjs)


Sepi

Sepi
Previous
Next (TCompareStrOptions)

Name
TCompareStrOption

Parent
ScStrUtils

Visibility
PUBLIC

Description
Option de comparaison de chaînes
coIgnoreCase : Ignore la casse
coIgnoreNonSpace : Ignore les accents
coIgnoreSymbols : Ignore les symboles

Source code
TCompareStrOption = ( coIgnoreCase , coIgnoreNonSpace , coIgnoreSymbols ) ;

Sepi
Class Tree
Index
Previous
Next (TCompareStrOptions)


Sepi

Sepi
Previous (TCompareStrOption)
Next

Name
TCompareStrOptions

Parent
ScStrUtils

Visibility
PUBLIC

Description
Ensemble d'options de comparaison de chaînes

Source code
TCompareStrOptions = set of TCompareStrOption ;

Sepi
Class Tree
Index
Previous (TCompareStrOption)
Next


Sepi

Sepi
Previous
Next (CompareVersion)

Name
CompareStringEx

Parent
ScStrUtils

Visibility
PUBLIC

Description
Compare deux chaînes de caractères avec des options avancées

Source code
function CompareStringEx ( const S1 , S2 : string ; CompareOptions : TCompareStrOptions = [ ] ) : Integer ; platform

Parameters
Parameter | Description
S1 : STRING | Première chaîne
S2 : STRING | Seconde chaîne
CompareOptions : TCompareStrOptions | Options de comparaison

Return
Types Description
INTEGER 0 si les chaînes sont semblables, un nombre positif si la première
est supérieure à la seconde, un nombre négatif dans le cas inverse

Sepi
Class Tree
Index
Previous
Next (CompareVersion)


Sepi

Sepi
Previous (CompareStringEx)
Next (ExtractFirstToken)

Name
CompareVersion

Parent
ScStrUtils

Visibility
PUBLIC

Description
Compare deux numéros de version selon les règles de comparaison GNU

Source code
function CompareVersion ( const Left , Right : string ) : TValueRelationship

Parameters
Parameter | Description
Left : STRING | Numéro de version de gauche
Right : STRING | Numéro de version de droite

Return
Types | Description
TValueRelationship | -1 si Left < Right, 1 si Left > Right, 0 si Left = Right

Sepi
Class Tree
Index
Previous (CompareStringEx)
Next (ExtractFirstToken)


Sepi

Sepi
Previous (CompareVersion)
Next (ExtractLastToken)

Name
ExtractFirstToken

Parent
ScStrUtils

Visibility
PUBLIC

Description
Extrait la première sous-chaîne d'une chaîne et la supprime de l'originale

Source code
function ExtractFirstToken ( var S : string ; Token : Char ) : string

Parameters
Parameter | Description
S : STRING | Chaîne à découper
Token : CHAR | Délimiteur

Return
Types | Description
STRING | La première sous-chaîne de S délimitée par Token (ou S si non trouvé)

Sepi
Class Tree
Index
Previous (CompareVersion)
Next (ExtractLastToken)


Sepi

Sepi
Previous (ExtractFirstToken)
Next (GetFirstToken)

Name
ExtractLastToken

Parent
ScStrUtils

Visibility
PUBLIC

Description
Extrait la dernière sous-chaîne d'une chaîne et la supprime de l'originale

Source code
function ExtractLastToken ( var S : string ; Token : Char ) : string

Parameters
Parameter | Description
S : STRING | Chaîne à découper
Token : CHAR | Délimiteur

Return
Types | Description
STRING | La dernière sous-chaîne de S délimitée par Token (ou S si non trouvé)

Sepi
Class Tree
Index
Previous (ExtractFirstToken)
Next (GetFirstToken)


Sepi

Sepi
Previous (ExtractLastToken)
Next (GetLastToken)

Name
GetFirstToken

Parent
ScStrUtils

Visibility
PUBLIC

Description
Découpe une chaîne selon un délimiteur et récupère la première sous-chaîne

Source code
function GetFirstToken ( const S : string ; Token : Char ) : string

Parameters
Parameter | Description
S : STRING | Chaîne à découper
Token : CHAR | Délimiteur

Return
Types | Description
STRING | La première sous-chaîne de S délimitée par Token (ou S si non trouvé)

Sepi
Class Tree
Index
Previous (ExtractLastToken)
Next (GetLastToken)


Sepi

Sepi
Previous (GetFirstToken)
Next (GetXToken)

Name
GetLastToken

Parent
ScStrUtils

Visibility
PUBLIC

Description
Découpe une chaîne selon un délimiteur et récupère la dernière sous-chaîne

Source code
function GetLastToken ( const S : string ; Token : Char ) : string

Parameters
Parameter | Description
S : STRING | Chaîne à découper
Token : CHAR | Délimiteur

Return
Types | Description
STRING | La dernière sous-chaîne de S délimitée par Token (ou S si non trouvé)

Sepi
Class Tree
Index
Previous (GetFirstToken)
Next (GetXToken)


Sepi

Sepi
Previous (GetLastToken)
Next (GetXWord)

Name
GetXToken

Parent
ScStrUtils

Visibility
PUBLIC

Description
Découpe une chaîne selon un délimiteur et récupère la Xème sous-chaîne

Source code
function GetXToken ( const S : string ; Token : Char ; X : Integer ) : string

Parameters
Parameter | Description
S : STRING | Chaîne à découper
Token : CHAR | Délimiteur
X : INTEGER | Index base sur 1 de la sous-chaîne à récupérer

Return
Types | Description
STRING | La Xème sous-chaîne de S délimitée par Token (ou '' si X trop grand)

Sepi
Class Tree
Index
Previous (GetLastToken)
Next (GetXWord)


Sepi

Sepi
Previous (GetXToken)
Next (HashOfStr)

Name
GetXWord

Parent
ScStrUtils

Visibility
PUBLIC

Description
Découpe une chaîne en mots et récupère le Xème mot
Les mots sont délimités par des espaces uniquement.

Source code
function GetXWord ( const S : string ; X : Integer ) : string

Parameters
Parameter | Description
S : STRING | Chaîne à découper
X : INTEGER | Index base sur 1 du mot à récupérer

Return
Types | Description
STRING | Le Xème mot de S (ou '' si X trop grand)

Sepi
Class Tree
Index
Previous (GetXToken)
Next (HashOfStr)


Sepi

Sepi
Previous (GetXWord)
Next (NberCharInStr)

Name
HashOfStr

Parent
ScStrUtils

Visibility
PUBLIC

Description
Calcule le hash d'une chaîne de caractères selon l'algorithme de TStringHash

Source code
function HashOfStr ( const Str : string ) : Cardinal

Parameters
Parameter | Description
Str : STRING | Chaîne de caractères

Return
Types | Description
CARDINAL | Hash de Str selon l'algorithme utilisé par IniFiles.TStringHash

Sepi
Class Tree
Index
Previous (GetXWord)
Next (NberCharInStr)


Sepi

Sepi
Previous (HashOfStr)
Next (NberSubStr)

Name
NberCharInStr

Parent
ScStrUtils

Visibility
PUBLIC

Description
Calcule le nombre d'occurences d'un caractère dans une chaîne

Source code
function NberCharInStr ( C : Char ; const Str : string ) : Integer

Parameters
Parameter | Description
C : CHAR | Caractère à chercher
Str : STRING | Chaîne dans laquelle chercher C

Return
Types | Description
INTEGER | Nombre d'occurences de C dans Str

Sepi
Class Tree
Index
Previous (HashOfStr)
Next (NberSubStr)


Sepi

Sepi
Previous (NberCharInStr)
Next (PosWord)

Name
NberSubStr

Parent
ScStrUtils

Visibility
PUBLIC

Description
Calcule le nombre d'occurences d'une sous-chaîne dans une chaîne

Source code
function NberSubStr ( const SubStr , Str : string ) : Integer

Parameters
Parameter | Description
SubStr : STRING | Sous-chaîne à chercher
Str : STRING | Chaîne dans laquelle chercher SubStr

Return
Types | Description
INTEGER | Nombre d'occurences de SubStr dans Str

Sepi
Class Tree
Index
Previous (NberCharInStr)
Next (PosWord)


Sepi

Sepi
Previous (NberSubStr)
Next (RightPos)

Name
PosWord

Parent
ScStrUtils

Visibility
PUBLIC

Description
Cherche la première occurence d'un mot dans une chaîne
Les mots sont délimités par des espaces uniquement.

Source code
function PosWord ( const Wrd , Str : string ; Index : Integer = 1 ) : Integer

Parameters
Parameter | Description
Wrd : STRING | Mot à chercher
Str : STRING | Chaîne dans laquelle chercher le mot
INDEX : INTEGER | Position dans la chaîne à partir de laquelle chercher le mot

Return
Types | Description
INTEGER | La position du premier caractère du mot dans la chaîne

Sepi
Class Tree
Index
Previous (NberSubStr)
Next (RightPos)


Sepi

Sepi
Previous (PosWord)
Next (SplitToken)

Name
RightPos

Parent
ScStrUtils

Visibility
PUBLIC

Description
Cherche un caractère dans une chaîne à partir de la fin de celle-ci

Source code
function RightPos ( C : Char ; const Str : string ) : Integer

Parameters
Parameter | Description
C : CHAR | Caractère à rechercher
Str : STRING | Chaîne dans laquelle rechercher C

Return
Types | Description
INTEGER | Index de la dernière occurence de C dans Str, ou 0 si non trouvé

Sepi
Class Tree
Index
Previous (PosWord)
Next (SplitToken)


Sepi

Sepi
Previous (RightPos)
Next (SplitTokenAll)

Name
SplitToken

Parent
ScStrUtils

Visibility
PUBLIC

Description
Découpe une chaîne en deux selon un délimiteur
Si plusieurs délimiteurs consécutifs sont trouvés, ils sont considérés comme
un seul. Mais s'ils sont séparés, seul le premier groupe prendra effet.

Source code
function SplitToken ( const S : string ; Token : Char ; out LeftStr , RightStr : string ) : Boolean

Parameters
Parameter | Description
S : STRING | Chaîne à découper
Token : CHAR | Délimiteur
LeftStr : STRING | Sous-chaîne de gauche (ou S si non trouvé)
RightStr : STRING | Sous-chaîne de droite (ou une chaîne vide si non trouvé)

Return
Types | Description
BOOLEAN | True si la chaîne a été séparée, False si Token n'est pas trouvé

Sepi
Class Tree
Index
Previous (RightPos)
Next (SplitTokenAll)


Sepi

Sepi
Previous (SplitToken)
Next

Name
SplitTokenAll

Parent
ScStrUtils

Visibility
PUBLIC

Description
Découpe une chaîne en morceaux selon un délimiteur

Source code
function SplitTokenAll ( const S : string ; Token : Char ) : TStringDynArray

Parameters
Parameter | Description
S : STRING | Chaîne à découper
Token : CHAR | Délimiteur

Return
Types | Description
TStringDynArray | Tableau des morceaux de la chaîne

Sepi
Class Tree
Index
Previous (SplitToken)
Next


Sepi

Sepi
Previous (ScStrUtils)
Next (ScTypInfo)

Name
ScSyncObjs

Parent
Sepi

Description
Définit des classes de synchronisations entre threads

Author
sjrd

Version
1.0

Types
Type | Description
TScTaskState (+) | État d'une tâche

Methods
Method | Description
InterlockedDecrement (+) | Décrémente un compteur de façon thread-safe
InterlockedIncrement (+) | Incrémente un compteur de façon thread-safe

Classes
Class | Description
TScCustomMessageTask (+) | Tâche de répartition de message
TScCustomMethodTask (+) | Tâche d'exécution d'une méthode d'un objet
TScCustomTaskQueue (+) | Gestionnaire de file (FIFO) de tâches
TScMessageTask (+) | Tâche de répartition de message
TScMethodTask (+) | Tâche d'exécution d'une méthode d'un objet
TScTask (+) | Tâche gérée par une instance de TScTaskQueue
TScTaskQueue (+) | Gestionnaire de file (FIFO) de tâches

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScStrUtils)
Next (ScTypInfo)


Sepi

Sepi
Previous
Next (TScCustomMethodTask)

Name
TScCustomMessageTask

Parent
ScSyncObjs

Class Hierarchy
TScTask

Visibility
PUBLIC

Description
Tâche de répartition de message
TScCustomMessageTask fournit une implémentation protégée d'une tâche de
dispatching de message.

Members
Fields
Field | Description
FDestObj (-) | Objet auquel délivrer le message
FMsg (-) | Pointeur sur le message
FMsgSize (-) | Taille du message

Methods
Method | Description
Create (+) | Crée une nouvelle tâche de message
Create (+) | Crée une nouvelle tâche de message
Destroy (+) | [@inheritDoc]
Execute (#) | [@inheritDoc]
GetMsg (#) | Récupère une copie du message

Properties
Property | Description
DestObj (#) | Objet auquel délivrer le message
Msg (#) | Pointeur sur le message
MsgSize (#) | Taille du message

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TScCustomMethodTask)


Sepi

Sepi
Previous
Next (FMsg)

Name
FDestObj

Parent
TScCustomMessageTask

Visibility
PRIVATE

Description
Objet auquel délivrer le message

Source code
FDestObj : TObject

Sepi
Class Tree
Index
Previous
Next (FMsg)


Sepi

Sepi
Previous (FDestObj)
Next (FMsgSize)

Name
FMsg

Parent
TScCustomMessageTask

Visibility
PRIVATE

Description
Pointeur sur le message

Source code
FMsg : Pointer

Sepi
Class Tree
Index
Previous (FDestObj)
Next (FMsgSize)


Sepi

Sepi
Previous (FMsg)
Next

Name
FMsgSize

Parent
TScCustomMessageTask

Visibility
PRIVATE

Description
Taille du message

Source code
FMsgSize : Integer

Sepi
Class Tree
Index
Previous (FMsg)
Next


Sepi

Sepi
Previous
Next (Msg)

Name
DestObj

Parent
TScCustomMessageTask

Visibility
PROTECTED

Description
Objet auquel délivrer le message

Source code
property DestObj : TObject read FDestObj

Read Access
FDestObj

Sepi
Class Tree
Index
Previous
Next (Msg)


Sepi

Sepi
Previous (DestObj)
Next (MsgSize)

Name
Msg

Parent
TScCustomMessageTask

Visibility
PROTECTED

Description
Pointeur sur le message

Source code
property Msg : Pointer read FMsg

Read Access
FMsg

Sepi
Class Tree
Index
Previous (DestObj)
Next (MsgSize)


Sepi

Sepi
Previous (Msg)
Next

Name
MsgSize

Parent
TScCustomMessageTask

Visibility
PROTECTED

Description
Taille du message

Source code
property MsgSize : Integer read FMsgSize

Read Access
FMsgSize

Sepi
Class Tree
Index
Previous (Msg)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TScCustomMessageTask

Visibility
PUBLIC

Description
Crée une nouvelle tâche de message

Source code
constructor Create ( AOwner : TScCustomTaskQueue ; const AMsg ; AMsgSize : Integer ; ADestObj : TObject ; AFreeOnFinished : Boolean ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | File de tâches propriétaire
AMsg : Untyped | Message
AMsgSize : INTEGER | Taille du message
ADestObj : TObject | Objet auquel délivrer le message
AFreeOnFinished : BOOLEAN | Valeur de la propriété FreeOnFinished

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TScCustomMessageTask

Visibility
PUBLIC

Description
Crée une nouvelle tâche de message

Source code
constructor Create ( AOwner : TScCustomTaskQueue ; const AMsg ; AMsgSize : Integer ; ADestObj : TObject ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | File de tâches propriétaire
AMsg : Untyped | Message
AMsgSize : INTEGER | Taille du message
ADestObj : TObject | Objet auquel délivrer le message

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Destroy

Parent
TScCustomMessageTask

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Destroy)
Next (GetMsg)

Name
Execute

Parent
TScCustomMessageTask

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Execute ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetMsg)


Sepi

Sepi
Previous (Execute)
Next

Name
GetMsg

Parent
TScCustomMessageTask

Visibility
PROTECTED

Description
Récupère une copie du message

Source code
procedure GetMsg ( out Msg )

Parameters
Parameter | Description
Msg : Untyped | Emplacement où copier le message

Sepi
Class Tree
Index
Previous (Execute)
Next


Sepi

Sepi
Previous (TScCustomMessageTask)
Next (TScCustomTaskQueue)

Name
TScCustomMethodTask

Parent
ScSyncObjs

Class Hierarchy
TScTask

Visibility
PUBLIC

Description
Tâche d'exécution d'une méthode d'un objet
TScCustomMethodTask fournit une implémentation protégée d'une tâche
d'exécution d'une méthode d'un objet.

Members
Fields
Field | Description
FMethod (-) | Méthode à exécuter

Methods
Method | Description
Create (+) | Crée une nouvelle tâche de méthode
Create (+) | Crée une nouvelle tâche de méthode
Execute (#) | [@inheritDoc]

Properties
Property | Description
Method (#) | Méthode à exécuter

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScCustomMessageTask)
Next (TScCustomTaskQueue)


Sepi

Sepi
Previous
Next

Name
FMethod

Parent
TScCustomMethodTask

Visibility
PRIVATE

Description
Méthode à exécuter

Source code
FMethod : TThreadMethod

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Method

Parent
TScCustomMethodTask

Visibility
PROTECTED

Description
Méthode à exécuter

Source code
property Method : TThreadMethod read FMethod

Read Access
FMethod

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TScCustomMethodTask

Visibility
PUBLIC

Description
Crée une nouvelle tâche de méthode

Source code
constructor Create ( AOwner : TScCustomTaskQueue ; AMethod : TThreadMethod ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | File de tâches propriétaire
AMethod : TThreadMethod | Méthode à exécuter

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Create

Parent
TScCustomMethodTask

Visibility
PUBLIC

Description
Crée une nouvelle tâche de méthode

Source code
constructor Create ( AOwner : TScCustomTaskQueue ; AMethod : TThreadMethod ; AFreeOnFinished : Boolean ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | File de tâches propriétaire
AMethod : TThreadMethod | Méthode à exécuter
AFreeOnFinished : BOOLEAN | Valeur de la propriété FreeOnFinished

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Create)
Next

Name
Execute

Parent
TScCustomMethodTask

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Execute ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TScCustomMethodTask)
Next (TScMessageTask)

Name
TScCustomTaskQueue

Parent
ScSyncObjs

Class Hierarchy
TThread

Visibility
PUBLIC

Description
Gestionnaire de file (FIFO) de tâches
TScCustomTaskQueue est une classe de base pour l'implémentation de files de
tâches, qui s'exécutent de façon synchrone entre elles, mais asynchrone par
rapport au contrôleur.
Puisque TScCustomTaskQueue hérite de TThread au lieu de l'encapsuler, le
contrôleur a plein accès sur le déroulement du thread de répartition.
Un appel à la méthode Terminate mettra fin à la répartition des tâches,
même si la file n'est pas vide.
Pour attendre que la liste des messages en attente soit vide, utilisez la
propriété Ready, et non la méthode WaitFor. Pour attendre qu'une tâche en
particulier soit terminée, les descendants de TScCustomTaskQueue peuvent
offrir l'accès aux objets TScTask, qui proposent une méthode WaitFor.
Vous pouvez positionner la propriété TerminateOnException à False si vous
ne voulez pas que le traitement des messages s'arrête en cas d'exception
lors de l'un d'eux.
Les descendants de TScTaskQueue ne devraient normalement pas réimplémenter
la méthode Execute.

Members
Fields
Field | Description
FCriticalSection (-) | Section critique sur la liste
FDefaultFreeOnFinished (-) | Valeur par défaut de la propriété FreeOnFinished des tâches de la file
FReady (-) | Indique si la file a terminé son travail
FTerminateOnException (-) | Indique si le thread d'exécution doit se terminer en cas d'exception
FWaitingQueue (-) | File des messages en attente

Methods
Method | Description
BeforeDestruction (+) | [@inheritDoc]
Cancel (-) | Retire une tâche de la file d'attente
Create (+) | Crée une liste de tâches
Destroy (+) | [@inheritDoc]
Execute (#) | [@inheritDoc]
Pop (-) | Récupère la tâche suivante dans la file d'attente
Push (-) | Ajoute une tâche à la file

Properties
Property | Description
CriticalSection (#) | Section critique sur la liste
DefaultFreeOnFinished (#) | Valeur par défaut de la propriété FreeOnFinished des tâches de la file
Ready (#) | Indique si la file a terminé son travail
TerminateOnException (#) | Indique si le thread d'exécution doit se terminer en cas d'exception
WaitingQueue (#) | File des messages en attente

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScCustomMethodTask)
Next (TScMessageTask)


Sepi

Sepi
Previous
Next (FDefaultFreeOnFinished)

Name
FCriticalSection

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
Section critique sur la liste

Source code
FCriticalSection : TCriticalSection

Sepi
Class Tree
Index
Previous
Next (FDefaultFreeOnFinished)


Sepi

Sepi
Previous (FCriticalSection)
Next (FReady)

Name
FDefaultFreeOnFinished

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
Valeur par défaut de la propriété FreeOnFinished des tâches de la file

Source code
FDefaultFreeOnFinished : Boolean

Sepi
Class Tree
Index
Previous (FCriticalSection)
Next (FReady)


Sepi

Sepi
Previous (FDefaultFreeOnFinished)
Next (FTerminateOnException)

Name
FReady

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
Indique si la file a terminé son travail

Source code
FReady : Boolean

Sepi
Class Tree
Index
Previous (FDefaultFreeOnFinished)
Next (FTerminateOnException)


Sepi

Sepi
Previous (FReady)
Next (FWaitingQueue)

Name
FTerminateOnException

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
Indique si le thread d'exécution doit se terminer en cas d'exception

Source code
FTerminateOnException : Boolean

Sepi
Class Tree
Index
Previous (FReady)
Next (FWaitingQueue)


Sepi

Sepi
Previous (FTerminateOnException)
Next

Name
FWaitingQueue

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
File des messages en attente

Source code
FWaitingQueue : TScWaitingObjectQueue

Sepi
Class Tree
Index
Previous (FTerminateOnException)
Next


Sepi

Sepi
Previous
Next (DefaultFreeOnFinished)

Name
CriticalSection

Parent
TScCustomTaskQueue

Visibility
PROTECTED

Description
Section critique sur la liste

Source code
property CriticalSection : TCriticalSection read FCriticalSection

Read Access
FCriticalSection

Sepi
Class Tree
Index
Previous
Next (DefaultFreeOnFinished)


Sepi

Sepi
Previous (CriticalSection)
Next (Ready)

Name
DefaultFreeOnFinished

Parent
TScCustomTaskQueue

Visibility
PROTECTED

Description
Valeur par défaut de la propriété FreeOnFinished des tâches de la file

Source code
property DefaultFreeOnFinished : Boolean read FDefaultFreeOnFinished write FDefaultFreeOnFinished

Read Access
FDefaultFreeOnFinished

Write Access
FDefaultFreeOnFinished

Sepi
Class Tree
Index
Previous (CriticalSection)
Next (Ready)


Sepi

Sepi
Previous (DefaultFreeOnFinished)
Next (TerminateOnException)

Name
Ready

Parent
TScCustomTaskQueue

Visibility
PROTECTED

Description
Indique si la file a terminé son travail

Source code
property Ready : Boolean read FReady

Read Access
FReady

Sepi
Class Tree
Index
Previous (DefaultFreeOnFinished)
Next (TerminateOnException)


Sepi

Sepi
Previous (Ready)
Next (WaitingQueue)

Name
TerminateOnException

Parent
TScCustomTaskQueue

Visibility
PROTECTED

Description
Indique si le thread d'exécution doit se terminer en cas d'exception

Source code
property TerminateOnException : Boolean read FTerminateOnException write FTerminateOnException

Read Access
FTerminateOnException

Write Access
FTerminateOnException

Sepi
Class Tree
Index
Previous (Ready)
Next (WaitingQueue)


Sepi

Sepi
Previous (TerminateOnException)
Next

Name
WaitingQueue

Parent
TScCustomTaskQueue

Visibility
PROTECTED

Description
File des messages en attente

Source code
property WaitingQueue : TScWaitingObjectQueue read FWaitingQueue

Read Access
FWaitingQueue

Sepi
Class Tree
Index
Previous (TerminateOnException)
Next


Sepi

Sepi
Previous
Next (Cancel)

Name
BeforeDestruction

Parent
TScCustomTaskQueue

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Cancel)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Create)

Name
Cancel

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
Retire une tâche de la file d'attente

Source code
procedure Cancel ( Task : TScTask )

Parameters
Parameter | Description
Task : TScTask | Tâche à retirer

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Create)


Sepi

Sepi
Previous (Cancel)
Next (Destroy)

Name
Create

Parent
TScCustomTaskQueue

Visibility
PUBLIC

Description
Crée une liste de tâches

Source code
constructor Create ( ADefaultFreeOnFinished : Boolean = True ; ATerminateOnException : Boolean = True )

Parameters
Parameter | Description
ADefaultFreeOnFinished : BOOLEAN | Valeur de la propriété DefaultFreeOnFinished
ATerminateOnException : BOOLEAN | Valeur de la propriété TerminateOnException

Sepi
Class Tree
Index
Previous (Cancel)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Destroy

Parent
TScCustomTaskQueue

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Destroy)
Next (Pop)

Name
Execute

Parent
TScCustomTaskQueue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Execute ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (Pop)


Sepi

Sepi
Previous (Execute)
Next (Push)

Name
Pop

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
Récupère la tâche suivante dans la file d'attente

Source code
function Pop : TScTask

Parameters
Parameter Description

Return
Types | Description
TScTask | La prochaine tâche dans la file, ou nil si aucune tâche

Sepi
Class Tree
Index
Previous (Execute)
Next (Push)


Sepi

Sepi
Previous (Pop)
Next

Name
Push

Parent
TScCustomTaskQueue

Visibility
PRIVATE

Description
Ajoute une tâche à la file

Source code
procedure Push ( Task : TScTask )

Parameters
Parameter | Description
Task : TScTask | Tâche à ajouter

Sepi
Class Tree
Index
Previous (Pop)
Next


Sepi

Sepi
Previous (TScCustomTaskQueue)
Next (TScMethodTask)

Name
TScMessageTask

Parent
ScSyncObjs

Class Hierarchy
TScCustomMessageTask

Visibility
PUBLIC

Description
Tâche de répartition de message
TScMessageTask est une version publique de TScCustomMessageTask.

Members
Methods
Method | Description
Cancel (+) | [@inheritDoc]
GetMsg (+) | [@inheritDoc]

Properties
Property | Description
DestObj (+) | #No TAG found in source code#
FatalException (+) | #No TAG found in source code#
FreeOnFinished (+) | #No TAG found in source code#
Msg (+) | #No TAG found in source code#
Owner (+) | #No TAG found in source code#
State (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScCustomTaskQueue)
Next (TScMethodTask)


Sepi

Sepi
Previous
Next (FatalException)

Name
DestObj

Parent
TScMessageTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property DestObj

Sepi
Class Tree
Index
Previous
Next (FatalException)


Sepi

Sepi
Previous (DestObj)
Next (FreeOnFinished)

Name
FatalException

Parent
TScMessageTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property FatalException

Sepi
Class Tree
Index
Previous (DestObj)
Next (FreeOnFinished)


Sepi

Sepi
Previous (FatalException)
Next (Msg)

Name
FreeOnFinished

Parent
TScMessageTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property FreeOnFinished

Sepi
Class Tree
Index
Previous (FatalException)
Next (Msg)


Sepi

Sepi
Previous (FreeOnFinished)
Next (Owner)

Name
Msg

Parent
TScMessageTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Msg

Sepi
Class Tree
Index
Previous (FreeOnFinished)
Next (Owner)


Sepi

Sepi
Previous (Msg)
Next (State)

Name
Owner

Parent
TScMessageTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Owner

Sepi
Class Tree
Index
Previous (Msg)
Next (State)


Sepi

Sepi
Previous (Owner)
Next

Name
State

Parent
TScMessageTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property State

Sepi
Class Tree
Index
Previous (Owner)
Next


Sepi

Sepi
Previous
Next (GetMsg)

Name
Cancel

Parent
TScMessageTask

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Cancel ( ForceFree : Boolean = False ) : Boolean

Parameters
Parameter | Description
ForceFree : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (GetMsg)


Sepi

Sepi
Previous (Cancel)
Next

Name
GetMsg

Parent
TScMessageTask

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure GetMsg ( out Msg )

Parameters
Parameter | Description
Msg : Untyped | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Cancel)
Next


Sepi

Sepi
Previous (TScMessageTask)
Next (TScTask)

Name
TScMethodTask

Parent
ScSyncObjs

Class Hierarchy
TScCustomMethodTask

Visibility
PUBLIC

Description
Tâche d'exécution d'une méthode d'un objet
TScMethodTask est une version publique de TScCustomMethodTask.

Members
Methods
Method | Description
Cancel (+) | [@inheritDoc]

Properties
Property | Description
FatalException (+) | #No TAG found in source code#
FreeOnFinished (+) | #No TAG found in source code#
Method (+) | #No TAG found in source code#
Owner (+) | #No TAG found in source code#
State (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScMessageTask)
Next (TScTask)


Sepi

Sepi
Previous
Next (FreeOnFinished)

Name
FatalException

Parent
TScMethodTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property FatalException

Sepi
Class Tree
Index
Previous
Next (FreeOnFinished)


Sepi

Sepi
Previous (FatalException)
Next (Method)

Name
FreeOnFinished

Parent
TScMethodTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property FreeOnFinished

Sepi
Class Tree
Index
Previous (FatalException)
Next (Method)


Sepi

Sepi
Previous (FreeOnFinished)
Next (Owner)

Name
Method

Parent
TScMethodTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Method

Sepi
Class Tree
Index
Previous (FreeOnFinished)
Next (Owner)


Sepi

Sepi
Previous (Method)
Next (State)

Name
Owner

Parent
TScMethodTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Owner

Sepi
Class Tree
Index
Previous (Method)
Next (State)


Sepi

Sepi
Previous (Owner)
Next

Name
State

Parent
TScMethodTask

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property State

Sepi
Class Tree
Index
Previous (Owner)
Next


Sepi

Sepi
Previous
Next

Name
Cancel

Parent
TScMethodTask

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Cancel ( ForceFree : Boolean = False ) : Boolean

Parameters
Parameter | Description
ForceFree : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TScMethodTask)
Next (TScTaskQueue)

Name
TScTask

Parent
ScSyncObjs

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Tâche gérée par une instance de TScTaskQueue

Members
Fields
Field | Description
FFatalException (-) | Exception non interceptée
FFreeOnFinished (-) | Se libère automatiquement
FOwner (-) | File propriétaire de la tâche
FState (-) | État de la tâche
FWaitForCount (-) | Nombre d'exécutions de WaitFor en cours

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
BeforeDestruction (+) | [@inheritDoc]
Cancel (#) | Annule la tâche
Create (+) | Crée une tâche
Create (+) | Crée une tâche en spécifiant FreeOnFinished
Destroy (+) | [@inheritDoc]
Execute (#) | Exécute l'action
Finish (-) | Termine la tâche
RaiseException (+) | Déclenche l'exception FatalException, si celle-ci est non nulle
WaitFor (+) | Attend que la tâche soit terminée

Properties
Property | Description
FatalException (#) | Exception non interceptée
FreeOnFinished (#) | Se libère automatiquement
Owner (#) | File propriétaire de la tâche
State (#) | État de la tâche

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScMethodTask)
Next (TScTaskQueue)


Sepi

Sepi
Previous
Next (FFreeOnFinished)

Name
FFatalException

Parent
TScTask

Visibility
PRIVATE

Description
Exception non interceptée

Source code
FFatalException : TObject

Sepi
Class Tree
Index
Previous
Next (FFreeOnFinished)


Sepi

Sepi
Previous (FFatalException)
Next (FOwner)

Name
FFreeOnFinished

Parent
TScTask

Visibility
PRIVATE

Description
Se libère automatiquement

Source code
FFreeOnFinished : Boolean

Sepi
Class Tree
Index
Previous (FFatalException)
Next (FOwner)


Sepi

Sepi
Previous (FFreeOnFinished)
Next (FState)

Name
FOwner

Parent
TScTask

Visibility
PRIVATE

Description
File propriétaire de la tâche

Source code
FOwner : TScCustomTaskQueue

Sepi
Class Tree
Index
Previous (FFreeOnFinished)
Next (FState)


Sepi

Sepi
Previous (FOwner)
Next (FWaitForCount)

Name
FState

Parent
TScTask

Visibility
PRIVATE

Description
État de la tâche

Source code
FState : TScTaskState

Sepi
Class Tree
Index
Previous (FOwner)
Next (FWaitForCount)


Sepi

Sepi
Previous (FState)
Next

Name
FWaitForCount

Parent
TScTask

Visibility
PRIVATE

Description
Nombre d'exécutions de WaitFor en cours

Source code
FWaitForCount : Integer

Sepi
Class Tree
Index
Previous (FState)
Next


Sepi

Sepi
Previous
Next (FreeOnFinished)

Name
FatalException

Parent
TScTask

Visibility
PROTECTED

Description
Exception non interceptée

Source code
property FatalException : TObject read FFatalException

Read Access
FFatalException

Sepi
Class Tree
Index
Previous
Next (FreeOnFinished)


Sepi

Sepi
Previous (FatalException)
Next (Owner)

Name
FreeOnFinished

Parent
TScTask

Visibility
PROTECTED

Description
Se libère automatiquement

Source code
property FreeOnFinished : Boolean read FFreeOnFinished write FFreeOnFinished

Read Access
FFreeOnFinished

Write Access
FFreeOnFinished

Sepi
Class Tree
Index
Previous (FatalException)
Next (Owner)


Sepi

Sepi
Previous (FreeOnFinished)
Next (State)

Name
Owner

Parent
TScTask

Visibility
PROTECTED

Description
File propriétaire de la tâche

Source code
property Owner : TScCustomTaskQueue read FOwner

Read Access
FOwner

Sepi
Class Tree
Index
Previous (FreeOnFinished)
Next (State)


Sepi

Sepi
Previous (Owner)
Next

Name
State

Parent
TScTask

Visibility
PROTECTED

Description
État de la tâche

Source code
property State : TScTaskState read FState

Read Access
FState

Sepi
Class Tree
Index
Previous (Owner)
Next


Sepi

Sepi
Previous
Next (BeforeDestruction)

Name
AfterConstruction

Parent
TScTask

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (BeforeDestruction)


Sepi

Sepi
Previous (AfterConstruction)
Next (Cancel)

Name
BeforeDestruction

Parent
TScTask

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Cancel)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Create)

Name
Cancel

Parent
TScTask

Visibility
PROTECTED

Description
Annule la tâche
Cancel ne fait rien si la tâche est déjà en cours ou terminée

Source code
function Cancel ( ForceFree : Boolean = False ) : Boolean

Parameters
Parameter | Description
ForceFree : BOOLEAN | À True, force la libération, même si FreeOnFinished = False

Return
Types | Description
BOOLEAN | True si réussi, False si la tâche était déjà en cours ou terminée

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Create)


Sepi

Sepi
Previous (Cancel)
Next (Create)

Name
Create

Parent
TScTask

Visibility
PUBLIC

Description
Crée une tâche

Source code
constructor Create ( AOwner : TScCustomTaskQueue ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | File de tâches propriétaire

Sepi
Class Tree
Index
Previous (Cancel)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TScTask

Visibility
PUBLIC

Description
Crée une tâche en spécifiant FreeOnFinished

Source code
constructor Create ( AOwner : TScCustomTaskQueue ; AFreeOnFinished : Boolean ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | File de tâches propriétaire
AFreeOnFinished : BOOLEAN | Indique si doit se détruire automatiquement

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Destroy

Parent
TScTask

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Destroy)
Next (Finish)

Name
Execute

Parent
TScTask

Visibility
PROTECTED

Description
Exécute l'action

Source code
procedure Execute ; virtual ; abstract

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (Finish)


Sepi

Sepi
Previous (Execute)
Next (RaiseException)

Name
Finish

Parent
TScTask

Visibility
PRIVATE

Description
Termine la tâche

Source code
procedure Finish ( AFatalException : TObject = nil )

Parameters
Parameter | Description
AFatalException : TObject | Exception non interceptée

Sepi
Class Tree
Index
Previous (Execute)
Next (RaiseException)


Sepi

Sepi
Previous (Finish)
Next (WaitFor)

Name
RaiseException

Parent
TScTask

Visibility
PUBLIC

Description
Déclenche l'exception FatalException, si celle-ci est non nulle
Utilisez RaiseException plutôt que "raise FatalException", ou vous courrez à
la violation d'accès lors de la libération de l'objet TScTask.

Source code
procedure RaiseException

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Finish)
Next (WaitFor)


Sepi

Sepi
Previous (RaiseException)
Next

Name
WaitFor

Parent
TScTask

Visibility
PUBLIC

Description
Attend que la tâche soit terminée
WaitFor peut être appelée sans risque sur une tâche dont la propriété
FreeOnFinished vaut True.

Source code
procedure WaitFor

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (RaiseException)
Next


Sepi

Sepi
Previous (TScTask)
Next

Name
TScTaskQueue

Parent
ScSyncObjs

Class Hierarchy
TScCustomTaskQueue

Visibility
PUBLIC

Description
Gestionnaire de file (FIFO) de tâches
TScTaskQueue propose une implémentation entièrement publique de
TScCustomTaskQueue.

Members
Properties
Property | Description
DefaultFreeOnFinished (+) | #No TAG found in source code#
Ready (+) | #No TAG found in source code#
TerminateOnException (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TScTask)
Next


Sepi

Sepi
Previous
Next (Ready)

Name
DefaultFreeOnFinished

Parent
TScTaskQueue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property DefaultFreeOnFinished

Sepi
Class Tree
Index
Previous
Next (Ready)


Sepi

Sepi
Previous (DefaultFreeOnFinished)
Next (TerminateOnException)

Name
Ready

Parent
TScTaskQueue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Ready

Sepi
Class Tree
Index
Previous (DefaultFreeOnFinished)
Next (TerminateOnException)


Sepi

Sepi
Previous (Ready)
Next

Name
TerminateOnException

Parent
TScTaskQueue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property TerminateOnException

Sepi
Class Tree
Index
Previous (Ready)
Next


Sepi

Sepi
Previous
Next

Name
TScTaskState

Parent
ScSyncObjs

Visibility
PUBLIC

Description
État d'une tâche
- tsWaiting : en attente ;
- tsProcessing : en cours ;
- tsFinished : terminée ;
- tsCanceled : annulée.

Source code
TScTaskState = ( tsWaiting , tsProcessing , tsFinished , tsCancelled ) ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (InterlockedIncrement)

Name
InterlockedDecrement

Parent
ScSyncObjs

Visibility
PUBLIC

Description
Décrémente un compteur de façon thread-safe

Source code
function InterlockedDecrement ( var I : Integer ) : Integer

Parameters
Parameter | Description
I : INTEGER | Compteur à décrémenter

Return
Types | Description
INTEGER | Nouvelle valeur du compteur

Sepi
Class Tree
Index
Previous
Next (InterlockedIncrement)


Sepi

Sepi
Previous (InterlockedDecrement)
Next

Name
InterlockedIncrement

Parent
ScSyncObjs

Visibility
PUBLIC

Description
Incrémente un compteur de façon thread-safe

Source code
function InterlockedIncrement ( var I : Integer ) : Integer

Parameters
Parameter | Description
I : INTEGER | Compteur à incrémenter

Return
Types | Description
INTEGER | Nouvelle valeur du compteur

Sepi
Class Tree
Index
Previous (InterlockedDecrement)
Next


Sepi

Sepi
Previous (ScSyncObjs)
Next (ScUtils)

Name
ScTypInfo

Parent
Sepi

Description
Étend les informations et les routines proposées par l'unité TypInfo

Author
sjrd

Version
1.0

Types
Type | Description
LongString (+) | Long string - ambivalent type for Delphi 2007- and Delphi 2009+
PArrayTypeData (+) | Pointeur vers TArrayTypeData
PManagedField (+) | Pointeur vers TManagedField
PRecordTypeData (+) | Pointeur vers TRecordTypeData
PTypeInfoString (+) | Pointeur sur un type chaîne utilisé dans les RTTI
TypeInfoString (+) | Type chaîne utilisé dans les RTTI

Constants
Constant | Description
NeedInitTypeKinds (+) | Types qui requièrent une initialisation
tkClassRefOrUnknown (+) | tkClassRef sous Delphi 2010+, tkUnknown sinon
tkPointerOrUnknown (+) | tkPointer sous Delphi 2010+, tkUnknown sinon
tkProcedureOrUnknown (+) | tkProcedure sous Delphi 2010+, tkUnknown sinon
tkUStringOrUnknown (+) | tkUString sous Delphi 2009+, tkUnknown sinon

Methods
Method | Description
AreInitFinitCompatible (+) | Teste si deux types sont compatibles au niveau de leur initialisation
CopyData (+) | Copie une variable
CopyData (+) | Copie une variable dont le type possède des RTTI
ReadTypeInfoStringFromStream (+) | Lit une chaîne de caractères de RTTI depuis un flux
TypeInfoDecode (+) | Decode a string coming from RTTI
TypeInfoEncode (+) | Encode a string for storing into RTTI
TypeSize (+) | Détermine la taille d'un type à partir de ses RTTI
WriteTypeInfoStringToStream (+) | Écrit une chaîne de caractères de RTTI dans un flux

Classes
Class | Description
TArrayTypeData (+) | Données d'un type tableau statique
TManagedField (+) | Champ managé d'un record (qui requiert une initialisation)
TRecordTypeData (+) | Données d'un type record

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScSyncObjs)
Next (ScUtils)


Sepi

Sepi
Previous
Next (TManagedField)

Name
TArrayTypeData

Parent
ScTypInfo

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Données d'un type tableau statique

Members
Fields
Field | Description
ElCount (*) | Nombre d'éléments (linéarisés)
ElType (*) | RTTI du type des éléments
Size (*) | Taille du type

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TManagedField)


Sepi

Sepi
Previous
Next (ElType)

Name
ElCount

Parent
TArrayTypeData

Visibility
PUBLISHED

Description
Nombre d'éléments (linéarisés)

Source code
ElCount : Integer

Sepi
Class Tree
Index
Previous
Next (ElType)


Sepi

Sepi
Previous (ElCount)
Next (Size)

Name
ElType

Parent
TArrayTypeData

Visibility
PUBLISHED

Description
RTTI du type des éléments

Source code
ElType : PPTypeInfo

Sepi
Class Tree
Index
Previous (ElCount)
Next (Size)


Sepi

Sepi
Previous (ElType)
Next

Name
Size

Parent
TArrayTypeData

Visibility
PUBLISHED

Description
Taille du type

Source code
Size : Integer

Sepi
Class Tree
Index
Previous (ElType)
Next


Sepi

Sepi
Previous (TArrayTypeData)
Next (TRecordTypeData)

Name
TManagedField

Parent
ScTypInfo

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Champ managé d'un record (qui requiert une initialisation)

Members
Fields
Field | Description
FldOffset (*) | Offset du champ dans le record
TypeRef (*) | RTTI du type du champ

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TArrayTypeData)
Next (TRecordTypeData)


Sepi

Sepi
Previous
Next (TypeRef)

Name
FldOffset

Parent
TManagedField

Visibility
PUBLISHED

Description
Offset du champ dans le record

Source code
FldOffset : Integer

Sepi
Class Tree
Index
Previous
Next (TypeRef)


Sepi

Sepi
Previous (FldOffset)
Next

Name
TypeRef

Parent
TManagedField

Visibility
PUBLISHED

Description
RTTI du type du champ

Source code
TypeRef : PPTypeInfo

Sepi
Class Tree
Index
Previous (FldOffset)
Next


Sepi

Sepi
Previous (TManagedField)
Next

Name
TRecordTypeData

Parent
ScTypInfo

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Données d'un type record

Members
Fields
Field | Description
ManagedCount (*) | Nombre de champs managés
ManagedFields (*) | Champs (0..ManagedCount-1)
Size (*) | Taille du type

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TManagedField)
Next


Sepi

Sepi
Previous
Next (ManagedFields)

Name
ManagedCount

Parent
TRecordTypeData

Visibility
PUBLISHED

Description
Nombre de champs managés

Source code
ManagedCount : Integer

Sepi
Class Tree
Index
Previous
Next (ManagedFields)


Sepi

Sepi
Previous (ManagedCount)
Next (Size)

Name
ManagedFields

Parent
TRecordTypeData

Visibility
PUBLISHED

Description
Champs (0..ManagedCount-1)

Source code
ManagedFields : array [ 0 .. 0 ] of TManagedField

Sepi
Class Tree
Index
Previous (ManagedCount)
Next (Size)


Sepi

Sepi
Previous (ManagedFields)
Next

Name
Size

Parent
TRecordTypeData

Visibility
PUBLISHED

Description
Taille du type

Source code
Size : Integer

Sepi
Class Tree
Index
Previous (ManagedFields)
Next


Sepi

Sepi
Previous
Next (PArrayTypeData)

Name
LongString

Parent
ScTypInfo

Visibility
PUBLIC

Description
Long string - ambivalent type for Delphi 2007- and Delphi 2009+

Source code
LongString = RawByteString ;

Sepi
Class Tree
Index
Previous
Next (PArrayTypeData)


Sepi

Sepi
Previous (LongString)
Next (PManagedField)

Name
PArrayTypeData

Parent
ScTypInfo

Visibility
PUBLIC

Description
Pointeur vers TArrayTypeData

Source code
PArrayTypeData = ^ TArrayTypeData ;

Sepi
Class Tree
Index
Previous (LongString)
Next (PManagedField)


Sepi

Sepi
Previous (PArrayTypeData)
Next (PRecordTypeData)

Name
PManagedField

Parent
ScTypInfo

Visibility
PUBLIC

Description
Pointeur vers TManagedField

Source code
PManagedField = ^ TManagedField ;

Sepi
Class Tree
Index
Previous (PArrayTypeData)
Next (PRecordTypeData)


Sepi

Sepi
Previous (PManagedField)
Next (PTypeInfoString)

Name
PRecordTypeData

Parent
ScTypInfo

Visibility
PUBLIC

Description
Pointeur vers TRecordTypeData

Source code
PRecordTypeData = ^ TRecordTypeData ;

Sepi
Class Tree
Index
Previous (PManagedField)
Next (PTypeInfoString)


Sepi

Sepi
Previous (PRecordTypeData)
Next (TypeInfoString)

Name
PTypeInfoString

Parent
ScTypInfo

Visibility
PUBLIC

Description
Pointeur sur un type chaîne utilisé dans les RTTI

Source code
PTypeInfoString = PShortString ;

Sepi
Class Tree
Index
Previous (PRecordTypeData)
Next (TypeInfoString)


Sepi

Sepi
Previous (PTypeInfoString)
Next

Name
TypeInfoString

Parent
ScTypInfo

Visibility
PUBLIC

Description
Type chaîne utilisé dans les RTTI

Source code
TypeInfoString = ShortString ;

Sepi
Class Tree
Index
Previous (PTypeInfoString)
Next


Sepi

Sepi
Previous
Next (tkClassRefOrUnknown)

Name
NeedInitTypeKinds

Parent
ScTypInfo

Visibility
PUBLIC

Description
Types qui requièrent une initialisation

Source code
NeedInitTypeKinds = [ tkLString , tkWString , tkVariant , tkArray , tkRecord , tkInterface , tkDynArray , tkUString ]

Sepi
Class Tree
Index
Previous
Next (tkClassRefOrUnknown)


Sepi

Sepi
Previous (NeedInitTypeKinds)
Next (tkPointerOrUnknown)

Name
tkClassRefOrUnknown

Parent
ScTypInfo

Visibility
PUBLIC

Description
tkClassRef sous Delphi 2010+, tkUnknown sinon

Source code
tkClassRefOrUnknown = tkClassRef

Sepi
Class Tree
Index
Previous (NeedInitTypeKinds)
Next (tkPointerOrUnknown)


Sepi

Sepi
Previous (tkClassRefOrUnknown)
Next (tkProcedureOrUnknown)

Name
tkPointerOrUnknown

Parent
ScTypInfo

Visibility
PUBLIC

Description
tkPointer sous Delphi 2010+, tkUnknown sinon

Source code
tkPointerOrUnknown = tkPointer

Sepi
Class Tree
Index
Previous (tkClassRefOrUnknown)
Next (tkProcedureOrUnknown)


Sepi

Sepi
Previous (tkPointerOrUnknown)
Next (tkUStringOrUnknown)

Name
tkProcedureOrUnknown

Parent
ScTypInfo

Visibility
PUBLIC

Description
tkProcedure sous Delphi 2010+, tkUnknown sinon

Source code
tkProcedureOrUnknown = tkProcedure

Sepi
Class Tree
Index
Previous (tkPointerOrUnknown)
Next (tkUStringOrUnknown)


Sepi

Sepi
Previous (tkProcedureOrUnknown)
Next

Name
tkUStringOrUnknown

Parent
ScTypInfo

Visibility
PUBLIC

Description
tkUString sous Delphi 2009+, tkUnknown sinon

Source code
tkUStringOrUnknown = tkUString

Sepi
Class Tree
Index
Previous (tkProcedureOrUnknown)
Next


Sepi

Sepi
Previous
Next (CopyData)

Name
AreInitFinitCompatible

Parent
ScTypInfo

Visibility
PUBLIC

Description
Teste si deux types sont compatibles au niveau de leur initialisation
Deux types sont compatibles si et seulement si initialiser/finaliser une
variable d'un des deux types avec les RTTI de l'autre type est valide.
Notez que les tailles des types n'ont pas besoin d'être égales. En
particulier, deux types de tailles quelconques et différentes sont compatibles
s'ils ne nécessitent aucune initialisation.
Un cas très particulier n'est pas traité parfaitement dans cette
implémentation : celui ou un type record a la même structure qu'un tableau
statique. Est alors renvoyé False au lieu de True.

Source code
function AreInitFinitCompatible ( Left , Right : PTypeInfo ) : Boolean

Parameters
Parameter | Description
Left : PTypeInfo | Premier type
Right : PTypeInfo | Second type

Return
Types | Description
BOOLEAN | True s'ils sont compatibles, False sinon

Sepi
Class Tree
Index
Previous
Next (CopyData)


Sepi

Sepi
Previous (AreInitFinitCompatible)
Next (CopyData)

Name
CopyData

Parent
ScTypInfo

Visibility
PUBLIC

Description
Copie une variable
Le paramètre TypeInfo n'est requis que si le type de données requiert une
initialisation. Mais ce n'est pas une erreur de le renseigner même dans les
autres cas.

Source code
procedure CopyData ( const Source ; var Dest ; Size : Integer ; TypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
Source : Untyped | Variable source
Dest : Untyped | Variable destination
Size : INTEGER | Taille du type de la variable
TypeInfo : PTypeInfo | RTTI du type de la variable (si requiert une initialisation)

Sepi
Class Tree
Index
Previous (AreInitFinitCompatible)
Next (CopyData)


Sepi

Sepi
Previous (CopyData)
Next (ReadTypeInfoStringFromStream)

Name
CopyData

Parent
ScTypInfo

Visibility
PUBLIC

Description
Copie une variable dont le type possède des RTTI
Utilisez cette variante de CopyData si vous ne connaissez pas la taille du
type de données. En revanche, vous devez fournir des RTTI non-nulles du type.

Source code
procedure CopyData ( const Source ; var Dest ; TypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
Source : Untyped | Variable source
Dest : Untyped | Variable destination
TypeInfo : PTypeInfo | RTTI du type de la variable

Sepi
Class Tree
Index
Previous (CopyData)
Next (ReadTypeInfoStringFromStream)


Sepi

Sepi
Previous (CopyData)
Next (TypeInfoDecode)

Name
ReadTypeInfoStringFromStream

Parent
ScTypInfo

Visibility
PUBLIC

Description
Lit une chaîne de caractères de RTTI depuis un flux
Cette chaîne doit avoir été écrite avec WriteTypeInfoStringToStream.

Source code
function ReadTypeInfoStringFromStream ( Stream : TStream ) : string

Parameters
Parameter | Description
Stream : TStream | Flux depuis lequel lire la chaîne

Return
Types | Description
STRING | La chaîne lue

Sepi
Class Tree
Index
Previous (CopyData)
Next (TypeInfoDecode)


Sepi

Sepi
Previous (ReadTypeInfoStringFromStream)
Next (TypeInfoEncode)

Name
TypeInfoDecode

Parent
ScTypInfo

Visibility
PUBLIC

Description
Decode a string coming from RTTI

Source code
function TypeInfoDecode ( const Str : TypeInfoString ) : string ; inline

Parameters
Parameter | Description
Str : TypeInfoString | String to decode

Return
Types | Description
STRING | The string Str decoded using the encoding of RTTI

Sepi
Class Tree
Index
Previous (ReadTypeInfoStringFromStream)
Next (TypeInfoEncode)


Sepi

Sepi
Previous (TypeInfoDecode)
Next (TypeSize)

Name
TypeInfoEncode

Parent
ScTypInfo

Visibility
PUBLIC

Description
Encode a string for storing into RTTI

Source code
function TypeInfoEncode ( const Str : string ) : TypeInfoString ; inline

Parameters
Parameter | Description
Str : STRING | String to encode

Return
Types | Description
TypeInfoString | The string Str encoded in the proper form for storing into RTTI

Sepi
Class Tree
Index
Previous (TypeInfoDecode)
Next (TypeSize)


Sepi

Sepi
Previous (TypeInfoEncode)
Next (WriteTypeInfoStringToStream)

Name
TypeSize

Parent
ScTypInfo

Visibility
PUBLIC

Description
Détermine la taille d'un type à partir de ses RTTI
Le seul cas dans lequel TypeSize est incapable de déterminer la taille du
type (et donc renvoie -1), est si TypeInfo.Kind = tkUnknown, ce qui ne
devrait jamais arriver.

Source code
function TypeSize ( TypeInfo : PTypeInfo ) : Integer

Parameters
Parameter | Description
TypeInfo : PTypeInfo | RTTI du type

Return
Types | Description
INTEGER | Taille du type, ou -1 si c'est impossible à déterminer

Sepi
Class Tree
Index
Previous (TypeInfoEncode)
Next (WriteTypeInfoStringToStream)


Sepi

Sepi
Previous (TypeSize)
Next

Name
WriteTypeInfoStringToStream

Parent
ScTypInfo

Visibility
PUBLIC

Description
Écrit une chaîne de caractères de RTTI dans un flux
Cette chaine pourra être relue avec ReadTypeInfoStringFromStream.

Source code
procedure WriteTypeInfoStringToStream ( Stream : TStream ; const Str : string )

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel enregistrer la chaîne
Str : STRING | Chaîne de caractères à écrire

Sepi
Class Tree
Index
Previous (TypeSize)
Next


Sepi

Sepi
Previous (ScTypInfo)
Next (ScWindows)

Name
ScUtils

Parent
Sepi

Description
Définit quelques routines usuelles

Author
sjrd

Version
1.0

Types
Type | Description
TSetOfBytes (+) | Ensemble de Byte
TSetOfChars (+) | Ensemble de caractères
TSysByteSet (+) | Ensemble de Byte

Constants
Constant | Description
DefaultRunURLVerb (+) | Verbe par défaut pour RunURL
No3DPoint (+) | Point 3D nul
NoGUID (+) | GUID nul
NoPoint (+) | Point nul

Methods
Method | Description
BaseToInt (+) | Convertit un nombre exprimé dans une base donnée en sa représentation décimale
BaseToIntDef (+) | Convertit un nombre exprimé dans une base donnée en sa représentation décimale
CharInSet (+) | Teste si un caractère est présent dans un ensemble de caractères
CharInSet (+) | Teste si un caractère est présent dans un ensemble de caractères
ConvertDoubleToInt64 (+) | Convertit une valeur Double en la valeur Int64 ayant les mêmes bits
ConvertInt64ToDouble (+) | Convertit une valeur Int64 en la valeur Double ayant les mêmes bits
CorrectFileName (+) | Teste si une chaîne de caractères est un nom de fichier correct
Dir (+) | Renvoie le chemin du dossier dans lequel se trouve l'application qui s'exécute
IIF (+) | Fonction de If Immédiat pour les décimaux
IIF (+) | Fonction de If Immédiat pour les caractères
IIF (+) | Fonction de If Immédiat pour les entiers
IIF (+) | Fonction de If Immédiat pour les objets
IIF (+) | Fonction de If Immédiat pour les chaînes de caractères
IIF (+) | Fonction de If Immédiat pour les pointeurs
IIF (+) | Fonction de If Immédiat pour les variants
IntDiv (+) | Division euclidienne
IntMod (+) | Reste de la division euclidienne
IntToBase (+) | Convertit un entier dans une base donnée
IntToStr0 (+) | Convertit un entier en chaîne, avec un nombre minimal de caractères spécifié
IsNo3DPoint (+) | Détermine si un point 3D est nul
IsNoGUID (+) | Détermine si un GUID est nul
IsNoPoint (+) | Détermine si un point est nul
MinMax (+) | S'assure qu'une valeur est bien dans un intervalle spécifié
Point3D (+) | Crée un point 3D
Point3DAdd (+) | Ajoute des coordonnées X, Y et Z à un point 3D
Point3DAdd (+) | Ajoute un point à un point 3D
Point3DAdd (+) | Additionne deux points 3D
Point3DToString (+) | Convertit un point 3D en chaîne de caractères
PointAdd (+) | Ajoute des coordonnées X et Y à un point
PointAdd (+) | Additionne deux points
ReadStrFromStream (+) | Lit une chaîne de caractères depuis un flux
ReadStrFromStream (+) | Lit une chaîne de caractères depuis un flux
RunURL (+) | Lance une URL
Same3DPoint (+) | Compare deux points 3D
SameGUID (+) | Compare deux GUID
SamePoint (+) | Compare deux points
Wait (+) | Met en pause l'exécution pendant un temps défini
WaitProcessMessages (+) | Met en pause l'exécution pendant un temps défini
WriteStrToStream (+) | Écrit une chaîne de caractères dans un flux
WriteStrToStream (+) | Écrit une chaîne de caractères dans un flux

Classes
Class | Description
T3DPoint (+) | Représente un point situé dans un espace en trois dimensions

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScTypInfo)
Next (ScWindows)


Sepi

Sepi
Previous
Next

Name
T3DPoint

Parent
ScUtils

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Représente un point situé dans un espace en trois dimensions

Members
Fields
Field | Description
X (*) | Coordonnée X du point
Y (*) | Coordonnée Y du point
Z (*) | Coordonnée Z du point

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Y)

Name
X

Parent
T3DPoint

Visibility
PUBLISHED

Description
Coordonnée X du point

Source code
X : Integer

Sepi
Class Tree
Index
Previous
Next (Y)


Sepi

Sepi
Previous (X)
Next (Z)

Name
Y

Parent
T3DPoint

Visibility
PUBLISHED

Description
Coordonnée Y du point

Source code
Y : Integer

Sepi
Class Tree
Index
Previous (X)
Next (Z)


Sepi

Sepi
Previous (Y)
Next

Name
Z

Parent
T3DPoint

Visibility
PUBLISHED

Description
Coordonnée Z du point

Source code
Z : Integer

Sepi
Class Tree
Index
Previous (Y)
Next


Sepi

Sepi
Previous
Next (TSetOfChars)

Name
TSetOfBytes

Parent
ScUtils

Visibility
PUBLIC

Description
Ensemble de Byte
Ce type est déprécié, utilisez TSysByteSet à la place.

Source code
TSetOfBytes = TSysByteSet ;

Sepi
Class Tree
Index
Previous
Next (TSetOfChars)


Sepi

Sepi
Previous (TSetOfBytes)
Next (TSysByteSet)

Name
TSetOfChars

Parent
ScUtils

Visibility
PUBLIC

Description
Ensemble de caractères
Ce type est déprécié, utilisez TSysCharSet à la place.

Source code
TSetOfChars = TSysCharSet ;

Sepi
Class Tree
Index
Previous (TSetOfBytes)
Next (TSysByteSet)


Sepi

Sepi
Previous (TSetOfChars)
Next

Name
TSysByteSet

Parent
ScUtils

Visibility
PUBLIC

Description
Ensemble de Byte

Source code
TSysByteSet = set of Byte ;

Sepi
Class Tree
Index
Previous (TSetOfChars)
Next


Sepi

Sepi
Previous
Next (No3DPoint)

Name
DefaultRunURLVerb

Parent
ScUtils

Visibility
PUBLIC

Description
Verbe par défaut pour RunURL

Source code
DefaultRunURLVerb = 'open'

Sepi
Class Tree
Index
Previous
Next (No3DPoint)


Sepi

Sepi
Previous (DefaultRunURLVerb)
Next (NoGUID)

Name
No3DPoint

Parent
ScUtils

Visibility
PUBLIC

Description
Point 3D nul

Source code
No3DPoint : T3DPoint = ( X : MaxInt ; Y : MaxInt ; Z : MaxInt )

Sepi
Class Tree
Index
Previous (DefaultRunURLVerb)
Next (NoGUID)


Sepi

Sepi
Previous (No3DPoint)
Next (NoPoint)

Name
NoGUID

Parent
ScUtils

Visibility
PUBLIC

Description
GUID nul

Source code
NoGUID : TGUID = ( D1 : 0 ; D2 : 0 ; D3 : 0 ; D4 : ( 0 , 0 , 0 , 0 , 0 , 0 , 0 , 0 ) )

Sepi
Class Tree
Index
Previous (No3DPoint)
Next (NoPoint)


Sepi

Sepi
Previous (NoGUID)
Next

Name
NoPoint

Parent
ScUtils

Visibility
PUBLIC

Description
Point nul

Source code
NoPoint : TPoint = ( X : MaxInt ; Y : MaxInt )

Sepi
Class Tree
Index
Previous (NoGUID)
Next


Sepi

Sepi
Previous
Next (BaseToIntDef)

Name
BaseToInt

Parent
ScUtils

Visibility
PUBLIC

Description
Convertit un nombre exprimé dans une base donnée en sa représentation décimale

Exception
EConvertError Base incorrecte
EConvertError Entier incorrect

Source code
function BaseToInt ( const Value : string ; Base : Byte = 10 ) : Integer

Parameters
Parameter | Description
Value : STRING | Chaîne de caractère représentant le nombre
Base : BYTE | Base dans laquelle est exprimée le nombre

Return
Types | Description
INTEGER | Valeur décimale du nombre

Sepi
Class Tree
Index
Previous
Next (BaseToIntDef)


Sepi

Sepi
Previous (BaseToInt)
Next (CharInSet)

Name
BaseToIntDef

Parent
ScUtils

Visibility
PUBLIC

Description
Convertit un nombre exprimé dans une base donnée en sa représentation décimale
Lorsque la chaîne n'est pas un entier valide, une valeur par défaut est
renvoyée.

Source code
function BaseToIntDef ( const Value : string ; Default : Integer = 0 ; Base : Byte = 10 ) : Integer

Parameters
Parameter | Description
Value : STRING | Chaîne de caractère représentant le nombre
DEFAULT : INTEGER | Valeur par défaut
Base : BYTE | Base dans laquelle est exprimée le nombre

Return
Types | Description
INTEGER | Valeur décimale du nombre

Sepi
Class Tree
Index
Previous (BaseToInt)
Next (CharInSet)


Sepi

Sepi
Previous (BaseToIntDef)
Next (CharInSet)

Name
CharInSet

Parent
ScUtils

Visibility
PUBLIC

Description
Teste si un caractère est présent dans un ensemble de caractères

Source code
function CharInSet ( C : WideChar ; const CharSet : TSysCharSet ) : Boolean ; overload ; inline

Parameters
Parameter | Description
C : WIDECHAR | Caractère à tester
CharSet : TSysCharSet | Ensemble de caractères

Return
Types | Description
BOOLEAN | True ssi C appartient à l'ensemble CharSet

Sepi
Class Tree
Index
Previous (BaseToIntDef)
Next (CharInSet)


Sepi

Sepi
Previous (CharInSet)
Next (ConvertDoubleToInt64)

Name
CharInSet

Parent
ScUtils

Visibility
PUBLIC

Description
Teste si un caractère est présent dans un ensemble de caractères

Source code
function CharInSet ( C : AnsiChar ; const CharSet : TSysCharSet ) : Boolean ; overload ; inline

Parameters
Parameter | Description
C : AnsiChar | Caractère à tester
CharSet : TSysCharSet | Ensemble de caractères

Return
Types | Description
BOOLEAN | True ssi C appartient à l'ensemble CharSet

Sepi
Class Tree
Index
Previous (CharInSet)
Next (ConvertDoubleToInt64)


Sepi

Sepi
Previous (CharInSet)
Next (ConvertInt64ToDouble)

Name
ConvertDoubleToInt64

Parent
ScUtils

Visibility
PUBLIC

Description
Convertit une valeur Double en la valeur Int64 ayant les mêmes bits
Attention ! Il n'y a aucune correspondance entre Value et Result ! Cette
fonction est totalement empirique.

Source code
function ConvertDoubleToInt64 ( Value : Double ) : Int64

Parameters
Parameter | Description
Value : DOUBLE | Valeur double à convertir

Return
Types | Description
INT64 | Valeur entière dont les bits sont identiques à Value

Sepi
Class Tree
Index
Previous (CharInSet)
Next (ConvertInt64ToDouble)


Sepi

Sepi
Previous (ConvertDoubleToInt64)
Next (CorrectFileName)

Name
ConvertInt64ToDouble

Parent
ScUtils

Visibility
PUBLIC

Description
Convertit une valeur Int64 en la valeur Double ayant les mêmes bits
Attention ! Il n'y a aucune correspondance entre Value et Result ! Cette
fonction est totalement empirique.

Source code
function ConvertInt64ToDouble ( Value : Int64 ) : Double

Parameters
Parameter | Description
Value : INT64 | Valeur entière à convertir

Return
Types | Description
DOUBLE | Valeur double dont les bits sont identiques à Value

Sepi
Class Tree
Index
Previous (ConvertDoubleToInt64)
Next (CorrectFileName)


Sepi

Sepi
Previous (ConvertInt64ToDouble)
Next (Dir)

Name
CorrectFileName

Parent
ScUtils

Visibility
PUBLIC

Description
Teste si une chaîne de caractères est un nom de fichier correct
Ce test est effectué conformément aux règles de nommage des fichiers du
système d'exploitation.

Source code
function CorrectFileName ( const FileName : string ; AcceptPathDelim : Boolean = False ; AcceptDriveDelim : Boolean = False ) : Boolean

Parameters
Parameter | Description
FileName : STRING | Chaîne à tester
AcceptPathDelim : BOOLEAN | Indique si le séparateur de chemin est accepté
AcceptDriveDelim : BOOLEAN | Indique si le séparateur de disque est accepté

Return
Types | Description
BOOLEAN | True si FileName est un nom de fichier correct, False sinon

Sepi
Class Tree
Index
Previous (ConvertInt64ToDouble)
Next (Dir)


Sepi

Sepi
Previous (CorrectFileName)
Next (IIF)

Name
Dir

Parent
ScUtils

Visibility
PUBLIC

Description
Renvoie le chemin du dossier dans lequel se trouve l'application qui s'exécute

Source code
function Dir : string

Parameters
Parameter Description

Return
Types | Description
STRING | Le chemin du dossier dans lequel se trouve l'application qui s'exécute

Sepi
Class Tree
Index
Previous (CorrectFileName)
Next (IIF)


Sepi

Sepi
Previous (Dir)
Next (IIF)

Name
IIF

Parent
ScUtils

Visibility
PUBLIC

Description
Fonction de If Immédiat pour les décimaux

Source code
function IIF ( Cond : Boolean ; Flo1 , Flo2 : Double ) : Double ; overload

Parameters
Parameter | Description
Cond : BOOLEAN | Condition à vérifier
Flo1 : DOUBLE | Valeur à renvoyer si la condition est vraie
Flo2 : DOUBLE | Valeur à renvoyer si la condition est fausse

Return
Types | Description
DOUBLE | Flo1 si Cond vaut True, Flo2 sinon

Sepi
Class Tree
Index
Previous (Dir)
Next (IIF)


Sepi

Sepi
Previous (IIF)
Next (IIF)

Name
IIF

Parent
ScUtils

Visibility
PUBLIC

Description
Fonction de If Immédiat pour les caractères

Source code
function IIF ( Cond : Boolean ; Chr1 , Chr2 : Char ) : Char ; overload

Parameters
Parameter | Description
Cond : BOOLEAN | Condition à vérifier
Chr1 : CHAR | Valeur à renvoyer si la condition est vraie
Chr2 : CHAR | Valeur à renvoyer si la condition est fausse

Return
Types | Description
CHAR | Chr1 si Cond vaut True, Chr2 sinon

Sepi
Class Tree
Index
Previous (IIF)
Next (IIF)


Sepi

Sepi
Previous (IIF)
Next (IIF)

Name
IIF

Parent
ScUtils

Visibility
PUBLIC

Description
Fonction de If Immédiat pour les entiers

Source code
function IIF ( Cond : Boolean ; Int1 , Int2 : Integer ) : Integer ; overload

Parameters
Parameter | Description
Cond : BOOLEAN | Condition à vérifier
Int1 : INTEGER | Valeur à renvoyer si la condition est vraie
Int2 : INTEGER | Valeur à renvoyer si la condition est fausse

Return
Types | Description
INTEGER | Int1 si Cond vaut True, Int2 sinon

Sepi
Class Tree
Index
Previous (IIF)
Next (IIF)


Sepi

Sepi
Previous (IIF)
Next (IIF)

Name
IIF

Parent
ScUtils

Visibility
PUBLIC

Description
Fonction de If Immédiat pour les objets

Source code
function IIF ( Cond : Boolean ; Obj1 , Obj2 : TObject ) : TObject ; overload

Parameters
Parameter | Description
Cond : BOOLEAN | Condition à vérifier
Obj1 : TObject | Valeur à renvoyer si la condition est vraie
Obj2 : TObject | Valeur à renvoyer si la condition est fausse

Return
Types | Description
TObject | Obj1 si Cond vaut True, Obj2 sinon

Sepi
Class Tree
Index
Previous (IIF)
Next (IIF)


Sepi

Sepi
Previous (IIF)
Next (IIF)

Name
IIF

Parent
ScUtils

Visibility
PUBLIC

Description
Fonction de If Immédiat pour les chaînes de caractères

Source code
function IIF ( Cond : Boolean ; const Str1 , Str2 : string ) : string ; overload

Parameters
Parameter | Description
Cond : BOOLEAN | Condition à vérifier
Str1 : STRING | Valeur à renvoyer si la condition est vraie
Str2 : STRING | Valeur à renvoyer si la condition est fausse

Return
Types | Description
STRING | Str1 si Cond vaut True, Str2 sinon

Sepi
Class Tree
Index
Previous (IIF)
Next (IIF)


Sepi

Sepi
Previous (IIF)
Next (IIF)

Name
IIF

Parent
ScUtils

Visibility
PUBLIC

Description
Fonction de If Immédiat pour les pointeurs

Source code
function IIF ( Cond : Boolean ; Ptr1 , Ptr2 : Pointer ) : Pointer ; overload

Parameters
Parameter | Description
Cond : BOOLEAN | Condition à vérifier
Ptr1 : Pointer | Valeur à renvoyer si la condition est vraie
Ptr2 : Pointer | Valeur à renvoyer si la condition est fausse

Return
Types | Description
Pointer | Ptr1 si Cond vaut True, Ptr2 sinon

Sepi
Class Tree
Index
Previous (IIF)
Next (IIF)


Sepi

Sepi
Previous (IIF)
Next (IntDiv)

Name
IIF

Parent
ScUtils

Visibility
PUBLIC

Description
Fonction de If Immédiat pour les variants

Source code
function IIF ( Cond : Boolean ; Var1 , Var2 : Variant ) : Variant ; overload

Parameters
Parameter | Description
Cond : BOOLEAN | Condition à vérifier
Var1 : VARIANT | Valeur à renvoyer si la condition est vraie
Var2 : VARIANT | Valeur à renvoyer si la condition est fausse

Return
Types | Description
VARIANT | Var1 si Cond vaut True, Var2 sinon

Sepi
Class Tree
Index
Previous (IIF)
Next (IntDiv)


Sepi

Sepi
Previous (IIF)
Next (IntMod)

Name
IntDiv

Parent
ScUtils

Visibility
PUBLIC

Description
Division euclidienne

Exception
EDivByZero Division par 0

Source code
function IntDiv ( Op1 , Op2 : Integer ) : Integer

Parameters
Parameter | Description
Op1 : INTEGER | Dividande
Op2 : INTEGER | Diviseur

Return
Types | Description
INTEGER | Résultat de la division euclidienne de Op1 par Op2

Sepi
Class Tree
Index
Previous (IIF)
Next (IntMod)


Sepi

Sepi
Previous (IntDiv)
Next (IntToBase)

Name
IntMod

Parent
ScUtils

Visibility
PUBLIC

Description
Reste de la division euclidienne

Exception
EDivByZero Division par 0

Source code
function IntMod ( Op1 , Op2 : Integer ) : Integer

Parameters
Parameter | Description
Op1 : INTEGER | Dividande
Op2 : INTEGER | Diviseur

Return
Types | Description
INTEGER | Reste de la division euclidienne de Op1 par Op2

Sepi
Class Tree
Index
Previous (IntDiv)
Next (IntToBase)


Sepi

Sepi
Previous (IntMod)
Next (IntToStr0)

Name
IntToBase

Parent
ScUtils

Visibility
PUBLIC

Description
Convertit un entier dans une base donnée

Exception
EConvertError Base incorrecte

Source code
function IntToBase ( Value : Integer ; Base : Byte = 10 ) : string

Parameters
Parameter | Description
Value : INTEGER | Entier à convertir
Base : BYTE | Base de destination

Return
Types | Description
STRING | Représentation en chaîne de Value exprimé dans la base Base

Sepi
Class Tree
Index
Previous (IntMod)
Next (IntToStr0)


Sepi

Sepi
Previous (IntToBase)
Next (IsNo3DPoint)

Name
IntToStr0

Parent
ScUtils

Visibility
PUBLIC

Description
Convertit un entier en chaîne, avec un nombre minimal de caractères spécifié
Exemples : IntToStr(345, 4) = '0345' ; IntToStr0(1000, 3) = '1000'

Source code
function IntToStr0 ( Value , Digits : Integer ) : string

Parameters
Parameter | Description
Value : INTEGER | Entier à convertir
Digits : INTEGER | Nombre minimal de caractères de la chaîne convertie

Return
Types | Description
STRING | La représentation en chaîne de Value, avec Digits caractères minimum

Sepi
Class Tree
Index
Previous (IntToBase)
Next (IsNo3DPoint)


Sepi

Sepi
Previous (IntToStr0)
Next (IsNoGUID)

Name
IsNo3DPoint

Parent
ScUtils

Visibility
PUBLIC

Description
Détermine si un point 3D est nul

Source code
function IsNo3DPoint ( const Point3D : T3DPoint ) : Boolean

Parameters
Parameter | Description
Point3D : T3DPoint | Point à tester

Return
Types | Description
BOOLEAN | True si le point Point3D est nul, False sinon

Sepi
Class Tree
Index
Previous (IntToStr0)
Next (IsNoGUID)


Sepi

Sepi
Previous (IsNo3DPoint)
Next (IsNoPoint)

Name
IsNoGUID

Parent
ScUtils

Visibility
PUBLIC

Description
Détermine si un GUID est nul

Source code
function IsNoGUID ( const GUID : TGUID ) : Boolean

Parameters
Parameter | Description
GUID : TGUID | GUID à tester

Return
Types | Description
BOOLEAN | True si le GUID est nul, False sinon

Sepi
Class Tree
Index
Previous (IsNo3DPoint)
Next (IsNoPoint)


Sepi

Sepi
Previous (IsNoGUID)
Next (MinMax)

Name
IsNoPoint

Parent
ScUtils

Visibility
PUBLIC

Description
Détermine si un point est nul

Source code
function IsNoPoint ( const Point : TPoint ) : Boolean

Parameters
Parameter | Description
Point : TPoint | Point à tester

Return
Types | Description
BOOLEAN | True si le point Point est nul, False sinon

Sepi
Class Tree
Index
Previous (IsNoGUID)
Next (MinMax)


Sepi

Sepi
Previous (IsNoPoint)
Next (Point3D)

Name
MinMax

Parent
ScUtils

Visibility
PUBLIC

Description
S'assure qu'une valeur est bien dans un intervalle spécifié

Source code
function MinMax ( Value , Min , Max : Integer ) : Integer

Parameters
Parameter | Description
Value : INTEGER | Valeur de base
Min : INTEGER | Valeur minimale
Max : INTEGER | Valeur maximale

Return
Types | Description
INTEGER | Valeur la plus proche de Value dans l'intervalle [Min;Max]

Sepi
Class Tree
Index
Previous (IsNoPoint)
Next (Point3D)


Sepi

Sepi
Previous (MinMax)
Next (Point3DAdd)

Name
Point3D

Parent
ScUtils

Visibility
PUBLIC

Description
Crée un point 3D

Source code
function Point3D ( X , Y , Z : Integer ) : T3DPoint

Parameters
Parameter | Description
X : INTEGER | Coordonnée X du point
Y : INTEGER | Coordonnée Y du point
Z : INTEGER | Coordonnée Z du point

Return
Types | Description
T3DPoint | Le point 3D (X, Y, Z)

Sepi
Class Tree
Index
Previous (MinMax)
Next (Point3DAdd)


Sepi

Sepi
Previous (Point3D)
Next (Point3DAdd)

Name
Point3DAdd

Parent
ScUtils

Visibility
PUBLIC

Description
Ajoute des coordonnées X, Y et Z à un point 3D

Source code
function Point3DAdd ( const Point : T3DPoint ; X , Y : Integer ; Z : Integer = 0 ) : T3DPoint ; overload

Parameters
Parameter | Description
Point : T3DPoint | Point auquel ajouter les coordonnées
X : INTEGER | Ajout en abscisses
Y : INTEGER | Ajout en ordonnées
Z : INTEGER | Ajout en hauteur (défaut = 0)

Return
Types | Description
T3DPoint | Somme du point Point et du point Point3D(X, Y, Z)

Sepi
Class Tree
Index
Previous (Point3D)
Next (Point3DAdd)


Sepi

Sepi
Previous (Point3DAdd)
Next (Point3DAdd)

Name
Point3DAdd

Parent
ScUtils

Visibility
PUBLIC

Description
Ajoute un point à un point 3D

Source code
function Point3DAdd ( const Point1 : T3DPoint ; const Point2 : TPoint ) : T3DPoint ; overload

Parameters
Parameter | Description
Point1 : T3DPoint | Premier point
Point2 : TPoint | Second point

Return
Types | Description
T3DPoint | Somme des deux points

Sepi
Class Tree
Index
Previous (Point3DAdd)
Next (Point3DAdd)


Sepi

Sepi
Previous (Point3DAdd)
Next (Point3DToString)

Name
Point3DAdd

Parent
ScUtils

Visibility
PUBLIC

Description
Additionne deux points 3D

Source code
function Point3DAdd ( const Point1 , Point2 : T3DPoint ) : T3DPoint ; overload

Parameters
Parameter | Description
Point1 : T3DPoint | Premier point
Point2 : T3DPoint | Second point

Return
Types | Description
T3DPoint | Somme des deux points

Sepi
Class Tree
Index
Previous (Point3DAdd)
Next (Point3DToString)


Sepi

Sepi
Previous (Point3DAdd)
Next (PointAdd)

Name
Point3DToString

Parent
ScUtils

Visibility
PUBLIC

Description
Convertit un point 3D en chaîne de caractères

Source code
function Point3DToString ( const Point3D : T3DPoint ; const Delim : string = ' ' ) : string

Parameters
Parameter | Description
Point3D : T3DPoint | Point 3D à convertir
Delim : STRING | Délimiteur à placer entre les coordonnées

Return
Types | Description
STRING | Point3D convertit en chaîne de caractères

Sepi
Class Tree
Index
Previous (Point3DAdd)
Next (PointAdd)


Sepi

Sepi
Previous (Point3DToString)
Next (PointAdd)

Name
PointAdd

Parent
ScUtils

Visibility
PUBLIC

Description
Ajoute des coordonnées X et Y à un point

Source code
function PointAdd ( const Point : TPoint ; X , Y : Integer ) : TPoint ; overload

Parameters
Parameter | Description
Point : TPoint | Point auquel ajouter les coordonnées
X : INTEGER | Ajout en abscisses
Y : INTEGER | Ajout en ordonnées

Return
Types | Description
TPoint | Somme du point Point et du point Point(X, Y)

Sepi
Class Tree
Index
Previous (Point3DToString)
Next (PointAdd)


Sepi

Sepi
Previous (PointAdd)
Next (ReadStrFromStream)

Name
PointAdd

Parent
ScUtils

Visibility
PUBLIC

Description
Additionne deux points

Source code
function PointAdd ( const Point1 , Point2 : TPoint ) : TPoint ; overload

Parameters
Parameter | Description
Point1 : TPoint | Premier point
Point2 : TPoint | Second point

Return
Types | Description
TPoint | Somme des deux points

Sepi
Class Tree
Index
Previous (PointAdd)
Next (ReadStrFromStream)


Sepi

Sepi
Previous (PointAdd)
Next (ReadStrFromStream)

Name
ReadStrFromStream

Parent
ScUtils

Visibility
PUBLIC

Description
Lit une chaîne de caractères depuis un flux
Cette chaîne doit avoir été écrite avec WriteStrToStream.

Source code
function ReadStrFromStream ( Stream : TStream ) : string ; overload

Parameters
Parameter | Description
Stream : TStream | Flux depuis lequel lire la chaîne

Return
Types | Description
STRING | La chaîne lue

Sepi
Class Tree
Index
Previous (PointAdd)
Next (ReadStrFromStream)


Sepi

Sepi
Previous (ReadStrFromStream)
Next (RunURL)

Name
ReadStrFromStream

Parent
ScUtils

Visibility
PUBLIC

Description
Lit une chaîne de caractères depuis un flux
Cette chaîne doit avoir été écrite avec WriteStrToStream.

Source code
function ReadStrFromStream ( Stream : TStream ; Encoding : TEncoding ) : string ; overload

Parameters
Parameter | Description
Stream : TStream | Flux depuis lequel lire la chaîne
Encoding : TEncoding | Encodage utilisé pour stocker la chaîne

Return
Types | Description
STRING | La chaîne lue

Sepi
Class Tree
Index
Previous (ReadStrFromStream)
Next (RunURL)


Sepi

Sepi
Previous (ReadStrFromStream)
Next (Same3DPoint)

Name
RunURL

Parent
ScUtils

Visibility
PUBLIC

Description
Lance une URL

Source code
procedure RunURL ( const URL : string ; const Verb : string = DefaultRunURLVerb ; const Parameters : string = '' )

Parameters
Parameter | Description
URL : STRING | URL à lancer
Verb : STRING | Verbe à utiliser pour lancer l'URL
Parameters : STRING

Sepi
Class Tree
Index
Previous (ReadStrFromStream)
Next (Same3DPoint)


Sepi

Sepi
Previous (RunURL)
Next (SameGUID)

Name
Same3DPoint

Parent
ScUtils

Visibility
PUBLIC

Description
Compare deux points 3D

Source code
function Same3DPoint ( const Point1 , Point2 : T3DPoint ) : Boolean

Parameters
Parameter | Description
Point1 : T3DPoint | Premier point
Point2 : T3DPoint | Second point

Return
Types | Description
BOOLEAN | True si Point1 et Point2 sont identiques, False sinon

Sepi
Class Tree
Index
Previous (RunURL)
Next (SameGUID)


Sepi

Sepi
Previous (Same3DPoint)
Next (SamePoint)

Name
SameGUID

Parent
ScUtils

Visibility
PUBLIC

Description
Compare deux GUID

Source code
function SameGUID ( const GUID1 , GUID2 : TGUID ) : Boolean

Parameters
Parameter | Description
GUID1 : TGUID | Premier GUID
GUID2 : TGUID | Second GUID

Return
Types | Description
BOOLEAN | True si GUID1 et GUID2 sont identiques, False sinon

Sepi
Class Tree
Index
Previous (Same3DPoint)
Next (SamePoint)


Sepi

Sepi
Previous (SameGUID)
Next (Wait)

Name
SamePoint

Parent
ScUtils

Visibility
PUBLIC

Description
Compare deux points

Source code
function SamePoint ( const Point1 , Point2 : TPoint ) : Boolean

Parameters
Parameter | Description
Point1 : TPoint | Premier point
Point2 : TPoint | Second point

Return
Types | Description
BOOLEAN | True si Point1 et Point2 sont identiques, False sinon

Sepi
Class Tree
Index
Previous (SameGUID)
Next (Wait)


Sepi

Sepi
Previous (SamePoint)
Next (WaitProcessMessages)

Name
Wait

Parent
ScUtils

Visibility
PUBLIC

Description
Met en pause l'exécution pendant un temps défini
Cette routine est dépréciée, utilisez Sleep à la place.

Source code
procedure Wait ( Milliseconds : Integer ) ; deprecated

Parameters
Parameter | Description
Milliseconds : INTEGER | Nombre de milisecondes pendant lesquelles pauser

Sepi
Class Tree
Index
Previous (SamePoint)
Next (WaitProcessMessages)


Sepi

Sepi
Previous (Wait)
Next (WriteStrToStream)

Name
WaitProcessMessages

Parent
ScUtils

Visibility
PUBLIC

Description
Met en pause l'exécution pendant un temps défini
Pendant cette pause, les messages Windows de l'applications sont tout de
même traités.

Source code
procedure WaitProcessMessages ( Milliseconds : Integer )

Parameters
Parameter | Description
Milliseconds : INTEGER | Nombre de milisecondes pendant lesquelles pauser

Sepi
Class Tree
Index
Previous (Wait)
Next (WriteStrToStream)


Sepi

Sepi
Previous (WaitProcessMessages)
Next (WriteStrToStream)

Name
WriteStrToStream

Parent
ScUtils

Visibility
PUBLIC

Description
Écrit une chaîne de caractères dans un flux
Cette chaine pourra être relue avec ReadStrFromStream.

Source code
procedure WriteStrToStream ( Stream : TStream ; const Str : string ) ; overload

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel enregistrer la chaîne
Str : STRING | Chaîne de caractères à écrire

Sepi
Class Tree
Index
Previous (WaitProcessMessages)
Next (WriteStrToStream)


Sepi

Sepi
Previous (WriteStrToStream)
Next

Name
WriteStrToStream

Parent
ScUtils

Visibility
PUBLIC

Description
Écrit une chaîne de caractères dans un flux
Cette chaine pourra être relue avec ReadStrFromStream.

Source code
procedure WriteStrToStream ( Stream : TStream ; const Str : string ; Encoding : TEncoding ) ; overload

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel enregistrer la chaîne
Str : STRING | Chaîne de caractères à écrire
Encoding : TEncoding | Encodage utilisé pour stocker la chaîne

Sepi
Class Tree
Index
Previous (WriteStrToStream)
Next


Sepi

Sepi
Previous (ScUtils)
Next (ScXML)

Name
ScWindows

Parent
Sepi

Description
Types et routines dépendant de la plate-forme Windows

Author
sjrd

Version
1.0

Types
Type | Description
TSoundType (+) | Type de son

Methods
Method | Description
AddResource (+) | Ajoute une ressource
AddResToFile (+) | Ajoute une ressources à un fichier module
BeginUpdateRes (+) | Débute la mise à jour des ressources d'un fichier module
CreateShellLink (+) | Crée un raccourci Windows
DelResInFile (+) | Supprime une ressources d'un fichier module
DelResource (+) | Supprime une ressource
EndUpdateRes (+) | Termine la mise à jour des ressources d'un fichier module
ExecuteSound (+) | Exécute un son à partir d'un fichier, d'une ressource ou d'un son système

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScUtils)
Next (ScXML)


Sepi

Sepi
Previous
Next

Name
TSoundType

Parent
ScWindows

Visibility
PUBLIC

Description
Type de son
stFileName : Nom de fichier
stResource : Nom d'une ressource
stSysSound : Nom d'un son système

Source code
TSoundType = ( stFileName , stResource , stSysSound ) ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (AddResToFile)

Name
AddResource

Parent
ScWindows

Visibility
PUBLIC

Description
Ajoute une ressource

Source code
procedure AddResource ( ResHandle : Integer ; const ResName : string ; Resource : TStream ; const ResType : string = 'RCDATA' )

Parameters
Parameter | Description
ResHandle : INTEGER | Handle de ressources obtenu par BeginUpdateRes
ResName : STRING | Nom de la ressource à ajouter
Resource : TStream | Flux contenant la ressource
ResType : STRING | Type de ressource

Sepi
Class Tree
Index
Previous
Next (AddResToFile)


Sepi

Sepi
Previous (AddResource)
Next (BeginUpdateRes)

Name
AddResToFile

Parent
ScWindows

Visibility
PUBLIC

Description
Ajoute une ressources à un fichier module

Source code
procedure AddResToFile ( const FileName , ResName : string ; Resource : TStream ; const ResType : string = 'RCDATA' )

Parameters
Parameter | Description
FileName : STRING | Nom du fichier module
ResName : STRING | Nom de la ressource à ajouter
Resource : TStream | Flux contenant la ressource
ResType : STRING | Type de ressource

Sepi
Class Tree
Index
Previous (AddResource)
Next (BeginUpdateRes)


Sepi

Sepi
Previous (AddResToFile)
Next (CreateShellLink)

Name
BeginUpdateRes

Parent
ScWindows

Visibility
PUBLIC

Description
Débute la mise à jour des ressources d'un fichier module
Tout appel à BeginUpdateRes doit être compensé par un appel à EndUpdateRes.

Source code
function BeginUpdateRes ( const FileName : string ) : Integer

Parameters
Parameter | Description
FileName : STRING | Nom du fichier module

Return
Types | Description
INTEGER | Handle de ressources

Sepi
Class Tree
Index
Previous (AddResToFile)
Next (CreateShellLink)


Sepi

Sepi
Previous (BeginUpdateRes)
Next (DelResInFile)

Name
CreateShellLink

Parent
ScWindows

Visibility
PUBLIC

Description
Crée un raccourci Windows
Seuls les paramètres Source et Dest sont obligatoires.

Source code
procedure CreateShellLink ( const Source , Dest : string ; const Description : string = '' ; const IconLocation : string = '' ; IconIndex : Integer = 0 ; const Arguments : string = '' ; const WorkDir : string = '' ; ShowCommand : Integer = SW_SHOW )

Parameters
Parameter | Description
Source : STRING | Nom du fichier raccourci
Dest : STRING | Destination du raccourci
Description : STRING | Description
IconLocation : STRING | Nom du fichier contenant l'icône du raccourci
IconIndex : INTEGER | Index de l'icône dans le fichier
Arguments : STRING | Arguments appliqués à la destination du raccourci
WorkDir : STRING | Répertoire de travail pour l'exécution du raccourci
ShowCommand : INTEGER | Commande d'affichage de la destination

Sepi
Class Tree
Index
Previous (BeginUpdateRes)
Next (DelResInFile)


Sepi

Sepi
Previous (CreateShellLink)
Next (DelResource)

Name
DelResInFile

Parent
ScWindows

Visibility
PUBLIC

Description
Supprime une ressources d'un fichier module

Source code
procedure DelResInFile ( const FileName , ResName : string )

Parameters
Parameter | Description
FileName : STRING | Nom du fichier module
ResName : STRING | Nom de la ressource à supprimer

Sepi
Class Tree
Index
Previous (CreateShellLink)
Next (DelResource)


Sepi

Sepi
Previous (DelResInFile)
Next (EndUpdateRes)

Name
DelResource

Parent
ScWindows

Visibility
PUBLIC

Description
Supprime une ressource

Source code
procedure DelResource ( ResHandle : Integer ; const ResName : string )

Parameters
Parameter | Description
ResHandle : INTEGER | Handle de ressources obtenu par BeginUpdateRes
ResName : STRING | Nom de la ressource à supprimer

Sepi
Class Tree
Index
Previous (DelResInFile)
Next (EndUpdateRes)


Sepi

Sepi
Previous (DelResource)
Next (ExecuteSound)

Name
EndUpdateRes

Parent
ScWindows

Visibility
PUBLIC

Description
Termine la mise à jour des ressources d'un fichier module

Source code
procedure EndUpdateRes ( ResHandle : Integer ; Cancel : Boolean = False )

Parameters
Parameter | Description
ResHandle : INTEGER | Handle de ressources obtenu par BeginUpdateRes
Cancel : BOOLEAN | Indique s'il faut annuler les modifications faites

Sepi
Class Tree
Index
Previous (DelResource)
Next (ExecuteSound)


Sepi

Sepi
Previous (EndUpdateRes)
Next

Name
ExecuteSound

Parent
ScWindows

Visibility
PUBLIC

Description
Exécute un son à partir d'un fichier, d'une ressource ou d'un son système

Source code
function ExecuteSound ( const Sound : string ; SoundType : TSoundType = stFileName ; Synchronous : Boolean = False ; Module : HMODULE = 0 ; AddFlags : LongWord = 0 ) : Boolean

Parameters
Parameter | Description
Sound : STRING | Nom du son (selon le type de son)
SoundType : TSoundType | Type de son
Synchronous : BOOLEAN | True pour exécuter le son de façon synchrône
Module : HMODULE | Dans le cas d'une ressource, le module la contenant
AddFlags : LONGWORD | Flags additionnels à passer à MMSystem.PlaySound

Return
Types | Description
BOOLEAN | True si le son a été correctement exécuté, False sinon

Sepi
Class Tree
Index
Previous (EndUpdateRes)
Next


Sepi

Sepi
Previous (ScWindows)
Next (ScZLib)

Name
ScXML

Parent
Sepi

Description
#Pas de TAG trouvé dans le code source#

Author
#Pas de TAG trouvé dans le code source#

Version
#Pas de TAG trouvé dans le code source#

Constants
Constant | Description
Base64Chars (+) | Caractères de la base 64
Base64NoDataChar (+) | Caractère spécial d'absence de données en fin de base 64

Variables
Variable Description

Methods
Method | Description
Base64Decode (+) | Décode un flux en base 64
Base64Encode (+) | Encode un flux en base 64
CreateXMLHeaderIfNotExists (+) | Crée le header XML pour un document XML s'il n'est pas déjà présent
IndentXMLDocument (+) | Indente un document XML
LoadXMLDocumentFromFile (+) | Charge un document XML depuis un fichier
LoadXMLDocumentFromStream (+) | Charge un document XML depuis un flux
SaveXMLDocumentToFile (+) | Enregistre un document XML dans un fichier
SaveXMLDocumentToStream (+) | Enregistre un document XML dans un flux

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScWindows)
Next (ScZLib)


Sepi

Sepi
Previous
Next (Base64NoDataChar)

Name
Base64Chars

Parent
ScXML

Visibility
PUBLIC

Description
Caractères de la base 64

Source code
Base64Chars : AnsiString = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/'

Sepi
Class Tree
Index
Previous
Next (Base64NoDataChar)


Sepi

Sepi
Previous (Base64Chars)
Next

Name
Base64NoDataChar

Parent
ScXML

Visibility
PUBLIC

Description
Caractère spécial d'absence de données en fin de base 64

Source code
Base64NoDataChar : AnsiChar = '='

Sepi
Class Tree
Index
Previous (Base64Chars)
Next


Sepi

Sepi
Previous
Next (Base64Encode)

Name
Base64Decode

Parent
ScXML

Visibility
PUBLIC

Description
Décode un flux en base 64

Source code
procedure Base64Decode ( Input , Output : TStream )

Parameters
Parameter | Description
Input : TStream | Flux à décoder
Output : TStream | En sortie : flux décodé

Sepi
Class Tree
Index
Previous
Next (Base64Encode)


Sepi

Sepi
Previous (Base64Decode)
Next (CreateXMLHeaderIfNotExists)

Name
Base64Encode

Parent
ScXML

Visibility
PUBLIC

Description
Encode un flux en base 64

Source code
procedure Base64Encode ( Input , Output : TStream )

Parameters
Parameter | Description
Input : TStream | Flux à encoder
Output : TStream | En sortie : flux encodé en base 64

Sepi
Class Tree
Index
Previous (Base64Decode)
Next (CreateXMLHeaderIfNotExists)


Sepi

Sepi
Previous (Base64Encode)
Next (IndentXMLDocument)

Name
CreateXMLHeaderIfNotExists

Parent
ScXML

Visibility
PUBLIC

Description
Crée le header XML pour un document XML s'il n'est pas déjà présent

Source code
procedure CreateXMLHeaderIfNotExists ( const Document : IXMLDOMDocument )

Parameters
Parameter | Description
Document : IXMLDOMDocument | Document pour lequel créer le header

Sepi
Class Tree
Index
Previous (Base64Encode)
Next (IndentXMLDocument)


Sepi

Sepi
Previous (CreateXMLHeaderIfNotExists)
Next (LoadXMLDocumentFromFile)

Name
IndentXMLDocument

Parent
ScXML

Visibility
PUBLIC

Description
Indente un document XML

Source code
function IndentXMLDocument ( const Document : IXMLDOMDocument ) : IXMLDOMDocument

Parameters
Parameter | Description
Document : IXMLDOMDocument | Document XML à indenter

Return
Types | Description
IXMLDOMDocument | Document indenté

Sepi
Class Tree
Index
Previous (CreateXMLHeaderIfNotExists)
Next (LoadXMLDocumentFromFile)


Sepi

Sepi
Previous (IndentXMLDocument)
Next (LoadXMLDocumentFromStream)

Name
LoadXMLDocumentFromFile

Parent
ScXML

Visibility
PUBLIC

Description
Charge un document XML depuis un fichier

Source code
function LoadXMLDocumentFromFile ( const FileName : TFileName ) : IXMLDOMDocument

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier source

Return
Types | Description
IXMLDOMDocument | Document XML chargé

Sepi
Class Tree
Index
Previous (IndentXMLDocument)
Next (LoadXMLDocumentFromStream)


Sepi

Sepi
Previous (LoadXMLDocumentFromFile)
Next (SaveXMLDocumentToFile)

Name
LoadXMLDocumentFromStream

Parent
ScXML

Visibility
PUBLIC

Description
Charge un document XML depuis un flux

Source code
function LoadXMLDocumentFromStream ( Stream : TStream ) : IXMLDOMDocument

Parameters
Parameter | Description
Stream : TStream | Flux source

Return
Types | Description
IXMLDOMDocument | Document XML chargé

Sepi
Class Tree
Index
Previous (LoadXMLDocumentFromFile)
Next (SaveXMLDocumentToFile)


Sepi

Sepi
Previous (LoadXMLDocumentFromStream)
Next (SaveXMLDocumentToStream)

Name
SaveXMLDocumentToFile

Parent
ScXML

Visibility
PUBLIC

Description
Enregistre un document XML dans un fichier

Source code
procedure SaveXMLDocumentToFile ( const Document : IXMLDOMDocument ; const FileName : TFileName ; Indent : Boolean = True )

Parameters
Parameter | Description
Document : IXMLDOMDocument | Document XML à enregistrer
FileName : TFileName | Nom du fichier destination
Indent : BOOLEAN

Sepi
Class Tree
Index
Previous (LoadXMLDocumentFromStream)
Next (SaveXMLDocumentToStream)


Sepi

Sepi
Previous (SaveXMLDocumentToFile)
Next

Name
SaveXMLDocumentToStream

Parent
ScXML

Visibility
PUBLIC

Description
Enregistre un document XML dans un flux

Source code
procedure SaveXMLDocumentToStream ( const Document : IXMLDOMDocument ; Stream : TStream ; Indent : Boolean = True )

Parameters
Parameter | Description
Document : IXMLDOMDocument | Document XML à enregistrer
Stream : TStream | Flux dans lequel enregistrer le document
Indent : BOOLEAN

Sepi
Class Tree
Index
Previous (SaveXMLDocumentToFile)
Next


Sepi

Sepi
Previous (ScXML)
Next (SdAbout)

Name
ScZLib

Parent
Sepi

Description
Définit deux routines de compression et décompression avec ZLib

Author
sjrd

Version
1.0

Constants
Constant | Description
clDefaultComp (+) | Compression par défaut
clFastestComp (+) | Compression la plus rapide
clMaxComp (+) | Compression maximale
clNoComp (+) | Pas de compression

Methods
Method | Description
CompressStream (+) | Compresse un flux avec la bibliothèque ZLib
DecompressStream (+) | Décompresse un flux avec la bibliothèque ZLib

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScXML)
Next (SdAbout)


Sepi

Sepi
Previous
Next (clFastestComp)

Name
clDefaultComp

Parent
ScZLib

Visibility
PUBLIC

Description
Compression par défaut

Source code
clDefaultComp = ZLib . clDefault

Sepi
Class Tree
Index
Previous
Next (clFastestComp)


Sepi

Sepi
Previous (clDefaultComp)
Next (clMaxComp)

Name
clFastestComp

Parent
ScZLib

Visibility
PUBLIC

Description
Compression la plus rapide

Source code
clFastestComp = ZLib . clFastest

Sepi
Class Tree
Index
Previous (clDefaultComp)
Next (clMaxComp)


Sepi

Sepi
Previous (clFastestComp)
Next (clNoComp)

Name
clMaxComp

Parent
ScZLib

Visibility
PUBLIC

Description
Compression maximale

Source code
clMaxComp = ZLib . clMax

Sepi
Class Tree
Index
Previous (clFastestComp)
Next (clNoComp)


Sepi

Sepi
Previous (clMaxComp)
Next

Name
clNoComp

Parent
ScZLib

Visibility
PUBLIC

Description
Pas de compression

Source code
clNoComp = ZLib . clNone

Sepi
Class Tree
Index
Previous (clMaxComp)
Next


Sepi

Sepi
Previous
Next (DecompressStream)

Name
CompressStream

Parent
ScZLib

Visibility
PUBLIC

Description
Compresse un flux avec la bibliothèque ZLib

Source code
procedure CompressStream ( Stream : TStream ; Dest : TStream = nil ; CompressionLevel : TCompressionLevel = clDefaultComp )

Parameters
Parameter | Description
Stream : TStream | Flux à compresser
Dest : TStream | Flux de destination (ou nil pour Stream, plus lent)
CompressionLevel : TCompressionLevel | Niveau de compression

Sepi
Class Tree
Index
Previous
Next (DecompressStream)


Sepi

Sepi
Previous (CompressStream)
Next

Name
DecompressStream

Parent
ScZLib

Visibility
PUBLIC

Description
Décompresse un flux avec la bibliothèque ZLib

Source code
procedure DecompressStream ( Stream : TStream ; Dest : TStream = nil )

Parameters
Parameter | Description
Stream : TStream | Flux à décompresser
Dest : TStream | Flux de destination (ou nil pour Stream, plus lent)

Sepi
Class Tree
Index
Previous (CompressStream)
Next


Sepi

Sepi
Previous (ScZLib)
Next (SDCConsts)

Name
SdAbout

Parent
Sepi

Description
Boîte de dialogue À propos

Author
sjrd

Version
1.0

Classes
Class | Description
TSdAboutForm (+) | Boîte de dialogue À propos

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ScZLib)
Next (SDCConsts)


Sepi

Sepi
Previous
Next

Name
TSdAboutForm

Parent
SdAbout

Class Hierarchy
TForm

Visibility
PUBLIC

Description
Boîte de dialogue À propos

Members
Fields
Field | Description
ButtonOK (*) | Bouton OK
ImageProgramIcon (*) | Image pour l'icône
LabelAuthor (*) | Label pour l'auteur
LabelProgramName (*) | Label pour le nom du programme
LabelProgramVersion (*) | Label pour la version
URLLabelEMail (+) | Label pour l'e-mail de l'auteur
URLLabelWebSite (+) | Label pour le site Web

Methods
Method | Description
FormCreate (*) | Gestionnaire d'événement OnCreate
ShowAbout (+) | Affiche une boîte de dialogue À propos

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ImageProgramIcon)

Name
ButtonOK

Parent
TSdAboutForm

Visibility
PUBLISHED

Description
Bouton OK

Source code
ButtonOK : TButton

Sepi
Class Tree
Index
Previous
Next (ImageProgramIcon)


Sepi

Sepi
Previous (ButtonOK)
Next (LabelAuthor)

Name
ImageProgramIcon

Parent
TSdAboutForm

Visibility
PUBLISHED

Description
Image pour l'icône

Source code
ImageProgramIcon : TImage

Sepi
Class Tree
Index
Previous (ButtonOK)
Next (LabelAuthor)


Sepi

Sepi
Previous (ImageProgramIcon)
Next (LabelProgramName)

Name
LabelAuthor

Parent
TSdAboutForm

Visibility
PUBLISHED

Description
Label pour l'auteur

Source code
LabelAuthor : TLabel

Sepi
Class Tree
Index
Previous (ImageProgramIcon)
Next (LabelProgramName)


Sepi

Sepi
Previous (LabelAuthor)
Next (LabelProgramVersion)

Name
LabelProgramName

Parent
TSdAboutForm

Visibility
PUBLISHED

Description
Label pour le nom du programme

Source code
LabelProgramName : TLabel

Sepi
Class Tree
Index
Previous (LabelAuthor)
Next (LabelProgramVersion)


Sepi

Sepi
Previous (LabelProgramName)
Next (URLLabelEMail)

Name
LabelProgramVersion

Parent
TSdAboutForm

Visibility
PUBLISHED

Description
Label pour la version

Source code
LabelProgramVersion : TLabel

Sepi
Class Tree
Index
Previous (LabelProgramName)
Next (URLLabelEMail)


Sepi

Sepi
Previous (LabelProgramVersion)
Next (URLLabelWebSite)

Name
URLLabelEMail

Parent
TSdAboutForm

Visibility
PUBLIC

Description
Label pour l'e-mail de l'auteur

Source code
URLLabelEMail : TSvURLLabel

Sepi
Class Tree
Index
Previous (LabelProgramVersion)
Next (URLLabelWebSite)


Sepi

Sepi
Previous (URLLabelEMail)
Next

Name
URLLabelWebSite

Parent
TSdAboutForm

Visibility
PUBLIC

Description
Label pour le site Web

Source code
URLLabelWebSite : TSvURLLabel

Sepi
Class Tree
Index
Previous (URLLabelEMail)
Next


Sepi

Sepi
Previous
Next (ShowAbout)

Name
FormCreate

Parent
TSdAboutForm

Visibility
PUBLISHED

Description
Gestionnaire d'événement OnCreate

Source code
procedure FormCreate ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement

Sepi
Class Tree
Index
Previous
Next (ShowAbout)


Sepi

Sepi
Previous (FormCreate)
Next

Name
ShowAbout

Parent
TSdAboutForm

Visibility
PUBLIC

Description
Affiche une boîte de dialogue À propos

Source code
class procedure ShowAbout ( Title : string ; ProgramIcon : TGraphic ; ProgramName : string ; ProgramVersion : string ; Author : string ; AuthorEMail : string = '' ; WebSite : string = '' )

Parameters
Parameter | Description
Title : STRING | Titre de la boîte de dialogue
ProgramIcon : TGraphic | Icône du programme
ProgramName : STRING | Nom du programme
ProgramVersion : STRING | Version du programme
Author : STRING | Auteur du programme
AuthorEMail : STRING | Adresse e-mail de l'auteur (optionnel)
WebSite : STRING | Site Web du programme (optionnel)

Sepi
Class Tree
Index
Previous (FormCreate)
Next


Sepi

Sepi
Previous (SdAbout)
Next (SdDialogs)

Name
SDCConsts

Parent
Sepi

Description
Constantes du projet SepiDelphiCompiler

Author
sjrd

Version
1.0

Constants
Constant | Description
CompiledIntfExt (+) | #No TAG found in source code#
CompiledUnitExt (+) | #No TAG found in source code#
DefaultOutputDir (+) | #No TAG found in source code#
MaxSizeBeforeLazyLoad (+) | #No TAG found in source code#
PascalExt (+) | #No TAG found in source code#
RCExt (+) | #No TAG found in source code#
SCantCompileRCFile (+) | #No TAG found in source code#
SCantFindSourceFile (+) | #No TAG found in source code#
SCantOpenDestFile (+) | #No TAG found in source code#
SCantOpenSourceFile (+) | #No TAG found in source code#
SOneOrMoreFileNamesRequired (+) | #No TAG found in source code#
SSepiInternalError (+) | #No TAG found in source code#
TextExt (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SdAbout)
Next (SdDialogs)


Sepi

Sepi
Previous
Next (CompiledUnitExt)

Name
CompiledIntfExt

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
CompiledIntfExt = '.sci'

Sepi
Class Tree
Index
Previous
Next (CompiledUnitExt)


Sepi

Sepi
Previous (CompiledIntfExt)
Next (DefaultOutputDir)

Name
CompiledUnitExt

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
CompiledUnitExt = '.scu'

Sepi
Class Tree
Index
Previous (CompiledIntfExt)
Next (DefaultOutputDir)


Sepi

Sepi
Previous (CompiledUnitExt)
Next (MaxSizeBeforeLazyLoad)

Name
DefaultOutputDir

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
DefaultOutputDir = 'Output\'

Sepi
Class Tree
Index
Previous (CompiledUnitExt)
Next (MaxSizeBeforeLazyLoad)


Sepi

Sepi
Previous (DefaultOutputDir)
Next (PascalExt)

Name
MaxSizeBeforeLazyLoad

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
MaxSizeBeforeLazyLoad = 100 * 1024

Sepi
Class Tree
Index
Previous (DefaultOutputDir)
Next (PascalExt)


Sepi

Sepi
Previous (MaxSizeBeforeLazyLoad)
Next (RCExt)

Name
PascalExt

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
PascalExt = '.pas'

Sepi
Class Tree
Index
Previous (MaxSizeBeforeLazyLoad)
Next (RCExt)


Sepi

Sepi
Previous (PascalExt)
Next (SCantCompileRCFile)

Name
RCExt

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
RCExt = '.rc'

Sepi
Class Tree
Index
Previous (PascalExt)
Next (SCantCompileRCFile)


Sepi

Sepi
Previous (RCExt)
Next (SCantFindSourceFile)

Name
SCantCompileRCFile

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantCompileRCFile = 'Ne peut compiler le fichier de ressources %s'

Sepi
Class Tree
Index
Previous (RCExt)
Next (SCantFindSourceFile)


Sepi

Sepi
Previous (SCantCompileRCFile)
Next (SCantOpenDestFile)

Name
SCantFindSourceFile

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantFindSourceFile = 'Le fichier source %s n''existe pas'

Sepi
Class Tree
Index
Previous (SCantCompileRCFile)
Next (SCantOpenDestFile)


Sepi

Sepi
Previous (SCantFindSourceFile)
Next (SCantOpenSourceFile)

Name
SCantOpenDestFile

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantOpenDestFile = 'Impossible de créer le fichier de sortie %s'

Sepi
Class Tree
Index
Previous (SCantFindSourceFile)
Next (SCantOpenSourceFile)


Sepi

Sepi
Previous (SCantOpenDestFile)
Next (SOneOrMoreFileNamesRequired)

Name
SCantOpenSourceFile

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantOpenSourceFile = 'Impossible de créer le fichier source %s'

Sepi
Class Tree
Index
Previous (SCantOpenDestFile)
Next (SOneOrMoreFileNamesRequired)


Sepi

Sepi
Previous (SCantOpenSourceFile)
Next (SSepiInternalError)

Name
SOneOrMoreFileNamesRequired

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOneOrMoreFileNamesRequired = 'Un argument ou plus requis'

Sepi
Class Tree
Index
Previous (SCantOpenSourceFile)
Next (SSepiInternalError)


Sepi

Sepi
Previous (SOneOrMoreFileNamesRequired)
Next (TextExt)

Name
SSepiInternalError

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiInternalError = 'Erreur interne : %s'

Sepi
Class Tree
Index
Previous (SOneOrMoreFileNamesRequired)
Next (TextExt)


Sepi

Sepi
Previous (SSepiInternalError)
Next

Name
TextExt

Parent
SDCConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
TextExt = '.txt'

Sepi
Class Tree
Index
Previous (SSepiInternalError)
Next


Sepi

Sepi
Previous (SDCConsts)
Next (SdNumber)

Name
SdDialogs

Parent
Sepi

Description
Définit des routines et composants utilisant des boîtes de dialogue

Author
sjrd

Version
1.0

Types
Type | Description
TDialogButtons (+) | Boutons présents dans une boîte de dialogue
TDialogResult (+) | Résultat de l'affichage d'une boîte de dialogue
TDialogType (+) | Type d'une boîte de dialogue

Methods
Method | Description
QueryNumber (+) | Demande un nombre à l'utilisateur
QueryPassword (+) | Demande un mot de passe à l'utilisateur
QueryPassWord (+) | Demande un mot de passe à l'utilisateur
ShowAbout (+) | Affiche une boîte de dialogue À propos
ShowDialog (+) | Affiche une boîte de dialogue modale Windows ou QT (selon la VCL utilisée)
ShowDialogRadio (+) | Affiche une boîte de dialogue avec des boutons radio
ShowMes (+) | Affiche une boîte de dialogue modale Windows

Classes
Class | Description
TSdAboutDialog (+) | Gère une boîte de dialogue À propos
TSdNumberDialog (+) | Gère une boîte de dialogue demandant un nombre à l'utilisateur
TSdPasswordDialog (+) | Gère une boîte de dialogue d'introduction de mot de passe

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SDCConsts)
Next (SdNumber)


Sepi

Sepi
Previous
Next (TSdNumberDialog)

Name
TSdAboutDialog

Parent
SdDialogs

Class Hierarchy
TComponent

Visibility
PUBLIC

Description
Gère une boîte de dialogue À propos

Members
Fields
Field | Description
FAuthor (-) | Intitulé d'auteur
FAuthorEMail (-) | Adresse e-mail de l'auteur (optionnel)
FAuthorName (-) | Nom de l'auteur du programme
FProgramIcon (-) | Icône du programme
FProgramName (-) | Nom du programme
FProgramVersion (-) | Version du programme
FTitle (-) | Titre de la boîte de dialogue
FVersion (-) | Intitulé de version
FWebSite (-) | Site Web du programme (optionnel)

Methods
Method | Description
Create (+) | Crée une instance de TSdAboutDialog
Destroy (+) | Détruit l'instance
Execute (+) | Affiche la boîte de dialogue
IsAuthorStored (-) | Indique si l'intitulé d'auteur doit être stocké dans un flux dfm
IsProgramVersionStored (-) | Indique si la version du programme doit être stockée dans un flux dfm
IsTitleStored (-) | Indique si le titre doit être stocké dans un flux dfm
IsVersionStored (-) | Indique si l'intitulé de version doit être stocké dans un flux dfm
SetProgramIcon (-) | Modifie l'icône du programme

Properties
Property | Description
Author (*) | Intitulé d'auteur
AuthorEMail (*) | Adresse e-mail de l'auteur (optionnel)
AuthorName (*) | Nom de l'auteur du programme
ProgramIcon (*) | Icône du programme
ProgramName (*) | Nom du programme
ProgramVersion (*) | Version du programme
Title (*) | Titre de la boîte de dialogue
Version (*) | Intitulé de version
WebSite (*) | Site Web du programme (optionnel)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSdNumberDialog)


Sepi

Sepi
Previous
Next (FAuthorEMail)

Name
FAuthor

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Intitulé d'auteur

Source code
FAuthor : string

Sepi
Class Tree
Index
Previous
Next (FAuthorEMail)


Sepi

Sepi
Previous (FAuthor)
Next (FAuthorName)

Name
FAuthorEMail

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Adresse e-mail de l'auteur (optionnel)

Source code
FAuthorEMail : string

Sepi
Class Tree
Index
Previous (FAuthor)
Next (FAuthorName)


Sepi

Sepi
Previous (FAuthorEMail)
Next (FProgramIcon)

Name
FAuthorName

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Nom de l'auteur du programme

Source code
FAuthorName : string

Sepi
Class Tree
Index
Previous (FAuthorEMail)
Next (FProgramIcon)


Sepi

Sepi
Previous (FAuthorName)
Next (FProgramName)

Name
FProgramIcon

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Icône du programme

Source code
FProgramIcon : TIcon

Sepi
Class Tree
Index
Previous (FAuthorName)
Next (FProgramName)


Sepi

Sepi
Previous (FProgramIcon)
Next (FProgramVersion)

Name
FProgramName

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Nom du programme

Source code
FProgramName : string

Sepi
Class Tree
Index
Previous (FProgramIcon)
Next (FProgramVersion)


Sepi

Sepi
Previous (FProgramName)
Next (FTitle)

Name
FProgramVersion

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Version du programme

Source code
FProgramVersion : string

Sepi
Class Tree
Index
Previous (FProgramName)
Next (FTitle)


Sepi

Sepi
Previous (FProgramVersion)
Next (FVersion)

Name
FTitle

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Titre de la boîte de dialogue

Source code
FTitle : string

Sepi
Class Tree
Index
Previous (FProgramVersion)
Next (FVersion)


Sepi

Sepi
Previous (FTitle)
Next (FWebSite)

Name
FVersion

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Intitulé de version

Source code
FVersion : string

Sepi
Class Tree
Index
Previous (FTitle)
Next (FWebSite)


Sepi

Sepi
Previous (FVersion)
Next

Name
FWebSite

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Site Web du programme (optionnel)

Source code
FWebSite : string

Sepi
Class Tree
Index
Previous (FVersion)
Next


Sepi

Sepi
Previous
Next (AuthorEMail)

Name
Author

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Intitulé d'auteur

Source code
property Author : string read FAuthor write FAuthor stored IsAuthorStored

Read Access
FAuthor

Write Access
FAuthor

Sepi
Class Tree
Index
Previous
Next (AuthorEMail)


Sepi

Sepi
Previous (Author)
Next (AuthorName)

Name
AuthorEMail

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Adresse e-mail de l'auteur (optionnel)

Source code
property AuthorEMail : string read FAuthorEMail write FAuthorEMail

Read Access
FAuthorEMail

Write Access
FAuthorEMail

Sepi
Class Tree
Index
Previous (Author)
Next (AuthorName)


Sepi

Sepi
Previous (AuthorEMail)
Next (ProgramIcon)

Name
AuthorName

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Nom de l'auteur du programme

Source code
property AuthorName : string read FAuthorName write FAuthorName

Read Access
FAuthorName

Write Access
FAuthorName

Sepi
Class Tree
Index
Previous (AuthorEMail)
Next (ProgramIcon)


Sepi

Sepi
Previous (AuthorName)
Next (ProgramName)

Name
ProgramIcon

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Icône du programme

Source code
property ProgramIcon : TIcon read FProgramIcon write SetProgramIcon

Read Access
FProgramIcon

Write Access
SetProgramIcon

Sepi
Class Tree
Index
Previous (AuthorName)
Next (ProgramName)


Sepi

Sepi
Previous (ProgramIcon)
Next (ProgramVersion)

Name
ProgramName

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Nom du programme

Source code
property ProgramName : string read FProgramName write FProgramName

Read Access
FProgramName

Write Access
FProgramName

Sepi
Class Tree
Index
Previous (ProgramIcon)
Next (ProgramVersion)


Sepi

Sepi
Previous (ProgramName)
Next (Title)

Name
ProgramVersion

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Version du programme

Source code
property ProgramVersion : string read FProgramVersion write FProgramVersion stored IsProgramVersionStored

Read Access
FProgramVersion

Write Access
FProgramVersion

Sepi
Class Tree
Index
Previous (ProgramName)
Next (Title)


Sepi

Sepi
Previous (ProgramVersion)
Next (Version)

Name
Title

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Titre de la boîte de dialogue

Source code
property Title : string read FTitle write FTitle stored IsTitleStored

Read Access
FTitle

Write Access
FTitle

Sepi
Class Tree
Index
Previous (ProgramVersion)
Next (Version)


Sepi

Sepi
Previous (Title)
Next (WebSite)

Name
Version

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Intitulé de version

Source code
property Version : string read FVersion write FVersion stored IsVersionStored

Read Access
FVersion

Write Access
FVersion

Sepi
Class Tree
Index
Previous (Title)
Next (WebSite)


Sepi

Sepi
Previous (Version)
Next

Name
WebSite

Parent
TSdAboutDialog

Visibility
PUBLISHED

Description
Site Web du programme (optionnel)

Source code
property WebSite : string read FWebSite write FWebSite

Read Access
FWebSite

Write Access
FWebSite

Sepi
Class Tree
Index
Previous (Version)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSdAboutDialog

Visibility
PUBLIC

Description
Crée une instance de TSdAboutDialog

Source code
constructor Create ( AOwner : TComponent ) ; override

Parameters
Parameter | Description
AOwner : TComponent | Propriétaire

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Destroy

Parent
TSdAboutDialog

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Destroy)
Next (IsAuthorStored)

Name
Execute

Parent
TSdAboutDialog

Visibility
PUBLIC

Description
Affiche la boîte de dialogue

Source code
procedure Execute

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (IsAuthorStored)


Sepi

Sepi
Previous (Execute)
Next (IsProgramVersionStored)

Name
IsAuthorStored

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Indique si l'intitulé d'auteur doit être stocké dans un flux dfm

Source code
function IsAuthorStored : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si l'intitulé est différent de celui par défaut, False sinon

Sepi
Class Tree
Index
Previous (Execute)
Next (IsProgramVersionStored)


Sepi

Sepi
Previous (IsAuthorStored)
Next (IsTitleStored)

Name
IsProgramVersionStored

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Indique si la version du programme doit être stockée dans un flux dfm

Source code
function IsProgramVersionStored : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si la version est '1.0', False sinon

Sepi
Class Tree
Index
Previous (IsAuthorStored)
Next (IsTitleStored)


Sepi

Sepi
Previous (IsProgramVersionStored)
Next (IsVersionStored)

Name
IsTitleStored

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Indique si le titre doit être stocké dans un flux dfm

Source code
function IsTitleStored : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si le titre est différent de celui par défaut, False sinon

Sepi
Class Tree
Index
Previous (IsProgramVersionStored)
Next (IsVersionStored)


Sepi

Sepi
Previous (IsTitleStored)
Next (SetProgramIcon)

Name
IsVersionStored

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Indique si l'intitulé de version doit être stocké dans un flux dfm

Source code
function IsVersionStored : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si l'intitulé est différent de celui par défaut, False sinon

Sepi
Class Tree
Index
Previous (IsTitleStored)
Next (SetProgramIcon)


Sepi

Sepi
Previous (IsVersionStored)
Next

Name
SetProgramIcon

Parent
TSdAboutDialog

Visibility
PRIVATE

Description
Modifie l'icône du programme

Source code
procedure SetProgramIcon ( New : TIcon )

Parameters
Parameter | Description
New : TIcon | Nouvelle icône

Sepi
Class Tree
Index
Previous (IsVersionStored)
Next


Sepi

Sepi
Previous (TSdAboutDialog)
Next (TSdPasswordDialog)

Name
TSdNumberDialog

Parent
SdDialogs

Class Hierarchy
TComponent

Visibility
PUBLIC

Description
Gère une boîte de dialogue demandant un nombre à l'utilisateur

Members
Fields
Field | Description
FMax (-) | Valeur maximale que peut choisir l'utilisateur
FMin (-) | Valeur minimale que peut choisir l'utilisateur
FPrompt (-) | Invite de la boîte de dialogue
FTitle (-) | Titre de la boîte de dialogue
FValue (-) | Valeur par défaut, puis celle saisie par l'utilisateur

Methods
Method | Description
Create (+) | Crée une instance de TSdNumberDialog
Execute (+) | Affiche la boîte de dialogue
Execute (+) | Affiche la boîte de dialogue
Execute (+) | Affiche la boîte de dialogue
Execute (+) | Affiche la boîte de dialogue
Execute (+) | Affiche la boîte de dialogue

Properties
Property | Description
Max (*) | Valeur maximale que peut choisir l'utilisateur
Min (*) | Valeur minimale que peut choisir l'utilisateur
Prompt (*) | Invite de la boîte de dialogue
Title (*) | Titre de la boîte de dialogue
Value (*) | Valeur par défaut, puis celle saisie par l'utilisateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSdAboutDialog)
Next (TSdPasswordDialog)


Sepi

Sepi
Previous
Next (FMin)

Name
FMax

Parent
TSdNumberDialog

Visibility
PRIVATE

Description
Valeur maximale que peut choisir l'utilisateur

Source code
FMax : Integer

Sepi
Class Tree
Index
Previous
Next (FMin)


Sepi

Sepi
Previous (FMax)
Next (FPrompt)

Name
FMin

Parent
TSdNumberDialog

Visibility
PRIVATE

Description
Valeur minimale que peut choisir l'utilisateur

Source code
FMin : Integer

Sepi
Class Tree
Index
Previous (FMax)
Next (FPrompt)


Sepi

Sepi
Previous (FMin)
Next (FTitle)

Name
FPrompt

Parent
TSdNumberDialog

Visibility
PRIVATE

Description
Invite de la boîte de dialogue

Source code
FPrompt : string

Sepi
Class Tree
Index
Previous (FMin)
Next (FTitle)


Sepi

Sepi
Previous (FPrompt)
Next (FValue)

Name
FTitle

Parent
TSdNumberDialog

Visibility
PRIVATE

Description
Titre de la boîte de dialogue

Source code
FTitle : string

Sepi
Class Tree
Index
Previous (FPrompt)
Next (FValue)


Sepi

Sepi
Previous (FTitle)
Next

Name
FValue

Parent
TSdNumberDialog

Visibility
PRIVATE

Description
Valeur par défaut, puis celle saisie par l'utilisateur

Source code
FValue : Integer

Sepi
Class Tree
Index
Previous (FTitle)
Next


Sepi

Sepi
Previous
Next (Min)

Name
Max

Parent
TSdNumberDialog

Visibility
PUBLISHED

Description
Valeur maximale que peut choisir l'utilisateur

Source code
property Max : Integer read FMax write FMax

Read Access
FMax

Write Access
FMax

Sepi
Class Tree
Index
Previous
Next (Min)


Sepi

Sepi
Previous (Max)
Next (Prompt)

Name
Min

Parent
TSdNumberDialog

Visibility
PUBLISHED

Description
Valeur minimale que peut choisir l'utilisateur

Source code
property Min : Integer read FMin write FMin

Read Access
FMin

Write Access
FMin

Sepi
Class Tree
Index
Previous (Max)
Next (Prompt)


Sepi

Sepi
Previous (Min)
Next (Title)

Name
Prompt

Parent
TSdNumberDialog

Visibility
PUBLISHED

Description
Invite de la boîte de dialogue

Source code
property Prompt : string read FPrompt write FPrompt

Read Access
FPrompt

Write Access
FPrompt

Sepi
Class Tree
Index
Previous (Min)
Next (Title)


Sepi

Sepi
Previous (Prompt)
Next (Value)

Name
Title

Parent
TSdNumberDialog

Visibility
PUBLISHED

Description
Titre de la boîte de dialogue

Source code
property Title : string read FTitle write FTitle

Read Access
FTitle

Write Access
FTitle

Sepi
Class Tree
Index
Previous (Prompt)
Next (Value)


Sepi

Sepi
Previous (Title)
Next

Name
Value

Parent
TSdNumberDialog

Visibility
PUBLISHED

Description
Valeur par défaut, puis celle saisie par l'utilisateur

Source code
property Value : Integer read FValue write FValue

Read Access
FValue

Write Access
FValue

Sepi
Class Tree
Index
Previous (Title)
Next


Sepi

Sepi
Previous
Next (Execute)

Name
Create

Parent
TSdNumberDialog

Visibility
PUBLIC

Description
Crée une instance de TSdNumberDialog

Source code
constructor Create ( AOwner : TComponent ) ; override

Parameters
Parameter | Description
AOwner : TComponent | Propriétaire

Sepi
Class Tree
Index
Previous
Next (Execute)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Execute

Parent
TSdNumberDialog

Visibility
PUBLIC

Description
Affiche la boîte de dialogue
Cette variante utilise comme valeur par défaut la valeur sélectionnée par
l'utilisateur lors de la précédent invocation.

Source code
function Execute ( AMin , AMax : Integer ) : Integer ; overload

Parameters
Parameter | Description
AMin : INTEGER | Valeur minimale
AMax : INTEGER | Valeur maximale

Return
Types | Description
INTEGER | Valeur sélectionnée par l'utilisateur

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Execute)
Next (Execute)

Name
Execute

Parent
TSdNumberDialog

Visibility
PUBLIC

Description
Affiche la boîte de dialogue
Cette variante utilise comme valeur par défaut la valeur sélectionnée par
l'utilisateur lors de la précédent invocation.

Source code
function Execute : Integer ; overload

Parameters
Parameter Description

Return
Types | Description
INTEGER | Valeur sélectionnée par l'utilisateur

Sepi
Class Tree
Index
Previous (Execute)
Next (Execute)


Sepi

Sepi
Previous (Execute)
Next (Execute)

Name
Execute

Parent
TSdNumberDialog

Visibility
PUBLIC

Description
Affiche la boîte de dialogue
Cette variante utilise comme valeur par défaut la valeur sélectionnée par
l'utilisateur lors de la précédent invocation.

Source code
function Execute ( const ATitle , APrompt : string ; AMin , AMax : Integer ) : Integer ; overload

Parameters
Parameter | Description
ATitle : STRING | Titre de la boîte de dialogue
APrompt : STRING | Invite
AMin : INTEGER | Valeur minimale
AMax : INTEGER | Valeur maximale

Return
Types | Description
INTEGER | Valeur sélectionnée par l'utilisateur

Sepi
Class Tree
Index
Previous (Execute)
Next (Execute)


Sepi

Sepi
Previous (Execute)
Next (Execute)

Name
Execute

Parent
TSdNumberDialog

Visibility
PUBLIC

Description
Affiche la boîte de dialogue

Source code
function Execute ( const ATitle , APrompt : string ; ADefault , AMin , AMax : Integer ) : Integer ; overload

Parameters
Parameter | Description
ATitle : STRING | Titre de la boîte de dialogue
APrompt : STRING | Invite
ADefault : INTEGER | Valeur par défaut
AMin : INTEGER | Valeur minimale
AMax : INTEGER | Valeur maximale

Return
Types | Description
INTEGER | Valeur sélectionnée par l'utilisateur

Sepi
Class Tree
Index
Previous (Execute)
Next (Execute)


Sepi

Sepi
Previous (Execute)
Next

Name
Execute

Parent
TSdNumberDialog

Visibility
PUBLIC

Description
Affiche la boîte de dialogue

Source code
function Execute ( ADefault , AMin , AMax : Integer ) : Integer ; overload

Parameters
Parameter | Description
ADefault : INTEGER | Valeur par défaut
AMin : INTEGER | Valeur minimale
AMax : INTEGER | Valeur maximale

Return
Types | Description
INTEGER | Valeur sélectionnée par l'utilisateur

Sepi
Class Tree
Index
Previous (Execute)
Next


Sepi

Sepi
Previous (TSdNumberDialog)
Next

Name
TSdPasswordDialog

Parent
SdDialogs

Class Hierarchy
TComponent

Visibility
PUBLIC

Description
Gère une boîte de dialogue d'introduction de mot de passe

Members
Fields
Field | Description
FPassword (-) | Mot de passe correct
FShowErrorMes (-) | Indique s'il faut notifier sur erreur

Methods
Method | Description
Create (+) | Crée une instance de TSdPasswordDialog
Execute (+) | Demande un mot de passe à l'utilisateur
Execute (+) | Demande un mot de passe à l'utilisateur
Execute (+) | Demande un mot de passe à l'utilisateur

Properties
Property | Description
Password (*) | Mot de passe correct
ShowErrorMes (*) | Indique s'il faut notifier sur erreur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSdNumberDialog)
Next


Sepi

Sepi
Previous
Next (FShowErrorMes)

Name
FPassword

Parent
TSdPasswordDialog

Visibility
PRIVATE

Description
Mot de passe correct

Source code
FPassword : string

Sepi
Class Tree
Index
Previous
Next (FShowErrorMes)


Sepi

Sepi
Previous (FPassword)
Next

Name
FShowErrorMes

Parent
TSdPasswordDialog

Visibility
PRIVATE

Description
Indique s'il faut notifier sur erreur

Source code
FShowErrorMes : Boolean

Sepi
Class Tree
Index
Previous (FPassword)
Next


Sepi

Sepi
Previous
Next (ShowErrorMes)

Name
Password

Parent
TSdPasswordDialog

Visibility
PUBLISHED

Description
Mot de passe correct

Source code
property Password : string read FPassword write FPassword

Read Access
FPassword

Write Access
FPassword

Sepi
Class Tree
Index
Previous
Next (ShowErrorMes)


Sepi

Sepi
Previous (Password)
Next

Name
ShowErrorMes

Parent
TSdPasswordDialog

Visibility
PUBLISHED

Description
Indique s'il faut notifier sur erreur

Source code
property ShowErrorMes : Boolean read FShowErrorMes write FShowErrorMes default True

Read Access
FShowErrorMes

Write Access
FShowErrorMes

Sepi
Class Tree
Index
Previous (Password)
Next


Sepi

Sepi
Previous
Next (Execute)

Name
Create

Parent
TSdPasswordDialog

Visibility
PUBLIC

Description
Crée une instance de TSdPasswordDialog

Source code
constructor Create ( AOwner : TComponent ) ; override

Parameters
Parameter | Description
AOwner : TComponent | Propriétaire

Sepi
Class Tree
Index
Previous
Next (Execute)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Execute

Parent
TSdPasswordDialog

Visibility
PUBLIC

Description
Demande un mot de passe à l'utilisateur

Source code
function Execute ( ShowErrorMes : Boolean ) : Boolean ; overload

Parameters
Parameter | Description
ShowErrorMes : BOOLEAN | Indique s'il faut notifier sur erreur

Return
Types | Description
BOOLEAN | True si l'utilisateur a saisi le bon mot de passe, False sinon

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Execute)
Next (Execute)

Name
Execute

Parent
TSdPasswordDialog

Visibility
PUBLIC

Description
Demande un mot de passe à l'utilisateur

Source code
function Execute ( Password : string ; ShowErrorMes : Boolean = True ) : Boolean ; overload

Parameters
Parameter | Description
Password : STRING | Mot de passe correct
ShowErrorMes : BOOLEAN | Indique s'il faut notifier sur erreur

Return
Types | Description
BOOLEAN | True si l'utilisateur a saisi le bon mot de passe, False sinon

Sepi
Class Tree
Index
Previous (Execute)
Next (Execute)


Sepi

Sepi
Previous (Execute)
Next

Name
Execute

Parent
TSdPasswordDialog

Visibility
PUBLIC

Description
Demande un mot de passe à l'utilisateur

Source code
function Execute : Boolean ; overload

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si l'utilisateur a saisi le bon mot de passe, False sinon

Sepi
Class Tree
Index
Previous (Execute)
Next


Sepi

Sepi
Previous
Next (TDialogResult)

Name
TDialogButtons

Parent
SdDialogs

Visibility
PUBLIC

Description
Boutons présents dans une boîte de dialogue
dbOK : OK
dbOKCancel : OK et Annuler
dbYesNo : Oui et Non
dbYesNoCancel : Oui, Non et Annuler
dbRetryCancel : Réessayer et Annuler
dbAbortRetryIgnore : Abandonner, Réessayer et Ignorer

Source code
TDialogButtons = ( dbOK , dbOKCancel , dbYesNo , dbYesNoCancel , dbRetryCancel , dbAbortRetryIgnore ) ;

Sepi
Class Tree
Index
Previous
Next (TDialogResult)


Sepi

Sepi
Previous (TDialogButtons)
Next (TDialogType)

Name
TDialogResult

Parent
SdDialogs

Visibility
PUBLIC

Description
Résultat de l'affichage d'une boîte de dialogue
drOK : OK
drYes : Oui
drNo : Non
drCancel : Annuler
drAbort : Abandonner
drRetry : Réessayer
drIgnore : Ignorer

Source code
TDialogResult = ( drOK , drYes , drNo , drCancel , drAbort , drRetry , drIgnore ) ;

Sepi
Class Tree
Index
Previous (TDialogButtons)
Next (TDialogType)


Sepi

Sepi
Previous (TDialogResult)
Next

Name
TDialogType

Parent
SdDialogs

Visibility
PUBLIC

Description
Type d'une boîte de dialogue
dtCustom : Type générique
dtInformation : Information
dtWarning : Avertissement
dtError : Erreur
dtConfirmation : Confirmation

Source code
TDialogType = ( dtCustom , dtInformation , dtWarning , dtError , dtConfirmation ) ;

Sepi
Class Tree
Index
Previous (TDialogResult)
Next


Sepi

Sepi
Previous
Next (QueryPassword)

Name
QueryNumber

Parent
SdDialogs

Visibility
PUBLIC

Description
Demande un nombre à l'utilisateur

Source code
function QueryNumber ( const Title , Prompt : string ; Default , Min , Max : Integer ) : Integer

Parameters
Parameter | Description
Title : STRING | Titre de la boîte de dialogue
Prompt : STRING | Invite de la boîte de dialogue
DEFAULT : INTEGER | Valeur par défaut
Min : INTEGER | Valeur minimum que peut choisir l'utilisateur
Max : INTEGER | Valeur maximum que peut choisir l'utilisateur

Return
Types | Description
INTEGER | Nombre qu'a choisi l'utilisateur

Sepi
Class Tree
Index
Previous
Next (QueryPassword)


Sepi

Sepi
Previous (QueryNumber)
Next (QueryPassWord)

Name
QueryPassword

Parent
SdDialogs

Visibility
PUBLIC

Description
Demande un mot de passe à l'utilisateur

Source code
function QueryPassword : string ; overload

Parameters
Parameter Description

Return
Types | Description
STRING | Le mot de passe qu'a saisi l'utilisateur

Sepi
Class Tree
Index
Previous (QueryNumber)
Next (QueryPassWord)


Sepi

Sepi
Previous (QueryPassword)
Next (ShowAbout)

Name
QueryPassWord

Parent
SdDialogs

Visibility
PUBLIC

Description
Demande un mot de passe à l'utilisateur

Source code
function QueryPassWord ( Password : string ; ShowErrorMes : Boolean = True ) : Boolean ; overload

Parameters
Parameter | Description
Password : STRING | Mot de passe correct
ShowErrorMes : BOOLEAN | Indique s'il faut notifier sur erreur

Return
Types | Description
BOOLEAN | True si l'utilisateur a saisi le bon mot de passe, False sinon

Sepi
Class Tree
Index
Previous (QueryPassword)
Next (ShowAbout)


Sepi

Sepi
Previous (QueryPassWord)
Next (ShowDialog)

Name
ShowAbout

Parent
SdDialogs

Visibility
PUBLIC

Description
Affiche une boîte de dialogue À propos

Source code
procedure ShowAbout ( Title : string ; ProgramIcon : TIcon ; ProgramName : string ; ProgramVersion : string ; Author : string ; AuthorEMail : string = '' ; WebSite : string = '' ) ; platform

Parameters
Parameter | Description
Title : STRING | Titre de la boîte de dialogue
ProgramIcon : TIcon | Icône du programme
ProgramName : STRING | Nom du programme
ProgramVersion : STRING | Version du programme
Author : STRING | Auteur du programme
AuthorEMail : STRING | Adresse e-mail de l'auteur (optionnel)
WebSite : STRING | Site Web du programme (optionnel)

Sepi
Class Tree
Index
Previous (QueryPassWord)
Next (ShowDialog)


Sepi

Sepi
Previous (ShowAbout)
Next (ShowDialogRadio)

Name
ShowDialog

Parent
SdDialogs

Visibility
PUBLIC

Description
Affiche une boîte de dialogue modale Windows ou QT (selon la VCL utilisée)

Source code
function ShowDialog ( const Title , Text : string ; DlgType : TDialogType = dtInformation ; DlgButtons : TDialogButtons = dbOK ; DefButton : Byte = 1 ; AddFlags : LongWord = 0 ) : TDialogResult

Parameters
Parameter | Description
Title : STRING | Titre de la boîte de dialogue
Text : STRING | Texte de la boîte de dialogue
DlgType : TDialogType | Type de boîte de dialogue
DlgButtons : TDialogButtons | Boutons à placer dans la boîte de dialogue
DefButton : BYTE | Numéro du bouton sélectionné par défaut (à partir de 1)
AddFlags : LONGWORD | Flags additionnels contrôlant de style de boîte (Win32)

Return
Types | Description
TDialogResult | Bouton sur lequel a cliqué l'utilisateur

Sepi
Class Tree
Index
Previous (ShowAbout)
Next (ShowDialogRadio)


Sepi

Sepi
Previous (ShowDialog)
Next (ShowMes)

Name
ShowDialogRadio

Parent
SdDialogs

Visibility
PUBLIC

Description
Affiche une boîte de dialogue avec des boutons radio
ShowDialogRadio est une variante de ShowDialog qui affiche des boutons radio
pour chaque choix possible.

Source code
function ShowDialogRadio ( const Title , Text : string ; DlgType : TMsgDlgType ; DlgButtons : TMsgDlgButtons ; DefButton : TModalResult ; const RadioTitles : array of string ; var Selected : Integer ; OverButtons : Boolean = False ) : Word

Parameters
Parameter | Description
Title : STRING | Titre de la boîte de dialogue
Text : STRING | Texte de la boîte de dialogue
DlgType : TMsgDlgType | Type de boîte de dialogue
DlgButtons : TMsgDlgButtons | Boutons présents dans la boîte de dialogue
DefButton : TModalResult | Bouton sélectionné par défaut
RadioTitles : STRING | Libellés des différents boutons radio
Selected : INTEGER | Bouton radio sélectionné
OverButtons : BOOLEAN | Boutons radio placés au-dessus des boutons si True

Return
Types | Description
WORD | Bouton sur lequel a cliqué l'utilisateur

Sepi
Class Tree
Index
Previous (ShowDialog)
Next (ShowMes)


Sepi

Sepi
Previous (ShowDialogRadio)
Next

Name
ShowMes

Parent
SdDialogs

Visibility
PUBLIC

Description
Affiche une boîte de dialogue modale Windows

Source code
function ShowMes ( const Title , Text : string ; Flags : LongWord ) : Integer ; platform

Parameters
Parameter | Description
Title : STRING | Titre de la boîte de dialogue
Text : STRING | Texte de la boîte de dialogue
Flags : LONGWORD | Flags contrôlant le style de boîte de dialogue

Return
Types | Description
INTEGER | Code de résultat du bouton sur lequel a cliqué l'utilisateur

Sepi
Class Tree
Index
Previous (ShowDialogRadio)
Next


Sepi

Sepi
Previous (SdDialogs)
Next (SdPassword)

Name
SdNumber

Parent
Sepi

Description
Boîte de dialogue demandant un nombre à l'utilisateur

Author
sjrd

Version
5.0

Classes
Class | Description
TSdNumberForm (+) | Boîte de dialogue demandant un nombre à l'utilisateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SdDialogs)
Next (SdPassword)


Sepi

Sepi
Previous
Next

Name
TSdNumberForm

Parent
SdNumber

Class Hierarchy
TForm

Visibility
PUBLIC

Description
Boîte de dialogue demandant un nombre à l'utilisateur

Members
Fields
Field | Description
ButtonOK (*) | Bouton OK
EditValue (-) | Éditeur pour la valeur sélectionnée
LabelPrompt (*) | Label pour l'invite

Methods
Method | Description
FormCreate (*) | Gestionnaire d'événement OnCreate
FormKeyDown (*) | Gestionnaire d'événement OnKeyDown
FormKeyPress (*) | Gestionnaire d'événement OnKeyPress
QueryNumber (+) | Affiche une invite à l'utilisateur lui demandant de choisir un nombre

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (EditValue)

Name
ButtonOK

Parent
TSdNumberForm

Visibility
PUBLISHED

Description
Bouton OK

Source code
ButtonOK : TButton

Sepi
Class Tree
Index
Previous
Next (EditValue)


Sepi

Sepi
Previous (ButtonOK)
Next (LabelPrompt)

Name
EditValue

Parent
TSdNumberForm

Visibility
PRIVATE

Description
Éditeur pour la valeur sélectionnée

Source code
EditValue : TSpinEdit

Sepi
Class Tree
Index
Previous (ButtonOK)
Next (LabelPrompt)


Sepi

Sepi
Previous (EditValue)
Next

Name
LabelPrompt

Parent
TSdNumberForm

Visibility
PUBLISHED

Description
Label pour l'invite

Source code
LabelPrompt : TLabel

Sepi
Class Tree
Index
Previous (EditValue)
Next


Sepi

Sepi
Previous
Next (FormKeyDown)

Name
FormCreate

Parent
TSdNumberForm

Visibility
PUBLISHED

Description
Gestionnaire d'événement OnCreate

Source code
procedure FormCreate ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement

Sepi
Class Tree
Index
Previous
Next (FormKeyDown)


Sepi

Sepi
Previous (FormCreate)
Next (FormKeyPress)

Name
FormKeyDown

Parent
TSdNumberForm

Visibility
PUBLISHED

Description
Gestionnaire d'événement OnKeyDown

Source code
procedure FormKeyDown ( Sender : TObject ; var Key : Word ; Shift : TShiftState )

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement
Key : WORD | Touche enfoncée
Shift : TShiftState | État des touches système

Sepi
Class Tree
Index
Previous (FormCreate)
Next (FormKeyPress)


Sepi

Sepi
Previous (FormKeyDown)
Next (QueryNumber)

Name
FormKeyPress

Parent
TSdNumberForm

Visibility
PUBLISHED

Description
Gestionnaire d'événement OnKeyPress

Source code
procedure FormKeyPress ( Sender : TObject ; var Key : Char )

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement
Key : CHAR | Caractère frappé

Sepi
Class Tree
Index
Previous (FormKeyDown)
Next (QueryNumber)


Sepi

Sepi
Previous (FormKeyPress)
Next

Name
QueryNumber

Parent
TSdNumberForm

Visibility
PUBLIC

Description
Affiche une invite à l'utilisateur lui demandant de choisir un nombre

Source code
class function QueryNumber ( const Title , Prompt : string ; Default , Min , Max : Integer ) : Integer

Parameters
Parameter | Description
Title : STRING | Titre de la boîte de dialogue
Prompt : STRING | Invite
DEFAULT : INTEGER | Valeur par défaut affichée
Min : INTEGER | Valeur minimale que peut choisir l'utilisateur
Max : INTEGER | Valeur maximale que peut choisir l'utilisateur

Return
Types | Description
INTEGER | La valeur qu'a choisie l'utilisateur

Sepi
Class Tree
Index
Previous (FormKeyPress)
Next


Sepi

Sepi
Previous (SdNumber)
Next (SepiAbout)

Name
SdPassword

Parent
Sepi

Description
Boîte de dialogue de saisie de mot de passe

Author
sjrd

Version
1.0

Classes
Class | Description
TSdPasswordForm (+) | Boîte de dialogue de saisie de mot de passe

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SdNumber)
Next (SepiAbout)


Sepi

Sepi
Previous
Next

Name
TSdPasswordForm

Parent
SdPassword

Class Hierarchy
TForm

Visibility
PUBLIC

Description
Boîte de dialogue de saisie de mot de passe

Members
Fields
Field | Description
BoutonAnnuler (*) | Bouton Annuler
BoutonOK (*) | Bouton OK
EditPassword (*) | Edit pour le mot de passe
LabelPrompt (*) | Label pour l'invite

Methods
Method | Description
QueryPassword (+) | Demande un mot de passe à l'utilisateur
QueryPassword (+) | Demande un mot de passe à l'utilisateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (BoutonOK)

Name
BoutonAnnuler

Parent
TSdPasswordForm

Visibility
PUBLISHED

Description
Bouton Annuler

Source code
BoutonAnnuler : TBitBtn

Sepi
Class Tree
Index
Previous
Next (BoutonOK)


Sepi

Sepi
Previous (BoutonAnnuler)
Next (EditPassword)

Name
BoutonOK

Parent
TSdPasswordForm

Visibility
PUBLISHED

Description
Bouton OK

Source code
BoutonOK : TBitBtn

Sepi
Class Tree
Index
Previous (BoutonAnnuler)
Next (EditPassword)


Sepi

Sepi
Previous (BoutonOK)
Next (LabelPrompt)

Name
EditPassword

Parent
TSdPasswordForm

Visibility
PUBLISHED

Description
Edit pour le mot de passe

Source code
EditPassword : TEdit

Sepi
Class Tree
Index
Previous (BoutonOK)
Next (LabelPrompt)


Sepi

Sepi
Previous (EditPassword)
Next

Name
LabelPrompt

Parent
TSdPasswordForm

Visibility
PUBLISHED

Description
Label pour l'invite

Source code
LabelPrompt : TLabel

Sepi
Class Tree
Index
Previous (EditPassword)
Next


Sepi

Sepi
Previous
Next (QueryPassword)

Name
QueryPassword

Parent
TSdPasswordForm

Visibility
PUBLIC

Description
Demande un mot de passe à l'utilisateur

Source code
class function QueryPassword ( Password : string ; ShowErrorMes : Boolean = True ) : Boolean ; overload

Parameters
Parameter | Description
Password : STRING | Mot de passe correct
ShowErrorMes : BOOLEAN | Indique s'il faut notifier sur erreur

Return
Types | Description
BOOLEAN | True si l'utilisateur a saisi le bon mot de passe, False sinon

Sepi
Class Tree
Index
Previous
Next (QueryPassword)


Sepi

Sepi
Previous (QueryPassword)
Next

Name
QueryPassword

Parent
TSdPasswordForm

Visibility
PUBLIC

Description
Demande un mot de passe à l'utilisateur

Source code
class function QueryPassword : string ; overload

Parameters
Parameter Description

Return
Types | Description
STRING | Le mot de passe qu'a saisi l'utilisateur

Sepi
Class Tree
Index
Previous (QueryPassword)
Next


Sepi

Sepi
Previous (SdPassword)
Next (SepiArrayTypes)

Name
SepiAbout

Parent
Sepi

Description
Définit le composant « À propos » de Sepi

Author
sjrd

Version
1.0

Classes
Class | Description
TSepiAboutDialog (+) | Boîte de dialogue « À propos » de Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SdPassword)
Next (SepiArrayTypes)


Sepi

Sepi
Previous
Next

Name
TSepiAboutDialog

Parent
SepiAbout

Class Hierarchy
TComponent

Visibility
PUBLIC

Description
Boîte de dialogue « À propos » de Sepi

Members
Fields
Field | Description
FDialog (-) | Boîte de dialogue générique

Methods
Method | Description
Create (+) | Crée une instance de TSepiAboutDialog
Execute (+) | Affiche la boîte de dialogue

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
FDialog

Parent
TSepiAboutDialog

Visibility
PRIVATE

Description
Boîte de dialogue générique

Source code
FDialog : TSdAboutDialog

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Execute)

Name
Create

Parent
TSepiAboutDialog

Visibility
PUBLIC

Description
Crée une instance de TSepiAboutDialog

Source code
constructor Create ( AOwner : TComponent ) ; override

Parameters
Parameter | Description
AOwner : TComponent | Propriétaire

Sepi
Class Tree
Index
Previous
Next (Execute)


Sepi

Sepi
Previous (Create)
Next

Name
Execute

Parent
TSepiAboutDialog

Visibility
PUBLIC

Description
Affiche la boîte de dialogue

Source code
procedure Execute

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (SepiAbout)
Next (SepiAsmInstructions)

Name
SepiArrayTypes

Parent
Sepi

Description
Définit les classes de gestion des types tableau

Author
sjrd

Version
1.0

Constants
Constant Description

Classes
Class | Description
TSepiArrayType (+) | Type tableau
TSepiDynArrayType (+) | Type tableau dynamique
TSepiOpenArrayType (+) | Type tableau ouvert
TSepiStaticArrayType (+) | Type tableau statique

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiAbout)
Next (SepiAsmInstructions)


Sepi

Sepi
Previous
Next (TSepiDynArrayType)

Name
TSepiArrayType

Parent
SepiArrayTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type tableau

Members
Fields
Field | Description
FElementType (-) | Type des éléments

Methods
Method | Description
Create (+) | Crée un nouveau type tableau
Equals (+) | [@inheritDoc]
GetIndexType (#) | Type de l'index
InternalValueToString (#) | Représentation sous forme de chaîne d'un tableau de ce type
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un type tableau depuis un flux
Save (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
ElementType (+) | Type des éléments
IndexType (+) | Type de l'index

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiDynArrayType)


Sepi

Sepi
Previous
Next

Name
FElementType

Parent
TSepiArrayType

Visibility
PRIVATE

Description
Type des éléments

Source code
FElementType : TSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (IndexType)

Name
ElementType

Parent
TSepiArrayType

Visibility
PUBLIC

Description
Type des éléments

Source code
property ElementType : TSepiType read FElementType

Read Access
FElementType

Sepi
Class Tree
Index
Previous
Next (IndexType)


Sepi

Sepi
Previous (ElementType)
Next

Name
IndexType

Parent
TSepiArrayType

Visibility
PUBLIC

Description
Type de l'index

Source code
property IndexType : TSepiOrdType read GetIndexType

Read Access
GetIndexType

Sepi
Class Tree
Index
Previous (ElementType)
Next


Sepi

Sepi
Previous
Next (Equals)

Name
Create

Parent
TSepiArrayType

Visibility
PUBLIC

Description
Crée un nouveau type tableau

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AKind : TTypeKind ; AElementType : TSepiType )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING
AKind : TTypeKind
AElementType : TSepiType

Sepi
Class Tree
Index
Previous
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (GetIndexType)

Name
Equals

Parent
TSepiArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetIndexType)


Sepi

Sepi
Previous (Equals)
Next (InternalValueToString)

Name
GetIndexType

Parent
TSepiArrayType

Visibility
PROTECTED

Description
Type de l'index

Source code
function GetIndexType : TSepiOrdType ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
TSepiOrdType | Type de l'index

Sepi
Class Tree
Index
Previous (Equals)
Next (InternalValueToString)


Sepi

Sepi
Previous (GetIndexType)
Next (ListReferences)

Name
InternalValueToString

Parent
TSepiArrayType

Visibility
PROTECTED

Description
Représentation sous forme de chaîne d'un tableau de ce type

Source code
function InternalValueToString ( Items : Pointer ; Count : Integer ) : string

Parameters
Parameter | Description
Items : Pointer | Pointeur sur le premier élément du tableau
Count : INTEGER | Nombre d'éléments

Return
Types | Description
STRING | Représentation sous forme de chaîne du tableau

Sepi
Class Tree
Index
Previous (GetIndexType)
Next (ListReferences)


Sepi

Sepi
Previous (InternalValueToString)
Next (Load)

Name
ListReferences

Parent
TSepiArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (InternalValueToString)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiArrayType

Visibility
PUBLIC

Description
Charge un type tableau depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (WriteDigestData)

Name
Save

Parent
TSepiArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (WriteDigestData)


Sepi

Sepi
Previous (Save)
Next

Name
WriteDigestData

Parent
TSepiArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next


Sepi

Sepi
Previous (TSepiArrayType)
Next (TSepiOpenArrayType)

Name
TSepiDynArrayType

Parent
SepiArrayTypes

Class Hierarchy
TSepiArrayType

Visibility
PUBLIC

Description
Type tableau dynamique

Members
Methods
Method | Description
Clone (+) | [@inheritDoc]
CompatibleWith (+) | [@inheritDoc]
Create (+) | Crée un nouveau type tableau dynamique
GetDescription (#) | [@inheritDoc]
GetIndexType (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiArrayType)
Next (TSepiOpenArrayType)


Sepi

Sepi
Previous
Next (CompatibleWith)

Name
Clone

Parent
TSepiDynArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
CompatibleWith

Parent
TSepiDynArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (GetDescription)

Name
Create

Parent
TSepiDynArrayType

Visibility
PUBLIC

Description
Crée un nouveau type tableau dynamique

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AElementType : TSepiType )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AElementType : TSepiType | Type des éléments

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (GetDescription)


Sepi

Sepi
Previous (Create)
Next (GetIndexType)

Name
GetDescription

Parent
TSepiDynArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetIndexType)


Sepi

Sepi
Previous (GetDescription)
Next (SetupProperties)

Name
GetIndexType

Parent
TSepiDynArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIndexType : TSepiOrdType ; override

Parameters
Parameter Description

Return
Types | Description
TSepiOrdType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDescription)
Next (SetupProperties)


Sepi

Sepi
Previous (GetIndexType)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiDynArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetIndexType)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteTypeInfo)

Name
ValueToString

Parent
TSepiDynArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (ValueToString)
Next

Name
WriteTypeInfo

Parent
TSepiDynArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next


Sepi

Sepi
Previous (TSepiDynArrayType)
Next (TSepiStaticArrayType)

Name
TSepiOpenArrayType

Parent
SepiArrayTypes

Class Hierarchy
TSepiArrayType

Visibility
PUBLIC

Description
Type tableau ouvert

Members
Fields
Field | Description
FHighVarName (-) | Nom de la variable reprenant la valeur de High
FIsArrayOfConst (-) | Indique si c'est un array of const

Methods
Method | Description
CompatibleWith (+) | [@inheritDoc]
Create (+) | Crée une instance TSepiOpenArrayType
GetDescription (#) | [@inheritDoc]
GetIndexType (#) | [@inheritDoc]
Load (+) | [@inheritDoc]
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]

Properties
Property | Description
HighVarName (+) | Nom de la variable reprenant la valeur de High
IsArrayOfConst (+) | Indique si c'est un array of const

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDynArrayType)
Next (TSepiStaticArrayType)


Sepi

Sepi
Previous
Next (FIsArrayOfConst)

Name
FHighVarName

Parent
TSepiOpenArrayType

Visibility
PRIVATE

Description
Nom de la variable reprenant la valeur de High

Source code
FHighVarName : string

Sepi
Class Tree
Index
Previous
Next (FIsArrayOfConst)


Sepi

Sepi
Previous (FHighVarName)
Next

Name
FIsArrayOfConst

Parent
TSepiOpenArrayType

Visibility
PRIVATE

Description
Indique si c'est un array of const

Source code
FIsArrayOfConst : Boolean

Sepi
Class Tree
Index
Previous (FHighVarName)
Next


Sepi

Sepi
Previous
Next (IsArrayOfConst)

Name
HighVarName

Parent
TSepiOpenArrayType

Visibility
PUBLIC

Description
Nom de la variable reprenant la valeur de High

Source code
property HighVarName : string read FHighVarName

Read Access
FHighVarName

Sepi
Class Tree
Index
Previous
Next (IsArrayOfConst)


Sepi

Sepi
Previous (HighVarName)
Next

Name
IsArrayOfConst

Parent
TSepiOpenArrayType

Visibility
PUBLIC

Description
Indique si c'est un array of const

Source code
property IsArrayOfConst : Boolean read FIsArrayOfConst

Read Access
FIsArrayOfConst

Sepi
Class Tree
Index
Previous (HighVarName)
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompatibleWith

Parent
TSepiOpenArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (GetDescription)

Name
Create

Parent
TSepiOpenArrayType

Visibility
PUBLIC

Description
Crée une instance TSepiOpenArrayType

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AElementType : TSepiType ; const AHighVarName : string )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire
AName : STRING | Nom du type
AElementType : TSepiType | Type d'élément
AHighVarName : STRING | Nom de la variable High

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (GetDescription)


Sepi

Sepi
Previous (Create)
Next (GetIndexType)

Name
GetDescription

Parent
TSepiOpenArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetIndexType)


Sepi

Sepi
Previous (GetDescription)
Next (Load)

Name
GetIndexType

Parent
TSepiOpenArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIndexType : TSepiOrdType ; override

Parameters
Parameter Description

Return
Types | Description
TSepiOrdType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDescription)
Next (Load)


Sepi

Sepi
Previous (GetIndexType)
Next (Save)

Name
Load

Parent
TSepiOpenArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIndexType)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiOpenArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiOpenArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next

Name
ValueToString

Parent
TSepiOpenArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next


Sepi

Sepi
Previous (TSepiOpenArrayType)
Next

Name
TSepiStaticArrayType

Parent
SepiArrayTypes

Class Hierarchy
TSepiArrayType

Visibility
PUBLIC

Description
Type tableau statique

Members
Fields
Field | Description
FBaseElementType (-) | Type d'élément de base
FDimCount (-) | Nombre de dimensions
FHigherBound (-) | Borne supérieure
FIndexType (-) | Type de l'index
FLowerBound (-) | Borne inférieure

Methods
Method | Description
Clone (+) | [@inheritDoc]
CompatibleWith (+) | [@inheritDoc]
Create (+) | Crée un nouveau type tableau
Equals (+) | [@inheritDoc]
GetAlignment (#) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
GetIndexType (#) | [@inheritDoc]
GetLength (-) | Longueur du tableau
HasTypeInfo (#) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un type tableau statique depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
ArrayLength (+) | Longueur du tableau
BaseElementType (+) | Type d'élément de base
DimCount (+) | Nombre de dimensions
HigherBound (+) | Borne supérieure
LowerBound (+) | Borne inférieure

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOpenArrayType)
Next


Sepi

Sepi
Previous
Next (FDimCount)

Name
FBaseElementType

Parent
TSepiStaticArrayType

Visibility
PRIVATE

Description
Type d'élément de base

Source code
FBaseElementType : TSepiType

Sepi
Class Tree
Index
Previous
Next (FDimCount)


Sepi

Sepi
Previous (FBaseElementType)
Next (FHigherBound)

Name
FDimCount

Parent
TSepiStaticArrayType

Visibility
PRIVATE

Description
Nombre de dimensions

Source code
FDimCount : Integer

Sepi
Class Tree
Index
Previous (FBaseElementType)
Next (FHigherBound)


Sepi

Sepi
Previous (FDimCount)
Next (FIndexType)

Name
FHigherBound

Parent
TSepiStaticArrayType

Visibility
PRIVATE

Description
Borne supérieure

Source code
FHigherBound : Integer

Sepi
Class Tree
Index
Previous (FDimCount)
Next (FIndexType)


Sepi

Sepi
Previous (FHigherBound)
Next (FLowerBound)

Name
FIndexType

Parent
TSepiStaticArrayType

Visibility
PRIVATE

Description
Type de l'index

Source code
FIndexType : TSepiOrdType

Sepi
Class Tree
Index
Previous (FHigherBound)
Next (FLowerBound)


Sepi

Sepi
Previous (FIndexType)
Next

Name
FLowerBound

Parent
TSepiStaticArrayType

Visibility
PRIVATE

Description
Borne inférieure

Source code
FLowerBound : Integer

Sepi
Class Tree
Index
Previous (FIndexType)
Next


Sepi

Sepi
Previous
Next (BaseElementType)

Name
ArrayLength

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
Longueur du tableau

Source code
property ArrayLength : Integer read GetLength

Read Access
GetLength

Sepi
Class Tree
Index
Previous
Next (BaseElementType)


Sepi

Sepi
Previous (ArrayLength)
Next (DimCount)

Name
BaseElementType

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
Type d'élément de base

Source code
property BaseElementType : TSepiType read FBaseElementType

Read Access
FBaseElementType

Sepi
Class Tree
Index
Previous (ArrayLength)
Next (DimCount)


Sepi

Sepi
Previous (BaseElementType)
Next (HigherBound)

Name
DimCount

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
Nombre de dimensions

Source code
property DimCount : Integer read FDimCount

Read Access
FDimCount

Sepi
Class Tree
Index
Previous (BaseElementType)
Next (HigherBound)


Sepi

Sepi
Previous (DimCount)
Next (LowerBound)

Name
HigherBound

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
Borne supérieure

Source code
property HigherBound : Integer read FHigherBound

Read Access
FHigherBound

Sepi
Class Tree
Index
Previous (DimCount)
Next (LowerBound)


Sepi

Sepi
Previous (HigherBound)
Next

Name
LowerBound

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
Borne inférieure

Source code
property LowerBound : Integer read FLowerBound

Read Access
FLowerBound

Sepi
Class Tree
Index
Previous (HigherBound)
Next


Sepi

Sepi
Previous
Next (CompatibleWith)

Name
Clone

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
CompatibleWith

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (Equals)

Name
Create

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
Crée un nouveau type tableau

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AIndexType : TSepiOrdType ; ALowerBound , AHigherBound : Integer ; AElementType : TSepiType )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING
AIndexType : TSepiOrdType | Type de l'index
ALowerBound : INTEGER | Borne inférieure
AHigherBound : INTEGER | Borne supérieure
AElementType : TSepiType

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (GetAlignment)

Name
Equals

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetAlignment)


Sepi

Sepi
Previous (Equals)
Next (GetDescription)

Name
GetAlignment

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetDescription)


Sepi

Sepi
Previous (GetAlignment)
Next (GetIndexType)

Name
GetDescription

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAlignment)
Next (GetIndexType)


Sepi

Sepi
Previous (GetDescription)
Next (GetLength)

Name
GetIndexType

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIndexType : TSepiOrdType ; override

Parameters
Parameter Description

Return
Types | Description
TSepiOrdType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDescription)
Next (GetLength)


Sepi

Sepi
Previous (GetIndexType)
Next (HasTypeInfo)

Name
GetLength

Parent
TSepiStaticArrayType

Visibility
PRIVATE

Description
Longueur du tableau

Source code
function GetLength : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Longueur du tableau

Sepi
Class Tree
Index
Previous (GetIndexType)
Next (HasTypeInfo)


Sepi

Sepi
Previous (GetLength)
Next (ListReferences)

Name
HasTypeInfo

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function HasTypeInfo : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetLength)
Next (ListReferences)


Sepi

Sepi
Previous (HasTypeInfo)
Next (Load)

Name
ListReferences

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (HasTypeInfo)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
Charge un type tableau statique depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiStaticArrayType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiStaticArrayType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (SepiArrayTypes)
Next (SepiCompiler)

Name
SepiAsmInstructions

Parent
Sepi

Description
Instructions assembleur Sepi

Author
sjrd

Version
1.0

Constants
Constant Description

Classes
Class | Description
ESepiInvalidDataSizeError (+) | Taille de données invalide pour un MOVE
ESepiInvalidParamsError (+) | Paramètres invalide dans une instruction CALL
TSepiAsmAddressCall (+) | Instruction Address CALL
TSepiAsmAsClass (+) | Instruction AS
TSepiAsmCall (+) | Instruction CALL
TSepiAsmCallParam (+) | Paramètre d'une instruction CALL
TSepiAsmCallParams (+) | Paramètres d'une instruction CALL
TSepiAsmCompare (+) | Instruction de comparaison
TSepiAsmCondJump (+) | Instruction JIT ou JIF (JUMP conditionnel)
TSepiAsmConvert (+) | Instruction CVRT
TSepiAsmDynamicCall (+) | Instruction Dynamic CALL
TSepiAsmDynArrayCopy (+) | Instruction DACP
TSepiAsmDynArraySetLength (+) | Instruction DASL
TSepiAsmGetRunInfo (+) | Instruction GTI, GDC ou GMC
TSepiAsmIsClass (+) | Instruction IS
TSepiAsmJump (+) | Instruction JUMP
TSepiAsmLoadAddress (+) | Instruction LEA
TSepiAsmMove (+) | Instruction MOVE
TSepiAsmMultiOn (+) | Instruction ON
TSepiAsmNope (+) | Instruction NOP
TSepiAsmOnClause (+) | Clause ON d'un MultiOn
TSepiAsmOperation (+) | Instruction opération
TSepiAsmRaise (+) | Instruction RAISE
TSepiAsmRefCall (+) | Instruction CALL avec une référence à la méthode
TSepiAsmReraise (+) | Instruction RERS
TSepiAsmSetCompare (+) | Instruction de comparaison de sets
TSepiAsmSetElem (+) | Instruction SELE
TSepiAsmSetExpand (+) | Instruction SEXP
TSepiAsmSetIn (+) | Instruction SIN
TSepiAsmSetIncludeExclude (+) | Instruction SINC ou SEXC
TSepiAsmSetOperation (+) | Instruction opération sur des sets
TSepiAsmSetRange (+) | Instruction SRNG ou SUR
TSepiAsmStaticCall (+) | Instruction Static CALL
TSepiAsmStrCopy (+) | Instruction ASCP ou WSCP
TSepiAsmStrSetLength (+) | Instruction ASSL ou WSSL
TSepiAsmTryExcept (+) | Instruction TRYE
TSepiAsmTryFinally (+) | Instruction TRYF
TSepiAsmValueToIntStdFunction (+) | Instruction ASL, WSL, DAL ou DAH

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiArrayTypes)
Next (SepiCompiler)


Sepi

Sepi
Previous
Next (ESepiInvalidParamsError)

Name
ESepiInvalidDataSizeError

Parent
SepiAsmInstructions

Class Hierarchy
ESepiCompilerError

Visibility
PUBLIC

Description
Taille de données invalide pour un MOVE

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ESepiInvalidParamsError)


Sepi

Sepi
Previous (ESepiInvalidDataSizeError)
Next (TSepiAsmAddressCall)

Name
ESepiInvalidParamsError

Parent
SepiAsmInstructions

Class Hierarchy
ESepiCompilerError

Visibility
PUBLIC

Description
Paramètres invalide dans une instruction CALL

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiInvalidDataSizeError)
Next (TSepiAsmAddressCall)


Sepi

Sepi
Previous (ESepiInvalidParamsError)
Next (TSepiAsmAsClass)

Name
TSepiAsmAddressCall

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmCall

Visibility
PUBLIC

Description
Instruction Address CALL

Members
Fields
Field | Description
FAddress (-) | Adresse de la méthode à appeler
FCallingConvention (-) | Convention d'appel
FOrdResultSize (-) | Taille d'un résultat ordinal
FRegUsage (-) | Utilisation des registres
FResultBehavior (-) | Comportement du résultat

Methods
Method | Description
Create (+) | Crée une instruction Basic CALL
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
Prepare (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Address (+) | Adresse de la méthode à appeler
CallingConvention (+) | Convention d'appel
OrdResultSize (+) | Taille d'un résultat ordinal
RegUsage (+) | Utilisation des registres
ResultBehavior (+) | Comportement du résultat

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiInvalidParamsError)
Next (TSepiAsmAsClass)


Sepi

Sepi
Previous
Next (FCallingConvention)

Name
FAddress

Parent
TSepiAsmAddressCall

Visibility
PRIVATE

Description
Adresse de la méthode à appeler

Source code
FAddress : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FCallingConvention)


Sepi

Sepi
Previous (FAddress)
Next (FOrdResultSize)

Name
FCallingConvention

Parent
TSepiAsmAddressCall

Visibility
PRIVATE

Description
Convention d'appel

Source code
FCallingConvention : TCallingConvention

Sepi
Class Tree
Index
Previous (FAddress)
Next (FOrdResultSize)


Sepi

Sepi
Previous (FCallingConvention)
Next (FRegUsage)

Name
FOrdResultSize

Parent
TSepiAsmAddressCall

Visibility
PRIVATE

Description
Taille d'un résultat ordinal

Source code
FOrdResultSize : Byte

Sepi
Class Tree
Index
Previous (FCallingConvention)
Next (FRegUsage)


Sepi

Sepi
Previous (FOrdResultSize)
Next (FResultBehavior)

Name
FRegUsage

Parent
TSepiAsmAddressCall

Visibility
PRIVATE

Description
Utilisation des registres

Source code
FRegUsage : Byte

Sepi
Class Tree
Index
Previous (FOrdResultSize)
Next (FResultBehavior)


Sepi

Sepi
Previous (FRegUsage)
Next

Name
FResultBehavior

Parent
TSepiAsmAddressCall

Visibility
PRIVATE

Description
Comportement du résultat

Source code
FResultBehavior : TSepiTypeResultBehavior

Sepi
Class Tree
Index
Previous (FRegUsage)
Next


Sepi

Sepi
Previous
Next (CallingConvention)

Name
Address

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
Adresse de la méthode à appeler

Source code
property Address : TSepiMemoryReference read FAddress

Read Access
FAddress

Sepi
Class Tree
Index
Previous
Next (CallingConvention)


Sepi

Sepi
Previous (Address)
Next (OrdResultSize)

Name
CallingConvention

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
Convention d'appel

Source code
property CallingConvention : TCallingConvention read FCallingConvention write FCallingConvention

Read Access
FCallingConvention

Write Access
FCallingConvention

Sepi
Class Tree
Index
Previous (Address)
Next (OrdResultSize)


Sepi

Sepi
Previous (CallingConvention)
Next (RegUsage)

Name
OrdResultSize

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
Taille d'un résultat ordinal

Source code
property OrdResultSize : Byte read FOrdResultSize write FOrdResultSize

Read Access
FOrdResultSize

Write Access
FOrdResultSize

Sepi
Class Tree
Index
Previous (CallingConvention)
Next (RegUsage)


Sepi

Sepi
Previous (OrdResultSize)
Next (ResultBehavior)

Name
RegUsage

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
Utilisation des registres

Source code
property RegUsage : Byte read FRegUsage write FRegUsage

Read Access
FRegUsage

Write Access
FRegUsage

Sepi
Class Tree
Index
Previous (OrdResultSize)
Next (ResultBehavior)


Sepi

Sepi
Previous (RegUsage)
Next

Name
ResultBehavior

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
Comportement du résultat

Source code
property ResultBehavior : TSepiTypeResultBehavior read FResultBehavior write FResultBehavior

Read Access
FResultBehavior

Write Access
FResultBehavior

Sepi
Class Tree
Index
Previous (RegUsage)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
Crée une instruction Basic CALL

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (Prepare)

Name
Make

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (Prepare)


Sepi

Sepi
Previous (Make)
Next (WriteToStream)

Name
Prepare

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Prepare ( Signature : TSepiSignature ) ; override

Parameters
Parameter | Description
Signature : TSepiSignature | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next (WriteToStream)


Sepi

Sepi
Previous (Prepare)
Next

Name
WriteToStream

Parent
TSepiAsmAddressCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Prepare)
Next


Sepi

Sepi
Previous (TSepiAsmAddressCall)
Next (TSepiAsmCall)

Name
TSepiAsmAsClass

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction AS

Members
Fields
Field | Description
FClassRef (-) | Référence à une classe (si msZero)
FMemClass (-) | Classe mémoire
FMemObject (-) | Objet mémoire

Methods
Method | Description
Create (+) | Crée une instruction AS
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
ClassRef (+) | Référence à une classe (si msZero)
MemClass (+) | Classe mémoire
MemObject (+) | Objet mémoire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmAddressCall)
Next (TSepiAsmCall)


Sepi

Sepi
Previous
Next (FMemClass)

Name
FClassRef

Parent
TSepiAsmAsClass

Visibility
PRIVATE

Description
Référence à une classe (si msZero)

Source code
FClassRef : Integer

Sepi
Class Tree
Index
Previous
Next (FMemClass)


Sepi

Sepi
Previous (FClassRef)
Next (FMemObject)

Name
FMemClass

Parent
TSepiAsmAsClass

Visibility
PRIVATE

Description
Classe mémoire

Source code
FMemClass : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FClassRef)
Next (FMemObject)


Sepi

Sepi
Previous (FMemClass)
Next

Name
FMemObject

Parent
TSepiAsmAsClass

Visibility
PRIVATE

Description
Objet mémoire

Source code
FMemObject : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FMemClass)
Next


Sepi

Sepi
Previous
Next (MemClass)

Name
ClassRef

Parent
TSepiAsmAsClass

Visibility
PUBLIC

Description
Référence à une classe (si msZero)

Source code
property ClassRef : Integer read FClassRef write FClassRef

Read Access
FClassRef

Write Access
FClassRef

Sepi
Class Tree
Index
Previous
Next (MemClass)


Sepi

Sepi
Previous (ClassRef)
Next (MemObject)

Name
MemClass

Parent
TSepiAsmAsClass

Visibility
PUBLIC

Description
Classe mémoire

Source code
property MemClass : TSepiMemoryReference read FMemClass

Read Access
FMemClass

Sepi
Class Tree
Index
Previous (ClassRef)
Next (MemObject)


Sepi

Sepi
Previous (MemClass)
Next

Name
MemObject

Parent
TSepiAsmAsClass

Visibility
PUBLIC

Description
Objet mémoire

Source code
property MemObject : TSepiMemoryReference read FMemObject

Read Access
FMemObject

Sepi
Class Tree
Index
Previous (MemClass)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmAsClass

Visibility
PUBLIC

Description
Crée une instruction AS

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmAsClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmAsClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmAsClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmAsClass)
Next (TSepiAsmCallParam)

Name
TSepiAsmCall

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction CALL

Members
Fields
Field | Description
FParameters (-) | Paramètres

Methods
Method | Description
Create (+) | Crée une instruction CALL
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
Prepare (+) | Prépare les paramètres en fonction de la signature d'un meta
Prepare (+) | Prépare les paramètres en fonction d'une signature
Prepare (+) | Prépare les paramètres en fonction de la signature d'un meta

Properties
Property | Description
Parameters (+) | Paramètres

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmAsClass)
Next (TSepiAsmCallParam)


Sepi

Sepi
Previous
Next

Name
FParameters

Parent
TSepiAsmCall

Visibility
PRIVATE

Description
Paramètres

Source code
FParameters : TSepiAsmCallParams

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Parameters

Parent
TSepiAsmCall

Visibility
PUBLIC

Description
Paramètres

Source code
property Parameters : TSepiAsmCallParams read FParameters

Read Access
FParameters

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmCall

Visibility
PUBLIC

Description
Crée une instruction CALL

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (Prepare)

Name
Make

Parent
TSepiAsmCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (Prepare)


Sepi

Sepi
Previous (Make)
Next (Prepare)

Name
Prepare

Parent
TSepiAsmCall

Visibility
PUBLIC

Description
Prépare les paramètres en fonction de la signature d'un meta

Source code
procedure Prepare ( const ComponentName : string ) ; overload

Parameters
Parameter Description
ComponentName : STRING

Sepi
Class Tree
Index
Previous (Make)
Next (Prepare)


Sepi

Sepi
Previous (Prepare)
Next (Prepare)

Name
Prepare

Parent
TSepiAsmCall

Visibility
PUBLIC

Description
Prépare les paramètres en fonction d'une signature

Source code
procedure Prepare ( Signature : TSepiSignature ) ; overload ; virtual

Parameters
Parameter | Description
Signature : TSepiSignature | Signature

Sepi
Class Tree
Index
Previous (Prepare)
Next (Prepare)


Sepi

Sepi
Previous (Prepare)
Next

Name
Prepare

Parent
TSepiAsmCall

Visibility
PUBLIC

Description
Prépare les paramètres en fonction de la signature d'un meta

Source code
procedure Prepare ( Component : TSepiComponent ) ; overload

Parameters
Parameter | Description
Component : TSepiComponent | Méthode ou type référence de méthode

Sepi
Class Tree
Index
Previous (Prepare)
Next


Sepi

Sepi
Previous (TSepiAsmCall)
Next (TSepiAsmCallParams)

Name
TSepiAsmCallParam

Parent
SepiAsmInstructions

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Paramètre d'une instruction CALL

Members
Fields
Field | Description
FMemoryRef (-) | Référence mémoire
FName (-) | Nom du paramètre
FParamSize (-) | Taille du paramètre
FSepiStackOffset (-) | Offset dans la pile Sepi
FSize (-) | Taille écrite dans le flux
FStackUsage (-) | Nombre de DWord utilisés dans la pile

Methods
Method | Description
Create (+) | Crée un paramètre
Destroy (+) | [@inheritDoc]
Make (+) | Construit le paramètre
WriteToStream (+) | Ecrit le paramètre dans un flux

Properties
Property | Description
MemoryRef (+) | Référence mémoire
NAME (+) | Nom du paramètre
ParamSize (+) | Taille du paramètre
SepiStackOffset (+) | Offset dans la pile Sepi
Size (+) | Taille écrite dans le flux
StackUsage (+) | Nombre de DWord utilisés dans la pile

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmCall)
Next (TSepiAsmCallParams)


Sepi

Sepi
Previous
Next (FName)

Name
FMemoryRef

Parent
TSepiAsmCallParam

Visibility
PRIVATE

Description
Référence mémoire

Source code
FMemoryRef : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FName)


Sepi

Sepi
Previous (FMemoryRef)
Next (FParamSize)

Name
FName

Parent
TSepiAsmCallParam

Visibility
PRIVATE

Description
Nom du paramètre

Source code
FName : string

Sepi
Class Tree
Index
Previous (FMemoryRef)
Next (FParamSize)


Sepi

Sepi
Previous (FName)
Next (FSepiStackOffset)

Name
FParamSize

Parent
TSepiAsmCallParam

Visibility
PRIVATE

Description
Taille du paramètre

Source code
FParamSize : TSepiParamSize

Sepi
Class Tree
Index
Previous (FName)
Next (FSepiStackOffset)


Sepi

Sepi
Previous (FParamSize)
Next (FSize)

Name
FSepiStackOffset

Parent
TSepiAsmCallParam

Visibility
PRIVATE

Description
Offset dans la pile Sepi

Source code
FSepiStackOffset : Integer

Sepi
Class Tree
Index
Previous (FParamSize)
Next (FSize)


Sepi

Sepi
Previous (FSepiStackOffset)
Next (FStackUsage)

Name
FSize

Parent
TSepiAsmCallParam

Visibility
PRIVATE

Description
Taille écrite dans le flux

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FSepiStackOffset)
Next (FStackUsage)


Sepi

Sepi
Previous (FSize)
Next

Name
FStackUsage

Parent
TSepiAsmCallParam

Visibility
PRIVATE

Description
Nombre de DWord utilisés dans la pile

Source code
FStackUsage : Integer

Sepi
Class Tree
Index
Previous (FSize)
Next


Sepi

Sepi
Previous
Next (NAME)

Name
MemoryRef

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Référence mémoire

Source code
property MemoryRef : TSepiMemoryReference read FMemoryRef

Read Access
FMemoryRef

Sepi
Class Tree
Index
Previous
Next (NAME)


Sepi

Sepi
Previous (MemoryRef)
Next (ParamSize)

Name
NAME

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Nom du paramètre

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (MemoryRef)
Next (ParamSize)


Sepi

Sepi
Previous (NAME)
Next (SepiStackOffset)

Name
ParamSize

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Taille du paramètre

Source code
property ParamSize : TSepiParamSize read FParamSize

Read Access
FParamSize

Sepi
Class Tree
Index
Previous (NAME)
Next (SepiStackOffset)


Sepi

Sepi
Previous (ParamSize)
Next (Size)

Name
SepiStackOffset

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Offset dans la pile Sepi

Source code
property SepiStackOffset : Integer read FSepiStackOffset

Read Access
FSepiStackOffset

Sepi
Class Tree
Index
Previous (ParamSize)
Next (Size)


Sepi

Sepi
Previous (SepiStackOffset)
Next (StackUsage)

Name
Size

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Taille écrite dans le flux

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (SepiStackOffset)
Next (StackUsage)


Sepi

Sepi
Previous (Size)
Next

Name
StackUsage

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Nombre de DWord utilisés dans la pile

Source code
property StackUsage : Integer read FStackUsage

Read Access
FStackUsage

Sepi
Class Tree
Index
Previous (Size)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Crée un paramètre

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ASepiStackOffset : Integer ; AParamSize : TSepiParamSize ; const AName : string = '' )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode Sepi
ASepiStackOffset : INTEGER | Offset dans la pile Sepi
AParamSize : TSepiParamSize | Taille de paramètre
AName : STRING

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Construit le paramètre

Source code
procedure Make

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmCallParam

Visibility
PUBLIC

Description
Ecrit le paramètre dans un flux

Source code
procedure WriteToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux de destination

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmCallParam)
Next (TSepiAsmCompare)

Name
TSepiAsmCallParams

Parent
SepiAsmInstructions

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Paramètres d'une instruction CALL

Members
Fields
Field | Description
FMethodCompiler (-) | Compilateur de méthode
FParameters (-) | Paramètres
FResult (-) | Résultat
FSize (-) | Taille écrite dans le flux

Methods
Method | Description
AddParam (+) | Ajoute un paramètre
Create (+) | Crée une liste de paramètres d'intruction CALL
Destroy (+) | [@inheritDoc]
GetCount (-) | Nombre de paramètres
GetParamByName (-) | Tableau des références mémoires des paramètres préparés indexés par leurs noms
GetParameters (-) | Tableau zero-based des paramètres
Make (+) | Construit la liste des paramètres
Prepare (+) | Prépare les paramètres en fonction d'une signature
SortParameters (-) | Trie les paramètres selon l'ordre de leurs propriétés SepiStackOffset
WriteToStream (+) | Ecrit les paramètres dans un flux

Properties
Property | Description
Count (+) | Nombre de paramètres
MethodCompiler (+) | Compilateur de méthode
ParamByName (+) | Tableau des références mémoires des paramètres préparés indexés par leurs noms
Parameters (+) | Tableau zero-based des paramètres
Result (+) | Résultat
Size (+) | Taille écrite dans le flux

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmCallParam)
Next (TSepiAsmCompare)


Sepi

Sepi
Previous
Next (FParameters)

Name
FMethodCompiler

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Compilateur de méthode

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous
Next (FParameters)


Sepi

Sepi
Previous (FMethodCompiler)
Next (FResult)

Name
FParameters

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Paramètres

Source code
FParameters : array of TSepiAsmCallParam

Sepi
Class Tree
Index
Previous (FMethodCompiler)
Next (FResult)


Sepi

Sepi
Previous (FParameters)
Next (FSize)

Name
FResult

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Résultat

Source code
FResult : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FParameters)
Next (FSize)


Sepi

Sepi
Previous (FResult)
Next

Name
FSize

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Taille écrite dans le flux

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FResult)
Next


Sepi

Sepi
Previous
Next (MethodCompiler)

Name
Count

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Nombre de paramètres

Source code
property Count : Integer read GetCount

Read Access
GetCount

Sepi
Class Tree
Index
Previous
Next (MethodCompiler)


Sepi

Sepi
Previous (Count)
Next (ParamByName)

Name
MethodCompiler

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Compilateur de méthode

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (Count)
Next (ParamByName)


Sepi

Sepi
Previous (MethodCompiler)
Next (Parameters)

Name
ParamByName

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Tableau des références mémoires des paramètres préparés indexés par leurs noms

Source code
property ParamByName [ const Name : string ] : TSepiMemoryReference read GetParamByName ; default

Read Access
GetParamByName

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next (Parameters)


Sepi

Sepi
Previous (ParamByName)
Next (Result)

Name
Parameters

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Tableau zero-based des paramètres

Source code
property Parameters [ Index : Integer ] : TSepiAsmCallParam read GetParameters

Read Access
GetParameters

Sepi
Class Tree
Index
Previous (ParamByName)
Next (Result)


Sepi

Sepi
Previous (Parameters)
Next (Size)

Name
Result

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Résultat

Source code
property Result : TSepiMemoryReference read FResult

Read Access
FResult

Sepi
Class Tree
Index
Previous (Parameters)
Next (Size)


Sepi

Sepi
Previous (Result)
Next

Name
Size

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Taille écrite dans le flux

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (Result)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AddParam

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Ajoute un paramètre

Source code
function AddParam ( SepiStackOffset : Integer ; ParamSize : TSepiParamSize ) : TSepiMemoryReference

Parameters
Parameter | Description
SepiStackOffset : INTEGER | Offset dans la pile Sepi
ParamSize : TSepiParamSize | Taille de paramètre

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AddParam)
Next (Destroy)

Name
Create

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Crée une liste de paramètres d'intruction CALL

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (AddParam)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetCount)

Name
Destroy

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetCount)


Sepi

Sepi
Previous (Destroy)
Next (GetParamByName)

Name
GetCount

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Nombre de paramètres

Source code
function GetCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de paramètres

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetParamByName)


Sepi

Sepi
Previous (GetCount)
Next (GetParameters)

Name
GetParamByName

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Tableau des références mémoires des paramètres préparés indexés par leurs noms

Exception
ESepiComponentNotFoundError Le paramètre n'a pas été trouvé

Source code
function GetParamByName ( const Name : string ) : TSepiMemoryReference

Parameters
Parameter | Description
NAME : STRING | Nom du paramètre

Return
Types | Description
TSepiMemoryReference | Référence mémoire du paramètre

Sepi
Class Tree
Index
Previous (GetCount)
Next (GetParameters)


Sepi

Sepi
Previous (GetParamByName)
Next (Make)

Name
GetParameters

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Tableau zero-based des paramètres

Source code
function GetParameters ( Index : Integer ) : TSepiAsmCallParam

Parameters
Parameter | Description
INDEX : INTEGER | Index d'un paramètre

Return
Types | Description
TSepiAsmCallParam | Paramètre à l'index spécifié

Sepi
Class Tree
Index
Previous (GetParamByName)
Next (Make)


Sepi

Sepi
Previous (GetParameters)
Next (Prepare)

Name
Make

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Construit la liste des paramètres

Source code
procedure Make

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetParameters)
Next (Prepare)


Sepi

Sepi
Previous (Make)
Next (SortParameters)

Name
Prepare

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Prépare les paramètres en fonction d'une signature
Préparer les paramètres a de multiples avantages. Il ne faut plus se
préoccuper des offsets et des tailles des paramètres, ni de leur éventuel
passage par adresse. De plus, pour les résultats qui sont passés comme
paramètres, le fait de préparer les paramètres assigne à la propriété Result
la référence mémoire à ce paramètre. Il n'y a donc plus de différences entre
un résultat passé par adresse ou pas.

Source code
procedure Prepare ( Signature : TSepiSignature )

Parameters
Parameter | Description
Signature : TSepiSignature | Signature

Sepi
Class Tree
Index
Previous (Make)
Next (SortParameters)


Sepi

Sepi
Previous (Prepare)
Next (WriteToStream)

Name
SortParameters

Parent
TSepiAsmCallParams

Visibility
PRIVATE

Description
Trie les paramètres selon l'ordre de leurs propriétés SepiStackOffset

Source code
procedure SortParameters

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Prepare)
Next (WriteToStream)


Sepi

Sepi
Previous (SortParameters)
Next

Name
WriteToStream

Parent
TSepiAsmCallParams

Visibility
PUBLIC

Description
Ecrit les paramètres dans un flux

Source code
procedure WriteToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux de destination

Sepi
Class Tree
Index
Previous (SortParameters)
Next


Sepi

Sepi
Previous (TSepiAsmCallParams)
Next (TSepiAsmCondJump)

Name
TSepiAsmCompare

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction de comparaison

Members
Fields
Field | Description
FDestination (-) | Destination
FLeft (-) | Opérande gauche
FRight (-) | Opérande droit
FVarType (-) | Type des variables

Methods
Method | Description
Create (+) | Crée une instruction de comparaison
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Left (+) | Opérande gauche
Right (+) | Opérande droit
VarType (+) | Type des variables

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmCallParams)
Next (TSepiAsmCondJump)


Sepi

Sepi
Previous
Next (FLeft)

Name
FDestination

Parent
TSepiAsmCompare

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FLeft)


Sepi

Sepi
Previous (FDestination)
Next (FRight)

Name
FLeft

Parent
TSepiAsmCompare

Visibility
PRIVATE

Description
Opérande gauche

Source code
FLeft : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FRight)


Sepi

Sepi
Previous (FLeft)
Next (FVarType)

Name
FRight

Parent
TSepiAsmCompare

Visibility
PRIVATE

Description
Opérande droit

Source code
FRight : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FLeft)
Next (FVarType)


Sepi

Sepi
Previous (FRight)
Next

Name
FVarType

Parent
TSepiAsmCompare

Visibility
PRIVATE

Description
Type des variables

Source code
FVarType : TSepiBaseType

Sepi
Class Tree
Index
Previous (FRight)
Next


Sepi

Sepi
Previous
Next (Left)

Name
Destination

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Left)


Sepi

Sepi
Previous (Destination)
Next (Right)

Name
Left

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
Opérande gauche

Source code
property Left : TSepiMemoryReference read FLeft

Read Access
FLeft

Sepi
Class Tree
Index
Previous (Destination)
Next (Right)


Sepi

Sepi
Previous (Left)
Next (VarType)

Name
Right

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
Opérande droit

Source code
property Right : TSepiMemoryReference read FRight

Read Access
FRight

Sepi
Class Tree
Index
Previous (Left)
Next (VarType)


Sepi

Sepi
Previous (Right)
Next

Name
VarType

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
Type des variables

Source code
property VarType : TSepiBaseType read FVarType

Read Access
FVarType

Sepi
Class Tree
Index
Previous (Right)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
Crée une instruction de comparaison

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode ; AVarType : TSepiBaseType )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode | OpCode de l'instruction (de type comparaison)
AVarType : TSepiBaseType | Type des variables

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmCompare

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmCompare)
Next (TSepiAsmConvert)

Name
TSepiAsmCondJump

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction JIT ou JIF (JUMP conditionnel)

Members
Fields
Field | Description
FDestination (-) | Destination du JUMP
FIfTrue (-) | True donne un JIT, False donne un JIF
FTest (-) | Condition du saut

Methods
Method | Description
Create (+) | Crée une instruction JIT ou JIF
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination du JUMP
IfTrue (+) | True donne un JIT, False donne un JIF
Test (+) | Condition du saut

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmCompare)
Next (TSepiAsmConvert)


Sepi

Sepi
Previous
Next (FIfTrue)

Name
FDestination

Parent
TSepiAsmCondJump

Visibility
PRIVATE

Description
Destination du JUMP

Source code
FDestination : TSepiJumpDest

Sepi
Class Tree
Index
Previous
Next (FIfTrue)


Sepi

Sepi
Previous (FDestination)
Next (FTest)

Name
FIfTrue

Parent
TSepiAsmCondJump

Visibility
PRIVATE

Description
True donne un JIT, False donne un JIF

Source code
FIfTrue : Boolean

Sepi
Class Tree
Index
Previous (FDestination)
Next (FTest)


Sepi

Sepi
Previous (FIfTrue)
Next

Name
FTest

Parent
TSepiAsmCondJump

Visibility
PRIVATE

Description
Condition du saut

Source code
FTest : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FIfTrue)
Next


Sepi

Sepi
Previous
Next (IfTrue)

Name
Destination

Parent
TSepiAsmCondJump

Visibility
PUBLIC

Description
Destination du JUMP

Source code
property Destination : TSepiJumpDest read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (IfTrue)


Sepi

Sepi
Previous (Destination)
Next (Test)

Name
IfTrue

Parent
TSepiAsmCondJump

Visibility
PUBLIC

Description
True donne un JIT, False donne un JIF

Source code
property IfTrue : Boolean read FIfTrue write FIfTrue

Read Access
FIfTrue

Write Access
FIfTrue

Sepi
Class Tree
Index
Previous (Destination)
Next (Test)


Sepi

Sepi
Previous (IfTrue)
Next

Name
Test

Parent
TSepiAsmCondJump

Visibility
PUBLIC

Description
Condition du saut

Source code
property Test : TSepiMemoryReference read FTest

Read Access
FTest

Sepi
Class Tree
Index
Previous (IfTrue)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmCondJump

Visibility
PUBLIC

Description
Crée une instruction JIT ou JIF

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AIfTrue : Boolean = True )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AIfTrue : BOOLEAN | True donne un JIT plutôt qu'un JIF

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmCondJump

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmCondJump

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmCondJump

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmCondJump)
Next (TSepiAsmDynamicCall)

Name
TSepiAsmConvert

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction CVRT

Members
Fields
Field | Description
FDestination (-) | Destination
FFromType (-) | Type de la source
FSource (-) | Source
FToType (-) | Type de la destination

Methods
Method | Description
Create (+) | Crée une instruction CVRT
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
FromType (+) | Type de la source
Source (+) | Source
ToType (+) | Type de la destination

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmCondJump)
Next (TSepiAsmDynamicCall)


Sepi

Sepi
Previous
Next (FFromType)

Name
FDestination

Parent
TSepiAsmConvert

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FFromType)


Sepi

Sepi
Previous (FDestination)
Next (FSource)

Name
FFromType

Parent
TSepiAsmConvert

Visibility
PRIVATE

Description
Type de la source

Source code
FFromType : TSepiBaseType

Sepi
Class Tree
Index
Previous (FDestination)
Next (FSource)


Sepi

Sepi
Previous (FFromType)
Next (FToType)

Name
FSource

Parent
TSepiAsmConvert

Visibility
PRIVATE

Description
Source

Source code
FSource : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FFromType)
Next (FToType)


Sepi

Sepi
Previous (FSource)
Next

Name
FToType

Parent
TSepiAsmConvert

Visibility
PRIVATE

Description
Type de la destination

Source code
FToType : TSepiBaseType

Sepi
Class Tree
Index
Previous (FSource)
Next


Sepi

Sepi
Previous
Next (FromType)

Name
Destination

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (FromType)


Sepi

Sepi
Previous (Destination)
Next (Source)

Name
FromType

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
Type de la source

Source code
property FromType : TSepiBaseType read FFromType

Read Access
FFromType

Sepi
Class Tree
Index
Previous (Destination)
Next (Source)


Sepi

Sepi
Previous (FromType)
Next (ToType)

Name
Source

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
Source

Source code
property Source : TSepiMemoryReference read FSource

Read Access
FSource

Sepi
Class Tree
Index
Previous (FromType)
Next (ToType)


Sepi

Sepi
Previous (Source)
Next

Name
ToType

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
Type de la destination

Source code
property ToType : TSepiBaseType read FToType

Read Access
FToType

Sepi
Class Tree
Index
Previous (Source)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
Crée une instruction CVRT

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AToType , AFromType : TSepiBaseType )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AToType : TSepiBaseType | Type de destination
AFromType : TSepiBaseType | Type de la source

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmConvert

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmConvert)
Next (TSepiAsmDynArrayCopy)

Name
TSepiAsmDynamicCall

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmRefCall

Visibility
PUBLIC

Description
Instruction Dynamic CALL

Members
Fields
Field | Description
FSelfMem (-) | Référence mémoire au Self

Methods
Method | Description
Create (+) | Crée une instruction Dynamic CALL
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
SelfMem (+) | Référence mémoire au Self

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmConvert)
Next (TSepiAsmDynArrayCopy)


Sepi

Sepi
Previous
Next

Name
FSelfMem

Parent
TSepiAsmDynamicCall

Visibility
PRIVATE

Description
Référence mémoire au Self

Source code
FSelfMem : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SelfMem

Parent
TSepiAsmDynamicCall

Visibility
PUBLIC

Description
Référence mémoire au Self

Source code
property SelfMem : TSepiMemoryReference read FSelfMem

Read Access
FSelfMem

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmDynamicCall

Visibility
PUBLIC

Description
Crée une instruction Dynamic CALL

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmDynamicCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmDynamicCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmDynamicCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmDynamicCall)
Next (TSepiAsmDynArraySetLength)

Name
TSepiAsmDynArrayCopy

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction DACP

Members
Fields
Field | Description
FCountValue (-) | Nombre de caractères à copier
FDestination (-) | Destination
FDynArrayType (-) | Type du tableau
FIndexValue (-) | Index de base de la copie
FIsRange (-) | Indique si c'est la version range
FSource (-) | Source

Methods
Method | Description
Create (+) | Crée une instruction DACP
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
CountValue (+) | Nombre de caractères à copier
Destination (+) | Destination
DynArrayType (+) | Type du tableau
IndexValue (+) | Index de base de la copie
IsRange (+) | Indique si c'est la version range
Source (+) | Source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmDynamicCall)
Next (TSepiAsmDynArraySetLength)


Sepi

Sepi
Previous
Next (FDestination)

Name
FCountValue

Parent
TSepiAsmDynArrayCopy

Visibility
PRIVATE

Description
Nombre de caractères à copier

Source code
FCountValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FDestination)


Sepi

Sepi
Previous (FCountValue)
Next (FDynArrayType)

Name
FDestination

Parent
TSepiAsmDynArrayCopy

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FCountValue)
Next (FDynArrayType)


Sepi

Sepi
Previous (FDestination)
Next (FIndexValue)

Name
FDynArrayType

Parent
TSepiAsmDynArrayCopy

Visibility
PRIVATE

Description
Type du tableau

Source code
FDynArrayType : TSepiDynArrayType

Sepi
Class Tree
Index
Previous (FDestination)
Next (FIndexValue)


Sepi

Sepi
Previous (FDynArrayType)
Next (FIsRange)

Name
FIndexValue

Parent
TSepiAsmDynArrayCopy

Visibility
PRIVATE

Description
Index de base de la copie

Source code
FIndexValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDynArrayType)
Next (FIsRange)


Sepi

Sepi
Previous (FIndexValue)
Next (FSource)

Name
FIsRange

Parent
TSepiAsmDynArrayCopy

Visibility
PRIVATE

Description
Indique si c'est la version range

Source code
FIsRange : Boolean

Sepi
Class Tree
Index
Previous (FIndexValue)
Next (FSource)


Sepi

Sepi
Previous (FIsRange)
Next

Name
FSource

Parent
TSepiAsmDynArrayCopy

Visibility
PRIVATE

Description
Source

Source code
FSource : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FIsRange)
Next


Sepi

Sepi
Previous
Next (Destination)

Name
CountValue

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
Nombre de caractères à copier

Source code
property CountValue : TSepiMemoryReference read FCountValue

Read Access
FCountValue

Sepi
Class Tree
Index
Previous
Next (Destination)


Sepi

Sepi
Previous (CountValue)
Next (DynArrayType)

Name
Destination

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous (CountValue)
Next (DynArrayType)


Sepi

Sepi
Previous (Destination)
Next (IndexValue)

Name
DynArrayType

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
Type du tableau

Source code
property DynArrayType : TSepiDynArrayType read FDynArrayType

Read Access
FDynArrayType

Sepi
Class Tree
Index
Previous (Destination)
Next (IndexValue)


Sepi

Sepi
Previous (DynArrayType)
Next (IsRange)

Name
IndexValue

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
Index de base de la copie

Source code
property IndexValue : TSepiMemoryReference read FIndexValue

Read Access
FIndexValue

Sepi
Class Tree
Index
Previous (DynArrayType)
Next (IsRange)


Sepi

Sepi
Previous (IndexValue)
Next (Source)

Name
IsRange

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
Indique si c'est la version range

Source code
property IsRange : Boolean read FIsRange

Read Access
FIsRange

Sepi
Class Tree
Index
Previous (IndexValue)
Next (Source)


Sepi

Sepi
Previous (IsRange)
Next

Name
Source

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
Source

Source code
property Source : TSepiMemoryReference read FSource

Read Access
FSource

Sepi
Class Tree
Index
Previous (IsRange)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
Crée une instruction DACP

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ADynArrayType : TSepiDynArrayType ; AIsRange : Boolean )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
ADynArrayType : TSepiDynArrayType | Type de tableau dynamique
AIsRange : BOOLEAN | Indique si c'est la version range

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmDynArrayCopy

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmDynArrayCopy)
Next (TSepiAsmGetRunInfo)

Name
TSepiAsmDynArraySetLength

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction DASL

Members
Fields
Field | Description
FDimCount (-) | Nombre de dimensions
FDimensions (-) | Dimensions
FDynArrayType (-) | Type du tableau
FDynArrayValue (-) | Tableau

Methods
Method | Description
Create (+) | Crée une instruction DASL
Destroy (+) | [@inheritDoc]
GetDimensions (-) | Tableau zero-based des dimensions
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
DimCount (+) | Nombre de dimensions
Dimensions (+) | Tableau zero-based des dimensions
DynArrayType (+) | Type du tableau
DynArrayValue (+) | Tableau
FirstDimension (+) | Tableau zero-based des dimensions

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmDynArrayCopy)
Next (TSepiAsmGetRunInfo)


Sepi

Sepi
Previous
Next (FDimensions)

Name
FDimCount

Parent
TSepiAsmDynArraySetLength

Visibility
PRIVATE

Description
Nombre de dimensions

Source code
FDimCount : Integer

Sepi
Class Tree
Index
Previous
Next (FDimensions)


Sepi

Sepi
Previous (FDimCount)
Next (FDynArrayType)

Name
FDimensions

Parent
TSepiAsmDynArraySetLength

Visibility
PRIVATE

Description
Dimensions

Source code
FDimensions : array of TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDimCount)
Next (FDynArrayType)


Sepi

Sepi
Previous (FDimensions)
Next (FDynArrayValue)

Name
FDynArrayType

Parent
TSepiAsmDynArraySetLength

Visibility
PRIVATE

Description
Type du tableau

Source code
FDynArrayType : TSepiDynArrayType

Sepi
Class Tree
Index
Previous (FDimensions)
Next (FDynArrayValue)


Sepi

Sepi
Previous (FDynArrayType)
Next

Name
FDynArrayValue

Parent
TSepiAsmDynArraySetLength

Visibility
PRIVATE

Description
Tableau

Source code
FDynArrayValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDynArrayType)
Next


Sepi

Sepi
Previous
Next (Dimensions)

Name
DimCount

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
Nombre de dimensions

Source code
property DimCount : Integer read FDimCount

Read Access
FDimCount

Sepi
Class Tree
Index
Previous
Next (Dimensions)


Sepi

Sepi
Previous (DimCount)
Next (DynArrayType)

Name
Dimensions

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
Tableau zero-based des dimensions

Source code
property Dimensions [ Index : Integer ] : TSepiMemoryReference read GetDimensions

Read Access
GetDimensions

Sepi
Class Tree
Index
Previous (DimCount)
Next (DynArrayType)


Sepi

Sepi
Previous (Dimensions)
Next (DynArrayValue)

Name
DynArrayType

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
Type du tableau

Source code
property DynArrayType : TSepiDynArrayType read FDynArrayType

Read Access
FDynArrayType

Sepi
Class Tree
Index
Previous (Dimensions)
Next (DynArrayValue)


Sepi

Sepi
Previous (DynArrayType)
Next (FirstDimension)

Name
DynArrayValue

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
Tableau

Source code
property DynArrayValue : TSepiMemoryReference read FDynArrayValue

Read Access
FDynArrayValue

Sepi
Class Tree
Index
Previous (DynArrayType)
Next (FirstDimension)


Sepi

Sepi
Previous (DynArrayValue)
Next

Name
FirstDimension

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
Tableau zero-based des dimensions

Source code
property FirstDimension : TSepiMemoryReference index 0 read GetDimensions

Read Access
GetDimensions

Sepi
Class Tree
Index
Previous (DynArrayValue)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
Crée une instruction DASL

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ADynArrayType : TSepiDynArrayType ; ADimCount : Integer = 1 )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
ADynArrayType : TSepiDynArrayType | Type de tableau dynamique
ADimCount : INTEGER | Nombre de dimensions (> 0)

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetDimensions)

Name
Destroy

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetDimensions)


Sepi

Sepi
Previous (Destroy)
Next (Make)

Name
GetDimensions

Parent
TSepiAsmDynArraySetLength

Visibility
PRIVATE

Description
Tableau zero-based des dimensions

Source code
function GetDimensions ( Index : Integer ) : TSepiMemoryReference

Parameters
Parameter | Description
INDEX : INTEGER | Index compris entre 0 inclus et DimCount exclu

Return
Types | Description
TSepiMemoryReference | Référence mémoire sur la valeur de la dimension d'index spécifié

Sepi
Class Tree
Index
Previous (Destroy)
Next (Make)


Sepi

Sepi
Previous (GetDimensions)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetDimensions)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmDynArraySetLength

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmDynArraySetLength)
Next (TSepiAsmIsClass)

Name
TSepiAsmGetRunInfo

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction GTI, GDC ou GMC

Members
Fields
Field | Description
FDestination (-) | Destination
FReference (-) | Référence

Methods
Method | Description
Create (+) | Crée une instruction GTI, GDC ou GMC
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
SetReference (+) | Assigne la référence
SetReference (+) | Assigne la référence
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
REFERENCE (+) | Référence

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmDynArraySetLength)
Next (TSepiAsmIsClass)


Sepi

Sepi
Previous
Next (FReference)

Name
FDestination

Parent
TSepiAsmGetRunInfo

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FReference)


Sepi

Sepi
Previous (FDestination)
Next

Name
FReference

Parent
TSepiAsmGetRunInfo

Visibility
PRIVATE

Description
Référence

Source code
FReference : Integer

Sepi
Class Tree
Index
Previous (FDestination)
Next


Sepi

Sepi
Previous
Next (REFERENCE)

Name
Destination

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (REFERENCE)


Sepi

Sepi
Previous (Destination)
Next

Name
REFERENCE

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
Référence

Source code
property Reference : Integer read FReference write FReference

Read Access
FReference

Write Access
FReference

Sepi
Class Tree
Index
Previous (Destination)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
Crée une instruction GTI, GDC ou GMC

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode | OpCode de l'instruction (GTI, GDC ou GMC)

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (SetReference)

Name
Make

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (SetReference)


Sepi

Sepi
Previous (Make)
Next (SetReference)

Name
SetReference

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
Assigne la référence

Source code
procedure SetReference ( const RefName : string ) ; overload

Parameters
Parameter | Description
RefName : STRING | Nom de la référence

Sepi
Class Tree
Index
Previous (Make)
Next (SetReference)


Sepi

Sepi
Previous (SetReference)
Next (WriteToStream)

Name
SetReference

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
Assigne la référence

Source code
procedure SetReference ( Reference : TSepiComponent ) ; overload

Parameters
Parameter | Description
REFERENCE : TSepiComponent | Référence

Sepi
Class Tree
Index
Previous (SetReference)
Next (WriteToStream)


Sepi

Sepi
Previous (SetReference)
Next

Name
WriteToStream

Parent
TSepiAsmGetRunInfo

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetReference)
Next


Sepi

Sepi
Previous (TSepiAsmGetRunInfo)
Next (TSepiAsmJump)

Name
TSepiAsmIsClass

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction IS

Members
Fields
Field | Description
FClassRef (-) | Référence à une classe (si msZero)
FDestination (-) | Destination
FMemClass (-) | Classe mémoire
FMemObject (-) | Objet mémoire

Methods
Method | Description
Create (+) | Crée une instruction IS
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
ClassRef (+) | Référence à une classe (si msZero)
Destination (+) | Destination
MemClass (+) | Classe mémoire
MemObject (+) | Objet mémoire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmGetRunInfo)
Next (TSepiAsmJump)


Sepi

Sepi
Previous
Next (FDestination)

Name
FClassRef

Parent
TSepiAsmIsClass

Visibility
PRIVATE

Description
Référence à une classe (si msZero)

Source code
FClassRef : Integer

Sepi
Class Tree
Index
Previous
Next (FDestination)


Sepi

Sepi
Previous (FClassRef)
Next (FMemClass)

Name
FDestination

Parent
TSepiAsmIsClass

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FClassRef)
Next (FMemClass)


Sepi

Sepi
Previous (FDestination)
Next (FMemObject)

Name
FMemClass

Parent
TSepiAsmIsClass

Visibility
PRIVATE

Description
Classe mémoire

Source code
FMemClass : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FMemObject)


Sepi

Sepi
Previous (FMemClass)
Next

Name
FMemObject

Parent
TSepiAsmIsClass

Visibility
PRIVATE

Description
Objet mémoire

Source code
FMemObject : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FMemClass)
Next


Sepi

Sepi
Previous
Next (Destination)

Name
ClassRef

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
Référence à une classe (si msZero)

Source code
property ClassRef : Integer read FClassRef write FClassRef

Read Access
FClassRef

Write Access
FClassRef

Sepi
Class Tree
Index
Previous
Next (Destination)


Sepi

Sepi
Previous (ClassRef)
Next (MemClass)

Name
Destination

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous (ClassRef)
Next (MemClass)


Sepi

Sepi
Previous (Destination)
Next (MemObject)

Name
MemClass

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
Classe mémoire

Source code
property MemClass : TSepiMemoryReference read FMemClass

Read Access
FMemClass

Sepi
Class Tree
Index
Previous (Destination)
Next (MemObject)


Sepi

Sepi
Previous (MemClass)
Next

Name
MemObject

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
Objet mémoire

Source code
property MemObject : TSepiMemoryReference read FMemObject

Read Access
FMemObject

Sepi
Class Tree
Index
Previous (MemClass)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
Crée une instruction IS

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmIsClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmIsClass)
Next (TSepiAsmLoadAddress)

Name
TSepiAsmJump

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction JUMP

Members
Fields
Field | Description
FDestination (-) | Destination du JUMP

Methods
Method | Description
Create (+) | Crée une instruction JUMP
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination du JUMP

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmIsClass)
Next (TSepiAsmLoadAddress)


Sepi

Sepi
Previous
Next

Name
FDestination

Parent
TSepiAsmJump

Visibility
PRIVATE

Description
Destination du JUMP

Source code
FDestination : TSepiJumpDest

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Destination

Parent
TSepiAsmJump

Visibility
PUBLIC

Description
Destination du JUMP

Source code
property Destination : TSepiJumpDest read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmJump

Visibility
PUBLIC

Description
Crée une instruction JUMP

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmJump

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmJump

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmJump

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmJump)
Next (TSepiAsmMove)

Name
TSepiAsmLoadAddress

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction LEA

Members
Fields
Field | Description
FDestination (-) | Destination
FSource (-) | Source

Methods
Method | Description
Create (+) | Crée une instruction LEA
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Source (+) | Source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmJump)
Next (TSepiAsmMove)


Sepi

Sepi
Previous
Next (FSource)

Name
FDestination

Parent
TSepiAsmLoadAddress

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FSource)


Sepi

Sepi
Previous (FDestination)
Next

Name
FSource

Parent
TSepiAsmLoadAddress

Visibility
PRIVATE

Description
Source

Source code
FSource : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next


Sepi

Sepi
Previous
Next (Source)

Name
Destination

Parent
TSepiAsmLoadAddress

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Source)


Sepi

Sepi
Previous (Destination)
Next

Name
Source

Parent
TSepiAsmLoadAddress

Visibility
PUBLIC

Description
Source

Source code
property Source : TSepiMemoryReference read FSource

Read Access
FSource

Sepi
Class Tree
Index
Previous (Destination)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmLoadAddress

Visibility
PUBLIC

Description
Crée une instruction LEA

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmLoadAddress

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmLoadAddress

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmLoadAddress

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmLoadAddress)
Next (TSepiAsmMultiOn)

Name
TSepiAsmMove

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction MOVE

Members
Fields
Field | Description
FDataSize (-) | Taille des données à copier
FDataType (-) | Type des données à copier (si requis)
FDestination (-) | Destination
FSource (-) | Source

Methods
Method | Description
Create (+) | Crée une instruction MOVE typée
Create (+) | Crée une instruction MOVE non typée
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
DataSize (+) | Taille des données à copier
DataType (+) | Type des données à copier (si requis)
Destination (+) | Destination
Source (+) | Source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmLoadAddress)
Next (TSepiAsmMultiOn)


Sepi

Sepi
Previous
Next (FDataType)

Name
FDataSize

Parent
TSepiAsmMove

Visibility
PRIVATE

Description
Taille des données à copier

Source code
FDataSize : Word

Sepi
Class Tree
Index
Previous
Next (FDataType)


Sepi

Sepi
Previous (FDataSize)
Next (FDestination)

Name
FDataType

Parent
TSepiAsmMove

Visibility
PRIVATE

Description
Type des données à copier (si requis)

Source code
FDataType : TSepiType

Sepi
Class Tree
Index
Previous (FDataSize)
Next (FDestination)


Sepi

Sepi
Previous (FDataType)
Next (FSource)

Name
FDestination

Parent
TSepiAsmMove

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDataType)
Next (FSource)


Sepi

Sepi
Previous (FDestination)
Next

Name
FSource

Parent
TSepiAsmMove

Visibility
PRIVATE

Description
Source

Source code
FSource : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next


Sepi

Sepi
Previous
Next (DataType)

Name
DataSize

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
Taille des données à copier

Source code
property DataSize : Word read FDataSize

Read Access
FDataSize

Sepi
Class Tree
Index
Previous
Next (DataType)


Sepi

Sepi
Previous (DataSize)
Next (Destination)

Name
DataType

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
Type des données à copier (si requis)

Source code
property DataType : TSepiType read FDataType

Read Access
FDataType

Sepi
Class Tree
Index
Previous (DataSize)
Next (Destination)


Sepi

Sepi
Previous (DataType)
Next (Source)

Name
Destination

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous (DataType)
Next (Source)


Sepi

Sepi
Previous (Destination)
Next

Name
Source

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
Source

Source code
property Source : TSepiMemoryReference read FSource

Read Access
FSource

Sepi
Class Tree
Index
Previous (Destination)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
Crée une instruction MOVE typée

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ADataType : TSepiType ) ; overload

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
ADataType : TSepiType | Type des données à copier

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
Crée une instruction MOVE non typée

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ADataSize : Word ) ; overload

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
ADataSize : WORD | Taille des données à copier

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmMove

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmMove)
Next (TSepiAsmNope)

Name
TSepiAsmMultiOn

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction ON

Members
Fields
Field | Description
FExceptObject (-) | Objet exception
FOnClauses (-) | Clauses ON

Methods
Method | Description
AddOnClause (+) | Ajoute une clause ON
AddOnClause (+) | Ajoute une clause ON
AddOnClause (+) | Ajoute une clause ON
Create (+) | Crée une instruction ON
Destroy (+) | [@inheritDoc]
GetOnClauseCount (-) | Nombre de clauses ON
GetOnClauses (-) | Tableau zero-based des clauses ON
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
ExceptObject (+) | Objet exception
OnClauseCount (+) | Nombre de clauses ON
OnClauses (+) | Tableau zero-based des clauses ON

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmMove)
Next (TSepiAsmNope)


Sepi

Sepi
Previous
Next (FOnClauses)

Name
FExceptObject

Parent
TSepiAsmMultiOn

Visibility
PRIVATE

Description
Objet exception

Source code
FExceptObject : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FOnClauses)


Sepi

Sepi
Previous (FExceptObject)
Next

Name
FOnClauses

Parent
TSepiAsmMultiOn

Visibility
PRIVATE

Description
Clauses ON

Source code
FOnClauses : array of TSepiAsmOnClause

Sepi
Class Tree
Index
Previous (FExceptObject)
Next


Sepi

Sepi
Previous
Next (OnClauseCount)

Name
ExceptObject

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
Objet exception

Source code
property ExceptObject : TSepiMemoryReference read FExceptObject

Read Access
FExceptObject

Sepi
Class Tree
Index
Previous
Next (OnClauseCount)


Sepi

Sepi
Previous (ExceptObject)
Next (OnClauses)

Name
OnClauseCount

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
Nombre de clauses ON

Source code
property OnClauseCount : Integer read GetOnClauseCount

Read Access
GetOnClauseCount

Sepi
Class Tree
Index
Previous (ExceptObject)
Next (OnClauses)


Sepi

Sepi
Previous (OnClauseCount)
Next

Name
OnClauses

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
Tableau zero-based des clauses ON

Source code
property OnClauses [ Index : Integer ] : TSepiAsmOnClause read GetOnClauses

Read Access
GetOnClauses

Sepi
Class Tree
Index
Previous (OnClauseCount)
Next


Sepi

Sepi
Previous
Next (AddOnClause)

Name
AddOnClause

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
Ajoute une clause ON

Source code
function AddOnClause ( AClassRef : Integer ) : TSepiJumpDest ; overload

Parameters
Parameter | Description
AClassRef : INTEGER | Référence à la classe d'exception

Return
Types | Description
TSepiJumpDest | Destination du ON

Sepi
Class Tree
Index
Previous
Next (AddOnClause)


Sepi

Sepi
Previous (AddOnClause)
Next (AddOnClause)

Name
AddOnClause

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
Ajoute une clause ON

Source code
function AddOnClause ( SepiClass : TSepiClass ) : TSepiJumpDest ; overload

Parameters
Parameter | Description
SepiClass : TSepiClass | Classe d'exception

Return
Types | Description
TSepiJumpDest | Destination du ON

Sepi
Class Tree
Index
Previous (AddOnClause)
Next (AddOnClause)


Sepi

Sepi
Previous (AddOnClause)
Next (Create)

Name
AddOnClause

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
Ajoute une clause ON

Source code
function AddOnClause ( const ClassName : string ) : TSepiJumpDest ; overload

Parameters
Parameter | Description
ClassName : STRING | Nom de la classe d'exception

Return
Types | Description
TSepiJumpDest | Destination du ON

Sepi
Class Tree
Index
Previous (AddOnClause)
Next (Create)


Sepi

Sepi
Previous (AddOnClause)
Next (Destroy)

Name
Create

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
Crée une instruction ON

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (AddOnClause)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetOnClauseCount)

Name
Destroy

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetOnClauseCount)


Sepi

Sepi
Previous (Destroy)
Next (GetOnClauses)

Name
GetOnClauseCount

Parent
TSepiAsmMultiOn

Visibility
PRIVATE

Description
Nombre de clauses ON

Source code
function GetOnClauseCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de clauses ON

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetOnClauses)


Sepi

Sepi
Previous (GetOnClauseCount)
Next (Make)

Name
GetOnClauses

Parent
TSepiAsmMultiOn

Visibility
PRIVATE

Description
Tableau zero-based des clauses ON

Source code
function GetOnClauses ( Index : Integer ) : TSepiAsmOnClause

Parameters
Parameter | Description
INDEX : INTEGER | Index d'une clause

Return
Types | Description
TSepiAsmOnClause | Clause à l'index spécifié

Sepi
Class Tree
Index
Previous (GetOnClauseCount)
Next (Make)


Sepi

Sepi
Previous (GetOnClauses)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetOnClauses)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmMultiOn

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmMultiOn)
Next (TSepiAsmOnClause)

Name
TSepiAsmNope

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction NOP

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmMultiOn)
Next (TSepiAsmOnClause)


Sepi

Sepi
Previous (TSepiAsmNope)
Next (TSepiAsmOperation)

Name
TSepiAsmOnClause

Parent
SepiAsmInstructions

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Clause ON d'un MultiOn

Members
Fields
Field | Description
ClassRef (*) | Référence à une classe
Destination (*) | Destination du ON

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmNope)
Next (TSepiAsmOperation)


Sepi

Sepi
Previous
Next (Destination)

Name
ClassRef

Parent
TSepiAsmOnClause

Visibility
PUBLISHED

Description
Référence à une classe

Source code
ClassRef : Integer

Sepi
Class Tree
Index
Previous
Next (Destination)


Sepi

Sepi
Previous (ClassRef)
Next

Name
Destination

Parent
TSepiAsmOnClause

Visibility
PUBLISHED

Description
Destination du ON

Source code
Destination : TSepiJumpDest

Sepi
Class Tree
Index
Previous (ClassRef)
Next


Sepi

Sepi
Previous (TSepiAsmOnClause)
Next (TSepiAsmRaise)

Name
TSepiAsmOperation

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction opération

Members
Fields
Field | Description
FDestination (-) | Destination
FLeft (-) | Opérande gauche
FRight (-) | Opérande droit
FUseLeft (-) | Utilise un opérande gauche
FUseRight (-) | Utilise un opérande droit
FVarType (-) | Type des variables

Methods
Method | Description
Create (+) | Crée une instruction opération
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Left (+) | Opérande gauche
Right (+) | Opérande droit
Source (+) | Opérande unique
UseLeft (+) | Utilise un opérande gauche
UseRight (+) | Utilise un opérande droit
VarType (+) | Type des variables

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmOnClause)
Next (TSepiAsmRaise)


Sepi

Sepi
Previous
Next (FLeft)

Name
FDestination

Parent
TSepiAsmOperation

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FLeft)


Sepi

Sepi
Previous (FDestination)
Next (FRight)

Name
FLeft

Parent
TSepiAsmOperation

Visibility
PRIVATE

Description
Opérande gauche

Source code
FLeft : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FRight)


Sepi

Sepi
Previous (FLeft)
Next (FUseLeft)

Name
FRight

Parent
TSepiAsmOperation

Visibility
PRIVATE

Description
Opérande droit

Source code
FRight : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FLeft)
Next (FUseLeft)


Sepi

Sepi
Previous (FRight)
Next (FUseRight)

Name
FUseLeft

Parent
TSepiAsmOperation

Visibility
PRIVATE

Description
Utilise un opérande gauche

Source code
FUseLeft : Boolean

Sepi
Class Tree
Index
Previous (FRight)
Next (FUseRight)


Sepi

Sepi
Previous (FUseLeft)
Next (FVarType)

Name
FUseRight

Parent
TSepiAsmOperation

Visibility
PRIVATE

Description
Utilise un opérande droit

Source code
FUseRight : Boolean

Sepi
Class Tree
Index
Previous (FUseLeft)
Next (FVarType)


Sepi

Sepi
Previous (FUseRight)
Next

Name
FVarType

Parent
TSepiAsmOperation

Visibility
PRIVATE

Description
Type des variables

Source code
FVarType : TSepiBaseType

Sepi
Class Tree
Index
Previous (FUseRight)
Next


Sepi

Sepi
Previous
Next (Left)

Name
Destination

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Left)


Sepi

Sepi
Previous (Destination)
Next (Right)

Name
Left

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Opérande gauche

Source code
property Left : TSepiMemoryReference read FLeft

Read Access
FLeft

Sepi
Class Tree
Index
Previous (Destination)
Next (Right)


Sepi

Sepi
Previous (Left)
Next (Source)

Name
Right

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Opérande droit

Source code
property Right : TSepiMemoryReference read FRight

Read Access
FRight

Sepi
Class Tree
Index
Previous (Left)
Next (Source)


Sepi

Sepi
Previous (Right)
Next (UseLeft)

Name
Source

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Opérande unique

Source code
property Source : TSepiMemoryReference read FLeft

Read Access
FLeft

Sepi
Class Tree
Index
Previous (Right)
Next (UseLeft)


Sepi

Sepi
Previous (Source)
Next (UseRight)

Name
UseLeft

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Utilise un opérande gauche

Source code
property UseLeft : Boolean read FUseLeft

Read Access
FUseLeft

Sepi
Class Tree
Index
Previous (Source)
Next (UseRight)


Sepi

Sepi
Previous (UseLeft)
Next (VarType)

Name
UseRight

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Utilise un opérande droit

Source code
property UseRight : Boolean read FUseRight

Read Access
FUseRight

Sepi
Class Tree
Index
Previous (UseLeft)
Next (VarType)


Sepi

Sepi
Previous (UseRight)
Next

Name
VarType

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Type des variables

Source code
property VarType : TSepiBaseType read FVarType

Read Access
FVarType

Sepi
Class Tree
Index
Previous (UseRight)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
Crée une instruction opération

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode ; AVarType : TSepiBaseType )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode | OpCode de l'instruction (de type opération)
AVarType : TSepiBaseType | Type des variables

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmOperation)
Next (TSepiAsmRefCall)

Name
TSepiAsmRaise

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction RAISE

Members
Fields
Field | Description
FExceptObject (-) | Objet exception

Methods
Method | Description
Create (+) | Crée une instruction RAISE
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
ExceptObject (+) | Objet exception

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmOperation)
Next (TSepiAsmRefCall)


Sepi

Sepi
Previous
Next

Name
FExceptObject

Parent
TSepiAsmRaise

Visibility
PRIVATE

Description
Objet exception

Source code
FExceptObject : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
ExceptObject

Parent
TSepiAsmRaise

Visibility
PUBLIC

Description
Objet exception

Source code
property ExceptObject : TSepiMemoryReference read FExceptObject

Read Access
FExceptObject

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmRaise

Visibility
PUBLIC

Description
Crée une instruction RAISE

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmRaise

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmRaise

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmRaise

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmRaise)
Next (TSepiAsmReraise)

Name
TSepiAsmRefCall

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmCall

Visibility
PUBLIC

Description
Instruction CALL avec une référence à la méthode

Members
Fields
Field | Description
FMethodRef (-) | Référence à la méthode

Methods
Method | Description
Create (+) | Crée une instruction CALL avec une référence à la méthode
SetMethod (+) | Renseigne la méthode à appeler
SetMethod (+) | Renseigne la méthode à appeler

Properties
Property | Description
MethodRef (+) | Référence à la méthode

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmRaise)
Next (TSepiAsmReraise)


Sepi

Sepi
Previous
Next

Name
FMethodRef

Parent
TSepiAsmRefCall

Visibility
PRIVATE

Description
Référence à la méthode

Source code
FMethodRef : Integer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
MethodRef

Parent
TSepiAsmRefCall

Visibility
PUBLIC

Description
Référence à la méthode

Source code
property MethodRef : Integer read FMethodRef write FMethodRef

Read Access
FMethodRef

Write Access
FMethodRef

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (SetMethod)

Name
Create

Parent
TSepiAsmRefCall

Visibility
PUBLIC

Description
Crée une instruction CALL avec une référence à la méthode

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (SetMethod)


Sepi

Sepi
Previous (Create)
Next (SetMethod)

Name
SetMethod

Parent
TSepiAsmRefCall

Visibility
PUBLIC

Description
Renseigne la méthode à appeler

Source code
procedure SetMethod ( const MethodName : string ; PrepareParams : Boolean = True ) ; overload

Parameters
Parameter Description
MethodName : STRING
PrepareParams : BOOLEAN

Sepi
Class Tree
Index
Previous (Create)
Next (SetMethod)


Sepi

Sepi
Previous (SetMethod)
Next

Name
SetMethod

Parent
TSepiAsmRefCall

Visibility
PUBLIC

Description
Renseigne la méthode à appeler

Source code
procedure SetMethod ( Method : TSepiMethod ; PrepareParams : Boolean = True ) ; overload

Parameters
Parameter | Description
Method : TSepiMethod | Méthode à appeler
PrepareParams : BOOLEAN

Sepi
Class Tree
Index
Previous (SetMethod)
Next


Sepi

Sepi
Previous (TSepiAsmRefCall)
Next (TSepiAsmSetCompare)

Name
TSepiAsmReraise

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction RERS

Members
Methods
Method | Description
Create (+) | Crée une instruction RERS

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmRefCall)
Next (TSepiAsmSetCompare)


Sepi

Sepi
Previous
Next

Name
Create

Parent
TSepiAsmReraise

Visibility
PUBLIC

Description
Crée une instruction RERS

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiAsmReraise)
Next (TSepiAsmSetElem)

Name
TSepiAsmSetCompare

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction de comparaison de sets

Members
Fields
Field | Description
FDestination (-) | Destination
FLeft (-) | Opérande gauche
FRight (-) | Opérande droit
FSetSize (-) | Taille des sets

Methods
Method | Description
Create (+) | Crée une instruction de comparaison
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Left (+) | Opérande gauche
Right (+) | Opérande droit
SetSize (+) | Taille des sets

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmReraise)
Next (TSepiAsmSetElem)


Sepi

Sepi
Previous
Next (FLeft)

Name
FDestination

Parent
TSepiAsmSetCompare

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FLeft)


Sepi

Sepi
Previous (FDestination)
Next (FRight)

Name
FLeft

Parent
TSepiAsmSetCompare

Visibility
PRIVATE

Description
Opérande gauche

Source code
FLeft : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FRight)


Sepi

Sepi
Previous (FLeft)
Next (FSetSize)

Name
FRight

Parent
TSepiAsmSetCompare

Visibility
PRIVATE

Description
Opérande droit

Source code
FRight : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FLeft)
Next (FSetSize)


Sepi

Sepi
Previous (FRight)
Next

Name
FSetSize

Parent
TSepiAsmSetCompare

Visibility
PRIVATE

Description
Taille des sets

Source code
FSetSize : Byte

Sepi
Class Tree
Index
Previous (FRight)
Next


Sepi

Sepi
Previous
Next (Left)

Name
Destination

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Left)


Sepi

Sepi
Previous (Destination)
Next (Right)

Name
Left

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
Opérande gauche

Source code
property Left : TSepiMemoryReference read FLeft

Read Access
FLeft

Sepi
Class Tree
Index
Previous (Destination)
Next (Right)


Sepi

Sepi
Previous (Left)
Next (SetSize)

Name
Right

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
Opérande droit

Source code
property Right : TSepiMemoryReference read FRight

Read Access
FRight

Sepi
Class Tree
Index
Previous (Left)
Next (SetSize)


Sepi

Sepi
Previous (Right)
Next

Name
SetSize

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
Taille des sets

Source code
property SetSize : Byte read FSetSize

Read Access
FSetSize

Sepi
Class Tree
Index
Previous (Right)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
Crée une instruction de comparaison

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode ; ASetSize : Byte )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode | OpCode de l'instruction (de type comparaison de sets)
ASetSize : BYTE

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmSetCompare

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmSetCompare)
Next (TSepiAsmSetExpand)

Name
TSepiAsmSetElem

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction SELE

Members
Fields
Field | Description
FDestination (-) | Destination
FElement (-) | Élément
FSetSize (-) | Taille du set
FUnion (-) | Indique si c'est un Union-Elem (Inc)

Methods
Method | Description
Create (+) | Crée une instruction set-elem
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Element (+) | Élément
SetSize (+) | Taille du set
Union (+) | Indique si c'est un Union-Elem (Inc)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmSetCompare)
Next (TSepiAsmSetExpand)


Sepi

Sepi
Previous
Next (FElement)

Name
FDestination

Parent
TSepiAsmSetElem

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FElement)


Sepi

Sepi
Previous (FDestination)
Next (FSetSize)

Name
FElement

Parent
TSepiAsmSetElem

Visibility
PRIVATE

Description
Élément

Source code
FElement : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FSetSize)


Sepi

Sepi
Previous (FElement)
Next (FUnion)

Name
FSetSize

Parent
TSepiAsmSetElem

Visibility
PRIVATE

Description
Taille du set

Source code
FSetSize : Byte

Sepi
Class Tree
Index
Previous (FElement)
Next (FUnion)


Sepi

Sepi
Previous (FSetSize)
Next

Name
FUnion

Parent
TSepiAsmSetElem

Visibility
PRIVATE

Description
Indique si c'est un Union-Elem (Inc)

Source code
FUnion : Boolean

Sepi
Class Tree
Index
Previous (FSetSize)
Next


Sepi

Sepi
Previous
Next (Element)

Name
Destination

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Element)


Sepi

Sepi
Previous (Destination)
Next (SetSize)

Name
Element

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
Élément

Source code
property Element : TSepiMemoryReference read FElement

Read Access
FElement

Sepi
Class Tree
Index
Previous (Destination)
Next (SetSize)


Sepi

Sepi
Previous (Element)
Next (Union)

Name
SetSize

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
Taille du set

Source code
property SetSize : Byte read FSetSize

Read Access
FSetSize

Sepi
Class Tree
Index
Previous (Element)
Next (Union)


Sepi

Sepi
Previous (SetSize)
Next

Name
Union

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
Indique si c'est un Union-Elem (Inc)

Source code
property Union : Boolean read FUnion

Read Access
FUnion

Sepi
Class Tree
Index
Previous (SetSize)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
Crée une instruction set-elem

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ASetSize : Byte ; AUnion : Boolean = False )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
ASetSize : BYTE | Taille du set
AUnion : BOOLEAN | True pour faire un Union-Elem (équivalent à Inc)

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmSetElem

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmSetElem)
Next (TSepiAsmSetIn)

Name
TSepiAsmSetExpand

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction SEXP

Members
Fields
Field | Description
FDestination (-) | Destination
FHigherByte (-) | Octet supérieur dans le packed
FLowerByte (-) | Octet inférieur dans le packed
FSource (-) | Source

Methods
Method | Description
Create (+) | Crée une instruction set-expand
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
HigherBound (+) | Octet supérieur dans le packed
LowerBound (+) | Octet inférieur dans le packed
Source (+) | Source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmSetElem)
Next (TSepiAsmSetIn)


Sepi

Sepi
Previous
Next (FHigherByte)

Name
FDestination

Parent
TSepiAsmSetExpand

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FHigherByte)


Sepi

Sepi
Previous (FDestination)
Next (FLowerByte)

Name
FHigherByte

Parent
TSepiAsmSetExpand

Visibility
PRIVATE

Description
Octet supérieur dans le packed

Source code
FHigherByte : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FLowerByte)


Sepi

Sepi
Previous (FHigherByte)
Next (FSource)

Name
FLowerByte

Parent
TSepiAsmSetExpand

Visibility
PRIVATE

Description
Octet inférieur dans le packed

Source code
FLowerByte : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FHigherByte)
Next (FSource)


Sepi

Sepi
Previous (FLowerByte)
Next

Name
FSource

Parent
TSepiAsmSetExpand

Visibility
PRIVATE

Description
Source

Source code
FSource : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FLowerByte)
Next


Sepi

Sepi
Previous
Next (HigherBound)

Name
Destination

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (HigherBound)


Sepi

Sepi
Previous (Destination)
Next (LowerBound)

Name
HigherBound

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
Octet supérieur dans le packed

Source code
property HigherBound : TSepiMemoryReference read FHigherByte

Read Access
FHigherByte

Sepi
Class Tree
Index
Previous (Destination)
Next (LowerBound)


Sepi

Sepi
Previous (HigherBound)
Next (Source)

Name
LowerBound

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
Octet inférieur dans le packed

Source code
property LowerBound : TSepiMemoryReference read FLowerByte

Read Access
FLowerByte

Sepi
Class Tree
Index
Previous (HigherBound)
Next (Source)


Sepi

Sepi
Previous (LowerBound)
Next

Name
Source

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
Source

Source code
property Source : TSepiMemoryReference read FSource

Read Access
FSource

Sepi
Class Tree
Index
Previous (LowerBound)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
Crée une instruction set-expand

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmSetExpand

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmSetExpand)
Next (TSepiAsmSetIncludeExclude)

Name
TSepiAsmSetIn

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction SIN

Members
Fields
Field | Description
FDestination (-) | Destination
FElement (-) | Élément
FSetValue (-) | Ensemble

Methods
Method | Description
Create (+) | Crée une instruction set-in
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Element (+) | Élément
SetValue (+) | Ensemble

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmSetExpand)
Next (TSepiAsmSetIncludeExclude)


Sepi

Sepi
Previous
Next (FElement)

Name
FDestination

Parent
TSepiAsmSetIn

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FElement)


Sepi

Sepi
Previous (FDestination)
Next (FSetValue)

Name
FElement

Parent
TSepiAsmSetIn

Visibility
PRIVATE

Description
Élément

Source code
FElement : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FSetValue)


Sepi

Sepi
Previous (FElement)
Next

Name
FSetValue

Parent
TSepiAsmSetIn

Visibility
PRIVATE

Description
Ensemble

Source code
FSetValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FElement)
Next


Sepi

Sepi
Previous
Next (Element)

Name
Destination

Parent
TSepiAsmSetIn

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Element)


Sepi

Sepi
Previous (Destination)
Next (SetValue)

Name
Element

Parent
TSepiAsmSetIn

Visibility
PUBLIC

Description
Élément

Source code
property Element : TSepiMemoryReference read FElement

Read Access
FElement

Sepi
Class Tree
Index
Previous (Destination)
Next (SetValue)


Sepi

Sepi
Previous (Element)
Next

Name
SetValue

Parent
TSepiAsmSetIn

Visibility
PUBLIC

Description
Ensemble

Source code
property SetValue : TSepiMemoryReference read FSetValue

Read Access
FSetValue

Sepi
Class Tree
Index
Previous (Element)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmSetIn

Visibility
PUBLIC

Description
Crée une instruction set-in

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmSetIn

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmSetIn

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmSetIn

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmSetIn)
Next (TSepiAsmSetOperation)

Name
TSepiAsmSetIncludeExclude

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction SINC ou SEXC

Members
Fields
Field | Description
FDestination (-) | Destination
FElement (-) | Élément

Methods
Method | Description
Create (+) | Crée une instruction set-include ou set-exclude
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Element (+) | Élément

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmSetIn)
Next (TSepiAsmSetOperation)


Sepi

Sepi
Previous
Next (FElement)

Name
FDestination

Parent
TSepiAsmSetIncludeExclude

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FElement)


Sepi

Sepi
Previous (FDestination)
Next

Name
FElement

Parent
TSepiAsmSetIncludeExclude

Visibility
PRIVATE

Description
Élément

Source code
FElement : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next


Sepi

Sepi
Previous
Next (Element)

Name
Destination

Parent
TSepiAsmSetIncludeExclude

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Element)


Sepi

Sepi
Previous (Destination)
Next

Name
Element

Parent
TSepiAsmSetIncludeExclude

Visibility
PUBLIC

Description
Élément

Source code
property Element : TSepiMemoryReference read FElement

Read Access
FElement

Sepi
Class Tree
Index
Previous (Destination)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmSetIncludeExclude

Visibility
PUBLIC

Description
Crée une instruction set-include ou set-exclude

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AInclude : Boolean )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AInclude : BOOLEAN | True pour Include, False pour Exclude

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmSetIncludeExclude

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmSetIncludeExclude

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmSetIncludeExclude

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmSetIncludeExclude)
Next (TSepiAsmSetRange)

Name
TSepiAsmSetOperation

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction opération sur des sets

Members
Fields
Field | Description
FDestination (-) | Destination
FLeft (-) | Opérande gauche
FRight (-) | Opérande droit
FSetSize (-) | Taille des sets
FUseLeft (-) | Utilise un opérande gauche

Methods
Method | Description
Create (+) | Crée une instruction opération
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Left (+) | Opérande gauche
Right (+) | Opérande droit
SetSize (+) | Taille des sets
UseLeft (+) | Utilise un opérande gauche

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmSetIncludeExclude)
Next (TSepiAsmSetRange)


Sepi

Sepi
Previous
Next (FLeft)

Name
FDestination

Parent
TSepiAsmSetOperation

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FLeft)


Sepi

Sepi
Previous (FDestination)
Next (FRight)

Name
FLeft

Parent
TSepiAsmSetOperation

Visibility
PRIVATE

Description
Opérande gauche

Source code
FLeft : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FRight)


Sepi

Sepi
Previous (FLeft)
Next (FSetSize)

Name
FRight

Parent
TSepiAsmSetOperation

Visibility
PRIVATE

Description
Opérande droit

Source code
FRight : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FLeft)
Next (FSetSize)


Sepi

Sepi
Previous (FRight)
Next (FUseLeft)

Name
FSetSize

Parent
TSepiAsmSetOperation

Visibility
PRIVATE

Description
Taille des sets

Source code
FSetSize : Byte

Sepi
Class Tree
Index
Previous (FRight)
Next (FUseLeft)


Sepi

Sepi
Previous (FSetSize)
Next

Name
FUseLeft

Parent
TSepiAsmSetOperation

Visibility
PRIVATE

Description
Utilise un opérande gauche

Source code
FUseLeft : Boolean

Sepi
Class Tree
Index
Previous (FSetSize)
Next


Sepi

Sepi
Previous
Next (Left)

Name
Destination

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Left)


Sepi

Sepi
Previous (Destination)
Next (Right)

Name
Left

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
Opérande gauche

Source code
property Left : TSepiMemoryReference read FLeft

Read Access
FLeft

Sepi
Class Tree
Index
Previous (Destination)
Next (Right)


Sepi

Sepi
Previous (Left)
Next (SetSize)

Name
Right

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
Opérande droit

Source code
property Right : TSepiMemoryReference read FRight

Read Access
FRight

Sepi
Class Tree
Index
Previous (Left)
Next (SetSize)


Sepi

Sepi
Previous (Right)
Next (UseLeft)

Name
SetSize

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
Taille des sets

Source code
property SetSize : Byte read FSetSize

Read Access
FSetSize

Sepi
Class Tree
Index
Previous (Right)
Next (UseLeft)


Sepi

Sepi
Previous (SetSize)
Next

Name
UseLeft

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
Utilise un opérande gauche

Source code
property UseLeft : Boolean read FUseLeft

Read Access
FUseLeft

Sepi
Class Tree
Index
Previous (SetSize)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
Crée une instruction opération

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode ; ASetSize : Byte )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode | OpCode de l'instruction (de type opération)
ASetSize : BYTE | Taille des sets

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmSetOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmSetOperation)
Next (TSepiAsmStaticCall)

Name
TSepiAsmSetRange

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction SRNG ou SUR

Members
Fields
Field | Description
FDestination (-) | Destination
FHigherBound (-) | Borne supérieure
FLowerBound (-) | Borne inférieure
FSetSize (-) | Taille du set
FUnion (-) | Indique si c'est un Union-Range

Methods
Method | Description
Create (+) | Crée une instruction set-range
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
HigherBound (+) | Borne supérieure
LowerBound (+) | Borne inférieure
SetSize (+) | Taille du set
Union (+) | Indique si c'est un Union-Range

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmSetOperation)
Next (TSepiAsmStaticCall)


Sepi

Sepi
Previous
Next (FHigherBound)

Name
FDestination

Parent
TSepiAsmSetRange

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FHigherBound)


Sepi

Sepi
Previous (FDestination)
Next (FLowerBound)

Name
FHigherBound

Parent
TSepiAsmSetRange

Visibility
PRIVATE

Description
Borne supérieure

Source code
FHigherBound : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FLowerBound)


Sepi

Sepi
Previous (FHigherBound)
Next (FSetSize)

Name
FLowerBound

Parent
TSepiAsmSetRange

Visibility
PRIVATE

Description
Borne inférieure

Source code
FLowerBound : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FHigherBound)
Next (FSetSize)


Sepi

Sepi
Previous (FLowerBound)
Next (FUnion)

Name
FSetSize

Parent
TSepiAsmSetRange

Visibility
PRIVATE

Description
Taille du set

Source code
FSetSize : Byte

Sepi
Class Tree
Index
Previous (FLowerBound)
Next (FUnion)


Sepi

Sepi
Previous (FSetSize)
Next

Name
FUnion

Parent
TSepiAsmSetRange

Visibility
PRIVATE

Description
Indique si c'est un Union-Range

Source code
FUnion : Boolean

Sepi
Class Tree
Index
Previous (FSetSize)
Next


Sepi

Sepi
Previous
Next (HigherBound)

Name
Destination

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (HigherBound)


Sepi

Sepi
Previous (Destination)
Next (LowerBound)

Name
HigherBound

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
Borne supérieure

Source code
property HigherBound : TSepiMemoryReference read FHigherBound

Read Access
FHigherBound

Sepi
Class Tree
Index
Previous (Destination)
Next (LowerBound)


Sepi

Sepi
Previous (HigherBound)
Next (SetSize)

Name
LowerBound

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
Borne inférieure

Source code
property LowerBound : TSepiMemoryReference read FLowerBound

Read Access
FLowerBound

Sepi
Class Tree
Index
Previous (HigherBound)
Next (SetSize)


Sepi

Sepi
Previous (LowerBound)
Next (Union)

Name
SetSize

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
Taille du set

Source code
property SetSize : Byte read FSetSize

Read Access
FSetSize

Sepi
Class Tree
Index
Previous (LowerBound)
Next (Union)


Sepi

Sepi
Previous (SetSize)
Next

Name
Union

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
Indique si c'est un Union-Range

Source code
property Union : Boolean read FUnion

Read Access
FUnion

Sepi
Class Tree
Index
Previous (SetSize)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
Crée une instruction set-range

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ASetSize : Byte ; AUnion : Boolean = False )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
ASetSize : BYTE | Taille du set
AUnion : BOOLEAN | True pour faire un Union-Range

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmSetRange

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmSetRange)
Next (TSepiAsmStrCopy)

Name
TSepiAsmStaticCall

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmRefCall

Visibility
PUBLIC

Description
Instruction Static CALL

Members
Methods
Method | Description
Create (+) | Crée une instruction Static CALL
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmSetRange)
Next (TSepiAsmStrCopy)


Sepi

Sepi
Previous
Next (Make)

Name
Create

Parent
TSepiAsmStaticCall

Visibility
PUBLIC

Description
Crée une instruction Static CALL

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Make)


Sepi

Sepi
Previous (Create)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmStaticCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmStaticCall

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmStaticCall)
Next (TSepiAsmStrSetLength)

Name
TSepiAsmStrCopy

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction ASCP ou WSCP

Members
Fields
Field | Description
FCountValue (-) | Nombre de caractères à copier
FDestination (-) | Destination
FIndexValue (-) | Index de base de la copie
FSource (-) | Source

Methods
Method | Description
Create (+) | Crée une instruction ASCP ou WSCP
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
CountValue (+) | Nombre de caractères à copier
Destination (+) | Destination
IndexValue (+) | Index de base de la copie
Source (+) | Source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmStaticCall)
Next (TSepiAsmStrSetLength)


Sepi

Sepi
Previous
Next (FDestination)

Name
FCountValue

Parent
TSepiAsmStrCopy

Visibility
PRIVATE

Description
Nombre de caractères à copier

Source code
FCountValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FDestination)


Sepi

Sepi
Previous (FCountValue)
Next (FIndexValue)

Name
FDestination

Parent
TSepiAsmStrCopy

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FCountValue)
Next (FIndexValue)


Sepi

Sepi
Previous (FDestination)
Next (FSource)

Name
FIndexValue

Parent
TSepiAsmStrCopy

Visibility
PRIVATE

Description
Index de base de la copie

Source code
FIndexValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next (FSource)


Sepi

Sepi
Previous (FIndexValue)
Next

Name
FSource

Parent
TSepiAsmStrCopy

Visibility
PRIVATE

Description
Source

Source code
FSource : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FIndexValue)
Next


Sepi

Sepi
Previous
Next (Destination)

Name
CountValue

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
Nombre de caractères à copier

Source code
property CountValue : TSepiMemoryReference read FCountValue

Read Access
FCountValue

Sepi
Class Tree
Index
Previous
Next (Destination)


Sepi

Sepi
Previous (CountValue)
Next (IndexValue)

Name
Destination

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous (CountValue)
Next (IndexValue)


Sepi

Sepi
Previous (Destination)
Next (Source)

Name
IndexValue

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
Index de base de la copie

Source code
property IndexValue : TSepiMemoryReference read FIndexValue

Read Access
FIndexValue

Sepi
Class Tree
Index
Previous (Destination)
Next (Source)


Sepi

Sepi
Previous (IndexValue)
Next

Name
Source

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
Source

Source code
property Source : TSepiMemoryReference read FSource

Read Access
FSource

Sepi
Class Tree
Index
Previous (IndexValue)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
Crée une instruction ASCP ou WSCP

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode | OpCode (in [ocAnsiStrCopy..ocWideStrCopy])

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmStrCopy

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmStrCopy)
Next (TSepiAsmTryExcept)

Name
TSepiAsmStrSetLength

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction ASSL ou WSSL

Members
Fields
Field | Description
FNewLength (-) | Nouvelle longueur de la chaîne
FStrValue (-) | Valeur chaîne

Methods
Method | Description
Create (+) | Crée une instruction ASSL ou WSSL
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
NewLength (+) | Nouvelle longueur de la chaîne
StrValue (+) | Valeur chaîne

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmStrCopy)
Next (TSepiAsmTryExcept)


Sepi

Sepi
Previous
Next (FStrValue)

Name
FNewLength

Parent
TSepiAsmStrSetLength

Visibility
PRIVATE

Description
Nouvelle longueur de la chaîne

Source code
FNewLength : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FStrValue)


Sepi

Sepi
Previous (FNewLength)
Next

Name
FStrValue

Parent
TSepiAsmStrSetLength

Visibility
PRIVATE

Description
Valeur chaîne

Source code
FStrValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FNewLength)
Next


Sepi

Sepi
Previous
Next (StrValue)

Name
NewLength

Parent
TSepiAsmStrSetLength

Visibility
PUBLIC

Description
Nouvelle longueur de la chaîne

Source code
property NewLength : TSepiMemoryReference read FNewLength

Read Access
FNewLength

Sepi
Class Tree
Index
Previous
Next (StrValue)


Sepi

Sepi
Previous (NewLength)
Next

Name
StrValue

Parent
TSepiAsmStrSetLength

Visibility
PUBLIC

Description
Valeur chaîne

Source code
property StrValue : TSepiMemoryReference read FStrValue

Read Access
FStrValue

Sepi
Class Tree
Index
Previous (NewLength)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmStrSetLength

Visibility
PUBLIC

Description
Crée une instruction ASSL ou WSSL

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode | OpCode (in [ocAnsiStrSetLength..ocWideStrSetLength])

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmStrSetLength

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmStrSetLength

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmStrSetLength

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmStrSetLength)
Next (TSepiAsmTryFinally)

Name
TSepiAsmTryExcept

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction TRYE

Members
Fields
Field | Description
FEndOfExcept (-) | Fin du except
FEndOfTry (-) | Fin du try
FExceptObject (-) | Objet exception

Methods
Method | Description
Create (+) | Crée une instruction TRYE
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
EndOfExcept (+) | Fin du except
EndOfTry (+) | Fin du try
ExceptObject (+) | Objet exception

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmStrSetLength)
Next (TSepiAsmTryFinally)


Sepi

Sepi
Previous
Next (FEndOfTry)

Name
FEndOfExcept

Parent
TSepiAsmTryExcept

Visibility
PRIVATE

Description
Fin du except

Source code
FEndOfExcept : TSepiJumpDest

Sepi
Class Tree
Index
Previous
Next (FEndOfTry)


Sepi

Sepi
Previous (FEndOfExcept)
Next (FExceptObject)

Name
FEndOfTry

Parent
TSepiAsmTryExcept

Visibility
PRIVATE

Description
Fin du try

Source code
FEndOfTry : TSepiJumpDest

Sepi
Class Tree
Index
Previous (FEndOfExcept)
Next (FExceptObject)


Sepi

Sepi
Previous (FEndOfTry)
Next

Name
FExceptObject

Parent
TSepiAsmTryExcept

Visibility
PRIVATE

Description
Objet exception

Source code
FExceptObject : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FEndOfTry)
Next


Sepi

Sepi
Previous
Next (EndOfTry)

Name
EndOfExcept

Parent
TSepiAsmTryExcept

Visibility
PUBLIC

Description
Fin du except

Source code
property EndOfExcept : TSepiJumpDest read FEndOfExcept

Read Access
FEndOfExcept

Sepi
Class Tree
Index
Previous
Next (EndOfTry)


Sepi

Sepi
Previous (EndOfExcept)
Next (ExceptObject)

Name
EndOfTry

Parent
TSepiAsmTryExcept

Visibility
PUBLIC

Description
Fin du try

Source code
property EndOfTry : TSepiJumpDest read FEndOfTry

Read Access
FEndOfTry

Sepi
Class Tree
Index
Previous (EndOfExcept)
Next (ExceptObject)


Sepi

Sepi
Previous (EndOfTry)
Next

Name
ExceptObject

Parent
TSepiAsmTryExcept

Visibility
PUBLIC

Description
Objet exception

Source code
property ExceptObject : TSepiMemoryReference read FExceptObject

Read Access
FExceptObject

Sepi
Class Tree
Index
Previous (EndOfTry)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmTryExcept

Visibility
PUBLIC

Description
Crée une instruction TRYE

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter Description
AMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmTryExcept

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmTryExcept

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmTryExcept

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmTryExcept)
Next (TSepiAsmValueToIntStdFunction)

Name
TSepiAsmTryFinally

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction TRYF

Members
Fields
Field | Description
FEndOfFinally (-) | Fin du finally
FEndOfTry (-) | Fin du try

Methods
Method | Description
Create (+) | Crée une instruction TRYF
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
EndOfFinally (+) | Fin du finally
EndOfTry (+) | Fin du try

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmTryExcept)
Next (TSepiAsmValueToIntStdFunction)


Sepi

Sepi
Previous
Next (FEndOfTry)

Name
FEndOfFinally

Parent
TSepiAsmTryFinally

Visibility
PRIVATE

Description
Fin du finally

Source code
FEndOfFinally : TSepiJumpDest

Sepi
Class Tree
Index
Previous
Next (FEndOfTry)


Sepi

Sepi
Previous (FEndOfFinally)
Next

Name
FEndOfTry

Parent
TSepiAsmTryFinally

Visibility
PRIVATE

Description
Fin du try

Source code
FEndOfTry : TSepiJumpDest

Sepi
Class Tree
Index
Previous (FEndOfFinally)
Next


Sepi

Sepi
Previous
Next (EndOfTry)

Name
EndOfFinally

Parent
TSepiAsmTryFinally

Visibility
PUBLIC

Description
Fin du finally

Source code
property EndOfFinally : TSepiJumpDest read FEndOfFinally

Read Access
FEndOfFinally

Sepi
Class Tree
Index
Previous
Next (EndOfTry)


Sepi

Sepi
Previous (EndOfFinally)
Next

Name
EndOfTry

Parent
TSepiAsmTryFinally

Visibility
PUBLIC

Description
Fin du try

Source code
property EndOfTry : TSepiJumpDest read FEndOfTry

Read Access
FEndOfTry

Sepi
Class Tree
Index
Previous (EndOfFinally)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmTryFinally

Visibility
PUBLIC

Description
Crée une instruction TRYF

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmTryFinally

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmTryFinally

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmTryFinally

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (TSepiAsmTryFinally)
Next

Name
TSepiAsmValueToIntStdFunction

Parent
SepiAsmInstructions

Class Hierarchy
TSepiAsmInstr

Visibility
PUBLIC

Description
Instruction ASL, WSL, DAL ou DAH

Members
Fields
Field | Description
FDestination (-) | Destination
FValue (-) | Valeur

Methods
Method | Description
Create (+) | Crée une instruction ASL, WSL, DAL ou DAH
Destroy (+) | [@inheritDoc]
Make (+) | [@inheritDoc]
WriteToStream (+) | [@inheritDoc]

Properties
Property | Description
Destination (+) | Destination
Value (+) | Valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmTryFinally)
Next


Sepi

Sepi
Previous
Next (FValue)

Name
FDestination

Parent
TSepiAsmValueToIntStdFunction

Visibility
PRIVATE

Description
Destination

Source code
FDestination : TSepiMemoryReference

Sepi
Class Tree
Index
Previous
Next (FValue)


Sepi

Sepi
Previous (FDestination)
Next

Name
FValue

Parent
TSepiAsmValueToIntStdFunction

Visibility
PRIVATE

Description
Valeur

Source code
FValue : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (FDestination)
Next


Sepi

Sepi
Previous
Next (Value)

Name
Destination

Parent
TSepiAsmValueToIntStdFunction

Visibility
PUBLIC

Description
Destination

Source code
property Destination : TSepiMemoryReference read FDestination

Read Access
FDestination

Sepi
Class Tree
Index
Previous
Next (Value)


Sepi

Sepi
Previous (Destination)
Next

Name
Value

Parent
TSepiAsmValueToIntStdFunction

Visibility
PUBLIC

Description
Valeur

Source code
property Value : TSepiMemoryReference read FValue

Read Access
FValue

Sepi
Class Tree
Index
Previous (Destination)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsmValueToIntStdFunction

Visibility
PUBLIC

Description
Crée une instruction ASL, WSL, DAL ou DAH

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOpCode : TSepiOpCode )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOpCode : TSepiOpCode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Make)

Name
Destroy

Parent
TSepiAsmValueToIntStdFunction

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Make)


Sepi

Sepi
Previous (Destroy)
Next (WriteToStream)

Name
Make

Parent
TSepiAsmValueToIntStdFunction

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Make ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (WriteToStream)


Sepi

Sepi
Previous (Make)
Next

Name
WriteToStream

Parent
TSepiAsmValueToIntStdFunction

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure WriteToStream ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Make)
Next


Sepi

Sepi
Previous (SepiAsmInstructions)
Next (SepiCompilerConsts)

Name
SepiCompiler

Parent
Sepi

Description
Compilateur Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TSepiResolveIdentFunc (+) | Méthode de call-back de résolution d'identificateur

Constants
Constant | Description
MaxOperationCount (+) | Nombre maximum d'opérations sur une adresse
msUnresolvedLocalVar (+) | Indique une variable locale non encore résolue
ResultFieldName (+) | Nom de la variable locale Result

Classes
Class | Description
ESepiCompilerError (+) | Erreur de compilation Sepi
ESepiInvalidJumpDest (+) | Destination de JUMP invalide
ESepiInvalidMemoryReference (+) | Référence mémoire invalide d'après l'instruction contenante
ESepiLabelError (+) | Label non trouvé lors de la compilation Sepi
ESepiMemoryReferenceError (+) | Erreur de référence mémoire
ESepiSealedMemoryReference (+) | Référence mémoire scellée
ISepiExpression (+) | Expression Sepi
ISepiExpressionPart (+) | Partie liable dynamiquement à une expression Sepi
TLocalInitInfo (+) | Informations d'initialisation d'une variable locale
TSepiAddressDerefAndOpRec (+) | Record d'informations de déréférencement et d'opération sur adresse
TSepiAsmInstr (+) | Instruction d'assemblage Sepi
TSepiAsmInstrList (+) | Liste d'instructions assembleur Sepi
TSepiCompilerBase (+) | Classe de base pour les classes TSepiMethodCompiler et TSepiUnitCompiler
TSepiExpression (+) | Implémentation principale de ISepiExpression
TSepiInstruction (+) | Instruction Sepi
TSepiInstructionList (+) | Liste d'instructions Sepi
TSepiInstructionRef (+) | Référence à une instruction
TSepiJumpDest (+) | Destination d'un JUMP Sepi
TSepiLanguageRules (+) | Règles sémantiques d'un langage
TSepiLocalVar (+) | Variable locale d'une méthode Sepi
TSepiLocalVariables (+) | Variables locales d'une méthode Sepi
TSepiLocalVarLife (+) | Vie d'une variable locale
TSepiMemoryReference (+) | Référence à un emplacement mémoire
TSepiMethodCompiler (+) | Compilateur d'une méthode Sepi
TSepiNamedLabel (+) | Pseudo-instruction label nommé
TSepiTempVarsLifeManager (+) | Gestionnaire de vie de plusieurs variables temporaires
TSepiUnitCompiler (+) | Compilateur d'unité Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiAsmInstructions)
Next (SepiCompilerConsts)


Sepi

Sepi
Previous
Next (ESepiInvalidJumpDest)

Name
ESepiCompilerError

Parent
SepiCompiler

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Erreur de compilation Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ESepiInvalidJumpDest)


Sepi

Sepi
Previous (ESepiCompilerError)
Next (ESepiInvalidMemoryReference)

Name
ESepiInvalidJumpDest

Parent
SepiCompiler

Class Hierarchy
ESepiCompilerError

Visibility
PUBLIC

Description
Destination de JUMP invalide

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiCompilerError)
Next (ESepiInvalidMemoryReference)


Sepi

Sepi
Previous (ESepiInvalidJumpDest)
Next (ESepiLabelError)

Name
ESepiInvalidMemoryReference

Parent
SepiCompiler

Class Hierarchy
ESepiMemoryReferenceError

Visibility
PUBLIC

Description
Référence mémoire invalide d'après l'instruction contenante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiInvalidJumpDest)
Next (ESepiLabelError)


Sepi

Sepi
Previous (ESepiInvalidMemoryReference)
Next (ESepiMemoryReferenceError)

Name
ESepiLabelError

Parent
SepiCompiler

Class Hierarchy
ESepiCompilerError

Visibility
PUBLIC

Description
Label non trouvé lors de la compilation Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiInvalidMemoryReference)
Next (ESepiMemoryReferenceError)


Sepi

Sepi
Previous (ESepiLabelError)
Next (ESepiSealedMemoryReference)

Name
ESepiMemoryReferenceError

Parent
SepiCompiler

Class Hierarchy
ESepiCompilerError

Visibility
PUBLIC

Description
Erreur de référence mémoire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiLabelError)
Next (ESepiSealedMemoryReference)


Sepi

Sepi
Previous (ESepiMemoryReferenceError)
Next (ISepiExpression)

Name
ESepiSealedMemoryReference

Parent
SepiCompiler

Class Hierarchy
ESepiMemoryReferenceError

Visibility
PUBLIC

Description
Référence mémoire scellée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiMemoryReferenceError)
Next (ISepiExpression)


Sepi

Sepi
Previous (ESepiSealedMemoryReference)
Next (ISepiExpressionPart)

Name
ISepiExpression

Parent
SepiCompiler

Class Hierarchy
IInterface

Visibility
PUBLIC

Description
Expression Sepi
Dans Sepi, une expression peut avoir différents types en même temps. Elle
peut à la fois être un composant et l'appel à une méthode, par exemple.
Les expressions Sepi sont donc des contrôleurs d'interfaces dynamiques, et
il est possible de leur attacher/détacher toute interface implémentant
ISepiExpressionPart.

Members
Methods
Method | Description
Attach (+) | Attache une interface dynamique
Detach (+) | Détache une interface dynamique identifiée par son ID
GetBaseCompiler (+) | Compilateur de base
GetLanguageRules (+) | Règles du langage utilisé
GetMethodCompiler (+) | Compilateur de méthode
GetSepiRoot (+) | Racine Sepi
GetSourcePos (+) | Position dans le source
GetUnitCompiler (+) | Compilateur d'unité
MakeError (+) | Produit une erreur de compilation au niveau de cette expression
SetSourcePos (+) | Position dans le source

Properties
Property | Description
BaseCompiler (+) | Compilateur de base
LanguageRules (+) | Règles du langage utilisé
MethodCompiler (+) | Compilateur de méthode
SepiRoot (+) | Racine Sepi
SourcePos (+) | Position dans le source
UnitCompiler (+) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiSealedMemoryReference)
Next (ISepiExpressionPart)


Sepi

Sepi
Previous
Next (LanguageRules)

Name
BaseCompiler

Parent
ISepiExpression

Visibility
PUBLIC

Description
Compilateur de base

Source code
property BaseCompiler : TSepiCompilerBase read GetBaseCompiler

Read Access
GetBaseCompiler

Sepi
Class Tree
Index
Previous
Next (LanguageRules)


Sepi

Sepi
Previous (BaseCompiler)
Next (MethodCompiler)

Name
LanguageRules

Parent
ISepiExpression

Visibility
PUBLIC

Description
Règles du langage utilisé

Source code
property LanguageRules : TSepiLanguageRules read GetLanguageRules

Read Access
GetLanguageRules

Sepi
Class Tree
Index
Previous (BaseCompiler)
Next (MethodCompiler)


Sepi

Sepi
Previous (LanguageRules)
Next (SepiRoot)

Name
MethodCompiler

Parent
ISepiExpression

Visibility
PUBLIC

Description
Compilateur de méthode

Source code
property MethodCompiler : TSepiMethodCompiler read GetMethodCompiler

Read Access
GetMethodCompiler

Sepi
Class Tree
Index
Previous (LanguageRules)
Next (SepiRoot)


Sepi

Sepi
Previous (MethodCompiler)
Next (SourcePos)

Name
SepiRoot

Parent
ISepiExpression

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read GetSepiRoot

Read Access
GetSepiRoot

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next (SourcePos)


Sepi

Sepi
Previous (SepiRoot)
Next (UnitCompiler)

Name
SourcePos

Parent
ISepiExpression

Visibility
PUBLIC

Description
Position dans le source

Source code
property SourcePos : TSepiSourcePosition read GetSourcePos write SetSourcePos

Read Access
GetSourcePos

Write Access
SetSourcePos

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (UnitCompiler)


Sepi

Sepi
Previous (SourcePos)
Next

Name
UnitCompiler

Parent
ISepiExpression

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read GetUnitCompiler

Read Access
GetUnitCompiler

Sepi
Class Tree
Index
Previous (SourcePos)
Next


Sepi

Sepi
Previous
Next (Detach)

Name
Attach

Parent
ISepiExpression

Visibility
PUBLIC

Description
Attache une interface dynamique

Source code
procedure Attach ( const IID : TGUID ; const Intf : ISepiExpressionPart )

Parameters
Parameter | Description
IID : TGUID | ID de l'interface à attacher
Intf : ISepiExpressionPart | Interface à lier

Sepi
Class Tree
Index
Previous
Next (Detach)


Sepi

Sepi
Previous (Attach)
Next (GetBaseCompiler)

Name
Detach

Parent
ISepiExpression

Visibility
PUBLIC

Description
Détache une interface dynamique identifiée par son ID

Source code
procedure Detach ( const IID : TGUID )

Parameters
Parameter | Description
IID : TGUID | ID de l'interface à détacher

Sepi
Class Tree
Index
Previous (Attach)
Next (GetBaseCompiler)


Sepi

Sepi
Previous (Detach)
Next (GetLanguageRules)

Name
GetBaseCompiler

Parent
ISepiExpression

Visibility
PUBLIC

Description
Compilateur de base

Source code
function GetBaseCompiler : TSepiCompilerBase

Parameters
Parameter Description

Return
Types | Description
TSepiCompilerBase | Compilateur de base

Sepi
Class Tree
Index
Previous (Detach)
Next (GetLanguageRules)


Sepi

Sepi
Previous (GetBaseCompiler)
Next (GetMethodCompiler)

Name
GetLanguageRules

Parent
ISepiExpression

Visibility
PUBLIC

Description
Règles du langage utilisé

Source code
function GetLanguageRules : TSepiLanguageRules

Parameters
Parameter Description

Return
Types | Description
TSepiLanguageRules | Règles du langage utilisé

Sepi
Class Tree
Index
Previous (GetBaseCompiler)
Next (GetMethodCompiler)


Sepi

Sepi
Previous (GetLanguageRules)
Next (GetSepiRoot)

Name
GetMethodCompiler

Parent
ISepiExpression

Visibility
PUBLIC

Description
Compilateur de méthode

Source code
function GetMethodCompiler : TSepiMethodCompiler

Parameters
Parameter Description

Return
Types | Description
TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (GetLanguageRules)
Next (GetSepiRoot)


Sepi

Sepi
Previous (GetMethodCompiler)
Next (GetSourcePos)

Name
GetSepiRoot

Parent
ISepiExpression

Visibility
PUBLIC

Description
Racine Sepi

Source code
function GetSepiRoot : TSepiRoot

Parameters
Parameter Description

Return
Types | Description
TSepiRoot | Racine Sepi

Sepi
Class Tree
Index
Previous (GetMethodCompiler)
Next (GetSourcePos)


Sepi

Sepi
Previous (GetSepiRoot)
Next (GetUnitCompiler)

Name
GetSourcePos

Parent
ISepiExpression

Visibility
PUBLIC

Description
Position dans le source

Source code
function GetSourcePos : TSepiSourcePosition

Parameters
Parameter Description

Return
Types | Description
TSepiSourcePosition | Position dans le source

Sepi
Class Tree
Index
Previous (GetSepiRoot)
Next (GetUnitCompiler)


Sepi

Sepi
Previous (GetSourcePos)
Next (MakeError)

Name
GetUnitCompiler

Parent
ISepiExpression

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
function GetUnitCompiler : TSepiUnitCompiler

Parameters
Parameter Description

Return
Types | Description
TSepiUnitCompiler | Compilateur d'unité

Sepi
Class Tree
Index
Previous (GetSourcePos)
Next (MakeError)


Sepi

Sepi
Previous (GetUnitCompiler)
Next (SetSourcePos)

Name
MakeError

Parent
ISepiExpression

Visibility
PUBLIC

Description
Produit une erreur de compilation au niveau de cette expression

Source code
procedure MakeError ( const Msg : string ; Kind : TSepiErrorKind = ekError )

Parameters
Parameter | Description
Msg : STRING | Message de l'erreur
Kind : TSepiErrorKind | Type d'erreur (défaut = ekError)

Sepi
Class Tree
Index
Previous (GetUnitCompiler)
Next (SetSourcePos)


Sepi

Sepi
Previous (MakeError)
Next

Name
SetSourcePos

Parent
ISepiExpression

Visibility
PUBLIC

Description
Position dans le source

Source code
procedure SetSourcePos ( const Value : TSepiSourcePosition )

Parameters
Parameter | Description
Value : TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next


Sepi

Sepi
Previous (ISepiExpression)
Next (TLocalInitInfo)

Name
ISepiExpressionPart

Parent
SepiCompiler

Class Hierarchy
IDynamicallyLinkable

Visibility
PUBLIC

Description
Partie liable dynamiquement à une expression Sepi

Members
Methods
Method | Description
AttachToExpression (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiExpression)
Next (TLocalInitInfo)


Sepi

Sepi
Previous
Next

Name
AttachToExpression

Parent
ISepiExpressionPart

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AttachToExpression ( const Expression : ISepiExpression )

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ISepiExpressionPart)
Next (TSepiAddressDerefAndOpRec)

Name
TLocalInitInfo

Parent
SepiCompiler

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Informations d'initialisation d'une variable locale

Members
Fields
Field | Description
OFFSET (*) | Offset de la variable
TypeRef (*) | Référence au type de la variable

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiExpressionPart)
Next (TSepiAddressDerefAndOpRec)


Sepi

Sepi
Previous
Next (TypeRef)

Name
OFFSET

Parent
TLocalInitInfo

Visibility
PUBLISHED

Description
Offset de la variable

Source code
Offset : Integer

Sepi
Class Tree
Index
Previous
Next (TypeRef)


Sepi

Sepi
Previous (OFFSET)
Next

Name
TypeRef

Parent
TLocalInitInfo

Visibility
PUBLISHED

Description
Référence au type de la variable

Source code
TypeRef : Integer

Sepi
Class Tree
Index
Previous (OFFSET)
Next


Sepi

Sepi
Previous (TLocalInitInfo)
Next (TSepiAsmInstr)

Name
TSepiAddressDerefAndOpRec

Parent
SepiCompiler

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Record d'informations de déréférencement et d'opération sur adresse

Members
Fields
Field | Description
ConstOperationArg (*) | Argument constant de l'opération
Dereference (*) | Déréférencement
MemOperationArg (*) | Argument mémoire de l'opération
Operation (*) | Opération

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TLocalInitInfo)
Next (TSepiAsmInstr)


Sepi

Sepi
Previous
Next (Dereference)

Name
ConstOperationArg

Parent
TSepiAddressDerefAndOpRec

Visibility
PUBLISHED

Description
Argument constant de l'opération

Source code
ConstOperationArg : Integer

Sepi
Class Tree
Index
Previous
Next (Dereference)


Sepi

Sepi
Previous (ConstOperationArg)
Next (MemOperationArg)

Name
Dereference

Parent
TSepiAddressDerefAndOpRec

Visibility
PUBLISHED

Description
Déréférencement

Source code
Dereference : TSepiAddressDereference

Sepi
Class Tree
Index
Previous (ConstOperationArg)
Next (MemOperationArg)


Sepi

Sepi
Previous (Dereference)
Next (Operation)

Name
MemOperationArg

Parent
TSepiAddressDerefAndOpRec

Visibility
PUBLISHED

Description
Argument mémoire de l'opération

Source code
MemOperationArg : TSepiMemoryReference

Sepi
Class Tree
Index
Previous (Dereference)
Next (Operation)


Sepi

Sepi
Previous (MemOperationArg)
Next

Name
Operation

Parent
TSepiAddressDerefAndOpRec

Visibility
PUBLISHED

Description
Opération

Source code
Operation : TSepiAddressOperation

Sepi
Class Tree
Index
Previous (MemOperationArg)
Next


Sepi

Sepi
Previous (TSepiAddressDerefAndOpRec)
Next (TSepiAsmInstrList)

Name
TSepiAsmInstr

Parent
SepiCompiler

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction d'assemblage Sepi

Members
Fields
Field | Description
FOpCode (#) | OpCode
FPosition (-) | Position de l'instruction
FSize (#) | Taille

Methods
Method | Description
ComputeActualSize (+) | Calcule la taille réelle en tenant compte des compressions possibles
Create (+) | Crée une nouvelle instruction assembleur Sepi
CustomCompile (#) | Compile l'instruction assembleur
GetEndPosition (#) | Position de la fin de l'instruction
Make (+) | Construit l'instruction
SetPosition (+) | Donne sa position à l'instruction
WriteToStream (+) | Ecrit l'instruction dans un flux

Properties
Property | Description
EndPosition (+) | Position de la fin de l'instruction
OpCode (+) | OpCode
Position (+) | Position de l'instruction
Size (+) | Taille

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAddressDerefAndOpRec)
Next (TSepiAsmInstrList)


Sepi

Sepi
Previous
Next (FPosition)

Name
FOpCode

Parent
TSepiAsmInstr

Visibility
PROTECTED

Description
OpCode

Source code
FOpCode : TSepiOpCode

Sepi
Class Tree
Index
Previous
Next (FPosition)


Sepi

Sepi
Previous (FOpCode)
Next (FSize)

Name
FPosition

Parent
TSepiAsmInstr

Visibility
PRIVATE

Description
Position de l'instruction

Source code
FPosition : Integer

Sepi
Class Tree
Index
Previous (FOpCode)
Next (FSize)


Sepi

Sepi
Previous (FPosition)
Next

Name
FSize

Parent
TSepiAsmInstr

Visibility
PROTECTED

Description
Taille

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FPosition)
Next


Sepi

Sepi
Previous
Next (OpCode)

Name
EndPosition

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Position de la fin de l'instruction

Source code
property EndPosition : Integer read GetEndPosition

Read Access
GetEndPosition

Sepi
Class Tree
Index
Previous
Next (OpCode)


Sepi

Sepi
Previous (EndPosition)
Next (Position)

Name
OpCode

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
OpCode

Source code
property OpCode : TSepiOpCode read FOpCode

Read Access
FOpCode

Sepi
Class Tree
Index
Previous (EndPosition)
Next (Position)


Sepi

Sepi
Previous (OpCode)
Next (Size)

Name
Position

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Position de l'instruction

Source code
property Position : Integer read FPosition

Read Access
FPosition

Sepi
Class Tree
Index
Previous (OpCode)
Next (Size)


Sepi

Sepi
Previous (Position)
Next

Name
Size

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Taille

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (Position)
Next


Sepi

Sepi
Previous
Next (Create)

Name
ComputeActualSize

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Calcule la taille réelle en tenant compte des compressions possibles
Après l'appel à ComputeActualSize, la taille ne doit plus changer !
L'implémentation par défaut dans TSepiAsmInstr ne fait rien.

Source code
procedure ComputeActualSize ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (ComputeActualSize)
Next (CustomCompile)

Name
Create

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Crée une nouvelle instruction assembleur Sepi

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (ComputeActualSize)
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next (GetEndPosition)

Name
CustomCompile

Parent
TSepiAsmInstr

Visibility
PROTECTED

Description
Compile l'instruction assembleur
La compilation d'une instruction assembleur consiste uniquement à s'ajouter à
la liste des instructions assembleur de son compilateur de méthode.

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetEndPosition)


Sepi

Sepi
Previous (CustomCompile)
Next (Make)

Name
GetEndPosition

Parent
TSepiAsmInstr

Visibility
PROTECTED

Description
Position de la fin de l'instruction

Source code
function GetEndPosition : Integer ; virtual

Parameters
Parameter Description

Return
Types | Description
INTEGER | Position de la fin de l'instruction

Sepi
Class Tree
Index
Previous (CustomCompile)
Next (Make)


Sepi

Sepi
Previous (GetEndPosition)
Next (SetPosition)

Name
Make

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Construit l'instruction
A partir de l'appel à Make, l'instruction ne sera plus modifiée jusqu'à
l'assemblage définitif.
La méthode Make doit au minimum renseigner correctement la propriété Size.
L'implémentation par défaut dans TSepiAsmInstr donne à MaxSize la taille d'un
OpCode (1).

Source code
procedure Make ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetEndPosition)
Next (SetPosition)


Sepi

Sepi
Previous (Make)
Next (WriteToStream)

Name
SetPosition

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Donne sa position à l'instruction

Source code
procedure SetPosition ( Value : Integer ) ; virtual

Parameters
Parameter | Description
Value : INTEGER | Position

Sepi
Class Tree
Index
Previous (Make)
Next (WriteToStream)


Sepi

Sepi
Previous (SetPosition)
Next

Name
WriteToStream

Parent
TSepiAsmInstr

Visibility
PUBLIC

Description
Ecrit l'instruction dans un flux
WriteToStream doit écrire exactement autant d'octets dans le flux que la
valeur de la propriété Size.
L'implémentation par défaut dans TSepiAsmInstr écrit l'OpCode

Source code
procedure WriteToStream ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (SetPosition)
Next


Sepi

Sepi
Previous (TSepiAsmInstr)
Next (TSepiCompilerBase)

Name
TSepiAsmInstrList

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Liste d'instructions assembleur Sepi

Members
Fields
Field | Description
FInstructions (-) | Instructions
FMethodCompiler (-) | Compilateur
FSize (-) | Taille

Methods
Method | Description
ADD (#) | Ajoute une instruction assembleur à la liste
Assemble (+) | Assemble les instructions
Clear (+) | Vide la liste des instructions
ComputeActualSize (-) | Calcule la taille réelle en tenant compte des compressions possibles
Create (+) | Crée une liste d'instructions assembleur
Destroy (+) | [@inheritDoc]
GetCount (-) | Nombre d'instructions
GetInstructions (-) | Tableau zero-based des instructions
Make (-) | Construit les instructions
SetPositions (-) | Donne leur position aux instructions
WriteToStream (+) | Ecrit les instructions dans un flux

Properties
Property | Description
Count (+) | Nombre d'instructions
CurrentPos (#) | Nombre d'instructions
Instructions (+) | Tableau zero-based des instructions
MethodCompiler (+) | Compilateur
Size (+) | Taille

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmInstr)
Next (TSepiCompilerBase)


Sepi

Sepi
Previous
Next (FMethodCompiler)

Name
FInstructions

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Instructions

Source code
FInstructions : TObjectList

Sepi
Class Tree
Index
Previous
Next (FMethodCompiler)


Sepi

Sepi
Previous (FInstructions)
Next (FSize)

Name
FMethodCompiler

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Compilateur

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous (FInstructions)
Next (FSize)


Sepi

Sepi
Previous (FMethodCompiler)
Next

Name
FSize

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Taille

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FMethodCompiler)
Next


Sepi

Sepi
Previous
Next (CurrentPos)

Name
Count

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Nombre d'instructions

Source code
property Count : Integer read GetCount

Read Access
GetCount

Sepi
Class Tree
Index
Previous
Next (CurrentPos)


Sepi

Sepi
Previous (Count)
Next (Instructions)

Name
CurrentPos

Parent
TSepiAsmInstrList

Visibility
PROTECTED

Description
Nombre d'instructions

Source code
property CurrentPos : Integer read GetCount

Read Access
GetCount

Sepi
Class Tree
Index
Previous (Count)
Next (Instructions)


Sepi

Sepi
Previous (CurrentPos)
Next (MethodCompiler)

Name
Instructions

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Tableau zero-based des instructions

Source code
property Instructions [ Index : Integer ] : TSepiAsmInstr read GetInstructions ; default

Read Access
GetInstructions

Sepi
Class Tree
Index
Previous (CurrentPos)
Next (MethodCompiler)


Sepi

Sepi
Previous (Instructions)
Next (Size)

Name
MethodCompiler

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Compilateur

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (Instructions)
Next (Size)


Sepi

Sepi
Previous (MethodCompiler)
Next

Name
Size

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Taille

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next


Sepi

Sepi
Previous
Next (Assemble)

Name
ADD

Parent
TSepiAsmInstrList

Visibility
PROTECTED

Description
Ajoute une instruction assembleur à la liste

Source code
procedure Add ( Instruction : TSepiAsmInstr )

Parameters
Parameter | Description
Instruction : TSepiAsmInstr | Instruction à ajouter

Sepi
Class Tree
Index
Previous
Next (Assemble)


Sepi

Sepi
Previous (ADD)
Next (Clear)

Name
Assemble

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Assemble les instructions

Source code
procedure Assemble

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ADD)
Next (Clear)


Sepi

Sepi
Previous (Assemble)
Next (ComputeActualSize)

Name
Clear

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Vide la liste des instructions

Source code
procedure Clear

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Assemble)
Next (ComputeActualSize)


Sepi

Sepi
Previous (Clear)
Next (Create)

Name
ComputeActualSize

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Calcule la taille réelle en tenant compte des compressions possibles

Source code
procedure ComputeActualSize

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Clear)
Next (Create)


Sepi

Sepi
Previous (ComputeActualSize)
Next (Destroy)

Name
Create

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Crée une liste d'instructions assembleur

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (ComputeActualSize)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetCount)

Name
Destroy

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetCount)


Sepi

Sepi
Previous (Destroy)
Next (GetInstructions)

Name
GetCount

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Nombre d'instructions

Source code
function GetCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'instructions dans la liste

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetInstructions)


Sepi

Sepi
Previous (GetCount)
Next (Make)

Name
GetInstructions

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Tableau zero-based des instructions

Source code
function GetInstructions ( Index : Integer ) : TSepiAsmInstr

Parameters
Parameter | Description
INDEX : INTEGER | Index d'une instruction

Return
Types | Description
TSepiAsmInstr | L'instruction à l'index spécifié

Sepi
Class Tree
Index
Previous (GetCount)
Next (Make)


Sepi

Sepi
Previous (GetInstructions)
Next (SetPositions)

Name
Make

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Construit les instructions

Source code
procedure Make

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetInstructions)
Next (SetPositions)


Sepi

Sepi
Previous (Make)
Next (WriteToStream)

Name
SetPositions

Parent
TSepiAsmInstrList

Visibility
PRIVATE

Description
Donne leur position aux instructions

Source code
procedure SetPositions

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Make)
Next (WriteToStream)


Sepi

Sepi
Previous (SetPositions)
Next

Name
WriteToStream

Parent
TSepiAsmInstrList

Visibility
PUBLIC

Description
Ecrit les instructions dans un flux

Source code
procedure WriteToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (SetPositions)
Next


Sepi

Sepi
Previous (TSepiAsmInstrList)
Next (TSepiExpression)

Name
TSepiCompilerBase

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe de base pour les classes TSepiMethodCompiler et TSepiUnitCompiler

Members
Fields
Field | Description
FErrors (-) | Erreurs
FSepiRoot (-) | Racine Sepi
FSepiUnit (-) | Unité Sepi
FSystemUnit (-) | Unité System
FUnitCompiler (-) | Compilateur d'unité

Methods
Method | Description
Create (+) | Crée un nouveau compilateur Sepi

Properties
Property | Description
Errors (+) | Erreurs
SepiRoot (+) | Racine Sepi
SepiUnit (+) | Unité Sepi
SystemUnit (+) | Unité System
UnitCompiler (+) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsmInstrList)
Next (TSepiExpression)


Sepi

Sepi
Previous
Next (FSepiRoot)

Name
FErrors

Parent
TSepiCompilerBase

Visibility
PRIVATE

Description
Erreurs

Source code
FErrors : TSepiCompilerErrorList

Sepi
Class Tree
Index
Previous
Next (FSepiRoot)


Sepi

Sepi
Previous (FErrors)
Next (FSepiUnit)

Name
FSepiRoot

Parent
TSepiCompilerBase

Visibility
PRIVATE

Description
Racine Sepi

Source code
FSepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FErrors)
Next (FSepiUnit)


Sepi

Sepi
Previous (FSepiRoot)
Next (FSystemUnit)

Name
FSepiUnit

Parent
TSepiCompilerBase

Visibility
PRIVATE

Description
Unité Sepi

Source code
FSepiUnit : TSepiUnit

Sepi
Class Tree
Index
Previous (FSepiRoot)
Next (FSystemUnit)


Sepi

Sepi
Previous (FSepiUnit)
Next (FUnitCompiler)

Name
FSystemUnit

Parent
TSepiCompilerBase

Visibility
PRIVATE

Description
Unité System

Source code
FSystemUnit : TSepiSystemUnit

Sepi
Class Tree
Index
Previous (FSepiUnit)
Next (FUnitCompiler)


Sepi

Sepi
Previous (FSystemUnit)
Next

Name
FUnitCompiler

Parent
TSepiCompilerBase

Visibility
PRIVATE

Description
Compilateur d'unité

Source code
FUnitCompiler : TSepiUnitCompiler

Sepi
Class Tree
Index
Previous (FSystemUnit)
Next


Sepi

Sepi
Previous
Next (SepiRoot)

Name
Errors

Parent
TSepiCompilerBase

Visibility
PUBLIC

Description
Erreurs

Source code
property Errors : TSepiCompilerErrorList read FErrors

Read Access
FErrors

Sepi
Class Tree
Index
Previous
Next (SepiRoot)


Sepi

Sepi
Previous (Errors)
Next (SepiUnit)

Name
SepiRoot

Parent
TSepiCompilerBase

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read FSepiRoot

Read Access
FSepiRoot

Sepi
Class Tree
Index
Previous (Errors)
Next (SepiUnit)


Sepi

Sepi
Previous (SepiRoot)
Next (SystemUnit)

Name
SepiUnit

Parent
TSepiCompilerBase

Visibility
PUBLIC

Description
Unité Sepi

Source code
property SepiUnit : TSepiUnit read FSepiUnit

Read Access
FSepiUnit

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (SystemUnit)


Sepi

Sepi
Previous (SepiUnit)
Next (UnitCompiler)

Name
SystemUnit

Parent
TSepiCompilerBase

Visibility
PUBLIC

Description
Unité System

Source code
property SystemUnit : TSepiSystemUnit read FSystemUnit

Read Access
FSystemUnit

Sepi
Class Tree
Index
Previous (SepiUnit)
Next (UnitCompiler)


Sepi

Sepi
Previous (SystemUnit)
Next

Name
UnitCompiler

Parent
TSepiCompilerBase

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read FUnitCompiler

Read Access
FUnitCompiler

Sepi
Class Tree
Index
Previous (SystemUnit)
Next


Sepi

Sepi
Previous
Next

Name
Create

Parent
TSepiCompilerBase

Visibility
PUBLIC

Description
Crée un nouveau compilateur Sepi

Source code
constructor Create ( AUnitCompiler : TSepiUnitCompiler ; AErrors : TSepiCompilerErrorList ; ASepiUnit : TSepiUnit )

Parameters
Parameter | Description
AUnitCompiler : TSepiUnitCompiler | Compilateur d'unité
AErrors : TSepiCompilerErrorList | Gestionnaire d'erreurs
ASepiUnit : TSepiUnit | Unité Sepi à compiler

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiCompilerBase)
Next (TSepiInstruction)

Name
TSepiExpression

Parent
SepiCompiler

Class Hierarchy
TDynamicIntfController,ISepiExpression

Visibility
PUBLIC

Description
Implémentation principale de ISepiExpression

Members
Fields
Field | Description
FBaseCompiler (-) | Compilateur de base
FLanguageRules (-) | Règles du langage utilisé
FMethodCompiler (-) | Compilateur de méthode
FSepiRoot (-) | Racine Sepi
FSourcePos (-) | Position dans le source
FUnitCompiler (-) | Compilateur d'unité

Methods
Method | Description
Attach (+) | [@inheritDoc]
Create (+) | Crée une expression dans le même contexte qu'une autre expression
Create (+) | Crée une expression
Detach (+) | [@inheritDoc]
GetBaseCompiler (#) | Compilateur de base
GetLanguageRules (#) | Règles du langage utilisé
GetMethodCompiler (#) | Compilateur de méthode
GetSepiRoot (#) | Racine Sepi
GetSourcePos (#) | Position dans le source
GetUnitCompiler (#) | Compilateur d'unité
MakeError (+) | [@inheritDoc]
SetSourcePos (#) | [@inheritDoc]

Properties
Property | Description
BaseCompiler (+) | Compilateur de base
LanguageRules (+) | Règles du langage utilisé
MethodCompiler (+) | Compilateur de méthode
SepiRoot (+) | Racine Sepi
SourcePos (+) | Position dans le source
UnitCompiler (+) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCompilerBase)
Next (TSepiInstruction)


Sepi

Sepi
Previous
Next (FLanguageRules)

Name
FBaseCompiler

Parent
TSepiExpression

Visibility
PRIVATE

Description
Compilateur de base

Source code
FBaseCompiler : TSepiCompilerBase

Sepi
Class Tree
Index
Previous
Next (FLanguageRules)


Sepi

Sepi
Previous (FBaseCompiler)
Next (FMethodCompiler)

Name
FLanguageRules

Parent
TSepiExpression

Visibility
PRIVATE

Description
Règles du langage utilisé

Source code
FLanguageRules : TSepiLanguageRules

Sepi
Class Tree
Index
Previous (FBaseCompiler)
Next (FMethodCompiler)


Sepi

Sepi
Previous (FLanguageRules)
Next (FSepiRoot)

Name
FMethodCompiler

Parent
TSepiExpression

Visibility
PRIVATE

Description
Compilateur de méthode

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous (FLanguageRules)
Next (FSepiRoot)


Sepi

Sepi
Previous (FMethodCompiler)
Next (FSourcePos)

Name
FSepiRoot

Parent
TSepiExpression

Visibility
PRIVATE

Description
Racine Sepi

Source code
FSepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FMethodCompiler)
Next (FSourcePos)


Sepi

Sepi
Previous (FSepiRoot)
Next (FUnitCompiler)

Name
FSourcePos

Parent
TSepiExpression

Visibility
PRIVATE

Description
Position dans le source

Source code
FSourcePos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (FSepiRoot)
Next (FUnitCompiler)


Sepi

Sepi
Previous (FSourcePos)
Next

Name
FUnitCompiler

Parent
TSepiExpression

Visibility
PRIVATE

Description
Compilateur d'unité

Source code
FUnitCompiler : TSepiUnitCompiler

Sepi
Class Tree
Index
Previous (FSourcePos)
Next


Sepi

Sepi
Previous
Next (LanguageRules)

Name
BaseCompiler

Parent
TSepiExpression

Visibility
PUBLIC

Description
Compilateur de base

Source code
property BaseCompiler : TSepiCompilerBase read FBaseCompiler

Read Access
FBaseCompiler

Sepi
Class Tree
Index
Previous
Next (LanguageRules)


Sepi

Sepi
Previous (BaseCompiler)
Next (MethodCompiler)

Name
LanguageRules

Parent
TSepiExpression

Visibility
PUBLIC

Description
Règles du langage utilisé

Source code
property LanguageRules : TSepiLanguageRules read FLanguageRules

Read Access
FLanguageRules

Sepi
Class Tree
Index
Previous (BaseCompiler)
Next (MethodCompiler)


Sepi

Sepi
Previous (LanguageRules)
Next (SepiRoot)

Name
MethodCompiler

Parent
TSepiExpression

Visibility
PUBLIC

Description
Compilateur de méthode

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (LanguageRules)
Next (SepiRoot)


Sepi

Sepi
Previous (MethodCompiler)
Next (SourcePos)

Name
SepiRoot

Parent
TSepiExpression

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read FSepiRoot

Read Access
FSepiRoot

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next (SourcePos)


Sepi

Sepi
Previous (SepiRoot)
Next (UnitCompiler)

Name
SourcePos

Parent
TSepiExpression

Visibility
PUBLIC

Description
Position dans le source

Source code
property SourcePos : TSepiSourcePosition read FSourcePos write FSourcePos

Read Access
FSourcePos

Write Access
FSourcePos

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (UnitCompiler)


Sepi

Sepi
Previous (SourcePos)
Next

Name
UnitCompiler

Parent
TSepiExpression

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read FUnitCompiler

Read Access
FUnitCompiler

Sepi
Class Tree
Index
Previous (SourcePos)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Attach

Parent
TSepiExpression

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Attach ( const IID : TGUID ; const Intf : ISepiExpressionPart )

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Intf : ISepiExpressionPart | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Attach)
Next (Create)

Name
Create

Parent
TSepiExpression

Visibility
PUBLIC

Description
Crée une expression dans le même contexte qu'une autre expression

Source code
constructor Create ( const Context : ISepiExpression ) ; overload

Parameters
Parameter | Description
Context : ISepiExpression | Expression qui fournit le contexte

Sepi
Class Tree
Index
Previous (Attach)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Detach)

Name
Create

Parent
TSepiExpression

Visibility
PUBLIC

Description
Crée une expression

Source code
constructor Create ( ACompiler : TSepiCompilerBase ) ; overload

Parameters
Parameter | Description
ACompiler : TSepiCompilerBase | Compilateur

Sepi
Class Tree
Index
Previous (Create)
Next (Detach)


Sepi

Sepi
Previous (Create)
Next (GetBaseCompiler)

Name
Detach

Parent
TSepiExpression

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Detach ( const IID : TGUID )

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetBaseCompiler)


Sepi

Sepi
Previous (Detach)
Next (GetLanguageRules)

Name
GetBaseCompiler

Parent
TSepiExpression

Visibility
PROTECTED

Description
Compilateur de base

Source code
function GetBaseCompiler : TSepiCompilerBase

Parameters
Parameter Description

Return
Types | Description
TSepiCompilerBase | Compilateur de base

Sepi
Class Tree
Index
Previous (Detach)
Next (GetLanguageRules)


Sepi

Sepi
Previous (GetBaseCompiler)
Next (GetMethodCompiler)

Name
GetLanguageRules

Parent
TSepiExpression

Visibility
PROTECTED

Description
Règles du langage utilisé

Source code
function GetLanguageRules : TSepiLanguageRules

Parameters
Parameter Description

Return
Types | Description
TSepiLanguageRules | Règles du langage utilisé

Sepi
Class Tree
Index
Previous (GetBaseCompiler)
Next (GetMethodCompiler)


Sepi

Sepi
Previous (GetLanguageRules)
Next (GetSepiRoot)

Name
GetMethodCompiler

Parent
TSepiExpression

Visibility
PROTECTED

Description
Compilateur de méthode

Source code
function GetMethodCompiler : TSepiMethodCompiler

Parameters
Parameter Description

Return
Types | Description
TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (GetLanguageRules)
Next (GetSepiRoot)


Sepi

Sepi
Previous (GetMethodCompiler)
Next (GetSourcePos)

Name
GetSepiRoot

Parent
TSepiExpression

Visibility
PROTECTED

Description
Racine Sepi

Source code
function GetSepiRoot : TSepiRoot

Parameters
Parameter Description

Return
Types | Description
TSepiRoot | Racine Sepi

Sepi
Class Tree
Index
Previous (GetMethodCompiler)
Next (GetSourcePos)


Sepi

Sepi
Previous (GetSepiRoot)
Next (GetUnitCompiler)

Name
GetSourcePos

Parent
TSepiExpression

Visibility
PROTECTED

Description
Position dans le source

Source code
function GetSourcePos : TSepiSourcePosition

Parameters
Parameter Description

Return
Types | Description
TSepiSourcePosition | Position dans le source

Sepi
Class Tree
Index
Previous (GetSepiRoot)
Next (GetUnitCompiler)


Sepi

Sepi
Previous (GetSourcePos)
Next (MakeError)

Name
GetUnitCompiler

Parent
TSepiExpression

Visibility
PROTECTED

Description
Compilateur d'unité

Source code
function GetUnitCompiler : TSepiUnitCompiler

Parameters
Parameter Description

Return
Types | Description
TSepiUnitCompiler | Compilateur d'unité

Sepi
Class Tree
Index
Previous (GetSourcePos)
Next (MakeError)


Sepi

Sepi
Previous (GetUnitCompiler)
Next (SetSourcePos)

Name
MakeError

Parent
TSepiExpression

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure MakeError ( const Msg : string ; Kind : TSepiErrorKind = ekError )

Parameters
Parameter | Description
Msg : STRING | #Pas de TAG trouvé dans le code source#
Kind : TSepiErrorKind | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetUnitCompiler)
Next (SetSourcePos)


Sepi

Sepi
Previous (MakeError)
Next

Name
SetSourcePos

Parent
TSepiExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetSourcePos ( const Value : TSepiSourcePosition )

Parameters
Parameter | Description
Value : TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next


Sepi

Sepi
Previous (TSepiExpression)
Next (TSepiInstructionList)

Name
TSepiInstruction

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Instruction Sepi
Les instructions Sepi sont toujours rattachées à un assembleur de méthodes.
Lorsque l'assembleur de méthodes est libérés, toutes les instructions qui
lui ont été rattachées sont libérées elles aussi. Ne libérez donc pas
manuellement une instruction Sepi.

Members
Fields
Field | Description
FAfterRef (-) | Référence après cette instruction
FBeforeRef (-) | Référence avant cette instruction
FMethodCompiler (-) | Compilateur
FSourcePos (-) | Position dans le source
FUnitCompiler (-) | Compilateur d'unité

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
Compile (+) | Compile l'instruction
Create (+) | Crée une nouvelle instruction Sepi
CustomCompile (#) | Compile l'instruction
Destroy (+) | [@inheritDoc]
MakeError (+) | Produit une erreur de compilation au niveau de cette instruction

Properties
Property | Description
AfterRef (+) | Référence après cette instruction
BeforeRef (+) | Référence avant cette instruction
MethodCompiler (+) | Compilateur
SourcePos (+) | Position dans le source
UnitCompiler (+) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExpression)
Next (TSepiInstructionList)


Sepi

Sepi
Previous
Next (FBeforeRef)

Name
FAfterRef

Parent
TSepiInstruction

Visibility
PRIVATE

Description
Référence après cette instruction

Source code
FAfterRef : TSepiInstructionRef

Sepi
Class Tree
Index
Previous
Next (FBeforeRef)


Sepi

Sepi
Previous (FAfterRef)
Next (FMethodCompiler)

Name
FBeforeRef

Parent
TSepiInstruction

Visibility
PRIVATE

Description
Référence avant cette instruction

Source code
FBeforeRef : TSepiInstructionRef

Sepi
Class Tree
Index
Previous (FAfterRef)
Next (FMethodCompiler)


Sepi

Sepi
Previous (FBeforeRef)
Next (FSourcePos)

Name
FMethodCompiler

Parent
TSepiInstruction

Visibility
PRIVATE

Description
Compilateur

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous (FBeforeRef)
Next (FSourcePos)


Sepi

Sepi
Previous (FMethodCompiler)
Next (FUnitCompiler)

Name
FSourcePos

Parent
TSepiInstruction

Visibility
PRIVATE

Description
Position dans le source

Source code
FSourcePos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (FMethodCompiler)
Next (FUnitCompiler)


Sepi

Sepi
Previous (FSourcePos)
Next

Name
FUnitCompiler

Parent
TSepiInstruction

Visibility
PRIVATE

Description
Compilateur d'unité

Source code
FUnitCompiler : TSepiUnitCompiler

Sepi
Class Tree
Index
Previous (FSourcePos)
Next


Sepi

Sepi
Previous
Next (BeforeRef)

Name
AfterRef

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Référence après cette instruction

Source code
property AfterRef : TSepiInstructionRef read FAfterRef

Read Access
FAfterRef

Sepi
Class Tree
Index
Previous
Next (BeforeRef)


Sepi

Sepi
Previous (AfterRef)
Next (MethodCompiler)

Name
BeforeRef

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Référence avant cette instruction

Source code
property BeforeRef : TSepiInstructionRef read FBeforeRef

Read Access
FBeforeRef

Sepi
Class Tree
Index
Previous (AfterRef)
Next (MethodCompiler)


Sepi

Sepi
Previous (BeforeRef)
Next (SourcePos)

Name
MethodCompiler

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Compilateur

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (BeforeRef)
Next (SourcePos)


Sepi

Sepi
Previous (MethodCompiler)
Next (UnitCompiler)

Name
SourcePos

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Position dans le source

Source code
property SourcePos : TSepiSourcePosition read FSourcePos write FSourcePos

Read Access
FSourcePos

Write Access
FSourcePos

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next (UnitCompiler)


Sepi

Sepi
Previous (SourcePos)
Next

Name
UnitCompiler

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read FUnitCompiler

Read Access
FUnitCompiler

Sepi
Class Tree
Index
Previous (SourcePos)
Next


Sepi

Sepi
Previous
Next (Compile)

Name
AfterConstruction

Parent
TSepiInstruction

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Compile)


Sepi

Sepi
Previous (AfterConstruction)
Next (Create)

Name
Compile

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Compile l'instruction

Source code
procedure Compile

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Create)


Sepi

Sepi
Previous (Compile)
Next (CustomCompile)

Name
Create

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Crée une nouvelle instruction Sepi

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (Compile)
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CustomCompile

Parent
TSepiInstruction

Visibility
PROTECTED

Description
Compile l'instruction
Cette méthode doit être surchargée par toutes les instructions afin de se
compiler. La compilation fera intervenir la création d'instructions assembleur
et leur compilation, en fin de récursion. La compilation des instructions
assembleur est particulière et consiste uniquement à s'ajouter à la liste des
instructions assembleur de la méthode.
Pour compiler les instructions subalternes, appelez Compile et non
CustomCompile. Mais surchargez CustomCompile.

Source code
procedure CustomCompile ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CustomCompile)
Next (MakeError)

Name
Destroy

Parent
TSepiInstruction

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CustomCompile)
Next (MakeError)


Sepi

Sepi
Previous (Destroy)
Next

Name
MakeError

Parent
TSepiInstruction

Visibility
PUBLIC

Description
Produit une erreur de compilation au niveau de cette instruction

Source code
procedure MakeError ( const Msg : string ; Kind : TSepiErrorKind = ekError )

Parameters
Parameter | Description
Msg : STRING | Message de l'erreur
Kind : TSepiErrorKind | Type d'erreur (défaut = ekError)

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (TSepiInstruction)
Next (TSepiInstructionRef)

Name
TSepiInstructionList

Parent
SepiCompiler

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Liste d'instructions Sepi

Members
Fields
Field | Description
FInstructions (-) | Instructions

Methods
Method | Description
ADD (+) | Ajoute une instruction à la fin de la liste
Create (+) | Crée une liste d'instructions
CustomCompile (#) | Compile les instructions
Destroy (+) | [@inheritDoc]
GetCount (-) | Nombre d'instructions
GetCurrentEndRef (+) | Obtient une référence sur la fin courante de la liste d'instructions
GetInstructions (-) | Tableau zero-based des instructions
Insert (+) | Insère une instruction à une position donnée dans la liste

Properties
Property | Description
Count (+) | Nombre d'instructions
Instructions (+) | Tableau zero-based des instructions

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInstruction)
Next (TSepiInstructionRef)


Sepi

Sepi
Previous
Next

Name
FInstructions

Parent
TSepiInstructionList

Visibility
PRIVATE

Description
Instructions

Source code
FInstructions : TObjectList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Instructions)

Name
Count

Parent
TSepiInstructionList

Visibility
PUBLIC

Description
Nombre d'instructions

Source code
property Count : Integer read GetCount

Read Access
GetCount

Sepi
Class Tree
Index
Previous
Next (Instructions)


Sepi

Sepi
Previous (Count)
Next

Name
Instructions

Parent
TSepiInstructionList

Visibility
PUBLIC

Description
Tableau zero-based des instructions

Source code
property Instructions [ Index : Integer ] : TSepiInstruction read GetInstructions ; default

Read Access
GetInstructions

Sepi
Class Tree
Index
Previous (Count)
Next


Sepi

Sepi
Previous
Next (Create)

Name
ADD

Parent
TSepiInstructionList

Visibility
PUBLIC

Description
Ajoute une instruction à la fin de la liste

Source code
function Add ( Instruction : TSepiInstruction ) : Integer

Parameters
Parameter | Description
Instruction : TSepiInstruction | Instruction à ajouter

Return
Types | Description
INTEGER | Position de l'instruction dans la liste

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (ADD)
Next (CustomCompile)

Name
Create

Parent
TSepiInstructionList

Visibility
PUBLIC

Description
Crée une liste d'instructions

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (ADD)
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CustomCompile

Parent
TSepiInstructionList

Visibility
PROTECTED

Description
Compile les instructions

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CustomCompile)
Next (GetCount)

Name
Destroy

Parent
TSepiInstructionList

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CustomCompile)
Next (GetCount)


Sepi

Sepi
Previous (Destroy)
Next (GetCurrentEndRef)

Name
GetCount

Parent
TSepiInstructionList

Visibility
PRIVATE

Description
Nombre d'instructions

Source code
function GetCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'instructions dans la liste

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetCurrentEndRef)


Sepi

Sepi
Previous (GetCount)
Next (GetInstructions)

Name
GetCurrentEndRef

Parent
TSepiInstructionList

Visibility
PUBLIC

Description
Obtient une référence sur la fin courante de la liste d'instructions

Source code
function GetCurrentEndRef : TSepiInstructionRef

Parameters
Parameter Description

Return
Types | Description
TSepiInstructionRef | Référence sur la fin courante de la liste d'instructions

Sepi
Class Tree
Index
Previous (GetCount)
Next (GetInstructions)


Sepi

Sepi
Previous (GetCurrentEndRef)
Next (Insert)

Name
GetInstructions

Parent
TSepiInstructionList

Visibility
PRIVATE

Description
Tableau zero-based des instructions

Source code
function GetInstructions ( Index : Integer ) : TSepiInstruction

Parameters
Parameter | Description
INDEX : INTEGER | Index d'une instruction

Return
Types | Description
TSepiInstruction | L'instruction à l'index spécifié

Sepi
Class Tree
Index
Previous (GetCurrentEndRef)
Next (Insert)


Sepi

Sepi
Previous (GetInstructions)
Next

Name
Insert

Parent
TSepiInstructionList

Visibility
PUBLIC

Description
Insère une instruction à une position donnée dans la liste

Source code
procedure Insert ( Index : Integer ; Instruction : TSepiInstruction )

Parameters
Parameter | Description
INDEX : INTEGER | Index où insérer l'instruction
Instruction : TSepiInstruction | Instruction à insérer

Sepi
Class Tree
Index
Previous (GetInstructions)
Next


Sepi

Sepi
Previous (TSepiInstructionList)
Next (TSepiJumpDest)

Name
TSepiInstructionRef

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Référence à une instruction

Members
Fields
Field | Description
FInstructionIndex (-) | Position de l'instruction référencée
FMethodCompiler (-) | Compilateur

Methods
Method | Description
Create (+) | Crée une référence à une instruction
GetPosition (-) | Position de la référence
SetInstructionIndex (-) | Renseigne la position de l'instruction référencée

Properties
Property | Description
InstructionIndex (+) | Position de l'instruction référencée
MethodCompiler (+) | Compilateur
Position (+) | Position de la référence

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInstructionList)
Next (TSepiJumpDest)


Sepi

Sepi
Previous
Next (FMethodCompiler)

Name
FInstructionIndex

Parent
TSepiInstructionRef

Visibility
PRIVATE

Description
Position de l'instruction référencée

Source code
FInstructionIndex : Integer

Sepi
Class Tree
Index
Previous
Next (FMethodCompiler)


Sepi

Sepi
Previous (FInstructionIndex)
Next

Name
FMethodCompiler

Parent
TSepiInstructionRef

Visibility
PRIVATE

Description
Compilateur

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous (FInstructionIndex)
Next


Sepi

Sepi
Previous
Next (MethodCompiler)

Name
InstructionIndex

Parent
TSepiInstructionRef

Visibility
PUBLIC

Description
Position de l'instruction référencée

Source code
property InstructionIndex : Integer read FInstructionIndex

Read Access
FInstructionIndex

Sepi
Class Tree
Index
Previous
Next (MethodCompiler)


Sepi

Sepi
Previous (InstructionIndex)
Next (Position)

Name
MethodCompiler

Parent
TSepiInstructionRef

Visibility
PUBLIC

Description
Compilateur

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (InstructionIndex)
Next (Position)


Sepi

Sepi
Previous (MethodCompiler)
Next

Name
Position

Parent
TSepiInstructionRef

Visibility
PUBLIC

Description
Position de la référence

Source code
property Position : Integer read GetPosition

Read Access
GetPosition

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next


Sepi

Sepi
Previous
Next (GetPosition)

Name
Create

Parent
TSepiInstructionRef

Visibility
PUBLIC

Description
Crée une référence à une instruction

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (GetPosition)


Sepi

Sepi
Previous (Create)
Next (SetInstructionIndex)

Name
GetPosition

Parent
TSepiInstructionRef

Visibility
PRIVATE

Description
Position de la référence

Source code
function GetPosition : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Position de la référence

Sepi
Class Tree
Index
Previous (Create)
Next (SetInstructionIndex)


Sepi

Sepi
Previous (GetPosition)
Next

Name
SetInstructionIndex

Parent
TSepiInstructionRef

Visibility
PRIVATE

Description
Renseigne la position de l'instruction référencée

Source code
procedure SetInstructionIndex ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Position de l'instruction référencée

Sepi
Class Tree
Index
Previous (GetPosition)
Next


Sepi

Sepi
Previous (TSepiInstructionRef)
Next (TSepiLanguageRules)

Name
TSepiJumpDest

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Destination d'un JUMP Sepi

Members
Fields
Field | Description
FInstructionRef (-) | Ref à l'instruction destination
FMethodCompiler (-) | Compilateur de méthode

Methods
Method | Description
Create (+) | Crée une destination de JUMP
Make (+) | Construit la destination de Jump
MakeOffset (+) | Calcule l'offset
SetToLabel (+) | Position la destination du Jump sur un label nommé
SetToLabel (+) | Position la destination du Jump sur un label nommé
WriteToStream (+) | Ecrit la destination de JUMP dans un flux

Properties
Property | Description
InstructionRef (+) | Ref à l'instruction destination
MethodCompiler (+) | Compilateur de méthode

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInstructionRef)
Next (TSepiLanguageRules)


Sepi

Sepi
Previous
Next (FMethodCompiler)

Name
FInstructionRef

Parent
TSepiJumpDest

Visibility
PRIVATE

Description
Ref à l'instruction destination

Source code
FInstructionRef : TSepiInstructionRef

Sepi
Class Tree
Index
Previous
Next (FMethodCompiler)


Sepi

Sepi
Previous (FInstructionRef)
Next

Name
FMethodCompiler

Parent
TSepiJumpDest

Visibility
PRIVATE

Description
Compilateur de méthode

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous (FInstructionRef)
Next


Sepi

Sepi
Previous
Next (MethodCompiler)

Name
InstructionRef

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Ref à l'instruction destination

Source code
property InstructionRef : TSepiInstructionRef read FInstructionRef write FInstructionRef

Read Access
FInstructionRef

Write Access
FInstructionRef

Sepi
Class Tree
Index
Previous
Next (MethodCompiler)


Sepi

Sepi
Previous (InstructionRef)
Next

Name
MethodCompiler

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Compilateur de méthode

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (InstructionRef)
Next


Sepi

Sepi
Previous
Next (Make)

Name
Create

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Crée une destination de JUMP

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (Make)


Sepi

Sepi
Previous (Create)
Next (MakeOffset)

Name
Make

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Construit la destination de Jump

Source code
procedure Make

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (MakeOffset)


Sepi

Sepi
Previous (Make)
Next (SetToLabel)

Name
MakeOffset

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Calcule l'offset

Source code
function MakeOffset ( FromPos : Integer ) : Integer

Parameters
Parameter | Description
FromPos : INTEGER | Position de provenance

Return
Types | Description
INTEGER | Offset

Sepi
Class Tree
Index
Previous (Make)
Next (SetToLabel)


Sepi

Sepi
Previous (MakeOffset)
Next (SetToLabel)

Name
SetToLabel

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Position la destination du Jump sur un label nommé

Source code
procedure SetToLabel ( NamedLabel : TSepiNamedLabel ) ; overload

Parameters
Parameter | Description
NamedLabel : TSepiNamedLabel | Label nommé

Sepi
Class Tree
Index
Previous (MakeOffset)
Next (SetToLabel)


Sepi

Sepi
Previous (SetToLabel)
Next (WriteToStream)

Name
SetToLabel

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Position la destination du Jump sur un label nommé

Source code
procedure SetToLabel ( const LabelName : string ; Create : Boolean = False ) ; overload

Parameters
Parameter | Description
LabelName : STRING | Nom du label
Create : BOOLEAN

Sepi
Class Tree
Index
Previous (SetToLabel)
Next (WriteToStream)


Sepi

Sepi
Previous (SetToLabel)
Next

Name
WriteToStream

Parent
TSepiJumpDest

Visibility
PUBLIC

Description
Ecrit la destination de JUMP dans un flux

Source code
procedure WriteToStream ( Stream : TStream ; FromPos : Integer )

Parameters
Parameter | Description
Stream : TStream | Flux de destination
FromPos : INTEGER | Position de provenance

Sepi
Class Tree
Index
Previous (SetToLabel)
Next


Sepi

Sepi
Previous (TSepiJumpDest)
Next (TSepiLocalVar)

Name
TSepiLanguageRules

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Règles sémantiques d'un langage

Members
Fields
Field | Description
FSepiRoot (-) | Racine Sepi
FSystemUnit (-) | Unité System
FUnitCompiler (-) | Compilateur d'unité

Methods
Method | Description
ConvertionToOpenArrayExists (+) | Teste si une conversion vers un tableau ouvert existe
ConvertToOpenArray (+) | Convertit une expression en tableau ouvert
Create (+) | Crée de nouvelles règles de langage
FieldSelection (+) | Sélection de champ d'une expression
ResolveIdent (+) | Résoud un identificateur
ResolveIdentInMethod (+) | Résoud un identificateur dans le contexte d'une méthode

Properties
Property | Description
SepiRoot (+) | Racine Sepi
SystemUnit (+) | Unité System
UnitCompiler (+) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiJumpDest)
Next (TSepiLocalVar)


Sepi

Sepi
Previous
Next (FSystemUnit)

Name
FSepiRoot

Parent
TSepiLanguageRules

Visibility
PRIVATE

Description
Racine Sepi

Source code
FSepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous
Next (FSystemUnit)


Sepi

Sepi
Previous (FSepiRoot)
Next (FUnitCompiler)

Name
FSystemUnit

Parent
TSepiLanguageRules

Visibility
PRIVATE

Description
Unité System

Source code
FSystemUnit : TSepiSystemUnit

Sepi
Class Tree
Index
Previous (FSepiRoot)
Next (FUnitCompiler)


Sepi

Sepi
Previous (FSystemUnit)
Next

Name
FUnitCompiler

Parent
TSepiLanguageRules

Visibility
PRIVATE

Description
Compilateur d'unité

Source code
FUnitCompiler : TSepiUnitCompiler

Sepi
Class Tree
Index
Previous (FSystemUnit)
Next


Sepi

Sepi
Previous
Next (SystemUnit)

Name
SepiRoot

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read FSepiRoot

Read Access
FSepiRoot

Sepi
Class Tree
Index
Previous
Next (SystemUnit)


Sepi

Sepi
Previous (SepiRoot)
Next (UnitCompiler)

Name
SystemUnit

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Unité System

Source code
property SystemUnit : TSepiSystemUnit read FSystemUnit

Read Access
FSystemUnit

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (UnitCompiler)


Sepi

Sepi
Previous (SystemUnit)
Next

Name
UnitCompiler

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read FUnitCompiler

Read Access
FUnitCompiler

Sepi
Class Tree
Index
Previous (SystemUnit)
Next


Sepi

Sepi
Previous
Next (ConvertToOpenArray)

Name
ConvertionToOpenArrayExists

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Teste si une conversion vers un tableau ouvert existe

Source code
function ConvertionToOpenArrayExists ( ElementType : TSepiType ; const Expression : ISepiExpression ) : Boolean ; virtual

Parameters
Parameter | Description
ElementType : TSepiType | Type d'élément voulu pour le tableau ouvert
Expression : ISepiExpression | Expression à convertir

Return
Types | Description
BOOLEAN | True si Expression peut être convertie, False sinon

Sepi
Class Tree
Index
Previous
Next (ConvertToOpenArray)


Sepi

Sepi
Previous (ConvertionToOpenArrayExists)
Next (Create)

Name
ConvertToOpenArray

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Convertit une expression en tableau ouvert
ConvertToOpenArray ne peut être appelée que si ConvertionToOpenArrayExists
renvoie True pour les mêmes arguments.
L'expression renvoyée est garantie supporter l'interface
SepiExpressions.ISepiOpenArrayValue.

Source code
function ConvertToOpenArray ( ElementType : TSepiType ; const Expression : ISepiExpression ) : ISepiExpression ; virtual

Parameters
Parameter | Description
ElementType : TSepiType | Type d'élément voulu pour le tableau ouvert
Expression : ISepiExpression | Expression à convertir

Return
Types | Description
ISepiExpression | Expression convertie en tableau ouvert

Sepi
Class Tree
Index
Previous (ConvertionToOpenArrayExists)
Next (Create)


Sepi

Sepi
Previous (ConvertToOpenArray)
Next (FieldSelection)

Name
Create

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Crée de nouvelles règles de langage

Source code
constructor Create ( AUnitCompiler : TSepiUnitCompiler ) ; virtual

Parameters
Parameter | Description
AUnitCompiler : TSepiUnitCompiler | Compilateur d'unité

Sepi
Class Tree
Index
Previous (ConvertToOpenArray)
Next (FieldSelection)


Sepi

Sepi
Previous (Create)
Next (ResolveIdent)

Name
FieldSelection

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Sélection de champ d'une expression

Source code
function FieldSelection ( Context : TSepiComponent ; const BaseExpression : ISepiExpression ; const FieldName : string ) : ISepiExpression ; virtual ; abstract

Parameters
Parameter | Description
Context : TSepiComponent | Contexte Sepi depuis lequel chercher
BaseExpression : ISepiExpression | Expression de base
FieldName : STRING | Nom du champ

Return
Types | Description
ISepiExpression | Expression représentant le champ sélectionné (nil si inexistant)

Sepi
Class Tree
Index
Previous (Create)
Next (ResolveIdent)


Sepi

Sepi
Previous (FieldSelection)
Next (ResolveIdentInMethod)

Name
ResolveIdent

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Résoud un identificateur

Source code
function ResolveIdent ( Context : TSepiComponent ; const Identifier : string ) : ISepiExpression ; virtual ; abstract

Parameters
Parameter | Description
Context : TSepiComponent | Contexte dans lequel rechercher l'identificateur
Identifier : STRING | Identificateur recherché

Return
Types | Description
ISepiExpression | Expression représentant l'identificateur, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (FieldSelection)
Next (ResolveIdentInMethod)


Sepi

Sepi
Previous (ResolveIdent)
Next

Name
ResolveIdentInMethod

Parent
TSepiLanguageRules

Visibility
PUBLIC

Description
Résoud un identificateur dans le contexte d'une méthode

Source code
function ResolveIdentInMethod ( Compiler : TSepiMethodCompiler ; const Identifier : string ) : ISepiExpression ; virtual ; abstract

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | Compilateur de la méthode
Identifier : STRING | Identificateur recherché

Return
Types | Description
ISepiExpression | Expression représentant l'identificateur, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (ResolveIdent)
Next


Sepi

Sepi
Previous (TSepiLanguageRules)
Next (TSepiLocalVariables)

Name
TSepiLocalVar

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Variable locale d'une méthode Sepi

Members
Fields
Field | Description
FAbsolutes (-) | Variables calées sur celle-ci
FAbsoluteTo (-) | Variable sur laquelle se caler
FIsFixed (-) | Indique si sa position est fixée
FIsParam (-) | Indique si c'est un paramètre
FLife (-) | Vie de la variable (peut être vide)
FName (-) | Nom (peut être vide)
FOffset (-) | Offset
FParamKind (-) | Type de paramètre
FType (-) | Type de la variable

Methods
Method | Description
AddAbsolute (-) | Recense une variable qui est calée sur celle-ci
CompileLife (+) | Compile la vie de cette variable
CreateAbsolute (+) | Crée une variable calée sur une autre
CreateParam (+) | Crée une variable d'accès à un paramètre
CreateResult (+) | Crée la variable résultat d'une méthode
CreateTempVar (+) | Crée une nouvelle variable temporaire
CreateVar (+) | Crée une nouvelle variable locale
Destroy (+) | [@inheritDoc]
GetIsAbsolute (-) | Indique si la variable est calée sur une autre
GetIsConstant (-) | Indique si la variable est en lecture seule
GetIsLifeHandled (-) | Indique si la vie de cette variable est gérée
GetIsLifeShared (-) | Indique si la vie de cette variable est partagée avec une autre
GetNeedDereference (-) | Indique si la variable doit être déréférencée pour y accéder
HandleLife (+) | Commence la gestion de la vie de cette variable
InterfereWith (+) | Teste si cette variable interfère avec une autre
SetLife (-) | Renseigne la vie de la variable
SetOffset (+) | Renseigne l'offset de cette variable

Properties
Property | Description
AbsoluteTo (+) | Variable sur laquelle se caler
IsAbsolute (+) | Indique si la variable est calée sur une autre
IsConstant (+) | Indique si la variable est en lecture seule
IsFixed (+) | Indique si sa position est fixée
IsLifeHandled (+) | Indique si la vie de cette variable est gérée
IsLifeShared (+) | Indique si la vie de cette variable est partagée avec une autre
IsParam (+) | Indique si c'est un paramètre
Life (+) | Vie de la variable (peut être vide)
NAME (+) | Nom (peut être vide)
NeedDereference (+) | Indique si la variable doit être déréférencée pour y accéder
OFFSET (+) | Offset
ParamKind (+) | Type de paramètre
VarType (+) | Type de la variable

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLanguageRules)
Next (TSepiLocalVariables)


Sepi

Sepi
Previous
Next (FAbsoluteTo)

Name
FAbsolutes

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Variables calées sur celle-ci

Source code
FAbsolutes : array of TSepiLocalVar

Sepi
Class Tree
Index
Previous
Next (FAbsoluteTo)


Sepi

Sepi
Previous (FAbsolutes)
Next (FIsFixed)

Name
FAbsoluteTo

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Variable sur laquelle se caler

Source code
FAbsoluteTo : TSepiLocalVar

Sepi
Class Tree
Index
Previous (FAbsolutes)
Next (FIsFixed)


Sepi

Sepi
Previous (FAbsoluteTo)
Next (FIsParam)

Name
FIsFixed

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Indique si sa position est fixée

Source code
FIsFixed : Boolean

Sepi
Class Tree
Index
Previous (FAbsoluteTo)
Next (FIsParam)


Sepi

Sepi
Previous (FIsFixed)
Next (FLife)

Name
FIsParam

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Indique si c'est un paramètre

Source code
FIsParam : Boolean

Sepi
Class Tree
Index
Previous (FIsFixed)
Next (FLife)


Sepi

Sepi
Previous (FIsParam)
Next (FName)

Name
FLife

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Vie de la variable (peut être vide)

Source code
FLife : TSepiLocalVarLife

Sepi
Class Tree
Index
Previous (FIsParam)
Next (FName)


Sepi

Sepi
Previous (FLife)
Next (FOffset)

Name
FName

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Nom (peut être vide)

Source code
FName : string

Sepi
Class Tree
Index
Previous (FLife)
Next (FOffset)


Sepi

Sepi
Previous (FName)
Next (FParamKind)

Name
FOffset

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Offset

Source code
FOffset : Integer

Sepi
Class Tree
Index
Previous (FName)
Next (FParamKind)


Sepi

Sepi
Previous (FOffset)
Next (FType)

Name
FParamKind

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Type de paramètre

Source code
FParamKind : TSepiParamKind

Sepi
Class Tree
Index
Previous (FOffset)
Next (FType)


Sepi

Sepi
Previous (FParamKind)
Next

Name
FType

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Type de la variable

Source code
FType : TSepiType

Sepi
Class Tree
Index
Previous (FParamKind)
Next


Sepi

Sepi
Previous
Next (IsAbsolute)

Name
AbsoluteTo

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Variable sur laquelle se caler

Source code
property AbsoluteTo : TSepiLocalVar read FAbsoluteTo

Read Access
FAbsoluteTo

Sepi
Class Tree
Index
Previous
Next (IsAbsolute)


Sepi

Sepi
Previous (AbsoluteTo)
Next (IsConstant)

Name
IsAbsolute

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Indique si la variable est calée sur une autre

Source code
property IsAbsolute : Boolean read GetIsAbsolute

Read Access
GetIsAbsolute

Sepi
Class Tree
Index
Previous (AbsoluteTo)
Next (IsConstant)


Sepi

Sepi
Previous (IsAbsolute)
Next (IsFixed)

Name
IsConstant

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Indique si la variable est en lecture seule

Source code
property IsConstant : Boolean read GetIsConstant

Read Access
GetIsConstant

Sepi
Class Tree
Index
Previous (IsAbsolute)
Next (IsFixed)


Sepi

Sepi
Previous (IsConstant)
Next (IsLifeHandled)

Name
IsFixed

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Indique si sa position est fixée

Source code
property IsFixed : Boolean read FIsFixed

Read Access
FIsFixed

Sepi
Class Tree
Index
Previous (IsConstant)
Next (IsLifeHandled)


Sepi

Sepi
Previous (IsFixed)
Next (IsLifeShared)

Name
IsLifeHandled

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Indique si la vie de cette variable est gérée

Source code
property IsLifeHandled : Boolean read GetIsLifeHandled

Read Access
GetIsLifeHandled

Sepi
Class Tree
Index
Previous (IsFixed)
Next (IsLifeShared)


Sepi

Sepi
Previous (IsLifeHandled)
Next (IsParam)

Name
IsLifeShared

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Indique si la vie de cette variable est partagée avec une autre

Source code
property IsLifeShared : Boolean read GetIsLifeShared

Read Access
GetIsLifeShared

Sepi
Class Tree
Index
Previous (IsLifeHandled)
Next (IsParam)


Sepi

Sepi
Previous (IsLifeShared)
Next (Life)

Name
IsParam

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Indique si c'est un paramètre

Source code
property IsParam : Boolean read FIsParam

Read Access
FIsParam

Sepi
Class Tree
Index
Previous (IsLifeShared)
Next (Life)


Sepi

Sepi
Previous (IsParam)
Next (NAME)

Name
Life

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Vie de la variable (peut être vide)

Source code
property Life : TSepiLocalVarLife read FLife

Read Access
FLife

Sepi
Class Tree
Index
Previous (IsParam)
Next (NAME)


Sepi

Sepi
Previous (Life)
Next (NeedDereference)

Name
NAME

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Nom (peut être vide)

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (Life)
Next (NeedDereference)


Sepi

Sepi
Previous (NAME)
Next (OFFSET)

Name
NeedDereference

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Indique si la variable doit être déréférencée pour y accéder

Source code
property NeedDereference : Boolean read GetNeedDereference

Read Access
GetNeedDereference

Sepi
Class Tree
Index
Previous (NAME)
Next (OFFSET)


Sepi

Sepi
Previous (NeedDereference)
Next (ParamKind)

Name
OFFSET

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Offset

Source code
property Offset : Integer read FOffset

Read Access
FOffset

Sepi
Class Tree
Index
Previous (NeedDereference)
Next (ParamKind)


Sepi

Sepi
Previous (OFFSET)
Next (VarType)

Name
ParamKind

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Type de paramètre

Source code
property ParamKind : TSepiParamKind read FParamKind

Read Access
FParamKind

Sepi
Class Tree
Index
Previous (OFFSET)
Next (VarType)


Sepi

Sepi
Previous (ParamKind)
Next

Name
VarType

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Type de la variable

Source code
property VarType : TSepiType read FType

Read Access
FType

Sepi
Class Tree
Index
Previous (ParamKind)
Next


Sepi

Sepi
Previous
Next (CompileLife)

Name
AddAbsolute

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Recense une variable qui est calée sur celle-ci

Source code
procedure AddAbsolute ( AbsVar : TSepiLocalVar )

Parameters
Parameter | Description
AbsVar : TSepiLocalVar | Variable à recenser

Sepi
Class Tree
Index
Previous
Next (CompileLife)


Sepi

Sepi
Previous (AddAbsolute)
Next (CreateAbsolute)

Name
CompileLife

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Compile la vie de cette variable

Source code
procedure CompileLife

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddAbsolute)
Next (CreateAbsolute)


Sepi

Sepi
Previous (CompileLife)
Next (CreateParam)

Name
CreateAbsolute

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Crée une variable calée sur une autre
Une variable calée sur une autre aura le même offset que celle-ci, quels que
soit leurs types respectifs. Leurs lignes de vies sont combinées, et
l'initialisation/finalisation du type de la variable calée n'est jamais prise
en compte.

Source code
constructor CreateAbsolute ( const AName : string ; AType : TSepiType ; AAbsoluteTo : TSepiLocalVar )

Parameters
Parameter | Description
AName : STRING | Nom
AType : TSepiType | Type
AAbsoluteTo : TSepiLocalVar | Variable sur laquelle se caler

Sepi
Class Tree
Index
Previous (CompileLife)
Next (CreateParam)


Sepi

Sepi
Previous (CreateAbsolute)
Next (CreateResult)

Name
CreateParam

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Crée une variable d'accès à un paramètre

Source code
constructor CreateParam ( Param : TSepiParam )

Parameters
Parameter | Description
Param : TSepiParam | Paramètre à accéder

Sepi
Class Tree
Index
Previous (CreateAbsolute)
Next (CreateResult)


Sepi

Sepi
Previous (CreateParam)
Next (CreateTempVar)

Name
CreateResult

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Crée la variable résultat d'une méthode

Source code
constructor CreateResult ( AType : TSepiType )

Parameters
Parameter | Description
AType : TSepiType | Type de retour

Sepi
Class Tree
Index
Previous (CreateParam)
Next (CreateTempVar)


Sepi

Sepi
Previous (CreateResult)
Next (CreateVar)

Name
CreateTempVar

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Crée une nouvelle variable temporaire

Source code
constructor CreateTempVar ( AType : TSepiType )

Parameters
Parameter | Description
AType : TSepiType | Type

Sepi
Class Tree
Index
Previous (CreateResult)
Next (CreateVar)


Sepi

Sepi
Previous (CreateTempVar)
Next (Destroy)

Name
CreateVar

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Crée une nouvelle variable locale

Source code
constructor CreateVar ( const AName : string ; AType : TSepiType )

Parameters
Parameter | Description
AName : STRING | Nom
AType : TSepiType | Type

Sepi
Class Tree
Index
Previous (CreateTempVar)
Next (Destroy)


Sepi

Sepi
Previous (CreateVar)
Next (GetIsAbsolute)

Name
Destroy

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateVar)
Next (GetIsAbsolute)


Sepi

Sepi
Previous (Destroy)
Next (GetIsConstant)

Name
GetIsAbsolute

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Indique si la variable est calée sur une autre

Source code
function GetIsAbsolute : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si elle est calée sur une autre, False sinon

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetIsAbsolute)
Next (GetIsLifeHandled)

Name
GetIsConstant

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Indique si la variable est en lecture seule

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si elle est en lecture seule, False sinon

Sepi
Class Tree
Index
Previous (GetIsAbsolute)
Next (GetIsLifeHandled)


Sepi

Sepi
Previous (GetIsConstant)
Next (GetIsLifeShared)

Name
GetIsLifeHandled

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Indique si la vie de cette variable est gérée

Source code
function GetIsLifeHandled : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si sa vie est gérée, False sinon

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (GetIsLifeShared)


Sepi

Sepi
Previous (GetIsLifeHandled)
Next (GetNeedDereference)

Name
GetIsLifeShared

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Indique si la vie de cette variable est partagée avec une autre
Seules les vies de variables calées les unes sur les autres sont partagées.
Si vous écrivez une analyse de vie dans votre compilateur, tenez compte de
cette information, sous peine de rater votre analyse, et donc de corrompre la
compilation.

Source code
function GetIsLifeShared : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si sa vie est partagée, False sinon

Sepi
Class Tree
Index
Previous (GetIsLifeHandled)
Next (GetNeedDereference)


Sepi

Sepi
Previous (GetIsLifeShared)
Next (HandleLife)

Name
GetNeedDereference

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Indique si la variable doit être déréférencée pour y accéder
Les variables qui doivent être déréférencées sont les paramètres qui sont
transmis par adresse, et eux seuls.

Source code
function GetNeedDereference : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si elle doit être déréférencée, False sinon

Sepi
Class Tree
Index
Previous (GetIsLifeShared)
Next (HandleLife)


Sepi

Sepi
Previous (GetNeedDereference)
Next (InterfereWith)

Name
HandleLife

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Commence la gestion de la vie de cette variable

Source code
procedure HandleLife

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetNeedDereference)
Next (InterfereWith)


Sepi

Sepi
Previous (HandleLife)
Next (SetLife)

Name
InterfereWith

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Teste si cette variable interfère avec une autre
Deux variables qui interfèrent entre elles ne peuvent être positionnée au
même offset dans les variables locales.

Source code
function InterfereWith ( Other : TSepiLocalVar ) : Boolean

Parameters
Parameter | Description
Other : TSepiLocalVar | Variable avec laquelle comparer

Return
Types | Description
BOOLEAN | True si les variables interfèrent, False sinon

Sepi
Class Tree
Index
Previous (HandleLife)
Next (SetLife)


Sepi

Sepi
Previous (InterfereWith)
Next (SetOffset)

Name
SetLife

Parent
TSepiLocalVar

Visibility
PRIVATE

Description
Renseigne la vie de la variable
Pour une variable sur laquelle sont calées d'autres, ces dernières sont
également notifiées de cette affectation.

Source code
procedure SetLife ( ALife : TSepiLocalVarLife )

Parameters
Parameter | Description
ALife : TSepiLocalVarLife | Vie de la variable

Sepi
Class Tree
Index
Previous (InterfereWith)
Next (SetOffset)


Sepi

Sepi
Previous (SetLife)
Next

Name
SetOffset

Parent
TSepiLocalVar

Visibility
PUBLIC

Description
Renseigne l'offset de cette variable
Pour les variables sur lesquelles sont calées d'autres, celles-ci sont
également notifiées de cette affectation.

Source code
procedure SetOffset ( AOffset : Integer )

Parameters
Parameter | Description
AOffset : INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetLife)
Next


Sepi

Sepi
Previous (TSepiLocalVar)
Next (TSepiLocalVarLife)

Name
TSepiLocalVariables

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Variables locales d'une méthode Sepi

Members
Fields
Field | Description
FCompiler (-) | Compilateur de méthode
FInitInfo (-) | Informations d'initialisation
FSize (-) | Taille des variables locales
FVariables (-) | Variables

Methods
Method | Description
AddAbsolute (+) | Ajoute une variable callée sur une autre
AddFromSignature (+) | Ajoute toutes les variables correspondant à une signature
AddLocalVar (+) | Ajoute une variable locale
AddLocalVar (+) | Ajoute une variable locale
AddLocalVar (+) | Ajoute une variable locale
AddTempVar (+) | Ajoute une variable temporaire
AllocateOffsets (-) | Alloue l'espace mémoire pour les variables locales et renseigne leurs offsets
Compile (+) | Compile les variables locales et leur donne des offsets
Create (+) | Crée les variables locales d'une méthode
Destroy (+) | [@inheritDoc]
GetCount (-) | Nombre de variables
GetHiddenVar (-) | Tableau des variables cachées indicées par le type de paramètre caché
GetVarByName (+) | Récupère une variable locale par son nom
GetVariables (-) | Tableau zero-based des variables
MakeInitInfo (-) | Construit les informations d'initialisation/finalisation
WriteInitInfo (+) | Ecrit les informations d'initialisation des variables locales

Properties
Property | Description
Compiler (+) | Compilateur de méthode
Count (+) | Nombre de variables
ResultVar (+) | Tableau des variables cachées indicées par le type de paramètre caché
SelfVar (+) | Tableau des variables cachées indicées par le type de paramètre caché
Size (+) | Taille des variables locales
Variables (+) | Tableau zero-based des variables

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLocalVar)
Next (TSepiLocalVarLife)


Sepi

Sepi
Previous
Next (FInitInfo)

Name
FCompiler

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Compilateur de méthode

Source code
FCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous
Next (FInitInfo)


Sepi

Sepi
Previous (FCompiler)
Next (FSize)

Name
FInitInfo

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Informations d'initialisation

Source code
FInitInfo : array of TLocalInitInfo

Sepi
Class Tree
Index
Previous (FCompiler)
Next (FSize)


Sepi

Sepi
Previous (FInitInfo)
Next (FVariables)

Name
FSize

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Taille des variables locales

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FInitInfo)
Next (FVariables)


Sepi

Sepi
Previous (FSize)
Next

Name
FVariables

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Variables

Source code
FVariables : TObjectList

Sepi
Class Tree
Index
Previous (FSize)
Next


Sepi

Sepi
Previous
Next (Count)

Name
Compiler

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Compilateur de méthode

Source code
property Compiler : TSepiMethodCompiler read FCompiler

Read Access
FCompiler

Sepi
Class Tree
Index
Previous
Next (Count)


Sepi

Sepi
Previous (Compiler)
Next (ResultVar)

Name
Count

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Nombre de variables

Source code
property Count : Integer read GetCount

Read Access
GetCount

Sepi
Class Tree
Index
Previous (Compiler)
Next (ResultVar)


Sepi

Sepi
Previous (Count)
Next (SelfVar)

Name
ResultVar

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Tableau des variables cachées indicées par le type de paramètre caché

Source code
property ResultVar : TSepiLocalVar index hpResult read GetHiddenVar

Read Access
GetHiddenVar

Sepi
Class Tree
Index
Previous (Count)
Next (SelfVar)


Sepi

Sepi
Previous (ResultVar)
Next (Size)

Name
SelfVar

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Tableau des variables cachées indicées par le type de paramètre caché

Source code
property SelfVar : TSepiLocalVar index hpSelf read GetHiddenVar

Read Access
GetHiddenVar

Sepi
Class Tree
Index
Previous (ResultVar)
Next (Size)


Sepi

Sepi
Previous (SelfVar)
Next (Variables)

Name
Size

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Taille des variables locales

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (SelfVar)
Next (Variables)


Sepi

Sepi
Previous (Size)
Next

Name
Variables

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Tableau zero-based des variables

Source code
property Variables [ Index : Integer ] : TSepiLocalVar read GetVariables ; default

Read Access
GetVariables

Sepi
Class Tree
Index
Previous (Size)
Next


Sepi

Sepi
Previous
Next (AddFromSignature)

Name
AddAbsolute

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Ajoute une variable callée sur une autre

Source code
function AddAbsolute ( const AName : string ; AType : TSepiType ; AAbsoluteTo : TSepiLocalVar ) : TSepiLocalVar

Parameters
Parameter | Description
AName : STRING | Nom de la variable
AType : TSepiType | Type de la variable
AAbsoluteTo : TSepiLocalVar | Variable sur laquelle se caller

Return
Types | Description
TSepiLocalVar | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AddFromSignature)


Sepi

Sepi
Previous (AddAbsolute)
Next (AddLocalVar)

Name
AddFromSignature

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Ajoute toutes les variables correspondant à une signature

Source code
procedure AddFromSignature ( Signature : TSepiSignature )

Parameters
Parameter | Description
Signature : TSepiSignature | Signature

Sepi
Class Tree
Index
Previous (AddAbsolute)
Next (AddLocalVar)


Sepi

Sepi
Previous (AddFromSignature)
Next (AddLocalVar)

Name
AddLocalVar

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Ajoute une variable locale

Source code
function AddLocalVar ( const AName : string ; AType : TSepiType ) : TSepiLocalVar ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la variable
AType : TSepiType | Type de la variable

Return
Types | Description
TSepiLocalVar | Variable créée

Sepi
Class Tree
Index
Previous (AddFromSignature)
Next (AddLocalVar)


Sepi

Sepi
Previous (AddLocalVar)
Next (AddLocalVar)

Name
AddLocalVar

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Ajoute une variable locale

Source code
function AddLocalVar ( const AName : string ; ATypeInfo : PTypeInfo ) : TSepiLocalVar ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la variable
ATypeInfo : PTypeInfo | RTTI du type de la variable

Return
Types | Description
TSepiLocalVar | Variable créée

Sepi
Class Tree
Index
Previous (AddLocalVar)
Next (AddLocalVar)


Sepi

Sepi
Previous (AddLocalVar)
Next (AddTempVar)

Name
AddLocalVar

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Ajoute une variable locale

Source code
function AddLocalVar ( const AName : string ; const ATypeName : string ) : TSepiLocalVar ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la variable
ATypeName : STRING

Return
Types | Description
TSepiLocalVar | Variable créée

Sepi
Class Tree
Index
Previous (AddLocalVar)
Next (AddTempVar)


Sepi

Sepi
Previous (AddLocalVar)
Next (AllocateOffsets)

Name
AddTempVar

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Ajoute une variable temporaire

Source code
function AddTempVar ( AType : TSepiType ) : TSepiLocalVar

Parameters
Parameter | Description
AType : TSepiType | Type de la variable

Return
Types | Description
TSepiLocalVar | Variable créée

Sepi
Class Tree
Index
Previous (AddLocalVar)
Next (AllocateOffsets)


Sepi

Sepi
Previous (AddTempVar)
Next (Compile)

Name
AllocateOffsets

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Alloue l'espace mémoire pour les variables locales et renseigne leurs offsets
Cette méthode renseigne également la propriété Size.

Source code
procedure AllocateOffsets

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddTempVar)
Next (Compile)


Sepi

Sepi
Previous (AllocateOffsets)
Next (Create)

Name
Compile

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Compile les variables locales et leur donne des offsets

Source code
procedure Compile

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AllocateOffsets)
Next (Create)


Sepi

Sepi
Previous (Compile)
Next (Destroy)

Name
Create

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Crée les variables locales d'une méthode

Source code
constructor Create ( ACompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
ACompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (Compile)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetCount)

Name
Destroy

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetCount)


Sepi

Sepi
Previous (Destroy)
Next (GetHiddenVar)

Name
GetCount

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Nombre de variables

Source code
function GetCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de variables

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetHiddenVar)


Sepi

Sepi
Previous (GetCount)
Next (GetVarByName)

Name
GetHiddenVar

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Tableau des variables cachées indicées par le type de paramètre caché

Source code
function GetHiddenVar ( Kind : TSepiHiddenParamKind ) : TSepiLocalVar

Parameters
Parameter | Description
Kind : TSepiHiddenParamKind | Type de paramètre caché

Return
Types | Description
TSepiLocalVar | Variable correspondante

Sepi
Class Tree
Index
Previous (GetCount)
Next (GetVarByName)


Sepi

Sepi
Previous (GetHiddenVar)
Next (GetVariables)

Name
GetVarByName

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Récupère une variable locale par son nom

Source code
function GetVarByName ( const Name : string ) : TSepiLocalVar

Parameters
Parameter | Description
NAME : STRING | Nom de la variable recherchée

Return
Types | Description
TSepiLocalVar | Variable correspondante, ou nil si non trouvée

Sepi
Class Tree
Index
Previous (GetHiddenVar)
Next (GetVariables)


Sepi

Sepi
Previous (GetVarByName)
Next (MakeInitInfo)

Name
GetVariables

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Tableau zero-based des variables

Source code
function GetVariables ( Index : Integer ) : TSepiLocalVar

Parameters
Parameter | Description
INDEX : INTEGER | Index d'une variable

Return
Types | Description
TSepiLocalVar | Variable à l'index spécifié

Sepi
Class Tree
Index
Previous (GetVarByName)
Next (MakeInitInfo)


Sepi

Sepi
Previous (GetVariables)
Next (WriteInitInfo)

Name
MakeInitInfo

Parent
TSepiLocalVariables

Visibility
PRIVATE

Description
Construit les informations d'initialisation/finalisation

Source code
procedure MakeInitInfo

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetVariables)
Next (WriteInitInfo)


Sepi

Sepi
Previous (MakeInitInfo)
Next

Name
WriteInitInfo

Parent
TSepiLocalVariables

Visibility
PUBLIC

Description
Ecrit les informations d'initialisation des variables locales

Source code
procedure WriteInitInfo ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux de destination

Sepi
Class Tree
Index
Previous (MakeInitInfo)
Next


Sepi

Sepi
Previous (TSepiLocalVariables)
Next (TSepiMemoryReference)

Name
TSepiLocalVarLife

Parent
SepiCompiler

Class Hierarchy
TScIntegerSet

Visibility
PUBLIC

Description
Vie d'une variable locale

Members
Fields
Field | Description
FBegunAt (-) | Commencement de l'intervalle à compléter
FInstrIntervals (-) | Tableau des intervalles d'instructions en attente de compilation

Methods
Method | Description
AddInstrInterval (+) | Ajoute un intervalle d'instructions
BeginInstrInterval (+) | Commence un intervalle de vie
Compile (+) | Compile les références d'instructions en leurs positions
Create (+) | Crée la vie d'une variable locale
EndInstrInterval (+) | Termine un intervalle de vie commencé avec BeginInstrInterval
InterfereWith (+) | Teste si cette vie interfère avec une autre

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLocalVariables)
Next (TSepiMemoryReference)


Sepi

Sepi
Previous
Next (FInstrIntervals)

Name
FBegunAt

Parent
TSepiLocalVarLife

Visibility
PRIVATE

Description
Commencement de l'intervalle à compléter

Source code
FBegunAt : TSepiInstructionRef

Sepi
Class Tree
Index
Previous
Next (FInstrIntervals)


Sepi

Sepi
Previous (FBegunAt)
Next

Name
FInstrIntervals

Parent
TSepiLocalVarLife

Visibility
PRIVATE

Description
Tableau des intervalles d'instructions en attente de compilation

Source code
FInstrIntervals : array of TSepiInstructionRef

Sepi
Class Tree
Index
Previous (FBegunAt)
Next


Sepi

Sepi
Previous
Next (BeginInstrInterval)

Name
AddInstrInterval

Parent
TSepiLocalVarLife

Visibility
PUBLIC

Description
Ajoute un intervalle d'instructions

Source code
procedure AddInstrInterval ( BeginAt , EndAt : TSepiInstructionRef )

Parameters
Parameter | Description
BeginAt : TSepiInstructionRef | Début de l'intervalle
EndAt : TSepiInstructionRef | Fin de l'intervalle

Sepi
Class Tree
Index
Previous
Next (BeginInstrInterval)


Sepi

Sepi
Previous (AddInstrInterval)
Next (Compile)

Name
BeginInstrInterval

Parent
TSepiLocalVarLife

Visibility
PUBLIC

Description
Commence un intervalle de vie
L'intervalle devra être terminé avec EndInstrInterval.

Source code
procedure BeginInstrInterval ( At : TSepiInstructionRef )

Parameters
Parameter | Description
AT : TSepiInstructionRef | Début de l'intervalle

Sepi
Class Tree
Index
Previous (AddInstrInterval)
Next (Compile)


Sepi

Sepi
Previous (BeginInstrInterval)
Next (Create)

Name
Compile

Parent
TSepiLocalVarLife

Visibility
PUBLIC

Description
Compile les références d'instructions en leurs positions

Source code
procedure Compile

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeginInstrInterval)
Next (Create)


Sepi

Sepi
Previous (Compile)
Next (EndInstrInterval)

Name
Create

Parent
TSepiLocalVarLife

Visibility
PUBLIC

Description
Crée la vie d'une variable locale

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Compile)
Next (EndInstrInterval)


Sepi

Sepi
Previous (Create)
Next (InterfereWith)

Name
EndInstrInterval

Parent
TSepiLocalVarLife

Visibility
PUBLIC

Description
Termine un intervalle de vie commencé avec BeginInstrInterval

Source code
procedure EndInstrInterval ( At : TSepiInstructionRef )

Parameters
Parameter | Description
AT : TSepiInstructionRef | Fin de l'intervalle

Sepi
Class Tree
Index
Previous (Create)
Next (InterfereWith)


Sepi

Sepi
Previous (EndInstrInterval)
Next

Name
InterfereWith

Parent
TSepiLocalVarLife

Visibility
PUBLIC

Description
Teste si cette vie interfère avec une autre

Source code
function InterfereWith ( Other : TSepiLocalVarLife ) : Boolean

Parameters
Parameter | Description
Other : TSepiLocalVarLife | Vie à comparer

Return
Types | Description
BOOLEAN | True si les vies interfèrent entre elles, False sinon

Sepi
Class Tree
Index
Previous (EndInstrInterval)
Next


Sepi

Sepi
Previous (TSepiLocalVarLife)
Next (TSepiMethodCompiler)

Name
TSepiMemoryReference

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Référence à un emplacement mémoire

Members
Fields
Field | Description
FConstant (-) | Constante (si Space = msConstant) - 0 par défaut
FConstSize (-) | Taille d'une constante
FIsSealed (-) | Indique si la référence est scellée
FMethodCompiler (-) | Compilateur de méthode
FOperations (-) | Opérations
FOptions (-) | Options
FSize (-) | Taille de la référence mémoire dans le code
FSpace (-) | Espace d'adressage
FSpaceArgument (-) | Argument de l'espace d'adressage (offset)
FUnresolvedLocalVar (-) | Variable locale non résolue

Methods
Method | Description
AddOperation (+) | Ajoute un déréférencement
AddOperation (+) | Ajoute une opération
AddOperation (+) | Ajoute un déréférencement et une opération
Assign (+) | Recopie depuis une référence mémoire
CanRemoveDereference (+) | Teste s'il est possible de retirer un déréférencement à la fin
CheckUnsealed (-) | Vérifie que la référence mémoire n'est pas scellée
ClearOperations (+) | Supprime toutes les opérations
Clone (+) | Construit une copie d'une référence mémoire
Create (+) | Crée une nouvelle référence mémoire
Destroy (+) | [@inheritDoc]
GetConstant (+) | Récupère la constante
GetOperationCount (-) | Nombre d'opérations
GetOperations (-) | Tableau zero-based des opérations
Make (+) | Construit la référence mémoire
RemoveDereference (+) | Retire le déréférencement en bout d'opérations
Seal (+) | Scelle la référence mémoire
SetAsConst (+) | Assigne la référence mémoire à une constante booléenne
SetAsConst (+) | Assigne la référence mémoire à une constante entière
SetAsConst (+) | Assigne la référence mémoire à une constante Currency
SetAsConst (+) | Assigne la référence mémoire à une constante flottante
SetConstant (+) | Spécifie la constante
SetSpace (+) | Modifie l'espace mémoire sur base d'une variable locale
SetSpace (+) | Modifie l'espace mémoire
SetSpace (+) | Modifie l'espace mémoire sur base d'une vraie constante
SetSpace (+) | Modifie l'espace mémoire sur base d'un nom, qui est d'abord recherché
SetSpace (+) | Modifie l'espace mémoire sur base d'une variable globale
WriteToStream (+) | Ecrit la référence mémoire dans un flux

Properties
Property | Description
ConstSize (+) | Taille d'une constante
IsSealed (+) | Indique si la référence est scellée
MethodCompiler (+) | Compilateur de méthode
OperationCount (+) | Nombre d'opérations
Operations (+) | Tableau zero-based des opérations
Options (+) | Options
Size (+) | Taille de la référence mémoire dans le code
Space (+) | Espace d'adressage
SpaceArgument (+) | Argument de l'espace d'adressage (offset)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLocalVarLife)
Next (TSepiMethodCompiler)


Sepi

Sepi
Previous
Next (FConstSize)

Name
FConstant

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Constante (si Space = msConstant) - 0 par défaut

Source code
FConstant : Pointer

Sepi
Class Tree
Index
Previous
Next (FConstSize)


Sepi

Sepi
Previous (FConstant)
Next (FIsSealed)

Name
FConstSize

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Taille d'une constante

Source code
FConstSize : Integer

Sepi
Class Tree
Index
Previous (FConstant)
Next (FIsSealed)


Sepi

Sepi
Previous (FConstSize)
Next (FMethodCompiler)

Name
FIsSealed

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Indique si la référence est scellée

Source code
FIsSealed : Boolean

Sepi
Class Tree
Index
Previous (FConstSize)
Next (FMethodCompiler)


Sepi

Sepi
Previous (FIsSealed)
Next (FOperations)

Name
FMethodCompiler

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Compilateur de méthode

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous (FIsSealed)
Next (FOperations)


Sepi

Sepi
Previous (FMethodCompiler)
Next (FOptions)

Name
FOperations

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Opérations

Source code
FOperations : array of TSepiAddressDerefAndOpRec

Sepi
Class Tree
Index
Previous (FMethodCompiler)
Next (FOptions)


Sepi

Sepi
Previous (FOperations)
Next (FSize)

Name
FOptions

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Options

Source code
FOptions : TSepiAddressOptions

Sepi
Class Tree
Index
Previous (FOperations)
Next (FSize)


Sepi

Sepi
Previous (FOptions)
Next (FSpace)

Name
FSize

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Taille de la référence mémoire dans le code

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FOptions)
Next (FSpace)


Sepi

Sepi
Previous (FSize)
Next (FSpaceArgument)

Name
FSpace

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Espace d'adressage

Source code
FSpace : TSepiMemorySpace

Sepi
Class Tree
Index
Previous (FSize)
Next (FSpaceArgument)


Sepi

Sepi
Previous (FSpace)
Next (FUnresolvedLocalVar)

Name
FSpaceArgument

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Argument de l'espace d'adressage (offset)

Source code
FSpaceArgument : Integer

Sepi
Class Tree
Index
Previous (FSpace)
Next (FUnresolvedLocalVar)


Sepi

Sepi
Previous (FSpaceArgument)
Next

Name
FUnresolvedLocalVar

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Variable locale non résolue

Source code
FUnresolvedLocalVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous (FSpaceArgument)
Next


Sepi

Sepi
Previous
Next (IsSealed)

Name
ConstSize

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Taille d'une constante

Source code
property ConstSize : Integer read FConstSize

Read Access
FConstSize

Sepi
Class Tree
Index
Previous
Next (IsSealed)


Sepi

Sepi
Previous (ConstSize)
Next (MethodCompiler)

Name
IsSealed

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Indique si la référence est scellée

Source code
property IsSealed : Boolean read FIsSealed

Read Access
FIsSealed

Sepi
Class Tree
Index
Previous (ConstSize)
Next (MethodCompiler)


Sepi

Sepi
Previous (IsSealed)
Next (OperationCount)

Name
MethodCompiler

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Compilateur de méthode

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (IsSealed)
Next (OperationCount)


Sepi

Sepi
Previous (MethodCompiler)
Next (Operations)

Name
OperationCount

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Nombre d'opérations

Source code
property OperationCount : Integer read GetOperationCount

Read Access
GetOperationCount

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next (Operations)


Sepi

Sepi
Previous (OperationCount)
Next (Options)

Name
Operations

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Tableau zero-based des opérations

Source code
property Operations [ Index : Integer ] : TSepiAddressDerefAndOpRec read GetOperations

Read Access
GetOperations

Sepi
Class Tree
Index
Previous (OperationCount)
Next (Options)


Sepi

Sepi
Previous (Operations)
Next (Size)

Name
Options

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Options

Source code
property Options : TSepiAddressOptions read FOptions

Read Access
FOptions

Sepi
Class Tree
Index
Previous (Operations)
Next (Size)


Sepi

Sepi
Previous (Options)
Next (Space)

Name
Size

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Taille de la référence mémoire dans le code

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (Options)
Next (Space)


Sepi

Sepi
Previous (Size)
Next (SpaceArgument)

Name
Space

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Espace d'adressage

Source code
property Space : TSepiMemorySpace read FSpace

Read Access
FSpace

Sepi
Class Tree
Index
Previous (Size)
Next (SpaceArgument)


Sepi

Sepi
Previous (Space)
Next

Name
SpaceArgument

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Argument de l'espace d'adressage (offset)

Source code
property SpaceArgument : Integer read FSpaceArgument

Read Access
FSpaceArgument

Sepi
Class Tree
Index
Previous (Space)
Next


Sepi

Sepi
Previous
Next (AddOperation)

Name
AddOperation

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Ajoute un déréférencement

Source code
procedure AddOperation ( ADereference : TSepiAddressDereference ) ; overload

Parameters
Parameter | Description
ADereference : TSepiAddressDereference | Déréférencement

Sepi
Class Tree
Index
Previous
Next (AddOperation)


Sepi

Sepi
Previous (AddOperation)
Next (AddOperation)

Name
AddOperation

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Ajoute une opération

Source code
function AddOperation ( AOperation : TSepiAddressOperation ; AConstOperationArg : Integer = 0 ) : TSepiMemoryReference ; overload

Parameters
Parameter | Description
AOperation : TSepiAddressOperation | Opération
AConstOperationArg : INTEGER | Argument constant de l'opération, si applicable

Return
Types | Description
TSepiMemoryReference | Argument mémoire de l'opération, si applicable (nil sinon)

Sepi
Class Tree
Index
Previous (AddOperation)
Next (AddOperation)


Sepi

Sepi
Previous (AddOperation)
Next (Assign)

Name
AddOperation

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Ajoute un déréférencement et une opération

Source code
function AddOperation ( ADereference : TSepiAddressDereference ; AOperation : TSepiAddressOperation ; AConstOperationArg : Integer = 0 ) : TSepiMemoryReference ; overload

Parameters
Parameter | Description
ADereference : TSepiAddressDereference | Déréférencement
AOperation : TSepiAddressOperation | Opération
AConstOperationArg : INTEGER | Argument constant de l'opération, si applicable

Return
Types | Description
TSepiMemoryReference | Argument mémoire de l'opération, si applicable (nil sinon)

Sepi
Class Tree
Index
Previous (AddOperation)
Next (Assign)


Sepi

Sepi
Previous (AddOperation)
Next (CanRemoveDereference)

Name
Assign

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Recopie depuis une référence mémoire
Cette méthode ne fait pas un clône : elle copie les espace mémoire et
opérations, mais pas les options ou le statut scellé. Il est donc possible
que cette méthode échoue si la référence source n'est pas compatible avec les
options de celles-ci.

Source code
procedure Assign ( Source : TSepiMemoryReference ; SealAfter : Boolean = True )

Parameters
Parameter | Description
Source : TSepiMemoryReference | Référence mémoire à recopier
SealAfter : BOOLEAN | Si True (par défaut), scelle cette référence mémoire après

Sepi
Class Tree
Index
Previous (AddOperation)
Next (CanRemoveDereference)


Sepi

Sepi
Previous (Assign)
Next (CheckUnsealed)

Name
CanRemoveDereference

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Teste s'il est possible de retirer un déréférencement à la fin

Source code
function CanRemoveDereference : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si c'est possible, False sinon

Sepi
Class Tree
Index
Previous (Assign)
Next (CheckUnsealed)


Sepi

Sepi
Previous (CanRemoveDereference)
Next (ClearOperations)

Name
CheckUnsealed

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Vérifie que la référence mémoire n'est pas scellée

Source code
procedure CheckUnsealed

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CanRemoveDereference)
Next (ClearOperations)


Sepi

Sepi
Previous (CheckUnsealed)
Next (Clone)

Name
ClearOperations

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Supprime toutes les opérations

Source code
procedure ClearOperations

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckUnsealed)
Next (Clone)


Sepi

Sepi
Previous (ClearOperations)
Next (Create)

Name
Clone

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Construit une copie d'une référence mémoire
La copie est en tout point identique à l'originale, excepté qu'elle n'est
jamais scellée.

Source code
constructor Clone ( Source : TSepiMemoryReference )

Parameters
Parameter | Description
Source : TSepiMemoryReference | Référence mémoire à copier

Sepi
Class Tree
Index
Previous (ClearOperations)
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Destroy)

Name
Create

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Crée une nouvelle référence mémoire

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AOptions : TSepiAddressOptions = [ ] ; AConstSize : Integer = 0 )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AOptions : TSepiAddressOptions | Options
AConstSize : INTEGER | Taille de constante

Sepi
Class Tree
Index
Previous (Clone)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetConstant)

Name
Destroy

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetConstant)


Sepi

Sepi
Previous (Destroy)
Next (GetOperationCount)

Name
GetConstant

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Récupère la constante
La référence mémoire doit accepter les constantes non nulles.

Source code
procedure GetConstant ( var AConstant )

Parameters
Parameter | Description
AConstant : Untyped | En sortie : valeur de la constante

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetOperationCount)


Sepi

Sepi
Previous (GetConstant)
Next (GetOperations)

Name
GetOperationCount

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Nombre d'opérations

Source code
function GetOperationCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'opérations

Sepi
Class Tree
Index
Previous (GetConstant)
Next (GetOperations)


Sepi

Sepi
Previous (GetOperationCount)
Next (Make)

Name
GetOperations

Parent
TSepiMemoryReference

Visibility
PRIVATE

Description
Tableau zero-based des opérations

Source code
function GetOperations ( Index : Integer ) : TSepiAddressDerefAndOpRec

Parameters
Parameter | Description
INDEX : INTEGER | Index d'une opération

Return
Types | Description
TSepiAddressDerefAndOpRec | Opération à l'index spécifié

Sepi
Class Tree
Index
Previous (GetOperationCount)
Next (Make)


Sepi

Sepi
Previous (GetOperations)
Next (RemoveDereference)

Name
Make

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Construit la référence mémoire

Source code
procedure Make

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetOperations)
Next (RemoveDereference)


Sepi

Sepi
Previous (Make)
Next (Seal)

Name
RemoveDereference

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Retire le déréférencement en bout d'opérations
L'appel à cette méthode n'est pas valide si CanRemoveDereference renvoie
False.

Source code
procedure RemoveDereference

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Make)
Next (Seal)


Sepi

Sepi
Previous (RemoveDereference)
Next (SetAsConst)

Name
Seal

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Scelle la référence mémoire
Dès lors qu'une référence mémoire est scellée, toute tentative de modification
de celle-ci provoquera une exception.

Source code
procedure Seal

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (RemoveDereference)
Next (SetAsConst)


Sepi

Sepi
Previous (Seal)
Next (SetAsConst)

Name
SetAsConst

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Assigne la référence mémoire à une constante booléenne

Source code
procedure SetAsConst ( Value : Boolean ) ; overload

Parameters
Parameter | Description
Value : BOOLEAN | Valeur constante

Sepi
Class Tree
Index
Previous (Seal)
Next (SetAsConst)


Sepi

Sepi
Previous (SetAsConst)
Next (SetAsConst)

Name
SetAsConst

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Assigne la référence mémoire à une constante entière

Source code
procedure SetAsConst ( Value : Int64 ) ; overload

Parameters
Parameter | Description
Value : INT64 | Valeur constante

Sepi
Class Tree
Index
Previous (SetAsConst)
Next (SetAsConst)


Sepi

Sepi
Previous (SetAsConst)
Next (SetAsConst)

Name
SetAsConst

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Assigne la référence mémoire à une constante Currency

Source code
procedure SetAsConst ( Value : Currency ) ; overload

Parameters
Parameter | Description
Value : CURRENCY | Valeur constante

Sepi
Class Tree
Index
Previous (SetAsConst)
Next (SetAsConst)


Sepi

Sepi
Previous (SetAsConst)
Next (SetConstant)

Name
SetAsConst

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Assigne la référence mémoire à une constante flottante

Source code
procedure SetAsConst ( Value : Extended ) ; overload

Parameters
Parameter | Description
Value : EXTENDED | Valeur constante

Sepi
Class Tree
Index
Previous (SetAsConst)
Next (SetConstant)


Sepi

Sepi
Previous (SetAsConst)
Next (SetSpace)

Name
SetConstant

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Spécifie la constante
La référence mémoire doit accepter les constantes non nulles.

Source code
procedure SetConstant ( const AConstant )

Parameters
Parameter | Description
AConstant : Untyped | Nouvelle valeur de la constante

Sepi
Class Tree
Index
Previous (SetAsConst)
Next (SetSpace)


Sepi

Sepi
Previous (SetConstant)
Next (SetSpace)

Name
SetSpace

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Modifie l'espace mémoire sur base d'une variable locale

Source code
procedure SetSpace ( LocalVar : TSepiLocalVar ) ; overload

Parameters
Parameter Description
LocalVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous (SetConstant)
Next (SetSpace)


Sepi

Sepi
Previous (SetSpace)
Next (SetSpace)

Name
SetSpace

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Modifie l'espace mémoire
Cette modification supprime toutes les opérations si le nouvel espace est
msZero (qui ne supporte pas les opérations).

Source code
procedure SetSpace ( ASpace : TSepiMemorySpace ; ASpaceArgument : Integer = 0 ) ; overload

Parameters
Parameter Description
ASpace : TSepiMemorySpace
ASpaceArgument : INTEGER

Sepi
Class Tree
Index
Previous (SetSpace)
Next (SetSpace)


Sepi

Sepi
Previous (SetSpace)
Next (SetSpace)

Name
SetSpace

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Modifie l'espace mémoire sur base d'une vraie constante

Source code
procedure SetSpace ( Constant : TSepiConstant ) ; overload

Parameters
Parameter | Description
Constant : TSepiConstant | Constante à pointer par l'espace mémoire

Sepi
Class Tree
Index
Previous (SetSpace)
Next (SetSpace)


Sepi

Sepi
Previous (SetSpace)
Next (SetSpace)

Name
SetSpace

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Modifie l'espace mémoire sur base d'un nom, qui est d'abord recherché
L'espace mémoire est recherché dans les variables locales, puis dans les
paramètres, puis via la méthode LookFor de la méthode qui est asssemblée.

Source code
procedure SetSpace ( const Name : string ) ; overload

Parameters
Parameter | Description
NAME : STRING | Nom de l'espace mémoire, à rechercher

Sepi
Class Tree
Index
Previous (SetSpace)
Next (SetSpace)


Sepi

Sepi
Previous (SetSpace)
Next (WriteToStream)

Name
SetSpace

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Modifie l'espace mémoire sur base d'une variable globale

Source code
procedure SetSpace ( Variable : TSepiVariable ) ; overload

Parameters
Parameter | Description
Variable : TSepiVariable | Variable à pointer par l'espace mémoire

Sepi
Class Tree
Index
Previous (SetSpace)
Next (WriteToStream)


Sepi

Sepi
Previous (SetSpace)
Next

Name
WriteToStream

Parent
TSepiMemoryReference

Visibility
PUBLIC

Description
Ecrit la référence mémoire dans un flux

Source code
procedure WriteToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux de destination

Sepi
Class Tree
Index
Previous (SetSpace)
Next


Sepi

Sepi
Previous (TSepiMemoryReference)
Next (TSepiNamedLabel)

Name
TSepiMethodCompiler

Parent
SepiCompiler

Class Hierarchy
TSepiCompilerBase

Visibility
PUBLIC

Description
Compilateur d'une méthode Sepi

Members
Fields
Field | Description
FAsmInstructions (-) | Instructions assembleur
FBreakReferences (-) | Références pour break
FContinueReferences (-) | Références pour continue
FInstructions (-) | Instructions
FLastInstruction (-) | #No TAG found in source code#
FLocalNamespace (-) | Espace de noms local
FLocals (-) | Variables locales
FNamedLabels (-) | Labels nommés (paire nom/instruction)
FObjFreeList (-) | Liste des objets à libérer en fin de vie
FSepiMethod (-) | Méthode Sepi correspondante
FSize (-) | Taille totale (après assemblage)

Methods
Method | Description
AddObjToFreeList (+) | Ajoute un objet à ceux devant être libérés en fin de vie
AfterConstruction (+) | [@inheritDoc]
BeforeDestruction (+) | [@inheritDoc]
Compile (+) | Compile les instructions
Complete (+) | Complète le corps de la méthode
Create (+) | Crée un nouveau compilateur de méthode Sepi
Destroy (+) | [@inheritDoc]
EnterLoop (+) | Entre dans une boucle, et met à jour ContinueRef et BreakRef
FindLabel (+) | Cherche un label nommé
GetBreakRef (-) | Référence à l'instruction de destination d'un break courante
GetContinueRef (-) | Référence à l'instruction de destination d'un continue courante
GetHasLocalNamespace (-) | Indique si la méthode a un espace de noms local
GetLocalNamespace (-) | Espace de noms local
LabelExists (+) | Teste l'existence d'un un label nommé
LeaveLoop (+) | Quitte la boucle courante, et récupère les anciens ContinueRef et BreakRef
LookFor (+) | Cherche un objet à partir de son nom
MakeUnnamedTrueConst (+) | Crée une vraie constante anonyme avec une valeur
SetLabel (-) | Notifie l'existence d'un label nommé
WriteLocalsInfo (+) | Ecrit les informations d'initialisation des variables locales
WriteToStream (+) | Ecrit la méthode dans un flux (tel que TSepiRuntimeMethod puisse le lire)

Properties
Property | Description
AsmInstructions (#) | Instructions assembleur
BreakRef (+) | Référence à l'instruction de destination d'un break courante
ContinueRef (+) | Référence à l'instruction de destination d'un continue courante
HasLocalNamespace (+) | Indique si la méthode a un espace de noms local
Instructions (+) | Instructions
LocalNamespace (+) | Espace de noms local
Locals (+) | Variables locales
SepiMethod (+) | Méthode Sepi correspondante
Size (+) | Taille totale (après assemblage)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMemoryReference)
Next (TSepiNamedLabel)


Sepi

Sepi
Previous
Next (FBreakReferences)

Name
FAsmInstructions

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Instructions assembleur

Source code
FAsmInstructions : TSepiAsmInstrList

Sepi
Class Tree
Index
Previous
Next (FBreakReferences)


Sepi

Sepi
Previous (FAsmInstructions)
Next (FContinueReferences)

Name
FBreakReferences

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Références pour break

Source code
FBreakReferences : TObjectStack

Sepi
Class Tree
Index
Previous (FAsmInstructions)
Next (FContinueReferences)


Sepi

Sepi
Previous (FBreakReferences)
Next (FInstructions)

Name
FContinueReferences

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Références pour continue

Source code
FContinueReferences : TObjectStack

Sepi
Class Tree
Index
Previous (FBreakReferences)
Next (FInstructions)


Sepi

Sepi
Previous (FContinueReferences)
Next (FLastInstruction)

Name
FInstructions

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Instructions

Source code
FInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous (FContinueReferences)
Next (FLastInstruction)


Sepi

Sepi
Previous (FInstructions)
Next (FLocalNamespace)

Name
FLastInstruction

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FLastInstruction : TSepiAsmInstrList

Sepi
Class Tree
Index
Previous (FInstructions)
Next (FLocalNamespace)


Sepi

Sepi
Previous (FLastInstruction)
Next (FLocals)

Name
FLocalNamespace

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Espace de noms local

Source code
FLocalNamespace : TSepiNamespace

Sepi
Class Tree
Index
Previous (FLastInstruction)
Next (FLocals)


Sepi

Sepi
Previous (FLocalNamespace)
Next (FNamedLabels)

Name
FLocals

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Variables locales

Source code
FLocals : TSepiLocalVariables

Sepi
Class Tree
Index
Previous (FLocalNamespace)
Next (FNamedLabels)


Sepi

Sepi
Previous (FLocals)
Next (FObjFreeList)

Name
FNamedLabels

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Labels nommés (paire nom/instruction)

Source code
FNamedLabels : TStrings

Sepi
Class Tree
Index
Previous (FLocals)
Next (FObjFreeList)


Sepi

Sepi
Previous (FNamedLabels)
Next (FSepiMethod)

Name
FObjFreeList

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Liste des objets à libérer en fin de vie

Source code
FObjFreeList : TObjectList

Sepi
Class Tree
Index
Previous (FNamedLabels)
Next (FSepiMethod)


Sepi

Sepi
Previous (FObjFreeList)
Next (FSize)

Name
FSepiMethod

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Méthode Sepi correspondante

Source code
FSepiMethod : TSepiMethod

Sepi
Class Tree
Index
Previous (FObjFreeList)
Next (FSize)


Sepi

Sepi
Previous (FSepiMethod)
Next

Name
FSize

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Taille totale (après assemblage)

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FSepiMethod)
Next


Sepi

Sepi
Previous
Next (BreakRef)

Name
AsmInstructions

Parent
TSepiMethodCompiler

Visibility
PROTECTED

Description
Instructions assembleur

Source code
property AsmInstructions : TSepiAsmInstrList read FAsmInstructions

Read Access
FAsmInstructions

Sepi
Class Tree
Index
Previous
Next (BreakRef)


Sepi

Sepi
Previous (AsmInstructions)
Next (ContinueRef)

Name
BreakRef

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Référence à l'instruction de destination d'un break courante

Source code
property BreakRef : TSepiInstructionRef read GetBreakRef

Read Access
GetBreakRef

Sepi
Class Tree
Index
Previous (AsmInstructions)
Next (ContinueRef)


Sepi

Sepi
Previous (BreakRef)
Next (HasLocalNamespace)

Name
ContinueRef

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Référence à l'instruction de destination d'un continue courante

Source code
property ContinueRef : TSepiInstructionRef read GetContinueRef

Read Access
GetContinueRef

Sepi
Class Tree
Index
Previous (BreakRef)
Next (HasLocalNamespace)


Sepi

Sepi
Previous (ContinueRef)
Next (Instructions)

Name
HasLocalNamespace

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Indique si la méthode a un espace de noms local

Source code
property HasLocalNamespace : Boolean read GetHasLocalNamespace

Read Access
GetHasLocalNamespace

Sepi
Class Tree
Index
Previous (ContinueRef)
Next (Instructions)


Sepi

Sepi
Previous (HasLocalNamespace)
Next (LocalNamespace)

Name
Instructions

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Instructions

Source code
property Instructions : TSepiInstructionList read FInstructions

Read Access
FInstructions

Sepi
Class Tree
Index
Previous (HasLocalNamespace)
Next (LocalNamespace)


Sepi

Sepi
Previous (Instructions)
Next (Locals)

Name
LocalNamespace

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Espace de noms local

Source code
property LocalNamespace : TSepiNamespace read GetLocalNamespace

Read Access
GetLocalNamespace

Sepi
Class Tree
Index
Previous (Instructions)
Next (Locals)


Sepi

Sepi
Previous (LocalNamespace)
Next (SepiMethod)

Name
Locals

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Variables locales

Source code
property Locals : TSepiLocalVariables read FLocals

Read Access
FLocals

Sepi
Class Tree
Index
Previous (LocalNamespace)
Next (SepiMethod)


Sepi

Sepi
Previous (Locals)
Next (Size)

Name
SepiMethod

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Méthode Sepi correspondante

Source code
property SepiMethod : TSepiMethod read FSepiMethod

Read Access
FSepiMethod

Sepi
Class Tree
Index
Previous (Locals)
Next (Size)


Sepi

Sepi
Previous (SepiMethod)
Next

Name
Size

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Taille totale (après assemblage)

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (SepiMethod)
Next


Sepi

Sepi
Previous
Next (AfterConstruction)

Name
AddObjToFreeList

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Ajoute un objet à ceux devant être libérés en fin de vie

Source code
procedure AddObjToFreeList ( Obj : TObject )

Parameters
Parameter | Description
Obj : TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AfterConstruction)


Sepi

Sepi
Previous (AddObjToFreeList)
Next (BeforeDestruction)

Name
AfterConstruction

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddObjToFreeList)
Next (BeforeDestruction)


Sepi

Sepi
Previous (AfterConstruction)
Next (Compile)

Name
BeforeDestruction

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Compile)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Complete)

Name
Compile

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Compile les instructions

Source code
procedure Compile

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Complete)


Sepi

Sepi
Previous (Compile)
Next (Create)

Name
Complete

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Complète le corps de la méthode

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Compile)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Destroy)

Name
Create

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Crée un nouveau compilateur de méthode Sepi

Source code
constructor Create ( AUnitCompiler : TSepiUnitCompiler ; ASepiMethod : TSepiMethod )

Parameters
Parameter | Description
AUnitCompiler : TSepiUnitCompiler | Compilateur d'unité
ASepiMethod : TSepiMethod | Méthode Sepi

Sepi
Class Tree
Index
Previous (Complete)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (EnterLoop)

Name
Destroy

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (EnterLoop)


Sepi

Sepi
Previous (Destroy)
Next (FindLabel)

Name
EnterLoop

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Entre dans une boucle, et met à jour ContinueRef et BreakRef

Source code
procedure EnterLoop ( ContinueRef , BreakRef : TSepiInstructionRef )

Parameters
Parameter | Description
ContinueRef : TSepiInstructionRef | Référence à l'instruction de destination d'un continue
BreakRef : TSepiInstructionRef | Référence à l'instruction de destination d'un break

Sepi
Class Tree
Index
Previous (Destroy)
Next (FindLabel)


Sepi

Sepi
Previous (EnterLoop)
Next (GetBreakRef)

Name
FindLabel

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Cherche un label nommé

Exception
ESepiLabelError Le label n'a pas été trouvé

Source code
function FindLabel ( const LabelName : string ; AllowCreate : Boolean = False ) : TSepiNamedLabel

Parameters
Parameter | Description
LabelName : STRING | Nom du label recherché
AllowCreate : BOOLEAN

Return
Types | Description
TSepiNamedLabel | Label nommé

Sepi
Class Tree
Index
Previous (EnterLoop)
Next (GetBreakRef)


Sepi

Sepi
Previous (FindLabel)
Next (GetContinueRef)

Name
GetBreakRef

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Référence à l'instruction de destination d'un break courante
Renvoie nil si on n'est pas actuellement dans une boucle

Source code
function GetBreakRef : TSepiInstructionRef

Parameters
Parameter Description

Return
Types | Description
TSepiInstructionRef | Référence à l'instruction de destination d'un break courante

Sepi
Class Tree
Index
Previous (FindLabel)
Next (GetContinueRef)


Sepi

Sepi
Previous (GetBreakRef)
Next (GetHasLocalNamespace)

Name
GetContinueRef

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Référence à l'instruction de destination d'un continue courante
Renvoie nil si on n'est pas actuellement dans une boucle

Source code
function GetContinueRef : TSepiInstructionRef

Parameters
Parameter Description

Return
Types | Description
TSepiInstructionRef | Référence à l'instruction de destination d'un continue courante

Sepi
Class Tree
Index
Previous (GetBreakRef)
Next (GetHasLocalNamespace)


Sepi

Sepi
Previous (GetContinueRef)
Next (GetLocalNamespace)

Name
GetHasLocalNamespace

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Indique si la méthode a un espace de noms local

Source code
function GetHasLocalNamespace : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si la méthode a un espace de noms local, False sinon

Sepi
Class Tree
Index
Previous (GetContinueRef)
Next (GetLocalNamespace)


Sepi

Sepi
Previous (GetHasLocalNamespace)
Next (LabelExists)

Name
GetLocalNamespace

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Espace de noms local

Source code
function GetLocalNamespace : TSepiNamespace

Parameters
Parameter Description

Return
Types | Description
TSepiNamespace | Espace de noms local

Sepi
Class Tree
Index
Previous (GetHasLocalNamespace)
Next (LabelExists)


Sepi

Sepi
Previous (GetLocalNamespace)
Next (LeaveLoop)

Name
LabelExists

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Teste l'existence d'un un label nommé

Source code
function LabelExists ( const LabelName : string ) : Boolean

Parameters
Parameter | Description
LabelName : STRING | Nom du label

Return
Types | Description
BOOLEAN | True si un label de ce nom existe, False sinon

Sepi
Class Tree
Index
Previous (GetLocalNamespace)
Next (LeaveLoop)


Sepi

Sepi
Previous (LabelExists)
Next (LookFor)

Name
LeaveLoop

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Quitte la boucle courante, et récupère les anciens ContinueRef et BreakRef

Source code
procedure LeaveLoop

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (LabelExists)
Next (LookFor)


Sepi

Sepi
Previous (LeaveLoop)
Next (MakeUnnamedTrueConst)

Name
LookFor

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Cherche un objet à partir de son nom
LookFor cherche parmi les variables locales, puis les paramètres, et enfin
essaie la méthode LookFor de la méthode Sepi correspondante. Le résultat peut
être de type TSepiComponent ou TSepiParam.

Source code
function LookFor ( const Name : string ) : TObject

Parameters
Parameter | Description
NAME : STRING | Nom de l'objet recherché

Return
Types | Description
TObject | Objet recherché, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LeaveLoop)
Next (MakeUnnamedTrueConst)


Sepi

Sepi
Previous (LookFor)
Next (SetLabel)

Name
MakeUnnamedTrueConst

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Crée une vraie constante anonyme avec une valeur

Source code
function MakeUnnamedTrueConst ( AType : TSepiType ; const AValue ) : TSepiConstant

Parameters
Parameter | Description
AType : TSepiType | Type de la constante
AValue : Untyped | Valeur de la constante

Return
Types | Description
TSepiConstant | Constante créée

Sepi
Class Tree
Index
Previous (LookFor)
Next (SetLabel)


Sepi

Sepi
Previous (MakeUnnamedTrueConst)
Next (WriteLocalsInfo)

Name
SetLabel

Parent
TSepiMethodCompiler

Visibility
PRIVATE

Description
Notifie l'existence d'un label nommé

Source code
procedure SetLabel ( NamedLabel : TSepiNamedLabel )

Parameters
Parameter | Description
NamedLabel : TSepiNamedLabel | Label nommé à ajouter

Sepi
Class Tree
Index
Previous (MakeUnnamedTrueConst)
Next (WriteLocalsInfo)


Sepi

Sepi
Previous (SetLabel)
Next (WriteToStream)

Name
WriteLocalsInfo

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Ecrit les informations d'initialisation des variables locales

Source code
procedure WriteLocalsInfo ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux de destination

Sepi
Class Tree
Index
Previous (SetLabel)
Next (WriteToStream)


Sepi

Sepi
Previous (WriteLocalsInfo)
Next

Name
WriteToStream

Parent
TSepiMethodCompiler

Visibility
PUBLIC

Description
Ecrit la méthode dans un flux (tel que TSepiRuntimeMethod puisse le lire)
La méthode doit avoir été compilée au préalable via la méthode Compile.

Source code
procedure WriteToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux de destination

Sepi
Class Tree
Index
Previous (WriteLocalsInfo)
Next


Sepi

Sepi
Previous (TSepiMethodCompiler)
Next (TSepiTempVarsLifeManager)

Name
TSepiNamedLabel

Parent
SepiCompiler

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Pseudo-instruction label nommé

Members
Fields
Field | Description
FName (-) | #No TAG found in source code#

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
Create (+) | Crée une nouveau label nommé
CustomCompile (#) | [@inheritDoc]

Properties
Property | Description
NAME (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodCompiler)
Next (TSepiTempVarsLifeManager)


Sepi

Sepi
Previous
Next

Name
FName

Parent
TSepiNamedLabel

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FName : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
NAME

Parent
TSepiNamedLabel

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
AfterConstruction

Parent
TSepiNamedLabel

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AfterConstruction)
Next (CustomCompile)

Name
Create

Parent
TSepiNamedLabel

Visibility
PUBLIC

Description
Crée une nouveau label nommé

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; const AName : string )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AName : STRING | Nom du label

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next

Name
CustomCompile

Parent
TSepiNamedLabel

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiNamedLabel)
Next (TSepiUnitCompiler)

Name
TSepiTempVarsLifeManager

Parent
SepiCompiler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Gestionnaire de vie de plusieurs variables temporaires

Members
Fields
Field | Description
FTempVars (-) | #No TAG found in source code#

Methods
Method | Description
Acquire (+) | Acquiert la gestion d'une variable temporaire
BeginLife (+) | Commence la vie d'une variable temporaire
Create (+) | Crée un gestionnaire
Destroy (+) | [@inheritDoc]
EndAllLifes (+) | Termine la vie de toutes les variables temporaires de ce gestionnaire
EndLife (+) | Termine la vie d'une variable temporaire
Extract (+) | Extrait une variable temporaire de ce gestionnaire, sans terminer sa vie
FindVarFromMemoryRef (+) | Cherche une variable temporaire pointée par une référence mémoire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiNamedLabel)
Next (TSepiUnitCompiler)


Sepi

Sepi
Previous
Next

Name
FTempVars

Parent
TSepiTempVarsLifeManager

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FTempVars : TObjectList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (BeginLife)

Name
Acquire

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
Acquiert la gestion d'une variable temporaire
La vie de cette variable doit avoir un intervalle en cours

Source code
procedure Acquire ( TempVar : TSepiLocalVar )

Parameters
Parameter | Description
TempVar : TSepiLocalVar | Variable à acquérir

Sepi
Class Tree
Index
Previous
Next (BeginLife)


Sepi

Sepi
Previous (Acquire)
Next (Create)

Name
BeginLife

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
Commence la vie d'une variable temporaire

Source code
procedure BeginLife ( TempVar : TSepiLocalVar ; At : TSepiInstructionRef )

Parameters
Parameter | Description
TempVar : TSepiLocalVar | Variable
AT : TSepiInstructionRef | Position où la vie commence

Sepi
Class Tree
Index
Previous (Acquire)
Next (Create)


Sepi

Sepi
Previous (BeginLife)
Next (Destroy)

Name
Create

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
Crée un gestionnaire

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeginLife)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (EndAllLifes)

Name
Destroy

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (EndAllLifes)


Sepi

Sepi
Previous (Destroy)
Next (EndLife)

Name
EndAllLifes

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
Termine la vie de toutes les variables temporaires de ce gestionnaire

Source code
procedure EndAllLifes ( At : TSepiInstructionRef )

Parameters
Parameter | Description
AT : TSepiInstructionRef | Position où la vie s'arrête

Sepi
Class Tree
Index
Previous (Destroy)
Next (EndLife)


Sepi

Sepi
Previous (EndAllLifes)
Next (Extract)

Name
EndLife

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
Termine la vie d'une variable temporaire

Source code
procedure EndLife ( TempVar : TSepiLocalVar ; At : TSepiInstructionRef )

Parameters
Parameter | Description
TempVar : TSepiLocalVar | Variable
AT : TSepiInstructionRef | Position où la vie s'arrête

Sepi
Class Tree
Index
Previous (EndAllLifes)
Next (Extract)


Sepi

Sepi
Previous (EndLife)
Next (FindVarFromMemoryRef)

Name
Extract

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
Extrait une variable temporaire de ce gestionnaire, sans terminer sa vie

Source code
function Extract ( TempVar : TSepiLocalVar ) : TSepiLocalVar

Parameters
Parameter | Description
TempVar : TSepiLocalVar | Variable temporaire à extraire

Return
Types | Description
TSepiLocalVar | TempVar si elle faisait bien partie de ce gestionnaire, nil sinon

Sepi
Class Tree
Index
Previous (EndLife)
Next (FindVarFromMemoryRef)


Sepi

Sepi
Previous (Extract)
Next

Name
FindVarFromMemoryRef

Parent
TSepiTempVarsLifeManager

Visibility
PUBLIC

Description
Cherche une variable temporaire pointée par une référence mémoire

Source code
function FindVarFromMemoryRef ( MemoryRef : TSepiMemoryReference ) : TSepiLocalVar

Parameters
Parameter | Description
MemoryRef : TSepiMemoryReference | Référence mémoire

Return
Types | Description
TSepiLocalVar | Variable temporaire pointée, ou nil si non trouvée

Sepi
Class Tree
Index
Previous (Extract)
Next


Sepi

Sepi
Previous (TSepiTempVarsLifeManager)
Next

Name
TSepiUnitCompiler

Parent
SepiCompiler

Class Hierarchy
TSepiCompilerBase

Visibility
PUBLIC

Description
Compilateur d'unité Sepi

Members
Fields
Field | Description
FCompileTimeTypes (-) | Types de compilation
FErroneousType (-) | Type erroné
FLanguageRules (-) | Règles du langage utilisé
FMethods (-) | Compilateurs de méthodes
FReferences (-) | Références

Methods
Method | Description
Create (+) | Crée un nouveau compilateur d'unité Sepi
Destroy (+) | [@inheritDoc]
FindMethodCompiler (+) | Cherche le compilateur de méthode pour une méthode donnée
GetEmptySetType (+) | Obtient un type d'ensemble vide qui ne durera que la compilation
GetErroneousType (+) | Récupère le type erroné s'il existe déjà, sinon le crée
GetMetaClass (+) | Obtient un type meta-classe qui ne durera que la compilation
GetMethodCount (-) | Nombre de compilateurs de méthode
GetMethods (-) | Tableau zero-based des compilateurs de méthode
GetPointerType (+) | Obtient un type pointeur qui ne durera que la compilation
MakeErroneousTypeAlias (+) | Crée un alias du type erroné
MakeReference (+) | Construit un numéro de référence à un meta Sepi
MakeSetType (+) | Construit un type ensemble pour un type d'élément donné (passe la compilation)
NeedCompileTimeTypes (-) | S'assure que le conteneur de types de compilation est créé
WriteToStream (+) | Ecrit l'unité compilée dans un flux

Properties
Property | Description
LanguageRules (+) | Règles du langage utilisé
MethodCount (+) | Nombre de compilateurs de méthode
Methods (+) | Tableau zero-based des compilateurs de méthode

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTempVarsLifeManager)
Next


Sepi

Sepi
Previous
Next (FErroneousType)

Name
FCompileTimeTypes

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
Types de compilation

Source code
FCompileTimeTypes : TSepiComponent

Sepi
Class Tree
Index
Previous
Next (FErroneousType)


Sepi

Sepi
Previous (FCompileTimeTypes)
Next (FLanguageRules)

Name
FErroneousType

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
Type erroné

Source code
FErroneousType : TSepiType

Sepi
Class Tree
Index
Previous (FCompileTimeTypes)
Next (FLanguageRules)


Sepi

Sepi
Previous (FErroneousType)
Next (FMethods)

Name
FLanguageRules

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
Règles du langage utilisé

Source code
FLanguageRules : TSepiLanguageRules

Sepi
Class Tree
Index
Previous (FErroneousType)
Next (FMethods)


Sepi

Sepi
Previous (FLanguageRules)
Next (FReferences)

Name
FMethods

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
Compilateurs de méthodes

Source code
FMethods : TObjectList

Sepi
Class Tree
Index
Previous (FLanguageRules)
Next (FReferences)


Sepi

Sepi
Previous (FMethods)
Next

Name
FReferences

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
Références

Source code
FReferences : TObjectList

Sepi
Class Tree
Index
Previous (FMethods)
Next


Sepi

Sepi
Previous
Next (MethodCount)

Name
LanguageRules

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Règles du langage utilisé

Source code
property LanguageRules : TSepiLanguageRules read FLanguageRules

Read Access
FLanguageRules

Sepi
Class Tree
Index
Previous
Next (MethodCount)


Sepi

Sepi
Previous (LanguageRules)
Next (Methods)

Name
MethodCount

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Nombre de compilateurs de méthode

Source code
property MethodCount : Integer read GetMethodCount

Read Access
GetMethodCount

Sepi
Class Tree
Index
Previous (LanguageRules)
Next (Methods)


Sepi

Sepi
Previous (MethodCount)
Next

Name
Methods

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Tableau zero-based des compilateurs de méthode

Source code
property Methods [ Index : Integer ] : TSepiMethodCompiler read GetMethods

Read Access
GetMethods

Sepi
Class Tree
Index
Previous (MethodCount)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Crée un nouveau compilateur d'unité Sepi

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; ASepiUnit : TSepiUnit ; ALanguageRulesClass : TSepiLanguageRulesClass )

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | Gestionnaire d'erreurs
ASepiUnit : TSepiUnit | Unité Sepi à compiler
ALanguageRulesClass : TSepiLanguageRulesClass | Classe du gestionnaire des règles du langage

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (FindMethodCompiler)

Name
Destroy

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (FindMethodCompiler)


Sepi

Sepi
Previous (Destroy)
Next (GetEmptySetType)

Name
FindMethodCompiler

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Cherche le compilateur de méthode pour une méthode donnée

Source code
function FindMethodCompiler ( SepiMethod : TSepiMethod ; AllowCreate : Boolean = False ) : TSepiMethodCompiler

Parameters
Parameter | Description
SepiMethod : TSepiMethod | Méthode dont on cherche le compilateur
AllowCreate : BOOLEAN | Si True, permet de créer le compilateur si inexistant

Return
Types | Description
TSepiMethodCompiler | Compilateur pour la méthode donnée, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetEmptySetType)


Sepi

Sepi
Previous (FindMethodCompiler)
Next (GetErroneousType)

Name
GetEmptySetType

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Obtient un type d'ensemble vide qui ne durera que la compilation

Source code
function GetEmptySetType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type ensemble vide

Sepi
Class Tree
Index
Previous (FindMethodCompiler)
Next (GetErroneousType)


Sepi

Sepi
Previous (GetEmptySetType)
Next (GetMetaClass)

Name
GetErroneousType

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Récupère le type erroné s'il existe déjà, sinon le crée

Source code
function GetErroneousType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type erroné

Sepi
Class Tree
Index
Previous (GetEmptySetType)
Next (GetMetaClass)


Sepi

Sepi
Previous (GetErroneousType)
Next (GetMethodCount)

Name
GetMetaClass

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Obtient un type meta-classe qui ne durera que la compilation

Source code
function GetMetaClass ( SepiClass : TSepiClass ) : TSepiMetaClass

Parameters
Parameter | Description
SepiClass : TSepiClass | Classe dont obtenir une meta-classe

Return
Types | Description
TSepiMetaClass | Meta-classe de la classe

Sepi
Class Tree
Index
Previous (GetErroneousType)
Next (GetMethodCount)


Sepi

Sepi
Previous (GetMetaClass)
Next (GetMethods)

Name
GetMethodCount

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
Nombre de compilateurs de méthode

Source code
function GetMethodCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de compilateurs de méthode

Sepi
Class Tree
Index
Previous (GetMetaClass)
Next (GetMethods)


Sepi

Sepi
Previous (GetMethodCount)
Next (GetPointerType)

Name
GetMethods

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
Tableau zero-based des compilateurs de méthode

Source code
function GetMethods ( Index : Integer ) : TSepiMethodCompiler

Parameters
Parameter | Description
INDEX : INTEGER | Index d'un compilateur

Return
Types | Description
TSepiMethodCompiler | Compilateur à l'index spécifié

Sepi
Class Tree
Index
Previous (GetMethodCount)
Next (GetPointerType)


Sepi

Sepi
Previous (GetMethods)
Next (MakeErroneousTypeAlias)

Name
GetPointerType

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Obtient un type pointeur qui ne durera que la compilation

Source code
function GetPointerType ( PointTo : TSepiType ) : TSepiPointerType

Parameters
Parameter | Description
PointTo : TSepiType | Type de données pointées par le pointeur

Return
Types | Description
TSepiPointerType | Type pointeur

Sepi
Class Tree
Index
Previous (GetMethods)
Next (MakeErroneousTypeAlias)


Sepi

Sepi
Previous (GetPointerType)
Next (MakeReference)

Name
MakeErroneousTypeAlias

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Crée un alias du type erroné

Source code
function MakeErroneousTypeAlias ( const AliasName : string ) : TSepiType

Parameters
Parameter Description
AliasName : STRING

Return
Types | Description
TSepiType | Type erroné

Sepi
Class Tree
Index
Previous (GetPointerType)
Next (MakeReference)


Sepi

Sepi
Previous (MakeErroneousTypeAlias)
Next (MakeSetType)

Name
MakeReference

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Construit un numéro de référence à un meta Sepi

Source code
function MakeReference ( Component : TSepiComponent ) : Integer

Parameters
Parameter | Description
Component : TSepiComponent | Component pour lequel construire un numéro de référence

Return
Types | Description
INTEGER | Numéro de référence du meta

Sepi
Class Tree
Index
Previous (MakeErroneousTypeAlias)
Next (MakeSetType)


Sepi

Sepi
Previous (MakeReference)
Next (NeedCompileTimeTypes)

Name
MakeSetType

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Construit un type ensemble pour un type d'élément donné (passe la compilation)

Source code
function MakeSetType ( CompType : TSepiOrdType ) : TSepiSetType

Parameters
Parameter | Description
CompType : TSepiOrdType | Type d'élément de l'ensemble

Return
Types | Description
TSepiSetType | Type ensemble dont les éléments sont de type CompType

Sepi
Class Tree
Index
Previous (MakeReference)
Next (NeedCompileTimeTypes)


Sepi

Sepi
Previous (MakeSetType)
Next (WriteToStream)

Name
NeedCompileTimeTypes

Parent
TSepiUnitCompiler

Visibility
PRIVATE

Description
S'assure que le conteneur de types de compilation est créé

Source code
procedure NeedCompileTimeTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeSetType)
Next (WriteToStream)


Sepi

Sepi
Previous (NeedCompileTimeTypes)
Next

Name
WriteToStream

Parent
TSepiUnitCompiler

Visibility
PUBLIC

Description
Ecrit l'unité compilée dans un flux

Source code
procedure WriteToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (NeedCompileTimeTypes)
Next


Sepi

Sepi
Previous
Next

Name
TSepiResolveIdentFunc

Parent
SepiCompiler

Visibility
PUBLIC

Description
Méthode de call-back de résolution d'identificateur

Source code
TSepiResolveIdentFunc = function ( const Identifier : string ) : ISepiExpression of object ;

Parameters
Parameter | Description
Identifier : STRING | Identificateur recherché

Return
Types | Description
ISepiExpression | Expression correspondant à cet identificateur

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (msUnresolvedLocalVar)

Name
MaxOperationCount

Parent
SepiCompiler

Visibility
PUBLIC

Description
Nombre maximum d'opérations sur une adresse

Source code
MaxOperationCount = $0F

Sepi
Class Tree
Index
Previous
Next (msUnresolvedLocalVar)


Sepi

Sepi
Previous (MaxOperationCount)
Next (ResultFieldName)

Name
msUnresolvedLocalVar

Parent
SepiCompiler

Visibility
PUBLIC

Description
Indique une variable locale non encore résolue

Source code
msUnresolvedLocalVar = TSepiMemorySpace ( - 1 )

Sepi
Class Tree
Index
Previous (MaxOperationCount)
Next (ResultFieldName)


Sepi

Sepi
Previous (msUnresolvedLocalVar)
Next

Name
ResultFieldName

Parent
SepiCompiler

Visibility
PUBLIC

Description
Nom de la variable locale Result

Source code
ResultFieldName = 'Result'

Sepi
Class Tree
Index
Previous (msUnresolvedLocalVar)
Next


Sepi

Sepi
Previous (SepiCompiler)
Next (SepiCompilerErrors)

Name
SepiCompilerConsts

Parent
Sepi

Description
Constantes utilisées dans un compilateur Sepi

Author
sjrd

Version
1.0

Constants
Constant | Description
SAddressableValueRequired (+) | #No TAG found in source code#
SArrayOrArrayPropRequired (+) | #No TAG found in source code#
SArrayPropertyRequired (+) | #No TAG found in source code#
SArrayTypeOrTypeIdentifierRequired (+) | #No TAG found in source code#
SArrayTypeRequired (+) | #No TAG found in source code#
SBadSourceCharacter (+) | #No TAG found in source code#
SBadStringLength (+) | #No TAG found in source code#
SBookmarksCantPassThroughLexer (+) | #No TAG found in source code#
SBreakAllowedOnlyInLoop (+) | #No TAG found in source code#
SByRefParamCantHaveDefaultValue (+) | #No TAG found in source code#
SCallableRequired (+) | #No TAG found in source code#
SCallPatternOnlyOnClassMethod (+) | #No TAG found in source code#
SCantOpenDestFile (+) | #No TAG found in source code#
SCantOpenSourceFile (+) | #No TAG found in source code#
SCantRemoveDereference (+) | #No TAG found in source code#
SClassDoesNotImplementIntf (+) | #No TAG found in source code#
SClassTypeRequired (+) | #No TAG found in source code#
SCompilerTransientTypeForbidden (+) | #No TAG found in source code#
SComponentRequired (+) | #No TAG found in source code#
SCompTypeTooNarrow (+) | #No TAG found in source code#
SConstArgMustBeShort (+) | #No TAG found in source code#
SConstExpressionRequired (+) | #No TAG found in source code#
SConstValueOutOfBounds (+) | #No TAG found in source code#
SContainerTypeRequired (+) | #No TAG found in source code#
SContinueAllowedOnlyInLoop (+) | #No TAG found in source code#
SDeclarationDiffersFromPreviousOne (+) | #No TAG found in source code#
SDuplicatedAbstractMarker (+) | #No TAG found in source code#
SDuplicateDefaultDirective (+) | #No TAG found in source code#
SDuplicateDefaultProperty (+) | #No TAG found in source code#
SDuplicatedLinkKind (+) | #No TAG found in source code#
SDuplicatedOfObjectMarker (+) | #No TAG found in source code#
SDynArrayTypeRequired (+) | #No TAG found in source code#
SEndOfFile (+) | #No TAG found in source code#
SExecutableRequired (+) | #No TAG found in source code#
SFieldOrMethodRequired (+) | #No TAG found in source code#
SFieldRequired (+) | #No TAG found in source code#
SIdentifier (+) | #No TAG found in source code#
SIdentifierNotFound (+) | #No TAG found in source code#
SIdentifierRequired (+) | #No TAG found in source code#
SInheritNeedClassOrObjectMethod (+) | #No TAG found in source code#
SInterfaceTypeRequired (+) | #No TAG found in source code#
SIntfMethodCantBeOverloaded (+) | #No TAG found in source code#
SIntfMethodCantChangeLinkKind (+) | #No TAG found in source code#
SInvalidArrayOfConstItem (+) | #No TAG found in source code#
SInvalidCast (+) | #No TAG found in source code#
SInvalidDataSize (+) | #No TAG found in source code#
SInvalidStorageValue (+) | #No TAG found in source code#
SLabelAlreadyExists (+) | #No TAG found in source code#
SLabelNotFound (+) | #No TAG found in source code#
SLocalVarNameRequired (+) | #No TAG found in source code#
SMemoryCantAccessObject (+) | #No TAG found in source code#
SMemoryCantBeConstant (+) | #No TAG found in source code#
SMemoryCantBeTrueConst (+) | #No TAG found in source code#
SMemoryCantBeZero (+) | #No TAG found in source code#
SMemoryRefIsSealed (+) | #No TAG found in source code#
SMemorySpaceOffsetMustBeWord (+) | #No TAG found in source code#
SMetaClassTypeRequired (+) | #No TAG found in source code#
SMethodAlreadyImplemented (+) | #No TAG found in source code#
SMethodMustBeOverloaded (+) | #No TAG found in source code#
SMethodNotDeclared (+) | #No TAG found in source code#
SMethodNotFoundInBaseClass (+) | #No TAG found in source code#
SMethodRequired (+) | #No TAG found in source code#
SMultiNameParamCantHaveDefaultValue (+) | #No TAG found in source code#
SMultipleParamsWithSameSepiStackOffset (+) | #No TAG found in source code#
SNeedConstExpression (+) | #No TAG found in source code#
SNoMatchingOverloadedMethod (+) | #No TAG found in source code#
SNotEnoughActualParameters (+) | #No TAG found in source code#
SNotInTry (+) | #No TAG found in source code#
SObjectMustHaveASignature (+) | #No TAG found in source code#
SOpenArrayParamCantHaveDefaultValue (+) | #No TAG found in source code#
SOpenArrayRequired (+) | #No TAG found in source code#
SOperationNotApplicableToType (+) | #No TAG found in source code#
SOrdinalOrArrayTypeRequired (+) | #No TAG found in source code#
SOrdinalTypeRequired (+) | #No TAG found in source code#
SParametersMismatch (+) | #No TAG found in source code#
SParamsAlreadyCompleted (+) | #No TAG found in source code#
SParamsSepiStackOffsetsDontFollow (+) | #No TAG found in source code#
SPointerTypeRequired (+) | #No TAG found in source code#
SPreviousDeclWasNotOverload (+) | #No TAG found in source code#
SPropertyNotFoundInBaseClass (+) | #No TAG found in source code#
SReadableValueRequired (+) | #No TAG found in source code#
SRecordFieldRequired (+) | #No TAG found in source code#
SRecordTypeRequired (+) | #No TAG found in source code#
SRedeclaredIdentifier (+) | #No TAG found in source code#
SReturnTypeForbidden (+) | #No TAG found in source code#
SReturnTypeRequired (+) | #No TAG found in source code#
SScalarPropertyRequired (+) | #No TAG found in source code#
SSepiCompilerErrorFormat (+) | #No TAG found in source code#
SSepiErroneousTypeName (+) | #No TAG found in source code#
SSepiErrorName (+) | #No TAG found in source code#
SSepiFatalErrorName (+) | #No TAG found in source code#
SSepiHintName (+) | #No TAG found in source code#
SSepiInternalError (+) | #No TAG found in source code#
SSepiThereWereErrors (+) | #No TAG found in source code#
SSepiWarningName (+) | #No TAG found in source code#
SSetRangeTooWide (+) | #No TAG found in source code#
SSetTypeRequired (+) | #No TAG found in source code#
SShortStringTooLong (+) | #No TAG found in source code#
SSignatureAlreadyKnown (+) | #No TAG found in source code#
SStaticMarkerOnlyWithClassMethods (+) | #No TAG found in source code#
SStringNotTerminated (+) | #No TAG found in source code#
SStringOrArrayTypeOrTypeIdentifierRequired (+) | #No TAG found in source code#
SStringOrArrayTypeRequired (+) | #No TAG found in source code#
SStringOrDynArrayTypeRequired (+) | #No TAG found in source code#
SStringTypeOrTypeIdentifierRequired (+) | #No TAG found in source code#
SStringTypeRequired (+) | #No TAG found in source code#
SSyntaxError (+) | #No TAG found in source code#
STestValueIsAlways (+) | #No TAG found in source code#
STooManyActualParameters (+) | #No TAG found in source code#
STooManyArrayIndices (+) | #No TAG found in source code#
STooManyErrors (+) | #No TAG found in source code#
STooManyOperations (+) | #No TAG found in source code#
STopOfStackIsNotASymbol (+) | #No TAG found in source code#
STopOfStackIsNotATry (+) | #No TAG found in source code#
STypeHasNoTypeInfo (+) | #No TAG found in source code#
STypeIdentifierRequired (+) | #No TAG found in source code#
STypeIsNotBaseType (+) | #No TAG found in source code#
STypeMismatch (+) | #No TAG found in source code#
SUntypedEmptySetNotSupported (+) | #No TAG found in source code#
SValueCantBeRead (+) | #No TAG found in source code#
SValueRequired (+) | #No TAG found in source code#
SVarParamTypeMustBeStrictlyEqual (+) | #No TAG found in source code#
SVarValueRequired (+) | #No TAG found in source code#
SVirtualOrDynamicMethodRequired (+) | #No TAG found in source code#
SWritableValueRequired (+) | #No TAG found in source code#
SZeroMemoryCantHaveOperations (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiCompiler)
Next (SepiCompilerErrors)


Sepi

Sepi
Previous
Next (SArrayOrArrayPropRequired)

Name
SAddressableValueRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SAddressableValueRequired = 'Valeur adressable requise'

Sepi
Class Tree
Index
Previous
Next (SArrayOrArrayPropRequired)


Sepi

Sepi
Previous (SAddressableValueRequired)
Next (SArrayPropertyRequired)

Name
SArrayOrArrayPropRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SArrayOrArrayPropRequired = 'Valeur tableau ou propriété tableau requise'

Sepi
Class Tree
Index
Previous (SAddressableValueRequired)
Next (SArrayPropertyRequired)


Sepi

Sepi
Previous (SArrayOrArrayPropRequired)
Next (SArrayTypeOrTypeIdentifierRequired)

Name
SArrayPropertyRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SArrayPropertyRequired = 'Propriété tableau requise'

Sepi
Class Tree
Index
Previous (SArrayOrArrayPropRequired)
Next (SArrayTypeOrTypeIdentifierRequired)


Sepi

Sepi
Previous (SArrayPropertyRequired)
Next (SArrayTypeRequired)

Name
SArrayTypeOrTypeIdentifierRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SArrayTypeOrTypeIdentifierRequired = 'Type tableau ou identificateur de type requis'

Sepi
Class Tree
Index
Previous (SArrayPropertyRequired)
Next (SArrayTypeRequired)


Sepi

Sepi
Previous (SArrayTypeOrTypeIdentifierRequired)
Next (SBadSourceCharacter)

Name
SArrayTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SArrayTypeRequired = 'Type tableau requis'

Sepi
Class Tree
Index
Previous (SArrayTypeOrTypeIdentifierRequired)
Next (SBadSourceCharacter)


Sepi

Sepi
Previous (SArrayTypeRequired)
Next (SBadStringLength)

Name
SBadSourceCharacter

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBadSourceCharacter = 'Caractère %s incorrect dans un source'

Sepi
Class Tree
Index
Previous (SArrayTypeRequired)
Next (SBadStringLength)


Sepi

Sepi
Previous (SBadSourceCharacter)
Next (SBookmarksCantPassThroughLexer)

Name
SBadStringLength

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBadStringLength = 'La taille des chaînes doit être comprise entre 0 et 255 inclus'

Sepi
Class Tree
Index
Previous (SBadSourceCharacter)
Next (SBookmarksCantPassThroughLexer)


Sepi

Sepi
Previous (SBadStringLength)
Next (SBreakAllowedOnlyInLoop)

Name
SBookmarksCantPassThroughLexer

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBookmarksCantPassThroughLexer = 'Impossible de revenir en arrière en changeant d''analyseur lexical de ' + 'base.'

Sepi
Class Tree
Index
Previous (SBadStringLength)
Next (SBreakAllowedOnlyInLoop)


Sepi

Sepi
Previous (SBookmarksCantPassThroughLexer)
Next (SByRefParamCantHaveDefaultValue)

Name
SBreakAllowedOnlyInLoop

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SBreakAllowedOnlyInLoop = 'L''instruction Break n''est autorisée que dans une boucle'

Sepi
Class Tree
Index
Previous (SBookmarksCantPassThroughLexer)
Next (SByRefParamCantHaveDefaultValue)


Sepi

Sepi
Previous (SBreakAllowedOnlyInLoop)
Next (SCallableRequired)

Name
SByRefParamCantHaveDefaultValue

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SByRefParamCantHaveDefaultValue = 'Un paramètre passé par référence ne peut pas avoir de valeur par défaut'

Sepi
Class Tree
Index
Previous (SBreakAllowedOnlyInLoop)
Next (SCallableRequired)


Sepi

Sepi
Previous (SByRefParamCantHaveDefaultValue)
Next (SCallPatternOnlyOnClassMethod)

Name
SCallableRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCallableRequired = 'Expression invocable requise'

Sepi
Class Tree
Index
Previous (SByRefParamCantHaveDefaultValue)
Next (SCallPatternOnlyOnClassMethod)


Sepi

Sepi
Previous (SCallableRequired)
Next (SCantOpenDestFile)

Name
SCallPatternOnlyOnClassMethod

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCallPatternOnlyOnClassMethod = 'Forme d''appel autorisée uniquement sur les méthodes de classe'

Sepi
Class Tree
Index
Previous (SCallableRequired)
Next (SCantOpenDestFile)


Sepi

Sepi
Previous (SCallPatternOnlyOnClassMethod)
Next (SCantOpenSourceFile)

Name
SCantOpenDestFile

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantOpenDestFile = 'Ne peut ouvrir le fichier de destination %s'

Sepi
Class Tree
Index
Previous (SCallPatternOnlyOnClassMethod)
Next (SCantOpenSourceFile)


Sepi

Sepi
Previous (SCantOpenDestFile)
Next (SCantRemoveDereference)

Name
SCantOpenSourceFile

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantOpenSourceFile = 'Ne peut ouvrir le fichier source %s'

Sepi
Class Tree
Index
Previous (SCantOpenDestFile)
Next (SCantRemoveDereference)


Sepi

Sepi
Previous (SCantOpenSourceFile)
Next (SClassDoesNotImplementIntf)

Name
SCantRemoveDereference

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantRemoveDereference = 'Ne peut retirer de déréférencement'

Sepi
Class Tree
Index
Previous (SCantOpenSourceFile)
Next (SClassDoesNotImplementIntf)


Sepi

Sepi
Previous (SCantRemoveDereference)
Next (SClassTypeRequired)

Name
SClassDoesNotImplementIntf

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SClassDoesNotImplementIntf = 'La classe %s n''implémente pas l''interface %s'

Sepi
Class Tree
Index
Previous (SCantRemoveDereference)
Next (SClassTypeRequired)


Sepi

Sepi
Previous (SClassDoesNotImplementIntf)
Next (SCompilerTransientTypeForbidden)

Name
SClassTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SClassTypeRequired = 'Type classe requis'

Sepi
Class Tree
Index
Previous (SClassDoesNotImplementIntf)
Next (SCompilerTransientTypeForbidden)


Sepi

Sepi
Previous (SClassTypeRequired)
Next (SComponentRequired)

Name
SCompilerTransientTypeForbidden

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCompilerTransientTypeForbidden = 'Type de valeur spécial du compilateur non autorisé ici'

Sepi
Class Tree
Index
Previous (SClassTypeRequired)
Next (SComponentRequired)


Sepi

Sepi
Previous (SCompilerTransientTypeForbidden)
Next (SCompTypeTooNarrow)

Name
SComponentRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SComponentRequired = 'Nom d''objet requis'

Sepi
Class Tree
Index
Previous (SCompilerTransientTypeForbidden)
Next (SCompTypeTooNarrow)


Sepi

Sepi
Previous (SComponentRequired)
Next (SConstArgMustBeShort)

Name
SCompTypeTooNarrow

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCompTypeTooNarrow = 'Le type d''élément %s est trop petit pour contenir toutes les valeurs ' + 'possibles de cet ensemble'

Sepi
Class Tree
Index
Previous (SComponentRequired)
Next (SConstArgMustBeShort)


Sepi

Sepi
Previous (SCompTypeTooNarrow)
Next (SConstExpressionRequired)

Name
SConstArgMustBeShort

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SConstArgMustBeShort = 'L''argument constant doit être contenu dans un Shortint'

Sepi
Class Tree
Index
Previous (SCompTypeTooNarrow)
Next (SConstExpressionRequired)


Sepi

Sepi
Previous (SConstArgMustBeShort)
Next (SConstValueOutOfBounds)

Name
SConstExpressionRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SConstExpressionRequired = 'Expression constante attendue'

Sepi
Class Tree
Index
Previous (SConstArgMustBeShort)
Next (SConstValueOutOfBounds)


Sepi

Sepi
Previous (SConstExpressionRequired)
Next (SContainerTypeRequired)

Name
SConstValueOutOfBounds

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SConstValueOutOfBounds = 'La valeur constante dépasse les limites de sous-étendue'

Sepi
Class Tree
Index
Previous (SConstExpressionRequired)
Next (SContainerTypeRequired)


Sepi

Sepi
Previous (SConstValueOutOfBounds)
Next (SContinueAllowedOnlyInLoop)

Name
SContainerTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SContainerTypeRequired = 'Type classe, interface ou record requis'

Sepi
Class Tree
Index
Previous (SConstValueOutOfBounds)
Next (SContinueAllowedOnlyInLoop)


Sepi

Sepi
Previous (SContainerTypeRequired)
Next (SDeclarationDiffersFromPreviousOne)

Name
SContinueAllowedOnlyInLoop

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SContinueAllowedOnlyInLoop = 'L''instruction Continue n''est autorisée que dans une boucle'

Sepi
Class Tree
Index
Previous (SContainerTypeRequired)
Next (SDeclarationDiffersFromPreviousOne)


Sepi

Sepi
Previous (SContinueAllowedOnlyInLoop)
Next (SDuplicatedAbstractMarker)

Name
SDeclarationDiffersFromPreviousOne

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDeclarationDiffersFromPreviousOne = 'La déclaration de %s diffère de la déclaration précédente'

Sepi
Class Tree
Index
Previous (SContinueAllowedOnlyInLoop)
Next (SDuplicatedAbstractMarker)


Sepi

Sepi
Previous (SDeclarationDiffersFromPreviousOne)
Next (SDuplicateDefaultDirective)

Name
SDuplicatedAbstractMarker

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDuplicatedAbstractMarker = 'Directive abstract dupliquée'

Sepi
Class Tree
Index
Previous (SDeclarationDiffersFromPreviousOne)
Next (SDuplicateDefaultDirective)


Sepi

Sepi
Previous (SDuplicatedAbstractMarker)
Next (SDuplicateDefaultProperty)

Name
SDuplicateDefaultDirective

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDuplicateDefaultDirective = 'Directive default dupliquée'

Sepi
Class Tree
Index
Previous (SDuplicatedAbstractMarker)
Next (SDuplicateDefaultProperty)


Sepi

Sepi
Previous (SDuplicateDefaultDirective)
Next (SDuplicatedLinkKind)

Name
SDuplicateDefaultProperty

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDuplicateDefaultProperty = 'Ne peut avoir plusieurs propriétés par défaut'

Sepi
Class Tree
Index
Previous (SDuplicateDefaultDirective)
Next (SDuplicatedLinkKind)


Sepi

Sepi
Previous (SDuplicateDefaultProperty)
Next (SDuplicatedOfObjectMarker)

Name
SDuplicatedLinkKind

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDuplicatedLinkKind = 'Directive de type de liaison dupliquée'

Sepi
Class Tree
Index
Previous (SDuplicateDefaultProperty)
Next (SDuplicatedOfObjectMarker)


Sepi

Sepi
Previous (SDuplicatedLinkKind)
Next (SDynArrayTypeRequired)

Name
SDuplicatedOfObjectMarker

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDuplicatedOfObjectMarker = 'Directive of object dupliquée'

Sepi
Class Tree
Index
Previous (SDuplicatedLinkKind)
Next (SDynArrayTypeRequired)


Sepi

Sepi
Previous (SDuplicatedOfObjectMarker)
Next (SEndOfFile)

Name
SDynArrayTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SDynArrayTypeRequired = 'Type tableau dynamique requis'

Sepi
Class Tree
Index
Previous (SDuplicatedOfObjectMarker)
Next (SEndOfFile)


Sepi

Sepi
Previous (SDynArrayTypeRequired)
Next (SExecutableRequired)

Name
SEndOfFile

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SEndOfFile = 'Fin de fichier'

Sepi
Class Tree
Index
Previous (SDynArrayTypeRequired)
Next (SExecutableRequired)


Sepi

Sepi
Previous (SEndOfFile)
Next (SFieldOrMethodRequired)

Name
SExecutableRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SExecutableRequired = 'Expression exécutable requise'

Sepi
Class Tree
Index
Previous (SEndOfFile)
Next (SFieldOrMethodRequired)


Sepi

Sepi
Previous (SExecutableRequired)
Next (SFieldRequired)

Name
SFieldOrMethodRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SFieldOrMethodRequired = 'Champ ou méthode requis'

Sepi
Class Tree
Index
Previous (SExecutableRequired)
Next (SFieldRequired)


Sepi

Sepi
Previous (SFieldOrMethodRequired)
Next (SIdentifier)

Name
SFieldRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SFieldRequired = 'Champ requis'

Sepi
Class Tree
Index
Previous (SFieldOrMethodRequired)
Next (SIdentifier)


Sepi

Sepi
Previous (SFieldRequired)
Next (SIdentifierNotFound)

Name
SIdentifier

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SIdentifier = 'Identificateur'

Sepi
Class Tree
Index
Previous (SFieldRequired)
Next (SIdentifierNotFound)


Sepi

Sepi
Previous (SIdentifier)
Next (SIdentifierRequired)

Name
SIdentifierNotFound

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SIdentifierNotFound = 'Identificateur %s non déclaré'

Sepi
Class Tree
Index
Previous (SIdentifier)
Next (SIdentifierRequired)


Sepi

Sepi
Previous (SIdentifierNotFound)
Next (SInheritNeedClassOrObjectMethod)

Name
SIdentifierRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SIdentifierRequired = 'Identificateur requis'

Sepi
Class Tree
Index
Previous (SIdentifierNotFound)
Next (SInheritNeedClassOrObjectMethod)


Sepi

Sepi
Previous (SIdentifierRequired)
Next (SInterfaceTypeRequired)

Name
SInheritNeedClassOrObjectMethod

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInheritNeedClassOrObjectMethod = 'Appel de type inherited invalide hors d''une méthode d''objet ou de ' + 'classe'

Sepi
Class Tree
Index
Previous (SIdentifierRequired)
Next (SInterfaceTypeRequired)


Sepi

Sepi
Previous (SInheritNeedClassOrObjectMethod)
Next (SIntfMethodCantBeOverloaded)

Name
SInterfaceTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInterfaceTypeRequired = 'Type interface requis'

Sepi
Class Tree
Index
Previous (SInheritNeedClassOrObjectMethod)
Next (SIntfMethodCantBeOverloaded)


Sepi

Sepi
Previous (SInterfaceTypeRequired)
Next (SIntfMethodCantChangeLinkKind)

Name
SIntfMethodCantBeOverloaded

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SIntfMethodCantBeOverloaded = 'Les méthodes d''interface ne peuvent être surchargées'

Sepi
Class Tree
Index
Previous (SInterfaceTypeRequired)
Next (SIntfMethodCantChangeLinkKind)


Sepi

Sepi
Previous (SIntfMethodCantBeOverloaded)
Next (SInvalidArrayOfConstItem)

Name
SIntfMethodCantChangeLinkKind

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SIntfMethodCantChangeLinkKind = 'Type de liaison invalide pour une méthode d''interface'

Sepi
Class Tree
Index
Previous (SIntfMethodCantBeOverloaded)
Next (SInvalidArrayOfConstItem)


Sepi

Sepi
Previous (SIntfMethodCantChangeLinkKind)
Next (SInvalidCast)

Name
SInvalidArrayOfConstItem

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidArrayOfConstItem = 'Type de valeur non autorisé dans un élément de tableau ouvert'

Sepi
Class Tree
Index
Previous (SIntfMethodCantChangeLinkKind)
Next (SInvalidCast)


Sepi

Sepi
Previous (SInvalidArrayOfConstItem)
Next (SInvalidDataSize)

Name
SInvalidCast

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidCast = 'Transtypage invalide de %s en %s'

Sepi
Class Tree
Index
Previous (SInvalidArrayOfConstItem)
Next (SInvalidDataSize)


Sepi

Sepi
Previous (SInvalidCast)
Next (SInvalidStorageValue)

Name
SInvalidDataSize

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidDataSize = 'Taille de données invalide'

Sepi
Class Tree
Index
Previous (SInvalidCast)
Next (SInvalidStorageValue)


Sepi

Sepi
Previous (SInvalidDataSize)
Next (SLabelAlreadyExists)

Name
SInvalidStorageValue

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidStorageValue = 'Spécificateur de stockage invalide'

Sepi
Class Tree
Index
Previous (SInvalidDataSize)
Next (SLabelAlreadyExists)


Sepi

Sepi
Previous (SInvalidStorageValue)
Next (SLabelNotFound)

Name
SLabelAlreadyExists

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SLabelAlreadyExists = 'Le label ''%s'' existe déjà'

Sepi
Class Tree
Index
Previous (SInvalidStorageValue)
Next (SLabelNotFound)


Sepi

Sepi
Previous (SLabelAlreadyExists)
Next (SLocalVarNameRequired)

Name
SLabelNotFound

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SLabelNotFound = 'Label ''%s'' non trouvé'

Sepi
Class Tree
Index
Previous (SLabelAlreadyExists)
Next (SLocalVarNameRequired)


Sepi

Sepi
Previous (SLabelNotFound)
Next (SMemoryCantAccessObject)

Name
SLocalVarNameRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SLocalVarNameRequired = 'Variable locale requise'

Sepi
Class Tree
Index
Previous (SLabelNotFound)
Next (SMemoryCantAccessObject)


Sepi

Sepi
Previous (SLocalVarNameRequired)
Next (SMemoryCantBeConstant)

Name
SMemoryCantAccessObject

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMemoryCantAccessObject = 'Impossible d''accéder à l''objet %s'

Sepi
Class Tree
Index
Previous (SLocalVarNameRequired)
Next (SMemoryCantBeConstant)


Sepi

Sepi
Previous (SMemoryCantAccessObject)
Next (SMemoryCantBeTrueConst)

Name
SMemoryCantBeConstant

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMemoryCantBeConstant = 'La référence mémoire ne peut être constante'

Sepi
Class Tree
Index
Previous (SMemoryCantAccessObject)
Next (SMemoryCantBeTrueConst)


Sepi

Sepi
Previous (SMemoryCantBeConstant)
Next (SMemoryCantBeZero)

Name
SMemoryCantBeTrueConst

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMemoryCantBeTrueConst = 'La référence mémoire ne peut être une vraie constante'

Sepi
Class Tree
Index
Previous (SMemoryCantBeConstant)
Next (SMemoryCantBeZero)


Sepi

Sepi
Previous (SMemoryCantBeTrueConst)
Next (SMemoryRefIsSealed)

Name
SMemoryCantBeZero

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMemoryCantBeZero = 'La référence mémoire ne peut être zéro'

Sepi
Class Tree
Index
Previous (SMemoryCantBeTrueConst)
Next (SMemoryRefIsSealed)


Sepi

Sepi
Previous (SMemoryCantBeZero)
Next (SMemorySpaceOffsetMustBeWord)

Name
SMemoryRefIsSealed

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMemoryRefIsSealed = 'La référence mémoire est scellée'

Sepi
Class Tree
Index
Previous (SMemoryCantBeZero)
Next (SMemorySpaceOffsetMustBeWord)


Sepi

Sepi
Previous (SMemoryRefIsSealed)
Next (SMetaClassTypeRequired)

Name
SMemorySpaceOffsetMustBeWord

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMemorySpaceOffsetMustBeWord = 'L''offset d''espace mémoire doit être contenu dans un Word'

Sepi
Class Tree
Index
Previous (SMemoryRefIsSealed)
Next (SMetaClassTypeRequired)


Sepi

Sepi
Previous (SMemorySpaceOffsetMustBeWord)
Next (SMethodAlreadyImplemented)

Name
SMetaClassTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMetaClassTypeRequired = 'Type méta-classe requis'

Sepi
Class Tree
Index
Previous (SMemorySpaceOffsetMustBeWord)
Next (SMethodAlreadyImplemented)


Sepi

Sepi
Previous (SMetaClassTypeRequired)
Next (SMethodMustBeOverloaded)

Name
SMethodAlreadyImplemented

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMethodAlreadyImplemented = 'La méthode %s a déjà été implémentée'

Sepi
Class Tree
Index
Previous (SMetaClassTypeRequired)
Next (SMethodMustBeOverloaded)


Sepi

Sepi
Previous (SMethodAlreadyImplemented)
Next (SMethodNotDeclared)

Name
SMethodMustBeOverloaded

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMethodMustBeOverloaded = 'La méthode %s doit être marquée avec la directive overload'

Sepi
Class Tree
Index
Previous (SMethodAlreadyImplemented)
Next (SMethodNotDeclared)


Sepi

Sepi
Previous (SMethodMustBeOverloaded)
Next (SMethodNotFoundInBaseClass)

Name
SMethodNotDeclared

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMethodNotDeclared = 'Méthode %s non déclarée'

Sepi
Class Tree
Index
Previous (SMethodMustBeOverloaded)
Next (SMethodNotFoundInBaseClass)


Sepi

Sepi
Previous (SMethodNotDeclared)
Next (SMethodRequired)

Name
SMethodNotFoundInBaseClass

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMethodNotFoundInBaseClass = 'Méthode non trouvée dans la classe de base'

Sepi
Class Tree
Index
Previous (SMethodNotDeclared)
Next (SMethodRequired)


Sepi

Sepi
Previous (SMethodNotFoundInBaseClass)
Next (SMultiNameParamCantHaveDefaultValue)

Name
SMethodRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMethodRequired = 'Identificateur de méthode requis'

Sepi
Class Tree
Index
Previous (SMethodNotFoundInBaseClass)
Next (SMultiNameParamCantHaveDefaultValue)


Sepi

Sepi
Previous (SMethodRequired)
Next (SMultipleParamsWithSameSepiStackOffset)

Name
SMultiNameParamCantHaveDefaultValue

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMultiNameParamCantHaveDefaultValue = 'Une définition de plusieurs paramètres ne peut pas avoir de valeur par ' + 'défaut'

Sepi
Class Tree
Index
Previous (SMethodRequired)
Next (SMultipleParamsWithSameSepiStackOffset)


Sepi

Sepi
Previous (SMultiNameParamCantHaveDefaultValue)
Next (SNeedConstExpression)

Name
SMultipleParamsWithSameSepiStackOffset

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SMultipleParamsWithSameSepiStackOffset = 'Plusieurs paramètres ont la même valeur de SepiStackOffset'

Sepi
Class Tree
Index
Previous (SMultiNameParamCantHaveDefaultValue)
Next (SNeedConstExpression)


Sepi

Sepi
Previous (SMultipleParamsWithSameSepiStackOffset)
Next (SNoMatchingOverloadedMethod)

Name
SNeedConstExpression

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SNeedConstExpression = 'Expression constante attendue'

Sepi
Class Tree
Index
Previous (SMultipleParamsWithSameSepiStackOffset)
Next (SNoMatchingOverloadedMethod)


Sepi

Sepi
Previous (SNeedConstExpression)
Next (SNotEnoughActualParameters)

Name
SNoMatchingOverloadedMethod

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SNoMatchingOverloadedMethod = 'Aucune méthode surchargée ne peut être invoquée avec ces paramètres'

Sepi
Class Tree
Index
Previous (SNeedConstExpression)
Next (SNotEnoughActualParameters)


Sepi

Sepi
Previous (SNoMatchingOverloadedMethod)
Next (SNotInTry)

Name
SNotEnoughActualParameters

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SNotEnoughActualParameters = 'Pas assez de paramètres réels'

Sepi
Class Tree
Index
Previous (SNoMatchingOverloadedMethod)
Next (SNotInTry)


Sepi

Sepi
Previous (SNotEnoughActualParameters)
Next (SObjectMustHaveASignature)

Name
SNotInTry

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SNotInTry = 'La pile n''est pas dans un try'

Sepi
Class Tree
Index
Previous (SNotEnoughActualParameters)
Next (SObjectMustHaveASignature)


Sepi

Sepi
Previous (SNotInTry)
Next (SOpenArrayParamCantHaveDefaultValue)

Name
SObjectMustHaveASignature

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SObjectMustHaveASignature = 'L''objet %s n''a pas de signature'

Sepi
Class Tree
Index
Previous (SNotInTry)
Next (SOpenArrayParamCantHaveDefaultValue)


Sepi

Sepi
Previous (SObjectMustHaveASignature)
Next (SOpenArrayRequired)

Name
SOpenArrayParamCantHaveDefaultValue

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOpenArrayParamCantHaveDefaultValue = 'Un paramètre tableau ouvert ne peut pas avoir de valeur par défaut'

Sepi
Class Tree
Index
Previous (SObjectMustHaveASignature)
Next (SOpenArrayRequired)


Sepi

Sepi
Previous (SOpenArrayParamCantHaveDefaultValue)
Next (SOperationNotApplicableToType)

Name
SOpenArrayRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOpenArrayRequired = 'Tableau ouvert de type %s requis'

Sepi
Class Tree
Index
Previous (SOpenArrayParamCantHaveDefaultValue)
Next (SOperationNotApplicableToType)


Sepi

Sepi
Previous (SOpenArrayRequired)
Next (SOrdinalOrArrayTypeRequired)

Name
SOperationNotApplicableToType

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOperationNotApplicableToType = 'Opération non applicable à ce type d''opérande'

Sepi
Class Tree
Index
Previous (SOpenArrayRequired)
Next (SOrdinalOrArrayTypeRequired)


Sepi

Sepi
Previous (SOperationNotApplicableToType)
Next (SOrdinalTypeRequired)

Name
SOrdinalOrArrayTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOrdinalOrArrayTypeRequired = 'Type ordinal ou tableau requis'

Sepi
Class Tree
Index
Previous (SOperationNotApplicableToType)
Next (SOrdinalTypeRequired)


Sepi

Sepi
Previous (SOrdinalOrArrayTypeRequired)
Next (SParametersMismatch)

Name
SOrdinalTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOrdinalTypeRequired = 'Type ordinal requis'

Sepi
Class Tree
Index
Previous (SOrdinalOrArrayTypeRequired)
Next (SParametersMismatch)


Sepi

Sepi
Previous (SOrdinalTypeRequired)
Next (SParamsAlreadyCompleted)

Name
SParametersMismatch

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SParametersMismatch = 'Les paramètres ne correspondent pas'

Sepi
Class Tree
Index
Previous (SOrdinalTypeRequired)
Next (SParamsAlreadyCompleted)


Sepi

Sepi
Previous (SParametersMismatch)
Next (SParamsSepiStackOffsetsDontFollow)

Name
SParamsAlreadyCompleted

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SParamsAlreadyCompleted = 'Les paramètres ont déjà été complétés'

Sepi
Class Tree
Index
Previous (SParametersMismatch)
Next (SParamsSepiStackOffsetsDontFollow)


Sepi

Sepi
Previous (SParamsAlreadyCompleted)
Next (SPointerTypeRequired)

Name
SParamsSepiStackOffsetsDontFollow

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SParamsSepiStackOffsetsDontFollow = 'Les SepiStackOffset des paramètres ne se suivent pas'

Sepi
Class Tree
Index
Previous (SParamsAlreadyCompleted)
Next (SPointerTypeRequired)


Sepi

Sepi
Previous (SParamsSepiStackOffsetsDontFollow)
Next (SPreviousDeclWasNotOverload)

Name
SPointerTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SPointerTypeRequired = 'Type pointeur requis'

Sepi
Class Tree
Index
Previous (SParamsSepiStackOffsetsDontFollow)
Next (SPreviousDeclWasNotOverload)


Sepi

Sepi
Previous (SPointerTypeRequired)
Next (SPropertyNotFoundInBaseClass)

Name
SPreviousDeclWasNotOverload

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SPreviousDeclWasNotOverload = 'La déclaration précédente de %s n''a pas été marquée avec la directive ' + 'overload'

Sepi
Class Tree
Index
Previous (SPointerTypeRequired)
Next (SPropertyNotFoundInBaseClass)


Sepi

Sepi
Previous (SPreviousDeclWasNotOverload)
Next (SReadableValueRequired)

Name
SPropertyNotFoundInBaseClass

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SPropertyNotFoundInBaseClass = 'La propriété n''a pas été trouvée dans la classe de base'

Sepi
Class Tree
Index
Previous (SPreviousDeclWasNotOverload)
Next (SReadableValueRequired)


Sepi

Sepi
Previous (SPropertyNotFoundInBaseClass)
Next (SRecordFieldRequired)

Name
SReadableValueRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SReadableValueRequired = 'Valeur requise'

Sepi
Class Tree
Index
Previous (SPropertyNotFoundInBaseClass)
Next (SRecordFieldRequired)


Sepi

Sepi
Previous (SReadableValueRequired)
Next (SRecordTypeRequired)

Name
SRecordFieldRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SRecordFieldRequired = 'Champ de type record requis'

Sepi
Class Tree
Index
Previous (SReadableValueRequired)
Next (SRecordTypeRequired)


Sepi

Sepi
Previous (SRecordFieldRequired)
Next (SRedeclaredIdentifier)

Name
SRecordTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SRecordTypeRequired = 'Type record requis'

Sepi
Class Tree
Index
Previous (SRecordFieldRequired)
Next (SRedeclaredIdentifier)


Sepi

Sepi
Previous (SRecordTypeRequired)
Next (SReturnTypeForbidden)

Name
SRedeclaredIdentifier

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SRedeclaredIdentifier = 'Identificateur redéclaré'

Sepi
Class Tree
Index
Previous (SRecordTypeRequired)
Next (SReturnTypeForbidden)


Sepi

Sepi
Previous (SRedeclaredIdentifier)
Next (SReturnTypeRequired)

Name
SReturnTypeForbidden

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SReturnTypeForbidden = 'La procédure ne peut avoir de type de retour'

Sepi
Class Tree
Index
Previous (SRedeclaredIdentifier)
Next (SReturnTypeRequired)


Sepi

Sepi
Previous (SReturnTypeForbidden)
Next (SScalarPropertyRequired)

Name
SReturnTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SReturnTypeRequired = 'La fonction exige un type de retour'

Sepi
Class Tree
Index
Previous (SReturnTypeForbidden)
Next (SScalarPropertyRequired)


Sepi

Sepi
Previous (SReturnTypeRequired)
Next (SSepiCompilerErrorFormat)

Name
SScalarPropertyRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SScalarPropertyRequired = 'Propriété non-tableau requise'

Sepi
Class Tree
Index
Previous (SReturnTypeRequired)
Next (SSepiCompilerErrorFormat)


Sepi

Sepi
Previous (SScalarPropertyRequired)
Next (SSepiErroneousTypeName)

Name
SSepiCompilerErrorFormat

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiCompilerErrorFormat = '[%s] %s(%d, %d) : %s'

Sepi
Class Tree
Index
Previous (SScalarPropertyRequired)
Next (SSepiErroneousTypeName)


Sepi

Sepi
Previous (SSepiCompilerErrorFormat)
Next (SSepiErrorName)

Name
SSepiErroneousTypeName

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiErroneousTypeName = 'type erroné'

Sepi
Class Tree
Index
Previous (SSepiCompilerErrorFormat)
Next (SSepiErrorName)


Sepi

Sepi
Previous (SSepiErroneousTypeName)
Next (SSepiFatalErrorName)

Name
SSepiErrorName

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiErrorName = 'Erreur'

Sepi
Class Tree
Index
Previous (SSepiErroneousTypeName)
Next (SSepiFatalErrorName)


Sepi

Sepi
Previous (SSepiErrorName)
Next (SSepiHintName)

Name
SSepiFatalErrorName

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiFatalErrorName = 'Erreur fatale'

Sepi
Class Tree
Index
Previous (SSepiErrorName)
Next (SSepiHintName)


Sepi

Sepi
Previous (SSepiFatalErrorName)
Next (SSepiInternalError)

Name
SSepiHintName

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiHintName = 'Conseil'

Sepi
Class Tree
Index
Previous (SSepiFatalErrorName)
Next (SSepiInternalError)


Sepi

Sepi
Previous (SSepiHintName)
Next (SSepiThereWereErrors)

Name
SSepiInternalError

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiInternalError = 'Erreur interne : %s'

Sepi
Class Tree
Index
Previous (SSepiHintName)
Next (SSepiThereWereErrors)


Sepi

Sepi
Previous (SSepiInternalError)
Next (SSepiWarningName)

Name
SSepiThereWereErrors

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiThereWereErrors = 'Il y a eu des erreurs à la compilation'

Sepi
Class Tree
Index
Previous (SSepiInternalError)
Next (SSepiWarningName)


Sepi

Sepi
Previous (SSepiThereWereErrors)
Next (SSetRangeTooWide)

Name
SSepiWarningName

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiWarningName = 'Avertissement'

Sepi
Class Tree
Index
Previous (SSepiThereWereErrors)
Next (SSetRangeTooWide)


Sepi

Sepi
Previous (SSepiWarningName)
Next (SSetTypeRequired)

Name
SSetRangeTooWide

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSetRangeTooWide = 'L''ensemble des valeurs est trop étendu'

Sepi
Class Tree
Index
Previous (SSepiWarningName)
Next (SSetTypeRequired)


Sepi

Sepi
Previous (SSetRangeTooWide)
Next (SShortStringTooLong)

Name
SSetTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSetTypeRequired = 'Type ensemble requis'

Sepi
Class Tree
Index
Previous (SSetRangeTooWide)
Next (SShortStringTooLong)


Sepi

Sepi
Previous (SSetTypeRequired)
Next (SSignatureAlreadyKnown)

Name
SShortStringTooLong

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SShortStringTooLong = 'La chaîne de caractère est trop longue (%d au lieu de %s)'

Sepi
Class Tree
Index
Previous (SSetTypeRequired)
Next (SSignatureAlreadyKnown)


Sepi

Sepi
Previous (SShortStringTooLong)
Next (SStaticMarkerOnlyWithClassMethods)

Name
SSignatureAlreadyKnown

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSignatureAlreadyKnown = 'La signature est déjà connue'

Sepi
Class Tree
Index
Previous (SShortStringTooLong)
Next (SStaticMarkerOnlyWithClassMethods)


Sepi

Sepi
Previous (SSignatureAlreadyKnown)
Next (SStringNotTerminated)

Name
SStaticMarkerOnlyWithClassMethods

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SStaticMarkerOnlyWithClassMethods = 'Seules les méthodes de classe peuvent être marquées ''static'''

Sepi
Class Tree
Index
Previous (SSignatureAlreadyKnown)
Next (SStringNotTerminated)


Sepi

Sepi
Previous (SStaticMarkerOnlyWithClassMethods)
Next (SStringOrArrayTypeOrTypeIdentifierRequired)

Name
SStringNotTerminated

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SStringNotTerminated = 'Chaîne non terminée'

Sepi
Class Tree
Index
Previous (SStaticMarkerOnlyWithClassMethods)
Next (SStringOrArrayTypeOrTypeIdentifierRequired)


Sepi

Sepi
Previous (SStringNotTerminated)
Next (SStringOrArrayTypeRequired)

Name
SStringOrArrayTypeOrTypeIdentifierRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SStringOrArrayTypeOrTypeIdentifierRequired = 'Type tableau, type chaîne, ou identificateur de type requis'

Sepi
Class Tree
Index
Previous (SStringNotTerminated)
Next (SStringOrArrayTypeRequired)


Sepi

Sepi
Previous (SStringOrArrayTypeOrTypeIdentifierRequired)
Next (SStringOrDynArrayTypeRequired)

Name
SStringOrArrayTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SStringOrArrayTypeRequired = 'Type chaîne ou tableau requis'

Sepi
Class Tree
Index
Previous (SStringOrArrayTypeOrTypeIdentifierRequired)
Next (SStringOrDynArrayTypeRequired)


Sepi

Sepi
Previous (SStringOrArrayTypeRequired)
Next (SStringTypeOrTypeIdentifierRequired)

Name
SStringOrDynArrayTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SStringOrDynArrayTypeRequired = 'Type chaîne ou tableau dynamique requis'

Sepi
Class Tree
Index
Previous (SStringOrArrayTypeRequired)
Next (SStringTypeOrTypeIdentifierRequired)


Sepi

Sepi
Previous (SStringOrDynArrayTypeRequired)
Next (SStringTypeRequired)

Name
SStringTypeOrTypeIdentifierRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SStringTypeOrTypeIdentifierRequired = 'Type chaîne ou identificateur de type requis'

Sepi
Class Tree
Index
Previous (SStringOrDynArrayTypeRequired)
Next (SStringTypeRequired)


Sepi

Sepi
Previous (SStringTypeOrTypeIdentifierRequired)
Next (SSyntaxError)

Name
SStringTypeRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SStringTypeRequired = 'Type chaîne requis'

Sepi
Class Tree
Index
Previous (SStringTypeOrTypeIdentifierRequired)
Next (SSyntaxError)


Sepi

Sepi
Previous (SStringTypeRequired)
Next (STestValueIsAlways)

Name
SSyntaxError

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSyntaxError = '%s attendu mais %s trouvé'

Sepi
Class Tree
Index
Previous (SStringTypeRequired)
Next (STestValueIsAlways)


Sepi

Sepi
Previous (SSyntaxError)
Next (STooManyActualParameters)

Name
STestValueIsAlways

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STestValueIsAlways = 'La condition est toujours évaluée à %s'

Sepi
Class Tree
Index
Previous (SSyntaxError)
Next (STooManyActualParameters)


Sepi

Sepi
Previous (STestValueIsAlways)
Next (STooManyArrayIndices)

Name
STooManyActualParameters

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STooManyActualParameters = 'Trop de paramètres réels'

Sepi
Class Tree
Index
Previous (STestValueIsAlways)
Next (STooManyArrayIndices)


Sepi

Sepi
Previous (STooManyActualParameters)
Next (STooManyErrors)

Name
STooManyArrayIndices

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STooManyArrayIndices = 'Trop d''index pour ce tableau'

Sepi
Class Tree
Index
Previous (STooManyActualParameters)
Next (STooManyErrors)


Sepi

Sepi
Previous (STooManyArrayIndices)
Next (STooManyOperations)

Name
STooManyErrors

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STooManyErrors = 'Trop d''erreurs'

Sepi
Class Tree
Index
Previous (STooManyArrayIndices)
Next (STooManyOperations)


Sepi

Sepi
Previous (STooManyErrors)
Next (STopOfStackIsNotASymbol)

Name
STooManyOperations

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STooManyOperations = 'Une référence mémoire ne peut avoir que 15 opérations maximum'

Sepi
Class Tree
Index
Previous (STooManyErrors)
Next (STopOfStackIsNotASymbol)


Sepi

Sepi
Previous (STooManyOperations)
Next (STopOfStackIsNotATry)

Name
STopOfStackIsNotASymbol

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STopOfStackIsNotASymbol = 'Le sommet de la pile n''est pas un symbole'

Sepi
Class Tree
Index
Previous (STooManyOperations)
Next (STopOfStackIsNotATry)


Sepi

Sepi
Previous (STopOfStackIsNotASymbol)
Next (STypeHasNoTypeInfo)

Name
STopOfStackIsNotATry

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STopOfStackIsNotATry = 'Le sommet de la pile n''est pas un try'

Sepi
Class Tree
Index
Previous (STopOfStackIsNotASymbol)
Next (STypeHasNoTypeInfo)


Sepi

Sepi
Previous (STopOfStackIsNotATry)
Next (STypeIdentifierRequired)

Name
STypeHasNoTypeInfo

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STypeHasNoTypeInfo = 'Ce type n''a pas d''informations de type'

Sepi
Class Tree
Index
Previous (STopOfStackIsNotATry)
Next (STypeIdentifierRequired)


Sepi

Sepi
Previous (STypeHasNoTypeInfo)
Next (STypeIsNotBaseType)

Name
STypeIdentifierRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STypeIdentifierRequired = 'Identificateur de type requis'

Sepi
Class Tree
Index
Previous (STypeHasNoTypeInfo)
Next (STypeIsNotBaseType)


Sepi

Sepi
Previous (STypeIdentifierRequired)
Next (STypeMismatch)

Name
STypeIsNotBaseType

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STypeIsNotBaseType = 'Le type %s n''est pas un type de base pour l''interpréteur Sepi'

Sepi
Class Tree
Index
Previous (STypeIdentifierRequired)
Next (STypeMismatch)


Sepi

Sepi
Previous (STypeIsNotBaseType)
Next (SUntypedEmptySetNotSupported)

Name
STypeMismatch

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
STypeMismatch = 'Types incompatibles : %s et %s'

Sepi
Class Tree
Index
Previous (STypeIsNotBaseType)
Next (SUntypedEmptySetNotSupported)


Sepi

Sepi
Previous (STypeMismatch)
Next (SValueCantBeRead)

Name
SUntypedEmptySetNotSupported

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SUntypedEmptySetNotSupported = 'Ensemble vide non typé non supporté'

Sepi
Class Tree
Index
Previous (STypeMismatch)
Next (SValueCantBeRead)


Sepi

Sepi
Previous (SUntypedEmptySetNotSupported)
Next (SValueRequired)

Name
SValueCantBeRead

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SValueCantBeRead = 'La valeur ne peut être lue'

Sepi
Class Tree
Index
Previous (SUntypedEmptySetNotSupported)
Next (SValueRequired)


Sepi

Sepi
Previous (SValueCantBeRead)
Next (SVarParamTypeMustBeStrictlyEqual)

Name
SValueRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SValueRequired = 'Valeur requise'

Sepi
Class Tree
Index
Previous (SValueCantBeRead)
Next (SVarParamTypeMustBeStrictlyEqual)


Sepi

Sepi
Previous (SValueRequired)
Next (SVarValueRequired)

Name
SVarParamTypeMustBeStrictlyEqual

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SVarParamTypeMustBeStrictlyEqual = 'Les paramètres var originaux et formels doivent avoir le même type'

Sepi
Class Tree
Index
Previous (SValueRequired)
Next (SVarValueRequired)


Sepi

Sepi
Previous (SVarParamTypeMustBeStrictlyEqual)
Next (SVirtualOrDynamicMethodRequired)

Name
SVarValueRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SVarValueRequired = 'Variable requise'

Sepi
Class Tree
Index
Previous (SVarParamTypeMustBeStrictlyEqual)
Next (SVirtualOrDynamicMethodRequired)


Sepi

Sepi
Previous (SVarValueRequired)
Next (SWritableValueRequired)

Name
SVirtualOrDynamicMethodRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SVirtualOrDynamicMethodRequired = 'Méthode virtuelle ou dynamique requise'

Sepi
Class Tree
Index
Previous (SVarValueRequired)
Next (SWritableValueRequired)


Sepi

Sepi
Previous (SVirtualOrDynamicMethodRequired)
Next (SZeroMemoryCantHaveOperations)

Name
SWritableValueRequired

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SWritableValueRequired = 'La valeur ne peut être écrite'

Sepi
Class Tree
Index
Previous (SVirtualOrDynamicMethodRequired)
Next (SZeroMemoryCantHaveOperations)


Sepi

Sepi
Previous (SWritableValueRequired)
Next

Name
SZeroMemoryCantHaveOperations

Parent
SepiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SZeroMemoryCantHaveOperations = 'Une référence mémoire vers des 0 ne peut avoir d''opérations'

Sepi
Class Tree
Index
Previous (SWritableValueRequired)
Next


Sepi

Sepi
Previous (SepiCompilerConsts)
Next (SepiCompilerUtils)

Name
SepiCompilerErrors

Parent
Sepi

Description
Gestion des erreurs de compilation Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TSepiAddErrorEvent (+) | Type de l'événement OnAddError de TSepiCompilerErrorList
TSepiErrorKind (+) | Type d'erreur de compilation Sepi

Constants
Constant | Description
MaxErrors (+) | Nombre maximum d'erreurs avant d'abandonner la compilation
SepiNoPosition (+) | Position non renseignée

Variables
Variable | Description
SepiErrorKindNames (+) | Nom des types d'erreur de compilation Sepi

Classes
Class | Description
ESepiCompilerFatalError (+) | Exception déclenchée en cas d'erreur fatale de compilation
TSepiCompilerError (+) | Erreur de compilation Sepi
TSepiCompilerErrorList (+) | Liste d'erreurs de compilation Sepi
TSepiSourcePosition (+) | Position dans un source Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiCompilerConsts)
Next (SepiCompilerUtils)


Sepi

Sepi
Previous
Next (TSepiCompilerError)

Name
ESepiCompilerFatalError

Parent
SepiCompilerErrors

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Exception déclenchée en cas d'erreur fatale de compilation

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiCompilerError)


Sepi

Sepi
Previous (ESepiCompilerFatalError)
Next (TSepiCompilerErrorList)

Name
TSepiCompilerError

Parent
SepiCompilerErrors

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Erreur de compilation Sepi

Members
Fields
Field | Description
FErrorMsg (-) | Message d'erreur
FKind (-) | Type d'erreur
FPosition (-) | Position dans le source

Methods
Method | Description
Create (+) | Crée une erreur de compilation Sepi
Create (+) | Crée une erreur de compilation Sepi de type Erreur
Create (+) | Crée une erreur de compilation Sepi
Create (+) | Crée une erreur de compilation Sepi
GetAsText (-) | Représentation textuelle de l'erreur

Properties
Property | Description
AsText (+) | Représentation textuelle de l'erreur
Col (+) | Colonne
ErrorMsg (+) | Message d'erreur
FileName (+) | Nom du fichier
Kind (+) | Type d'erreur
Line (+) | Ligne
Position (+) | Position dans le source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiCompilerFatalError)
Next (TSepiCompilerErrorList)


Sepi

Sepi
Previous
Next (FKind)

Name
FErrorMsg

Parent
TSepiCompilerError

Visibility
PRIVATE

Description
Message d'erreur

Source code
FErrorMsg : string

Sepi
Class Tree
Index
Previous
Next (FKind)


Sepi

Sepi
Previous (FErrorMsg)
Next (FPosition)

Name
FKind

Parent
TSepiCompilerError

Visibility
PRIVATE

Description
Type d'erreur

Source code
FKind : TSepiErrorKind

Sepi
Class Tree
Index
Previous (FErrorMsg)
Next (FPosition)


Sepi

Sepi
Previous (FKind)
Next

Name
FPosition

Parent
TSepiCompilerError

Visibility
PRIVATE

Description
Position dans le source

Source code
FPosition : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (FKind)
Next


Sepi

Sepi
Previous
Next (Col)

Name
AsText

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Représentation textuelle de l'erreur

Source code
property AsText : string read GetAsText

Read Access
GetAsText

Sepi
Class Tree
Index
Previous
Next (Col)


Sepi

Sepi
Previous (AsText)
Next (ErrorMsg)

Name
Col

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Colonne

Source code
property Col : Integer read FPosition . Col

Read Access
FPosition

Sepi
Class Tree
Index
Previous (AsText)
Next (ErrorMsg)


Sepi

Sepi
Previous (Col)
Next (FileName)

Name
ErrorMsg

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Message d'erreur

Source code
property ErrorMsg : string read FErrorMsg

Read Access
FErrorMsg

Sepi
Class Tree
Index
Previous (Col)
Next (FileName)


Sepi

Sepi
Previous (ErrorMsg)
Next (Kind)

Name
FileName

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Nom du fichier

Source code
property FileName : TFileName read FPosition . FileName

Read Access
FPosition

Sepi
Class Tree
Index
Previous (ErrorMsg)
Next (Kind)


Sepi

Sepi
Previous (FileName)
Next (Line)

Name
Kind

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Type d'erreur

Source code
property Kind : TSepiErrorKind read FKind

Read Access
FKind

Sepi
Class Tree
Index
Previous (FileName)
Next (Line)


Sepi

Sepi
Previous (Kind)
Next (Position)

Name
Line

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Ligne

Source code
property Line : Integer read FPosition . Line

Read Access
FPosition

Sepi
Class Tree
Index
Previous (Kind)
Next (Position)


Sepi

Sepi
Previous (Line)
Next

Name
Position

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Position dans le source

Source code
property Position : TSepiSourcePosition read FPosition

Read Access
FPosition

Sepi
Class Tree
Index
Previous (Line)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Crée une erreur de compilation Sepi

Source code
constructor Create ( const AErrorMsg : string ; AKind : TSepiErrorKind ; const AFileName : TFileName = '' ; ALine : Integer = 0 ; ACol : Integer = 0 ) ; overload

Parameters
Parameter | Description
AErrorMsg : STRING | Message d'erreur
AKind : TSepiErrorKind | Type d'erreur
AFileName : TFileName | Nom du fichier
ALine : INTEGER | Ligne (défaut = 0)
ACol : INTEGER | Colonne (défaut = 0)

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Crée une erreur de compilation Sepi de type Erreur

Source code
constructor Create ( const AErrorMsg : string ; const AFileName : TFileName = '' ; ALine : Integer = 0 ; ACol : Integer = 0 ) ; overload

Parameters
Parameter | Description
AErrorMsg : STRING | Message d'erreur
AFileName : TFileName | Nom du fichier
ALine : INTEGER | Ligne (défaut = 0)
ACol : INTEGER | Colonne (défaut = 0)

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Crée une erreur de compilation Sepi

Source code
constructor Create ( const AErrorMsg : string ; const APosition : TSepiSourcePosition ) ; overload

Parameters
Parameter | Description
AErrorMsg : STRING | Message d'erreur
APosition : TSepiSourcePosition | Position dans le source

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (GetAsText)

Name
Create

Parent
TSepiCompilerError

Visibility
PUBLIC

Description
Crée une erreur de compilation Sepi

Source code
constructor Create ( const AErrorMsg : string ; AKind : TSepiErrorKind ; const APosition : TSepiSourcePosition ) ; overload

Parameters
Parameter | Description
AErrorMsg : STRING | Message d'erreur
AKind : TSepiErrorKind | Type d'erreur
APosition : TSepiSourcePosition | Position dans le source

Sepi
Class Tree
Index
Previous (Create)
Next (GetAsText)


Sepi

Sepi
Previous (Create)
Next

Name
GetAsText

Parent
TSepiCompilerError

Visibility
PRIVATE

Description
Représentation textuelle de l'erreur

Source code
function GetAsText : string

Parameters
Parameter Description

Return
Types | Description
STRING | Représentation textuelle de l'erreur

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiCompilerError)
Next (TSepiSourcePosition)

Name
TSepiCompilerErrorList

Parent
SepiCompilerErrors

Class Hierarchy
TObjectList

Visibility
PUBLIC

Description
Liste d'erreurs de compilation Sepi

Members
Fields
Field | Description
FCurrentFileName (-) | Nom du fichier courant
FOnAddError (-) | Déclenché à l'ajout d'une erreur

Methods
Method | Description
CheckForErrors (+) | Ajoute une erreur fatale si une ou plusieurs erreurs sont présentes
GetErrorCount (-) | Nombre d'erreurs de type ekError dans la liste d'erreurs
GetErrors (-) | Tableau zero-based des erreurs
MakeError (+) | Ajoute une erreur de type Erreur à la liste
MakeError (+) | Ajoute une erreur à la liste, dans le fichier courant
MakeError (+) | Ajoute une erreur de type Erreur à la liste, dans le fichier courant
MakeError (+) | Ajoute une erreur à la liste, avec une position explicite
MakeError (+) | Ajoute une erreur de type Erreur à la liste, avec une position explicite
MakeError (+) | Ajoute une erreur à la liste
Notify (#) | [@inheritDoc]

Properties
Property | Description
CurrentFileName (+) | Nom du fichier courant
ErrorCount (+) | Nombre d'erreurs de type ekError dans la liste d'erreurs
Errors (+) | Tableau zero-based des erreurs
OnAddError (+) | Déclenché à l'ajout d'une erreur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCompilerError)
Next (TSepiSourcePosition)


Sepi

Sepi
Previous
Next (FOnAddError)

Name
FCurrentFileName

Parent
TSepiCompilerErrorList

Visibility
PRIVATE

Description
Nom du fichier courant

Source code
FCurrentFileName : TFileName

Sepi
Class Tree
Index
Previous
Next (FOnAddError)


Sepi

Sepi
Previous (FCurrentFileName)
Next

Name
FOnAddError

Parent
TSepiCompilerErrorList

Visibility
PRIVATE

Description
Déclenché à l'ajout d'une erreur

Source code
FOnAddError : TSepiAddErrorEvent

Sepi
Class Tree
Index
Previous (FCurrentFileName)
Next


Sepi

Sepi
Previous
Next (ErrorCount)

Name
CurrentFileName

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Nom du fichier courant

Source code
property CurrentFileName : TFileName read FCurrentFileName write FCurrentFileName

Read Access
FCurrentFileName

Write Access
FCurrentFileName

Sepi
Class Tree
Index
Previous
Next (ErrorCount)


Sepi

Sepi
Previous (CurrentFileName)
Next (Errors)

Name
ErrorCount

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Nombre d'erreurs de type ekError dans la liste d'erreurs

Source code
property ErrorCount : Integer read GetErrorCount

Read Access
GetErrorCount

Sepi
Class Tree
Index
Previous (CurrentFileName)
Next (Errors)


Sepi

Sepi
Previous (ErrorCount)
Next (OnAddError)

Name
Errors

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Tableau zero-based des erreurs

Source code
property Errors [ Index : Integer ] : TSepiCompilerError read GetErrors ; default

Read Access
GetErrors

Sepi
Class Tree
Index
Previous (ErrorCount)
Next (OnAddError)


Sepi

Sepi
Previous (Errors)
Next

Name
OnAddError

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Déclenché à l'ajout d'une erreur

Source code
property OnAddError : TSepiAddErrorEvent read FOnAddError write FOnAddError

Read Access
FOnAddError

Write Access
FOnAddError

Sepi
Class Tree
Index
Previous (Errors)
Next


Sepi

Sepi
Previous
Next (GetErrorCount)

Name
CheckForErrors

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Ajoute une erreur fatale si une ou plusieurs erreurs sont présentes

Source code
procedure CheckForErrors

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetErrorCount)


Sepi

Sepi
Previous (CheckForErrors)
Next (GetErrors)

Name
GetErrorCount

Parent
TSepiCompilerErrorList

Visibility
PRIVATE

Description
Nombre d'erreurs de type ekError dans la liste d'erreurs

Source code
function GetErrorCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'erreurs

Sepi
Class Tree
Index
Previous (CheckForErrors)
Next (GetErrors)


Sepi

Sepi
Previous (GetErrorCount)
Next (MakeError)

Name
GetErrors

Parent
TSepiCompilerErrorList

Visibility
PRIVATE

Description
Tableau zero-based des erreurs

Source code
function GetErrors ( Index : Integer ) : TSepiCompilerError

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'erreur

Return
Types | Description
TSepiCompilerError | Erreur à l'index spécifié

Sepi
Class Tree
Index
Previous (GetErrorCount)
Next (MakeError)


Sepi

Sepi
Previous (GetErrors)
Next (MakeError)

Name
MakeError

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Ajoute une erreur de type Erreur à la liste

Source code
function MakeError ( const ErrorMsg : string ; const FileName : TFileName ; Line : Integer = 0 ; Col : Integer = 0 ) : TSepiCompilerError ; overload

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
FileName : TFileName | Nom du fichier
Line : INTEGER | Ligne (défaut = 0)
Col : INTEGER | Colonne (défaut = 0)

Return
Types | Description
TSepiCompilerError | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetErrors)
Next (MakeError)


Sepi

Sepi
Previous (MakeError)
Next (MakeError)

Name
MakeError

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Ajoute une erreur à la liste, dans le fichier courant
Si c'est une erreur fatale, une exception ESepiCompilerFatalError est ensuite
déclenchée.

Exception
ESepiCompilerFatalError L'erreur est une erreur fatale

Source code
function MakeError ( const ErrorMsg : string ; Kind : TSepiErrorKind ; Line : Integer = 0 ; Col : Integer = 0 ) : TSepiCompilerError ; overload

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Kind : TSepiErrorKind | Type d'erreur
Line : INTEGER | Ligne (défaut = 0)
Col : INTEGER | Colonne (défaut = 0)

Return
Types | Description
TSepiCompilerError | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next (MakeError)


Sepi

Sepi
Previous (MakeError)
Next (MakeError)

Name
MakeError

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Ajoute une erreur de type Erreur à la liste, dans le fichier courant

Source code
function MakeError ( const ErrorMsg : string ; Line : Integer = 0 ; Col : Integer = 0 ) : TSepiCompilerError ; overload

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Line : INTEGER | Ligne (défaut = 0)
Col : INTEGER | Colonne (défaut = 0)

Return
Types | Description
TSepiCompilerError | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next (MakeError)


Sepi

Sepi
Previous (MakeError)
Next (MakeError)

Name
MakeError

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Ajoute une erreur à la liste, avec une position explicite
Si c'est une erreur fatale, une exception ESepiCompilerFatalError est ensuite
déclenchée.

Exception
ESepiCompilerFatalError L'erreur est une erreur fatale

Source code
function MakeError ( const ErrorMsg : string ; Kind : TSepiErrorKind ; const Position : TSepiSourcePosition ) : TSepiCompilerError ; overload

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Kind : TSepiErrorKind | Type d'erreur
Position : TSepiSourcePosition | Position dans le source

Return
Types | Description
TSepiCompilerError | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next (MakeError)


Sepi

Sepi
Previous (MakeError)
Next (MakeError)

Name
MakeError

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Ajoute une erreur de type Erreur à la liste, avec une position explicite

Source code
function MakeError ( const ErrorMsg : string ; const Position : TSepiSourcePosition ) : TSepiCompilerError ; overload

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Position : TSepiSourcePosition | Position dans le source

Return
Types | Description
TSepiCompilerError | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next (MakeError)


Sepi

Sepi
Previous (MakeError)
Next (Notify)

Name
MakeError

Parent
TSepiCompilerErrorList

Visibility
PUBLIC

Description
Ajoute une erreur à la liste
Si c'est une erreur fatale, une exception ESepiCompilerFatalError est ensuite
déclenchée.

Exception
ESepiCompilerFatalError L'erreur est une erreur fatale

Source code
function MakeError ( const ErrorMsg : string ; Kind : TSepiErrorKind ; const FileName : TFileName ; Line : Integer = 0 ; Col : Integer = 0 ) : TSepiCompilerError ; overload

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Kind : TSepiErrorKind | Type d'erreur
FileName : TFileName | Nom du fichier
Line : INTEGER | Ligne (défaut = 0)
Col : INTEGER | Colonne (défaut = 0)

Return
Types | Description
TSepiCompilerError | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next (Notify)


Sepi

Sepi
Previous (MakeError)
Next

Name
Notify

Parent
TSepiCompilerErrorList

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Notify ( Ptr : Pointer ; Action : TListNotification ) ; override

Parameters
Parameter | Description
PTR : Pointer | #Pas de TAG trouvé dans le code source#
Action : TListNotification | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeError)
Next


Sepi

Sepi
Previous (TSepiCompilerErrorList)
Next

Name
TSepiSourcePosition

Parent
SepiCompilerErrors

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Position dans un source Sepi

Members
Fields
Field | Description
Col (*) | Colonne
FileName (*) | Nom du fichier
Line (*) | Ligne

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCompilerErrorList)
Next


Sepi

Sepi
Previous
Next (FileName)

Name
Col

Parent
TSepiSourcePosition

Visibility
PUBLISHED

Description
Colonne

Source code
Col : Integer

Sepi
Class Tree
Index
Previous
Next (FileName)


Sepi

Sepi
Previous (Col)
Next (Line)

Name
FileName

Parent
TSepiSourcePosition

Visibility
PUBLISHED

Description
Nom du fichier

Source code
FileName : TFileName

Sepi
Class Tree
Index
Previous (Col)
Next (Line)


Sepi

Sepi
Previous (FileName)
Next

Name
Line

Parent
TSepiSourcePosition

Visibility
PUBLISHED

Description
Ligne

Source code
Line : Integer

Sepi
Class Tree
Index
Previous (FileName)
Next


Sepi

Sepi
Previous
Next (TSepiErrorKind)

Name
TSepiAddErrorEvent

Parent
SepiCompilerErrors

Visibility
PUBLIC

Description
Type de l'événement OnAddError de TSepiCompilerErrorList

Source code
TSepiAddErrorEvent = procedure ( Sender : TObject ; Error : TSepiCompilerError ) of object ;

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement
Error : TSepiCompilerError | Erreur ajoutée

Sepi
Class Tree
Index
Previous
Next (TSepiErrorKind)


Sepi

Sepi
Previous (TSepiAddErrorEvent)
Next

Name
TSepiErrorKind

Parent
SepiCompilerErrors

Visibility
PUBLIC

Description
Type d'erreur de compilation Sepi

Source code
TSepiErrorKind = ( ekHint , ekWarning , ekError , ekFatalError ) ;

Sepi
Class Tree
Index
Previous (TSepiAddErrorEvent)
Next


Sepi

Sepi
Previous
Next (SepiNoPosition)

Name
MaxErrors

Parent
SepiCompilerErrors

Visibility
PUBLIC

Description
Nombre maximum d'erreurs avant d'abandonner la compilation

Source code
MaxErrors = 100

Sepi
Class Tree
Index
Previous
Next (SepiNoPosition)


Sepi

Sepi
Previous (MaxErrors)
Next

Name
SepiNoPosition

Parent
SepiCompilerErrors

Visibility
PUBLIC

Description
Position non renseignée

Source code
SepiNoPosition : TSepiSourcePosition = ( FileName : '' ; Line : 0 ; Col : 0 )

Sepi
Class Tree
Index
Previous (MaxErrors)
Next


Sepi

Sepi
Previous
Next

Name
SepiErrorKindNames

Parent
SepiCompilerErrors

Visibility
PUBLIC

Description
Nom des types d'erreur de compilation Sepi

Source code
SepiErrorKindNames : array [ TSepiErrorKind ] of string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiCompilerErrors)
Next (SepiConsts)

Name
SepiCompilerUtils

Parent
Sepi

Description
#Pas de TAG trouvé dans le code source#

Author
#Pas de TAG trouvé dans le code source#

Version
#Pas de TAG trouvé dans le code source#

Methods
Method | Description
CompileSepiSource (+) | Compile un fichier source Sepi
ConstValueAsInt64 (+) | Lit une valeur constante comme un Int64
RequireReadableValue (+) | Requiert une valeur qui peut être lue
RequireWritableValue (+) | Requiert une valeur qui peut être écrite
TryAndConvertValues (+) | Essaie de convertir les valeurs pour qu'elles aient le même type

Classes
Class | Description
TSepiCompilerTransientType (+) | Type transient utilisé par un compilateur
TSepiEmptySetType (+) | Type transient ensemble vide
TSepiMemberBuilder (+) | Classe de base pour les constructeurs de membres de type composites
TSepiPropertyBuilder (+) | Constructeur de propriété

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiCompilerErrors)
Next (SepiConsts)


Sepi

Sepi
Previous
Next (TSepiEmptySetType)

Name
TSepiCompilerTransientType

Parent
SepiCompilerUtils

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type transient utilisé par un compilateur
Toute tentative de charger ou sauvegarder une instance de
TSepiCompilerTransientType déclenchera une exception EAssertionFailed.

Members
Methods
Method | Description
Create (+) | Crée un type transient du compilateur
Load (+) | [@inheritDoc]
Save (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiEmptySetType)


Sepi

Sepi
Previous
Next (Load)

Name
Create

Parent
TSepiCompilerTransientType

Visibility
PUBLIC

Description
Crée un type transient du compilateur

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AKind : TTypeKind = tkUnknown )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AKind : TTypeKind | Type de type (tkUnknown par défaut)

Sepi
Class Tree
Index
Previous
Next (Load)


Sepi

Sepi
Previous (Create)
Next (Save)

Name
Load

Parent
TSepiCompilerTransientType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (Save)


Sepi

Sepi
Previous (Load)
Next

Name
Save

Parent
TSepiCompilerTransientType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next


Sepi

Sepi
Previous (TSepiCompilerTransientType)
Next (TSepiMemberBuilder)

Name
TSepiEmptySetType

Parent
SepiCompilerUtils

Class Hierarchy
TSepiCompilerTransientType

Visibility
PUBLIC

Description
Type transient ensemble vide

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCompilerTransientType)
Next (TSepiMemberBuilder)


Sepi

Sepi
Previous (TSepiEmptySetType)
Next (TSepiPropertyBuilder)

Name
TSepiMemberBuilder

Parent
SepiCompilerUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe de base pour les constructeurs de membres de type composites

Members
Fields
Field | Description
FCurrentNode (-) | Noeud courant pour les erreurs
FName (-) | Nom du membre à construire
FOwner (-) | Propriétaire du membre à construire
FOwnerClass (-) | Classe propriétaire (si applicable)
FOwnerIntf (-) | Interface propriétaire (si applicable)
FOwnerRecord (-) | Record propriétaire (si applicable)
FOwnerType (-) | Type propriétaire (si applicable)

Methods
Method | Description
Build (+) | Construit le membre
Create (+) | Crée un nouveau constructeur de membre
LookForMember (#) | Cherche un membre du type englobant d'après son nom
LookForMemberOrError (#) | Cherche un membre du type englobant d'après son nom
MakeError (#) | Produit un message d'erreur

Properties
Property | Description
CurrentNode (+) | Noeud courant pour les erreurs
NAME (+) | Nom du membre à construire
Owner (+) | Propriétaire du membre à construire
OwnerClass (#) | Classe propriétaire (si applicable)
OwnerIntf (#) | Interface propriétaire (si applicable)
OwnerRecord (#) | Record propriétaire (si applicable)
OwnerType (#) | Type propriétaire (si applicable)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiEmptySetType)
Next (TSepiPropertyBuilder)


Sepi

Sepi
Previous
Next (FName)

Name
FCurrentNode

Parent
TSepiMemberBuilder

Visibility
PRIVATE

Description
Noeud courant pour les erreurs

Source code
FCurrentNode : TSepiParseTreeNode

Sepi
Class Tree
Index
Previous
Next (FName)


Sepi

Sepi
Previous (FCurrentNode)
Next (FOwner)

Name
FName

Parent
TSepiMemberBuilder

Visibility
PRIVATE

Description
Nom du membre à construire

Source code
FName : string

Sepi
Class Tree
Index
Previous (FCurrentNode)
Next (FOwner)


Sepi

Sepi
Previous (FName)
Next (FOwnerClass)

Name
FOwner

Parent
TSepiMemberBuilder

Visibility
PRIVATE

Description
Propriétaire du membre à construire

Source code
FOwner : TSepiComponent

Sepi
Class Tree
Index
Previous (FName)
Next (FOwnerClass)


Sepi

Sepi
Previous (FOwner)
Next (FOwnerIntf)

Name
FOwnerClass

Parent
TSepiMemberBuilder

Visibility
PRIVATE

Description
Classe propriétaire (si applicable)

Source code
FOwnerClass : TSepiClass

Sepi
Class Tree
Index
Previous (FOwner)
Next (FOwnerIntf)


Sepi

Sepi
Previous (FOwnerClass)
Next (FOwnerRecord)

Name
FOwnerIntf

Parent
TSepiMemberBuilder

Visibility
PRIVATE

Description
Interface propriétaire (si applicable)

Source code
FOwnerIntf : TSepiInterface

Sepi
Class Tree
Index
Previous (FOwnerClass)
Next (FOwnerRecord)


Sepi

Sepi
Previous (FOwnerIntf)
Next (FOwnerType)

Name
FOwnerRecord

Parent
TSepiMemberBuilder

Visibility
PRIVATE

Description
Record propriétaire (si applicable)

Source code
FOwnerRecord : TSepiRecordType

Sepi
Class Tree
Index
Previous (FOwnerIntf)
Next (FOwnerType)


Sepi

Sepi
Previous (FOwnerRecord)
Next

Name
FOwnerType

Parent
TSepiMemberBuilder

Visibility
PRIVATE

Description
Type propriétaire (si applicable)

Source code
FOwnerType : TSepiContainerType

Sepi
Class Tree
Index
Previous (FOwnerRecord)
Next


Sepi

Sepi
Previous
Next (NAME)

Name
CurrentNode

Parent
TSepiMemberBuilder

Visibility
PUBLIC

Description
Noeud courant pour les erreurs

Source code
property CurrentNode : TSepiParseTreeNode read FCurrentNode write FCurrentNode

Read Access
FCurrentNode

Write Access
FCurrentNode

Sepi
Class Tree
Index
Previous
Next (NAME)


Sepi

Sepi
Previous (CurrentNode)
Next (Owner)

Name
NAME

Parent
TSepiMemberBuilder

Visibility
PUBLIC

Description
Nom du membre à construire

Source code
property Name : string read FName write FName

Read Access
FName

Write Access
FName

Sepi
Class Tree
Index
Previous (CurrentNode)
Next (Owner)


Sepi

Sepi
Previous (NAME)
Next (OwnerClass)

Name
Owner

Parent
TSepiMemberBuilder

Visibility
PUBLIC

Description
Propriétaire du membre à construire

Source code
property Owner : TSepiComponent read FOwner

Read Access
FOwner

Sepi
Class Tree
Index
Previous (NAME)
Next (OwnerClass)


Sepi

Sepi
Previous (Owner)
Next (OwnerIntf)

Name
OwnerClass

Parent
TSepiMemberBuilder

Visibility
PROTECTED

Description
Classe propriétaire (si applicable)

Source code
property OwnerClass : TSepiClass read FOwnerClass

Read Access
FOwnerClass

Sepi
Class Tree
Index
Previous (Owner)
Next (OwnerIntf)


Sepi

Sepi
Previous (OwnerClass)
Next (OwnerRecord)

Name
OwnerIntf

Parent
TSepiMemberBuilder

Visibility
PROTECTED

Description
Interface propriétaire (si applicable)

Source code
property OwnerIntf : TSepiInterface read FOwnerIntf

Read Access
FOwnerIntf

Sepi
Class Tree
Index
Previous (OwnerClass)
Next (OwnerRecord)


Sepi

Sepi
Previous (OwnerIntf)
Next (OwnerType)

Name
OwnerRecord

Parent
TSepiMemberBuilder

Visibility
PROTECTED

Description
Record propriétaire (si applicable)

Source code
property OwnerRecord : TSepiRecordType read FOwnerRecord

Read Access
FOwnerRecord

Sepi
Class Tree
Index
Previous (OwnerIntf)
Next (OwnerType)


Sepi

Sepi
Previous (OwnerRecord)
Next

Name
OwnerType

Parent
TSepiMemberBuilder

Visibility
PROTECTED

Description
Type propriétaire (si applicable)

Source code
property OwnerType : TSepiContainerType read FOwnerType

Read Access
FOwnerType

Sepi
Class Tree
Index
Previous (OwnerRecord)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Build

Parent
TSepiMemberBuilder

Visibility
PUBLIC

Description
Construit le membre

Source code
procedure Build ; virtual ; abstract

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Build)
Next (LookForMember)

Name
Create

Parent
TSepiMemberBuilder

Visibility
PUBLIC

Description
Crée un nouveau constructeur de membre

Source code
constructor Create ( AOwner : TSepiComponent )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du membre à construire

Sepi
Class Tree
Index
Previous (Build)
Next (LookForMember)


Sepi

Sepi
Previous (Create)
Next (LookForMemberOrError)

Name
LookForMember

Parent
TSepiMemberBuilder

Visibility
PROTECTED

Description
Cherche un membre du type englobant d'après son nom

Source code
function LookForMember ( const MemberName : string ) : TSepiMember

Parameters
Parameter | Description
MemberName : STRING | Nom du membre

Return
Types | Description
TSepiMember | Membre recherché, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (Create)
Next (LookForMemberOrError)


Sepi

Sepi
Previous (LookForMember)
Next (MakeError)

Name
LookForMemberOrError

Parent
TSepiMemberBuilder

Visibility
PROTECTED

Description
Cherche un membre du type englobant d'après son nom
En cas d'erreur, produit un message d'erreur.

Source code
function LookForMemberOrError ( const MemberName : string ) : TSepiMember

Parameters
Parameter | Description
MemberName : STRING | Nom du membre

Return
Types | Description
TSepiMember | Membre recherché, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LookForMember)
Next (MakeError)


Sepi

Sepi
Previous (LookForMemberOrError)
Next

Name
MakeError

Parent
TSepiMemberBuilder

Visibility
PROTECTED

Description
Produit un message d'erreur

Source code
procedure MakeError ( const ErrorMsg : string ; Kind : TSepiErrorKind = ekError )

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Kind : TSepiErrorKind | Type d'erreur

Sepi
Class Tree
Index
Previous (LookForMemberOrError)
Next


Sepi

Sepi
Previous (TSepiMemberBuilder)
Next

Name
TSepiPropertyBuilder

Parent
SepiCompilerUtils

Class Hierarchy
TSepiMemberBuilder

Visibility
PUBLIC

Description
Constructeur de propriété

Members
Fields
Field | Description
FDefaultValue (-) | Valeur par défaut
FIndex (-) | Index
FIndexType (-) | Type de l'index
FIsDefault (-) | True si c'est la propriété par défaut
FReadAccess (-) | Accesseur en lecture
FSignature (-) | Signature
FStorage (-) | Spécificateur de stockage
FWriteAccess (-) | Accesseur en écriture

Methods
Method | Description
Build (+) | [@inheritDoc]
CheckDefaultAllowed (-) | Vérifie que default ou nodefault est valide
Create (+) | Crée un nouveau constructeur de propriété
Destroy (+) | [@inheritDoc]
IsTypeValidForDefault (-) | Teste si un type de propriété peut avoir un default
LookForAccessOrError (-) | Cherche un membre accesseur du type englobant d'après son nom
Redefine (+) | Redéfinit une propriété héritée
SetDefaultValue (+) | Spécifie la valeur par défaut
SetIndex (+) | Spécifie l'index
SetIsDefault (+) | Spécifie que c'est la propriété par défaut
SetNoDefault (+) | Spécifie qu'il n'y a pas de valeur par défaut
SetReadAccess (+) | Spécifie l'accesseur en lecture
SetStorage (+) | Définit le spécificateur de stockage
SetWriteAccess (+) | Spécifie l'accesseur en écriture
ValidateAccess (-) | Valide un accesseur
ValidateFieldAccess (-) | Valide un accès via un champ
ValidateMethodAccess (-) | Valide un accès via une méthode
ValidateOverloadedMethodAccess (-) | Valide un accès via une méthode surchargée

Properties
Property | Description
DefaultValue (+) | Valeur par défaut
INDEX (+) | Index
IndexType (+) | Type de l'index
IsDefault (+) | True si c'est la propriété par défaut
ReadAccess (+) | Accesseur en lecture
Signature (+) | Signature
Storage (+) | Spécificateur de stockage
WriteAccess (+) | Accesseur en écriture

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMemberBuilder)
Next


Sepi

Sepi
Previous
Next (FIndex)

Name
FDefaultValue

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Valeur par défaut

Source code
FDefaultValue : Integer

Sepi
Class Tree
Index
Previous
Next (FIndex)


Sepi

Sepi
Previous (FDefaultValue)
Next (FIndexType)

Name
FIndex

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Index

Source code
FIndex : Integer

Sepi
Class Tree
Index
Previous (FDefaultValue)
Next (FIndexType)


Sepi

Sepi
Previous (FIndex)
Next (FIsDefault)

Name
FIndexType

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Type de l'index

Source code
FIndexType : TSepiOrdType

Sepi
Class Tree
Index
Previous (FIndex)
Next (FIsDefault)


Sepi

Sepi
Previous (FIndexType)
Next (FReadAccess)

Name
FIsDefault

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
True si c'est la propriété par défaut

Source code
FIsDefault : Boolean

Sepi
Class Tree
Index
Previous (FIndexType)
Next (FReadAccess)


Sepi

Sepi
Previous (FIsDefault)
Next (FSignature)

Name
FReadAccess

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Accesseur en lecture

Source code
FReadAccess : TSepiMember

Sepi
Class Tree
Index
Previous (FIsDefault)
Next (FSignature)


Sepi

Sepi
Previous (FReadAccess)
Next (FStorage)

Name
FSignature

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Signature

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous (FReadAccess)
Next (FStorage)


Sepi

Sepi
Previous (FSignature)
Next (FWriteAccess)

Name
FStorage

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Spécificateur de stockage

Source code
FStorage : TSepiPropertyStorage

Sepi
Class Tree
Index
Previous (FSignature)
Next (FWriteAccess)


Sepi

Sepi
Previous (FStorage)
Next

Name
FWriteAccess

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Accesseur en écriture

Source code
FWriteAccess : TSepiMember

Sepi
Class Tree
Index
Previous (FStorage)
Next


Sepi

Sepi
Previous
Next (INDEX)

Name
DefaultValue

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Valeur par défaut

Source code
property DefaultValue : Integer read FDefaultValue

Read Access
FDefaultValue

Sepi
Class Tree
Index
Previous
Next (INDEX)


Sepi

Sepi
Previous (DefaultValue)
Next (IndexType)

Name
INDEX

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Index

Source code
property Index : Integer read FIndex

Read Access
FIndex

Sepi
Class Tree
Index
Previous (DefaultValue)
Next (IndexType)


Sepi

Sepi
Previous (INDEX)
Next (IsDefault)

Name
IndexType

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Type de l'index

Source code
property IndexType : TSepiOrdType read FIndexType

Read Access
FIndexType

Sepi
Class Tree
Index
Previous (INDEX)
Next (IsDefault)


Sepi

Sepi
Previous (IndexType)
Next (ReadAccess)

Name
IsDefault

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
True si c'est la propriété par défaut

Source code
property IsDefault : Boolean read FIsDefault

Read Access
FIsDefault

Sepi
Class Tree
Index
Previous (IndexType)
Next (ReadAccess)


Sepi

Sepi
Previous (IsDefault)
Next (Signature)

Name
ReadAccess

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Accesseur en lecture

Source code
property ReadAccess : TSepiMember read FReadAccess

Read Access
FReadAccess

Sepi
Class Tree
Index
Previous (IsDefault)
Next (Signature)


Sepi

Sepi
Previous (ReadAccess)
Next (Storage)

Name
Signature

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Signature

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous (ReadAccess)
Next (Storage)


Sepi

Sepi
Previous (Signature)
Next (WriteAccess)

Name
Storage

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Spécificateur de stockage

Source code
property Storage : TSepiPropertyStorage read FStorage

Read Access
FStorage

Sepi
Class Tree
Index
Previous (Signature)
Next (WriteAccess)


Sepi

Sepi
Previous (Storage)
Next

Name
WriteAccess

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Accesseur en écriture

Source code
property WriteAccess : TSepiMember read FWriteAccess

Read Access
FWriteAccess

Sepi
Class Tree
Index
Previous (Storage)
Next


Sepi

Sepi
Previous
Next (CheckDefaultAllowed)

Name
Build

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Build ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CheckDefaultAllowed)


Sepi

Sepi
Previous (Build)
Next (Create)

Name
CheckDefaultAllowed

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Vérifie que default ou nodefault est valide

Source code
function CheckDefaultAllowed : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si autorisé, False sinon

Sepi
Class Tree
Index
Previous (Build)
Next (Create)


Sepi

Sepi
Previous (CheckDefaultAllowed)
Next (Destroy)

Name
Create

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Crée un nouveau constructeur de propriété

Source code
constructor Create ( AOwner : TSepiComponent )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du membre à construire

Sepi
Class Tree
Index
Previous (CheckDefaultAllowed)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (IsTypeValidForDefault)

Name
Destroy

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (IsTypeValidForDefault)


Sepi

Sepi
Previous (Destroy)
Next (LookForAccessOrError)

Name
IsTypeValidForDefault

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Teste si un type de propriété peut avoir un default

Source code
function IsTypeValidForDefault ( PropType : TSepiType ) : Boolean

Parameters
Parameter | Description
PropType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (LookForAccessOrError)


Sepi

Sepi
Previous (IsTypeValidForDefault)
Next (Redefine)

Name
LookForAccessOrError

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Cherche un membre accesseur du type englobant d'après son nom
En cas d'erreur, produit un message d'erreur.

Source code
function LookForAccessOrError ( const AccessName : string ) : TSepiMember

Parameters
Parameter Description
AccessName : STRING

Return
Types | Description
TSepiMember | Membre recherché, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (IsTypeValidForDefault)
Next (Redefine)


Sepi

Sepi
Previous (LookForAccessOrError)
Next (SetDefaultValue)

Name
Redefine

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Redéfinit une propriété héritée

Source code
function Redefine ( Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (LookForAccessOrError)
Next (SetDefaultValue)


Sepi

Sepi
Previous (Redefine)
Next (SetIndex)

Name
SetDefaultValue

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Spécifie la valeur par défaut

Source code
function SetDefaultValue ( const Value : ISepiReadableValue ; Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
Value : ISepiReadableValue | Valeur par défaut
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (Redefine)
Next (SetIndex)


Sepi

Sepi
Previous (SetDefaultValue)
Next (SetIsDefault)

Name
SetIndex

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Spécifie l'index

Source code
function SetIndex ( const Value : ISepiReadableValue ; Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
Value : ISepiReadableValue | Valeur index
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (SetDefaultValue)
Next (SetIsDefault)


Sepi

Sepi
Previous (SetIndex)
Next (SetNoDefault)

Name
SetIsDefault

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Spécifie que c'est la propriété par défaut

Source code
function SetIsDefault ( Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (SetIndex)
Next (SetNoDefault)


Sepi

Sepi
Previous (SetIsDefault)
Next (SetReadAccess)

Name
SetNoDefault

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Spécifie qu'il n'y a pas de valeur par défaut

Source code
function SetNoDefault ( Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (SetIsDefault)
Next (SetReadAccess)


Sepi

Sepi
Previous (SetNoDefault)
Next (SetStorage)

Name
SetReadAccess

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Spécifie l'accesseur en lecture

Source code
function SetReadAccess ( const ReadAccessName : string ; Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
ReadAccessName : STRING | Nom de l'accesseur
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (SetNoDefault)
Next (SetStorage)


Sepi

Sepi
Previous (SetReadAccess)
Next (SetWriteAccess)

Name
SetStorage

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Définit le spécificateur de stockage

Source code
function SetStorage ( const Expression : ISepiExpression ; Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
Expression : ISepiExpression | Expression du spécificateur de stockage
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (SetReadAccess)
Next (SetWriteAccess)


Sepi

Sepi
Previous (SetStorage)
Next (ValidateAccess)

Name
SetWriteAccess

Parent
TSepiPropertyBuilder

Visibility
PUBLIC

Description
Spécifie l'accesseur en écriture

Source code
function SetWriteAccess ( const WriteAccessName : string ; Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
WriteAccessName : STRING
Node : TSepiParseTreeNode | Noeud utilisé pour produire les erreurs

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (SetStorage)
Next (ValidateAccess)


Sepi

Sepi
Previous (SetWriteAccess)
Next (ValidateFieldAccess)

Name
ValidateAccess

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Valide un accesseur

Source code
function ValidateAccess ( var Access : TSepiMember ; IsWriteAccess : Boolean ) : Boolean

Parameters
Parameter | Description
Access : TSepiMember | Accesseur
IsWriteAccess : BOOLEAN | Indique si c'est l'accès en écriture

Return
Types | Description
BOOLEAN | True si l'accesseur est valide, False sinon

Sepi
Class Tree
Index
Previous (SetWriteAccess)
Next (ValidateFieldAccess)


Sepi

Sepi
Previous (ValidateAccess)
Next (ValidateMethodAccess)

Name
ValidateFieldAccess

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Valide un accès via un champ

Source code
function ValidateFieldAccess ( Field : TSepiField ) : Boolean

Parameters
Parameter | Description
Field : TSepiField | Champ accesseur

Return
Types | Description
BOOLEAN | True si le champ est valide, False sinon

Sepi
Class Tree
Index
Previous (ValidateAccess)
Next (ValidateMethodAccess)


Sepi

Sepi
Previous (ValidateFieldAccess)
Next (ValidateOverloadedMethodAccess)

Name
ValidateMethodAccess

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Valide un accès via une méthode

Source code
function ValidateMethodAccess ( Method : TSepiMethod ; IsWriteAccess , ShowError : Boolean ) : Boolean

Parameters
Parameter | Description
Method : TSepiMethod | Méthode accesseur
IsWriteAccess : BOOLEAN | Indique si c'est l'accès en écriture
ShowError : BOOLEAN | Montrer les erreurs

Return
Types | Description
BOOLEAN | True si la méthode est valide, False sinon

Sepi
Class Tree
Index
Previous (ValidateFieldAccess)
Next (ValidateOverloadedMethodAccess)


Sepi

Sepi
Previous (ValidateMethodAccess)
Next

Name
ValidateOverloadedMethodAccess

Parent
TSepiPropertyBuilder

Visibility
PRIVATE

Description
Valide un accès via une méthode surchargée

Source code
function ValidateOverloadedMethodAccess ( var Access : TSepiMember ; IsWriteAccess : Boolean ) : Boolean

Parameters
Parameter | Description
Access : TSepiMember
IsWriteAccess : BOOLEAN | Indique si c'est l'accès en écriture

Return
Types | Description
BOOLEAN | True si la méthode est valide, False sinon

Sepi
Class Tree
Index
Previous (ValidateMethodAccess)
Next


Sepi

Sepi
Previous
Next (ConstValueAsInt64)

Name
CompileSepiSource

Parent
SepiCompilerUtils

Visibility
PUBLIC

Description
Compile un fichier source Sepi

Source code
function CompileSepiSource ( SepiRoot : TSepiRoot ; Errors : TSepiCompilerErrorList ; SourceFile : TStrings ; const DestFileName : TFileName ; RootNodeClass : TSepiParseTreeRootNodeClass ; RootSymbolClass : TSepiSymbolClass ; LexerClass : TSepiCustomLexerClass ; ParserClass : TSepiCustomParserClass ) : TSepiUnit

Parameters
Parameter | Description
SepiRoot : TSepiRoot | Racine Sepi
Errors : TSepiCompilerErrorList | Gestionnaire d'erreurs
SourceFile : TStrings | Source à compiler
DestFileName : TFileName | Nom du fichier de sortie
RootNodeClass : TSepiParseTreeRootNodeClass | Classe du noeud racine
RootSymbolClass : TSepiSymbolClass | Classe de symboles du noeud racine
LexerClass : TSepiCustomLexerClass | Classe de l'analyseur lexical
ParserClass : TSepiCustomParserClass | Classe de l'analyseur syntaxique

Return
Types | Description
TSepiUnit | Unité Sepi compilée

Sepi
Class Tree
Index
Previous
Next (ConstValueAsInt64)


Sepi

Sepi
Previous (CompileSepiSource)
Next (RequireReadableValue)

Name
ConstValueAsInt64

Parent
SepiCompilerUtils

Visibility
PUBLIC

Description
Lit une valeur constante comme un Int64

Source code
function ConstValueAsInt64 ( const Value : ISepiReadableValue ) : Int64

Parameters
Parameter | Description
Value : ISepiReadableValue | Valeur à lire

Return
Types | Description
INT64 | Valeur sous forme d'Int64

Sepi
Class Tree
Index
Previous (CompileSepiSource)
Next (RequireReadableValue)


Sepi

Sepi
Previous (ConstValueAsInt64)
Next (RequireWritableValue)

Name
RequireReadableValue

Parent
SepiCompilerUtils

Visibility
PUBLIC

Description
Requiert une valeur qui peut être lue
En cas d'erreur, Value est affectée à une valeur erronée

Source code
function RequireReadableValue ( const Expression : ISepiExpression ; out Value : ISepiReadableValue ) : Boolean

Parameters
Parameter | Description
Expression : ISepiExpression | Expression
Value : ISepiReadableValue | En sortie : l'expression sous forme de valeur lisible

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (ConstValueAsInt64)
Next (RequireWritableValue)


Sepi

Sepi
Previous (RequireReadableValue)
Next (TryAndConvertValues)

Name
RequireWritableValue

Parent
SepiCompilerUtils

Visibility
PUBLIC

Description
Requiert une valeur qui peut être écrite
En cas d'erreur, Value est affectée à nil

Source code
function RequireWritableValue ( const Expression : ISepiExpression ; out Value : ISepiWritableValue ) : Boolean

Parameters
Parameter | Description
Expression : ISepiExpression | Expression
Value : ISepiWritableValue | En sortie : l'expression sous forme de valeur à écrire

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (RequireReadableValue)
Next (TryAndConvertValues)


Sepi

Sepi
Previous (RequireWritableValue)
Next

Name
TryAndConvertValues

Parent
SepiCompilerUtils

Visibility
PUBLIC

Description
Essaie de convertir les valeurs pour qu'elles aient le même type

Source code
procedure TryAndConvertValues ( SystemUnit : TSepiSystemUnit ; var LowerValue , HigherValue : ISepiReadableValue )

Parameters
Parameter | Description
SystemUnit : TSepiSystemUnit | Unité système
LowerValue : ISepiReadableValue | Valeur basse
HigherValue : ISepiReadableValue | Valeur haute

Sepi
Class Tree
Index
Previous (RequireWritableValue)
Next


Sepi

Sepi
Previous (SepiCompilerUtils)
Next (SepiCore)

Name
SepiConsts

Parent
Sepi

Description
Définit les constantes générales de Sepi

Author
sjrd

Version
1.0

Constants
Constant | Description
SepiEnvVarName (+) | Variable d'environnement de Sepi
SepiVersion (+) | Version de Sepi
SSepiAbout (+) | #No TAG found in source code#
SSepiAuthor (+) | #No TAG found in source code#
SSepiAuthorEMail (+) | #No TAG found in source code#
SSepiCopyright (+) | #No TAG found in source code#
SSepiName (+) | #No TAG found in source code#
SSepiWebSite (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiCompilerUtils)
Next (SepiCore)


Sepi

Sepi
Previous
Next (SepiVersion)

Name
SepiEnvVarName

Parent
SepiConsts

Visibility
PUBLIC

Description
Variable d'environnement de Sepi

Source code
SepiEnvVarName = 'SEPI'

Sepi
Class Tree
Index
Previous
Next (SepiVersion)


Sepi

Sepi
Previous (SepiEnvVarName)
Next (SSepiAbout)

Name
SepiVersion

Parent
SepiConsts

Visibility
PUBLIC

Description
Version de Sepi

Source code
SepiVersion = '1.0~alpha1'

Sepi
Class Tree
Index
Previous (SepiEnvVarName)
Next (SSepiAbout)


Sepi

Sepi
Previous (SepiVersion)
Next (SSepiAuthor)

Name
SSepiAbout

Parent
SepiConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiAbout = 'À propos de Sepi'

Sepi
Class Tree
Index
Previous (SepiVersion)
Next (SSepiAuthor)


Sepi

Sepi
Previous (SSepiAbout)
Next (SSepiAuthorEMail)

Name
SSepiAuthor

Parent
SepiConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiAuthor = 'Sébastien Doeraene'

Sepi
Class Tree
Index
Previous (SSepiAbout)
Next (SSepiAuthorEMail)


Sepi

Sepi
Previous (SSepiAuthor)
Next (SSepiCopyright)

Name
SSepiAuthorEMail

Parent
SepiConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiAuthorEMail = 'sjrd@redaction-developpez.com'

Sepi
Class Tree
Index
Previous (SSepiAuthor)
Next (SSepiCopyright)


Sepi

Sepi
Previous (SSepiAuthorEMail)
Next (SSepiName)

Name
SSepiCopyright

Parent
SepiConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiCopyright = 'Sepi v%s - Copyright © 2005-2010 Sébastien Doeraene'

Sepi
Class Tree
Index
Previous (SSepiAuthorEMail)
Next (SSepiName)


Sepi

Sepi
Previous (SSepiCopyright)
Next (SSepiWebSite)

Name
SSepiName

Parent
SepiConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiName = 'Moteur de script Sepi'

Sepi
Class Tree
Index
Previous (SSepiCopyright)
Next (SSepiWebSite)


Sepi

Sepi
Previous (SSepiName)
Next

Name
SSepiWebSite

Parent
SepiConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiWebSite = 'http://sjrd.developpez.com/sepi/'

Sepi
Class Tree
Index
Previous (SSepiName)
Next


Sepi

Sepi
Previous (SepiConsts)
Next (SepiDelphiCompiler)

Name
SepiCore

Parent
Sepi

Description
Définit les classes coeur de Sepi

Author
sjrd

Version
1.0

Classes
Class | Description
ESepiError (+) | Exception relative à la technologie Sepi
ESepiUnsupportedFeatureException (+) | Générée lorsqu'une opération requise n'est pas encore implémentée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiConsts)
Next (SepiDelphiCompiler)


Sepi

Sepi
Previous
Next (ESepiUnsupportedFeatureException)

Name
ESepiError

Parent
SepiCore

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Exception relative à la technologie Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ESepiUnsupportedFeatureException)


Sepi

Sepi
Previous (ESepiError)
Next

Name
ESepiUnsupportedFeatureException

Parent
SepiCore

Class Hierarchy
ESepiError

Visibility
PUBLIC

Description
Générée lorsqu'une opération requise n'est pas encore implémentée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiError)
Next


Sepi

Sepi
Previous (SepiCore)
Next (SepiDelphiCompilerConsts)

Name
SepiDelphiCompiler

Parent
Sepi

Description
Classes de compilation d'une unité Delphi dans Sepi

Author
sjrd

Version
1.0

Methods
Method | Description
CompileDelphiSource (+) | Compile un fichier source Delphi

Classes
Class | Description
TDelphiArrayInitializationNode (+) | Noeud d'expression d'initialisation d'un tableau
TDelphiArrayTypeNode (+) | Noeud descripteur d'un type tableau
TDelphiBinaryOpNode (+) | Noeud opérateur binaire
TDelphiClassTypeNode (+) | Noeud descripteur d'un type classe
TDelphiConstantDeclNode (+) | Noeud déclaration de constante
TDelphiConstOrTypeNode (+) | Noeud expression constante ou type
TDelphiEnumTypeNode (+) | Noeud descripteur d'un type énumération
TDelphiFakeEnumTypeNode (+) | Noeud descripteur d'un type fausse énumération
TDelphiFakeEnumValueNode (+) | Noeud descripteur d'une valeur d'un type fausse énumération
TDelphiGUIDInitializationNode (+) | Noeud d'expression d'initialisation d'un GUID
TDelphiImplementationNode (+) | Noeud implémentation
TDelphiInitializationExpressionNode (+) | Noeud d'expression d'initialisation
TDelphiInterfaceGUIDNode (+) | Noeud GUID d'interface
TDelphiInterfaceNode (+) | Noeud interface
TDelphiInterfaceTypeNode (+) | Noeud descripteur d'un type interface
TDelphiMethodRefTypeNode (+) | Noeud descripteur d'un type référence de méthode
TDelphiOfObjectMarkerNode (+) | Noeud marqueur of object
TDelphiOtherInitializationNode (+) | Noeud d'expression d'initialisation d'un autre type que tableau ou record
TDelphiPackedArrayTypeNode (+) | Noeud descripteur d'un type tableau packed
TDelphiPackedRecordTypeNode (+) | Noeud descripteur d'un type packed record
TDelphiParametersNode (+) | Noeud paramètres réels
TDelphiPointerTypeNode (+) | Noeud descripteur d'un type pointeur
TDelphiRangeOrEnumTypeNode (+) | Noeud descripteur d'un type intervalle ou énumération
TDelphiRangeTypeNode (+) | Noeud descripteur d'un type intervalle
TDelphiRecordInitializationNode (+) | Noeud d'expression d'initialisation d'un record
TDelphiRecordTypeNode (+) | Noeud descripteur d'un type record
TDelphiRootNode (+) | Noeud racine
TDelphiSetTypeNode (+) | Noeud descripteur d'un type ensemble
TDelphiSingleExprNode (+) | Noeud expression simple (sans opérateurs binaires)
TDelphiStringTypeNode (+) | Noeud descripteur d'un type chaîne courte
TDelphiTypeCloneNode (+) | Noeud descripteur d'un clone de type
TDelphiTypeDeclNode (+) | Noeud déclaration de type
TDelphiUnaryOpNode (+) | Noeud opérateur unaire
TDelphiVariableDeclNode (+) | Noeud déclaration de variable

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiCore)
Next (SepiDelphiCompilerConsts)


Sepi

Sepi
Previous
Next (TDelphiArrayTypeNode)

Name
TDelphiArrayInitializationNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Noeud d'expression d'initialisation d'un tableau

Members
Fields
Field | Description
FArrayType (-) | Type de valeur comme type tableau
FElementType (-) | Type des éléments du tableau

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
IsValidType (+) | [@inheritDoc]

Properties
Property | Description
ArrayType (+) | Type de valeur comme type tableau
ElementType (+) | Type des éléments du tableau

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TDelphiArrayTypeNode)


Sepi

Sepi
Previous
Next (FElementType)

Name
FArrayType

Parent
TDelphiArrayInitializationNode

Visibility
PRIVATE

Description
Type de valeur comme type tableau

Source code
FArrayType : TSepiStaticArrayType

Sepi
Class Tree
Index
Previous
Next (FElementType)


Sepi

Sepi
Previous (FArrayType)
Next

Name
FElementType

Parent
TDelphiArrayInitializationNode

Visibility
PRIVATE

Description
Type des éléments du tableau

Source code
FElementType : TSepiType

Sepi
Class Tree
Index
Previous (FArrayType)
Next


Sepi

Sepi
Previous
Next (ElementType)

Name
ArrayType

Parent
TDelphiArrayInitializationNode

Visibility
PUBLIC

Description
Type de valeur comme type tableau

Source code
property ArrayType : TSepiStaticArrayType read FArrayType

Read Access
FArrayType

Sepi
Class Tree
Index
Previous
Next (ElementType)


Sepi

Sepi
Previous (ArrayType)
Next

Name
ElementType

Parent
TDelphiArrayInitializationNode

Visibility
PUBLIC

Description
Type des éléments du tableau

Source code
property ElementType : TSepiType read FElementType

Read Access
FElementType

Sepi
Class Tree
Index
Previous (ArrayType)
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TDelphiArrayInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (EndParsing)

Name
ChildBeginParsing

Parent
TDelphiArrayInitializationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (IsValidType)

Name
EndParsing

Parent
TDelphiArrayInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (IsValidType)


Sepi

Sepi
Previous (EndParsing)
Next

Name
IsValidType

Parent
TDelphiArrayInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function IsValidType ( AValueType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TDelphiArrayInitializationNode)
Next (TDelphiBinaryOpNode)

Name
TDelphiArrayTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type tableau

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]
RangeDefinition (-) | Crée un tableau statique d'après une définition par intervalle
TypedDefinition (-) | Crée un tableau statique d'après une définition par type

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiArrayInitializationNode)
Next (TDelphiBinaryOpNode)


Sepi

Sepi
Previous
Next (RangeDefinition)

Name
EndParsing

Parent
TDelphiArrayTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (RangeDefinition)


Sepi

Sepi
Previous (EndParsing)
Next (TypedDefinition)

Name
RangeDefinition

Parent
TDelphiArrayTypeNode

Visibility
PRIVATE

Description
Crée un tableau statique d'après une définition par intervalle

Source code
function RangeDefinition ( const TypeName : string ; RangeNode : TSepiParseTreeNode ; ElementType : TSepiType ) : TSepiStaticArrayType

Parameters
Parameter | Description
TypeName : STRING | Nom du type tableau à créer
RangeNode : TSepiParseTreeNode | Noeud intervalle
ElementType : TSepiType | Type des éléments

Return
Types | Description
TSepiStaticArrayType | Type tableau créé

Sepi
Class Tree
Index
Previous (EndParsing)
Next (TypedDefinition)


Sepi

Sepi
Previous (RangeDefinition)
Next

Name
TypedDefinition

Parent
TDelphiArrayTypeNode

Visibility
PRIVATE

Description
Crée un tableau statique d'après une définition par type

Source code
function TypedDefinition ( const TypeName : string ; IndexNode : TSepiConstExpressionNode ; ElementType : TSepiType ) : TSepiStaticArrayType

Parameters
Parameter | Description
TypeName : STRING | Nom du type tableau à créer
IndexNode : TSepiConstExpressionNode
ElementType : TSepiType | Type des éléments

Return
Types | Description
TSepiStaticArrayType | Type tableau créé

Sepi
Class Tree
Index
Previous (RangeDefinition)
Next


Sepi

Sepi
Previous (TDelphiArrayTypeNode)
Next (TDelphiClassTypeNode)

Name
TDelphiBinaryOpNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiDelphiLikeBinaryOpNode

Visibility
PUBLIC

Description
Noeud opérateur binaire

Members
Methods
Method | Description
GetOperation (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiArrayTypeNode)
Next (TDelphiClassTypeNode)


Sepi

Sepi
Previous
Next

Name
GetOperation

Parent
TDelphiBinaryOpNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetOperation : TSepiOperation ; override

Parameters
Parameter Description

Return
Types | Description
TSepiOperation | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiBinaryOpNode)
Next (TDelphiConstantDeclNode)

Name
TDelphiClassTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type classe

Members
Fields
Field | Description
FIsClass (-) | True si c'est une classe
FIsForwardClass (-) | True si c'est une classe forwardée
FIsMetaClass (-) | True si c'est une meta-classe
FSepiClass (-) | Classe Sepi compilée
FSepiMetaClass (-) | Component-classe compilée

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
CreateClass (-) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
GetSepiContext (#) | [@inheritDoc]
ResolveIdent (+) | [@inheritDoc]

Properties
Property | Description
IsClass (+) | True si c'est une classe
IsForwardClass (+) | True si c'est une classe forwardée
IsMetaClass (+) | True si c'est une meta-classe
SepiClass (+) | Classe Sepi compilée
SepiMetaClass (+) | Component-classe compilée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiBinaryOpNode)
Next (TDelphiConstantDeclNode)


Sepi

Sepi
Previous
Next (FIsForwardClass)

Name
FIsClass

Parent
TDelphiClassTypeNode

Visibility
PRIVATE

Description
True si c'est une classe

Source code
FIsClass : Boolean

Sepi
Class Tree
Index
Previous
Next (FIsForwardClass)


Sepi

Sepi
Previous (FIsClass)
Next (FIsMetaClass)

Name
FIsForwardClass

Parent
TDelphiClassTypeNode

Visibility
PRIVATE

Description
True si c'est une classe forwardée

Source code
FIsForwardClass : Boolean

Sepi
Class Tree
Index
Previous (FIsClass)
Next (FIsMetaClass)


Sepi

Sepi
Previous (FIsForwardClass)
Next (FSepiClass)

Name
FIsMetaClass

Parent
TDelphiClassTypeNode

Visibility
PRIVATE

Description
True si c'est une meta-classe

Source code
FIsMetaClass : Boolean

Sepi
Class Tree
Index
Previous (FIsForwardClass)
Next (FSepiClass)


Sepi

Sepi
Previous (FIsMetaClass)
Next (FSepiMetaClass)

Name
FSepiClass

Parent
TDelphiClassTypeNode

Visibility
PRIVATE

Description
Classe Sepi compilée

Source code
FSepiClass : TSepiClass

Sepi
Class Tree
Index
Previous (FIsMetaClass)
Next (FSepiMetaClass)


Sepi

Sepi
Previous (FSepiClass)
Next

Name
FSepiMetaClass

Parent
TDelphiClassTypeNode

Visibility
PRIVATE

Description
Component-classe compilée

Source code
FSepiMetaClass : TSepiMetaClass

Sepi
Class Tree
Index
Previous (FSepiClass)
Next


Sepi

Sepi
Previous
Next (IsForwardClass)

Name
IsClass

Parent
TDelphiClassTypeNode

Visibility
PUBLIC

Description
True si c'est une classe

Source code
property IsClass : Boolean read FIsClass

Read Access
FIsClass

Sepi
Class Tree
Index
Previous
Next (IsForwardClass)


Sepi

Sepi
Previous (IsClass)
Next (IsMetaClass)

Name
IsForwardClass

Parent
TDelphiClassTypeNode

Visibility
PUBLIC

Description
True si c'est une classe forwardée

Source code
property IsForwardClass : Boolean read FIsForwardClass

Read Access
FIsForwardClass

Sepi
Class Tree
Index
Previous (IsClass)
Next (IsMetaClass)


Sepi

Sepi
Previous (IsForwardClass)
Next (SepiClass)

Name
IsMetaClass

Parent
TDelphiClassTypeNode

Visibility
PUBLIC

Description
True si c'est une meta-classe

Source code
property IsMetaClass : Boolean read FIsMetaClass

Read Access
FIsMetaClass

Sepi
Class Tree
Index
Previous (IsForwardClass)
Next (SepiClass)


Sepi

Sepi
Previous (IsMetaClass)
Next (SepiMetaClass)

Name
SepiClass

Parent
TDelphiClassTypeNode

Visibility
PUBLIC

Description
Classe Sepi compilée

Source code
property SepiClass : TSepiClass read FSepiClass

Read Access
FSepiClass

Sepi
Class Tree
Index
Previous (IsMetaClass)
Next (SepiMetaClass)


Sepi

Sepi
Previous (SepiClass)
Next

Name
SepiMetaClass

Parent
TDelphiClassTypeNode

Visibility
PUBLIC

Description
Component-classe compilée

Source code
property SepiMetaClass : TSepiMetaClass read FSepiMetaClass

Read Access
FSepiMetaClass

Sepi
Class Tree
Index
Previous (SepiClass)
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TDelphiClassTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (CreateClass)

Name
ChildEndParsing

Parent
TDelphiClassTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (CreateClass)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
CreateClass

Parent
TDelphiClassTypeNode

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure CreateClass ( ParentClass : TSepiClass = nil )

Parameters
Parameter | Description
ParentClass : TSepiClass | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (CreateClass)
Next (GetSepiContext)

Name
EndParsing

Parent
TDelphiClassTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateClass)
Next (GetSepiContext)


Sepi

Sepi
Previous (EndParsing)
Next (ResolveIdent)

Name
GetSepiContext

Parent
TDelphiClassTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetSepiContext : TSepiComponent ; override

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next (ResolveIdent)


Sepi

Sepi
Previous (GetSepiContext)
Next

Name
ResolveIdent

Parent
TDelphiClassTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetSepiContext)
Next


Sepi

Sepi
Previous (TDelphiClassTypeNode)
Next (TDelphiConstOrTypeNode)

Name
TDelphiConstantDeclNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud déclaration de constante

Members
Fields
Field | Description
FConstant (-) | Constante Sepi (peut être nil)
FConstType (-) | Type de la constante
FConstVar (-) | Variable constante Sepi (peut être nil)
FName (-) | Nom de la constante

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]

Properties
Property | Description
Constant (+) | Constante Sepi (peut être nil)
ConstType (+) | Type de la constante
ConstVar (+) | Variable constante Sepi (peut être nil)
NAME (+) | Nom de la constante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiClassTypeNode)
Next (TDelphiConstOrTypeNode)


Sepi

Sepi
Previous
Next (FConstType)

Name
FConstant

Parent
TDelphiConstantDeclNode

Visibility
PRIVATE

Description
Constante Sepi (peut être nil)

Source code
FConstant : TSepiConstant

Sepi
Class Tree
Index
Previous
Next (FConstType)


Sepi

Sepi
Previous (FConstant)
Next (FConstVar)

Name
FConstType

Parent
TDelphiConstantDeclNode

Visibility
PRIVATE

Description
Type de la constante

Source code
FConstType : TSepiType

Sepi
Class Tree
Index
Previous (FConstant)
Next (FConstVar)


Sepi

Sepi
Previous (FConstType)
Next (FName)

Name
FConstVar

Parent
TDelphiConstantDeclNode

Visibility
PRIVATE

Description
Variable constante Sepi (peut être nil)

Source code
FConstVar : TSepiVariable

Sepi
Class Tree
Index
Previous (FConstType)
Next (FName)


Sepi

Sepi
Previous (FConstVar)
Next

Name
FName

Parent
TDelphiConstantDeclNode

Visibility
PRIVATE

Description
Nom de la constante

Source code
FName : string

Sepi
Class Tree
Index
Previous (FConstVar)
Next


Sepi

Sepi
Previous
Next (ConstType)

Name
Constant

Parent
TDelphiConstantDeclNode

Visibility
PUBLIC

Description
Constante Sepi (peut être nil)

Source code
property Constant : TSepiConstant read FConstant

Read Access
FConstant

Sepi
Class Tree
Index
Previous
Next (ConstType)


Sepi

Sepi
Previous (Constant)
Next (ConstVar)

Name
ConstType

Parent
TDelphiConstantDeclNode

Visibility
PUBLIC

Description
Type de la constante

Source code
property ConstType : TSepiType read FConstType

Read Access
FConstType

Sepi
Class Tree
Index
Previous (Constant)
Next (ConstVar)


Sepi

Sepi
Previous (ConstType)
Next (NAME)

Name
ConstVar

Parent
TDelphiConstantDeclNode

Visibility
PUBLIC

Description
Variable constante Sepi (peut être nil)

Source code
property ConstVar : TSepiVariable read FConstVar

Read Access
FConstVar

Sepi
Class Tree
Index
Previous (ConstType)
Next (NAME)


Sepi

Sepi
Previous (ConstVar)
Next

Name
NAME

Parent
TDelphiConstantDeclNode

Visibility
PUBLIC

Description
Nom de la constante

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (ConstVar)
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TDelphiConstantDeclNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
ChildEndParsing

Parent
TDelphiConstantDeclNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TDelphiConstantDeclNode)
Next (TDelphiEnumTypeNode)

Name
TDelphiConstOrTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiConstExpressionNode

Visibility
PUBLIC

Description
Noeud expression constante ou type

Members
Methods
Method | Description
GetIsType (-) | Indique si c'est un type
ValidateExpression (#) | [@inheritDoc]

Properties
Property | Description
IsType (+) | Indique si c'est un type

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiConstantDeclNode)
Next (TDelphiEnumTypeNode)


Sepi

Sepi
Previous
Next

Name
IsType

Parent
TDelphiConstOrTypeNode

Visibility
PUBLIC

Description
Indique si c'est un type

Source code
property IsType : Boolean read GetIsType

Read Access
GetIsType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ValidateExpression)

Name
GetIsType

Parent
TDelphiConstOrTypeNode

Visibility
PRIVATE

Description
Indique si c'est un type

Source code
function GetIsType : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si c'est un type, False sinon

Sepi
Class Tree
Index
Previous
Next (ValidateExpression)


Sepi

Sepi
Previous (GetIsType)
Next

Name
ValidateExpression

Parent
TDelphiConstOrTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function ValidateExpression : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsType)
Next


Sepi

Sepi
Previous (TDelphiConstOrTypeNode)
Next (TDelphiFakeEnumTypeNode)

Name
TDelphiEnumTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type énumération

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiConstOrTypeNode)
Next (TDelphiFakeEnumTypeNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TDelphiEnumTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiEnumTypeNode)
Next (TDelphiFakeEnumValueNode)

Name
TDelphiFakeEnumTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type fausse énumération

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiEnumTypeNode)
Next (TDelphiFakeEnumValueNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TDelphiFakeEnumTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiFakeEnumTypeNode)
Next (TDelphiGUIDInitializationNode)

Name
TDelphiFakeEnumValueNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud descripteur d'une valeur d'un type fausse énumération

Members
Fields
Field | Description
FValue (-) | Valeur

Methods
Method | Description
ChildEndParsing (#) | [@inheritDoc]

Properties
Property | Description
Value (+) | Valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiFakeEnumTypeNode)
Next (TDelphiGUIDInitializationNode)


Sepi

Sepi
Previous
Next

Name
FValue

Parent
TDelphiFakeEnumValueNode

Visibility
PRIVATE

Description
Valeur

Source code
FValue : TSepiFakeEnumValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Value

Parent
TDelphiFakeEnumValueNode

Visibility
PUBLIC

Description
Valeur

Source code
property Value : TSepiFakeEnumValue read FValue

Read Access
FValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
ChildEndParsing

Parent
TDelphiFakeEnumValueNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiFakeEnumValueNode)
Next (TDelphiImplementationNode)

Name
TDelphiGUIDInitializationNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Noeud d'expression d'initialisation d'un GUID

Members
Fields
Field | Description
FRecordType (-) | Type de valeur comme type record

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
IsValidType (+) | [@inheritDoc]

Properties
Property | Description
RecordType (+) | Type de valeur comme type record

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiFakeEnumValueNode)
Next (TDelphiImplementationNode)


Sepi

Sepi
Previous
Next

Name
FRecordType

Parent
TDelphiGUIDInitializationNode

Visibility
PRIVATE

Description
Type de valeur comme type record

Source code
FRecordType : TSepiRecordType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
RecordType

Parent
TDelphiGUIDInitializationNode

Visibility
PUBLIC

Description
Type de valeur comme type record

Source code
property RecordType : TSepiRecordType read FRecordType write FRecordType

Read Access
FRecordType

Write Access
FRecordType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TDelphiGUIDInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TDelphiGUIDInitializationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (IsValidType)

Name
ChildEndParsing

Parent
TDelphiGUIDInitializationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (IsValidType)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
IsValidType

Parent
TDelphiGUIDInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function IsValidType ( AValueType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TDelphiGUIDInitializationNode)
Next (TDelphiInitializationExpressionNode)

Name
TDelphiImplementationNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud implémentation

Members
Methods
Method | Description
BeginParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiGUIDInitializationNode)
Next (TDelphiInitializationExpressionNode)


Sepi

Sepi
Previous
Next

Name
BeginParsing

Parent
TDelphiImplementationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiImplementationNode)
Next (TDelphiInterfaceGUIDNode)

Name
TDelphiInitializationExpressionNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Noeud d'expression d'initialisation

Members
Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
IsValidType (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiImplementationNode)
Next (TDelphiInterfaceGUIDNode)


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TDelphiInitializationExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (IsValidType)

Name
ChildBeginParsing

Parent
TDelphiInitializationExpressionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (IsValidType)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
IsValidType

Parent
TDelphiInitializationExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function IsValidType ( AValueType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TDelphiInitializationExpressionNode)
Next (TDelphiInterfaceNode)

Name
TDelphiInterfaceGUIDNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Noeud GUID d'interface

Members
Methods
Method | Description
ChildEndParsing (#) | [@inheritDoc]
SetValuePtr (+) | Indique où stocker le résultat

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiInitializationExpressionNode)
Next (TDelphiInterfaceNode)


Sepi

Sepi
Previous
Next (SetValuePtr)

Name
ChildEndParsing

Parent
TDelphiInterfaceGUIDNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (SetValuePtr)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
SetValuePtr

Parent
TDelphiInterfaceGUIDNode

Visibility
PUBLIC

Description
Indique où stocker le résultat
Si AValuePtr vaut nil, une nouvelle valeur de type TGUID sera créée, et
libérée à la destruction de cet objet.
Cette méthode doit être appelée exactement une fois, avant BeginParsing.

Source code
procedure SetValuePtr ( AValuePtr : PGUID )

Parameters
Parameter | Description
AValuePtr : PGUID | Pointeur où stocker le résultat (peut être nil)

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TDelphiInterfaceGUIDNode)
Next (TDelphiInterfaceTypeNode)

Name
TDelphiInterfaceNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud interface

Members
Methods
Method | Description
BeginParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiInterfaceGUIDNode)
Next (TDelphiInterfaceTypeNode)


Sepi

Sepi
Previous
Next

Name
BeginParsing

Parent
TDelphiInterfaceNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiInterfaceNode)
Next (TDelphiMethodRefTypeNode)

Name
TDelphiInterfaceTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type interface

Members
Fields
Field | Description
FGUID (-) | GUID de l'interface
FIsDispIntf (-) | True si c'est une dispinterface
FParentIntf (-) | Interface parent
FSepiIntf (-) | Interface Sepi compilée

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
CreateInterface (-) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
GetSepiContext (#) | [@inheritDoc]
ResolveIdent (+) | [@inheritDoc]

Properties
Property | Description
GUID (+) | GUID de l'interface
IsDispIntf (+) | True si c'est une dispinterface
ParentIntf (+) | Interface parent
SepiIntf (+) | Interface Sepi compilée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiInterfaceNode)
Next (TDelphiMethodRefTypeNode)


Sepi

Sepi
Previous
Next (FIsDispIntf)

Name
FGUID

Parent
TDelphiInterfaceTypeNode

Visibility
PRIVATE

Description
GUID de l'interface

Source code
FGUID : TGUID

Sepi
Class Tree
Index
Previous
Next (FIsDispIntf)


Sepi

Sepi
Previous (FGUID)
Next (FParentIntf)

Name
FIsDispIntf

Parent
TDelphiInterfaceTypeNode

Visibility
PRIVATE

Description
True si c'est une dispinterface

Source code
FIsDispIntf : Boolean

Sepi
Class Tree
Index
Previous (FGUID)
Next (FParentIntf)


Sepi

Sepi
Previous (FIsDispIntf)
Next (FSepiIntf)

Name
FParentIntf

Parent
TDelphiInterfaceTypeNode

Visibility
PRIVATE

Description
Interface parent

Source code
FParentIntf : TSepiInterface

Sepi
Class Tree
Index
Previous (FIsDispIntf)
Next (FSepiIntf)


Sepi

Sepi
Previous (FParentIntf)
Next

Name
FSepiIntf

Parent
TDelphiInterfaceTypeNode

Visibility
PRIVATE

Description
Interface Sepi compilée

Source code
FSepiIntf : TSepiInterface

Sepi
Class Tree
Index
Previous (FParentIntf)
Next


Sepi

Sepi
Previous
Next (IsDispIntf)

Name
GUID

Parent
TDelphiInterfaceTypeNode

Visibility
PUBLIC

Description
GUID de l'interface

Source code
property GUID : TGUID read FGUID

Read Access
FGUID

Sepi
Class Tree
Index
Previous
Next (IsDispIntf)


Sepi

Sepi
Previous (GUID)
Next (ParentIntf)

Name
IsDispIntf

Parent
TDelphiInterfaceTypeNode

Visibility
PUBLIC

Description
True si c'est une dispinterface

Source code
property IsDispIntf : Boolean read FIsDispIntf

Read Access
FIsDispIntf

Sepi
Class Tree
Index
Previous (GUID)
Next (ParentIntf)


Sepi

Sepi
Previous (IsDispIntf)
Next (SepiIntf)

Name
ParentIntf

Parent
TDelphiInterfaceTypeNode

Visibility
PUBLIC

Description
Interface parent

Source code
property ParentIntf : TSepiInterface read FParentIntf

Read Access
FParentIntf

Sepi
Class Tree
Index
Previous (IsDispIntf)
Next (SepiIntf)


Sepi

Sepi
Previous (ParentIntf)
Next

Name
SepiIntf

Parent
TDelphiInterfaceTypeNode

Visibility
PUBLIC

Description
Interface Sepi compilée

Source code
property SepiIntf : TSepiInterface read FSepiIntf

Read Access
FSepiIntf

Sepi
Class Tree
Index
Previous (ParentIntf)
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TDelphiInterfaceTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TDelphiInterfaceTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (CreateInterface)

Name
ChildEndParsing

Parent
TDelphiInterfaceTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (CreateInterface)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
CreateInterface

Parent
TDelphiInterfaceTypeNode

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure CreateInterface

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (CreateInterface)
Next (GetSepiContext)

Name
EndParsing

Parent
TDelphiInterfaceTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateInterface)
Next (GetSepiContext)


Sepi

Sepi
Previous (EndParsing)
Next (ResolveIdent)

Name
GetSepiContext

Parent
TDelphiInterfaceTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetSepiContext : TSepiComponent ; override

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next (ResolveIdent)


Sepi

Sepi
Previous (GetSepiContext)
Next

Name
ResolveIdent

Parent
TDelphiInterfaceTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetSepiContext)
Next


Sepi

Sepi
Previous (TDelphiInterfaceTypeNode)
Next (TDelphiOfObjectMarkerNode)

Name
TDelphiMethodRefTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type référence de méthode

Members
Fields
Field | Description
FSignature (-) | Signature

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Signature (+) | Signature

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiInterfaceTypeNode)
Next (TDelphiOfObjectMarkerNode)


Sepi

Sepi
Previous
Next

Name
FSignature

Parent
TDelphiMethodRefTypeNode

Visibility
PRIVATE

Description
Signature

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Signature

Parent
TDelphiMethodRefTypeNode

Visibility
PUBLIC

Description
Signature

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TDelphiMethodRefTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TDelphiMethodRefTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (Destroy)

Name
ChildEndParsing

Parent
TDelphiMethodRefTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (Destroy)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
Destroy

Parent
TDelphiMethodRefTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (Destroy)
Next

Name
EndParsing

Parent
TDelphiMethodRefTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (TDelphiMethodRefTypeNode)
Next (TDelphiOtherInitializationNode)

Name
TDelphiOfObjectMarkerNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud marqueur of object

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiMethodRefTypeNode)
Next (TDelphiOtherInitializationNode)


Sepi

Sepi
Previous (TDelphiOfObjectMarkerNode)
Next (TDelphiPackedArrayTypeNode)

Name
TDelphiOtherInitializationNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Noeud d'expression d'initialisation d'un autre type que tableau ou record

Members
Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
IsValidType (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiOfObjectMarkerNode)
Next (TDelphiPackedArrayTypeNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
ChildBeginParsing

Parent
TDelphiOtherInitializationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (IsValidType)

Name
EndParsing

Parent
TDelphiOtherInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (IsValidType)


Sepi

Sepi
Previous (EndParsing)
Next

Name
IsValidType

Parent
TDelphiOtherInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function IsValidType ( AValueType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TDelphiOtherInitializationNode)
Next (TDelphiPackedRecordTypeNode)

Name
TDelphiPackedArrayTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TDelphiArrayTypeNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type tableau packed

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiOtherInitializationNode)
Next (TDelphiPackedRecordTypeNode)


Sepi

Sepi
Previous (TDelphiPackedArrayTypeNode)
Next (TDelphiParametersNode)

Name
TDelphiPackedRecordTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TDelphiRecordTypeNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type packed record

Members
Methods
Method | Description
Create (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiPackedArrayTypeNode)
Next (TDelphiParametersNode)


Sepi

Sepi
Previous
Next

Name
Create

Parent
TDelphiPackedRecordTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AParent : TSepiNonTerminal ; AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; override

Parameters
Parameter | Description
AParent : TSepiNonTerminal | #Pas de TAG trouvé dans le code source#
AClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#
ASourcePos : TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiPackedRecordTypeNode)
Next (TDelphiPointerTypeNode)

Name
TDelphiParametersNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiDelphiLikeParametersNode

Visibility
PUBLIC

Description
Noeud paramètres réels

Members
Methods
Method | Description
BeginParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiPackedRecordTypeNode)
Next (TDelphiPointerTypeNode)


Sepi

Sepi
Previous
Next

Name
BeginParsing

Parent
TDelphiParametersNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiParametersNode)
Next (TDelphiRangeOrEnumTypeNode)

Name
TDelphiPointerTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type pointeur

Members
Methods
Method | Description
CMNotifyTypeCreated (-) | Gestionnaire du message CM_NOTIFYTYPECREATED
EndParsing (+) | [@inheritDoc]
GetPointedType (-) | Récupère le type pointé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiParametersNode)
Next (TDelphiRangeOrEnumTypeNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
CMNotifyTypeCreated

Parent
TDelphiPointerTypeNode

Visibility
PRIVATE

Description
Gestionnaire du message CM_NOTIFYTYPECREATED

Source code
procedure CMNotifyTypeCreated ( var Msg : TCMNotifyTypeCreated ) ; message CM_NOTIFYTYPECREATED

Parameters
Parameter | Description
Msg : TCMNotifyTypeCreated | Message

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (CMNotifyTypeCreated)
Next (GetPointedType)

Name
EndParsing

Parent
TDelphiPointerTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CMNotifyTypeCreated)
Next (GetPointedType)


Sepi

Sepi
Previous (EndParsing)
Next

Name
GetPointedType

Parent
TDelphiPointerTypeNode

Visibility
PRIVATE

Description
Récupère le type pointé

Source code
function GetPointedType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type pointé, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TDelphiPointerTypeNode)
Next (TDelphiRangeTypeNode)

Name
TDelphiRangeOrEnumTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type intervalle ou énumération

Members
Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiPointerTypeNode)
Next (TDelphiRangeTypeNode)


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TDelphiRangeOrEnumTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
ChildEndParsing

Parent
TDelphiRangeOrEnumTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TDelphiRangeOrEnumTypeNode)
Next (TDelphiRecordInitializationNode)

Name
TDelphiRangeTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type intervalle

Members
Methods
Method | Description
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
MakeType (-) | Construit le type

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiRangeOrEnumTypeNode)
Next (TDelphiRecordInitializationNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
ChildEndParsing

Parent
TDelphiRangeTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next (MakeType)

Name
EndParsing

Parent
TDelphiRangeTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (MakeType)


Sepi

Sepi
Previous (EndParsing)
Next

Name
MakeType

Parent
TDelphiRangeTypeNode

Visibility
PRIVATE

Description
Construit le type

Source code
function MakeType ( const TypeName : string ; BaseType : TSepiType ; const LowerValue , HigherValue ) : TSepiType

Parameters
Parameter | Description
TypeName : STRING | Nom du type à créer
BaseType : TSepiType | Type de base
LowerValue : Untyped | Valeur basse
HigherValue : Untyped | Valeur haute

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TDelphiRangeTypeNode)
Next (TDelphiRecordTypeNode)

Name
TDelphiRecordInitializationNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Noeud d'expression d'initialisation d'un record

Members
Fields
Field | Description
FRecordType (-) | Type de valeur comme type record

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
IsValidType (+) | [@inheritDoc]

Properties
Property | Description
RecordType (+) | Type de valeur comme type record

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiRangeTypeNode)
Next (TDelphiRecordTypeNode)


Sepi

Sepi
Previous
Next

Name
FRecordType

Parent
TDelphiRecordInitializationNode

Visibility
PRIVATE

Description
Type de valeur comme type record

Source code
FRecordType : TSepiRecordType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
RecordType

Parent
TDelphiRecordInitializationNode

Visibility
PUBLIC

Description
Type de valeur comme type record

Source code
property RecordType : TSepiRecordType read FRecordType write FRecordType

Read Access
FRecordType

Write Access
FRecordType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TDelphiRecordInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (IsValidType)

Name
ChildBeginParsing

Parent
TDelphiRecordInitializationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (IsValidType)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
IsValidType

Parent
TDelphiRecordInitializationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function IsValidType ( AValueType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TDelphiRecordInitializationNode)
Next (TDelphiRootNode)

Name
TDelphiRecordTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type record

Members
Fields
Field | Description
FIsPacked (-) | Indique si le record doit être packed
FRecordType (-) | Type record

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
GetSepiContext (#) | [@inheritDoc]

Properties
Property | Description
IsPacked (#) | Indique si le record doit être packed
RecordType (+) | Type record

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiRecordInitializationNode)
Next (TDelphiRootNode)


Sepi

Sepi
Previous
Next (FRecordType)

Name
FIsPacked

Parent
TDelphiRecordTypeNode

Visibility
PRIVATE

Description
Indique si le record doit être packed

Source code
FIsPacked : Boolean

Sepi
Class Tree
Index
Previous
Next (FRecordType)


Sepi

Sepi
Previous (FIsPacked)
Next

Name
FRecordType

Parent
TDelphiRecordTypeNode

Visibility
PRIVATE

Description
Type record

Source code
FRecordType : TSepiRecordType

Sepi
Class Tree
Index
Previous (FIsPacked)
Next


Sepi

Sepi
Previous
Next (RecordType)

Name
IsPacked

Parent
TDelphiRecordTypeNode

Visibility
PROTECTED

Description
Indique si le record doit être packed

Source code
property IsPacked : Boolean read FIsPacked write FIsPacked

Read Access
FIsPacked

Write Access
FIsPacked

Sepi
Class Tree
Index
Previous
Next (RecordType)


Sepi

Sepi
Previous (IsPacked)
Next

Name
RecordType

Parent
TDelphiRecordTypeNode

Visibility
PUBLIC

Description
Type record

Source code
property RecordType : TSepiRecordType read FRecordType

Read Access
FRecordType

Sepi
Class Tree
Index
Previous (IsPacked)
Next


Sepi

Sepi
Previous
Next (EndParsing)

Name
BeginParsing

Parent
TDelphiRecordTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (GetSepiContext)

Name
EndParsing

Parent
TDelphiRecordTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (GetSepiContext)


Sepi

Sepi
Previous (EndParsing)
Next

Name
GetSepiContext

Parent
TDelphiRecordTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetSepiContext : TSepiComponent ; override

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TDelphiRecordTypeNode)
Next (TDelphiSetTypeNode)

Name
TDelphiRootNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Noeud racine

Members
Fields
Field | Description
FMaxAlign (-) | Alignment maximum des champs
FMinEnumSize (-) | Taille minimale d'énumération

Methods
Method | Description
CDMAlign (-) | Gestionnaire de message CDM_ALIGN
CDMMinEnumSize (-) | Gestionnaire de message CDM_MINENUMSIZE
ChildEndParsing (#) | [@inheritDoc]
Create (+) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
ResolveIdent (+) | [@inheritDoc]

Properties
Property | Description
MaxAlign (+) | Alignment maximum des champs
MinEnumSize (+) | Taille minimale d'énumération

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiRecordTypeNode)
Next (TDelphiSetTypeNode)


Sepi

Sepi
Previous
Next (FMinEnumSize)

Name
FMaxAlign

Parent
TDelphiRootNode

Visibility
PRIVATE

Description
Alignment maximum des champs

Source code
FMaxAlign : Integer

Sepi
Class Tree
Index
Previous
Next (FMinEnumSize)


Sepi

Sepi
Previous (FMaxAlign)
Next

Name
FMinEnumSize

Parent
TDelphiRootNode

Visibility
PRIVATE

Description
Taille minimale d'énumération

Source code
FMinEnumSize : TSepiMinEnumSize

Sepi
Class Tree
Index
Previous (FMaxAlign)
Next


Sepi

Sepi
Previous
Next (MinEnumSize)

Name
MaxAlign

Parent
TDelphiRootNode

Visibility
PUBLIC

Description
Alignment maximum des champs

Source code
property MaxAlign : Integer read FMaxAlign

Read Access
FMaxAlign

Sepi
Class Tree
Index
Previous
Next (MinEnumSize)


Sepi

Sepi
Previous (MaxAlign)
Next

Name
MinEnumSize

Parent
TDelphiRootNode

Visibility
PUBLIC

Description
Taille minimale d'énumération

Source code
property MinEnumSize : TSepiMinEnumSize read FMinEnumSize

Read Access
FMinEnumSize

Sepi
Class Tree
Index
Previous (MaxAlign)
Next


Sepi

Sepi
Previous
Next (CDMMinEnumSize)

Name
CDMAlign

Parent
TDelphiRootNode

Visibility
PRIVATE

Description
Gestionnaire de message CDM_ALIGN

Source code
procedure CDMAlign ( var Msg : TCDMAlign ) ; message CDM_ALIGN

Parameters
Parameter | Description
Msg : TCDMAlign | Message

Sepi
Class Tree
Index
Previous
Next (CDMMinEnumSize)


Sepi

Sepi
Previous (CDMAlign)
Next (ChildEndParsing)

Name
CDMMinEnumSize

Parent
TDelphiRootNode

Visibility
PRIVATE

Description
Gestionnaire de message CDM_MINENUMSIZE

Source code
procedure CDMMinEnumSize ( var Msg : TCDMMinEnumSize ) ; message CDM_MINENUMSIZE

Parameters
Parameter | Description
Msg : TCDMMinEnumSize | Message

Sepi
Class Tree
Index
Previous (CDMAlign)
Next (ChildEndParsing)


Sepi

Sepi
Previous (CDMMinEnumSize)
Next (Create)

Name
ChildEndParsing

Parent
TDelphiRootNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CDMMinEnumSize)
Next (Create)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
Create

Parent
TDelphiRootNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AClass : TSepiSymbolClass ; ASepiRoot : TSepiRoot ; AErrors : TSepiCompilerErrorList ) ; override

Parameters
Parameter | Description
AClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#
ASepiRoot : TSepiRoot | #Pas de TAG trouvé dans le code source#
AErrors : TSepiCompilerErrorList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (Create)
Next (ResolveIdent)

Name
EndParsing

Parent
TDelphiRootNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (ResolveIdent)


Sepi

Sepi
Previous (EndParsing)
Next

Name
ResolveIdent

Parent
TDelphiRootNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TDelphiRootNode)
Next (TDelphiSingleExprNode)

Name
TDelphiSetTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type ensemble

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]
IsValidCompType (#) | Teste si un type donné est valide comme type d'élément d'ensemble
MakeErroneousType (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiRootNode)
Next (TDelphiSingleExprNode)


Sepi

Sepi
Previous
Next (IsValidCompType)

Name
EndParsing

Parent
TDelphiSetTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (IsValidCompType)


Sepi

Sepi
Previous (EndParsing)
Next (MakeErroneousType)

Name
IsValidCompType

Parent
TDelphiSetTypeNode

Visibility
PROTECTED

Description
Teste si un type donné est valide comme type d'élément d'ensemble

Source code
function IsValidCompType ( CompType : TSepiType ) : Boolean

Parameters
Parameter | Description
CompType : TSepiType | Type de composant à tester

Return
Types | Description
BOOLEAN | True s'il est valide, False sinon

Sepi
Class Tree
Index
Previous (EndParsing)
Next (MakeErroneousType)


Sepi

Sepi
Previous (IsValidCompType)
Next

Name
MakeErroneousType

Parent
TDelphiSetTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure MakeErroneousType ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (IsValidCompType)
Next


Sepi

Sepi
Previous (TDelphiSetTypeNode)
Next (TDelphiStringTypeNode)

Name
TDelphiSingleExprNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiExpressionWithModifiersNode

Visibility
PUBLIC

Description
Noeud expression simple (sans opérateurs binaires)

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiSetTypeNode)
Next (TDelphiStringTypeNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TDelphiSingleExprNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiSingleExprNode)
Next (TDelphiTypeCloneNode)

Name
TDelphiStringTypeNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un type chaîne courte

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiSingleExprNode)
Next (TDelphiTypeCloneNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TDelphiStringTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiStringTypeNode)
Next (TDelphiTypeDeclNode)

Name
TDelphiTypeCloneNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Noeud descripteur d'un clone de type

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiStringTypeNode)
Next (TDelphiTypeDeclNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TDelphiTypeCloneNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiTypeCloneNode)
Next (TDelphiUnaryOpNode)

Name
TDelphiTypeDeclNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud déclaration de type

Members
Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiTypeCloneNode)
Next (TDelphiUnaryOpNode)


Sepi

Sepi
Previous
Next

Name
ChildBeginParsing

Parent
TDelphiTypeDeclNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiTypeDeclNode)
Next (TDelphiVariableDeclNode)

Name
TDelphiUnaryOpNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiDelphiLikeUnaryOpNode

Visibility
PUBLIC

Description
Noeud opérateur unaire

Members
Methods
Method | Description
GetOperation (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiTypeDeclNode)
Next (TDelphiVariableDeclNode)


Sepi

Sepi
Previous
Next

Name
GetOperation

Parent
TDelphiUnaryOpNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetOperation : TSepiOperation ; override

Parameters
Parameter Description

Return
Types | Description
TSepiOperation | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TDelphiUnaryOpNode)
Next

Name
TDelphiVariableDeclNode

Parent
SepiDelphiCompiler

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud déclaration de variable

Members
Fields
Field | Description
FNames (-) | Nom de la variable
FVariable (-) | Variable Sepi
FVarType (-) | Type de la variable

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]

Properties
Property | Description
Names (+) | Nom de la variable
Variable (+) | Variable Sepi
VarType (+) | Type de la variable

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TDelphiUnaryOpNode)
Next


Sepi

Sepi
Previous
Next (FVariable)

Name
FNames

Parent
TDelphiVariableDeclNode

Visibility
PRIVATE

Description
Nom de la variable

Source code
FNames : TStrings

Sepi
Class Tree
Index
Previous
Next (FVariable)


Sepi

Sepi
Previous (FNames)
Next (FVarType)

Name
FVariable

Parent
TDelphiVariableDeclNode

Visibility
PRIVATE

Description
Variable Sepi

Source code
FVariable : TSepiVariable

Sepi
Class Tree
Index
Previous (FNames)
Next (FVarType)


Sepi

Sepi
Previous (FVariable)
Next

Name
FVarType

Parent
TDelphiVariableDeclNode

Visibility
PRIVATE

Description
Type de la variable

Source code
FVarType : TSepiType

Sepi
Class Tree
Index
Previous (FVariable)
Next


Sepi

Sepi
Previous
Next (Variable)

Name
Names

Parent
TDelphiVariableDeclNode

Visibility
PUBLIC

Description
Nom de la variable

Source code
property Names : TStrings read FNames

Read Access
FNames

Sepi
Class Tree
Index
Previous
Next (Variable)


Sepi

Sepi
Previous (Names)
Next (VarType)

Name
Variable

Parent
TDelphiVariableDeclNode

Visibility
PUBLIC

Description
Variable Sepi

Source code
property Variable : TSepiVariable read FVariable

Read Access
FVariable

Sepi
Class Tree
Index
Previous (Names)
Next (VarType)


Sepi

Sepi
Previous (Variable)
Next

Name
VarType

Parent
TDelphiVariableDeclNode

Visibility
PUBLIC

Description
Type de la variable

Source code
property VarType : TSepiType read FVarType

Read Access
FVarType

Sepi
Class Tree
Index
Previous (Variable)
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TDelphiVariableDeclNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (Destroy)

Name
ChildEndParsing

Parent
TDelphiVariableDeclNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (Destroy)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
Destroy

Parent
TDelphiVariableDeclNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous
Next

Name
CompileDelphiSource

Parent
SepiDelphiCompiler

Visibility
PUBLIC

Description
Compile un fichier source Delphi

Source code
function CompileDelphiSource ( SepiRoot : TSepiRoot ; Errors : TSepiCompilerErrorList ; SourceFile : TStrings ; const DestFileName : TFileName ) : TSepiUnit

Parameters
Parameter | Description
SepiRoot : TSepiRoot | Racine Sepi
Errors : TSepiCompilerErrorList | Gestionnaire d'erreurs
SourceFile : TStrings | Source à compiler
DestFileName : TFileName | Nom du fichier de sortie

Return
Types | Description
TSepiUnit | Unité Sepi compilée (interface seulement, pas d'implémentation)

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiDelphiCompiler)
Next (SepiDelphiLexer)

Name
SepiDelphiCompilerConsts

Parent
Sepi

Description
Constantes pour la compilation d'unité unité Delphi en Sepi

Author
sjrd

Version
1.0

Constants
Constant | Description
SCodePageSpecificationForbidden (+) | #No TAG found in source code#
SElementCountMismatch (+) | #No TAG found in source code#
SWrongSetCompType (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiDelphiCompiler)
Next (SepiDelphiLexer)


Sepi

Sepi
Previous
Next (SElementCountMismatch)

Name
SCodePageSpecificationForbidden

Parent
SepiDelphiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCodePageSpecificationForbidden = 'Spécification de page de code non autorisée en dehors des AnsiString'

Sepi
Class Tree
Index
Previous
Next (SElementCountMismatch)


Sepi

Sepi
Previous (SCodePageSpecificationForbidden)
Next (SWrongSetCompType)

Name
SElementCountMismatch

Parent
SepiDelphiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SElementCountMismatch = 'Le nombre d''éléments (%1:d) diffère de la déclaration (%0:d)'

Sepi
Class Tree
Index
Previous (SCodePageSpecificationForbidden)
Next (SWrongSetCompType)


Sepi

Sepi
Previous (SElementCountMismatch)
Next

Name
SWrongSetCompType

Parent
SepiDelphiCompilerConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SWrongSetCompType = 'Les éléments d''un ensemble doivent être des ordinaux avec maximum 256 ' + 'valeurs'

Sepi
Class Tree
Index
Previous (SElementCountMismatch)
Next


Sepi

Sepi
Previous (SepiDelphiCompilerConsts)
Next (SepiDelphiLikeCompilerUtils)

Name
SepiDelphiLexer

Parent
Sepi

Description
Analyseur lexical d'une unité Delphi

Author
sjrd

Version
1.0

Types
Type | Description
TPreProcInstruction (+) | Type d'instruction du pré-processuer

Constants
Constant | Description
CDM_ALIGN (+) | ID message Direction du Compilateur : $ALIGN ou $A
CDM_MINENUMSIZE (+) | ID message Directive du Compilateur : $MINEMUMSIZE ou $Z
FirstTerminal (+) | #No TAG found in source code#
LastTerminal (+) | #No TAG found in source code#
SErrorInIFInstr (+) | #No TAG found in source code#
SIFInstrNotSupported (+) | #No TAG found in source code#
SPreProcReachedEndOfFile (+) | #No TAG found in source code#
tkAbstract (+) | #No TAG found in source code#
tkAnd (+) | #No TAG found in source code#
tkArray (+) | #No TAG found in source code#
tkAs (+) | #No TAG found in source code#
tkAssembler (+) | #No TAG found in source code#
tkAssign (+) | #No TAG found in source code#
tkAt (+) | #No TAG found in source code#
tkBegin (+) | #No TAG found in source code#
tkBlank (+) | Lexème blanc
tkCase (+) | #No TAG found in source code#
tkCDecl (+) | #No TAG found in source code#
tkClass (+) | #No TAG found in source code#
tkCloseBracket (+) | #No TAG found in source code#
tkCloseSqBracket (+) | #No TAG found in source code#
tkColon (+) | #No TAG found in source code#
tkComma (+) | #No TAG found in source code#
tkComment (+) | Lexème commentaire
tkConst (+) | #No TAG found in source code#
tkConstructor (+) | #No TAG found in source code#
tkDefault (+) | #No TAG found in source code#
tkDeprecated (+) | #No TAG found in source code#
tkDestructor (+) | #No TAG found in source code#
tkDispID (+) | #No TAG found in source code#
tkDispInterface (+) | #No TAG found in source code#
tkDiv (+) | #No TAG found in source code#
tkDivide (+) | #No TAG found in source code#
tkDo (+) | #No TAG found in source code#
tkDot (+) | #No TAG found in source code#
tkDownTo (+) | #No TAG found in source code#
tkDynamic (+) | #No TAG found in source code#
tkElse (+) | #No TAG found in source code#
tkEnd (+) | #No TAG found in source code#
tkEof (+) | Fin de fichier
tkEquals (+) | #No TAG found in source code#
tkExcept (+) | #No TAG found in source code#
tkFinalization (+) | #No TAG found in source code#
tkFinally (+) | #No TAG found in source code#
tkFloat (+) | #No TAG found in source code#
tkFor (+) | #No TAG found in source code#
tkForward (+) | #No TAG found in source code#
tkFunction (+) | #No TAG found in source code#
tkGreaterEq (+) | #No TAG found in source code#
tkGreaterThan (+) | #No TAG found in source code#
tkHat (+) | #No TAG found in source code#
tkIdentifier (+) | #No TAG found in source code#
tkIf (+) | #No TAG found in source code#
tkImplementation (+) | #No TAG found in source code#
tkIn (+) | #No TAG found in source code#
tkIndex (+) | #No TAG found in source code#
tkInherited (+) | #No TAG found in source code#
tkInitialization (+) | #No TAG found in source code#
tkInline (+) | #No TAG found in source code#
tkInteger (+) | #No TAG found in source code#
tkInterface (+) | #No TAG found in source code#
tkIs (+) | #No TAG found in source code#
tkLowerEq (+) | #No TAG found in source code#
tkLowerThan (+) | #No TAG found in source code#
tkMessage (+) | #No TAG found in source code#
tkMinus (+) | #No TAG found in source code#
tkMod (+) | #No TAG found in source code#
tkName (+) | #No TAG found in source code#
tkNil (+) | #No TAG found in source code#
tkNoDefault (+) | #No TAG found in source code#
tkNot (+) | #No TAG found in source code#
tkNotEqual (+) | #No TAG found in source code#
tkObject (+) | #No TAG found in source code#
tkOf (+) | #No TAG found in source code#
tkOn (+) | #No TAG found in source code#
tkOpenBracket (+) | #No TAG found in source code#
tkOpenSqBracket (+) | #No TAG found in source code#
tkOr (+) | #No TAG found in source code#
tkOut (+) | #No TAG found in source code#
tkOverload (+) | #No TAG found in source code#
tkOverride (+) | #No TAG found in source code#
tkPacked (+) | #No TAG found in source code#
tkPascal (+) | #No TAG found in source code#
tkPlatform (+) | #No TAG found in source code#
tkPlus (+) | #No TAG found in source code#
tkPreProcessor (+) | #No TAG found in source code#
tkPrivate (+) | #No TAG found in source code#
tkProcedure (+) | #No TAG found in source code#
tkProperty (+) | #No TAG found in source code#
tkProtected (+) | #No TAG found in source code#
tkPublic (+) | #No TAG found in source code#
tkPublished (+) | #No TAG found in source code#
tkRaise (+) | #No TAG found in source code#
tkRange (+) | #No TAG found in source code#
tkRead (+) | #No TAG found in source code#
tkReadOnly (+) | #No TAG found in source code#
tkRecord (+) | #No TAG found in source code#
tkRegister (+) | #No TAG found in source code#
tkReintroduce (+) | #No TAG found in source code#
tkRepeat (+) | #No TAG found in source code#
tkResourceString (+) | #No TAG found in source code#
tkSafeCall (+) | #No TAG found in source code#
tkSemiColon (+) | #No TAG found in source code#
tkSet (+) | #No TAG found in source code#
tkShl (+) | #No TAG found in source code#
tkShr (+) | #No TAG found in source code#
tkStatic (+) | #No TAG found in source code#
tkStdCall (+) | #No TAG found in source code#
tkStored (+) | #No TAG found in source code#
tkStrict (+) | #No TAG found in source code#
tkString (+) | #No TAG found in source code#
tkStringCst (+) | #No TAG found in source code#
tkThen (+) | #No TAG found in source code#
tkTimes (+) | #No TAG found in source code#
tkTo (+) | #No TAG found in source code#
tkTry (+) | #No TAG found in source code#
tkType (+) | #No TAG found in source code#
tkUnit (+) | #No TAG found in source code#
tkUntil (+) | #No TAG found in source code#
tkUses (+) | #No TAG found in source code#
tkVar (+) | #No TAG found in source code#
tkVirtual (+) | #No TAG found in source code#
tkWhile (+) | #No TAG found in source code#
tkWith (+) | #No TAG found in source code#
tkWrite (+) | #No TAG found in source code#
tkWriteOnly (+) | #No TAG found in source code#
tkXor (+) | #No TAG found in source code#

Variables
Variable | Description
SymbolClassNames (+) | Symbol class names, indexed by their IDs

Classes
Class | Description
TCDMAlign (+) | Type de message Directive du Compilateur : $ALIGN ou $A
TCDMMinEnumSize (+) | Type de message Directive du Compilateur : $MINEMUMSIZE ou $Z
TPreProcIfConditionNode (+) | Noeud condition d'une instruction du pré-processeur $IF
TSepiDefinedDeclaredPseudoRoutine (+) | Pseudo-routine d'opération sur un type
TSepiDelphiBaseLexer (+) | Analyseur lexical de base pour le langage Delphi
TSepiDelphiInterfaceLexer (+) | Analyseur lexical de base pour le langage Delphi - interface uniquement
TSepiDelphiLexer (+) | Analyseur lexical de base pour le langage Delphi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiDelphiCompilerConsts)
Next (SepiDelphiLikeCompilerUtils)


Sepi

Sepi
Previous
Next (TCDMMinEnumSize)

Name
TCDMAlign

Parent
SepiDelphiLexer

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Type de message Directive du Compilateur : $ALIGN ou $A

Members
Fields
Field | Description
MaxAlign (*) | Nouvel alignment maximal
MsgID (*) | ID du message (CDM_ALIGN)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TCDMMinEnumSize)


Sepi

Sepi
Previous
Next (MsgID)

Name
MaxAlign

Parent
TCDMAlign

Visibility
PUBLISHED

Description
Nouvel alignment maximal

Source code
MaxAlign : Integer

Sepi
Class Tree
Index
Previous
Next (MsgID)


Sepi

Sepi
Previous (MaxAlign)
Next

Name
MsgID

Parent
TCDMAlign

Visibility
PUBLISHED

Description
ID du message (CDM_ALIGN)

Source code
MsgID : Word

Sepi
Class Tree
Index
Previous (MaxAlign)
Next


Sepi

Sepi
Previous (TCDMAlign)
Next (TPreProcIfConditionNode)

Name
TCDMMinEnumSize

Parent
SepiDelphiLexer

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Type de message Directive du Compilateur : $MINEMUMSIZE ou $Z

Members
Fields
Field | Description
MinEmumSize (*) | Nouvelle taille mininum d'enum
MsgID (*) | ID du message (CDM_MINENUMSIZE)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCDMAlign)
Next (TPreProcIfConditionNode)


Sepi

Sepi
Previous
Next (MsgID)

Name
MinEmumSize

Parent
TCDMMinEnumSize

Visibility
PUBLISHED

Description
Nouvelle taille mininum d'enum

Source code
MinEmumSize : TSepiMinEnumSize

Sepi
Class Tree
Index
Previous
Next (MsgID)


Sepi

Sepi
Previous (MinEmumSize)
Next

Name
MsgID

Parent
TCDMMinEnumSize

Visibility
PUBLISHED

Description
ID du message (CDM_MINENUMSIZE)

Source code
MsgID : Word

Sepi
Class Tree
Index
Previous (MinEmumSize)
Next


Sepi

Sepi
Previous (TCDMMinEnumSize)
Next (TSepiDefinedDeclaredPseudoRoutine)

Name
TPreProcIfConditionNode

Parent
SepiDelphiLexer

Class Hierarchy
TSepiHiddenNonTerminal

Visibility
PUBLIC

Description
Noeud condition d'une instruction du pré-processeur $IF

Members
Fields
Field | Description
FLexer (-) | Analyseur propriétaire

Methods
Method | Description
ResolveIdent (+) | [@inheritDoc]

Properties
Property | Description
Lexer (+) | Analyseur propriétaire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCDMMinEnumSize)
Next (TSepiDefinedDeclaredPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
FLexer

Parent
TPreProcIfConditionNode

Visibility
PRIVATE

Description
Analyseur propriétaire

Source code
FLexer : TSepiDelphiLexer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Lexer

Parent
TPreProcIfConditionNode

Visibility
PUBLIC

Description
Analyseur propriétaire

Source code
property Lexer : TSepiDelphiLexer read FLexer

Read Access
FLexer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
ResolveIdent

Parent
TPreProcIfConditionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TPreProcIfConditionNode)
Next (TSepiDelphiBaseLexer)

Name
TSepiDefinedDeclaredPseudoRoutine

Parent
SepiDelphiLexer

Class Hierarchy
TSepiCustomComputedValue,ISepiIdentifierTestPseudoRoutine

Visibility
PUBLIC

Description
Pseudo-routine d'opération sur un type

Members
Fields
Field | Description
FIdentifier (-) | Identificateur à tester
FIsDeclared (-) | False pour Defined ; True pour Declared
FLexer (-) | Analyseur du contexte

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète la pseudo-routine
Create (+) | Crée la pseudo-routine
GetIdentifier (#) | [@inheritDoc]
SetIdentifier (#) | [@inheritDoc]

Properties
Property | Description
Identifier (+) | Identificateur à tester
IsDeclared (+) | False pour Defined ; True pour Declared
Lexer (+) | Analyseur du contexte

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TPreProcIfConditionNode)
Next (TSepiDelphiBaseLexer)


Sepi

Sepi
Previous
Next (FIsDeclared)

Name
FIdentifier

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PRIVATE

Description
Identificateur à tester

Source code
FIdentifier : string

Sepi
Class Tree
Index
Previous
Next (FIsDeclared)


Sepi

Sepi
Previous (FIdentifier)
Next (FLexer)

Name
FIsDeclared

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PRIVATE

Description
False pour Defined ; True pour Declared

Source code
FIsDeclared : Boolean

Sepi
Class Tree
Index
Previous (FIdentifier)
Next (FLexer)


Sepi

Sepi
Previous (FIsDeclared)
Next

Name
FLexer

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PRIVATE

Description
Analyseur du contexte

Source code
FLexer : TSepiDelphiLexer

Sepi
Class Tree
Index
Previous (FIsDeclared)
Next


Sepi

Sepi
Previous
Next (IsDeclared)

Name
Identifier

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PUBLIC

Description
Identificateur à tester

Source code
property Identifier : string read FIdentifier write FIdentifier

Read Access
FIdentifier

Write Access
FIdentifier

Sepi
Class Tree
Index
Previous
Next (IsDeclared)


Sepi

Sepi
Previous (Identifier)
Next (Lexer)

Name
IsDeclared

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PUBLIC

Description
False pour Defined ; True pour Declared

Source code
property IsDeclared : Boolean read FIsDeclared

Read Access
FIsDeclared

Sepi
Class Tree
Index
Previous (Identifier)
Next (Lexer)


Sepi

Sepi
Previous (IsDeclared)
Next

Name
Lexer

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PUBLIC

Description
Analyseur du contexte

Source code
property Lexer : TSepiDelphiLexer read FLexer

Read Access
FLexer

Sepi
Class Tree
Index
Previous (IsDeclared)
Next


Sepi

Sepi
Previous
Next (CompileCompute)

Name
AttachToExpression

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileCompute)


Sepi

Sepi
Previous (AttachToExpression)
Next (Complete)

Name
CompileCompute

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (Create)

Name
Complete

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PUBLIC

Description
Complète la pseudo-routine

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (GetIdentifier)

Name
Create

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PUBLIC

Description
Crée la pseudo-routine

Source code
constructor Create ( ALexer : TSepiDelphiLexer ; AIsDeclared : Boolean )

Parameters
Parameter | Description
ALexer : TSepiDelphiLexer | #Pas de TAG trouvé dans le code source#
AIsDeclared : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (GetIdentifier)


Sepi

Sepi
Previous (Create)
Next (SetIdentifier)

Name
GetIdentifier

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIdentifier : string

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (SetIdentifier)


Sepi

Sepi
Previous (GetIdentifier)
Next

Name
SetIdentifier

Parent
TSepiDefinedDeclaredPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetIdentifier ( const Value : string )

Parameters
Parameter | Description
Value : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIdentifier)
Next


Sepi

Sepi
Previous (TSepiDefinedDeclaredPseudoRoutine)
Next (TSepiDelphiInterfaceLexer)

Name
TSepiDelphiBaseLexer

Parent
SepiDelphiLexer

Class Hierarchy
TSepiCustomManualLexer

Visibility
PUBLIC

Description
Analyseur lexical de base pour le langage Delphi

Members
Methods
Method | Description
ActionIdentifier (#) | Analyse un identificateur
ActionMultiLineComment (#) | Analyse un commentaire sur plusieurs lignes
ActionNumber (#) | Analyse un nombre
ActionSingleLineComment (#) | Analyse un commentaire sur une ligne
ActionString (#) | Analyse une chaîne de caractères
ActionSymbol (#) | Analyse un symbole ou un commentaire
IdentifyKeyword (#) | [@inheritDoc]
InitLexingProcs (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDefinedDeclaredPseudoRoutine)
Next (TSepiDelphiInterfaceLexer)


Sepi

Sepi
Previous
Next (ActionMultiLineComment)

Name
ActionIdentifier

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
Analyse un identificateur

Source code
procedure ActionIdentifier

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ActionMultiLineComment)


Sepi

Sepi
Previous (ActionIdentifier)
Next (ActionNumber)

Name
ActionMultiLineComment

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
Analyse un commentaire sur plusieurs lignes

Source code
procedure ActionMultiLineComment

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ActionIdentifier)
Next (ActionNumber)


Sepi

Sepi
Previous (ActionMultiLineComment)
Next (ActionSingleLineComment)

Name
ActionNumber

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
Analyse un nombre

Source code
procedure ActionNumber

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ActionMultiLineComment)
Next (ActionSingleLineComment)


Sepi

Sepi
Previous (ActionNumber)
Next (ActionString)

Name
ActionSingleLineComment

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
Analyse un commentaire sur une ligne

Source code
procedure ActionSingleLineComment

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ActionNumber)
Next (ActionString)


Sepi

Sepi
Previous (ActionSingleLineComment)
Next (ActionSymbol)

Name
ActionString

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
Analyse une chaîne de caractères

Source code
procedure ActionString

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ActionSingleLineComment)
Next (ActionSymbol)


Sepi

Sepi
Previous (ActionString)
Next (IdentifyKeyword)

Name
ActionSymbol

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
Analyse un symbole ou un commentaire

Source code
procedure ActionSymbol

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ActionString)
Next (IdentifyKeyword)


Sepi

Sepi
Previous (ActionSymbol)
Next (InitLexingProcs)

Name
IdentifyKeyword

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure IdentifyKeyword ( const OrigKey : string ; var SymbolClass : TSepiSymbolClass ) ; override

Parameters
Parameter | Description
OrigKey : STRING | #Pas de TAG trouvé dans le code source#
SymbolClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ActionSymbol)
Next (InitLexingProcs)


Sepi

Sepi
Previous (IdentifyKeyword)
Next

Name
InitLexingProcs

Parent
TSepiDelphiBaseLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InitLexingProcs ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (IdentifyKeyword)
Next


Sepi

Sepi
Previous (TSepiDelphiBaseLexer)
Next (TSepiDelphiLexer)

Name
TSepiDelphiInterfaceLexer

Parent
SepiDelphiLexer

Class Hierarchy
TSepiDelphiLexer

Visibility
PUBLIC

Description
Analyseur lexical de base pour le langage Delphi - interface uniquement

Members
Fields
Field | Description
FSpecialTerminal (-) | #No TAG found in source code#
FStep (-) | Étape du lexer

Methods
Method | Description
Destroy (+) | [@inheritDoc]
DoNextTerminal (#) | [@inheritDoc]
GetCurTerminal (#) | [@inheritDoc]
ResetToBookmark (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDelphiBaseLexer)
Next (TSepiDelphiLexer)


Sepi

Sepi
Previous
Next (FStep)

Name
FSpecialTerminal

Parent
TSepiDelphiInterfaceLexer

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FSpecialTerminal : TSepiTerminal

Sepi
Class Tree
Index
Previous
Next (FStep)


Sepi

Sepi
Previous (FSpecialTerminal)
Next

Name
FStep

Parent
TSepiDelphiInterfaceLexer

Visibility
PRIVATE

Description
Étape du lexer

Source code
FStep : ( stNormal , stImplementation , stEnd , stFinalDot , stEof )

Sepi
Class Tree
Index
Previous (FSpecialTerminal)
Next


Sepi

Sepi
Previous
Next (DoNextTerminal)

Name
Destroy

Parent
TSepiDelphiInterfaceLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (DoNextTerminal)


Sepi

Sepi
Previous (Destroy)
Next (GetCurTerminal)

Name
DoNextTerminal

Parent
TSepiDelphiInterfaceLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure DoNextTerminal ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetCurTerminal)


Sepi

Sepi
Previous (DoNextTerminal)
Next (ResetToBookmark)

Name
GetCurTerminal

Parent
TSepiDelphiInterfaceLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetCurTerminal : TSepiTerminal ; override

Parameters
Parameter Description

Return
Types | Description
TSepiTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (DoNextTerminal)
Next (ResetToBookmark)


Sepi

Sepi
Previous (GetCurTerminal)
Next

Name
ResetToBookmark

Parent
TSepiDelphiInterfaceLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure ResetToBookmark ( ABookmark : TSepiLexerBookmark ; FreeBookmark : Boolean = True ) ; override

Parameters
Parameter | Description
ABookmark : TSepiLexerBookmark | #Pas de TAG trouvé dans le code source#
FreeBookmark : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCurTerminal)
Next


Sepi

Sepi
Previous (TSepiDelphiInterfaceLexer)
Next

Name
TSepiDelphiLexer

Parent
SepiDelphiLexer

Class Hierarchy
TSepiCustomCompositeLexer

Visibility
PUBLIC

Description
Analyseur lexical de base pour le langage Delphi

Members
Fields
Field | Description
FDefines (-) | Liste des defines

Methods
Method | Description
Create (+) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
DoAlign (-) | Applique la directive $ALIGN ou $A
DoInclude (-) | Applique la directive $INCLUDE ou $I
DoMinEnumSize (-) | Applique la directive $MINENUMSIZE ou $Z
DoNextTerminal (#) | [@inheritDoc]
EvalCondition (-) | Évalue une condition booléenne constante dans le contexte courant
HandleToggle (-) | Applique une directive de type toggle
HandleToggles (-) | Applique une directive avec des toggles
PreProc (-) | Applique une instruction du pré-processeur
ReadCommand (-) | Lit la commande du pré-processeur
Skip (-) | Élimine une portion de code, jusqu'au $ELSE, $ENDIF ou $IFEND correspondant

Properties
Property | Description
Defines (+) | Liste des defines

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDelphiInterfaceLexer)
Next


Sepi

Sepi
Previous
Next

Name
FDefines

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Liste des defines

Source code
FDefines : TStrings

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Defines

Parent
TSepiDelphiLexer

Visibility
PUBLIC

Description
Liste des defines

Source code
property Defines : TStrings read FDefines

Read Access
FDefines

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiDelphiLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; const ACode : string ; const AFileName : TFileName = '' ) ; override

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | #Pas de TAG trouvé dans le code source#
ACode : STRING | #Pas de TAG trouvé dans le code source#
AFileName : TFileName | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (DoAlign)

Name
Destroy

Parent
TSepiDelphiLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (DoAlign)


Sepi

Sepi
Previous (Destroy)
Next (DoInclude)

Name
DoAlign

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Applique la directive $ALIGN ou $A

Source code
procedure DoAlign ( const Param : string )

Parameters
Parameter | Description
Param : STRING | Paramètre

Sepi
Class Tree
Index
Previous (Destroy)
Next (DoInclude)


Sepi

Sepi
Previous (DoAlign)
Next (DoMinEnumSize)

Name
DoInclude

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Applique la directive $INCLUDE ou $I

Source code
procedure DoInclude ( const Param : string )

Parameters
Parameter | Description
Param : STRING | Paramètre

Sepi
Class Tree
Index
Previous (DoAlign)
Next (DoMinEnumSize)


Sepi

Sepi
Previous (DoInclude)
Next (DoNextTerminal)

Name
DoMinEnumSize

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Applique la directive $MINENUMSIZE ou $Z

Source code
procedure DoMinEnumSize ( const Param : string )

Parameters
Parameter | Description
Param : STRING | Paramètre

Sepi
Class Tree
Index
Previous (DoInclude)
Next (DoNextTerminal)


Sepi

Sepi
Previous (DoMinEnumSize)
Next (EvalCondition)

Name
DoNextTerminal

Parent
TSepiDelphiLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure DoNextTerminal ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DoMinEnumSize)
Next (EvalCondition)


Sepi

Sepi
Previous (DoNextTerminal)
Next (HandleToggle)

Name
EvalCondition

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Évalue une condition booléenne constante dans le contexte courant

Source code
function EvalCondition ( const Condition : string ) : Boolean

Parameters
Parameter | Description
Condition : STRING | Condition à tester

Return
Types | Description
BOOLEAN | Valeur de vérité de la condition

Sepi
Class Tree
Index
Previous (DoNextTerminal)
Next (HandleToggle)


Sepi

Sepi
Previous (EvalCondition)
Next (HandleToggles)

Name
HandleToggle

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Applique une directive de type toggle

Source code
procedure HandleToggle ( Toggle , Value : Char )

Parameters
Parameter | Description
Toggle : CHAR | Toggle à appliquer
Value : CHAR | Valeur du toggle

Sepi
Class Tree
Index
Previous (EvalCondition)
Next (HandleToggles)


Sepi

Sepi
Previous (HandleToggle)
Next (PreProc)

Name
HandleToggles

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Applique une directive avec des toggles

Source code
procedure HandleToggles ( const Toggles : string )

Parameters
Parameter Description
Toggles : STRING

Sepi
Class Tree
Index
Previous (HandleToggle)
Next (PreProc)


Sepi

Sepi
Previous (HandleToggles)
Next (ReadCommand)

Name
PreProc

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Applique une instruction du pré-processeur

Source code
procedure PreProc

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (HandleToggles)
Next (ReadCommand)


Sepi

Sepi
Previous (PreProc)
Next (Skip)

Name
ReadCommand

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Lit la commande du pré-processeur

Source code
function ReadCommand ( out Param : string ) : TPreProcInstruction

Parameters
Parameter | Description
Param : STRING | En sortie : paramètre de la commande (ou '' si aucun)

Return
Types | Description
TPreProcInstruction | Numéro de la commande, ou -1 si inconnue

Sepi
Class Tree
Index
Previous (PreProc)
Next (Skip)


Sepi

Sepi
Previous (ReadCommand)
Next

Name
Skip

Parent
TSepiDelphiLexer

Visibility
PRIVATE

Description
Élimine une portion de code, jusqu'au $ELSE, $ENDIF ou $IFEND correspondant

Source code
procedure Skip ( StopOnElseIf : Boolean = False )

Parameters
Parameter | Description
StopOnElseIf : BOOLEAN | Si True, s'arrête aussi sur un $ELSEIF

Sepi
Class Tree
Index
Previous (ReadCommand)
Next


Sepi

Sepi
Previous
Next

Name
TPreProcInstruction

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
Type d'instruction du pré-processuer

Source code
TPreProcInstruction = ( ppUnknown , ppToggles , ppDefine , ppUndef , ppIfDef , ppIfNDef , ppIf , ppElse , ppElseIf , ppEndIf , ppIfEnd , ppMinEnumSize , ppAlign , ppInclude ) ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CDM_MINENUMSIZE)

Name
CDM_ALIGN

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
ID message Direction du Compilateur : $ALIGN ou $A

Source code
CDM_ALIGN = 2

Sepi
Class Tree
Index
Previous
Next (CDM_MINENUMSIZE)


Sepi

Sepi
Previous (CDM_ALIGN)
Next (FirstTerminal)

Name
CDM_MINENUMSIZE

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
ID message Directive du Compilateur : $MINEMUMSIZE ou $Z

Source code
CDM_MINENUMSIZE = 1

Sepi
Class Tree
Index
Previous (CDM_ALIGN)
Next (FirstTerminal)


Sepi

Sepi
Previous (CDM_MINENUMSIZE)
Next (LastTerminal)

Name
FirstTerminal

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
FirstTerminal = 0

Sepi
Class Tree
Index
Previous (CDM_MINENUMSIZE)
Next (LastTerminal)


Sepi

Sepi
Previous (FirstTerminal)
Next (SErrorInIFInstr)

Name
LastTerminal

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
LastTerminal = 119

Sepi
Class Tree
Index
Previous (FirstTerminal)
Next (SErrorInIFInstr)


Sepi

Sepi
Previous (LastTerminal)
Next (SIFInstrNotSupported)

Name
SErrorInIFInstr

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SErrorInIFInstr = 'Erreur dans la condition d''un $IF ou $ELSEIF'

Sepi
Class Tree
Index
Previous (LastTerminal)
Next (SIFInstrNotSupported)


Sepi

Sepi
Previous (SErrorInIFInstr)
Next (SPreProcReachedEndOfFile)

Name
SIFInstrNotSupported

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SIFInstrNotSupported = 'Instruction du pré-processeur $IF non supportée sans contexte'

Sepi
Class Tree
Index
Previous (SErrorInIFInstr)
Next (SPreProcReachedEndOfFile)


Sepi

Sepi
Previous (SIFInstrNotSupported)
Next (tkAbstract)

Name
SPreProcReachedEndOfFile

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SPreProcReachedEndOfFile = 'Fin de fichier atteinte par le pré-processeur'

Sepi
Class Tree
Index
Previous (SIFInstrNotSupported)
Next (tkAbstract)


Sepi

Sepi
Previous (SPreProcReachedEndOfFile)
Next (tkAnd)

Name
tkAbstract

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkAbstract = 94

Sepi
Class Tree
Index
Previous (SPreProcReachedEndOfFile)
Next (tkAnd)


Sepi

Sepi
Previous (tkAbstract)
Next (tkArray)

Name
tkAnd

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkAnd = 59

Sepi
Class Tree
Index
Previous (tkAbstract)
Next (tkArray)


Sepi

Sepi
Previous (tkAnd)
Next (tkAs)

Name
tkArray

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkArray = 27

Sepi
Class Tree
Index
Previous (tkAnd)
Next (tkAs)


Sepi

Sepi
Previous (tkArray)
Next (tkAssembler)

Name
tkAs

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkAs = 69

Sepi
Class Tree
Index
Previous (tkArray)
Next (tkAssembler)


Sepi

Sepi
Previous (tkAs)
Next (tkAssign)

Name
tkAssembler

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkAssembler = 75

Sepi
Class Tree
Index
Previous (tkAs)
Next (tkAssign)


Sepi

Sepi
Previous (tkAssembler)
Next (tkAt)

Name
tkAssign

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkAssign = 19

Sepi
Class Tree
Index
Previous (tkAssembler)
Next (tkAt)


Sepi

Sepi
Previous (tkAssign)
Next (tkBegin)

Name
tkAt

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkAt = 18

Sepi
Class Tree
Index
Previous (tkAssign)
Next (tkBegin)


Sepi

Sepi
Previous (tkAt)
Next (tkBlank)

Name
tkBegin

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkBegin = 42

Sepi
Class Tree
Index
Previous (tkAt)
Next (tkBlank)


Sepi

Sepi
Previous (tkBegin)
Next (tkCase)

Name
tkBlank

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
Lexème blanc

Source code
tkBlank = SepiLexerUtils . tkBlank

Sepi
Class Tree
Index
Previous (tkBegin)
Next (tkCase)


Sepi

Sepi
Previous (tkBlank)
Next (tkCDecl)

Name
tkCase

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkCase = 33

Sepi
Class Tree
Index
Previous (tkBlank)
Next (tkCDecl)


Sepi

Sepi
Previous (tkCase)
Next (tkClass)

Name
tkCDecl

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkCDecl = 71

Sepi
Class Tree
Index
Previous (tkCase)
Next (tkClass)


Sepi

Sepi
Previous (tkCDecl)
Next (tkCloseBracket)

Name
tkClass

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkClass = 36

Sepi
Class Tree
Index
Previous (tkCDecl)
Next (tkCloseBracket)


Sepi

Sepi
Previous (tkClass)
Next (tkCloseSqBracket)

Name
tkCloseBracket

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkCloseBracket = 8

Sepi
Class Tree
Index
Previous (tkClass)
Next (tkCloseSqBracket)


Sepi

Sepi
Previous (tkCloseBracket)
Next (tkColon)

Name
tkCloseSqBracket

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkCloseSqBracket = 10

Sepi
Class Tree
Index
Previous (tkCloseBracket)
Next (tkColon)


Sepi

Sepi
Previous (tkCloseSqBracket)
Next (tkComma)

Name
tkColon

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkColon = 13

Sepi
Class Tree
Index
Previous (tkCloseSqBracket)
Next (tkComma)


Sepi

Sepi
Previous (tkColon)
Next (tkComment)

Name
tkComma

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkComma = 12

Sepi
Class Tree
Index
Previous (tkColon)
Next (tkComment)


Sepi

Sepi
Previous (tkComma)
Next (tkConst)

Name
tkComment

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
Lexème commentaire

Source code
tkComment = SepiLexerUtils . tkComment

Sepi
Class Tree
Index
Previous (tkComma)
Next (tkConst)


Sepi

Sepi
Previous (tkComment)
Next (tkConstructor)

Name
tkConst

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkConst = 23

Sepi
Class Tree
Index
Previous (tkComment)
Next (tkConstructor)


Sepi

Sepi
Previous (tkConst)
Next (tkDefault)

Name
tkConstructor

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkConstructor = 48

Sepi
Class Tree
Index
Previous (tkConst)
Next (tkDefault)


Sepi

Sepi
Previous (tkConstructor)
Next (tkDeprecated)

Name
tkDefault

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDefault = 80

Sepi
Class Tree
Index
Previous (tkConstructor)
Next (tkDeprecated)


Sepi

Sepi
Previous (tkDefault)
Next (tkDestructor)

Name
tkDeprecated

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDeprecated = 87

Sepi
Class Tree
Index
Previous (tkDefault)
Next (tkDestructor)


Sepi

Sepi
Previous (tkDeprecated)
Next (tkDispID)

Name
tkDestructor

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDestructor = 49

Sepi
Class Tree
Index
Previous (tkDeprecated)
Next (tkDispID)


Sepi

Sepi
Previous (tkDestructor)
Next (tkDispInterface)

Name
tkDispID

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDispID = 83

Sepi
Class Tree
Index
Previous (tkDestructor)
Next (tkDispInterface)


Sepi

Sepi
Previous (tkDispID)
Next (tkDiv)

Name
tkDispInterface

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDispInterface = 35

Sepi
Class Tree
Index
Previous (tkDispID)
Next (tkDiv)


Sepi

Sepi
Previous (tkDispInterface)
Next (tkDivide)

Name
tkDiv

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDiv = 54

Sepi
Class Tree
Index
Previous (tkDispInterface)
Next (tkDivide)


Sepi

Sepi
Previous (tkDiv)
Next (tkDo)

Name
tkDivide

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDivide = 53

Sepi
Class Tree
Index
Previous (tkDiv)
Next (tkDo)


Sepi

Sepi
Previous (tkDivide)
Next (tkDot)

Name
tkDo

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDo = 106

Sepi
Class Tree
Index
Previous (tkDivide)
Next (tkDot)


Sepi

Sepi
Previous (tkDo)
Next (tkDownTo)

Name
tkDot

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDot = 15

Sepi
Class Tree
Index
Previous (tkDo)
Next (tkDownTo)


Sepi

Sepi
Previous (tkDot)
Next (tkDynamic)

Name
tkDownTo

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDownTo = 111

Sepi
Class Tree
Index
Previous (tkDot)
Next (tkDynamic)


Sepi

Sepi
Previous (tkDownTo)
Next (tkElse)

Name
tkDynamic

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkDynamic = 91

Sepi
Class Tree
Index
Previous (tkDownTo)
Next (tkElse)


Sepi

Sepi
Previous (tkDynamic)
Next (tkEnd)

Name
tkElse

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkElse = 104

Sepi
Class Tree
Index
Previous (tkDynamic)
Next (tkEnd)


Sepi

Sepi
Previous (tkElse)
Next (tkEof)

Name
tkEnd

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkEnd = 43

Sepi
Class Tree
Index
Previous (tkElse)
Next (tkEof)


Sepi

Sepi
Previous (tkEnd)
Next (tkEquals)

Name
tkEof

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
Fin de fichier

Source code
tkEof = SepiLexerUtils . tkEof

Sepi
Class Tree
Index
Previous (tkEnd)
Next (tkEquals)


Sepi

Sepi
Previous (tkEof)
Next (tkExcept)

Name
tkEquals

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkEquals = 11

Sepi
Class Tree
Index
Previous (tkEof)
Next (tkExcept)


Sepi

Sepi
Previous (tkEquals)
Next (tkFinalization)

Name
tkExcept

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkExcept = 113

Sepi
Class Tree
Index
Previous (tkEquals)
Next (tkFinalization)


Sepi

Sepi
Previous (tkExcept)
Next (tkFinally)

Name
tkFinalization

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkFinalization = 101

Sepi
Class Tree
Index
Previous (tkExcept)
Next (tkFinally)


Sepi

Sepi
Previous (tkFinalization)
Next (tkFloat)

Name
tkFinally

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkFinally = 115

Sepi
Class Tree
Index
Previous (tkFinalization)
Next (tkFloat)


Sepi

Sepi
Previous (tkFinally)
Next (tkFor)

Name
tkFloat

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkFloat = 5

Sepi
Class Tree
Index
Previous (tkFinally)
Next (tkFor)


Sepi

Sepi
Previous (tkFloat)
Next (tkForward)

Name
tkFor

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkFor = 109

Sepi
Class Tree
Index
Previous (tkFloat)
Next (tkForward)


Sepi

Sepi
Previous (tkFor)
Next (tkFunction)

Name
tkForward

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkForward = 99

Sepi
Class Tree
Index
Previous (tkFor)
Next (tkFunction)


Sepi

Sepi
Previous (tkForward)
Next (tkGreaterEq)

Name
tkFunction

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkFunction = 46

Sepi
Class Tree
Index
Previous (tkForward)
Next (tkGreaterEq)


Sepi

Sepi
Previous (tkFunction)
Next (tkGreaterThan)

Name
tkGreaterEq

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkGreaterEq = 65

Sepi
Class Tree
Index
Previous (tkFunction)
Next (tkGreaterThan)


Sepi

Sepi
Previous (tkGreaterEq)
Next (tkHat)

Name
tkGreaterThan

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkGreaterThan = 64

Sepi
Class Tree
Index
Previous (tkGreaterEq)
Next (tkHat)


Sepi

Sepi
Previous (tkGreaterThan)
Next (tkIdentifier)

Name
tkHat

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkHat = 17

Sepi
Class Tree
Index
Previous (tkGreaterThan)
Next (tkIdentifier)


Sepi

Sepi
Previous (tkHat)
Next (tkIf)

Name
tkIdentifier

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkIdentifier = 3

Sepi
Class Tree
Index
Previous (tkHat)
Next (tkIf)


Sepi

Sepi
Previous (tkIdentifier)
Next (tkImplementation)

Name
tkIf

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkIf = 102

Sepi
Class Tree
Index
Previous (tkIdentifier)
Next (tkImplementation)


Sepi

Sepi
Previous (tkIf)
Next (tkIn)

Name
tkImplementation

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkImplementation = 98

Sepi
Class Tree
Index
Previous (tkIf)
Next (tkIn)


Sepi

Sepi
Previous (tkImplementation)
Next (tkIndex)

Name
tkIn

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkIn = 67

Sepi
Class Tree
Index
Previous (tkImplementation)
Next (tkIndex)


Sepi

Sepi
Previous (tkIn)
Next (tkInherited)

Name
tkIndex

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkIndex = 77

Sepi
Class Tree
Index
Previous (tkIn)
Next (tkInherited)


Sepi

Sepi
Previous (tkIndex)
Next (tkInitialization)

Name
tkInherited

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkInherited = 117

Sepi
Class Tree
Index
Previous (tkIndex)
Next (tkInitialization)


Sepi

Sepi
Previous (tkInherited)
Next (tkInline)

Name
tkInitialization

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkInitialization = 100

Sepi
Class Tree
Index
Previous (tkInherited)
Next (tkInline)


Sepi

Sepi
Previous (tkInitialization)
Next (tkInteger)

Name
tkInline

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkInline = 97

Sepi
Class Tree
Index
Previous (tkInitialization)
Next (tkInteger)


Sepi

Sepi
Previous (tkInline)
Next (tkInterface)

Name
tkInteger

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkInteger = 4

Sepi
Class Tree
Index
Previous (tkInline)
Next (tkInterface)


Sepi

Sepi
Previous (tkInteger)
Next (tkIs)

Name
tkInterface

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkInterface = 34

Sepi
Class Tree
Index
Previous (tkInteger)
Next (tkIs)


Sepi

Sepi
Previous (tkInterface)
Next (tkLowerEq)

Name
tkIs

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkIs = 68

Sepi
Class Tree
Index
Previous (tkInterface)
Next (tkLowerEq)


Sepi

Sepi
Previous (tkIs)
Next (tkLowerThan)

Name
tkLowerEq

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkLowerEq = 63

Sepi
Class Tree
Index
Previous (tkIs)
Next (tkLowerThan)


Sepi

Sepi
Previous (tkLowerEq)
Next (tkMessage)

Name
tkLowerThan

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkLowerThan = 62

Sepi
Class Tree
Index
Previous (tkLowerEq)
Next (tkMessage)


Sepi

Sepi
Previous (tkLowerThan)
Next (tkMinus)

Name
tkMessage

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkMessage = 92

Sepi
Class Tree
Index
Previous (tkLowerThan)
Next (tkMinus)


Sepi

Sepi
Previous (tkMessage)
Next (tkMod)

Name
tkMinus

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkMinus = 51

Sepi
Class Tree
Index
Previous (tkMessage)
Next (tkMod)


Sepi

Sepi
Previous (tkMinus)
Next (tkName)

Name
tkMod

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkMod = 55

Sepi
Class Tree
Index
Previous (tkMinus)
Next (tkName)


Sepi

Sepi
Previous (tkMod)
Next (tkNil)

Name
tkName

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkName = 76

Sepi
Class Tree
Index
Previous (tkMod)
Next (tkNil)


Sepi

Sepi
Previous (tkName)
Next (tkNoDefault)

Name
tkNil

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkNil = 44

Sepi
Class Tree
Index
Previous (tkName)
Next (tkNoDefault)


Sepi

Sepi
Previous (tkNil)
Next (tkNot)

Name
tkNoDefault

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkNoDefault = 81

Sepi
Class Tree
Index
Previous (tkNil)
Next (tkNot)


Sepi

Sepi
Previous (tkNoDefault)
Next (tkNotEqual)

Name
tkNot

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkNot = 61

Sepi
Class Tree
Index
Previous (tkNoDefault)
Next (tkNotEqual)


Sepi

Sepi
Previous (tkNot)
Next (tkObject)

Name
tkNotEqual

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkNotEqual = 66

Sepi
Class Tree
Index
Previous (tkNot)
Next (tkObject)


Sepi

Sepi
Previous (tkNotEqual)
Next (tkOf)

Name
tkObject

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkObject = 30

Sepi
Class Tree
Index
Previous (tkNotEqual)
Next (tkOf)


Sepi

Sepi
Previous (tkObject)
Next (tkOn)

Name
tkOf

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOf = 29

Sepi
Class Tree
Index
Previous (tkObject)
Next (tkOn)


Sepi

Sepi
Previous (tkOf)
Next (tkOpenBracket)

Name
tkOn

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOn = 114

Sepi
Class Tree
Index
Previous (tkOf)
Next (tkOpenBracket)


Sepi

Sepi
Previous (tkOn)
Next (tkOpenSqBracket)

Name
tkOpenBracket

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOpenBracket = 7

Sepi
Class Tree
Index
Previous (tkOn)
Next (tkOpenSqBracket)


Sepi

Sepi
Previous (tkOpenBracket)
Next (tkOr)

Name
tkOpenSqBracket

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOpenSqBracket = 9

Sepi
Class Tree
Index
Previous (tkOpenBracket)
Next (tkOr)


Sepi

Sepi
Previous (tkOpenSqBracket)
Next (tkOut)

Name
tkOr

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOr = 58

Sepi
Class Tree
Index
Previous (tkOpenSqBracket)
Next (tkOut)


Sepi

Sepi
Previous (tkOr)
Next (tkOverload)

Name
tkOut

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOut = 26

Sepi
Class Tree
Index
Previous (tkOr)
Next (tkOverload)


Sepi

Sepi
Previous (tkOut)
Next (tkOverride)

Name
tkOverload

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOverload = 89

Sepi
Class Tree
Index
Previous (tkOut)
Next (tkOverride)


Sepi

Sepi
Previous (tkOverload)
Next (tkPacked)

Name
tkOverride

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkOverride = 93

Sepi
Class Tree
Index
Previous (tkOverload)
Next (tkPacked)


Sepi

Sepi
Previous (tkOverride)
Next (tkPascal)

Name
tkPacked

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPacked = 31

Sepi
Class Tree
Index
Previous (tkOverride)
Next (tkPascal)


Sepi

Sepi
Previous (tkPacked)
Next (tkPlatform)

Name
tkPascal

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPascal = 72

Sepi
Class Tree
Index
Previous (tkPacked)
Next (tkPlatform)


Sepi

Sepi
Previous (tkPascal)
Next (tkPlus)

Name
tkPlatform

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPlatform = 88

Sepi
Class Tree
Index
Previous (tkPascal)
Next (tkPlus)


Sepi

Sepi
Previous (tkPlatform)
Next (tkPreProcessor)

Name
tkPlus

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPlus = 50

Sepi
Class Tree
Index
Previous (tkPlatform)
Next (tkPreProcessor)


Sepi

Sepi
Previous (tkPlus)
Next (tkPrivate)

Name
tkPreProcessor

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPreProcessor = 119

Sepi
Class Tree
Index
Previous (tkPlus)
Next (tkPrivate)


Sepi

Sepi
Previous (tkPreProcessor)
Next (tkProcedure)

Name
tkPrivate

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPrivate = 37

Sepi
Class Tree
Index
Previous (tkPreProcessor)
Next (tkProcedure)


Sepi

Sepi
Previous (tkPrivate)
Next (tkProperty)

Name
tkProcedure

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkProcedure = 45

Sepi
Class Tree
Index
Previous (tkPrivate)
Next (tkProperty)


Sepi

Sepi
Previous (tkProcedure)
Next (tkProtected)

Name
tkProperty

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkProperty = 47

Sepi
Class Tree
Index
Previous (tkProcedure)
Next (tkProtected)


Sepi

Sepi
Previous (tkProperty)
Next (tkPublic)

Name
tkProtected

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkProtected = 38

Sepi
Class Tree
Index
Previous (tkProperty)
Next (tkPublic)


Sepi

Sepi
Previous (tkProtected)
Next (tkPublished)

Name
tkPublic

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPublic = 39

Sepi
Class Tree
Index
Previous (tkProtected)
Next (tkPublished)


Sepi

Sepi
Previous (tkPublic)
Next (tkRaise)

Name
tkPublished

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkPublished = 40

Sepi
Class Tree
Index
Previous (tkPublic)
Next (tkRaise)


Sepi

Sepi
Previous (tkPublished)
Next (tkRange)

Name
tkRaise

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkRaise = 116

Sepi
Class Tree
Index
Previous (tkPublished)
Next (tkRange)


Sepi

Sepi
Previous (tkRaise)
Next (tkRead)

Name
tkRange

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkRange = 16

Sepi
Class Tree
Index
Previous (tkRaise)
Next (tkRead)


Sepi

Sepi
Previous (tkRange)
Next (tkReadOnly)

Name
tkRead

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkRead = 78

Sepi
Class Tree
Index
Previous (tkRange)
Next (tkReadOnly)


Sepi

Sepi
Previous (tkRead)
Next (tkRecord)

Name
tkReadOnly

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkReadOnly = 84

Sepi
Class Tree
Index
Previous (tkRead)
Next (tkRecord)


Sepi

Sepi
Previous (tkReadOnly)
Next (tkRegister)

Name
tkRecord

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkRecord = 32

Sepi
Class Tree
Index
Previous (tkReadOnly)
Next (tkRegister)


Sepi

Sepi
Previous (tkRecord)
Next (tkReintroduce)

Name
tkRegister

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkRegister = 70

Sepi
Class Tree
Index
Previous (tkRecord)
Next (tkReintroduce)


Sepi

Sepi
Previous (tkRegister)
Next (tkRepeat)

Name
tkReintroduce

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkReintroduce = 96

Sepi
Class Tree
Index
Previous (tkRegister)
Next (tkRepeat)


Sepi

Sepi
Previous (tkReintroduce)
Next (tkResourceString)

Name
tkRepeat

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkRepeat = 107

Sepi
Class Tree
Index
Previous (tkReintroduce)
Next (tkResourceString)


Sepi

Sepi
Previous (tkRepeat)
Next (tkSafeCall)

Name
tkResourceString

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkResourceString = 24

Sepi
Class Tree
Index
Previous (tkRepeat)
Next (tkSafeCall)


Sepi

Sepi
Previous (tkResourceString)
Next (tkSemiColon)

Name
tkSafeCall

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkSafeCall = 74

Sepi
Class Tree
Index
Previous (tkResourceString)
Next (tkSemiColon)


Sepi

Sepi
Previous (tkSafeCall)
Next (tkSet)

Name
tkSemiColon

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkSemiColon = 14

Sepi
Class Tree
Index
Previous (tkSafeCall)
Next (tkSet)


Sepi

Sepi
Previous (tkSemiColon)
Next (tkShl)

Name
tkSet

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkSet = 28

Sepi
Class Tree
Index
Previous (tkSemiColon)
Next (tkShl)


Sepi

Sepi
Previous (tkSet)
Next (tkShr)

Name
tkShl

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkShl = 56

Sepi
Class Tree
Index
Previous (tkSet)
Next (tkShr)


Sepi

Sepi
Previous (tkShl)
Next (tkStatic)

Name
tkShr

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkShr = 57

Sepi
Class Tree
Index
Previous (tkShl)
Next (tkStatic)


Sepi

Sepi
Previous (tkShr)
Next (tkStdCall)

Name
tkStatic

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkStatic = 95

Sepi
Class Tree
Index
Previous (tkShr)
Next (tkStdCall)


Sepi

Sepi
Previous (tkStatic)
Next (tkStored)

Name
tkStdCall

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkStdCall = 73

Sepi
Class Tree
Index
Previous (tkStatic)
Next (tkStored)


Sepi

Sepi
Previous (tkStdCall)
Next (tkStrict)

Name
tkStored

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkStored = 82

Sepi
Class Tree
Index
Previous (tkStdCall)
Next (tkStrict)


Sepi

Sepi
Previous (tkStored)
Next (tkString)

Name
tkStrict

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkStrict = 41

Sepi
Class Tree
Index
Previous (tkStored)
Next (tkString)


Sepi

Sepi
Previous (tkStrict)
Next (tkStringCst)

Name
tkString

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkString = 86

Sepi
Class Tree
Index
Previous (tkStrict)
Next (tkStringCst)


Sepi

Sepi
Previous (tkString)
Next (tkThen)

Name
tkStringCst

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkStringCst = 6

Sepi
Class Tree
Index
Previous (tkString)
Next (tkThen)


Sepi

Sepi
Previous (tkStringCst)
Next (tkTimes)

Name
tkThen

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkThen = 103

Sepi
Class Tree
Index
Previous (tkStringCst)
Next (tkTimes)


Sepi

Sepi
Previous (tkThen)
Next (tkTo)

Name
tkTimes

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkTimes = 52

Sepi
Class Tree
Index
Previous (tkThen)
Next (tkTo)


Sepi

Sepi
Previous (tkTimes)
Next (tkTry)

Name
tkTo

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkTo = 110

Sepi
Class Tree
Index
Previous (tkTimes)
Next (tkTry)


Sepi

Sepi
Previous (tkTo)
Next (tkType)

Name
tkTry

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkTry = 112

Sepi
Class Tree
Index
Previous (tkTo)
Next (tkType)


Sepi

Sepi
Previous (tkTry)
Next (tkUnit)

Name
tkType

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkType = 22

Sepi
Class Tree
Index
Previous (tkTry)
Next (tkUnit)


Sepi

Sepi
Previous (tkType)
Next (tkUntil)

Name
tkUnit

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkUnit = 20

Sepi
Class Tree
Index
Previous (tkType)
Next (tkUntil)


Sepi

Sepi
Previous (tkUnit)
Next (tkUses)

Name
tkUntil

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkUntil = 108

Sepi
Class Tree
Index
Previous (tkUnit)
Next (tkUses)


Sepi

Sepi
Previous (tkUntil)
Next (tkVar)

Name
tkUses

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkUses = 21

Sepi
Class Tree
Index
Previous (tkUntil)
Next (tkVar)


Sepi

Sepi
Previous (tkUses)
Next (tkVirtual)

Name
tkVar

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkVar = 25

Sepi
Class Tree
Index
Previous (tkUses)
Next (tkVirtual)


Sepi

Sepi
Previous (tkVar)
Next (tkWhile)

Name
tkVirtual

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkVirtual = 90

Sepi
Class Tree
Index
Previous (tkVar)
Next (tkWhile)


Sepi

Sepi
Previous (tkVirtual)
Next (tkWith)

Name
tkWhile

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkWhile = 105

Sepi
Class Tree
Index
Previous (tkVirtual)
Next (tkWith)


Sepi

Sepi
Previous (tkWhile)
Next (tkWrite)

Name
tkWith

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkWith = 118

Sepi
Class Tree
Index
Previous (tkWhile)
Next (tkWrite)


Sepi

Sepi
Previous (tkWith)
Next (tkWriteOnly)

Name
tkWrite

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkWrite = 79

Sepi
Class Tree
Index
Previous (tkWith)
Next (tkWriteOnly)


Sepi

Sepi
Previous (tkWrite)
Next (tkXor)

Name
tkWriteOnly

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkWriteOnly = 85

Sepi
Class Tree
Index
Previous (tkWrite)
Next (tkXor)


Sepi

Sepi
Previous (tkWriteOnly)
Next

Name
tkXor

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
tkXor = 60

Sepi
Class Tree
Index
Previous (tkWriteOnly)
Next


Sepi

Sepi
Previous
Next

Name
SymbolClassNames

Parent
SepiDelphiLexer

Visibility
PUBLIC

Description
Symbol class names, indexed by their IDs

Source code
SymbolClassNames : array of string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiDelphiLexer)
Next (SepiDelphiParser)

Name
SepiDelphiLikeCompilerUtils

Parent
Sepi

Description
Utilitaires pour les compilateurs Sepi de langages ressemblant à Delphi

Author
sjrd

Version
1.0

Types
Type | Description
TSepiSpecialJumpKind (+) | Type de saut spécial existant en Delphi
TSepiTypeOperationOption (+) | Option d'une opération sur un type
TSepiTypeOperationOptions (+) | Options d'une opération sur un type

Constants
Constant | Description
ChrName (+) | Nom de la pseudo-routine Chr
CopyName (+) | Nom de la pseudo-routine Copy
OrdName (+) | Nom de la pseudo-routine Ord
SetLengthName (+) | Nom de la pseudo-routine SetLength
SpecialJumpNames (+) | Nom des pseudo-routines de jump spécial
tooDelphiOptions (+) | Options des opérations sur les types utilisées en Delphi
TypeOperationNames (+) | Noms des opérations sur des types

Classes
Class | Description
ISepiIdentifierTestPseudoRoutine (+) | Pseudo-routine de test d'identificateur
TSepiCastOrConvertPseudoRoutine (+) | Pseudo-routine de transtypage ou de conversion
TSepiCastPseudoRoutine (+) | Pseudo-routine de transtypage
TSepiCopyPseudoRoutine (+) | Pseudo-routine Copy
TSepiDelphiLanguageRules (+) | Règles sémantiques du langage Delphi
TSepiExecutableBackedPseudoRoutine (+) | Pseudo-routine compilée en une expression exécutable
TSepiOneParamValueBackedPseudoRoutine (+) | Pseudo-routine avec exactement un paramètre, et compilée en une valeur
TSepiSetLengthPseudoRoutine (+) | Pseudo-routine SetLength
TSepiSpecialJumpPseudoRoutine (+) | Pseudo-routine de jump spécial (Continue, Break ou Exit)
TSepiTypeOperationPseudoRoutine (+) | Pseudo-routine d'opération sur un type
TSepiValueBackedPseudoRoutine (+) | Pseudo-routine compilée en une valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiDelphiLexer)
Next (SepiDelphiParser)


Sepi

Sepi
Previous
Next (TSepiCastOrConvertPseudoRoutine)

Name
ISepiIdentifierTestPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
ISepiReadableValue

Visibility
PUBLIC

Description
Pseudo-routine de test d'identificateur
Ces pseudo-routines (en Delphi : Defined et Declared) sont utilisées par
les instructions du pré-processuer $IF. Aucune implémentation de cette
interface n'est disponible dans cette unité : les pré-processeurs les
définiront selon leur mode de fonctionnement.

Members
Methods
Method | Description
Complete (+) | #No TAG found in source code#
GetIdentifier (+) | #No TAG found in source code#
SetIdentifier (+) | #No TAG found in source code#

Properties
Property | Description
Identifier (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiCastOrConvertPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
Identifier

Parent
ISepiIdentifierTestPseudoRoutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Identifier : string read GetIdentifier write SetIdentifier

Read Access
GetIdentifier

Write Access
SetIdentifier

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetIdentifier)

Name
Complete

Parent
ISepiIdentifierTestPseudoRoutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetIdentifier)


Sepi

Sepi
Previous (Complete)
Next (SetIdentifier)

Name
GetIdentifier

Parent
ISepiIdentifierTestPseudoRoutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetIdentifier : string

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (SetIdentifier)


Sepi

Sepi
Previous (GetIdentifier)
Next

Name
SetIdentifier

Parent
ISepiIdentifierTestPseudoRoutine

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetIdentifier ( const Value : string )

Parameters
Parameter | Description
Value : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIdentifier)
Next


Sepi

Sepi
Previous (ISepiIdentifierTestPseudoRoutine)
Next (TSepiCastPseudoRoutine)

Name
TSepiCastOrConvertPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiOneParamValueBackedPseudoRoutine

Visibility
PUBLIC

Description
Pseudo-routine de transtypage ou de conversion
Lorsque la conversion est possible, elle est utilisée. Sinon un transtypage
est utilisé.

Members
Fields
Field | Description
FDestType (-) | Type de destination

Methods
Method | Description
CompleteParams (#) | [@inheritDoc]
Create (+) | Crée une pseudo-routine de transtypage ou conversion
IsConversionAllowedAfterCast (-) | Teste si une conversion est autorisée après avoir fait un cast
IsConversionAllowedBeforeCast (-) | Teste si une conversion est autorisée avant de faire un cast

Properties
Property | Description
DestType (+) | Type de destination

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiIdentifierTestPseudoRoutine)
Next (TSepiCastPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
FDestType

Parent
TSepiCastOrConvertPseudoRoutine

Visibility
PRIVATE

Description
Type de destination

Source code
FDestType : TSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
DestType

Parent
TSepiCastOrConvertPseudoRoutine

Visibility
PUBLIC

Description
Type de destination

Source code
property DestType : TSepiType read FDestType

Read Access
FDestType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompleteParams

Parent
TSepiCastOrConvertPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompleteParams)
Next (IsConversionAllowedAfterCast)

Name
Create

Parent
TSepiCastOrConvertPseudoRoutine

Visibility
PUBLIC

Description
Crée une pseudo-routine de transtypage ou conversion

Source code
constructor Create ( ADestType : TSepiType )

Parameters
Parameter | Description
ADestType : TSepiType | Type de destination

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (IsConversionAllowedAfterCast)


Sepi

Sepi
Previous (Create)
Next (IsConversionAllowedBeforeCast)

Name
IsConversionAllowedAfterCast

Parent
TSepiCastOrConvertPseudoRoutine

Visibility
PRIVATE

Description
Teste si une conversion est autorisée après avoir fait un cast

Source code
function IsConversionAllowedAfterCast ( DestType , SourceType : TSepiType ; out MiddleType : TSepiType ) : Boolean

Parameters
Parameter | Description
DestType : TSepiType | Type destination
SourceType : TSepiType | Type source
MiddleType : TSepiType | En sortie : type transitoire pour la conversion

Return
Types | Description
BOOLEAN | True si la conversion est autorisée, False sinon

Sepi
Class Tree
Index
Previous (Create)
Next (IsConversionAllowedBeforeCast)


Sepi

Sepi
Previous (IsConversionAllowedAfterCast)
Next

Name
IsConversionAllowedBeforeCast

Parent
TSepiCastOrConvertPseudoRoutine

Visibility
PRIVATE

Description
Teste si une conversion est autorisée avant de faire un cast

Source code
function IsConversionAllowedBeforeCast ( DestType , SourceType : TSepiType ; out MiddleType : TSepiType ) : Boolean

Parameters
Parameter | Description
DestType : TSepiType | Type destination
SourceType : TSepiType | Type source
MiddleType : TSepiType | En sortie : type transitoire pour la conversion

Return
Types | Description
BOOLEAN | True si la conversion est autorisée, False sinon

Sepi
Class Tree
Index
Previous (IsConversionAllowedAfterCast)
Next


Sepi

Sepi
Previous (TSepiCastOrConvertPseudoRoutine)
Next (TSepiCopyPseudoRoutine)

Name
TSepiCastPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiOneParamValueBackedPseudoRoutine

Visibility
PUBLIC

Description
Pseudo-routine de transtypage

Members
Fields
Field | Description
FCastOperator (-) | Opération sous-jacente

Methods
Method | Description
CompleteParams (#) | [@inheritDoc]
Create (+) | Crée une pseudo-routine opérateur de transtypage
CreateChr (+) | Crée une pseudo-routine opérateur de transtypage Chr
CreateOrd (+) | Crée une pseudo-routine opérateur de transtypage Ord

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCastOrConvertPseudoRoutine)
Next (TSepiCopyPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
FCastOperator

Parent
TSepiCastPseudoRoutine

Visibility
PRIVATE

Description
Opération sous-jacente

Source code
FCastOperator : TSepiCastOperator

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompleteParams

Parent
TSepiCastPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompleteParams)
Next (CreateChr)

Name
Create

Parent
TSepiCastPseudoRoutine

Visibility
PUBLIC

Description
Crée une pseudo-routine opérateur de transtypage

Source code
constructor Create ( DestType : TSepiType )

Parameters
Parameter Description
DestType : TSepiType

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (CreateChr)


Sepi

Sepi
Previous (Create)
Next (CreateOrd)

Name
CreateChr

Parent
TSepiCastPseudoRoutine

Visibility
PUBLIC

Description
Crée une pseudo-routine opérateur de transtypage Chr

Source code
constructor CreateChr

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (CreateOrd)


Sepi

Sepi
Previous (CreateChr)
Next

Name
CreateOrd

Parent
TSepiCastPseudoRoutine

Visibility
PUBLIC

Description
Crée une pseudo-routine opérateur de transtypage Ord

Source code
constructor CreateOrd

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateChr)
Next


Sepi

Sepi
Previous (TSepiCastPseudoRoutine)
Next (TSepiDelphiLanguageRules)

Name
TSepiCopyPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiValueBackedPseudoRoutine

Visibility
PUBLIC

Description
Pseudo-routine Copy

Members
Methods
Method | Description
CompleteParams (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCastPseudoRoutine)
Next (TSepiDelphiLanguageRules)


Sepi

Sepi
Previous
Next

Name
CompleteParams

Parent
TSepiCopyPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiCopyPseudoRoutine)
Next (TSepiExecutableBackedPseudoRoutine)

Name
TSepiDelphiLanguageRules

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiLanguageRules

Visibility
PUBLIC

Description
Règles sémantiques du langage Delphi

Members
Methods
Method | Description
AddClassIntfMemberToExpression (#) | Ajoute un membre d'une classe ou d'une interface à une expression
AddComponentToExpression (#) | Ajoute un composant à une expression
AddPseudoRoutineToExpression (#) | Ajoute une pseudo-routine à une expression
ClassIntfMemberSelection (#) | Sélection de champ d'une valeur classe, meta-classe ou interface
FieldSelection (+) | [@inheritDoc]
ResolveIdent (+) | [@inheritDoc]
ResolveIdentInMethod (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCopyPseudoRoutine)
Next (TSepiExecutableBackedPseudoRoutine)


Sepi

Sepi
Previous
Next (AddComponentToExpression)

Name
AddClassIntfMemberToExpression

Parent
TSepiDelphiLanguageRules

Visibility
PROTECTED

Description
Ajoute un membre d'une classe ou d'une interface à une expression

Source code
function AddClassIntfMemberToExpression ( const Expression : ISepiExpression ; Context : TSepiComponent ; const BaseValue : ISepiReadableValue ; Member : TSepiMember ) : Boolean ; virtual

Parameters
Parameter | Description
Expression : ISepiExpression | Expression
Context : TSepiComponent
BaseValue : ISepiReadableValue | Valeur classe ou interface de base
Member : TSepiMember | Membre à ajouter

Return
Types | Description
BOOLEAN | True si réussi, False sinon

Sepi
Class Tree
Index
Previous
Next (AddComponentToExpression)


Sepi

Sepi
Previous (AddClassIntfMemberToExpression)
Next (AddPseudoRoutineToExpression)

Name
AddComponentToExpression

Parent
TSepiDelphiLanguageRules

Visibility
PROTECTED

Description
Ajoute un composant à une expression

Source code
procedure AddComponentToExpression ( const Expression : ISepiExpression ; Component : TSepiComponent ) ; virtual

Parameters
Parameter | Description
Expression : ISepiExpression | Expression
Component : TSepiComponent | Composant (peut être nil)

Sepi
Class Tree
Index
Previous (AddClassIntfMemberToExpression)
Next (AddPseudoRoutineToExpression)


Sepi

Sepi
Previous (AddComponentToExpression)
Next (ClassIntfMemberSelection)

Name
AddPseudoRoutineToExpression

Parent
TSepiDelphiLanguageRules

Visibility
PROTECTED

Description
Ajoute une pseudo-routine à une expression

Source code
function AddPseudoRoutineToExpression ( const Expression : ISepiExpression ; const Identifier : string ) : Boolean ; virtual

Parameters
Parameter | Description
Expression : ISepiExpression | Expression
Identifier : STRING | Identificateur de la pseudo-routine

Return
Types | Description
BOOLEAN | True si une pseudo-routine a été trouvée, False sinon

Sepi
Class Tree
Index
Previous (AddComponentToExpression)
Next (ClassIntfMemberSelection)


Sepi

Sepi
Previous (AddPseudoRoutineToExpression)
Next (FieldSelection)

Name
ClassIntfMemberSelection

Parent
TSepiDelphiLanguageRules

Visibility
PROTECTED

Description
Sélection de champ d'une valeur classe, meta-classe ou interface

Source code
function ClassIntfMemberSelection ( const Expression : ISepiExpression ; Context : TSepiComponent ; const BaseValue : ISepiReadableValue ; const FieldName : string ) : Boolean ; virtual

Parameters
Parameter | Description
Expression : ISepiExpression | Expression destination
Context : TSepiComponent | Contexte Sepi depuis lequel chercher
BaseValue : ISepiReadableValue | Valeur de base
FieldName : STRING | Nom du champ

Return
Types | Description
BOOLEAN | True si réussi, False sinon

Sepi
Class Tree
Index
Previous (AddPseudoRoutineToExpression)
Next (FieldSelection)


Sepi

Sepi
Previous (ClassIntfMemberSelection)
Next (ResolveIdent)

Name
FieldSelection

Parent
TSepiDelphiLanguageRules

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function FieldSelection ( Context : TSepiComponent ; const BaseExpression : ISepiExpression ; const FieldName : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Context : TSepiComponent | #Pas de TAG trouvé dans le code source#
BaseExpression : ISepiExpression | #Pas de TAG trouvé dans le code source#
FieldName : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ClassIntfMemberSelection)
Next (ResolveIdent)


Sepi

Sepi
Previous (FieldSelection)
Next (ResolveIdentInMethod)

Name
ResolveIdent

Parent
TSepiDelphiLanguageRules

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( Context : TSepiComponent ; const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Context : TSepiComponent | #Pas de TAG trouvé dans le code source#
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FieldSelection)
Next (ResolveIdentInMethod)


Sepi

Sepi
Previous (ResolveIdent)
Next

Name
ResolveIdentInMethod

Parent
TSepiDelphiLanguageRules

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdentInMethod ( Compiler : TSepiMethodCompiler ; const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ResolveIdent)
Next


Sepi

Sepi
Previous (TSepiDelphiLanguageRules)
Next (TSepiOneParamValueBackedPseudoRoutine)

Name
TSepiExecutableBackedPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiCustomWithParams,ISepiWantingParams,ISepiExecutable

Visibility
PUBLIC

Description
Pseudo-routine compilée en une expression exécutable

Members
Fields
Field | Description
FBackingExecutable (-) | Implémentation de la pseudo-routine

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileExecute (#) | [@inheritDoc]
QueryInterface (#) | [@inheritDoc]

Properties
Property | Description
BackingExecutable (#) | Implémentation de la pseudo-routine

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDelphiLanguageRules)
Next (TSepiOneParamValueBackedPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
FBackingExecutable

Parent
TSepiExecutableBackedPseudoRoutine

Visibility
PRIVATE

Description
Implémentation de la pseudo-routine

Source code
FBackingExecutable : ISepiExecutable

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
BackingExecutable

Parent
TSepiExecutableBackedPseudoRoutine

Visibility
PROTECTED

Description
Implémentation de la pseudo-routine

Source code
property BackingExecutable : ISepiExecutable read FBackingExecutable write FBackingExecutable

Read Access
FBackingExecutable

Write Access
FBackingExecutable

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileExecute)

Name
AttachToExpression

Parent
TSepiExecutableBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (AttachToExpression)
Next (QueryInterface)

Name
CompileExecute

Parent
TSepiExecutableBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (QueryInterface)


Sepi

Sepi
Previous (CompileExecute)
Next

Name
QueryInterface

Parent
TSepiExecutableBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileExecute)
Next


Sepi

Sepi
Previous (TSepiExecutableBackedPseudoRoutine)
Next (TSepiSetLengthPseudoRoutine)

Name
TSepiOneParamValueBackedPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiValueBackedPseudoRoutine

Visibility
PUBLIC

Description
Pseudo-routine avec exactement un paramètre, et compilée en une valeur

Members
Methods
Method | Description
CompleteParams (#) | [@inheritDoc]
GetOperand (-) | Opérande de la pseudo-routine

Properties
Property | Description
Operand (#) | Opérande de la pseudo-routine

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExecutableBackedPseudoRoutine)
Next (TSepiSetLengthPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
Operand

Parent
TSepiOneParamValueBackedPseudoRoutine

Visibility
PROTECTED

Description
Opérande de la pseudo-routine

Source code
property Operand : ISepiExpression read GetOperand

Read Access
GetOperand

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetOperand)

Name
CompleteParams

Parent
TSepiOneParamValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetOperand)


Sepi

Sepi
Previous (CompleteParams)
Next

Name
GetOperand

Parent
TSepiOneParamValueBackedPseudoRoutine

Visibility
PRIVATE

Description
Opérande de la pseudo-routine

Source code
function GetOperand : ISepiExpression

Parameters
Parameter Description

Return
Types | Description
ISepiExpression | Le premier paramètre s'il y en a, ou nil s'il n'y a aucun paramètre

Sepi
Class Tree
Index
Previous (CompleteParams)
Next


Sepi

Sepi
Previous (TSepiOneParamValueBackedPseudoRoutine)
Next (TSepiSpecialJumpPseudoRoutine)

Name
TSepiSetLengthPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiExecutableBackedPseudoRoutine

Visibility
PUBLIC

Description
Pseudo-routine SetLength

Members
Methods
Method | Description
CompleteParams (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOneParamValueBackedPseudoRoutine)
Next (TSepiSpecialJumpPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
CompleteParams

Parent
TSepiSetLengthPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiSetLengthPseudoRoutine)
Next (TSepiTypeOperationPseudoRoutine)

Name
TSepiSpecialJumpPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiCustomExpressionPart,ISepiExecutable

Visibility
PUBLIC

Description
Pseudo-routine de jump spécial (Continue, Break ou Exit)

Members
Fields
Field | Description
FKind (-) | Type de saut spécial

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileExecute (#) | [@inheritDoc]
Create (+) | Crée la pseudo-routine de jump spécial

Properties
Property | Description
Kind (+) | Type de saut spécial

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSetLengthPseudoRoutine)
Next (TSepiTypeOperationPseudoRoutine)


Sepi

Sepi
Previous
Next

Name
FKind

Parent
TSepiSpecialJumpPseudoRoutine

Visibility
PRIVATE

Description
Type de saut spécial

Source code
FKind : TSepiSpecialJumpKind

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Kind

Parent
TSepiSpecialJumpPseudoRoutine

Visibility
PUBLIC

Description
Type de saut spécial

Source code
property Kind : TSepiSpecialJumpKind read FKind

Read Access
FKind

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileExecute)

Name
AttachToExpression

Parent
TSepiSpecialJumpPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (AttachToExpression)
Next (Create)

Name
CompileExecute

Parent
TSepiSpecialJumpPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (Create)


Sepi

Sepi
Previous (CompileExecute)
Next

Name
Create

Parent
TSepiSpecialJumpPseudoRoutine

Visibility
PUBLIC

Description
Crée la pseudo-routine de jump spécial

Source code
constructor Create ( AKind : TSepiSpecialJumpKind )

Parameters
Parameter | Description
AKind : TSepiSpecialJumpKind | Type de saut spécial

Sepi
Class Tree
Index
Previous (CompileExecute)
Next


Sepi

Sepi
Previous (TSepiSpecialJumpPseudoRoutine)
Next (TSepiValueBackedPseudoRoutine)

Name
TSepiTypeOperationPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiOneParamValueBackedPseudoRoutine

Visibility
PUBLIC

Description
Pseudo-routine d'opération sur un type

Members
Fields
Field | Description
FKind (-) | Type d'opération
FOptions (-) | Options

Methods
Method | Description
CompleteArrayBound (#) | Complète une opération sur un tableau
CompleteParams (#) | [@inheritDoc]
CompleteStrOperation (#) | Complète une opération sur une chaîne de caractères
CompleteTypeOperation (#) | Complète une opération sur un type
Create (+) | Crée une pseudo-routine opération sur un type
MakeTypeExpression (#) | Construit une expression pour un type

Properties
Property | Description
Kind (+) | Type d'opération
Options (+) | Options

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSpecialJumpPseudoRoutine)
Next (TSepiValueBackedPseudoRoutine)


Sepi

Sepi
Previous
Next (FOptions)

Name
FKind

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PRIVATE

Description
Type d'opération

Source code
FKind : TSepiTypeOperation

Sepi
Class Tree
Index
Previous
Next (FOptions)


Sepi

Sepi
Previous (FKind)
Next

Name
FOptions

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PRIVATE

Description
Options

Source code
FOptions : TSepiTypeOperationOptions

Sepi
Class Tree
Index
Previous (FKind)
Next


Sepi

Sepi
Previous
Next (Options)

Name
Kind

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PUBLIC

Description
Type d'opération

Source code
property Kind : TSepiTypeOperation read FKind

Read Access
FKind

Sepi
Class Tree
Index
Previous
Next (Options)


Sepi

Sepi
Previous (Kind)
Next

Name
Options

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PUBLIC

Description
Options

Source code
property Options : TSepiTypeOperationOptions read FOptions

Read Access
FOptions

Sepi
Class Tree
Index
Previous (Kind)
Next


Sepi

Sepi
Previous
Next (CompleteParams)

Name
CompleteArrayBound

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PROTECTED

Description
Complète une opération sur un tableau

Source code
procedure CompleteArrayBound ( const ArrayValue : ISepiReadableValue ) ; virtual

Parameters
Parameter | Description
ArrayValue : ISepiReadableValue | Valeur tableau

Sepi
Class Tree
Index
Previous
Next (CompleteParams)


Sepi

Sepi
Previous (CompleteArrayBound)
Next (CompleteStrOperation)

Name
CompleteParams

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompleteArrayBound)
Next (CompleteStrOperation)


Sepi

Sepi
Previous (CompleteParams)
Next (CompleteTypeOperation)

Name
CompleteStrOperation

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PROTECTED

Description
Complète une opération sur une chaîne de caractères

Source code
procedure CompleteStrOperation ( const StrValue : ISepiReadableValue ) ; virtual

Parameters
Parameter | Description
StrValue : ISepiReadableValue | Valeur chaîne

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (CompleteTypeOperation)


Sepi

Sepi
Previous (CompleteStrOperation)
Next (Create)

Name
CompleteTypeOperation

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PROTECTED

Description
Complète une opération sur un type

Source code
procedure CompleteTypeOperation ( const TypeExpression : ISepiTypeExpression ) ; virtual

Parameters
Parameter | Description
TypeExpression : ISepiTypeExpression | Expression de type

Sepi
Class Tree
Index
Previous (CompleteStrOperation)
Next (Create)


Sepi

Sepi
Previous (CompleteTypeOperation)
Next (MakeTypeExpression)

Name
Create

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PUBLIC

Description
Crée une pseudo-routine opération sur un type

Source code
constructor Create ( AKind : TSepiTypeOperation ; AOptions : TSepiTypeOperationOptions = tooDelphiOptions )

Parameters
Parameter Description
AKind : TSepiTypeOperation
AOptions : TSepiTypeOperationOptions

Sepi
Class Tree
Index
Previous (CompleteTypeOperation)
Next (MakeTypeExpression)


Sepi

Sepi
Previous (Create)
Next

Name
MakeTypeExpression

Parent
TSepiTypeOperationPseudoRoutine

Visibility
PROTECTED

Description
Construit une expression pour un type

Source code
function MakeTypeExpression ( SepiType : TSepiType ) : ISepiTypeExpression

Parameters
Parameter | Description
SepiType : TSepiType | Type

Return
Types | Description
ISepiTypeExpression | Expression représentant le type

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiTypeOperationPseudoRoutine)
Next

Name
TSepiValueBackedPseudoRoutine

Parent
SepiDelphiLikeCompilerUtils

Class Hierarchy
TSepiCustomWithParams,ISepiWantingParams,ISepiValue,ISepiReadableValue,ISepiWritableValue,ISepiAddressableValue

Visibility
PUBLIC

Description
Pseudo-routine compilée en une valeur

Members
Fields
Field | Description
FBackingValue (-) | Valeur implémentant la pseudo-routine

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileLoadAddress (#) | [@inheritDoc]
CompileRead (#) | [@inheritDoc]
CompileWrite (#) | [@inheritDoc]
GetAddressType (#) | [@inheritDoc]
GetConstValuePtr (#) | [@inheritDoc]
GetIsConstant (#) | [@inheritDoc]
GetValueType (#) | [@inheritDoc]
QueryInterface (#) | [@inheritDoc]

Properties
Property | Description
BackingValue (#) | Valeur implémentant la pseudo-routine

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeOperationPseudoRoutine)
Next


Sepi

Sepi
Previous
Next

Name
FBackingValue

Parent
TSepiValueBackedPseudoRoutine

Visibility
PRIVATE

Description
Valeur implémentant la pseudo-routine

Source code
FBackingValue : ISepiValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
BackingValue

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
Valeur implémentant la pseudo-routine

Source code
property BackingValue : ISepiValue read FBackingValue write FBackingValue

Read Access
FBackingValue

Write Access
FBackingValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileLoadAddress)

Name
AttachToExpression

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileLoadAddress)


Sepi

Sepi
Previous (AttachToExpression)
Next (CompileRead)

Name
CompileLoadAddress

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileLoadAddress ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CompileRead)


Sepi

Sepi
Previous (CompileLoadAddress)
Next (CompileWrite)

Name
CompileRead

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileLoadAddress)
Next (CompileWrite)


Sepi

Sepi
Previous (CompileRead)
Next (GetAddressType)

Name
CompileWrite

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileWrite ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Source : ISepiReadableValue )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Source : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileRead)
Next (GetAddressType)


Sepi

Sepi
Previous (CompileWrite)
Next (GetConstValuePtr)

Name
GetAddressType

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAddressType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileWrite)
Next (GetConstValuePtr)


Sepi

Sepi
Previous (GetAddressType)
Next (GetIsConstant)

Name
GetConstValuePtr

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAddressType)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetConstValuePtr)
Next (GetValueType)

Name
GetIsConstant

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next (GetValueType)


Sepi

Sepi
Previous (GetIsConstant)
Next (QueryInterface)

Name
GetValueType

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (QueryInterface)


Sepi

Sepi
Previous (GetValueType)
Next

Name
QueryInterface

Parent
TSepiValueBackedPseudoRoutine

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetValueType)
Next


Sepi

Sepi
Previous
Next (TSepiTypeOperationOption)

Name
TSepiSpecialJumpKind

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Type de saut spécial existant en Delphi

Source code
TSepiSpecialJumpKind = ( sjkContinue , sjkBreak , sjkExit ) ;

Sepi
Class Tree
Index
Previous
Next (TSepiTypeOperationOption)


Sepi

Sepi
Previous (TSepiSpecialJumpKind)
Next (TSepiTypeOperationOptions)

Name
TSepiTypeOperationOption

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Option d'une opération sur un type
- tooTypeOperand : accepte un opérande qui est un type
- tooValueTypeOperand : accepte un opérande valeur pour en extraire le type
- tooStrValueOperand : accepte un opérande chaîne
- tooArrayValueOperand : accepte un opérande tableau
- tooNilIfNoTypeInfo : pour TypeInfo, accepte un type sans RTTI -> nil

Source code
TSepiTypeOperationOption = ( tooTypeOperand , tooValueTypeOperand , tooStrValueOperand , tooArrayValueOperand , tooNilIfNoTypeInfo ) ;

Sepi
Class Tree
Index
Previous (TSepiSpecialJumpKind)
Next (TSepiTypeOperationOptions)


Sepi

Sepi
Previous (TSepiTypeOperationOption)
Next

Name
TSepiTypeOperationOptions

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Options d'une opération sur un type

Source code
TSepiTypeOperationOptions = set of TSepiTypeOperationOption ;

Sepi
Class Tree
Index
Previous (TSepiTypeOperationOption)
Next


Sepi

Sepi
Previous
Next (CopyName)

Name
ChrName

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Nom de la pseudo-routine Chr

Source code
ChrName = 'Chr'

Sepi
Class Tree
Index
Previous
Next (CopyName)


Sepi

Sepi
Previous (ChrName)
Next (OrdName)

Name
CopyName

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Nom de la pseudo-routine Copy

Source code
CopyName = 'Copy'

Sepi
Class Tree
Index
Previous (ChrName)
Next (OrdName)


Sepi

Sepi
Previous (CopyName)
Next (SetLengthName)

Name
OrdName

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Nom de la pseudo-routine Ord

Source code
OrdName = 'Ord'

Sepi
Class Tree
Index
Previous (CopyName)
Next (SetLengthName)


Sepi

Sepi
Previous (OrdName)
Next (SpecialJumpNames)

Name
SetLengthName

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Nom de la pseudo-routine SetLength

Source code
SetLengthName = 'SetLength'

Sepi
Class Tree
Index
Previous (OrdName)
Next (SpecialJumpNames)


Sepi

Sepi
Previous (SetLengthName)
Next (tooDelphiOptions)

Name
SpecialJumpNames

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Nom des pseudo-routines de jump spécial

Source code
SpecialJumpNames : array [ TSepiSpecialJumpKind ] of string = ( 'Continue' , 'Break' , 'Exit' )

Sepi
Class Tree
Index
Previous (SetLengthName)
Next (tooDelphiOptions)


Sepi

Sepi
Previous (SpecialJumpNames)
Next (TypeOperationNames)

Name
tooDelphiOptions

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Options des opérations sur les types utilisées en Delphi

Source code
tooDelphiOptions = [ tooTypeOperand .. tooArrayValueOperand ]

Sepi
Class Tree
Index
Previous (SpecialJumpNames)
Next (TypeOperationNames)


Sepi

Sepi
Previous (tooDelphiOptions)
Next

Name
TypeOperationNames

Parent
SepiDelphiLikeCompilerUtils

Visibility
PUBLIC

Description
Noms des opérations sur des types

Source code
TypeOperationNames : array [ TSepiTypeOperation ] of string = ( 'SizeOf' , 'TypeInfo' , 'Low' , 'High' , 'Length' )

Sepi
Class Tree
Index
Previous (tooDelphiOptions)
Next


Sepi

Sepi
Previous (SepiDelphiLikeCompilerUtils)
Next (SepiDisassembler)

Name
SepiDelphiParser

Parent
Sepi

Description
#Pas de TAG trouvé dans le code source#

Author
#Pas de TAG trouvé dans le code source#

Version
#Pas de TAG trouvé dans le code source#

Types
Type Description

Constants
Constant | Description
ChoiceCount (+) | #No TAG found in source code#
FirstNonTerminal (+) | #No TAG found in source code#
LastNonTerminal (+) | #No TAG found in source code#
ntAbstractMarker (+) | #No TAG found in source code#
ntAddressOfOp (+) | #No TAG found in source code#
ntAnsiStringCodePage (+) | #No TAG found in source code#
ntArithmeticLogicOp (+) | #No TAG found in source code#
ntArithmeticLogicOpNoEquals (+) | #No TAG found in source code#
ntArrayDesc (+) | #No TAG found in source code#
ntArrayDims (+) | #No TAG found in source code#
ntArrayIndices (+) | #No TAG found in source code#
ntArrayInitialization (+) | #No TAG found in source code#
ntArrayInitializationExpression (+) | #No TAG found in source code#
ntArrayRange (+) | #No TAG found in source code#
ntAsOperation (+) | #No TAG found in source code#
ntAssignmentOp (+) | #No TAG found in source code#
ntAttribute (+) | #No TAG found in source code#
ntAttributeParam (+) | #No TAG found in source code#
ntAttributeParams (+) | #No TAG found in source code#
ntAttributes (+) | #No TAG found in source code#
ntAttrParamPart (+) | #No TAG found in source code#
ntBeginEndBlock (+) | #No TAG found in source code#
ntBinaryOp (+) | #No TAG found in source code#
ntBinaryOpNoEquals (+) | #No TAG found in source code#
ntCallingConvention (+) | #No TAG found in source code#
ntCaseLabels (+) | #No TAG found in source code#
ntCaseOfClause (+) | #No TAG found in source code#
ntCaseOfElseClause (+) | #No TAG found in source code#
ntCaseOfInstruction (+) | #No TAG found in source code#
ntCaseOfSetValue (+) | #No TAG found in source code#
ntClassClassMethodProp (+) | #No TAG found in source code#
ntClassContents (+) | #No TAG found in source code#
ntClassDesc (+) | #No TAG found in source code#
ntClassExDesc (+) | #No TAG found in source code#
ntClassHeritage (+) | #No TAG found in source code#
ntClassMemberList (+) | #No TAG found in source code#
ntClassMemberLists (+) | #No TAG found in source code#
ntClassMethodDecl (+) | #No TAG found in source code#
ntClassMethodImplKind (+) | #No TAG found in source code#
ntClassMethodProp (+) | #No TAG found in source code#
ntCloneDesc (+) | #No TAG found in source code#
ntCommaIdentDeclList (+) | #No TAG found in source code#
ntCommaIdentList (+) | #No TAG found in source code#
ntComplexParamType (+) | #No TAG found in source code#
ntConstDecl (+) | #No TAG found in source code#
ntConstExpression (+) | #No TAG found in source code#
ntConstExpressionNoEquals (+) | #No TAG found in source code#
ntConstKeyWord (+) | #No TAG found in source code#
ntConstOrType (+) | #No TAG found in source code#
ntConstOrTypeNoEquals (+) | #No TAG found in source code#
ntConstSection (+) | #No TAG found in source code#
ntDefaultMarker (+) | #No TAG found in source code#
ntDereferenceOp (+) | #No TAG found in source code#
ntDispInterfaceDesc (+) | #No TAG found in source code#
ntDispInterfaceHeritage (+) | #No TAG found in source code#
ntElseBranch (+) | #No TAG found in source code#
ntEnumDesc (+) | #No TAG found in source code#
ntEventDesc (+) | #No TAG found in source code#
ntEventIsOfObject (+) | #No TAG found in source code#
ntEventModifiers (+) | #No TAG found in source code#
ntExceptClause (+) | #No TAG found in source code#
ntExceptionVarAndType (+) | #No TAG found in source code#
ntExecutableExpression (+) | #No TAG found in source code#
ntExpression (+) | #No TAG found in source code#
ntExpressionInstruction (+) | #No TAG found in source code#
ntExpressionNoEquals (+) | #No TAG found in source code#
ntExprList (+) | #No TAG found in source code#
ntFakeEnumDesc (+) | #No TAG found in source code#
ntFakeEnumValue (+) | #No TAG found in source code#
ntField (+) | #No TAG found in source code#
ntFieldSelection (+) | #No TAG found in source code#
ntFinallyClause (+) | #No TAG found in source code#
ntFloatConst (+) | #No TAG found in source code#
ntForControlVar (+) | #No TAG found in source code#
ntForDownTo (+) | #No TAG found in source code#
ntForInstruction (+) | #No TAG found in source code#
ntForTo (+) | #No TAG found in source code#
ntForToDownTo (+) | #No TAG found in source code#
ntForwardMarker (+) | #No TAG found in source code#
ntForwardOrMethodBody (+) | #No TAG found in source code#
ntGlobalVar (+) | #No TAG found in source code#
ntGUIDInitialization (+) | #No TAG found in source code#
ntGUIDInitializationExpression (+) | #No TAG found in source code#
ntIdentifier (+) | #No TAG found in source code#
ntIdentifierDecl (+) | #No TAG found in source code#
ntIdentifierSingleValue (+) | #No TAG found in source code#
ntIdentTestParam (+) | #No TAG found in source code#
ntIfThenElseInstruction (+) | #No TAG found in source code#
ntIgnoredMethodModifier (+) | #No TAG found in source code#
ntIgnoredPropertyModifier (+) | #No TAG found in source code#
ntIgnoredPropInfo (+) | #No TAG found in source code#
ntIgnoredRoutineModifier (+) | #No TAG found in source code#
ntImplementation (+) | #No TAG found in source code#
ntImplSection (+) | #No TAG found in source code#
ntInheritedExpression (+) | #No TAG found in source code#
ntInheritedSingleValue (+) | #No TAG found in source code#
ntInitFinit (+) | #No TAG found in source code#
ntInitializationExpression (+) | #No TAG found in source code#
ntInMethodSection (+) | #No TAG found in source code#
ntInnerConstDecl (+) | #No TAG found in source code#
ntInnerGlobalVar (+) | #No TAG found in source code#
ntInnerParameters (+) | #No TAG found in source code#
ntInnerWith (+) | #No TAG found in source code#
ntInOperation (+) | #No TAG found in source code#
ntInPreProcessorExpression (+) | #No TAG found in source code#
ntInstruction (+) | #No TAG found in source code#
ntInstructionList (+) | #No TAG found in source code#
ntIntegerConst (+) | #No TAG found in source code#
ntInterface (+) | #No TAG found in source code#
ntInterfaceDesc (+) | #No TAG found in source code#
ntInterfaceGUID (+) | #No TAG found in source code#
ntInterfaceHeritage (+) | #No TAG found in source code#
ntInterfaceMemberList (+) | #No TAG found in source code#
ntIntfMethodProp (+) | #No TAG found in source code#
ntIntfMethodRedirector (+) | #No TAG found in source code#
ntIntfMethodRedirKind (+) | #No TAG found in source code#
ntIntfSection (+) | #No TAG found in source code#
ntIsOperation (+) | #No TAG found in source code#
ntLocalVar (+) | #No TAG found in source code#
ntLocalVarSection (+) | #No TAG found in source code#
ntMethodBody (+) | #No TAG found in source code#
ntMethodDecl (+) | #No TAG found in source code#
ntMethodImpl (+) | #No TAG found in source code#
ntMethodImplHeader (+) | #No TAG found in source code#
ntMethodImplKind (+) | #No TAG found in source code#
ntMethodKind (+) | #No TAG found in source code#
ntMethodLinkKind (+) | #No TAG found in source code#
ntMethodModifier (+) | #No TAG found in source code#
ntMethodNameDeclaration (+) | #No TAG found in source code#
ntMethodParamList (+) | #No TAG found in source code#
ntMethodSignature (+) | #No TAG found in source code#
ntMultiOn (+) | #No TAG found in source code#
ntMultiOnElseClause (+) | #No TAG found in source code#
ntNextExceptClause (+) | #No TAG found in source code#
ntNextExpr (+) | #No TAG found in source code#
ntNextRecordCaseContents (+) | #No TAG found in source code#
ntNextRecordCaseContentsEx (+) | #No TAG found in source code#
ntNextTryInstruction (+) | #No TAG found in source code#
ntNilValue (+) | #No TAG found in source code#
ntNoInstruction (+) | #No TAG found in source code#
ntOnClause (+) | #No TAG found in source code#
ntOtherInitialization (+) | #No TAG found in source code#
ntOtherInitializationExpression (+) | #No TAG found in source code#
ntOverloadMarker (+) | #No TAG found in source code#
ntPackedArrayDesc (+) | #No TAG found in source code#
ntPackedDesc (+) | #No TAG found in source code#
ntPackedRecordDesc (+) | #No TAG found in source code#
ntParam (+) | #No TAG found in source code#
ntParamArrayType (+) | #No TAG found in source code#
ntParamDefault (+) | #No TAG found in source code#
ntParameter (+) | #No TAG found in source code#
ntParameters (+) | #No TAG found in source code#
ntParamIsArray (+) | #No TAG found in source code#
ntParamKind (+) | #No TAG found in source code#
ntParamList (+) | #No TAG found in source code#
ntParamName (+) | #No TAG found in source code#
ntParamNameList (+) | #No TAG found in source code#
ntParamType (+) | #No TAG found in source code#
ntParamTypeAndDefault (+) | #No TAG found in source code#
ntParenthesizedExpr (+) | #No TAG found in source code#
ntPointerDesc (+) | #No TAG found in source code#
ntPriv0 (+) | #No TAG found in source code#
ntPriv1 (+) | #No TAG found in source code#
ntPriv10 (+) | #No TAG found in source code#
ntPriv11 (+) | #No TAG found in source code#
ntPriv12 (+) | #No TAG found in source code#
ntPriv13 (+) | #No TAG found in source code#
ntPriv14 (+) | #No TAG found in source code#
ntPriv15 (+) | #No TAG found in source code#
ntPriv16 (+) | #No TAG found in source code#
ntPriv17 (+) | #No TAG found in source code#
ntPriv18 (+) | #No TAG found in source code#
ntPriv19 (+) | #No TAG found in source code#
ntPriv2 (+) | #No TAG found in source code#
ntPriv20 (+) | #No TAG found in source code#
ntPriv21 (+) | #No TAG found in source code#
ntPriv22 (+) | #No TAG found in source code#
ntPriv23 (+) | #No TAG found in source code#
ntPriv24 (+) | #No TAG found in source code#
ntPriv25 (+) | #No TAG found in source code#
ntPriv26 (+) | #No TAG found in source code#
ntPriv27 (+) | #No TAG found in source code#
ntPriv28 (+) | #No TAG found in source code#
ntPriv29 (+) | #No TAG found in source code#
ntPriv3 (+) | #No TAG found in source code#
ntPriv30 (+) | #No TAG found in source code#
ntPriv31 (+) | #No TAG found in source code#
ntPriv32 (+) | #No TAG found in source code#
ntPriv33 (+) | #No TAG found in source code#
ntPriv34 (+) | #No TAG found in source code#
ntPriv35 (+) | #No TAG found in source code#
ntPriv36 (+) | #No TAG found in source code#
ntPriv37 (+) | #No TAG found in source code#
ntPriv38 (+) | #No TAG found in source code#
ntPriv39 (+) | #No TAG found in source code#
ntPriv4 (+) | #No TAG found in source code#
ntPriv40 (+) | #No TAG found in source code#
ntPriv41 (+) | #No TAG found in source code#
ntPriv42 (+) | #No TAG found in source code#
ntPriv43 (+) | #No TAG found in source code#
ntPriv44 (+) | #No TAG found in source code#
ntPriv45 (+) | #No TAG found in source code#
ntPriv46 (+) | #No TAG found in source code#
ntPriv47 (+) | #No TAG found in source code#
ntPriv48 (+) | #No TAG found in source code#
ntPriv49 (+) | #No TAG found in source code#
ntPriv5 (+) | #No TAG found in source code#
ntPriv50 (+) | #No TAG found in source code#
ntPriv51 (+) | #No TAG found in source code#
ntPriv52 (+) | #No TAG found in source code#
ntPriv53 (+) | #No TAG found in source code#
ntPriv54 (+) | #No TAG found in source code#
ntPriv55 (+) | #No TAG found in source code#
ntPriv56 (+) | #No TAG found in source code#
ntPriv57 (+) | #No TAG found in source code#
ntPriv58 (+) | #No TAG found in source code#
ntPriv59 (+) | #No TAG found in source code#
ntPriv6 (+) | #No TAG found in source code#
ntPriv60 (+) | #No TAG found in source code#
ntPriv61 (+) | #No TAG found in source code#
ntPriv62 (+) | #No TAG found in source code#
ntPriv63 (+) | #No TAG found in source code#
ntPriv64 (+) | #No TAG found in source code#
ntPriv65 (+) | #No TAG found in source code#
ntPriv66 (+) | #No TAG found in source code#
ntPriv67 (+) | #No TAG found in source code#
ntPriv68 (+) | #No TAG found in source code#
ntPriv69 (+) | #No TAG found in source code#
ntPriv7 (+) | #No TAG found in source code#
ntPriv70 (+) | #No TAG found in source code#
ntPriv71 (+) | #No TAG found in source code#
ntPriv8 (+) | #No TAG found in source code#
ntPriv9 (+) | #No TAG found in source code#
ntPropDefaultValue (+) | #No TAG found in source code#
ntPropertyDecl (+) | #No TAG found in source code#
ntPropertyKind (+) | #No TAG found in source code#
ntPropertyModifier (+) | #No TAG found in source code#
ntPropertyNextDecl (+) | #No TAG found in source code#
ntPropertySignature (+) | #No TAG found in source code#
ntPropIndex (+) | #No TAG found in source code#
ntPropInfo (+) | #No TAG found in source code#
ntPropReadAccess (+) | #No TAG found in source code#
ntPropStorage (+) | #No TAG found in source code#
ntPropType (+) | #No TAG found in source code#
ntPropWriteAccess (+) | #No TAG found in source code#
ntPureInheritedExpression (+) | #No TAG found in source code#
ntQualifiedIdent (+) | #No TAG found in source code#
ntRaiseInstruction (+) | #No TAG found in source code#
ntRangeDesc (+) | #No TAG found in source code#
ntRangeOrEnumDesc (+) | #No TAG found in source code#
ntRecordCase (+) | #No TAG found in source code#
ntRecordCaseBlock (+) | #No TAG found in source code#
ntRecordCaseContents (+) | #No TAG found in source code#
ntRecordCaseField (+) | #No TAG found in source code#
ntRecordCaseHeader (+) | #No TAG found in source code#
ntRecordContents (+) | #No TAG found in source code#
ntRecordDesc (+) | #No TAG found in source code#
ntRecordField (+) | #No TAG found in source code#
ntRecordInitEx (+) | #No TAG found in source code#
ntRecordInitialization (+) | #No TAG found in source code#
ntRecordInitializationExpression (+) | #No TAG found in source code#
ntRedefineMarker (+) | #No TAG found in source code#
ntRepeatInstruction (+) | #No TAG found in source code#
ntReturnType (+) | #No TAG found in source code#
ntRoutineDecl (+) | #No TAG found in source code#
ntRoutineKind (+) | #No TAG found in source code#
ntRoutineModifier (+) | #No TAG found in source code#
ntSetDesc (+) | #No TAG found in source code#
ntSetOrOpenArrayBuilder (+) | #No TAG found in source code#
ntSetOrOpenArrayRange (+) | #No TAG found in source code#
ntSetRange (+) | #No TAG found in source code#
ntSetValue (+) | #No TAG found in source code#
ntSingleExpr (+) | #No TAG found in source code#
ntSingleValue (+) | #No TAG found in source code#
ntSource (+) | #No TAG found in source code#
ntStaticMarker (+) | #No TAG found in source code#
ntStrictVisibility (+) | #No TAG found in source code#
ntStringConst (+) | #No TAG found in source code#
ntStringDesc (+) | #No TAG found in source code#
ntTryInstruction (+) | #No TAG found in source code#
ntTypeDecl (+) | #No TAG found in source code#
ntTypeDesc (+) | #No TAG found in source code#
ntTypeModifier (+) | #No TAG found in source code#
ntTypeModifiers (+) | #No TAG found in source code#
ntTypeName (+) | #No TAG found in source code#
ntTypeSection (+) | #No TAG found in source code#
ntUnaryOp (+) | #No TAG found in source code#
ntUnaryOpExpr (+) | #No TAG found in source code#
ntUnaryOpModifier (+) | #No TAG found in source code#
ntUnitFinalization (+) | #No TAG found in source code#
ntUnitInitialization (+) | #No TAG found in source code#
ntUsesSection (+) | #No TAG found in source code#
ntVarSection (+) | #No TAG found in source code#
ntVisibility (+) | #No TAG found in source code#
ntWhileInstruction (+) | #No TAG found in source code#
ntWithEx (+) | #No TAG found in source code#
ntWithInstruction (+) | #No TAG found in source code#

Variables
Variable | Description
NonTerminalClasses (+) | #No TAG found in source code#

Methods
Method Description

Classes
Class | Description
TSepiDelphiParser (+) | Analyseur syntaxique

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiDelphiLikeCompilerUtils)
Next (SepiDisassembler)


Sepi

Sepi
Previous
Next

Name
TSepiDelphiParser

Parent
SepiDelphiParser

Class Hierarchy
TSepiCustomLL1Parser

Visibility
PUBLIC

Description
Analyseur syntaxique

Members
Methods
Method | Description
GetExpectedString (#) | [@inheritDoc]
GetNonTerminalClass (#) | [@inheritDoc]
GetParsingTable (#) | [@inheritDoc]
InitPushChoiceProcs (#) | [@inheritDoc]
IsNonTerminal (#) | [@inheritDoc]
IsTerminal (#) | [@inheritDoc]
PushChoice1 (-) | #No TAG found in source code#
PushChoice10 (-) | #No TAG found in source code#
PushChoice100 (-) | #No TAG found in source code#
PushChoice101 (-) | #No TAG found in source code#
PushChoice102 (-) | #No TAG found in source code#
PushChoice103 (-) | #No TAG found in source code#
PushChoice104 (-) | #No TAG found in source code#
PushChoice105 (-) | #No TAG found in source code#
PushChoice106 (-) | #No TAG found in source code#
PushChoice107 (-) | #No TAG found in source code#
PushChoice108 (-) | #No TAG found in source code#
PushChoice109 (-) | #No TAG found in source code#
PushChoice11 (-) | #No TAG found in source code#
PushChoice110 (-) | #No TAG found in source code#
PushChoice111 (-) | #No TAG found in source code#
PushChoice112 (-) | #No TAG found in source code#
PushChoice113 (-) | #No TAG found in source code#
PushChoice114 (-) | #No TAG found in source code#
PushChoice115 (-) | #No TAG found in source code#
PushChoice116 (-) | #No TAG found in source code#
PushChoice117 (-) | #No TAG found in source code#
PushChoice118 (-) | #No TAG found in source code#
PushChoice119 (-) | #No TAG found in source code#
PushChoice12 (-) | #No TAG found in source code#
PushChoice120 (-) | #No TAG found in source code#
PushChoice121 (-) | #No TAG found in source code#
PushChoice122 (-) | #No TAG found in source code#
PushChoice123 (-) | #No TAG found in source code#
PushChoice124 (-) | #No TAG found in source code#
PushChoice125 (-) | #No TAG found in source code#
PushChoice126 (-) | #No TAG found in source code#
PushChoice127 (-) | #No TAG found in source code#
PushChoice128 (-) | #No TAG found in source code#
PushChoice129 (-) | #No TAG found in source code#
PushChoice13 (-) | #No TAG found in source code#
PushChoice130 (-) | #No TAG found in source code#
PushChoice131 (-) | #No TAG found in source code#
PushChoice132 (-) | #No TAG found in source code#
PushChoice133 (-) | #No TAG found in source code#
PushChoice134 (-) | #No TAG found in source code#
PushChoice135 (-) | #No TAG found in source code#
PushChoice136 (-) | #No TAG found in source code#
PushChoice137 (-) | #No TAG found in source code#
PushChoice138 (-) | #No TAG found in source code#
PushChoice139 (-) | #No TAG found in source code#
PushChoice14 (-) | #No TAG found in source code#
PushChoice140 (-) | #No TAG found in source code#
PushChoice141 (-) | #No TAG found in source code#
PushChoice142 (-) | #No TAG found in source code#
PushChoice143 (-) | #No TAG found in source code#
PushChoice144 (-) | #No TAG found in source code#
PushChoice145 (-) | #No TAG found in source code#
PushChoice146 (-) | #No TAG found in source code#
PushChoice147 (-) | #No TAG found in source code#
PushChoice148 (-) | #No TAG found in source code#
PushChoice149 (-) | #No TAG found in source code#
PushChoice15 (-) | #No TAG found in source code#
PushChoice150 (-) | #No TAG found in source code#
PushChoice151 (-) | #No TAG found in source code#
PushChoice152 (-) | #No TAG found in source code#
PushChoice153 (-) | #No TAG found in source code#
PushChoice154 (-) | #No TAG found in source code#
PushChoice155 (-) | #No TAG found in source code#
PushChoice156 (-) | #No TAG found in source code#
PushChoice157 (-) | #No TAG found in source code#
PushChoice158 (-) | #No TAG found in source code#
PushChoice159 (-) | #No TAG found in source code#
PushChoice16 (-) | #No TAG found in source code#
PushChoice160 (-) | #No TAG found in source code#
PushChoice161 (-) | #No TAG found in source code#
PushChoice162 (-) | #No TAG found in source code#
PushChoice163 (-) | #No TAG found in source code#
PushChoice164 (-) | #No TAG found in source code#
PushChoice165 (-) | #No TAG found in source code#
PushChoice166 (-) | #No TAG found in source code#
PushChoice167 (-) | #No TAG found in source code#
PushChoice168 (-) | #No TAG found in source code#
PushChoice169 (-) | #No TAG found in source code#
PushChoice17 (-) | #No TAG found in source code#
PushChoice170 (-) | #No TAG found in source code#
PushChoice171 (-) | #No TAG found in source code#
PushChoice172 (-) | #No TAG found in source code#
PushChoice173 (-) | #No TAG found in source code#
PushChoice174 (-) | #No TAG found in source code#
PushChoice175 (-) | #No TAG found in source code#
PushChoice176 (-) | #No TAG found in source code#
PushChoice177 (-) | #No TAG found in source code#
PushChoice178 (-) | #No TAG found in source code#
PushChoice179 (-) | #No TAG found in source code#
PushChoice18 (-) | #No TAG found in source code#
PushChoice180 (-) | #No TAG found in source code#
PushChoice181 (-) | #No TAG found in source code#
PushChoice182 (-) | #No TAG found in source code#
PushChoice183 (-) | #No TAG found in source code#
PushChoice184 (-) | #No TAG found in source code#
PushChoice185 (-) | #No TAG found in source code#
PushChoice186 (-) | #No TAG found in source code#
PushChoice187 (-) | #No TAG found in source code#
PushChoice188 (-) | #No TAG found in source code#
PushChoice189 (-) | #No TAG found in source code#
PushChoice19 (-) | #No TAG found in source code#
PushChoice190 (-) | #No TAG found in source code#
PushChoice191 (-) | #No TAG found in source code#
PushChoice192 (-) | #No TAG found in source code#
PushChoice193 (-) | #No TAG found in source code#
PushChoice194 (-) | #No TAG found in source code#
PushChoice195 (-) | #No TAG found in source code#
PushChoice196 (-) | #No TAG found in source code#
PushChoice197 (-) | #No TAG found in source code#
PushChoice198 (-) | #No TAG found in source code#
PushChoice199 (-) | #No TAG found in source code#
PushChoice2 (-) | #No TAG found in source code#
PushChoice20 (-) | #No TAG found in source code#
PushChoice200 (-) | #No TAG found in source code#
PushChoice201 (-) | #No TAG found in source code#
PushChoice202 (-) | #No TAG found in source code#
PushChoice203 (-) | #No TAG found in source code#
PushChoice204 (-) | #No TAG found in source code#
PushChoice205 (-) | #No TAG found in source code#
PushChoice206 (-) | #No TAG found in source code#
PushChoice207 (-) | #No TAG found in source code#
PushChoice208 (-) | #No TAG found in source code#
PushChoice209 (-) | #No TAG found in source code#
PushChoice21 (-) | #No TAG found in source code#
PushChoice210 (-) | #No TAG found in source code#
PushChoice211 (-) | #No TAG found in source code#
PushChoice212 (-) | #No TAG found in source code#
PushChoice213 (-) | #No TAG found in source code#
PushChoice214 (-) | #No TAG found in source code#
PushChoice215 (-) | #No TAG found in source code#
PushChoice216 (-) | #No TAG found in source code#
PushChoice217 (-) | #No TAG found in source code#
PushChoice218 (-) | #No TAG found in source code#
PushChoice219 (-) | #No TAG found in source code#
PushChoice22 (-) | #No TAG found in source code#
PushChoice220 (-) | #No TAG found in source code#
PushChoice221 (-) | #No TAG found in source code#
PushChoice222 (-) | #No TAG found in source code#
PushChoice223 (-) | #No TAG found in source code#
PushChoice224 (-) | #No TAG found in source code#
PushChoice225 (-) | #No TAG found in source code#
PushChoice226 (-) | #No TAG found in source code#
PushChoice227 (-) | #No TAG found in source code#
PushChoice228 (-) | #No TAG found in source code#
PushChoice229 (-) | #No TAG found in source code#
PushChoice23 (-) | #No TAG found in source code#
PushChoice230 (-) | #No TAG found in source code#
PushChoice231 (-) | #No TAG found in source code#
PushChoice232 (-) | #No TAG found in source code#
PushChoice233 (-) | #No TAG found in source code#
PushChoice234 (-) | #No TAG found in source code#
PushChoice235 (-) | #No TAG found in source code#
PushChoice236 (-) | #No TAG found in source code#
PushChoice237 (-) | #No TAG found in source code#
PushChoice238 (-) | #No TAG found in source code#
PushChoice239 (-) | #No TAG found in source code#
PushChoice24 (-) | #No TAG found in source code#
PushChoice240 (-) | #No TAG found in source code#
PushChoice241 (-) | #No TAG found in source code#
PushChoice242 (-) | #No TAG found in source code#
PushChoice243 (-) | #No TAG found in source code#
PushChoice244 (-) | #No TAG found in source code#
PushChoice245 (-) | #No TAG found in source code#
PushChoice246 (-) | #No TAG found in source code#
PushChoice247 (-) | #No TAG found in source code#
PushChoice248 (-) | #No TAG found in source code#
PushChoice249 (-) | #No TAG found in source code#
PushChoice25 (-) | #No TAG found in source code#
PushChoice250 (-) | #No TAG found in source code#
PushChoice251 (-) | #No TAG found in source code#
PushChoice252 (-) | #No TAG found in source code#
PushChoice253 (-) | #No TAG found in source code#
PushChoice254 (-) | #No TAG found in source code#
PushChoice255 (-) | #No TAG found in source code#
PushChoice256 (-) | #No TAG found in source code#
PushChoice257 (-) | #No TAG found in source code#
PushChoice258 (-) | #No TAG found in source code#
PushChoice259 (-) | #No TAG found in source code#
PushChoice26 (-) | #No TAG found in source code#
PushChoice260 (-) | #No TAG found in source code#
PushChoice261 (-) | #No TAG found in source code#
PushChoice262 (-) | #No TAG found in source code#
PushChoice263 (-) | #No TAG found in source code#
PushChoice264 (-) | #No TAG found in source code#
PushChoice265 (-) | #No TAG found in source code#
PushChoice266 (-) | #No TAG found in source code#
PushChoice267 (-) | #No TAG found in source code#
PushChoice268 (-) | #No TAG found in source code#
PushChoice269 (-) | #No TAG found in source code#
PushChoice27 (-) | #No TAG found in source code#
PushChoice270 (-) | #No TAG found in source code#
PushChoice271 (-) | #No TAG found in source code#
PushChoice272 (-) | #No TAG found in source code#
PushChoice273 (-) | #No TAG found in source code#
PushChoice274 (-) | #No TAG found in source code#
PushChoice275 (-) | #No TAG found in source code#
PushChoice276 (-) | #No TAG found in source code#
PushChoice277 (-) | #No TAG found in source code#
PushChoice278 (-) | #No TAG found in source code#
PushChoice279 (-) | #No TAG found in source code#
PushChoice28 (-) | #No TAG found in source code#
PushChoice280 (-) | #No TAG found in source code#
PushChoice281 (-) | #No TAG found in source code#
PushChoice282 (-) | #No TAG found in source code#
PushChoice283 (-) | #No TAG found in source code#
PushChoice284 (-) | #No TAG found in source code#
PushChoice285 (-) | #No TAG found in source code#
PushChoice286 (-) | #No TAG found in source code#
PushChoice287 (-) | #No TAG found in source code#
PushChoice288 (-) | #No TAG found in source code#
PushChoice289 (-) | #No TAG found in source code#
PushChoice29 (-) | #No TAG found in source code#
PushChoice290 (-) | #No TAG found in source code#
PushChoice291 (-) | #No TAG found in source code#
PushChoice292 (-) | #No TAG found in source code#
PushChoice293 (-) | #No TAG found in source code#
PushChoice294 (-) | #No TAG found in source code#
PushChoice295 (-) | #No TAG found in source code#
PushChoice296 (-) | #No TAG found in source code#
PushChoice297 (-) | #No TAG found in source code#
PushChoice298 (-) | #No TAG found in source code#
PushChoice299 (-) | #No TAG found in source code#
PushChoice3 (-) | #No TAG found in source code#
PushChoice30 (-) | #No TAG found in source code#
PushChoice300 (-) | #No TAG found in source code#
PushChoice301 (-) | #No TAG found in source code#
PushChoice302 (-) | #No TAG found in source code#
PushChoice303 (-) | #No TAG found in source code#
PushChoice304 (-) | #No TAG found in source code#
PushChoice305 (-) | #No TAG found in source code#
PushChoice306 (-) | #No TAG found in source code#
PushChoice307 (-) | #No TAG found in source code#
PushChoice308 (-) | #No TAG found in source code#
PushChoice309 (-) | #No TAG found in source code#
PushChoice31 (-) | #No TAG found in source code#
PushChoice310 (-) | #No TAG found in source code#
PushChoice311 (-) | #No TAG found in source code#
PushChoice312 (-) | #No TAG found in source code#
PushChoice313 (-) | #No TAG found in source code#
PushChoice314 (-) | #No TAG found in source code#
PushChoice315 (-) | #No TAG found in source code#
PushChoice316 (-) | #No TAG found in source code#
PushChoice317 (-) | #No TAG found in source code#
PushChoice318 (-) | #No TAG found in source code#
PushChoice319 (-) | #No TAG found in source code#
PushChoice32 (-) | #No TAG found in source code#
PushChoice320 (-) | #No TAG found in source code#
PushChoice321 (-) | #No TAG found in source code#
PushChoice322 (-) | #No TAG found in source code#
PushChoice323 (-) | #No TAG found in source code#
PushChoice324 (-) | #No TAG found in source code#
PushChoice325 (-) | #No TAG found in source code#
PushChoice326 (-) | #No TAG found in source code#
PushChoice327 (-) | #No TAG found in source code#
PushChoice328 (-) | #No TAG found in source code#
PushChoice329 (-) | #No TAG found in source code#
PushChoice33 (-) | #No TAG found in source code#
PushChoice330 (-) | #No TAG found in source code#
PushChoice331 (-) | #No TAG found in source code#
PushChoice332 (-) | #No TAG found in source code#
PushChoice333 (-) | #No TAG found in source code#
PushChoice334 (-) | #No TAG found in source code#
PushChoice335 (-) | #No TAG found in source code#
PushChoice336 (-) | #No TAG found in source code#
PushChoice337 (-) | #No TAG found in source code#
PushChoice338 (-) | #No TAG found in source code#
PushChoice339 (-) | #No TAG found in source code#
PushChoice34 (-) | #No TAG found in source code#
PushChoice340 (-) | #No TAG found in source code#
PushChoice341 (-) | #No TAG found in source code#
PushChoice342 (-) | #No TAG found in source code#
PushChoice343 (-) | #No TAG found in source code#
PushChoice344 (-) | #No TAG found in source code#
PushChoice345 (-) | #No TAG found in source code#
PushChoice346 (-) | #No TAG found in source code#
PushChoice347 (-) | #No TAG found in source code#
PushChoice348 (-) | #No TAG found in source code#
PushChoice349 (-) | #No TAG found in source code#
PushChoice35 (-) | #No TAG found in source code#
PushChoice350 (-) | #No TAG found in source code#
PushChoice351 (-) | #No TAG found in source code#
PushChoice352 (-) | #No TAG found in source code#
PushChoice353 (-) | #No TAG found in source code#
PushChoice354 (-) | #No TAG found in source code#
PushChoice355 (-) | #No TAG found in source code#
PushChoice356 (-) | #No TAG found in source code#
PushChoice357 (-) | #No TAG found in source code#
PushChoice358 (-) | #No TAG found in source code#
PushChoice359 (-) | #No TAG found in source code#
PushChoice36 (-) | #No TAG found in source code#
PushChoice360 (-) | #No TAG found in source code#
PushChoice361 (-) | #No TAG found in source code#
PushChoice362 (-) | #No TAG found in source code#
PushChoice363 (-) | #No TAG found in source code#
PushChoice364 (-) | #No TAG found in source code#
PushChoice365 (-) | #No TAG found in source code#
PushChoice366 (-) | #No TAG found in source code#
PushChoice367 (-) | #No TAG found in source code#
PushChoice368 (-) | #No TAG found in source code#
PushChoice369 (-) | #No TAG found in source code#
PushChoice37 (-) | #No TAG found in source code#
PushChoice370 (-) | #No TAG found in source code#
PushChoice371 (-) | #No TAG found in source code#
PushChoice372 (-) | #No TAG found in source code#
PushChoice373 (-) | #No TAG found in source code#
PushChoice374 (-) | #No TAG found in source code#
PushChoice375 (-) | #No TAG found in source code#
PushChoice376 (-) | #No TAG found in source code#
PushChoice377 (-) | #No TAG found in source code#
PushChoice378 (-) | #No TAG found in source code#
PushChoice379 (-) | #No TAG found in source code#
PushChoice38 (-) | #No TAG found in source code#
PushChoice380 (-) | #No TAG found in source code#
PushChoice381 (-) | #No TAG found in source code#
PushChoice382 (-) | #No TAG found in source code#
PushChoice383 (-) | #No TAG found in source code#
PushChoice384 (-) | #No TAG found in source code#
PushChoice385 (-) | #No TAG found in source code#
PushChoice386 (-) | #No TAG found in source code#
PushChoice387 (-) | #No TAG found in source code#
PushChoice388 (-) | #No TAG found in source code#
PushChoice389 (-) | #No TAG found in source code#
PushChoice39 (-) | #No TAG found in source code#
PushChoice390 (-) | #No TAG found in source code#
PushChoice391 (-) | #No TAG found in source code#
PushChoice392 (-) | #No TAG found in source code#
PushChoice393 (-) | #No TAG found in source code#
PushChoice394 (-) | #No TAG found in source code#
PushChoice395 (-) | #No TAG found in source code#
PushChoice396 (-) | #No TAG found in source code#
PushChoice397 (-) | #No TAG found in source code#
PushChoice398 (-) | #No TAG found in source code#
PushChoice399 (-) | #No TAG found in source code#
PushChoice4 (-) | #No TAG found in source code#
PushChoice40 (-) | #No TAG found in source code#
PushChoice400 (-) | #No TAG found in source code#
PushChoice401 (-) | #No TAG found in source code#
PushChoice402 (-) | #No TAG found in source code#
PushChoice403 (-) | #No TAG found in source code#
PushChoice404 (-) | #No TAG found in source code#
PushChoice405 (-) | #No TAG found in source code#
PushChoice406 (-) | #No TAG found in source code#
PushChoice407 (-) | #No TAG found in source code#
PushChoice408 (-) | #No TAG found in source code#
PushChoice409 (-) | #No TAG found in source code#
PushChoice41 (-) | #No TAG found in source code#
PushChoice410 (-) | #No TAG found in source code#
PushChoice411 (-) | #No TAG found in source code#
PushChoice412 (-) | #No TAG found in source code#
PushChoice413 (-) | #No TAG found in source code#
PushChoice414 (-) | #No TAG found in source code#
PushChoice415 (-) | #No TAG found in source code#
PushChoice416 (-) | #No TAG found in source code#
PushChoice417 (-) | #No TAG found in source code#
PushChoice418 (-) | #No TAG found in source code#
PushChoice419 (-) | #No TAG found in source code#
PushChoice42 (-) | #No TAG found in source code#
PushChoice420 (-) | #No TAG found in source code#
PushChoice421 (-) | #No TAG found in source code#
PushChoice422 (-) | #No TAG found in source code#
PushChoice423 (-) | #No TAG found in source code#
PushChoice424 (-) | #No TAG found in source code#
PushChoice425 (-) | #No TAG found in source code#
PushChoice426 (-) | #No TAG found in source code#
PushChoice427 (-) | #No TAG found in source code#
PushChoice428 (-) | #No TAG found in source code#
PushChoice429 (-) | #No TAG found in source code#
PushChoice43 (-) | #No TAG found in source code#
PushChoice430 (-) | #No TAG found in source code#
PushChoice431 (-) | #No TAG found in source code#
PushChoice432 (-) | #No TAG found in source code#
PushChoice433 (-) | #No TAG found in source code#
PushChoice434 (-) | #No TAG found in source code#
PushChoice435 (-) | #No TAG found in source code#
PushChoice436 (-) | #No TAG found in source code#
PushChoice437 (-) | #No TAG found in source code#
PushChoice438 (-) | #No TAG found in source code#
PushChoice439 (-) | #No TAG found in source code#
PushChoice44 (-) | #No TAG found in source code#
PushChoice440 (-) | #No TAG found in source code#
PushChoice441 (-) | #No TAG found in source code#
PushChoice442 (-) | #No TAG found in source code#
PushChoice443 (-) | #No TAG found in source code#
PushChoice444 (-) | #No TAG found in source code#
PushChoice445 (-) | #No TAG found in source code#
PushChoice446 (-) | #No TAG found in source code#
PushChoice447 (-) | #No TAG found in source code#
PushChoice448 (-) | #No TAG found in source code#
PushChoice449 (-) | #No TAG found in source code#
PushChoice45 (-) | #No TAG found in source code#
PushChoice450 (-) | #No TAG found in source code#
PushChoice451 (-) | #No TAG found in source code#
PushChoice452 (-) | #No TAG found in source code#
PushChoice453 (-) | #No TAG found in source code#
PushChoice454 (-) | #No TAG found in source code#
PushChoice455 (-) | #No TAG found in source code#
PushChoice456 (-) | #No TAG found in source code#
PushChoice457 (-) | #No TAG found in source code#
PushChoice458 (-) | #No TAG found in source code#
PushChoice459 (-) | #No TAG found in source code#
PushChoice46 (-) | #No TAG found in source code#
PushChoice460 (-) | #No TAG found in source code#
PushChoice461 (-) | #No TAG found in source code#
PushChoice462 (-) | #No TAG found in source code#
PushChoice463 (-) | #No TAG found in source code#
PushChoice464 (-) | #No TAG found in source code#
PushChoice465 (-) | #No TAG found in source code#
PushChoice466 (-) | #No TAG found in source code#
PushChoice467 (-) | #No TAG found in source code#
PushChoice468 (-) | #No TAG found in source code#
PushChoice469 (-) | #No TAG found in source code#
PushChoice47 (-) | #No TAG found in source code#
PushChoice470 (-) | #No TAG found in source code#
PushChoice471 (-) | #No TAG found in source code#
PushChoice472 (-) | #No TAG found in source code#
PushChoice473 (-) | #No TAG found in source code#
PushChoice474 (-) | #No TAG found in source code#
PushChoice475 (-) | #No TAG found in source code#
PushChoice476 (-) | #No TAG found in source code#
PushChoice477 (-) | #No TAG found in source code#
PushChoice478 (-) | #No TAG found in source code#
PushChoice479 (-) | #No TAG found in source code#
PushChoice48 (-) | #No TAG found in source code#
PushChoice480 (-) | #No TAG found in source code#
PushChoice481 (-) | #No TAG found in source code#
PushChoice482 (-) | #No TAG found in source code#
PushChoice483 (-) | #No TAG found in source code#
PushChoice484 (-) | #No TAG found in source code#
PushChoice485 (-) | #No TAG found in source code#
PushChoice49 (-) | #No TAG found in source code#
PushChoice5 (-) | #No TAG found in source code#
PushChoice50 (-) | #No TAG found in source code#
PushChoice51 (-) | #No TAG found in source code#
PushChoice52 (-) | #No TAG found in source code#
PushChoice53 (-) | #No TAG found in source code#
PushChoice54 (-) | #No TAG found in source code#
PushChoice55 (-) | #No TAG found in source code#
PushChoice56 (-) | #No TAG found in source code#
PushChoice57 (-) | #No TAG found in source code#
PushChoice58 (-) | #No TAG found in source code#
PushChoice59 (-) | #No TAG found in source code#
PushChoice6 (-) | #No TAG found in source code#
PushChoice60 (-) | #No TAG found in source code#
PushChoice61 (-) | #No TAG found in source code#
PushChoice62 (-) | #No TAG found in source code#
PushChoice63 (-) | #No TAG found in source code#
PushChoice64 (-) | #No TAG found in source code#
PushChoice65 (-) | #No TAG found in source code#
PushChoice66 (-) | #No TAG found in source code#
PushChoice67 (-) | #No TAG found in source code#
PushChoice68 (-) | #No TAG found in source code#
PushChoice69 (-) | #No TAG found in source code#
PushChoice7 (-) | #No TAG found in source code#
PushChoice70 (-) | #No TAG found in source code#
PushChoice71 (-) | #No TAG found in source code#
PushChoice72 (-) | #No TAG found in source code#
PushChoice73 (-) | #No TAG found in source code#
PushChoice74 (-) | #No TAG found in source code#
PushChoice75 (-) | #No TAG found in source code#
PushChoice76 (-) | #No TAG found in source code#
PushChoice77 (-) | #No TAG found in source code#
PushChoice78 (-) | #No TAG found in source code#
PushChoice79 (-) | #No TAG found in source code#
PushChoice8 (-) | #No TAG found in source code#
PushChoice80 (-) | #No TAG found in source code#
PushChoice81 (-) | #No TAG found in source code#
PushChoice82 (-) | #No TAG found in source code#
PushChoice83 (-) | #No TAG found in source code#
PushChoice84 (-) | #No TAG found in source code#
PushChoice85 (-) | #No TAG found in source code#
PushChoice86 (-) | #No TAG found in source code#
PushChoice87 (-) | #No TAG found in source code#
PushChoice88 (-) | #No TAG found in source code#
PushChoice89 (-) | #No TAG found in source code#
PushChoice9 (-) | #No TAG found in source code#
PushChoice90 (-) | #No TAG found in source code#
PushChoice91 (-) | #No TAG found in source code#
PushChoice92 (-) | #No TAG found in source code#
PushChoice93 (-) | #No TAG found in source code#
PushChoice94 (-) | #No TAG found in source code#
PushChoice95 (-) | #No TAG found in source code#
PushChoice96 (-) | #No TAG found in source code#
PushChoice97 (-) | #No TAG found in source code#
PushChoice98 (-) | #No TAG found in source code#
PushChoice99 (-) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetNonTerminalClass)

Name
GetExpectedString

Parent
TSepiDelphiParser

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetExpectedString ( ExpectedSymbol : TSepiSymbolClass ) : string ; override

Parameters
Parameter | Description
ExpectedSymbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (GetNonTerminalClass)


Sepi

Sepi
Previous (GetExpectedString)
Next (GetParsingTable)

Name
GetNonTerminalClass

Parent
TSepiDelphiParser

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetNonTerminalClass ( Symbol : TSepiSymbolClass ) : TSepiNonTerminalClass ; override

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiNonTerminalClass | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetExpectedString)
Next (GetParsingTable)


Sepi

Sepi
Previous (GetNonTerminalClass)
Next (InitPushChoiceProcs)

Name
GetParsingTable

Parent
TSepiDelphiParser

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetParsingTable ( NonTerminalClass : TSepiSymbolClass ; TerminalClass : TSepiSymbolClass ) : TRuleID ; override

Parameters
Parameter | Description
NonTerminalClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#
TerminalClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TRuleID | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNonTerminalClass)
Next (InitPushChoiceProcs)


Sepi

Sepi
Previous (GetParsingTable)
Next (IsNonTerminal)

Name
InitPushChoiceProcs

Parent
TSepiDelphiParser

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InitPushChoiceProcs ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetParsingTable)
Next (IsNonTerminal)


Sepi

Sepi
Previous (InitPushChoiceProcs)
Next (IsTerminal)

Name
IsNonTerminal

Parent
TSepiDelphiParser

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function IsNonTerminal ( Symbol : TSepiSymbolClass ) : Boolean ; override

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InitPushChoiceProcs)
Next (IsTerminal)


Sepi

Sepi
Previous (IsNonTerminal)
Next (PushChoice1)

Name
IsTerminal

Parent
TSepiDelphiParser

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function IsTerminal ( Symbol : TSepiSymbolClass ) : Boolean ; override

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsNonTerminal)
Next (PushChoice1)


Sepi

Sepi
Previous (IsTerminal)
Next (PushChoice10)

Name
PushChoice1

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice1

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (IsTerminal)
Next (PushChoice10)


Sepi

Sepi
Previous (PushChoice1)
Next (PushChoice100)

Name
PushChoice10

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice10

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice1)
Next (PushChoice100)


Sepi

Sepi
Previous (PushChoice10)
Next (PushChoice101)

Name
PushChoice100

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice100

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice10)
Next (PushChoice101)


Sepi

Sepi
Previous (PushChoice100)
Next (PushChoice102)

Name
PushChoice101

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice101

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice100)
Next (PushChoice102)


Sepi

Sepi
Previous (PushChoice101)
Next (PushChoice103)

Name
PushChoice102

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice102

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice101)
Next (PushChoice103)


Sepi

Sepi
Previous (PushChoice102)
Next (PushChoice104)

Name
PushChoice103

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice103

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice102)
Next (PushChoice104)


Sepi

Sepi
Previous (PushChoice103)
Next (PushChoice105)

Name
PushChoice104

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice104

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice103)
Next (PushChoice105)


Sepi

Sepi
Previous (PushChoice104)
Next (PushChoice106)

Name
PushChoice105

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice105

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice104)
Next (PushChoice106)


Sepi

Sepi
Previous (PushChoice105)
Next (PushChoice107)

Name
PushChoice106

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice106

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice105)
Next (PushChoice107)


Sepi

Sepi
Previous (PushChoice106)
Next (PushChoice108)

Name
PushChoice107

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice107

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice106)
Next (PushChoice108)


Sepi

Sepi
Previous (PushChoice107)
Next (PushChoice109)

Name
PushChoice108

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice108

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice107)
Next (PushChoice109)


Sepi

Sepi
Previous (PushChoice108)
Next (PushChoice11)

Name
PushChoice109

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice109

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice108)
Next (PushChoice11)


Sepi

Sepi
Previous (PushChoice109)
Next (PushChoice110)

Name
PushChoice11

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice11

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice109)
Next (PushChoice110)


Sepi

Sepi
Previous (PushChoice11)
Next (PushChoice111)

Name
PushChoice110

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice110

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice11)
Next (PushChoice111)


Sepi

Sepi
Previous (PushChoice110)
Next (PushChoice112)

Name
PushChoice111

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice111

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice110)
Next (PushChoice112)


Sepi

Sepi
Previous (PushChoice111)
Next (PushChoice113)

Name
PushChoice112

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice112

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice111)
Next (PushChoice113)


Sepi

Sepi
Previous (PushChoice112)
Next (PushChoice114)

Name
PushChoice113

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice113

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice112)
Next (PushChoice114)


Sepi

Sepi
Previous (PushChoice113)
Next (PushChoice115)

Name
PushChoice114

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice114

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice113)
Next (PushChoice115)


Sepi

Sepi
Previous (PushChoice114)
Next (PushChoice116)

Name
PushChoice115

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice115

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice114)
Next (PushChoice116)


Sepi

Sepi
Previous (PushChoice115)
Next (PushChoice117)

Name
PushChoice116

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice116

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice115)
Next (PushChoice117)


Sepi

Sepi
Previous (PushChoice116)
Next (PushChoice118)

Name
PushChoice117

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice117

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice116)
Next (PushChoice118)


Sepi

Sepi
Previous (PushChoice117)
Next (PushChoice119)

Name
PushChoice118

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice118

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice117)
Next (PushChoice119)


Sepi

Sepi
Previous (PushChoice118)
Next (PushChoice12)

Name
PushChoice119

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice119

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice118)
Next (PushChoice12)


Sepi

Sepi
Previous (PushChoice119)
Next (PushChoice120)

Name
PushChoice12

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice12

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice119)
Next (PushChoice120)


Sepi

Sepi
Previous (PushChoice12)
Next (PushChoice121)

Name
PushChoice120

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice120

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice12)
Next (PushChoice121)


Sepi

Sepi
Previous (PushChoice120)
Next (PushChoice122)

Name
PushChoice121

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice121

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice120)
Next (PushChoice122)


Sepi

Sepi
Previous (PushChoice121)
Next (PushChoice123)

Name
PushChoice122

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice122

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice121)
Next (PushChoice123)


Sepi

Sepi
Previous (PushChoice122)
Next (PushChoice124)

Name
PushChoice123

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice123

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice122)
Next (PushChoice124)


Sepi

Sepi
Previous (PushChoice123)
Next (PushChoice125)

Name
PushChoice124

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice124

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice123)
Next (PushChoice125)


Sepi

Sepi
Previous (PushChoice124)
Next (PushChoice126)

Name
PushChoice125

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice125

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice124)
Next (PushChoice126)


Sepi

Sepi
Previous (PushChoice125)
Next (PushChoice127)

Name
PushChoice126

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice126

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice125)
Next (PushChoice127)


Sepi

Sepi
Previous (PushChoice126)
Next (PushChoice128)

Name
PushChoice127

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice127

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice126)
Next (PushChoice128)


Sepi

Sepi
Previous (PushChoice127)
Next (PushChoice129)

Name
PushChoice128

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice128

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice127)
Next (PushChoice129)


Sepi

Sepi
Previous (PushChoice128)
Next (PushChoice13)

Name
PushChoice129

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice129

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice128)
Next (PushChoice13)


Sepi

Sepi
Previous (PushChoice129)
Next (PushChoice130)

Name
PushChoice13

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice13

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice129)
Next (PushChoice130)


Sepi

Sepi
Previous (PushChoice13)
Next (PushChoice131)

Name
PushChoice130

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice130

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice13)
Next (PushChoice131)


Sepi

Sepi
Previous (PushChoice130)
Next (PushChoice132)

Name
PushChoice131

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice131

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice130)
Next (PushChoice132)


Sepi

Sepi
Previous (PushChoice131)
Next (PushChoice133)

Name
PushChoice132

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice132

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice131)
Next (PushChoice133)


Sepi

Sepi
Previous (PushChoice132)
Next (PushChoice134)

Name
PushChoice133

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice133

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice132)
Next (PushChoice134)


Sepi

Sepi
Previous (PushChoice133)
Next (PushChoice135)

Name
PushChoice134

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice134

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice133)
Next (PushChoice135)


Sepi

Sepi
Previous (PushChoice134)
Next (PushChoice136)

Name
PushChoice135

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice135

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice134)
Next (PushChoice136)


Sepi

Sepi
Previous (PushChoice135)
Next (PushChoice137)

Name
PushChoice136

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice136

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice135)
Next (PushChoice137)


Sepi

Sepi
Previous (PushChoice136)
Next (PushChoice138)

Name
PushChoice137

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice137

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice136)
Next (PushChoice138)


Sepi

Sepi
Previous (PushChoice137)
Next (PushChoice139)

Name
PushChoice138

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice138

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice137)
Next (PushChoice139)


Sepi

Sepi
Previous (PushChoice138)
Next (PushChoice14)

Name
PushChoice139

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice139

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice138)
Next (PushChoice14)


Sepi

Sepi
Previous (PushChoice139)
Next (PushChoice140)

Name
PushChoice14

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice14

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice139)
Next (PushChoice140)


Sepi

Sepi
Previous (PushChoice14)
Next (PushChoice141)

Name
PushChoice140

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice140

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice14)
Next (PushChoice141)


Sepi

Sepi
Previous (PushChoice140)
Next (PushChoice142)

Name
PushChoice141

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice141

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice140)
Next (PushChoice142)


Sepi

Sepi
Previous (PushChoice141)
Next (PushChoice143)

Name
PushChoice142

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice142

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice141)
Next (PushChoice143)


Sepi

Sepi
Previous (PushChoice142)
Next (PushChoice144)

Name
PushChoice143

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice143

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice142)
Next (PushChoice144)


Sepi

Sepi
Previous (PushChoice143)
Next (PushChoice145)

Name
PushChoice144

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice144

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice143)
Next (PushChoice145)


Sepi

Sepi
Previous (PushChoice144)
Next (PushChoice146)

Name
PushChoice145

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice145

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice144)
Next (PushChoice146)


Sepi

Sepi
Previous (PushChoice145)
Next (PushChoice147)

Name
PushChoice146

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice146

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice145)
Next (PushChoice147)


Sepi

Sepi
Previous (PushChoice146)
Next (PushChoice148)

Name
PushChoice147

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice147

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice146)
Next (PushChoice148)


Sepi

Sepi
Previous (PushChoice147)
Next (PushChoice149)

Name
PushChoice148

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice148

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice147)
Next (PushChoice149)


Sepi

Sepi
Previous (PushChoice148)
Next (PushChoice15)

Name
PushChoice149

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice149

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice148)
Next (PushChoice15)


Sepi

Sepi
Previous (PushChoice149)
Next (PushChoice150)

Name
PushChoice15

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice15

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice149)
Next (PushChoice150)


Sepi

Sepi
Previous (PushChoice15)
Next (PushChoice151)

Name
PushChoice150

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice150

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice15)
Next (PushChoice151)


Sepi

Sepi
Previous (PushChoice150)
Next (PushChoice152)

Name
PushChoice151

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice151

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice150)
Next (PushChoice152)


Sepi

Sepi
Previous (PushChoice151)
Next (PushChoice153)

Name
PushChoice152

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice152

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice151)
Next (PushChoice153)


Sepi

Sepi
Previous (PushChoice152)
Next (PushChoice154)

Name
PushChoice153

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice153

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice152)
Next (PushChoice154)


Sepi

Sepi
Previous (PushChoice153)
Next (PushChoice155)

Name
PushChoice154

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice154

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice153)
Next (PushChoice155)


Sepi

Sepi
Previous (PushChoice154)
Next (PushChoice156)

Name
PushChoice155

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice155

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice154)
Next (PushChoice156)


Sepi

Sepi
Previous (PushChoice155)
Next (PushChoice157)

Name
PushChoice156

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice156

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice155)
Next (PushChoice157)


Sepi

Sepi
Previous (PushChoice156)
Next (PushChoice158)

Name
PushChoice157

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice157

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice156)
Next (PushChoice158)


Sepi

Sepi
Previous (PushChoice157)
Next (PushChoice159)

Name
PushChoice158

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice158

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice157)
Next (PushChoice159)


Sepi

Sepi
Previous (PushChoice158)
Next (PushChoice16)

Name
PushChoice159

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice159

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice158)
Next (PushChoice16)


Sepi

Sepi
Previous (PushChoice159)
Next (PushChoice160)

Name
PushChoice16

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice16

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice159)
Next (PushChoice160)


Sepi

Sepi
Previous (PushChoice16)
Next (PushChoice161)

Name
PushChoice160

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice160

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice16)
Next (PushChoice161)


Sepi

Sepi
Previous (PushChoice160)
Next (PushChoice162)

Name
PushChoice161

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice161

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice160)
Next (PushChoice162)


Sepi

Sepi
Previous (PushChoice161)
Next (PushChoice163)

Name
PushChoice162

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice162

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice161)
Next (PushChoice163)


Sepi

Sepi
Previous (PushChoice162)
Next (PushChoice164)

Name
PushChoice163

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice163

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice162)
Next (PushChoice164)


Sepi

Sepi
Previous (PushChoice163)
Next (PushChoice165)

Name
PushChoice164

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice164

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice163)
Next (PushChoice165)


Sepi

Sepi
Previous (PushChoice164)
Next (PushChoice166)

Name
PushChoice165

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice165

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice164)
Next (PushChoice166)


Sepi

Sepi
Previous (PushChoice165)
Next (PushChoice167)

Name
PushChoice166

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice166

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice165)
Next (PushChoice167)


Sepi

Sepi
Previous (PushChoice166)
Next (PushChoice168)

Name
PushChoice167

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice167

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice166)
Next (PushChoice168)


Sepi

Sepi
Previous (PushChoice167)
Next (PushChoice169)

Name
PushChoice168

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice168

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice167)
Next (PushChoice169)


Sepi

Sepi
Previous (PushChoice168)
Next (PushChoice17)

Name
PushChoice169

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice169

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice168)
Next (PushChoice17)


Sepi

Sepi
Previous (PushChoice169)
Next (PushChoice170)

Name
PushChoice17

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice17

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice169)
Next (PushChoice170)


Sepi

Sepi
Previous (PushChoice17)
Next (PushChoice171)

Name
PushChoice170

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice170

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice17)
Next (PushChoice171)


Sepi

Sepi
Previous (PushChoice170)
Next (PushChoice172)

Name
PushChoice171

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice171

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice170)
Next (PushChoice172)


Sepi

Sepi
Previous (PushChoice171)
Next (PushChoice173)

Name
PushChoice172

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice172

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice171)
Next (PushChoice173)


Sepi

Sepi
Previous (PushChoice172)
Next (PushChoice174)

Name
PushChoice173

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice173

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice172)
Next (PushChoice174)


Sepi

Sepi
Previous (PushChoice173)
Next (PushChoice175)

Name
PushChoice174

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice174

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice173)
Next (PushChoice175)


Sepi

Sepi
Previous (PushChoice174)
Next (PushChoice176)

Name
PushChoice175

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice175

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice174)
Next (PushChoice176)


Sepi

Sepi
Previous (PushChoice175)
Next (PushChoice177)

Name
PushChoice176

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice176

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice175)
Next (PushChoice177)


Sepi

Sepi
Previous (PushChoice176)
Next (PushChoice178)

Name
PushChoice177

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice177

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice176)
Next (PushChoice178)


Sepi

Sepi
Previous (PushChoice177)
Next (PushChoice179)

Name
PushChoice178

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice178

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice177)
Next (PushChoice179)


Sepi

Sepi
Previous (PushChoice178)
Next (PushChoice18)

Name
PushChoice179

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice179

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice178)
Next (PushChoice18)


Sepi

Sepi
Previous (PushChoice179)
Next (PushChoice180)

Name
PushChoice18

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice18

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice179)
Next (PushChoice180)


Sepi

Sepi
Previous (PushChoice18)
Next (PushChoice181)

Name
PushChoice180

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice180

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice18)
Next (PushChoice181)


Sepi

Sepi
Previous (PushChoice180)
Next (PushChoice182)

Name
PushChoice181

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice181

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice180)
Next (PushChoice182)


Sepi

Sepi
Previous (PushChoice181)
Next (PushChoice183)

Name
PushChoice182

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice182

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice181)
Next (PushChoice183)


Sepi

Sepi
Previous (PushChoice182)
Next (PushChoice184)

Name
PushChoice183

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice183

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice182)
Next (PushChoice184)


Sepi

Sepi
Previous (PushChoice183)
Next (PushChoice185)

Name
PushChoice184

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice184

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice183)
Next (PushChoice185)


Sepi

Sepi
Previous (PushChoice184)
Next (PushChoice186)

Name
PushChoice185

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice185

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice184)
Next (PushChoice186)


Sepi

Sepi
Previous (PushChoice185)
Next (PushChoice187)

Name
PushChoice186

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice186

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice185)
Next (PushChoice187)


Sepi

Sepi
Previous (PushChoice186)
Next (PushChoice188)

Name
PushChoice187

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice187

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice186)
Next (PushChoice188)


Sepi

Sepi
Previous (PushChoice187)
Next (PushChoice189)

Name
PushChoice188

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice188

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice187)
Next (PushChoice189)


Sepi

Sepi
Previous (PushChoice188)
Next (PushChoice19)

Name
PushChoice189

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice189

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice188)
Next (PushChoice19)


Sepi

Sepi
Previous (PushChoice189)
Next (PushChoice190)

Name
PushChoice19

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice19

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice189)
Next (PushChoice190)


Sepi

Sepi
Previous (PushChoice19)
Next (PushChoice191)

Name
PushChoice190

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice190

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice19)
Next (PushChoice191)


Sepi

Sepi
Previous (PushChoice190)
Next (PushChoice192)

Name
PushChoice191

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice191

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice190)
Next (PushChoice192)


Sepi

Sepi
Previous (PushChoice191)
Next (PushChoice193)

Name
PushChoice192

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice192

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice191)
Next (PushChoice193)


Sepi

Sepi
Previous (PushChoice192)
Next (PushChoice194)

Name
PushChoice193

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice193

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice192)
Next (PushChoice194)


Sepi

Sepi
Previous (PushChoice193)
Next (PushChoice195)

Name
PushChoice194

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice194

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice193)
Next (PushChoice195)


Sepi

Sepi
Previous (PushChoice194)
Next (PushChoice196)

Name
PushChoice195

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice195

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice194)
Next (PushChoice196)


Sepi

Sepi
Previous (PushChoice195)
Next (PushChoice197)

Name
PushChoice196

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice196

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice195)
Next (PushChoice197)


Sepi

Sepi
Previous (PushChoice196)
Next (PushChoice198)

Name
PushChoice197

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice197

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice196)
Next (PushChoice198)


Sepi

Sepi
Previous (PushChoice197)
Next (PushChoice199)

Name
PushChoice198

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice198

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice197)
Next (PushChoice199)


Sepi

Sepi
Previous (PushChoice198)
Next (PushChoice2)

Name
PushChoice199

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice199

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice198)
Next (PushChoice2)


Sepi

Sepi
Previous (PushChoice199)
Next (PushChoice20)

Name
PushChoice2

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice2

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice199)
Next (PushChoice20)


Sepi

Sepi
Previous (PushChoice2)
Next (PushChoice200)

Name
PushChoice20

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice20

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice2)
Next (PushChoice200)


Sepi

Sepi
Previous (PushChoice20)
Next (PushChoice201)

Name
PushChoice200

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice200

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice20)
Next (PushChoice201)


Sepi

Sepi
Previous (PushChoice200)
Next (PushChoice202)

Name
PushChoice201

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice201

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice200)
Next (PushChoice202)


Sepi

Sepi
Previous (PushChoice201)
Next (PushChoice203)

Name
PushChoice202

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice202

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice201)
Next (PushChoice203)


Sepi

Sepi
Previous (PushChoice202)
Next (PushChoice204)

Name
PushChoice203

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice203

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice202)
Next (PushChoice204)


Sepi

Sepi
Previous (PushChoice203)
Next (PushChoice205)

Name
PushChoice204

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice204

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice203)
Next (PushChoice205)


Sepi

Sepi
Previous (PushChoice204)
Next (PushChoice206)

Name
PushChoice205

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice205

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice204)
Next (PushChoice206)


Sepi

Sepi
Previous (PushChoice205)
Next (PushChoice207)

Name
PushChoice206

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice206

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice205)
Next (PushChoice207)


Sepi

Sepi
Previous (PushChoice206)
Next (PushChoice208)

Name
PushChoice207

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice207

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice206)
Next (PushChoice208)


Sepi

Sepi
Previous (PushChoice207)
Next (PushChoice209)

Name
PushChoice208

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice208

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice207)
Next (PushChoice209)


Sepi

Sepi
Previous (PushChoice208)
Next (PushChoice21)

Name
PushChoice209

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice209

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice208)
Next (PushChoice21)


Sepi

Sepi
Previous (PushChoice209)
Next (PushChoice210)

Name
PushChoice21

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice21

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice209)
Next (PushChoice210)


Sepi

Sepi
Previous (PushChoice21)
Next (PushChoice211)

Name
PushChoice210

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice210

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice21)
Next (PushChoice211)


Sepi

Sepi
Previous (PushChoice210)
Next (PushChoice212)

Name
PushChoice211

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice211

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice210)
Next (PushChoice212)


Sepi

Sepi
Previous (PushChoice211)
Next (PushChoice213)

Name
PushChoice212

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice212

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice211)
Next (PushChoice213)


Sepi

Sepi
Previous (PushChoice212)
Next (PushChoice214)

Name
PushChoice213

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice213

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice212)
Next (PushChoice214)


Sepi

Sepi
Previous (PushChoice213)
Next (PushChoice215)

Name
PushChoice214

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice214

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice213)
Next (PushChoice215)


Sepi

Sepi
Previous (PushChoice214)
Next (PushChoice216)

Name
PushChoice215

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice215

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice214)
Next (PushChoice216)


Sepi

Sepi
Previous (PushChoice215)
Next (PushChoice217)

Name
PushChoice216

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice216

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice215)
Next (PushChoice217)


Sepi

Sepi
Previous (PushChoice216)
Next (PushChoice218)

Name
PushChoice217

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice217

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice216)
Next (PushChoice218)


Sepi

Sepi
Previous (PushChoice217)
Next (PushChoice219)

Name
PushChoice218

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice218

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice217)
Next (PushChoice219)


Sepi

Sepi
Previous (PushChoice218)
Next (PushChoice22)

Name
PushChoice219

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice219

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice218)
Next (PushChoice22)


Sepi

Sepi
Previous (PushChoice219)
Next (PushChoice220)

Name
PushChoice22

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice22

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice219)
Next (PushChoice220)


Sepi

Sepi
Previous (PushChoice22)
Next (PushChoice221)

Name
PushChoice220

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice220

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice22)
Next (PushChoice221)


Sepi

Sepi
Previous (PushChoice220)
Next (PushChoice222)

Name
PushChoice221

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice221

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice220)
Next (PushChoice222)


Sepi

Sepi
Previous (PushChoice221)
Next (PushChoice223)

Name
PushChoice222

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice222

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice221)
Next (PushChoice223)


Sepi

Sepi
Previous (PushChoice222)
Next (PushChoice224)

Name
PushChoice223

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice223

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice222)
Next (PushChoice224)


Sepi

Sepi
Previous (PushChoice223)
Next (PushChoice225)

Name
PushChoice224

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice224

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice223)
Next (PushChoice225)


Sepi

Sepi
Previous (PushChoice224)
Next (PushChoice226)

Name
PushChoice225

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice225

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice224)
Next (PushChoice226)


Sepi

Sepi
Previous (PushChoice225)
Next (PushChoice227)

Name
PushChoice226

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice226

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice225)
Next (PushChoice227)


Sepi

Sepi
Previous (PushChoice226)
Next (PushChoice228)

Name
PushChoice227

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice227

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice226)
Next (PushChoice228)


Sepi

Sepi
Previous (PushChoice227)
Next (PushChoice229)

Name
PushChoice228

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice228

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice227)
Next (PushChoice229)


Sepi

Sepi
Previous (PushChoice228)
Next (PushChoice23)

Name
PushChoice229

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice229

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice228)
Next (PushChoice23)


Sepi

Sepi
Previous (PushChoice229)
Next (PushChoice230)

Name
PushChoice23

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice23

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice229)
Next (PushChoice230)


Sepi

Sepi
Previous (PushChoice23)
Next (PushChoice231)

Name
PushChoice230

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice230

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice23)
Next (PushChoice231)


Sepi

Sepi
Previous (PushChoice230)
Next (PushChoice232)

Name
PushChoice231

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice231

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice230)
Next (PushChoice232)


Sepi

Sepi
Previous (PushChoice231)
Next (PushChoice233)

Name
PushChoice232

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice232

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice231)
Next (PushChoice233)


Sepi

Sepi
Previous (PushChoice232)
Next (PushChoice234)

Name
PushChoice233

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice233

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice232)
Next (PushChoice234)


Sepi

Sepi
Previous (PushChoice233)
Next (PushChoice235)

Name
PushChoice234

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice234

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice233)
Next (PushChoice235)


Sepi

Sepi
Previous (PushChoice234)
Next (PushChoice236)

Name
PushChoice235

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice235

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice234)
Next (PushChoice236)


Sepi

Sepi
Previous (PushChoice235)
Next (PushChoice237)

Name
PushChoice236

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice236

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice235)
Next (PushChoice237)


Sepi

Sepi
Previous (PushChoice236)
Next (PushChoice238)

Name
PushChoice237

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice237

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice236)
Next (PushChoice238)


Sepi

Sepi
Previous (PushChoice237)
Next (PushChoice239)

Name
PushChoice238

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice238

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice237)
Next (PushChoice239)


Sepi

Sepi
Previous (PushChoice238)
Next (PushChoice24)

Name
PushChoice239

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice239

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice238)
Next (PushChoice24)


Sepi

Sepi
Previous (PushChoice239)
Next (PushChoice240)

Name
PushChoice24

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice24

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice239)
Next (PushChoice240)


Sepi

Sepi
Previous (PushChoice24)
Next (PushChoice241)

Name
PushChoice240

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice240

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice24)
Next (PushChoice241)


Sepi

Sepi
Previous (PushChoice240)
Next (PushChoice242)

Name
PushChoice241

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice241

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice240)
Next (PushChoice242)


Sepi

Sepi
Previous (PushChoice241)
Next (PushChoice243)

Name
PushChoice242

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice242

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice241)
Next (PushChoice243)


Sepi

Sepi
Previous (PushChoice242)
Next (PushChoice244)

Name
PushChoice243

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice243

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice242)
Next (PushChoice244)


Sepi

Sepi
Previous (PushChoice243)
Next (PushChoice245)

Name
PushChoice244

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice244

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice243)
Next (PushChoice245)


Sepi

Sepi
Previous (PushChoice244)
Next (PushChoice246)

Name
PushChoice245

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice245

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice244)
Next (PushChoice246)


Sepi

Sepi
Previous (PushChoice245)
Next (PushChoice247)

Name
PushChoice246

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice246

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice245)
Next (PushChoice247)


Sepi

Sepi
Previous (PushChoice246)
Next (PushChoice248)

Name
PushChoice247

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice247

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice246)
Next (PushChoice248)


Sepi

Sepi
Previous (PushChoice247)
Next (PushChoice249)

Name
PushChoice248

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice248

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice247)
Next (PushChoice249)


Sepi

Sepi
Previous (PushChoice248)
Next (PushChoice25)

Name
PushChoice249

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice249

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice248)
Next (PushChoice25)


Sepi

Sepi
Previous (PushChoice249)
Next (PushChoice250)

Name
PushChoice25

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice25

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice249)
Next (PushChoice250)


Sepi

Sepi
Previous (PushChoice25)
Next (PushChoice251)

Name
PushChoice250

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice250

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice25)
Next (PushChoice251)


Sepi

Sepi
Previous (PushChoice250)
Next (PushChoice252)

Name
PushChoice251

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice251

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice250)
Next (PushChoice252)


Sepi

Sepi
Previous (PushChoice251)
Next (PushChoice253)

Name
PushChoice252

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice252

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice251)
Next (PushChoice253)


Sepi

Sepi
Previous (PushChoice252)
Next (PushChoice254)

Name
PushChoice253

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice253

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice252)
Next (PushChoice254)


Sepi

Sepi
Previous (PushChoice253)
Next (PushChoice255)

Name
PushChoice254

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice254

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice253)
Next (PushChoice255)


Sepi

Sepi
Previous (PushChoice254)
Next (PushChoice256)

Name
PushChoice255

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice255

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice254)
Next (PushChoice256)


Sepi

Sepi
Previous (PushChoice255)
Next (PushChoice257)

Name
PushChoice256

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice256

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice255)
Next (PushChoice257)


Sepi

Sepi
Previous (PushChoice256)
Next (PushChoice258)

Name
PushChoice257

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice257

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice256)
Next (PushChoice258)


Sepi

Sepi
Previous (PushChoice257)
Next (PushChoice259)

Name
PushChoice258

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice258

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice257)
Next (PushChoice259)


Sepi

Sepi
Previous (PushChoice258)
Next (PushChoice26)

Name
PushChoice259

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice259

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice258)
Next (PushChoice26)


Sepi

Sepi
Previous (PushChoice259)
Next (PushChoice260)

Name
PushChoice26

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice26

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice259)
Next (PushChoice260)


Sepi

Sepi
Previous (PushChoice26)
Next (PushChoice261)

Name
PushChoice260

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice260

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice26)
Next (PushChoice261)


Sepi

Sepi
Previous (PushChoice260)
Next (PushChoice262)

Name
PushChoice261

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice261

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice260)
Next (PushChoice262)


Sepi

Sepi
Previous (PushChoice261)
Next (PushChoice263)

Name
PushChoice262

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice262

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice261)
Next (PushChoice263)


Sepi

Sepi
Previous (PushChoice262)
Next (PushChoice264)

Name
PushChoice263

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice263

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice262)
Next (PushChoice264)


Sepi

Sepi
Previous (PushChoice263)
Next (PushChoice265)

Name
PushChoice264

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice264

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice263)
Next (PushChoice265)


Sepi

Sepi
Previous (PushChoice264)
Next (PushChoice266)

Name
PushChoice265

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice265

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice264)
Next (PushChoice266)


Sepi

Sepi
Previous (PushChoice265)
Next (PushChoice267)

Name
PushChoice266

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice266

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice265)
Next (PushChoice267)


Sepi

Sepi
Previous (PushChoice266)
Next (PushChoice268)

Name
PushChoice267

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice267

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice266)
Next (PushChoice268)


Sepi

Sepi
Previous (PushChoice267)
Next (PushChoice269)

Name
PushChoice268

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice268

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice267)
Next (PushChoice269)


Sepi

Sepi
Previous (PushChoice268)
Next (PushChoice27)

Name
PushChoice269

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice269

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice268)
Next (PushChoice27)


Sepi

Sepi
Previous (PushChoice269)
Next (PushChoice270)

Name
PushChoice27

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice27

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice269)
Next (PushChoice270)


Sepi

Sepi
Previous (PushChoice27)
Next (PushChoice271)

Name
PushChoice270

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice270

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice27)
Next (PushChoice271)


Sepi

Sepi
Previous (PushChoice270)
Next (PushChoice272)

Name
PushChoice271

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice271

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice270)
Next (PushChoice272)


Sepi

Sepi
Previous (PushChoice271)
Next (PushChoice273)

Name
PushChoice272

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice272

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice271)
Next (PushChoice273)


Sepi

Sepi
Previous (PushChoice272)
Next (PushChoice274)

Name
PushChoice273

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice273

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice272)
Next (PushChoice274)


Sepi

Sepi
Previous (PushChoice273)
Next (PushChoice275)

Name
PushChoice274

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice274

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice273)
Next (PushChoice275)


Sepi

Sepi
Previous (PushChoice274)
Next (PushChoice276)

Name
PushChoice275

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice275

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice274)
Next (PushChoice276)


Sepi

Sepi
Previous (PushChoice275)
Next (PushChoice277)

Name
PushChoice276

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice276

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice275)
Next (PushChoice277)


Sepi

Sepi
Previous (PushChoice276)
Next (PushChoice278)

Name
PushChoice277

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice277

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice276)
Next (PushChoice278)


Sepi

Sepi
Previous (PushChoice277)
Next (PushChoice279)

Name
PushChoice278

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice278

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice277)
Next (PushChoice279)


Sepi

Sepi
Previous (PushChoice278)
Next (PushChoice28)

Name
PushChoice279

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice279

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice278)
Next (PushChoice28)


Sepi

Sepi
Previous (PushChoice279)
Next (PushChoice280)

Name
PushChoice28

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice28

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice279)
Next (PushChoice280)


Sepi

Sepi
Previous (PushChoice28)
Next (PushChoice281)

Name
PushChoice280

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice280

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice28)
Next (PushChoice281)


Sepi

Sepi
Previous (PushChoice280)
Next (PushChoice282)

Name
PushChoice281

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice281

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice280)
Next (PushChoice282)


Sepi

Sepi
Previous (PushChoice281)
Next (PushChoice283)

Name
PushChoice282

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice282

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice281)
Next (PushChoice283)


Sepi

Sepi
Previous (PushChoice282)
Next (PushChoice284)

Name
PushChoice283

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice283

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice282)
Next (PushChoice284)


Sepi

Sepi
Previous (PushChoice283)
Next (PushChoice285)

Name
PushChoice284

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice284

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice283)
Next (PushChoice285)


Sepi

Sepi
Previous (PushChoice284)
Next (PushChoice286)

Name
PushChoice285

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice285

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice284)
Next (PushChoice286)


Sepi

Sepi
Previous (PushChoice285)
Next (PushChoice287)

Name
PushChoice286

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice286

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice285)
Next (PushChoice287)


Sepi

Sepi
Previous (PushChoice286)
Next (PushChoice288)

Name
PushChoice287

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice287

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice286)
Next (PushChoice288)


Sepi

Sepi
Previous (PushChoice287)
Next (PushChoice289)

Name
PushChoice288

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice288

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice287)
Next (PushChoice289)


Sepi

Sepi
Previous (PushChoice288)
Next (PushChoice29)

Name
PushChoice289

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice289

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice288)
Next (PushChoice29)


Sepi

Sepi
Previous (PushChoice289)
Next (PushChoice290)

Name
PushChoice29

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice29

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice289)
Next (PushChoice290)


Sepi

Sepi
Previous (PushChoice29)
Next (PushChoice291)

Name
PushChoice290

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice290

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice29)
Next (PushChoice291)


Sepi

Sepi
Previous (PushChoice290)
Next (PushChoice292)

Name
PushChoice291

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice291

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice290)
Next (PushChoice292)


Sepi

Sepi
Previous (PushChoice291)
Next (PushChoice293)

Name
PushChoice292

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice292

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice291)
Next (PushChoice293)


Sepi

Sepi
Previous (PushChoice292)
Next (PushChoice294)

Name
PushChoice293

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice293

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice292)
Next (PushChoice294)


Sepi

Sepi
Previous (PushChoice293)
Next (PushChoice295)

Name
PushChoice294

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice294

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice293)
Next (PushChoice295)


Sepi

Sepi
Previous (PushChoice294)
Next (PushChoice296)

Name
PushChoice295

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice295

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice294)
Next (PushChoice296)


Sepi

Sepi
Previous (PushChoice295)
Next (PushChoice297)

Name
PushChoice296

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice296

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice295)
Next (PushChoice297)


Sepi

Sepi
Previous (PushChoice296)
Next (PushChoice298)

Name
PushChoice297

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice297

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice296)
Next (PushChoice298)


Sepi

Sepi
Previous (PushChoice297)
Next (PushChoice299)

Name
PushChoice298

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice298

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice297)
Next (PushChoice299)


Sepi

Sepi
Previous (PushChoice298)
Next (PushChoice3)

Name
PushChoice299

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice299

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice298)
Next (PushChoice3)


Sepi

Sepi
Previous (PushChoice299)
Next (PushChoice30)

Name
PushChoice3

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice3

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice299)
Next (PushChoice30)


Sepi

Sepi
Previous (PushChoice3)
Next (PushChoice300)

Name
PushChoice30

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice30

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice3)
Next (PushChoice300)


Sepi

Sepi
Previous (PushChoice30)
Next (PushChoice301)

Name
PushChoice300

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice300

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice30)
Next (PushChoice301)


Sepi

Sepi
Previous (PushChoice300)
Next (PushChoice302)

Name
PushChoice301

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice301

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice300)
Next (PushChoice302)


Sepi

Sepi
Previous (PushChoice301)
Next (PushChoice303)

Name
PushChoice302

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice302

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice301)
Next (PushChoice303)


Sepi

Sepi
Previous (PushChoice302)
Next (PushChoice304)

Name
PushChoice303

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice303

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice302)
Next (PushChoice304)


Sepi

Sepi
Previous (PushChoice303)
Next (PushChoice305)

Name
PushChoice304

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice304

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice303)
Next (PushChoice305)


Sepi

Sepi
Previous (PushChoice304)
Next (PushChoice306)

Name
PushChoice305

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice305

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice304)
Next (PushChoice306)


Sepi

Sepi
Previous (PushChoice305)
Next (PushChoice307)

Name
PushChoice306

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice306

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice305)
Next (PushChoice307)


Sepi

Sepi
Previous (PushChoice306)
Next (PushChoice308)

Name
PushChoice307

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice307

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice306)
Next (PushChoice308)


Sepi

Sepi
Previous (PushChoice307)
Next (PushChoice309)

Name
PushChoice308

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice308

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice307)
Next (PushChoice309)


Sepi

Sepi
Previous (PushChoice308)
Next (PushChoice31)

Name
PushChoice309

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice309

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice308)
Next (PushChoice31)


Sepi

Sepi
Previous (PushChoice309)
Next (PushChoice310)

Name
PushChoice31

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice31

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice309)
Next (PushChoice310)


Sepi

Sepi
Previous (PushChoice31)
Next (PushChoice311)

Name
PushChoice310

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice310

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice31)
Next (PushChoice311)


Sepi

Sepi
Previous (PushChoice310)
Next (PushChoice312)

Name
PushChoice311

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice311

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice310)
Next (PushChoice312)


Sepi

Sepi
Previous (PushChoice311)
Next (PushChoice313)

Name
PushChoice312

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice312

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice311)
Next (PushChoice313)


Sepi

Sepi
Previous (PushChoice312)
Next (PushChoice314)

Name
PushChoice313

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice313

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice312)
Next (PushChoice314)


Sepi

Sepi
Previous (PushChoice313)
Next (PushChoice315)

Name
PushChoice314

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice314

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice313)
Next (PushChoice315)


Sepi

Sepi
Previous (PushChoice314)
Next (PushChoice316)

Name
PushChoice315

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice315

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice314)
Next (PushChoice316)


Sepi

Sepi
Previous (PushChoice315)
Next (PushChoice317)

Name
PushChoice316

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice316

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice315)
Next (PushChoice317)


Sepi

Sepi
Previous (PushChoice316)
Next (PushChoice318)

Name
PushChoice317

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice317

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice316)
Next (PushChoice318)


Sepi

Sepi
Previous (PushChoice317)
Next (PushChoice319)

Name
PushChoice318

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice318

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice317)
Next (PushChoice319)


Sepi

Sepi
Previous (PushChoice318)
Next (PushChoice32)

Name
PushChoice319

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice319

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice318)
Next (PushChoice32)


Sepi

Sepi
Previous (PushChoice319)
Next (PushChoice320)

Name
PushChoice32

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice32

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice319)
Next (PushChoice320)


Sepi

Sepi
Previous (PushChoice32)
Next (PushChoice321)

Name
PushChoice320

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice320

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice32)
Next (PushChoice321)


Sepi

Sepi
Previous (PushChoice320)
Next (PushChoice322)

Name
PushChoice321

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice321

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice320)
Next (PushChoice322)


Sepi

Sepi
Previous (PushChoice321)
Next (PushChoice323)

Name
PushChoice322

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice322

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice321)
Next (PushChoice323)


Sepi

Sepi
Previous (PushChoice322)
Next (PushChoice324)

Name
PushChoice323

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice323

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice322)
Next (PushChoice324)


Sepi

Sepi
Previous (PushChoice323)
Next (PushChoice325)

Name
PushChoice324

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice324

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice323)
Next (PushChoice325)


Sepi

Sepi
Previous (PushChoice324)
Next (PushChoice326)

Name
PushChoice325

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice325

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice324)
Next (PushChoice326)


Sepi

Sepi
Previous (PushChoice325)
Next (PushChoice327)

Name
PushChoice326

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice326

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice325)
Next (PushChoice327)


Sepi

Sepi
Previous (PushChoice326)
Next (PushChoice328)

Name
PushChoice327

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice327

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice326)
Next (PushChoice328)


Sepi

Sepi
Previous (PushChoice327)
Next (PushChoice329)

Name
PushChoice328

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice328

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice327)
Next (PushChoice329)


Sepi

Sepi
Previous (PushChoice328)
Next (PushChoice33)

Name
PushChoice329

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice329

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice328)
Next (PushChoice33)


Sepi

Sepi
Previous (PushChoice329)
Next (PushChoice330)

Name
PushChoice33

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice33

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice329)
Next (PushChoice330)


Sepi

Sepi
Previous (PushChoice33)
Next (PushChoice331)

Name
PushChoice330

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice330

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice33)
Next (PushChoice331)


Sepi

Sepi
Previous (PushChoice330)
Next (PushChoice332)

Name
PushChoice331

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice331

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice330)
Next (PushChoice332)


Sepi

Sepi
Previous (PushChoice331)
Next (PushChoice333)

Name
PushChoice332

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice332

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice331)
Next (PushChoice333)


Sepi

Sepi
Previous (PushChoice332)
Next (PushChoice334)

Name
PushChoice333

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice333

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice332)
Next (PushChoice334)


Sepi

Sepi
Previous (PushChoice333)
Next (PushChoice335)

Name
PushChoice334

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice334

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice333)
Next (PushChoice335)


Sepi

Sepi
Previous (PushChoice334)
Next (PushChoice336)

Name
PushChoice335

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice335

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice334)
Next (PushChoice336)


Sepi

Sepi
Previous (PushChoice335)
Next (PushChoice337)

Name
PushChoice336

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice336

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice335)
Next (PushChoice337)


Sepi

Sepi
Previous (PushChoice336)
Next (PushChoice338)

Name
PushChoice337

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice337

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice336)
Next (PushChoice338)


Sepi

Sepi
Previous (PushChoice337)
Next (PushChoice339)

Name
PushChoice338

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice338

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice337)
Next (PushChoice339)


Sepi

Sepi
Previous (PushChoice338)
Next (PushChoice34)

Name
PushChoice339

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice339

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice338)
Next (PushChoice34)


Sepi

Sepi
Previous (PushChoice339)
Next (PushChoice340)

Name
PushChoice34

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice34

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice339)
Next (PushChoice340)


Sepi

Sepi
Previous (PushChoice34)
Next (PushChoice341)

Name
PushChoice340

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice340

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice34)
Next (PushChoice341)


Sepi

Sepi
Previous (PushChoice340)
Next (PushChoice342)

Name
PushChoice341

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice341

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice340)
Next (PushChoice342)


Sepi

Sepi
Previous (PushChoice341)
Next (PushChoice343)

Name
PushChoice342

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice342

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice341)
Next (PushChoice343)


Sepi

Sepi
Previous (PushChoice342)
Next (PushChoice344)

Name
PushChoice343

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice343

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice342)
Next (PushChoice344)


Sepi

Sepi
Previous (PushChoice343)
Next (PushChoice345)

Name
PushChoice344

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice344

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice343)
Next (PushChoice345)


Sepi

Sepi
Previous (PushChoice344)
Next (PushChoice346)

Name
PushChoice345

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice345

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice344)
Next (PushChoice346)


Sepi

Sepi
Previous (PushChoice345)
Next (PushChoice347)

Name
PushChoice346

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice346

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice345)
Next (PushChoice347)


Sepi

Sepi
Previous (PushChoice346)
Next (PushChoice348)

Name
PushChoice347

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice347

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice346)
Next (PushChoice348)


Sepi

Sepi
Previous (PushChoice347)
Next (PushChoice349)

Name
PushChoice348

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice348

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice347)
Next (PushChoice349)


Sepi

Sepi
Previous (PushChoice348)
Next (PushChoice35)

Name
PushChoice349

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice349

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice348)
Next (PushChoice35)


Sepi

Sepi
Previous (PushChoice349)
Next (PushChoice350)

Name
PushChoice35

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice35

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice349)
Next (PushChoice350)


Sepi

Sepi
Previous (PushChoice35)
Next (PushChoice351)

Name
PushChoice350

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice350

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice35)
Next (PushChoice351)


Sepi

Sepi
Previous (PushChoice350)
Next (PushChoice352)

Name
PushChoice351

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice351

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice350)
Next (PushChoice352)


Sepi

Sepi
Previous (PushChoice351)
Next (PushChoice353)

Name
PushChoice352

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice352

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice351)
Next (PushChoice353)


Sepi

Sepi
Previous (PushChoice352)
Next (PushChoice354)

Name
PushChoice353

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice353

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice352)
Next (PushChoice354)


Sepi

Sepi
Previous (PushChoice353)
Next (PushChoice355)

Name
PushChoice354

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice354

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice353)
Next (PushChoice355)


Sepi

Sepi
Previous (PushChoice354)
Next (PushChoice356)

Name
PushChoice355

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice355

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice354)
Next (PushChoice356)


Sepi

Sepi
Previous (PushChoice355)
Next (PushChoice357)

Name
PushChoice356

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice356

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice355)
Next (PushChoice357)


Sepi

Sepi
Previous (PushChoice356)
Next (PushChoice358)

Name
PushChoice357

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice357

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice356)
Next (PushChoice358)


Sepi

Sepi
Previous (PushChoice357)
Next (PushChoice359)

Name
PushChoice358

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice358

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice357)
Next (PushChoice359)


Sepi

Sepi
Previous (PushChoice358)
Next (PushChoice36)

Name
PushChoice359

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice359

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice358)
Next (PushChoice36)


Sepi

Sepi
Previous (PushChoice359)
Next (PushChoice360)

Name
PushChoice36

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice36

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice359)
Next (PushChoice360)


Sepi

Sepi
Previous (PushChoice36)
Next (PushChoice361)

Name
PushChoice360

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice360

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice36)
Next (PushChoice361)


Sepi

Sepi
Previous (PushChoice360)
Next (PushChoice362)

Name
PushChoice361

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice361

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice360)
Next (PushChoice362)


Sepi

Sepi
Previous (PushChoice361)
Next (PushChoice363)

Name
PushChoice362

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice362

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice361)
Next (PushChoice363)


Sepi

Sepi
Previous (PushChoice362)
Next (PushChoice364)

Name
PushChoice363

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice363

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice362)
Next (PushChoice364)


Sepi

Sepi
Previous (PushChoice363)
Next (PushChoice365)

Name
PushChoice364

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice364

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice363)
Next (PushChoice365)


Sepi

Sepi
Previous (PushChoice364)
Next (PushChoice366)

Name
PushChoice365

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice365

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice364)
Next (PushChoice366)


Sepi

Sepi
Previous (PushChoice365)
Next (PushChoice367)

Name
PushChoice366

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice366

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice365)
Next (PushChoice367)


Sepi

Sepi
Previous (PushChoice366)
Next (PushChoice368)

Name
PushChoice367

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice367

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice366)
Next (PushChoice368)


Sepi

Sepi
Previous (PushChoice367)
Next (PushChoice369)

Name
PushChoice368

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice368

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice367)
Next (PushChoice369)


Sepi

Sepi
Previous (PushChoice368)
Next (PushChoice37)

Name
PushChoice369

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice369

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice368)
Next (PushChoice37)


Sepi

Sepi
Previous (PushChoice369)
Next (PushChoice370)

Name
PushChoice37

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice37

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice369)
Next (PushChoice370)


Sepi

Sepi
Previous (PushChoice37)
Next (PushChoice371)

Name
PushChoice370

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice370

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice37)
Next (PushChoice371)


Sepi

Sepi
Previous (PushChoice370)
Next (PushChoice372)

Name
PushChoice371

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice371

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice370)
Next (PushChoice372)


Sepi

Sepi
Previous (PushChoice371)
Next (PushChoice373)

Name
PushChoice372

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice372

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice371)
Next (PushChoice373)


Sepi

Sepi
Previous (PushChoice372)
Next (PushChoice374)

Name
PushChoice373

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice373

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice372)
Next (PushChoice374)


Sepi

Sepi
Previous (PushChoice373)
Next (PushChoice375)

Name
PushChoice374

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice374

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice373)
Next (PushChoice375)


Sepi

Sepi
Previous (PushChoice374)
Next (PushChoice376)

Name
PushChoice375

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice375

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice374)
Next (PushChoice376)


Sepi

Sepi
Previous (PushChoice375)
Next (PushChoice377)

Name
PushChoice376

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice376

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice375)
Next (PushChoice377)


Sepi

Sepi
Previous (PushChoice376)
Next (PushChoice378)

Name
PushChoice377

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice377

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice376)
Next (PushChoice378)


Sepi

Sepi
Previous (PushChoice377)
Next (PushChoice379)

Name
PushChoice378

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice378

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice377)
Next (PushChoice379)


Sepi

Sepi
Previous (PushChoice378)
Next (PushChoice38)

Name
PushChoice379

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice379

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice378)
Next (PushChoice38)


Sepi

Sepi
Previous (PushChoice379)
Next (PushChoice380)

Name
PushChoice38

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice38

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice379)
Next (PushChoice380)


Sepi

Sepi
Previous (PushChoice38)
Next (PushChoice381)

Name
PushChoice380

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice380

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice38)
Next (PushChoice381)


Sepi

Sepi
Previous (PushChoice380)
Next (PushChoice382)

Name
PushChoice381

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice381

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice380)
Next (PushChoice382)


Sepi

Sepi
Previous (PushChoice381)
Next (PushChoice383)

Name
PushChoice382

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice382

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice381)
Next (PushChoice383)


Sepi

Sepi
Previous (PushChoice382)
Next (PushChoice384)

Name
PushChoice383

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice383

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice382)
Next (PushChoice384)


Sepi

Sepi
Previous (PushChoice383)
Next (PushChoice385)

Name
PushChoice384

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice384

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice383)
Next (PushChoice385)


Sepi

Sepi
Previous (PushChoice384)
Next (PushChoice386)

Name
PushChoice385

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice385

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice384)
Next (PushChoice386)


Sepi

Sepi
Previous (PushChoice385)
Next (PushChoice387)

Name
PushChoice386

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice386

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice385)
Next (PushChoice387)


Sepi

Sepi
Previous (PushChoice386)
Next (PushChoice388)

Name
PushChoice387

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice387

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice386)
Next (PushChoice388)


Sepi

Sepi
Previous (PushChoice387)
Next (PushChoice389)

Name
PushChoice388

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice388

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice387)
Next (PushChoice389)


Sepi

Sepi
Previous (PushChoice388)
Next (PushChoice39)

Name
PushChoice389

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice389

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice388)
Next (PushChoice39)


Sepi

Sepi
Previous (PushChoice389)
Next (PushChoice390)

Name
PushChoice39

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice39

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice389)
Next (PushChoice390)


Sepi

Sepi
Previous (PushChoice39)
Next (PushChoice391)

Name
PushChoice390

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice390

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice39)
Next (PushChoice391)


Sepi

Sepi
Previous (PushChoice390)
Next (PushChoice392)

Name
PushChoice391

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice391

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice390)
Next (PushChoice392)


Sepi

Sepi
Previous (PushChoice391)
Next (PushChoice393)

Name
PushChoice392

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice392

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice391)
Next (PushChoice393)


Sepi

Sepi
Previous (PushChoice392)
Next (PushChoice394)

Name
PushChoice393

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice393

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice392)
Next (PushChoice394)


Sepi

Sepi
Previous (PushChoice393)
Next (PushChoice395)

Name
PushChoice394

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice394

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice393)
Next (PushChoice395)


Sepi

Sepi
Previous (PushChoice394)
Next (PushChoice396)

Name
PushChoice395

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice395

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice394)
Next (PushChoice396)


Sepi

Sepi
Previous (PushChoice395)
Next (PushChoice397)

Name
PushChoice396

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice396

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice395)
Next (PushChoice397)


Sepi

Sepi
Previous (PushChoice396)
Next (PushChoice398)

Name
PushChoice397

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice397

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice396)
Next (PushChoice398)


Sepi

Sepi
Previous (PushChoice397)
Next (PushChoice399)

Name
PushChoice398

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice398

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice397)
Next (PushChoice399)


Sepi

Sepi
Previous (PushChoice398)
Next (PushChoice4)

Name
PushChoice399

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice399

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice398)
Next (PushChoice4)


Sepi

Sepi
Previous (PushChoice399)
Next (PushChoice40)

Name
PushChoice4

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice4

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice399)
Next (PushChoice40)


Sepi

Sepi
Previous (PushChoice4)
Next (PushChoice400)

Name
PushChoice40

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice40

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice4)
Next (PushChoice400)


Sepi

Sepi
Previous (PushChoice40)
Next (PushChoice401)

Name
PushChoice400

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice400

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice40)
Next (PushChoice401)


Sepi

Sepi
Previous (PushChoice400)
Next (PushChoice402)

Name
PushChoice401

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice401

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice400)
Next (PushChoice402)


Sepi

Sepi
Previous (PushChoice401)
Next (PushChoice403)

Name
PushChoice402

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice402

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice401)
Next (PushChoice403)


Sepi

Sepi
Previous (PushChoice402)
Next (PushChoice404)

Name
PushChoice403

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice403

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice402)
Next (PushChoice404)


Sepi

Sepi
Previous (PushChoice403)
Next (PushChoice405)

Name
PushChoice404

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice404

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice403)
Next (PushChoice405)


Sepi

Sepi
Previous (PushChoice404)
Next (PushChoice406)

Name
PushChoice405

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice405

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice404)
Next (PushChoice406)


Sepi

Sepi
Previous (PushChoice405)
Next (PushChoice407)

Name
PushChoice406

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice406

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice405)
Next (PushChoice407)


Sepi

Sepi
Previous (PushChoice406)
Next (PushChoice408)

Name
PushChoice407

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice407

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice406)
Next (PushChoice408)


Sepi

Sepi
Previous (PushChoice407)
Next (PushChoice409)

Name
PushChoice408

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice408

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice407)
Next (PushChoice409)


Sepi

Sepi
Previous (PushChoice408)
Next (PushChoice41)

Name
PushChoice409

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice409

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice408)
Next (PushChoice41)


Sepi

Sepi
Previous (PushChoice409)
Next (PushChoice410)

Name
PushChoice41

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice41

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice409)
Next (PushChoice410)


Sepi

Sepi
Previous (PushChoice41)
Next (PushChoice411)

Name
PushChoice410

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice410

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice41)
Next (PushChoice411)


Sepi

Sepi
Previous (PushChoice410)
Next (PushChoice412)

Name
PushChoice411

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice411

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice410)
Next (PushChoice412)


Sepi

Sepi
Previous (PushChoice411)
Next (PushChoice413)

Name
PushChoice412

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice412

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice411)
Next (PushChoice413)


Sepi

Sepi
Previous (PushChoice412)
Next (PushChoice414)

Name
PushChoice413

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice413

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice412)
Next (PushChoice414)


Sepi

Sepi
Previous (PushChoice413)
Next (PushChoice415)

Name
PushChoice414

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice414

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice413)
Next (PushChoice415)


Sepi

Sepi
Previous (PushChoice414)
Next (PushChoice416)

Name
PushChoice415

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice415

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice414)
Next (PushChoice416)


Sepi

Sepi
Previous (PushChoice415)
Next (PushChoice417)

Name
PushChoice416

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice416

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice415)
Next (PushChoice417)


Sepi

Sepi
Previous (PushChoice416)
Next (PushChoice418)

Name
PushChoice417

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice417

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice416)
Next (PushChoice418)


Sepi

Sepi
Previous (PushChoice417)
Next (PushChoice419)

Name
PushChoice418

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice418

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice417)
Next (PushChoice419)


Sepi

Sepi
Previous (PushChoice418)
Next (PushChoice42)

Name
PushChoice419

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice419

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice418)
Next (PushChoice42)


Sepi

Sepi
Previous (PushChoice419)
Next (PushChoice420)

Name
PushChoice42

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice42

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice419)
Next (PushChoice420)


Sepi

Sepi
Previous (PushChoice42)
Next (PushChoice421)

Name
PushChoice420

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice420

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice42)
Next (PushChoice421)


Sepi

Sepi
Previous (PushChoice420)
Next (PushChoice422)

Name
PushChoice421

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice421

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice420)
Next (PushChoice422)


Sepi

Sepi
Previous (PushChoice421)
Next (PushChoice423)

Name
PushChoice422

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice422

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice421)
Next (PushChoice423)


Sepi

Sepi
Previous (PushChoice422)
Next (PushChoice424)

Name
PushChoice423

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice423

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice422)
Next (PushChoice424)


Sepi

Sepi
Previous (PushChoice423)
Next (PushChoice425)

Name
PushChoice424

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice424

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice423)
Next (PushChoice425)


Sepi

Sepi
Previous (PushChoice424)
Next (PushChoice426)

Name
PushChoice425

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice425

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice424)
Next (PushChoice426)


Sepi

Sepi
Previous (PushChoice425)
Next (PushChoice427)

Name
PushChoice426

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice426

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice425)
Next (PushChoice427)


Sepi

Sepi
Previous (PushChoice426)
Next (PushChoice428)

Name
PushChoice427

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice427

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice426)
Next (PushChoice428)


Sepi

Sepi
Previous (PushChoice427)
Next (PushChoice429)

Name
PushChoice428

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice428

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice427)
Next (PushChoice429)


Sepi

Sepi
Previous (PushChoice428)
Next (PushChoice43)

Name
PushChoice429

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice429

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice428)
Next (PushChoice43)


Sepi

Sepi
Previous (PushChoice429)
Next (PushChoice430)

Name
PushChoice43

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice43

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice429)
Next (PushChoice430)


Sepi

Sepi
Previous (PushChoice43)
Next (PushChoice431)

Name
PushChoice430

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice430

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice43)
Next (PushChoice431)


Sepi

Sepi
Previous (PushChoice430)
Next (PushChoice432)

Name
PushChoice431

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice431

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice430)
Next (PushChoice432)


Sepi

Sepi
Previous (PushChoice431)
Next (PushChoice433)

Name
PushChoice432

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice432

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice431)
Next (PushChoice433)


Sepi

Sepi
Previous (PushChoice432)
Next (PushChoice434)

Name
PushChoice433

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice433

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice432)
Next (PushChoice434)


Sepi

Sepi
Previous (PushChoice433)
Next (PushChoice435)

Name
PushChoice434

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice434

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice433)
Next (PushChoice435)


Sepi

Sepi
Previous (PushChoice434)
Next (PushChoice436)

Name
PushChoice435

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice435

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice434)
Next (PushChoice436)


Sepi

Sepi
Previous (PushChoice435)
Next (PushChoice437)

Name
PushChoice436

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice436

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice435)
Next (PushChoice437)


Sepi

Sepi
Previous (PushChoice436)
Next (PushChoice438)

Name
PushChoice437

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice437

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice436)
Next (PushChoice438)


Sepi

Sepi
Previous (PushChoice437)
Next (PushChoice439)

Name
PushChoice438

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice438

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice437)
Next (PushChoice439)


Sepi

Sepi
Previous (PushChoice438)
Next (PushChoice44)

Name
PushChoice439

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice439

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice438)
Next (PushChoice44)


Sepi

Sepi
Previous (PushChoice439)
Next (PushChoice440)

Name
PushChoice44

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice44

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice439)
Next (PushChoice440)


Sepi

Sepi
Previous (PushChoice44)
Next (PushChoice441)

Name
PushChoice440

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice440

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice44)
Next (PushChoice441)


Sepi

Sepi
Previous (PushChoice440)
Next (PushChoice442)

Name
PushChoice441

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice441

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice440)
Next (PushChoice442)


Sepi

Sepi
Previous (PushChoice441)
Next (PushChoice443)

Name
PushChoice442

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice442

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice441)
Next (PushChoice443)


Sepi

Sepi
Previous (PushChoice442)
Next (PushChoice444)

Name
PushChoice443

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice443

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice442)
Next (PushChoice444)


Sepi

Sepi
Previous (PushChoice443)
Next (PushChoice445)

Name
PushChoice444

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice444

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice443)
Next (PushChoice445)


Sepi

Sepi
Previous (PushChoice444)
Next (PushChoice446)

Name
PushChoice445

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice445

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice444)
Next (PushChoice446)


Sepi

Sepi
Previous (PushChoice445)
Next (PushChoice447)

Name
PushChoice446

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice446

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice445)
Next (PushChoice447)


Sepi

Sepi
Previous (PushChoice446)
Next (PushChoice448)

Name
PushChoice447

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice447

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice446)
Next (PushChoice448)


Sepi

Sepi
Previous (PushChoice447)
Next (PushChoice449)

Name
PushChoice448

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice448

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice447)
Next (PushChoice449)


Sepi

Sepi
Previous (PushChoice448)
Next (PushChoice45)

Name
PushChoice449

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice449

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice448)
Next (PushChoice45)


Sepi

Sepi
Previous (PushChoice449)
Next (PushChoice450)

Name
PushChoice45

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice45

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice449)
Next (PushChoice450)


Sepi

Sepi
Previous (PushChoice45)
Next (PushChoice451)

Name
PushChoice450

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice450

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice45)
Next (PushChoice451)


Sepi

Sepi
Previous (PushChoice450)
Next (PushChoice452)

Name
PushChoice451

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice451

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice450)
Next (PushChoice452)


Sepi

Sepi
Previous (PushChoice451)
Next (PushChoice453)

Name
PushChoice452

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice452

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice451)
Next (PushChoice453)


Sepi

Sepi
Previous (PushChoice452)
Next (PushChoice454)

Name
PushChoice453

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice453

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice452)
Next (PushChoice454)


Sepi

Sepi
Previous (PushChoice453)
Next (PushChoice455)

Name
PushChoice454

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice454

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice453)
Next (PushChoice455)


Sepi

Sepi
Previous (PushChoice454)
Next (PushChoice456)

Name
PushChoice455

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice455

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice454)
Next (PushChoice456)


Sepi

Sepi
Previous (PushChoice455)
Next (PushChoice457)

Name
PushChoice456

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice456

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice455)
Next (PushChoice457)


Sepi

Sepi
Previous (PushChoice456)
Next (PushChoice458)

Name
PushChoice457

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice457

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice456)
Next (PushChoice458)


Sepi

Sepi
Previous (PushChoice457)
Next (PushChoice459)

Name
PushChoice458

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice458

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice457)
Next (PushChoice459)


Sepi

Sepi
Previous (PushChoice458)
Next (PushChoice46)

Name
PushChoice459

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice459

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice458)
Next (PushChoice46)


Sepi

Sepi
Previous (PushChoice459)
Next (PushChoice460)

Name
PushChoice46

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice46

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice459)
Next (PushChoice460)


Sepi

Sepi
Previous (PushChoice46)
Next (PushChoice461)

Name
PushChoice460

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice460

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice46)
Next (PushChoice461)


Sepi

Sepi
Previous (PushChoice460)
Next (PushChoice462)

Name
PushChoice461

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice461

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice460)
Next (PushChoice462)


Sepi

Sepi
Previous (PushChoice461)
Next (PushChoice463)

Name
PushChoice462

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice462

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice461)
Next (PushChoice463)


Sepi

Sepi
Previous (PushChoice462)
Next (PushChoice464)

Name
PushChoice463

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice463

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice462)
Next (PushChoice464)


Sepi

Sepi
Previous (PushChoice463)
Next (PushChoice465)

Name
PushChoice464

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice464

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice463)
Next (PushChoice465)


Sepi

Sepi
Previous (PushChoice464)
Next (PushChoice466)

Name
PushChoice465

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice465

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice464)
Next (PushChoice466)


Sepi

Sepi
Previous (PushChoice465)
Next (PushChoice467)

Name
PushChoice466

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice466

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice465)
Next (PushChoice467)


Sepi

Sepi
Previous (PushChoice466)
Next (PushChoice468)

Name
PushChoice467

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice467

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice466)
Next (PushChoice468)


Sepi

Sepi
Previous (PushChoice467)
Next (PushChoice469)

Name
PushChoice468

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice468

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice467)
Next (PushChoice469)


Sepi

Sepi
Previous (PushChoice468)
Next (PushChoice47)

Name
PushChoice469

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice469

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice468)
Next (PushChoice47)


Sepi

Sepi
Previous (PushChoice469)
Next (PushChoice470)

Name
PushChoice47

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice47

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice469)
Next (PushChoice470)


Sepi

Sepi
Previous (PushChoice47)
Next (PushChoice471)

Name
PushChoice470

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice470

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice47)
Next (PushChoice471)


Sepi

Sepi
Previous (PushChoice470)
Next (PushChoice472)

Name
PushChoice471

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice471

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice470)
Next (PushChoice472)


Sepi

Sepi
Previous (PushChoice471)
Next (PushChoice473)

Name
PushChoice472

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice472

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice471)
Next (PushChoice473)


Sepi

Sepi
Previous (PushChoice472)
Next (PushChoice474)

Name
PushChoice473

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice473

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice472)
Next (PushChoice474)


Sepi

Sepi
Previous (PushChoice473)
Next (PushChoice475)

Name
PushChoice474

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice474

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice473)
Next (PushChoice475)


Sepi

Sepi
Previous (PushChoice474)
Next (PushChoice476)

Name
PushChoice475

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice475

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice474)
Next (PushChoice476)


Sepi

Sepi
Previous (PushChoice475)
Next (PushChoice477)

Name
PushChoice476

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice476

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice475)
Next (PushChoice477)


Sepi

Sepi
Previous (PushChoice476)
Next (PushChoice478)

Name
PushChoice477

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice477

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice476)
Next (PushChoice478)


Sepi

Sepi
Previous (PushChoice477)
Next (PushChoice479)

Name
PushChoice478

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice478

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice477)
Next (PushChoice479)


Sepi

Sepi
Previous (PushChoice478)
Next (PushChoice48)

Name
PushChoice479

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice479

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice478)
Next (PushChoice48)


Sepi

Sepi
Previous (PushChoice479)
Next (PushChoice480)

Name
PushChoice48

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice48

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice479)
Next (PushChoice480)


Sepi

Sepi
Previous (PushChoice48)
Next (PushChoice481)

Name
PushChoice480

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice480

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice48)
Next (PushChoice481)


Sepi

Sepi
Previous (PushChoice480)
Next (PushChoice482)

Name
PushChoice481

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice481

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice480)
Next (PushChoice482)


Sepi

Sepi
Previous (PushChoice481)
Next (PushChoice483)

Name
PushChoice482

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice482

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice481)
Next (PushChoice483)


Sepi

Sepi
Previous (PushChoice482)
Next (PushChoice484)

Name
PushChoice483

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice483

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice482)
Next (PushChoice484)


Sepi

Sepi
Previous (PushChoice483)
Next (PushChoice485)

Name
PushChoice484

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice484

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice483)
Next (PushChoice485)


Sepi

Sepi
Previous (PushChoice484)
Next (PushChoice49)

Name
PushChoice485

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice485

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice484)
Next (PushChoice49)


Sepi

Sepi
Previous (PushChoice485)
Next (PushChoice5)

Name
PushChoice49

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice49

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice485)
Next (PushChoice5)


Sepi

Sepi
Previous (PushChoice49)
Next (PushChoice50)

Name
PushChoice5

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice5

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice49)
Next (PushChoice50)


Sepi

Sepi
Previous (PushChoice5)
Next (PushChoice51)

Name
PushChoice50

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice50

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice5)
Next (PushChoice51)


Sepi

Sepi
Previous (PushChoice50)
Next (PushChoice52)

Name
PushChoice51

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice51

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice50)
Next (PushChoice52)


Sepi

Sepi
Previous (PushChoice51)
Next (PushChoice53)

Name
PushChoice52

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice52

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice51)
Next (PushChoice53)


Sepi

Sepi
Previous (PushChoice52)
Next (PushChoice54)

Name
PushChoice53

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice53

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice52)
Next (PushChoice54)


Sepi

Sepi
Previous (PushChoice53)
Next (PushChoice55)

Name
PushChoice54

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice54

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice53)
Next (PushChoice55)


Sepi

Sepi
Previous (PushChoice54)
Next (PushChoice56)

Name
PushChoice55

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice55

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice54)
Next (PushChoice56)


Sepi

Sepi
Previous (PushChoice55)
Next (PushChoice57)

Name
PushChoice56

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice56

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice55)
Next (PushChoice57)


Sepi

Sepi
Previous (PushChoice56)
Next (PushChoice58)

Name
PushChoice57

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice57

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice56)
Next (PushChoice58)


Sepi

Sepi
Previous (PushChoice57)
Next (PushChoice59)

Name
PushChoice58

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice58

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice57)
Next (PushChoice59)


Sepi

Sepi
Previous (PushChoice58)
Next (PushChoice6)

Name
PushChoice59

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice59

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice58)
Next (PushChoice6)


Sepi

Sepi
Previous (PushChoice59)
Next (PushChoice60)

Name
PushChoice6

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice6

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice59)
Next (PushChoice60)


Sepi

Sepi
Previous (PushChoice6)
Next (PushChoice61)

Name
PushChoice60

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice60

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice6)
Next (PushChoice61)


Sepi

Sepi
Previous (PushChoice60)
Next (PushChoice62)

Name
PushChoice61

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice61

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice60)
Next (PushChoice62)


Sepi

Sepi
Previous (PushChoice61)
Next (PushChoice63)

Name
PushChoice62

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice62

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice61)
Next (PushChoice63)


Sepi

Sepi
Previous (PushChoice62)
Next (PushChoice64)

Name
PushChoice63

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice63

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice62)
Next (PushChoice64)


Sepi

Sepi
Previous (PushChoice63)
Next (PushChoice65)

Name
PushChoice64

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice64

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice63)
Next (PushChoice65)


Sepi

Sepi
Previous (PushChoice64)
Next (PushChoice66)

Name
PushChoice65

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice65

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice64)
Next (PushChoice66)


Sepi

Sepi
Previous (PushChoice65)
Next (PushChoice67)

Name
PushChoice66

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice66

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice65)
Next (PushChoice67)


Sepi

Sepi
Previous (PushChoice66)
Next (PushChoice68)

Name
PushChoice67

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice67

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice66)
Next (PushChoice68)


Sepi

Sepi
Previous (PushChoice67)
Next (PushChoice69)

Name
PushChoice68

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice68

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice67)
Next (PushChoice69)


Sepi

Sepi
Previous (PushChoice68)
Next (PushChoice7)

Name
PushChoice69

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice69

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice68)
Next (PushChoice7)


Sepi

Sepi
Previous (PushChoice69)
Next (PushChoice70)

Name
PushChoice7

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice7

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice69)
Next (PushChoice70)


Sepi

Sepi
Previous (PushChoice7)
Next (PushChoice71)

Name
PushChoice70

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice70

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice7)
Next (PushChoice71)


Sepi

Sepi
Previous (PushChoice70)
Next (PushChoice72)

Name
PushChoice71

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice71

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice70)
Next (PushChoice72)


Sepi

Sepi
Previous (PushChoice71)
Next (PushChoice73)

Name
PushChoice72

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice72

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice71)
Next (PushChoice73)


Sepi

Sepi
Previous (PushChoice72)
Next (PushChoice74)

Name
PushChoice73

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice73

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice72)
Next (PushChoice74)


Sepi

Sepi
Previous (PushChoice73)
Next (PushChoice75)

Name
PushChoice74

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice74

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice73)
Next (PushChoice75)


Sepi

Sepi
Previous (PushChoice74)
Next (PushChoice76)

Name
PushChoice75

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice75

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice74)
Next (PushChoice76)


Sepi

Sepi
Previous (PushChoice75)
Next (PushChoice77)

Name
PushChoice76

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice76

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice75)
Next (PushChoice77)


Sepi

Sepi
Previous (PushChoice76)
Next (PushChoice78)

Name
PushChoice77

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice77

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice76)
Next (PushChoice78)


Sepi

Sepi
Previous (PushChoice77)
Next (PushChoice79)

Name
PushChoice78

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice78

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice77)
Next (PushChoice79)


Sepi

Sepi
Previous (PushChoice78)
Next (PushChoice8)

Name
PushChoice79

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice79

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice78)
Next (PushChoice8)


Sepi

Sepi
Previous (PushChoice79)
Next (PushChoice80)

Name
PushChoice8

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice8

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice79)
Next (PushChoice80)


Sepi

Sepi
Previous (PushChoice8)
Next (PushChoice81)

Name
PushChoice80

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice80

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice8)
Next (PushChoice81)


Sepi

Sepi
Previous (PushChoice80)
Next (PushChoice82)

Name
PushChoice81

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice81

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice80)
Next (PushChoice82)


Sepi

Sepi
Previous (PushChoice81)
Next (PushChoice83)

Name
PushChoice82

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice82

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice81)
Next (PushChoice83)


Sepi

Sepi
Previous (PushChoice82)
Next (PushChoice84)

Name
PushChoice83

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice83

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice82)
Next (PushChoice84)


Sepi

Sepi
Previous (PushChoice83)
Next (PushChoice85)

Name
PushChoice84

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice84

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice83)
Next (PushChoice85)


Sepi

Sepi
Previous (PushChoice84)
Next (PushChoice86)

Name
PushChoice85

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice85

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice84)
Next (PushChoice86)


Sepi

Sepi
Previous (PushChoice85)
Next (PushChoice87)

Name
PushChoice86

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice86

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice85)
Next (PushChoice87)


Sepi

Sepi
Previous (PushChoice86)
Next (PushChoice88)

Name
PushChoice87

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice87

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice86)
Next (PushChoice88)


Sepi

Sepi
Previous (PushChoice87)
Next (PushChoice89)

Name
PushChoice88

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice88

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice87)
Next (PushChoice89)


Sepi

Sepi
Previous (PushChoice88)
Next (PushChoice9)

Name
PushChoice89

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice89

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice88)
Next (PushChoice9)


Sepi

Sepi
Previous (PushChoice89)
Next (PushChoice90)

Name
PushChoice9

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice9

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice89)
Next (PushChoice90)


Sepi

Sepi
Previous (PushChoice9)
Next (PushChoice91)

Name
PushChoice90

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice90

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice9)
Next (PushChoice91)


Sepi

Sepi
Previous (PushChoice90)
Next (PushChoice92)

Name
PushChoice91

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice91

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice90)
Next (PushChoice92)


Sepi

Sepi
Previous (PushChoice91)
Next (PushChoice93)

Name
PushChoice92

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice92

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice91)
Next (PushChoice93)


Sepi

Sepi
Previous (PushChoice92)
Next (PushChoice94)

Name
PushChoice93

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice93

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice92)
Next (PushChoice94)


Sepi

Sepi
Previous (PushChoice93)
Next (PushChoice95)

Name
PushChoice94

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice94

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice93)
Next (PushChoice95)


Sepi

Sepi
Previous (PushChoice94)
Next (PushChoice96)

Name
PushChoice95

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice95

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice94)
Next (PushChoice96)


Sepi

Sepi
Previous (PushChoice95)
Next (PushChoice97)

Name
PushChoice96

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice96

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice95)
Next (PushChoice97)


Sepi

Sepi
Previous (PushChoice96)
Next (PushChoice98)

Name
PushChoice97

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice97

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice96)
Next (PushChoice98)


Sepi

Sepi
Previous (PushChoice97)
Next (PushChoice99)

Name
PushChoice98

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice98

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice97)
Next (PushChoice99)


Sepi

Sepi
Previous (PushChoice98)
Next

Name
PushChoice99

Parent
TSepiDelphiParser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PushChoice99

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushChoice98)
Next


Sepi

Sepi
Previous
Next (FirstNonTerminal)

Name
ChoiceCount

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ChoiceCount = 486

Sepi
Class Tree
Index
Previous
Next (FirstNonTerminal)


Sepi

Sepi
Previous (ChoiceCount)
Next (LastNonTerminal)

Name
FirstNonTerminal

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
FirstNonTerminal = 120

Sepi
Class Tree
Index
Previous (ChoiceCount)
Next (LastNonTerminal)


Sepi

Sepi
Previous (FirstNonTerminal)
Next (ntAbstractMarker)

Name
LastNonTerminal

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
LastNonTerminal = 413

Sepi
Class Tree
Index
Previous (FirstNonTerminal)
Next (ntAbstractMarker)


Sepi

Sepi
Previous (LastNonTerminal)
Next (ntAddressOfOp)

Name
ntAbstractMarker

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAbstractMarker = 277

Sepi
Class Tree
Index
Previous (LastNonTerminal)
Next (ntAddressOfOp)


Sepi

Sepi
Previous (ntAbstractMarker)
Next (ntAnsiStringCodePage)

Name
ntAddressOfOp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAddressOfOp = 184

Sepi
Class Tree
Index
Previous (ntAbstractMarker)
Next (ntAnsiStringCodePage)


Sepi

Sepi
Previous (ntAddressOfOp)
Next (ntArithmeticLogicOp)

Name
ntAnsiStringCodePage

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAnsiStringCodePage = 209

Sepi
Class Tree
Index
Previous (ntAddressOfOp)
Next (ntArithmeticLogicOp)


Sepi

Sepi
Previous (ntAnsiStringCodePage)
Next (ntArithmeticLogicOpNoEquals)

Name
ntArithmeticLogicOp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArithmeticLogicOp = 178

Sepi
Class Tree
Index
Previous (ntAnsiStringCodePage)
Next (ntArithmeticLogicOpNoEquals)


Sepi

Sepi
Previous (ntArithmeticLogicOp)
Next (ntArrayDesc)

Name
ntArithmeticLogicOpNoEquals

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArithmeticLogicOpNoEquals = 179

Sepi
Class Tree
Index
Previous (ntArithmeticLogicOp)
Next (ntArrayDesc)


Sepi

Sepi
Previous (ntArithmeticLogicOpNoEquals)
Next (ntArrayDims)

Name
ntArrayDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArrayDesc = 202

Sepi
Class Tree
Index
Previous (ntArithmeticLogicOpNoEquals)
Next (ntArrayDims)


Sepi

Sepi
Previous (ntArrayDesc)
Next (ntArrayIndices)

Name
ntArrayDims

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArrayDims = 204

Sepi
Class Tree
Index
Previous (ntArrayDesc)
Next (ntArrayIndices)


Sepi

Sepi
Previous (ntArrayDims)
Next (ntArrayInitialization)

Name
ntArrayIndices

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArrayIndices = 161

Sepi
Class Tree
Index
Previous (ntArrayDims)
Next (ntArrayInitialization)


Sepi

Sepi
Previous (ntArrayIndices)
Next (ntArrayInitializationExpression)

Name
ntArrayInitialization

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArrayInitialization = 135

Sepi
Class Tree
Index
Previous (ntArrayIndices)
Next (ntArrayInitializationExpression)


Sepi

Sepi
Previous (ntArrayInitialization)
Next (ntArrayRange)

Name
ntArrayInitializationExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArrayInitializationExpression = 134

Sepi
Class Tree
Index
Previous (ntArrayInitialization)
Next (ntArrayRange)


Sepi

Sepi
Previous (ntArrayInitializationExpression)
Next (ntAsOperation)

Name
ntArrayRange

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntArrayRange = 205

Sepi
Class Tree
Index
Previous (ntArrayInitializationExpression)
Next (ntAsOperation)


Sepi

Sepi
Previous (ntArrayRange)
Next (ntAssignmentOp)

Name
ntAsOperation

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAsOperation = 182

Sepi
Class Tree
Index
Previous (ntArrayRange)
Next (ntAssignmentOp)


Sepi

Sepi
Previous (ntAsOperation)
Next (ntAttribute)

Name
ntAssignmentOp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAssignmentOp = 338

Sepi
Class Tree
Index
Previous (ntAsOperation)
Next (ntAttribute)


Sepi

Sepi
Previous (ntAssignmentOp)
Next (ntAttributeParam)

Name
ntAttribute

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAttribute = 195

Sepi
Class Tree
Index
Previous (ntAssignmentOp)
Next (ntAttributeParam)


Sepi

Sepi
Previous (ntAttribute)
Next (ntAttributeParams)

Name
ntAttributeParam

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAttributeParam = 197

Sepi
Class Tree
Index
Previous (ntAttribute)
Next (ntAttributeParams)


Sepi

Sepi
Previous (ntAttributeParam)
Next (ntAttributes)

Name
ntAttributeParams

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAttributeParams = 196

Sepi
Class Tree
Index
Previous (ntAttributeParam)
Next (ntAttributes)


Sepi

Sepi
Previous (ntAttributeParams)
Next (ntAttrParamPart)

Name
ntAttributes

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAttributes = 194

Sepi
Class Tree
Index
Previous (ntAttributeParams)
Next (ntAttrParamPart)


Sepi

Sepi
Previous (ntAttributes)
Next (ntBeginEndBlock)

Name
ntAttrParamPart

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntAttrParamPart = 198

Sepi
Class Tree
Index
Previous (ntAttributes)
Next (ntBeginEndBlock)


Sepi

Sepi
Previous (ntAttrParamPart)
Next (ntBinaryOp)

Name
ntBeginEndBlock

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntBeginEndBlock = 313

Sepi
Class Tree
Index
Previous (ntAttrParamPart)
Next (ntBinaryOp)


Sepi

Sepi
Previous (ntBeginEndBlock)
Next (ntBinaryOpNoEquals)

Name
ntBinaryOp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntBinaryOp = 176

Sepi
Class Tree
Index
Previous (ntBeginEndBlock)
Next (ntBinaryOpNoEquals)


Sepi

Sepi
Previous (ntBinaryOp)
Next (ntCallingConvention)

Name
ntBinaryOpNoEquals

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntBinaryOpNoEquals = 177

Sepi
Class Tree
Index
Previous (ntBinaryOp)
Next (ntCallingConvention)


Sepi

Sepi
Previous (ntBinaryOpNoEquals)
Next (ntCaseLabels)

Name
ntCallingConvention

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCallingConvention = 275

Sepi
Class Tree
Index
Previous (ntBinaryOpNoEquals)
Next (ntCaseLabels)


Sepi

Sepi
Previous (ntCallingConvention)
Next (ntCaseOfClause)

Name
ntCaseLabels

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCaseLabels = 224

Sepi
Class Tree
Index
Previous (ntCallingConvention)
Next (ntCaseOfClause)


Sepi

Sepi
Previous (ntCaseLabels)
Next (ntCaseOfElseClause)

Name
ntCaseOfClause

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCaseOfClause = 317

Sepi
Class Tree
Index
Previous (ntCaseLabels)
Next (ntCaseOfElseClause)


Sepi

Sepi
Previous (ntCaseOfClause)
Next (ntCaseOfInstruction)

Name
ntCaseOfElseClause

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCaseOfElseClause = 318

Sepi
Class Tree
Index
Previous (ntCaseOfClause)
Next (ntCaseOfInstruction)


Sepi

Sepi
Previous (ntCaseOfElseClause)
Next (ntCaseOfSetValue)

Name
ntCaseOfInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCaseOfInstruction = 316

Sepi
Class Tree
Index
Previous (ntCaseOfElseClause)
Next (ntCaseOfSetValue)


Sepi

Sepi
Previous (ntCaseOfInstruction)
Next (ntClassClassMethodProp)

Name
ntCaseOfSetValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCaseOfSetValue = 174

Sepi
Class Tree
Index
Previous (ntCaseOfInstruction)
Next (ntClassClassMethodProp)


Sepi

Sepi
Previous (ntCaseOfSetValue)
Next (ntClassContents)

Name
ntClassClassMethodProp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassClassMethodProp = 247

Sepi
Class Tree
Index
Previous (ntCaseOfSetValue)
Next (ntClassContents)


Sepi

Sepi
Previous (ntClassClassMethodProp)
Next (ntClassDesc)

Name
ntClassContents

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassContents = 233

Sepi
Class Tree
Index
Previous (ntClassClassMethodProp)
Next (ntClassDesc)


Sepi

Sepi
Previous (ntClassContents)
Next (ntClassExDesc)

Name
ntClassDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassDesc = 231

Sepi
Class Tree
Index
Previous (ntClassContents)
Next (ntClassExDesc)


Sepi

Sepi
Previous (ntClassDesc)
Next (ntClassHeritage)

Name
ntClassExDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassExDesc = 232

Sepi
Class Tree
Index
Previous (ntClassDesc)
Next (ntClassHeritage)


Sepi

Sepi
Previous (ntClassExDesc)
Next (ntClassMemberList)

Name
ntClassHeritage

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassHeritage = 234

Sepi
Class Tree
Index
Previous (ntClassExDesc)
Next (ntClassMemberList)


Sepi

Sepi
Previous (ntClassHeritage)
Next (ntClassMemberLists)

Name
ntClassMemberList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassMemberList = 238

Sepi
Class Tree
Index
Previous (ntClassHeritage)
Next (ntClassMemberLists)


Sepi

Sepi
Previous (ntClassMemberList)
Next (ntClassMethodDecl)

Name
ntClassMemberLists

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassMemberLists = 235

Sepi
Class Tree
Index
Previous (ntClassMemberList)
Next (ntClassMethodDecl)


Sepi

Sepi
Previous (ntClassMemberLists)
Next (ntClassMethodImplKind)

Name
ntClassMethodDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassMethodDecl = 246

Sepi
Class Tree
Index
Previous (ntClassMemberLists)
Next (ntClassMethodImplKind)


Sepi

Sepi
Previous (ntClassMethodDecl)
Next (ntClassMethodProp)

Name
ntClassMethodImplKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassMethodImplKind = 301

Sepi
Class Tree
Index
Previous (ntClassMethodDecl)
Next (ntClassMethodProp)


Sepi

Sepi
Previous (ntClassMethodImplKind)
Next (ntCloneDesc)

Name
ntClassMethodProp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntClassMethodProp = 245

Sepi
Class Tree
Index
Previous (ntClassMethodImplKind)
Next (ntCloneDesc)


Sepi

Sepi
Previous (ntClassMethodProp)
Next (ntCommaIdentDeclList)

Name
ntCloneDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCloneDesc = 208

Sepi
Class Tree
Index
Previous (ntClassMethodProp)
Next (ntCommaIdentDeclList)


Sepi

Sepi
Previous (ntCloneDesc)
Next (ntCommaIdentList)

Name
ntCommaIdentDeclList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCommaIdentDeclList = 130

Sepi
Class Tree
Index
Previous (ntCloneDesc)
Next (ntCommaIdentList)


Sepi

Sepi
Previous (ntCommaIdentDeclList)
Next (ntComplexParamType)

Name
ntCommaIdentList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntCommaIdentList = 129

Sepi
Class Tree
Index
Previous (ntCommaIdentDeclList)
Next (ntComplexParamType)


Sepi

Sepi
Previous (ntCommaIdentList)
Next (ntConstDecl)

Name
ntComplexParamType

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntComplexParamType = 293

Sepi
Class Tree
Index
Previous (ntCommaIdentList)
Next (ntConstDecl)


Sepi

Sepi
Previous (ntComplexParamType)
Next (ntConstExpression)

Name
ntConstDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntConstDecl = 187

Sepi
Class Tree
Index
Previous (ntComplexParamType)
Next (ntConstExpression)


Sepi

Sepi
Previous (ntConstDecl)
Next (ntConstExpressionNoEquals)

Name
ntConstExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntConstExpression = 145

Sepi
Class Tree
Index
Previous (ntConstDecl)
Next (ntConstExpressionNoEquals)


Sepi

Sepi
Previous (ntConstExpression)
Next (ntConstKeyWord)

Name
ntConstExpressionNoEquals

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntConstExpressionNoEquals = 146

Sepi
Class Tree
Index
Previous (ntConstExpression)
Next (ntConstKeyWord)


Sepi

Sepi
Previous (ntConstExpressionNoEquals)
Next (ntConstOrType)

Name
ntConstKeyWord

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntConstKeyWord = 186

Sepi
Class Tree
Index
Previous (ntConstExpressionNoEquals)
Next (ntConstOrType)


Sepi

Sepi
Previous (ntConstKeyWord)
Next (ntConstOrTypeNoEquals)

Name
ntConstOrType

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntConstOrType = 147

Sepi
Class Tree
Index
Previous (ntConstKeyWord)
Next (ntConstOrTypeNoEquals)


Sepi

Sepi
Previous (ntConstOrType)
Next (ntConstSection)

Name
ntConstOrTypeNoEquals

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntConstOrTypeNoEquals = 148

Sepi
Class Tree
Index
Previous (ntConstOrType)
Next (ntConstSection)


Sepi

Sepi
Previous (ntConstOrTypeNoEquals)
Next (ntDefaultMarker)

Name
ntConstSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntConstSection = 185

Sepi
Class Tree
Index
Previous (ntConstOrTypeNoEquals)
Next (ntDefaultMarker)


Sepi

Sepi
Previous (ntConstSection)
Next (ntDereferenceOp)

Name
ntDefaultMarker

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntDefaultMarker = 264

Sepi
Class Tree
Index
Previous (ntConstSection)
Next (ntDereferenceOp)


Sepi

Sepi
Previous (ntDefaultMarker)
Next (ntDispInterfaceDesc)

Name
ntDereferenceOp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntDereferenceOp = 154

Sepi
Class Tree
Index
Previous (ntDefaultMarker)
Next (ntDispInterfaceDesc)


Sepi

Sepi
Previous (ntDereferenceOp)
Next (ntDispInterfaceHeritage)

Name
ntDispInterfaceDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntDispInterfaceDesc = 241

Sepi
Class Tree
Index
Previous (ntDereferenceOp)
Next (ntDispInterfaceHeritage)


Sepi

Sepi
Previous (ntDispInterfaceDesc)
Next (ntElseBranch)

Name
ntDispInterfaceHeritage

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntDispInterfaceHeritage = 242

Sepi
Class Tree
Index
Previous (ntDispInterfaceDesc)
Next (ntElseBranch)


Sepi

Sepi
Previous (ntDispInterfaceHeritage)
Next (ntEnumDesc)

Name
ntElseBranch

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntElseBranch = 315

Sepi
Class Tree
Index
Previous (ntDispInterfaceHeritage)
Next (ntEnumDesc)


Sepi

Sepi
Previous (ntElseBranch)
Next (ntEventDesc)

Name
ntEnumDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntEnumDesc = 212

Sepi
Class Tree
Index
Previous (ntElseBranch)
Next (ntEventDesc)


Sepi

Sepi
Previous (ntEnumDesc)
Next (ntEventIsOfObject)

Name
ntEventDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntEventDesc = 266

Sepi
Class Tree
Index
Previous (ntEnumDesc)
Next (ntEventIsOfObject)


Sepi

Sepi
Previous (ntEventDesc)
Next (ntEventModifiers)

Name
ntEventIsOfObject

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntEventIsOfObject = 268

Sepi
Class Tree
Index
Previous (ntEventDesc)
Next (ntEventModifiers)


Sepi

Sepi
Previous (ntEventIsOfObject)
Next (ntExceptClause)

Name
ntEventModifiers

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntEventModifiers = 267

Sepi
Class Tree
Index
Previous (ntEventIsOfObject)
Next (ntExceptClause)


Sepi

Sepi
Previous (ntEventModifiers)
Next (ntExceptionVarAndType)

Name
ntExceptClause

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntExceptClause = 328

Sepi
Class Tree
Index
Previous (ntEventModifiers)
Next (ntExceptionVarAndType)


Sepi

Sepi
Previous (ntExceptClause)
Next (ntExecutableExpression)

Name
ntExceptionVarAndType

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntExceptionVarAndType = 332

Sepi
Class Tree
Index
Previous (ntExceptClause)
Next (ntExecutableExpression)


Sepi

Sepi
Previous (ntExceptionVarAndType)
Next (ntExpression)

Name
ntExecutableExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntExecutableExpression = 337

Sepi
Class Tree
Index
Previous (ntExceptionVarAndType)
Next (ntExpression)


Sepi

Sepi
Previous (ntExecutableExpression)
Next (ntExpressionInstruction)

Name
ntExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntExpression = 143

Sepi
Class Tree
Index
Previous (ntExecutableExpression)
Next (ntExpressionInstruction)


Sepi

Sepi
Previous (ntExpression)
Next (ntExpressionNoEquals)

Name
ntExpressionInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntExpressionInstruction = 336

Sepi
Class Tree
Index
Previous (ntExpression)
Next (ntExpressionNoEquals)


Sepi

Sepi
Previous (ntExpressionInstruction)
Next (ntExprList)

Name
ntExpressionNoEquals

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntExpressionNoEquals = 144

Sepi
Class Tree
Index
Previous (ntExpressionInstruction)
Next (ntExprList)


Sepi

Sepi
Previous (ntExpressionNoEquals)
Next (ntFakeEnumDesc)

Name
ntExprList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntExprList = 162

Sepi
Class Tree
Index
Previous (ntExpressionNoEquals)
Next (ntFakeEnumDesc)


Sepi

Sepi
Previous (ntExprList)
Next (ntFakeEnumValue)

Name
ntFakeEnumDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntFakeEnumDesc = 213

Sepi
Class Tree
Index
Previous (ntExprList)
Next (ntFakeEnumValue)


Sepi

Sepi
Previous (ntFakeEnumDesc)
Next (ntField)

Name
ntFakeEnumValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntFakeEnumValue = 214

Sepi
Class Tree
Index
Previous (ntFakeEnumDesc)
Next (ntField)


Sepi

Sepi
Previous (ntFakeEnumValue)
Next (ntFieldSelection)

Name
ntField

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntField = 230

Sepi
Class Tree
Index
Previous (ntFakeEnumValue)
Next (ntFieldSelection)


Sepi

Sepi
Previous (ntField)
Next (ntFinallyClause)

Name
ntFieldSelection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntFieldSelection = 163

Sepi
Class Tree
Index
Previous (ntField)
Next (ntFinallyClause)


Sepi

Sepi
Previous (ntFieldSelection)
Next (ntFloatConst)

Name
ntFinallyClause

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntFinallyClause = 334

Sepi
Class Tree
Index
Previous (ntFieldSelection)
Next (ntFloatConst)


Sepi

Sepi
Previous (ntFinallyClause)
Next (ntForControlVar)

Name
ntFloatConst

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntFloatConst = 166

Sepi
Class Tree
Index
Previous (ntFinallyClause)
Next (ntForControlVar)


Sepi

Sepi
Previous (ntFloatConst)
Next (ntForDownTo)

Name
ntForControlVar

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntForControlVar = 322

Sepi
Class Tree
Index
Previous (ntFloatConst)
Next (ntForDownTo)


Sepi

Sepi
Previous (ntForControlVar)
Next (ntForInstruction)

Name
ntForDownTo

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntForDownTo = 325

Sepi
Class Tree
Index
Previous (ntForControlVar)
Next (ntForInstruction)


Sepi

Sepi
Previous (ntForDownTo)
Next (ntForTo)

Name
ntForInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntForInstruction = 321

Sepi
Class Tree
Index
Previous (ntForDownTo)
Next (ntForTo)


Sepi

Sepi
Previous (ntForInstruction)
Next (ntForToDownTo)

Name
ntForTo

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntForTo = 324

Sepi
Class Tree
Index
Previous (ntForInstruction)
Next (ntForToDownTo)


Sepi

Sepi
Previous (ntForTo)
Next (ntForwardMarker)

Name
ntForToDownTo

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntForToDownTo = 323

Sepi
Class Tree
Index
Previous (ntForTo)
Next (ntForwardMarker)


Sepi

Sepi
Previous (ntForToDownTo)
Next (ntForwardOrMethodBody)

Name
ntForwardMarker

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntForwardMarker = 305

Sepi
Class Tree
Index
Previous (ntForToDownTo)
Next (ntForwardOrMethodBody)


Sepi

Sepi
Previous (ntForwardMarker)
Next (ntGlobalVar)

Name
ntForwardOrMethodBody

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntForwardOrMethodBody = 302

Sepi
Class Tree
Index
Previous (ntForwardMarker)
Next (ntGlobalVar)


Sepi

Sepi
Previous (ntForwardOrMethodBody)
Next (ntGUIDInitialization)

Name
ntGlobalVar

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntGlobalVar = 190

Sepi
Class Tree
Index
Previous (ntForwardOrMethodBody)
Next (ntGUIDInitialization)


Sepi

Sepi
Previous (ntGlobalVar)
Next (ntGUIDInitializationExpression)

Name
ntGUIDInitialization

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntGUIDInitialization = 140

Sepi
Class Tree
Index
Previous (ntGlobalVar)
Next (ntGUIDInitializationExpression)


Sepi

Sepi
Previous (ntGUIDInitialization)
Next (ntIdentifier)

Name
ntGUIDInitializationExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntGUIDInitializationExpression = 139

Sepi
Class Tree
Index
Previous (ntGUIDInitialization)
Next (ntIdentifier)


Sepi

Sepi
Previous (ntGUIDInitializationExpression)
Next (ntIdentifierDecl)

Name
ntIdentifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIdentifier = 127

Sepi
Class Tree
Index
Previous (ntGUIDInitializationExpression)
Next (ntIdentifierDecl)


Sepi

Sepi
Previous (ntIdentifier)
Next (ntIdentifierSingleValue)

Name
ntIdentifierDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIdentifierDecl = 132

Sepi
Class Tree
Index
Previous (ntIdentifier)
Next (ntIdentifierSingleValue)


Sepi

Sepi
Previous (ntIdentifierDecl)
Next (ntIdentTestParam)

Name
ntIdentifierSingleValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIdentifierSingleValue = 168

Sepi
Class Tree
Index
Previous (ntIdentifierDecl)
Next (ntIdentTestParam)


Sepi

Sepi
Previous (ntIdentifierSingleValue)
Next (ntIfThenElseInstruction)

Name
ntIdentTestParam

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIdentTestParam = 160

Sepi
Class Tree
Index
Previous (ntIdentifierSingleValue)
Next (ntIfThenElseInstruction)


Sepi

Sepi
Previous (ntIdentTestParam)
Next (ntIgnoredMethodModifier)

Name
ntIfThenElseInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIfThenElseInstruction = 314

Sepi
Class Tree
Index
Previous (ntIdentTestParam)
Next (ntIgnoredMethodModifier)


Sepi

Sepi
Previous (ntIfThenElseInstruction)
Next (ntIgnoredPropertyModifier)

Name
ntIgnoredMethodModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIgnoredMethodModifier = 281

Sepi
Class Tree
Index
Previous (ntIfThenElseInstruction)
Next (ntIgnoredPropertyModifier)


Sepi

Sepi
Previous (ntIgnoredMethodModifier)
Next (ntIgnoredPropInfo)

Name
ntIgnoredPropertyModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIgnoredPropertyModifier = 265

Sepi
Class Tree
Index
Previous (ntIgnoredMethodModifier)
Next (ntIgnoredPropInfo)


Sepi

Sepi
Previous (ntIgnoredPropertyModifier)
Next (ntIgnoredRoutineModifier)

Name
ntIgnoredPropInfo

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIgnoredPropInfo = 262

Sepi
Class Tree
Index
Previous (ntIgnoredPropertyModifier)
Next (ntIgnoredRoutineModifier)


Sepi

Sepi
Previous (ntIgnoredPropInfo)
Next (ntImplementation)

Name
ntIgnoredRoutineModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIgnoredRoutineModifier = 280

Sepi
Class Tree
Index
Previous (ntIgnoredPropInfo)
Next (ntImplementation)


Sepi

Sepi
Previous (ntIgnoredRoutineModifier)
Next (ntImplSection)

Name
ntImplementation

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntImplementation = 123

Sepi
Class Tree
Index
Previous (ntIgnoredRoutineModifier)
Next (ntImplSection)


Sepi

Sepi
Previous (ntImplementation)
Next (ntInheritedExpression)

Name
ntImplSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntImplSection = 125

Sepi
Class Tree
Index
Previous (ntImplementation)
Next (ntInheritedExpression)


Sepi

Sepi
Previous (ntImplSection)
Next (ntInheritedSingleValue)

Name
ntInheritedExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInheritedExpression = 170

Sepi
Class Tree
Index
Previous (ntImplSection)
Next (ntInheritedSingleValue)


Sepi

Sepi
Previous (ntInheritedExpression)
Next (ntInitFinit)

Name
ntInheritedSingleValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInheritedSingleValue = 169

Sepi
Class Tree
Index
Previous (ntInheritedExpression)
Next (ntInitFinit)


Sepi

Sepi
Previous (ntInheritedSingleValue)
Next (ntInitializationExpression)

Name
ntInitFinit

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInitFinit = 126

Sepi
Class Tree
Index
Previous (ntInheritedSingleValue)
Next (ntInitializationExpression)


Sepi

Sepi
Previous (ntInitFinit)
Next (ntInMethodSection)

Name
ntInitializationExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInitializationExpression = 133

Sepi
Class Tree
Index
Previous (ntInitFinit)
Next (ntInMethodSection)


Sepi

Sepi
Previous (ntInitializationExpression)
Next (ntInnerConstDecl)

Name
ntInMethodSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInMethodSection = 304

Sepi
Class Tree
Index
Previous (ntInitializationExpression)
Next (ntInnerConstDecl)


Sepi

Sepi
Previous (ntInMethodSection)
Next (ntInnerGlobalVar)

Name
ntInnerConstDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInnerConstDecl = 188

Sepi
Class Tree
Index
Previous (ntInMethodSection)
Next (ntInnerGlobalVar)


Sepi

Sepi
Previous (ntInnerConstDecl)
Next (ntInnerParameters)

Name
ntInnerGlobalVar

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInnerGlobalVar = 191

Sepi
Class Tree
Index
Previous (ntInnerConstDecl)
Next (ntInnerParameters)


Sepi

Sepi
Previous (ntInnerGlobalVar)
Next (ntInnerWith)

Name
ntInnerParameters

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInnerParameters = 156

Sepi
Class Tree
Index
Previous (ntInnerGlobalVar)
Next (ntInnerWith)


Sepi

Sepi
Previous (ntInnerParameters)
Next (ntInOperation)

Name
ntInnerWith

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInnerWith = 341

Sepi
Class Tree
Index
Previous (ntInnerParameters)
Next (ntInOperation)


Sepi

Sepi
Previous (ntInnerWith)
Next (ntInPreProcessorExpression)

Name
ntInOperation

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInOperation = 180

Sepi
Class Tree
Index
Previous (ntInnerWith)
Next (ntInPreProcessorExpression)


Sepi

Sepi
Previous (ntInOperation)
Next (ntInstruction)

Name
ntInPreProcessorExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInPreProcessorExpression = 121

Sepi
Class Tree
Index
Previous (ntInOperation)
Next (ntInstruction)


Sepi

Sepi
Previous (ntInPreProcessorExpression)
Next (ntInstructionList)

Name
ntInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInstruction = 311

Sepi
Class Tree
Index
Previous (ntInPreProcessorExpression)
Next (ntInstructionList)


Sepi

Sepi
Previous (ntInstruction)
Next (ntIntegerConst)

Name
ntInstructionList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInstructionList = 310

Sepi
Class Tree
Index
Previous (ntInstruction)
Next (ntIntegerConst)


Sepi

Sepi
Previous (ntInstructionList)
Next (ntInterface)

Name
ntIntegerConst

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIntegerConst = 165

Sepi
Class Tree
Index
Previous (ntInstructionList)
Next (ntInterface)


Sepi

Sepi
Previous (ntIntegerConst)
Next (ntInterfaceDesc)

Name
ntInterface

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInterface = 122

Sepi
Class Tree
Index
Previous (ntIntegerConst)
Next (ntInterfaceDesc)


Sepi

Sepi
Previous (ntInterface)
Next (ntInterfaceGUID)

Name
ntInterfaceDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInterfaceDesc = 239

Sepi
Class Tree
Index
Previous (ntInterface)
Next (ntInterfaceGUID)


Sepi

Sepi
Previous (ntInterfaceDesc)
Next (ntInterfaceHeritage)

Name
ntInterfaceGUID

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInterfaceGUID = 243

Sepi
Class Tree
Index
Previous (ntInterfaceDesc)
Next (ntInterfaceHeritage)


Sepi

Sepi
Previous (ntInterfaceGUID)
Next (ntInterfaceMemberList)

Name
ntInterfaceHeritage

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInterfaceHeritage = 240

Sepi
Class Tree
Index
Previous (ntInterfaceGUID)
Next (ntInterfaceMemberList)


Sepi

Sepi
Previous (ntInterfaceHeritage)
Next (ntIntfMethodProp)

Name
ntInterfaceMemberList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntInterfaceMemberList = 244

Sepi
Class Tree
Index
Previous (ntInterfaceHeritage)
Next (ntIntfMethodProp)


Sepi

Sepi
Previous (ntInterfaceMemberList)
Next (ntIntfMethodRedirector)

Name
ntIntfMethodProp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIntfMethodProp = 248

Sepi
Class Tree
Index
Previous (ntInterfaceMemberList)
Next (ntIntfMethodRedirector)


Sepi

Sepi
Previous (ntIntfMethodProp)
Next (ntIntfMethodRedirKind)

Name
ntIntfMethodRedirector

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIntfMethodRedirector = 249

Sepi
Class Tree
Index
Previous (ntIntfMethodProp)
Next (ntIntfMethodRedirKind)


Sepi

Sepi
Previous (ntIntfMethodRedirector)
Next (ntIntfSection)

Name
ntIntfMethodRedirKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIntfMethodRedirKind = 250

Sepi
Class Tree
Index
Previous (ntIntfMethodRedirector)
Next (ntIntfSection)


Sepi

Sepi
Previous (ntIntfMethodRedirKind)
Next (ntIsOperation)

Name
ntIntfSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIntfSection = 124

Sepi
Class Tree
Index
Previous (ntIntfMethodRedirKind)
Next (ntIsOperation)


Sepi

Sepi
Previous (ntIntfSection)
Next (ntLocalVar)

Name
ntIsOperation

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntIsOperation = 181

Sepi
Class Tree
Index
Previous (ntIntfSection)
Next (ntLocalVar)


Sepi

Sepi
Previous (ntIsOperation)
Next (ntLocalVarSection)

Name
ntLocalVar

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntLocalVar = 309

Sepi
Class Tree
Index
Previous (ntIsOperation)
Next (ntLocalVarSection)


Sepi

Sepi
Previous (ntLocalVar)
Next (ntMethodBody)

Name
ntLocalVarSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntLocalVarSection = 308

Sepi
Class Tree
Index
Previous (ntLocalVar)
Next (ntMethodBody)


Sepi

Sepi
Previous (ntLocalVarSection)
Next (ntMethodDecl)

Name
ntMethodBody

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodBody = 303

Sepi
Class Tree
Index
Previous (ntLocalVarSection)
Next (ntMethodDecl)


Sepi

Sepi
Previous (ntMethodBody)
Next (ntMethodImpl)

Name
ntMethodDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodDecl = 251

Sepi
Class Tree
Index
Previous (ntMethodBody)
Next (ntMethodImpl)


Sepi

Sepi
Previous (ntMethodDecl)
Next (ntMethodImplHeader)

Name
ntMethodImpl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodImpl = 298

Sepi
Class Tree
Index
Previous (ntMethodDecl)
Next (ntMethodImplHeader)


Sepi

Sepi
Previous (ntMethodImpl)
Next (ntMethodImplKind)

Name
ntMethodImplHeader

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodImplHeader = 299

Sepi
Class Tree
Index
Previous (ntMethodImpl)
Next (ntMethodImplKind)


Sepi

Sepi
Previous (ntMethodImplHeader)
Next (ntMethodKind)

Name
ntMethodImplKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodImplKind = 300

Sepi
Class Tree
Index
Previous (ntMethodImplHeader)
Next (ntMethodKind)


Sepi

Sepi
Previous (ntMethodImplKind)
Next (ntMethodLinkKind)

Name
ntMethodKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodKind = 271

Sepi
Class Tree
Index
Previous (ntMethodImplKind)
Next (ntMethodLinkKind)


Sepi

Sepi
Previous (ntMethodKind)
Next (ntMethodModifier)

Name
ntMethodLinkKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodLinkKind = 276

Sepi
Class Tree
Index
Previous (ntMethodKind)
Next (ntMethodModifier)


Sepi

Sepi
Previous (ntMethodLinkKind)
Next (ntMethodNameDeclaration)

Name
ntMethodModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodModifier = 274

Sepi
Class Tree
Index
Previous (ntMethodLinkKind)
Next (ntMethodNameDeclaration)


Sepi

Sepi
Previous (ntMethodModifier)
Next (ntMethodParamList)

Name
ntMethodNameDeclaration

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodNameDeclaration = 272

Sepi
Class Tree
Index
Previous (ntMethodModifier)
Next (ntMethodParamList)


Sepi

Sepi
Previous (ntMethodNameDeclaration)
Next (ntMethodSignature)

Name
ntMethodParamList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodParamList = 284

Sepi
Class Tree
Index
Previous (ntMethodNameDeclaration)
Next (ntMethodSignature)


Sepi

Sepi
Previous (ntMethodParamList)
Next (ntMultiOn)

Name
ntMethodSignature

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMethodSignature = 282

Sepi
Class Tree
Index
Previous (ntMethodParamList)
Next (ntMultiOn)


Sepi

Sepi
Previous (ntMethodSignature)
Next (ntMultiOnElseClause)

Name
ntMultiOn

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMultiOn = 330

Sepi
Class Tree
Index
Previous (ntMethodSignature)
Next (ntMultiOnElseClause)


Sepi

Sepi
Previous (ntMultiOn)
Next (ntNextExceptClause)

Name
ntMultiOnElseClause

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntMultiOnElseClause = 333

Sepi
Class Tree
Index
Previous (ntMultiOn)
Next (ntNextExceptClause)


Sepi

Sepi
Previous (ntMultiOnElseClause)
Next (ntNextExpr)

Name
ntNextExceptClause

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntNextExceptClause = 329

Sepi
Class Tree
Index
Previous (ntMultiOnElseClause)
Next (ntNextExpr)


Sepi

Sepi
Previous (ntNextExceptClause)
Next (ntNextRecordCaseContents)

Name
ntNextExpr

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntNextExpr = 152

Sepi
Class Tree
Index
Previous (ntNextExceptClause)
Next (ntNextRecordCaseContents)


Sepi

Sepi
Previous (ntNextExpr)
Next (ntNextRecordCaseContentsEx)

Name
ntNextRecordCaseContents

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntNextRecordCaseContents = 226

Sepi
Class Tree
Index
Previous (ntNextExpr)
Next (ntNextRecordCaseContentsEx)


Sepi

Sepi
Previous (ntNextRecordCaseContents)
Next (ntNextTryInstruction)

Name
ntNextRecordCaseContentsEx

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntNextRecordCaseContentsEx = 227

Sepi
Class Tree
Index
Previous (ntNextRecordCaseContents)
Next (ntNextTryInstruction)


Sepi

Sepi
Previous (ntNextRecordCaseContentsEx)
Next (ntNilValue)

Name
ntNextTryInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntNextTryInstruction = 327

Sepi
Class Tree
Index
Previous (ntNextRecordCaseContentsEx)
Next (ntNilValue)


Sepi

Sepi
Previous (ntNextTryInstruction)
Next (ntNoInstruction)

Name
ntNilValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntNilValue = 172

Sepi
Class Tree
Index
Previous (ntNextTryInstruction)
Next (ntNoInstruction)


Sepi

Sepi
Previous (ntNilValue)
Next (ntOnClause)

Name
ntNoInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntNoInstruction = 312

Sepi
Class Tree
Index
Previous (ntNilValue)
Next (ntOnClause)


Sepi

Sepi
Previous (ntNoInstruction)
Next (ntOtherInitialization)

Name
ntOnClause

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntOnClause = 331

Sepi
Class Tree
Index
Previous (ntNoInstruction)
Next (ntOtherInitialization)


Sepi

Sepi
Previous (ntOnClause)
Next (ntOtherInitializationExpression)

Name
ntOtherInitialization

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntOtherInitialization = 142

Sepi
Class Tree
Index
Previous (ntOnClause)
Next (ntOtherInitializationExpression)


Sepi

Sepi
Previous (ntOtherInitialization)
Next (ntOverloadMarker)

Name
ntOtherInitializationExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntOtherInitializationExpression = 141

Sepi
Class Tree
Index
Previous (ntOtherInitialization)
Next (ntOverloadMarker)


Sepi

Sepi
Previous (ntOtherInitializationExpression)
Next (ntPackedArrayDesc)

Name
ntOverloadMarker

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntOverloadMarker = 278

Sepi
Class Tree
Index
Previous (ntOtherInitializationExpression)
Next (ntPackedArrayDesc)


Sepi

Sepi
Previous (ntOverloadMarker)
Next (ntPackedDesc)

Name
ntPackedArrayDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPackedArrayDesc = 203

Sepi
Class Tree
Index
Previous (ntOverloadMarker)
Next (ntPackedDesc)


Sepi

Sepi
Previous (ntPackedArrayDesc)
Next (ntPackedRecordDesc)

Name
ntPackedDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPackedDesc = 201

Sepi
Class Tree
Index
Previous (ntPackedArrayDesc)
Next (ntPackedRecordDesc)


Sepi

Sepi
Previous (ntPackedDesc)
Next (ntParam)

Name
ntPackedRecordDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPackedRecordDesc = 219

Sepi
Class Tree
Index
Previous (ntPackedDesc)
Next (ntParam)


Sepi

Sepi
Previous (ntPackedRecordDesc)
Next (ntParamArrayType)

Name
ntParam

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParam = 288

Sepi
Class Tree
Index
Previous (ntPackedRecordDesc)
Next (ntParamArrayType)


Sepi

Sepi
Previous (ntParam)
Next (ntParamDefault)

Name
ntParamArrayType

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamArrayType = 295

Sepi
Class Tree
Index
Previous (ntParam)
Next (ntParamDefault)


Sepi

Sepi
Previous (ntParamArrayType)
Next (ntParameter)

Name
ntParamDefault

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamDefault = 297

Sepi
Class Tree
Index
Previous (ntParamArrayType)
Next (ntParameter)


Sepi

Sepi
Previous (ntParamDefault)
Next (ntParameters)

Name
ntParameter

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParameter = 157

Sepi
Class Tree
Index
Previous (ntParamDefault)
Next (ntParameters)


Sepi

Sepi
Previous (ntParameter)
Next (ntParamIsArray)

Name
ntParameters

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParameters = 155

Sepi
Class Tree
Index
Previous (ntParameter)
Next (ntParamIsArray)


Sepi

Sepi
Previous (ntParameters)
Next (ntParamKind)

Name
ntParamIsArray

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamIsArray = 294

Sepi
Class Tree
Index
Previous (ntParameters)
Next (ntParamKind)


Sepi

Sepi
Previous (ntParamIsArray)
Next (ntParamList)

Name
ntParamKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamKind = 289

Sepi
Class Tree
Index
Previous (ntParamIsArray)
Next (ntParamList)


Sepi

Sepi
Previous (ntParamKind)
Next (ntParamName)

Name
ntParamList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamList = 285

Sepi
Class Tree
Index
Previous (ntParamKind)
Next (ntParamName)


Sepi

Sepi
Previous (ntParamList)
Next (ntParamNameList)

Name
ntParamName

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamName = 291

Sepi
Class Tree
Index
Previous (ntParamList)
Next (ntParamNameList)


Sepi

Sepi
Previous (ntParamName)
Next (ntParamType)

Name
ntParamNameList

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamNameList = 290

Sepi
Class Tree
Index
Previous (ntParamName)
Next (ntParamType)


Sepi

Sepi
Previous (ntParamNameList)
Next (ntParamTypeAndDefault)

Name
ntParamType

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamType = 296

Sepi
Class Tree
Index
Previous (ntParamNameList)
Next (ntParamTypeAndDefault)


Sepi

Sepi
Previous (ntParamType)
Next (ntParenthesizedExpr)

Name
ntParamTypeAndDefault

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParamTypeAndDefault = 292

Sepi
Class Tree
Index
Previous (ntParamType)
Next (ntParenthesizedExpr)


Sepi

Sepi
Previous (ntParamTypeAndDefault)
Next (ntPointerDesc)

Name
ntParenthesizedExpr

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntParenthesizedExpr = 151

Sepi
Class Tree
Index
Previous (ntParamTypeAndDefault)
Next (ntPointerDesc)


Sepi

Sepi
Previous (ntParenthesizedExpr)
Next (ntPriv0)

Name
ntPointerDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPointerDesc = 217

Sepi
Class Tree
Index
Previous (ntParenthesizedExpr)
Next (ntPriv0)


Sepi

Sepi
Previous (ntPointerDesc)
Next (ntPriv1)

Name
ntPriv0

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv0 = 342

Sepi
Class Tree
Index
Previous (ntPointerDesc)
Next (ntPriv1)


Sepi

Sepi
Previous (ntPriv0)
Next (ntPriv10)

Name
ntPriv1

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv1 = 343

Sepi
Class Tree
Index
Previous (ntPriv0)
Next (ntPriv10)


Sepi

Sepi
Previous (ntPriv1)
Next (ntPriv11)

Name
ntPriv10

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv10 = 352

Sepi
Class Tree
Index
Previous (ntPriv1)
Next (ntPriv11)


Sepi

Sepi
Previous (ntPriv10)
Next (ntPriv12)

Name
ntPriv11

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv11 = 353

Sepi
Class Tree
Index
Previous (ntPriv10)
Next (ntPriv12)


Sepi

Sepi
Previous (ntPriv11)
Next (ntPriv13)

Name
ntPriv12

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv12 = 354

Sepi
Class Tree
Index
Previous (ntPriv11)
Next (ntPriv13)


Sepi

Sepi
Previous (ntPriv12)
Next (ntPriv14)

Name
ntPriv13

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv13 = 355

Sepi
Class Tree
Index
Previous (ntPriv12)
Next (ntPriv14)


Sepi

Sepi
Previous (ntPriv13)
Next (ntPriv15)

Name
ntPriv14

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv14 = 356

Sepi
Class Tree
Index
Previous (ntPriv13)
Next (ntPriv15)


Sepi

Sepi
Previous (ntPriv14)
Next (ntPriv16)

Name
ntPriv15

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv15 = 357

Sepi
Class Tree
Index
Previous (ntPriv14)
Next (ntPriv16)


Sepi

Sepi
Previous (ntPriv15)
Next (ntPriv17)

Name
ntPriv16

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv16 = 358

Sepi
Class Tree
Index
Previous (ntPriv15)
Next (ntPriv17)


Sepi

Sepi
Previous (ntPriv16)
Next (ntPriv18)

Name
ntPriv17

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv17 = 359

Sepi
Class Tree
Index
Previous (ntPriv16)
Next (ntPriv18)


Sepi

Sepi
Previous (ntPriv17)
Next (ntPriv19)

Name
ntPriv18

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv18 = 360

Sepi
Class Tree
Index
Previous (ntPriv17)
Next (ntPriv19)


Sepi

Sepi
Previous (ntPriv18)
Next (ntPriv2)

Name
ntPriv19

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv19 = 361

Sepi
Class Tree
Index
Previous (ntPriv18)
Next (ntPriv2)


Sepi

Sepi
Previous (ntPriv19)
Next (ntPriv20)

Name
ntPriv2

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv2 = 344

Sepi
Class Tree
Index
Previous (ntPriv19)
Next (ntPriv20)


Sepi

Sepi
Previous (ntPriv2)
Next (ntPriv21)

Name
ntPriv20

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv20 = 362

Sepi
Class Tree
Index
Previous (ntPriv2)
Next (ntPriv21)


Sepi

Sepi
Previous (ntPriv20)
Next (ntPriv22)

Name
ntPriv21

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv21 = 363

Sepi
Class Tree
Index
Previous (ntPriv20)
Next (ntPriv22)


Sepi

Sepi
Previous (ntPriv21)
Next (ntPriv23)

Name
ntPriv22

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv22 = 364

Sepi
Class Tree
Index
Previous (ntPriv21)
Next (ntPriv23)


Sepi

Sepi
Previous (ntPriv22)
Next (ntPriv24)

Name
ntPriv23

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv23 = 365

Sepi
Class Tree
Index
Previous (ntPriv22)
Next (ntPriv24)


Sepi

Sepi
Previous (ntPriv23)
Next (ntPriv25)

Name
ntPriv24

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv24 = 366

Sepi
Class Tree
Index
Previous (ntPriv23)
Next (ntPriv25)


Sepi

Sepi
Previous (ntPriv24)
Next (ntPriv26)

Name
ntPriv25

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv25 = 367

Sepi
Class Tree
Index
Previous (ntPriv24)
Next (ntPriv26)


Sepi

Sepi
Previous (ntPriv25)
Next (ntPriv27)

Name
ntPriv26

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv26 = 368

Sepi
Class Tree
Index
Previous (ntPriv25)
Next (ntPriv27)


Sepi

Sepi
Previous (ntPriv26)
Next (ntPriv28)

Name
ntPriv27

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv27 = 369

Sepi
Class Tree
Index
Previous (ntPriv26)
Next (ntPriv28)


Sepi

Sepi
Previous (ntPriv27)
Next (ntPriv29)

Name
ntPriv28

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv28 = 370

Sepi
Class Tree
Index
Previous (ntPriv27)
Next (ntPriv29)


Sepi

Sepi
Previous (ntPriv28)
Next (ntPriv3)

Name
ntPriv29

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv29 = 371

Sepi
Class Tree
Index
Previous (ntPriv28)
Next (ntPriv3)


Sepi

Sepi
Previous (ntPriv29)
Next (ntPriv30)

Name
ntPriv3

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv3 = 345

Sepi
Class Tree
Index
Previous (ntPriv29)
Next (ntPriv30)


Sepi

Sepi
Previous (ntPriv3)
Next (ntPriv31)

Name
ntPriv30

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv30 = 372

Sepi
Class Tree
Index
Previous (ntPriv3)
Next (ntPriv31)


Sepi

Sepi
Previous (ntPriv30)
Next (ntPriv32)

Name
ntPriv31

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv31 = 373

Sepi
Class Tree
Index
Previous (ntPriv30)
Next (ntPriv32)


Sepi

Sepi
Previous (ntPriv31)
Next (ntPriv33)

Name
ntPriv32

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv32 = 374

Sepi
Class Tree
Index
Previous (ntPriv31)
Next (ntPriv33)


Sepi

Sepi
Previous (ntPriv32)
Next (ntPriv34)

Name
ntPriv33

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv33 = 375

Sepi
Class Tree
Index
Previous (ntPriv32)
Next (ntPriv34)


Sepi

Sepi
Previous (ntPriv33)
Next (ntPriv35)

Name
ntPriv34

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv34 = 376

Sepi
Class Tree
Index
Previous (ntPriv33)
Next (ntPriv35)


Sepi

Sepi
Previous (ntPriv34)
Next (ntPriv36)

Name
ntPriv35

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv35 = 377

Sepi
Class Tree
Index
Previous (ntPriv34)
Next (ntPriv36)


Sepi

Sepi
Previous (ntPriv35)
Next (ntPriv37)

Name
ntPriv36

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv36 = 378

Sepi
Class Tree
Index
Previous (ntPriv35)
Next (ntPriv37)


Sepi

Sepi
Previous (ntPriv36)
Next (ntPriv38)

Name
ntPriv37

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv37 = 379

Sepi
Class Tree
Index
Previous (ntPriv36)
Next (ntPriv38)


Sepi

Sepi
Previous (ntPriv37)
Next (ntPriv39)

Name
ntPriv38

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv38 = 380

Sepi
Class Tree
Index
Previous (ntPriv37)
Next (ntPriv39)


Sepi

Sepi
Previous (ntPriv38)
Next (ntPriv4)

Name
ntPriv39

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv39 = 381

Sepi
Class Tree
Index
Previous (ntPriv38)
Next (ntPriv4)


Sepi

Sepi
Previous (ntPriv39)
Next (ntPriv40)

Name
ntPriv4

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv4 = 346

Sepi
Class Tree
Index
Previous (ntPriv39)
Next (ntPriv40)


Sepi

Sepi
Previous (ntPriv4)
Next (ntPriv41)

Name
ntPriv40

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv40 = 382

Sepi
Class Tree
Index
Previous (ntPriv4)
Next (ntPriv41)


Sepi

Sepi
Previous (ntPriv40)
Next (ntPriv42)

Name
ntPriv41

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv41 = 383

Sepi
Class Tree
Index
Previous (ntPriv40)
Next (ntPriv42)


Sepi

Sepi
Previous (ntPriv41)
Next (ntPriv43)

Name
ntPriv42

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv42 = 384

Sepi
Class Tree
Index
Previous (ntPriv41)
Next (ntPriv43)


Sepi

Sepi
Previous (ntPriv42)
Next (ntPriv44)

Name
ntPriv43

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv43 = 385

Sepi
Class Tree
Index
Previous (ntPriv42)
Next (ntPriv44)


Sepi

Sepi
Previous (ntPriv43)
Next (ntPriv45)

Name
ntPriv44

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv44 = 386

Sepi
Class Tree
Index
Previous (ntPriv43)
Next (ntPriv45)


Sepi

Sepi
Previous (ntPriv44)
Next (ntPriv46)

Name
ntPriv45

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv45 = 387

Sepi
Class Tree
Index
Previous (ntPriv44)
Next (ntPriv46)


Sepi

Sepi
Previous (ntPriv45)
Next (ntPriv47)

Name
ntPriv46

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv46 = 388

Sepi
Class Tree
Index
Previous (ntPriv45)
Next (ntPriv47)


Sepi

Sepi
Previous (ntPriv46)
Next (ntPriv48)

Name
ntPriv47

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv47 = 389

Sepi
Class Tree
Index
Previous (ntPriv46)
Next (ntPriv48)


Sepi

Sepi
Previous (ntPriv47)
Next (ntPriv49)

Name
ntPriv48

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv48 = 390

Sepi
Class Tree
Index
Previous (ntPriv47)
Next (ntPriv49)


Sepi

Sepi
Previous (ntPriv48)
Next (ntPriv5)

Name
ntPriv49

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv49 = 391

Sepi
Class Tree
Index
Previous (ntPriv48)
Next (ntPriv5)


Sepi

Sepi
Previous (ntPriv49)
Next (ntPriv50)

Name
ntPriv5

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv5 = 347

Sepi
Class Tree
Index
Previous (ntPriv49)
Next (ntPriv50)


Sepi

Sepi
Previous (ntPriv5)
Next (ntPriv51)

Name
ntPriv50

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv50 = 392

Sepi
Class Tree
Index
Previous (ntPriv5)
Next (ntPriv51)


Sepi

Sepi
Previous (ntPriv50)
Next (ntPriv52)

Name
ntPriv51

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv51 = 393

Sepi
Class Tree
Index
Previous (ntPriv50)
Next (ntPriv52)


Sepi

Sepi
Previous (ntPriv51)
Next (ntPriv53)

Name
ntPriv52

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv52 = 394

Sepi
Class Tree
Index
Previous (ntPriv51)
Next (ntPriv53)


Sepi

Sepi
Previous (ntPriv52)
Next (ntPriv54)

Name
ntPriv53

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv53 = 395

Sepi
Class Tree
Index
Previous (ntPriv52)
Next (ntPriv54)


Sepi

Sepi
Previous (ntPriv53)
Next (ntPriv55)

Name
ntPriv54

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv54 = 396

Sepi
Class Tree
Index
Previous (ntPriv53)
Next (ntPriv55)


Sepi

Sepi
Previous (ntPriv54)
Next (ntPriv56)

Name
ntPriv55

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv55 = 397

Sepi
Class Tree
Index
Previous (ntPriv54)
Next (ntPriv56)


Sepi

Sepi
Previous (ntPriv55)
Next (ntPriv57)

Name
ntPriv56

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv56 = 398

Sepi
Class Tree
Index
Previous (ntPriv55)
Next (ntPriv57)


Sepi

Sepi
Previous (ntPriv56)
Next (ntPriv58)

Name
ntPriv57

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv57 = 399

Sepi
Class Tree
Index
Previous (ntPriv56)
Next (ntPriv58)


Sepi

Sepi
Previous (ntPriv57)
Next (ntPriv59)

Name
ntPriv58

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv58 = 400

Sepi
Class Tree
Index
Previous (ntPriv57)
Next (ntPriv59)


Sepi

Sepi
Previous (ntPriv58)
Next (ntPriv6)

Name
ntPriv59

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv59 = 401

Sepi
Class Tree
Index
Previous (ntPriv58)
Next (ntPriv6)


Sepi

Sepi
Previous (ntPriv59)
Next (ntPriv60)

Name
ntPriv6

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv6 = 348

Sepi
Class Tree
Index
Previous (ntPriv59)
Next (ntPriv60)


Sepi

Sepi
Previous (ntPriv6)
Next (ntPriv61)

Name
ntPriv60

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv60 = 402

Sepi
Class Tree
Index
Previous (ntPriv6)
Next (ntPriv61)


Sepi

Sepi
Previous (ntPriv60)
Next (ntPriv62)

Name
ntPriv61

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv61 = 403

Sepi
Class Tree
Index
Previous (ntPriv60)
Next (ntPriv62)


Sepi

Sepi
Previous (ntPriv61)
Next (ntPriv63)

Name
ntPriv62

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv62 = 404

Sepi
Class Tree
Index
Previous (ntPriv61)
Next (ntPriv63)


Sepi

Sepi
Previous (ntPriv62)
Next (ntPriv64)

Name
ntPriv63

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv63 = 405

Sepi
Class Tree
Index
Previous (ntPriv62)
Next (ntPriv64)


Sepi

Sepi
Previous (ntPriv63)
Next (ntPriv65)

Name
ntPriv64

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv64 = 406

Sepi
Class Tree
Index
Previous (ntPriv63)
Next (ntPriv65)


Sepi

Sepi
Previous (ntPriv64)
Next (ntPriv66)

Name
ntPriv65

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv65 = 407

Sepi
Class Tree
Index
Previous (ntPriv64)
Next (ntPriv66)


Sepi

Sepi
Previous (ntPriv65)
Next (ntPriv67)

Name
ntPriv66

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv66 = 408

Sepi
Class Tree
Index
Previous (ntPriv65)
Next (ntPriv67)


Sepi

Sepi
Previous (ntPriv66)
Next (ntPriv68)

Name
ntPriv67

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv67 = 409

Sepi
Class Tree
Index
Previous (ntPriv66)
Next (ntPriv68)


Sepi

Sepi
Previous (ntPriv67)
Next (ntPriv69)

Name
ntPriv68

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv68 = 410

Sepi
Class Tree
Index
Previous (ntPriv67)
Next (ntPriv69)


Sepi

Sepi
Previous (ntPriv68)
Next (ntPriv7)

Name
ntPriv69

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv69 = 411

Sepi
Class Tree
Index
Previous (ntPriv68)
Next (ntPriv7)


Sepi

Sepi
Previous (ntPriv69)
Next (ntPriv70)

Name
ntPriv7

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv7 = 349

Sepi
Class Tree
Index
Previous (ntPriv69)
Next (ntPriv70)


Sepi

Sepi
Previous (ntPriv7)
Next (ntPriv71)

Name
ntPriv70

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv70 = 412

Sepi
Class Tree
Index
Previous (ntPriv7)
Next (ntPriv71)


Sepi

Sepi
Previous (ntPriv70)
Next (ntPriv8)

Name
ntPriv71

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv71 = 413

Sepi
Class Tree
Index
Previous (ntPriv70)
Next (ntPriv8)


Sepi

Sepi
Previous (ntPriv71)
Next (ntPriv9)

Name
ntPriv8

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv8 = 350

Sepi
Class Tree
Index
Previous (ntPriv71)
Next (ntPriv9)


Sepi

Sepi
Previous (ntPriv8)
Next (ntPropDefaultValue)

Name
ntPriv9

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPriv9 = 351

Sepi
Class Tree
Index
Previous (ntPriv8)
Next (ntPropDefaultValue)


Sepi

Sepi
Previous (ntPriv9)
Next (ntPropertyDecl)

Name
ntPropDefaultValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropDefaultValue = 260

Sepi
Class Tree
Index
Previous (ntPriv9)
Next (ntPropertyDecl)


Sepi

Sepi
Previous (ntPropDefaultValue)
Next (ntPropertyKind)

Name
ntPropertyDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropertyDecl = 252

Sepi
Class Tree
Index
Previous (ntPropDefaultValue)
Next (ntPropertyKind)


Sepi

Sepi
Previous (ntPropertyDecl)
Next (ntPropertyModifier)

Name
ntPropertyKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropertyKind = 253

Sepi
Class Tree
Index
Previous (ntPropertyDecl)
Next (ntPropertyModifier)


Sepi

Sepi
Previous (ntPropertyKind)
Next (ntPropertyNextDecl)

Name
ntPropertyModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropertyModifier = 263

Sepi
Class Tree
Index
Previous (ntPropertyKind)
Next (ntPropertyNextDecl)


Sepi

Sepi
Previous (ntPropertyModifier)
Next (ntPropertySignature)

Name
ntPropertyNextDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropertyNextDecl = 254

Sepi
Class Tree
Index
Previous (ntPropertyModifier)
Next (ntPropertySignature)


Sepi

Sepi
Previous (ntPropertyNextDecl)
Next (ntPropIndex)

Name
ntPropertySignature

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropertySignature = 283

Sepi
Class Tree
Index
Previous (ntPropertyNextDecl)
Next (ntPropIndex)


Sepi

Sepi
Previous (ntPropertySignature)
Next (ntPropInfo)

Name
ntPropIndex

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropIndex = 259

Sepi
Class Tree
Index
Previous (ntPropertySignature)
Next (ntPropInfo)


Sepi

Sepi
Previous (ntPropIndex)
Next (ntPropReadAccess)

Name
ntPropInfo

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropInfo = 256

Sepi
Class Tree
Index
Previous (ntPropIndex)
Next (ntPropReadAccess)


Sepi

Sepi
Previous (ntPropInfo)
Next (ntPropStorage)

Name
ntPropReadAccess

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropReadAccess = 257

Sepi
Class Tree
Index
Previous (ntPropInfo)
Next (ntPropStorage)


Sepi

Sepi
Previous (ntPropReadAccess)
Next (ntPropType)

Name
ntPropStorage

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropStorage = 261

Sepi
Class Tree
Index
Previous (ntPropReadAccess)
Next (ntPropType)


Sepi

Sepi
Previous (ntPropStorage)
Next (ntPropWriteAccess)

Name
ntPropType

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropType = 287

Sepi
Class Tree
Index
Previous (ntPropStorage)
Next (ntPropWriteAccess)


Sepi

Sepi
Previous (ntPropType)
Next (ntPureInheritedExpression)

Name
ntPropWriteAccess

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPropWriteAccess = 258

Sepi
Class Tree
Index
Previous (ntPropType)
Next (ntPureInheritedExpression)


Sepi

Sepi
Previous (ntPropWriteAccess)
Next (ntQualifiedIdent)

Name
ntPureInheritedExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntPureInheritedExpression = 171

Sepi
Class Tree
Index
Previous (ntPropWriteAccess)
Next (ntQualifiedIdent)


Sepi

Sepi
Previous (ntPureInheritedExpression)
Next (ntRaiseInstruction)

Name
ntQualifiedIdent

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntQualifiedIdent = 131

Sepi
Class Tree
Index
Previous (ntPureInheritedExpression)
Next (ntRaiseInstruction)


Sepi

Sepi
Previous (ntQualifiedIdent)
Next (ntRangeDesc)

Name
ntRaiseInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRaiseInstruction = 335

Sepi
Class Tree
Index
Previous (ntQualifiedIdent)
Next (ntRangeDesc)


Sepi

Sepi
Previous (ntRaiseInstruction)
Next (ntRangeOrEnumDesc)

Name
ntRangeDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRangeDesc = 211

Sepi
Class Tree
Index
Previous (ntRaiseInstruction)
Next (ntRangeOrEnumDesc)


Sepi

Sepi
Previous (ntRangeDesc)
Next (ntRecordCase)

Name
ntRangeOrEnumDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRangeOrEnumDesc = 210

Sepi
Class Tree
Index
Previous (ntRangeDesc)
Next (ntRecordCase)


Sepi

Sepi
Previous (ntRangeOrEnumDesc)
Next (ntRecordCaseBlock)

Name
ntRecordCase

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordCase = 223

Sepi
Class Tree
Index
Previous (ntRangeOrEnumDesc)
Next (ntRecordCaseBlock)


Sepi

Sepi
Previous (ntRecordCase)
Next (ntRecordCaseContents)

Name
ntRecordCaseBlock

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordCaseBlock = 221

Sepi
Class Tree
Index
Previous (ntRecordCase)
Next (ntRecordCaseContents)


Sepi

Sepi
Previous (ntRecordCaseBlock)
Next (ntRecordCaseField)

Name
ntRecordCaseContents

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordCaseContents = 225

Sepi
Class Tree
Index
Previous (ntRecordCaseBlock)
Next (ntRecordCaseField)


Sepi

Sepi
Previous (ntRecordCaseContents)
Next (ntRecordCaseHeader)

Name
ntRecordCaseField

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordCaseField = 229

Sepi
Class Tree
Index
Previous (ntRecordCaseContents)
Next (ntRecordCaseHeader)


Sepi

Sepi
Previous (ntRecordCaseField)
Next (ntRecordContents)

Name
ntRecordCaseHeader

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordCaseHeader = 222

Sepi
Class Tree
Index
Previous (ntRecordCaseField)
Next (ntRecordContents)


Sepi

Sepi
Previous (ntRecordCaseHeader)
Next (ntRecordDesc)

Name
ntRecordContents

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordContents = 220

Sepi
Class Tree
Index
Previous (ntRecordCaseHeader)
Next (ntRecordDesc)


Sepi

Sepi
Previous (ntRecordContents)
Next (ntRecordField)

Name
ntRecordDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordDesc = 218

Sepi
Class Tree
Index
Previous (ntRecordContents)
Next (ntRecordField)


Sepi

Sepi
Previous (ntRecordDesc)
Next (ntRecordInitEx)

Name
ntRecordField

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordField = 228

Sepi
Class Tree
Index
Previous (ntRecordDesc)
Next (ntRecordInitEx)


Sepi

Sepi
Previous (ntRecordField)
Next (ntRecordInitialization)

Name
ntRecordInitEx

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordInitEx = 138

Sepi
Class Tree
Index
Previous (ntRecordField)
Next (ntRecordInitialization)


Sepi

Sepi
Previous (ntRecordInitEx)
Next (ntRecordInitializationExpression)

Name
ntRecordInitialization

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordInitialization = 137

Sepi
Class Tree
Index
Previous (ntRecordInitEx)
Next (ntRecordInitializationExpression)


Sepi

Sepi
Previous (ntRecordInitialization)
Next (ntRedefineMarker)

Name
ntRecordInitializationExpression

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRecordInitializationExpression = 136

Sepi
Class Tree
Index
Previous (ntRecordInitialization)
Next (ntRedefineMarker)


Sepi

Sepi
Previous (ntRecordInitializationExpression)
Next (ntRepeatInstruction)

Name
ntRedefineMarker

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRedefineMarker = 255

Sepi
Class Tree
Index
Previous (ntRecordInitializationExpression)
Next (ntRepeatInstruction)


Sepi

Sepi
Previous (ntRedefineMarker)
Next (ntReturnType)

Name
ntRepeatInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRepeatInstruction = 320

Sepi
Class Tree
Index
Previous (ntRedefineMarker)
Next (ntReturnType)


Sepi

Sepi
Previous (ntRepeatInstruction)
Next (ntRoutineDecl)

Name
ntReturnType

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntReturnType = 286

Sepi
Class Tree
Index
Previous (ntRepeatInstruction)
Next (ntRoutineDecl)


Sepi

Sepi
Previous (ntReturnType)
Next (ntRoutineKind)

Name
ntRoutineDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRoutineDecl = 269

Sepi
Class Tree
Index
Previous (ntReturnType)
Next (ntRoutineKind)


Sepi

Sepi
Previous (ntRoutineDecl)
Next (ntRoutineModifier)

Name
ntRoutineKind

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRoutineKind = 270

Sepi
Class Tree
Index
Previous (ntRoutineDecl)
Next (ntRoutineModifier)


Sepi

Sepi
Previous (ntRoutineKind)
Next (ntSetDesc)

Name
ntRoutineModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntRoutineModifier = 273

Sepi
Class Tree
Index
Previous (ntRoutineKind)
Next (ntSetDesc)


Sepi

Sepi
Previous (ntRoutineModifier)
Next (ntSetOrOpenArrayBuilder)

Name
ntSetDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSetDesc = 215

Sepi
Class Tree
Index
Previous (ntRoutineModifier)
Next (ntSetOrOpenArrayBuilder)


Sepi

Sepi
Previous (ntSetDesc)
Next (ntSetOrOpenArrayRange)

Name
ntSetOrOpenArrayBuilder

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSetOrOpenArrayBuilder = 158

Sepi
Class Tree
Index
Previous (ntSetDesc)
Next (ntSetOrOpenArrayRange)


Sepi

Sepi
Previous (ntSetOrOpenArrayBuilder)
Next (ntSetRange)

Name
ntSetOrOpenArrayRange

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSetOrOpenArrayRange = 159

Sepi
Class Tree
Index
Previous (ntSetOrOpenArrayBuilder)
Next (ntSetRange)


Sepi

Sepi
Previous (ntSetOrOpenArrayRange)
Next (ntSetValue)

Name
ntSetRange

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSetRange = 175

Sepi
Class Tree
Index
Previous (ntSetOrOpenArrayRange)
Next (ntSetValue)


Sepi

Sepi
Previous (ntSetRange)
Next (ntSingleExpr)

Name
ntSetValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSetValue = 173

Sepi
Class Tree
Index
Previous (ntSetRange)
Next (ntSingleExpr)


Sepi

Sepi
Previous (ntSetValue)
Next (ntSingleValue)

Name
ntSingleExpr

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSingleExpr = 149

Sepi
Class Tree
Index
Previous (ntSetValue)
Next (ntSingleValue)


Sepi

Sepi
Previous (ntSingleExpr)
Next (ntSource)

Name
ntSingleValue

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSingleValue = 164

Sepi
Class Tree
Index
Previous (ntSingleExpr)
Next (ntSource)


Sepi

Sepi
Previous (ntSingleValue)
Next (ntStaticMarker)

Name
ntSource

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntSource = 120

Sepi
Class Tree
Index
Previous (ntSingleValue)
Next (ntStaticMarker)


Sepi

Sepi
Previous (ntSource)
Next (ntStrictVisibility)

Name
ntStaticMarker

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntStaticMarker = 279

Sepi
Class Tree
Index
Previous (ntSource)
Next (ntStrictVisibility)


Sepi

Sepi
Previous (ntStaticMarker)
Next (ntStringConst)

Name
ntStrictVisibility

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntStrictVisibility = 237

Sepi
Class Tree
Index
Previous (ntStaticMarker)
Next (ntStringConst)


Sepi

Sepi
Previous (ntStrictVisibility)
Next (ntStringDesc)

Name
ntStringConst

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntStringConst = 167

Sepi
Class Tree
Index
Previous (ntStrictVisibility)
Next (ntStringDesc)


Sepi

Sepi
Previous (ntStringConst)
Next (ntTryInstruction)

Name
ntStringDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntStringDesc = 216

Sepi
Class Tree
Index
Previous (ntStringConst)
Next (ntTryInstruction)


Sepi

Sepi
Previous (ntStringDesc)
Next (ntTypeDecl)

Name
ntTryInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntTryInstruction = 326

Sepi
Class Tree
Index
Previous (ntStringDesc)
Next (ntTypeDecl)


Sepi

Sepi
Previous (ntTryInstruction)
Next (ntTypeDesc)

Name
ntTypeDecl

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntTypeDecl = 193

Sepi
Class Tree
Index
Previous (ntTryInstruction)
Next (ntTypeDesc)


Sepi

Sepi
Previous (ntTypeDecl)
Next (ntTypeModifier)

Name
ntTypeDesc

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntTypeDesc = 199

Sepi
Class Tree
Index
Previous (ntTypeDecl)
Next (ntTypeModifier)


Sepi

Sepi
Previous (ntTypeDesc)
Next (ntTypeModifiers)

Name
ntTypeModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntTypeModifier = 207

Sepi
Class Tree
Index
Previous (ntTypeDesc)
Next (ntTypeModifiers)


Sepi

Sepi
Previous (ntTypeModifier)
Next (ntTypeName)

Name
ntTypeModifiers

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntTypeModifiers = 206

Sepi
Class Tree
Index
Previous (ntTypeModifier)
Next (ntTypeName)


Sepi

Sepi
Previous (ntTypeModifiers)
Next (ntTypeSection)

Name
ntTypeName

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntTypeName = 200

Sepi
Class Tree
Index
Previous (ntTypeModifiers)
Next (ntTypeSection)


Sepi

Sepi
Previous (ntTypeName)
Next (ntUnaryOp)

Name
ntTypeSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntTypeSection = 192

Sepi
Class Tree
Index
Previous (ntTypeName)
Next (ntUnaryOp)


Sepi

Sepi
Previous (ntTypeSection)
Next (ntUnaryOpExpr)

Name
ntUnaryOp

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntUnaryOp = 183

Sepi
Class Tree
Index
Previous (ntTypeSection)
Next (ntUnaryOpExpr)


Sepi

Sepi
Previous (ntUnaryOp)
Next (ntUnaryOpModifier)

Name
ntUnaryOpExpr

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntUnaryOpExpr = 150

Sepi
Class Tree
Index
Previous (ntUnaryOp)
Next (ntUnaryOpModifier)


Sepi

Sepi
Previous (ntUnaryOpExpr)
Next (ntUnitFinalization)

Name
ntUnaryOpModifier

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntUnaryOpModifier = 153

Sepi
Class Tree
Index
Previous (ntUnaryOpExpr)
Next (ntUnitFinalization)


Sepi

Sepi
Previous (ntUnaryOpModifier)
Next (ntUnitInitialization)

Name
ntUnitFinalization

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntUnitFinalization = 307

Sepi
Class Tree
Index
Previous (ntUnaryOpModifier)
Next (ntUnitInitialization)


Sepi

Sepi
Previous (ntUnitFinalization)
Next (ntUsesSection)

Name
ntUnitInitialization

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntUnitInitialization = 306

Sepi
Class Tree
Index
Previous (ntUnitFinalization)
Next (ntUsesSection)


Sepi

Sepi
Previous (ntUnitInitialization)
Next (ntVarSection)

Name
ntUsesSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntUsesSection = 128

Sepi
Class Tree
Index
Previous (ntUnitInitialization)
Next (ntVarSection)


Sepi

Sepi
Previous (ntUsesSection)
Next (ntVisibility)

Name
ntVarSection

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntVarSection = 189

Sepi
Class Tree
Index
Previous (ntUsesSection)
Next (ntVisibility)


Sepi

Sepi
Previous (ntVarSection)
Next (ntWhileInstruction)

Name
ntVisibility

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntVisibility = 236

Sepi
Class Tree
Index
Previous (ntVarSection)
Next (ntWhileInstruction)


Sepi

Sepi
Previous (ntVisibility)
Next (ntWithEx)

Name
ntWhileInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntWhileInstruction = 319

Sepi
Class Tree
Index
Previous (ntVisibility)
Next (ntWithEx)


Sepi

Sepi
Previous (ntWhileInstruction)
Next (ntWithInstruction)

Name
ntWithEx

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntWithEx = 340

Sepi
Class Tree
Index
Previous (ntWhileInstruction)
Next (ntWithInstruction)


Sepi

Sepi
Previous (ntWithEx)
Next

Name
ntWithInstruction

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
ntWithInstruction = 339

Sepi
Class Tree
Index
Previous (ntWithEx)
Next


Sepi

Sepi
Previous
Next

Name
NonTerminalClasses

Parent
SepiDelphiParser

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
NonTerminalClasses : array [ FirstNonTerminal .. LastNonTerminal ] of TSepiNonTerminalClass

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiDelphiParser)
Next (SepiExecution)

Name
SepiDisassembler

Parent
Sepi

Description
Désassembleur Sepi

Author
sjrd

Version
1.0

Types
Type Description

Constants
Constant Description

Variables
Variable Description

Methods
Method Description

Classes
Class | Description
TSepiDisassembler (+) | Désassembleur Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiDelphiParser)
Next (SepiExecution)


Sepi

Sepi
Previous
Next

Name
TSepiDisassembler

Parent
SepiDisassembler

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Désassembleur Sepi

Members
Fields
Field | Description
Instructions (-) | Instructions à désassembler
RuntimeUnit (-) | Unité d'exécution

Methods
Method | Description
Create (+) | Crée un désassembleur Sepi
Destroy (+) | [@inheritDoc]
Disassemble (+) | Désassemble un code
DisassembleInstruction (-) | Désassemble une instruction
OpCodeAddressCall (-) | OpCode BasicCall
OpCodeAsClass (-) | OpCode AsClass
OpCodeCompare (-) | OpCode de comparaison
OpCodeConvert (-) | OpCode Convert
OpCodeDynamicCall (-) | OpCode DynamicCall
OpCodeDynArrayCopy (-) | OpCode DACP version tableau entier
OpCodeDynArrayCopyRange (-) | OpCode DACP version range
OpCodeDynArraySetLength (-) | OpCode DASL
OpCodeGetRuntimeInfo (-) | OpCode GetTypeInfo, GetDelphiClass ou GetMethodCode
OpCodeIsClass (-) | OpCode IsClass
OpCodeJump (-) | OpCode Jump
OpCodeJumpIf (-) | OpCode Jump If (True or False)
OpCodeLoadAddress (-) | OpCode LoadAddress
OpCodeMoveFixed (-) | OpCode MoveSome et MoveMany
OpCodeMoveOther (-) | OpCode MoveOther
OpCodeMultiOn (-) | OpCode MultiOn
OpCodeNope (-) | OpCode Nope
OpCodeOtherBinaryOp (-) | Opérations binaires sur un autre
OpCodeOtherUnaryOp (-) | Opérations unaires sur un autre
OpCodeRaise (-) | OpCode Raise
OpCodeReraise (-) | OpCode Reraise
OpCodeSelfBinaryOp (-) | Opérations binaires sur soi-même
OpCodeSelfUnaryOp (-) | Opérations unaires sur soi-même
OpCodeSetCmpOp (-) | OpCode SetEquals, SetNotEquals ou SetContained
OpCodeSetElem (-) | OpCode SetElem
OpCodeSetExpand (-) | OpCode SetExpand
OpCodeSetIn (-) | OpCode SetIn
OpCodeSetIncludeExclude (-) | OpCode SetInclude ou SetExclude
OpCodeSetOtherOp (-) | OpCode SetOtherIntersect, SetOtherUnion, SetOtherSubract
OpCodeSetRange (-) | OpCode SetRange
OpCodeSetSelfOp (-) | OpCode SetSelfIntersect, SetSelfUnion ou SetSelfSubtract
OpCodeSimpleMove (-) | OpCode Move
OpCodeStaticCall (-) | OpCode StaticCall
OpCodeStrCopy (-) | OpCode ASCP et WSCP
OpCodeStrSetLength (-) | OpCode ASSL et WSSL
OpCodeTryExcept (-) | OpCode BeginTryExcept
OpCodeTryFinally (-) | OpCode BeginTryFinally
OpCodeValueToIntStdFunction (-) | OpCode ASL, WSL, DAL et DAH
ReadAddress (-) | Lit l'adresse d'une zone mémoire depuis le flux d'instructions
ReadAddressOperation (-) | Lit une opération sur une adresse et l'applique à une adresse donnée
ReadBaseAddress (-) | Lit une adresse de base depuis les instructions
ReadClassValue (-) | Lit une valeur de type classe (TClass)
ReadParams (-) | Lit les paramètres et le résultat d'un CALL
ReadRef (-) | Lit une référence depuis les instructions
UnknownOpCode (-) | OpCode inconnu

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (RuntimeUnit)

Name
Instructions

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Instructions à désassembler

Source code
Instructions : TAbsoluteMemoryStream

Sepi
Class Tree
Index
Previous
Next (RuntimeUnit)


Sepi

Sepi
Previous (Instructions)
Next

Name
RuntimeUnit

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Unité d'exécution

Source code
RuntimeUnit : TSepiRuntimeUnit

Sepi
Class Tree
Index
Previous (Instructions)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiDisassembler

Visibility
PUBLIC

Description
Crée un désassembleur Sepi

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Disassemble)

Name
Destroy

Parent
TSepiDisassembler

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Disassemble)


Sepi

Sepi
Previous (Destroy)
Next (DisassembleInstruction)

Name
Disassemble

Parent
TSepiDisassembler

Visibility
PUBLIC

Description
Désassemble un code
Vous pouvez passer 0 comme paramètre CodeSize (resp. MaxInstructions) pour
lever la limitation de taille de code (resp. de nombre d'instructions).
En sortie, la liste de chaînes Result a une entrée supplémentaire pour chaque
instruction désassemblée : la chaîne est une version textuelle de
l'instructions, l'objet est l'adresse de début de l'instruction.

Source code
procedure Disassemble ( Code : Pointer ; Result : TStrings ; RunUnit : TSepiRuntimeUnit ; CodeSize , MaxInstructions : Integer )

Parameters
Parameter | Description
Code : Pointer | Pointeur sur le code à désassembler
Result : TStrings | Liste de chaînes où stocker le résultat
RunUnit : TSepiRuntimeUnit | Unité d'exécution
CodeSize : INTEGER | Taille maximum du code à désassembler
MaxInstructions : INTEGER | Nombre maximum d'instructions à désassembler

Sepi
Class Tree
Index
Previous (Destroy)
Next (DisassembleInstruction)


Sepi

Sepi
Previous (Disassemble)
Next (OpCodeAddressCall)

Name
DisassembleInstruction

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Désassemble une instruction

Source code
function DisassembleInstruction : string

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Disassemble)
Next (OpCodeAddressCall)


Sepi

Sepi
Previous (DisassembleInstruction)
Next (OpCodeAsClass)

Name
OpCodeAddressCall

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode BasicCall

Source code
function OpCodeAddressCall ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (DisassembleInstruction)
Next (OpCodeAsClass)


Sepi

Sepi
Previous (OpCodeAddressCall)
Next (OpCodeCompare)

Name
OpCodeAsClass

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode AsClass

Source code
function OpCodeAsClass ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeAddressCall)
Next (OpCodeCompare)


Sepi

Sepi
Previous (OpCodeAsClass)
Next (OpCodeConvert)

Name
OpCodeCompare

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode de comparaison

Source code
function OpCodeCompare ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeAsClass)
Next (OpCodeConvert)


Sepi

Sepi
Previous (OpCodeCompare)
Next (OpCodeDynamicCall)

Name
OpCodeConvert

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode Convert

Source code
function OpCodeConvert ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeCompare)
Next (OpCodeDynamicCall)


Sepi

Sepi
Previous (OpCodeConvert)
Next (OpCodeDynArrayCopy)

Name
OpCodeDynamicCall

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode DynamicCall

Source code
function OpCodeDynamicCall ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeConvert)
Next (OpCodeDynArrayCopy)


Sepi

Sepi
Previous (OpCodeDynamicCall)
Next (OpCodeDynArrayCopyRange)

Name
OpCodeDynArrayCopy

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode DACP version tableau entier

Source code
function OpCodeDynArrayCopy ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeDynamicCall)
Next (OpCodeDynArrayCopyRange)


Sepi

Sepi
Previous (OpCodeDynArrayCopy)
Next (OpCodeDynArraySetLength)

Name
OpCodeDynArrayCopyRange

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode DACP version range

Source code
function OpCodeDynArrayCopyRange ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeDynArrayCopy)
Next (OpCodeDynArraySetLength)


Sepi

Sepi
Previous (OpCodeDynArrayCopyRange)
Next (OpCodeGetRuntimeInfo)

Name
OpCodeDynArraySetLength

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode DASL

Source code
function OpCodeDynArraySetLength ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeDynArrayCopyRange)
Next (OpCodeGetRuntimeInfo)


Sepi

Sepi
Previous (OpCodeDynArraySetLength)
Next (OpCodeIsClass)

Name
OpCodeGetRuntimeInfo

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode GetTypeInfo, GetDelphiClass ou GetMethodCode

Source code
function OpCodeGetRuntimeInfo ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeDynArraySetLength)
Next (OpCodeIsClass)


Sepi

Sepi
Previous (OpCodeGetRuntimeInfo)
Next (OpCodeJump)

Name
OpCodeIsClass

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode IsClass

Source code
function OpCodeIsClass ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeGetRuntimeInfo)
Next (OpCodeJump)


Sepi

Sepi
Previous (OpCodeIsClass)
Next (OpCodeJumpIf)

Name
OpCodeJump

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode Jump

Source code
function OpCodeJump ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeIsClass)
Next (OpCodeJumpIf)


Sepi

Sepi
Previous (OpCodeJump)
Next (OpCodeLoadAddress)

Name
OpCodeJumpIf

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode Jump If (True or False)

Source code
function OpCodeJumpIf ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeJump)
Next (OpCodeLoadAddress)


Sepi

Sepi
Previous (OpCodeJumpIf)
Next (OpCodeMoveFixed)

Name
OpCodeLoadAddress

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode LoadAddress

Source code
function OpCodeLoadAddress ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeJumpIf)
Next (OpCodeMoveFixed)


Sepi

Sepi
Previous (OpCodeLoadAddress)
Next (OpCodeMoveOther)

Name
OpCodeMoveFixed

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode MoveSome et MoveMany

Source code
function OpCodeMoveFixed ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeLoadAddress)
Next (OpCodeMoveOther)


Sepi

Sepi
Previous (OpCodeMoveFixed)
Next (OpCodeMultiOn)

Name
OpCodeMoveOther

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode MoveOther

Source code
function OpCodeMoveOther ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeMoveFixed)
Next (OpCodeMultiOn)


Sepi

Sepi
Previous (OpCodeMoveOther)
Next (OpCodeNope)

Name
OpCodeMultiOn

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode MultiOn

Source code
function OpCodeMultiOn ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeMoveOther)
Next (OpCodeNope)


Sepi

Sepi
Previous (OpCodeMultiOn)
Next (OpCodeOtherBinaryOp)

Name
OpCodeNope

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode Nope

Source code
function OpCodeNope ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeMultiOn)
Next (OpCodeOtherBinaryOp)


Sepi

Sepi
Previous (OpCodeNope)
Next (OpCodeOtherUnaryOp)

Name
OpCodeOtherBinaryOp

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Opérations binaires sur un autre

Source code
function OpCodeOtherBinaryOp ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeNope)
Next (OpCodeOtherUnaryOp)


Sepi

Sepi
Previous (OpCodeOtherBinaryOp)
Next (OpCodeRaise)

Name
OpCodeOtherUnaryOp

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Opérations unaires sur un autre

Source code
function OpCodeOtherUnaryOp ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeOtherBinaryOp)
Next (OpCodeRaise)


Sepi

Sepi
Previous (OpCodeOtherUnaryOp)
Next (OpCodeReraise)

Name
OpCodeRaise

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode Raise

Source code
function OpCodeRaise ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeOtherUnaryOp)
Next (OpCodeReraise)


Sepi

Sepi
Previous (OpCodeRaise)
Next (OpCodeSelfBinaryOp)

Name
OpCodeReraise

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode Reraise

Source code
function OpCodeReraise ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeRaise)
Next (OpCodeSelfBinaryOp)


Sepi

Sepi
Previous (OpCodeReraise)
Next (OpCodeSelfUnaryOp)

Name
OpCodeSelfBinaryOp

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Opérations binaires sur soi-même

Source code
function OpCodeSelfBinaryOp ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeReraise)
Next (OpCodeSelfUnaryOp)


Sepi

Sepi
Previous (OpCodeSelfBinaryOp)
Next (OpCodeSetCmpOp)

Name
OpCodeSelfUnaryOp

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Opérations unaires sur soi-même

Source code
function OpCodeSelfUnaryOp ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSelfBinaryOp)
Next (OpCodeSetCmpOp)


Sepi

Sepi
Previous (OpCodeSelfUnaryOp)
Next (OpCodeSetElem)

Name
OpCodeSetCmpOp

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetEquals, SetNotEquals ou SetContained

Source code
function OpCodeSetCmpOp ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSelfUnaryOp)
Next (OpCodeSetElem)


Sepi

Sepi
Previous (OpCodeSetCmpOp)
Next (OpCodeSetExpand)

Name
OpCodeSetElem

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetElem

Source code
function OpCodeSetElem ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetCmpOp)
Next (OpCodeSetExpand)


Sepi

Sepi
Previous (OpCodeSetElem)
Next (OpCodeSetIn)

Name
OpCodeSetExpand

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetExpand

Source code
function OpCodeSetExpand ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetElem)
Next (OpCodeSetIn)


Sepi

Sepi
Previous (OpCodeSetExpand)
Next (OpCodeSetIncludeExclude)

Name
OpCodeSetIn

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetIn

Source code
function OpCodeSetIn ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetExpand)
Next (OpCodeSetIncludeExclude)


Sepi

Sepi
Previous (OpCodeSetIn)
Next (OpCodeSetOtherOp)

Name
OpCodeSetIncludeExclude

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetInclude ou SetExclude

Source code
function OpCodeSetIncludeExclude ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetIn)
Next (OpCodeSetOtherOp)


Sepi

Sepi
Previous (OpCodeSetIncludeExclude)
Next (OpCodeSetRange)

Name
OpCodeSetOtherOp

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetOtherIntersect, SetOtherUnion, SetOtherSubract

Source code
function OpCodeSetOtherOp ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetIncludeExclude)
Next (OpCodeSetRange)


Sepi

Sepi
Previous (OpCodeSetOtherOp)
Next (OpCodeSetSelfOp)

Name
OpCodeSetRange

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetRange

Source code
function OpCodeSetRange ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetOtherOp)
Next (OpCodeSetSelfOp)


Sepi

Sepi
Previous (OpCodeSetRange)
Next (OpCodeSimpleMove)

Name
OpCodeSetSelfOp

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode SetSelfIntersect, SetSelfUnion ou SetSelfSubtract

Source code
function OpCodeSetSelfOp ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetRange)
Next (OpCodeSimpleMove)


Sepi

Sepi
Previous (OpCodeSetSelfOp)
Next (OpCodeStaticCall)

Name
OpCodeSimpleMove

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode Move

Source code
function OpCodeSimpleMove ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSetSelfOp)
Next (OpCodeStaticCall)


Sepi

Sepi
Previous (OpCodeSimpleMove)
Next (OpCodeStrCopy)

Name
OpCodeStaticCall

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode StaticCall

Source code
function OpCodeStaticCall ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeSimpleMove)
Next (OpCodeStrCopy)


Sepi

Sepi
Previous (OpCodeStaticCall)
Next (OpCodeStrSetLength)

Name
OpCodeStrCopy

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode ASCP et WSCP

Source code
function OpCodeStrCopy ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeStaticCall)
Next (OpCodeStrSetLength)


Sepi

Sepi
Previous (OpCodeStrCopy)
Next (OpCodeTryExcept)

Name
OpCodeStrSetLength

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode ASSL et WSSL

Source code
function OpCodeStrSetLength ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeStrCopy)
Next (OpCodeTryExcept)


Sepi

Sepi
Previous (OpCodeStrSetLength)
Next (OpCodeTryFinally)

Name
OpCodeTryExcept

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode BeginTryExcept

Source code
function OpCodeTryExcept ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeStrSetLength)
Next (OpCodeTryFinally)


Sepi

Sepi
Previous (OpCodeTryExcept)
Next (OpCodeValueToIntStdFunction)

Name
OpCodeTryFinally

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode BeginTryFinally

Source code
function OpCodeTryFinally ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeTryExcept)
Next (OpCodeValueToIntStdFunction)


Sepi

Sepi
Previous (OpCodeTryFinally)
Next (ReadAddress)

Name
OpCodeValueToIntStdFunction

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode ASL, WSL, DAL et DAH

Source code
function OpCodeValueToIntStdFunction ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeTryFinally)
Next (ReadAddress)


Sepi

Sepi
Previous (OpCodeValueToIntStdFunction)
Next (ReadAddressOperation)

Name
ReadAddress

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Lit l'adresse d'une zone mémoire depuis le flux d'instructions

Source code
function ReadAddress ( Options : TSepiAddressOptions = [ ] ; ConstSize : Integer = 0 ) : string

Parameters
Parameter | Description
Options : TSepiAddressOptions | Options de lecture d'addresse
ConstSize : INTEGER | Taille d'une constante dans le code

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (OpCodeValueToIntStdFunction)
Next (ReadAddressOperation)


Sepi

Sepi
Previous (ReadAddress)
Next (ReadBaseAddress)

Name
ReadAddressOperation

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Lit une opération sur une adresse et l'applique à une adresse donnée

Source code
procedure ReadAddressOperation ( var Address : string )

Parameters
Parameter | Description
Address : STRING | Adresse à modifier

Sepi
Class Tree
Index
Previous (ReadAddress)
Next (ReadBaseAddress)


Sepi

Sepi
Previous (ReadAddressOperation)
Next (ReadClassValue)

Name
ReadBaseAddress

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Lit une adresse de base depuis les instructions

Source code
function ReadBaseAddress ( Options : TSepiAddressOptions ; ConstSize : Integer ; MemorySpace : TSepiMemorySpace ) : string

Parameters
Parameter | Description
Options : TSepiAddressOptions | Options de lecture d'addresse
ConstSize : INTEGER | Taille d'une constante dans le code
MemorySpace : TSepiMemorySpace | Espace d'adressage

Return
Types | Description
STRING | Adresse de base lue

Sepi
Class Tree
Index
Previous (ReadAddressOperation)
Next (ReadClassValue)


Sepi

Sepi
Previous (ReadBaseAddress)
Next (ReadParams)

Name
ReadClassValue

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Lit une valeur de type classe (TClass)

Source code
function ReadClassValue : string

Parameters
Parameter Description

Return
Types | Description
STRING | Classe lue

Sepi
Class Tree
Index
Previous (ReadBaseAddress)
Next (ReadParams)


Sepi

Sepi
Previous (ReadClassValue)
Next (ReadRef)

Name
ReadParams

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Lit les paramètres et le résultat d'un CALL

Source code
function ReadParams : string

Parameters
Parameter Description

Return
Types | Description
STRING | Paramètres et résultat

Sepi
Class Tree
Index
Previous (ReadClassValue)
Next (ReadRef)


Sepi

Sepi
Previous (ReadParams)
Next (UnknownOpCode)

Name
ReadRef

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
Lit une référence depuis les instructions

Source code
function ReadRef : string

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ReadParams)
Next (UnknownOpCode)


Sepi

Sepi
Previous (ReadRef)
Next

Name
UnknownOpCode

Parent
TSepiDisassembler

Visibility
PRIVATE

Description
OpCode inconnu

Source code
function UnknownOpCode ( OpCode : TSepiOpCode ) : string

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ReadRef)
Next


Sepi

Sepi
Previous (SepiDisassembler)
Next (SepiExplorerMain)

Name
SepiExecution

Parent
Sepi

Description
Exécution d'une unité Sepi

Author
sjrd

Version
1.0

Constants
Constant | Description
CompiledUnitExt (+) | Extension d'une unité Sepi compilée

Classes
Class | Description
TSepiExecution (+) | Contexte d'exécution d'un programme Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiDisassembler)
Next (SepiExplorerMain)


Sepi

Sepi
Previous
Next

Name
TSepiExecution

Parent
SepiExecution

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Contexte d'exécution d'un programme Sepi

Members
Fields
Field | Description
FBrowsingPath (-) | Chemin de recherche
FSepiRoot (-) | Racine Sepi
FUseDebugger (-) | Indique s'il faut utiliser un debugger

Methods
Method | Description
Create (+) | Crée un contexte d'exécution de programme Sepi
Destroy (+) | [@inheritDoc]
Execute (+) | Exécute une unité
ExtraSimpleDebug (+) | Gestionnaire de débogage extrêmement simple
LoadUnit (+) | Charge une unité depuis son nom
SearchFile (+) | Recherche un fichier dans le chemin de recherche

Properties
Property | Description
BrowsingPath (+) | Chemin de recherche
SepiRoot (+) | Racine Sepi
UseDebugger (+) | Indique s'il faut utiliser un debugger

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FSepiRoot)

Name
FBrowsingPath

Parent
TSepiExecution

Visibility
PRIVATE

Description
Chemin de recherche

Source code
FBrowsingPath : string

Sepi
Class Tree
Index
Previous
Next (FSepiRoot)


Sepi

Sepi
Previous (FBrowsingPath)
Next (FUseDebugger)

Name
FSepiRoot

Parent
TSepiExecution

Visibility
PRIVATE

Description
Racine Sepi

Source code
FSepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FBrowsingPath)
Next (FUseDebugger)


Sepi

Sepi
Previous (FSepiRoot)
Next

Name
FUseDebugger

Parent
TSepiExecution

Visibility
PRIVATE

Description
Indique s'il faut utiliser un debugger

Source code
FUseDebugger : Boolean

Sepi
Class Tree
Index
Previous (FSepiRoot)
Next


Sepi

Sepi
Previous
Next (SepiRoot)

Name
BrowsingPath

Parent
TSepiExecution

Visibility
PUBLIC

Description
Chemin de recherche

Source code
property BrowsingPath : string read FBrowsingPath write FBrowsingPath

Read Access
FBrowsingPath

Write Access
FBrowsingPath

Sepi
Class Tree
Index
Previous
Next (SepiRoot)


Sepi

Sepi
Previous (BrowsingPath)
Next (UseDebugger)

Name
SepiRoot

Parent
TSepiExecution

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read FSepiRoot

Read Access
FSepiRoot

Sepi
Class Tree
Index
Previous (BrowsingPath)
Next (UseDebugger)


Sepi

Sepi
Previous (SepiRoot)
Next

Name
UseDebugger

Parent
TSepiExecution

Visibility
PUBLIC

Description
Indique s'il faut utiliser un debugger

Source code
property UseDebugger : Boolean read FUseDebugger write FUseDebugger

Read Access
FUseDebugger

Write Access
FUseDebugger

Sepi
Class Tree
Index
Previous (SepiRoot)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiExecution

Visibility
PUBLIC

Description
Crée un contexte d'exécution de programme Sepi

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Destroy

Parent
TSepiExecution

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Destroy)
Next (ExtraSimpleDebug)

Name
Execute

Parent
TSepiExecution

Visibility
PUBLIC

Description
Exécute une unité

Source code
procedure Execute ( const UnitName : string )

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité à charger et exécuter

Sepi
Class Tree
Index
Previous (Destroy)
Next (ExtraSimpleDebug)


Sepi

Sepi
Previous (Execute)
Next (LoadUnit)

Name
ExtraSimpleDebug

Parent
TSepiExecution

Visibility
PUBLIC

Description
Gestionnaire de débogage extrêmement simple

Source code
procedure ExtraSimpleDebug ( Context : TSepiRuntimeContext )

Parameters
Parameter | Description
Context : TSepiRuntimeContext | Contexte d'exécution

Sepi
Class Tree
Index
Previous (Execute)
Next (LoadUnit)


Sepi

Sepi
Previous (ExtraSimpleDebug)
Next (SearchFile)

Name
LoadUnit

Parent
TSepiExecution

Visibility
PUBLIC

Description
Charge une unité depuis son nom

Source code
function LoadUnit ( Sender : TSepiRoot ; const UnitName : string ) : TSepiUnit

Parameters
Parameter | Description
Sender : TSepiRoot | Racine Sepi qui déclenche ce gestionnaire
UnitName : STRING | Nom de l'unité à charger

Return
Types | Description
TSepiUnit | Unité chargée, ou nil si non trouvée

Sepi
Class Tree
Index
Previous (ExtraSimpleDebug)
Next (SearchFile)


Sepi

Sepi
Previous (LoadUnit)
Next

Name
SearchFile

Parent
TSepiExecution

Visibility
PUBLIC

Description
Recherche un fichier dans le chemin de recherche

Source code
function SearchFile ( const FileName : TFileName ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Fichier à rechercher

Return
Types | Description
TFileName | Nom complet du fichier, ou une chaîne vide si non trouvé

Sepi
Class Tree
Index
Previous (LoadUnit)
Next


Sepi

Sepi
Previous
Next

Name
CompiledUnitExt

Parent
SepiExecution

Visibility
PUBLIC

Description
Extension d'une unité Sepi compilée

Source code
CompiledUnitExt = '.scu'

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiExecution)
Next (SepiExpressions)

Name
SepiExplorerMain

Parent
Sepi

Description
Fiche principale de l'explorateur

Author
sjrd

Version
1.0

Types
Type Description

Variables
Variable | Description
ExplorerForm (+) | Form principale

Classes
Class | Description
TExplorerForm (+) | Fiche principale de l'explorateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiExecution)
Next (SepiExpressions)


Sepi

Sepi
Previous
Next

Name
TExplorerForm

Parent
SepiExplorerMain

Class Hierarchy
TForm

Visibility
PUBLIC

Description
Fiche principale de l'explorateur

Members
Fields
Field | Description
ActionEditBrowsingPath (*) | #No TAG found in source code#
ActionExit (*) | #No TAG found in source code#
ActionList (*) | #No TAG found in source code#
ActionLoadUnit (*) | #No TAG found in source code#
BigMenuFile (*) | #No TAG found in source code#
BigMenuOptions (*) | #No TAG found in source code#
ComponentExplorer (*) | #No TAG found in source code#
FDisableLazyLoad (-) | Désactive le lazy-load temporairement
FOptions (-) | Options de l'explorateur
FRuntimeUnits (-) | Unités de type run-time
FSepiRoot (-) | Racine Sepi
ImageList (*) | #No TAG found in source code#
MainMenu (*) | #No TAG found in source code#
MenuEditBrowsingPath (*) | #No TAG found in source code#
MenuExit (*) | #No TAG found in source code#
MenuLoadUnit (*) | #No TAG found in source code#
MenuSepFile1 (*) | #No TAG found in source code#
SplitterLeft (*) | #No TAG found in source code#
TreeView (*) | #No TAG found in source code#

Methods
Method | Description
ActionEditBrowsingPathExecute (*) | Action Modifier le chemin de recherche
ActionExitExecute (*) | Action Quitter
ActionLoadUnitExecute (*) | Action Charger une unité
FindComponentNode (+) | Trouve le noeud de l'arbre correspondant à un meta donné
FormCreate (*) | Création de la fiche
FormDestroy (*) | Destruction de la fiche
GetNodeComponent (-) | Obtient le meta représenté par un noeud donné
GetRuntimeMethod (-) | Trouve la méthode run-time correspondant à une méthode Sepi
LoadUnit (-) | Charge une unité et l'affiche dans l'arbre
RootLoadUnit (-) | Charge une unité
TreeViewChange (*) | Changement de sélection dans le treeview
TreeViewGetText (*) | Récupérer le nom d'un noeud
TreeViewInitChildren (*) | Initialise le nombre d'enfants d'un noeud
TreeViewInitNode (*) | Initialise un noeud

Properties
Property | Description
Options (+) | Options de l'explorateur
SepiRoot (+) | Racine Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ActionExit)

Name
ActionEditBrowsingPath

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ActionEditBrowsingPath : TAction

Sepi
Class Tree
Index
Previous
Next (ActionExit)


Sepi

Sepi
Previous (ActionEditBrowsingPath)
Next (ActionList)

Name
ActionExit

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ActionExit : TAction

Sepi
Class Tree
Index
Previous (ActionEditBrowsingPath)
Next (ActionList)


Sepi

Sepi
Previous (ActionExit)
Next (ActionLoadUnit)

Name
ActionList

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ActionList : TActionList

Sepi
Class Tree
Index
Previous (ActionExit)
Next (ActionLoadUnit)


Sepi

Sepi
Previous (ActionList)
Next (BigMenuFile)

Name
ActionLoadUnit

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ActionLoadUnit : TAction

Sepi
Class Tree
Index
Previous (ActionList)
Next (BigMenuFile)


Sepi

Sepi
Previous (ActionLoadUnit)
Next (BigMenuOptions)

Name
BigMenuFile

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
BigMenuFile : TMenuItem

Sepi
Class Tree
Index
Previous (ActionLoadUnit)
Next (BigMenuOptions)


Sepi

Sepi
Previous (BigMenuFile)
Next (ComponentExplorer)

Name
BigMenuOptions

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
BigMenuOptions : TMenuItem

Sepi
Class Tree
Index
Previous (BigMenuFile)
Next (ComponentExplorer)


Sepi

Sepi
Previous (BigMenuOptions)
Next (FDisableLazyLoad)

Name
ComponentExplorer

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ComponentExplorer : TFrameComponentExplorer

Sepi
Class Tree
Index
Previous (BigMenuOptions)
Next (FDisableLazyLoad)


Sepi

Sepi
Previous (ComponentExplorer)
Next (FOptions)

Name
FDisableLazyLoad

Parent
TExplorerForm

Visibility
PRIVATE

Description
Désactive le lazy-load temporairement

Source code
FDisableLazyLoad : Boolean

Sepi
Class Tree
Index
Previous (ComponentExplorer)
Next (FOptions)


Sepi

Sepi
Previous (FDisableLazyLoad)
Next (FRuntimeUnits)

Name
FOptions

Parent
TExplorerForm

Visibility
PRIVATE

Description
Options de l'explorateur

Source code
FOptions : TExplorerOptions

Sepi
Class Tree
Index
Previous (FDisableLazyLoad)
Next (FRuntimeUnits)


Sepi

Sepi
Previous (FOptions)
Next (FSepiRoot)

Name
FRuntimeUnits

Parent
TExplorerForm

Visibility
PRIVATE

Description
Unités de type run-time

Source code
FRuntimeUnits : TStrings

Sepi
Class Tree
Index
Previous (FOptions)
Next (FSepiRoot)


Sepi

Sepi
Previous (FRuntimeUnits)
Next (ImageList)

Name
FSepiRoot

Parent
TExplorerForm

Visibility
PRIVATE

Description
Racine Sepi

Source code
FSepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FRuntimeUnits)
Next (ImageList)


Sepi

Sepi
Previous (FSepiRoot)
Next (MainMenu)

Name
ImageList

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ImageList : TImageList

Sepi
Class Tree
Index
Previous (FSepiRoot)
Next (MainMenu)


Sepi

Sepi
Previous (ImageList)
Next (MenuEditBrowsingPath)

Name
MainMenu

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
MainMenu : TMainMenu

Sepi
Class Tree
Index
Previous (ImageList)
Next (MenuEditBrowsingPath)


Sepi

Sepi
Previous (MainMenu)
Next (MenuExit)

Name
MenuEditBrowsingPath

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
MenuEditBrowsingPath : TMenuItem

Sepi
Class Tree
Index
Previous (MainMenu)
Next (MenuExit)


Sepi

Sepi
Previous (MenuEditBrowsingPath)
Next (MenuLoadUnit)

Name
MenuExit

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
MenuExit : TMenuItem

Sepi
Class Tree
Index
Previous (MenuEditBrowsingPath)
Next (MenuLoadUnit)


Sepi

Sepi
Previous (MenuExit)
Next (MenuSepFile1)

Name
MenuLoadUnit

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
MenuLoadUnit : TMenuItem

Sepi
Class Tree
Index
Previous (MenuExit)
Next (MenuSepFile1)


Sepi

Sepi
Previous (MenuLoadUnit)
Next (SplitterLeft)

Name
MenuSepFile1

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
MenuSepFile1 : TMenuItem

Sepi
Class Tree
Index
Previous (MenuLoadUnit)
Next (SplitterLeft)


Sepi

Sepi
Previous (MenuSepFile1)
Next (TreeView)

Name
SplitterLeft

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
SplitterLeft : TSplitter

Sepi
Class Tree
Index
Previous (MenuSepFile1)
Next (TreeView)


Sepi

Sepi
Previous (SplitterLeft)
Next

Name
TreeView

Parent
TExplorerForm

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
TreeView : TVirtualStringTree

Sepi
Class Tree
Index
Previous (SplitterLeft)
Next


Sepi

Sepi
Previous
Next (SepiRoot)

Name
Options

Parent
TExplorerForm

Visibility
PUBLIC

Description
Options de l'explorateur

Source code
property Options : TExplorerOptions read FOptions

Read Access
FOptions

Sepi
Class Tree
Index
Previous
Next (SepiRoot)


Sepi

Sepi
Previous (Options)
Next

Name
SepiRoot

Parent
TExplorerForm

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read FSepiRoot

Read Access
FSepiRoot

Sepi
Class Tree
Index
Previous (Options)
Next


Sepi

Sepi
Previous
Next (ActionExitExecute)

Name
ActionEditBrowsingPathExecute

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Action Modifier le chemin de recherche

Source code
procedure ActionEditBrowsingPathExecute ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ActionExitExecute)


Sepi

Sepi
Previous (ActionEditBrowsingPathExecute)
Next (ActionLoadUnitExecute)

Name
ActionExitExecute

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Action Quitter

Source code
procedure ActionExitExecute ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ActionEditBrowsingPathExecute)
Next (ActionLoadUnitExecute)


Sepi

Sepi
Previous (ActionExitExecute)
Next (FindComponentNode)

Name
ActionLoadUnitExecute

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Action Charger une unité

Source code
procedure ActionLoadUnitExecute ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ActionExitExecute)
Next (FindComponentNode)


Sepi

Sepi
Previous (ActionLoadUnitExecute)
Next (FormCreate)

Name
FindComponentNode

Parent
TExplorerForm

Visibility
PUBLIC

Description
Trouve le noeud de l'arbre correspondant à un meta donné
Il n'y a aucun test de vérification d'erreur

Source code
function FindComponentNode ( Component : TSepiComponent ) : PVirtualNode

Parameters
Parameter | Description
Component : TSepiComponent | Component recherché

Return
Types | Description
PVirtualNode | Noeud correspondant

Sepi
Class Tree
Index
Previous (ActionLoadUnitExecute)
Next (FormCreate)


Sepi

Sepi
Previous (FindComponentNode)
Next (FormDestroy)

Name
FormCreate

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Création de la fiche

Source code
procedure FormCreate ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FindComponentNode)
Next (FormDestroy)


Sepi

Sepi
Previous (FormCreate)
Next (GetNodeComponent)

Name
FormDestroy

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Destruction de la fiche

Source code
procedure FormDestroy ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FormCreate)
Next (GetNodeComponent)


Sepi

Sepi
Previous (FormDestroy)
Next (GetRuntimeMethod)

Name
GetNodeComponent

Parent
TExplorerForm

Visibility
PRIVATE

Description
Obtient le meta représenté par un noeud donné

Source code
function GetNodeComponent ( Node : PVirtualNode ) : TSepiComponent

Parameters
Parameter | Description
Node : PVirtualNode | Noeud de l'arbre

Return
Types | Description
TSepiComponent | Component représenté par ce noeud

Sepi
Class Tree
Index
Previous (FormDestroy)
Next (GetRuntimeMethod)


Sepi

Sepi
Previous (GetNodeComponent)
Next (LoadUnit)

Name
GetRuntimeMethod

Parent
TExplorerForm

Visibility
PRIVATE

Description
Trouve la méthode run-time correspondant à une méthode Sepi

Source code
function GetRuntimeMethod ( SepiMethod : TSepiMethod ) : TSepiRuntimeMethod

Parameters
Parameter | Description
SepiMethod : TSepiMethod | Méthode Sepi

Return
Types | Description
TSepiRuntimeMethod | Méthode run-time correspondante, ou nil si non trouvée

Sepi
Class Tree
Index
Previous (GetNodeComponent)
Next (LoadUnit)


Sepi

Sepi
Previous (GetRuntimeMethod)
Next (RootLoadUnit)

Name
LoadUnit

Parent
TExplorerForm

Visibility
PRIVATE

Description
Charge une unité et l'affiche dans l'arbre

Source code
procedure LoadUnit ( const UnitName : string )

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité à charger

Sepi
Class Tree
Index
Previous (GetRuntimeMethod)
Next (RootLoadUnit)


Sepi

Sepi
Previous (LoadUnit)
Next (TreeViewChange)

Name
RootLoadUnit

Parent
TExplorerForm

Visibility
PRIVATE

Description
Charge une unité

Source code
function RootLoadUnit ( Sender : TSepiRoot ; const UnitName : string ) : TSepiUnit

Parameters
Parameter | Description
Sender : TSepiRoot | Racine Sepi
UnitName : STRING | Nom de l'unité à charger

Return
Types | Description
TSepiUnit | Unité chargée, ou nil si non trouvée

Sepi
Class Tree
Index
Previous (LoadUnit)
Next (TreeViewChange)


Sepi

Sepi
Previous (RootLoadUnit)
Next (TreeViewGetText)

Name
TreeViewChange

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Changement de sélection dans le treeview

Source code
procedure TreeViewChange ( Sender : TBaseVirtualTree ; Node : PVirtualNode )

Parameters
Parameter | Description
Sender : TBaseVirtualTree | #Pas de TAG trouvé dans le code source#
Node : PVirtualNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (RootLoadUnit)
Next (TreeViewGetText)


Sepi

Sepi
Previous (TreeViewChange)
Next (TreeViewInitChildren)

Name
TreeViewGetText

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Récupérer le nom d'un noeud

Source code
procedure TreeViewGetText ( Sender : TBaseVirtualTree ; Node : PVirtualNode ; Column : TColumnIndex ; TextType : TVSTTextType ; var CellText : string )

Parameters
Parameter | Description
Sender : TBaseVirtualTree | #Pas de TAG trouvé dans le code source#
Node : PVirtualNode | #Pas de TAG trouvé dans le code source#
Column : TColumnIndex | #Pas de TAG trouvé dans le code source#
TextType : TVSTTextType | #Pas de TAG trouvé dans le code source#
CellText : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (TreeViewChange)
Next (TreeViewInitChildren)


Sepi

Sepi
Previous (TreeViewGetText)
Next (TreeViewInitNode)

Name
TreeViewInitChildren

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Initialise le nombre d'enfants d'un noeud

Source code
procedure TreeViewInitChildren ( Sender : TBaseVirtualTree ; Node : PVirtualNode ; var ChildCount : Cardinal )

Parameters
Parameter | Description
Sender : TBaseVirtualTree | #Pas de TAG trouvé dans le code source#
Node : PVirtualNode | #Pas de TAG trouvé dans le code source#
ChildCount : CARDINAL | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (TreeViewGetText)
Next (TreeViewInitNode)


Sepi

Sepi
Previous (TreeViewInitChildren)
Next

Name
TreeViewInitNode

Parent
TExplorerForm

Visibility
PUBLISHED

Description
Initialise un noeud

Source code
procedure TreeViewInitNode ( Sender : TBaseVirtualTree ; ParentNode , Node : PVirtualNode ; var InitialStates : TVirtualNodeInitStates )

Parameters
Parameter | Description
Sender : TBaseVirtualTree | #Pas de TAG trouvé dans le code source#
ParentNode : PVirtualNode | #Pas de TAG trouvé dans le code source#
Node : PVirtualNode | #Pas de TAG trouvé dans le code source#
InitialStates : TVirtualNodeInitStates | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (TreeViewInitChildren)
Next


Sepi

Sepi
Previous
Next

Name
ExplorerForm

Parent
SepiExplorerMain

Visibility
PUBLIC

Description
Form principale

Source code
ExplorerForm : TExplorerForm

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiExplorerMain)
Next (SepiInCalls)

Name
SepiExpressions

Parent
Sepi

Description
Expressions Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TSepiArrayBoundKind (+) | Type de borne de tableau
TSepiOperation (+) | Opération Sepi
TSepiTypeOperation (+) | Opération Sepi sur un type

Constants
Constant | Description
opAllOps (+) | Toutes les opérations valides
opBinaryOps (+) | Operations binaires (dont comparaisons)
opComparisonOps (+) | Opérations de comparaison
opUnaryOps (+) | Opérations unaires

Methods
Method | Description
DefaultSepiTypeFor (+) | Trouve le type Sepi par défaut correspondant à un type de base
IsZeroMemory (+) | Teste si une valeur est un zéro mémoire, tel qu'on peut utiliser msZero
NeedDestination (+) | Exige une destination mémoire valide
SepiTypeToBaseType (+) | Récupère le type de base correspondant à un type Sepi
SepiTypeToBaseType (+) | Récupère le type de base correspondant à un type Sepi
SmallestIntegerTypeFor (+) | Plus petit type entier pouvant contenir l'entier spécifié

Classes
Class | Description
ISepiAddressableValue (+) | Valeur dont on peut récupérer l'adresse à l'exécution
ISepiComponentExpression (+) | Expression qui représente un meta
ISepiExecutable (+) | Expression qui peut être exécutée
ISepiOpenArrayBuilder (+) | Constructeur de tableau ouvert
ISepiOpenArrayValue (+) | Valeur tableau ouvert
ISepiProperty (+) | Propriété
ISepiReadableValue (+) | Valeur qui peut être lue à l'exécution
ISepiSetBuilder (+) | Constructeur d'ensemble
ISepiSetOrOpenArrayBuilder (+) | Constructeur d'ensemble ou de tableau ouvert
ISepiTypeExpression (+) | Expression qui représente un type
ISepiTypeForceableSetValue (+) | Valeur ensemble dont le type d'ensemble ou d'élément peut être forcé
ISepiTypeForceableValue (+) | Valeur dont le type peut être forcé
ISepiValue (+) | Valeur
ISepiWantingParams (+) | Expression qui peut être appelée
ISepiWritableValue (+) | Valeur qui peut être modifiée à l'exécution
TSepiAddressOfValue (+) | Opérateur d'adressage
TSepiArithmeticLogicOperation (+) | Opération arithmétique ou logique
TSepiArrayBoundValue (+) | Borne d'un tableau (Low, High ou Length)
TSepiArrayItemValue (+) | Valeur élément de de tableau
TSepiAsOperation (+) | Opération as
TSepiAssignmentOperation (+) | Opération d'assignation
TSepiBinaryOperation (+) | Opération binaire (dont comparaisons)
TSepiCastOperator (+) | Opérateur de transtypage
TSepiComponentExpression (+) | Expression représentant un meta
TSepiConvertOperation (+) | Opération de conversion
TSepiCustomCallable (+) | Classe de base pour les expressions qui peuvent être invoquées
TSepiCustomComputedValue (+) | Classe de base pour des valeurs à calculer
TSepiCustomDirectValue (+) | Implémentation de base de ISepiDirectValue
TSepiCustomExecutable (+) | Classe de base pour les expressions exécutables
TSepiCustomExpressionPart (+) | Implémentation de base de ISepiExpressionPart
TSepiCustomWithParams (+) | Classe de base pour les expressions qui ont des paramètres
TSepiDereferenceValue (+) | Opérateur de déréférencement
TSepiDynArrayCopyExpression (+) | Expression copie d'une partie d'une chaîne de caractères
TSepiDynArraySetLengthExpression (+) | Expression de changement de la longueur d'un tableau dynamique
TSepiErroneousValue (+) | Valeur erronée
TSepiFloatLiteralValue (+) | Valeur constante litérale entière
TSepiInSetOperation (+) | Opération in (appartenance à un ensemble)
TSepiInstructionExpression (+) | Expression wrapper pour une instruction
TSepiIntegerLiteralValue (+) | Valeur constante litérale entière
TSepiIsAsOperation (+) | Classe de base pour les opérations is et as
TSepiIsOperation (+) | Opération is
TSepiLiteralValue (+) | Valeur constante litérale
TSepiLocalVarValue (+) | Valeur variable locale
TSepiMetaClassValue (+) | Valeur meta-classe
TSepiMethodCall (+) | Appel de méthode
TSepiMethodRefCall (+) | Appel de référence de méthode
TSepiNilValue (+) | Valeur nil
TSepiObjectFieldValue (+) | Valeur champ d'un objet
TSepiOpenArrayBuilder (+) | Valeur tableau ouvert construit sur place
TSepiOpenArrayFromArrayValue (+) | Valeur tableau ouvert construit à partir d'une valeur tableau
TSepiOperator (+) | Opérateur Sepi
TSepiPropertyValue (+) | Valeur propriété
TSepiPureInheritedCall (+) | Appel inherited pur (même nom de méthode et mêmes paramètres)
TSepiRecordFieldValue (+) | Valeur champ de record
TSepiSetBuilder (+) | Constructeur d'ensemble
TSepiSetBuilderRange (+) | Intervalle de valeurs dans un constructeur d'ensemble
TSepiSetOperation (+) | Opération sur des ensembles
TSepiSetOrOpenArrayBuilder (+) | Constructeur d'ensemble ou de tableau ouvert
TSepiStrCopyExpression (+) | Expression copie d'une partie d'une chaîne de caractères
TSepiStringLengthValue (+) | Longueur d'une chaîne de caractères
TSepiStringLiteralValue (+) | Valeur constante litérale chaîne
TSepiStrSetLengthExpression (+) | Expression de changement de la longueur d'une chaîne de caractères
TSepiTrueConstValue (+) | Valeur constante
TSepiTypeExpression (+) | Expression représentant un type
TSepiTypeOperationValue (+) | Opération sur un type
TSepiUnaryOperation (+) | Opération unaire
TSepiVariableValue (+) | Valeur variable globale

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiExplorerMain)
Next (SepiInCalls)


Sepi

Sepi
Previous
Next (ISepiComponentExpression)

Name
ISepiAddressableValue

Parent
SepiExpressions

Class Hierarchy
ISepiValue

Visibility
PUBLIC

Description
Valeur dont on peut récupérer l'adresse à l'exécution

Members
Methods
Method | Description
CompileLoadAddress (+) | #No TAG found in source code#
GetAddressType (+) | #No TAG found in source code#

Properties
Property | Description
AddressType (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ISepiComponentExpression)


Sepi

Sepi
Previous
Next

Name
AddressType

Parent
ISepiAddressableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property AddressType : TSepiType read GetAddressType

Read Access
GetAddressType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetAddressType)

Name
CompileLoadAddress

Parent
ISepiAddressableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileLoadAddress ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (GetAddressType)


Sepi

Sepi
Previous (CompileLoadAddress)
Next

Name
GetAddressType

Parent
ISepiAddressableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetAddressType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileLoadAddress)
Next


Sepi

Sepi
Previous (ISepiAddressableValue)
Next (ISepiExecutable)

Name
ISepiComponentExpression

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Expression qui représente un meta

Members
Methods
Method | Description
GetComponent (+) | #No TAG found in source code#

Properties
Property | Description
Component (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiAddressableValue)
Next (ISepiExecutable)


Sepi

Sepi
Previous
Next

Name
Component

Parent
ISepiComponentExpression

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Component : TSepiComponent read GetComponent

Read Access
GetComponent

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
GetComponent

Parent
ISepiComponentExpression

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetComponent : TSepiComponent

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ISepiComponentExpression)
Next (ISepiOpenArrayBuilder)

Name
ISepiExecutable

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Expression qui peut être exécutée

Members
Methods
Method | Description
CompileExecute (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiComponentExpression)
Next (ISepiOpenArrayBuilder)


Sepi

Sepi
Previous
Next

Name
CompileExecute

Parent
ISepiExecutable

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ISepiExecutable)
Next (ISepiOpenArrayValue)

Name
ISepiOpenArrayBuilder

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Constructeur de tableau ouvert

Members
Methods
Method | Description
AddItem (+) | #No TAG found in source code#
Complete (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiExecutable)
Next (ISepiOpenArrayValue)


Sepi

Sepi
Previous
Next (Complete)

Name
AddItem

Parent
ISepiOpenArrayBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddItem ( const AItem : ISepiReadableValue )

Parameters
Parameter | Description
AItem : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (AddItem)
Next

Name
Complete

Parent
ISepiOpenArrayBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddItem)
Next


Sepi

Sepi
Previous (ISepiOpenArrayBuilder)
Next (ISepiProperty)

Name
ISepiOpenArrayValue

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Valeur tableau ouvert

Members
Methods
Method | Description
CanForceElementType (+) | #No TAG found in source code#
CompileReadOpenArray (+) | #No TAG found in source code#
ForceElementType (+) | #No TAG found in source code#
GetElementType (+) | #No TAG found in source code#

Properties
Property | Description
ElementType (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiOpenArrayBuilder)
Next (ISepiProperty)


Sepi

Sepi
Previous
Next

Name
ElementType

Parent
ISepiOpenArrayValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ElementType : TSepiType read GetElementType

Read Access
GetElementType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileReadOpenArray)

Name
CanForceElementType

Parent
ISepiOpenArrayValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function CanForceElementType ( AElementType : TSepiType ) : Boolean

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileReadOpenArray)


Sepi

Sepi
Previous (CanForceElementType)
Next (ForceElementType)

Name
CompileReadOpenArray

Parent
ISepiOpenArrayValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileReadOpenArray ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var OpenArrayDest , HighValueDest : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
OpenArrayDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
HighValueDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceElementType)
Next (ForceElementType)


Sepi

Sepi
Previous (CompileReadOpenArray)
Next (GetElementType)

Name
ForceElementType

Parent
ISepiOpenArrayValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ForceElementType ( AElementType : TSepiType )

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileReadOpenArray)
Next (GetElementType)


Sepi

Sepi
Previous (ForceElementType)
Next

Name
GetElementType

Parent
ISepiOpenArrayValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetElementType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceElementType)
Next


Sepi

Sepi
Previous (ISepiOpenArrayValue)
Next (ISepiReadableValue)

Name
ISepiProperty

Parent
SepiExpressions

Class Hierarchy
ISepiValue

Visibility
PUBLIC

Description
Propriété

Members
Methods
Method | Description
CompleteParams (+) | #No TAG found in source code#
GetParamCount (+) | #No TAG found in source code#
GetParams (+) | #No TAG found in source code#
GetParamsCompleted (+) | #No TAG found in source code#
SetParams (+) | #No TAG found in source code#

Properties
Property | Description
ParamCount (+) | #No TAG found in source code#
Params (+) | #No TAG found in source code#
ParamsCompleted (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiOpenArrayValue)
Next (ISepiReadableValue)


Sepi

Sepi
Previous
Next (Params)

Name
ParamCount

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParamCount : Integer read GetParamCount

Read Access
GetParamCount

Sepi
Class Tree
Index
Previous
Next (Params)


Sepi

Sepi
Previous (ParamCount)
Next (ParamsCompleted)

Name
Params

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Params [ Index : Integer ] : ISepiExpression read GetParams write SetParams

Read Access
GetParams

Write Access
SetParams

Sepi
Class Tree
Index
Previous (ParamCount)
Next (ParamsCompleted)


Sepi

Sepi
Previous (Params)
Next

Name
ParamsCompleted

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParamsCompleted : Boolean read GetParamsCompleted

Read Access
GetParamsCompleted

Sepi
Class Tree
Index
Previous (Params)
Next


Sepi

Sepi
Previous
Next (GetParamCount)

Name
CompleteParams

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompleteParams

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetParamCount)


Sepi

Sepi
Previous (CompleteParams)
Next (GetParams)

Name
GetParamCount

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParamCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (GetParams)


Sepi

Sepi
Previous (GetParamCount)
Next (GetParamsCompleted)

Name
GetParams

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParams ( Index : Integer ) : ISepiExpression

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetParamCount)
Next (GetParamsCompleted)


Sepi

Sepi
Previous (GetParams)
Next (SetParams)

Name
GetParamsCompleted

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParamsCompleted : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetParams)
Next (SetParams)


Sepi

Sepi
Previous (GetParamsCompleted)
Next

Name
SetParams

Parent
ISepiProperty

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetParams ( Index : Integer ; const Value : ISepiExpression )

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#
Value : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetParamsCompleted)
Next


Sepi

Sepi
Previous (ISepiProperty)
Next (ISepiSetBuilder)

Name
ISepiReadableValue

Parent
SepiExpressions

Class Hierarchy
ISepiValue

Visibility
PUBLIC

Description
Valeur qui peut être lue à l'exécution

Members
Methods
Method | Description
CompileRead (+) | #No TAG found in source code#
GetConstValuePtr (+) | #No TAG found in source code#
GetIsConstant (+) | #No TAG found in source code#

Properties
Property | Description
ConstValuePtr (+) | #No TAG found in source code#
IsConstant (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiProperty)
Next (ISepiSetBuilder)


Sepi

Sepi
Previous
Next (IsConstant)

Name
ConstValuePtr

Parent
ISepiReadableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ConstValuePtr : Pointer read GetConstValuePtr

Read Access
GetConstValuePtr

Sepi
Class Tree
Index
Previous
Next (IsConstant)


Sepi

Sepi
Previous (ConstValuePtr)
Next

Name
IsConstant

Parent
ISepiReadableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property IsConstant : Boolean read GetIsConstant

Read Access
GetIsConstant

Sepi
Class Tree
Index
Previous (ConstValuePtr)
Next


Sepi

Sepi
Previous
Next (GetConstValuePtr)

Name
CompileRead

Parent
ISepiReadableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (GetConstValuePtr)


Sepi

Sepi
Previous (CompileRead)
Next (GetIsConstant)

Name
GetConstValuePtr

Parent
ISepiReadableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileRead)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetConstValuePtr)
Next

Name
GetIsConstant

Parent
ISepiReadableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next


Sepi

Sepi
Previous (ISepiReadableValue)
Next (ISepiSetOrOpenArrayBuilder)

Name
ISepiSetBuilder

Parent
SepiExpressions

Class Hierarchy
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
Constructeur d'ensemble

Members
Methods
Method | Description
AddRange (+) | #No TAG found in source code#
AddSingle (+) | #No TAG found in source code#
Complete (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiReadableValue)
Next (ISepiSetOrOpenArrayBuilder)


Sepi

Sepi
Previous
Next (AddSingle)

Name
AddRange

Parent
ISepiSetBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddRange ( const Lower , Higher : ISepiReadableValue )

Parameters
Parameter | Description
Lower : ISepiReadableValue | #Pas de TAG trouvé dans le code source#
Higher : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AddSingle)


Sepi

Sepi
Previous (AddRange)
Next (Complete)

Name
AddSingle

Parent
ISepiSetBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddSingle ( const Value : ISepiReadableValue )

Parameters
Parameter | Description
Value : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddRange)
Next (Complete)


Sepi

Sepi
Previous (AddSingle)
Next

Name
Complete

Parent
ISepiSetBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddSingle)
Next


Sepi

Sepi
Previous (ISepiSetBuilder)
Next (ISepiTypeExpression)

Name
ISepiSetOrOpenArrayBuilder

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Constructeur d'ensemble ou de tableau ouvert

Members
Methods
Method | Description
AddRange (+) | #No TAG found in source code#
AddSingle (+) | #No TAG found in source code#
Complete (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiSetBuilder)
Next (ISepiTypeExpression)


Sepi

Sepi
Previous
Next (AddSingle)

Name
AddRange

Parent
ISepiSetOrOpenArrayBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddRange ( const Lower , Higher : ISepiReadableValue )

Parameters
Parameter | Description
Lower : ISepiReadableValue | #Pas de TAG trouvé dans le code source#
Higher : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AddSingle)


Sepi

Sepi
Previous (AddRange)
Next (Complete)

Name
AddSingle

Parent
ISepiSetOrOpenArrayBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddSingle ( const Value : ISepiReadableValue )

Parameters
Parameter | Description
Value : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddRange)
Next (Complete)


Sepi

Sepi
Previous (AddSingle)
Next

Name
Complete

Parent
ISepiSetOrOpenArrayBuilder

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddSingle)
Next


Sepi

Sepi
Previous (ISepiSetOrOpenArrayBuilder)
Next (ISepiTypeForceableSetValue)

Name
ISepiTypeExpression

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Expression qui représente un type

Members
Methods
Method | Description
GetType (+) | #No TAG found in source code#

Properties
Property | Description
ExprType (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiSetOrOpenArrayBuilder)
Next (ISepiTypeForceableSetValue)


Sepi

Sepi
Previous
Next

Name
ExprType

Parent
ISepiTypeExpression

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ExprType : TSepiType read GetType

Read Access
GetType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
GetType

Parent
ISepiTypeExpression

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ISepiTypeExpression)
Next (ISepiTypeForceableValue)

Name
ISepiTypeForceableSetValue

Parent
SepiExpressions

Class Hierarchy
ISepiTypeForceableValue

Visibility
PUBLIC

Description
Valeur ensemble dont le type d'ensemble ou d'élément peut être forcé

Members
Methods
Method | Description
CanForceCompType (+) | #No TAG found in source code#
ForceCompType (+) | #No TAG found in source code#
GetCompKind (+) | #No TAG found in source code#
GetCompType (+) | #No TAG found in source code#
GetHigherBound (+) | #No TAG found in source code#
GetIsEmpty (+) | #No TAG found in source code#
GetLowerBound (+) | #No TAG found in source code#
GetSetType (+) | #No TAG found in source code#

Properties
Property | Description
CompKind (+) | #No TAG found in source code#
CompType (+) | #No TAG found in source code#
HigherBound (+) | #No TAG found in source code#
IsEmpty (+) | #No TAG found in source code#
LowerBound (+) | #No TAG found in source code#
SetType (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiTypeExpression)
Next (ISepiTypeForceableValue)


Sepi

Sepi
Previous
Next (CompType)

Name
CompKind

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property CompKind : TTypeKind read GetCompKind

Read Access
GetCompKind

Sepi
Class Tree
Index
Previous
Next (CompType)


Sepi

Sepi
Previous (CompKind)
Next (HigherBound)

Name
CompType

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property CompType : TSepiOrdType read GetCompType

Read Access
GetCompType

Sepi
Class Tree
Index
Previous (CompKind)
Next (HigherBound)


Sepi

Sepi
Previous (CompType)
Next (IsEmpty)

Name
HigherBound

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property HigherBound : Integer read GetHigherBound

Read Access
GetHigherBound

Sepi
Class Tree
Index
Previous (CompType)
Next (IsEmpty)


Sepi

Sepi
Previous (HigherBound)
Next (LowerBound)

Name
IsEmpty

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property IsEmpty : Boolean read GetIsEmpty

Read Access
GetIsEmpty

Sepi
Class Tree
Index
Previous (HigherBound)
Next (LowerBound)


Sepi

Sepi
Previous (IsEmpty)
Next (SetType)

Name
LowerBound

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property LowerBound : Integer read GetLowerBound

Read Access
GetLowerBound

Sepi
Class Tree
Index
Previous (IsEmpty)
Next (SetType)


Sepi

Sepi
Previous (LowerBound)
Next

Name
SetType

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property SetType : TSepiSetType read GetSetType

Read Access
GetSetType

Sepi
Class Tree
Index
Previous (LowerBound)
Next


Sepi

Sepi
Previous
Next (ForceCompType)

Name
CanForceCompType

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function CanForceCompType ( ACompType : TSepiOrdType ) : Boolean

Parameters
Parameter | Description
ACompType : TSepiOrdType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ForceCompType)


Sepi

Sepi
Previous (CanForceCompType)
Next (GetCompKind)

Name
ForceCompType

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ForceCompType ( ACompType : TSepiOrdType )

Parameters
Parameter | Description
ACompType : TSepiOrdType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceCompType)
Next (GetCompKind)


Sepi

Sepi
Previous (ForceCompType)
Next (GetCompType)

Name
GetCompKind

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetCompKind : TTypeKind

Parameters
Parameter Description

Return
Types | Description
TTypeKind | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceCompType)
Next (GetCompType)


Sepi

Sepi
Previous (GetCompKind)
Next (GetHigherBound)

Name
GetCompType

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetCompType : TSepiOrdType

Parameters
Parameter Description

Return
Types | Description
TSepiOrdType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCompKind)
Next (GetHigherBound)


Sepi

Sepi
Previous (GetCompType)
Next (GetIsEmpty)

Name
GetHigherBound

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetHigherBound : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCompType)
Next (GetIsEmpty)


Sepi

Sepi
Previous (GetHigherBound)
Next (GetLowerBound)

Name
GetIsEmpty

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetIsEmpty : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetHigherBound)
Next (GetLowerBound)


Sepi

Sepi
Previous (GetIsEmpty)
Next (GetSetType)

Name
GetLowerBound

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetLowerBound : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsEmpty)
Next (GetSetType)


Sepi

Sepi
Previous (GetLowerBound)
Next

Name
GetSetType

Parent
ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetSetType : TSepiSetType

Parameters
Parameter Description

Return
Types | Description
TSepiSetType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetLowerBound)
Next


Sepi

Sepi
Previous (ISepiTypeForceableSetValue)
Next (ISepiValue)

Name
ISepiTypeForceableValue

Parent
SepiExpressions

Class Hierarchy
ISepiValue

Visibility
PUBLIC

Description
Valeur dont le type peut être forcé

Members
Methods
Method | Description
CanForceType (+) | #No TAG found in source code#
ForceType (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiTypeForceableSetValue)
Next (ISepiValue)


Sepi

Sepi
Previous
Next (ForceType)

Name
CanForceType

Parent
ISepiTypeForceableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ForceType)


Sepi

Sepi
Previous (CanForceType)
Next

Name
ForceType

Parent
ISepiTypeForceableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceType)
Next


Sepi

Sepi
Previous (ISepiTypeForceableValue)
Next (ISepiWantingParams)

Name
ISepiValue

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Valeur

Members
Methods
Method | Description
GetValueType (+) | #No TAG found in source code#

Properties
Property | Description
ValueType (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiTypeForceableValue)
Next (ISepiWantingParams)


Sepi

Sepi
Previous
Next

Name
ValueType

Parent
ISepiValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ValueType : TSepiType read GetValueType

Read Access
GetValueType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
GetValueType

Parent
ISepiValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ISepiValue)
Next (ISepiWritableValue)

Name
ISepiWantingParams

Parent
SepiExpressions

Class Hierarchy
ISepiExpressionPart

Visibility
PUBLIC

Description
Expression qui peut être appelée

Members
Methods
Method | Description
AddParam (+) | #No TAG found in source code#
CompleteParams (+) | #No TAG found in source code#
GetParamCount (+) | #No TAG found in source code#
GetParams (+) | #No TAG found in source code#
GetParamsCompleted (+) | #No TAG found in source code#

Properties
Property | Description
ParamCount (+) | #No TAG found in source code#
Params (+) | #No TAG found in source code#
ParamsCompleted (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiValue)
Next (ISepiWritableValue)


Sepi

Sepi
Previous
Next (Params)

Name
ParamCount

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParamCount : Integer read GetParamCount

Read Access
GetParamCount

Sepi
Class Tree
Index
Previous
Next (Params)


Sepi

Sepi
Previous (ParamCount)
Next (ParamsCompleted)

Name
Params

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Params [ Index : Integer ] : ISepiExpression read GetParams

Read Access
GetParams

Sepi
Class Tree
Index
Previous (ParamCount)
Next (ParamsCompleted)


Sepi

Sepi
Previous (Params)
Next

Name
ParamsCompleted

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParamsCompleted : Boolean read GetParamsCompleted

Read Access
GetParamsCompleted

Sepi
Class Tree
Index
Previous (Params)
Next


Sepi

Sepi
Previous
Next (CompleteParams)

Name
AddParam

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddParam ( const Value : ISepiExpression )

Parameters
Parameter | Description
Value : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompleteParams)


Sepi

Sepi
Previous (AddParam)
Next (GetParamCount)

Name
CompleteParams

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompleteParams

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddParam)
Next (GetParamCount)


Sepi

Sepi
Previous (CompleteParams)
Next (GetParams)

Name
GetParamCount

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParamCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (GetParams)


Sepi

Sepi
Previous (GetParamCount)
Next (GetParamsCompleted)

Name
GetParams

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParams ( Index : Integer ) : ISepiExpression

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetParamCount)
Next (GetParamsCompleted)


Sepi

Sepi
Previous (GetParams)
Next

Name
GetParamsCompleted

Parent
ISepiWantingParams

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParamsCompleted : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetParams)
Next


Sepi

Sepi
Previous (ISepiWantingParams)
Next (TSepiAddressOfValue)

Name
ISepiWritableValue

Parent
SepiExpressions

Class Hierarchy
ISepiValue

Visibility
PUBLIC

Description
Valeur qui peut être modifiée à l'exécution

Members
Methods
Method | Description
CompileWrite (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiWantingParams)
Next (TSepiAddressOfValue)


Sepi

Sepi
Previous
Next

Name
CompileWrite

Parent
ISepiWritableValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileWrite ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Source : ISepiReadableValue )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Source : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (ISepiWritableValue)
Next (TSepiArithmeticLogicOperation)

Name
TSepiAddressOfValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Opérateur d'adressage

Members
Fields
Field | Description
FOperand (-) | Opérande

Methods
Method | Description
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'opérateur d'adressage
MakeAddressOf (+) | Construit un opérateur d'adressage

Properties
Property | Description
Operand (+) | Opérande

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ISepiWritableValue)
Next (TSepiArithmeticLogicOperation)


Sepi

Sepi
Previous
Next

Name
FOperand

Parent
TSepiAddressOfValue

Visibility
PRIVATE

Description
Opérande

Source code
FOperand : ISepiAddressableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Operand

Parent
TSepiAddressOfValue

Visibility
PUBLIC

Description
Opérande

Source code
property Operand : ISepiAddressableValue read FOperand write FOperand

Read Access
FOperand

Write Access
FOperand

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Complete)

Name
CompileCompute

Parent
TSepiAddressOfValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (MakeAddressOf)

Name
Complete

Parent
TSepiAddressOfValue

Visibility
PUBLIC

Description
Complète l'opérateur d'adressage

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (MakeAddressOf)


Sepi

Sepi
Previous (Complete)
Next

Name
MakeAddressOf

Parent
TSepiAddressOfValue

Visibility
PUBLIC

Description
Construit un opérateur d'adressage

Source code
class function MakeAddressOf ( const Operand : ISepiAddressableValue ) : ISepiReadableValue

Parameters
Parameter | Description
Operand : ISepiAddressableValue | Opérande

Return
Types | Description
ISepiReadableValue | Valeur représentant l'opérateur d'adressage

Sepi
Class Tree
Index
Previous (Complete)
Next


Sepi

Sepi
Previous (TSepiAddressOfValue)
Next (TSepiArrayBoundValue)

Name
TSepiArithmeticLogicOperation

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Opération arithmétique ou logique

Members
Fields
Field | Description
FOperation (-) | Opération

Methods
Method | Description
Create (+) | Crée l'opération
GetOpCode (#) | Obtient l'OpCode correspondant à cette opération

Properties
Property | Description
Operation (+) | Opération

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAddressOfValue)
Next (TSepiArrayBoundValue)


Sepi

Sepi
Previous
Next

Name
FOperation

Parent
TSepiArithmeticLogicOperation

Visibility
PRIVATE

Description
Opération

Source code
FOperation : TSepiOperation

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Operation

Parent
TSepiArithmeticLogicOperation

Visibility
PUBLIC

Description
Opération

Source code
property Operation : TSepiOperation read FOperation

Read Access
FOperation

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetOpCode)

Name
Create

Parent
TSepiArithmeticLogicOperation

Visibility
PUBLIC

Description
Crée l'opération

Source code
constructor Create ( AOperation : TSepiOperation )

Parameters
Parameter | Description
AOperation : TSepiOperation | Opération

Sepi
Class Tree
Index
Previous
Next (GetOpCode)


Sepi

Sepi
Previous (Create)
Next

Name
GetOpCode

Parent
TSepiArithmeticLogicOperation

Visibility
PROTECTED

Description
Obtient l'OpCode correspondant à cette opération

Source code
function GetOpCode ( SelfOp : Boolean ) : TSepiOpCode

Parameters
Parameter | Description
SelfOp : BOOLEAN | Si True, utilise une instruction réflexive

Return
Types | Description
TSepiOpCode | OpCode de l'opération

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiArithmeticLogicOperation)
Next (TSepiArrayItemValue)

Name
TSepiArrayBoundValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Borne d'un tableau (Low, High ou Length)

Members
Fields
Field | Description
FArrayType (-) | Type tableau de l'opérande
FKind (-) | Type de borne
FOperand (-) | Opérande

Methods
Method | Description
CheckTypes (-) | Vérification de type
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
CompileComputeDynArray (#) | [@inheritDoc]
CompileComputeOpenArray (#) | [@inheritDoc]
Complete (+) | Complète l'opération
Create (+) | Crée une valeur borne de tableau
MakeArrayBoundValue (+) | Construit une valeur longueur de chaîne de caractères

Properties
Property | Description
ArrayType (#) | Type tableau de l'opérande
Kind (+) | Type de borne
Operand (+) | Opérande

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiArithmeticLogicOperation)
Next (TSepiArrayItemValue)


Sepi

Sepi
Previous
Next (FKind)

Name
FArrayType

Parent
TSepiArrayBoundValue

Visibility
PRIVATE

Description
Type tableau de l'opérande

Source code
FArrayType : TSepiArrayType

Sepi
Class Tree
Index
Previous
Next (FKind)


Sepi

Sepi
Previous (FArrayType)
Next (FOperand)

Name
FKind

Parent
TSepiArrayBoundValue

Visibility
PRIVATE

Description
Type de borne

Source code
FKind : TSepiArrayBoundKind

Sepi
Class Tree
Index
Previous (FArrayType)
Next (FOperand)


Sepi

Sepi
Previous (FKind)
Next

Name
FOperand

Parent
TSepiArrayBoundValue

Visibility
PRIVATE

Description
Opérande

Source code
FOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FKind)
Next


Sepi

Sepi
Previous
Next (Kind)

Name
ArrayType

Parent
TSepiArrayBoundValue

Visibility
PROTECTED

Description
Type tableau de l'opérande

Source code
property ArrayType : TSepiArrayType read FArrayType

Read Access
FArrayType

Sepi
Class Tree
Index
Previous
Next (Kind)


Sepi

Sepi
Previous (ArrayType)
Next (Operand)

Name
Kind

Parent
TSepiArrayBoundValue

Visibility
PUBLIC

Description
Type de borne

Source code
property Kind : TSepiArrayBoundKind read FKind

Read Access
FKind

Sepi
Class Tree
Index
Previous (ArrayType)
Next (Operand)


Sepi

Sepi
Previous (Kind)
Next

Name
Operand

Parent
TSepiArrayBoundValue

Visibility
PUBLIC

Description
Opérande

Source code
property Operand : ISepiReadableValue read FOperand write FOperand

Read Access
FOperand

Write Access
FOperand

Sepi
Class Tree
Index
Previous (Kind)
Next


Sepi

Sepi
Previous
Next (CollapseConsts)

Name
CheckTypes

Parent
TSepiArrayBoundValue

Visibility
PRIVATE

Description
Vérification de type

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CollapseConsts)


Sepi

Sepi
Previous (CheckTypes)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiArrayBoundValue

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (CompileComputeDynArray)

Name
CompileCompute

Parent
TSepiArrayBoundValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (CompileComputeDynArray)


Sepi

Sepi
Previous (CompileCompute)
Next (CompileComputeOpenArray)

Name
CompileComputeDynArray

Parent
TSepiArrayBoundValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileComputeDynArray ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (CompileComputeOpenArray)


Sepi

Sepi
Previous (CompileComputeDynArray)
Next (Complete)

Name
CompileComputeOpenArray

Parent
TSepiArrayBoundValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileComputeOpenArray ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileComputeDynArray)
Next (Complete)


Sepi

Sepi
Previous (CompileComputeOpenArray)
Next (Create)

Name
Complete

Parent
TSepiArrayBoundValue

Visibility
PUBLIC

Description
Complète l'opération
L'opération doit avoir été attachée à une expression auparavant, pour pouvoir
bénéficier du contexte de celle-ci.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileComputeOpenArray)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (MakeArrayBoundValue)

Name
Create

Parent
TSepiArrayBoundValue

Visibility
PUBLIC

Description
Crée une valeur borne de tableau

Source code
constructor Create ( AKind : TSepiArrayBoundKind )

Parameters
Parameter | Description
AKind : TSepiArrayBoundKind | Type de borne

Sepi
Class Tree
Index
Previous (Complete)
Next (MakeArrayBoundValue)


Sepi

Sepi
Previous (Create)
Next

Name
MakeArrayBoundValue

Parent
TSepiArrayBoundValue

Visibility
PUBLIC

Description
Construit une valeur longueur de chaîne de caractères

Source code
class function MakeArrayBoundValue ( Kind : TSepiArrayBoundKind ; const Operand : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter | Description
Kind : TSepiArrayBoundKind
Operand : ISepiReadableValue | Opérande

Return
Types | Description
ISepiReadableValue | Valeur représentant la longueur de la chaîne de caractères

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiArrayBoundValue)
Next (TSepiAsOperation)

Name
TSepiArrayItemValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Valeur élément de de tableau

Members
Fields
Field | Description
FArrayType (-) | Type du tableau
FArrayValue (-) | Valeur tableau
FIndexType (-) | Type de l'index
FIndexValue (-) | Valeur index

Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Complete (+) | Complète la valeur
MakeArrayItemValue (+) | Construit une valeur élément de tableau

Properties
Property | Description
ArrayType (#) | Type du tableau
ArrayValue (+) | Valeur tableau
IndexType (#) | Type de l'index
IndexValue (+) | Valeur index

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiArrayBoundValue)
Next (TSepiAsOperation)


Sepi

Sepi
Previous
Next (FArrayValue)

Name
FArrayType

Parent
TSepiArrayItemValue

Visibility
PRIVATE

Description
Type du tableau

Source code
FArrayType : TSepiArrayType

Sepi
Class Tree
Index
Previous
Next (FArrayValue)


Sepi

Sepi
Previous (FArrayType)
Next (FIndexType)

Name
FArrayValue

Parent
TSepiArrayItemValue

Visibility
PRIVATE

Description
Valeur tableau

Source code
FArrayValue : ISepiValue

Sepi
Class Tree
Index
Previous (FArrayType)
Next (FIndexType)


Sepi

Sepi
Previous (FArrayValue)
Next (FIndexValue)

Name
FIndexType

Parent
TSepiArrayItemValue

Visibility
PRIVATE

Description
Type de l'index

Source code
FIndexType : TSepiOrdType

Sepi
Class Tree
Index
Previous (FArrayValue)
Next (FIndexValue)


Sepi

Sepi
Previous (FIndexType)
Next

Name
FIndexValue

Parent
TSepiArrayItemValue

Visibility
PRIVATE

Description
Valeur index

Source code
FIndexValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FIndexType)
Next


Sepi

Sepi
Previous
Next (ArrayValue)

Name
ArrayType

Parent
TSepiArrayItemValue

Visibility
PROTECTED

Description
Type du tableau

Source code
property ArrayType : TSepiArrayType read FArrayType

Read Access
FArrayType

Sepi
Class Tree
Index
Previous
Next (ArrayValue)


Sepi

Sepi
Previous (ArrayType)
Next (IndexType)

Name
ArrayValue

Parent
TSepiArrayItemValue

Visibility
PUBLIC

Description
Valeur tableau

Source code
property ArrayValue : ISepiValue read FArrayValue write FArrayValue

Read Access
FArrayValue

Write Access
FArrayValue

Sepi
Class Tree
Index
Previous (ArrayType)
Next (IndexType)


Sepi

Sepi
Previous (ArrayValue)
Next (IndexValue)

Name
IndexType

Parent
TSepiArrayItemValue

Visibility
PROTECTED

Description
Type de l'index

Source code
property IndexType : TSepiOrdType read FIndexType

Read Access
FIndexType

Sepi
Class Tree
Index
Previous (ArrayValue)
Next (IndexValue)


Sepi

Sepi
Previous (IndexType)
Next

Name
IndexValue

Parent
TSepiArrayItemValue

Visibility
PUBLIC

Description
Valeur index

Source code
property IndexValue : ISepiReadableValue read FIndexValue write FIndexValue

Read Access
FIndexValue

Write Access
FIndexValue

Sepi
Class Tree
Index
Previous (IndexType)
Next


Sepi

Sepi
Previous
Next (Complete)

Name
CompileAsMemoryRef

Parent
TSepiArrayItemValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (MakeArrayItemValue)

Name
Complete

Parent
TSepiArrayItemValue

Visibility
PUBLIC

Description
Complète la valeur
Doit avoir été attaché à une expression au préalable, pour bénéficier du
contexte.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (MakeArrayItemValue)


Sepi

Sepi
Previous (Complete)
Next

Name
MakeArrayItemValue

Parent
TSepiArrayItemValue

Visibility
PUBLIC

Description
Construit une valeur élément de tableau

Source code
class function MakeArrayItemValue ( const ArrayValue : ISepiValue ; const IndexValue : ISepiReadableValue ) : ISepiValue

Parameters
Parameter | Description
ArrayValue : ISepiValue | Valeur tableau
IndexValue : ISepiReadableValue | Valeur index

Return
Types | Description
ISepiValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next


Sepi

Sepi
Previous (TSepiArrayItemValue)
Next (TSepiAssignmentOperation)

Name
TSepiAsOperation

Parent
SepiExpressions

Class Hierarchy
TSepiIsAsOperation

Visibility
PUBLIC

Description
Opération as

Members
Methods
Method | Description
CompileCompute (#) | [@inheritDoc]
UpdateValueType (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiArrayItemValue)
Next (TSepiAssignmentOperation)


Sepi

Sepi
Previous
Next (UpdateValueType)

Name
CompileCompute

Parent
TSepiAsOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (UpdateValueType)


Sepi

Sepi
Previous (CompileCompute)
Next

Name
UpdateValueType

Parent
TSepiAsOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure UpdateValueType ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next


Sepi

Sepi
Previous (TSepiAsOperation)
Next (TSepiBinaryOperation)

Name
TSepiAssignmentOperation

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiExecutable

Visibility
PUBLIC

Description
Opération d'assignation

Members
Fields
Field | Description
FAutoConvert (-) | Si True, l'opérande source est automatiquement converti
FDestination (-) | Destination
FSource (-) | Source

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileExecute (#) | [@inheritDoc]
Complete (+) | Complète l'opération
Create (+) | Crée une opération d'assignation
MakeOperation (+) | Construit une opération d'assignation

Properties
Property | Description
AutoConvert (+) | Si True, l'opérande source est automatiquement converti
Destination (+) | Destination
Source (+) | Source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsOperation)
Next (TSepiBinaryOperation)


Sepi

Sepi
Previous
Next (FDestination)

Name
FAutoConvert

Parent
TSepiAssignmentOperation

Visibility
PRIVATE

Description
Si True, l'opérande source est automatiquement converti

Source code
FAutoConvert : Boolean

Sepi
Class Tree
Index
Previous
Next (FDestination)


Sepi

Sepi
Previous (FAutoConvert)
Next (FSource)

Name
FDestination

Parent
TSepiAssignmentOperation

Visibility
PRIVATE

Description
Destination

Source code
FDestination : ISepiWritableValue

Sepi
Class Tree
Index
Previous (FAutoConvert)
Next (FSource)


Sepi

Sepi
Previous (FDestination)
Next

Name
FSource

Parent
TSepiAssignmentOperation

Visibility
PRIVATE

Description
Source

Source code
FSource : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FDestination)
Next


Sepi

Sepi
Previous
Next (Destination)

Name
AutoConvert

Parent
TSepiAssignmentOperation

Visibility
PUBLIC

Description
Si True, l'opérande source est automatiquement converti

Source code
property AutoConvert : Boolean read FAutoConvert write FAutoConvert

Read Access
FAutoConvert

Write Access
FAutoConvert

Sepi
Class Tree
Index
Previous
Next (Destination)


Sepi

Sepi
Previous (AutoConvert)
Next (Source)

Name
Destination

Parent
TSepiAssignmentOperation

Visibility
PUBLIC

Description
Destination

Source code
property Destination : ISepiWritableValue read FDestination write FDestination

Read Access
FDestination

Write Access
FDestination

Sepi
Class Tree
Index
Previous (AutoConvert)
Next (Source)


Sepi

Sepi
Previous (Destination)
Next

Name
Source

Parent
TSepiAssignmentOperation

Visibility
PUBLIC

Description
Source

Source code
property Source : ISepiReadableValue read FSource write FSource

Read Access
FSource

Write Access
FSource

Sepi
Class Tree
Index
Previous (Destination)
Next


Sepi

Sepi
Previous
Next (CompileExecute)

Name
AttachToExpression

Parent
TSepiAssignmentOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (AttachToExpression)
Next (Complete)

Name
CompileExecute

Parent
TSepiAssignmentOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (Complete)


Sepi

Sepi
Previous (CompileExecute)
Next (Create)

Name
Complete

Parent
TSepiAssignmentOperation

Visibility
PUBLIC

Description
Complète l'opération

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileExecute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (MakeOperation)

Name
Create

Parent
TSepiAssignmentOperation

Visibility
PUBLIC

Description
Crée une opération d'assignation

Source code
constructor Create ( AAutoConvert : Boolean = True )

Parameters
Parameter | Description
AAutoConvert : BOOLEAN | Si True, l'opérande source est automatiquement converti

Sepi
Class Tree
Index
Previous (Complete)
Next (MakeOperation)


Sepi

Sepi
Previous (Create)
Next

Name
MakeOperation

Parent
TSepiAssignmentOperation

Visibility
PUBLIC

Description
Construit une opération d'assignation

Source code
class function MakeOperation ( const Destination : ISepiWritableValue ; const Source : ISepiReadableValue ; AutoConvert : Boolean = True ) : ISepiExecutable

Parameters
Parameter | Description
Destination : ISepiWritableValue | Destination
Source : ISepiReadableValue | Source
AutoConvert : BOOLEAN | Si True, l'opérande source est automatiquement converti

Return
Types | Description
ISepiExecutable | Expression exécutable représentant l'opération

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiAssignmentOperation)
Next (TSepiCastOperator)

Name
TSepiBinaryOperation

Parent
SepiExpressions

Class Hierarchy
TSepiArithmeticLogicOperation

Visibility
PUBLIC

Description
Opération binaire (dont comparaisons)

Members
Fields
Field | Description
FAutoConvert (-) | Si True, les opérandes sont convertis automatiquement
FLeftOperand (-) | Opérande de gauche
FRightOperand (-) | Opérande de droite

Methods
Method | Description
CheckNonBaseTypes (-) | Vérification de types pour des types non de base
CheckTypes (-) | Vérification de types
CheckTypesArithmetic (-) | Vérification de types pour une opération arithmétique
CheckTypesComparison (-) | Vérification de types pour une opération de comparaison
CheckTypesShift (-) | Vérification de types pour une opération shift
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
CompileReadOperandInto (#) | Compile la lecture d'un opérande dans une référence mémoire spécifique
CompileShortCircuitAndOr (#) | [@inheritDoc]
Complete (+) | Complète l'opération
ConvertLeftOperand (#) | Convertit l'opérande de gauche
ConvertRightOperand (#) | Convertit l'opérande de droite
Create (+) | Crée l'opération
DefaultSepiTypeFor (#) | Type Sepi par défaut pour un type de base
ErrorTypeMismatch (#) | Produit une erreur Types incompatibles
MakeOperation (+) | Construit une opération binaire
SmallestCommonType (+) | Trouve le plus petit type commun à deux types de base

Properties
Property | Description
AutoConvert (+) | Si True, les opérandes sont convertis automatiquement
LeftOperand (+) | Opérande de gauche
RightOperand (+) | Opérande de droite

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAssignmentOperation)
Next (TSepiCastOperator)


Sepi

Sepi
Previous
Next (FLeftOperand)

Name
FAutoConvert

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Si True, les opérandes sont convertis automatiquement

Source code
FAutoConvert : Boolean

Sepi
Class Tree
Index
Previous
Next (FLeftOperand)


Sepi

Sepi
Previous (FAutoConvert)
Next (FRightOperand)

Name
FLeftOperand

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Opérande de gauche

Source code
FLeftOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FAutoConvert)
Next (FRightOperand)


Sepi

Sepi
Previous (FLeftOperand)
Next

Name
FRightOperand

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Opérande de droite

Source code
FRightOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FLeftOperand)
Next


Sepi

Sepi
Previous
Next (LeftOperand)

Name
AutoConvert

Parent
TSepiBinaryOperation

Visibility
PUBLIC

Description
Si True, les opérandes sont convertis automatiquement

Source code
property AutoConvert : Boolean read FAutoConvert write FAutoConvert

Read Access
FAutoConvert

Write Access
FAutoConvert

Sepi
Class Tree
Index
Previous
Next (LeftOperand)


Sepi

Sepi
Previous (AutoConvert)
Next (RightOperand)

Name
LeftOperand

Parent
TSepiBinaryOperation

Visibility
PUBLIC

Description
Opérande de gauche

Source code
property LeftOperand : ISepiReadableValue read FLeftOperand write FLeftOperand

Read Access
FLeftOperand

Write Access
FLeftOperand

Sepi
Class Tree
Index
Previous (AutoConvert)
Next (RightOperand)


Sepi

Sepi
Previous (LeftOperand)
Next

Name
RightOperand

Parent
TSepiBinaryOperation

Visibility
PUBLIC

Description
Opérande de droite

Source code
property RightOperand : ISepiReadableValue read FRightOperand write FRightOperand

Read Access
FRightOperand

Write Access
FRightOperand

Sepi
Class Tree
Index
Previous (LeftOperand)
Next


Sepi

Sepi
Previous
Next (CheckTypes)

Name
CheckNonBaseTypes

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Vérification de types pour des types non de base

Source code
function CheckNonBaseTypes ( LeftType , RightType : TSepiType ) : TSepiBaseType

Parameters
Parameter | Description
LeftType : TSepiType | Type de gauche
RightType : TSepiType | Type de droite

Return
Types | Description
TSepiBaseType | Type commun

Sepi
Class Tree
Index
Previous
Next (CheckTypes)


Sepi

Sepi
Previous (CheckNonBaseTypes)
Next (CheckTypesArithmetic)

Name
CheckTypes

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Vérification de types

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckNonBaseTypes)
Next (CheckTypesArithmetic)


Sepi

Sepi
Previous (CheckTypes)
Next (CheckTypesComparison)

Name
CheckTypesArithmetic

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Vérification de types pour une opération arithmétique

Source code
procedure CheckTypesArithmetic ( LeftBaseType , RightBaseType : TSepiBaseType ; BaseTypes : TSepiBaseTypes )

Parameters
Parameter | Description
LeftBaseType : TSepiBaseType
RightBaseType : TSepiBaseType
BaseTypes : TSepiBaseTypes | Types de gauche et droite

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (CheckTypesComparison)


Sepi

Sepi
Previous (CheckTypesArithmetic)
Next (CheckTypesShift)

Name
CheckTypesComparison

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Vérification de types pour une opération de comparaison

Source code
procedure CheckTypesComparison ( LeftBaseType , RightBaseType : TSepiBaseType ; BaseTypes : TSepiBaseTypes )

Parameters
Parameter | Description
LeftBaseType : TSepiBaseType
RightBaseType : TSepiBaseType
BaseTypes : TSepiBaseTypes | Types de gauche et droite

Sepi
Class Tree
Index
Previous (CheckTypesArithmetic)
Next (CheckTypesShift)


Sepi

Sepi
Previous (CheckTypesComparison)
Next (CollapseConsts)

Name
CheckTypesShift

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Vérification de types pour une opération shift

Source code
procedure CheckTypesShift ( LeftBaseType , RightBaseType : TSepiBaseType ; BaseTypes : TSepiBaseTypes )

Parameters
Parameter | Description
LeftBaseType : TSepiBaseType
RightBaseType : TSepiBaseType
BaseTypes : TSepiBaseTypes | Types de gauche et droite

Sepi
Class Tree
Index
Previous (CheckTypesComparison)
Next (CollapseConsts)


Sepi

Sepi
Previous (CheckTypesShift)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiBinaryOperation

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckTypesShift)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (CompileReadOperandInto)

Name
CompileCompute

Parent
TSepiBinaryOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (CompileReadOperandInto)


Sepi

Sepi
Previous (CompileCompute)
Next (CompileShortCircuitAndOr)

Name
CompileReadOperandInto

Parent
TSepiBinaryOperation

Visibility
PROTECTED

Description
Compile la lecture d'un opérande dans une référence mémoire spécifique

Source code
procedure CompileReadOperandInto ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Destination : TSepiMemoryReference ; const Operand : ISepiReadableValue )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | Compilateur
Instructions : TSepiInstructionList | Liste d'instructions
Destination : TSepiMemoryReference | Référence mémoire où stocker le résultat
Operand : ISepiReadableValue | Opérande à lire

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (CompileShortCircuitAndOr)


Sepi

Sepi
Previous (CompileReadOperandInto)
Next (Complete)

Name
CompileShortCircuitAndOr

Parent
TSepiBinaryOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileShortCircuitAndOr ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileReadOperandInto)
Next (Complete)


Sepi

Sepi
Previous (CompileShortCircuitAndOr)
Next (ConvertLeftOperand)

Name
Complete

Parent
TSepiBinaryOperation

Visibility
PUBLIC

Description
Complète l'opération
L'opération doit avoir été attachée à une expression auparavant, pour pouvoir
bénéficier du contexte de celle-ci.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileShortCircuitAndOr)
Next (ConvertLeftOperand)


Sepi

Sepi
Previous (Complete)
Next (ConvertRightOperand)

Name
ConvertLeftOperand

Parent
TSepiBinaryOperation

Visibility
PROTECTED

Description
Convertit l'opérande de gauche

Source code
function ConvertLeftOperand ( NewType : TSepiBaseType ) : TSepiType

Parameters
Parameter | Description
NewType : TSepiBaseType | Type de base en lequel convertir l'opérande

Return
Types | Description
TSepiType | Nouveau type Sepi de l'opérande

Sepi
Class Tree
Index
Previous (Complete)
Next (ConvertRightOperand)


Sepi

Sepi
Previous (ConvertLeftOperand)
Next (Create)

Name
ConvertRightOperand

Parent
TSepiBinaryOperation

Visibility
PROTECTED

Description
Convertit l'opérande de droite

Source code
function ConvertRightOperand ( NewType : TSepiBaseType ) : TSepiType

Parameters
Parameter | Description
NewType : TSepiBaseType | Type de base en lequel convertir l'opérande

Return
Types | Description
TSepiType | Nouveau type Sepi de l'opérande

Sepi
Class Tree
Index
Previous (ConvertLeftOperand)
Next (Create)


Sepi

Sepi
Previous (ConvertRightOperand)
Next (DefaultSepiTypeFor)

Name
Create

Parent
TSepiBinaryOperation

Visibility
PUBLIC

Description
Crée l'opération

Source code
constructor Create ( AOperation : TSepiOperation ; AAutoConvert : Boolean = True )

Parameters
Parameter | Description
AOperation : TSepiOperation | Opération
AAutoConvert : BOOLEAN | Valeur initiale de AutoConvert (défaut = True)

Sepi
Class Tree
Index
Previous (ConvertRightOperand)
Next (DefaultSepiTypeFor)


Sepi

Sepi
Previous (Create)
Next (ErrorTypeMismatch)

Name
DefaultSepiTypeFor

Parent
TSepiBinaryOperation

Visibility
PROTECTED

Description
Type Sepi par défaut pour un type de base

Source code
function DefaultSepiTypeFor ( BaseType : TSepiBaseType ) : TSepiType

Parameters
Parameter | Description
BaseType : TSepiBaseType | Type de base

Return
Types | Description
TSepiType | Type Sepi par défaut correspondant

Sepi
Class Tree
Index
Previous (Create)
Next (ErrorTypeMismatch)


Sepi

Sepi
Previous (DefaultSepiTypeFor)
Next (MakeOperation)

Name
ErrorTypeMismatch

Parent
TSepiBinaryOperation

Visibility
PROTECTED

Description
Produit une erreur Types incompatibles

Source code
procedure ErrorTypeMismatch

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DefaultSepiTypeFor)
Next (MakeOperation)


Sepi

Sepi
Previous (ErrorTypeMismatch)
Next (SmallestCommonType)

Name
MakeOperation

Parent
TSepiBinaryOperation

Visibility
PUBLIC

Description
Construit une opération binaire

Source code
class function MakeOperation ( Operation : TSepiOperation ; const LeftOperand , RightOperand : ISepiReadableValue ; AutoConvert : Boolean = True ) : ISepiReadableValue

Parameters
Parameter | Description
Operation : TSepiOperation | Opération
LeftOperand : ISepiReadableValue | Opérande de gauche
RightOperand : ISepiReadableValue | Opérande de droite
AutoConvert : BOOLEAN | True permet d'effectuer des conversions automatiques

Return
Types | Description
ISepiReadableValue | Valeur représentant l'opération

Sepi
Class Tree
Index
Previous (ErrorTypeMismatch)
Next (SmallestCommonType)


Sepi

Sepi
Previous (MakeOperation)
Next

Name
SmallestCommonType

Parent
TSepiBinaryOperation

Visibility
PUBLIC

Description
Trouve le plus petit type commun à deux types de base

Source code
class function SmallestCommonType ( LeftType , RightType : TSepiBaseType ; out CommonType : TSepiBaseType ) : Boolean

Parameters
Parameter | Description
LeftType : TSepiBaseType | Type de gauche
RightType : TSepiBaseType | Type de droite
CommonType : TSepiBaseType | En sortie : Type commun

Return
Types | Description
BOOLEAN | True si un type commun a pu être trouvé, False sinon

Sepi
Class Tree
Index
Previous (MakeOperation)
Next


Sepi

Sepi
Previous (TSepiBinaryOperation)
Next (TSepiComponentExpression)

Name
TSepiCastOperator

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Opérateur de transtypage

Members
Fields
Field | Description
FForceCast (-) | True force même avec des tailles différentes
FIsChr (-) | Indique si c'est un cast de type Chr
FIsOrd (-) | Indique si c'est un cast de type Ord
FOperand (-) | Valeur source

Methods
Method | Description
CastValue (+) | Transtype une valeur
CastValueChr (+) | Transtype une valeur comme Chr
CastValueOrd (+) | Transtype une valeur comme Ord
CollapseConsts (-) | Pliage des constantes
CompileAsMemoryRef (#) | [@inheritDoc]
CompileLoadAddress (#) | [@inheritDoc]
CompileRead (#) | [@inheritDoc]
CompileWrite (#) | [@inheritDoc]
Complete (+) | Complète le transtypage
Create (+) | #No TAG found in source code#
CreateChr (+) | Crée une opération de conversion Chr
CreateOrd (+) | Crée une opération de conversion Ord
HandleOrdChr (-) | Gère le cas Ord et le cas Chr
InternalCastValue (-) | Tronc commun des fonctions de classe CastValue, CastValueOrd et CastValueChr

Properties
Property | Description
ForceCast (+) | True force même avec des tailles différentes
IsChr (+) | Indique si c'est un cast de type Chr
IsOrd (+) | Indique si c'est un cast de type Ord
Operand (+) | Valeur source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBinaryOperation)
Next (TSepiComponentExpression)


Sepi

Sepi
Previous
Next (FIsChr)

Name
FForceCast

Parent
TSepiCastOperator

Visibility
PRIVATE

Description
True force même avec des tailles différentes

Source code
FForceCast : Boolean

Sepi
Class Tree
Index
Previous
Next (FIsChr)


Sepi

Sepi
Previous (FForceCast)
Next (FIsOrd)

Name
FIsChr

Parent
TSepiCastOperator

Visibility
PRIVATE

Description
Indique si c'est un cast de type Chr

Source code
FIsChr : Boolean

Sepi
Class Tree
Index
Previous (FForceCast)
Next (FIsOrd)


Sepi

Sepi
Previous (FIsChr)
Next (FOperand)

Name
FIsOrd

Parent
TSepiCastOperator

Visibility
PRIVATE

Description
Indique si c'est un cast de type Ord

Source code
FIsOrd : Boolean

Sepi
Class Tree
Index
Previous (FIsChr)
Next (FOperand)


Sepi

Sepi
Previous (FIsOrd)
Next

Name
FOperand

Parent
TSepiCastOperator

Visibility
PRIVATE

Description
Valeur source

Source code
FOperand : ISepiValue

Sepi
Class Tree
Index
Previous (FIsOrd)
Next


Sepi

Sepi
Previous
Next (IsChr)

Name
ForceCast

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
True force même avec des tailles différentes

Source code
property ForceCast : Boolean read FForceCast write FForceCast

Read Access
FForceCast

Write Access
FForceCast

Sepi
Class Tree
Index
Previous
Next (IsChr)


Sepi

Sepi
Previous (ForceCast)
Next (IsOrd)

Name
IsChr

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Indique si c'est un cast de type Chr

Source code
property IsChr : Boolean read FIsChr

Read Access
FIsChr

Sepi
Class Tree
Index
Previous (ForceCast)
Next (IsOrd)


Sepi

Sepi
Previous (IsChr)
Next (Operand)

Name
IsOrd

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Indique si c'est un cast de type Ord

Source code
property IsOrd : Boolean read FIsOrd

Read Access
FIsOrd

Sepi
Class Tree
Index
Previous (IsChr)
Next (Operand)


Sepi

Sepi
Previous (IsOrd)
Next

Name
Operand

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Valeur source

Source code
property Operand : ISepiValue read FOperand write FOperand

Read Access
FOperand

Write Access
FOperand

Sepi
Class Tree
Index
Previous (IsOrd)
Next


Sepi

Sepi
Previous
Next (CastValueChr)

Name
CastValue

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Transtype une valeur

Source code
class function CastValue ( DestType : TSepiType ; const Value : ISepiValue ; ForceCast : Boolean = False ) : ISepiValue

Parameters
Parameter | Description
DestType : TSepiType | Type de destination
Value : ISepiValue | Valeur à transtyper
ForceCast : BOOLEAN

Return
Types | Description
ISepiValue | Valeur transtypée

Sepi
Class Tree
Index
Previous
Next (CastValueChr)


Sepi

Sepi
Previous (CastValue)
Next (CastValueOrd)

Name
CastValueChr

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Transtype une valeur comme Chr

Source code
class function CastValueChr ( const Value : ISepiValue ) : ISepiValue

Parameters
Parameter | Description
Value : ISepiValue | Valeur à transtyper

Return
Types | Description
ISepiValue | Valeur transtypée

Sepi
Class Tree
Index
Previous (CastValue)
Next (CastValueOrd)


Sepi

Sepi
Previous (CastValueChr)
Next (CollapseConsts)

Name
CastValueOrd

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Transtype une valeur comme Ord

Source code
class function CastValueOrd ( const Value : ISepiValue ) : ISepiValue

Parameters
Parameter | Description
Value : ISepiValue | Valeur à transtyper

Return
Types | Description
ISepiValue | Valeur transtypée

Sepi
Class Tree
Index
Previous (CastValueChr)
Next (CollapseConsts)


Sepi

Sepi
Previous (CastValueOrd)
Next (CompileAsMemoryRef)

Name
CollapseConsts

Parent
TSepiCastOperator

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CastValueOrd)
Next (CompileAsMemoryRef)


Sepi

Sepi
Previous (CollapseConsts)
Next (CompileLoadAddress)

Name
CompileAsMemoryRef

Parent
TSepiCastOperator

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (CompileLoadAddress)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (CompileRead)

Name
CompileLoadAddress

Parent
TSepiCastOperator

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileLoadAddress ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (CompileRead)


Sepi

Sepi
Previous (CompileLoadAddress)
Next (CompileWrite)

Name
CompileRead

Parent
TSepiCastOperator

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileLoadAddress)
Next (CompileWrite)


Sepi

Sepi
Previous (CompileRead)
Next (Complete)

Name
CompileWrite

Parent
TSepiCastOperator

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileWrite ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Source : ISepiReadableValue ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Source : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileRead)
Next (Complete)


Sepi

Sepi
Previous (CompileWrite)
Next (Create)

Name
Complete

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Complète le transtypage

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileWrite)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (CreateChr)

Name
Create

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( DestType : TSepiType ; const AOperand : ISepiValue = nil )

Parameters
Parameter | Description
DestType : TSepiType | #Pas de TAG trouvé dans le code source#
AOperand : ISepiValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (CreateChr)


Sepi

Sepi
Previous (Create)
Next (CreateOrd)

Name
CreateChr

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Crée une opération de conversion Chr

Source code
constructor CreateChr ( const AOperand : ISepiValue = nil )

Parameters
Parameter Description
AOperand : ISepiValue

Sepi
Class Tree
Index
Previous (Create)
Next (CreateOrd)


Sepi

Sepi
Previous (CreateChr)
Next (HandleOrdChr)

Name
CreateOrd

Parent
TSepiCastOperator

Visibility
PUBLIC

Description
Crée une opération de conversion Ord

Source code
constructor CreateOrd ( const AOperand : ISepiValue = nil )

Parameters
Parameter Description
AOperand : ISepiValue

Sepi
Class Tree
Index
Previous (CreateChr)
Next (HandleOrdChr)


Sepi

Sepi
Previous (CreateOrd)
Next (InternalCastValue)

Name
HandleOrdChr

Parent
TSepiCastOperator

Visibility
PRIVATE

Description
Gère le cas Ord et le cas Chr

Source code
procedure HandleOrdChr

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateOrd)
Next (InternalCastValue)


Sepi

Sepi
Previous (HandleOrdChr)
Next

Name
InternalCastValue

Parent
TSepiCastOperator

Visibility
PRIVATE

Description
Tronc commun des fonctions de classe CastValue, CastValueOrd et CastValueChr

Source code
function InternalCastValue : ISepiValue

Parameters
Parameter Description

Return
Types | Description
ISepiValue | Valeur transtypée

Sepi
Class Tree
Index
Previous (HandleOrdChr)
Next


Sepi

Sepi
Previous (TSepiCastOperator)
Next (TSepiConvertOperation)

Name
TSepiComponentExpression

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiComponentExpression

Visibility
PUBLIC

Description
Expression représentant un meta

Members
Fields
Field | Description
FComponent (-) | Component

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
Create (+) | Crée une expression représentant un meta
GetComponent (#) | Component

Properties
Property | Description
Component (+) | Component

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCastOperator)
Next (TSepiConvertOperation)


Sepi

Sepi
Previous
Next

Name
FComponent

Parent
TSepiComponentExpression

Visibility
PRIVATE

Description
Component

Source code
FComponent : TSepiComponent

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Component

Parent
TSepiComponentExpression

Visibility
PUBLIC

Description
Component

Source code
property Component : TSepiComponent read FComponent

Read Access
FComponent

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
AttachToExpression

Parent
TSepiComponentExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AttachToExpression)
Next (GetComponent)

Name
Create

Parent
TSepiComponentExpression

Visibility
PUBLIC

Description
Crée une expression représentant un meta

Source code
constructor Create ( AComponent : TSepiComponent )

Parameters
Parameter | Description
AComponent : TSepiComponent | Component représenté

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (GetComponent)


Sepi

Sepi
Previous (Create)
Next

Name
GetComponent

Parent
TSepiComponentExpression

Visibility
PROTECTED

Description
Component

Source code
function GetComponent : TSepiComponent

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | Component

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiComponentExpression)
Next (TSepiCustomCallable)

Name
TSepiConvertOperation

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Opération de conversion

Members
Fields
Field | Description
FSource (-) | Expression source

Methods
Method | Description
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'opération
ConversionExists (+) | Teste si une conversion existe et est possible d'une valeur en un type donné
ConversionExists (+) | Teste si une conversion existe et est possible depuis un type vers un autre
ConvertValue (+) | Convertit une valeur
Create (+) | Crée une opération de conversion

Properties
Property | Description
Source (+) | Expression source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiComponentExpression)
Next (TSepiCustomCallable)


Sepi

Sepi
Previous
Next

Name
FSource

Parent
TSepiConvertOperation

Visibility
PRIVATE

Description
Expression source

Source code
FSource : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Source

Parent
TSepiConvertOperation

Visibility
PUBLIC

Description
Expression source

Source code
property Source : ISepiReadableValue read FSource write FSource

Read Access
FSource

Write Access
FSource

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiConvertOperation

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (Complete)

Name
CompileCompute

Parent
TSepiConvertOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (ConversionExists)

Name
Complete

Parent
TSepiConvertOperation

Visibility
PUBLIC

Description
Complète l'opération

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (ConversionExists)


Sepi

Sepi
Previous (Complete)
Next (ConversionExists)

Name
ConversionExists

Parent
TSepiConvertOperation

Visibility
PUBLIC

Description
Teste si une conversion existe et est possible d'une valeur en un type donné

Source code
class function ConversionExists ( DestType : TSepiType ; const Source : ISepiReadableValue ) : Boolean ; overload

Parameters
Parameter | Description
DestType : TSepiType | Type de destination
Source : ISepiReadableValue | Valeur source

Return
Types | Description
BOOLEAN | True si une conversion est possible, False sinon

Sepi
Class Tree
Index
Previous (Complete)
Next (ConversionExists)


Sepi

Sepi
Previous (ConversionExists)
Next (ConvertValue)

Name
ConversionExists

Parent
TSepiConvertOperation

Visibility
PUBLIC

Description
Teste si une conversion existe et est possible depuis un type vers un autre

Source code
class function ConversionExists ( DestType , SrcType : TSepiType ) : Boolean ; overload

Parameters
Parameter | Description
DestType : TSepiType | Type de destination
SrcType : TSepiType | Type source

Return
Types | Description
BOOLEAN | True si une conversion est possible, False sinon

Sepi
Class Tree
Index
Previous (ConversionExists)
Next (ConvertValue)


Sepi

Sepi
Previous (ConversionExists)
Next (Create)

Name
ConvertValue

Parent
TSepiConvertOperation

Visibility
PUBLIC

Description
Convertit une valeur

Source code
class function ConvertValue ( DestType : TSepiType ; const Value : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter | Description
DestType : TSepiType | Type de destination
Value : ISepiReadableValue | Valeur à convertir

Return
Types | Description
ISepiReadableValue | Valeur convertie

Sepi
Class Tree
Index
Previous (ConversionExists)
Next (Create)


Sepi

Sepi
Previous (ConvertValue)
Next

Name
Create

Parent
TSepiConvertOperation

Visibility
PUBLIC

Description
Crée une opération de conversion

Source code
constructor Create ( DestType : TSepiType ; const ASource : ISepiReadableValue = nil )

Parameters
Parameter | Description
DestType : TSepiType | Type de destination
ASource : ISepiReadableValue | Expression source

Sepi
Class Tree
Index
Previous (ConvertValue)
Next


Sepi

Sepi
Previous (TSepiConvertOperation)
Next (TSepiCustomComputedValue)

Name
TSepiCustomCallable

Parent
SepiExpressions

Class Hierarchy
TSepiCustomWithParams,ISepiWantingParams,ISepiExecutable,ISepiValue,ISepiReadableValue

Visibility
PUBLIC

Description
Classe de base pour les expressions qui peuvent être invoquées

Members
Fields
Field | Description
FSignature (-) | Signature de l'appel

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileCall (#) | #No TAG found in source code#
CompileExecute (#) | [@inheritDoc]
CompileOpenArrayParam (-) | Compile un paramètre tableau ouvert
CompileParam (-) | Compile un paramètre
CompileParams (#) | Compile les paramètres dans une instruction assembleur CALL
CompileRead (#) | [@inheritDoc]
Create (+) | Crée une expression qui peut être invoquée
GetConstValuePtr (#) | [@inheritDoc]
GetIsConstant (#) | [@inheritDoc]
GetReturnType (#) | [@inheritDoc]
GetValueType (#) | [@inheritDoc]
QueryInterface (#) | [@inheritDoc]
SetSignature (#) | Renseigne la signature

Properties
Property | Description
ReturnType (#) | [@inheritDoc]
Signature (#) | Signature de l'appel

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiConvertOperation)
Next (TSepiCustomComputedValue)


Sepi

Sepi
Previous
Next

Name
FSignature

Parent
TSepiCustomCallable

Visibility
PRIVATE

Description
Signature de l'appel

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Signature)

Name
ReturnType

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property ReturnType : TSepiType read GetReturnType

Read Access
GetReturnType

Sepi
Class Tree
Index
Previous
Next (Signature)


Sepi

Sepi
Previous (ReturnType)
Next

Name
Signature

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
Signature de l'appel

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous (ReturnType)
Next


Sepi

Sepi
Previous
Next (CompileCall)

Name
AttachToExpression

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileCall)


Sepi

Sepi
Previous (AttachToExpression)
Next (CompileExecute)

Name
CompileCall

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileCall ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Destination : TSepiMemoryReference ) ; virtual ; abstract

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CompileExecute)


Sepi

Sepi
Previous (CompileCall)
Next (CompileOpenArrayParam)

Name
CompileExecute

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileCall)
Next (CompileOpenArrayParam)


Sepi

Sepi
Previous (CompileExecute)
Next (CompileParam)

Name
CompileOpenArrayParam

Parent
TSepiCustomCallable

Visibility
PRIVATE

Description
Compile un paramètre tableau ouvert

Source code
procedure CompileOpenArrayParam ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; SignatureParam : TSepiParam ; const OpenArray : ISepiOpenArrayValue ; InstrOpenArrayMemory , InstrHighValueMemory : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | Compilateur de méthode
Instructions : TSepiInstructionList | Liste d'instructions
SignatureParam : TSepiParam | Paramètre de la signature
OpenArray : ISepiOpenArrayValue | Tableau ouvert
InstrOpenArrayMemory : TSepiMemoryReference | Référence mémoire au paramètre tableau ouvert
InstrHighValueMemory : TSepiMemoryReference | Référence mémoire au paramètre High
TempVars : TSepiTempVarsLifeManager | Gestionnaire de vie des variables temporaires

Sepi
Class Tree
Index
Previous (CompileExecute)
Next (CompileParam)


Sepi

Sepi
Previous (CompileOpenArrayParam)
Next (CompileParams)

Name
CompileParam

Parent
TSepiCustomCallable

Visibility
PRIVATE

Description
Compile un paramètre

Source code
procedure CompileParam ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; SignatureParam : TSepiParam ; ParamValue : ISepiValue ; InstrParamMemory : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ; FreeParamValue : Boolean = False )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | Compilateur de méthode
Instructions : TSepiInstructionList | Liste d'instructions
SignatureParam : TSepiParam | Paramètre de la signature
ParamValue : ISepiValue | Valeur du paramètre
InstrParamMemory : TSepiMemoryReference | Référence mémoire au paramètre dans l'instruction
TempVars : TSepiTempVarsLifeManager | Gestionnaire de vie des variables temporaires
FreeParamValue : BOOLEAN | Valeur à donner au paramètre $Free (défaut = False)

Sepi
Class Tree
Index
Previous (CompileOpenArrayParam)
Next (CompileParams)


Sepi

Sepi
Previous (CompileParam)
Next (CompileRead)

Name
CompileParams

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
Compile les paramètres dans une instruction assembleur CALL
Lorsqu'il y a un paramètre Self, et que SelfValue <> nil, c'est SelfValue qui
est utilisé pour l'évaluer, et SelfMem est modifié en sortie pour pointer sur
le résultat de cette évaluation (et ne doit donc pas être scellé). Mais si
SelfValue = nil, alors SelfMem est utilisé pour le paramètre, et il doit
avoir été scellé avant.

Source code
procedure CompileParams ( CallInstr : TSepiAsmCall ; Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Destination : TSepiMemoryReference ; const SelfValue : ISepiReadableValue = nil ; SelfMem : TSepiMemoryReference = nil ; FreeParamValue : Boolean = False )

Parameters
Parameter | Description
CallInstr : TSepiAsmCall | Instruction CALL
Compiler : TSepiMethodCompiler | Compilateur de méthode
Instructions : TSepiInstructionList | Liste d'instructions
Destination : TSepiMemoryReference | Référence mémoire à la variable résultat
SelfValue : ISepiReadableValue | Valeur pour le paramètre caché Self
SelfMem : TSepiMemoryReference | Référence mémoire au paramètre Self
FreeParamValue : BOOLEAN | Valeur à donner au paramètre $Free (défaut = False)

Sepi
Class Tree
Index
Previous (CompileParam)
Next (CompileRead)


Sepi

Sepi
Previous (CompileParams)
Next (Create)

Name
CompileRead

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileParams)
Next (Create)


Sepi

Sepi
Previous (CompileRead)
Next (GetConstValuePtr)

Name
Create

Parent
TSepiCustomCallable

Visibility
PUBLIC

Description
Crée une expression qui peut être invoquée

Source code
constructor Create ( ASignature : TSepiSignature = nil ; APrepareParams : Boolean = False )

Parameters
Parameter | Description
ASignature : TSepiSignature | Signature (défaut = nil)
APrepareParams : BOOLEAN | Si True, les paramètres sont préparés

Sepi
Class Tree
Index
Previous (CompileRead)
Next (GetConstValuePtr)


Sepi

Sepi
Previous (Create)
Next (GetIsConstant)

Name
GetConstValuePtr

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetConstValuePtr)
Next (GetReturnType)

Name
GetIsConstant

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next (GetReturnType)


Sepi

Sepi
Previous (GetIsConstant)
Next (GetValueType)

Name
GetReturnType

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetReturnType : TSepiType ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (GetValueType)


Sepi

Sepi
Previous (GetReturnType)
Next (QueryInterface)

Name
GetValueType

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetReturnType)
Next (QueryInterface)


Sepi

Sepi
Previous (GetValueType)
Next (SetSignature)

Name
QueryInterface

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetValueType)
Next (SetSignature)


Sepi

Sepi
Previous (QueryInterface)
Next

Name
SetSignature

Parent
TSepiCustomCallable

Visibility
PROTECTED

Description
Renseigne la signature

Source code
procedure SetSignature ( ASignature : TSepiSignature ; APrepareParams : Boolean = False )

Parameters
Parameter | Description
ASignature : TSepiSignature | Signature
APrepareParams : BOOLEAN

Sepi
Class Tree
Index
Previous (QueryInterface)
Next


Sepi

Sepi
Previous (TSepiCustomCallable)
Next (TSepiCustomDirectValue)

Name
TSepiCustomComputedValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiValue,ISepiReadableValue

Visibility
PUBLIC

Description
Classe de base pour des valeurs à calculer

Members
Fields
Field | Description
FConstValuePtr (-) | Pointeur sur la valeur constante
FValueType (-) | Type de valeur

Methods
Method | Description
AllocateConstant (#) | Alloue la constante
AttachToExpression (#) | [@inheritDoc]
CompileCompute (#) | #No TAG found in source code#
CompileRead (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
ErrorTypeNotApplicable (#) | Produit une erreur Opération non applicable à ce type d'opérande
GetConstValuePtr (#) | [@inheritDoc]
GetIsConstant (#) | [@inheritDoc]
GetValueType (#) | Type de valeur
SetValueType (#) | Renseigne le type de valeur

Properties
Property | Description
ConstValuePtr (#) | Pointeur sur la valeur constante
IsConstant (#) | [@inheritDoc]
ValueType (+) | Type de valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomCallable)
Next (TSepiCustomDirectValue)


Sepi

Sepi
Previous
Next (FValueType)

Name
FConstValuePtr

Parent
TSepiCustomComputedValue

Visibility
PRIVATE

Description
Pointeur sur la valeur constante

Source code
FConstValuePtr : Pointer

Sepi
Class Tree
Index
Previous
Next (FValueType)


Sepi

Sepi
Previous (FConstValuePtr)
Next

Name
FValueType

Parent
TSepiCustomComputedValue

Visibility
PRIVATE

Description
Type de valeur

Source code
FValueType : TSepiType

Sepi
Class Tree
Index
Previous (FConstValuePtr)
Next


Sepi

Sepi
Previous
Next (IsConstant)

Name
ConstValuePtr

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
Pointeur sur la valeur constante

Source code
property ConstValuePtr : Pointer read FConstValuePtr

Read Access
FConstValuePtr

Sepi
Class Tree
Index
Previous
Next (IsConstant)


Sepi

Sepi
Previous (ConstValuePtr)
Next (ValueType)

Name
IsConstant

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property IsConstant : Boolean read GetIsConstant

Read Access
GetIsConstant

Sepi
Class Tree
Index
Previous (ConstValuePtr)
Next (ValueType)


Sepi

Sepi
Previous (IsConstant)
Next

Name
ValueType

Parent
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Type de valeur

Source code
property ValueType : TSepiType read FValueType

Read Access
FValueType

Sepi
Class Tree
Index
Previous (IsConstant)
Next


Sepi

Sepi
Previous
Next (AttachToExpression)

Name
AllocateConstant

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
Alloue la constante
La constante est initialisée à 0

Source code
procedure AllocateConstant

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (AttachToExpression)


Sepi

Sepi
Previous (AllocateConstant)
Next (CompileCompute)

Name
AttachToExpression

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AllocateConstant)
Next (CompileCompute)


Sepi

Sepi
Previous (AttachToExpression)
Next (CompileRead)

Name
CompileCompute

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; virtual ; abstract

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CompileRead)


Sepi

Sepi
Previous (CompileCompute)
Next (Destroy)

Name
CompileRead

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (Destroy)


Sepi

Sepi
Previous (CompileRead)
Next (ErrorTypeNotApplicable)

Name
Destroy

Parent
TSepiCustomComputedValue

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileRead)
Next (ErrorTypeNotApplicable)


Sepi

Sepi
Previous (Destroy)
Next (GetConstValuePtr)

Name
ErrorTypeNotApplicable

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
Produit une erreur Opération non applicable à ce type d'opérande

Source code
procedure ErrorTypeNotApplicable

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetConstValuePtr)


Sepi

Sepi
Previous (ErrorTypeNotApplicable)
Next (GetIsConstant)

Name
GetConstValuePtr

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ErrorTypeNotApplicable)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetConstValuePtr)
Next (GetValueType)

Name
GetIsConstant

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next (GetValueType)


Sepi

Sepi
Previous (GetIsConstant)
Next (SetValueType)

Name
GetValueType

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
Type de valeur

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type de valeur

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (SetValueType)


Sepi

Sepi
Previous (GetValueType)
Next

Name
SetValueType

Parent
TSepiCustomComputedValue

Visibility
PROTECTED

Description
Renseigne le type de valeur
Si la constante avait déjà été allouée, et que AType n'est pas égal (au sens
de Equals) à l'ancien type de valeur, alors elle est désallouée.

Source code
procedure SetValueType ( AType : TSepiType )

Parameters
Parameter | Description
AType : TSepiType | Type de valeur

Sepi
Class Tree
Index
Previous (GetValueType)
Next


Sepi

Sepi
Previous (TSepiCustomComputedValue)
Next (TSepiCustomExecutable)

Name
TSepiCustomDirectValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiValue,ISepiReadableValue,ISepiWritableValue,ISepiAddressableValue

Visibility
PUBLIC

Description
Implémentation de base de ISepiDirectValue
Bien que, syntaxiquement, cette classe implémente les trois interfaces
ISepiReadableValue, ISepiWritableValue et ISepiAddressableValue, les
classes descendantes peuvent activer et désactiver celles-ci à volonté au
moyen des propriétés IsReadable, IsWritable et IsAddressable respectivement.

Members
Fields
Field | Description
FConstValuePtr (-) | Pointeur sur la valeur constante
FIsAddressable (-) | Indique si la valeur peut être adressée
FIsReadable (-) | Indique si la valeur peut être lue
FIsWritable (-) | Indique si la valeur peut être écrite
FValueType (-) | Type de la valeur

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileAsMemoryRef (#) | #No TAG found in source code#
CompileLoadAddress (#) | [@inheritDoc]
CompileRead (#) | [@inheritDoc]
CompileWrite (#) | [@inheritDoc]
GetAddressType (#) | [@inheritDoc]
GetConstValuePtr (#) | [@inheritDoc]
GetIsConstant (#) | [@inheritDoc]
GetValueType (#) | [@inheritDoc]
QueryInterface (#) | [@inheritDoc]
SetValueType (#) | Renseigne le type de la valeur

Properties
Property | Description
AddressType (+) | [@inheritDoc]
ConstValuePtr (#) | Pointeur sur la valeur constante
IsAddressable (#) | Indique si la valeur peut être adressée
IsConstant (#) | [@inheritDoc]
IsReadable (#) | Indique si la valeur peut être lue
IsWritable (#) | Indique si la valeur peut être écrite
ValueType (+) | Type de la valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomComputedValue)
Next (TSepiCustomExecutable)


Sepi

Sepi
Previous
Next (FIsAddressable)

Name
FConstValuePtr

Parent
TSepiCustomDirectValue

Visibility
PRIVATE

Description
Pointeur sur la valeur constante

Source code
FConstValuePtr : Pointer

Sepi
Class Tree
Index
Previous
Next (FIsAddressable)


Sepi

Sepi
Previous (FConstValuePtr)
Next (FIsReadable)

Name
FIsAddressable

Parent
TSepiCustomDirectValue

Visibility
PRIVATE

Description
Indique si la valeur peut être adressée

Source code
FIsAddressable : Boolean

Sepi
Class Tree
Index
Previous (FConstValuePtr)
Next (FIsReadable)


Sepi

Sepi
Previous (FIsAddressable)
Next (FIsWritable)

Name
FIsReadable

Parent
TSepiCustomDirectValue

Visibility
PRIVATE

Description
Indique si la valeur peut être lue

Source code
FIsReadable : Boolean

Sepi
Class Tree
Index
Previous (FIsAddressable)
Next (FIsWritable)


Sepi

Sepi
Previous (FIsReadable)
Next (FValueType)

Name
FIsWritable

Parent
TSepiCustomDirectValue

Visibility
PRIVATE

Description
Indique si la valeur peut être écrite

Source code
FIsWritable : Boolean

Sepi
Class Tree
Index
Previous (FIsReadable)
Next (FValueType)


Sepi

Sepi
Previous (FIsWritable)
Next

Name
FValueType

Parent
TSepiCustomDirectValue

Visibility
PRIVATE

Description
Type de la valeur

Source code
FValueType : TSepiType

Sepi
Class Tree
Index
Previous (FIsWritable)
Next


Sepi

Sepi
Previous
Next (ConstValuePtr)

Name
AddressType

Parent
TSepiCustomDirectValue

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
property AddressType : TSepiType read GetAddressType

Read Access
GetAddressType

Sepi
Class Tree
Index
Previous
Next (ConstValuePtr)


Sepi

Sepi
Previous (AddressType)
Next (IsAddressable)

Name
ConstValuePtr

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
Pointeur sur la valeur constante

Source code
property ConstValuePtr : Pointer read FConstValuePtr write FConstValuePtr

Read Access
FConstValuePtr

Write Access
FConstValuePtr

Sepi
Class Tree
Index
Previous (AddressType)
Next (IsAddressable)


Sepi

Sepi
Previous (ConstValuePtr)
Next (IsConstant)

Name
IsAddressable

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
Indique si la valeur peut être adressée

Source code
property IsAddressable : Boolean read FIsAddressable write FIsAddressable

Read Access
FIsAddressable

Write Access
FIsAddressable

Sepi
Class Tree
Index
Previous (ConstValuePtr)
Next (IsConstant)


Sepi

Sepi
Previous (IsAddressable)
Next (IsReadable)

Name
IsConstant

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property IsConstant : Boolean read GetIsConstant

Read Access
GetIsConstant

Sepi
Class Tree
Index
Previous (IsAddressable)
Next (IsReadable)


Sepi

Sepi
Previous (IsConstant)
Next (IsWritable)

Name
IsReadable

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
Indique si la valeur peut être lue

Source code
property IsReadable : Boolean read FIsReadable write FIsReadable

Read Access
FIsReadable

Write Access
FIsReadable

Sepi
Class Tree
Index
Previous (IsConstant)
Next (IsWritable)


Sepi

Sepi
Previous (IsReadable)
Next (ValueType)

Name
IsWritable

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
Indique si la valeur peut être écrite

Source code
property IsWritable : Boolean read FIsWritable write FIsWritable

Read Access
FIsWritable

Write Access
FIsWritable

Sepi
Class Tree
Index
Previous (IsReadable)
Next (ValueType)


Sepi

Sepi
Previous (IsWritable)
Next

Name
ValueType

Parent
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Type de la valeur

Source code
property ValueType : TSepiType read FValueType

Read Access
FValueType

Sepi
Class Tree
Index
Previous (IsWritable)
Next


Sepi

Sepi
Previous
Next (CompileAsMemoryRef)

Name
AttachToExpression

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileAsMemoryRef)


Sepi

Sepi
Previous (AttachToExpression)
Next (CompileLoadAddress)

Name
CompileAsMemoryRef

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; virtual ; abstract

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CompileLoadAddress)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (CompileRead)

Name
CompileLoadAddress

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileLoadAddress ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (CompileRead)


Sepi

Sepi
Previous (CompileLoadAddress)
Next (CompileWrite)

Name
CompileRead

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileLoadAddress)
Next (CompileWrite)


Sepi

Sepi
Previous (CompileRead)
Next (GetAddressType)

Name
CompileWrite

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileWrite ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Source : ISepiReadableValue ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Source : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileRead)
Next (GetAddressType)


Sepi

Sepi
Previous (CompileWrite)
Next (GetConstValuePtr)

Name
GetAddressType

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAddressType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileWrite)
Next (GetConstValuePtr)


Sepi

Sepi
Previous (GetAddressType)
Next (GetIsConstant)

Name
GetConstValuePtr

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAddressType)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetConstValuePtr)
Next (GetValueType)

Name
GetIsConstant

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next (GetValueType)


Sepi

Sepi
Previous (GetIsConstant)
Next (QueryInterface)

Name
GetValueType

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (QueryInterface)


Sepi

Sepi
Previous (GetValueType)
Next (SetValueType)

Name
QueryInterface

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetValueType)
Next (SetValueType)


Sepi

Sepi
Previous (QueryInterface)
Next

Name
SetValueType

Parent
TSepiCustomDirectValue

Visibility
PROTECTED

Description
Renseigne le type de la valeur

Source code
procedure SetValueType ( AType : TSepiType )

Parameters
Parameter | Description
AType : TSepiType | Type de la valeur

Sepi
Class Tree
Index
Previous (QueryInterface)
Next


Sepi

Sepi
Previous (TSepiCustomDirectValue)
Next (TSepiCustomExpressionPart)

Name
TSepiCustomExecutable

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiExecutable

Visibility
PUBLIC

Description
Classe de base pour les expressions exécutables

Members
Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileExecute (#) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomDirectValue)
Next (TSepiCustomExpressionPart)


Sepi

Sepi
Previous
Next (CompileExecute)

Name
AttachToExpression

Parent
TSepiCustomExecutable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (AttachToExpression)
Next

Name
CompileExecute

Parent
TSepiCustomExecutable

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ) ; virtual ; abstract

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next


Sepi

Sepi
Previous (TSepiCustomExecutable)
Next (TSepiCustomWithParams)

Name
TSepiCustomExpressionPart

Parent
SepiExpressions

Class Hierarchy
TDynamicallyLinkedObject,ISepiExpressionPart

Visibility
PUBLIC

Description
Implémentation de base de ISepiExpressionPart
La majorité des classes devant implémenter ISepiExpressionPart devraient
hériter de cette classe.

Members
Fields
Field | Description
FBaseCompiler (-) | Compilateur de base
FExpression (-) | Référence faible à l'expression contrôleur
FLanguageRules (-) | Règles du langage utilisé
FMethodCompiler (-) | Compilateur de méthode
FSepiRoot (-) | Racine Sepi
FSystemUnit (-) | Unité System
FUnitCompiler (-) | Compilateur d'unité

Methods
Method | Description
AttachTo (#) | [@inheritDoc]
AttachToExpression (#) | #No TAG found in source code#
DetachFromController (#) | [@inheritDoc]
GetExpression (-) | Expression à laquelle est rattachée cette part d'expression
MakeError (#) | Produit une erreur de compilation au niveau de cette expression

Properties
Property | Description
BaseCompiler (#) | Compilateur de base
Expression (#) | Expression à laquelle est rattachée cette part d'expression
LanguageRules (#) | Règles du langage utilisé
MethodCompiler (#) | Compilateur de méthode
SepiRoot (#) | Racine Sepi
SystemUnit (#) | Unité System
UnitCompiler (#) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomExecutable)
Next (TSepiCustomWithParams)


Sepi

Sepi
Previous
Next (FExpression)

Name
FBaseCompiler

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Compilateur de base

Source code
FBaseCompiler : TSepiCompilerBase

Sepi
Class Tree
Index
Previous
Next (FExpression)


Sepi

Sepi
Previous (FBaseCompiler)
Next (FLanguageRules)

Name
FExpression

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Référence faible à l'expression contrôleur

Source code
FExpression : Pointer

Sepi
Class Tree
Index
Previous (FBaseCompiler)
Next (FLanguageRules)


Sepi

Sepi
Previous (FExpression)
Next (FMethodCompiler)

Name
FLanguageRules

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Règles du langage utilisé

Source code
FLanguageRules : TSepiLanguageRules

Sepi
Class Tree
Index
Previous (FExpression)
Next (FMethodCompiler)


Sepi

Sepi
Previous (FLanguageRules)
Next (FSepiRoot)

Name
FMethodCompiler

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Compilateur de méthode

Source code
FMethodCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous (FLanguageRules)
Next (FSepiRoot)


Sepi

Sepi
Previous (FMethodCompiler)
Next (FSystemUnit)

Name
FSepiRoot

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Racine Sepi

Source code
FSepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FMethodCompiler)
Next (FSystemUnit)


Sepi

Sepi
Previous (FSepiRoot)
Next (FUnitCompiler)

Name
FSystemUnit

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Unité System

Source code
FSystemUnit : TSepiSystemUnit

Sepi
Class Tree
Index
Previous (FSepiRoot)
Next (FUnitCompiler)


Sepi

Sepi
Previous (FSystemUnit)
Next

Name
FUnitCompiler

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Compilateur d'unité

Source code
FUnitCompiler : TSepiUnitCompiler

Sepi
Class Tree
Index
Previous (FSystemUnit)
Next


Sepi

Sepi
Previous
Next (Expression)

Name
BaseCompiler

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Compilateur de base

Source code
property BaseCompiler : TSepiCompilerBase read FBaseCompiler

Read Access
FBaseCompiler

Sepi
Class Tree
Index
Previous
Next (Expression)


Sepi

Sepi
Previous (BaseCompiler)
Next (LanguageRules)

Name
Expression

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Expression à laquelle est rattachée cette part d'expression

Source code
property Expression : ISepiExpression read GetExpression

Read Access
GetExpression

Sepi
Class Tree
Index
Previous (BaseCompiler)
Next (LanguageRules)


Sepi

Sepi
Previous (Expression)
Next (MethodCompiler)

Name
LanguageRules

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Règles du langage utilisé

Source code
property LanguageRules : TSepiLanguageRules read FLanguageRules

Read Access
FLanguageRules

Sepi
Class Tree
Index
Previous (Expression)
Next (MethodCompiler)


Sepi

Sepi
Previous (LanguageRules)
Next (SepiRoot)

Name
MethodCompiler

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Compilateur de méthode

Source code
property MethodCompiler : TSepiMethodCompiler read FMethodCompiler

Read Access
FMethodCompiler

Sepi
Class Tree
Index
Previous (LanguageRules)
Next (SepiRoot)


Sepi

Sepi
Previous (MethodCompiler)
Next (SystemUnit)

Name
SepiRoot

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read FSepiRoot

Read Access
FSepiRoot

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next (SystemUnit)


Sepi

Sepi
Previous (SepiRoot)
Next (UnitCompiler)

Name
SystemUnit

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Unité System

Source code
property SystemUnit : TSepiSystemUnit read FSystemUnit

Read Access
FSystemUnit

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (UnitCompiler)


Sepi

Sepi
Previous (SystemUnit)
Next

Name
UnitCompiler

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read FUnitCompiler

Read Access
FUnitCompiler

Sepi
Class Tree
Index
Previous (SystemUnit)
Next


Sepi

Sepi
Previous
Next (AttachToExpression)

Name
AttachTo

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachTo ( const Controller : IInterface ) ; override

Parameters
Parameter | Description
Controller : IInterface | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AttachToExpression)


Sepi

Sepi
Previous (AttachTo)
Next (DetachFromController)

Name
AttachToExpression

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; virtual ; abstract

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachTo)
Next (DetachFromController)


Sepi

Sepi
Previous (AttachToExpression)
Next (GetExpression)

Name
DetachFromController

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure DetachFromController ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (GetExpression)


Sepi

Sepi
Previous (DetachFromController)
Next (MakeError)

Name
GetExpression

Parent
TSepiCustomExpressionPart

Visibility
PRIVATE

Description
Expression à laquelle est rattachée cette part d'expression

Source code
function GetExpression : ISepiExpression

Parameters
Parameter Description

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (DetachFromController)
Next (MakeError)


Sepi

Sepi
Previous (GetExpression)
Next

Name
MakeError

Parent
TSepiCustomExpressionPart

Visibility
PROTECTED

Description
Produit une erreur de compilation au niveau de cette expression

Source code
procedure MakeError ( const Msg : string ; Kind : TSepiErrorKind = ekError )

Parameters
Parameter | Description
Msg : STRING | Message de l'erreur
Kind : TSepiErrorKind | Type d'erreur (défaut = ekError)

Sepi
Class Tree
Index
Previous (GetExpression)
Next


Sepi

Sepi
Previous (TSepiCustomExpressionPart)
Next (TSepiDereferenceValue)

Name
TSepiCustomWithParams

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart

Visibility
PUBLIC

Description
Classe de base pour les expressions qui ont des paramètres

Members
Fields
Field | Description
FParams (-) | Liste des paramètres
FParamsCompleted (-) | True si les paramètres sont clôturés

Methods
Method | Description
AddParam (#) | Ajoute un paramètre
ClearParams (#) | Efface tous les paramètres
CompleteParams (#) | Complète les paramètres
Create (+) | Crée une expression à paramètres
DeleteParam (#) | Supprime un paramètre
GetParamCount (#) | Nombre de paramètres
GetParams (#) | Tableau zero-based des paramètres
GetParamsCompleted (#) | Indique si les paramètres sont complétés
MatchesSignature (#) | Teste si les paramètres correspondent à une signature
SetParamCount (#) | Modifie le nombre de paramètres
SetParams (#) | Modifie un paramètre

Properties
Property | Description
ParamCount (#) | Nombre de paramètres
Params (#) | Tableau zero-based des paramètres
ParamsCompleted (#) | True si les paramètres sont clôturés

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomExpressionPart)
Next (TSepiDereferenceValue)


Sepi

Sepi
Previous
Next (FParamsCompleted)

Name
FParams

Parent
TSepiCustomWithParams

Visibility
PRIVATE

Description
Liste des paramètres

Source code
FParams : IInterfaceList

Sepi
Class Tree
Index
Previous
Next (FParamsCompleted)


Sepi

Sepi
Previous (FParams)
Next

Name
FParamsCompleted

Parent
TSepiCustomWithParams

Visibility
PRIVATE

Description
True si les paramètres sont clôturés

Source code
FParamsCompleted : Boolean

Sepi
Class Tree
Index
Previous (FParams)
Next


Sepi

Sepi
Previous
Next (Params)

Name
ParamCount

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Nombre de paramètres

Source code
property ParamCount : Integer read GetParamCount

Read Access
GetParamCount

Sepi
Class Tree
Index
Previous
Next (Params)


Sepi

Sepi
Previous (ParamCount)
Next (ParamsCompleted)

Name
Params

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Tableau zero-based des paramètres

Source code
property Params [ Index : Integer ] : ISepiExpression read GetParams write SetParams

Read Access
GetParams

Write Access
SetParams

Sepi
Class Tree
Index
Previous (ParamCount)
Next (ParamsCompleted)


Sepi

Sepi
Previous (Params)
Next

Name
ParamsCompleted

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
True si les paramètres sont clôturés

Source code
property ParamsCompleted : Boolean read FParamsCompleted

Read Access
FParamsCompleted

Sepi
Class Tree
Index
Previous (Params)
Next


Sepi

Sepi
Previous
Next (ClearParams)

Name
AddParam

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Ajoute un paramètre

Source code
procedure AddParam ( const Value : ISepiExpression )

Parameters
Parameter | Description
Value : ISepiExpression | Paramètre à ajouter

Sepi
Class Tree
Index
Previous
Next (ClearParams)


Sepi

Sepi
Previous (AddParam)
Next (CompleteParams)

Name
ClearParams

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Efface tous les paramètres

Source code
procedure ClearParams

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddParam)
Next (CompleteParams)


Sepi

Sepi
Previous (ClearParams)
Next (Create)

Name
CompleteParams

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Complète les paramètres
Une fois complétés, il n'est plus possible de modifier ou d'ajouter de
paramètre.

Source code
procedure CompleteParams ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ClearParams)
Next (Create)


Sepi

Sepi
Previous (CompleteParams)
Next (DeleteParam)

Name
Create

Parent
TSepiCustomWithParams

Visibility
PUBLIC

Description
Crée une expression à paramètres

Source code
constructor Create ( AInitParamCount : Integer = 0 )

Parameters
Parameter | Description
AInitParamCount : INTEGER | Nombre initial de paramètres (défaut = 0)

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (DeleteParam)


Sepi

Sepi
Previous (Create)
Next (GetParamCount)

Name
DeleteParam

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Supprime un paramètre

Source code
procedure DeleteParam ( Index : Integer )

Parameters
Parameter | Description
INDEX : INTEGER | Index du paramètre à supprimer

Sepi
Class Tree
Index
Previous (Create)
Next (GetParamCount)


Sepi

Sepi
Previous (DeleteParam)
Next (GetParams)

Name
GetParamCount

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Nombre de paramètres

Source code
function GetParamCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de paramètres

Sepi
Class Tree
Index
Previous (DeleteParam)
Next (GetParams)


Sepi

Sepi
Previous (GetParamCount)
Next (GetParamsCompleted)

Name
GetParams

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Tableau zero-based des paramètres

Source code
function GetParams ( Index : Integer ) : ISepiExpression

Parameters
Parameter | Description
INDEX : INTEGER | Index dans le tableau des paramètres

Return
Types | Description
ISepiExpression | Paramètre à l'index spécifié

Sepi
Class Tree
Index
Previous (GetParamCount)
Next (GetParamsCompleted)


Sepi

Sepi
Previous (GetParams)
Next (MatchesSignature)

Name
GetParamsCompleted

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Indique si les paramètres sont complétés

Source code
function GetParamsCompleted : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si les paramètres sont complétés, False sinon

Sepi
Class Tree
Index
Previous (GetParams)
Next (MatchesSignature)


Sepi

Sepi
Previous (GetParamsCompleted)
Next (SetParamCount)

Name
MatchesSignature

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Teste si les paramètres correspondent à une signature

Source code
function MatchesSignature ( Signature : TSepiSignature ; MakeErrors : Boolean = True ) : Boolean

Parameters
Parameter | Description
Signature : TSepiSignature | Signature à tester
MakeErrors : BOOLEAN | Si True (par défaut), génère des erreurs de compilation

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetParamsCompleted)
Next (SetParamCount)


Sepi

Sepi
Previous (MatchesSignature)
Next (SetParams)

Name
SetParamCount

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Modifie le nombre de paramètres

Source code
procedure SetParamCount ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Nouveau nombre de paramètres

Sepi
Class Tree
Index
Previous (MatchesSignature)
Next (SetParams)


Sepi

Sepi
Previous (SetParamCount)
Next

Name
SetParams

Parent
TSepiCustomWithParams

Visibility
PROTECTED

Description
Modifie un paramètre

Source code
procedure SetParams ( Index : Integer ; const Value : ISepiExpression )

Parameters
Parameter | Description
INDEX : INTEGER | Index du paramètre à modifié
Value : ISepiExpression | Nouvelle valeur du paramètre

Sepi
Class Tree
Index
Previous (SetParamCount)
Next


Sepi

Sepi
Previous (TSepiCustomWithParams)
Next (TSepiDynArrayCopyExpression)

Name
TSepiDereferenceValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Opérateur de déréférencement

Members
Fields
Field | Description
FOperand (-) | Opérande

Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Complete (+) | Complète l'opérateur de déréférencement
Create (+) | Crée une opération de déréférencement
MakeDereference (+) | Construit un déréférencement

Properties
Property | Description
Operand (+) | Opérande

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomWithParams)
Next (TSepiDynArrayCopyExpression)


Sepi

Sepi
Previous
Next

Name
FOperand

Parent
TSepiDereferenceValue

Visibility
PRIVATE

Description
Opérande

Source code
FOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Operand

Parent
TSepiDereferenceValue

Visibility
PUBLIC

Description
Opérande

Source code
property Operand : ISepiReadableValue read FOperand write FOperand

Read Access
FOperand

Write Access
FOperand

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Complete)

Name
CompileAsMemoryRef

Parent
TSepiDereferenceValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (Create)

Name
Complete

Parent
TSepiDereferenceValue

Visibility
PUBLIC

Description
Complète l'opérateur de déréférencement
Doit avoir été attaché à une expression au préalable, pour bénéficier du
contexte.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (MakeDereference)

Name
Create

Parent
TSepiDereferenceValue

Visibility
PUBLIC

Description
Crée une opération de déréférencement

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Complete)
Next (MakeDereference)


Sepi

Sepi
Previous (Create)
Next

Name
MakeDereference

Parent
TSepiDereferenceValue

Visibility
PUBLIC

Description
Construit un déréférencement

Source code
class function MakeDereference ( const Operand : ISepiReadableValue ) : ISepiValue

Parameters
Parameter | Description
Operand : ISepiReadableValue | Opérande

Return
Types | Description
ISepiValue | Valeur déréférencée

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiDereferenceValue)
Next (TSepiDynArraySetLengthExpression)

Name
TSepiDynArrayCopyExpression

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Expression copie d'une partie d'une chaîne de caractères

Members
Fields
Field | Description
FCountValue (-) | Valeur du nombre d'éléments à copier
FIndexValue (-) | Valeur de l'index
FIsRange (-) | Indique si c'est la version range
FSourceArray (-) | Tableau source

Methods
Method | Description
CheckTypes (-) | Vérification de type
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'expression
Create (+) | Crée une expression copie de tableau dynamique
MakeDynArrayCopy (+) | Construit une expression copie d'une partie de chaîne de caractères
MakeDynArrayCopyRange (+) | Construit une expression copie d'une partie de chaîne de caractères

Properties
Property | Description
CountValue (+) | Valeur du nombre d'éléments à copier
IndexValue (+) | Valeur de l'index
IsRange (+) | Indique si c'est la version range
SourceArray (+) | Tableau source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDereferenceValue)
Next (TSepiDynArraySetLengthExpression)


Sepi

Sepi
Previous
Next (FIndexValue)

Name
FCountValue

Parent
TSepiDynArrayCopyExpression

Visibility
PRIVATE

Description
Valeur du nombre d'éléments à copier

Source code
FCountValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (FIndexValue)


Sepi

Sepi
Previous (FCountValue)
Next (FIsRange)

Name
FIndexValue

Parent
TSepiDynArrayCopyExpression

Visibility
PRIVATE

Description
Valeur de l'index

Source code
FIndexValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FCountValue)
Next (FIsRange)


Sepi

Sepi
Previous (FIndexValue)
Next (FSourceArray)

Name
FIsRange

Parent
TSepiDynArrayCopyExpression

Visibility
PRIVATE

Description
Indique si c'est la version range

Source code
FIsRange : Boolean

Sepi
Class Tree
Index
Previous (FIndexValue)
Next (FSourceArray)


Sepi

Sepi
Previous (FIsRange)
Next

Name
FSourceArray

Parent
TSepiDynArrayCopyExpression

Visibility
PRIVATE

Description
Tableau source

Source code
FSourceArray : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FIsRange)
Next


Sepi

Sepi
Previous
Next (IndexValue)

Name
CountValue

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Valeur du nombre d'éléments à copier

Source code
property CountValue : ISepiReadableValue read FCountValue write FCountValue

Read Access
FCountValue

Write Access
FCountValue

Sepi
Class Tree
Index
Previous
Next (IndexValue)


Sepi

Sepi
Previous (CountValue)
Next (IsRange)

Name
IndexValue

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Valeur de l'index

Source code
property IndexValue : ISepiReadableValue read FIndexValue write FIndexValue

Read Access
FIndexValue

Write Access
FIndexValue

Sepi
Class Tree
Index
Previous (CountValue)
Next (IsRange)


Sepi

Sepi
Previous (IndexValue)
Next (SourceArray)

Name
IsRange

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Indique si c'est la version range

Source code
property IsRange : Boolean read FIsRange

Read Access
FIsRange

Sepi
Class Tree
Index
Previous (IndexValue)
Next (SourceArray)


Sepi

Sepi
Previous (IsRange)
Next

Name
SourceArray

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Tableau source

Source code
property SourceArray : ISepiReadableValue read FSourceArray write FSourceArray

Read Access
FSourceArray

Write Access
FSourceArray

Sepi
Class Tree
Index
Previous (IsRange)
Next


Sepi

Sepi
Previous
Next (CompileCompute)

Name
CheckTypes

Parent
TSepiDynArrayCopyExpression

Visibility
PRIVATE

Description
Vérification de type

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileCompute)


Sepi

Sepi
Previous (CheckTypes)
Next (Complete)

Name
CompileCompute

Parent
TSepiDynArrayCopyExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (Create)

Name
Complete

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Complète l'expression

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (MakeDynArrayCopy)

Name
Create

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Crée une expression copie de tableau dynamique

Source code
constructor Create ( AIsRange : Boolean )

Parameters
Parameter | Description
AIsRange : BOOLEAN | Indique si c'est la version range

Sepi
Class Tree
Index
Previous (Complete)
Next (MakeDynArrayCopy)


Sepi

Sepi
Previous (Create)
Next (MakeDynArrayCopyRange)

Name
MakeDynArrayCopy

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Construit une expression copie d'une partie de chaîne de caractères

Source code
class function MakeDynArrayCopy ( const SourceArray : ISepiReadableValue ) : ISepiReadableValue ; overload

Parameters
Parameter | Description
SourceArray : ISepiReadableValue | Tableau source

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (MakeDynArrayCopyRange)


Sepi

Sepi
Previous (MakeDynArrayCopy)
Next

Name
MakeDynArrayCopyRange

Parent
TSepiDynArrayCopyExpression

Visibility
PUBLIC

Description
Construit une expression copie d'une partie de chaîne de caractères

Source code
class function MakeDynArrayCopyRange ( const SourceArray : ISepiReadableValue ; const IndexValue , CountValue : ISepiReadableValue ) : ISepiReadableValue ; overload

Parameters
Parameter | Description
SourceArray : ISepiReadableValue | Tableau source
IndexValue : ISepiReadableValue | Valeur index de début de la copie
CountValue : ISepiReadableValue | Valeur nombre de caractères à copier

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeDynArrayCopy)
Next


Sepi

Sepi
Previous (TSepiDynArrayCopyExpression)
Next (TSepiErroneousValue)

Name
TSepiDynArraySetLengthExpression

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExecutable

Visibility
PUBLIC

Description
Expression de changement de la longueur d'un tableau dynamique

Members
Fields
Field | Description
FDimCount (-) | Nombre de dimensions
FDimensions (-) | Dimensions
FDynArrayValue (-) | Chaîne dont modifier la longueur

Methods
Method | Description
CheckTypes (-) | Vérification de type
CompileExecute (#) | [@inheritDoc]
Complete (+) | Complète l'expression
Create (+) | Crée une expression de changement de la longueur d'un tableau dynamique
GetDimensions (-) | Tableau zero-based des dimensions
MakeDynArraySetLengthExpression (+) | Construit une expression de changement de la longueur d'un tableau dynamique
SetDimensions (-) | Modifie le tableau zero-based des dimensions

Properties
Property | Description
DimCount (+) | Nombre de dimensions
Dimensions (+) | Tableau zero-based des dimensions
DynArrayValue (+) | Chaîne dont modifier la longueur
FirstDimension (+) | Tableau zero-based des dimensions

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDynArrayCopyExpression)
Next (TSepiErroneousValue)


Sepi

Sepi
Previous
Next (FDimensions)

Name
FDimCount

Parent
TSepiDynArraySetLengthExpression

Visibility
PRIVATE

Description
Nombre de dimensions

Source code
FDimCount : Integer

Sepi
Class Tree
Index
Previous
Next (FDimensions)


Sepi

Sepi
Previous (FDimCount)
Next (FDynArrayValue)

Name
FDimensions

Parent
TSepiDynArraySetLengthExpression

Visibility
PRIVATE

Description
Dimensions

Source code
FDimensions : IInterfaceList

Sepi
Class Tree
Index
Previous (FDimCount)
Next (FDynArrayValue)


Sepi

Sepi
Previous (FDimensions)
Next

Name
FDynArrayValue

Parent
TSepiDynArraySetLengthExpression

Visibility
PRIVATE

Description
Chaîne dont modifier la longueur

Source code
FDynArrayValue : ISepiValue

Sepi
Class Tree
Index
Previous (FDimensions)
Next


Sepi

Sepi
Previous
Next (Dimensions)

Name
DimCount

Parent
TSepiDynArraySetLengthExpression

Visibility
PUBLIC

Description
Nombre de dimensions

Source code
property DimCount : Integer read FDimCount

Read Access
FDimCount

Sepi
Class Tree
Index
Previous
Next (Dimensions)


Sepi

Sepi
Previous (DimCount)
Next (DynArrayValue)

Name
Dimensions

Parent
TSepiDynArraySetLengthExpression

Visibility
PUBLIC

Description
Tableau zero-based des dimensions

Source code
property Dimensions [ Index : Integer ] : ISepiReadableValue read GetDimensions write SetDimensions

Read Access
GetDimensions

Write Access
SetDimensions

Sepi
Class Tree
Index
Previous (DimCount)
Next (DynArrayValue)


Sepi

Sepi
Previous (Dimensions)
Next (FirstDimension)

Name
DynArrayValue

Parent
TSepiDynArraySetLengthExpression

Visibility
PUBLIC

Description
Chaîne dont modifier la longueur

Source code
property DynArrayValue : ISepiValue read FDynArrayValue write FDynArrayValue

Read Access
FDynArrayValue

Write Access
FDynArrayValue

Sepi
Class Tree
Index
Previous (Dimensions)
Next (FirstDimension)


Sepi

Sepi
Previous (DynArrayValue)
Next

Name
FirstDimension

Parent
TSepiDynArraySetLengthExpression

Visibility
PUBLIC

Description
Tableau zero-based des dimensions

Source code
property FirstDimension : ISepiReadableValue index 0 read GetDimensions write SetDimensions

Read Access
GetDimensions

Write Access
SetDimensions

Sepi
Class Tree
Index
Previous (DynArrayValue)
Next


Sepi

Sepi
Previous
Next (CompileExecute)

Name
CheckTypes

Parent
TSepiDynArraySetLengthExpression

Visibility
PRIVATE

Description
Vérification de type

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (CheckTypes)
Next (Complete)

Name
CompileExecute

Parent
TSepiDynArraySetLengthExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (Complete)


Sepi

Sepi
Previous (CompileExecute)
Next (Create)

Name
Complete

Parent
TSepiDynArraySetLengthExpression

Visibility
PUBLIC

Description
Complète l'expression

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileExecute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (GetDimensions)

Name
Create

Parent
TSepiDynArraySetLengthExpression

Visibility
PUBLIC

Description
Crée une expression de changement de la longueur d'un tableau dynamique

Source code
constructor Create ( ADimCount : Integer = 1 )

Parameters
Parameter | Description
ADimCount : INTEGER | Nombre de dimensions (> 0)

Sepi
Class Tree
Index
Previous (Complete)
Next (GetDimensions)


Sepi

Sepi
Previous (Create)
Next (MakeDynArraySetLengthExpression)

Name
GetDimensions

Parent
TSepiDynArraySetLengthExpression

Visibility
PRIVATE

Description
Tableau zero-based des dimensions

Source code
function GetDimensions ( Index : Integer ) : ISepiReadableValue

Parameters
Parameter | Description
INDEX : INTEGER | Index compris entre 0 inclus et DimCount exclu

Return
Types | Description
ISepiReadableValue | Dimension à l'index spécifié

Sepi
Class Tree
Index
Previous (Create)
Next (MakeDynArraySetLengthExpression)


Sepi

Sepi
Previous (GetDimensions)
Next (SetDimensions)

Name
MakeDynArraySetLengthExpression

Parent
TSepiDynArraySetLengthExpression

Visibility
PUBLIC

Description
Construit une expression de changement de la longueur d'un tableau dynamique

Source code
class function MakeDynArraySetLengthExpression ( const DynArrayValue : ISepiValue ; const Dimensions : array of ISepiReadableValue ) : ISepiExecutable

Parameters
Parameter | Description
DynArrayValue : ISepiValue | Valeur tableau dynamique
Dimensions : ISepiReadableValue | Nouvelles longueurs des dimensions

Return
Types | Description
ISepiExecutable | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDimensions)
Next (SetDimensions)


Sepi

Sepi
Previous (MakeDynArraySetLengthExpression)
Next

Name
SetDimensions

Parent
TSepiDynArraySetLengthExpression

Visibility
PRIVATE

Description
Modifie le tableau zero-based des dimensions

Source code
procedure SetDimensions ( Index : Integer ; const Value : ISepiReadableValue )

Parameters
Parameter | Description
INDEX : INTEGER | Index compris entre 0 inclus et DimCount exclu
Value : ISepiReadableValue | Nouvelle valeur pour la dimension à l'index spécifié

Sepi
Class Tree
Index
Previous (MakeDynArraySetLengthExpression)
Next


Sepi

Sepi
Previous (TSepiDynArraySetLengthExpression)
Next (TSepiFloatLiteralValue)

Name
TSepiErroneousValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue,ISepiTypeForceableValue

Visibility
PUBLIC

Description
Valeur erronée

Members
Methods
Method | Description
CanForceType (#) | [@inheritDoc]
CompileAsMemoryRef (#) | [@inheritDoc]
Create (+) | Crée une valeur erronée d'un type inconnu
Create (+) | Crée une valeur erronée d'un type donné
ForceType (#) | [@inheritDoc]
MakeReplacementValue (+) | Construit une valeur erronée pour remplacer une expression non valide

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDynArraySetLengthExpression)
Next (TSepiFloatLiteralValue)


Sepi

Sepi
Previous
Next (CompileAsMemoryRef)

Name
CanForceType

Parent
TSepiErroneousValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileAsMemoryRef)


Sepi

Sepi
Previous (CanForceType)
Next (Create)

Name
CompileAsMemoryRef

Parent
TSepiErroneousValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceType)
Next (Create)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (Create)

Name
Create

Parent
TSepiErroneousValue

Visibility
PUBLIC

Description
Crée une valeur erronée d'un type inconnu

Source code
constructor Create ( ASepiRoot : TSepiRoot ) ; overload

Parameters
Parameter | Description
ASepiRoot : TSepiRoot | RacineSepi

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (ForceType)

Name
Create

Parent
TSepiErroneousValue

Visibility
PUBLIC

Description
Crée une valeur erronée d'un type donné

Source code
constructor Create ( AValueType : TSepiType ) ; overload

Parameters
Parameter | Description
AValueType : TSepiType | Type de la valeur erronée

Sepi
Class Tree
Index
Previous (Create)
Next (ForceType)


Sepi

Sepi
Previous (Create)
Next (MakeReplacementValue)

Name
ForceType

Parent
TSepiErroneousValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (MakeReplacementValue)


Sepi

Sepi
Previous (ForceType)
Next

Name
MakeReplacementValue

Parent
TSepiErroneousValue

Visibility
PUBLIC

Description
Construit une valeur erronée pour remplacer une expression non valide

Source code
class function MakeReplacementValue ( const OrigExpr : ISepiExpression ; ValueType : TSepiType = nil ) : ISepiReadableValue

Parameters
Parameter | Description
OrigExpr : ISepiExpression | Expression à remplacer
ValueType : TSepiType | Type de la valeur erronée

Return
Types | Description
ISepiReadableValue | Valeur erronée créée

Sepi
Class Tree
Index
Previous (ForceType)
Next


Sepi

Sepi
Previous (TSepiErroneousValue)
Next (TSepiInSetOperation)

Name
TSepiFloatLiteralValue

Parent
SepiExpressions

Class Hierarchy
TSepiLiteralValue,ISepiTypeForceableValue

Visibility
PUBLIC

Description
Valeur constante litérale entière

Members
Fields
Field | Description
FConstValueBuffer (-) | Buffer pour la valeur constante typée
FValue (-) | Valeur constante

Methods
Method | Description
CanForceType (#) | [@inheritDoc]
Create (+) | Crée une valeur constante litérale flottante
ForceType (#) | [@inheritDoc]
MakeValue (+) | Construit une valeur constante litérale flottante

Properties
Property | Description
Value (+) | Valeur constante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiErroneousValue)
Next (TSepiInSetOperation)


Sepi

Sepi
Previous
Next (FValue)

Name
FConstValueBuffer

Parent
TSepiFloatLiteralValue

Visibility
PRIVATE

Description
Buffer pour la valeur constante typée

Source code
FConstValueBuffer : Extended

Sepi
Class Tree
Index
Previous
Next (FValue)


Sepi

Sepi
Previous (FConstValueBuffer)
Next

Name
FValue

Parent
TSepiFloatLiteralValue

Visibility
PRIVATE

Description
Valeur constante

Source code
FValue : Extended

Sepi
Class Tree
Index
Previous (FConstValueBuffer)
Next


Sepi

Sepi
Previous
Next

Name
Value

Parent
TSepiFloatLiteralValue

Visibility
PUBLIC

Description
Valeur constante

Source code
property Value : Extended read FValue

Read Access
FValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
CanForceType

Parent
TSepiFloatLiteralValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CanForceType)
Next (ForceType)

Name
Create

Parent
TSepiFloatLiteralValue

Visibility
PUBLIC

Description
Crée une valeur constante litérale flottante

Source code
constructor Create ( ASepiRoot : TSepiRoot ; AValue : Extended )

Parameters
Parameter | Description
ASepiRoot : TSepiRoot | Racine Sepi
AValue : EXTENDED | Valeur constante

Sepi
Class Tree
Index
Previous (CanForceType)
Next (ForceType)


Sepi

Sepi
Previous (Create)
Next (MakeValue)

Name
ForceType

Parent
TSepiFloatLiteralValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (MakeValue)


Sepi

Sepi
Previous (ForceType)
Next

Name
MakeValue

Parent
TSepiFloatLiteralValue

Visibility
PUBLIC

Description
Construit une valeur constante litérale flottante

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; Value : Extended ) : ISepiReadableValue

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur
Value : EXTENDED | Valeur constante

Return
Types | Description
ISepiReadableValue | Valeur constante litérale entière

Sepi
Class Tree
Index
Previous (ForceType)
Next


Sepi

Sepi
Previous (TSepiFloatLiteralValue)
Next (TSepiInstructionExpression)

Name
TSepiInSetOperation

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Opération in (appartenance à un ensemble)

Members
Fields
Field | Description
FItemOperand (-) | Opérande élément
FSetOperand (-) | Opérande ensemble

Methods
Method | Description
CheckTypes (-) | Vérifie le type des opérandes
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'opération
Create (+) | Crée une opération is ou as
MakeOperation (+) | Construit une opération binaire

Properties
Property | Description
ItemOperand (+) | Opérande élément
SetOperand (+) | Opérande ensemble

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFloatLiteralValue)
Next (TSepiInstructionExpression)


Sepi

Sepi
Previous
Next (FSetOperand)

Name
FItemOperand

Parent
TSepiInSetOperation

Visibility
PRIVATE

Description
Opérande élément

Source code
FItemOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (FSetOperand)


Sepi

Sepi
Previous (FItemOperand)
Next

Name
FSetOperand

Parent
TSepiInSetOperation

Visibility
PRIVATE

Description
Opérande ensemble

Source code
FSetOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FItemOperand)
Next


Sepi

Sepi
Previous
Next (SetOperand)

Name
ItemOperand

Parent
TSepiInSetOperation

Visibility
PUBLIC

Description
Opérande élément

Source code
property ItemOperand : ISepiReadableValue read FItemOperand write FItemOperand

Read Access
FItemOperand

Write Access
FItemOperand

Sepi
Class Tree
Index
Previous
Next (SetOperand)


Sepi

Sepi
Previous (ItemOperand)
Next

Name
SetOperand

Parent
TSepiInSetOperation

Visibility
PUBLIC

Description
Opérande ensemble

Source code
property SetOperand : ISepiReadableValue read FSetOperand write FSetOperand

Read Access
FSetOperand

Write Access
FSetOperand

Sepi
Class Tree
Index
Previous (ItemOperand)
Next


Sepi

Sepi
Previous
Next (CollapseConsts)

Name
CheckTypes

Parent
TSepiInSetOperation

Visibility
PRIVATE

Description
Vérifie le type des opérandes

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CollapseConsts)


Sepi

Sepi
Previous (CheckTypes)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiInSetOperation

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (Complete)

Name
CompileCompute

Parent
TSepiInSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (Create)

Name
Complete

Parent
TSepiInSetOperation

Visibility
PUBLIC

Description
Complète l'opération
L'opération doit avoir été attachée à une expression auparavant, pour pouvoir
bénéficier du contexte de celle-ci.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (MakeOperation)

Name
Create

Parent
TSepiInSetOperation

Visibility
PUBLIC

Description
Crée une opération is ou as

Source code
constructor Create ( ASepiRoot : TSepiRoot )

Parameters
Parameter | Description
ASepiRoot : TSepiRoot | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (MakeOperation)


Sepi

Sepi
Previous (Create)
Next

Name
MakeOperation

Parent
TSepiInSetOperation

Visibility
PUBLIC

Description
Construit une opération binaire

Source code
class function MakeOperation ( const ItemOperand : ISepiReadableValue ; const SetOperand : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter Description
ItemOperand : ISepiReadableValue
SetOperand : ISepiReadableValue

Return
Types | Description
ISepiReadableValue | Valeur représentant l'opération

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiInSetOperation)
Next (TSepiIntegerLiteralValue)

Name
TSepiInstructionExpression

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiExecutable

Visibility
PUBLIC

Description
Expression wrapper pour une instruction

Members
Fields
Field | Description
FInstruction (-) | Instruction wrappée

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileExecute (#) | [@inheritDoc]
Create (+) | Crée une expression wrapper pour une instruction

Properties
Property | Description
Instruction (+) | Instruction wrappée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInSetOperation)
Next (TSepiIntegerLiteralValue)


Sepi

Sepi
Previous
Next

Name
FInstruction

Parent
TSepiInstructionExpression

Visibility
PRIVATE

Description
Instruction wrappée

Source code
FInstruction : TSepiInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Instruction

Parent
TSepiInstructionExpression

Visibility
PUBLIC

Description
Instruction wrappée

Source code
property Instruction : TSepiInstruction read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileExecute)

Name
AttachToExpression

Parent
TSepiInstructionExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (AttachToExpression)
Next (Create)

Name
CompileExecute

Parent
TSepiInstructionExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (Create)


Sepi

Sepi
Previous (CompileExecute)
Next

Name
Create

Parent
TSepiInstructionExpression

Visibility
PUBLIC

Description
Crée une expression wrapper pour une instruction

Source code
constructor Create ( AInstruction : TSepiInstruction )

Parameters
Parameter | Description
AInstruction : TSepiInstruction | Instruction wrappée

Sepi
Class Tree
Index
Previous (CompileExecute)
Next


Sepi

Sepi
Previous (TSepiInstructionExpression)
Next (TSepiIsAsOperation)

Name
TSepiIntegerLiteralValue

Parent
SepiExpressions

Class Hierarchy
TSepiLiteralValue,ISepiTypeForceableValue

Visibility
PUBLIC

Description
Valeur constante litérale entière

Members
Fields
Field | Description
FValue (-) | Valeur constante

Methods
Method | Description
CanForceType (#) | [@inheritDoc]
Create (+) | Crée une valeur constante litérale entière
ForceType (#) | [@inheritDoc]
MakeValue (+) | Construit une valeur constante litérale entière
MakeValue (+) | Construit une valeur constante litérale entière

Properties
Property | Description
Value (+) | Valeur constante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInstructionExpression)
Next (TSepiIsAsOperation)


Sepi

Sepi
Previous
Next

Name
FValue

Parent
TSepiIntegerLiteralValue

Visibility
PRIVATE

Description
Valeur constante

Source code
FValue : Int64

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Value

Parent
TSepiIntegerLiteralValue

Visibility
PUBLIC

Description
Valeur constante

Source code
property Value : Int64 read FValue

Read Access
FValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
CanForceType

Parent
TSepiIntegerLiteralValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CanForceType)
Next (ForceType)

Name
Create

Parent
TSepiIntegerLiteralValue

Visibility
PUBLIC

Description
Crée une valeur constante litérale entière

Source code
constructor Create ( ASepiRoot : TSepiRoot ; AValue : Int64 )

Parameters
Parameter | Description
ASepiRoot : TSepiRoot | Racine Sepi
AValue : INT64 | Valeur constante

Sepi
Class Tree
Index
Previous (CanForceType)
Next (ForceType)


Sepi

Sepi
Previous (Create)
Next (MakeValue)

Name
ForceType

Parent
TSepiIntegerLiteralValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (MakeValue)


Sepi

Sepi
Previous (ForceType)
Next (MakeValue)

Name
MakeValue

Parent
TSepiIntegerLiteralValue

Visibility
PUBLIC

Description
Construit une valeur constante litérale entière

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; Value : Int64 ; ValueType : TSepiType ) : ISepiReadableValue ; overload

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur
Value : INT64 | Valeur constante
ValueType : TSepiType | Type de la valeur

Return
Types | Description
ISepiReadableValue | Valeur constante litérale entière

Sepi
Class Tree
Index
Previous (ForceType)
Next (MakeValue)


Sepi

Sepi
Previous (MakeValue)
Next

Name
MakeValue

Parent
TSepiIntegerLiteralValue

Visibility
PUBLIC

Description
Construit une valeur constante litérale entière

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; Value : Int64 ) : ISepiReadableValue ; overload

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur
Value : INT64 | Valeur constante

Return
Types | Description
ISepiReadableValue | Valeur constante litérale entière

Sepi
Class Tree
Index
Previous (MakeValue)
Next


Sepi

Sepi
Previous (TSepiIntegerLiteralValue)
Next (TSepiIsOperation)

Name
TSepiIsAsOperation

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Classe de base pour les opérations is et as

Members
Fields
Field | Description
FClassOperand (-) | Opérande classe
FObjectOperand (-) | Opérande objet

Methods
Method | Description
CheckTypes (-) | Vérifie le type des opérandes
Complete (+) | Complète l'opération
Create (+) | Crée une opération is ou as
MakeOperation (+) | Construit une opération binaire
UpdateValueType (#) | Met à jour le type de valeur suite à la complétion de l'opération

Properties
Property | Description
ClassOperand (+) | Opérande classe
ObjectOperand (+) | Opérande objet

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIntegerLiteralValue)
Next (TSepiIsOperation)


Sepi

Sepi
Previous
Next (FObjectOperand)

Name
FClassOperand

Parent
TSepiIsAsOperation

Visibility
PRIVATE

Description
Opérande classe

Source code
FClassOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (FObjectOperand)


Sepi

Sepi
Previous (FClassOperand)
Next

Name
FObjectOperand

Parent
TSepiIsAsOperation

Visibility
PRIVATE

Description
Opérande objet

Source code
FObjectOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FClassOperand)
Next


Sepi

Sepi
Previous
Next (ObjectOperand)

Name
ClassOperand

Parent
TSepiIsAsOperation

Visibility
PUBLIC

Description
Opérande classe

Source code
property ClassOperand : ISepiReadableValue read FClassOperand write FClassOperand

Read Access
FClassOperand

Write Access
FClassOperand

Sepi
Class Tree
Index
Previous
Next (ObjectOperand)


Sepi

Sepi
Previous (ClassOperand)
Next

Name
ObjectOperand

Parent
TSepiIsAsOperation

Visibility
PUBLIC

Description
Opérande objet

Source code
property ObjectOperand : ISepiReadableValue read FObjectOperand write FObjectOperand

Read Access
FObjectOperand

Write Access
FObjectOperand

Sepi
Class Tree
Index
Previous (ClassOperand)
Next


Sepi

Sepi
Previous
Next (Complete)

Name
CheckTypes

Parent
TSepiIsAsOperation

Visibility
PRIVATE

Description
Vérifie le type des opérandes

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (CheckTypes)
Next (Create)

Name
Complete

Parent
TSepiIsAsOperation

Visibility
PUBLIC

Description
Complète l'opération
L'opération doit avoir été attachée à une expression auparavant, pour pouvoir
bénéficier du contexte de celle-ci.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (MakeOperation)

Name
Create

Parent
TSepiIsAsOperation

Visibility
PUBLIC

Description
Crée une opération is ou as

Source code
constructor Create ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Complete)
Next (MakeOperation)


Sepi

Sepi
Previous (Create)
Next (UpdateValueType)

Name
MakeOperation

Parent
TSepiIsAsOperation

Visibility
PUBLIC

Description
Construit une opération binaire

Source code
class function MakeOperation ( const ObjectOperand : ISepiReadableValue ; const ClassOperand : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter Description
ObjectOperand : ISepiReadableValue
ClassOperand : ISepiReadableValue

Return
Types | Description
ISepiReadableValue | Valeur représentant l'opération

Sepi
Class Tree
Index
Previous (Create)
Next (UpdateValueType)


Sepi

Sepi
Previous (MakeOperation)
Next

Name
UpdateValueType

Parent
TSepiIsAsOperation

Visibility
PROTECTED

Description
Met à jour le type de valeur suite à la complétion de l'opération

Source code
procedure UpdateValueType ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeOperation)
Next


Sepi

Sepi
Previous (TSepiIsAsOperation)
Next (TSepiLiteralValue)

Name
TSepiIsOperation

Parent
SepiExpressions

Class Hierarchy
TSepiIsAsOperation

Visibility
PUBLIC

Description
Opération is

Members
Methods
Method | Description
CompileCompute (#) | [@inheritDoc]
UpdateValueType (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIsAsOperation)
Next (TSepiLiteralValue)


Sepi

Sepi
Previous
Next (UpdateValueType)

Name
CompileCompute

Parent
TSepiIsOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (UpdateValueType)


Sepi

Sepi
Previous (CompileCompute)
Next

Name
UpdateValueType

Parent
TSepiIsOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure UpdateValueType ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next


Sepi

Sepi
Previous (TSepiIsOperation)
Next (TSepiLocalVarValue)

Name
TSepiLiteralValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Valeur constante litérale

Members
Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Create (+) | Crée une constante littérale

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIsOperation)
Next (TSepiLocalVarValue)


Sepi

Sepi
Previous
Next (Create)

Name
CompileAsMemoryRef

Parent
TSepiLiteralValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next

Name
Create

Parent
TSepiLiteralValue

Visibility
PUBLIC

Description
Crée une constante littérale

Source code
constructor Create ( AType : TSepiType )

Parameters
Parameter | Description
AType : TSepiType | Type de la constante

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next


Sepi

Sepi
Previous (TSepiLiteralValue)
Next (TSepiMetaClassValue)

Name
TSepiLocalVarValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Valeur variable locale

Members
Fields
Field | Description
FLocalVar (-) | Variable locale représentée

Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Create (+) | Crée une valeur variable locale
MakeValue (+) | Construit une expression valeur pour une variable locale

Properties
Property | Description
LocalVar (+) | Variable locale représentée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLiteralValue)
Next (TSepiMetaClassValue)


Sepi

Sepi
Previous
Next

Name
FLocalVar

Parent
TSepiLocalVarValue

Visibility
PRIVATE

Description
Variable locale représentée

Source code
FLocalVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
LocalVar

Parent
TSepiLocalVarValue

Visibility
PUBLIC

Description
Variable locale représentée

Source code
property LocalVar : TSepiLocalVar read FLocalVar

Read Access
FLocalVar

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompileAsMemoryRef

Parent
TSepiLocalVarValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (MakeValue)

Name
Create

Parent
TSepiLocalVarValue

Visibility
PUBLIC

Description
Crée une valeur variable locale

Source code
constructor Create ( ALocalVar : TSepiLocalVar )

Parameters
Parameter | Description
ALocalVar : TSepiLocalVar | LocalVar

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (MakeValue)


Sepi

Sepi
Previous (Create)
Next

Name
MakeValue

Parent
TSepiLocalVarValue

Visibility
PUBLIC

Description
Construit une expression valeur pour une variable locale

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; LocalVar : TSepiLocalVar ) : ISepiValue

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur de méthode
LocalVar : TSepiLocalVar | Variable locale

Return
Types | Description
ISepiValue | Valeur représentant la variable locale

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiLocalVarValue)
Next (TSepiMethodCall)

Name
TSepiMetaClassValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Valeur meta-classe

Members
Fields
Field | Description
FSepiClass (-) | Classe Sepi

Methods
Method | Description
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète la valeur
Create (+) | Crée une valeur meta-classe
MakeValue (+) | Construit une valeur meta-classe

Properties
Property | Description
SepiClass (+) | Classe Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLocalVarValue)
Next (TSepiMethodCall)


Sepi

Sepi
Previous
Next

Name
FSepiClass

Parent
TSepiMetaClassValue

Visibility
PRIVATE

Description
Classe Sepi

Source code
FSepiClass : TSepiClass

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SepiClass

Parent
TSepiMetaClassValue

Visibility
PUBLIC

Description
Classe Sepi

Source code
property SepiClass : TSepiClass read FSepiClass write FSepiClass

Read Access
FSepiClass

Write Access
FSepiClass

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Complete)

Name
CompileCompute

Parent
TSepiMetaClassValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (Create)

Name
Complete

Parent
TSepiMetaClassValue

Visibility
PUBLIC

Description
Complète la valeur
La valeur doit auparavant avoir été liée à une expression, pour bénéficier de
son contexte.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (MakeValue)

Name
Create

Parent
TSepiMetaClassValue

Visibility
PUBLIC

Description
Crée une valeur meta-classe

Source code
constructor Create ( ASepiClass : TSepiClass = nil )

Parameters
Parameter | Description
ASepiClass : TSepiClass | Classe Sepi

Sepi
Class Tree
Index
Previous (Complete)
Next (MakeValue)


Sepi

Sepi
Previous (Create)
Next

Name
MakeValue

Parent
TSepiMetaClassValue

Visibility
PUBLIC

Description
Construit une valeur meta-classe

Source code
class function MakeValue ( Compiler : TSepiMethodCompiler ; SepiClass : TSepiClass ) : ISepiReadableValue

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler
SepiClass : TSepiClass | Classe Sepi

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiMetaClassValue)
Next (TSepiMethodRefCall)

Name
TSepiMethodCall

Parent
SepiExpressions

Class Hierarchy
TSepiCustomCallable

Visibility
PUBLIC

Description
Appel de méthode

Members
Fields
Field | Description
FForceStaticCall (-) | Force un appel statique
FFreeParamValue (-) | Valeur de l'éventuel paramètre $Free
FMethod (-) | Méthode à appeler
FOverloadedMethod (-) | Méthode surchargée à appeler
FSelfValue (-) | Valeur Self

Methods
Method | Description
CheckSelfValueType (-) | [@inheritDoc]
CompileCall (#) | [@inheritDoc]
CompleteParams (#) | [@inheritDoc]
Create (+) | Crée une expression d'invocation de méthode
GetReturnType (#) | [@inheritDoc]

Properties
Property | Description
ForceStaticCall (+) | Force un appel statique
FreeParamValue (+) | Valeur de l'éventuel paramètre $Free
Method (+) | Méthode à appeler
OverloadedMethod (+) | Méthode surchargée à appeler
SelfValue (+) | Valeur Self

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMetaClassValue)
Next (TSepiMethodRefCall)


Sepi

Sepi
Previous
Next (FFreeParamValue)

Name
FForceStaticCall

Parent
TSepiMethodCall

Visibility
PRIVATE

Description
Force un appel statique

Source code
FForceStaticCall : Boolean

Sepi
Class Tree
Index
Previous
Next (FFreeParamValue)


Sepi

Sepi
Previous (FForceStaticCall)
Next (FMethod)

Name
FFreeParamValue

Parent
TSepiMethodCall

Visibility
PRIVATE

Description
Valeur de l'éventuel paramètre $Free

Source code
FFreeParamValue : Boolean

Sepi
Class Tree
Index
Previous (FForceStaticCall)
Next (FMethod)


Sepi

Sepi
Previous (FFreeParamValue)
Next (FOverloadedMethod)

Name
FMethod

Parent
TSepiMethodCall

Visibility
PRIVATE

Description
Méthode à appeler

Source code
FMethod : TSepiMethod

Sepi
Class Tree
Index
Previous (FFreeParamValue)
Next (FOverloadedMethod)


Sepi

Sepi
Previous (FMethod)
Next (FSelfValue)

Name
FOverloadedMethod

Parent
TSepiMethodCall

Visibility
PRIVATE

Description
Méthode surchargée à appeler

Source code
FOverloadedMethod : TSepiOverloadedMethod

Sepi
Class Tree
Index
Previous (FMethod)
Next (FSelfValue)


Sepi

Sepi
Previous (FOverloadedMethod)
Next

Name
FSelfValue

Parent
TSepiMethodCall

Visibility
PRIVATE

Description
Valeur Self

Source code
FSelfValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FOverloadedMethod)
Next


Sepi

Sepi
Previous
Next (FreeParamValue)

Name
ForceStaticCall

Parent
TSepiMethodCall

Visibility
PUBLIC

Description
Force un appel statique

Source code
property ForceStaticCall : Boolean read FForceStaticCall write FForceStaticCall

Read Access
FForceStaticCall

Write Access
FForceStaticCall

Sepi
Class Tree
Index
Previous
Next (FreeParamValue)


Sepi

Sepi
Previous (ForceStaticCall)
Next (Method)

Name
FreeParamValue

Parent
TSepiMethodCall

Visibility
PUBLIC

Description
Valeur de l'éventuel paramètre $Free

Source code
property FreeParamValue : Boolean read FFreeParamValue write FFreeParamValue

Read Access
FFreeParamValue

Write Access
FFreeParamValue

Sepi
Class Tree
Index
Previous (ForceStaticCall)
Next (Method)


Sepi

Sepi
Previous (FreeParamValue)
Next (OverloadedMethod)

Name
Method

Parent
TSepiMethodCall

Visibility
PUBLIC

Description
Méthode à appeler

Source code
property Method : TSepiMethod read FMethod

Read Access
FMethod

Sepi
Class Tree
Index
Previous (FreeParamValue)
Next (OverloadedMethod)


Sepi

Sepi
Previous (Method)
Next (SelfValue)

Name
OverloadedMethod

Parent
TSepiMethodCall

Visibility
PUBLIC

Description
Méthode surchargée à appeler

Source code
property OverloadedMethod : TSepiOverloadedMethod read FOverloadedMethod

Read Access
FOverloadedMethod

Sepi
Class Tree
Index
Previous (Method)
Next (SelfValue)


Sepi

Sepi
Previous (OverloadedMethod)
Next

Name
SelfValue

Parent
TSepiMethodCall

Visibility
PUBLIC

Description
Valeur Self

Source code
property SelfValue : ISepiReadableValue read FSelfValue write FSelfValue

Read Access
FSelfValue

Write Access
FSelfValue

Sepi
Class Tree
Index
Previous (OverloadedMethod)
Next


Sepi

Sepi
Previous
Next (CompileCall)

Name
CheckSelfValueType

Parent
TSepiMethodCall

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure CheckSelfValueType

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileCall)


Sepi

Sepi
Previous (CheckSelfValueType)
Next (CompleteParams)

Name
CompileCall

Parent
TSepiMethodCall

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCall ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Destination : TSepiMemoryReference ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckSelfValueType)
Next (CompleteParams)


Sepi

Sepi
Previous (CompileCall)
Next (Create)

Name
CompleteParams

Parent
TSepiMethodCall

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCall)
Next (Create)


Sepi

Sepi
Previous (CompleteParams)
Next (GetReturnType)

Name
Create

Parent
TSepiMethodCall

Visibility
PUBLIC

Description
Crée une expression d'invocation de méthode

Source code
constructor Create ( AMethod : TSepiMethodBase ; const ASelfValue : ISepiReadableValue = nil ; AForceStaticCall : Boolean = False ; AFreeParamValue : Boolean = False )

Parameters
Parameter | Description
AMethod : TSepiMethodBase | Méthode à appeler
ASelfValue : ISepiReadableValue | Valeur Self (défaut = nil)
AForceStaticCall : BOOLEAN | Force un appel statique (défaut = False)
AFreeParamValue : BOOLEAN | Valeur à donner au paramètre $Free (défaut = False)

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (GetReturnType)


Sepi

Sepi
Previous (Create)
Next

Name
GetReturnType

Parent
TSepiMethodCall

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetReturnType : TSepiType ; override

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiMethodCall)
Next (TSepiNilValue)

Name
TSepiMethodRefCall

Parent
SepiExpressions

Class Hierarchy
TSepiCustomCallable

Visibility
PUBLIC

Description
Appel de référence de méthode

Members
Fields
Field | Description
FMethodRefValue (-) | Valeur référence de méthode

Methods
Method | Description
CompileCall (#) | [@inheritDoc]
Complete (+) | Complète l'appel de référence de méthode
CompleteParams (#) | [@inheritDoc]
Create (+) | Crée une expression d'invocation de référence méthode

Properties
Property | Description
MethodRefValue (+) | Valeur référence de méthode

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodCall)
Next (TSepiNilValue)


Sepi

Sepi
Previous
Next

Name
FMethodRefValue

Parent
TSepiMethodRefCall

Visibility
PRIVATE

Description
Valeur référence de méthode

Source code
FMethodRefValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
MethodRefValue

Parent
TSepiMethodRefCall

Visibility
PUBLIC

Description
Valeur référence de méthode

Source code
property MethodRefValue : ISepiReadableValue read FMethodRefValue write FMethodRefValue

Read Access
FMethodRefValue

Write Access
FMethodRefValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Complete)

Name
CompileCall

Parent
TSepiMethodRefCall

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCall ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Destination : TSepiMemoryReference ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (CompileCall)
Next (CompleteParams)

Name
Complete

Parent
TSepiMethodRefCall

Visibility
PUBLIC

Description
Complète l'appel de référence de méthode
L'appel doit avoir été lié à une expression auparavant, pour bénéficier de
son contexte.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCall)
Next (CompleteParams)


Sepi

Sepi
Previous (Complete)
Next (Create)

Name
CompleteParams

Parent
TSepiMethodRefCall

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Complete)
Next (Create)


Sepi

Sepi
Previous (CompleteParams)
Next

Name
Create

Parent
TSepiMethodRefCall

Visibility
PUBLIC

Description
Crée une expression d'invocation de référence méthode

Source code
constructor Create ( const AMethodRefValue : ISepiReadableValue = nil ; AComplete : Boolean = False )

Parameters
Parameter | Description
AMethodRefValue : ISepiReadableValue | Référence de méthode
AComplete : BOOLEAN | Si True, complète immédiatement

Sepi
Class Tree
Index
Previous (CompleteParams)
Next


Sepi

Sepi
Previous (TSepiMethodRefCall)
Next (TSepiObjectFieldValue)

Name
TSepiNilValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiValue,ISepiReadableValue,ISepiTypeForceableValue

Visibility
PUBLIC

Description
Valeur nil

Members
Fields
Field | Description
FValueType (-) | Type de valeur

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CanForceType (#) | [@inheritDoc]
CompileRead (#) | [@inheritDoc]
Create (+) | #No TAG found in source code#
ForceType (#) | [@inheritDoc]
GetConstValuePtr (#) | [@inheritDoc]
GetIsConstant (#) | [@inheritDoc]
GetValueType (#) | [@inheritDoc]
MakeValue (+) | Construit une valeur nil

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodRefCall)
Next (TSepiObjectFieldValue)


Sepi

Sepi
Previous
Next

Name
FValueType

Parent
TSepiNilValue

Visibility
PRIVATE

Description
Type de valeur

Source code
FValueType : TSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CanForceType)

Name
AttachToExpression

Parent
TSepiNilValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CanForceType)


Sepi

Sepi
Previous (AttachToExpression)
Next (CompileRead)

Name
CanForceType

Parent
TSepiNilValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CompileRead)


Sepi

Sepi
Previous (CanForceType)
Next (Create)

Name
CompileRead

Parent
TSepiNilValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceType)
Next (Create)


Sepi

Sepi
Previous (CompileRead)
Next (ForceType)

Name
Create

Parent
TSepiNilValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( SepiRoot : TSepiRoot )

Parameters
Parameter | Description
SepiRoot : TSepiRoot | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileRead)
Next (ForceType)


Sepi

Sepi
Previous (Create)
Next (GetConstValuePtr)

Name
ForceType

Parent
TSepiNilValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetConstValuePtr)


Sepi

Sepi
Previous (ForceType)
Next (GetIsConstant)

Name
GetConstValuePtr

Parent
TSepiNilValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceType)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetConstValuePtr)
Next (GetValueType)

Name
GetIsConstant

Parent
TSepiNilValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next (GetValueType)


Sepi

Sepi
Previous (GetIsConstant)
Next (MakeValue)

Name
GetValueType

Parent
TSepiNilValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (MakeValue)


Sepi

Sepi
Previous (GetValueType)
Next

Name
MakeValue

Parent
TSepiNilValue

Visibility
PUBLIC

Description
Construit une valeur nil

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ) : ISepiReadableValue

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur

Return
Types | Description
ISepiReadableValue | Valeur nil créée

Sepi
Class Tree
Index
Previous (GetValueType)
Next


Sepi

Sepi
Previous (TSepiNilValue)
Next (TSepiOpenArrayBuilder)

Name
TSepiObjectFieldValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Valeur champ d'un objet

Members
Fields
Field | Description
FField (-) | Champ
FObjectValue (-) | Valeur objet

Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Create (+) | Crée une valeur champ d'objet

Properties
Property | Description
Field (+) | Champ
ObjectValue (+) | Valeur objet

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiNilValue)
Next (TSepiOpenArrayBuilder)


Sepi

Sepi
Previous
Next (FObjectValue)

Name
FField

Parent
TSepiObjectFieldValue

Visibility
PRIVATE

Description
Champ

Source code
FField : TSepiField

Sepi
Class Tree
Index
Previous
Next (FObjectValue)


Sepi

Sepi
Previous (FField)
Next

Name
FObjectValue

Parent
TSepiObjectFieldValue

Visibility
PRIVATE

Description
Valeur objet

Source code
FObjectValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FField)
Next


Sepi

Sepi
Previous
Next (ObjectValue)

Name
Field

Parent
TSepiObjectFieldValue

Visibility
PUBLIC

Description
Champ

Source code
property Field : TSepiField read FField

Read Access
FField

Sepi
Class Tree
Index
Previous
Next (ObjectValue)


Sepi

Sepi
Previous (Field)
Next

Name
ObjectValue

Parent
TSepiObjectFieldValue

Visibility
PUBLIC

Description
Valeur objet

Source code
property ObjectValue : ISepiReadableValue read FObjectValue

Read Access
FObjectValue

Sepi
Class Tree
Index
Previous (Field)
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompileAsMemoryRef

Parent
TSepiObjectFieldValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next

Name
Create

Parent
TSepiObjectFieldValue

Visibility
PUBLIC

Description
Crée une valeur champ d'objet

Source code
constructor Create ( const AObjectValue : ISepiReadableValue ; AField : TSepiField )

Parameters
Parameter | Description
AObjectValue : ISepiReadableValue | Valeur objet
AField : TSepiField | Champ

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next


Sepi

Sepi
Previous (TSepiObjectFieldValue)
Next (TSepiOpenArrayFromArrayValue)

Name
TSepiOpenArrayBuilder

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiOpenArrayBuilder,ISepiOpenArrayValue

Visibility
PUBLIC

Description
Valeur tableau ouvert construit sur place

Members
Fields
Field | Description
FCompleted (-) | Indique si le constructeur est complété
FElementType (-) | Type des éléments
FItems (-) | Éléments du tableau ouvert
FVarRecType (-) | Type TVarRec

Methods
Method | Description
AddItem (#) | [@inheritDoc]
AttachToExpression (#) | [@inheritDoc]
CanForceElementType (#) | [@inheritDoc]
CompileReadOpenArray (#) | [@inheritDoc]
CompileReadVarRecItem (-) | Compile la lecture d'un élément de tableau ouvert de const (donc TVarRec)
Complete (#) | [@inheritDoc]
Create (+) | Crée une instance de TSepiOpenArrayBuilder
ForceElementType (#) | [@inheritDoc]
GetElementType (#) | [@inheritDoc]
GetItemCount (-) | Nombre d'éléments
GetItems (-) | Tableau zero-based des éléments
GetVType (-) | Détermine le VType correspondant à un type Sepi
QueryInterface (#) | [@inheritDoc]

Properties
Property | Description
Completed (+) | Indique si le constructeur est complété
ElementType (#) | Type des éléments
ItemCount (#) | Nombre d'éléments
Items (#) | Tableau zero-based des éléments

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiObjectFieldValue)
Next (TSepiOpenArrayFromArrayValue)


Sepi

Sepi
Previous
Next (FElementType)

Name
FCompleted

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Indique si le constructeur est complété

Source code
FCompleted : Boolean

Sepi
Class Tree
Index
Previous
Next (FElementType)


Sepi

Sepi
Previous (FCompleted)
Next (FItems)

Name
FElementType

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Type des éléments

Source code
FElementType : TSepiType

Sepi
Class Tree
Index
Previous (FCompleted)
Next (FItems)


Sepi

Sepi
Previous (FElementType)
Next (FVarRecType)

Name
FItems

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Éléments du tableau ouvert

Source code
FItems : IInterfaceList

Sepi
Class Tree
Index
Previous (FElementType)
Next (FVarRecType)


Sepi

Sepi
Previous (FItems)
Next

Name
FVarRecType

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Type TVarRec

Source code
FVarRecType : TSepiType

Sepi
Class Tree
Index
Previous (FItems)
Next


Sepi

Sepi
Previous
Next (ElementType)

Name
Completed

Parent
TSepiOpenArrayBuilder

Visibility
PUBLIC

Description
Indique si le constructeur est complété

Source code
property Completed : Boolean read FCompleted

Read Access
FCompleted

Sepi
Class Tree
Index
Previous
Next (ElementType)


Sepi

Sepi
Previous (Completed)
Next (ItemCount)

Name
ElementType

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
Type des éléments

Source code
property ElementType : TSepiType read FElementType

Read Access
FElementType

Sepi
Class Tree
Index
Previous (Completed)
Next (ItemCount)


Sepi

Sepi
Previous (ElementType)
Next (Items)

Name
ItemCount

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
Nombre d'éléments

Source code
property ItemCount : Integer read GetItemCount

Read Access
GetItemCount

Sepi
Class Tree
Index
Previous (ElementType)
Next (Items)


Sepi

Sepi
Previous (ItemCount)
Next

Name
Items

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
Tableau zero-based des éléments

Source code
property Items [ Index : Integer ] : ISepiReadableValue read GetItems

Read Access
GetItems

Sepi
Class Tree
Index
Previous (ItemCount)
Next


Sepi

Sepi
Previous
Next (AttachToExpression)

Name
AddItem

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AddItem ( const AItem : ISepiReadableValue )

Parameters
Parameter | Description
AItem : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AttachToExpression)


Sepi

Sepi
Previous (AddItem)
Next (CanForceElementType)

Name
AttachToExpression

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddItem)
Next (CanForceElementType)


Sepi

Sepi
Previous (AttachToExpression)
Next (CompileReadOpenArray)

Name
CanForceElementType

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceElementType ( AElementType : TSepiType ) : Boolean

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CompileReadOpenArray)


Sepi

Sepi
Previous (CanForceElementType)
Next (CompileReadVarRecItem)

Name
CompileReadOpenArray

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileReadOpenArray ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var OpenArrayDest , HighValueDest : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
OpenArrayDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
HighValueDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceElementType)
Next (CompileReadVarRecItem)


Sepi

Sepi
Previous (CompileReadOpenArray)
Next (Complete)

Name
CompileReadVarRecItem

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Compile la lecture d'un élément de tableau ouvert de const (donc TVarRec)

Source code
procedure CompileReadVarRecItem ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; const VarRecValue : ISepiWritableValue ; const AItemValue : ISepiReadableValue ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | Compilateur
Instructions : TSepiInstructionList | Liste d'instructions
VarRecValue : ISepiWritableValue | Valeur de type TVarRec destination
AItemValue : ISepiReadableValue | Valeur de l'élément à enregistrer dans VarRecValue
TempVars : TSepiTempVarsLifeManager | Gestionnaire de variables temporaires

Sepi
Class Tree
Index
Previous (CompileReadOpenArray)
Next (Complete)


Sepi

Sepi
Previous (CompileReadVarRecItem)
Next (Create)

Name
Complete

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileReadVarRecItem)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (ForceElementType)

Name
Create

Parent
TSepiOpenArrayBuilder

Visibility
PUBLIC

Description
Crée une instance de TSepiOpenArrayBuilder

Source code
constructor Create ( ASepiRoot : TSepiRoot )

Parameters
Parameter | Description
ASepiRoot : TSepiRoot | Racine Sepi

Sepi
Class Tree
Index
Previous (Complete)
Next (ForceElementType)


Sepi

Sepi
Previous (Create)
Next (GetElementType)

Name
ForceElementType

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceElementType ( AElementType : TSepiType )

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetElementType)


Sepi

Sepi
Previous (ForceElementType)
Next (GetItemCount)

Name
GetElementType

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetElementType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceElementType)
Next (GetItemCount)


Sepi

Sepi
Previous (GetElementType)
Next (GetItems)

Name
GetItemCount

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Nombre d'éléments

Source code
function GetItemCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'éléments

Sepi
Class Tree
Index
Previous (GetElementType)
Next (GetItems)


Sepi

Sepi
Previous (GetItemCount)
Next (GetVType)

Name
GetItems

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Tableau zero-based des éléments

Source code
function GetItems ( Index : Integer ) : ISepiReadableValue

Parameters
Parameter | Description
INDEX : INTEGER | Index compris entre 0 inclus et ItemCount exlu

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetItemCount)
Next (GetVType)


Sepi

Sepi
Previous (GetItems)
Next (QueryInterface)

Name
GetVType

Parent
TSepiOpenArrayBuilder

Visibility
PRIVATE

Description
Détermine le VType correspondant à un type Sepi
GetVType ajuste également le paramètre ValueType pour qu'il corresponde
exactement au type de valeur attendu, si nécessaire.

Source code
function GetVType ( var ValueType : TSepiType ) : Byte

Parameters
Parameter | Description
ValueType : TSepiType | Type de valeur

Return
Types | Description
BYTE | VType correspondant

Sepi
Class Tree
Index
Previous (GetItems)
Next (QueryInterface)


Sepi

Sepi
Previous (GetVType)
Next

Name
QueryInterface

Parent
TSepiOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetVType)
Next


Sepi

Sepi
Previous (TSepiOpenArrayBuilder)
Next (TSepiOperator)

Name
TSepiOpenArrayFromArrayValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiOpenArrayValue

Visibility
PUBLIC

Description
Valeur tableau ouvert construit à partir d'une valeur tableau

Members
Fields
Field | Description
FArrayValue (-) | Valeur tableau à avoir

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CanForceElementType (#) | [@inheritDoc]
CheckTypes (-) | Vérifie les types
CompileReadOpenArray (#) | [@inheritDoc]
Complete (+) | Complète la valeur
ForceElementType (#) | [@inheritDoc]
GetElementType (#) | [@inheritDoc]
MakeOpenArrayValue (+) | Construit une valeur tableau ouvert sur base d'une valeur tableau

Properties
Property | Description
ArrayValue (+) | Valeur tableau à avoir
ElementType (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOpenArrayBuilder)
Next (TSepiOperator)


Sepi

Sepi
Previous
Next

Name
FArrayValue

Parent
TSepiOpenArrayFromArrayValue

Visibility
PRIVATE

Description
Valeur tableau à avoir

Source code
FArrayValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ElementType)

Name
ArrayValue

Parent
TSepiOpenArrayFromArrayValue

Visibility
PUBLIC

Description
Valeur tableau à avoir

Source code
property ArrayValue : ISepiReadableValue read FArrayValue write FArrayValue

Read Access
FArrayValue

Write Access
FArrayValue

Sepi
Class Tree
Index
Previous
Next (ElementType)


Sepi

Sepi
Previous (ArrayValue)
Next

Name
ElementType

Parent
TSepiOpenArrayFromArrayValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property ElementType : TSepiType read GetElementType

Read Access
GetElementType

Sepi
Class Tree
Index
Previous (ArrayValue)
Next


Sepi

Sepi
Previous
Next (CanForceElementType)

Name
AttachToExpression

Parent
TSepiOpenArrayFromArrayValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CanForceElementType)


Sepi

Sepi
Previous (AttachToExpression)
Next (CheckTypes)

Name
CanForceElementType

Parent
TSepiOpenArrayFromArrayValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceElementType ( AElementType : TSepiType ) : Boolean

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CheckTypes)


Sepi

Sepi
Previous (CanForceElementType)
Next (CompileReadOpenArray)

Name
CheckTypes

Parent
TSepiOpenArrayFromArrayValue

Visibility
PRIVATE

Description
Vérifie les types

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CanForceElementType)
Next (CompileReadOpenArray)


Sepi

Sepi
Previous (CheckTypes)
Next (Complete)

Name
CompileReadOpenArray

Parent
TSepiOpenArrayFromArrayValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileReadOpenArray ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var OpenArrayDest , HighValueDest : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
OpenArrayDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
HighValueDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (Complete)


Sepi

Sepi
Previous (CompileReadOpenArray)
Next (ForceElementType)

Name
Complete

Parent
TSepiOpenArrayFromArrayValue

Visibility
PUBLIC

Description
Complète la valeur

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileReadOpenArray)
Next (ForceElementType)


Sepi

Sepi
Previous (Complete)
Next (GetElementType)

Name
ForceElementType

Parent
TSepiOpenArrayFromArrayValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceElementType ( AElementType : TSepiType )

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (GetElementType)


Sepi

Sepi
Previous (ForceElementType)
Next (MakeOpenArrayValue)

Name
GetElementType

Parent
TSepiOpenArrayFromArrayValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetElementType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceElementType)
Next (MakeOpenArrayValue)


Sepi

Sepi
Previous (GetElementType)
Next

Name
MakeOpenArrayValue

Parent
TSepiOpenArrayFromArrayValue

Visibility
PUBLIC

Description
Construit une valeur tableau ouvert sur base d'une valeur tableau

Source code
class function MakeOpenArrayValue ( const ArrayValue : ISepiReadableValue ) : ISepiOpenArrayValue

Parameters
Parameter | Description
ArrayValue : ISepiReadableValue | Valeur tableau

Return
Types | Description
ISepiOpenArrayValue | Valeur tableau ouvert

Sepi
Class Tree
Index
Previous (GetElementType)
Next


Sepi

Sepi
Previous (TSepiOpenArrayFromArrayValue)
Next (TSepiPropertyValue)

Name
TSepiOperator

Parent
SepiExpressions

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Opérateur Sepi

Members
Methods
Method | Description
ForceOneToAnother (+) | Force (implicitement) un des opérandes à avoir le type de l'autre
ForceOneToAnother (+) | Force (implicitement) un opérande à avoir le type du second
MakeBinaryOperation (+) | Construit une opération binaire
MakeUnaryOperation (+) | Construit une opération unaire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOpenArrayFromArrayValue)
Next (TSepiPropertyValue)


Sepi

Sepi
Previous
Next (ForceOneToAnother)

Name
ForceOneToAnother

Parent
TSepiOperator

Visibility
PUBLIC

Description
Force (implicitement) un des opérandes à avoir le type de l'autre
Si les deux opérandes peuvent être forcés l'un à l'autre mutuellement, cette
méthode choisit de forcer le type l'opérande droit à celui de l'opérande
gauche.

Source code
class function ForceOneToAnother ( const Left , Right : ISepiReadableValue ) : Boolean ; overload

Parameters
Parameter | Description
Left : ISepiReadableValue | Opérande gauche
Right : ISepiReadableValue | Opérande droit

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ForceOneToAnother)


Sepi

Sepi
Previous (ForceOneToAnother)
Next (MakeBinaryOperation)

Name
ForceOneToAnother

Parent
TSepiOperator

Visibility
PUBLIC

Description
Force (implicitement) un opérande à avoir le type du second

Source code
class function ForceOneToAnother ( const Left : ISepiTypeForceableValue ; const Right : ISepiReadableValue ) : Boolean ; overload

Parameters
Parameter | Description
Left : ISepiTypeForceableValue | Opérande dont forcer le type
Right : ISepiReadableValue | Opérande à imiter

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceOneToAnother)
Next (MakeBinaryOperation)


Sepi

Sepi
Previous (ForceOneToAnother)
Next (MakeUnaryOperation)

Name
MakeBinaryOperation

Parent
TSepiOperator

Visibility
PUBLIC

Description
Construit une opération binaire

Source code
class function MakeBinaryOperation ( Operation : TSepiOperation ; const LeftOperand , RightOperand : ISepiReadableValue ; AutoConvert : Boolean = True ) : ISepiReadableValue

Parameters
Parameter | Description
Operation : TSepiOperation | Opération
LeftOperand : ISepiReadableValue | Opérande de gauche
RightOperand : ISepiReadableValue | Opérande de droite
AutoConvert : BOOLEAN | True permet d'effectuer des conversions automatiques

Return
Types | Description
ISepiReadableValue | Valeur représentant l'opération

Sepi
Class Tree
Index
Previous (ForceOneToAnother)
Next (MakeUnaryOperation)


Sepi

Sepi
Previous (MakeBinaryOperation)
Next

Name
MakeUnaryOperation

Parent
TSepiOperator

Visibility
PUBLIC

Description
Construit une opération unaire

Source code
class function MakeUnaryOperation ( Operation : TSepiOperation ; const Operand : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter | Description
Operation : TSepiOperation | Opération
Operand : ISepiReadableValue | Opérande

Return
Types | Description
ISepiReadableValue | Valeur représentant l'opération

Sepi
Class Tree
Index
Previous (MakeBinaryOperation)
Next


Sepi

Sepi
Previous (TSepiOperator)
Next (TSepiPureInheritedCall)

Name
TSepiPropertyValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomWithParams,ISepiProperty,ISepiValue,ISepiReadableValue,ISepiWritableValue

Visibility
PUBLIC

Description
Valeur propriété
Bien que, syntaxiquement, cette classe implémente les deux interfaces
ISepiReadableValue et ISepiWritableValue, ces implémentations ne sont
effectives que si la propriété sous-jacente peut être lue et écrite
respectivement.

Members
Fields
Field | Description
FObjectValue (-) | Valeur objet
FProperty (-) | Propriété

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileRead (#) | [@inheritDoc]
CompileWrite (#) | [@inheritDoc]
CompleteParams (#) | [@inheritDoc]
Create (+) | Crée une valeur propriété
GetConstValuePtr (#) | [@inheritDoc]
GetIsConstant (#) | [@inheritDoc]
GetValueType (#) | [@inheritDoc]
MakeIndexValue (-) | Construit une valeur représentant l'index de la propriété
QueryInterface (#) | [@inheritDoc]

Properties
Property | Description
ObjectProperty (+) | Propriété
ObjectValue (+) | Valeur objet
ValueType (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOperator)
Next (TSepiPureInheritedCall)


Sepi

Sepi
Previous
Next (FProperty)

Name
FObjectValue

Parent
TSepiPropertyValue

Visibility
PRIVATE

Description
Valeur objet

Source code
FObjectValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (FProperty)


Sepi

Sepi
Previous (FObjectValue)
Next

Name
FProperty

Parent
TSepiPropertyValue

Visibility
PRIVATE

Description
Propriété

Source code
FProperty : TSepiProperty

Sepi
Class Tree
Index
Previous (FObjectValue)
Next


Sepi

Sepi
Previous
Next (ObjectValue)

Name
ObjectProperty

Parent
TSepiPropertyValue

Visibility
PUBLIC

Description
Propriété

Source code
property ObjectProperty : TSepiProperty read FProperty

Read Access
FProperty

Sepi
Class Tree
Index
Previous
Next (ObjectValue)


Sepi

Sepi
Previous (ObjectProperty)
Next (ValueType)

Name
ObjectValue

Parent
TSepiPropertyValue

Visibility
PUBLIC

Description
Valeur objet

Source code
property ObjectValue : ISepiReadableValue read FObjectValue

Read Access
FObjectValue

Sepi
Class Tree
Index
Previous (ObjectProperty)
Next (ValueType)


Sepi

Sepi
Previous (ObjectValue)
Next

Name
ValueType

Parent
TSepiPropertyValue

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
property ValueType : TSepiType read GetValueType

Read Access
GetValueType

Sepi
Class Tree
Index
Previous (ObjectValue)
Next


Sepi

Sepi
Previous
Next (CompileRead)

Name
AttachToExpression

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileRead)


Sepi

Sepi
Previous (AttachToExpression)
Next (CompileWrite)

Name
CompileRead

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CompileWrite)


Sepi

Sepi
Previous (CompileRead)
Next (CompleteParams)

Name
CompileWrite

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileWrite ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; Source : ISepiReadableValue ) ; virtual

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Source : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileRead)
Next (CompleteParams)


Sepi

Sepi
Previous (CompileWrite)
Next (Create)

Name
CompleteParams

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompleteParams ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileWrite)
Next (Create)


Sepi

Sepi
Previous (CompleteParams)
Next (GetConstValuePtr)

Name
Create

Parent
TSepiPropertyValue

Visibility
PUBLIC

Description
Crée une valeur propriété

Source code
constructor Create ( const AObjectValue : ISepiReadableValue ; AProperty : TSepiProperty )

Parameters
Parameter | Description
AObjectValue : ISepiReadableValue | Valeur objet
AProperty : TSepiProperty | Propriété

Sepi
Class Tree
Index
Previous (CompleteParams)
Next (GetConstValuePtr)


Sepi

Sepi
Previous (Create)
Next (GetIsConstant)

Name
GetConstValuePtr

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetConstValuePtr)
Next (GetValueType)

Name
GetIsConstant

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next (GetValueType)


Sepi

Sepi
Previous (GetIsConstant)
Next (MakeIndexValue)

Name
GetValueType

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (MakeIndexValue)


Sepi

Sepi
Previous (GetValueType)
Next (QueryInterface)

Name
MakeIndexValue

Parent
TSepiPropertyValue

Visibility
PRIVATE

Description
Construit une valeur représentant l'index de la propriété

Source code
function MakeIndexValue ( Compiler : TSepiMethodCompiler ; Method : TSepiMethod ) : ISepiReadableValue

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Method : TSepiMethod | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetValueType)
Next (QueryInterface)


Sepi

Sepi
Previous (MakeIndexValue)
Next

Name
QueryInterface

Parent
TSepiPropertyValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeIndexValue)
Next


Sepi

Sepi
Previous (TSepiPropertyValue)
Next (TSepiRecordFieldValue)

Name
TSepiPureInheritedCall

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiExecutable

Visibility
PUBLIC

Description
Appel inherited pur (même nom de méthode et mêmes paramètres)

Members
Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
CompileExecute (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropertyValue)
Next (TSepiRecordFieldValue)


Sepi

Sepi
Previous
Next (CompileExecute)

Name
AttachToExpression

Parent
TSepiPureInheritedCall

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (AttachToExpression)
Next

Name
CompileExecute

Parent
TSepiPureInheritedCall

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next


Sepi

Sepi
Previous (TSepiPureInheritedCall)
Next (TSepiSetBuilder)

Name
TSepiRecordFieldValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Valeur champ de record

Members
Fields
Field | Description
FField (-) | Champ
FRecordValue (-) | Valeur record

Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Create (+) | Crée une valeur champ

Properties
Property | Description
Field (+) | Champ
RecordValue (+) | Valeur record

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPureInheritedCall)
Next (TSepiSetBuilder)


Sepi

Sepi
Previous
Next (FRecordValue)

Name
FField

Parent
TSepiRecordFieldValue

Visibility
PRIVATE

Description
Champ

Source code
FField : TSepiField

Sepi
Class Tree
Index
Previous
Next (FRecordValue)


Sepi

Sepi
Previous (FField)
Next

Name
FRecordValue

Parent
TSepiRecordFieldValue

Visibility
PRIVATE

Description
Valeur record

Source code
FRecordValue : ISepiValue

Sepi
Class Tree
Index
Previous (FField)
Next


Sepi

Sepi
Previous
Next (RecordValue)

Name
Field

Parent
TSepiRecordFieldValue

Visibility
PUBLIC

Description
Champ

Source code
property Field : TSepiField read FField

Read Access
FField

Sepi
Class Tree
Index
Previous
Next (RecordValue)


Sepi

Sepi
Previous (Field)
Next

Name
RecordValue

Parent
TSepiRecordFieldValue

Visibility
PUBLIC

Description
Valeur record

Source code
property RecordValue : ISepiValue read FRecordValue

Read Access
FRecordValue

Sepi
Class Tree
Index
Previous (Field)
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompileAsMemoryRef

Parent
TSepiRecordFieldValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next

Name
Create

Parent
TSepiRecordFieldValue

Visibility
PUBLIC

Description
Crée une valeur champ

Source code
constructor Create ( const ARecordValue : ISepiValue ; AField : TSepiField )

Parameters
Parameter | Description
ARecordValue : ISepiValue | Conteneur du champ
AField : TSepiField | Champ

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next


Sepi

Sepi
Previous (TSepiRecordFieldValue)
Next (TSepiSetBuilderRange)

Name
TSepiSetBuilder

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue,ISepiSetBuilder,ISepiTypeForceableValue,ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
Constructeur d'ensemble

Members
Fields
Field | Description
FCompKind (-) | Sorte de type des éléments
FCompType (-) | Type d'élément
FConstantValues (-) | Valeurs constantes
FHigherBound (-) | Borne supérieure courante
FLowerBound (-) | Borne inférieure courante
FRanges (-) | Intervalles de valeur
FSetType (-) | Type de l'ensemble
FSingles (-) | Valeurs simples

Methods
Method | Description
AddConstInterval (#) | Ajoute un intervalle constant à l'ensemble en construction
AddRange (#) | Ajoute un intervalle de valeur à l'ensemble en construction
AddSingle (#) | Ajoute un élément dans l'ensemble en construction
AddType (#) | Ajoute un type de composant à l'ensemble en construction
AttachToExpression (#) | [@inheritDoc]
CanForceCompType (#) | Teste si l'ensemble peut être forcé à un type d'élément donné
CanForceType (#) | Teste si l'ensemble peut être forcé à un type donné
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
Complete (#) | Complète l'ensemble en construction
Create (+) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
ExportConstantValues (-) | Exporte les valeurs constantes dans un ensemble
ForceCompType (#) | Force le type d'élément à un type donné
ForceType (#) | Force le type de l'ensemble à un type donné
GetCompKind (-) | Sorte de type des éléments
GetCompType (-) | Type des éléments
GetHigherBound (-) | Borne supérieure courante
GetIsEmpty (-) | Indique si l'ensemble est vide
GetLowerBound (-) | Borne inférieure courante
GetSetType (-) | Type de l'ensemble
SetCompType (#) | Définit le type des éléments
SetCompType (#) | Définit le type des éléments
SetSetType (#) | Définit le type de l'ensemble
SetValueType (#) | [@inheritDoc]

Properties
Property | Description
CompKind (+) | Sorte de type des éléments
CompType (+) | Type d'élément
HigherBound (+) | Borne supérieure courante
IsEmpty (+) | Indique si l'ensemble est vide
LowerBound (+) | Borne inférieure courante
SetType (+) | Type de l'ensemble

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRecordFieldValue)
Next (TSepiSetBuilderRange)


Sepi

Sepi
Previous
Next (FCompType)

Name
FCompKind

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Sorte de type des éléments

Source code
FCompKind : TTypeKind

Sepi
Class Tree
Index
Previous
Next (FCompType)


Sepi

Sepi
Previous (FCompKind)
Next (FConstantValues)

Name
FCompType

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Type d'élément

Source code
FCompType : TSepiOrdType

Sepi
Class Tree
Index
Previous (FCompKind)
Next (FConstantValues)


Sepi

Sepi
Previous (FCompType)
Next (FHigherBound)

Name
FConstantValues

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Valeurs constantes

Source code
FConstantValues : TScIntegerSet

Sepi
Class Tree
Index
Previous (FCompType)
Next (FHigherBound)


Sepi

Sepi
Previous (FConstantValues)
Next (FLowerBound)

Name
FHigherBound

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Borne supérieure courante

Source code
FHigherBound : Integer

Sepi
Class Tree
Index
Previous (FConstantValues)
Next (FLowerBound)


Sepi

Sepi
Previous (FHigherBound)
Next (FRanges)

Name
FLowerBound

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Borne inférieure courante

Source code
FLowerBound : Integer

Sepi
Class Tree
Index
Previous (FHigherBound)
Next (FRanges)


Sepi

Sepi
Previous (FLowerBound)
Next (FSetType)

Name
FRanges

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Intervalles de valeur

Source code
FRanges : array of TSepiSetBuilderRange

Sepi
Class Tree
Index
Previous (FLowerBound)
Next (FSetType)


Sepi

Sepi
Previous (FRanges)
Next (FSingles)

Name
FSetType

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Type de l'ensemble

Source code
FSetType : TSepiSetType

Sepi
Class Tree
Index
Previous (FRanges)
Next (FSingles)


Sepi

Sepi
Previous (FSetType)
Next

Name
FSingles

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Valeurs simples

Source code
FSingles : array of ISepiReadableValue

Sepi
Class Tree
Index
Previous (FSetType)
Next


Sepi

Sepi
Previous
Next (CompType)

Name
CompKind

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
Sorte de type des éléments

Source code
property CompKind : TTypeKind read FCompKind

Read Access
FCompKind

Sepi
Class Tree
Index
Previous
Next (CompType)


Sepi

Sepi
Previous (CompKind)
Next (HigherBound)

Name
CompType

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
Type d'élément

Source code
property CompType : TSepiOrdType read FCompType

Read Access
FCompType

Sepi
Class Tree
Index
Previous (CompKind)
Next (HigherBound)


Sepi

Sepi
Previous (CompType)
Next (IsEmpty)

Name
HigherBound

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
Borne supérieure courante

Source code
property HigherBound : Integer read FHigherBound

Read Access
FHigherBound

Sepi
Class Tree
Index
Previous (CompType)
Next (IsEmpty)


Sepi

Sepi
Previous (HigherBound)
Next (LowerBound)

Name
IsEmpty

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
Indique si l'ensemble est vide

Source code
property IsEmpty : Boolean read GetIsEmpty

Read Access
GetIsEmpty

Sepi
Class Tree
Index
Previous (HigherBound)
Next (LowerBound)


Sepi

Sepi
Previous (IsEmpty)
Next (SetType)

Name
LowerBound

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
Borne inférieure courante

Source code
property LowerBound : Integer read FLowerBound

Read Access
FLowerBound

Sepi
Class Tree
Index
Previous (IsEmpty)
Next (SetType)


Sepi

Sepi
Previous (LowerBound)
Next

Name
SetType

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
Type de l'ensemble

Source code
property SetType : TSepiSetType read FSetType

Read Access
FSetType

Sepi
Class Tree
Index
Previous (LowerBound)
Next


Sepi

Sepi
Previous
Next (AddRange)

Name
AddConstInterval

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Ajoute un intervalle constant à l'ensemble en construction

Source code
procedure AddConstInterval ( const Lower , Higher : ISepiReadableValue )

Parameters
Parameter | Description
Lower : ISepiReadableValue | Borne inférieure de l'intervalle
Higher : ISepiReadableValue | Borne supérieure de l'intervalle

Sepi
Class Tree
Index
Previous
Next (AddRange)


Sepi

Sepi
Previous (AddConstInterval)
Next (AddSingle)

Name
AddRange

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Ajoute un intervalle de valeur à l'ensemble en construction

Source code
procedure AddRange ( const Lower , Higher : ISepiReadableValue )

Parameters
Parameter | Description
Lower : ISepiReadableValue | Borne inférieure de l'intervalle
Higher : ISepiReadableValue | Borne supérieure de l'intervalle

Sepi
Class Tree
Index
Previous (AddConstInterval)
Next (AddSingle)


Sepi

Sepi
Previous (AddRange)
Next (AddType)

Name
AddSingle

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Ajoute un élément dans l'ensemble en construction

Source code
procedure AddSingle ( const Value : ISepiReadableValue )

Parameters
Parameter | Description
Value : ISepiReadableValue | Valeur à ajouter

Sepi
Class Tree
Index
Previous (AddRange)
Next (AddType)


Sepi

Sepi
Previous (AddSingle)
Next (AttachToExpression)

Name
AddType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Ajoute un type de composant à l'ensemble en construction

Source code
function AddType ( ACompType : TSepiOrdType ) : Boolean

Parameters
Parameter | Description
ACompType : TSepiOrdType | Type de composant à ajouter

Return
Types | Description
BOOLEAN | True en cas de succès, False si ACompType est incompatible

Sepi
Class Tree
Index
Previous (AddSingle)
Next (AttachToExpression)


Sepi

Sepi
Previous (AddType)
Next (CanForceCompType)

Name
AttachToExpression

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddType)
Next (CanForceCompType)


Sepi

Sepi
Previous (AttachToExpression)
Next (CanForceType)

Name
CanForceCompType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Teste si l'ensemble peut être forcé à un type d'élément donné

Source code
function CanForceCompType ( ACompType : TSepiOrdType ) : Boolean

Parameters
Parameter | Description
ACompType : TSepiOrdType | Type d'élément à tester

Return
Types | Description
BOOLEAN | True si le type est valide, False sinon

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CanForceType)


Sepi

Sepi
Previous (CanForceCompType)
Next (CollapseConsts)

Name
CanForceType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Teste si l'ensemble peut être forcé à un type donné

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | Type à tester
Explicit : BOOLEAN

Return
Types | Description
BOOLEAN | True si le type est valide, False sinon

Sepi
Class Tree
Index
Previous (CanForceCompType)
Next (CollapseConsts)


Sepi

Sepi
Previous (CanForceType)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CanForceType)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (Complete)

Name
CompileCompute

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (Create)

Name
Complete

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Complète l'ensemble en construction

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Destroy)

Name
Create

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( UnitCompiler : TSepiUnitCompiler )

Parameters
Parameter | Description
UnitCompiler : TSepiUnitCompiler | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (ExportConstantValues)

Name
Destroy

Parent
TSepiSetBuilder

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (ExportConstantValues)


Sepi

Sepi
Previous (Destroy)
Next (ForceCompType)

Name
ExportConstantValues

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Exporte les valeurs constantes dans un ensemble

Source code
procedure ExportConstantValues ( var ConstSet )

Parameters
Parameter | Description
ConstSet : Untyped | Ensemble destination (de type SetType)

Sepi
Class Tree
Index
Previous (Destroy)
Next (ForceCompType)


Sepi

Sepi
Previous (ExportConstantValues)
Next (ForceType)

Name
ForceCompType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Force le type d'élément à un type donné
Cette méthode ne peut être appelée que si CanForceCompType renvoie True pour
le type ACompType.

Source code
procedure ForceCompType ( ACompType : TSepiOrdType )

Parameters
Parameter | Description
ACompType : TSepiOrdType | Type auquel forcer les éléments

Sepi
Class Tree
Index
Previous (ExportConstantValues)
Next (ForceType)


Sepi

Sepi
Previous (ForceCompType)
Next (GetCompKind)

Name
ForceType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Force le type de l'ensemble à un type donné
Cette méthode ne peut être appelée que si CanForceType renvoie True pour le
type AValueType.

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | Type auquel forcer l'ensemble

Sepi
Class Tree
Index
Previous (ForceCompType)
Next (GetCompKind)


Sepi

Sepi
Previous (ForceType)
Next (GetCompType)

Name
GetCompKind

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Sorte de type des éléments

Source code
function GetCompKind : TTypeKind

Parameters
Parameter Description

Return
Types | Description
TTypeKind | Sorte de type des éléments

Sepi
Class Tree
Index
Previous (ForceType)
Next (GetCompType)


Sepi

Sepi
Previous (GetCompKind)
Next (GetHigherBound)

Name
GetCompType

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Type des éléments

Source code
function GetCompType : TSepiOrdType

Parameters
Parameter Description

Return
Types | Description
TSepiOrdType | Type des éléments

Sepi
Class Tree
Index
Previous (GetCompKind)
Next (GetHigherBound)


Sepi

Sepi
Previous (GetCompType)
Next (GetIsEmpty)

Name
GetHigherBound

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Borne supérieure courante

Source code
function GetHigherBound : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Borne supérieure courante

Sepi
Class Tree
Index
Previous (GetCompType)
Next (GetIsEmpty)


Sepi

Sepi
Previous (GetHigherBound)
Next (GetLowerBound)

Name
GetIsEmpty

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Indique si l'ensemble est vide

Source code
function GetIsEmpty : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si l'ensemble est vide, False sinon

Sepi
Class Tree
Index
Previous (GetHigherBound)
Next (GetLowerBound)


Sepi

Sepi
Previous (GetIsEmpty)
Next (GetSetType)

Name
GetLowerBound

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Borne inférieure courante

Source code
function GetLowerBound : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Borne inférieure courante

Sepi
Class Tree
Index
Previous (GetIsEmpty)
Next (GetSetType)


Sepi

Sepi
Previous (GetLowerBound)
Next (SetCompType)

Name
GetSetType

Parent
TSepiSetBuilder

Visibility
PRIVATE

Description
Type de l'ensemble

Source code
function GetSetType : TSepiSetType

Parameters
Parameter Description

Return
Types | Description
TSepiSetType | Type de l'ensemble

Sepi
Class Tree
Index
Previous (GetLowerBound)
Next (SetCompType)


Sepi

Sepi
Previous (GetSetType)
Next (SetCompType)

Name
SetCompType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Définit le type des éléments
Cette méthode ne peut être appelée qu'une fois, avec un type d'éléments
compatible avec d'éventuelles valeurs déjà insérées.

Source code
procedure SetCompType ( ACompType : TSepiOrdType ) ; overload

Parameters
Parameter | Description
ACompType : TSepiOrdType | Type des éléments

Sepi
Class Tree
Index
Previous (GetSetType)
Next (SetCompType)


Sepi

Sepi
Previous (SetCompType)
Next (SetSetType)

Name
SetCompType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Définit le type des éléments
Cette méthode ne peut être appelée qu'une fois, avec un type d'éléments
compatible avec d'éventuelles valeurs déjà insérées.

Source code
procedure SetCompType ( ACompTypeInfo : PTypeInfo ) ; overload

Parameters
Parameter | Description
ACompTypeInfo : PTypeInfo | RTTI du type des éléments

Sepi
Class Tree
Index
Previous (SetCompType)
Next (SetSetType)


Sepi

Sepi
Previous (SetCompType)
Next (SetValueType)

Name
SetSetType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
Définit le type de l'ensemble
Cette méthode ne peut être appelée qu'une fois, avec un type ensemble
compatible avec d'éventuelles valeurs déjà insérées.

Source code
procedure SetSetType ( ASetType : TSepiSetType )

Parameters
Parameter | Description
ASetType : TSepiSetType | Type ensemble

Sepi
Class Tree
Index
Previous (SetCompType)
Next (SetValueType)


Sepi

Sepi
Previous (SetSetType)
Next

Name
SetValueType

Parent
TSepiSetBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetValueType ( AType : TSepiType ) ; reintroduce

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetSetType)
Next


Sepi

Sepi
Previous (TSepiSetBuilder)
Next (TSepiSetOperation)

Name
TSepiSetBuilderRange

Parent
SepiExpressions

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Intervalle de valeurs dans un constructeur d'ensemble

Members
Fields
Field | Description
HigherValue (*) | Valeur haute
LowerValue (*) | Valeur basse

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSetBuilder)
Next (TSepiSetOperation)


Sepi

Sepi
Previous
Next (LowerValue)

Name
HigherValue

Parent
TSepiSetBuilderRange

Visibility
PUBLISHED

Description
Valeur haute

Source code
HigherValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (LowerValue)


Sepi

Sepi
Previous (HigherValue)
Next

Name
LowerValue

Parent
TSepiSetBuilderRange

Visibility
PUBLISHED

Description
Valeur basse

Source code
LowerValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (HigherValue)
Next


Sepi

Sepi
Previous (TSepiSetBuilderRange)
Next (TSepiSetOrOpenArrayBuilder)

Name
TSepiSetOperation

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue,ISepiTypeForceableValue,ISepiTypeForceableSetValue

Visibility
PUBLIC

Description
Opération sur des ensembles
Bien que syntaxiquement, cette classe implémente les interfaces
ISepiTypeForceableValue et ISepiTypeForceableSetValue, ces deux interfaces
ne sont effectivement supportées à l'exécution que si les deux opérandes
implémentent l'interface ISepiTypeForceableSetValue.

Members
Fields
Field | Description
FLeftForceable (-) | Opérande gauche forçable
FLeftOperand (-) | Opérande de gauche
FOperation (-) | Opération
FRightForceable (-) | Opérande droite forçable
FRightOperand (-) | Opérande de droite

Methods
Method | Description
CanForceCompType (#) | [@inheritDoc]
CanForceType (#) | [@inheritDoc]
CheckTypes (-) | [@inheritDoc]
CollapseConsts (-) | [@inheritDoc]
CompileCompute (#) | [@inheritDoc]
Complete (+) | [@inheritDoc]
Create (+) | [@inheritDoc]
ErrorTypeMismatch (#) | [@inheritDoc]
ForceCompType (#) | [@inheritDoc]
ForceType (#) | [@inheritDoc]
ForceTypesTogether (-) | Force les types des deux opérandes pour les mettre d'accord
GetCompKind (-) | [@inheritDoc]
GetCompType (-) | [@inheritDoc]
GetHigherBound (-) | [@inheritDoc]
GetIsEmpty (-) | [@inheritDoc]
GetLowerBound (-) | [@inheritDoc]
GetOpCode (#) | [@inheritDoc]
GetSetType (-) | [@inheritDoc]
IsTypeForceable (-) | Teste si le type de cette opération peut être forcé
MakeOperation (+) | [@inheritDoc]
QueryInterface (#) | [@inheritDoc]
SetLeftOperand (-) | Modifie l'opérande de gauche
SetRightOperand (-) | Modifie l'opérande de droite

Properties
Property | Description
LeftForceable (#) | Opérande gauche forçable
LeftOperand (+) | Opérande de gauche
Operation (+) | Opération
RightForceable (#) | Opérande droite forçable
RightOperand (+) | Opérande de droite

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSetBuilderRange)
Next (TSepiSetOrOpenArrayBuilder)


Sepi

Sepi
Previous
Next (FLeftOperand)

Name
FLeftForceable

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Opérande gauche forçable

Source code
FLeftForceable : ISepiTypeForceableSetValue

Sepi
Class Tree
Index
Previous
Next (FLeftOperand)


Sepi

Sepi
Previous (FLeftForceable)
Next (FOperation)

Name
FLeftOperand

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Opérande de gauche

Source code
FLeftOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FLeftForceable)
Next (FOperation)


Sepi

Sepi
Previous (FLeftOperand)
Next (FRightForceable)

Name
FOperation

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Opération

Source code
FOperation : TSepiOperation

Sepi
Class Tree
Index
Previous (FLeftOperand)
Next (FRightForceable)


Sepi

Sepi
Previous (FOperation)
Next (FRightOperand)

Name
FRightForceable

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Opérande droite forçable

Source code
FRightForceable : ISepiTypeForceableSetValue

Sepi
Class Tree
Index
Previous (FOperation)
Next (FRightOperand)


Sepi

Sepi
Previous (FRightForceable)
Next

Name
FRightOperand

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Opérande de droite

Source code
FRightOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FRightForceable)
Next


Sepi

Sepi
Previous
Next (LeftOperand)

Name
LeftForceable

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
Opérande gauche forçable

Source code
property LeftForceable : ISepiTypeForceableSetValue read FLeftForceable

Read Access
FLeftForceable

Sepi
Class Tree
Index
Previous
Next (LeftOperand)


Sepi

Sepi
Previous (LeftForceable)
Next (Operation)

Name
LeftOperand

Parent
TSepiSetOperation

Visibility
PUBLIC

Description
Opérande de gauche

Source code
property LeftOperand : ISepiReadableValue read FLeftOperand write SetLeftOperand

Read Access
FLeftOperand

Write Access
SetLeftOperand

Sepi
Class Tree
Index
Previous (LeftForceable)
Next (Operation)


Sepi

Sepi
Previous (LeftOperand)
Next (RightForceable)

Name
Operation

Parent
TSepiSetOperation

Visibility
PUBLIC

Description
Opération

Source code
property Operation : TSepiOperation read FOperation

Read Access
FOperation

Sepi
Class Tree
Index
Previous (LeftOperand)
Next (RightForceable)


Sepi

Sepi
Previous (Operation)
Next (RightOperand)

Name
RightForceable

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
Opérande droite forçable

Source code
property RightForceable : ISepiTypeForceableSetValue read FRightForceable

Read Access
FRightForceable

Sepi
Class Tree
Index
Previous (Operation)
Next (RightOperand)


Sepi

Sepi
Previous (RightForceable)
Next

Name
RightOperand

Parent
TSepiSetOperation

Visibility
PUBLIC

Description
Opérande de droite

Source code
property RightOperand : ISepiReadableValue read FRightOperand write SetRightOperand

Read Access
FRightOperand

Write Access
SetRightOperand

Sepi
Class Tree
Index
Previous (RightForceable)
Next


Sepi

Sepi
Previous
Next (CanForceType)

Name
CanForceCompType

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceCompType ( ACompType : TSepiOrdType ) : Boolean

Parameters
Parameter | Description
ACompType : TSepiOrdType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CanForceType)


Sepi

Sepi
Previous (CanForceCompType)
Next (CheckTypes)

Name
CanForceType

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceCompType)
Next (CheckTypes)


Sepi

Sepi
Previous (CanForceType)
Next (CollapseConsts)

Name
CheckTypes

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CanForceType)
Next (CollapseConsts)


Sepi

Sepi
Previous (CheckTypes)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (Complete)

Name
CompileCompute

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (Create)

Name
Complete

Parent
TSepiSetOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (ErrorTypeMismatch)

Name
Create

Parent
TSepiSetOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AOperation : TSepiOperation )

Parameters
Parameter | Description
AOperation : TSepiOperation | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (ErrorTypeMismatch)


Sepi

Sepi
Previous (Create)
Next (ForceCompType)

Name
ErrorTypeMismatch

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ErrorTypeMismatch

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (ForceCompType)


Sepi

Sepi
Previous (ErrorTypeMismatch)
Next (ForceType)

Name
ForceCompType

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceCompType ( ACompType : TSepiOrdType )

Parameters
Parameter | Description
ACompType : TSepiOrdType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ErrorTypeMismatch)
Next (ForceType)


Sepi

Sepi
Previous (ForceCompType)
Next (ForceTypesTogether)

Name
ForceType

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceCompType)
Next (ForceTypesTogether)


Sepi

Sepi
Previous (ForceType)
Next (GetCompKind)

Name
ForceTypesTogether

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Force les types des deux opérandes pour les mettre d'accord

Source code
procedure ForceTypesTogether

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ForceType)
Next (GetCompKind)


Sepi

Sepi
Previous (ForceTypesTogether)
Next (GetCompType)

Name
GetCompKind

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
function GetCompKind : TTypeKind

Parameters
Parameter Description

Return
Types | Description
TTypeKind | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceTypesTogether)
Next (GetCompType)


Sepi

Sepi
Previous (GetCompKind)
Next (GetHigherBound)

Name
GetCompType

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
function GetCompType : TSepiOrdType

Parameters
Parameter Description

Return
Types | Description
TSepiOrdType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCompKind)
Next (GetHigherBound)


Sepi

Sepi
Previous (GetCompType)
Next (GetIsEmpty)

Name
GetHigherBound

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
function GetHigherBound : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCompType)
Next (GetIsEmpty)


Sepi

Sepi
Previous (GetHigherBound)
Next (GetLowerBound)

Name
GetIsEmpty

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
function GetIsEmpty : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetHigherBound)
Next (GetLowerBound)


Sepi

Sepi
Previous (GetIsEmpty)
Next (GetOpCode)

Name
GetLowerBound

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
function GetLowerBound : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsEmpty)
Next (GetOpCode)


Sepi

Sepi
Previous (GetLowerBound)
Next (GetSetType)

Name
GetOpCode

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetOpCode ( SelfOp : Boolean ) : TSepiOpCode

Parameters
Parameter | Description
SelfOp : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiOpCode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetLowerBound)
Next (GetSetType)


Sepi

Sepi
Previous (GetOpCode)
Next (IsTypeForceable)

Name
GetSetType

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
function GetSetType : TSepiSetType

Parameters
Parameter Description

Return
Types | Description
TSepiSetType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetOpCode)
Next (IsTypeForceable)


Sepi

Sepi
Previous (GetSetType)
Next (MakeOperation)

Name
IsTypeForceable

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Teste si le type de cette opération peut être forcé

Source code
function IsTypeForceable : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetSetType)
Next (MakeOperation)


Sepi

Sepi
Previous (IsTypeForceable)
Next (QueryInterface)

Name
MakeOperation

Parent
TSepiSetOperation

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
class function MakeOperation ( Operation : TSepiOperation ; const LeftOperand , RightOperand : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter | Description
Operation : TSepiOperation | #Pas de TAG trouvé dans le code source#
LeftOperand : ISepiReadableValue | #Pas de TAG trouvé dans le code source#
RightOperand : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsTypeForceable)
Next (QueryInterface)


Sepi

Sepi
Previous (MakeOperation)
Next (SetLeftOperand)

Name
QueryInterface

Parent
TSepiSetOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeOperation)
Next (SetLeftOperand)


Sepi

Sepi
Previous (QueryInterface)
Next (SetRightOperand)

Name
SetLeftOperand

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Modifie l'opérande de gauche

Source code
procedure SetLeftOperand ( const Value : ISepiReadableValue )

Parameters
Parameter | Description
Value : ISepiReadableValue | Nouvel opérande de gauche

Sepi
Class Tree
Index
Previous (QueryInterface)
Next (SetRightOperand)


Sepi

Sepi
Previous (SetLeftOperand)
Next

Name
SetRightOperand

Parent
TSepiSetOperation

Visibility
PRIVATE

Description
Modifie l'opérande de droite

Source code
procedure SetRightOperand ( const Value : ISepiReadableValue )

Parameters
Parameter | Description
Value : ISepiReadableValue | Nouvel opérande de droite

Sepi
Class Tree
Index
Previous (SetLeftOperand)
Next


Sepi

Sepi
Previous (TSepiSetOperation)
Next (TSepiStrCopyExpression)

Name
TSepiSetOrOpenArrayBuilder

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiSetOrOpenArrayBuilder,ISepiValue,ISepiReadableValue,ISepiTypeForceableValue,ISepiOpenArrayValue

Visibility
PUBLIC

Description
Constructeur d'ensemble ou de tableau ouvert

Members
Fields
Field | Description
FCompleted (-) | True si complété
FOpenArrayAvailable (-) | Indique si un tableau ouvert est possible
FOpenArrayBuilder (-) | Constructeur de tableau ouvert
FOpenArrayBuilderCompleted (-) | Indique si le tableau est complété
FRanges (-) | Intervalles de valeur
FSetBuilder (-) | Constructeur d'ensemble
FSetBuilderCompleted (-) | Indique si l'ensemble est complété
FSingles (-) | Valeurs simples

Methods
Method | Description
AddRange (#) | [@inheritDoc]
AddSingle (#) | [@inheritDoc]
AttachToExpression (#) | [@inheritDoc]
CanForceElementType (#) | [@inheritDoc]
CanForceType (#) | [@inheritDoc]
CompileRead (#) | [@inheritDoc]
CompileReadOpenArray (#) | [@inheritDoc]
Complete (#) | [@inheritDoc]
Create (+) | Crée une instance de TSepiSetOrOpenArrayBuilder
ForceElementType (#) | [@inheritDoc]
ForceType (#) | [@inheritDoc]
GetConstValuePtr (#) | [@inheritDoc]
GetElementType (#) | [@inheritDoc]
GetIsConstant (#) | [@inheritDoc]
GetValueType (#) | [@inheritDoc]
NeedOpenArrayBuilder (-) | [@inheritDoc]
NeedSetBuilder (-) | [@inheritDoc]
QueryInterface (#) | [@inheritDoc]

Properties
Property | Description
Completed (#) | True si complété
OpenArrayBuilder (#) | Constructeur de tableau ouvert
SetBuilder (#) | Constructeur d'ensemble

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSetOperation)
Next (TSepiStrCopyExpression)


Sepi

Sepi
Previous
Next (FOpenArrayAvailable)

Name
FCompleted

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
True si complété

Source code
FCompleted : Boolean

Sepi
Class Tree
Index
Previous
Next (FOpenArrayAvailable)


Sepi

Sepi
Previous (FCompleted)
Next (FOpenArrayBuilder)

Name
FOpenArrayAvailable

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
Indique si un tableau ouvert est possible

Source code
FOpenArrayAvailable : Boolean

Sepi
Class Tree
Index
Previous (FCompleted)
Next (FOpenArrayBuilder)


Sepi

Sepi
Previous (FOpenArrayAvailable)
Next (FOpenArrayBuilderCompleted)

Name
FOpenArrayBuilder

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
Constructeur de tableau ouvert

Source code
FOpenArrayBuilder : ISepiOpenArrayBuilder

Sepi
Class Tree
Index
Previous (FOpenArrayAvailable)
Next (FOpenArrayBuilderCompleted)


Sepi

Sepi
Previous (FOpenArrayBuilder)
Next (FRanges)

Name
FOpenArrayBuilderCompleted

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
Indique si le tableau est complété

Source code
FOpenArrayBuilderCompleted : Boolean

Sepi
Class Tree
Index
Previous (FOpenArrayBuilder)
Next (FRanges)


Sepi

Sepi
Previous (FOpenArrayBuilderCompleted)
Next (FSetBuilder)

Name
FRanges

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
Intervalles de valeur

Source code
FRanges : array of TSepiSetBuilderRange

Sepi
Class Tree
Index
Previous (FOpenArrayBuilderCompleted)
Next (FSetBuilder)


Sepi

Sepi
Previous (FRanges)
Next (FSetBuilderCompleted)

Name
FSetBuilder

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
Constructeur d'ensemble

Source code
FSetBuilder : ISepiSetBuilder

Sepi
Class Tree
Index
Previous (FRanges)
Next (FSetBuilderCompleted)


Sepi

Sepi
Previous (FSetBuilder)
Next (FSingles)

Name
FSetBuilderCompleted

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
Indique si l'ensemble est complété

Source code
FSetBuilderCompleted : Boolean

Sepi
Class Tree
Index
Previous (FSetBuilder)
Next (FSingles)


Sepi

Sepi
Previous (FSetBuilderCompleted)
Next

Name
FSingles

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
Valeurs simples

Source code
FSingles : array of ISepiReadableValue

Sepi
Class Tree
Index
Previous (FSetBuilderCompleted)
Next


Sepi

Sepi
Previous
Next (OpenArrayBuilder)

Name
Completed

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
True si complété

Source code
property Completed : Boolean read FCompleted

Read Access
FCompleted

Sepi
Class Tree
Index
Previous
Next (OpenArrayBuilder)


Sepi

Sepi
Previous (Completed)
Next (SetBuilder)

Name
OpenArrayBuilder

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
Constructeur de tableau ouvert

Source code
property OpenArrayBuilder : ISepiOpenArrayBuilder read FOpenArrayBuilder

Read Access
FOpenArrayBuilder

Sepi
Class Tree
Index
Previous (Completed)
Next (SetBuilder)


Sepi

Sepi
Previous (OpenArrayBuilder)
Next

Name
SetBuilder

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
Constructeur d'ensemble

Source code
property SetBuilder : ISepiSetBuilder read FSetBuilder

Read Access
FSetBuilder

Sepi
Class Tree
Index
Previous (OpenArrayBuilder)
Next


Sepi

Sepi
Previous
Next (AddSingle)

Name
AddRange

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AddRange ( const Lower , Higher : ISepiReadableValue )

Parameters
Parameter | Description
Lower : ISepiReadableValue | #Pas de TAG trouvé dans le code source#
Higher : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AddSingle)


Sepi

Sepi
Previous (AddRange)
Next (AttachToExpression)

Name
AddSingle

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AddSingle ( const Value : ISepiReadableValue )

Parameters
Parameter | Description
Value : ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddRange)
Next (AttachToExpression)


Sepi

Sepi
Previous (AddSingle)
Next (CanForceElementType)

Name
AttachToExpression

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddSingle)
Next (CanForceElementType)


Sepi

Sepi
Previous (AttachToExpression)
Next (CanForceType)

Name
CanForceElementType

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceElementType ( AElementType : TSepiType ) : Boolean

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (CanForceType)


Sepi

Sepi
Previous (CanForceElementType)
Next (CompileRead)

Name
CanForceType

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceElementType)
Next (CompileRead)


Sepi

Sepi
Previous (CanForceType)
Next (CompileReadOpenArray)

Name
CompileRead

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileRead ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CanForceType)
Next (CompileReadOpenArray)


Sepi

Sepi
Previous (CompileRead)
Next (Complete)

Name
CompileReadOpenArray

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileReadOpenArray ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var OpenArrayDest , HighValueDest : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
OpenArrayDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
HighValueDest : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileRead)
Next (Complete)


Sepi

Sepi
Previous (CompileReadOpenArray)
Next (Create)

Name
Complete

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileReadOpenArray)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (ForceElementType)

Name
Create

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PUBLIC

Description
Crée une instance de TSepiSetOrOpenArrayBuilder

Source code
constructor Create ( UnitCompiler : TSepiUnitCompiler )

Parameters
Parameter | Description
UnitCompiler : TSepiUnitCompiler | Compilateur d'unité

Sepi
Class Tree
Index
Previous (Complete)
Next (ForceElementType)


Sepi

Sepi
Previous (Create)
Next (ForceType)

Name
ForceElementType

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceElementType ( AElementType : TSepiType )

Parameters
Parameter | Description
AElementType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (ForceType)


Sepi

Sepi
Previous (ForceElementType)
Next (GetConstValuePtr)

Name
ForceType

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceElementType)
Next (GetConstValuePtr)


Sepi

Sepi
Previous (ForceType)
Next (GetElementType)

Name
GetConstValuePtr

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetConstValuePtr : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForceType)
Next (GetElementType)


Sepi

Sepi
Previous (GetConstValuePtr)
Next (GetIsConstant)

Name
GetElementType

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetElementType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetConstValuePtr)
Next (GetIsConstant)


Sepi

Sepi
Previous (GetElementType)
Next (GetValueType)

Name
GetIsConstant

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsConstant : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetElementType)
Next (GetValueType)


Sepi

Sepi
Previous (GetIsConstant)
Next (NeedOpenArrayBuilder)

Name
GetValueType

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetValueType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetIsConstant)
Next (NeedOpenArrayBuilder)


Sepi

Sepi
Previous (GetValueType)
Next (NeedSetBuilder)

Name
NeedOpenArrayBuilder

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure NeedOpenArrayBuilder

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetValueType)
Next (NeedSetBuilder)


Sepi

Sepi
Previous (NeedOpenArrayBuilder)
Next (QueryInterface)

Name
NeedSetBuilder

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure NeedSetBuilder

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (NeedOpenArrayBuilder)
Next (QueryInterface)


Sepi

Sepi
Previous (NeedSetBuilder)
Next

Name
QueryInterface

Parent
TSepiSetOrOpenArrayBuilder

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function QueryInterface ( const IID : TGUID ; out Obj ) : HResult ; override ; stdcall

Parameters
Parameter | Description
IID : TGUID | #Pas de TAG trouvé dans le code source#
Obj : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
HResult | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (NeedSetBuilder)
Next


Sepi

Sepi
Previous (TSepiSetOrOpenArrayBuilder)
Next (TSepiStringLengthValue)

Name
TSepiStrCopyExpression

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Expression copie d'une partie d'une chaîne de caractères

Members
Fields
Field | Description
FCountValue (-) | Valeur du nombre de caractères à copier
FIndexValue (-) | Valeur de l'index
FSourceStr (-) | Chaîne source

Methods
Method | Description
CheckTypes (-) | Vérification de type
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'expression
MakeStrCopy (+) | Construit une expression copie d'une partie de chaîne de caractères

Properties
Property | Description
CountValue (+) | Valeur du nombre de caractères à copier
IndexValue (+) | Valeur de l'index
SourceStr (+) | Chaîne source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSetOrOpenArrayBuilder)
Next (TSepiStringLengthValue)


Sepi

Sepi
Previous
Next (FIndexValue)

Name
FCountValue

Parent
TSepiStrCopyExpression

Visibility
PRIVATE

Description
Valeur du nombre de caractères à copier

Source code
FCountValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (FIndexValue)


Sepi

Sepi
Previous (FCountValue)
Next (FSourceStr)

Name
FIndexValue

Parent
TSepiStrCopyExpression

Visibility
PRIVATE

Description
Valeur de l'index

Source code
FIndexValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FCountValue)
Next (FSourceStr)


Sepi

Sepi
Previous (FIndexValue)
Next

Name
FSourceStr

Parent
TSepiStrCopyExpression

Visibility
PRIVATE

Description
Chaîne source

Source code
FSourceStr : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FIndexValue)
Next


Sepi

Sepi
Previous
Next (IndexValue)

Name
CountValue

Parent
TSepiStrCopyExpression

Visibility
PUBLIC

Description
Valeur du nombre de caractères à copier

Source code
property CountValue : ISepiReadableValue read FCountValue write FCountValue

Read Access
FCountValue

Write Access
FCountValue

Sepi
Class Tree
Index
Previous
Next (IndexValue)


Sepi

Sepi
Previous (CountValue)
Next (SourceStr)

Name
IndexValue

Parent
TSepiStrCopyExpression

Visibility
PUBLIC

Description
Valeur de l'index

Source code
property IndexValue : ISepiReadableValue read FIndexValue write FIndexValue

Read Access
FIndexValue

Write Access
FIndexValue

Sepi
Class Tree
Index
Previous (CountValue)
Next (SourceStr)


Sepi

Sepi
Previous (IndexValue)
Next

Name
SourceStr

Parent
TSepiStrCopyExpression

Visibility
PUBLIC

Description
Chaîne source

Source code
property SourceStr : ISepiReadableValue read FSourceStr write FSourceStr

Read Access
FSourceStr

Write Access
FSourceStr

Sepi
Class Tree
Index
Previous (IndexValue)
Next


Sepi

Sepi
Previous
Next (CollapseConsts)

Name
CheckTypes

Parent
TSepiStrCopyExpression

Visibility
PRIVATE

Description
Vérification de type

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CollapseConsts)


Sepi

Sepi
Previous (CheckTypes)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiStrCopyExpression

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (Complete)

Name
CompileCompute

Parent
TSepiStrCopyExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (MakeStrCopy)

Name
Complete

Parent
TSepiStrCopyExpression

Visibility
PUBLIC

Description
Complète l'expression

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (MakeStrCopy)


Sepi

Sepi
Previous (Complete)
Next

Name
MakeStrCopy

Parent
TSepiStrCopyExpression

Visibility
PUBLIC

Description
Construit une expression copie d'une partie de chaîne de caractères

Source code
class function MakeStrCopy ( const SourceStr : ISepiReadableValue ; const IndexValue , CountValue : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter | Description
SourceStr : ISepiReadableValue | Chaîne source
IndexValue : ISepiReadableValue | Valeur index de début de la copie
CountValue : ISepiReadableValue | Valeur nombre de caractères à copier

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next


Sepi

Sepi
Previous (TSepiStrCopyExpression)
Next (TSepiStringLiteralValue)

Name
TSepiStringLengthValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Longueur d'une chaîne de caractères

Members
Fields
Field | Description
FOperand (-) | Opérande

Methods
Method | Description
CheckType (-) | Vérification de type
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'opération
MakeStringLengthValue (+) | Construit une valeur longueur de chaîne de caractères

Properties
Property | Description
Operand (+) | Opérande

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiStrCopyExpression)
Next (TSepiStringLiteralValue)


Sepi

Sepi
Previous
Next

Name
FOperand

Parent
TSepiStringLengthValue

Visibility
PRIVATE

Description
Opérande

Source code
FOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Operand

Parent
TSepiStringLengthValue

Visibility
PUBLIC

Description
Opérande

Source code
property Operand : ISepiReadableValue read FOperand write FOperand

Read Access
FOperand

Write Access
FOperand

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CollapseConsts)

Name
CheckType

Parent
TSepiStringLengthValue

Visibility
PRIVATE

Description
Vérification de type

Source code
procedure CheckType

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CollapseConsts)


Sepi

Sepi
Previous (CheckType)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiStringLengthValue

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckType)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (Complete)

Name
CompileCompute

Parent
TSepiStringLengthValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (MakeStringLengthValue)

Name
Complete

Parent
TSepiStringLengthValue

Visibility
PUBLIC

Description
Complète l'opération
L'opération doit avoir été attachée à une expression auparavant, pour pouvoir
bénéficier du contexte de celle-ci.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (MakeStringLengthValue)


Sepi

Sepi
Previous (Complete)
Next

Name
MakeStringLengthValue

Parent
TSepiStringLengthValue

Visibility
PUBLIC

Description
Construit une valeur longueur de chaîne de caractères

Source code
class function MakeStringLengthValue ( const Operand : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter | Description
Operand : ISepiReadableValue | Opérande

Return
Types | Description
ISepiReadableValue | Valeur représentant la longueur de la chaîne de caractères

Sepi
Class Tree
Index
Previous (Complete)
Next


Sepi

Sepi
Previous (TSepiStringLengthValue)
Next (TSepiStrSetLengthExpression)

Name
TSepiStringLiteralValue

Parent
SepiExpressions

Class Hierarchy
TSepiLiteralValue,ISepiTypeForceableValue

Visibility
PUBLIC

Description
Valeur constante litérale chaîne

Members
Fields
Field | Description
FPCharValue (-) | Valeur constante PChar
FValue (-) | Valeur constante

Methods
Method | Description
CanForceType (#) | [@inheritDoc]
Create (+) | Crée une valeur constante litérale chaîne
Destroy (+) | [@inheritDoc]
ForceType (#) | [@inheritDoc]
MakeValue (+) | Construit une valeur constante litérale chaîne

Properties
Property | Description
Value (+) | Valeur constante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiStringLengthValue)
Next (TSepiStrSetLengthExpression)


Sepi

Sepi
Previous
Next (FValue)

Name
FPCharValue

Parent
TSepiStringLiteralValue

Visibility
PRIVATE

Description
Valeur constante PChar

Source code
FPCharValue : Pointer

Sepi
Class Tree
Index
Previous
Next (FValue)


Sepi

Sepi
Previous (FPCharValue)
Next

Name
FValue

Parent
TSepiStringLiteralValue

Visibility
PRIVATE

Description
Valeur constante

Source code
FValue : string

Sepi
Class Tree
Index
Previous (FPCharValue)
Next


Sepi

Sepi
Previous
Next

Name
Value

Parent
TSepiStringLiteralValue

Visibility
PUBLIC

Description
Valeur constante

Source code
property Value : string read FValue

Read Access
FValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
CanForceType

Parent
TSepiStringLiteralValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CanForceType ( AValueType : TSepiType ; Explicit : Boolean = False ) : Boolean

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#
Explicit : BOOLEAN | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CanForceType)
Next (Destroy)

Name
Create

Parent
TSepiStringLiteralValue

Visibility
PUBLIC

Description
Crée une valeur constante litérale chaîne

Source code
constructor Create ( ASepiRoot : TSepiRoot ; const AValue : string )

Parameters
Parameter | Description
ASepiRoot : TSepiRoot | Racine Sepi
AValue : STRING | Valeur constante

Sepi
Class Tree
Index
Previous (CanForceType)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (ForceType)

Name
Destroy

Parent
TSepiStringLiteralValue

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (ForceType)


Sepi

Sepi
Previous (Destroy)
Next (MakeValue)

Name
ForceType

Parent
TSepiStringLiteralValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ForceType ( AValueType : TSepiType )

Parameters
Parameter | Description
AValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (MakeValue)


Sepi

Sepi
Previous (ForceType)
Next

Name
MakeValue

Parent
TSepiStringLiteralValue

Visibility
PUBLIC

Description
Construit une valeur constante litérale chaîne

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; const Value : string ) : ISepiReadableValue

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur
Value : STRING | Valeur constante

Return
Types | Description
ISepiReadableValue | Valeur constante litérale chaîne

Sepi
Class Tree
Index
Previous (ForceType)
Next


Sepi

Sepi
Previous (TSepiStringLiteralValue)
Next (TSepiTrueConstValue)

Name
TSepiStrSetLengthExpression

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExecutable

Visibility
PUBLIC

Description
Expression de changement de la longueur d'une chaîne de caractères

Members
Fields
Field | Description
FNewLengthValue (-) | Nouvelle longueur
FStrValue (-) | Chaîne dont modifier la longueur

Methods
Method | Description
CheckTypes (-) | Vérification de type
CompileExecute (#) | [@inheritDoc]
Complete (+) | Complète l'expression
MakeStrSetLengthExpression (+) | Construit une expression de changement de la longueur d'une chaîne

Properties
Property | Description
NewLengthValue (+) | Nouvelle longueur
StrValue (+) | Chaîne dont modifier la longueur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiStringLiteralValue)
Next (TSepiTrueConstValue)


Sepi

Sepi
Previous
Next (FStrValue)

Name
FNewLengthValue

Parent
TSepiStrSetLengthExpression

Visibility
PRIVATE

Description
Nouvelle longueur

Source code
FNewLengthValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (FStrValue)


Sepi

Sepi
Previous (FNewLengthValue)
Next

Name
FStrValue

Parent
TSepiStrSetLengthExpression

Visibility
PRIVATE

Description
Chaîne dont modifier la longueur

Source code
FStrValue : ISepiValue

Sepi
Class Tree
Index
Previous (FNewLengthValue)
Next


Sepi

Sepi
Previous
Next (StrValue)

Name
NewLengthValue

Parent
TSepiStrSetLengthExpression

Visibility
PUBLIC

Description
Nouvelle longueur

Source code
property NewLengthValue : ISepiReadableValue read FNewLengthValue write FNewLengthValue

Read Access
FNewLengthValue

Write Access
FNewLengthValue

Sepi
Class Tree
Index
Previous
Next (StrValue)


Sepi

Sepi
Previous (NewLengthValue)
Next

Name
StrValue

Parent
TSepiStrSetLengthExpression

Visibility
PUBLIC

Description
Chaîne dont modifier la longueur

Source code
property StrValue : ISepiValue read FStrValue write FStrValue

Read Access
FStrValue

Write Access
FStrValue

Sepi
Class Tree
Index
Previous (NewLengthValue)
Next


Sepi

Sepi
Previous
Next (CompileExecute)

Name
CheckTypes

Parent
TSepiStrSetLengthExpression

Visibility
PRIVATE

Description
Vérification de type

Source code
procedure CheckTypes

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileExecute)


Sepi

Sepi
Previous (CheckTypes)
Next (Complete)

Name
CompileExecute

Parent
TSepiStrSetLengthExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileExecute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckTypes)
Next (Complete)


Sepi

Sepi
Previous (CompileExecute)
Next (MakeStrSetLengthExpression)

Name
Complete

Parent
TSepiStrSetLengthExpression

Visibility
PUBLIC

Description
Complète l'expression

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileExecute)
Next (MakeStrSetLengthExpression)


Sepi

Sepi
Previous (Complete)
Next

Name
MakeStrSetLengthExpression

Parent
TSepiStrSetLengthExpression

Visibility
PUBLIC

Description
Construit une expression de changement de la longueur d'une chaîne

Source code
class function MakeStrSetLengthExpression ( const StrValue : ISepiValue ; const NewLengthValue : ISepiReadableValue ) : ISepiExecutable

Parameters
Parameter | Description
StrValue : ISepiValue | Valeur chaîne
NewLengthValue : ISepiReadableValue | Nouvelle longueur de la chaîne

Return
Types | Description
ISepiExecutable | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next


Sepi

Sepi
Previous (TSepiStrSetLengthExpression)
Next (TSepiTypeExpression)

Name
TSepiTrueConstValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Valeur constante

Members
Fields
Field | Description
FConstant (-) | Constante

Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Create (+) | Crée une expression représentant une vraie constante
Create (+) | Tronc commun des créations de constantes litérales
Destroy (+) | [@inheritDoc]
MakeValue (+) | Construit une expression valeur pour une constante globale
MakeValue (+) | Construit une expression valeur pour une valeur quelconque

Properties
Property | Description
Constant (+) | Constante
ConstValuePtr (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiStrSetLengthExpression)
Next (TSepiTypeExpression)


Sepi

Sepi
Previous
Next

Name
FConstant

Parent
TSepiTrueConstValue

Visibility
PRIVATE

Description
Constante

Source code
FConstant : TSepiConstant

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ConstValuePtr)

Name
Constant

Parent
TSepiTrueConstValue

Visibility
PUBLIC

Description
Constante

Source code
property Constant : TSepiConstant read FConstant

Read Access
FConstant

Sepi
Class Tree
Index
Previous
Next (ConstValuePtr)


Sepi

Sepi
Previous (Constant)
Next

Name
ConstValuePtr

Parent
TSepiTrueConstValue

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ConstValuePtr

Sepi
Class Tree
Index
Previous (Constant)
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompileAsMemoryRef

Parent
TSepiTrueConstValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (Create)

Name
Create

Parent
TSepiTrueConstValue

Visibility
PUBLIC

Description
Crée une expression représentant une vraie constante

Source code
constructor Create ( Constant : TSepiConstant ) ; overload

Parameters
Parameter | Description
Constant : TSepiConstant | Vraie constante représentée

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TSepiTrueConstValue

Visibility
PUBLIC

Description
Tronc commun des créations de constantes litérales

Source code
constructor Create ( AType : TSepiType ) ; overload

Parameters
Parameter | Description
AType : TSepiType | Type de la constante

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (MakeValue)

Name
Destroy

Parent
TSepiTrueConstValue

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (MakeValue)


Sepi

Sepi
Previous (Destroy)
Next (MakeValue)

Name
MakeValue

Parent
TSepiTrueConstValue

Visibility
PUBLIC

Description
Construit une expression valeur pour une constante globale

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; Constant : TSepiConstant ) : ISepiReadableValue ; overload

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur
Constant : TSepiConstant | Constante globale

Return
Types | Description
ISepiReadableValue | Valeur représentant la constante globale

Sepi
Class Tree
Index
Previous (Destroy)
Next (MakeValue)


Sepi

Sepi
Previous (MakeValue)
Next

Name
MakeValue

Parent
TSepiTrueConstValue

Visibility
PUBLIC

Description
Construit une expression valeur pour une valeur quelconque

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; ValueType : TSepiType ; const Value ) : ISepiReadableValue ; overload

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur
ValueType : TSepiType | Type de la valeur
Value : Untyped | Valeur

Return
Types | Description
ISepiReadableValue | Valeur représentant la valeur Value de type ValueType

Sepi
Class Tree
Index
Previous (MakeValue)
Next


Sepi

Sepi
Previous (TSepiTrueConstValue)
Next (TSepiTypeOperationValue)

Name
TSepiTypeExpression

Parent
SepiExpressions

Class Hierarchy
TSepiCustomExpressionPart,ISepiTypeExpression

Visibility
PUBLIC

Description
Expression représentant un type

Members
Fields
Field | Description
FType (-) | Type

Methods
Method | Description
AttachToExpression (#) | [@inheritDoc]
Create (+) | Crée une expression représentant un type
GetType (#) | Type

Properties
Property | Description
ExprType (+) | Type

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTrueConstValue)
Next (TSepiTypeOperationValue)


Sepi

Sepi
Previous
Next

Name
FType

Parent
TSepiTypeExpression

Visibility
PRIVATE

Description
Type

Source code
FType : TSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
ExprType

Parent
TSepiTypeExpression

Visibility
PUBLIC

Description
Type

Source code
property ExprType : TSepiType read FType

Read Access
FType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
AttachToExpression

Parent
TSepiTypeExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AttachToExpression ( const Expression : ISepiExpression ) ; override

Parameters
Parameter | Description
Expression : ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AttachToExpression)
Next (GetType)

Name
Create

Parent
TSepiTypeExpression

Visibility
PUBLIC

Description
Crée une expression représentant un type

Source code
constructor Create ( AType : TSepiType )

Parameters
Parameter | Description
AType : TSepiType | Type représenté

Sepi
Class Tree
Index
Previous (AttachToExpression)
Next (GetType)


Sepi

Sepi
Previous (Create)
Next

Name
GetType

Parent
TSepiTypeExpression

Visibility
PROTECTED

Description
Type

Source code
function GetType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiTypeExpression)
Next (TSepiUnaryOperation)

Name
TSepiTypeOperationValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomComputedValue

Visibility
PUBLIC

Description
Opération sur un type

Members
Fields
Field | Description
FNilIfNoTypeInfo (-) | Si True, TypeInfo peut renvoyer nil
FOperand (-) | Opérande
FOperation (-) | Opération

Methods
Method | Description
CheckOperand (-) | Vérifie si l'opérande est valide
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'opération
CompleteArrayBound (-) | Complète une borne de tableau
CompleteOrdinalBound (-) | Complète une borne d'ordinal
CompleteSizeOf (-) | Complète un SizeOf
CompleteTypeInfo (-) | Complète un TypeInfo
Create (+) | Crée l'opération
MakeTypeOperationValue (+) | Construit une valeur opération de type

Properties
Property | Description
NilIfNoTypeInfo (+) | Si True, TypeInfo peut renvoyer nil
Operand (+) | Opérande
Operation (+) | Opération

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeExpression)
Next (TSepiUnaryOperation)


Sepi

Sepi
Previous
Next (FOperand)

Name
FNilIfNoTypeInfo

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Si True, TypeInfo peut renvoyer nil

Source code
FNilIfNoTypeInfo : Boolean

Sepi
Class Tree
Index
Previous
Next (FOperand)


Sepi

Sepi
Previous (FNilIfNoTypeInfo)
Next (FOperation)

Name
FOperand

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Opérande

Source code
FOperand : ISepiTypeExpression

Sepi
Class Tree
Index
Previous (FNilIfNoTypeInfo)
Next (FOperation)


Sepi

Sepi
Previous (FOperand)
Next

Name
FOperation

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Opération

Source code
FOperation : TSepiTypeOperation

Sepi
Class Tree
Index
Previous (FOperand)
Next


Sepi

Sepi
Previous
Next (Operand)

Name
NilIfNoTypeInfo

Parent
TSepiTypeOperationValue

Visibility
PUBLIC

Description
Si True, TypeInfo peut renvoyer nil

Source code
property NilIfNoTypeInfo : Boolean read FNilIfNoTypeInfo write FNilIfNoTypeInfo

Read Access
FNilIfNoTypeInfo

Write Access
FNilIfNoTypeInfo

Sepi
Class Tree
Index
Previous
Next (Operand)


Sepi

Sepi
Previous (NilIfNoTypeInfo)
Next (Operation)

Name
Operand

Parent
TSepiTypeOperationValue

Visibility
PUBLIC

Description
Opérande

Source code
property Operand : ISepiTypeExpression read FOperand write FOperand

Read Access
FOperand

Write Access
FOperand

Sepi
Class Tree
Index
Previous (NilIfNoTypeInfo)
Next (Operation)


Sepi

Sepi
Previous (Operand)
Next

Name
Operation

Parent
TSepiTypeOperationValue

Visibility
PUBLIC

Description
Opération

Source code
property Operation : TSepiTypeOperation read FOperation

Read Access
FOperation

Sepi
Class Tree
Index
Previous (Operand)
Next


Sepi

Sepi
Previous
Next (CompileCompute)

Name
CheckOperand

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Vérifie si l'opérande est valide

Source code
procedure CheckOperand

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileCompute)


Sepi

Sepi
Previous (CheckOperand)
Next (Complete)

Name
CompileCompute

Parent
TSepiTypeOperationValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckOperand)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (CompleteArrayBound)

Name
Complete

Parent
TSepiTypeOperationValue

Visibility
PUBLIC

Description
Complète l'opération
L'opération doit avoir été attachée à une expression auparavant, pour pouvoir
bénéficier du contexte de celle-ci.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (CompleteArrayBound)


Sepi

Sepi
Previous (Complete)
Next (CompleteOrdinalBound)

Name
CompleteArrayBound

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Complète une borne de tableau

Source code
procedure CompleteArrayBound

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Complete)
Next (CompleteOrdinalBound)


Sepi

Sepi
Previous (CompleteArrayBound)
Next (CompleteSizeOf)

Name
CompleteOrdinalBound

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Complète une borne d'ordinal

Source code
procedure CompleteOrdinalBound

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompleteArrayBound)
Next (CompleteSizeOf)


Sepi

Sepi
Previous (CompleteOrdinalBound)
Next (CompleteTypeInfo)

Name
CompleteSizeOf

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Complète un SizeOf

Source code
procedure CompleteSizeOf

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompleteOrdinalBound)
Next (CompleteTypeInfo)


Sepi

Sepi
Previous (CompleteSizeOf)
Next (Create)

Name
CompleteTypeInfo

Parent
TSepiTypeOperationValue

Visibility
PRIVATE

Description
Complète un TypeInfo

Source code
procedure CompleteTypeInfo

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompleteSizeOf)
Next (Create)


Sepi

Sepi
Previous (CompleteTypeInfo)
Next (MakeTypeOperationValue)

Name
Create

Parent
TSepiTypeOperationValue

Visibility
PUBLIC

Description
Crée l'opération

Source code
constructor Create ( AOperation : TSepiTypeOperation ; ANilIfNoTypeInfo : Boolean = False )

Parameters
Parameter | Description
AOperation : TSepiTypeOperation | Opération
ANilIfNoTypeInfo : BOOLEAN | Si True, TypeInfo peut renvoyer nil

Sepi
Class Tree
Index
Previous (CompleteTypeInfo)
Next (MakeTypeOperationValue)


Sepi

Sepi
Previous (Create)
Next

Name
MakeTypeOperationValue

Parent
TSepiTypeOperationValue

Visibility
PUBLIC

Description
Construit une valeur opération de type

Source code
class function MakeTypeOperationValue ( Operation : TSepiTypeOperation ; const Operand : ISepiTypeExpression ; NilIfNoTypeInfo : Boolean = False ) : ISepiReadableValue

Parameters
Parameter | Description
Operation : TSepiTypeOperation | Opération à effectuer sur le type
Operand : ISepiTypeExpression | Opérande
NilIfNoTypeInfo : BOOLEAN

Return
Types | Description
ISepiReadableValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiTypeOperationValue)
Next (TSepiVariableValue)

Name
TSepiUnaryOperation

Parent
SepiExpressions

Class Hierarchy
TSepiArithmeticLogicOperation

Visibility
PUBLIC

Description
Opération unaire

Members
Fields
Field | Description
FOperand (-) | Opérande

Methods
Method | Description
CheckType (-) | Vérification de type
CollapseConsts (-) | Pliage des constantes
CompileCompute (#) | [@inheritDoc]
Complete (+) | Complète l'opération
MakeOperation (+) | Construit une opération unaire

Properties
Property | Description
Operand (+) | Opérande

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeOperationValue)
Next (TSepiVariableValue)


Sepi

Sepi
Previous
Next

Name
FOperand

Parent
TSepiUnaryOperation

Visibility
PRIVATE

Description
Opérande

Source code
FOperand : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Operand

Parent
TSepiUnaryOperation

Visibility
PUBLIC

Description
Opérande

Source code
property Operand : ISepiReadableValue read FOperand write FOperand

Read Access
FOperand

Write Access
FOperand

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CollapseConsts)

Name
CheckType

Parent
TSepiUnaryOperation

Visibility
PRIVATE

Description
Vérification de type

Source code
procedure CheckType

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CollapseConsts)


Sepi

Sepi
Previous (CheckType)
Next (CompileCompute)

Name
CollapseConsts

Parent
TSepiUnaryOperation

Visibility
PRIVATE

Description
Pliage des constantes

Source code
procedure CollapseConsts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckType)
Next (CompileCompute)


Sepi

Sepi
Previous (CollapseConsts)
Next (Complete)

Name
CompileCompute

Parent
TSepiUnaryOperation

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileCompute ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; var Destination : TSepiMemoryReference ; TempVars : TSepiTempVarsLifeManager ) ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
Destination : TSepiMemoryReference | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CollapseConsts)
Next (Complete)


Sepi

Sepi
Previous (CompileCompute)
Next (MakeOperation)

Name
Complete

Parent
TSepiUnaryOperation

Visibility
PUBLIC

Description
Complète l'opération
L'opération doit avoir été attachée à une expression auparavant, pour pouvoir
bénéficier du contexte de celle-ci.

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileCompute)
Next (MakeOperation)


Sepi

Sepi
Previous (Complete)
Next

Name
MakeOperation

Parent
TSepiUnaryOperation

Visibility
PUBLIC

Description
Construit une opération unaire

Source code
class function MakeOperation ( Operation : TSepiOperation ; const Operand : ISepiReadableValue ) : ISepiReadableValue

Parameters
Parameter | Description
Operation : TSepiOperation | Opération
Operand : ISepiReadableValue | Opérande

Return
Types | Description
ISepiReadableValue | Valeur représentant l'opération

Sepi
Class Tree
Index
Previous (Complete)
Next


Sepi

Sepi
Previous (TSepiUnaryOperation)
Next

Name
TSepiVariableValue

Parent
SepiExpressions

Class Hierarchy
TSepiCustomDirectValue

Visibility
PUBLIC

Description
Valeur variable globale

Members
Fields
Field | Description
FVariable (-) | Variable représentée

Methods
Method | Description
CompileAsMemoryRef (#) | [@inheritDoc]
Create (+) | Crée une valeur variable globale
MakeValue (+) | Construit une expression valeur pour une variable globale

Properties
Property | Description
Variable (+) | Variable représentée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUnaryOperation)
Next


Sepi

Sepi
Previous
Next

Name
FVariable

Parent
TSepiVariableValue

Visibility
PRIVATE

Description
Variable représentée

Source code
FVariable : TSepiVariable

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Variable

Parent
TSepiVariableValue

Visibility
PUBLIC

Description
Variable représentée

Source code
property Variable : TSepiVariable read FVariable

Read Access
FVariable

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
CompileAsMemoryRef

Parent
TSepiVariableValue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsMemoryRef ( Compiler : TSepiMethodCompiler ; Instructions : TSepiInstructionList ; TempVars : TSepiTempVarsLifeManager ) : TSepiMemoryReference ; override

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#
Instructions : TSepiInstructionList | #Pas de TAG trouvé dans le code source#
TempVars : TSepiTempVarsLifeManager | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMemoryReference | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompileAsMemoryRef)
Next (MakeValue)

Name
Create

Parent
TSepiVariableValue

Visibility
PUBLIC

Description
Crée une valeur variable globale

Source code
constructor Create ( AVariable : TSepiVariable )

Parameters
Parameter | Description
AVariable : TSepiVariable | Variable

Sepi
Class Tree
Index
Previous (CompileAsMemoryRef)
Next (MakeValue)


Sepi

Sepi
Previous (Create)
Next

Name
MakeValue

Parent
TSepiVariableValue

Visibility
PUBLIC

Description
Construit une expression valeur pour une variable globale

Source code
class function MakeValue ( Compiler : TSepiCompilerBase ; Variable : TSepiVariable ) : ISepiValue

Parameters
Parameter | Description
Compiler : TSepiCompilerBase | Compilateur
Variable : TSepiVariable | Variable globale

Return
Types | Description
ISepiValue | Valeur représentant la variable globale

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous
Next (TSepiOperation)

Name
TSepiArrayBoundKind

Parent
SepiExpressions

Visibility
PUBLIC

Description
Type de borne de tableau
- abkLow : Borne inférieure ;
- abkHigh : Borne supérieure ;
- abkLength : Longueur du tableau.

Source code
TSepiArrayBoundKind = ( abkLow , abkHigh , abkLength ) ;

Sepi
Class Tree
Index
Previous
Next (TSepiOperation)


Sepi

Sepi
Previous (TSepiArrayBoundKind)
Next (TSepiTypeOperation)

Name
TSepiOperation

Parent
SepiExpressions

Visibility
PUBLIC

Description
Opération Sepi

Source code
TSepiOperation = opAdd .. opCmpGE ;

Sepi
Class Tree
Index
Previous (TSepiArrayBoundKind)
Next (TSepiTypeOperation)


Sepi

Sepi
Previous (TSepiOperation)
Next

Name
TSepiTypeOperation

Parent
SepiExpressions

Visibility
PUBLIC

Description
Opération Sepi sur un type
- toSizeOf : SizeOf(TypeName)
- toTypeInfo : TypeInfo(TypeName)
- toLowerBound : Low(TypeName)
- toHigherBound : High(TypeName)
- toLength : Length(TypeName)

Source code
TSepiTypeOperation = ( toSizeOf , toTypeInfo , toLowerBound , toHigherBound , toLength ) ;

Sepi
Class Tree
Index
Previous (TSepiOperation)
Next


Sepi

Sepi
Previous
Next (opBinaryOps)

Name
opAllOps

Parent
SepiExpressions

Visibility
PUBLIC

Description
Toutes les opérations valides

Source code
opAllOps = [ Low ( TSepiOperation ) .. High ( TSepiOperation ) ]

Sepi
Class Tree
Index
Previous
Next (opBinaryOps)


Sepi

Sepi
Previous (opAllOps)
Next (opComparisonOps)

Name
opBinaryOps

Parent
SepiExpressions

Visibility
PUBLIC

Description
Operations binaires (dont comparaisons)

Source code
opBinaryOps = opAllOps - opUnaryOps

Sepi
Class Tree
Index
Previous (opAllOps)
Next (opComparisonOps)


Sepi

Sepi
Previous (opBinaryOps)
Next (opUnaryOps)

Name
opComparisonOps

Parent
SepiExpressions

Visibility
PUBLIC

Description
Opérations de comparaison

Source code
opComparisonOps = [ opCmpEQ .. opCmpGE ]

Sepi
Class Tree
Index
Previous (opBinaryOps)
Next (opUnaryOps)


Sepi

Sepi
Previous (opComparisonOps)
Next

Name
opUnaryOps

Parent
SepiExpressions

Visibility
PUBLIC

Description
Opérations unaires

Source code
opUnaryOps = [ opNegate , opNot ]

Sepi
Class Tree
Index
Previous (opComparisonOps)
Next


Sepi

Sepi
Previous
Next (IsZeroMemory)

Name
DefaultSepiTypeFor

Parent
SepiExpressions

Visibility
PUBLIC

Description
Trouve le type Sepi par défaut correspondant à un type de base

Source code
function DefaultSepiTypeFor ( BaseType : TSepiBaseType ; SepiRoot : TSepiRoot ) : TSepiType

Parameters
Parameter | Description
BaseType : TSepiBaseType | Type de base
SepiRoot : TSepiRoot | Racine Sepi

Return
Types | Description
TSepiType | Type Sepi correspondant

Sepi
Class Tree
Index
Previous
Next (IsZeroMemory)


Sepi

Sepi
Previous (DefaultSepiTypeFor)
Next (NeedDestination)

Name
IsZeroMemory

Parent
SepiExpressions

Visibility
PUBLIC

Description
Teste si une valeur est un zéro mémoire, tel qu'on peut utiliser msZero
Une valeur est un zéro mémoire si et seulement si sa taille n'est pas plus
grande qu'un Variant et que tous ses octets sont nuls.

Source code
function IsZeroMemory ( Address : Pointer ; Size : Integer ) : Boolean

Parameters
Parameter | Description
Address : Pointer | Adresse mémoire de la valeur
Size : INTEGER | Taille de la valeur

Return
Types | Description
BOOLEAN | True si la valeur est un zéro mémoire, False sinon

Sepi
Class Tree
Index
Previous (DefaultSepiTypeFor)
Next (NeedDestination)


Sepi

Sepi
Previous (IsZeroMemory)
Next (SepiTypeToBaseType)

Name
NeedDestination

Parent
SepiExpressions

Visibility
PUBLIC

Description
Exige une destination mémoire valide
Si Destination vaut nil en entrée, cette routine allouera une variable
temporaire du type demandé pour avoir une référence mémoire valide.

Source code
procedure NeedDestination ( var Destination : TSepiMemoryReference ; ValueType : TSepiType ; Compiler : TSepiMethodCompiler ; TempVars : TSepiTempVarsLifeManager ; BeginLifeAt : TSepiInstructionRef )

Parameters
Parameter | Description
Destination : TSepiMemoryReference | Destination mémoire
ValueType : TSepiType | Type de valeur à mettre dans la destination
Compiler : TSepiMethodCompiler | Compilateur
TempVars : TSepiTempVarsLifeManager | Gestionnaire de vie de variables temporaires
BeginLifeAt : TSepiInstructionRef | Début de la vie de la variable temporaire

Sepi
Class Tree
Index
Previous (IsZeroMemory)
Next (SepiTypeToBaseType)


Sepi

Sepi
Previous (NeedDestination)
Next (SepiTypeToBaseType)

Name
SepiTypeToBaseType

Parent
SepiExpressions

Visibility
PUBLIC

Description
Récupère le type de base correspondant à un type Sepi

Source code
function SepiTypeToBaseType ( SepiType : TSepiType ) : TSepiBaseType ; overload

Parameters
Parameter | Description
SepiType : TSepiType | Type Sepi

Return
Types | Description
TSepiBaseType | Type de base correspondant

Sepi
Class Tree
Index
Previous (NeedDestination)
Next (SepiTypeToBaseType)


Sepi

Sepi
Previous (SepiTypeToBaseType)
Next (SmallestIntegerTypeFor)

Name
SepiTypeToBaseType

Parent
SepiExpressions

Visibility
PUBLIC

Description
Récupère le type de base correspondant à un type Sepi

Source code
function SepiTypeToBaseType ( SepiType : TSepiType ; out BaseType : TSepiBaseType ) : Boolean ; overload

Parameters
Parameter | Description
SepiType : TSepiType | Type Sepi
BaseType : TSepiBaseType | En sortie : type de base correspondant, si existe

Return
Types | Description
BOOLEAN | False si le type Sepi n'admet pas de type de base, True sinon

Sepi
Class Tree
Index
Previous (SepiTypeToBaseType)
Next (SmallestIntegerTypeFor)


Sepi

Sepi
Previous (SepiTypeToBaseType)
Next

Name
SmallestIntegerTypeFor

Parent
SepiExpressions

Visibility
PUBLIC

Description
Plus petit type entier pouvant contenir l'entier spécifié

Source code
function SmallestIntegerTypeFor ( SepiRoot : TSepiRoot ; Value : Int64 ) : TSepiType

Parameters
Parameter | Description
SepiRoot : TSepiRoot | Racine Sepi (pour trouver le type Sepi)
Value : INT64 | Valeur entière

Return
Types | Description
TSepiType | Plus petit type entier pouvant contenir l'entier Value

Sepi
Class Tree
Index
Previous (SepiTypeToBaseType)
Next


Sepi

Sepi
Previous (SepiExpressions)
Next (SepiInstructions)

Name
SepiInCalls

Parent
Sepi

Description
Gestion des appels entrant dans Sepi

Author
sjrd

Version
1.0

Methods
Method | Description
MakeInCallCode (+) | Construit le code natif d'un appel entrant dans Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiExpressions)
Next (SepiInstructions)


Sepi

Sepi
Previous
Next

Name
MakeInCallCode

Parent
SepiInCalls

Visibility
PUBLIC

Description
Construit le code natif d'un appel entrant dans Sepi

Source code
function MakeInCallCode ( RuntimeMethod : TSepiRuntimeMethod ; ResultType : TSepiType ; CallingConvention : TCallingConvention ; SepiStackUsage : Word ; RegUsage : Word = 0 ) : Pointer

Parameters
Parameter | Description
RuntimeMethod : TSepiRuntimeMethod | Méthode d'exécution (TSepiRuntimeMethod)
ResultType : TSepiType | Type du résultat
CallingConvention : TCallingConvention | Convention d'appel native
SepiStackUsage : WORD | Taille que Sepi utilise pour la pile
RegUsage : WORD | Nombre de registres utilisés en natif

Return
Types | Description
Pointer | Pointeur sur le code natif construit

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiInCalls)
Next (SepiLexerUtils)

Name
SepiInstructions

Parent
Sepi

Description
Instructions de haut niveau Sepi

Author
sjrd

Version
1.0

Methods
Method | Description
CompileTestValue (+) | Compile le test d'une valeur booléenne

Classes
Class | Description
TSepiAssignment (+) | Instruction d'assignation :=
TSepiBreak (+) | Instruction break
TSepiCaseOf (+) | Instruction case of
TSepiCaseOfClause (+) | Clause d'un case of
TSepiContinue (+) | Instruction continue
TSepiExecuteExpression (+) | Instruction d'exécution d'une expression (exécutable)
TSepiExit (+) | Instruction exit
TSepiFor (+) | Instruction for..do
TSepiIfThenElse (+) | Instruction if..then..else
TSepiMultiOn (+) | Instruction multi-on
TSepiRaise (+) | Instruction raise
TSepiReraise (+) | Instruction reraise
TSepiSpecialJump (+) | Classe de base pour les instructions de jump spécial
TSepiTryExcept (+) | Instruction try..except
TSepiTryFinally (+) | Instruction try..finally
TSepiWhile (+) | Instruction while..do ou do..while

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiInCalls)
Next (SepiLexerUtils)


Sepi

Sepi
Previous
Next (TSepiBreak)

Name
TSepiAssignment

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction d'assignation :=

Members
Fields
Field | Description
FAutoConvert (-) | Autorise les conversions automatiques
FDestination (-) | Destination de l'assignation
FSource (-) | Source de l'assignation

Methods
Method | Description
Create (+) | Crée une instruction d'assignation :=
CustomCompile (#) | [@inheritDoc]

Properties
Property | Description
AutoConvert (+) | Autorise les conversions automatiques
Destination (+) | Destination de l'assignation
Source (+) | Source de l'assignation

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiBreak)


Sepi

Sepi
Previous
Next (FDestination)

Name
FAutoConvert

Parent
TSepiAssignment

Visibility
PRIVATE

Description
Autorise les conversions automatiques

Source code
FAutoConvert : Boolean

Sepi
Class Tree
Index
Previous
Next (FDestination)


Sepi

Sepi
Previous (FAutoConvert)
Next (FSource)

Name
FDestination

Parent
TSepiAssignment

Visibility
PRIVATE

Description
Destination de l'assignation

Source code
FDestination : ISepiWritableValue

Sepi
Class Tree
Index
Previous (FAutoConvert)
Next (FSource)


Sepi

Sepi
Previous (FDestination)
Next

Name
FSource

Parent
TSepiAssignment

Visibility
PRIVATE

Description
Source de l'assignation

Source code
FSource : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FDestination)
Next


Sepi

Sepi
Previous
Next (Destination)

Name
AutoConvert

Parent
TSepiAssignment

Visibility
PUBLIC

Description
Autorise les conversions automatiques

Source code
property AutoConvert : Boolean read FAutoConvert write FAutoConvert

Read Access
FAutoConvert

Write Access
FAutoConvert

Sepi
Class Tree
Index
Previous
Next (Destination)


Sepi

Sepi
Previous (AutoConvert)
Next (Source)

Name
Destination

Parent
TSepiAssignment

Visibility
PUBLIC

Description
Destination de l'assignation

Source code
property Destination : ISepiWritableValue read FDestination write FDestination

Read Access
FDestination

Write Access
FDestination

Sepi
Class Tree
Index
Previous (AutoConvert)
Next (Source)


Sepi

Sepi
Previous (Destination)
Next

Name
Source

Parent
TSepiAssignment

Visibility
PUBLIC

Description
Source de l'assignation

Source code
property Source : ISepiReadableValue read FSource write FSource

Read Access
FSource

Write Access
FSource

Sepi
Class Tree
Index
Previous (Destination)
Next


Sepi

Sepi
Previous
Next (CustomCompile)

Name
Create

Parent
TSepiAssignment

Visibility
PUBLIC

Description
Crée une instruction d'assignation :=

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AAutoConvert : Boolean = True )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AAutoConvert : BOOLEAN | Autorise les conversions automatiques (défaut = True)

Sepi
Class Tree
Index
Previous
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next

Name
CustomCompile

Parent
TSepiAssignment

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiAssignment)
Next (TSepiCaseOf)

Name
TSepiBreak

Parent
SepiInstructions

Class Hierarchy
TSepiSpecialJump

Visibility
PUBLIC

Description
Instruction break

Members
Methods
Method | Description
CustomCompile (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAssignment)
Next (TSepiCaseOf)


Sepi

Sepi
Previous
Next

Name
CustomCompile

Parent
TSepiBreak

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiBreak)
Next (TSepiCaseOfClause)

Name
TSepiCaseOf

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction case of

Members
Fields
Field | Description
FClauses (-) | Clauses de test
FElseInstructions (-) | Instructions dans le else
FTestValue (-) | Valeur à tester

Methods
Method | Description
AddClause (+) | Ajoute une clause
Create (+) | Crée une instruction case of
CustomCompile (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
GetClauseCount (-) | Nombre de clauses
GetClauses (-) | Tableau zero-based des clauses
ReadTestValue (-) | Lit la valeur de test

Properties
Property | Description
ClauseCount (+) | Nombre de clauses
Clauses (+) | Tableau zero-based des clauses
ElseInstructions (+) | Instructions dans le else
TestValue (+) | Valeur à tester

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBreak)
Next (TSepiCaseOfClause)


Sepi

Sepi
Previous
Next (FElseInstructions)

Name
FClauses

Parent
TSepiCaseOf

Visibility
PRIVATE

Description
Clauses de test

Source code
FClauses : TObjectList

Sepi
Class Tree
Index
Previous
Next (FElseInstructions)


Sepi

Sepi
Previous (FClauses)
Next (FTestValue)

Name
FElseInstructions

Parent
TSepiCaseOf

Visibility
PRIVATE

Description
Instructions dans le else

Source code
FElseInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous (FClauses)
Next (FTestValue)


Sepi

Sepi
Previous (FElseInstructions)
Next

Name
FTestValue

Parent
TSepiCaseOf

Visibility
PRIVATE

Description
Valeur à tester

Source code
FTestValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FElseInstructions)
Next


Sepi

Sepi
Previous
Next (Clauses)

Name
ClauseCount

Parent
TSepiCaseOf

Visibility
PUBLIC

Description
Nombre de clauses

Source code
property ClauseCount : Integer read GetClauseCount

Read Access
GetClauseCount

Sepi
Class Tree
Index
Previous
Next (Clauses)


Sepi

Sepi
Previous (ClauseCount)
Next (ElseInstructions)

Name
Clauses

Parent
TSepiCaseOf

Visibility
PUBLIC

Description
Tableau zero-based des clauses

Source code
property Clauses [ Index : Integer ] : TSepiCaseOfClause read GetClauses

Read Access
GetClauses

Sepi
Class Tree
Index
Previous (ClauseCount)
Next (ElseInstructions)


Sepi

Sepi
Previous (Clauses)
Next (TestValue)

Name
ElseInstructions

Parent
TSepiCaseOf

Visibility
PUBLIC

Description
Instructions dans le else

Source code
property ElseInstructions : TSepiInstructionList read FElseInstructions

Read Access
FElseInstructions

Sepi
Class Tree
Index
Previous (Clauses)
Next (TestValue)


Sepi

Sepi
Previous (ElseInstructions)
Next

Name
TestValue

Parent
TSepiCaseOf

Visibility
PUBLIC

Description
Valeur à tester

Source code
property TestValue : ISepiReadableValue read FTestValue write FTestValue

Read Access
FTestValue

Write Access
FTestValue

Sepi
Class Tree
Index
Previous (ElseInstructions)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AddClause

Parent
TSepiCaseOf

Visibility
PUBLIC

Description
Ajoute une clause

Source code
function AddClause : TSepiCaseOfClause

Parameters
Parameter Description

Return
Types | Description
TSepiCaseOfClause | Clause ajoutée

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AddClause)
Next (CustomCompile)

Name
Create

Parent
TSepiCaseOf

Visibility
PUBLIC

Description
Crée une instruction case of

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (AddClause)
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CustomCompile

Parent
TSepiCaseOf

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CustomCompile)
Next (GetClauseCount)

Name
Destroy

Parent
TSepiCaseOf

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CustomCompile)
Next (GetClauseCount)


Sepi

Sepi
Previous (Destroy)
Next (GetClauses)

Name
GetClauseCount

Parent
TSepiCaseOf

Visibility
PRIVATE

Description
Nombre de clauses

Source code
function GetClauseCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de clauses

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetClauses)


Sepi

Sepi
Previous (GetClauseCount)
Next (ReadTestValue)

Name
GetClauses

Parent
TSepiCaseOf

Visibility
PRIVATE

Description
Tableau zero-based des clauses

Source code
function GetClauses ( Index : Integer ) : TSepiCaseOfClause

Parameters
Parameter | Description
INDEX : INTEGER | Index compris entre 0 inclus et ClauseCount exclus

Return
Types | Description
TSepiCaseOfClause | Clause à l'index spécifié

Sepi
Class Tree
Index
Previous (GetClauseCount)
Next (ReadTestValue)


Sepi

Sepi
Previous (GetClauses)
Next

Name
ReadTestValue

Parent
TSepiCaseOf

Visibility
PRIVATE

Description
Lit la valeur de test

Source code
procedure ReadTestValue ( out TestValueVar : TSepiLocalVar )

Parameters
Parameter | Description
TestValueVar : TSepiLocalVar | En sortie : variable stockant la valeur de test

Sepi
Class Tree
Index
Previous (GetClauses)
Next


Sepi

Sepi
Previous (TSepiCaseOf)
Next (TSepiContinue)

Name
TSepiCaseOfClause

Parent
SepiInstructions

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Clause d'un case of

Members
Fields
Field | Description
FInstructions (-) | Instructions de cette clause
FValue (-) | Valeur associée à cette clause

Methods
Method | Description
Create (+) | Crée une clause de case of

Properties
Property | Description
Instructions (+) | Instructions de cette clause
Value (+) | Valeur associée à cette clause

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCaseOf)
Next (TSepiContinue)


Sepi

Sepi
Previous
Next (FValue)

Name
FInstructions

Parent
TSepiCaseOfClause

Visibility
PRIVATE

Description
Instructions de cette clause

Source code
FInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next (FValue)


Sepi

Sepi
Previous (FInstructions)
Next

Name
FValue

Parent
TSepiCaseOfClause

Visibility
PRIVATE

Description
Valeur associée à cette clause

Source code
FValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FInstructions)
Next


Sepi

Sepi
Previous
Next (Value)

Name
Instructions

Parent
TSepiCaseOfClause

Visibility
PUBLIC

Description
Instructions de cette clause

Source code
property Instructions : TSepiInstructionList read FInstructions

Read Access
FInstructions

Sepi
Class Tree
Index
Previous
Next (Value)


Sepi

Sepi
Previous (Instructions)
Next

Name
Value

Parent
TSepiCaseOfClause

Visibility
PUBLIC

Description
Valeur associée à cette clause

Source code
property Value : ISepiReadableValue read FValue write FValue

Read Access
FValue

Write Access
FValue

Sepi
Class Tree
Index
Previous (Instructions)
Next


Sepi

Sepi
Previous
Next

Name
Create

Parent
TSepiCaseOfClause

Visibility
PUBLIC

Description
Crée une clause de case of

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiCaseOfClause)
Next (TSepiExecuteExpression)

Name
TSepiContinue

Parent
SepiInstructions

Class Hierarchy
TSepiSpecialJump

Visibility
PUBLIC

Description
Instruction continue

Members
Methods
Method | Description
CustomCompile (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCaseOfClause)
Next (TSepiExecuteExpression)


Sepi

Sepi
Previous
Next

Name
CustomCompile

Parent
TSepiContinue

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiContinue)
Next (TSepiExit)

Name
TSepiExecuteExpression

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction d'exécution d'une expression (exécutable)

Members
Fields
Field | Description
FExecutable (-) | Invocable

Methods
Method | Description
CustomCompile (#) | [@inheritDoc]

Properties
Property | Description
Executable (+) | Invocable

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiContinue)
Next (TSepiExit)


Sepi

Sepi
Previous
Next

Name
FExecutable

Parent
TSepiExecuteExpression

Visibility
PRIVATE

Description
Invocable

Source code
FExecutable : ISepiExecutable

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Executable

Parent
TSepiExecuteExpression

Visibility
PUBLIC

Description
Invocable

Source code
property Executable : ISepiExecutable read FExecutable write FExecutable

Read Access
FExecutable

Write Access
FExecutable

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CustomCompile

Parent
TSepiExecuteExpression

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiExecuteExpression)
Next (TSepiFor)

Name
TSepiExit

Parent
SepiInstructions

Class Hierarchy
TSepiSpecialJump

Visibility
PUBLIC

Description
Instruction exit

Members
Methods
Method | Description
CustomCompile (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExecuteExpression)
Next (TSepiFor)


Sepi

Sepi
Previous
Next

Name
CustomCompile

Parent
TSepiExit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiExit)
Next (TSepiIfThenElse)

Name
TSepiFor

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction for..do
Il s'agit bien ici d'une instruction for..do à la Delphi. Avec une variable,
une borne de départ et d'arrivée, qui sont évaluées une seule fois avant la
boucle. Pour compiler des boucles for à la C, utilisez plutôt TSepiWhile.

Members
Fields
Field | Description
FAutoConvert (-) | Autorise les conversions automatiques
FControlVar (-) | Variable de contrôle
FEndValue (-) | Valeur de fin du for
FIsDownTo (-) | True pour un downto
FLoopInstructions (-) | Instructions dans la boucle
FStartValue (-) | Valeur de départ du for

Methods
Method | Description
CheckValues (-) | Vérifie les valeurs
CompileReadBounds (-) | Compile les instructions de lecture des bornes
Create (+) | Crée une instruction for..do
CustomCompile (#) | [@inheritDoc]
UseTempVar (+) | Utilise une variable temporaire comme variable de contrôle

Properties
Property | Description
AutoConvert (+) | Autorise les conversions automatiques
ControlVar (+) | Variable de contrôle
EndValue (+) | Valeur de fin du for
IsDownTo (+) | True pour un downto
LoopInstructions (+) | Instructions dans la boucle
StartValue (+) | Valeur de départ du for

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExit)
Next (TSepiIfThenElse)


Sepi

Sepi
Previous
Next (FControlVar)

Name
FAutoConvert

Parent
TSepiFor

Visibility
PRIVATE

Description
Autorise les conversions automatiques

Source code
FAutoConvert : Boolean

Sepi
Class Tree
Index
Previous
Next (FControlVar)


Sepi

Sepi
Previous (FAutoConvert)
Next (FEndValue)

Name
FControlVar

Parent
TSepiFor

Visibility
PRIVATE

Description
Variable de contrôle

Source code
FControlVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous (FAutoConvert)
Next (FEndValue)


Sepi

Sepi
Previous (FControlVar)
Next (FIsDownTo)

Name
FEndValue

Parent
TSepiFor

Visibility
PRIVATE

Description
Valeur de fin du for

Source code
FEndValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FControlVar)
Next (FIsDownTo)


Sepi

Sepi
Previous (FEndValue)
Next (FLoopInstructions)

Name
FIsDownTo

Parent
TSepiFor

Visibility
PRIVATE

Description
True pour un downto

Source code
FIsDownTo : Boolean

Sepi
Class Tree
Index
Previous (FEndValue)
Next (FLoopInstructions)


Sepi

Sepi
Previous (FIsDownTo)
Next (FStartValue)

Name
FLoopInstructions

Parent
TSepiFor

Visibility
PRIVATE

Description
Instructions dans la boucle

Source code
FLoopInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous (FIsDownTo)
Next (FStartValue)


Sepi

Sepi
Previous (FLoopInstructions)
Next

Name
FStartValue

Parent
TSepiFor

Visibility
PRIVATE

Description
Valeur de départ du for

Source code
FStartValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FLoopInstructions)
Next


Sepi

Sepi
Previous
Next (ControlVar)

Name
AutoConvert

Parent
TSepiFor

Visibility
PUBLIC

Description
Autorise les conversions automatiques

Source code
property AutoConvert : Boolean read FAutoConvert write FAutoConvert

Read Access
FAutoConvert

Write Access
FAutoConvert

Sepi
Class Tree
Index
Previous
Next (ControlVar)


Sepi

Sepi
Previous (AutoConvert)
Next (EndValue)

Name
ControlVar

Parent
TSepiFor

Visibility
PUBLIC

Description
Variable de contrôle

Source code
property ControlVar : TSepiLocalVar read FControlVar write FControlVar

Read Access
FControlVar

Write Access
FControlVar

Sepi
Class Tree
Index
Previous (AutoConvert)
Next (EndValue)


Sepi

Sepi
Previous (ControlVar)
Next (IsDownTo)

Name
EndValue

Parent
TSepiFor

Visibility
PUBLIC

Description
Valeur de fin du for

Source code
property EndValue : ISepiReadableValue read FEndValue write FEndValue

Read Access
FEndValue

Write Access
FEndValue

Sepi
Class Tree
Index
Previous (ControlVar)
Next (IsDownTo)


Sepi

Sepi
Previous (EndValue)
Next (LoopInstructions)

Name
IsDownTo

Parent
TSepiFor

Visibility
PUBLIC

Description
True pour un downto

Source code
property IsDownTo : Boolean read FIsDownTo write FIsDownTo

Read Access
FIsDownTo

Write Access
FIsDownTo

Sepi
Class Tree
Index
Previous (EndValue)
Next (LoopInstructions)


Sepi

Sepi
Previous (IsDownTo)
Next (StartValue)

Name
LoopInstructions

Parent
TSepiFor

Visibility
PUBLIC

Description
Instructions dans la boucle

Source code
property LoopInstructions : TSepiInstructionList read FLoopInstructions

Read Access
FLoopInstructions

Sepi
Class Tree
Index
Previous (IsDownTo)
Next (StartValue)


Sepi

Sepi
Previous (LoopInstructions)
Next

Name
StartValue

Parent
TSepiFor

Visibility
PUBLIC

Description
Valeur de départ du for

Source code
property StartValue : ISepiReadableValue read FStartValue write FStartValue

Read Access
FStartValue

Write Access
FStartValue

Sepi
Class Tree
Index
Previous (LoopInstructions)
Next


Sepi

Sepi
Previous
Next (CompileReadBounds)

Name
CheckValues

Parent
TSepiFor

Visibility
PRIVATE

Description
Vérifie les valeurs

Source code
function CheckValues : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompileReadBounds)


Sepi

Sepi
Previous (CheckValues)
Next (Create)

Name
CompileReadBounds

Parent
TSepiFor

Visibility
PRIVATE

Description
Compile les instructions de lecture des bornes

Source code
procedure CompileReadBounds ( out HigherBoundVar : TSepiLocalVar )

Parameters
Parameter | Description
HigherBoundVar : TSepiLocalVar | En sortie : variable locale de borne supérieure

Sepi
Class Tree
Index
Previous (CheckValues)
Next (Create)


Sepi

Sepi
Previous (CompileReadBounds)
Next (CustomCompile)

Name
Create

Parent
TSepiFor

Visibility
PUBLIC

Description
Crée une instruction for..do

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; AAutoConvert : Boolean = True )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
AAutoConvert : BOOLEAN | Autorise les conversions automatiques (défaut = True)

Sepi
Class Tree
Index
Previous (CompileReadBounds)
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next (UseTempVar)

Name
CustomCompile

Parent
TSepiFor

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (UseTempVar)


Sepi

Sepi
Previous (CustomCompile)
Next

Name
UseTempVar

Parent
TSepiFor

Visibility
PUBLIC

Description
Utilise une variable temporaire comme variable de contrôle

Source code
function UseTempVar ( AType : TSepiOrdType ) : TSepiLocalVar

Parameters
Parameter | Description
AType : TSepiOrdType | Type de la variable temporaire de contrôle

Return
Types | Description
TSepiLocalVar | Variable temporaire créée (= ControlVar)

Sepi
Class Tree
Index
Previous (CustomCompile)
Next


Sepi

Sepi
Previous (TSepiFor)
Next (TSepiMultiOn)

Name
TSepiIfThenElse

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction if..then..else

Members
Fields
Field | Description
FFalseInstructions (-) | Instructions si False
FTestValue (-) | Valeur de test du if
FTrueInstructions (-) | Instructions si True

Methods
Method | Description
Create (+) | Crée une instruction if..then.else
CustomCompile (#) | [@inheritDoc]

Properties
Property | Description
FalseInstructions (+) | Instructions si False
TestValue (+) | Valeur de test du if
TrueInstructions (+) | Instructions si True

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFor)
Next (TSepiMultiOn)


Sepi

Sepi
Previous
Next (FTestValue)

Name
FFalseInstructions

Parent
TSepiIfThenElse

Visibility
PRIVATE

Description
Instructions si False

Source code
FFalseInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next (FTestValue)


Sepi

Sepi
Previous (FFalseInstructions)
Next (FTrueInstructions)

Name
FTestValue

Parent
TSepiIfThenElse

Visibility
PRIVATE

Description
Valeur de test du if

Source code
FTestValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FFalseInstructions)
Next (FTrueInstructions)


Sepi

Sepi
Previous (FTestValue)
Next

Name
FTrueInstructions

Parent
TSepiIfThenElse

Visibility
PRIVATE

Description
Instructions si True

Source code
FTrueInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous (FTestValue)
Next


Sepi

Sepi
Previous
Next (TestValue)

Name
FalseInstructions

Parent
TSepiIfThenElse

Visibility
PUBLIC

Description
Instructions si False

Source code
property FalseInstructions : TSepiInstructionList read FFalseInstructions

Read Access
FFalseInstructions

Sepi
Class Tree
Index
Previous
Next (TestValue)


Sepi

Sepi
Previous (FalseInstructions)
Next (TrueInstructions)

Name
TestValue

Parent
TSepiIfThenElse

Visibility
PUBLIC

Description
Valeur de test du if

Source code
property TestValue : ISepiReadableValue read FTestValue write FTestValue

Read Access
FTestValue

Write Access
FTestValue

Sepi
Class Tree
Index
Previous (FalseInstructions)
Next (TrueInstructions)


Sepi

Sepi
Previous (TestValue)
Next

Name
TrueInstructions

Parent
TSepiIfThenElse

Visibility
PUBLIC

Description
Instructions si True

Source code
property TrueInstructions : TSepiInstructionList read FTrueInstructions

Read Access
FTrueInstructions

Sepi
Class Tree
Index
Previous (TestValue)
Next


Sepi

Sepi
Previous
Next (CustomCompile)

Name
Create

Parent
TSepiIfThenElse

Visibility
PUBLIC

Description
Crée une instruction if..then.else

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next

Name
CustomCompile

Parent
TSepiIfThenElse

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiIfThenElse)
Next (TSepiRaise)

Name
TSepiMultiOn

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction multi-on

Members
Fields
Field | Description
FElseInstructions (-) | Instructions dans le else
FExceptObjectVar (-) | Variable de l'objet exception
FOnClauses (-) | Clauses on

Methods
Method | Description
AddOnClause (+) | Ajoute une clause on
Create (+) | Crée une instruction multi-on
CustomCompile (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]

Properties
Property | Description
ElseInstructions (+) | Instructions dans le else
ExceptObjectVar (+) | Variable de l'objet exception

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIfThenElse)
Next (TSepiRaise)


Sepi

Sepi
Previous
Next (FExceptObjectVar)

Name
FElseInstructions

Parent
TSepiMultiOn

Visibility
PRIVATE

Description
Instructions dans le else

Source code
FElseInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next (FExceptObjectVar)


Sepi

Sepi
Previous (FElseInstructions)
Next (FOnClauses)

Name
FExceptObjectVar

Parent
TSepiMultiOn

Visibility
PRIVATE

Description
Variable de l'objet exception

Source code
FExceptObjectVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous (FElseInstructions)
Next (FOnClauses)


Sepi

Sepi
Previous (FExceptObjectVar)
Next

Name
FOnClauses

Parent
TSepiMultiOn

Visibility
PRIVATE

Description
Clauses on

Source code
FOnClauses : TObjectList

Sepi
Class Tree
Index
Previous (FExceptObjectVar)
Next


Sepi

Sepi
Previous
Next (ExceptObjectVar)

Name
ElseInstructions

Parent
TSepiMultiOn

Visibility
PUBLIC

Description
Instructions dans le else

Source code
property ElseInstructions : TSepiInstructionList read FElseInstructions

Read Access
FElseInstructions

Sepi
Class Tree
Index
Previous
Next (ExceptObjectVar)


Sepi

Sepi
Previous (ElseInstructions)
Next

Name
ExceptObjectVar

Parent
TSepiMultiOn

Visibility
PUBLIC

Description
Variable de l'objet exception

Source code
property ExceptObjectVar : TSepiLocalVar read FExceptObjectVar write FExceptObjectVar

Read Access
FExceptObjectVar

Write Access
FExceptObjectVar

Sepi
Class Tree
Index
Previous (ElseInstructions)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AddOnClause

Parent
TSepiMultiOn

Visibility
PUBLIC

Description
Ajoute une clause on

Source code
function AddOnClause ( AExceptionClass : TSepiClass ) : TSepiInstructionList

Parameters
Parameter | Description
AExceptionClass : TSepiClass | Classe d'exception à tester

Return
Types | Description
TSepiInstructionList | Liste d'instructions pour cette classe d'exception

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AddOnClause)
Next (CustomCompile)

Name
Create

Parent
TSepiMultiOn

Visibility
PUBLIC

Description
Crée une instruction multi-on

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous (AddOnClause)
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CustomCompile

Parent
TSepiMultiOn

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CustomCompile)
Next

Name
Destroy

Parent
TSepiMultiOn

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CustomCompile)
Next


Sepi

Sepi
Previous (TSepiMultiOn)
Next (TSepiReraise)

Name
TSepiRaise

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction raise

Members
Fields
Field | Description
FExceptionValue (-) | Valeur exception

Methods
Method | Description
CustomCompile (#) | [@inheritDoc]

Properties
Property | Description
ExceptionValue (+) | Valeur exception

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMultiOn)
Next (TSepiReraise)


Sepi

Sepi
Previous
Next

Name
FExceptionValue

Parent
TSepiRaise

Visibility
PRIVATE

Description
Valeur exception

Source code
FExceptionValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
ExceptionValue

Parent
TSepiRaise

Visibility
PUBLIC

Description
Valeur exception

Source code
property ExceptionValue : ISepiReadableValue read FExceptionValue write FExceptionValue

Read Access
FExceptionValue

Write Access
FExceptionValue

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CustomCompile

Parent
TSepiRaise

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiRaise)
Next (TSepiSpecialJump)

Name
TSepiReraise

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction reraise

Members
Methods
Method | Description
CustomCompile (#) | Compile l'instruction

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRaise)
Next (TSepiSpecialJump)


Sepi

Sepi
Previous
Next

Name
CustomCompile

Parent
TSepiReraise

Visibility
PROTECTED

Description
Compile l'instruction
Cette méthode doit être surchargée par toutes les instructions afin de se
compiler. La compilation fera intervenir la création d'instructions assembleur
et leur compilation, en fin de récursion. La compilation des instructions
assembleur est particulière et consiste uniquement à s'ajouter à la liste des
instructions assembleur de la méthode.
Pour compiler les instructions subalternes, appelez Compile et non
CustomCompile. Mais surchargez CustomCompile.

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiReraise)
Next (TSepiTryExcept)

Name
TSepiSpecialJump

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Classe de base pour les instructions de jump spécial

Members
Methods
Method | Description
CompileJump (#) | Compile l'instruction jump

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiReraise)
Next (TSepiTryExcept)


Sepi

Sepi
Previous
Next

Name
CompileJump

Parent
TSepiSpecialJump

Visibility
PROTECTED

Description
Compile l'instruction jump

Source code
procedure CompileJump ( Destination : TSepiInstructionRef )

Parameters
Parameter | Description
Destination : TSepiInstructionRef | Destination du jump

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiSpecialJump)
Next (TSepiTryFinally)

Name
TSepiTryExcept

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction try..except

Members
Fields
Field | Description
FExceptInstructions (-) | Instructions dans le except
FExceptObjectVar (-) | Variable qui stockera l'objet exception
FTryInstructions (-) | Instructions dans le try

Methods
Method | Description
Create (+) | Crée une instruction try..except
CustomCompile (#) | [@inheritDoc]
UseTempVar (+) | Utilise une variable temporaire comme variable pour l'objet exception

Properties
Property | Description
ExceptInstructions (+) | Instructions dans le except
ExceptObjectVar (+) | Variable qui stockera l'objet exception
TryInstructions (+) | Instructions dans le try

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSpecialJump)
Next (TSepiTryFinally)


Sepi

Sepi
Previous
Next (FExceptObjectVar)

Name
FExceptInstructions

Parent
TSepiTryExcept

Visibility
PRIVATE

Description
Instructions dans le except

Source code
FExceptInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next (FExceptObjectVar)


Sepi

Sepi
Previous (FExceptInstructions)
Next (FTryInstructions)

Name
FExceptObjectVar

Parent
TSepiTryExcept

Visibility
PRIVATE

Description
Variable qui stockera l'objet exception

Source code
FExceptObjectVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous (FExceptInstructions)
Next (FTryInstructions)


Sepi

Sepi
Previous (FExceptObjectVar)
Next

Name
FTryInstructions

Parent
TSepiTryExcept

Visibility
PRIVATE

Description
Instructions dans le try

Source code
FTryInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous (FExceptObjectVar)
Next


Sepi

Sepi
Previous
Next (ExceptObjectVar)

Name
ExceptInstructions

Parent
TSepiTryExcept

Visibility
PUBLIC

Description
Instructions dans le except

Source code
property ExceptInstructions : TSepiInstructionList read FExceptInstructions

Read Access
FExceptInstructions

Sepi
Class Tree
Index
Previous
Next (ExceptObjectVar)


Sepi

Sepi
Previous (ExceptInstructions)
Next (TryInstructions)

Name
ExceptObjectVar

Parent
TSepiTryExcept

Visibility
PUBLIC

Description
Variable qui stockera l'objet exception

Source code
property ExceptObjectVar : TSepiLocalVar read FExceptObjectVar write FExceptObjectVar

Read Access
FExceptObjectVar

Write Access
FExceptObjectVar

Sepi
Class Tree
Index
Previous (ExceptInstructions)
Next (TryInstructions)


Sepi

Sepi
Previous (ExceptObjectVar)
Next

Name
TryInstructions

Parent
TSepiTryExcept

Visibility
PUBLIC

Description
Instructions dans le try

Source code
property TryInstructions : TSepiInstructionList read FTryInstructions

Read Access
FTryInstructions

Sepi
Class Tree
Index
Previous (ExceptObjectVar)
Next


Sepi

Sepi
Previous
Next (CustomCompile)

Name
Create

Parent
TSepiTryExcept

Visibility
PUBLIC

Description
Crée une instruction try..except

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next (UseTempVar)

Name
CustomCompile

Parent
TSepiTryExcept

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (UseTempVar)


Sepi

Sepi
Previous (CustomCompile)
Next

Name
UseTempVar

Parent
TSepiTryExcept

Visibility
PUBLIC

Description
Utilise une variable temporaire comme variable pour l'objet exception

Source code
function UseTempVar : TSepiLocalVar

Parameters
Parameter Description

Return
Types | Description
TSepiLocalVar | Variable temporaire créée (= ExceptObjectVar)

Sepi
Class Tree
Index
Previous (CustomCompile)
Next


Sepi

Sepi
Previous (TSepiTryExcept)
Next (TSepiWhile)

Name
TSepiTryFinally

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction try..finally

Members
Fields
Field | Description
FFinallyInstructions (-) | Instructions dans le finally
FTryInstructions (-) | Instructions dans le try

Methods
Method | Description
Create (+) | Crée une instruction try..finally
CustomCompile (#) | [@inheritDoc]

Properties
Property | Description
FinallyInstructions (+) | Instructions dans le finally
TryInstructions (+) | Instructions dans le try

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTryExcept)
Next (TSepiWhile)


Sepi

Sepi
Previous
Next (FTryInstructions)

Name
FFinallyInstructions

Parent
TSepiTryFinally

Visibility
PRIVATE

Description
Instructions dans le finally

Source code
FFinallyInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next (FTryInstructions)


Sepi

Sepi
Previous (FFinallyInstructions)
Next

Name
FTryInstructions

Parent
TSepiTryFinally

Visibility
PRIVATE

Description
Instructions dans le try

Source code
FTryInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous (FFinallyInstructions)
Next


Sepi

Sepi
Previous
Next (TryInstructions)

Name
FinallyInstructions

Parent
TSepiTryFinally

Visibility
PUBLIC

Description
Instructions dans le finally

Source code
property FinallyInstructions : TSepiInstructionList read FFinallyInstructions

Read Access
FFinallyInstructions

Sepi
Class Tree
Index
Previous
Next (TryInstructions)


Sepi

Sepi
Previous (FinallyInstructions)
Next

Name
TryInstructions

Parent
TSepiTryFinally

Visibility
PUBLIC

Description
Instructions dans le try

Source code
property TryInstructions : TSepiInstructionList read FTryInstructions

Read Access
FTryInstructions

Sepi
Class Tree
Index
Previous (FinallyInstructions)
Next


Sepi

Sepi
Previous
Next (CustomCompile)

Name
Create

Parent
TSepiTryFinally

Visibility
PUBLIC

Description
Crée une instruction try..finally

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode

Sepi
Class Tree
Index
Previous
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next

Name
CustomCompile

Parent
TSepiTryFinally

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiTryFinally)
Next

Name
TSepiWhile

Parent
SepiInstructions

Class Hierarchy
TSepiInstruction

Visibility
PUBLIC

Description
Instruction while..do ou do..while
Attention, la version do..while de cette instruction n'est pas un
repeat..until : la boucle est toujours effectuée tant que la condition du
test est *vraie*. Si vous avez besoin d'un repeat..until, encapsulez la
condition du test dans une opération unaire not.

Members
Fields
Field | Description
FLoopInstructions (-) | Instructions dans la boucle
FTestAtEnd (-) | Si True, évalue la condition en fin de boucle (do..while)
FTestValue (-) | Valeur de test du while

Methods
Method | Description
Create (+) | Crée une instruction while..do ou do..while
CustomCompile (#) | [@inheritDoc]

Properties
Property | Description
LoopInstructions (+) | Instructions dans la boucle
TestAtEnd (+) | Si True, évalue la condition en fin de boucle (do..while)
TestValue (+) | Valeur de test du while

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTryFinally)
Next


Sepi

Sepi
Previous
Next (FTestAtEnd)

Name
FLoopInstructions

Parent
TSepiWhile

Visibility
PRIVATE

Description
Instructions dans la boucle

Source code
FLoopInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next (FTestAtEnd)


Sepi

Sepi
Previous (FLoopInstructions)
Next (FTestValue)

Name
FTestAtEnd

Parent
TSepiWhile

Visibility
PRIVATE

Description
Si True, évalue la condition en fin de boucle (do..while)

Source code
FTestAtEnd : Boolean

Sepi
Class Tree
Index
Previous (FLoopInstructions)
Next (FTestValue)


Sepi

Sepi
Previous (FTestAtEnd)
Next

Name
FTestValue

Parent
TSepiWhile

Visibility
PRIVATE

Description
Valeur de test du while

Source code
FTestValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous (FTestAtEnd)
Next


Sepi

Sepi
Previous
Next (TestAtEnd)

Name
LoopInstructions

Parent
TSepiWhile

Visibility
PUBLIC

Description
Instructions dans la boucle

Source code
property LoopInstructions : TSepiInstructionList read FLoopInstructions

Read Access
FLoopInstructions

Sepi
Class Tree
Index
Previous
Next (TestAtEnd)


Sepi

Sepi
Previous (LoopInstructions)
Next (TestValue)

Name
TestAtEnd

Parent
TSepiWhile

Visibility
PUBLIC

Description
Si True, évalue la condition en fin de boucle (do..while)

Source code
property TestAtEnd : Boolean read FTestAtEnd

Read Access
FTestAtEnd

Sepi
Class Tree
Index
Previous (LoopInstructions)
Next (TestValue)


Sepi

Sepi
Previous (TestAtEnd)
Next

Name
TestValue

Parent
TSepiWhile

Visibility
PUBLIC

Description
Valeur de test du while

Source code
property TestValue : ISepiReadableValue read FTestValue write FTestValue

Read Access
FTestValue

Write Access
FTestValue

Sepi
Class Tree
Index
Previous (TestAtEnd)
Next


Sepi

Sepi
Previous
Next (CustomCompile)

Name
Create

Parent
TSepiWhile

Visibility
PUBLIC

Description
Crée une instruction while..do ou do..while

Source code
constructor Create ( AMethodCompiler : TSepiMethodCompiler ; ATestAtEnd : Boolean = False )

Parameters
Parameter | Description
AMethodCompiler : TSepiMethodCompiler | Compilateur de méthode
ATestAtEnd : BOOLEAN | True pour avoir le test à la fin (do..while)

Sepi
Class Tree
Index
Previous
Next (CustomCompile)


Sepi

Sepi
Previous (Create)
Next

Name
CustomCompile

Parent
TSepiWhile

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CustomCompile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous
Next

Name
CompileTestValue

Parent
SepiInstructions

Visibility
PUBLIC

Description
Compile le test d'une valeur booléenne

Source code
procedure CompileTestValue ( Compiler : TSepiMethodCompiler ; TestValue : ISepiReadableValue ; var Destination : TSepiMemoryReference ; out TestIsConst , TestConstValue : Boolean )

Parameters
Parameter | Description
Compiler : TSepiMethodCompiler | Compilateur de méthode
TestValue : ISepiReadableValue | Valeur du test
Destination : TSepiMemoryReference | En entrée et/ou sortie : référence mémoire du résultat
TestIsConst : BOOLEAN | En sortie : True si le teste est une constante
TestConstValue : BOOLEAN | En sortie, si TestIsConst : valeur constante du test

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiInstructions)
Next (SepiLL1Grammars)

Name
SepiLexerUtils

Parent
Sepi

Description
Utilitaires d'analyse lexicale Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TSepiLexerNeedFileEvent (+) | Type d'événement OnNeedFile des analyseurs lexicaux Sepi
TSepiLexingProc (+) | Fonction d'analyse d'un terminal

Constants
Constant | Description
BlankChars (+) | #No TAG found in source code#
tkBlank (+) | Lexème blanc
tkComment (+) | Lexème commentaire
tkEof (+) | Lexème fin de fichier

Classes
Class | Description
ESepiLexicalError (+) | Erreur d'analyse lexicale
TSepiBaseLexer (+) | Classe de base pour les analyseurs lexicaux Sepi de base (non composites)
TSepiBaseLexerBookmark (+) | Bookmark pour TSepiBaseLexer
TSepiCompositeLexerBookmark (+) | Bookmark pour TSepiCustomCompositeLexer
TSepiCustomCompositeLexer (+) | Classe de base pour les analyseurs lexicaux composites
TSepiCustomLexer (+) | Classe de base pour les analyseurs lexicaux Sepi
TSepiCustomManualLexer (+) | Classe de base pour les analyseurs lexicaux Sepi écrits à la main
TSepiLexerBookmark (+) | Marque dans le source - utilisé pour retourner en arrière dans le code

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiInstructions)
Next (SepiLL1Grammars)


Sepi

Sepi
Previous
Next (TSepiBaseLexer)

Name
ESepiLexicalError

Parent
SepiLexerUtils

Class Hierarchy
ESepiError

Visibility
PUBLIC

Description
Erreur d'analyse lexicale

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiBaseLexer)


Sepi

Sepi
Previous (ESepiLexicalError)
Next (TSepiBaseLexerBookmark)

Name
TSepiBaseLexer

Parent
SepiLexerUtils

Class Hierarchy
TSepiCustomLexer

Visibility
PUBLIC

Description
Classe de base pour les analyseurs lexicaux Sepi de base (non composites)

Members
Fields
Field | Description
FCode (-) | Code source à analyser
FCurrentPos (-) | Position courante
FCursor (-) | Index courant dans le source
FCurTerminal (-) | Dernier terminal analysé
FNextPos (-) | Prochaine position

Methods
Method | Description
Create (+) | Crée un analyseur lexical
CursorForward (#) | Avance le curseur
Destroy (+) | [@inheritDoc]
GetCurrentPos (#) | [@inheritDoc]
GetCurTerminal (#) | [@inheritDoc]
IdentifyKeyword (#) | Identifie un mot-clef
MakeBookmark (+) | [@inheritDoc]
ResetToBookmark (+) | [@inheritDoc]
TerminalParsed (#) | Indique qu'un terminal a été analysé

Properties
Property | Description
Code (+) | Code source à analyser
CurrentPos (+) | Position courante
Cursor (+) | Index courant dans le source
CurTerminal (+) | Dernier terminal analysé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiLexicalError)
Next (TSepiBaseLexerBookmark)


Sepi

Sepi
Previous
Next (FCurrentPos)

Name
FCode

Parent
TSepiBaseLexer

Visibility
PRIVATE

Description
Code source à analyser

Source code
FCode : string

Sepi
Class Tree
Index
Previous
Next (FCurrentPos)


Sepi

Sepi
Previous (FCode)
Next (FCursor)

Name
FCurrentPos

Parent
TSepiBaseLexer

Visibility
PRIVATE

Description
Position courante

Source code
FCurrentPos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (FCode)
Next (FCursor)


Sepi

Sepi
Previous (FCurrentPos)
Next (FCurTerminal)

Name
FCursor

Parent
TSepiBaseLexer

Visibility
PRIVATE

Description
Index courant dans le source

Source code
FCursor : Integer

Sepi
Class Tree
Index
Previous (FCurrentPos)
Next (FCurTerminal)


Sepi

Sepi
Previous (FCursor)
Next (FNextPos)

Name
FCurTerminal

Parent
TSepiBaseLexer

Visibility
PRIVATE

Description
Dernier terminal analysé

Source code
FCurTerminal : TSepiTerminal

Sepi
Class Tree
Index
Previous (FCursor)
Next (FNextPos)


Sepi

Sepi
Previous (FCurTerminal)
Next

Name
FNextPos

Parent
TSepiBaseLexer

Visibility
PRIVATE

Description
Prochaine position

Source code
FNextPos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (FCurTerminal)
Next


Sepi

Sepi
Previous
Next (CurrentPos)

Name
Code

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
Code source à analyser

Source code
property Code : string read FCode

Read Access
FCode

Sepi
Class Tree
Index
Previous
Next (CurrentPos)


Sepi

Sepi
Previous (Code)
Next (Cursor)

Name
CurrentPos

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
Position courante

Source code
property CurrentPos : TSepiSourcePosition read FCurrentPos

Read Access
FCurrentPos

Sepi
Class Tree
Index
Previous (Code)
Next (Cursor)


Sepi

Sepi
Previous (CurrentPos)
Next (CurTerminal)

Name
Cursor

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
Index courant dans le source

Source code
property Cursor : Integer read FCursor

Read Access
FCursor

Sepi
Class Tree
Index
Previous (CurrentPos)
Next (CurTerminal)


Sepi

Sepi
Previous (Cursor)
Next

Name
CurTerminal

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
Dernier terminal analysé

Source code
property CurTerminal : TSepiTerminal read FCurTerminal

Read Access
FCurTerminal

Sepi
Class Tree
Index
Previous (Cursor)
Next


Sepi

Sepi
Previous
Next (CursorForward)

Name
Create

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
Crée un analyseur lexical

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; const ACode : string ; const AFileName : TFileName = '' ) ; override

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | Erreurs de compilation
ACode : STRING | Code source à analyser
AFileName : TFileName | Nom du fichier source

Sepi
Class Tree
Index
Previous
Next (CursorForward)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CursorForward

Parent
TSepiBaseLexer

Visibility
PROTECTED

Description
Avance le curseur

Source code
procedure CursorForward ( Amount : Integer = 1 )

Parameters
Parameter | Description
Amount : INTEGER | Nombre de caractères à passer (défaut = 1)

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CursorForward)
Next (GetCurrentPos)

Name
Destroy

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CursorForward)
Next (GetCurrentPos)


Sepi

Sepi
Previous (Destroy)
Next (GetCurTerminal)

Name
GetCurrentPos

Parent
TSepiBaseLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetCurrentPos : TSepiSourcePosition ; override

Parameters
Parameter Description

Return
Types | Description
TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetCurTerminal)


Sepi

Sepi
Previous (GetCurrentPos)
Next (IdentifyKeyword)

Name
GetCurTerminal

Parent
TSepiBaseLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetCurTerminal : TSepiTerminal ; override

Parameters
Parameter Description

Return
Types | Description
TSepiTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCurrentPos)
Next (IdentifyKeyword)


Sepi

Sepi
Previous (GetCurTerminal)
Next (MakeBookmark)

Name
IdentifyKeyword

Parent
TSepiBaseLexer

Visibility
PROTECTED

Description
Identifie un mot-clef

Source code
procedure IdentifyKeyword ( const Key : string ; var SymbolClass : TSepiSymbolClass ) ; virtual

Parameters
Parameter | Description
Key : STRING | Mot-clef éventuel à identifier
SymbolClass : TSepiSymbolClass | À modifier selon la classe du mot-clef

Sepi
Class Tree
Index
Previous (GetCurTerminal)
Next (MakeBookmark)


Sepi

Sepi
Previous (IdentifyKeyword)
Next (ResetToBookmark)

Name
MakeBookmark

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeBookmark : TSepiLexerBookmark ; override

Parameters
Parameter Description

Return
Types | Description
TSepiLexerBookmark | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IdentifyKeyword)
Next (ResetToBookmark)


Sepi

Sepi
Previous (MakeBookmark)
Next (TerminalParsed)

Name
ResetToBookmark

Parent
TSepiBaseLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure ResetToBookmark ( ABookmark : TSepiLexerBookmark ; FreeBookmark : Boolean = True ) ; override

Parameters
Parameter | Description
ABookmark : TSepiLexerBookmark | #Pas de TAG trouvé dans le code source#
FreeBookmark : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeBookmark)
Next (TerminalParsed)


Sepi

Sepi
Previous (ResetToBookmark)
Next

Name
TerminalParsed

Parent
TSepiBaseLexer

Visibility
PROTECTED

Description
Indique qu'un terminal a été analysé

Source code
procedure TerminalParsed ( SymbolClass : TSepiSymbolClass ; const Representation : string )

Parameters
Parameter | Description
SymbolClass : TSepiSymbolClass | Class de symbole
Representation : STRING | Représentation du terminal

Sepi
Class Tree
Index
Previous (ResetToBookmark)
Next


Sepi

Sepi
Previous (TSepiBaseLexer)
Next (TSepiCompositeLexerBookmark)

Name
TSepiBaseLexerBookmark

Parent
SepiLexerUtils

Class Hierarchy
TSepiLexerBookmark

Visibility
PUBLIC

Description
Bookmark pour TSepiBaseLexer

Members
Fields
Field | Description
FCurrentPos (-) | Position courante
FCursor (-) | Index courant dans le source
FCurTerminal (-) | Dernier terminal analysé
FNextPos (-) | Prochaine position

Methods
Method | Description
Create (+) | Crée un marque-page
Destroy (+) | [@inheritDoc]

Properties
Property | Description
CurrentPos (+) | Position courante
Cursor (+) | Index courant dans le source
CurTerminal (+) | Dernier terminal analysé
NextPos (+) | Prochaine position

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBaseLexer)
Next (TSepiCompositeLexerBookmark)


Sepi

Sepi
Previous
Next (FCursor)

Name
FCurrentPos

Parent
TSepiBaseLexerBookmark

Visibility
PRIVATE

Description
Position courante

Source code
FCurrentPos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous
Next (FCursor)


Sepi

Sepi
Previous (FCurrentPos)
Next (FCurTerminal)

Name
FCursor

Parent
TSepiBaseLexerBookmark

Visibility
PRIVATE

Description
Index courant dans le source

Source code
FCursor : Integer

Sepi
Class Tree
Index
Previous (FCurrentPos)
Next (FCurTerminal)


Sepi

Sepi
Previous (FCursor)
Next (FNextPos)

Name
FCurTerminal

Parent
TSepiBaseLexerBookmark

Visibility
PRIVATE

Description
Dernier terminal analysé

Source code
FCurTerminal : TSepiTerminal

Sepi
Class Tree
Index
Previous (FCursor)
Next (FNextPos)


Sepi

Sepi
Previous (FCurTerminal)
Next

Name
FNextPos

Parent
TSepiBaseLexerBookmark

Visibility
PRIVATE

Description
Prochaine position

Source code
FNextPos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (FCurTerminal)
Next


Sepi

Sepi
Previous
Next (Cursor)

Name
CurrentPos

Parent
TSepiBaseLexerBookmark

Visibility
PUBLIC

Description
Position courante

Source code
property CurrentPos : TSepiSourcePosition read FCurrentPos

Read Access
FCurrentPos

Sepi
Class Tree
Index
Previous
Next (Cursor)


Sepi

Sepi
Previous (CurrentPos)
Next (CurTerminal)

Name
Cursor

Parent
TSepiBaseLexerBookmark

Visibility
PUBLIC

Description
Index courant dans le source

Source code
property Cursor : Integer read FCursor

Read Access
FCursor

Sepi
Class Tree
Index
Previous (CurrentPos)
Next (CurTerminal)


Sepi

Sepi
Previous (Cursor)
Next (NextPos)

Name
CurTerminal

Parent
TSepiBaseLexerBookmark

Visibility
PUBLIC

Description
Dernier terminal analysé

Source code
property CurTerminal : TSepiTerminal read FCurTerminal

Read Access
FCurTerminal

Sepi
Class Tree
Index
Previous (Cursor)
Next (NextPos)


Sepi

Sepi
Previous (CurTerminal)
Next

Name
NextPos

Parent
TSepiBaseLexerBookmark

Visibility
PUBLIC

Description
Prochaine position

Source code
property NextPos : TSepiSourcePosition read FNextPos

Read Access
FNextPos

Sepi
Class Tree
Index
Previous (CurTerminal)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiBaseLexerBookmark

Visibility
PUBLIC

Description
Crée un marque-page

Source code
constructor Create ( ACursor : Integer ; const ACurrentPos , ANextPos : TSepiSourcePosition ; ACurTerminal : TSepiTerminal )

Parameters
Parameter | Description
ACursor : INTEGER | Index courant dans le source
ACurrentPos : TSepiSourcePosition | Position courante
ANextPos : TSepiSourcePosition | Prochaine position
ACurTerminal : TSepiTerminal | Dernier terminal analysé

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next

Name
Destroy

Parent
TSepiBaseLexerBookmark

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiBaseLexerBookmark)
Next (TSepiCustomCompositeLexer)

Name
TSepiCompositeLexerBookmark

Parent
SepiLexerUtils

Class Hierarchy
TSepiLexerBookmark

Visibility
PUBLIC

Description
Bookmark pour TSepiCustomCompositeLexer

Members
Fields
Field | Description
FCurLexerBookmark (-) | Bookmark pour l'analyseur courant
FLexerChangeCount (-) | Nombre de changements d'analyseur

Methods
Method | Description
Create (+) | Crée un bookmark
Destroy (+) | [@inheritDoc]

Properties
Property | Description
CurLexerBookmark (+) | Bookmark pour l'analyseur courant
LexerChangeCount (+) | Nombre de changements d'analyseur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBaseLexerBookmark)
Next (TSepiCustomCompositeLexer)


Sepi

Sepi
Previous
Next (FLexerChangeCount)

Name
FCurLexerBookmark

Parent
TSepiCompositeLexerBookmark

Visibility
PRIVATE

Description
Bookmark pour l'analyseur courant

Source code
FCurLexerBookmark : TSepiLexerBookmark

Sepi
Class Tree
Index
Previous
Next (FLexerChangeCount)


Sepi

Sepi
Previous (FCurLexerBookmark)
Next

Name
FLexerChangeCount

Parent
TSepiCompositeLexerBookmark

Visibility
PRIVATE

Description
Nombre de changements d'analyseur

Source code
FLexerChangeCount : Integer

Sepi
Class Tree
Index
Previous (FCurLexerBookmark)
Next


Sepi

Sepi
Previous
Next (LexerChangeCount)

Name
CurLexerBookmark

Parent
TSepiCompositeLexerBookmark

Visibility
PUBLIC

Description
Bookmark pour l'analyseur courant

Source code
property CurLexerBookmark : TSepiLexerBookmark read FCurLexerBookmark

Read Access
FCurLexerBookmark

Sepi
Class Tree
Index
Previous
Next (LexerChangeCount)


Sepi

Sepi
Previous (CurLexerBookmark)
Next

Name
LexerChangeCount

Parent
TSepiCompositeLexerBookmark

Visibility
PUBLIC

Description
Nombre de changements d'analyseur

Source code
property LexerChangeCount : Integer read FLexerChangeCount

Read Access
FLexerChangeCount

Sepi
Class Tree
Index
Previous (CurLexerBookmark)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiCompositeLexerBookmark

Visibility
PUBLIC

Description
Crée un bookmark

Source code
constructor Create ( ALexerChangeCount : Integer ; ACurLexerBookmark : TSepiLexerBookmark )

Parameters
Parameter | Description
ALexerChangeCount : INTEGER | Nombre de changements d'analyseur
ACurLexerBookmark : TSepiLexerBookmark | Bookmark pour l'analyseur courant

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next

Name
Destroy

Parent
TSepiCompositeLexerBookmark

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiCompositeLexerBookmark)
Next (TSepiCustomLexer)

Name
TSepiCustomCompositeLexer

Parent
SepiLexerUtils

Class Hierarchy
TSepiCustomLexer

Visibility
PUBLIC

Description
Classe de base pour les analyseurs lexicaux composites
Un analyseur lexical composite n'analyse pas directement un code source,
mais prend sa source depuis un ou plusieurs autres analyseurs lexicaux, et
transforme leur produit.
Un exemple simple est celui d'un pré-processeur, ou d'un processeur de
directives de compilations comme celui de Delphi.

Members
Fields
Field | Description
FCurLexer (-) | Analyseur courant
FLexerChangeCount (-) | Nombre de changements d'analyseur
FLexerStack (-) | Pile des analyseurs sauvegardés

Methods
Method | Description
Create (+) | [@inheritDoc]
CurLexerChanged (#) | Appelé lorsque l'analyseur courant a été modifié
Destroy (+) | [@inheritDoc]
DoNextTerminal (#) | [@inheritDoc]
EnterFile (#) | Entre dans un nouvel analyseur pour un fichier donné
EnterLexer (#) | Entre dans un nouvel analyseur
GetCurrentPos (#) | [@inheritDoc]
GetCurTerminal (#) | [@inheritDoc]
LeaveCurLexer (#) | Quitte l'analyseur courant
MakeBookmark (+) | [@inheritDoc]
ResetToBookmark (+) | [@inheritDoc]
SetBaseLexer (#) | Renseigne l'analyseur de base
SetContext (#) | [@inheritDoc]

Properties
Property | Description
CurLexer (#) | Analyseur courant

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCompositeLexerBookmark)
Next (TSepiCustomLexer)


Sepi

Sepi
Previous
Next (FLexerChangeCount)

Name
FCurLexer

Parent
TSepiCustomCompositeLexer

Visibility
PRIVATE

Description
Analyseur courant

Source code
FCurLexer : TSepiCustomLexer

Sepi
Class Tree
Index
Previous
Next (FLexerChangeCount)


Sepi

Sepi
Previous (FCurLexer)
Next (FLexerStack)

Name
FLexerChangeCount

Parent
TSepiCustomCompositeLexer

Visibility
PRIVATE

Description
Nombre de changements d'analyseur

Source code
FLexerChangeCount : Integer

Sepi
Class Tree
Index
Previous (FCurLexer)
Next (FLexerStack)


Sepi

Sepi
Previous (FLexerChangeCount)
Next

Name
FLexerStack

Parent
TSepiCustomCompositeLexer

Visibility
PRIVATE

Description
Pile des analyseurs sauvegardés

Source code
FLexerStack : TObjectStack

Sepi
Class Tree
Index
Previous (FLexerChangeCount)
Next


Sepi

Sepi
Previous
Next

Name
CurLexer

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
Analyseur courant

Source code
property CurLexer : TSepiCustomLexer read FCurLexer

Read Access
FCurLexer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CurLexerChanged)

Name
Create

Parent
TSepiCustomCompositeLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; const ACode : string ; const AFileName : TFileName = '' ) ; override

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | #Pas de TAG trouvé dans le code source#
ACode : STRING | #Pas de TAG trouvé dans le code source#
AFileName : TFileName | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CurLexerChanged)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CurLexerChanged

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
Appelé lorsque l'analyseur courant a été modifié

Source code
procedure CurLexerChanged ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CurLexerChanged)
Next (DoNextTerminal)

Name
Destroy

Parent
TSepiCustomCompositeLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CurLexerChanged)
Next (DoNextTerminal)


Sepi

Sepi
Previous (Destroy)
Next (EnterFile)

Name
DoNextTerminal

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure DoNextTerminal ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (EnterFile)


Sepi

Sepi
Previous (DoNextTerminal)
Next (EnterLexer)

Name
EnterFile

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
Entre dans un nouvel analyseur pour un fichier donné
Le type d'analyseur utilisé est le même que celui de l'analyseur courant

Source code
procedure EnterFile ( const FileName : TFileName )

Parameters
Parameter | Description
FileName : TFileName | Nom du fichier a chargé dans le nouvel analyseur

Sepi
Class Tree
Index
Previous (DoNextTerminal)
Next (EnterLexer)


Sepi

Sepi
Previous (EnterFile)
Next (GetCurrentPos)

Name
EnterLexer

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
Entre dans un nouvel analyseur

Source code
procedure EnterLexer ( NewLexer : TSepiCustomLexer )

Parameters
Parameter | Description
NewLexer : TSepiCustomLexer | Nouvel analyseur dans lequel entrer

Sepi
Class Tree
Index
Previous (EnterFile)
Next (GetCurrentPos)


Sepi

Sepi
Previous (EnterLexer)
Next (GetCurTerminal)

Name
GetCurrentPos

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetCurrentPos : TSepiSourcePosition ; override

Parameters
Parameter Description

Return
Types | Description
TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EnterLexer)
Next (GetCurTerminal)


Sepi

Sepi
Previous (GetCurrentPos)
Next (LeaveCurLexer)

Name
GetCurTerminal

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetCurTerminal : TSepiTerminal ; override

Parameters
Parameter Description

Return
Types | Description
TSepiTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCurrentPos)
Next (LeaveCurLexer)


Sepi

Sepi
Previous (GetCurTerminal)
Next (MakeBookmark)

Name
LeaveCurLexer

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
Quitte l'analyseur courant
S'il n'y a plus d'analyseur "en réserve", sur la pile, l'analyseur de base
est amené jusqu'à sa fin de fichier.

Source code
procedure LeaveCurLexer

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetCurTerminal)
Next (MakeBookmark)


Sepi

Sepi
Previous (LeaveCurLexer)
Next (ResetToBookmark)

Name
MakeBookmark

Parent
TSepiCustomCompositeLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeBookmark : TSepiLexerBookmark ; override

Parameters
Parameter Description

Return
Types | Description
TSepiLexerBookmark | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LeaveCurLexer)
Next (ResetToBookmark)


Sepi

Sepi
Previous (MakeBookmark)
Next (SetBaseLexer)

Name
ResetToBookmark

Parent
TSepiCustomCompositeLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure ResetToBookmark ( ABookmark : TSepiLexerBookmark ; FreeBookmark : Boolean = True ) ; override

Parameters
Parameter | Description
ABookmark : TSepiLexerBookmark | #Pas de TAG trouvé dans le code source#
FreeBookmark : BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeBookmark)
Next (SetBaseLexer)


Sepi

Sepi
Previous (ResetToBookmark)
Next (SetContext)

Name
SetBaseLexer

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
Renseigne l'analyseur de base
Cette méthode doit être appelée une et une seule fois dans le constructeur.

Source code
procedure SetBaseLexer ( BaseLexer : TSepiCustomLexer )

Parameters
Parameter | Description
BaseLexer : TSepiCustomLexer | Analyseur de base

Sepi
Class Tree
Index
Previous (ResetToBookmark)
Next (SetContext)


Sepi

Sepi
Previous (SetBaseLexer)
Next

Name
SetContext

Parent
TSepiCustomCompositeLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetContext ( Value : TSepiNonTerminal ) ; override

Parameters
Parameter | Description
Value : TSepiNonTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetBaseLexer)
Next


Sepi

Sepi
Previous (TSepiCustomCompositeLexer)
Next (TSepiCustomManualLexer)

Name
TSepiCustomLexer

Parent
SepiLexerUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe de base pour les analyseurs lexicaux Sepi

Members
Fields
Field | Description
FContext (-) | Contexte courant (peut être nil)
FErrors (-) | Erreurs de compilation
FExcludedTokens (-) | Types de lexèmes à exclure complètement
FOnNeedFile (-) | Événement déclenché lorsque cet analyseur a besoin d'un fichier

Methods
Method | Description
Create (+) | Crée un analyseur lexical
DoNeedFile (#) | Exécuté lorsque cet analyseur a besoin d'un fichier valide
DoNextTerminal (#) | #No TAG found in source code#
FindFile (#) | Trouve un fichier
GetCurrentPos (#) | #No TAG found in source code#
GetCurTerminal (#) | #No TAG found in source code#
GetIsEof (-) | Indique si l'analyseur a atteint la fin du fichier
MakeBookmark (+) | Construit un marque-page à la position courante
MakeError (#) | Produit une erreur
NextTerminal (+) | Passe au lexème suivant
ResetToBookmark (+) | Retourne dans le code source à la position d'un marque-page
SetContext (#) | Modifie le noeud contexte courant
SetExcludedTokens (-) | Modifie les types de lexèmes à exclure complètement

Properties
Property | Description
Context (+) | Contexte courant (peut être nil)
CurrentPos (+) | #No TAG found in source code#
CurTerminal (+) | #No TAG found in source code#
Errors (+) | Erreurs de compilation
ExcludedTokens (+) | Types de lexèmes à exclure complètement
IsEof (+) | Indique si l'analyseur a atteint la fin du fichier
OnNeedFile (+) | Événement déclenché lorsque cet analyseur a besoin d'un fichier

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomCompositeLexer)
Next (TSepiCustomManualLexer)


Sepi

Sepi
Previous
Next (FErrors)

Name
FContext

Parent
TSepiCustomLexer

Visibility
PRIVATE

Description
Contexte courant (peut être nil)

Source code
FContext : TSepiNonTerminal

Sepi
Class Tree
Index
Previous
Next (FErrors)


Sepi

Sepi
Previous (FContext)
Next (FExcludedTokens)

Name
FErrors

Parent
TSepiCustomLexer

Visibility
PRIVATE

Description
Erreurs de compilation

Source code
FErrors : TSepiCompilerErrorList

Sepi
Class Tree
Index
Previous (FContext)
Next (FExcludedTokens)


Sepi

Sepi
Previous (FErrors)
Next (FOnNeedFile)

Name
FExcludedTokens

Parent
TSepiCustomLexer

Visibility
PRIVATE

Description
Types de lexèmes à exclure complètement

Source code
FExcludedTokens : TSysByteSet

Sepi
Class Tree
Index
Previous (FErrors)
Next (FOnNeedFile)


Sepi

Sepi
Previous (FExcludedTokens)
Next

Name
FOnNeedFile

Parent
TSepiCustomLexer

Visibility
PRIVATE

Description
Événement déclenché lorsque cet analyseur a besoin d'un fichier

Source code
FOnNeedFile : TSepiLexerNeedFileEvent

Sepi
Class Tree
Index
Previous (FExcludedTokens)
Next


Sepi

Sepi
Previous
Next (CurrentPos)

Name
Context

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Contexte courant (peut être nil)

Source code
property Context : TSepiNonTerminal read FContext write SetContext

Read Access
FContext

Write Access
SetContext

Sepi
Class Tree
Index
Previous
Next (CurrentPos)


Sepi

Sepi
Previous (Context)
Next (CurTerminal)

Name
CurrentPos

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property CurrentPos : TSepiSourcePosition read GetCurrentPos

Read Access
GetCurrentPos

Sepi
Class Tree
Index
Previous (Context)
Next (CurTerminal)


Sepi

Sepi
Previous (CurrentPos)
Next (Errors)

Name
CurTerminal

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property CurTerminal : TSepiTerminal read GetCurTerminal

Read Access
GetCurTerminal

Sepi
Class Tree
Index
Previous (CurrentPos)
Next (Errors)


Sepi

Sepi
Previous (CurTerminal)
Next (ExcludedTokens)

Name
Errors

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Erreurs de compilation

Source code
property Errors : TSepiCompilerErrorList read FErrors

Read Access
FErrors

Sepi
Class Tree
Index
Previous (CurTerminal)
Next (ExcludedTokens)


Sepi

Sepi
Previous (Errors)
Next (IsEof)

Name
ExcludedTokens

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Types de lexèmes à exclure complètement

Source code
property ExcludedTokens : TSysByteSet read FExcludedTokens write SetExcludedTokens

Read Access
FExcludedTokens

Write Access
SetExcludedTokens

Sepi
Class Tree
Index
Previous (Errors)
Next (IsEof)


Sepi

Sepi
Previous (ExcludedTokens)
Next (OnNeedFile)

Name
IsEof

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Indique si l'analyseur a atteint la fin du fichier

Source code
property IsEof : Boolean read GetIsEof

Read Access
GetIsEof

Sepi
Class Tree
Index
Previous (ExcludedTokens)
Next (OnNeedFile)


Sepi

Sepi
Previous (IsEof)
Next

Name
OnNeedFile

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Événement déclenché lorsque cet analyseur a besoin d'un fichier

Source code
property OnNeedFile : TSepiLexerNeedFileEvent read FOnNeedFile write FOnNeedFile

Read Access
FOnNeedFile

Write Access
FOnNeedFile

Sepi
Class Tree
Index
Previous (IsEof)
Next


Sepi

Sepi
Previous
Next (DoNeedFile)

Name
Create

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Crée un analyseur lexical

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; const ACode : string ; const AFileName : TFileName = '' ) ; virtual

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | Erreurs de compilation
ACode : STRING | Code source à analyser
AFileName : TFileName | Nom du fichier source

Sepi
Class Tree
Index
Previous
Next (DoNeedFile)


Sepi

Sepi
Previous (Create)
Next (DoNextTerminal)

Name
DoNeedFile

Parent
TSepiCustomLexer

Visibility
PROTECTED

Description
Exécuté lorsque cet analyseur a besoin d'un fichier valide

Source code
procedure DoNeedFile ( var FileName : TFileName ) ; virtual

Parameters
Parameter | Description
FileName : TFileName | Nom de fichier recherché

Sepi
Class Tree
Index
Previous (Create)
Next (DoNextTerminal)


Sepi

Sepi
Previous (DoNeedFile)
Next (FindFile)

Name
DoNextTerminal

Parent
TSepiCustomLexer

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure DoNextTerminal ; virtual ; abstract

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DoNeedFile)
Next (FindFile)


Sepi

Sepi
Previous (DoNextTerminal)
Next (GetCurrentPos)

Name
FindFile

Parent
TSepiCustomLexer

Visibility
PROTECTED

Description
Trouve un fichier

Exception
ESepiCompilerFatalError Le fichier n'a pas été trouvé

Source code
function FindFile ( const FileName : TFileName ) : TFileName

Parameters
Parameter | Description
FileName : TFileName | Nom de fichier recherché au départ

Return
Types | Description
TFileName | Nom de fichier complet valide

Sepi
Class Tree
Index
Previous (DoNextTerminal)
Next (GetCurrentPos)


Sepi

Sepi
Previous (FindFile)
Next (GetCurTerminal)

Name
GetCurrentPos

Parent
TSepiCustomLexer

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetCurrentPos : TSepiSourcePosition ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FindFile)
Next (GetCurTerminal)


Sepi

Sepi
Previous (GetCurrentPos)
Next (GetIsEof)

Name
GetCurTerminal

Parent
TSepiCustomLexer

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetCurTerminal : TSepiTerminal ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
TSepiTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetCurrentPos)
Next (GetIsEof)


Sepi

Sepi
Previous (GetCurTerminal)
Next (MakeBookmark)

Name
GetIsEof

Parent
TSepiCustomLexer

Visibility
PRIVATE

Description
Indique si l'analyseur a atteint la fin du fichier

Source code
function GetIsEof : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si la fin de fichier a été atteinte, False sinon

Sepi
Class Tree
Index
Previous (GetCurTerminal)
Next (MakeBookmark)


Sepi

Sepi
Previous (GetIsEof)
Next (MakeError)

Name
MakeBookmark

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Construit un marque-page à la position courante

Source code
function MakeBookmark : TSepiLexerBookmark ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiLexerBookmark | Le marque-page construit

Sepi
Class Tree
Index
Previous (GetIsEof)
Next (MakeError)


Sepi

Sepi
Previous (MakeBookmark)
Next (NextTerminal)

Name
MakeError

Parent
TSepiCustomLexer

Visibility
PROTECTED

Description
Produit une erreur

Source code
procedure MakeError ( const ErrorMsg : string ; Kind : TSepiErrorKind = ekError )

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Kind : TSepiErrorKind | Type d'erreur (défaut = Erreur)

Sepi
Class Tree
Index
Previous (MakeBookmark)
Next (NextTerminal)


Sepi

Sepi
Previous (MakeError)
Next (ResetToBookmark)

Name
NextTerminal

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Passe au lexème suivant

Source code
procedure NextTerminal

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeError)
Next (ResetToBookmark)


Sepi

Sepi
Previous (NextTerminal)
Next (SetContext)

Name
ResetToBookmark

Parent
TSepiCustomLexer

Visibility
PUBLIC

Description
Retourne dans le code source à la position d'un marque-page

Source code
procedure ResetToBookmark ( Bookmark : TSepiLexerBookmark ; FreeBookmark : Boolean = True ) ; virtual

Parameters
Parameter | Description
Bookmark : TSepiLexerBookmark | Marque-page
FreeBookmark : BOOLEAN | Si True, le marque-page est ensuite détruit

Sepi
Class Tree
Index
Previous (NextTerminal)
Next (SetContext)


Sepi

Sepi
Previous (ResetToBookmark)
Next (SetExcludedTokens)

Name
SetContext

Parent
TSepiCustomLexer

Visibility
PROTECTED

Description
Modifie le noeud contexte courant

Source code
procedure SetContext ( Value : TSepiNonTerminal ) ; virtual

Parameters
Parameter | Description
Value : TSepiNonTerminal | Nouveau noeud contexte

Sepi
Class Tree
Index
Previous (ResetToBookmark)
Next (SetExcludedTokens)


Sepi

Sepi
Previous (SetContext)
Next

Name
SetExcludedTokens

Parent
TSepiCustomLexer

Visibility
PRIVATE

Description
Modifie les types de lexèmes à exclure complètement

Source code
procedure SetExcludedTokens ( const Value : TSysByteSet )

Parameters
Parameter | Description
Value : TSysByteSet | Nouvel ensemble de lexèmes à exclure (tkEof non pris en compte)

Sepi
Class Tree
Index
Previous (SetContext)
Next


Sepi

Sepi
Previous (TSepiCustomLexer)
Next (TSepiLexerBookmark)

Name
TSepiCustomManualLexer

Parent
SepiLexerUtils

Class Hierarchy
TSepiBaseLexer

Visibility
PUBLIC

Description
Classe de base pour les analyseurs lexicaux Sepi écrits à la main

Members
Fields
Field | Description
LexingProcs (#) | Tableau des fonctions d'analyse indexé par les caractères de début

Methods
Method | Description
ActionBlank (#) | Analise un blanc
ActionEof (#) | Analise un caractère de fin de fichier
ActionUnknown (#) | Action pour un caractère inconnu - déclenche une erreur lexicale
Create (+) | [@inheritDoc]
DoNextTerminal (#) | [@inheritDoc]
InitLexingProcs (#) | Initialise le tableau LexingProcs

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomLexer)
Next (TSepiLexerBookmark)


Sepi

Sepi
Previous
Next

Name
LexingProcs

Parent
TSepiCustomManualLexer

Visibility
PROTECTED

Description
Tableau des fonctions d'analyse indexé par les caractères de début

Source code
LexingProcs : array [ # 0 .. # 255 ] of TSepiLexingProc

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ActionEof)

Name
ActionBlank

Parent
TSepiCustomManualLexer

Visibility
PROTECTED

Description
Analise un blanc

Source code
procedure ActionBlank

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ActionEof)


Sepi

Sepi
Previous (ActionBlank)
Next (ActionUnknown)

Name
ActionEof

Parent
TSepiCustomManualLexer

Visibility
PROTECTED

Description
Analise un caractère de fin de fichier

Source code
procedure ActionEof

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ActionBlank)
Next (ActionUnknown)


Sepi

Sepi
Previous (ActionEof)
Next (Create)

Name
ActionUnknown

Parent
TSepiCustomManualLexer

Visibility
PROTECTED

Description
Action pour un caractère inconnu - déclenche une erreur lexicale

Source code
procedure ActionUnknown

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ActionEof)
Next (Create)


Sepi

Sepi
Previous (ActionUnknown)
Next (DoNextTerminal)

Name
Create

Parent
TSepiCustomManualLexer

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AErrors : TSepiCompilerErrorList ; const ACode : string ; const AFileName : TFileName = '' ) ; override

Parameters
Parameter | Description
AErrors : TSepiCompilerErrorList | #Pas de TAG trouvé dans le code source#
ACode : STRING | #Pas de TAG trouvé dans le code source#
AFileName : TFileName | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ActionUnknown)
Next (DoNextTerminal)


Sepi

Sepi
Previous (Create)
Next (InitLexingProcs)

Name
DoNextTerminal

Parent
TSepiCustomManualLexer

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure DoNextTerminal ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (InitLexingProcs)


Sepi

Sepi
Previous (DoNextTerminal)
Next

Name
InitLexingProcs

Parent
TSepiCustomManualLexer

Visibility
PROTECTED

Description
Initialise le tableau LexingProcs

Source code
procedure InitLexingProcs ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DoNextTerminal)
Next


Sepi

Sepi
Previous (TSepiCustomManualLexer)
Next

Name
TSepiLexerBookmark

Parent
SepiLexerUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Marque dans le source - utilisé pour retourner en arrière dans le code

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomManualLexer)
Next


Sepi

Sepi
Previous
Next (TSepiLexingProc)

Name
TSepiLexerNeedFileEvent

Parent
SepiLexerUtils

Visibility
PUBLIC

Description
Type d'événement OnNeedFile des analyseurs lexicaux Sepi

Source code
TSepiLexerNeedFileEvent = procedure ( Sender : TSepiCustomLexer ; var FileName : TFileName ) of object ;

Parameters
Parameter | Description
Sender : TSepiCustomLexer | Analyseur lexical qui a déclenché l'événement
FileName : TFileName | Nom de fichier à résoudre

Sepi
Class Tree
Index
Previous
Next (TSepiLexingProc)


Sepi

Sepi
Previous (TSepiLexerNeedFileEvent)
Next

Name
TSepiLexingProc

Parent
SepiLexerUtils

Visibility
PUBLIC

Description
Fonction d'analyse d'un terminal

Source code
TSepiLexingProc = procedure of object ;

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (TSepiLexerNeedFileEvent)
Next


Sepi

Sepi
Previous
Next (tkBlank)

Name
BlankChars

Parent
SepiLexerUtils

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
BlankChars = [ # 9 , # 10 , # 13 , ' ' ]

Sepi
Class Tree
Index
Previous
Next (tkBlank)


Sepi

Sepi
Previous (BlankChars)
Next (tkComment)

Name
tkBlank

Parent
SepiLexerUtils

Visibility
PUBLIC

Description
Lexème blanc

Source code
tkBlank = 1

Sepi
Class Tree
Index
Previous (BlankChars)
Next (tkComment)


Sepi

Sepi
Previous (tkBlank)
Next (tkEof)

Name
tkComment

Parent
SepiLexerUtils

Visibility
PUBLIC

Description
Lexème commentaire

Source code
tkComment = 2

Sepi
Class Tree
Index
Previous (tkBlank)
Next (tkEof)


Sepi

Sepi
Previous (tkComment)
Next

Name
tkEof

Parent
SepiLexerUtils

Visibility
PUBLIC

Description
Lexème fin de fichier

Source code
tkEof = 0

Sepi
Class Tree
Index
Previous (tkComment)
Next


Sepi

Sepi
Previous (SepiLexerUtils)
Next (SepiLL1ParserUtils)

Name
SepiLL1Grammars

Parent
Sepi

Description
#Pas de TAG trouvé dans le code source#

Author
#Pas de TAG trouvé dans le code source#

Version
#Pas de TAG trouvé dans le code source#

Types
Type | Description
TPrivNonTerminalKind (+) | Type de non-terminal priv
TSymbolClass (+) | Classe de symbole

Methods
Method Description

Classes
Class | Description
TChoice (+) | Choix
TChoiceEnd (+) | Fin de choix
TChooseIfSet (+) | Ensemble Choisir-Si
TGrammar (+) | Grammaire
TGramSymbol (+) | Symbole grammatical
TLL1Conflict (+) | Conflit LL(1)
TNonTerminal (+) | Non-terminal
TParsingTable (+) | Table de transition
TPremSet (+) | Ensemble des PREM
TSuivSet (+) | Ensemble des SUIV
TTerminal (+) | Terminal

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiLexerUtils)
Next (SepiLL1ParserUtils)


Sepi

Sepi
Previous
Next (TChoiceEnd)

Name
TChoice

Parent
SepiLL1Grammars

Class Hierarchy
TChoiceEnd

Visibility
PUBLIC

Description
Choix

Members
Fields
Field | Description
FAlternativeChoice (-) | #No TAG found in source code#
FChooseIf (-) | #No TAG found in source code#
FID (-) | #No TAG found in source code#
FIsTry (-) | #No TAG found in source code#
FItemsToRemove (-) | #No TAG found in source code#
FNonTerminals (-) | #No TAG found in source code#
FPriority (-) | #No TAG found in source code#

Methods
Method | Description
AddNonTerminal (-) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
CreateEmpty (+) | #No TAG found in source code#
CreateFromDef (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#
GetChooseIf (-) | #No TAG found in source code#
GetItemsToRemove (-) | #No TAG found in source code#
GetNonTerminalCount (-) | #No TAG found in source code#
GetNonTerminals (-) | #No TAG found in source code#
SetAlternativeChoice (-) | #No TAG found in source code#

Properties
Property | Description
AlternativeChoice (+) | #No TAG found in source code#
ChooseIf (+) | #No TAG found in source code#
ID (+) | #No TAG found in source code#
IsTry (+) | #No TAG found in source code#
ItemsToRemove (+) | #No TAG found in source code#
NonTerminalCount (+) | #No TAG found in source code#
NonTerminals (+) | #No TAG found in source code#
Priority (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TChoiceEnd)


Sepi

Sepi
Previous
Next (FChooseIf)

Name
FAlternativeChoice

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FAlternativeChoice : TChoice

Sepi
Class Tree
Index
Previous
Next (FChooseIf)


Sepi

Sepi
Previous (FAlternativeChoice)
Next (FID)

Name
FChooseIf

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FChooseIf : array of TChooseIfSet

Sepi
Class Tree
Index
Previous (FAlternativeChoice)
Next (FID)


Sepi

Sepi
Previous (FChooseIf)
Next (FIsTry)

Name
FID

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FID : Integer

Sepi
Class Tree
Index
Previous (FChooseIf)
Next (FIsTry)


Sepi

Sepi
Previous (FID)
Next (FItemsToRemove)

Name
FIsTry

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FIsTry : Boolean

Sepi
Class Tree
Index
Previous (FID)
Next (FItemsToRemove)


Sepi

Sepi
Previous (FIsTry)
Next (FNonTerminals)

Name
FItemsToRemove

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FItemsToRemove : array of Boolean

Sepi
Class Tree
Index
Previous (FIsTry)
Next (FNonTerminals)


Sepi

Sepi
Previous (FItemsToRemove)
Next (FPriority)

Name
FNonTerminals

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FNonTerminals : TObjectList

Sepi
Class Tree
Index
Previous (FItemsToRemove)
Next (FPriority)


Sepi

Sepi
Previous (FNonTerminals)
Next

Name
FPriority

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FPriority : Integer

Sepi
Class Tree
Index
Previous (FNonTerminals)
Next


Sepi

Sepi
Previous
Next (ChooseIf)

Name
AlternativeChoice

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property AlternativeChoice : TChoice read FAlternativeChoice

Read Access
FAlternativeChoice

Sepi
Class Tree
Index
Previous
Next (ChooseIf)


Sepi

Sepi
Previous (AlternativeChoice)
Next (ID)

Name
ChooseIf

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ChooseIf [ NT : TNonTerminal ] : TChooseIfSet read GetChooseIf

Read Access
GetChooseIf

Sepi
Class Tree
Index
Previous (AlternativeChoice)
Next (ID)


Sepi

Sepi
Previous (ChooseIf)
Next (IsTry)

Name
ID

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ID : Integer read FID

Read Access
FID

Sepi
Class Tree
Index
Previous (ChooseIf)
Next (IsTry)


Sepi

Sepi
Previous (ID)
Next (ItemsToRemove)

Name
IsTry

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property IsTry : Boolean read FIsTry

Read Access
FIsTry

Sepi
Class Tree
Index
Previous (ID)
Next (ItemsToRemove)


Sepi

Sepi
Previous (IsTry)
Next (NonTerminalCount)

Name
ItemsToRemove

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ItemsToRemove [ Index : Integer ] : Boolean read GetItemsToRemove

Read Access
GetItemsToRemove

Sepi
Class Tree
Index
Previous (IsTry)
Next (NonTerminalCount)


Sepi

Sepi
Previous (ItemsToRemove)
Next (NonTerminals)

Name
NonTerminalCount

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property NonTerminalCount : Integer read GetNonTerminalCount

Read Access
GetNonTerminalCount

Sepi
Class Tree
Index
Previous (ItemsToRemove)
Next (NonTerminals)


Sepi

Sepi
Previous (NonTerminalCount)
Next (Priority)

Name
NonTerminals

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property NonTerminals [ Index : Integer ] : TNonTerminal read GetNonTerminals

Read Access
GetNonTerminals

Sepi
Class Tree
Index
Previous (NonTerminalCount)
Next (Priority)


Sepi

Sepi
Previous (NonTerminals)
Next

Name
Priority

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Priority : Integer read FPriority

Read Access
FPriority

Sepi
Class Tree
Index
Previous (NonTerminals)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AddNonTerminal

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddNonTerminal ( NT : TNonTerminal )

Parameters
Parameter | Description
NT : TNonTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AddNonTerminal)
Next (CreateEmpty)

Name
Create

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddNonTerminal)
Next (CreateEmpty)


Sepi

Sepi
Previous (Create)
Next (CreateFromDef)

Name
CreateEmpty

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateEmpty

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (CreateFromDef)


Sepi

Sepi
Previous (CreateEmpty)
Next (Destroy)

Name
CreateFromDef

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateFromDef ( AID : Integer ; Str : string ; Grammar : TGrammar )

Parameters
Parameter | Description
AID : INTEGER | #Pas de TAG trouvé dans le code source#
Str : STRING | #Pas de TAG trouvé dans le code source#
Grammar : TGrammar | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateEmpty)
Next (Destroy)


Sepi

Sepi
Previous (CreateFromDef)
Next (GetChooseIf)

Name
Destroy

Parent
TChoice

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateFromDef)
Next (GetChooseIf)


Sepi

Sepi
Previous (Destroy)
Next (GetItemsToRemove)

Name
GetChooseIf

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetChooseIf ( NT : TNonTerminal ) : TChooseIfSet

Parameters
Parameter | Description
NT : TNonTerminal | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TChooseIfSet | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetItemsToRemove)


Sepi

Sepi
Previous (GetChooseIf)
Next (GetNonTerminalCount)

Name
GetItemsToRemove

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetItemsToRemove ( Index : Integer ) : Boolean

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetChooseIf)
Next (GetNonTerminalCount)


Sepi

Sepi
Previous (GetItemsToRemove)
Next (GetNonTerminals)

Name
GetNonTerminalCount

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetNonTerminalCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetItemsToRemove)
Next (GetNonTerminals)


Sepi

Sepi
Previous (GetNonTerminalCount)
Next (SetAlternativeChoice)

Name
GetNonTerminals

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetNonTerminals ( Index : Integer ) : TNonTerminal

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TNonTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNonTerminalCount)
Next (SetAlternativeChoice)


Sepi

Sepi
Previous (GetNonTerminals)
Next

Name
SetAlternativeChoice

Parent
TChoice

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetAlternativeChoice ( AltChoice : TChoice )

Parameters
Parameter | Description
AltChoice : TChoice | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNonTerminals)
Next


Sepi

Sepi
Previous (TChoice)
Next (TChooseIfSet)

Name
TChoiceEnd

Parent
SepiLL1Grammars

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Fin de choix

Members
Fields
Field | Description
FChoiceEnd (-) | #No TAG found in source code#
FEmpty (-) | #No TAG found in source code#
FItems (-) | #No TAG found in source code#
FPremSet (-) | #No TAG found in source code#

Methods
Method | Description
Create (+) | #No TAG found in source code#
CreateAsPartOf (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#
Equals (+) | #No TAG found in source code#
GetItemCount (-) | #No TAG found in source code#
GetItems (-) | #No TAG found in source code#

Properties
Property | Description
ChoiceEnd (+) | #No TAG found in source code#
Empty (+) | #No TAG found in source code#
First (+) | #No TAG found in source code#
ItemCount (+) | #No TAG found in source code#
Items (+) | #No TAG found in source code#
PremSet (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TChoice)
Next (TChooseIfSet)


Sepi

Sepi
Previous
Next (FEmpty)

Name
FChoiceEnd

Parent
TChoiceEnd

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FChoiceEnd : TChoiceEnd

Sepi
Class Tree
Index
Previous
Next (FEmpty)


Sepi

Sepi
Previous (FChoiceEnd)
Next (FItems)

Name
FEmpty

Parent
TChoiceEnd

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FEmpty : Boolean

Sepi
Class Tree
Index
Previous (FChoiceEnd)
Next (FItems)


Sepi

Sepi
Previous (FEmpty)
Next (FPremSet)

Name
FItems

Parent
TChoiceEnd

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FItems : TObjectList

Sepi
Class Tree
Index
Previous (FEmpty)
Next (FPremSet)


Sepi

Sepi
Previous (FItems)
Next

Name
FPremSet

Parent
TChoiceEnd

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FPremSet : TPremSet

Sepi
Class Tree
Index
Previous (FItems)
Next


Sepi

Sepi
Previous
Next (Empty)

Name
ChoiceEnd

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ChoiceEnd : TChoiceEnd read FChoiceEnd

Read Access
FChoiceEnd

Sepi
Class Tree
Index
Previous
Next (Empty)


Sepi

Sepi
Previous (ChoiceEnd)
Next (First)

Name
Empty

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Empty : Boolean read FEmpty

Read Access
FEmpty

Sepi
Class Tree
Index
Previous (ChoiceEnd)
Next (First)


Sepi

Sepi
Previous (Empty)
Next (ItemCount)

Name
First

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property First : TGramSymbol index 0 read GetItems

Read Access
GetItems

Sepi
Class Tree
Index
Previous (Empty)
Next (ItemCount)


Sepi

Sepi
Previous (First)
Next (Items)

Name
ItemCount

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ItemCount : Integer read GetItemCount

Read Access
GetItemCount

Sepi
Class Tree
Index
Previous (First)
Next (Items)


Sepi

Sepi
Previous (ItemCount)
Next (PremSet)

Name
Items

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Items [ Index : Integer ] : TGramSymbol read GetItems

Read Access
GetItems

Sepi
Class Tree
Index
Previous (ItemCount)
Next (PremSet)


Sepi

Sepi
Previous (Items)
Next

Name
PremSet

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property PremSet : TPremSet read FPremSet

Read Access
FPremSet

Sepi
Class Tree
Index
Previous (Items)
Next


Sepi

Sepi
Previous
Next (CreateAsPartOf)

Name
Create

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CreateAsPartOf)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CreateAsPartOf

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor CreateAsPartOf ( ChoiceEnd : TChoiceEnd )

Parameters
Parameter | Description
ChoiceEnd : TChoiceEnd | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CreateAsPartOf)
Next (Equals)

Name
Destroy

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateAsPartOf)
Next (Equals)


Sepi

Sepi
Previous (Destroy)
Next (GetItemCount)

Name
Equals

Parent
TChoiceEnd

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function Equals ( Obj : TObject ) : Boolean ; override

Parameters
Parameter | Description
Obj : TObject | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetItemCount)


Sepi

Sepi
Previous (Equals)
Next (GetItems)

Name
GetItemCount

Parent
TChoiceEnd

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetItemCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetItems)


Sepi

Sepi
Previous (GetItemCount)
Next

Name
GetItems

Parent
TChoiceEnd

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetItems ( Index : Integer ) : TGramSymbol

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TGramSymbol | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetItemCount)
Next


Sepi

Sepi
Previous (TChoiceEnd)
Next (TGrammar)

Name
TChooseIfSet

Parent
SepiLL1Grammars

Class Hierarchy
TScIntegerSet

Visibility
PUBLIC

Description
Ensemble Choisir-Si

Members
Methods
Method | Description
ConflictWith (+) | Test whether this set conflicts with another one

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TChoiceEnd)
Next (TGrammar)


Sepi

Sepi
Previous
Next

Name
ConflictWith

Parent
TChooseIfSet

Visibility
PUBLIC

Description
Test whether this set conflicts with another one

Source code
function ConflictWith ( Other : TChooseIfSet ) : Boolean

Parameters
Parameter | Description
Other : TChooseIfSet | Other Choose-If set to compare with

Return
Types | Description
BOOLEAN | True if sets conflict with each other, False otherwise

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TChooseIfSet)
Next (TGramSymbol)

Name
TGrammar

Parent
SepiLL1Grammars

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Grammaire

Members
Fields
Field | Description
FChoiceCount (-) | #No TAG found in source code#
FChoiceEnds (-) | #No TAG found in source code#
FFirstNonTerminalID (-) | #No TAG found in source code#
FLL1Conflicts (-) | #No TAG found in source code#
FNonTerminals (-) | #No TAG found in source code#
FTerminals (-) | #No TAG found in source code#

Methods
Method | Description
CheckForConflicts (-) | #No TAG found in source code#
ChoiceEndExists (-) | #No TAG found in source code#
ComputeChooseIf (-) | #No TAG found in source code#
ComputePremSets (-) | #No TAG found in source code#
ComputeSuivSets (-) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#
FindSymbol (+) | #No TAG found in source code#
FindSymbol (+) | #No TAG found in source code#
GetChoiceEndCount (-) | #No TAG found in source code#
GetChoiceEnds (-) | #No TAG found in source code#
GetChoices (-) | #No TAG found in source code#
GetLL1ConflictCount (-) | #No TAG found in source code#
GetLL1Conflicts (-) | #No TAG found in source code#
GetNonTerminalCount (-) | #No TAG found in source code#
GetNonTerminals (-) | #No TAG found in source code#
GetTerminalCount (-) | #No TAG found in source code#
GetTerminals (-) | #No TAG found in source code#
LoadChoiceEnds (-) | #No TAG found in source code#
LoadNonTerminals (-) | #No TAG found in source code#
MakePrivNonTerminal (-) | #No TAG found in source code#

Properties
Property | Description
ChoiceCount (+) | #No TAG found in source code#
ChoiceEndCount (+) | #No TAG found in source code#
ChoiceEnds (+) | #No TAG found in source code#
Choices (+) | #No TAG found in source code#
EmptyChoice (+) | #No TAG found in source code#
FirstNonTerminalID (+) | #No TAG found in source code#
LL1ConflictCount (+) | #No TAG found in source code#
LL1Conflicts (+) | #No TAG found in source code#
NonTerminalCount (+) | #No TAG found in source code#
NonTerminals (+) | #No TAG found in source code#
TerminalCount (+) | #No TAG found in source code#
Terminals (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TChooseIfSet)
Next (TGramSymbol)


Sepi

Sepi
Previous
Next (FChoiceEnds)

Name
FChoiceCount

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FChoiceCount : Integer

Sepi
Class Tree
Index
Previous
Next (FChoiceEnds)


Sepi

Sepi
Previous (FChoiceCount)
Next (FFirstNonTerminalID)

Name
FChoiceEnds

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FChoiceEnds : TObjectList

Sepi
Class Tree
Index
Previous (FChoiceCount)
Next (FFirstNonTerminalID)


Sepi

Sepi
Previous (FChoiceEnds)
Next (FLL1Conflicts)

Name
FFirstNonTerminalID

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FFirstNonTerminalID : Integer

Sepi
Class Tree
Index
Previous (FChoiceEnds)
Next (FLL1Conflicts)


Sepi

Sepi
Previous (FFirstNonTerminalID)
Next (FNonTerminals)

Name
FLL1Conflicts

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FLL1Conflicts : TObjectList

Sepi
Class Tree
Index
Previous (FFirstNonTerminalID)
Next (FNonTerminals)


Sepi

Sepi
Previous (FLL1Conflicts)
Next (FTerminals)

Name
FNonTerminals

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FNonTerminals : TObjectList

Sepi
Class Tree
Index
Previous (FLL1Conflicts)
Next (FTerminals)


Sepi

Sepi
Previous (FNonTerminals)
Next

Name
FTerminals

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FTerminals : TObjectList

Sepi
Class Tree
Index
Previous (FNonTerminals)
Next


Sepi

Sepi
Previous
Next (ChoiceEndCount)

Name
ChoiceCount

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ChoiceCount : Integer read FChoiceCount

Read Access
FChoiceCount

Sepi
Class Tree
Index
Previous
Next (ChoiceEndCount)


Sepi

Sepi
Previous (ChoiceCount)
Next (ChoiceEnds)

Name
ChoiceEndCount

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ChoiceEndCount : Integer read GetChoiceEndCount

Read Access
GetChoiceEndCount

Sepi
Class Tree
Index
Previous (ChoiceCount)
Next (ChoiceEnds)


Sepi

Sepi
Previous (ChoiceEndCount)
Next (Choices)

Name
ChoiceEnds

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ChoiceEnds [ Index : Integer ] : TChoiceEnd read GetChoiceEnds

Read Access
GetChoiceEnds

Sepi
Class Tree
Index
Previous (ChoiceEndCount)
Next (Choices)


Sepi

Sepi
Previous (ChoiceEnds)
Next (EmptyChoice)

Name
Choices

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Choices [ Index : Integer ] : TChoice read GetChoices

Read Access
GetChoices

Sepi
Class Tree
Index
Previous (ChoiceEnds)
Next (EmptyChoice)


Sepi

Sepi
Previous (Choices)
Next (FirstNonTerminalID)

Name
EmptyChoice

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property EmptyChoice : TChoice index 0 read GetChoices

Read Access
GetChoices

Sepi
Class Tree
Index
Previous (Choices)
Next (FirstNonTerminalID)


Sepi

Sepi
Previous (EmptyChoice)
Next (LL1ConflictCount)

Name
FirstNonTerminalID

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property FirstNonTerminalID : Integer read FFirstNonTerminalID

Read Access
FFirstNonTerminalID

Sepi
Class Tree
Index
Previous (EmptyChoice)
Next (LL1ConflictCount)


Sepi

Sepi
Previous (FirstNonTerminalID)
Next (LL1Conflicts)

Name
LL1ConflictCount

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property LL1ConflictCount : Integer read GetLL1ConflictCount

Read Access
GetLL1ConflictCount

Sepi
Class Tree
Index
Previous (FirstNonTerminalID)
Next (LL1Conflicts)


Sepi

Sepi
Previous (LL1ConflictCount)
Next (NonTerminalCount)

Name
LL1Conflicts

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property LL1Conflicts [ Index : Integer ] : TLL1Conflict read GetLL1Conflicts

Read Access
GetLL1Conflicts

Sepi
Class Tree
Index
Previous (LL1ConflictCount)
Next (NonTerminalCount)


Sepi

Sepi
Previous (LL1Conflicts)
Next (NonTerminals)

Name
NonTerminalCount

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property NonTerminalCount : Integer read GetNonTerminalCount

Read Access
GetNonTerminalCount

Sepi
Class Tree
Index
Previous (LL1Conflicts)
Next (NonTerminals)


Sepi

Sepi
Previous (NonTerminalCount)
Next (TerminalCount)

Name
NonTerminals

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property NonTerminals [ Index : Integer ] : TNonTerminal read GetNonTerminals

Read Access
GetNonTerminals

Sepi
Class Tree
Index
Previous (NonTerminalCount)
Next (TerminalCount)


Sepi

Sepi
Previous (NonTerminals)
Next (Terminals)

Name
TerminalCount

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property TerminalCount : Integer read GetTerminalCount

Read Access
GetTerminalCount

Sepi
Class Tree
Index
Previous (NonTerminals)
Next (Terminals)


Sepi

Sepi
Previous (TerminalCount)
Next

Name
Terminals

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Terminals [ Index : Integer ] : TTerminal read GetTerminals

Read Access
GetTerminals

Sepi
Class Tree
Index
Previous (TerminalCount)
Next


Sepi

Sepi
Previous
Next (ChoiceEndExists)

Name
CheckForConflicts

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure CheckForConflicts

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChoiceEndExists)


Sepi

Sepi
Previous (CheckForConflicts)
Next (ComputeChooseIf)

Name
ChoiceEndExists

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function ChoiceEndExists ( var ChoiceEnd : TChoiceEnd ) : Boolean

Parameters
Parameter | Description
ChoiceEnd : TChoiceEnd | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckForConflicts)
Next (ComputeChooseIf)


Sepi

Sepi
Previous (ChoiceEndExists)
Next (ComputePremSets)

Name
ComputeChooseIf

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ComputeChooseIf

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChoiceEndExists)
Next (ComputePremSets)


Sepi

Sepi
Previous (ComputeChooseIf)
Next (ComputeSuivSets)

Name
ComputePremSets

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ComputePremSets

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ComputeChooseIf)
Next (ComputeSuivSets)


Sepi

Sepi
Previous (ComputePremSets)
Next (Create)

Name
ComputeSuivSets

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure ComputeSuivSets

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ComputePremSets)
Next (Create)


Sepi

Sepi
Previous (ComputeSuivSets)
Next (Destroy)

Name
Create

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( FileName : TFileName )

Parameters
Parameter | Description
FileName : TFileName | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ComputeSuivSets)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (FindSymbol)

Name
Destroy

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (FindSymbol)


Sepi

Sepi
Previous (Destroy)
Next (FindSymbol)

Name
FindSymbol

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function FindSymbol ( ID : Integer ) : TGramSymbol ; overload

Parameters
Parameter | Description
ID : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TGramSymbol | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (FindSymbol)


Sepi

Sepi
Previous (FindSymbol)
Next (GetChoiceEndCount)

Name
FindSymbol

Parent
TGrammar

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function FindSymbol ( Str : string ) : TGramSymbol ; overload

Parameters
Parameter | Description
Str : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TGramSymbol | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FindSymbol)
Next (GetChoiceEndCount)


Sepi

Sepi
Previous (FindSymbol)
Next (GetChoiceEnds)

Name
GetChoiceEndCount

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetChoiceEndCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FindSymbol)
Next (GetChoiceEnds)


Sepi

Sepi
Previous (GetChoiceEndCount)
Next (GetChoices)

Name
GetChoiceEnds

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetChoiceEnds ( Index : Integer ) : TChoiceEnd

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TChoiceEnd | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetChoiceEndCount)
Next (GetChoices)


Sepi

Sepi
Previous (GetChoiceEnds)
Next (GetLL1ConflictCount)

Name
GetChoices

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetChoices ( Index : Integer ) : TChoice

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TChoice | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetChoiceEnds)
Next (GetLL1ConflictCount)


Sepi

Sepi
Previous (GetChoices)
Next (GetLL1Conflicts)

Name
GetLL1ConflictCount

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetLL1ConflictCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetChoices)
Next (GetLL1Conflicts)


Sepi

Sepi
Previous (GetLL1ConflictCount)
Next (GetNonTerminalCount)

Name
GetLL1Conflicts

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetLL1Conflicts ( Index : Integer ) : TLL1Conflict

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TLL1Conflict | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetLL1ConflictCount)
Next (GetNonTerminalCount)


Sepi

Sepi
Previous (GetLL1Conflicts)
Next (GetNonTerminals)

Name
GetNonTerminalCount

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetNonTerminalCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetLL1Conflicts)
Next (GetNonTerminals)


Sepi

Sepi
Previous (GetNonTerminalCount)
Next (GetTerminalCount)

Name
GetNonTerminals

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetNonTerminals ( Index : Integer ) : TNonTerminal

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TNonTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNonTerminalCount)
Next (GetTerminalCount)


Sepi

Sepi
Previous (GetNonTerminals)
Next (GetTerminals)

Name
GetTerminalCount

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetTerminalCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNonTerminals)
Next (GetTerminals)


Sepi

Sepi
Previous (GetTerminalCount)
Next (LoadChoiceEnds)

Name
GetTerminals

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetTerminals ( Index : Integer ) : TTerminal

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetTerminalCount)
Next (LoadChoiceEnds)


Sepi

Sepi
Previous (GetTerminals)
Next (LoadNonTerminals)

Name
LoadChoiceEnds

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure LoadChoiceEnds ( Strings : TStrings )

Parameters
Parameter | Description
Strings : TStrings | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetTerminals)
Next (LoadNonTerminals)


Sepi

Sepi
Previous (LoadChoiceEnds)
Next (MakePrivNonTerminal)

Name
LoadNonTerminals

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure LoadNonTerminals ( Strings : TStrings )

Parameters
Parameter | Description
Strings : TStrings | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadChoiceEnds)
Next (MakePrivNonTerminal)


Sepi

Sepi
Previous (LoadNonTerminals)
Next

Name
MakePrivNonTerminal

Parent
TGrammar

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function MakePrivNonTerminal ( Strings : TStrings ; No : Integer ; Kind : TPrivNonTerminalKind ; const Contents : string ) : string

Parameters
Parameter | Description
Strings : TStrings | #Pas de TAG trouvé dans le code source#
No : INTEGER | #Pas de TAG trouvé dans le code source#
Kind : TPrivNonTerminalKind | #Pas de TAG trouvé dans le code source#
Contents : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadNonTerminals)
Next


Sepi

Sepi
Previous (TGrammar)
Next (TLL1Conflict)

Name
TGramSymbol

Parent
SepiLL1Grammars

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Symbole grammatical

Members
Fields
Field | Description
FID (-) | #No TAG found in source code#
FName (-) | #No TAG found in source code#
FPremSet (-) | #No TAG found in source code#
FStrID (-) | #No TAG found in source code#

Methods
Method | Description
Create (+) | #No TAG found in source code#
Destroy (+) | [@inheritDoc]

Properties
Property | Description
ID (+) | #No TAG found in source code#
NAME (+) | #No TAG found in source code#
PremSet (+) | #No TAG found in source code#
StrID (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TGrammar)
Next (TLL1Conflict)


Sepi

Sepi
Previous
Next (FName)

Name
FID

Parent
TGramSymbol

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FID : TSymbolClass

Sepi
Class Tree
Index
Previous
Next (FName)


Sepi

Sepi
Previous (FID)
Next (FPremSet)

Name
FName

Parent
TGramSymbol

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FName : string

Sepi
Class Tree
Index
Previous (FID)
Next (FPremSet)


Sepi

Sepi
Previous (FName)
Next (FStrID)

Name
FPremSet

Parent
TGramSymbol

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FPremSet : TPremSet

Sepi
Class Tree
Index
Previous (FName)
Next (FStrID)


Sepi

Sepi
Previous (FPremSet)
Next

Name
FStrID

Parent
TGramSymbol

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FStrID : string

Sepi
Class Tree
Index
Previous (FPremSet)
Next


Sepi

Sepi
Previous
Next (NAME)

Name
ID

Parent
TGramSymbol

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ID : TSymbolClass read FID

Read Access
FID

Sepi
Class Tree
Index
Previous
Next (NAME)


Sepi

Sepi
Previous (ID)
Next (PremSet)

Name
NAME

Parent
TGramSymbol

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (ID)
Next (PremSet)


Sepi

Sepi
Previous (NAME)
Next (StrID)

Name
PremSet

Parent
TGramSymbol

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property PremSet : TPremSet read FPremSet

Read Access
FPremSet

Sepi
Class Tree
Index
Previous (NAME)
Next (StrID)


Sepi

Sepi
Previous (PremSet)
Next

Name
StrID

Parent
TGramSymbol

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property StrID : string read FStrID

Read Access
FStrID

Sepi
Class Tree
Index
Previous (PremSet)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TGramSymbol

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( AID : TSymbolClass ; const AStrID , AName : string )

Parameters
Parameter | Description
AID : TSymbolClass | #Pas de TAG trouvé dans le code source#
AStrID : STRING | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next

Name
Destroy

Parent
TGramSymbol

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TGramSymbol)
Next (TNonTerminal)

Name
TLL1Conflict

Parent
SepiLL1Grammars

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Conflit LL(1)

Members
Fields
Field | Description
FChoice1 (-) | #No TAG found in source code#
FChoice2 (-) | #No TAG found in source code#
FNonTerminal (-) | #No TAG found in source code#

Methods
Method | Description
Create (+) | #No TAG found in source code#

Properties
Property | Description
Choice1 (+) | #No TAG found in source code#
Choice2 (+) | #No TAG found in source code#
NonTerminal (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TGramSymbol)
Next (TNonTerminal)


Sepi

Sepi
Previous
Next (FChoice2)

Name
FChoice1

Parent
TLL1Conflict

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FChoice1 : Integer

Sepi
Class Tree
Index
Previous
Next (FChoice2)


Sepi

Sepi
Previous (FChoice1)
Next (FNonTerminal)

Name
FChoice2

Parent
TLL1Conflict

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FChoice2 : Integer

Sepi
Class Tree
Index
Previous (FChoice1)
Next (FNonTerminal)


Sepi

Sepi
Previous (FChoice2)
Next

Name
FNonTerminal

Parent
TLL1Conflict

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FNonTerminal : TNonTerminal

Sepi
Class Tree
Index
Previous (FChoice2)
Next


Sepi

Sepi
Previous
Next (Choice2)

Name
Choice1

Parent
TLL1Conflict

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Choice1 : Integer read FChoice1

Read Access
FChoice1

Sepi
Class Tree
Index
Previous
Next (Choice2)


Sepi

Sepi
Previous (Choice1)
Next (NonTerminal)

Name
Choice2

Parent
TLL1Conflict

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Choice2 : Integer read FChoice2

Read Access
FChoice2

Sepi
Class Tree
Index
Previous (Choice1)
Next (NonTerminal)


Sepi

Sepi
Previous (Choice2)
Next

Name
NonTerminal

Parent
TLL1Conflict

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property NonTerminal : TNonTerminal read FNonTerminal

Read Access
FNonTerminal

Sepi
Class Tree
Index
Previous (Choice2)
Next


Sepi

Sepi
Previous
Next

Name
Create

Parent
TLL1Conflict

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( ANonTerminal : TNonTerminal ; AChoice1 , AChoice2 : Integer )

Parameters
Parameter | Description
ANonTerminal : TNonTerminal | #Pas de TAG trouvé dans le code source#
AChoice1 : INTEGER | #Pas de TAG trouvé dans le code source#
AChoice2 : INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TLL1Conflict)
Next (TParsingTable)

Name
TNonTerminal

Parent
SepiLL1Grammars

Class Hierarchy
TGramSymbol

Visibility
PUBLIC

Description
Non-terminal

Members
Fields
Field | Description
FChoices (-) | #No TAG found in source code#
FShowAsText (-) | #No TAG found in source code#
FSimplify (-) | #No TAG found in source code#
FSuccessiveTries (-) | #No TAG found in source code#
FSuivSet (-) | #No TAG found in source code#

Methods
Method | Description
AddChoice (-) | #No TAG found in source code#
Complete (-) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
Destroy (+) | [@inheritDoc]
GetChoiceCount (-) | #No TAG found in source code#
GetChoices (-) | #No TAG found in source code#

Properties
Property | Description
ChoiceCount (+) | #No TAG found in source code#
Choices (+) | #No TAG found in source code#
ShowAsText (+) | #No TAG found in source code#
Simplify (+) | #No TAG found in source code#
SuccessiveTries (+) | #No TAG found in source code#
SuivSet (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TLL1Conflict)
Next (TParsingTable)


Sepi

Sepi
Previous
Next (FShowAsText)

Name
FChoices

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FChoices : TObjectList

Sepi
Class Tree
Index
Previous
Next (FShowAsText)


Sepi

Sepi
Previous (FChoices)
Next (FSimplify)

Name
FShowAsText

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FShowAsText : Boolean

Sepi
Class Tree
Index
Previous (FChoices)
Next (FSimplify)


Sepi

Sepi
Previous (FShowAsText)
Next (FSuccessiveTries)

Name
FSimplify

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FSimplify : Boolean

Sepi
Class Tree
Index
Previous (FShowAsText)
Next (FSuccessiveTries)


Sepi

Sepi
Previous (FSimplify)
Next (FSuivSet)

Name
FSuccessiveTries

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FSuccessiveTries : Boolean

Sepi
Class Tree
Index
Previous (FSimplify)
Next (FSuivSet)


Sepi

Sepi
Previous (FSuccessiveTries)
Next

Name
FSuivSet

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FSuivSet : TSuivSet

Sepi
Class Tree
Index
Previous (FSuccessiveTries)
Next


Sepi

Sepi
Previous
Next (Choices)

Name
ChoiceCount

Parent
TNonTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ChoiceCount : Integer read GetChoiceCount

Read Access
GetChoiceCount

Sepi
Class Tree
Index
Previous
Next (Choices)


Sepi

Sepi
Previous (ChoiceCount)
Next (ShowAsText)

Name
Choices

Parent
TNonTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Choices [ Index : Integer ] : TChoice read GetChoices

Read Access
GetChoices

Sepi
Class Tree
Index
Previous (ChoiceCount)
Next (ShowAsText)


Sepi

Sepi
Previous (Choices)
Next (Simplify)

Name
ShowAsText

Parent
TNonTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ShowAsText : Boolean read FShowAsText

Read Access
FShowAsText

Sepi
Class Tree
Index
Previous (Choices)
Next (Simplify)


Sepi

Sepi
Previous (ShowAsText)
Next (SuccessiveTries)

Name
Simplify

Parent
TNonTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Simplify : Boolean read FSimplify

Read Access
FSimplify

Sepi
Class Tree
Index
Previous (ShowAsText)
Next (SuccessiveTries)


Sepi

Sepi
Previous (Simplify)
Next (SuivSet)

Name
SuccessiveTries

Parent
TNonTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property SuccessiveTries : Boolean read FSuccessiveTries

Read Access
FSuccessiveTries

Sepi
Class Tree
Index
Previous (Simplify)
Next (SuivSet)


Sepi

Sepi
Previous (SuccessiveTries)
Next

Name
SuivSet

Parent
TNonTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property SuivSet : TSuivSet read FSuivSet

Read Access
FSuivSet

Sepi
Class Tree
Index
Previous (SuccessiveTries)
Next


Sepi

Sepi
Previous
Next (Complete)

Name
AddChoice

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure AddChoice ( Choice : TChoice )

Parameters
Parameter | Description
Choice : TChoice | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (AddChoice)
Next (Create)

Name
Complete

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddChoice)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Destroy)

Name
Create

Parent
TNonTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( AID : TSymbolClass ; const Str : string )

Parameters
Parameter | Description
AID : TSymbolClass | #Pas de TAG trouvé dans le code source#
Str : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Complete)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetChoiceCount)

Name
Destroy

Parent
TNonTerminal

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetChoiceCount)


Sepi

Sepi
Previous (Destroy)
Next (GetChoices)

Name
GetChoiceCount

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetChoiceCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetChoices)


Sepi

Sepi
Previous (GetChoiceCount)
Next

Name
GetChoices

Parent
TNonTerminal

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetChoices ( Index : Integer ) : TChoice

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TChoice | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetChoiceCount)
Next


Sepi

Sepi
Previous (TNonTerminal)
Next (TPremSet)

Name
TParsingTable

Parent
SepiLL1Grammars

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Table de transition

Members
Fields
Field | Description
FHeight (-) | #No TAG found in source code#
FTable (-) | #No TAG found in source code#
FWidth (-) | #No TAG found in source code#

Methods
Method | Description
Create (+) | #No TAG found in source code#
Destroy (+) | #No TAG found in source code#
GetTable (-) | #No TAG found in source code#

Properties
Property | Description
Height (+) | #No TAG found in source code#
Table (+) | #No TAG found in source code#
Width (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TNonTerminal)
Next (TPremSet)


Sepi

Sepi
Previous
Next (FTable)

Name
FHeight

Parent
TParsingTable

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FHeight : Integer

Sepi
Class Tree
Index
Previous
Next (FTable)


Sepi

Sepi
Previous (FHeight)
Next (FWidth)

Name
FTable

Parent
TParsingTable

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FTable : array of array of TChoice

Sepi
Class Tree
Index
Previous (FHeight)
Next (FWidth)


Sepi

Sepi
Previous (FTable)
Next

Name
FWidth

Parent
TParsingTable

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FWidth : Integer

Sepi
Class Tree
Index
Previous (FTable)
Next


Sepi

Sepi
Previous
Next (Table)

Name
Height

Parent
TParsingTable

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Height : Integer read FHeight

Read Access
FHeight

Sepi
Class Tree
Index
Previous
Next (Table)


Sepi

Sepi
Previous (Height)
Next (Width)

Name
Table

Parent
TParsingTable

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Table [ NonTerminal , Terminal : TSymbolClass ] : TChoice read GetTable ; default

Read Access
GetTable

Sepi
Class Tree
Index
Previous (Height)
Next (Width)


Sepi

Sepi
Previous (Table)
Next

Name
Width

Parent
TParsingTable

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Width : Integer read FWidth

Read Access
FWidth

Sepi
Class Tree
Index
Previous (Table)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TParsingTable

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( Grammar : TGrammar )

Parameters
Parameter | Description
Grammar : TGrammar | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetTable)

Name
Destroy

Parent
TParsingTable

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetTable)


Sepi

Sepi
Previous (Destroy)
Next

Name
GetTable

Parent
TParsingTable

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetTable ( NonTerminal , Terminal : TSymbolClass ) : TChoice

Parameters
Parameter | Description
NonTerminal : TSymbolClass | #Pas de TAG trouvé dans le code source#
Terminal : TSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TChoice | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (TParsingTable)
Next (TSuivSet)

Name
TPremSet

Parent
SepiLL1Grammars

Class Hierarchy
TScIntegerSet

Visibility
PUBLIC

Description
Ensemble des PREM

Members
Fields
Field | Description
FEmpty (-) | #No TAG found in source code#

Methods
Method | Description
AddPrem (+) | Adds the contents of another PREM set to this PREM set
SetEmpty (-) | Modifie la propriété Empty

Properties
Property | Description
Empty (+) | Modifie la propriété Empty

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TParsingTable)
Next (TSuivSet)


Sepi

Sepi
Previous
Next

Name
FEmpty

Parent
TPremSet

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
FEmpty : Boolean

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Empty

Parent
TPremSet

Visibility
PUBLIC

Description
Modifie la propriété Empty

Source code
property Empty : Boolean read FEmpty write SetEmpty

Read Access
FEmpty

Write Access
SetEmpty

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (SetEmpty)

Name
AddPrem

Parent
TPremSet

Visibility
PUBLIC

Description
Adds the contents of another PREM set to this PREM set

Source code
function AddPrem ( Source : TPremSet ; WithEmpty : Boolean = True ) : Boolean

Parameters
Parameter | Description
Source : TPremSet | Source PREM set
WithEmpty : BOOLEAN | True for including the empty flag, False otherwise

Return
Types | Description
BOOLEAN | True if the set has changed, False otherwise

Sepi
Class Tree
Index
Previous
Next (SetEmpty)


Sepi

Sepi
Previous (AddPrem)
Next

Name
SetEmpty

Parent
TPremSet

Visibility
PRIVATE

Description
Modifie la propriété Empty

Source code
procedure SetEmpty ( Value : Boolean )

Parameters
Parameter | Description
Value : BOOLEAN | Nouvelle valeur de la propriété Empty

Sepi
Class Tree
Index
Previous (AddPrem)
Next


Sepi

Sepi
Previous (TPremSet)
Next (TTerminal)

Name
TSuivSet

Parent
SepiLL1Grammars

Class Hierarchy
TScIntegerSet

Visibility
PUBLIC

Description
Ensemble des SUIV

Members
Methods
Method | Description
AddPrem (+) | Adds the contents of a PREM set to this SUIV set
AddSuiv (+) | Adds the contents of another SUIV set to this SUIV set

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TPremSet)
Next (TTerminal)


Sepi

Sepi
Previous
Next (AddSuiv)

Name
AddPrem

Parent
TSuivSet

Visibility
PUBLIC

Description
Adds the contents of a PREM set to this SUIV set

Source code
function AddPrem ( Source : TPremSet ) : Boolean

Parameters
Parameter | Description
Source : TPremSet | Source SUIV set

Return
Types | Description
BOOLEAN | True if the set has changed, False otherwise

Sepi
Class Tree
Index
Previous
Next (AddSuiv)


Sepi

Sepi
Previous (AddPrem)
Next

Name
AddSuiv

Parent
TSuivSet

Visibility
PUBLIC

Description
Adds the contents of another SUIV set to this SUIV set

Source code
function AddSuiv ( Source : TSuivSet ) : Boolean

Parameters
Parameter | Description
Source : TSuivSet | Source SUIV set

Return
Types | Description
BOOLEAN | True if the set has changed, False otherwise

Sepi
Class Tree
Index
Previous (AddPrem)
Next


Sepi

Sepi
Previous (TSuivSet)
Next

Name
TTerminal

Parent
SepiLL1Grammars

Class Hierarchy
TGramSymbol

Visibility
PUBLIC

Description
Terminal

Members
Methods
Method | Description
Create (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSuivSet)
Next


Sepi

Sepi
Previous
Next

Name
Create

Parent
TTerminal

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( AID : TSymbolClass ; const Str : string )

Parameters
Parameter | Description
AID : TSymbolClass | #Pas de TAG trouvé dans le code source#
Str : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (TSymbolClass)

Name
TPrivNonTerminalKind

Parent
SepiLL1Grammars

Visibility
PUBLIC

Description
Type de non-terminal priv

Source code
TPrivNonTerminalKind = ( ntkZeroMany , ntkOneMany , ntkZeroOne ) ;

Sepi
Class Tree
Index
Previous
Next (TSymbolClass)


Sepi

Sepi
Previous (TPrivNonTerminalKind)
Next

Name
TSymbolClass

Parent
SepiLL1Grammars

Visibility
PUBLIC

Description
Classe de symbole

Source code
TSymbolClass = type Word ;

Sepi
Class Tree
Index
Previous (TPrivNonTerminalKind)
Next


Sepi

Sepi
Previous (SepiLL1Grammars)
Next (SepiMembers)

Name
SepiLL1ParserUtils

Parent
Sepi

Description
Utilitaires d'analyse syntaxique LL(1) pour Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TPushChoiceProc (+) | Procédure de push d'un choix sur la pile prédictive
TRuleID (+) | Identificateur de règle (contenu des tables d'analyse)

Constants
Constant Description

Classes
Class | Description
ESepiLL1ParserError (+) | Erreur de parser LL(1) Sepi
TSepiChildThroughNonTerminal (+) | Non-terminal "child-through"
TSepiCustomLL1Parser (+) | Classe de base pour les analyseurs syntaxiques LL(1) Sepi
TSepiFakeNonTerminal (+) | Faux non-terminal
TSepiLL1ParsingStack (+) | Pile d'un analyse syntaxique LL(1)
TTryTag (+) | Tag marquant un try dans la pile prédictive

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiLL1Grammars)
Next (SepiMembers)


Sepi

Sepi
Previous
Next (TSepiChildThroughNonTerminal)

Name
ESepiLL1ParserError

Parent
SepiLL1ParserUtils

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Erreur de parser LL(1) Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiChildThroughNonTerminal)


Sepi

Sepi
Previous (ESepiLL1ParserError)
Next (TSepiCustomLL1Parser)

Name
TSepiChildThroughNonTerminal

Parent
SepiLL1ParserUtils

Class Hierarchy
TSepiHiddenNonTerminal

Visibility
PUBLIC

Description
Non-terminal "child-through"
Un non-terminal "child-through" redirige tous les enfants qui lui sont
attachés vers son parent, à la position qu'il occupe - ou plutôt, qu'il
devrait occuper, lui-même étant invisible.
L'utilisation de non-terminaux "child-through" est un moyen particulièrement
simple d'implémenter des grammaires EBNF avec un analyseur BNF.

Members
Methods
Method | Description
AddChild (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiLL1ParserError)
Next (TSepiCustomLL1Parser)


Sepi

Sepi
Previous
Next (EndParsing)

Name
AddChild

Parent
TSepiChildThroughNonTerminal

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AddChild ( Index : Integer ; Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (AddChild)
Next

Name
EndParsing

Parent
TSepiChildThroughNonTerminal

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddChild)
Next


Sepi

Sepi
Previous (TSepiChildThroughNonTerminal)
Next (TSepiFakeNonTerminal)

Name
TSepiCustomLL1Parser

Parent
SepiLL1ParserUtils

Class Hierarchy
TSepiCustomParser

Visibility
PUBLIC

Description
Classe de base pour les analyseurs syntaxiques LL(1) Sepi

Members
Fields
Field | Description
FCurrent (-) | Non-terminal courant
FStack (-) | Pile prédictive
PushChoiceProcs (#) | Tableau des procédures qui push les choix sur la pile prédictive

Methods
Method | Description
BackToParent (-) | Retourne au parent
BeginFakeNonTerminal (-) | Commence un emballage dans un faux non-terminal
BeginNonTerminal (-) | Commence l'analyse d'un non-terminal
BeginNonTerminalParsing (-) | Commence l'analyse du non-terminal courant
BeginRootNode (-) | Commence l'analyse du noeud racine
Create (+) | [@inheritDoc]
CreateNonTerminal (#) | Crée un non-terminal de la bonne classe
Destroy (+) | [@inheritDoc]
GetExpectedString (#) | #No TAG found in source code#
GetNonTerminalClass (#) | #No TAG found in source code#
GetParsingTable (#) | #No TAG found in source code#
InitPushChoiceProcs (#) | Initialise le tableau PushChoiceProcs
InternalParse (#) | [@inheritDoc]
IsNonTerminal (#) | #No TAG found in source code#
IsTerminal (#) | #No TAG found in source code#
ParseTerminal (-) | Analyse un terminal
PopTry (-) | Pop un try de la pile prédictive
PushBackToParent (#) | Push un code indiquant de remonter au parent sur la pile prédictive
PushEmptyChoice (#) | Push un choix vide sur la pile prédictive
PushFakeSymbol (#) | Push un faux symbole grammatical sur la pile prédictive
PushSymbol (#) | Push un symbole grammatical sur la pile prédictive
PushTry (#) | Push un try sur la pile prédictive
SetCurrent (-) | #No TAG found in source code#
UnwindTry (#) | Déroule le try courant
UnwindTryOrSyntaxError (#) | Déroule le try courant s'il y en a un, sinon produit une erreur de syntaxe
UnwindTryOrSyntaxError (#) | Déroule le try courant s'il y en a un, sinon produit une erreur de syntaxe

Properties
Property | Description
Current (#) | Non-terminal courant
Stack (-) | Pile prédictive

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiChildThroughNonTerminal)
Next (TSepiFakeNonTerminal)


Sepi

Sepi
Previous
Next (FStack)

Name
FCurrent

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Non-terminal courant

Source code
FCurrent : TSepiNonTerminal

Sepi
Class Tree
Index
Previous
Next (FStack)


Sepi

Sepi
Previous (FCurrent)
Next (PushChoiceProcs)

Name
FStack

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Pile prédictive

Source code
FStack : TSepiLL1ParsingStack

Sepi
Class Tree
Index
Previous (FCurrent)
Next (PushChoiceProcs)


Sepi

Sepi
Previous (FStack)
Next

Name
PushChoiceProcs

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Tableau des procédures qui push les choix sur la pile prédictive

Source code
PushChoiceProcs : array of TPushChoiceProc

Sepi
Class Tree
Index
Previous (FStack)
Next


Sepi

Sepi
Previous
Next (Stack)

Name
Current

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Non-terminal courant

Source code
property Current : TSepiNonTerminal read FCurrent

Read Access
FCurrent

Sepi
Class Tree
Index
Previous
Next (Stack)


Sepi

Sepi
Previous (Current)
Next

Name
Stack

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Pile prédictive

Source code
property Stack : TSepiLL1ParsingStack read FStack

Read Access
FStack

Sepi
Class Tree
Index
Previous (Current)
Next


Sepi

Sepi
Previous
Next (BeginFakeNonTerminal)

Name
BackToParent

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Retourne au parent

Source code
procedure BackToParent

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (BeginFakeNonTerminal)


Sepi

Sepi
Previous (BackToParent)
Next (BeginNonTerminal)

Name
BeginFakeNonTerminal

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Commence un emballage dans un faux non-terminal

Source code
procedure BeginFakeNonTerminal

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BackToParent)
Next (BeginNonTerminal)


Sepi

Sepi
Previous (BeginFakeNonTerminal)
Next (BeginNonTerminalParsing)

Name
BeginNonTerminal

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Commence l'analyse d'un non-terminal

Source code
procedure BeginNonTerminal ( Symbol : TSepiSymbolClass )

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | Symbole de non-terminal attendu

Sepi
Class Tree
Index
Previous (BeginFakeNonTerminal)
Next (BeginNonTerminalParsing)


Sepi

Sepi
Previous (BeginNonTerminal)
Next (BeginRootNode)

Name
BeginNonTerminalParsing

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Commence l'analyse du non-terminal courant

Source code
procedure BeginNonTerminalParsing

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeginNonTerminal)
Next (BeginRootNode)


Sepi

Sepi
Previous (BeginNonTerminalParsing)
Next (Create)

Name
BeginRootNode

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Commence l'analyse du noeud racine

Source code
procedure BeginRootNode ( RootNode : TSepiNonTerminal )

Parameters
Parameter | Description
RootNode : TSepiNonTerminal | Noeud racine

Sepi
Class Tree
Index
Previous (BeginNonTerminalParsing)
Next (Create)


Sepi

Sepi
Previous (BeginRootNode)
Next (CreateNonTerminal)

Name
Create

Parent
TSepiCustomLL1Parser

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( ALexer : TSepiCustomLexer ) ; override

Parameters
Parameter | Description
ALexer : TSepiCustomLexer | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginRootNode)
Next (CreateNonTerminal)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CreateNonTerminal

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Crée un non-terminal de la bonne classe

Source code
function CreateNonTerminal ( Parent : TSepiNonTerminal ; Symbol : TSepiSymbolClass ; const SourcePos : TSepiSourcePosition ) : TSepiNonTerminal

Parameters
Parameter | Description
Parent : TSepiNonTerminal | Parent du non-terminal à créer
Symbol : TSepiSymbolClass | Symbole du non-terminal
SourcePos : TSepiSourcePosition | Position du non-terminal dans le source

Return
Types | Description
TSepiNonTerminal | Non-terminal créé

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CreateNonTerminal)
Next (GetExpectedString)

Name
Destroy

Parent
TSepiCustomLL1Parser

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateNonTerminal)
Next (GetExpectedString)


Sepi

Sepi
Previous (Destroy)
Next (GetNonTerminalClass)

Name
GetExpectedString

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetExpectedString ( ExpectedSymbol : TSepiSymbolClass ) : string ; virtual ; abstract

Parameters
Parameter | Description
ExpectedSymbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetNonTerminalClass)


Sepi

Sepi
Previous (GetExpectedString)
Next (GetParsingTable)

Name
GetNonTerminalClass

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetNonTerminalClass ( Symbol : TSepiSymbolClass ) : TSepiNonTerminalClass ; virtual ; abstract

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiNonTerminalClass | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetExpectedString)
Next (GetParsingTable)


Sepi

Sepi
Previous (GetNonTerminalClass)
Next (InitPushChoiceProcs)

Name
GetParsingTable

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParsingTable ( NonTerminalClass : TSepiSymbolClass ; TerminalClass : TSepiSymbolClass ) : TRuleID ; virtual ; abstract

Parameters
Parameter | Description
NonTerminalClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#
TerminalClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TRuleID | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetNonTerminalClass)
Next (InitPushChoiceProcs)


Sepi

Sepi
Previous (GetParsingTable)
Next (InternalParse)

Name
InitPushChoiceProcs

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Initialise le tableau PushChoiceProcs

Source code
procedure InitPushChoiceProcs ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetParsingTable)
Next (InternalParse)


Sepi

Sepi
Previous (InitPushChoiceProcs)
Next (IsNonTerminal)

Name
InternalParse

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure InternalParse ( RootNode : TSepiNonTerminal ) ; override

Parameters
Parameter | Description
RootNode : TSepiNonTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InitPushChoiceProcs)
Next (IsNonTerminal)


Sepi

Sepi
Previous (InternalParse)
Next (IsTerminal)

Name
IsNonTerminal

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function IsNonTerminal ( Symbol : TSepiSymbolClass ) : Boolean ; virtual ; abstract

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InternalParse)
Next (IsTerminal)


Sepi

Sepi
Previous (IsNonTerminal)
Next (ParseTerminal)

Name
IsTerminal

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function IsTerminal ( Symbol : TSepiSymbolClass ) : Boolean ; virtual ; abstract

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsNonTerminal)
Next (ParseTerminal)


Sepi

Sepi
Previous (IsTerminal)
Next (PopTry)

Name
ParseTerminal

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Analyse un terminal

Source code
procedure ParseTerminal ( Symbol : TSepiSymbolClass )

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | Symbole de terminal attendu

Sepi
Class Tree
Index
Previous (IsTerminal)
Next (PopTry)


Sepi

Sepi
Previous (ParseTerminal)
Next (PushBackToParent)

Name
PopTry

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
Pop un try de la pile prédictive

Source code
procedure PopTry

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ParseTerminal)
Next (PushBackToParent)


Sepi

Sepi
Previous (PopTry)
Next (PushEmptyChoice)

Name
PushBackToParent

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Push un code indiquant de remonter au parent sur la pile prédictive

Source code
procedure PushBackToParent

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PopTry)
Next (PushEmptyChoice)


Sepi

Sepi
Previous (PushBackToParent)
Next (PushFakeSymbol)

Name
PushEmptyChoice

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Push un choix vide sur la pile prédictive

Source code
procedure PushEmptyChoice

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (PushBackToParent)
Next (PushFakeSymbol)


Sepi

Sepi
Previous (PushEmptyChoice)
Next (PushSymbol)

Name
PushFakeSymbol

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Push un faux symbole grammatical sur la pile prédictive
Un faux symbole sera emballé dans un TSepiFakeNonTerminal, et n'apparaîtra
donc pas réellement dans l'arbre syntaxique.

Source code
procedure PushFakeSymbol ( Symbol : TSepiSymbolClass )

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | Symbole à placer

Sepi
Class Tree
Index
Previous (PushEmptyChoice)
Next (PushSymbol)


Sepi

Sepi
Previous (PushFakeSymbol)
Next (PushTry)

Name
PushSymbol

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Push un symbole grammatical sur la pile prédictive

Source code
procedure PushSymbol ( Symbol : TSepiSymbolClass )

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | Symbole à placer

Sepi
Class Tree
Index
Previous (PushFakeSymbol)
Next (PushTry)


Sepi

Sepi
Previous (PushSymbol)
Next (SetCurrent)

Name
PushTry

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Push un try sur la pile prédictive

Source code
procedure PushTry ( AltRule : TRuleID )

Parameters
Parameter | Description
AltRule : TRuleID | Règle alternative

Sepi
Class Tree
Index
Previous (PushSymbol)
Next (SetCurrent)


Sepi

Sepi
Previous (PushTry)
Next (UnwindTry)

Name
SetCurrent

Parent
TSepiCustomLL1Parser

Visibility
PRIVATE

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure SetCurrent ( Value : TSepiNonTerminal )

Parameters
Parameter | Description
Value : TSepiNonTerminal | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PushTry)
Next (UnwindTry)


Sepi

Sepi
Previous (SetCurrent)
Next (UnwindTryOrSyntaxError)

Name
UnwindTry

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Déroule le try courant

Source code
procedure UnwindTry

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (SetCurrent)
Next (UnwindTryOrSyntaxError)


Sepi

Sepi
Previous (UnwindTry)
Next (UnwindTryOrSyntaxError)

Name
UnwindTryOrSyntaxError

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Déroule le try courant s'il y en a un, sinon produit une erreur de syntaxe

Source code
procedure UnwindTryOrSyntaxError ( ExpectedSymbol : TSepiSymbolClass ) ; overload

Parameters
Parameter | Description
ExpectedSymbol : TSepiSymbolClass | Symbole attendu, si erreur

Sepi
Class Tree
Index
Previous (UnwindTry)
Next (UnwindTryOrSyntaxError)


Sepi

Sepi
Previous (UnwindTryOrSyntaxError)
Next

Name
UnwindTryOrSyntaxError

Parent
TSepiCustomLL1Parser

Visibility
PROTECTED

Description
Déroule le try courant s'il y en a un, sinon produit une erreur de syntaxe

Source code
procedure UnwindTryOrSyntaxError ( const Expected : string ) ; overload

Parameters
Parameter | Description
Expected : STRING | Représentation de ce qui était attendu, si erreur

Sepi
Class Tree
Index
Previous (UnwindTryOrSyntaxError)
Next


Sepi

Sepi
Previous (TSepiCustomLL1Parser)
Next (TSepiLL1ParsingStack)

Name
TSepiFakeNonTerminal

Parent
SepiLL1ParserUtils

Class Hierarchy
TSepiHiddenNonTerminal

Visibility
PUBLIC

Description
Faux non-terminal
Un faux non-terminal ne s'attache pas à son parent, et se libère
automatiquement dès que son analyse est terminée.

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCustomLL1Parser)
Next (TSepiLL1ParsingStack)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiFakeNonTerminal

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiFakeNonTerminal)
Next (TTryTag)

Name
TSepiLL1ParsingStack

Parent
SepiLL1ParserUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Pile d'un analyse syntaxique LL(1)

Members
Fields
Field | Description
FStack (-) | Pile interne
FTryCount (-) | Indique le nombre d'imbrication de try

Methods
Method | Description
Create (+) | Crée une nouvelle pile d'analyse syntaxique LL(1)
Destroy (+) | [@inheritDoc]
GetEmpty (-) | Teste si la pile est vide
GetIsInTry (-) | Indique si la pile est dans un try
Pop (+) | Pop un symbole du haut de la pile
PopTry (+) | Pop un try du sommet de la pile et libère son tag
Push (+) | Push un symbole sur la pile
PushTry (+) | Push un try sur la pile
UnwindTry (+) | Déroule la pile jusqu'à trouver un try, le retire et récupère le tag

Properties
Property | Description
Empty (+) | Teste si la pile est vide
IsInTry (+) | Indique si la pile est dans un try

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFakeNonTerminal)
Next (TTryTag)


Sepi

Sepi
Previous
Next (FTryCount)

Name
FStack

Parent
TSepiLL1ParsingStack

Visibility
PRIVATE

Description
Pile interne

Source code
FStack : TStack

Sepi
Class Tree
Index
Previous
Next (FTryCount)


Sepi

Sepi
Previous (FStack)
Next

Name
FTryCount

Parent
TSepiLL1ParsingStack

Visibility
PRIVATE

Description
Indique le nombre d'imbrication de try

Source code
FTryCount : Integer

Sepi
Class Tree
Index
Previous (FStack)
Next


Sepi

Sepi
Previous
Next (IsInTry)

Name
Empty

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Teste si la pile est vide

Source code
property Empty : Boolean read GetEmpty

Read Access
GetEmpty

Sepi
Class Tree
Index
Previous
Next (IsInTry)


Sepi

Sepi
Previous (Empty)
Next

Name
IsInTry

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Indique si la pile est dans un try

Source code
property IsInTry : Boolean read GetIsInTry

Read Access
GetIsInTry

Sepi
Class Tree
Index
Previous (Empty)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Crée une nouvelle pile d'analyse syntaxique LL(1)

Source code
constructor Create ( StartSymbol : TSepiSymbolClass )

Parameters
Parameter | Description
StartSymbol : TSepiSymbolClass | Symbole de départ de la grammaire

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetEmpty)

Name
Destroy

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetEmpty)


Sepi

Sepi
Previous (Destroy)
Next (GetIsInTry)

Name
GetEmpty

Parent
TSepiLL1ParsingStack

Visibility
PRIVATE

Description
Teste si la pile est vide

Source code
function GetEmpty : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si la pile est vide, False sinon

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetIsInTry)


Sepi

Sepi
Previous (GetEmpty)
Next (Pop)

Name
GetIsInTry

Parent
TSepiLL1ParsingStack

Visibility
PRIVATE

Description
Indique si la pile est dans un try

Source code
function GetIsInTry : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si la pile est dans un try, False sinon

Sepi
Class Tree
Index
Previous (GetEmpty)
Next (Pop)


Sepi

Sepi
Previous (GetIsInTry)
Next (PopTry)

Name
Pop

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Pop un symbole du haut de la pile

Source code
function Pop : TSepiSymbolClass

Parameters
Parameter Description

Return
Types | Description
TSepiSymbolClass | Symbole poppé

Sepi
Class Tree
Index
Previous (GetIsInTry)
Next (PopTry)


Sepi

Sepi
Previous (Pop)
Next (Push)

Name
PopTry

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Pop un try du sommet de la pile et libère son tag

Source code
procedure PopTry

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Pop)
Next (Push)


Sepi

Sepi
Previous (PopTry)
Next (PushTry)

Name
Push

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Push un symbole sur la pile

Source code
procedure Push ( Symbol : TSepiSymbolClass )

Parameters
Parameter | Description
Symbol : TSepiSymbolClass | Symbole à pusher sur la pile

Sepi
Class Tree
Index
Previous (PopTry)
Next (PushTry)


Sepi

Sepi
Previous (Push)
Next (UnwindTry)

Name
PushTry

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Push un try sur la pile

Source code
procedure PushTry ( Tag : TObject )

Parameters
Parameter | Description
Tag : TObject | Tag à apposer au try

Sepi
Class Tree
Index
Previous (Push)
Next (UnwindTry)


Sepi

Sepi
Previous (PushTry)
Next

Name
UnwindTry

Parent
TSepiLL1ParsingStack

Visibility
PUBLIC

Description
Déroule la pile jusqu'à trouver un try, le retire et récupère le tag

Source code
function UnwindTry : TObject

Parameters
Parameter Description

Return
Types | Description
TObject | Tag apposé au try

Sepi
Class Tree
Index
Previous (PushTry)
Next


Sepi

Sepi
Previous (TSepiLL1ParsingStack)
Next

Name
TTryTag

Parent
SepiLL1ParserUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Tag marquant un try dans la pile prédictive
Sauf cas exceptionnels, vous ne devriez pas vous servir directement de
TTryTag. Cette classe est utilisée en interne par TSepiCustomLL1Parser pour
marquer un try dans sa pile prédictive.

Members
Fields
Field | Description
FAltRule (-) | Règle alternative
FBookmark (-) | Marque-page de l'analyseur lexical
FCurrent (-) | Non-terminal courant sur ce try

Methods
Method | Description
Create (+) | Crée un tag de try
Destroy (+) | [@inheritDoc]

Properties
Property | Description
AltRule (+) | Règle alternative
Bookmark (+) | Marque-page de l'analyseur lexical
Current (+) | Non-terminal courant sur ce try

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLL1ParsingStack)
Next


Sepi

Sepi
Previous
Next (FBookmark)

Name
FAltRule

Parent
TTryTag

Visibility
PRIVATE

Description
Règle alternative

Source code
FAltRule : TRuleID

Sepi
Class Tree
Index
Previous
Next (FBookmark)


Sepi

Sepi
Previous (FAltRule)
Next (FCurrent)

Name
FBookmark

Parent
TTryTag

Visibility
PRIVATE

Description
Marque-page de l'analyseur lexical

Source code
FBookmark : TSepiLexerBookmark

Sepi
Class Tree
Index
Previous (FAltRule)
Next (FCurrent)


Sepi

Sepi
Previous (FBookmark)
Next

Name
FCurrent

Parent
TTryTag

Visibility
PRIVATE

Description
Non-terminal courant sur ce try

Source code
FCurrent : TSepiNonTerminal

Sepi
Class Tree
Index
Previous (FBookmark)
Next


Sepi

Sepi
Previous
Next (Bookmark)

Name
AltRule

Parent
TTryTag

Visibility
PUBLIC

Description
Règle alternative

Source code
property AltRule : TRuleID read FAltRule

Read Access
FAltRule

Sepi
Class Tree
Index
Previous
Next (Bookmark)


Sepi

Sepi
Previous (AltRule)
Next (Current)

Name
Bookmark

Parent
TTryTag

Visibility
PUBLIC

Description
Marque-page de l'analyseur lexical

Source code
property Bookmark : TSepiLexerBookmark read FBookmark

Read Access
FBookmark

Sepi
Class Tree
Index
Previous (AltRule)
Next (Current)


Sepi

Sepi
Previous (Bookmark)
Next

Name
Current

Parent
TTryTag

Visibility
PUBLIC

Description
Non-terminal courant sur ce try

Source code
property Current : TSepiNonTerminal read FCurrent

Read Access
FCurrent

Sepi
Class Tree
Index
Previous (Bookmark)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TTryTag

Visibility
PUBLIC

Description
Crée un tag de try

Source code
constructor Create ( ABookmark : TSepiLexerBookmark ; AAltRule : TRuleID ; ACurrent : TSepiNonTerminal )

Parameters
Parameter | Description
ABookmark : TSepiLexerBookmark | Marque-page de l'analyseur lexical
AAltRule : TRuleID | Règle alternative
ACurrent : TSepiNonTerminal | Non-terminal courant sur ce try

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next

Name
Destroy

Parent
TTryTag

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous
Next (TRuleID)

Name
TPushChoiceProc

Parent
SepiLL1ParserUtils

Visibility
PUBLIC

Description
Procédure de push d'un choix sur la pile prédictive

Source code
TPushChoiceProc = procedure of object ;

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (TRuleID)


Sepi

Sepi
Previous (TPushChoiceProc)
Next

Name
TRuleID

Parent
SepiLL1ParserUtils

Visibility
PUBLIC

Description
Identificateur de règle (contenu des tables d'analyse)

Source code
TRuleID = type Smallint ;

Sepi
Class Tree
Index
Previous (TPushChoiceProc)
Next


Sepi

Sepi
Previous (SepiLL1ParserUtils)
Next (SepiOpCodes)

Name
SepiMembers

Parent
Sepi

Description
Définit les classes de gestion des types composites

Author
sjrd

Version
1.0

Types
Type | Description
PSepiInterfaceEntry (+) | Pointeur vers TSepiInterfaceEntry
TCallingConvention (+) | Convention d'appel d'une méthode
TMethodLinkKind (+) | Type de liaison d'une méthode
TPropertyAccessKind (+) | Type d'accesseur d'une propriété
TPropertyStorageKind (+) | Type de stockage d'une propriété
TSepiClassField (+) | Champ de classe
TSepiHiddenParamKind (+) | Type de paramètre caché
TSepiParamKind (+) | Type de paramètre
TSepiParamPlace (+) | Emplacement d'un paramètre
TSepiSignatureCompareOption (+) | Option de comparaison de signatures (et paramètres)
TSepiSignatureCompareOptions (+) | Options de comparaison de signatures (et paramètres)
TSepiSignatureKind (+) | Type de signature

Constants
Constant | Description
CallingConventionStrings (+) | Chaînes des conventions d'appel
hfFieldSize (+) | Taille des champs cachés dans un objet
HiddenParamNames (+) | Noms des paramètres cachés
LinkKindStrings (+) | Chaînes des types de liaison de méthodes
NoDefaultValue (+) | Pas de valeur par défaut
NoIndex (+) | Pas d'index
OverloadedNameFormat (+) | Format du nom d'une méthode surchargée
ParamKindStrings (+) | Chaînes des types de paramètre
pcoAll (+) | Comparaison stricte des paramètres
pcoCompatibility (+) | Comparaison des paramètres pour compatibilité d'assignation
pcoDeclaration (+) | Comparaison des paramètres pour recherche de la déclaration
pcoInheritance (+) | Comparaison des paramètres pour recherche de la méthode héritée
scoAll (+) | Comparaison stricte des signatures
scoCompatibility (+) | Comparaison des signatures pour compatibilité d'assignation
scoDeclaration (+) | Comparaison des signatures pour recherche de la déclaration
scoInheritance (+) | Comparaison des signatures pour recherche de la méthode héritée
SignatureKindStrings (+) | Chaînes des types de méthode
skAll (+) | Tous les types de signature
skAnyProperty (+) | Propriété (d'objet ou de classe)
skFunction (+) | Fonction (statique, d'objet ou de classe)
skProcedure (+) | Procédure (statique, d'objet ou de classe)
skWithReturnType (+) | Types de signature avec valeur de retour
skWithSelfParam (+) | Types de signature avec un paramètre Self

Methods
Method Description

Classes
Class | Description
TSepiClass (+) | Classe (type objet)
TSepiField (+) | Champ
TSepiInheritableContainerType (+) | Type conteneur qui peut être hérité
TSepiInterface (+) | Interface
TSepiInterfaceEntry (+) | Entrée d'interface pour les classes Sepi
TSepiIntfMethodRedirector (+) | Redirecteur de méthode d'interface pour une classe Sepi
TSepiMetaClass (+) | Meta-classe (type classe)
TSepiMethod (+) | Méthode ou routine
TSepiMethodBase (+) | Classe de base pour les classes TSepiMethod et TSepiOverloadedMethod
TSepiMethodRefType (+) | Type référence de méthode
TSepiOverloadedMethod (+) | Méthode ou routine surchargée
TSepiParam (+) | Paramètre de méthode
TSepiParamCallInfo (+) | Informations d'appel d'un paramètre (où et comment le passer)
TSepiProperty (+) | Propriété
TSepiPropertyAccess (+) | Accès de propriété
TSepiPropertyStorage (+) | Stockage de propriété
TSepiRecordType (+) | Type enregistrement
TSepiSignature (+) | Signature de routine, méthode ou propriété
TSepiTextFileType (+) | Type fichier texte (Text)
TSepiVariantType (+) | Type variant

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiLL1ParserUtils)
Next (SepiOpCodes)


Sepi

Sepi
Previous
Next (TSepiField)

Name
TSepiClass

Parent
SepiMembers

Class Hierarchy
TSepiInheritableContainerType

Visibility
PUBLIC

Description
Classe (type objet)

Members
Fields
Field | Description
FDefaultProperty (-) | Propriété tableau par défaut
FDelphiClass (-) | Classe Delphi
FDMTNextIndex (-) | Prochain index à utiliser dans la DMT
FInstSize (-) | Taille d'une instance de la classe
FInterfaces (-) | Interfaces supportées par la classe
FIntfMethodRedirectors (-) | Redirecteurs de méthodes d'interface
FParent (-) | Classe parent (nil si n'existe pas - TObject)
FPublishedPropCount (-) | Nombre de propriétés publiées
FStoredInstSize (-) | Valeur de FInstSize telle que stockée
FVMTSize (-) | Taille de la VMT dans les index positifs

Methods
Method | Description
AddField (+) | Ajoute un champ à la classe
AddInterface (+) | Ajoute le support d'une interface
AddIntfMethodRedirector (+) | Ajoute un redirecteur de méthode d'interface
AddMethod (+) | Ajoute une méthode à la classe
AddMethod (+) | Ajoute une méthode à la classe
AddMethod (+) | Ajoute une méthode à la classe
AddOverloadedMethod (+) | Ajoute une méthode surchargée à la classe
AddOverloadedMethod (+) | Ajoute une méthode surchargée à la classe
AddOverloadedMethod (+) | Ajoute une méthode surchargée à la classe
AddProperty (+) | Ajoute une propriété à la classe
AddProperty (+) | Ajoute une propriété à la classe
AddProperty (+) | Ajoute une propriété à la classe
ChildAdded (#) | [@inheritDoc]
ClassImplementsInterface (+) | Détermine si la classe implémente une interface donnée
ClassInheritsFrom (+) | Détermine si la classe hérite d'une classe donnée
CompatibleWith (+) | [@inheritDoc]
Complete (+) | [@inheritDoc]
Create (+) | Crée une nouvelle classe
Destroy (+) | Détruit l'instance
Equals (+) | [@inheritDoc]
FindIntfMethodImpl (#) | Trouve la méthode qui implémente une méthode d'interface
ForwardDecl (+) | Déclare un type classe en forward
GetDescription (#) | [@inheritDoc]
GetInterfaceCount (-) | Nombre d'interfaces supportées
GetInterfaces (-) | Tableau zero-based des interfaces supportées
GetParentContainer (#) | [@inheritDoc]
GetTotalInstSize (-) | Taille totale d'instance (incluant les champs cachés)
GetVMTEntries (-) | VMT de la classe, indexée par les constantes vmtXXX
HasAnyRedirectorFor (#) | Teste si cette classe a un quelconque redirecteur pour une interface donnée
IsIntfMethodRedirected (#) | Teste si une méthode d'interface est redirigée dans cette class
ListCompleteIMTInterfaces (-) | Liste les interfaces qui doivent avoir une IMT complète
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une classe depuis un flux
LoadInitialDataFromParent (-) | Charge les données initiales depuis le parent de cette classe
MakeCompleteIMTs (-) | Construit les IMTs complètes
MakeDMT (-) | Construit la DMT
MakeFieldTable (-) | Construit la table des champs publiés
MakeIMT (-) | Construit une IMT non native
MakeIMTRedirects (-) | Construit les IMTs redirigées vers d'autres IMTs (complètes)
MakeIMTs (-) | Construit les IMTs
MakeInitTable (-) | Construit la table d'initialisation
MakeIntfTable (-) | Construit la table des interfaces
MakeMethodTable (-) | Construit la table des méthodes publiées
MakeRuntimeInfo (#) | [@inheritDoc]
MakeVMT (-) | Construit la VMT
ReadNativeIMTs (-) | Lit la table des IMTs natives pour obtenir les offsets réels
RedefineProperty (+) | Redéfinit une propriété héritée
RedefineProperty (+) | Redéfinit une propriété héritée
RedefineProperty (+) | Redéfinit une propriété héritée
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
SetVMTEntries (-) | Modifie la VMT de la classe, indexée par les constantes vmtXXX
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
DefaultProperty (+) | Propriété tableau par défaut
DelphiClass (+) | Classe Delphi
InstSize (+) | Taille d'une instance de la classe
InterfaceCount (+) | Nombre d'interfaces supportées
Interfaces (+) | Tableau zero-based des interfaces supportées
Parent (+) | Classe parent (nil si n'existe pas - TObject)
TotalInstSize (+) | Taille totale d'instance (incluant les champs cachés)
VMTEntries (#) | VMT de la classe, indexée par les constantes vmtXXX
VMTSize (+) | Taille de la VMT dans les index positifs

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiField)


Sepi

Sepi
Previous
Next (FDelphiClass)

Name
FDefaultProperty

Parent
TSepiClass

Visibility
PRIVATE

Description
Propriété tableau par défaut

Source code
FDefaultProperty : TSepiProperty

Sepi
Class Tree
Index
Previous
Next (FDelphiClass)


Sepi

Sepi
Previous (FDefaultProperty)
Next (FDMTNextIndex)

Name
FDelphiClass

Parent
TSepiClass

Visibility
PRIVATE

Description
Classe Delphi

Source code
FDelphiClass : TClass

Sepi
Class Tree
Index
Previous (FDefaultProperty)
Next (FDMTNextIndex)


Sepi

Sepi
Previous (FDelphiClass)
Next (FInstSize)

Name
FDMTNextIndex

Parent
TSepiClass

Visibility
PRIVATE

Description
Prochain index à utiliser dans la DMT

Source code
FDMTNextIndex : Integer

Sepi
Class Tree
Index
Previous (FDelphiClass)
Next (FInstSize)


Sepi

Sepi
Previous (FDMTNextIndex)
Next (FInterfaces)

Name
FInstSize

Parent
TSepiClass

Visibility
PRIVATE

Description
Taille d'une instance de la classe

Source code
FInstSize : Integer

Sepi
Class Tree
Index
Previous (FDMTNextIndex)
Next (FInterfaces)


Sepi

Sepi
Previous (FInstSize)
Next (FIntfMethodRedirectors)

Name
FInterfaces

Parent
TSepiClass

Visibility
PRIVATE

Description
Interfaces supportées par la classe

Source code
FInterfaces : array of TSepiInterfaceEntry

Sepi
Class Tree
Index
Previous (FInstSize)
Next (FIntfMethodRedirectors)


Sepi

Sepi
Previous (FInterfaces)
Next (FParent)

Name
FIntfMethodRedirectors

Parent
TSepiClass

Visibility
PRIVATE

Description
Redirecteurs de méthodes d'interface

Source code
FIntfMethodRedirectors : array of TSepiIntfMethodRedirector

Sepi
Class Tree
Index
Previous (FInterfaces)
Next (FParent)


Sepi

Sepi
Previous (FIntfMethodRedirectors)
Next (FPublishedPropCount)

Name
FParent

Parent
TSepiClass

Visibility
PRIVATE

Description
Classe parent (nil si n'existe pas - TObject)

Source code
FParent : TSepiClass

Sepi
Class Tree
Index
Previous (FIntfMethodRedirectors)
Next (FPublishedPropCount)


Sepi

Sepi
Previous (FParent)
Next (FStoredInstSize)

Name
FPublishedPropCount

Parent
TSepiClass

Visibility
PRIVATE

Description
Nombre de propriétés publiées

Source code
FPublishedPropCount : Integer

Sepi
Class Tree
Index
Previous (FParent)
Next (FStoredInstSize)


Sepi

Sepi
Previous (FPublishedPropCount)
Next (FVMTSize)

Name
FStoredInstSize

Parent
TSepiClass

Visibility
PRIVATE

Description
Valeur de FInstSize telle que stockée

Source code
FStoredInstSize : Integer

Sepi
Class Tree
Index
Previous (FPublishedPropCount)
Next (FVMTSize)


Sepi

Sepi
Previous (FStoredInstSize)
Next

Name
FVMTSize

Parent
TSepiClass

Visibility
PRIVATE

Description
Taille de la VMT dans les index positifs

Source code
FVMTSize : Integer

Sepi
Class Tree
Index
Previous (FStoredInstSize)
Next


Sepi

Sepi
Previous
Next (DelphiClass)

Name
DefaultProperty

Parent
TSepiClass

Visibility
PUBLIC

Description
Propriété tableau par défaut

Source code
property DefaultProperty : TSepiProperty read FDefaultProperty

Read Access
FDefaultProperty

Sepi
Class Tree
Index
Previous
Next (DelphiClass)


Sepi

Sepi
Previous (DefaultProperty)
Next (InstSize)

Name
DelphiClass

Parent
TSepiClass

Visibility
PUBLIC

Description
Classe Delphi

Source code
property DelphiClass : TClass read FDelphiClass

Read Access
FDelphiClass

Sepi
Class Tree
Index
Previous (DefaultProperty)
Next (InstSize)


Sepi

Sepi
Previous (DelphiClass)
Next (InterfaceCount)

Name
InstSize

Parent
TSepiClass

Visibility
PUBLIC

Description
Taille d'une instance de la classe

Source code
property InstSize : Integer read FInstSize

Read Access
FInstSize

Sepi
Class Tree
Index
Previous (DelphiClass)
Next (InterfaceCount)


Sepi

Sepi
Previous (InstSize)
Next (Interfaces)

Name
InterfaceCount

Parent
TSepiClass

Visibility
PUBLIC

Description
Nombre d'interfaces supportées

Source code
property InterfaceCount : Integer read GetInterfaceCount

Read Access
GetInterfaceCount

Sepi
Class Tree
Index
Previous (InstSize)
Next (Interfaces)


Sepi

Sepi
Previous (InterfaceCount)
Next (Parent)

Name
Interfaces

Parent
TSepiClass

Visibility
PUBLIC

Description
Tableau zero-based des interfaces supportées

Source code
property Interfaces [ Index : Integer ] : TSepiInterface read GetInterfaces

Read Access
GetInterfaces

Sepi
Class Tree
Index
Previous (InterfaceCount)
Next (Parent)


Sepi

Sepi
Previous (Interfaces)
Next (TotalInstSize)

Name
Parent

Parent
TSepiClass

Visibility
PUBLIC

Description
Classe parent (nil si n'existe pas - TObject)

Source code
property Parent : TSepiClass read FParent

Read Access
FParent

Sepi
Class Tree
Index
Previous (Interfaces)
Next (TotalInstSize)


Sepi

Sepi
Previous (Parent)
Next (VMTEntries)

Name
TotalInstSize

Parent
TSepiClass

Visibility
PUBLIC

Description
Taille totale d'instance (incluant les champs cachés)

Source code
property TotalInstSize : Integer read GetTotalInstSize

Read Access
GetTotalInstSize

Sepi
Class Tree
Index
Previous (Parent)
Next (VMTEntries)


Sepi

Sepi
Previous (TotalInstSize)
Next (VMTSize)

Name
VMTEntries

Parent
TSepiClass

Visibility
PROTECTED

Description
VMT de la classe, indexée par les constantes vmtXXX

Source code
property VMTEntries [ Index : Integer ] : Pointer read GetVMTEntries write SetVMTEntries

Read Access
GetVMTEntries

Write Access
SetVMTEntries

Sepi
Class Tree
Index
Previous (TotalInstSize)
Next (VMTSize)


Sepi

Sepi
Previous (VMTEntries)
Next

Name
VMTSize

Parent
TSepiClass

Visibility
PUBLIC

Description
Taille de la VMT dans les index positifs

Source code
property VMTSize : Integer read FVMTSize

Read Access
FVMTSize

Sepi
Class Tree
Index
Previous (VMTEntries)
Next


Sepi

Sepi
Previous
Next (AddInterface)

Name
AddField

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute un champ à la classe

Source code
function AddField ( const FieldName : string ; FieldType : TSepiType ; ForcePack : Boolean = False ) : TSepiField

Parameters
Parameter | Description
FieldName : STRING | Nom du champ
FieldType : TSepiType | Type du champ
ForcePack : BOOLEAN | Force un pack sur ce champ si True

Return
Types | Description
TSepiField | Champ nouvellement ajouté

Sepi
Class Tree
Index
Previous
Next (AddInterface)


Sepi

Sepi
Previous (AddField)
Next (AddIntfMethodRedirector)

Name
AddInterface

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute le support d'une interface

Source code
procedure AddInterface ( AInterface : TSepiInterface )

Parameters
Parameter | Description
AInterface : TSepiInterface | Interface à supporter

Sepi
Class Tree
Index
Previous (AddField)
Next (AddIntfMethodRedirector)


Sepi

Sepi
Previous (AddInterface)
Next (AddMethod)

Name
AddIntfMethodRedirector

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute un redirecteur de méthode d'interface

Source code
procedure AddIntfMethodRedirector ( Intf : TSepiInterface ; IntfMethod : TSepiMethod ; const RedirectorName : string )

Parameters
Parameter | Description
Intf : TSepiInterface | Interface dont rediriger une méthode
IntfMethod : TSepiMethod | Méthode d'interface à rediriger
RedirectorName : STRING | Nom du redirecteur

Sepi
Class Tree
Index
Previous (AddInterface)
Next (AddMethod)


Sepi

Sepi
Previous (AddIntfMethodRedirector)
Next (AddMethod)

Name
AddMethod

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une méthode à la classe

Source code
function AddMethod ( const MethodName : string ; ACode : Pointer ; const ASignature : string ; ACallingConvention : TCallingConvention ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : STRING | Signature Delphi de la méthode
ACallingConvention : TCallingConvention | Convention d'appel de la méthode

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddIntfMethodRedirector)
Next (AddMethod)


Sepi

Sepi
Previous (AddMethod)
Next (AddMethod)

Name
AddMethod

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une méthode à la classe

Source code
function AddMethod ( const MethodName : string ; ACode : Pointer ; ASignature : TSepiSignature ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : TSepiSignature | Signature Delphi de la méthode
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddMethod)
Next (AddMethod)


Sepi

Sepi
Previous (AddMethod)
Next (AddOverloadedMethod)

Name
AddMethod

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une méthode à la classe

Source code
function AddMethod ( const MethodName : string ; ACode : Pointer ; const ASignature : string ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ; ACallingConvention : TCallingConvention = ccRegister ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : STRING | Signature Delphi de la méthode
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté
ACallingConvention : TCallingConvention | Convention d'appel de la méthode

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddMethod)
Next (AddOverloadedMethod)


Sepi

Sepi
Previous (AddMethod)
Next (AddOverloadedMethod)

Name
AddOverloadedMethod

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une méthode surchargée à la classe

Source code
function AddOverloadedMethod ( const MethodName : string ; ACode : Pointer ; const ASignature : string ; ACallingConvention : TCallingConvention ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : STRING | Signature Delphi de la méthode
ACallingConvention : TCallingConvention | Convention d'appel de la méthode

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddMethod)
Next (AddOverloadedMethod)


Sepi

Sepi
Previous (AddOverloadedMethod)
Next (AddOverloadedMethod)

Name
AddOverloadedMethod

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une méthode surchargée à la classe

Source code
function AddOverloadedMethod ( const MethodName : string ; ACode : Pointer ; const ASignature : string ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ; ACallingConvention : TCallingConvention = ccRegister ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : STRING | Signature Delphi de la méthode
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté
ACallingConvention : TCallingConvention | Convention d'appel de la méthode

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddOverloadedMethod)
Next (AddOverloadedMethod)


Sepi

Sepi
Previous (AddOverloadedMethod)
Next (AddProperty)

Name
AddOverloadedMethod

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une méthode surchargée à la classe

Source code
function AddOverloadedMethod ( const MethodName : string ; ACode : Pointer ; ASignature : TSepiSignature ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : TSepiSignature | Signature Delphi de la méthode
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddOverloadedMethod)
Next (AddProperty)


Sepi

Sepi
Previous (AddOverloadedMethod)
Next (AddProperty)

Name
AddProperty

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une propriété à la classe

Source code
function AddProperty ( const AName , ASignature , AReadAccess , AWriteAccess : string ; AIsDefault : Boolean ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
ASignature : STRING | Signature
AReadAccess : STRING | Accès en lecture à la propriété (peut être vide)
AWriteAccess : STRING | Accès en écriture à la propriété (peut être vide)
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddOverloadedMethod)
Next (AddProperty)


Sepi

Sepi
Previous (AddProperty)
Next (AddProperty)

Name
AddProperty

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une propriété à la classe

Source code
function AddProperty ( const AName , ASignature , AReadAccess , AWriteAccess : string ; AIndex : Integer = NoIndex ; ADefaultValue : Integer = NoDefaultValue ; const AStorage : string = '' ; AIsDefault : Boolean = False ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
ASignature : STRING | Signature
AReadAccess : STRING | Accès en lecture à la propriété (peut être vide)
AWriteAccess : STRING | Accès en écriture à la propriété (peut être vide)
AIndex : INTEGER | Index d'accès
ADefaultValue : INTEGER | Valeur par défaut de la propriété
AStorage : STRING
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddProperty)
Next (AddProperty)


Sepi

Sepi
Previous (AddProperty)
Next (ChildAdded)

Name
AddProperty

Parent
TSepiClass

Visibility
PUBLIC

Description
Ajoute une propriété à la classe

Source code
function AddProperty ( const AName : string ; ASignature : TSepiSignature ; AReadAccess , AWriteAccess : TSepiMember ; AIndex , ADefaultValue : Integer ; const AStorage : TSepiPropertyStorage ; AIsDefault : Boolean ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
ASignature : TSepiSignature | Signature
AReadAccess : TSepiMember | Accès en lecture à la propriété (peut être nil)
AWriteAccess : TSepiMember | Accès en écriture à la propriété (peut être nil)
AIndex : INTEGER | Index d'accès
ADefaultValue : INTEGER | Valeur par défaut de la propriété
AStorage : TSepiPropertyStorage
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddProperty)
Next (ChildAdded)


Sepi

Sepi
Previous (AddProperty)
Next (ClassImplementsInterface)

Name
ChildAdded

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildAdded ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddProperty)
Next (ClassImplementsInterface)


Sepi

Sepi
Previous (ChildAdded)
Next (ClassInheritsFrom)

Name
ClassImplementsInterface

Parent
TSepiClass

Visibility
PUBLIC

Description
Détermine si la classe implémente une interface donnée

Source code
function ClassImplementsInterface ( AInterface : TSepiInterface ) : Boolean

Parameters
Parameter | Description
AInterface : TSepiInterface | Interface à tester

Return
Types | Description
BOOLEAN | True si la classe implémente AInterface, False sinon

Sepi
Class Tree
Index
Previous (ChildAdded)
Next (ClassInheritsFrom)


Sepi

Sepi
Previous (ClassImplementsInterface)
Next (CompatibleWith)

Name
ClassInheritsFrom

Parent
TSepiClass

Visibility
PUBLIC

Description
Détermine si la classe hérite d'une classe donnée

Source code
function ClassInheritsFrom ( AParent : TSepiClass ) : Boolean

Parameters
Parameter | Description
AParent : TSepiClass | Ancêtre à tester

Return
Types | Description
BOOLEAN | True si la classe hérite de AParent, False sinon

Sepi
Class Tree
Index
Previous (ClassImplementsInterface)
Next (CompatibleWith)


Sepi

Sepi
Previous (ClassInheritsFrom)
Next (Complete)

Name
CompatibleWith

Parent
TSepiClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ClassInheritsFrom)
Next (Complete)


Sepi

Sepi
Previous (CompatibleWith)
Next (Create)

Name
Complete

Parent
TSepiClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Complete ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Destroy)

Name
Create

Parent
TSepiClass

Visibility
PUBLIC

Description
Crée une nouvelle classe

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AParent : TSepiClass )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AParent : TSepiClass | Classe parent

Sepi
Class Tree
Index
Previous (Complete)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Equals)

Name
Destroy

Parent
TSepiClass

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Equals)


Sepi

Sepi
Previous (Destroy)
Next (FindIntfMethodImpl)

Name
Equals

Parent
TSepiClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (FindIntfMethodImpl)


Sepi

Sepi
Previous (Equals)
Next (ForwardDecl)

Name
FindIntfMethodImpl

Parent
TSepiClass

Visibility
PROTECTED

Description
Trouve la méthode qui implémente une méthode d'interface

Source code
function FindIntfMethodImpl ( Intf : TSepiInterface ; IntfMethod : TSepiMethod ; FromClass : TSepiClass ) : TSepiMethod

Parameters
Parameter | Description
Intf : TSepiInterface | Interface dont on cherche l'implémentation
IntfMethod : TSepiMethod | Méthode d'interface dont on cherche l'implémentation
FromClass : TSepiClass | Classe depuis laquelle on cherche

Return
Types | Description
TSepiMethod | Méthode qui implémente, ou nil si non trouvée

Sepi
Class Tree
Index
Previous (Equals)
Next (ForwardDecl)


Sepi

Sepi
Previous (FindIntfMethodImpl)
Next (GetDescription)

Name
ForwardDecl

Parent
TSepiClass

Visibility
PUBLIC

Description
Déclare un type classe en forward

Source code
class function ForwardDecl ( AOwner : TSepiComponent ; const AName : string ) : TSepiClass

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom de la classe

Return
Types | Description
TSepiClass | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (FindIntfMethodImpl)
Next (GetDescription)


Sepi

Sepi
Previous (ForwardDecl)
Next (GetInterfaceCount)

Name
GetDescription

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForwardDecl)
Next (GetInterfaceCount)


Sepi

Sepi
Previous (GetDescription)
Next (GetInterfaces)

Name
GetInterfaceCount

Parent
TSepiClass

Visibility
PRIVATE

Description
Nombre d'interfaces supportées

Source code
function GetInterfaceCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'interfaces supportées

Sepi
Class Tree
Index
Previous (GetDescription)
Next (GetInterfaces)


Sepi

Sepi
Previous (GetInterfaceCount)
Next (GetParentContainer)

Name
GetInterfaces

Parent
TSepiClass

Visibility
PRIVATE

Description
Tableau zero-based des interfaces supportées

Source code
function GetInterfaces ( Index : Integer ) : TSepiInterface

Parameters
Parameter | Description
INDEX : INTEGER | Index dans le tableau

Return
Types | Description
TSepiInterface | Interface supportée à l'index spécifié

Sepi
Class Tree
Index
Previous (GetInterfaceCount)
Next (GetParentContainer)


Sepi

Sepi
Previous (GetInterfaces)
Next (GetTotalInstSize)

Name
GetParentContainer

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetParentContainer : TSepiInheritableContainerType ; override

Parameters
Parameter Description

Return
Types | Description
TSepiInheritableContainerType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetInterfaces)
Next (GetTotalInstSize)


Sepi

Sepi
Previous (GetParentContainer)
Next (GetVMTEntries)

Name
GetTotalInstSize

Parent
TSepiClass

Visibility
PRIVATE

Description
Taille totale d'instance (incluant les champs cachés)

Source code
function GetTotalInstSize : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Taille totale d'instance (incluant les champs cachés)

Sepi
Class Tree
Index
Previous (GetParentContainer)
Next (GetVMTEntries)


Sepi

Sepi
Previous (GetTotalInstSize)
Next (HasAnyRedirectorFor)

Name
GetVMTEntries

Parent
TSepiClass

Visibility
PRIVATE

Description
VMT de la classe, indexée par les constantes vmtXXX

Source code
function GetVMTEntries ( Index : Integer ) : Pointer

Parameters
Parameter | Description
INDEX : INTEGER | Index dans la VMT

Return
Types | Description
Pointer | Information contenue dans la VMT à l'index spécifié

Sepi
Class Tree
Index
Previous (GetTotalInstSize)
Next (HasAnyRedirectorFor)


Sepi

Sepi
Previous (GetVMTEntries)
Next (IsIntfMethodRedirected)

Name
HasAnyRedirectorFor

Parent
TSepiClass

Visibility
PROTECTED

Description
Teste si cette classe a un quelconque redirecteur pour une interface donnée

Source code
function HasAnyRedirectorFor ( Intf : TSepiInterface ) : Boolean

Parameters
Parameter | Description
Intf : TSepiInterface | Interface à tester

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetVMTEntries)
Next (IsIntfMethodRedirected)


Sepi

Sepi
Previous (HasAnyRedirectorFor)
Next (ListCompleteIMTInterfaces)

Name
IsIntfMethodRedirected

Parent
TSepiClass

Visibility
PROTECTED

Description
Teste si une méthode d'interface est redirigée dans cette class

Source code
function IsIntfMethodRedirected ( Intf : TSepiInterface ; IntfMethod : TSepiMethod ) : Boolean

Parameters
Parameter | Description
Intf : TSepiInterface | Interface à tester
IntfMethod : TSepiMethod | Méthode d'interface à tester

Return
Types | Description
BOOLEAN | True si cette méthode est redirigée, False sinon

Sepi
Class Tree
Index
Previous (HasAnyRedirectorFor)
Next (ListCompleteIMTInterfaces)


Sepi

Sepi
Previous (IsIntfMethodRedirected)
Next (ListReferences)

Name
ListCompleteIMTInterfaces

Parent
TSepiClass

Visibility
PRIVATE

Description
Liste les interfaces qui doivent avoir une IMT complète

Source code
procedure ListCompleteIMTInterfaces ( CompleteIMTInterfaces : TObjectList )

Parameters
Parameter | Description
CompleteIMTInterfaces : TObjectList | Liste des interfaces à IMT complète

Sepi
Class Tree
Index
Previous (IsIntfMethodRedirected)
Next (ListReferences)


Sepi

Sepi
Previous (ListCompleteIMTInterfaces)
Next (Load)

Name
ListReferences

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ListCompleteIMTInterfaces)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (LoadInitialDataFromParent)

Name
Load

Parent
TSepiClass

Visibility
PUBLIC

Description
Charge une classe depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (LoadInitialDataFromParent)


Sepi

Sepi
Previous (Load)
Next (MakeCompleteIMTs)

Name
LoadInitialDataFromParent

Parent
TSepiClass

Visibility
PRIVATE

Description
Charge les données initiales depuis le parent de cette classe

Source code
procedure LoadInitialDataFromParent

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Load)
Next (MakeCompleteIMTs)


Sepi

Sepi
Previous (LoadInitialDataFromParent)
Next (MakeDMT)

Name
MakeCompleteIMTs

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit les IMTs complètes

Source code
procedure MakeCompleteIMTs ( CompleteIMTInterfaces : TObjectList )

Parameters
Parameter | Description
CompleteIMTInterfaces : TObjectList | Liste des interfaces à IMT complète

Sepi
Class Tree
Index
Previous (LoadInitialDataFromParent)
Next (MakeDMT)


Sepi

Sepi
Previous (MakeCompleteIMTs)
Next (MakeFieldTable)

Name
MakeDMT

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit la DMT
Range également l'adresse de la DMT à l'emplacement prévu de la VMT.

Source code
procedure MakeDMT

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeCompleteIMTs)
Next (MakeFieldTable)


Sepi

Sepi
Previous (MakeDMT)
Next (MakeIMT)

Name
MakeFieldTable

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit la table des champs publiés
Range également l'adresse de cette table à l'emplacement prévu de la VMT.

Source code
procedure MakeFieldTable

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeDMT)
Next (MakeIMT)


Sepi

Sepi
Previous (MakeFieldTable)
Next (MakeIMTRedirects)

Name
MakeIMT

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit une IMT non native

Source code
procedure MakeIMT ( IntfEntry : PSepiInterfaceEntry )

Parameters
Parameter | Description
IntfEntry : PSepiInterfaceEntry | Entrée de l'IMT à construire

Sepi
Class Tree
Index
Previous (MakeFieldTable)
Next (MakeIMTRedirects)


Sepi

Sepi
Previous (MakeIMT)
Next (MakeIMTs)

Name
MakeIMTRedirects

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit les IMTs redirigées vers d'autres IMTs (complètes)

Source code
procedure MakeIMTRedirects ( CompleteIMTInterfaces : TObjectList )

Parameters
Parameter | Description
CompleteIMTInterfaces : TObjectList | Liste des interfaces à IMT complète

Sepi
Class Tree
Index
Previous (MakeIMT)
Next (MakeIMTs)


Sepi

Sepi
Previous (MakeIMTRedirects)
Next (MakeInitTable)

Name
MakeIMTs

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit les IMTs

Source code
procedure MakeIMTs

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeIMTRedirects)
Next (MakeInitTable)


Sepi

Sepi
Previous (MakeIMTs)
Next (MakeIntfTable)

Name
MakeInitTable

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit la table d'initialisation
Range également l'adresse de cette table à l'emplacement prévu de la VMT.

Source code
procedure MakeInitTable

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeIMTs)
Next (MakeIntfTable)


Sepi

Sepi
Previous (MakeInitTable)
Next (MakeMethodTable)

Name
MakeIntfTable

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit la table des interfaces
Range également l'adresse de cette table à l'emplacement prévu de la VMT.

Source code
procedure MakeIntfTable

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeInitTable)
Next (MakeMethodTable)


Sepi

Sepi
Previous (MakeIntfTable)
Next (MakeRuntimeInfo)

Name
MakeMethodTable

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit la table des méthodes publiées
Range également l'adresse de cette table à l'emplacement prévu de la VMT.

Source code
procedure MakeMethodTable

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeIntfTable)
Next (MakeRuntimeInfo)


Sepi

Sepi
Previous (MakeMethodTable)
Next (MakeVMT)

Name
MakeRuntimeInfo

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure MakeRuntimeInfo ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeMethodTable)
Next (MakeVMT)


Sepi

Sepi
Previous (MakeRuntimeInfo)
Next (ReadNativeIMTs)

Name
MakeVMT

Parent
TSepiClass

Visibility
PRIVATE

Description
Construit la VMT

Source code
procedure MakeVMT

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeRuntimeInfo)
Next (ReadNativeIMTs)


Sepi

Sepi
Previous (MakeVMT)
Next (RedefineProperty)

Name
ReadNativeIMTs

Parent
TSepiClass

Visibility
PRIVATE

Description
Lit la table des IMTs natives pour obtenir les offsets réels

Source code
procedure ReadNativeIMTs

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeVMT)
Next (RedefineProperty)


Sepi

Sepi
Previous (ReadNativeIMTs)
Next (RedefineProperty)

Name
RedefineProperty

Parent
TSepiClass

Visibility
PUBLIC

Description
Redéfinit une propriété héritée

Source code
function RedefineProperty ( const AName , AReadAccess , AWriteAccess : string ; ADefaultValue : Integer ; const AStorage : string = '' ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
AReadAccess : STRING | Accès en lecture à la propriété
AWriteAccess : STRING | Accès en écriture à la propriété
ADefaultValue : INTEGER | Valeur par défaut
AStorage : STRING | Spécificateur de stockage

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ReadNativeIMTs)
Next (RedefineProperty)


Sepi

Sepi
Previous (RedefineProperty)
Next (RedefineProperty)

Name
RedefineProperty

Parent
TSepiClass

Visibility
PUBLIC

Description
Redéfinit une propriété héritée

Source code
function RedefineProperty ( const AName : string ; AReadAccess , AWriteAccess : TSepiMember ; ADefaultValue : Integer ; const AStorage : TSepiPropertyStorage ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
AReadAccess : TSepiMember | Accès en lecture à la propriété
AWriteAccess : TSepiMember | Accès en écriture à la propriété
ADefaultValue : INTEGER | Valeur par défaut
AStorage : TSepiPropertyStorage | Spécificateur de stockage

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (RedefineProperty)
Next (RedefineProperty)


Sepi

Sepi
Previous (RedefineProperty)
Next (Save)

Name
RedefineProperty

Parent
TSepiClass

Visibility
PUBLIC

Description
Redéfinit une propriété héritée

Source code
function RedefineProperty ( const AName : string ; const AReadAccess : string = '' ; const AWriteAccess : string = '' ; const AStorage : string = '' ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
AReadAccess : STRING | Accès en lecture à la propriété
AWriteAccess : STRING | Accès en écriture à la propriété
AStorage : STRING | Spécificateur de stockage

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (RedefineProperty)
Next (Save)


Sepi

Sepi
Previous (RedefineProperty)
Next (SetupProperties)

Name
Save

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (RedefineProperty)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (SetVMTEntries)

Name
SetupProperties

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (SetVMTEntries)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteTypeInfo)

Name
SetVMTEntries

Parent
TSepiClass

Visibility
PRIVATE

Description
Modifie la VMT de la classe, indexée par les constantes vmtXXX
Cette méthode ne fonctionne que pour des VMT créées par Sepi. Dans le cas où
la VMT serait créée à la compilation, cette méthode provoquera une violation
d'accès.

Source code
procedure SetVMTEntries ( Index : Integer ; Value : Pointer )

Parameters
Parameter | Description
INDEX : INTEGER | Index dans la VMT
Value : Pointer | Information à stocker dans la VMT à l'index spécifié

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (SetVMTEntries)
Next

Name
WriteTypeInfo

Parent
TSepiClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetVMTEntries)
Next


Sepi

Sepi
Previous (TSepiClass)
Next (TSepiInheritableContainerType)

Name
TSepiField

Parent
SepiMembers

Class Hierarchy
TSepiMember

Visibility
PUBLIC

Description
Champ

Members
Fields
Field | Description
FOffset (-) | Offset
FType (-) | Type du champ

Methods
Method | Description
Create (+) | Crée un nouveau champ
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un champ depuis un flux
Save (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
FieldType (+) | Type du champ
OFFSET (+) | Offset

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiClass)
Next (TSepiInheritableContainerType)


Sepi

Sepi
Previous
Next (FType)

Name
FOffset

Parent
TSepiField

Visibility
PRIVATE

Description
Offset

Source code
FOffset : Integer

Sepi
Class Tree
Index
Previous
Next (FType)


Sepi

Sepi
Previous (FOffset)
Next

Name
FType

Parent
TSepiField

Visibility
PRIVATE

Description
Type du champ

Source code
FType : TSepiType

Sepi
Class Tree
Index
Previous (FOffset)
Next


Sepi

Sepi
Previous
Next (OFFSET)

Name
FieldType

Parent
TSepiField

Visibility
PUBLIC

Description
Type du champ

Source code
property FieldType : TSepiType read FType

Read Access
FType

Sepi
Class Tree
Index
Previous
Next (OFFSET)


Sepi

Sepi
Previous (FieldType)
Next

Name
OFFSET

Parent
TSepiField

Visibility
PUBLIC

Description
Offset

Source code
property Offset : Integer read FOffset

Read Access
FOffset

Sepi
Class Tree
Index
Previous (FieldType)
Next


Sepi

Sepi
Previous
Next (ListReferences)

Name
Create

Parent
TSepiField

Visibility
PUBLIC

Description
Crée un nouveau champ

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AType : TSepiType ; AOffset : Integer )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du champ
AName : STRING | Nom du champ
AType : TSepiType | Type du champ
AOffset : INTEGER

Sepi
Class Tree
Index
Previous
Next (ListReferences)


Sepi

Sepi
Previous (Create)
Next (Load)

Name
ListReferences

Parent
TSepiField

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiField

Visibility
PUBLIC

Description
Charge un champ depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (WriteDigestData)

Name
Save

Parent
TSepiField

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (WriteDigestData)


Sepi

Sepi
Previous (Save)
Next

Name
WriteDigestData

Parent
TSepiField

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next


Sepi

Sepi
Previous (TSepiField)
Next (TSepiInterface)

Name
TSepiInheritableContainerType

Parent
SepiMembers

Class Hierarchy
TSepiContainerType

Visibility
PUBLIC

Description
Type conteneur qui peut être hérité

Members
Methods
Method | Description
ContainerInheritsFrom (+) | Teste si ce conteneur hérite d'un conteneur donné
GetParentContainer (#) | #No TAG found in source code#
InternalLookFor (#) | [@inheritDoc]
Load (+) | [@inheritDoc]
LookForMember (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
ParentContainer (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiField)
Next (TSepiInterface)


Sepi

Sepi
Previous
Next

Name
ParentContainer

Parent
TSepiInheritableContainerType

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParentContainer : TSepiInheritableContainerType read GetParentContainer

Read Access
GetParentContainer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetParentContainer)

Name
ContainerInheritsFrom

Parent
TSepiInheritableContainerType

Visibility
PUBLIC

Description
Teste si ce conteneur hérite d'un conteneur donné

Source code
function ContainerInheritsFrom ( Ancestor : TSepiInheritableContainerType ) : Boolean

Parameters
Parameter | Description
Ancestor : TSepiInheritableContainerType | Ancêtre à tester

Return
Types | Description
BOOLEAN | True si ce conteneur hérite de Ancestor, False sinon

Sepi
Class Tree
Index
Previous
Next (GetParentContainer)


Sepi

Sepi
Previous (ContainerInheritsFrom)
Next (InternalLookFor)

Name
GetParentContainer

Parent
TSepiInheritableContainerType

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetParentContainer : TSepiInheritableContainerType ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
TSepiInheritableContainerType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ContainerInheritsFrom)
Next (InternalLookFor)


Sepi

Sepi
Previous (GetParentContainer)
Next (Load)

Name
InternalLookFor

Parent
TSepiInheritableContainerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function InternalLookFor ( const Name : string ; FromComponent : TSepiComponent ) : TSepiComponent ; override

Parameters
Parameter | Description
NAME : STRING | #Pas de TAG trouvé dans le code source#
FromComponent : TSepiComponent | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetParentContainer)
Next (Load)


Sepi

Sepi
Previous (InternalLookFor)
Next (LookForMember)

Name
Load

Parent
TSepiInheritableContainerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InternalLookFor)
Next (LookForMember)


Sepi

Sepi
Previous (Load)
Next (WriteDigestData)

Name
LookForMember

Parent
TSepiInheritableContainerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function LookForMember ( const MemberName : string ; FromComponent : TSepiComponent ) : TSepiMember ; override

Parameters
Parameter | Description
MemberName : STRING | #Pas de TAG trouvé dans le code source#
FromComponent : TSepiComponent | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMember | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (WriteDigestData)


Sepi

Sepi
Previous (LookForMember)
Next

Name
WriteDigestData

Parent
TSepiInheritableContainerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LookForMember)
Next


Sepi

Sepi
Previous (TSepiInheritableContainerType)
Next (TSepiInterfaceEntry)

Name
TSepiInterface

Parent
SepiMembers

Class Hierarchy
TSepiInheritableContainerType

Visibility
PUBLIC

Description
Interface

Members
Fields
Field | Description
FGUID (-) | GUID de l'interface, si elle en a un
FHasGUID (-) | Indique si l'interface possède un GUID
FIMTSize (-) | Taille de l'IMT
FIsDispatch (-) | Indique si c'est une IDispatch
FIsDispInterface (-) | Indique si c'est une disp interface
FParent (-) | Interface parent (ou nil - IInterface)

Methods
Method | Description
AddMethod (+) | Ajoute une méthode à l'interface
AddMethod (+) | Ajoute une méthode à l'interface
AddProperty (+) | Ajoute une propriété à l'interface
AddProperty (+) | Ajoute une propriété à l'interface
AddProperty (+) | Ajoute une propriété à l'interface
Complete (+) | [@inheritDoc]
Create (+) | Crée une nouvelle interface
Equals (+) | [@inheritDoc]
ForwardDecl (+) | Déclare un type interface en forward
GetDescription (#) | [@inheritDoc]
GetParentContainer (#) | [@inheritDoc]
IntfInheritsFrom (+) | Détermine si l'interface hérite d'une interface donnée
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une interface depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
GUID (+) | GUID de l'interface, si elle en a un
HasGUID (+) | Indique si l'interface possède un GUID
IMTSize (+) | Taille de l'IMT
IsDispatch (+) | Indique si c'est une IDispatch
IsDispInterface (+) | Indique si c'est une disp interface
Parent (+) | Interface parent (ou nil - IInterface)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInheritableContainerType)
Next (TSepiInterfaceEntry)


Sepi

Sepi
Previous
Next (FHasGUID)

Name
FGUID

Parent
TSepiInterface

Visibility
PRIVATE

Description
GUID de l'interface, si elle en a un

Source code
FGUID : TGUID

Sepi
Class Tree
Index
Previous
Next (FHasGUID)


Sepi

Sepi
Previous (FGUID)
Next (FIMTSize)

Name
FHasGUID

Parent
TSepiInterface

Visibility
PRIVATE

Description
Indique si l'interface possède un GUID

Source code
FHasGUID : Boolean

Sepi
Class Tree
Index
Previous (FGUID)
Next (FIMTSize)


Sepi

Sepi
Previous (FHasGUID)
Next (FIsDispatch)

Name
FIMTSize

Parent
TSepiInterface

Visibility
PRIVATE

Description
Taille de l'IMT

Source code
FIMTSize : Integer

Sepi
Class Tree
Index
Previous (FHasGUID)
Next (FIsDispatch)


Sepi

Sepi
Previous (FIMTSize)
Next (FIsDispInterface)

Name
FIsDispatch

Parent
TSepiInterface

Visibility
PRIVATE

Description
Indique si c'est une IDispatch

Source code
FIsDispatch : Boolean

Sepi
Class Tree
Index
Previous (FIMTSize)
Next (FIsDispInterface)


Sepi

Sepi
Previous (FIsDispatch)
Next (FParent)

Name
FIsDispInterface

Parent
TSepiInterface

Visibility
PRIVATE

Description
Indique si c'est une disp interface

Source code
FIsDispInterface : Boolean

Sepi
Class Tree
Index
Previous (FIsDispatch)
Next (FParent)


Sepi

Sepi
Previous (FIsDispInterface)
Next

Name
FParent

Parent
TSepiInterface

Visibility
PRIVATE

Description
Interface parent (ou nil - IInterface)

Source code
FParent : TSepiInterface

Sepi
Class Tree
Index
Previous (FIsDispInterface)
Next


Sepi

Sepi
Previous
Next (HasGUID)

Name
GUID

Parent
TSepiInterface

Visibility
PUBLIC

Description
GUID de l'interface, si elle en a un

Source code
property GUID : TGUID read FGUID

Read Access
FGUID

Sepi
Class Tree
Index
Previous
Next (HasGUID)


Sepi

Sepi
Previous (GUID)
Next (IMTSize)

Name
HasGUID

Parent
TSepiInterface

Visibility
PUBLIC

Description
Indique si l'interface possède un GUID

Source code
property HasGUID : Boolean read FHasGUID

Read Access
FHasGUID

Sepi
Class Tree
Index
Previous (GUID)
Next (IMTSize)


Sepi

Sepi
Previous (HasGUID)
Next (IsDispatch)

Name
IMTSize

Parent
TSepiInterface

Visibility
PUBLIC

Description
Taille de l'IMT

Source code
property IMTSize : Integer read FIMTSize

Read Access
FIMTSize

Sepi
Class Tree
Index
Previous (HasGUID)
Next (IsDispatch)


Sepi

Sepi
Previous (IMTSize)
Next (IsDispInterface)

Name
IsDispatch

Parent
TSepiInterface

Visibility
PUBLIC

Description
Indique si c'est une IDispatch

Source code
property IsDispatch : Boolean read FIsDispatch

Read Access
FIsDispatch

Sepi
Class Tree
Index
Previous (IMTSize)
Next (IsDispInterface)


Sepi

Sepi
Previous (IsDispatch)
Next (Parent)

Name
IsDispInterface

Parent
TSepiInterface

Visibility
PUBLIC

Description
Indique si c'est une disp interface

Source code
property IsDispInterface : Boolean read FIsDispInterface

Read Access
FIsDispInterface

Sepi
Class Tree
Index
Previous (IsDispatch)
Next (Parent)


Sepi

Sepi
Previous (IsDispInterface)
Next

Name
Parent

Parent
TSepiInterface

Visibility
PUBLIC

Description
Interface parent (ou nil - IInterface)

Source code
property Parent : TSepiInterface read FParent

Read Access
FParent

Sepi
Class Tree
Index
Previous (IsDispInterface)
Next


Sepi

Sepi
Previous
Next (AddMethod)

Name
AddMethod

Parent
TSepiInterface

Visibility
PUBLIC

Description
Ajoute une méthode à l'interface

Source code
function AddMethod ( const MethodName , ASignature : string ; ACallingConvention : TCallingConvention = ccRegister ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ASignature : STRING | Signature Delphi de la méthode
ACallingConvention : TCallingConvention | Convention d'appel de la méthode

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (AddMethod)


Sepi

Sepi
Previous (AddMethod)
Next (AddProperty)

Name
AddMethod

Parent
TSepiInterface

Visibility
PUBLIC

Description
Ajoute une méthode à l'interface

Source code
function AddMethod ( const MethodName : string ; ASignature : TSepiSignature ) : TSepiMethod ; overload

Parameters
Parameter | Description
MethodName : STRING | Nom de la méthode
ASignature : TSepiSignature | Signature

Return
Types | Description
TSepiMethod | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddMethod)
Next (AddProperty)


Sepi

Sepi
Previous (AddMethod)
Next (AddProperty)

Name
AddProperty

Parent
TSepiInterface

Visibility
PUBLIC

Description
Ajoute une propriété à l'interface

Source code
function AddProperty ( const AName : string ; ASignature : TSepiSignature ; AReadAccess , AWriteAccess : TSepiMember ; AIndex : Integer ; AIsDefault : Boolean ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
ASignature : TSepiSignature | Signature
AReadAccess : TSepiMember | Accès en lecture à la propriété (peut être nil)
AWriteAccess : TSepiMember | Accès en écriture à la propriété (peut être nil)
AIndex : INTEGER | Index d'accès
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddMethod)
Next (AddProperty)


Sepi

Sepi
Previous (AddProperty)
Next (AddProperty)

Name
AddProperty

Parent
TSepiInterface

Visibility
PUBLIC

Description
Ajoute une propriété à l'interface

Source code
function AddProperty ( const AName , ASignature , AReadAccess , AWriteAccess : string ; AIsDefault : Boolean ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
ASignature : STRING | Signature
AReadAccess : STRING | Accès en lecture à la propriété (peut être vide)
AWriteAccess : STRING | Accès en écriture à la propriété (peut être vide)
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddProperty)
Next (AddProperty)


Sepi

Sepi
Previous (AddProperty)
Next (Complete)

Name
AddProperty

Parent
TSepiInterface

Visibility
PUBLIC

Description
Ajoute une propriété à l'interface

Source code
function AddProperty ( const AName , ASignature , AReadAccess , AWriteAccess : string ; AIndex : Integer = NoIndex ; AIsDefault : Boolean = False ) : TSepiProperty ; overload

Parameters
Parameter | Description
AName : STRING | Nom de la propriété
ASignature : STRING | Signature
AReadAccess : STRING | Accès en lecture à la propriété (peut être vide)
AWriteAccess : STRING | Accès en écriture à la propriété (peut être vide)
AIndex : INTEGER | Index d'accès
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Return
Types | Description
TSepiProperty | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddProperty)
Next (Complete)


Sepi

Sepi
Previous (AddProperty)
Next (Create)

Name
Complete

Parent
TSepiInterface

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Complete ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddProperty)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Equals)

Name
Create

Parent
TSepiInterface

Visibility
PUBLIC

Description
Crée une nouvelle interface

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AParent : TSepiInterface ; const AGUID : TGUID ; AIsDispInterface : Boolean = False )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AParent : TSepiInterface | Classe parent
AGUID : TGUID
AIsDispInterface : BOOLEAN

Sepi
Class Tree
Index
Previous (Complete)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (ForwardDecl)

Name
Equals

Parent
TSepiInterface

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (ForwardDecl)


Sepi

Sepi
Previous (Equals)
Next (GetDescription)

Name
ForwardDecl

Parent
TSepiInterface

Visibility
PUBLIC

Description
Déclare un type interface en forward

Source code
class function ForwardDecl ( AOwner : TSepiComponent ; const AName : string ) : TSepiInterface

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom de l'interface

Return
Types | Description
TSepiInterface | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetDescription)


Sepi

Sepi
Previous (ForwardDecl)
Next (GetParentContainer)

Name
GetDescription

Parent
TSepiInterface

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForwardDecl)
Next (GetParentContainer)


Sepi

Sepi
Previous (GetDescription)
Next (IntfInheritsFrom)

Name
GetParentContainer

Parent
TSepiInterface

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetParentContainer : TSepiInheritableContainerType ; override

Parameters
Parameter Description

Return
Types | Description
TSepiInheritableContainerType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDescription)
Next (IntfInheritsFrom)


Sepi

Sepi
Previous (GetParentContainer)
Next (ListReferences)

Name
IntfInheritsFrom

Parent
TSepiInterface

Visibility
PUBLIC

Description
Détermine si l'interface hérite d'une interface donnée

Source code
function IntfInheritsFrom ( AParent : TSepiInterface ) : Boolean

Parameters
Parameter | Description
AParent : TSepiInterface | Ancêtre à tester

Return
Types | Description
BOOLEAN | True si l'interface hérite de AParent, False sinon

Sepi
Class Tree
Index
Previous (GetParentContainer)
Next (ListReferences)


Sepi

Sepi
Previous (IntfInheritsFrom)
Next (Load)

Name
ListReferences

Parent
TSepiInterface

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (IntfInheritsFrom)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiInterface

Visibility
PUBLIC

Description
Charge une interface depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiInterface

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (WriteDigestData)

Name
SetupProperties

Parent
TSepiInterface

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (WriteDigestData)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiInterface

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiInterface

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiInterface)
Next (TSepiIntfMethodRedirector)

Name
TSepiInterfaceEntry

Parent
SepiMembers

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Entrée d'interface pour les classes Sepi
Chaque classe a, pour chaque interface qu'elle implémente, une entrée de
type TSepiInterfaceEntry.

Members
Fields
Field | Description
IMT (*) | Interface Method Table
IntfRef (*) | Interface implémentée
OFFSET (*) | Offset du champ interface dans l'objet
OwnsIMT (*) | Indique si cette entrée possède son IMT
Relocates (*) | Thunks de relocalisation

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInterface)
Next (TSepiIntfMethodRedirector)


Sepi

Sepi
Previous
Next (IntfRef)

Name
IMT

Parent
TSepiInterfaceEntry

Visibility
PUBLISHED

Description
Interface Method Table

Source code
IMT : Pointer

Sepi
Class Tree
Index
Previous
Next (IntfRef)


Sepi

Sepi
Previous (IMT)
Next (OFFSET)

Name
IntfRef

Parent
TSepiInterfaceEntry

Visibility
PUBLISHED

Description
Interface implémentée

Source code
IntfRef : TSepiInterface

Sepi
Class Tree
Index
Previous (IMT)
Next (OFFSET)


Sepi

Sepi
Previous (IntfRef)
Next (OwnsIMT)

Name
OFFSET

Parent
TSepiInterfaceEntry

Visibility
PUBLISHED

Description
Offset du champ interface dans l'objet

Source code
Offset : Integer

Sepi
Class Tree
Index
Previous (IntfRef)
Next (OwnsIMT)


Sepi

Sepi
Previous (OFFSET)
Next (Relocates)

Name
OwnsIMT

Parent
TSepiInterfaceEntry

Visibility
PUBLISHED

Description
Indique si cette entrée possède son IMT

Source code
OwnsIMT : Boolean

Sepi
Class Tree
Index
Previous (OFFSET)
Next (Relocates)


Sepi

Sepi
Previous (OwnsIMT)
Next

Name
Relocates

Parent
TSepiInterfaceEntry

Visibility
PUBLISHED

Description
Thunks de relocalisation

Source code
Relocates : Pointer

Sepi
Class Tree
Index
Previous (OwnsIMT)
Next


Sepi

Sepi
Previous (TSepiInterfaceEntry)
Next (TSepiMetaClass)

Name
TSepiIntfMethodRedirector

Parent
SepiMembers

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Redirecteur de méthode d'interface pour une classe Sepi

Members
Fields
Field | Description
Intf (*) | Interface
IntfMethod (*) | Méthode de l'interface
RedirectorName (*) | Nom de la méthode de redirection

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInterfaceEntry)
Next (TSepiMetaClass)


Sepi

Sepi
Previous
Next (IntfMethod)

Name
Intf

Parent
TSepiIntfMethodRedirector

Visibility
PUBLISHED

Description
Interface

Source code
Intf : TSepiInterface

Sepi
Class Tree
Index
Previous
Next (IntfMethod)


Sepi

Sepi
Previous (Intf)
Next (RedirectorName)

Name
IntfMethod

Parent
TSepiIntfMethodRedirector

Visibility
PUBLISHED

Description
Méthode de l'interface

Source code
IntfMethod : TSepiMethod

Sepi
Class Tree
Index
Previous (Intf)
Next (RedirectorName)


Sepi

Sepi
Previous (IntfMethod)
Next

Name
RedirectorName

Parent
TSepiIntfMethodRedirector

Visibility
PUBLISHED

Description
Nom de la méthode de redirection

Source code
RedirectorName : string

Sepi
Class Tree
Index
Previous (IntfMethod)
Next


Sepi

Sepi
Previous (TSepiIntfMethodRedirector)
Next (TSepiMethod)

Name
TSepiMetaClass

Parent
SepiMembers

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Meta-classe (type classe)

Members
Fields
Field | Description
FClass (-) | Classe correspondante

Methods
Method | Description
Clone (+) | [@inheritDoc]
CompatibleWith (+) | [@inheritDoc]
Create (+) | Crée une nouvelle meta-classe
Equals (+) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une meta-classe depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
SepiClass (+) | Classe correspondante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIntfMethodRedirector)
Next (TSepiMethod)


Sepi

Sepi
Previous
Next

Name
FClass

Parent
TSepiMetaClass

Visibility
PRIVATE

Description
Classe correspondante

Source code
FClass : TSepiClass

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SepiClass

Parent
TSepiMetaClass

Visibility
PUBLIC

Description
Classe correspondante

Source code
property SepiClass : TSepiClass read FClass

Read Access
FClass

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompatibleWith)

Name
Clone

Parent
TSepiMetaClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
CompatibleWith

Parent
TSepiMetaClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (Equals)

Name
Create

Parent
TSepiMetaClass

Visibility
PUBLIC

Description
Crée une nouvelle meta-classe

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AClass : TSepiClass )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AClass : TSepiClass | Classe correspondante

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (GetDescription)

Name
Equals

Parent
TSepiMetaClass

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetDescription)


Sepi

Sepi
Previous (Equals)
Next (ListReferences)

Name
GetDescription

Parent
TSepiMetaClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (ListReferences)


Sepi

Sepi
Previous (GetDescription)
Next (Load)

Name
ListReferences

Parent
TSepiMetaClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetDescription)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiMetaClass

Visibility
PUBLIC

Description
Charge une meta-classe depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiMetaClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (WriteDigestData)

Name
SetupProperties

Parent
TSepiMetaClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (WriteDigestData)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiMetaClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiMetaClass

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiMetaClass)
Next (TSepiMethodBase)

Name
TSepiMethod

Parent
SepiMembers

Class Hierarchy
TSepiMethodBase

Visibility
PUBLIC

Description
Méthode ou routine

Members
Fields
Field | Description
FAbstract (-) | Indique si la méthode est abstraite
FCode (-) | Adresse de code natif
FCodeHandler (-) | Gestionnaire de code
FCodeJumper (-) | Jumper sur le code, si non native
FFirstDeclaration (-) | Faux uniquement quand 'override'
FInherited (-) | Méthode héritée
FIsOverloaded (-) | Indique si surchargée
FLinkIndex (-) | Offset de VMT ou index de DMT, selon la liaison
FLinkKind (-) | Type de liaison d'appel
FOverloaded (-) | Méthode surchargée (ou nil)
FOverloadIndex (-) | Index de surcharge
FSignature (-) | Signature de la méthode

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
CommonCreate (-) | Partie commune à tous les constructeurs
Create (+) | Crée une nouvelle méthode d'après une signature déjà construite
Create (+) | Crée une nouvelle méthode
CreateOverloaded (+) | Crée une nouvelle méthode surchargée d'après une signature déjà construite
CreateOverloaded (+) | Crée une nouvelle méthode surchargée
Destroy (+) | Détruit l'instance
FindNativeCode (-) | Cherche le code d'une méthode native
GetRealName (-) | Nom réel, tel que déclaré (indépendant d'une surcharge ou non)
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une meta-méthode depuis un flux
MakeLink (-) | Met au point la liaison et l'index de liaison
Save (#) | [@inheritDoc]
SetCode (+) | Donne l'adresse de début du code de la méthode
SetCodeMethod (+) | Donne l'adresse de début du code de la méthode, à partir d'une méthode
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
Code (+) | Adresse de code natif
CodeHandler (+) | Gestionnaire de code
DMTIndex (+) | Offset de VMT ou index de DMT, selon la liaison
FirstDeclaration (+) | Faux uniquement quand 'override'
IMTIndex (+) | Offset de VMT ou index de DMT, selon la liaison
InheritedMethod (+) | Méthode héritée
IsAbstract (+) | Indique si la méthode est abstraite
IsOverloaded (+) | Indique si surchargée
LinkKind (+) | Type de liaison d'appel
MsgID (+) | Offset de VMT ou index de DMT, selon la liaison
Overloaded (+) | Méthode surchargée (ou nil)
OverloadIndex (+) | Index de surcharge
RealName (+) | Nom réel, tel que déclaré (indépendant d'une surcharge ou non)
Signature (+) | Signature de la méthode
VMTOFFSET (+) | Offset de VMT ou index de DMT, selon la liaison

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMetaClass)
Next (TSepiMethodBase)


Sepi

Sepi
Previous
Next (FCode)

Name
FAbstract

Parent
TSepiMethod

Visibility
PRIVATE

Description
Indique si la méthode est abstraite

Source code
FAbstract : Boolean

Sepi
Class Tree
Index
Previous
Next (FCode)


Sepi

Sepi
Previous (FAbstract)
Next (FCodeHandler)

Name
FCode

Parent
TSepiMethod

Visibility
PRIVATE

Description
Adresse de code natif

Source code
FCode : Pointer

Sepi
Class Tree
Index
Previous (FAbstract)
Next (FCodeHandler)


Sepi

Sepi
Previous (FCode)
Next (FCodeJumper)

Name
FCodeHandler

Parent
TSepiMethod

Visibility
PRIVATE

Description
Gestionnaire de code

Source code
FCodeHandler : TObject

Sepi
Class Tree
Index
Previous (FCode)
Next (FCodeJumper)


Sepi

Sepi
Previous (FCodeHandler)
Next (FFirstDeclaration)

Name
FCodeJumper

Parent
TSepiMethod

Visibility
PRIVATE

Description
Jumper sur le code, si non native

Source code
FCodeJumper : TJmpInstruction

Sepi
Class Tree
Index
Previous (FCodeHandler)
Next (FFirstDeclaration)


Sepi

Sepi
Previous (FCodeJumper)
Next (FInherited)

Name
FFirstDeclaration

Parent
TSepiMethod

Visibility
PRIVATE

Description
Faux uniquement quand 'override'

Source code
FFirstDeclaration : Boolean

Sepi
Class Tree
Index
Previous (FCodeJumper)
Next (FInherited)


Sepi

Sepi
Previous (FFirstDeclaration)
Next (FIsOverloaded)

Name
FInherited

Parent
TSepiMethod

Visibility
PRIVATE

Description
Méthode héritée

Source code
FInherited : TSepiMethod

Sepi
Class Tree
Index
Previous (FFirstDeclaration)
Next (FIsOverloaded)


Sepi

Sepi
Previous (FInherited)
Next (FLinkIndex)

Name
FIsOverloaded

Parent
TSepiMethod

Visibility
PRIVATE

Description
Indique si surchargée

Source code
FIsOverloaded : Boolean

Sepi
Class Tree
Index
Previous (FInherited)
Next (FLinkIndex)


Sepi

Sepi
Previous (FIsOverloaded)
Next (FLinkKind)

Name
FLinkIndex

Parent
TSepiMethod

Visibility
PRIVATE

Description
Offset de VMT ou index de DMT, selon la liaison

Source code
FLinkIndex : Integer

Sepi
Class Tree
Index
Previous (FIsOverloaded)
Next (FLinkKind)


Sepi

Sepi
Previous (FLinkIndex)
Next (FOverloaded)

Name
FLinkKind

Parent
TSepiMethod

Visibility
PRIVATE

Description
Type de liaison d'appel

Source code
FLinkKind : TMethodLinkKind

Sepi
Class Tree
Index
Previous (FLinkIndex)
Next (FOverloaded)


Sepi

Sepi
Previous (FLinkKind)
Next (FOverloadIndex)

Name
FOverloaded

Parent
TSepiMethod

Visibility
PRIVATE

Description
Méthode surchargée (ou nil)

Source code
FOverloaded : TSepiOverloadedMethod

Sepi
Class Tree
Index
Previous (FLinkKind)
Next (FOverloadIndex)


Sepi

Sepi
Previous (FOverloaded)
Next (FSignature)

Name
FOverloadIndex

Parent
TSepiMethod

Visibility
PRIVATE

Description
Index de surcharge

Source code
FOverloadIndex : Byte

Sepi
Class Tree
Index
Previous (FOverloaded)
Next (FSignature)


Sepi

Sepi
Previous (FOverloadIndex)
Next

Name
FSignature

Parent
TSepiMethod

Visibility
PRIVATE

Description
Signature de la méthode

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous (FOverloadIndex)
Next


Sepi

Sepi
Previous
Next (CodeHandler)

Name
Code

Parent
TSepiMethod

Visibility
PUBLIC

Description
Adresse de code natif

Source code
property Code : Pointer read FCode

Read Access
FCode

Sepi
Class Tree
Index
Previous
Next (CodeHandler)


Sepi

Sepi
Previous (Code)
Next (DMTIndex)

Name
CodeHandler

Parent
TSepiMethod

Visibility
PUBLIC

Description
Gestionnaire de code

Source code
property CodeHandler : TObject read FCodeHandler

Read Access
FCodeHandler

Sepi
Class Tree
Index
Previous (Code)
Next (DMTIndex)


Sepi

Sepi
Previous (CodeHandler)
Next (FirstDeclaration)

Name
DMTIndex

Parent
TSepiMethod

Visibility
PUBLIC

Description
Offset de VMT ou index de DMT, selon la liaison

Source code
property DMTIndex : Integer read FLinkIndex

Read Access
FLinkIndex

Sepi
Class Tree
Index
Previous (CodeHandler)
Next (FirstDeclaration)


Sepi

Sepi
Previous (DMTIndex)
Next (IMTIndex)

Name
FirstDeclaration

Parent
TSepiMethod

Visibility
PUBLIC

Description
Faux uniquement quand 'override'

Source code
property FirstDeclaration : Boolean read FFirstDeclaration

Read Access
FFirstDeclaration

Sepi
Class Tree
Index
Previous (DMTIndex)
Next (IMTIndex)


Sepi

Sepi
Previous (FirstDeclaration)
Next (InheritedMethod)

Name
IMTIndex

Parent
TSepiMethod

Visibility
PUBLIC

Description
Offset de VMT ou index de DMT, selon la liaison

Source code
property IMTIndex : Integer read FLinkIndex

Read Access
FLinkIndex

Sepi
Class Tree
Index
Previous (FirstDeclaration)
Next (InheritedMethod)


Sepi

Sepi
Previous (IMTIndex)
Next (IsAbstract)

Name
InheritedMethod

Parent
TSepiMethod

Visibility
PUBLIC

Description
Méthode héritée

Source code
property InheritedMethod : TSepiMethod read FInherited

Read Access
FInherited

Sepi
Class Tree
Index
Previous (IMTIndex)
Next (IsAbstract)


Sepi

Sepi
Previous (InheritedMethod)
Next (IsOverloaded)

Name
IsAbstract

Parent
TSepiMethod

Visibility
PUBLIC

Description
Indique si la méthode est abstraite

Source code
property IsAbstract : Boolean read FAbstract

Read Access
FAbstract

Sepi
Class Tree
Index
Previous (InheritedMethod)
Next (IsOverloaded)


Sepi

Sepi
Previous (IsAbstract)
Next (LinkKind)

Name
IsOverloaded

Parent
TSepiMethod

Visibility
PUBLIC

Description
Indique si surchargée

Source code
property IsOverloaded : Boolean read FIsOverloaded

Read Access
FIsOverloaded

Sepi
Class Tree
Index
Previous (IsAbstract)
Next (LinkKind)


Sepi

Sepi
Previous (IsOverloaded)
Next (MsgID)

Name
LinkKind

Parent
TSepiMethod

Visibility
PUBLIC

Description
Type de liaison d'appel

Source code
property LinkKind : TMethodLinkKind read FLinkKind

Read Access
FLinkKind

Sepi
Class Tree
Index
Previous (IsOverloaded)
Next (MsgID)


Sepi

Sepi
Previous (LinkKind)
Next (Overloaded)

Name
MsgID

Parent
TSepiMethod

Visibility
PUBLIC

Description
Offset de VMT ou index de DMT, selon la liaison

Source code
property MsgID : Integer read FLinkIndex

Read Access
FLinkIndex

Sepi
Class Tree
Index
Previous (LinkKind)
Next (Overloaded)


Sepi

Sepi
Previous (MsgID)
Next (OverloadIndex)

Name
Overloaded

Parent
TSepiMethod

Visibility
PUBLIC

Description
Méthode surchargée (ou nil)

Source code
property Overloaded : TSepiOverloadedMethod read FOverloaded

Read Access
FOverloaded

Sepi
Class Tree
Index
Previous (MsgID)
Next (OverloadIndex)


Sepi

Sepi
Previous (Overloaded)
Next (RealName)

Name
OverloadIndex

Parent
TSepiMethod

Visibility
PUBLIC

Description
Index de surcharge

Source code
property OverloadIndex : Byte read FOverloadIndex

Read Access
FOverloadIndex

Sepi
Class Tree
Index
Previous (Overloaded)
Next (RealName)


Sepi

Sepi
Previous (OverloadIndex)
Next (Signature)

Name
RealName

Parent
TSepiMethod

Visibility
PUBLIC

Description
Nom réel, tel que déclaré (indépendant d'une surcharge ou non)

Source code
property RealName : string read GetRealName

Read Access
GetRealName

Sepi
Class Tree
Index
Previous (OverloadIndex)
Next (Signature)


Sepi

Sepi
Previous (RealName)
Next (VMTOFFSET)

Name
Signature

Parent
TSepiMethod

Visibility
PUBLIC

Description
Signature de la méthode

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous (RealName)
Next (VMTOFFSET)


Sepi

Sepi
Previous (Signature)
Next

Name
VMTOFFSET

Parent
TSepiMethod

Visibility
PUBLIC

Description
Offset de VMT ou index de DMT, selon la liaison

Source code
property VMTOffset : Integer read FLinkIndex

Read Access
FLinkIndex

Sepi
Class Tree
Index
Previous (Signature)
Next


Sepi

Sepi
Previous
Next (CommonCreate)

Name
AfterConstruction

Parent
TSepiMethod

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CommonCreate)


Sepi

Sepi
Previous (AfterConstruction)
Next (Create)

Name
CommonCreate

Parent
TSepiMethod

Visibility
PRIVATE

Description
Partie commune à tous les constructeurs

Source code
procedure CommonCreate ( ACode : Pointer ; ALinkKind : TMethodLinkKind ; AAbstract : Boolean ; AMsgID : Integer )

Parameters
Parameter | Description
ACode : Pointer | #Pas de TAG trouvé dans le code source#
ALinkKind : TMethodLinkKind | #Pas de TAG trouvé dans le code source#
AAbstract : BOOLEAN | #Pas de TAG trouvé dans le code source#
AMsgID : INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Create)


Sepi

Sepi
Previous (CommonCreate)
Next (Create)

Name
Create

Parent
TSepiMethod

Visibility
PUBLIC

Description
Crée une nouvelle méthode d'après une signature déjà construite

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ACode : Pointer ; ASignature : TSepiSignature ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la méthode
AName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : TSepiSignature | Signature
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté

Sepi
Class Tree
Index
Previous (CommonCreate)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (CreateOverloaded)

Name
Create

Parent
TSepiMethod

Visibility
PUBLIC

Description
Crée une nouvelle méthode

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ACode : Pointer ; const ASignature : string ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ; ACallingConvention : TCallingConvention = ccRegister ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la méthode
AName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : STRING | Signature Delphi de la méthode
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté
ACallingConvention : TCallingConvention | Convention d'appel de la méthode

Sepi
Class Tree
Index
Previous (Create)
Next (CreateOverloaded)


Sepi

Sepi
Previous (Create)
Next (CreateOverloaded)

Name
CreateOverloaded

Parent
TSepiMethod

Visibility
PUBLIC

Description
Crée une nouvelle méthode surchargée d'après une signature déjà construite

Source code
constructor CreateOverloaded ( AOwner : TSepiComponent ; const AName : string ; ACode : Pointer ; ASignature : TSepiSignature ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la méthode
AName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : TSepiSignature | Signature Delphi de la méthode
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté

Sepi
Class Tree
Index
Previous (Create)
Next (CreateOverloaded)


Sepi

Sepi
Previous (CreateOverloaded)
Next (Destroy)

Name
CreateOverloaded

Parent
TSepiMethod

Visibility
PUBLIC

Description
Crée une nouvelle méthode surchargée

Source code
constructor CreateOverloaded ( AOwner : TSepiComponent ; const AName : string ; ACode : Pointer ; const ASignature : string ; ALinkKind : TMethodLinkKind = mlkStatic ; AAbstract : Boolean = False ; AMsgID : Integer = 0 ; ACallingConvention : TCallingConvention = ccRegister ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la méthode
AName : STRING | Nom de la méthode
ACode : Pointer | Pointeur sur le code de la méthode
ASignature : STRING | Signature Delphi de la méthode
ALinkKind : TMethodLinkKind | Type de liaison
AAbstract : BOOLEAN | Indique si la méthode est abstraite
AMsgID : INTEGER | Pour les méthodes de message, le message intercepté
ACallingConvention : TCallingConvention | Convention d'appel de la méthode

Sepi
Class Tree
Index
Previous (CreateOverloaded)
Next (Destroy)


Sepi

Sepi
Previous (CreateOverloaded)
Next (FindNativeCode)

Name
Destroy

Parent
TSepiMethod

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateOverloaded)
Next (FindNativeCode)


Sepi

Sepi
Previous (Destroy)
Next (GetRealName)

Name
FindNativeCode

Parent
TSepiMethod

Visibility
PRIVATE

Description
Cherche le code d'une méthode native

Source code
procedure FindNativeCode

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetRealName)


Sepi

Sepi
Previous (FindNativeCode)
Next (ListReferences)

Name
GetRealName

Parent
TSepiMethod

Visibility
PRIVATE

Description
Nom réel, tel que déclaré (indépendant d'une surcharge ou non)

Source code
function GetRealName : string

Parameters
Parameter Description

Return
Types | Description
STRING | Nom réel

Sepi
Class Tree
Index
Previous (FindNativeCode)
Next (ListReferences)


Sepi

Sepi
Previous (GetRealName)
Next (Load)

Name
ListReferences

Parent
TSepiMethod

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetRealName)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (MakeLink)

Name
Load

Parent
TSepiMethod

Visibility
PUBLIC

Description
Charge une meta-méthode depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (MakeLink)


Sepi

Sepi
Previous (Load)
Next (Save)

Name
MakeLink

Parent
TSepiMethod

Visibility
PRIVATE

Description
Met au point la liaison et l'index de liaison
Par extension, recherche aussi la méthode héritée.

Source code
procedure MakeLink

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Load)
Next (Save)


Sepi

Sepi
Previous (MakeLink)
Next (SetCode)

Name
Save

Parent
TSepiMethod

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeLink)
Next (SetCode)


Sepi

Sepi
Previous (Save)
Next (SetCodeMethod)

Name
SetCode

Parent
TSepiMethod

Visibility
PUBLIC

Description
Donne l'adresse de début du code de la méthode
Cette méthode ne peut être appelée qu'une seule fois par méthode, et
seulement pour les méthodes non natives.

Source code
procedure SetCode ( ACode : Pointer ; ACodeHandler : TObject = nil )

Parameters
Parameter | Description
ACode : Pointer | Adresse de code
ACodeHandler : TObject | Gestionnaire de code

Sepi
Class Tree
Index
Previous (Save)
Next (SetCodeMethod)


Sepi

Sepi
Previous (SetCode)
Next (WriteDigestData)

Name
SetCodeMethod

Parent
TSepiMethod

Visibility
PUBLIC

Description
Donne l'adresse de début du code de la méthode, à partir d'une méthode
Cette méthode ne peut être appelée qu'une seule fois par méthode, et
seulement pour les méthodes non natives.

Source code
procedure SetCodeMethod ( const AMethod : TMethod ; ACodeHandler : TObject = nil )

Parameters
Parameter | Description
AMethod : TMethod | Méthode de code
ACodeHandler : TObject | Gestionnaire de code

Sepi
Class Tree
Index
Previous (SetCode)
Next (WriteDigestData)


Sepi

Sepi
Previous (SetCodeMethod)
Next

Name
WriteDigestData

Parent
TSepiMethod

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetCodeMethod)
Next


Sepi

Sepi
Previous (TSepiMethod)
Next (TSepiMethodRefType)

Name
TSepiMethodBase

Parent
SepiMembers

Class Hierarchy
TSepiMember

Visibility
PUBLIC

Description
Classe de base pour les classes TSepiMethod et TSepiOverloadedMethod

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethod)
Next (TSepiMethodRefType)


Sepi

Sepi
Previous (TSepiMethodBase)
Next (TSepiOverloadedMethod)

Name
TSepiMethodRefType

Parent
SepiMembers

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type référence de méthode

Members
Fields
Field | Description
FSignature (-) | Signature

Methods
Method | Description
Clone (+) | [@inheritDoc]
CompatibleWith (+) | [@inheritDoc]
Create (+) | Crée un nouveau type référence de méthode
Destroy (+) | Détruit l'instance
Equals (+) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
HasTypeInfo (#) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un type référence de méthode depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
Signature (+) | Signature

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodBase)
Next (TSepiOverloadedMethod)


Sepi

Sepi
Previous
Next

Name
FSignature

Parent
TSepiMethodRefType

Visibility
PRIVATE

Description
Signature

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Signature

Parent
TSepiMethodRefType

Visibility
PUBLIC

Description
Signature

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompatibleWith)

Name
Clone

Parent
TSepiMethodRefType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
CompatibleWith

Parent
TSepiMethodRefType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (Destroy)

Name
Create

Parent
TSepiMethodRefType

Visibility
PUBLIC

Description
Crée un nouveau type référence de méthode

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ASignature : TSepiSignature )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
ASignature : TSepiSignature | Signature

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Equals)

Name
Destroy

Parent
TSepiMethodRefType

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Equals)


Sepi

Sepi
Previous (Destroy)
Next (GetDescription)

Name
Equals

Parent
TSepiMethodRefType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetDescription)


Sepi

Sepi
Previous (Equals)
Next (HasTypeInfo)

Name
GetDescription

Parent
TSepiMethodRefType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (HasTypeInfo)


Sepi

Sepi
Previous (GetDescription)
Next (ListReferences)

Name
HasTypeInfo

Parent
TSepiMethodRefType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function HasTypeInfo : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDescription)
Next (ListReferences)


Sepi

Sepi
Previous (HasTypeInfo)
Next (Load)

Name
ListReferences

Parent
TSepiMethodRefType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (HasTypeInfo)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiMethodRefType

Visibility
PUBLIC

Description
Charge un type référence de méthode depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiMethodRefType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (WriteDigestData)

Name
SetupProperties

Parent
TSepiMethodRefType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (WriteDigestData)


Sepi

Sepi
Previous (SetupProperties)
Next

Name
WriteDigestData

Parent
TSepiMethodRefType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next


Sepi

Sepi
Previous (TSepiMethodRefType)
Next (TSepiParam)

Name
TSepiOverloadedMethod

Parent
SepiMembers

Class Hierarchy
TSepiMethodBase

Visibility
PUBLIC

Description
Méthode ou routine surchargée

Members
Fields
Field | Description
FMethods (-) | Liste des méthodes de même nom

Methods
Method | Description
Create (+) | Crée une nouvelle méthode surchargée
Destroy (+) | [@inheritDoc]
FindInherited (-) | Trouve la méthode effective dont une signature donnée hérite
FindMethod (+) | Trouve la méthode effective qui correspond à une signature donnée
FindMethod (+) | Trouve la méthode effective qui correspond à une liste de types de paramètres
GetMethodCount (-) | Nombre de méthodes de même nom
GetMethods (-) | Tableau zero-based des méthodes de même nom
IsVisibleFrom (+) | [@inheritDoc]
Load (+) | Charge une méthode surchargée depuis un flux

Properties
Property | Description
DefaultMethod (+) | Tableau zero-based des méthodes de même nom
MethodCount (+) | Nombre de méthodes de même nom
Methods (+) | Tableau zero-based des méthodes de même nom

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodRefType)
Next (TSepiParam)


Sepi

Sepi
Previous
Next

Name
FMethods

Parent
TSepiOverloadedMethod

Visibility
PRIVATE

Description
Liste des méthodes de même nom

Source code
FMethods : TObjectList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (MethodCount)

Name
DefaultMethod

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
Tableau zero-based des méthodes de même nom

Source code
property DefaultMethod : TSepiMethod index 0 read GetMethods

Read Access
GetMethods

Sepi
Class Tree
Index
Previous
Next (MethodCount)


Sepi

Sepi
Previous (DefaultMethod)
Next (Methods)

Name
MethodCount

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
Nombre de méthodes de même nom

Source code
property MethodCount : Integer read GetMethodCount

Read Access
GetMethodCount

Sepi
Class Tree
Index
Previous (DefaultMethod)
Next (Methods)


Sepi

Sepi
Previous (MethodCount)
Next

Name
Methods

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
Tableau zero-based des méthodes de même nom

Source code
property Methods [ Index : Integer ] : TSepiMethod read GetMethods

Read Access
GetMethods

Sepi
Class Tree
Index
Previous (MethodCount)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
Crée une nouvelle méthode surchargée

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la méthode
AName : STRING | Nom de la méthode

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (FindInherited)

Name
Destroy

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (FindInherited)


Sepi

Sepi
Previous (Destroy)
Next (FindMethod)

Name
FindInherited

Parent
TSepiOverloadedMethod

Visibility
PRIVATE

Description
Trouve la méthode effective dont une signature donnée hérite

Source code
function FindInherited ( ASignature : TSepiSignature ) : TSepiMethod

Parameters
Parameter | Description
ASignature : TSepiSignature | Signature à rechercher

Return
Types | Description
TSepiMethod | Méthode effective correspondante

Sepi
Class Tree
Index
Previous (Destroy)
Next (FindMethod)


Sepi

Sepi
Previous (FindInherited)
Next (FindMethod)

Name
FindMethod

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
Trouve la méthode effective qui correspond à une signature donnée

Source code
function FindMethod ( ASignature : TSepiSignature ; Options : TSepiSignatureCompareOptions = scoAll ) : TSepiMethod ; overload

Parameters
Parameter | Description
ASignature : TSepiSignature | Signature à rechercher
Options : TSepiSignatureCompareOptions | Options de comparaison

Return
Types | Description
TSepiMethod | Méthode effective correspondante

Sepi
Class Tree
Index
Previous (FindInherited)
Next (FindMethod)


Sepi

Sepi
Previous (FindMethod)
Next (GetMethodCount)

Name
FindMethod

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
Trouve la méthode effective qui correspond à une liste de types de paramètres

Source code
function FindMethod ( const ATypes : array of TSepiType ) : TSepiMethod ; overload

Parameters
Parameter | Description
ATypes : TSepiType | Liste des types de paramètres

Return
Types | Description
TSepiMethod | Méthode effective correspondante

Sepi
Class Tree
Index
Previous (FindMethod)
Next (GetMethodCount)


Sepi

Sepi
Previous (FindMethod)
Next (GetMethods)

Name
GetMethodCount

Parent
TSepiOverloadedMethod

Visibility
PRIVATE

Description
Nombre de méthodes de même nom

Source code
function GetMethodCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de méthodes de même nom

Sepi
Class Tree
Index
Previous (FindMethod)
Next (GetMethods)


Sepi

Sepi
Previous (GetMethodCount)
Next (IsVisibleFrom)

Name
GetMethods

Parent
TSepiOverloadedMethod

Visibility
PRIVATE

Description
Tableau zero-based des méthodes de même nom

Source code
function GetMethods ( Index : Integer ) : TSepiMethod

Parameters
Parameter | Description
INDEX : INTEGER | Index de la méthode

Return
Types | Description
TSepiMethod | Méthode de même nom à l'index spécifié

Sepi
Class Tree
Index
Previous (GetMethodCount)
Next (IsVisibleFrom)


Sepi

Sepi
Previous (GetMethods)
Next (Load)

Name
IsVisibleFrom

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function IsVisibleFrom ( FromComponent : TSepiComponent ) : Boolean ; override

Parameters
Parameter | Description
FromComponent : TSepiComponent | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetMethods)
Next (Load)


Sepi

Sepi
Previous (IsVisibleFrom)
Next

Name
Load

Parent
TSepiOverloadedMethod

Visibility
PUBLIC

Description
Charge une méthode surchargée depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsVisibleFrom)
Next


Sepi

Sepi
Previous (TSepiOverloadedMethod)
Next (TSepiParamCallInfo)

Name
TSepiParam

Parent
SepiMembers

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Paramètre de méthode
Les paramètres cachés ont aussi leur existence en tant que TSepiParam.
Les cinq types de paramètres cachés sont Self (classe ou instance), Result
(lorsqu'il est passé par adresse), le paramètre spécial $Alloc des
constructeurs, le paramètre spécial $Free des destructeurs et les
paramètres High$xxx suivant chaque paramètre de type "open array".

Members
Fields
Field | Description
FByRef (-) | True si passé par référence
FCallInfo (-) | Informations d'appel du paramètre
FDefaultValuePtr (-) | Pointeur sur la valeur par défaut
FElementType (-) | Type des éléments du tableau ouvert
FFlags (-) | Flags du paramètre
FHiddenKind (-) | Type de paramètre caché
FIsUntyped (-) | Indique si non typé
FKind (-) | Type de paramètre
FLoading (-) | True si en chargement depuis un flux
FName (-) | Nom
FOpenArray (-) | Indique si c'est un tableau ouvert
FOwner (-) | Signature propriétaire
FType (-) | Type du paramètre

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
AllocDefaultValue (+) | Alloue une valeur par défaut pour ce paramètre
Clone (+) | Clône un paramètre
CompatibleWith (+) | Détermine si un type est compatible avec le paramètre
Create (+) | Crée un nouveau paramètre
CreateFromString (-) | Crée un ou plusieurs paramètre(s) depuis sa définition Delphi
CreateHidden (-) | Crée un paramètre caché
Destroy (+) | [@inheritDoc]
Equals (+) | Détermine si deux paramètres sont identiques
GetDescription (-) | Description du paramètre
GetHasDefaultValue (-) | Indique si ce paramètre a une valeur par défaut
ListReferences (-) | [@inheritDoc]
Load (-) | Charge un paramètre depuis un flux
MakeFlags (-) | Construit la propriété Flags
Save (-) | [@inheritDoc]
WriteDigestData (-) | Écrit les données nécessaires au digest de compatibilité dans un flux

Properties
Property | Description
ByRef (+) | True si passé par référence
CallInfo (+) | Informations d'appel du paramètre
DefaultValuePtr (+) | Pointeur sur la valeur par défaut
Description (+) | Description du paramètre
ElementType (+) | Type des éléments du tableau ouvert
Flags (+) | Flags du paramètre
HasDefaultValue (+) | Indique si ce paramètre a une valeur par défaut
HiddenKind (+) | Type de paramètre caché
IsUntyped (+) | Indique si non typé
Kind (+) | Type de paramètre
NAME (+) | Nom
OpenArray (+) | Indique si c'est un tableau ouvert
Owner (+) | Signature propriétaire
ParamType (+) | Type du paramètre

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOverloadedMethod)
Next (TSepiParamCallInfo)


Sepi

Sepi
Previous
Next (FCallInfo)

Name
FByRef

Parent
TSepiParam

Visibility
PRIVATE

Description
True si passé par référence

Source code
FByRef : Boolean

Sepi
Class Tree
Index
Previous
Next (FCallInfo)


Sepi

Sepi
Previous (FByRef)
Next (FDefaultValuePtr)

Name
FCallInfo

Parent
TSepiParam

Visibility
PRIVATE

Description
Informations d'appel du paramètre

Source code
FCallInfo : TSepiParamCallInfo

Sepi
Class Tree
Index
Previous (FByRef)
Next (FDefaultValuePtr)


Sepi

Sepi
Previous (FCallInfo)
Next (FElementType)

Name
FDefaultValuePtr

Parent
TSepiParam

Visibility
PRIVATE

Description
Pointeur sur la valeur par défaut

Source code
FDefaultValuePtr : Pointer

Sepi
Class Tree
Index
Previous (FCallInfo)
Next (FElementType)


Sepi

Sepi
Previous (FDefaultValuePtr)
Next (FFlags)

Name
FElementType

Parent
TSepiParam

Visibility
PRIVATE

Description
Type des éléments du tableau ouvert

Source code
FElementType : TSepiType

Sepi
Class Tree
Index
Previous (FDefaultValuePtr)
Next (FFlags)


Sepi

Sepi
Previous (FElementType)
Next (FHiddenKind)

Name
FFlags

Parent
TSepiParam

Visibility
PRIVATE

Description
Flags du paramètre

Source code
FFlags : TParamFlags

Sepi
Class Tree
Index
Previous (FElementType)
Next (FHiddenKind)


Sepi

Sepi
Previous (FFlags)
Next (FIsUntyped)

Name
FHiddenKind

Parent
TSepiParam

Visibility
PRIVATE

Description
Type de paramètre caché

Source code
FHiddenKind : TSepiHiddenParamKind

Sepi
Class Tree
Index
Previous (FFlags)
Next (FIsUntyped)


Sepi

Sepi
Previous (FHiddenKind)
Next (FKind)

Name
FIsUntyped

Parent
TSepiParam

Visibility
PRIVATE

Description
Indique si non typé

Source code
FIsUntyped : Boolean

Sepi
Class Tree
Index
Previous (FHiddenKind)
Next (FKind)


Sepi

Sepi
Previous (FIsUntyped)
Next (FLoading)

Name
FKind

Parent
TSepiParam

Visibility
PRIVATE

Description
Type de paramètre

Source code
FKind : TSepiParamKind

Sepi
Class Tree
Index
Previous (FIsUntyped)
Next (FLoading)


Sepi

Sepi
Previous (FKind)
Next (FName)

Name
FLoading

Parent
TSepiParam

Visibility
PRIVATE

Description
True si en chargement depuis un flux

Source code
FLoading : Boolean

Sepi
Class Tree
Index
Previous (FKind)
Next (FName)


Sepi

Sepi
Previous (FLoading)
Next (FOpenArray)

Name
FName

Parent
TSepiParam

Visibility
PRIVATE

Description
Nom

Source code
FName : string

Sepi
Class Tree
Index
Previous (FLoading)
Next (FOpenArray)


Sepi

Sepi
Previous (FName)
Next (FOwner)

Name
FOpenArray

Parent
TSepiParam

Visibility
PRIVATE

Description
Indique si c'est un tableau ouvert

Source code
FOpenArray : Boolean

Sepi
Class Tree
Index
Previous (FName)
Next (FOwner)


Sepi

Sepi
Previous (FOpenArray)
Next (FType)

Name
FOwner

Parent
TSepiParam

Visibility
PRIVATE

Description
Signature propriétaire

Source code
FOwner : TSepiSignature

Sepi
Class Tree
Index
Previous (FOpenArray)
Next (FType)


Sepi

Sepi
Previous (FOwner)
Next

Name
FType

Parent
TSepiParam

Visibility
PRIVATE

Description
Type du paramètre

Source code
FType : TSepiType

Sepi
Class Tree
Index
Previous (FOwner)
Next


Sepi

Sepi
Previous
Next (CallInfo)

Name
ByRef

Parent
TSepiParam

Visibility
PUBLIC

Description
True si passé par référence

Source code
property ByRef : Boolean read FByRef

Read Access
FByRef

Sepi
Class Tree
Index
Previous
Next (CallInfo)


Sepi

Sepi
Previous (ByRef)
Next (DefaultValuePtr)

Name
CallInfo

Parent
TSepiParam

Visibility
PUBLIC

Description
Informations d'appel du paramètre

Source code
property CallInfo : TSepiParamCallInfo read FCallInfo

Read Access
FCallInfo

Sepi
Class Tree
Index
Previous (ByRef)
Next (DefaultValuePtr)


Sepi

Sepi
Previous (CallInfo)
Next (Description)

Name
DefaultValuePtr

Parent
TSepiParam

Visibility
PUBLIC

Description
Pointeur sur la valeur par défaut

Source code
property DefaultValuePtr : Pointer read FDefaultValuePtr

Read Access
FDefaultValuePtr

Sepi
Class Tree
Index
Previous (CallInfo)
Next (Description)


Sepi

Sepi
Previous (DefaultValuePtr)
Next (ElementType)

Name
Description

Parent
TSepiParam

Visibility
PUBLIC

Description
Description du paramètre

Source code
property Description : string read GetDescription

Read Access
GetDescription

Sepi
Class Tree
Index
Previous (DefaultValuePtr)
Next (ElementType)


Sepi

Sepi
Previous (Description)
Next (Flags)

Name
ElementType

Parent
TSepiParam

Visibility
PUBLIC

Description
Type des éléments du tableau ouvert

Source code
property ElementType : TSepiType read FElementType

Read Access
FElementType

Sepi
Class Tree
Index
Previous (Description)
Next (Flags)


Sepi

Sepi
Previous (ElementType)
Next (HasDefaultValue)

Name
Flags

Parent
TSepiParam

Visibility
PUBLIC

Description
Flags du paramètre

Source code
property Flags : TParamFlags read FFlags

Read Access
FFlags

Sepi
Class Tree
Index
Previous (ElementType)
Next (HasDefaultValue)


Sepi

Sepi
Previous (Flags)
Next (HiddenKind)

Name
HasDefaultValue

Parent
TSepiParam

Visibility
PUBLIC

Description
Indique si ce paramètre a une valeur par défaut

Source code
property HasDefaultValue : Boolean read GetHasDefaultValue

Read Access
GetHasDefaultValue

Sepi
Class Tree
Index
Previous (Flags)
Next (HiddenKind)


Sepi

Sepi
Previous (HasDefaultValue)
Next (IsUntyped)

Name
HiddenKind

Parent
TSepiParam

Visibility
PUBLIC

Description
Type de paramètre caché

Source code
property HiddenKind : TSepiHiddenParamKind read FHiddenKind

Read Access
FHiddenKind

Sepi
Class Tree
Index
Previous (HasDefaultValue)
Next (IsUntyped)


Sepi

Sepi
Previous (HiddenKind)
Next (Kind)

Name
IsUntyped

Parent
TSepiParam

Visibility
PUBLIC

Description
Indique si non typé

Source code
property IsUntyped : Boolean read FIsUntyped

Read Access
FIsUntyped

Sepi
Class Tree
Index
Previous (HiddenKind)
Next (Kind)


Sepi

Sepi
Previous (IsUntyped)
Next (NAME)

Name
Kind

Parent
TSepiParam

Visibility
PUBLIC

Description
Type de paramètre

Source code
property Kind : TSepiParamKind read FKind

Read Access
FKind

Sepi
Class Tree
Index
Previous (IsUntyped)
Next (NAME)


Sepi

Sepi
Previous (Kind)
Next (OpenArray)

Name
NAME

Parent
TSepiParam

Visibility
PUBLIC

Description
Nom

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (Kind)
Next (OpenArray)


Sepi

Sepi
Previous (NAME)
Next (Owner)

Name
OpenArray

Parent
TSepiParam

Visibility
PUBLIC

Description
Indique si c'est un tableau ouvert

Source code
property OpenArray : Boolean read FOpenArray

Read Access
FOpenArray

Sepi
Class Tree
Index
Previous (NAME)
Next (Owner)


Sepi

Sepi
Previous (OpenArray)
Next (ParamType)

Name
Owner

Parent
TSepiParam

Visibility
PUBLIC

Description
Signature propriétaire

Source code
property Owner : TSepiSignature read FOwner

Read Access
FOwner

Sepi
Class Tree
Index
Previous (OpenArray)
Next (ParamType)


Sepi

Sepi
Previous (Owner)
Next

Name
ParamType

Parent
TSepiParam

Visibility
PUBLIC

Description
Type du paramètre

Source code
property ParamType : TSepiType read FType

Read Access
FType

Sepi
Class Tree
Index
Previous (Owner)
Next


Sepi

Sepi
Previous
Next (AllocDefaultValue)

Name
AfterConstruction

Parent
TSepiParam

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (AllocDefaultValue)


Sepi

Sepi
Previous (AfterConstruction)
Next (Clone)

Name
AllocDefaultValue

Parent
TSepiParam

Visibility
PUBLIC

Description
Alloue une valeur par défaut pour ce paramètre

Source code
procedure AllocDefaultValue

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Clone)


Sepi

Sepi
Previous (AllocDefaultValue)
Next (CompatibleWith)

Name
Clone

Parent
TSepiParam

Visibility
PUBLIC

Description
Clône un paramètre

Source code
constructor Clone ( AOwner : TSepiSignature ; Source : TSepiParam )

Parameters
Parameter | Description
AOwner : TSepiSignature | Propriétaire du paramètre
Source : TSepiParam

Sepi
Class Tree
Index
Previous (AllocDefaultValue)
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
CompatibleWith

Parent
TSepiParam

Visibility
PUBLIC

Description
Détermine si un type est compatible avec le paramètre

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean

Parameters
Parameter | Description
AType : TSepiType | Type à Tester

Return
Types | Description
BOOLEAN | True si le type est compatible, False sinon

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (CreateFromString)

Name
Create

Parent
TSepiParam

Visibility
PUBLIC

Description
Crée un nouveau paramètre

Source code
constructor Create ( AOwner : TSepiSignature ; const AName : string ; AType : TSepiType ; AKind : TSepiParamKind = pkValue ; AOpenArray : Boolean = False )

Parameters
Parameter | Description
AOwner : TSepiSignature | Propriétaire du paramètre
AName : STRING | Nom du paramètre
AType : TSepiType | Type du paramètre
AKind : TSepiParamKind | Type de paramètre
AOpenArray : BOOLEAN | True pour un paramètre tableau ouvert

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (CreateFromString)


Sepi

Sepi
Previous (Create)
Next (CreateHidden)

Name
CreateFromString

Parent
TSepiParam

Visibility
PRIVATE

Description
Crée un ou plusieurs paramètre(s) depuis sa définition Delphi

Source code
class procedure CreateFromString ( AOwner : TSepiSignature ; const Definition : string )

Parameters
Parameter | Description
AOwner : TSepiSignature | Propriétaire du ou des paramètre(s)
Definition : STRING | Définition Delphi du ou des paramètre(s)

Sepi
Class Tree
Index
Previous (Create)
Next (CreateHidden)


Sepi

Sepi
Previous (CreateFromString)
Next (Destroy)

Name
CreateHidden

Parent
TSepiParam

Visibility
PRIVATE

Description
Crée un paramètre caché

Source code
constructor CreateHidden ( AOwner : TSepiSignature ; AHiddenKind : TSepiHiddenParamKind ; AType : TSepiType = nil )

Parameters
Parameter | Description
AOwner : TSepiSignature | Propriétaire du paramètre
AHiddenKind : TSepiHiddenParamKind | Type de paramètre caché (doit être différent de pkNormal)
AType : TSepiType | Type du paramètre (uniquement pour AKind = pkResult)

Sepi
Class Tree
Index
Previous (CreateFromString)
Next (Destroy)


Sepi

Sepi
Previous (CreateHidden)
Next (Equals)

Name
Destroy

Parent
TSepiParam

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateHidden)
Next (Equals)


Sepi

Sepi
Previous (Destroy)
Next (GetDescription)

Name
Equals

Parent
TSepiParam

Visibility
PUBLIC

Description
Détermine si deux paramètres sont identiques

Source code
function Equals ( AParam : TSepiParam ; Options : TSepiSignatureCompareOptions = pcoAll ) : Boolean ; reintroduce

Parameters
Parameter | Description
AParam : TSepiParam | Paramètre à comparer
Options : TSepiSignatureCompareOptions | Options de comparaison

Return
Types | Description
BOOLEAN | True si les paramètres sont identiques, False sinon

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetDescription)


Sepi

Sepi
Previous (Equals)
Next (GetHasDefaultValue)

Name
GetDescription

Parent
TSepiParam

Visibility
PRIVATE

Description
Description du paramètre

Source code
function GetDescription : string

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetHasDefaultValue)


Sepi

Sepi
Previous (GetDescription)
Next (ListReferences)

Name
GetHasDefaultValue

Parent
TSepiParam

Visibility
PRIVATE

Description
Indique si ce paramètre a une valeur par défaut

Source code
function GetHasDefaultValue : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si ce paramètre a une valeur par défaut, False sinon

Sepi
Class Tree
Index
Previous (GetDescription)
Next (ListReferences)


Sepi

Sepi
Previous (GetHasDefaultValue)
Next (Load)

Name
ListReferences

Parent
TSepiParam

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure ListReferences

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetHasDefaultValue)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (MakeFlags)

Name
Load

Parent
TSepiParam

Visibility
PRIVATE

Description
Charge un paramètre depuis un flux

Source code
constructor Load ( AOwner : TSepiSignature ; Stream : TStream )

Parameters
Parameter | Description
AOwner : TSepiSignature | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (MakeFlags)


Sepi

Sepi
Previous (Load)
Next (Save)

Name
MakeFlags

Parent
TSepiParam

Visibility
PRIVATE

Description
Construit la propriété Flags

Source code
procedure MakeFlags

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Load)
Next (Save)


Sepi

Sepi
Previous (MakeFlags)
Next (WriteDigestData)

Name
Save

Parent
TSepiParam

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeFlags)
Next (WriteDigestData)


Sepi

Sepi
Previous (Save)
Next

Name
WriteDigestData

Parent
TSepiParam

Visibility
PRIVATE

Description
Écrit les données nécessaires au digest de compatibilité dans un flux

Source code
procedure WriteDigestData ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (Save)
Next


Sepi

Sepi
Previous (TSepiParam)
Next (TSepiProperty)

Name
TSepiParamCallInfo

Parent
SepiMembers

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Informations d'appel d'un paramètre (où et comment le passer)

Members
Fields
Field | Description
ByAddress (*) | True pour le passer par adresse
Place (*) | Endroit où le placer
SepiStackOffset (*) | Offset dans la pile pour des appels Sepi
StackOffset (*) | Offset où le placer dans la pile

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParam)
Next (TSepiProperty)


Sepi

Sepi
Previous
Next (Place)

Name
ByAddress

Parent
TSepiParamCallInfo

Visibility
PUBLISHED

Description
True pour le passer par adresse

Source code
ByAddress : Boolean

Sepi
Class Tree
Index
Previous
Next (Place)


Sepi

Sepi
Previous (ByAddress)
Next (SepiStackOffset)

Name
Place

Parent
TSepiParamCallInfo

Visibility
PUBLISHED

Description
Endroit où le placer

Source code
Place : TSepiParamPlace

Sepi
Class Tree
Index
Previous (ByAddress)
Next (SepiStackOffset)


Sepi

Sepi
Previous (Place)
Next (StackOffset)

Name
SepiStackOffset

Parent
TSepiParamCallInfo

Visibility
PUBLISHED

Description
Offset dans la pile pour des appels Sepi

Source code
SepiStackOffset : Word

Sepi
Class Tree
Index
Previous (Place)
Next (StackOffset)


Sepi

Sepi
Previous (SepiStackOffset)
Next

Name
StackOffset

Parent
TSepiParamCallInfo

Visibility
PUBLISHED

Description
Offset où le placer dans la pile

Source code
StackOffset : Word

Sepi
Class Tree
Index
Previous (SepiStackOffset)
Next


Sepi

Sepi
Previous (TSepiParamCallInfo)
Next (TSepiPropertyAccess)

Name
TSepiProperty

Parent
SepiMembers

Class Hierarchy
TSepiMember

Visibility
PUBLIC

Description
Propriété

Members
Fields
Field | Description
FDefaultValue (-) | Valeur par défaut
FIndex (-) | Index d'accès
FIsDefault (-) | Indique si c'est la propriété par défaut
FNameIndex (-) | Index de cette propriété dans les PropInfos
FReadAccess (-) | Accès en lecture
FSignature (-) | Signature
FStorage (-) | Spécificateur de stockage
FWriteAccess (-) | Accès en écriture

Methods
Method | Description
Create (+) | Crée une nouvelle propriété
Create (+) | Crée une nouvelle propriété
Create (+) | Crée une nouvelle propriété
Destroy (+) | Détruit l'instance
Destroying (#) | [@inheritDoc]
GetIsClassProperty (-) | Indique si c'est une propriété de classe
GetPropType (-) | Type de la propriété
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une propriété depuis un flux
Redefine (+) | Redéfinit une propriété héritée
Redefine (+) | Redéfinit une propriété héritée
Redefine (+) | Redéfinit une propriété héritée
Save (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WritePropInfo (-) | Construit les informations de propriétés pour les RTTI

Properties
Property | Description
DefaultValue (+) | Valeur par défaut
INDEX (+) | Index d'accès
IsClassProperty (+) | Indique si c'est une propriété de classe
IsDefault (+) | Indique si c'est la propriété par défaut
PropType (+) | Type de la propriété
ReadAccess (+) | Accès en lecture
Signature (+) | Signature
Storage (+) | Spécificateur de stockage
WriteAccess (+) | Accès en écriture

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParamCallInfo)
Next (TSepiPropertyAccess)


Sepi

Sepi
Previous
Next (FIndex)

Name
FDefaultValue

Parent
TSepiProperty

Visibility
PRIVATE

Description
Valeur par défaut

Source code
FDefaultValue : Integer

Sepi
Class Tree
Index
Previous
Next (FIndex)


Sepi

Sepi
Previous (FDefaultValue)
Next (FIsDefault)

Name
FIndex

Parent
TSepiProperty

Visibility
PRIVATE

Description
Index d'accès

Source code
FIndex : Integer

Sepi
Class Tree
Index
Previous (FDefaultValue)
Next (FIsDefault)


Sepi

Sepi
Previous (FIndex)
Next (FNameIndex)

Name
FIsDefault

Parent
TSepiProperty

Visibility
PRIVATE

Description
Indique si c'est la propriété par défaut

Source code
FIsDefault : Boolean

Sepi
Class Tree
Index
Previous (FIndex)
Next (FNameIndex)


Sepi

Sepi
Previous (FIsDefault)
Next (FReadAccess)

Name
FNameIndex

Parent
TSepiProperty

Visibility
PRIVATE

Description
Index de cette propriété dans les PropInfos

Source code
FNameIndex : Integer

Sepi
Class Tree
Index
Previous (FIsDefault)
Next (FReadAccess)


Sepi

Sepi
Previous (FNameIndex)
Next (FSignature)

Name
FReadAccess

Parent
TSepiProperty

Visibility
PRIVATE

Description
Accès en lecture

Source code
FReadAccess : TSepiPropertyAccess

Sepi
Class Tree
Index
Previous (FNameIndex)
Next (FSignature)


Sepi

Sepi
Previous (FReadAccess)
Next (FStorage)

Name
FSignature

Parent
TSepiProperty

Visibility
PRIVATE

Description
Signature

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous (FReadAccess)
Next (FStorage)


Sepi

Sepi
Previous (FSignature)
Next (FWriteAccess)

Name
FStorage

Parent
TSepiProperty

Visibility
PRIVATE

Description
Spécificateur de stockage

Source code
FStorage : TSepiPropertyStorage

Sepi
Class Tree
Index
Previous (FSignature)
Next (FWriteAccess)


Sepi

Sepi
Previous (FStorage)
Next

Name
FWriteAccess

Parent
TSepiProperty

Visibility
PRIVATE

Description
Accès en écriture

Source code
FWriteAccess : TSepiPropertyAccess

Sepi
Class Tree
Index
Previous (FStorage)
Next


Sepi

Sepi
Previous
Next (INDEX)

Name
DefaultValue

Parent
TSepiProperty

Visibility
PUBLIC

Description
Valeur par défaut

Source code
property DefaultValue : Integer read FDefaultValue

Read Access
FDefaultValue

Sepi
Class Tree
Index
Previous
Next (INDEX)


Sepi

Sepi
Previous (DefaultValue)
Next (IsClassProperty)

Name
INDEX

Parent
TSepiProperty

Visibility
PUBLIC

Description
Index d'accès

Source code
property Index : Integer read FIndex

Read Access
FIndex

Sepi
Class Tree
Index
Previous (DefaultValue)
Next (IsClassProperty)


Sepi

Sepi
Previous (INDEX)
Next (IsDefault)

Name
IsClassProperty

Parent
TSepiProperty

Visibility
PUBLIC

Description
Indique si c'est une propriété de classe

Source code
property IsClassProperty : Boolean read GetIsClassProperty

Read Access
GetIsClassProperty

Sepi
Class Tree
Index
Previous (INDEX)
Next (IsDefault)


Sepi

Sepi
Previous (IsClassProperty)
Next (PropType)

Name
IsDefault

Parent
TSepiProperty

Visibility
PUBLIC

Description
Indique si c'est la propriété par défaut

Source code
property IsDefault : Boolean read FIsDefault

Read Access
FIsDefault

Sepi
Class Tree
Index
Previous (IsClassProperty)
Next (PropType)


Sepi

Sepi
Previous (IsDefault)
Next (ReadAccess)

Name
PropType

Parent
TSepiProperty

Visibility
PUBLIC

Description
Type de la propriété

Source code
property PropType : TSepiType read GetPropType

Read Access
GetPropType

Sepi
Class Tree
Index
Previous (IsDefault)
Next (ReadAccess)


Sepi

Sepi
Previous (PropType)
Next (Signature)

Name
ReadAccess

Parent
TSepiProperty

Visibility
PUBLIC

Description
Accès en lecture

Source code
property ReadAccess : TSepiPropertyAccess read FReadAccess

Read Access
FReadAccess

Sepi
Class Tree
Index
Previous (PropType)
Next (Signature)


Sepi

Sepi
Previous (ReadAccess)
Next (Storage)

Name
Signature

Parent
TSepiProperty

Visibility
PUBLIC

Description
Signature

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous (ReadAccess)
Next (Storage)


Sepi

Sepi
Previous (Signature)
Next (WriteAccess)

Name
Storage

Parent
TSepiProperty

Visibility
PUBLIC

Description
Spécificateur de stockage

Source code
property Storage : TSepiPropertyStorage read FStorage

Read Access
FStorage

Sepi
Class Tree
Index
Previous (Signature)
Next (WriteAccess)


Sepi

Sepi
Previous (Storage)
Next

Name
WriteAccess

Parent
TSepiProperty

Visibility
PUBLIC

Description
Accès en écriture

Source code
property WriteAccess : TSepiPropertyAccess read FWriteAccess

Read Access
FWriteAccess

Sepi
Class Tree
Index
Previous (Storage)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TSepiProperty

Visibility
PUBLIC

Description
Crée une nouvelle propriété

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ASignature : TSepiSignature ; AReadAccess , AWriteAccess : TSepiMember ; AIndex , ADefaultValue : Integer ; const AStorage : TSepiPropertyStorage ; AIsDefault : Boolean ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la propriété
AName : STRING | Nom de la propriété
ASignature : TSepiSignature | Signature
AReadAccess : TSepiMember | Accès en lecture à la propriété (peut être nil)
AWriteAccess : TSepiMember | Accès en écriture à la propriété (peut être nil)
AIndex : INTEGER | Index d'accès
ADefaultValue : INTEGER | Valeur par défaut de la propriété
AStorage : TSepiPropertyStorage | Spécificateur de stockage
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TSepiProperty

Visibility
PUBLIC

Description
Crée une nouvelle propriété

Source code
constructor Create ( AOwner : TSepiComponent ; const AName , ASignature , AReadAccess , AWriteAccess : string ; AIsDefault : Boolean ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la propriété
AName : STRING | Nom de la propriété
ASignature : STRING | Signature
AReadAccess : STRING | Accès en lecture à la propriété (peut être vide)
AWriteAccess : STRING | Accès en écriture à la propriété (peut être vide)
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TSepiProperty

Visibility
PUBLIC

Description
Crée une nouvelle propriété

Source code
constructor Create ( AOwner : TSepiComponent ; const AName , ASignature , AReadAccess , AWriteAccess : string ; AIndex : Integer = NoIndex ; ADefaultValue : Integer = NoDefaultValue ; const AStorage : string = '' ; AIsDefault : Boolean = False ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la propriété
AName : STRING | Nom de la propriété
ASignature : STRING | Signature
AReadAccess : STRING | Accès en lecture à la propriété (peut être vide)
AWriteAccess : STRING | Accès en écriture à la propriété (peut être vide)
AIndex : INTEGER | Index d'accès
ADefaultValue : INTEGER | Valeur par défaut de la propriété
AStorage : STRING | Spécificateur de stockage
AIsDefault : BOOLEAN | Indique si c'est la propriété tableau par défaut

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Destroying)

Name
Destroy

Parent
TSepiProperty

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroying)


Sepi

Sepi
Previous (Destroy)
Next (GetIsClassProperty)

Name
Destroying

Parent
TSepiProperty

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Destroying ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetIsClassProperty)


Sepi

Sepi
Previous (Destroying)
Next (GetPropType)

Name
GetIsClassProperty

Parent
TSepiProperty

Visibility
PRIVATE

Description
Indique si c'est une propriété de classe

Source code
function GetIsClassProperty : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si c'est une propriété de classe, False sinon

Sepi
Class Tree
Index
Previous (Destroying)
Next (GetPropType)


Sepi

Sepi
Previous (GetIsClassProperty)
Next (ListReferences)

Name
GetPropType

Parent
TSepiProperty

Visibility
PRIVATE

Description
Type de la propriété

Source code
function GetPropType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type de la propriété

Sepi
Class Tree
Index
Previous (GetIsClassProperty)
Next (ListReferences)


Sepi

Sepi
Previous (GetPropType)
Next (Load)

Name
ListReferences

Parent
TSepiProperty

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetPropType)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Redefine)

Name
Load

Parent
TSepiProperty

Visibility
PUBLIC

Description
Charge une propriété depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Redefine)


Sepi

Sepi
Previous (Load)
Next (Redefine)

Name
Redefine

Parent
TSepiProperty

Visibility
PUBLIC

Description
Redéfinit une propriété héritée

Source code
constructor Redefine ( AOwner : TSepiComponent ; const AName : string ; const AReadAccess : string = '' ; const AWriteAccess : string = '' ; const AStorage : string = '' ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la propriété
AName : STRING | Nom de la propriété
AReadAccess : STRING | Accès en lecture à la propriété
AWriteAccess : STRING | Accès en écriture à la propriété
AStorage : STRING | Spécificateur de stockage

Sepi
Class Tree
Index
Previous (Load)
Next (Redefine)


Sepi

Sepi
Previous (Redefine)
Next (Redefine)

Name
Redefine

Parent
TSepiProperty

Visibility
PUBLIC

Description
Redéfinit une propriété héritée

Source code
constructor Redefine ( AOwner : TSepiComponent ; const AName , AReadAccess , AWriteAccess : string ; ADefaultValue : Integer ; const AStorage : string = '' ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la propriété
AName : STRING | Nom de la propriété
AReadAccess : STRING | Accès en lecture à la propriété (peut être vide)
AWriteAccess : STRING | Accès en écriture à la propriété (peut être vide)
ADefaultValue : INTEGER | Valeur par défaut de la propriété
AStorage : STRING | Spécificateur de stockage

Sepi
Class Tree
Index
Previous (Redefine)
Next (Redefine)


Sepi

Sepi
Previous (Redefine)
Next (Save)

Name
Redefine

Parent
TSepiProperty

Visibility
PUBLIC

Description
Redéfinit une propriété héritée

Source code
constructor Redefine ( AOwner : TSepiComponent ; const AName : string ; AReadAccess , AWriteAccess : TSepiMember ; ADefaultValue : Integer ; const AStorage : TSepiPropertyStorage ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la propriété
AName : STRING | Nom de la propriété
AReadAccess : TSepiMember | Accès en lecture à la propriété
AWriteAccess : TSepiMember | Accès en écriture à la propriété
ADefaultValue : INTEGER
AStorage : TSepiPropertyStorage | Spécificateur de stockage

Sepi
Class Tree
Index
Previous (Redefine)
Next (Save)


Sepi

Sepi
Previous (Redefine)
Next (WriteDigestData)

Name
Save

Parent
TSepiProperty

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Redefine)
Next (WriteDigestData)


Sepi

Sepi
Previous (Save)
Next (WritePropInfo)

Name
WriteDigestData

Parent
TSepiProperty

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next (WritePropInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WritePropInfo

Parent
TSepiProperty

Visibility
PRIVATE

Description
Construit les informations de propriétés pour les RTTI
Cette méthode ne doit être appelée que pour des propriétés d'objet, pas pour
des propriétés d'interface ou de classe.

Source code
procedure WritePropInfo ( Stream : TStream )

Parameters
Parameter Description
Stream : TStream

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiProperty)
Next (TSepiPropertyStorage)

Name
TSepiPropertyAccess

Parent
SepiMembers

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Accès de propriété

Members
Fields
Field | Description
ClassField (*) | #No TAG found in source code#
Component (*) | #No TAG found in source code#
Field (*) | #No TAG found in source code#
Kind (*) | Type d'accès
Method (*) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiProperty)
Next (TSepiPropertyStorage)


Sepi

Sepi
Previous
Next (Component)

Name
ClassField

Parent
TSepiPropertyAccess

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ClassField : TSepiClassField

Sepi
Class Tree
Index
Previous
Next (Component)


Sepi

Sepi
Previous (ClassField)
Next (Field)

Name
Component

Parent
TSepiPropertyAccess

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Component : TSepiMember

Sepi
Class Tree
Index
Previous (ClassField)
Next (Field)


Sepi

Sepi
Previous (Component)
Next (Kind)

Name
Field

Parent
TSepiPropertyAccess

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Field : TSepiField

Sepi
Class Tree
Index
Previous (Component)
Next (Kind)


Sepi

Sepi
Previous (Field)
Next (Method)

Name
Kind

Parent
TSepiPropertyAccess

Visibility
PUBLISHED

Description
Type d'accès
Accès neutre
Accès champ
Accès méthode
Accès champ de classe

Source code
Kind : TPropertyAccessKind

Sepi
Class Tree
Index
Previous (Field)
Next (Method)


Sepi

Sepi
Previous (Kind)
Next

Name
Method

Parent
TSepiPropertyAccess

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Method : TSepiMethod

Sepi
Class Tree
Index
Previous (Kind)
Next


Sepi

Sepi
Previous (TSepiPropertyAccess)
Next (TSepiRecordType)

Name
TSepiPropertyStorage

Parent
SepiMembers

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Stockage de propriété

Members
Fields
Field | Description
Component (*) | #No TAG found in source code#
Field (*) | #No TAG found in source code#
Kind (*) | Type de stockage
Method (*) | #No TAG found in source code#
STORED (*) | Constante de stockage

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropertyAccess)
Next (TSepiRecordType)


Sepi

Sepi
Previous
Next (Field)

Name
Component

Parent
TSepiPropertyStorage

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Component : TSepiMember

Sepi
Class Tree
Index
Previous
Next (Field)


Sepi

Sepi
Previous (Component)
Next (Kind)

Name
Field

Parent
TSepiPropertyStorage

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Field : TSepiField

Sepi
Class Tree
Index
Previous (Component)
Next (Kind)


Sepi

Sepi
Previous (Field)
Next (Method)

Name
Kind

Parent
TSepiPropertyStorage

Visibility
PUBLISHED

Description
Type de stockage

Source code
Kind : TPropertyStorageKind

Sepi
Class Tree
Index
Previous (Field)
Next (Method)


Sepi

Sepi
Previous (Kind)
Next (STORED)

Name
Method

Parent
TSepiPropertyStorage

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Method : TSepiMethod

Sepi
Class Tree
Index
Previous (Kind)
Next (STORED)


Sepi

Sepi
Previous (Method)
Next

Name
STORED

Parent
TSepiPropertyStorage

Visibility
PUBLISHED

Description
Constante de stockage
Membre de stockage
Champ de stockage
Méthode de stockage

Source code
Stored : Boolean

Sepi
Class Tree
Index
Previous (Method)
Next


Sepi

Sepi
Previous (TSepiPropertyStorage)
Next (TSepiSignature)

Name
TSepiRecordType

Parent
SepiMembers

Class Hierarchy
TSepiContainerType

Visibility
PUBLIC

Description
Type enregistrement

Members
Fields
Field | Description
FAlignment (-) | Alignement
FFields (-) | Champs
FMaxAlign (-) | Alignement maximum
FPacked (-) | Indique si le record est packed

Methods
Method | Description
AddField (+) | Ajoute un champ au record
AddFieldAfter (+) | Ajoute un champ au record après un champ donné en mémoire
ChildAdded (#) | [@inheritDoc]
Clone (+) | [@inheritDoc]
CompatibleWith (+) | [@inheritDoc]
Complete (+) | [@inheritDoc]
Create (+) | Crée un nouveau type record
Destroy (+) | [@inheritDoc]
Equals (+) | [@inheritDoc]
GetAlignment (#) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
GetFieldCount (-) | Nombre de champs
GetFields (-) | Tableau zero-based des champs
HasTypeInfo (#) | [@inheritDoc]
IsStrongComposite (#) | [@inheritDoc]
Load (+) | Charge un type record depuis un flux
PrivAddField (-) | Ajoute un champ au record
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
FieldCount (+) | Nombre de champs
Fields (+) | Tableau zero-based des champs
IsPacked (+) | Indique si le record est packed
MaxAlign (+) | Alignement maximum

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropertyStorage)
Next (TSepiSignature)


Sepi

Sepi
Previous
Next (FFields)

Name
FAlignment

Parent
TSepiRecordType

Visibility
PRIVATE

Description
Alignement

Source code
FAlignment : Integer

Sepi
Class Tree
Index
Previous
Next (FFields)


Sepi

Sepi
Previous (FAlignment)
Next (FMaxAlign)

Name
FFields

Parent
TSepiRecordType

Visibility
PRIVATE

Description
Champs

Source code
FFields : TObjectList

Sepi
Class Tree
Index
Previous (FAlignment)
Next (FMaxAlign)


Sepi

Sepi
Previous (FFields)
Next (FPacked)

Name
FMaxAlign

Parent
TSepiRecordType

Visibility
PRIVATE

Description
Alignement maximum

Source code
FMaxAlign : Integer

Sepi
Class Tree
Index
Previous (FFields)
Next (FPacked)


Sepi

Sepi
Previous (FMaxAlign)
Next

Name
FPacked

Parent
TSepiRecordType

Visibility
PRIVATE

Description
Indique si le record est packed

Source code
FPacked : Boolean

Sepi
Class Tree
Index
Previous (FMaxAlign)
Next


Sepi

Sepi
Previous
Next (Fields)

Name
FieldCount

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Nombre de champs

Source code
property FieldCount : Integer read GetFieldCount

Read Access
GetFieldCount

Sepi
Class Tree
Index
Previous
Next (Fields)


Sepi

Sepi
Previous (FieldCount)
Next (IsPacked)

Name
Fields

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Tableau zero-based des champs

Source code
property Fields [ Index : Integer ] : TSepiField read GetFields

Read Access
GetFields

Sepi
Class Tree
Index
Previous (FieldCount)
Next (IsPacked)


Sepi

Sepi
Previous (Fields)
Next (MaxAlign)

Name
IsPacked

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Indique si le record est packed

Source code
property IsPacked : Boolean read FPacked

Read Access
FPacked

Sepi
Class Tree
Index
Previous (Fields)
Next (MaxAlign)


Sepi

Sepi
Previous (IsPacked)
Next

Name
MaxAlign

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Alignement maximum

Source code
property MaxAlign : Integer read FMaxAlign write FMaxAlign

Read Access
FMaxAlign

Write Access
FMaxAlign

Sepi
Class Tree
Index
Previous (IsPacked)
Next


Sepi

Sepi
Previous
Next (AddFieldAfter)

Name
AddField

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Ajoute un champ au record

Source code
function AddField ( const FieldName : string ; FieldType : TSepiType ; ForcePack : Boolean = False ) : TSepiField

Parameters
Parameter | Description
FieldName : STRING | Nom du champ
FieldType : TSepiType | Type du champ
ForcePack : BOOLEAN | Force un pack sur ce champ si True

Return
Types | Description
TSepiField | Champ nouvellement ajouté

Sepi
Class Tree
Index
Previous
Next (AddFieldAfter)


Sepi

Sepi
Previous (AddField)
Next (ChildAdded)

Name
AddFieldAfter

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Ajoute un champ au record après un champ donné en mémoire

Source code
function AddFieldAfter ( const FieldName : string ; FieldType : TSepiType ; const After : string ; ForcePack : Boolean = False ) : TSepiField

Parameters
Parameter | Description
FieldName : STRING | Nom du champ
FieldType : TSepiType | Type du champ
After : STRING | Nom du champ précédent en mémoire (vide pour le début)
ForcePack : BOOLEAN | Force un pack sur ce champ si True

Return
Types | Description
TSepiField | Champ nouvellement ajouté

Sepi
Class Tree
Index
Previous (AddField)
Next (ChildAdded)


Sepi

Sepi
Previous (AddFieldAfter)
Next (Clone)

Name
ChildAdded

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildAdded ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AddFieldAfter)
Next (Clone)


Sepi

Sepi
Previous (ChildAdded)
Next (CompatibleWith)

Name
Clone

Parent
TSepiRecordType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildAdded)
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Complete)

Name
CompatibleWith

Parent
TSepiRecordType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clone)
Next (Complete)


Sepi

Sepi
Previous (CompatibleWith)
Next (Create)

Name
Complete

Parent
TSepiRecordType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure Complete ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Destroy)

Name
Create

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Crée un nouveau type record

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; APacked : Boolean = False )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
APacked : BOOLEAN

Sepi
Class Tree
Index
Previous (Complete)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Equals)

Name
Destroy

Parent
TSepiRecordType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Equals)


Sepi

Sepi
Previous (Destroy)
Next (GetAlignment)

Name
Equals

Parent
TSepiRecordType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetAlignment)


Sepi

Sepi
Previous (Equals)
Next (GetDescription)

Name
GetAlignment

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetDescription)


Sepi

Sepi
Previous (GetAlignment)
Next (GetFieldCount)

Name
GetDescription

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAlignment)
Next (GetFieldCount)


Sepi

Sepi
Previous (GetDescription)
Next (GetFields)

Name
GetFieldCount

Parent
TSepiRecordType

Visibility
PRIVATE

Description
Nombre de champs

Source code
function GetFieldCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de champs

Sepi
Class Tree
Index
Previous (GetDescription)
Next (GetFields)


Sepi

Sepi
Previous (GetFieldCount)
Next (HasTypeInfo)

Name
GetFields

Parent
TSepiRecordType

Visibility
PRIVATE

Description
Tableau zero-based des champs

Source code
function GetFields ( Index : Integer ) : TSepiField

Parameters
Parameter | Description
INDEX : INTEGER | Index de champ compris entre 0 inclus et FieldCount exclu

Return
Types | Description
TSepiField | Champ à l'index spécifié

Sepi
Class Tree
Index
Previous (GetFieldCount)
Next (HasTypeInfo)


Sepi

Sepi
Previous (GetFields)
Next (IsStrongComposite)

Name
HasTypeInfo

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function HasTypeInfo : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetFields)
Next (IsStrongComposite)


Sepi

Sepi
Previous (HasTypeInfo)
Next (Load)

Name
IsStrongComposite

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function IsStrongComposite : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (HasTypeInfo)
Next (Load)


Sepi

Sepi
Previous (IsStrongComposite)
Next (PrivAddField)

Name
Load

Parent
TSepiRecordType

Visibility
PUBLIC

Description
Charge un type record depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsStrongComposite)
Next (PrivAddField)


Sepi

Sepi
Previous (Load)
Next (Save)

Name
PrivAddField

Parent
TSepiRecordType

Visibility
PRIVATE

Description
Ajoute un champ au record

Source code
function PrivAddField ( const FieldName : string ; FieldType : TSepiType ; After : TSepiField ; ForcePack : Boolean = False ) : TSepiField

Parameters
Parameter | Description
FieldName : STRING | Nom du champ
FieldType : TSepiType | Type du champ
After : TSepiField | Champ précédent en mémoire
ForcePack : BOOLEAN | Force un pack sur ce champ si True

Return
Types | Description
TSepiField | Champ nouvellement ajouté

Sepi
Class Tree
Index
Previous (Load)
Next (Save)


Sepi

Sepi
Previous (PrivAddField)
Next (SetupProperties)

Name
Save

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrivAddField)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiRecordType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiRecordType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiRecordType)
Next (TSepiTextFileType)

Name
TSepiSignature

Parent
SepiMembers

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Signature de routine, méthode ou propriété

Members
Fields
Field | Description
FActualParams (-) | Paramètres réels
FAutoCreateHidden (-) | True pour créer automatiquement les cachés
FCallingConvention (-) | Convention d'appel
FCompleted (-) | True si la signature est complétée
FContext (-) | Contexte
FKind (-) | Type de signature
FLoadingCloning (-) | True si en chargement ou en clônage
FOwner (-) | Propriétaire de la signature
FOwningUnit (-) | Unité contenante
FParams (-) | Paramètres déclarés (visibles)
FRegUsage (-) | Nombre de registres utilisés (entre 0 et 3)
FReturnType (-) | Type de retour
FRoot (-) | Racine
FSepiStackUsage (-) | Taille utilisée sur la pile Sepi (en octets)
FStackUsage (-) | Taille utilisée sur la pile (en octets)

Methods
Method | Description
AddParam (-) | Recense l'ajout d'un paramètre
BaseCreate (-) | Constructeur de base
CheckInherited (-) | Vérifie que la signature peut hériter d'une autre
CheckNotCompleted (-) | Vérifie que la signature n'est pas encore complétée
Clone (+) | Clône une signature
CompatibleWith (+) | Détermine si une liste de types est compatible avec la signature
Complete (+) | Complète la signature
Create (+) | Crée une signature de méthode
CreateConstructing (+) | Crée une signature en construction
Destroy (+) | [@inheritDoc]
Equals (+) | Détermine si deux signatures sont identiques
GetActualParamCount (-) | Nombre de paramètres réels (incluant les paramètres cachés)
GetActualParams (-) | Tableau zero-based des paramètres réels (incluant les paramètres cachés)
GetDescription (-) | [@inheritDoc]
GetHiddenParam (-) | Paramètres cachés d'après leur type
GetParam (+) | Cherche un paramètre par son nom
GetParamByName (-) | Tableau des paramètres indexés par leurs noms
GetParamCount (-) | Nombre de paramètres déclarés (visibles)
GetParams (-) | Tableau zero-based des paramètres déclarés (visibles)
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une signature depuis un flux
MakeCallInfo (-) | Construit les informations d'appel de la signature
Save (#) | [@inheritDoc]
SetCallingConvention (-) | Modifie la convention d'appel
SetKind (-) | Modifie le type de signature
SetReturnType (-) | Modifie le type de retour
WriteDigestData (#) | Écrit les données nécessaires au digest de compatibilité dans un flux

Properties
Property | Description
ActualParamCount (+) | Nombre de paramètres réels (incluant les paramètres cachés)
ActualParams (+) | Tableau zero-based des paramètres réels (incluant les paramètres cachés)
AllocParam (+) | Paramètres cachés d'après leur type
CallingConvention (+) | Convention d'appel
Completed (+) | True si la signature est complétée
Context (+) | Contexte
Description (+) | [@inheritDoc]
FreeParam (+) | Paramètres cachés d'après leur type
HiddenParam (+) | Paramètres cachés d'après leur type
Kind (+) | Type de signature
Owner (+) | Propriétaire de la signature
OwningUnit (+) | Unité contenante
ParamByName (+) | Tableau des paramètres indexés par leurs noms
ParamCount (+) | Nombre de paramètres déclarés (visibles)
Params (+) | Tableau zero-based des paramètres déclarés (visibles)
RegUsage (+) | Nombre de registres utilisés (entre 0 et 3)
ResultParam (+) | Paramètres cachés d'après leur type
ReturnType (+) | Type de retour
Root (+) | Racine
SelfParam (+) | Paramètres cachés d'après leur type
SepiStackUsage (+) | Taille utilisée sur la pile Sepi (en octets)
StackUsage (+) | Taille utilisée sur la pile (en octets)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRecordType)
Next (TSepiTextFileType)


Sepi

Sepi
Previous
Next (FAutoCreateHidden)

Name
FActualParams

Parent
TSepiSignature

Visibility
PRIVATE

Description
Paramètres réels

Source code
FActualParams : TObjectList

Sepi
Class Tree
Index
Previous
Next (FAutoCreateHidden)


Sepi

Sepi
Previous (FActualParams)
Next (FCallingConvention)

Name
FAutoCreateHidden

Parent
TSepiSignature

Visibility
PRIVATE

Description
True pour créer automatiquement les cachés

Source code
FAutoCreateHidden : Boolean

Sepi
Class Tree
Index
Previous (FActualParams)
Next (FCallingConvention)


Sepi

Sepi
Previous (FAutoCreateHidden)
Next (FCompleted)

Name
FCallingConvention

Parent
TSepiSignature

Visibility
PRIVATE

Description
Convention d'appel

Source code
FCallingConvention : TCallingConvention

Sepi
Class Tree
Index
Previous (FAutoCreateHidden)
Next (FCompleted)


Sepi

Sepi
Previous (FCallingConvention)
Next (FContext)

Name
FCompleted

Parent
TSepiSignature

Visibility
PRIVATE

Description
True si la signature est complétée

Source code
FCompleted : Boolean

Sepi
Class Tree
Index
Previous (FCallingConvention)
Next (FContext)


Sepi

Sepi
Previous (FCompleted)
Next (FKind)

Name
FContext

Parent
TSepiSignature

Visibility
PRIVATE

Description
Contexte

Source code
FContext : TSepiComponent

Sepi
Class Tree
Index
Previous (FCompleted)
Next (FKind)


Sepi

Sepi
Previous (FContext)
Next (FLoadingCloning)

Name
FKind

Parent
TSepiSignature

Visibility
PRIVATE

Description
Type de signature

Source code
FKind : TSepiSignatureKind

Sepi
Class Tree
Index
Previous (FContext)
Next (FLoadingCloning)


Sepi

Sepi
Previous (FKind)
Next (FOwner)

Name
FLoadingCloning

Parent
TSepiSignature

Visibility
PRIVATE

Description
True si en chargement ou en clônage

Source code
FLoadingCloning : Boolean

Sepi
Class Tree
Index
Previous (FKind)
Next (FOwner)


Sepi

Sepi
Previous (FLoadingCloning)
Next (FOwningUnit)

Name
FOwner

Parent
TSepiSignature

Visibility
PRIVATE

Description
Propriétaire de la signature

Source code
FOwner : TSepiComponent

Sepi
Class Tree
Index
Previous (FLoadingCloning)
Next (FOwningUnit)


Sepi

Sepi
Previous (FOwner)
Next (FParams)

Name
FOwningUnit

Parent
TSepiSignature

Visibility
PRIVATE

Description
Unité contenante

Source code
FOwningUnit : TSepiUnit

Sepi
Class Tree
Index
Previous (FOwner)
Next (FParams)


Sepi

Sepi
Previous (FOwningUnit)
Next (FRegUsage)

Name
FParams

Parent
TSepiSignature

Visibility
PRIVATE

Description
Paramètres déclarés (visibles)

Source code
FParams : TObjectList

Sepi
Class Tree
Index
Previous (FOwningUnit)
Next (FRegUsage)


Sepi

Sepi
Previous (FParams)
Next (FReturnType)

Name
FRegUsage

Parent
TSepiSignature

Visibility
PRIVATE

Description
Nombre de registres utilisés (entre 0 et 3)

Source code
FRegUsage : Byte

Sepi
Class Tree
Index
Previous (FParams)
Next (FReturnType)


Sepi

Sepi
Previous (FRegUsage)
Next (FRoot)

Name
FReturnType

Parent
TSepiSignature

Visibility
PRIVATE

Description
Type de retour

Source code
FReturnType : TSepiType

Sepi
Class Tree
Index
Previous (FRegUsage)
Next (FRoot)


Sepi

Sepi
Previous (FReturnType)
Next (FSepiStackUsage)

Name
FRoot

Parent
TSepiSignature

Visibility
PRIVATE

Description
Racine

Source code
FRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FReturnType)
Next (FSepiStackUsage)


Sepi

Sepi
Previous (FRoot)
Next (FStackUsage)

Name
FSepiStackUsage

Parent
TSepiSignature

Visibility
PRIVATE

Description
Taille utilisée sur la pile Sepi (en octets)

Source code
FSepiStackUsage : Word

Sepi
Class Tree
Index
Previous (FRoot)
Next (FStackUsage)


Sepi

Sepi
Previous (FSepiStackUsage)
Next

Name
FStackUsage

Parent
TSepiSignature

Visibility
PRIVATE

Description
Taille utilisée sur la pile (en octets)

Source code
FStackUsage : Word

Sepi
Class Tree
Index
Previous (FSepiStackUsage)
Next


Sepi

Sepi
Previous
Next (ActualParams)

Name
ActualParamCount

Parent
TSepiSignature

Visibility
PUBLIC

Description
Nombre de paramètres réels (incluant les paramètres cachés)

Source code
property ActualParamCount : Integer read GetActualParamCount

Read Access
GetActualParamCount

Sepi
Class Tree
Index
Previous
Next (ActualParams)


Sepi

Sepi
Previous (ActualParamCount)
Next (AllocParam)

Name
ActualParams

Parent
TSepiSignature

Visibility
PUBLIC

Description
Tableau zero-based des paramètres réels (incluant les paramètres cachés)

Source code
property ActualParams [ Index : Integer ] : TSepiParam read GetActualParams

Read Access
GetActualParams

Sepi
Class Tree
Index
Previous (ActualParamCount)
Next (AllocParam)


Sepi

Sepi
Previous (ActualParams)
Next (CallingConvention)

Name
AllocParam

Parent
TSepiSignature

Visibility
PUBLIC

Description
Paramètres cachés d'après leur type

Source code
property AllocParam : TSepiParam index hpAlloc read GetHiddenParam

Read Access
GetHiddenParam

Sepi
Class Tree
Index
Previous (ActualParams)
Next (CallingConvention)


Sepi

Sepi
Previous (AllocParam)
Next (Completed)

Name
CallingConvention

Parent
TSepiSignature

Visibility
PUBLIC

Description
Convention d'appel

Source code
property CallingConvention : TCallingConvention read FCallingConvention write SetCallingConvention

Read Access
FCallingConvention

Write Access
SetCallingConvention

Sepi
Class Tree
Index
Previous (AllocParam)
Next (Completed)


Sepi

Sepi
Previous (CallingConvention)
Next (Context)

Name
Completed

Parent
TSepiSignature

Visibility
PUBLIC

Description
True si la signature est complétée

Source code
property Completed : Boolean read FCompleted

Read Access
FCompleted

Sepi
Class Tree
Index
Previous (CallingConvention)
Next (Context)


Sepi

Sepi
Previous (Completed)
Next (Description)

Name
Context

Parent
TSepiSignature

Visibility
PUBLIC

Description
Contexte

Source code
property Context : TSepiComponent read FContext

Read Access
FContext

Sepi
Class Tree
Index
Previous (Completed)
Next (Description)


Sepi

Sepi
Previous (Context)
Next (FreeParam)

Name
Description

Parent
TSepiSignature

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
property Description : string read GetDescription

Read Access
GetDescription

Sepi
Class Tree
Index
Previous (Context)
Next (FreeParam)


Sepi

Sepi
Previous (Description)
Next (HiddenParam)

Name
FreeParam

Parent
TSepiSignature

Visibility
PUBLIC

Description
Paramètres cachés d'après leur type

Source code
property FreeParam : TSepiParam index hpFree read GetHiddenParam

Read Access
GetHiddenParam

Sepi
Class Tree
Index
Previous (Description)
Next (HiddenParam)


Sepi

Sepi
Previous (FreeParam)
Next (Kind)

Name
HiddenParam

Parent
TSepiSignature

Visibility
PUBLIC

Description
Paramètres cachés d'après leur type

Source code
property HiddenParam [ Kind : TSepiHiddenParamKind ] : TSepiParam read GetHiddenParam

Read Access
GetHiddenParam

Sepi
Class Tree
Index
Previous (FreeParam)
Next (Kind)


Sepi

Sepi
Previous (HiddenParam)
Next (Owner)

Name
Kind

Parent
TSepiSignature

Visibility
PUBLIC

Description
Type de signature

Source code
property Kind : TSepiSignatureKind read FKind write SetKind

Read Access
FKind

Write Access
SetKind

Sepi
Class Tree
Index
Previous (HiddenParam)
Next (Owner)


Sepi

Sepi
Previous (Kind)
Next (OwningUnit)

Name
Owner

Parent
TSepiSignature

Visibility
PUBLIC

Description
Propriétaire de la signature

Source code
property Owner : TSepiComponent read FOwner

Read Access
FOwner

Sepi
Class Tree
Index
Previous (Kind)
Next (OwningUnit)


Sepi

Sepi
Previous (Owner)
Next (ParamByName)

Name
OwningUnit

Parent
TSepiSignature

Visibility
PUBLIC

Description
Unité contenante

Source code
property OwningUnit : TSepiUnit read FOwningUnit

Read Access
FOwningUnit

Sepi
Class Tree
Index
Previous (Owner)
Next (ParamByName)


Sepi

Sepi
Previous (OwningUnit)
Next (ParamCount)

Name
ParamByName

Parent
TSepiSignature

Visibility
PUBLIC

Description
Tableau des paramètres indexés par leurs noms

Source code
property ParamByName [ const ParamName : string ] : TSepiParam read GetParamByName ; default

Read Access
GetParamByName

Sepi
Class Tree
Index
Previous (OwningUnit)
Next (ParamCount)


Sepi

Sepi
Previous (ParamByName)
Next (Params)

Name
ParamCount

Parent
TSepiSignature

Visibility
PUBLIC

Description
Nombre de paramètres déclarés (visibles)

Source code
property ParamCount : Integer read GetParamCount

Read Access
GetParamCount

Sepi
Class Tree
Index
Previous (ParamByName)
Next (Params)


Sepi

Sepi
Previous (ParamCount)
Next (RegUsage)

Name
Params

Parent
TSepiSignature

Visibility
PUBLIC

Description
Tableau zero-based des paramètres déclarés (visibles)

Source code
property Params [ Index : Integer ] : TSepiParam read GetParams

Read Access
GetParams

Sepi
Class Tree
Index
Previous (ParamCount)
Next (RegUsage)


Sepi

Sepi
Previous (Params)
Next (ResultParam)

Name
RegUsage

Parent
TSepiSignature

Visibility
PUBLIC

Description
Nombre de registres utilisés (entre 0 et 3)

Source code
property RegUsage : Byte read FRegUsage

Read Access
FRegUsage

Sepi
Class Tree
Index
Previous (Params)
Next (ResultParam)


Sepi

Sepi
Previous (RegUsage)
Next (ReturnType)

Name
ResultParam

Parent
TSepiSignature

Visibility
PUBLIC

Description
Paramètres cachés d'après leur type

Source code
property ResultParam : TSepiParam index hpResult read GetHiddenParam

Read Access
GetHiddenParam

Sepi
Class Tree
Index
Previous (RegUsage)
Next (ReturnType)


Sepi

Sepi
Previous (ResultParam)
Next (Root)

Name
ReturnType

Parent
TSepiSignature

Visibility
PUBLIC

Description
Type de retour

Source code
property ReturnType : TSepiType read FReturnType write SetReturnType

Read Access
FReturnType

Write Access
SetReturnType

Sepi
Class Tree
Index
Previous (ResultParam)
Next (Root)


Sepi

Sepi
Previous (ReturnType)
Next (SelfParam)

Name
Root

Parent
TSepiSignature

Visibility
PUBLIC

Description
Racine

Source code
property Root : TSepiRoot read FRoot

Read Access
FRoot

Sepi
Class Tree
Index
Previous (ReturnType)
Next (SelfParam)


Sepi

Sepi
Previous (Root)
Next (SepiStackUsage)

Name
SelfParam

Parent
TSepiSignature

Visibility
PUBLIC

Description
Paramètres cachés d'après leur type

Source code
property SelfParam : TSepiParam index hpSelf read GetHiddenParam

Read Access
GetHiddenParam

Sepi
Class Tree
Index
Previous (Root)
Next (SepiStackUsage)


Sepi

Sepi
Previous (SelfParam)
Next (StackUsage)

Name
SepiStackUsage

Parent
TSepiSignature

Visibility
PUBLIC

Description
Taille utilisée sur la pile Sepi (en octets)

Source code
property SepiStackUsage : Word read FSepiStackUsage

Read Access
FSepiStackUsage

Sepi
Class Tree
Index
Previous (SelfParam)
Next (StackUsage)


Sepi

Sepi
Previous (SepiStackUsage)
Next

Name
StackUsage

Parent
TSepiSignature

Visibility
PUBLIC

Description
Taille utilisée sur la pile (en octets)

Source code
property StackUsage : Word read FStackUsage

Read Access
FStackUsage

Sepi
Class Tree
Index
Previous (SepiStackUsage)
Next


Sepi

Sepi
Previous
Next (BaseCreate)

Name
AddParam

Parent
TSepiSignature

Visibility
PRIVATE

Description
Recense l'ajout d'un paramètre

Source code
procedure AddParam ( Param : TSepiParam )

Parameters
Parameter | Description
Param : TSepiParam | Paramètre ajouté

Sepi
Class Tree
Index
Previous
Next (BaseCreate)


Sepi

Sepi
Previous (AddParam)
Next (CheckInherited)

Name
BaseCreate

Parent
TSepiSignature

Visibility
PRIVATE

Description
Constructeur de base

Source code
constructor BaseCreate ( AOwner : TSepiComponent )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la signature

Sepi
Class Tree
Index
Previous (AddParam)
Next (CheckInherited)


Sepi

Sepi
Previous (BaseCreate)
Next (CheckNotCompleted)

Name
CheckInherited

Parent
TSepiSignature

Visibility
PRIVATE

Description
Vérifie que la signature peut hériter d'une autre
CheckInherited met à jour la convention d'appel si besoin est, contrairement
à Equals.

Source code
function CheckInherited ( ASignature : TSepiSignature ) : Boolean

Parameters
Parameter | Description
ASignature : TSepiSignature | Signature à comparer

Return
Types | Description
BOOLEAN | True si les signatures sont identiques, False sinon

Sepi
Class Tree
Index
Previous (BaseCreate)
Next (CheckNotCompleted)


Sepi

Sepi
Previous (CheckInherited)
Next (Clone)

Name
CheckNotCompleted

Parent
TSepiSignature

Visibility
PRIVATE

Description
Vérifie que la signature n'est pas encore complétée

Source code
procedure CheckNotCompleted

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CheckInherited)
Next (Clone)


Sepi

Sepi
Previous (CheckNotCompleted)
Next (CompatibleWith)

Name
Clone

Parent
TSepiSignature

Visibility
PUBLIC

Description
Clône une signature

Source code
constructor Clone ( AOwner : TSepiComponent ; Source : TSepiSignature )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire
Source : TSepiSignature | Signature à clôner

Sepi
Class Tree
Index
Previous (CheckNotCompleted)
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Complete)

Name
CompatibleWith

Parent
TSepiSignature

Visibility
PUBLIC

Description
Détermine si une liste de types est compatible avec la signature

Source code
function CompatibleWith ( const ATypes : array of TSepiType ) : Boolean

Parameters
Parameter | Description
ATypes : TSepiType | Liste des types à tester

Return
Types | Description
BOOLEAN | True si la liste de types est compatible, False sinon

Sepi
Class Tree
Index
Previous (Clone)
Next (Complete)


Sepi

Sepi
Previous (CompatibleWith)
Next (Create)

Name
Complete

Parent
TSepiSignature

Visibility
PUBLIC

Description
Complète la signature

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (CreateConstructing)

Name
Create

Parent
TSepiSignature

Visibility
PUBLIC

Description
Crée une signature de méthode

Source code
constructor Create ( AOwner : TSepiComponent ; const ASignature : string ; ACallingConvention : TCallingConvention = ccRegister )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la signature
ASignature : STRING | Signature Delphi
ACallingConvention : TCallingConvention | Convention d'appel

Sepi
Class Tree
Index
Previous (Complete)
Next (CreateConstructing)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CreateConstructing

Parent
TSepiSignature

Visibility
PUBLIC

Description
Crée une signature en construction

Source code
constructor CreateConstructing ( AContext : TSepiComponent )

Parameters
Parameter | Description
AContext : TSepiComponent | Contexte

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CreateConstructing)
Next (Equals)

Name
Destroy

Parent
TSepiSignature

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateConstructing)
Next (Equals)


Sepi

Sepi
Previous (Destroy)
Next (GetActualParamCount)

Name
Equals

Parent
TSepiSignature

Visibility
PUBLIC

Description
Détermine si deux signatures sont identiques

Source code
function Equals ( ASignature : TSepiSignature ; Options : TSepiSignatureCompareOptions = scoAll ) : Boolean ; reintroduce

Parameters
Parameter | Description
ASignature : TSepiSignature | Signature à comparer
Options : TSepiSignatureCompareOptions | Options de comparaison

Return
Types | Description
BOOLEAN | True si les signatures sont identiques, False sinon

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetActualParamCount)


Sepi

Sepi
Previous (Equals)
Next (GetActualParams)

Name
GetActualParamCount

Parent
TSepiSignature

Visibility
PRIVATE

Description
Nombre de paramètres réels (incluant les paramètres cachés)

Source code
function GetActualParamCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de paramètres réels

Sepi
Class Tree
Index
Previous (Equals)
Next (GetActualParams)


Sepi

Sepi
Previous (GetActualParamCount)
Next (GetDescription)

Name
GetActualParams

Parent
TSepiSignature

Visibility
PRIVATE

Description
Tableau zero-based des paramètres réels (incluant les paramètres cachés)

Source code
function GetActualParams ( Index : Integer ) : TSepiParam

Parameters
Parameter | Description
INDEX : INTEGER | Index du paramètre à récupérer

Return
Types | Description
TSepiParam | Paramètre situé à l'index Index

Sepi
Class Tree
Index
Previous (GetActualParamCount)
Next (GetDescription)


Sepi

Sepi
Previous (GetActualParams)
Next (GetHiddenParam)

Name
GetDescription

Parent
TSepiSignature

Visibility
PRIVATE

Description
[@inheritDoc]

Source code
function GetDescription : string

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetActualParams)
Next (GetHiddenParam)


Sepi

Sepi
Previous (GetDescription)
Next (GetParam)

Name
GetHiddenParam

Parent
TSepiSignature

Visibility
PRIVATE

Description
Paramètres cachés d'après leur type

Source code
function GetHiddenParam ( Kind : TSepiHiddenParamKind ) : TSepiParam

Parameters
Parameter | Description
Kind : TSepiHiddenParamKind | Type de paramètre caché

Return
Types | Description
TSepiParam | Le paramètre caché correspondant, ou nil s'il n'y en a pas

Sepi
Class Tree
Index
Previous (GetDescription)
Next (GetParam)


Sepi

Sepi
Previous (GetHiddenParam)
Next (GetParamByName)

Name
GetParam

Parent
TSepiSignature

Visibility
PUBLIC

Description
Cherche un paramètre par son nom

Source code
function GetParam ( const ParamName : string ) : TSepiParam

Parameters
Parameter | Description
ParamName : STRING | Nom du paramètre

Return
Types | Description
TSepiParam | Paramètre correspondant, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (GetHiddenParam)
Next (GetParamByName)


Sepi

Sepi
Previous (GetParam)
Next (GetParamCount)

Name
GetParamByName

Parent
TSepiSignature

Visibility
PRIVATE

Description
Tableau des paramètres indexés par leurs noms

Exception
ESepiComponentNotFoundError Le paramètre n'a pas été trouvé

Source code
function GetParamByName ( const ParamName : string ) : TSepiParam

Parameters
Parameter | Description
ParamName : STRING | Nom du paramètre recherché

Return
Types | Description
TSepiParam | Paramètre dont le nom est ParamName

Sepi
Class Tree
Index
Previous (GetParam)
Next (GetParamCount)


Sepi

Sepi
Previous (GetParamByName)
Next (GetParams)

Name
GetParamCount

Parent
TSepiSignature

Visibility
PRIVATE

Description
Nombre de paramètres déclarés (visibles)

Source code
function GetParamCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de paramètres

Sepi
Class Tree
Index
Previous (GetParamByName)
Next (GetParams)


Sepi

Sepi
Previous (GetParamCount)
Next (ListReferences)

Name
GetParams

Parent
TSepiSignature

Visibility
PRIVATE

Description
Tableau zero-based des paramètres déclarés (visibles)

Source code
function GetParams ( Index : Integer ) : TSepiParam

Parameters
Parameter | Description
INDEX : INTEGER | Index du paramètre à récupérer

Return
Types | Description
TSepiParam | Paramètre situé à l'index Index

Sepi
Class Tree
Index
Previous (GetParamCount)
Next (ListReferences)


Sepi

Sepi
Previous (GetParams)
Next (Load)

Name
ListReferences

Parent
TSepiSignature

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetParams)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (MakeCallInfo)

Name
Load

Parent
TSepiSignature

Visibility
PUBLIC

Description
Charge une signature depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la signature
Stream : TStream | Flux depuis lequel charger la signature

Sepi
Class Tree
Index
Previous (ListReferences)
Next (MakeCallInfo)


Sepi

Sepi
Previous (Load)
Next (Save)

Name
MakeCallInfo

Parent
TSepiSignature

Visibility
PRIVATE

Description
Construit les informations d'appel de la signature

Source code
procedure MakeCallInfo

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Load)
Next (Save)


Sepi

Sepi
Previous (MakeCallInfo)
Next (SetCallingConvention)

Name
Save

Parent
TSepiSignature

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeCallInfo)
Next (SetCallingConvention)


Sepi

Sepi
Previous (Save)
Next (SetKind)

Name
SetCallingConvention

Parent
TSepiSignature

Visibility
PRIVATE

Description
Modifie la convention d'appel

Source code
procedure SetCallingConvention ( Value : TCallingConvention )

Parameters
Parameter | Description
Value : TCallingConvention | Nouvelle convention d'appel

Sepi
Class Tree
Index
Previous (Save)
Next (SetKind)


Sepi

Sepi
Previous (SetCallingConvention)
Next (SetReturnType)

Name
SetKind

Parent
TSepiSignature

Visibility
PRIVATE

Description
Modifie le type de signature

Source code
procedure SetKind ( Value : TSepiSignatureKind )

Parameters
Parameter | Description
Value : TSepiSignatureKind | Nouveau type de signature

Sepi
Class Tree
Index
Previous (SetCallingConvention)
Next (SetReturnType)


Sepi

Sepi
Previous (SetKind)
Next (WriteDigestData)

Name
SetReturnType

Parent
TSepiSignature

Visibility
PRIVATE

Description
Modifie le type de retour

Source code
procedure SetReturnType ( Value : TSepiType )

Parameters
Parameter | Description
Value : TSepiType | Nouveau type de retour

Sepi
Class Tree
Index
Previous (SetKind)
Next (WriteDigestData)


Sepi

Sepi
Previous (SetReturnType)
Next

Name
WriteDigestData

Parent
TSepiSignature

Visibility
PROTECTED

Description
Écrit les données nécessaires au digest de compatibilité dans un flux

Source code
procedure WriteDigestData ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (SetReturnType)
Next


Sepi

Sepi
Previous (TSepiSignature)
Next (TSepiVariantType)

Name
TSepiTextFileType

Parent
SepiMembers

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type fichier texte (Text)

Members
Methods
Method | Description
Clone (+) | [@inheritDoc]
Create (+) | Crée un type variant
GetAlignment (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSignature)
Next (TSepiVariantType)


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiTextFileType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (GetAlignment)

Name
Create

Parent
TSepiTextFileType

Visibility
PUBLIC

Description
Crée un type variant

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire
AName : STRING | Nom du type

Sepi
Class Tree
Index
Previous (Clone)
Next (GetAlignment)


Sepi

Sepi
Previous (Create)
Next (SetupProperties)

Name
GetAlignment

Parent
TSepiTextFileType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (SetupProperties)


Sepi

Sepi
Previous (GetAlignment)
Next

Name
SetupProperties

Parent
TSepiTextFileType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetAlignment)
Next


Sepi

Sepi
Previous (TSepiTextFileType)
Next

Name
TSepiVariantType

Parent
SepiMembers

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type variant

Members
Methods
Method | Description
Clone (+) | [@inheritDoc]
Create (+) | Crée un type variant
GetAlignment (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTextFileType)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiVariantType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (GetAlignment)

Name
Create

Parent
TSepiVariantType

Visibility
PUBLIC

Description
Crée un type variant

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire
AName : STRING | Nom du type

Sepi
Class Tree
Index
Previous (Clone)
Next (GetAlignment)


Sepi

Sepi
Previous (Create)
Next (SetupProperties)

Name
GetAlignment

Parent
TSepiVariantType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (SetupProperties)


Sepi

Sepi
Previous (GetAlignment)
Next

Name
SetupProperties

Parent
TSepiVariantType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetAlignment)
Next


Sepi

Sepi
Previous
Next (TCallingConvention)

Name
PSepiInterfaceEntry

Parent
SepiMembers

Visibility
PUBLIC

Description
Pointeur vers TSepiInterfaceEntry

Source code
PSepiInterfaceEntry = ^ TSepiInterfaceEntry ;

Sepi
Class Tree
Index
Previous
Next (TCallingConvention)


Sepi

Sepi
Previous (PSepiInterfaceEntry)
Next (TMethodLinkKind)

Name
TCallingConvention

Parent
SepiMembers

Visibility
PUBLIC

Description
Convention d'appel d'une méthode

Source code
TCallingConvention = ( ccRegister , ccCDecl , ccPascal , ccStdCall , ccSafeCall ) ;

Sepi
Class Tree
Index
Previous (PSepiInterfaceEntry)
Next (TMethodLinkKind)


Sepi

Sepi
Previous (TCallingConvention)
Next (TPropertyAccessKind)

Name
TMethodLinkKind

Parent
SepiMembers

Visibility
PUBLIC

Description
Type de liaison d'une méthode
- mlkStatic : méthode statique (ni virtuelle ni dynamique)
- mlkVirtual : méthode à liaison virtuelle (via VMT)
- mlkDynamic : méthode à liaison dynamique (via DMT)
- mlkMessage : méthode d'interception de message (via DMT)
- mlkInterface : méthode à liaison d'interface (via IMT)
- mlkOverride : détermine le type de liaison depuis la méthode héritée

Source code
TMethodLinkKind = ( mlkStatic , mlkVirtual , mlkDynamic , mlkMessage , mlkInterface , mlkOverride ) ;

Sepi
Class Tree
Index
Previous (TCallingConvention)
Next (TPropertyAccessKind)


Sepi

Sepi
Previous (TMethodLinkKind)
Next (TPropertyStorageKind)

Name
TPropertyAccessKind

Parent
SepiMembers

Visibility
PUBLIC

Description
Type d'accesseur d'une propriété

Source code
TPropertyAccessKind = ( pakNone , pakField , pakMethod , pakClassField ) ;

Sepi
Class Tree
Index
Previous (TMethodLinkKind)
Next (TPropertyStorageKind)


Sepi

Sepi
Previous (TPropertyAccessKind)
Next (TSepiClassField)

Name
TPropertyStorageKind

Parent
SepiMembers

Visibility
PUBLIC

Description
Type de stockage d'une propriété

Source code
TPropertyStorageKind = ( pskConstant , pskField , pskMethod ) ;

Sepi
Class Tree
Index
Previous (TPropertyAccessKind)
Next (TSepiClassField)


Sepi

Sepi
Previous (TPropertyStorageKind)
Next (TSepiHiddenParamKind)

Name
TSepiClassField

Parent
SepiMembers

Visibility
PUBLIC

Description
Champ de classe

Source code
TSepiClassField = TSepiVariable ;

Sepi
Class Tree
Index
Previous (TPropertyStorageKind)
Next (TSepiHiddenParamKind)


Sepi

Sepi
Previous (TSepiClassField)
Next (TSepiParamKind)

Name
TSepiHiddenParamKind

Parent
SepiMembers

Visibility
PUBLIC

Description
Type de paramètre caché
- hpNormal : paramètre normal
- hpSelf : paramètre Self des méthodes
- hpResult : paramètre Result des fonctions
- hpAlloc : paramètre $Alloc des constructeurs
- hpFree : paramètre $Free des destructeurs
- hpOpenArrayHighValue : valeur maximale d'indice du tableau ouvert

Source code
TSepiHiddenParamKind = ( hpNormal , hpSelf , hpResult , hpAlloc , hpFree , hpOpenArrayHighValue ) ;

Sepi
Class Tree
Index
Previous (TSepiClassField)
Next (TSepiParamKind)


Sepi

Sepi
Previous (TSepiHiddenParamKind)
Next (TSepiParamPlace)

Name
TSepiParamKind

Parent
SepiMembers

Visibility
PUBLIC

Description
Type de paramètre
- pkValue : transmis par valeur
- pkVar : paramètre var
- pkConst : paramètre const
- pkOut : paramètre out

Source code
TSepiParamKind = ( pkValue , pkVar , pkConst , pkOut ) ;

Sepi
Class Tree
Index
Previous (TSepiHiddenParamKind)
Next (TSepiParamPlace)


Sepi

Sepi
Previous (TSepiParamKind)
Next (TSepiSignatureCompareOption)

Name
TSepiParamPlace

Parent
SepiMembers

Visibility
PUBLIC

Description
Emplacement d'un paramètre
- ppEAX : registre EAX
- ppEDX : registre EDX
- ppECX : registre ECX
- ppStack : sur la pile

Source code
TSepiParamPlace = ( ppEAX , ppEDX , ppECX , ppStack ) ;

Sepi
Class Tree
Index
Previous (TSepiParamKind)
Next (TSepiSignatureCompareOption)


Sepi

Sepi
Previous (TSepiParamPlace)
Next (TSepiSignatureCompareOptions)

Name
TSepiSignatureCompareOption

Parent
SepiMembers

Visibility
PUBLIC

Description
Option de comparaison de signatures (et paramètres)
- scoKind : Compare les types de signature
- scoCallingConvention : Compare les conventions d'appel
- scoParams : Compare les paramètres
- scoReturnType : Compare les types de retour
- pcoHiddenKind : Compare les types de paramètre caché des paramètres
- pcoKind : Compare les types de paramètre (value/const/var/out)
- pcoName : Compare les noms des paramètres
- pcoType : Compare les types des paramètres
- pcoDefaultValue : Compare les valeurs par défaut (pour usage futur)

Source code
TSepiSignatureCompareOption = ( scoKind , scoCallingConvention , scoParams , scoReturnType , pcoHiddenKind , pcoKind , pcoName , pcoType , pcoDefaultValue ) ;

Sepi
Class Tree
Index
Previous (TSepiParamPlace)
Next (TSepiSignatureCompareOptions)


Sepi

Sepi
Previous (TSepiSignatureCompareOption)
Next (TSepiSignatureKind)

Name
TSepiSignatureCompareOptions

Parent
SepiMembers

Visibility
PUBLIC

Description
Options de comparaison de signatures (et paramètres)

Source code
TSepiSignatureCompareOptions = set of TSepiSignatureCompareOption ;

Sepi
Class Tree
Index
Previous (TSepiSignatureCompareOption)
Next (TSepiSignatureKind)


Sepi

Sepi
Previous (TSepiSignatureCompareOptions)
Next

Name
TSepiSignatureKind

Parent
SepiMembers

Visibility
PUBLIC

Description
Type de signature
- skStaticProcedure : procédure statique (pas de Self) ;
- skStaticFunction : fonction statique (pas de Self) ;
- skObjectProcedure : procédure d'objet ;
- skObjectFunction : fonction d'objet ;
- skConstructor : constructeur ;
- skDestructor : destructeur ;
- skClassProcedure : procédure de classe ;
- skClassFunction : fonction de classe ;
- skClassConstructor : constructeur de classe (pour usage futur) ;
- skOperator : surcharge d'opérateur (pour usage futur) ;
- skProperty : propriété ;
- skClassProperty : propriété de classe ;
- skClassDestructor : destructeur de classe (pour usage futur).

Source code
TSepiSignatureKind = ( skStaticProcedure , skStaticFunction , skObjectProcedure , skObjectFunction , skConstructor , skDestructor , skClassProcedure , skClassFunction , skClassConstructor , skOperator , skProperty , skClassProperty , skClassDestructor ) ;

Sepi
Class Tree
Index
Previous (TSepiSignatureCompareOptions)
Next


Sepi

Sepi
Previous
Next (hfFieldSize)

Name
CallingConventionStrings

Parent
SepiMembers

Visibility
PUBLIC

Description
Chaînes des conventions d'appel

Source code
CallingConventionStrings : array [ TCallingConvention ] of string = ( 'register' , 'cdecl' , 'pascal' , 'stdcall' , 'safecall' )

Sepi
Class Tree
Index
Previous
Next (hfFieldSize)


Sepi

Sepi
Previous (CallingConventionStrings)
Next (HiddenParamNames)

Name
hfFieldSize

Parent
SepiMembers

Visibility
PUBLIC

Description
Taille des champs cachés dans un objet

Source code
hfFieldSize = System . hfFieldSize

Sepi
Class Tree
Index
Previous (CallingConventionStrings)
Next (HiddenParamNames)


Sepi

Sepi
Previous (hfFieldSize)
Next (LinkKindStrings)

Name
HiddenParamNames

Parent
SepiMembers

Visibility
PUBLIC

Description
Noms des paramètres cachés

Source code
HiddenParamNames : array [ TSepiHiddenParamKind ] of string = ( '' , 'Self' , 'Result' , '$Alloc' , '$Free' , 'High$' )

Sepi
Class Tree
Index
Previous (hfFieldSize)
Next (LinkKindStrings)


Sepi

Sepi
Previous (HiddenParamNames)
Next (NoDefaultValue)

Name
LinkKindStrings

Parent
SepiMembers

Visibility
PUBLIC

Description
Chaînes des types de liaison de méthodes

Source code
LinkKindStrings : array [ TMethodLinkKind ] of string = ( '' , 'virtual' , 'dynamic' , 'message' , '' , 'override' )

Sepi
Class Tree
Index
Previous (HiddenParamNames)
Next (NoDefaultValue)


Sepi

Sepi
Previous (LinkKindStrings)
Next (NoIndex)

Name
NoDefaultValue

Parent
SepiMembers

Visibility
PUBLIC

Description
Pas de valeur par défaut

Source code
NoDefaultValue = Integer ( $80000000 )

Sepi
Class Tree
Index
Previous (LinkKindStrings)
Next (NoIndex)


Sepi

Sepi
Previous (NoDefaultValue)
Next (OverloadedNameFormat)

Name
NoIndex

Parent
SepiMembers

Visibility
PUBLIC

Description
Pas d'index

Source code
NoIndex = Integer ( $80000000 )

Sepi
Class Tree
Index
Previous (NoDefaultValue)
Next (OverloadedNameFormat)


Sepi

Sepi
Previous (NoIndex)
Next (ParamKindStrings)

Name
OverloadedNameFormat

Parent
SepiMembers

Visibility
PUBLIC

Description
Format du nom d'une méthode surchargée

Source code
OverloadedNameFormat = 'OL$%s$%d'

Sepi
Class Tree
Index
Previous (NoIndex)
Next (ParamKindStrings)


Sepi

Sepi
Previous (OverloadedNameFormat)
Next (pcoAll)

Name
ParamKindStrings

Parent
SepiMembers

Visibility
PUBLIC

Description
Chaînes des types de paramètre

Source code
ParamKindStrings : array [ TSepiParamKind ] of string = ( '' , 'var' , 'const' , 'out' )

Sepi
Class Tree
Index
Previous (OverloadedNameFormat)
Next (pcoAll)


Sepi

Sepi
Previous (ParamKindStrings)
Next (pcoCompatibility)

Name
pcoAll

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison stricte des paramètres

Source code
pcoAll = [ pcoHiddenKind .. pcoDefaultValue ]

Sepi
Class Tree
Index
Previous (ParamKindStrings)
Next (pcoCompatibility)


Sepi

Sepi
Previous (pcoAll)
Next (pcoDeclaration)

Name
pcoCompatibility

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison des paramètres pour compatibilité d'assignation

Source code
pcoCompatibility = pcoAll - [ pcoName , pcoDefaultValue ]

Sepi
Class Tree
Index
Previous (pcoAll)
Next (pcoDeclaration)


Sepi

Sepi
Previous (pcoCompatibility)
Next (pcoInheritance)

Name
pcoDeclaration

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison des paramètres pour recherche de la déclaration

Source code
pcoDeclaration = pcoAll

Sepi
Class Tree
Index
Previous (pcoCompatibility)
Next (pcoInheritance)


Sepi

Sepi
Previous (pcoDeclaration)
Next (scoAll)

Name
pcoInheritance

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison des paramètres pour recherche de la méthode héritée

Source code
pcoInheritance = pcoCompatibility

Sepi
Class Tree
Index
Previous (pcoDeclaration)
Next (scoAll)


Sepi

Sepi
Previous (pcoInheritance)
Next (scoCompatibility)

Name
scoAll

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison stricte des signatures

Source code
scoAll = [ scoKind .. pcoDefaultValue ]

Sepi
Class Tree
Index
Previous (pcoInheritance)
Next (scoCompatibility)


Sepi

Sepi
Previous (scoAll)
Next (scoDeclaration)

Name
scoCompatibility

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison des signatures pour compatibilité d'assignation

Source code
scoCompatibility = scoAll - [ pcoName , pcoDefaultValue ]

Sepi
Class Tree
Index
Previous (scoAll)
Next (scoDeclaration)


Sepi

Sepi
Previous (scoCompatibility)
Next (scoInheritance)

Name
scoDeclaration

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison des signatures pour recherche de la déclaration

Source code
scoDeclaration = scoAll - [ scoCallingConvention ]

Sepi
Class Tree
Index
Previous (scoCompatibility)
Next (scoInheritance)


Sepi

Sepi
Previous (scoDeclaration)
Next (SignatureKindStrings)

Name
scoInheritance

Parent
SepiMembers

Visibility
PUBLIC

Description
Comparaison des signatures pour recherche de la méthode héritée

Source code
scoInheritance = scoCompatibility - [ scoCallingConvention ]

Sepi
Class Tree
Index
Previous (scoDeclaration)
Next (SignatureKindStrings)


Sepi

Sepi
Previous (scoInheritance)
Next (skAll)

Name
SignatureKindStrings

Parent
SepiMembers

Visibility
PUBLIC

Description
Chaînes des types de méthode

Source code
SignatureKindStrings : array [ TSepiSignatureKind ] of string = ( 'static procedure' , 'static function' , 'object procedure' , 'object function' , 'constructor' , 'destructor' , 'class procedure' , 'class function' , 'class constructor' , 'operator' , 'property' , 'class property' , 'class destructor' )

Sepi
Class Tree
Index
Previous (scoInheritance)
Next (skAll)


Sepi

Sepi
Previous (SignatureKindStrings)
Next (skAnyProperty)

Name
skAll

Parent
SepiMembers

Visibility
PUBLIC

Description
Tous les types de signature

Source code
skAll = [ Low ( TSepiSignatureKind ) .. High ( TSepiSignatureKind ) ]

Sepi
Class Tree
Index
Previous (SignatureKindStrings)
Next (skAnyProperty)


Sepi

Sepi
Previous (skAll)
Next (skFunction)

Name
skAnyProperty

Parent
SepiMembers

Visibility
PUBLIC

Description
Propriété (d'objet ou de classe)

Source code
skAnyProperty = [ skProperty , skClassProperty ]

Sepi
Class Tree
Index
Previous (skAll)
Next (skFunction)


Sepi

Sepi
Previous (skAnyProperty)
Next (skProcedure)

Name
skFunction

Parent
SepiMembers

Visibility
PUBLIC

Description
Fonction (statique, d'objet ou de classe)

Source code
skFunction = [ skStaticFunction , skObjectFunction , skClassFunction ]

Sepi
Class Tree
Index
Previous (skAnyProperty)
Next (skProcedure)


Sepi

Sepi
Previous (skFunction)
Next (skWithReturnType)

Name
skProcedure

Parent
SepiMembers

Visibility
PUBLIC

Description
Procédure (statique, d'objet ou de classe)

Source code
skProcedure = [ skStaticProcedure , skObjectProcedure , skClassProcedure ]

Sepi
Class Tree
Index
Previous (skFunction)
Next (skWithReturnType)


Sepi

Sepi
Previous (skProcedure)
Next (skWithSelfParam)

Name
skWithReturnType

Parent
SepiMembers

Visibility
PUBLIC

Description
Types de signature avec valeur de retour

Source code
skWithReturnType = skFunction + [ skOperator ] + skAnyProperty

Sepi
Class Tree
Index
Previous (skProcedure)
Next (skWithSelfParam)


Sepi

Sepi
Previous (skWithReturnType)
Next

Name
skWithSelfParam

Parent
SepiMembers

Visibility
PUBLIC

Description
Types de signature avec un paramètre Self

Source code
skWithSelfParam = [ skObjectProcedure .. skClassConstructor ]

Sepi
Class Tree
Index
Previous (skWithReturnType)
Next


Sepi

Sepi
Previous (SepiMembers)
Next (SepiOrdTypes)

Name
SepiOpCodes

Parent
Sepi

Description
Types et constantes définissant les OpCodes de Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TSepiAddressDerefAndOp (+) | Combinaison d'un déréférencement et d'une opération sur une adresse
TSepiAddressDereference (+) | Dérérencement d'adresse
TSepiAddressOperation (+) | Type d'opération à appliquer à une adresse
TSepiAddressOption (+) | Option de lecture d'adresse
TSepiAddressOptions (+) | Options de lecture d'adresse
TSepiBaseType (+) | Types de données de base que gère l'interpréteur Sepi
TSepiBaseTypes (+) | Ensemble de types de données de base
TSepiCallSettings (+) | Configuration d'un appel basique
TSepiMemoryRef (+) | Type d'adressage
TSepiMemorySpace (+) | Espace d'adressage
TSepiOpCode (+) | Type d'un OpCode
TSepiParamSize (+) | Taille d'un paramètre à passer à une procédure

Constants
Constant | Description
AddrDerefMask (+) | Masque de déréférencement
AddrDerefShift (+) | Offset du déréférencement
AddrOperationMask (+) | Masque de l'opération sur adresse
aoAcceptAllConsts (+) | #No TAG found in source code#
aoAcceptNonCodeConsts (+) | Accepte tous les types de constantes hors code
BaseTypeConstSizes (+) | Taille des constantes en fonction des types de base
btChars (+) | #No TAG found in source code#
btCharsAndStrings (+) | #No TAG found in source code#
btFloats (+) | #No TAG found in source code#
btIntegers (+) | #No TAG found in source code#
btNumbers (+) | #No TAG found in source code#
btStrings (+) | #No TAG found in source code#
MemOpCountMask (+) | Masque du nombre d'opérations
MemOpCountShift (+) | Offset du nombre d'opérations
MemPlaceMask (+) | Masque d'espace mémoire
msNil (+) | Constante nil
msNoResult (+) | Ne pas garder le résultat
msResult (+) | Variable résultat
msSelf (+) | Paramètre Self
ocAddressCall (+) | CALL CallSettings (ORS)? Address Params
ocAnsiStrCopy (+) | ASCP Dest, Src, Index, Count
ocAnsiStrLength (+) | ASL Dest, Value
ocAnsiStrSetLength (+) | ASSL Var, Len
ocAsClass (+) | AS Object, Class
ocCompEquals (+) | EQ Type, Dest, Left, Right
ocCompGreater (+) | GT Type, Dest, Left, Right
ocCompGreaterEq (+) | GE Type, Dest, Left, Right
ocCompLower (+) | LT Type, Dest, Left, Right
ocCompLowerEq (+) | LE Type, Dest, Left, Right
ocCompNotEquals (+) | NEQ Type, Dest, Left, Right
ocConvert (+) | CVRT Type, Type, [CP,] Mem, Mem
ocDynamicCall (+) | CALL Method-Ref Self Params
ocDynArrayCopy (+) | DACP Type-Ref, Dest, Src
ocDynArrayCopyRange (+) | DACP Type-Ref, Dest, Src,Idx,Cnt
ocDynArrayHigh (+) | DAH Dest, Value
ocDynArrayLength (+) | DAL Dest, Value
ocDynArraySetLength (+) | DASL Type-Ref, Var,DimCount,Dims
ocExtended (+) | Instruction étendue (non utilisé)
ocGetDelphiClass (+) | GDC Dest, Class-Ref
ocGetMethodCode (+) | GMC Dest, Method-Ref
ocGetTypeInfo (+) | GTI Dest, Type-Ref
ocIsClass (+) | IS Dest, Object, Class
ocJump (+) | JUMP Dest
ocJumpIfFalse (+) | JIF Dest, Test
ocJumpIfTrue (+) | JIT Dest, Test
ocLoadAddress (+) | LEA Dest, Src
ocMoveAnsiStr (+) | MOVAS Dest, Src
ocMoveByte (+) | MOVB Dest, Src
ocMoveDWord (+) | MOVD Dest, Src
ocMoveExt (+) | MOVE Dest, Src
ocMoveIntf (+) | MOVI Dest, Src
ocMoveMany (+) | MOVM Word-Count, Dest, Src
ocMoveOther (+) | MOVO Type-Ref, Dest, Src
ocMoveQWord (+) | MOVQ Dest, Src
ocMoveSome (+) | MOVS Byte-Count, Dest, Src
ocMoveUnicodeStr (+) | MOVUS Dest, Src
ocMoveVariant (+) | MOVV Dest, Src
ocMoveWideStr (+) | MOVWS Dest, Src
ocMoveWord (+) | MOVW Dest, Src
ocMultiOn (+) | ON ExceptObject, Byte-Count, (Class-Ref, Dest){Count}
ocNope (+) | NOP
ocOtherAdd (+) | ADD Type, Dest, Left, Right
ocOtherAnd (+) | AND Type, Dest, Left, Right
ocOtherDec (+) | DEC Type, Dest, Value
ocOtherDivide (+) | DIV Type, Dest, Left, Right
ocOtherInc (+) | INC Type, Dest, Value
ocOtherIntDiv (+) | IDV Type, Dest, Left, Right
ocOtherModulus (+) | MOD Type, Dest, Left, Right
ocOtherMultiply (+) | MUL Type, Dest, Left, Right
ocOtherNeg (+) | NEG Type, Dest, Value
ocOtherNot (+) | NOT Type, Dest, Value
ocOtherOr (+) | OR Type, Dest, Left, Right
ocOtherShl (+) | SHL Type, Dest, Left, Right
ocOtherShr (+) | SHR Type, Dest, Left, Right
ocOtherSubtract (+) | SUB Type, Dest, Left, Right
ocOtherXor (+) | XOR Type, Dest, Left, Right
ocRaise (+) | RAISE ExceptObject
ocReraise (+) | RERS
ocSelfAdd (+) | ADD Type, Var, Value
ocSelfAnd (+) | AND Type, Var, Value
ocSelfDec (+) | DEC Type, Var
ocSelfDivide (+) | DIV Type, Var, Value
ocSelfInc (+) | INC Type, Var
ocSelfIntDiv (+) | IDV Type, Var, Value
ocSelfModulus (+) | MOD Type, Var, Value
ocSelfMultiply (+) | MUL Type, Var, Value
ocSelfNeg (+) | NEG Type, Var
ocSelfNot (+) | NOT Type, Var
ocSelfOr (+) | OR Type, Var, Value
ocSelfShl (+) | SHL Type, Var, Value
ocSelfShr (+) | SHR Type, Var, Value
ocSelfSubtract (+) | SUB Type, Var, Value
ocSelfXor (+) | XOR Type, Var, Value
ocSetContained (+) | SLE SetSize, Dest, Set1, Set2
ocSetElem (+) | SELE SetSize, Dest, Elem
ocSetEquals (+) | SEQ SetSize, Dest, Set1, Set2
ocSetExclude (+) | SEXC Dest, Elem
ocSetExpand (+) | SEXP Dest, Src, Lo, Hi
ocSetIn (+) | SIN Dest, Set, Elem
ocSetInclude (+) | SINC Dest, Elem
ocSetNotEquals (+) | SNE SetSize, Dest, Set1, Set2
ocSetOtherIntersect (+) | SINT SetSize, Dest, Left, Right
ocSetOtherSubtract (+) | SSUB SetSize, Dest, Left, Right
ocSetOtherUnion (+) | SADD SetSize, Dest, Left, Right
ocSetRange (+) | SRNG SetSize, Dest, Lo, Hi
ocSetSelfIntersect (+) | SINT SetSize, Dest, Src
ocSetSelfSubtract (+) | SSUB SetSize, Dest, Src
ocSetSelfUnion (+) | SADD SetSize, Dest, Src
ocSetUnionRange (+) | SUR SetSize, Dest, Lo, Hi
ocStaticCall (+) | CALL Method-Ref Params
ocTryExcept (+) | TRYE TrySize, ExceptSize, [ExceptObject]
ocTryFinally (+) | TRYF TrySize, FinallySize
ocUnicodeStrCopy (+) | USCP Dest, Src, Index, Count
ocUnicodeStrLength (+) | USL Dest, Value
ocUnicodeStrSetLength (+) | USSL Var, Len
ocWideStrCopy (+) | WSCP Dest, Src, Index, Count
ocWideStrLength (+) | WSL Dest, Value
ocWideStrSetLength (+) | WSSL Var, Len
psByAddress (+) | Le paramètre est passé par adresse
SettingsCallingConvMask (+) | Masque de la convention d'appel
SettingsRegUsageMask (+) | Masque de l'usage des registres
SettingsRegUsageShift (+) | Offset de l'usage des registres
SettingsResultBehaviorMask (+) | Masque du comportement du résultat
SettingsResultBehaviorShift (+) | Offset du comportement du résultat
SInvalidOpCode (+) | #No TAG found in source code#

Methods
Method | Description
AddressDerefAndOpDecode (+) | Décode un déréférencement + opération sur adresse
AddressDerefAndOpEncode (+) | Encode un déréférencement + opération sur adresse
CallSettingsDecode (+) | Décode une configuration d'appel
CallSettingsEncode (+) | Encode une configuration d'appel
MemoryRefDecode (+) | Décode une référence mémoire
MemoryRefEncode (+) | Encode une référence mémoire
RaiseInvalidOpCode (+) | Déclenche une exception OpCode invalide

Classes
Class | Description
ESepiInvalidOpCode (+) | Déclenchée si l'interpréteur rencontre un OpCode invalide

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiMembers)
Next (SepiOrdTypes)


Sepi

Sepi
Previous
Next

Name
ESepiInvalidOpCode

Parent
SepiOpCodes

Class Hierarchy
Exception

Visibility
PUBLIC

Description
Déclenchée si l'interpréteur rencontre un OpCode invalide

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (TSepiAddressDereference)

Name
TSepiAddressDerefAndOp

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Combinaison d'un déréférencement et d'une opération sur une adresse
Utilisez les routines AddressDerefAndOpEncode et AddressDerefAndOpDecode
pour travailler sur des valeurs de type TSepiAddressDerefAndOp.
S'il est présent, le déréférencement est toujours appliqué avant
l'opération. Cela correspond à l'accès indicé d'un tableau (ou chaîne de
caractères).

Source code
TSepiAddressDerefAndOp = type Byte ;

Sepi
Class Tree
Index
Previous
Next (TSepiAddressDereference)


Sepi

Sepi
Previous (TSepiAddressDerefAndOp)
Next (TSepiAddressOperation)

Name
TSepiAddressDereference

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Dérérencement d'adresse
Les doubles déréférencements sont utilisés essentiellement lorsqu'on accède
à un champ de la VMT d'un objet. Mais ils peuvent avoir d'autres
utilisations.
- adNone : pas de déréférencement
- adSimple : déréférencement simple (Ptr^)
- adDouble : déréférencement double (Ptr^^)

Source code
TSepiAddressDereference = ( adNone , adSimple , adDouble ) ;

Sepi
Class Tree
Index
Previous (TSepiAddressDerefAndOp)
Next (TSepiAddressOperation)


Sepi

Sepi
Previous (TSepiAddressDereference)
Next (TSepiAddressOption)

Name
TSepiAddressOperation

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Type d'opération à appliquer à une adresse
Les "+ const" sont utiles pour les offsets de champs, comme dans les record
ou les objets, ou encore dans les VMT.
Les "+ mem" sont utiles pour les index de tableaux de bytes, ou pour les
index de caractère dans les chaînes.
Les "+ const*mem" sont utiles pour les index de tableaux dont les éléments
font plus d'un octet.
- aoNone : aucune opération
- aoPlusConstShortint : ajoute un Shortint constant
- aoPlusConstSmallint : ajoute un Smallint constant
- aoPlusConstLongint : ajoute un Longint constant
- aoPlusMemShortint : ajoute un Shortint mémoire
- aoPlusMemSmallint : ajoute un Smallint mémoire
- aoPlusMemLongint : ajoute un Longint mémoire
- aoPlusConstTimesMemShortint : ajoute un Byte constant multiplié par un
Shortint mémoire
- aoPlusConstTimesMemSmallint : ajoute un Byte constant multiplié par un
Smallint mémoire
- aoPlusConstTimesMemLongint : ajoute un Byte constant multiplié par un
Longint mémoire

Source code
TSepiAddressOperation = ( aoNone , aoPlusConstShortint , aoPlusConstSmallint , aoPlusConstLongint , aoPlusMemShortint , aoPlusMemSmallint , aoPlusMemLongint , aoPlusConstTimesMemShortint , aoPlusConstTimesMemSmallint , aoPlusConstTimesMemLongint , aoPlusConstTimesMemByte , aoPlusConstTimesMemWord , aoPlusConstTimesMemLongWord , aoPlusLongConstTimesMemShortint , aoPlusLongConstTimesMemSmallint , aoPlusLongConstTimesMemLongint , aoPlusLongConstTimesMemByte , aoPlusLongConstTimesMemWord , aoPlusLongConstTimesMemLongWord ) ;

Sepi
Class Tree
Index
Previous (TSepiAddressDereference)
Next (TSepiAddressOption)


Sepi

Sepi
Previous (TSepiAddressOperation)
Next (TSepiAddressOptions)

Name
TSepiAddressOption

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Option de lecture d'adresse
Si aoZeroAsNil est spécifié, aoAcceptZero n'a aucun effet.
Si la taille des constantes est négative ou nulle, aoAcceptConstInCode n'a
aucun effet.
- aoZeroAsNil : mappe un msZero en nil au retour
- aoAcceptZero : accepte msZero
- aoAcceptTrueConst : accepte les vraies constantes
- aoAcceptAddressedConst : accepte les constantes adressées
- aoAcceptConstInCode : accepte les constantes dans le code

Source code
TSepiAddressOption = ( aoZeroAsNil , aoAcceptZero , aoAcceptTrueConst , aoAcceptAddressedConst , aoAcceptConstInCode ) ;

Sepi
Class Tree
Index
Previous (TSepiAddressOperation)
Next (TSepiAddressOptions)


Sepi

Sepi
Previous (TSepiAddressOption)
Next (TSepiBaseType)

Name
TSepiAddressOptions

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Options de lecture d'adresse

Source code
TSepiAddressOptions = set of TSepiAddressOption ;

Sepi
Class Tree
Index
Previous (TSepiAddressOption)
Next (TSepiBaseType)


Sepi

Sepi
Previous (TSepiAddressOptions)
Next (TSepiBaseTypes)

Name
TSepiBaseType

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Types de données de base que gère l'interpréteur Sepi

Source code
TSepiBaseType = ( btBoolean , btByte , btWord , btDWord , btShortint , btSmallint , btLongint , btInt64 , btSingle , btDouble , btExtended , btComp , btCurrency , btAnsiChar , btWideChar , btAnsiStr , btWideStr , btUnicodeStr , btVariant ) ;

Sepi
Class Tree
Index
Previous (TSepiAddressOptions)
Next (TSepiBaseTypes)


Sepi

Sepi
Previous (TSepiBaseType)
Next (TSepiCallSettings)

Name
TSepiBaseTypes

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Ensemble de types de données de base

Source code
TSepiBaseTypes = set of TSepiBaseType ;

Sepi
Class Tree
Index
Previous (TSepiBaseType)
Next (TSepiCallSettings)


Sepi

Sepi
Previous (TSepiBaseTypes)
Next (TSepiMemoryRef)

Name
TSepiCallSettings

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Configuration d'un appel basique

Source code
TSepiCallSettings = type Byte ;

Sepi
Class Tree
Index
Previous (TSepiBaseTypes)
Next (TSepiMemoryRef)


Sepi

Sepi
Previous (TSepiCallSettings)
Next (TSepiMemorySpace)

Name
TSepiMemoryRef

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Type d'adressage
L'octet est décomposé en deux partie : $HL. Les 4 bits de poids faible (L)
sont une valeur de type TSepiMemorySpace. Les 4 bits de poids fort (H)
indiquent le nombre d'opérations de type Address à appliquer successivement
sur l'adresse.

Source code
TSepiMemoryRef = type Byte ;

Sepi
Class Tree
Index
Previous (TSepiCallSettings)
Next (TSepiMemorySpace)


Sepi

Sepi
Previous (TSepiMemoryRef)
Next (TSepiOpCode)

Name
TSepiMemorySpace

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Espace d'adressage
Les deux valeurs msConstant et msTrueConst représentent, comme leur nom
l'indique, des constantes. Certaines opérations n'acceptent pas les
constantes en paramètre, par exemple la destination d'un MOV ne peut pas
être une constante. De même, msVariable indique une TSepiVariable, qui peut
également être une constante (adressée) : la plupart des opérations
n'acceptant pas les constantes n'acceptent pas non plus une TSepiVariable
constante.
La valeur msZero est parfois acceptée par des instructions n'acceptant pas
de constantes, bien que 0 soit manifestement une constante. C'est le cas
par exemple de l'affectation de chaîne, qui n'accepte que la constante
nulle (qui vaut la chaîne vide '').
La valeur msZero en tant que valeur de retour d'un CALL est interprétée
plutôt en tant que msNoResult, autrement dit cela demande que le résultat
ne soit pas stocké. C'est également le cas de l'argument ExceptObject d'un
TRYE (try-except).
- msZero : 0, nil, '', etc. selon le type de variable
- msConstant : la variable est une constante, stockée juste derrière
- msLocalsBase : variable locale, sans offset
- msLocalsByte : variable locale, offset d'un octet
- msLocalsWord : variable locale, offset de deux octets
- msParamsBase : paramètre, sans offset
- msParamsByte : paramètre, offset d'un octet
- msParamsWord : paramètre, offset de deux octets
- msTrueConst : référence à une TSepiConstant
- msVariable : référence à une TSepiVariable

Source code
TSepiMemorySpace = ( msZero , msConstant , msLocalsBase , msLocalsByte , msLocalsWord , msParamsBase , msParamsByte , msParamsWord , msTrueConst , msVariable ) ;

Sepi
Class Tree
Index
Previous (TSepiMemoryRef)
Next (TSepiOpCode)


Sepi

Sepi
Previous (TSepiMemorySpace)
Next (TSepiParamSize)

Name
TSepiOpCode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Type d'un OpCode

Source code
TSepiOpCode = type Byte ;

Sepi
Class Tree
Index
Previous (TSepiMemorySpace)
Next (TSepiParamSize)


Sepi

Sepi
Previous (TSepiOpCode)
Next

Name
TSepiParamSize

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Taille d'un paramètre à passer à une procédure

Source code
TSepiParamSize = type Byte ;

Sepi
Class Tree
Index
Previous (TSepiOpCode)
Next


Sepi

Sepi
Previous
Next (AddrDerefShift)

Name
AddrDerefMask

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Masque de déréférencement

Source code
AddrDerefMask = $C0

Sepi
Class Tree
Index
Previous
Next (AddrDerefShift)


Sepi

Sepi
Previous (AddrDerefMask)
Next (AddrOperationMask)

Name
AddrDerefShift

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Offset du déréférencement

Source code
AddrDerefShift = 6

Sepi
Class Tree
Index
Previous (AddrDerefMask)
Next (AddrOperationMask)


Sepi

Sepi
Previous (AddrDerefShift)
Next (aoAcceptAllConsts)

Name
AddrOperationMask

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Masque de l'opération sur adresse

Source code
AddrOperationMask = $3F

Sepi
Class Tree
Index
Previous (AddrDerefShift)
Next (aoAcceptAllConsts)


Sepi

Sepi
Previous (AddrOperationMask)
Next (aoAcceptNonCodeConsts)

Name
aoAcceptAllConsts

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
aoAcceptAllConsts = [ aoAcceptZero , aoAcceptTrueConst , aoAcceptAddressedConst , aoAcceptConstInCode ]

Sepi
Class Tree
Index
Previous (AddrOperationMask)
Next (aoAcceptNonCodeConsts)


Sepi

Sepi
Previous (aoAcceptAllConsts)
Next (BaseTypeConstSizes)

Name
aoAcceptNonCodeConsts

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Accepte tous les types de constantes hors code

Source code
aoAcceptNonCodeConsts = [ aoAcceptZero , aoAcceptTrueConst , aoAcceptAddressedConst ]

Sepi
Class Tree
Index
Previous (aoAcceptAllConsts)
Next (BaseTypeConstSizes)


Sepi

Sepi
Previous (aoAcceptNonCodeConsts)
Next (btChars)

Name
BaseTypeConstSizes

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Taille des constantes en fonction des types de base

Source code
BaseTypeConstSizes : array [ TSepiBaseType ] of Integer = ( 1 , 1 , 2 , 4 , 1 , 2 , 4 , 8 , 4 , 8 , 10 , 8 , 8 , 1 , 2 , 0 , 0 , 0 , 0 )

Sepi
Class Tree
Index
Previous (aoAcceptNonCodeConsts)
Next (btChars)


Sepi

Sepi
Previous (BaseTypeConstSizes)
Next (btCharsAndStrings)

Name
btChars

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
btChars = [ btAnsiChar , btWideChar ]

Sepi
Class Tree
Index
Previous (BaseTypeConstSizes)
Next (btCharsAndStrings)


Sepi

Sepi
Previous (btChars)
Next (btFloats)

Name
btCharsAndStrings

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
btCharsAndStrings = btChars + btStrings

Sepi
Class Tree
Index
Previous (btChars)
Next (btFloats)


Sepi

Sepi
Previous (btCharsAndStrings)
Next (btIntegers)

Name
btFloats

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
btFloats = [ btSingle , btDouble , btExtended , btComp , btCurrency ]

Sepi
Class Tree
Index
Previous (btCharsAndStrings)
Next (btIntegers)


Sepi

Sepi
Previous (btFloats)
Next (btNumbers)

Name
btIntegers

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
btIntegers = [ btByte , btWord , btDWord , btShortint , btSmallint , btLongint , btInt64 ]

Sepi
Class Tree
Index
Previous (btFloats)
Next (btNumbers)


Sepi

Sepi
Previous (btIntegers)
Next (btStrings)

Name
btNumbers

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
btNumbers = btIntegers + btFloats

Sepi
Class Tree
Index
Previous (btIntegers)
Next (btStrings)


Sepi

Sepi
Previous (btNumbers)
Next (MemOpCountMask)

Name
btStrings

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
btStrings = [ btAnsiStr , btWideStr , btUnicodeStr ]

Sepi
Class Tree
Index
Previous (btNumbers)
Next (MemOpCountMask)


Sepi

Sepi
Previous (btStrings)
Next (MemOpCountShift)

Name
MemOpCountMask

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Masque du nombre d'opérations

Source code
MemOpCountMask = $F0

Sepi
Class Tree
Index
Previous (btStrings)
Next (MemOpCountShift)


Sepi

Sepi
Previous (MemOpCountMask)
Next (MemPlaceMask)

Name
MemOpCountShift

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Offset du nombre d'opérations

Source code
MemOpCountShift = 4

Sepi
Class Tree
Index
Previous (MemOpCountMask)
Next (MemPlaceMask)


Sepi

Sepi
Previous (MemOpCountShift)
Next (msNil)

Name
MemPlaceMask

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Masque d'espace mémoire

Source code
MemPlaceMask = $0F

Sepi
Class Tree
Index
Previous (MemOpCountShift)
Next (msNil)


Sepi

Sepi
Previous (MemPlaceMask)
Next (msNoResult)

Name
msNil

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Constante nil

Source code
msNil = msZero

Sepi
Class Tree
Index
Previous (MemPlaceMask)
Next (msNoResult)


Sepi

Sepi
Previous (msNil)
Next (msResult)

Name
msNoResult

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Ne pas garder le résultat

Source code
msNoResult = msZero

Sepi
Class Tree
Index
Previous (msNil)
Next (msResult)


Sepi

Sepi
Previous (msNoResult)
Next (msSelf)

Name
msResult

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Variable résultat

Source code
msResult = msLocalsBase

Sepi
Class Tree
Index
Previous (msNoResult)
Next (msSelf)


Sepi

Sepi
Previous (msResult)
Next (ocAddressCall)

Name
msSelf

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Paramètre Self

Source code
msSelf = msParamsBase

Sepi
Class Tree
Index
Previous (msResult)
Next (ocAddressCall)


Sepi

Sepi
Previous (msSelf)
Next (ocAnsiStrCopy)

Name
ocAddressCall

Parent
SepiOpCodes

Visibility
PUBLIC

Description
CALL CallSettings (ORS)? Address Params

Source code
ocAddressCall = TSepiOpCode ( $05 )

Sepi
Class Tree
Index
Previous (msSelf)
Next (ocAnsiStrCopy)


Sepi

Sepi
Previous (ocAddressCall)
Next (ocAnsiStrLength)

Name
ocAnsiStrCopy

Parent
SepiOpCodes

Visibility
PUBLIC

Description
ASCP Dest, Src, Index, Count

Source code
ocAnsiStrCopy = TSepiOpCode ( $89 )

Sepi
Class Tree
Index
Previous (ocAddressCall)
Next (ocAnsiStrLength)


Sepi

Sepi
Previous (ocAnsiStrCopy)
Next (ocAnsiStrSetLength)

Name
ocAnsiStrLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
ASL Dest, Value

Source code
ocAnsiStrLength = TSepiOpCode ( $80 )

Sepi
Class Tree
Index
Previous (ocAnsiStrCopy)
Next (ocAnsiStrSetLength)


Sepi

Sepi
Previous (ocAnsiStrLength)
Next (ocAsClass)

Name
ocAnsiStrSetLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
ASSL Var, Len

Source code
ocAnsiStrSetLength = TSepiOpCode ( $85 )

Sepi
Class Tree
Index
Previous (ocAnsiStrLength)
Next (ocAsClass)


Sepi

Sepi
Previous (ocAnsiStrSetLength)
Next (ocCompEquals)

Name
ocAsClass

Parent
SepiOpCodes

Visibility
PUBLIC

Description
AS Object, Class

Source code
ocAsClass = TSepiOpCode ( $54 )

Sepi
Class Tree
Index
Previous (ocAnsiStrSetLength)
Next (ocCompEquals)


Sepi

Sepi
Previous (ocAsClass)
Next (ocCompGreater)

Name
ocCompEquals

Parent
SepiOpCodes

Visibility
PUBLIC

Description
EQ Type, Dest, Left, Right

Source code
ocCompEquals = TSepiOpCode ( $40 )

Sepi
Class Tree
Index
Previous (ocAsClass)
Next (ocCompGreater)


Sepi

Sepi
Previous (ocCompEquals)
Next (ocCompGreaterEq)

Name
ocCompGreater

Parent
SepiOpCodes

Visibility
PUBLIC

Description
GT Type, Dest, Left, Right

Source code
ocCompGreater = TSepiOpCode ( $43 )

Sepi
Class Tree
Index
Previous (ocCompEquals)
Next (ocCompGreaterEq)


Sepi

Sepi
Previous (ocCompGreater)
Next (ocCompLower)

Name
ocCompGreaterEq

Parent
SepiOpCodes

Visibility
PUBLIC

Description
GE Type, Dest, Left, Right

Source code
ocCompGreaterEq = TSepiOpCode ( $45 )

Sepi
Class Tree
Index
Previous (ocCompGreater)
Next (ocCompLower)


Sepi

Sepi
Previous (ocCompGreaterEq)
Next (ocCompLowerEq)

Name
ocCompLower

Parent
SepiOpCodes

Visibility
PUBLIC

Description
LT Type, Dest, Left, Right

Source code
ocCompLower = TSepiOpCode ( $42 )

Sepi
Class Tree
Index
Previous (ocCompGreaterEq)
Next (ocCompLowerEq)


Sepi

Sepi
Previous (ocCompLower)
Next (ocCompNotEquals)

Name
ocCompLowerEq

Parent
SepiOpCodes

Visibility
PUBLIC

Description
LE Type, Dest, Left, Right

Source code
ocCompLowerEq = TSepiOpCode ( $44 )

Sepi
Class Tree
Index
Previous (ocCompLower)
Next (ocCompNotEquals)


Sepi

Sepi
Previous (ocCompLowerEq)
Next (ocConvert)

Name
ocCompNotEquals

Parent
SepiOpCodes

Visibility
PUBLIC

Description
NEQ Type, Dest, Left, Right

Source code
ocCompNotEquals = TSepiOpCode ( $41 )

Sepi
Class Tree
Index
Previous (ocCompLowerEq)
Next (ocConvert)


Sepi

Sepi
Previous (ocCompNotEquals)
Next (ocDynamicCall)

Name
ocConvert

Parent
SepiOpCodes

Visibility
PUBLIC

Description
CVRT Type, Type, [CP,] Mem, Mem

Source code
ocConvert = TSepiOpCode ( $1E )

Sepi
Class Tree
Index
Previous (ocCompNotEquals)
Next (ocDynamicCall)


Sepi

Sepi
Previous (ocConvert)
Next (ocDynArrayCopy)

Name
ocDynamicCall

Parent
SepiOpCodes

Visibility
PUBLIC

Description
CALL Method-Ref Self Params

Source code
ocDynamicCall = TSepiOpCode ( $07 )

Sepi
Class Tree
Index
Previous (ocConvert)
Next (ocDynArrayCopy)


Sepi

Sepi
Previous (ocDynamicCall)
Next (ocDynArrayCopyRange)

Name
ocDynArrayCopy

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DACP Type-Ref, Dest, Src

Source code
ocDynArrayCopy = TSepiOpCode ( $8C )

Sepi
Class Tree
Index
Previous (ocDynamicCall)
Next (ocDynArrayCopyRange)


Sepi

Sepi
Previous (ocDynArrayCopy)
Next (ocDynArrayHigh)

Name
ocDynArrayCopyRange

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DACP Type-Ref, Dest, Src,Idx,Cnt

Source code
ocDynArrayCopyRange = TSepiOpCode ( $8D )

Sepi
Class Tree
Index
Previous (ocDynArrayCopy)
Next (ocDynArrayHigh)


Sepi

Sepi
Previous (ocDynArrayCopyRange)
Next (ocDynArrayLength)

Name
ocDynArrayHigh

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DAH Dest, Value

Source code
ocDynArrayHigh = TSepiOpCode ( $84 )

Sepi
Class Tree
Index
Previous (ocDynArrayCopyRange)
Next (ocDynArrayLength)


Sepi

Sepi
Previous (ocDynArrayHigh)
Next (ocDynArraySetLength)

Name
ocDynArrayLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DAL Dest, Value

Source code
ocDynArrayLength = TSepiOpCode ( $83 )

Sepi
Class Tree
Index
Previous (ocDynArrayHigh)
Next (ocDynArraySetLength)


Sepi

Sepi
Previous (ocDynArrayLength)
Next (ocExtended)

Name
ocDynArraySetLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DASL Type-Ref, Var,DimCount,Dims

Source code
ocDynArraySetLength = TSepiOpCode ( $88 )

Sepi
Class Tree
Index
Previous (ocDynArrayLength)
Next (ocExtended)


Sepi

Sepi
Previous (ocDynArraySetLength)
Next (ocGetDelphiClass)

Name
ocExtended

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Instruction étendue (non utilisé)

Source code
ocExtended = TSepiOpCode ( $01 )

Sepi
Class Tree
Index
Previous (ocDynArraySetLength)
Next (ocGetDelphiClass)


Sepi

Sepi
Previous (ocExtended)
Next (ocGetMethodCode)

Name
ocGetDelphiClass

Parent
SepiOpCodes

Visibility
PUBLIC

Description
GDC Dest, Class-Ref

Source code
ocGetDelphiClass = TSepiOpCode ( $51 )

Sepi
Class Tree
Index
Previous (ocExtended)
Next (ocGetMethodCode)


Sepi

Sepi
Previous (ocGetDelphiClass)
Next (ocGetTypeInfo)

Name
ocGetMethodCode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
GMC Dest, Method-Ref

Source code
ocGetMethodCode = TSepiOpCode ( $52 )

Sepi
Class Tree
Index
Previous (ocGetDelphiClass)
Next (ocGetTypeInfo)


Sepi

Sepi
Previous (ocGetMethodCode)
Next (ocIsClass)

Name
ocGetTypeInfo

Parent
SepiOpCodes

Visibility
PUBLIC

Description
GTI Dest, Type-Ref

Source code
ocGetTypeInfo = TSepiOpCode ( $50 )

Sepi
Class Tree
Index
Previous (ocGetMethodCode)
Next (ocIsClass)


Sepi

Sepi
Previous (ocGetTypeInfo)
Next (ocJump)

Name
ocIsClass

Parent
SepiOpCodes

Visibility
PUBLIC

Description
IS Dest, Object, Class

Source code
ocIsClass = TSepiOpCode ( $53 )

Sepi
Class Tree
Index
Previous (ocGetTypeInfo)
Next (ocJump)


Sepi

Sepi
Previous (ocIsClass)
Next (ocJumpIfFalse)

Name
ocJump

Parent
SepiOpCodes

Visibility
PUBLIC

Description
JUMP Dest

Source code
ocJump = TSepiOpCode ( $02 )

Sepi
Class Tree
Index
Previous (ocIsClass)
Next (ocJumpIfFalse)


Sepi

Sepi
Previous (ocJump)
Next (ocJumpIfTrue)

Name
ocJumpIfFalse

Parent
SepiOpCodes

Visibility
PUBLIC

Description
JIF Dest, Test

Source code
ocJumpIfFalse = TSepiOpCode ( $04 )

Sepi
Class Tree
Index
Previous (ocJump)
Next (ocJumpIfTrue)


Sepi

Sepi
Previous (ocJumpIfFalse)
Next (ocLoadAddress)

Name
ocJumpIfTrue

Parent
SepiOpCodes

Visibility
PUBLIC

Description
JIT Dest, Test

Source code
ocJumpIfTrue = TSepiOpCode ( $03 )

Sepi
Class Tree
Index
Previous (ocJumpIfFalse)
Next (ocLoadAddress)


Sepi

Sepi
Previous (ocJumpIfTrue)
Next (ocMoveAnsiStr)

Name
ocLoadAddress

Parent
SepiOpCodes

Visibility
PUBLIC

Description
LEA Dest, Src

Source code
ocLoadAddress = TSepiOpCode ( $10 )

Sepi
Class Tree
Index
Previous (ocJumpIfTrue)
Next (ocMoveAnsiStr)


Sepi

Sepi
Previous (ocLoadAddress)
Next (ocMoveByte)

Name
ocMoveAnsiStr

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVAS Dest, Src

Source code
ocMoveAnsiStr = TSepiOpCode ( $16 )

Sepi
Class Tree
Index
Previous (ocLoadAddress)
Next (ocMoveByte)


Sepi

Sepi
Previous (ocMoveAnsiStr)
Next (ocMoveDWord)

Name
ocMoveByte

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVB Dest, Src

Source code
ocMoveByte = TSepiOpCode ( $11 )

Sepi
Class Tree
Index
Previous (ocMoveAnsiStr)
Next (ocMoveDWord)


Sepi

Sepi
Previous (ocMoveByte)
Next (ocMoveExt)

Name
ocMoveDWord

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVD Dest, Src

Source code
ocMoveDWord = TSepiOpCode ( $13 )

Sepi
Class Tree
Index
Previous (ocMoveByte)
Next (ocMoveExt)


Sepi

Sepi
Previous (ocMoveDWord)
Next (ocMoveIntf)

Name
ocMoveExt

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVE Dest, Src

Source code
ocMoveExt = TSepiOpCode ( $15 )

Sepi
Class Tree
Index
Previous (ocMoveDWord)
Next (ocMoveIntf)


Sepi

Sepi
Previous (ocMoveExt)
Next (ocMoveMany)

Name
ocMoveIntf

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVI Dest, Src

Source code
ocMoveIntf = TSepiOpCode ( $1A )

Sepi
Class Tree
Index
Previous (ocMoveExt)
Next (ocMoveMany)


Sepi

Sepi
Previous (ocMoveIntf)
Next (ocMoveOther)

Name
ocMoveMany

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVM Word-Count, Dest, Src

Source code
ocMoveMany = TSepiOpCode ( $1C )

Sepi
Class Tree
Index
Previous (ocMoveIntf)
Next (ocMoveOther)


Sepi

Sepi
Previous (ocMoveMany)
Next (ocMoveQWord)

Name
ocMoveOther

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVO Type-Ref, Dest, Src

Source code
ocMoveOther = TSepiOpCode ( $1D )

Sepi
Class Tree
Index
Previous (ocMoveMany)
Next (ocMoveQWord)


Sepi

Sepi
Previous (ocMoveOther)
Next (ocMoveSome)

Name
ocMoveQWord

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVQ Dest, Src

Source code
ocMoveQWord = TSepiOpCode ( $14 )

Sepi
Class Tree
Index
Previous (ocMoveOther)
Next (ocMoveSome)


Sepi

Sepi
Previous (ocMoveQWord)
Next (ocMoveUnicodeStr)

Name
ocMoveSome

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVS Byte-Count, Dest, Src

Source code
ocMoveSome = TSepiOpCode ( $1B )

Sepi
Class Tree
Index
Previous (ocMoveQWord)
Next (ocMoveUnicodeStr)


Sepi

Sepi
Previous (ocMoveSome)
Next (ocMoveVariant)

Name
ocMoveUnicodeStr

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVUS Dest, Src

Source code
ocMoveUnicodeStr = TSepiOpCode ( $18 )

Sepi
Class Tree
Index
Previous (ocMoveSome)
Next (ocMoveVariant)


Sepi

Sepi
Previous (ocMoveUnicodeStr)
Next (ocMoveWideStr)

Name
ocMoveVariant

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVV Dest, Src

Source code
ocMoveVariant = TSepiOpCode ( $19 )

Sepi
Class Tree
Index
Previous (ocMoveUnicodeStr)
Next (ocMoveWideStr)


Sepi

Sepi
Previous (ocMoveVariant)
Next (ocMoveWord)

Name
ocMoveWideStr

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVWS Dest, Src

Source code
ocMoveWideStr = TSepiOpCode ( $17 )

Sepi
Class Tree
Index
Previous (ocMoveVariant)
Next (ocMoveWord)


Sepi

Sepi
Previous (ocMoveWideStr)
Next (ocMultiOn)

Name
ocMoveWord

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOVW Dest, Src

Source code
ocMoveWord = TSepiOpCode ( $12 )

Sepi
Class Tree
Index
Previous (ocMoveWideStr)
Next (ocMultiOn)


Sepi

Sepi
Previous (ocMoveWord)
Next (ocNope)

Name
ocMultiOn

Parent
SepiOpCodes

Visibility
PUBLIC

Description
ON ExceptObject, Byte-Count, (Class-Ref, Dest){Count}

Source code
ocMultiOn = TSepiOpCode ( $64 )

Sepi
Class Tree
Index
Previous (ocMoveWord)
Next (ocNope)


Sepi

Sepi
Previous (ocMultiOn)
Next (ocOtherAdd)

Name
ocNope

Parent
SepiOpCodes

Visibility
PUBLIC

Description
NOP

Source code
ocNope = TSepiOpCode ( $00 )

Sepi
Class Tree
Index
Previous (ocMultiOn)
Next (ocOtherAdd)


Sepi

Sepi
Previous (ocNope)
Next (ocOtherAnd)

Name
ocOtherAdd

Parent
SepiOpCodes

Visibility
PUBLIC

Description
ADD Type, Dest, Left, Right

Source code
ocOtherAdd = TSepiOpCode ( $34 )

Sepi
Class Tree
Index
Previous (ocNope)
Next (ocOtherAnd)


Sepi

Sepi
Previous (ocOtherAdd)
Next (ocOtherDec)

Name
ocOtherAnd

Parent
SepiOpCodes

Visibility
PUBLIC

Description
AND Type, Dest, Left, Right

Source code
ocOtherAnd = TSepiOpCode ( $3C )

Sepi
Class Tree
Index
Previous (ocOtherAdd)
Next (ocOtherDec)


Sepi

Sepi
Previous (ocOtherAnd)
Next (ocOtherDivide)

Name
ocOtherDec

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DEC Type, Dest, Value

Source code
ocOtherDec = TSepiOpCode ( $31 )

Sepi
Class Tree
Index
Previous (ocOtherAnd)
Next (ocOtherDivide)


Sepi

Sepi
Previous (ocOtherDec)
Next (ocOtherInc)

Name
ocOtherDivide

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DIV Type, Dest, Left, Right

Source code
ocOtherDivide = TSepiOpCode ( $37 )

Sepi
Class Tree
Index
Previous (ocOtherDec)
Next (ocOtherInc)


Sepi

Sepi
Previous (ocOtherDivide)
Next (ocOtherIntDiv)

Name
ocOtherInc

Parent
SepiOpCodes

Visibility
PUBLIC

Description
INC Type, Dest, Value

Source code
ocOtherInc = TSepiOpCode ( $30 )

Sepi
Class Tree
Index
Previous (ocOtherDivide)
Next (ocOtherIntDiv)


Sepi

Sepi
Previous (ocOtherInc)
Next (ocOtherModulus)

Name
ocOtherIntDiv

Parent
SepiOpCodes

Visibility
PUBLIC

Description
IDV Type, Dest, Left, Right

Source code
ocOtherIntDiv = TSepiOpCode ( $38 )

Sepi
Class Tree
Index
Previous (ocOtherInc)
Next (ocOtherModulus)


Sepi

Sepi
Previous (ocOtherIntDiv)
Next (ocOtherMultiply)

Name
ocOtherModulus

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOD Type, Dest, Left, Right

Source code
ocOtherModulus = TSepiOpCode ( $39 )

Sepi
Class Tree
Index
Previous (ocOtherIntDiv)
Next (ocOtherMultiply)


Sepi

Sepi
Previous (ocOtherModulus)
Next (ocOtherNeg)

Name
ocOtherMultiply

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MUL Type, Dest, Left, Right

Source code
ocOtherMultiply = TSepiOpCode ( $36 )

Sepi
Class Tree
Index
Previous (ocOtherModulus)
Next (ocOtherNeg)


Sepi

Sepi
Previous (ocOtherMultiply)
Next (ocOtherNot)

Name
ocOtherNeg

Parent
SepiOpCodes

Visibility
PUBLIC

Description
NEG Type, Dest, Value

Source code
ocOtherNeg = TSepiOpCode ( $33 )

Sepi
Class Tree
Index
Previous (ocOtherMultiply)
Next (ocOtherNot)


Sepi

Sepi
Previous (ocOtherNeg)
Next (ocOtherOr)

Name
ocOtherNot

Parent
SepiOpCodes

Visibility
PUBLIC

Description
NOT Type, Dest, Value

Source code
ocOtherNot = TSepiOpCode ( $32 )

Sepi
Class Tree
Index
Previous (ocOtherNeg)
Next (ocOtherOr)


Sepi

Sepi
Previous (ocOtherNot)
Next (ocOtherShl)

Name
ocOtherOr

Parent
SepiOpCodes

Visibility
PUBLIC

Description
OR Type, Dest, Left, Right

Source code
ocOtherOr = TSepiOpCode ( $3D )

Sepi
Class Tree
Index
Previous (ocOtherNot)
Next (ocOtherShl)


Sepi

Sepi
Previous (ocOtherOr)
Next (ocOtherShr)

Name
ocOtherShl

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SHL Type, Dest, Left, Right

Source code
ocOtherShl = TSepiOpCode ( $3A )

Sepi
Class Tree
Index
Previous (ocOtherOr)
Next (ocOtherShr)


Sepi

Sepi
Previous (ocOtherShl)
Next (ocOtherSubtract)

Name
ocOtherShr

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SHR Type, Dest, Left, Right

Source code
ocOtherShr = TSepiOpCode ( $3B )

Sepi
Class Tree
Index
Previous (ocOtherShl)
Next (ocOtherSubtract)


Sepi

Sepi
Previous (ocOtherShr)
Next (ocOtherXor)

Name
ocOtherSubtract

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SUB Type, Dest, Left, Right

Source code
ocOtherSubtract = TSepiOpCode ( $35 )

Sepi
Class Tree
Index
Previous (ocOtherShr)
Next (ocOtherXor)


Sepi

Sepi
Previous (ocOtherSubtract)
Next (ocRaise)

Name
ocOtherXor

Parent
SepiOpCodes

Visibility
PUBLIC

Description
XOR Type, Dest, Left, Right

Source code
ocOtherXor = TSepiOpCode ( $3E )

Sepi
Class Tree
Index
Previous (ocOtherSubtract)
Next (ocRaise)


Sepi

Sepi
Previous (ocOtherXor)
Next (ocReraise)

Name
ocRaise

Parent
SepiOpCodes

Visibility
PUBLIC

Description
RAISE ExceptObject

Source code
ocRaise = TSepiOpCode ( $60 )

Sepi
Class Tree
Index
Previous (ocOtherXor)
Next (ocReraise)


Sepi

Sepi
Previous (ocRaise)
Next (ocSelfAdd)

Name
ocReraise

Parent
SepiOpCodes

Visibility
PUBLIC

Description
RERS

Source code
ocReraise = TSepiOpCode ( $61 )

Sepi
Class Tree
Index
Previous (ocRaise)
Next (ocSelfAdd)


Sepi

Sepi
Previous (ocReraise)
Next (ocSelfAnd)

Name
ocSelfAdd

Parent
SepiOpCodes

Visibility
PUBLIC

Description
ADD Type, Var, Value

Source code
ocSelfAdd = TSepiOpCode ( $24 )

Sepi
Class Tree
Index
Previous (ocReraise)
Next (ocSelfAnd)


Sepi

Sepi
Previous (ocSelfAdd)
Next (ocSelfDec)

Name
ocSelfAnd

Parent
SepiOpCodes

Visibility
PUBLIC

Description
AND Type, Var, Value

Source code
ocSelfAnd = TSepiOpCode ( $2C )

Sepi
Class Tree
Index
Previous (ocSelfAdd)
Next (ocSelfDec)


Sepi

Sepi
Previous (ocSelfAnd)
Next (ocSelfDivide)

Name
ocSelfDec

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DEC Type, Var

Source code
ocSelfDec = TSepiOpCode ( $21 )

Sepi
Class Tree
Index
Previous (ocSelfAnd)
Next (ocSelfDivide)


Sepi

Sepi
Previous (ocSelfDec)
Next (ocSelfInc)

Name
ocSelfDivide

Parent
SepiOpCodes

Visibility
PUBLIC

Description
DIV Type, Var, Value

Source code
ocSelfDivide = TSepiOpCode ( $27 )

Sepi
Class Tree
Index
Previous (ocSelfDec)
Next (ocSelfInc)


Sepi

Sepi
Previous (ocSelfDivide)
Next (ocSelfIntDiv)

Name
ocSelfInc

Parent
SepiOpCodes

Visibility
PUBLIC

Description
INC Type, Var

Source code
ocSelfInc = TSepiOpCode ( $20 )

Sepi
Class Tree
Index
Previous (ocSelfDivide)
Next (ocSelfIntDiv)


Sepi

Sepi
Previous (ocSelfInc)
Next (ocSelfModulus)

Name
ocSelfIntDiv

Parent
SepiOpCodes

Visibility
PUBLIC

Description
IDV Type, Var, Value

Source code
ocSelfIntDiv = TSepiOpCode ( $28 )

Sepi
Class Tree
Index
Previous (ocSelfInc)
Next (ocSelfModulus)


Sepi

Sepi
Previous (ocSelfIntDiv)
Next (ocSelfMultiply)

Name
ocSelfModulus

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MOD Type, Var, Value

Source code
ocSelfModulus = TSepiOpCode ( $29 )

Sepi
Class Tree
Index
Previous (ocSelfIntDiv)
Next (ocSelfMultiply)


Sepi

Sepi
Previous (ocSelfModulus)
Next (ocSelfNeg)

Name
ocSelfMultiply

Parent
SepiOpCodes

Visibility
PUBLIC

Description
MUL Type, Var, Value

Source code
ocSelfMultiply = TSepiOpCode ( $26 )

Sepi
Class Tree
Index
Previous (ocSelfModulus)
Next (ocSelfNeg)


Sepi

Sepi
Previous (ocSelfMultiply)
Next (ocSelfNot)

Name
ocSelfNeg

Parent
SepiOpCodes

Visibility
PUBLIC

Description
NEG Type, Var

Source code
ocSelfNeg = TSepiOpCode ( $23 )

Sepi
Class Tree
Index
Previous (ocSelfMultiply)
Next (ocSelfNot)


Sepi

Sepi
Previous (ocSelfNeg)
Next (ocSelfOr)

Name
ocSelfNot

Parent
SepiOpCodes

Visibility
PUBLIC

Description
NOT Type, Var

Source code
ocSelfNot = TSepiOpCode ( $22 )

Sepi
Class Tree
Index
Previous (ocSelfNeg)
Next (ocSelfOr)


Sepi

Sepi
Previous (ocSelfNot)
Next (ocSelfShl)

Name
ocSelfOr

Parent
SepiOpCodes

Visibility
PUBLIC

Description
OR Type, Var, Value

Source code
ocSelfOr = TSepiOpCode ( $2D )

Sepi
Class Tree
Index
Previous (ocSelfNot)
Next (ocSelfShl)


Sepi

Sepi
Previous (ocSelfOr)
Next (ocSelfShr)

Name
ocSelfShl

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SHL Type, Var, Value

Source code
ocSelfShl = TSepiOpCode ( $2A )

Sepi
Class Tree
Index
Previous (ocSelfOr)
Next (ocSelfShr)


Sepi

Sepi
Previous (ocSelfShl)
Next (ocSelfSubtract)

Name
ocSelfShr

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SHR Type, Var, Value

Source code
ocSelfShr = TSepiOpCode ( $2B )

Sepi
Class Tree
Index
Previous (ocSelfShl)
Next (ocSelfSubtract)


Sepi

Sepi
Previous (ocSelfShr)
Next (ocSelfXor)

Name
ocSelfSubtract

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SUB Type, Var, Value

Source code
ocSelfSubtract = TSepiOpCode ( $25 )

Sepi
Class Tree
Index
Previous (ocSelfShr)
Next (ocSelfXor)


Sepi

Sepi
Previous (ocSelfSubtract)
Next (ocSetContained)

Name
ocSelfXor

Parent
SepiOpCodes

Visibility
PUBLIC

Description
XOR Type, Var, Value

Source code
ocSelfXor = TSepiOpCode ( $2E )

Sepi
Class Tree
Index
Previous (ocSelfSubtract)
Next (ocSetContained)


Sepi

Sepi
Previous (ocSelfXor)
Next (ocSetElem)

Name
ocSetContained

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SLE SetSize, Dest, Set1, Set2

Source code
ocSetContained = TSepiOpCode ( $78 )

Sepi
Class Tree
Index
Previous (ocSelfXor)
Next (ocSetElem)


Sepi

Sepi
Previous (ocSetContained)
Next (ocSetEquals)

Name
ocSetElem

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SELE SetSize, Dest, Elem

Source code
ocSetElem = TSepiOpCode ( $73 )

Sepi
Class Tree
Index
Previous (ocSetContained)
Next (ocSetEquals)


Sepi

Sepi
Previous (ocSetElem)
Next (ocSetExclude)

Name
ocSetEquals

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SEQ SetSize, Dest, Set1, Set2

Source code
ocSetEquals = TSepiOpCode ( $76 )

Sepi
Class Tree
Index
Previous (ocSetElem)
Next (ocSetExclude)


Sepi

Sepi
Previous (ocSetEquals)
Next (ocSetExpand)

Name
ocSetExclude

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SEXC Dest, Elem

Source code
ocSetExclude = TSepiOpCode ( $71 )

Sepi
Class Tree
Index
Previous (ocSetEquals)
Next (ocSetExpand)


Sepi

Sepi
Previous (ocSetExclude)
Next (ocSetIn)

Name
ocSetExpand

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SEXP Dest, Src, Lo, Hi

Source code
ocSetExpand = TSepiOpCode ( $7F )

Sepi
Class Tree
Index
Previous (ocSetExclude)
Next (ocSetIn)


Sepi

Sepi
Previous (ocSetExpand)
Next (ocSetInclude)

Name
ocSetIn

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SIN Dest, Set, Elem

Source code
ocSetIn = TSepiOpCode ( $72 )

Sepi
Class Tree
Index
Previous (ocSetExpand)
Next (ocSetInclude)


Sepi

Sepi
Previous (ocSetIn)
Next (ocSetNotEquals)

Name
ocSetInclude

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SINC Dest, Elem

Source code
ocSetInclude = TSepiOpCode ( $70 )

Sepi
Class Tree
Index
Previous (ocSetIn)
Next (ocSetNotEquals)


Sepi

Sepi
Previous (ocSetInclude)
Next (ocSetOtherIntersect)

Name
ocSetNotEquals

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SNE SetSize, Dest, Set1, Set2

Source code
ocSetNotEquals = TSepiOpCode ( $77 )

Sepi
Class Tree
Index
Previous (ocSetInclude)
Next (ocSetOtherIntersect)


Sepi

Sepi
Previous (ocSetNotEquals)
Next (ocSetOtherSubtract)

Name
ocSetOtherIntersect

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SINT SetSize, Dest, Left, Right

Source code
ocSetOtherIntersect = TSepiOpCode ( $7C )

Sepi
Class Tree
Index
Previous (ocSetNotEquals)
Next (ocSetOtherSubtract)


Sepi

Sepi
Previous (ocSetOtherIntersect)
Next (ocSetOtherUnion)

Name
ocSetOtherSubtract

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SSUB SetSize, Dest, Left, Right

Source code
ocSetOtherSubtract = TSepiOpCode ( $7E )

Sepi
Class Tree
Index
Previous (ocSetOtherIntersect)
Next (ocSetOtherUnion)


Sepi

Sepi
Previous (ocSetOtherSubtract)
Next (ocSetRange)

Name
ocSetOtherUnion

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SADD SetSize, Dest, Left, Right

Source code
ocSetOtherUnion = TSepiOpCode ( $7D )

Sepi
Class Tree
Index
Previous (ocSetOtherSubtract)
Next (ocSetRange)


Sepi

Sepi
Previous (ocSetOtherUnion)
Next (ocSetSelfIntersect)

Name
ocSetRange

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SRNG SetSize, Dest, Lo, Hi

Source code
ocSetRange = TSepiOpCode ( $74 )

Sepi
Class Tree
Index
Previous (ocSetOtherUnion)
Next (ocSetSelfIntersect)


Sepi

Sepi
Previous (ocSetRange)
Next (ocSetSelfSubtract)

Name
ocSetSelfIntersect

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SINT SetSize, Dest, Src

Source code
ocSetSelfIntersect = TSepiOpCode ( $79 )

Sepi
Class Tree
Index
Previous (ocSetRange)
Next (ocSetSelfSubtract)


Sepi

Sepi
Previous (ocSetSelfIntersect)
Next (ocSetSelfUnion)

Name
ocSetSelfSubtract

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SSUB SetSize, Dest, Src

Source code
ocSetSelfSubtract = TSepiOpCode ( $7B )

Sepi
Class Tree
Index
Previous (ocSetSelfIntersect)
Next (ocSetSelfUnion)


Sepi

Sepi
Previous (ocSetSelfSubtract)
Next (ocSetUnionRange)

Name
ocSetSelfUnion

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SADD SetSize, Dest, Src

Source code
ocSetSelfUnion = TSepiOpCode ( $7A )

Sepi
Class Tree
Index
Previous (ocSetSelfSubtract)
Next (ocSetUnionRange)


Sepi

Sepi
Previous (ocSetSelfUnion)
Next (ocStaticCall)

Name
ocSetUnionRange

Parent
SepiOpCodes

Visibility
PUBLIC

Description
SUR SetSize, Dest, Lo, Hi

Source code
ocSetUnionRange = TSepiOpCode ( $75 )

Sepi
Class Tree
Index
Previous (ocSetSelfUnion)
Next (ocStaticCall)


Sepi

Sepi
Previous (ocSetUnionRange)
Next (ocTryExcept)

Name
ocStaticCall

Parent
SepiOpCodes

Visibility
PUBLIC

Description
CALL Method-Ref Params

Source code
ocStaticCall = TSepiOpCode ( $06 )

Sepi
Class Tree
Index
Previous (ocSetUnionRange)
Next (ocTryExcept)


Sepi

Sepi
Previous (ocStaticCall)
Next (ocTryFinally)

Name
ocTryExcept

Parent
SepiOpCodes

Visibility
PUBLIC

Description
TRYE TrySize, ExceptSize, [ExceptObject]

Source code
ocTryExcept = TSepiOpCode ( $62 )

Sepi
Class Tree
Index
Previous (ocStaticCall)
Next (ocTryFinally)


Sepi

Sepi
Previous (ocTryExcept)
Next (ocUnicodeStrCopy)

Name
ocTryFinally

Parent
SepiOpCodes

Visibility
PUBLIC

Description
TRYF TrySize, FinallySize

Source code
ocTryFinally = TSepiOpCode ( $63 )

Sepi
Class Tree
Index
Previous (ocTryExcept)
Next (ocUnicodeStrCopy)


Sepi

Sepi
Previous (ocTryFinally)
Next (ocUnicodeStrLength)

Name
ocUnicodeStrCopy

Parent
SepiOpCodes

Visibility
PUBLIC

Description
USCP Dest, Src, Index, Count

Source code
ocUnicodeStrCopy = TSepiOpCode ( $8B )

Sepi
Class Tree
Index
Previous (ocTryFinally)
Next (ocUnicodeStrLength)


Sepi

Sepi
Previous (ocUnicodeStrCopy)
Next (ocUnicodeStrSetLength)

Name
ocUnicodeStrLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
USL Dest, Value

Source code
ocUnicodeStrLength = TSepiOpCode ( $82 )

Sepi
Class Tree
Index
Previous (ocUnicodeStrCopy)
Next (ocUnicodeStrSetLength)


Sepi

Sepi
Previous (ocUnicodeStrLength)
Next (ocWideStrCopy)

Name
ocUnicodeStrSetLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
USSL Var, Len

Source code
ocUnicodeStrSetLength = TSepiOpCode ( $87 )

Sepi
Class Tree
Index
Previous (ocUnicodeStrLength)
Next (ocWideStrCopy)


Sepi

Sepi
Previous (ocUnicodeStrSetLength)
Next (ocWideStrLength)

Name
ocWideStrCopy

Parent
SepiOpCodes

Visibility
PUBLIC

Description
WSCP Dest, Src, Index, Count

Source code
ocWideStrCopy = TSepiOpCode ( $8A )

Sepi
Class Tree
Index
Previous (ocUnicodeStrSetLength)
Next (ocWideStrLength)


Sepi

Sepi
Previous (ocWideStrCopy)
Next (ocWideStrSetLength)

Name
ocWideStrLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
WSL Dest, Value

Source code
ocWideStrLength = TSepiOpCode ( $81 )

Sepi
Class Tree
Index
Previous (ocWideStrCopy)
Next (ocWideStrSetLength)


Sepi

Sepi
Previous (ocWideStrLength)
Next (psByAddress)

Name
ocWideStrSetLength

Parent
SepiOpCodes

Visibility
PUBLIC

Description
WSSL Var, Len

Source code
ocWideStrSetLength = TSepiOpCode ( $86 )

Sepi
Class Tree
Index
Previous (ocWideStrLength)
Next (psByAddress)


Sepi

Sepi
Previous (ocWideStrSetLength)
Next (SettingsCallingConvMask)

Name
psByAddress

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Le paramètre est passé par adresse

Source code
psByAddress = TSepiParamSize ( 0 )

Sepi
Class Tree
Index
Previous (ocWideStrSetLength)
Next (SettingsCallingConvMask)


Sepi

Sepi
Previous (psByAddress)
Next (SettingsRegUsageMask)

Name
SettingsCallingConvMask

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Masque de la convention d'appel

Source code
SettingsCallingConvMask = $07

Sepi
Class Tree
Index
Previous (psByAddress)
Next (SettingsRegUsageMask)


Sepi

Sepi
Previous (SettingsCallingConvMask)
Next (SettingsRegUsageShift)

Name
SettingsRegUsageMask

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Masque de l'usage des registres

Source code
SettingsRegUsageMask = $18

Sepi
Class Tree
Index
Previous (SettingsCallingConvMask)
Next (SettingsRegUsageShift)


Sepi

Sepi
Previous (SettingsRegUsageMask)
Next (SettingsResultBehaviorMask)

Name
SettingsRegUsageShift

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Offset de l'usage des registres

Source code
SettingsRegUsageShift = 3

Sepi
Class Tree
Index
Previous (SettingsRegUsageMask)
Next (SettingsResultBehaviorMask)


Sepi

Sepi
Previous (SettingsRegUsageShift)
Next (SettingsResultBehaviorShift)

Name
SettingsResultBehaviorMask

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Masque du comportement du résultat

Source code
SettingsResultBehaviorMask = $E0

Sepi
Class Tree
Index
Previous (SettingsRegUsageShift)
Next (SettingsResultBehaviorShift)


Sepi

Sepi
Previous (SettingsResultBehaviorMask)
Next (SInvalidOpCode)

Name
SettingsResultBehaviorShift

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Offset du comportement du résultat

Source code
SettingsResultBehaviorShift = 5

Sepi
Class Tree
Index
Previous (SettingsResultBehaviorMask)
Next (SInvalidOpCode)


Sepi

Sepi
Previous (SettingsResultBehaviorShift)
Next

Name
SInvalidOpCode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SInvalidOpCode = 'OpCode invalide'

Sepi
Class Tree
Index
Previous (SettingsResultBehaviorShift)
Next


Sepi

Sepi
Previous
Next (AddressDerefAndOpEncode)

Name
AddressDerefAndOpDecode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Décode un déréférencement + opération sur adresse

Source code
procedure AddressDerefAndOpDecode ( AddressDerefAndOp : TSepiAddressDerefAndOp ; out Dereference : TSepiAddressDereference ; out Operation : TSepiAddressOperation )

Parameters
Parameter | Description
AddressDerefAndOp : TSepiAddressDerefAndOp | Combinaison à décoder
Dereference : TSepiAddressDereference | En sortie : Déréférencement
Operation : TSepiAddressOperation | En sortie : Opération

Sepi
Class Tree
Index
Previous
Next (AddressDerefAndOpEncode)


Sepi

Sepi
Previous (AddressDerefAndOpDecode)
Next (CallSettingsDecode)

Name
AddressDerefAndOpEncode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Encode un déréférencement + opération sur adresse

Source code
function AddressDerefAndOpEncode ( Dereference : TSepiAddressDereference ; Operation : TSepiAddressOperation ) : TSepiAddressDerefAndOp

Parameters
Parameter | Description
Dereference : TSepiAddressDereference | Déréférencement
Operation : TSepiAddressOperation | Opération

Return
Types | Description
TSepiAddressDerefAndOp | Combinaison du déréférencement et de l'opération

Sepi
Class Tree
Index
Previous (AddressDerefAndOpDecode)
Next (CallSettingsDecode)


Sepi

Sepi
Previous (AddressDerefAndOpEncode)
Next (CallSettingsEncode)

Name
CallSettingsDecode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Décode une configuration d'appel

Source code
procedure CallSettingsDecode ( Settings : TSepiCallSettings ; out CallingConvention : TCallingConvention ; out RegUsage : Byte ; out ResultBehavior : TSepiTypeResultBehavior )

Parameters
Parameter | Description
Settings : TSepiCallSettings | Configuration à décoder
CallingConvention : TCallingConvention | En sortie : Convention d'appel
RegUsage : BYTE | En sortie : Usage des registres
ResultBehavior : TSepiTypeResultBehavior | En sortie : Comportement du résultat

Sepi
Class Tree
Index
Previous (AddressDerefAndOpEncode)
Next (CallSettingsEncode)


Sepi

Sepi
Previous (CallSettingsDecode)
Next (MemoryRefDecode)

Name
CallSettingsEncode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Encode une configuration d'appel

Source code
function CallSettingsEncode ( CallingConvention : TCallingConvention ; RegUsage : Byte ; ResultBehavior : TSepiTypeResultBehavior ) : TSepiCallSettings

Parameters
Parameter | Description
CallingConvention : TCallingConvention | Convention d'appel
RegUsage : BYTE | Usage des registres
ResultBehavior : TSepiTypeResultBehavior | Comportement du résultat

Return
Types | Description
TSepiCallSettings | Configuration d'appel correspondante

Sepi
Class Tree
Index
Previous (CallSettingsDecode)
Next (MemoryRefDecode)


Sepi

Sepi
Previous (CallSettingsEncode)
Next (MemoryRefEncode)

Name
MemoryRefDecode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Décode une référence mémoire

Source code
procedure MemoryRefDecode ( MemoryRef : TSepiMemoryRef ; out MemorySpace : TSepiMemorySpace ; out OpCount : Integer )

Parameters
Parameter | Description
MemoryRef : TSepiMemoryRef | Référence mémoire à décoder
MemorySpace : TSepiMemorySpace
OpCount : INTEGER | En sortie : Nombre d'opérations

Sepi
Class Tree
Index
Previous (CallSettingsEncode)
Next (MemoryRefEncode)


Sepi

Sepi
Previous (MemoryRefDecode)
Next (RaiseInvalidOpCode)

Name
MemoryRefEncode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Encode une référence mémoire

Source code
function MemoryRefEncode ( MemorySpace : TSepiMemorySpace ; OpCount : Integer ) : TSepiMemoryRef

Parameters
Parameter | Description
MemorySpace : TSepiMemorySpace
OpCount : INTEGER | Nombre d'opérations

Return
Types | Description
TSepiMemoryRef | Référence mémoire correspondante

Sepi
Class Tree
Index
Previous (MemoryRefDecode)
Next (RaiseInvalidOpCode)


Sepi

Sepi
Previous (MemoryRefEncode)
Next

Name
RaiseInvalidOpCode

Parent
SepiOpCodes

Visibility
PUBLIC

Description
Déclenche une exception OpCode invalide

Source code
procedure RaiseInvalidOpCode

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MemoryRefEncode)
Next


Sepi

Sepi
Previous (SepiOpCodes)
Next (SepiParserUtils)

Name
SepiOrdTypes

Parent
Sepi

Description
Définit les classes de gestion des types ordinaux

Author
sjrd

Version
1.0

Types
Type | Description
TBooleanKind (+) | Type de booléen
TSepiFakeEnumValueDynArray (+) | Tableau de valeurs d'un faux enum
TSepiMinEnumSize (+) | Taille minimale d'un type énuméré

Constants
Constant | Description
MaxInt64 (+) | #No TAG found in source code#
MinInt64 (+) | #No TAG found in source code#
otUnknown (+) | #No TAG found in source code#

Methods
Method | Description
CardinalSize (+) | Calcule la taille en octets d'un entier non signé
IntegerSize (+) | Calcule la taille en octets d'un entier signé
IsIntegerType (+) | Teste si un type donné est un type entier (TSepiIntegerType ou TSepiInt64Type)
ValueAsCardinal (+) | Lit une valeur ordinale comme un Cardinal
ValueAsCardinal (+) | Lit une valeur ordinale comme un Cardinal
ValueAsInteger (+) | Lit une valeur ordinale comme un Integer
ValueAsInteger (+) | Lit une valeur ordinale comme un Integer

Classes
Class | Description
TSepiBooleanType (+) | Type booléen
TSepiCharType (+) | Type caractère
TSepiEnumType (+) | Type énumération
TSepiFakeEnumType (+) | Fausse énumération
TSepiFakeEnumValue (+) | Valeur d'un faux enum
TSepiFloatType (+) | Type nombre à virgule flottante
TSepiInt64Type (+) | Type entier long (64 bits)
TSepiIntegerType (+) | Type entier
TSepiOrdType (+) | Type ordinal
TSepiPointerType (+) | Type pointeur
TSepiSetType (+) | Type ensemble

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiOpCodes)
Next (SepiParserUtils)


Sepi

Sepi
Previous
Next (TSepiCharType)

Name
TSepiBooleanType

Parent
SepiOrdTypes

Class Hierarchy
TSepiOrdType

Visibility
PUBLIC

Description
Type booléen

Members
Fields
Field | Description
FBooleanKind (-) | Type de booléen

Methods
Method | Description
Clone (+) | [@inheritDoc]
Create (+) | Crée un type booléen
Load (+) | Charge un type booléen depuis un flux
Save (#) | [@inheritDoc]
ValueAsBoolean (+) | Lit une valeur de ce type comme valeur Boolean
ValueToString (+) | [@inheritedDoc]
WriteTypeInfo (#) | Construit les RTTI

Properties
Property | Description
BooleanKind (+) | Type de booléen

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiCharType)


Sepi

Sepi
Previous
Next

Name
FBooleanKind

Parent
TSepiBooleanType

Visibility
PRIVATE

Description
Type de booléen

Source code
FBooleanKind : TBooleanKind

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
BooleanKind

Parent
TSepiBooleanType

Visibility
PUBLIC

Description
Type de booléen

Source code
property BooleanKind : TBooleanKind read FBooleanKind

Read Access
FBooleanKind

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiBooleanType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Load)

Name
Create

Parent
TSepiBooleanType

Visibility
PUBLIC

Description
Crée un type booléen

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ABooleanKind : TBooleanKind = bkBoolean )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire
AName : STRING | Nom du type
ABooleanKind : TBooleanKind | Type de booléen (défaut : bkBoolean)

Sepi
Class Tree
Index
Previous (Clone)
Next (Load)


Sepi

Sepi
Previous (Create)
Next (Save)

Name
Load

Parent
TSepiBooleanType

Visibility
PUBLIC

Description
Charge un type booléen depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (ValueAsBoolean)

Name
Save

Parent
TSepiBooleanType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (ValueAsBoolean)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
ValueAsBoolean

Parent
TSepiBooleanType

Visibility
PUBLIC

Description
Lit une valeur de ce type comme valeur Boolean

Source code
function ValueAsBoolean ( const Value ) : Boolean

Parameters
Parameter | Description
Value : Untyped | Valeur à lire

Return
Types | Description
BOOLEAN | Valeur comme Boolean

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (ValueAsBoolean)
Next (WriteTypeInfo)

Name
ValueToString

Parent
TSepiBooleanType

Visibility
PUBLIC

Description
[@inheritedDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueAsBoolean)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (ValueToString)
Next

Name
WriteTypeInfo

Parent
TSepiBooleanType

Visibility
PROTECTED

Description
Construit les RTTI

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next


Sepi

Sepi
Previous (TSepiBooleanType)
Next (TSepiEnumType)

Name
TSepiCharType

Parent
SepiOrdTypes

Class Hierarchy
TSepiOrdType

Visibility
PUBLIC

Description
Type caractère

Members
Fields
Field | Description
FChrMaxValue (-) | Valeur maximale
FChrMinValue (-) | Valeur minimale
FIsUnicode (-) | Indique si le caractère est Unicode
FNeedRangeCheck (-) | Indique s'il faut vérifier les étendues

Methods
Method | Description
CheckInRange (+) | S'assure qu'une valeur est dans l'intervalle supporté par le type
Clone (+) | [@inheritDoc]
Create (+) | Crée un nouveau type caractère
GetDescription (#) | [@inheritDoc]
InRange (+) | Teste si une valeur est dans l'intervalle supporté par le type
SetupProperties (#) | [@inheritedDoc]
ValueToString (+) | [@inheritDoc]

Properties
Property | Description
ChrMaxValue (+) | Valeur maximale
ChrMinValue (+) | Valeur minimale
IsUnicode (+) | Indique si le caractère est Unicode
NeedRangeCheck (+) | Indique s'il faut vérifier les étendues

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBooleanType)
Next (TSepiEnumType)


Sepi

Sepi
Previous
Next (FChrMinValue)

Name
FChrMaxValue

Parent
TSepiCharType

Visibility
PRIVATE

Description
Valeur maximale

Source code
FChrMaxValue : WideChar

Sepi
Class Tree
Index
Previous
Next (FChrMinValue)


Sepi

Sepi
Previous (FChrMaxValue)
Next (FIsUnicode)

Name
FChrMinValue

Parent
TSepiCharType

Visibility
PRIVATE

Description
Valeur minimale

Source code
FChrMinValue : WideChar

Sepi
Class Tree
Index
Previous (FChrMaxValue)
Next (FIsUnicode)


Sepi

Sepi
Previous (FChrMinValue)
Next (FNeedRangeCheck)

Name
FIsUnicode

Parent
TSepiCharType

Visibility
PRIVATE

Description
Indique si le caractère est Unicode

Source code
FIsUnicode : Boolean

Sepi
Class Tree
Index
Previous (FChrMinValue)
Next (FNeedRangeCheck)


Sepi

Sepi
Previous (FIsUnicode)
Next

Name
FNeedRangeCheck

Parent
TSepiCharType

Visibility
PRIVATE

Description
Indique s'il faut vérifier les étendues

Source code
FNeedRangeCheck : Boolean

Sepi
Class Tree
Index
Previous (FIsUnicode)
Next


Sepi

Sepi
Previous
Next (ChrMinValue)

Name
ChrMaxValue

Parent
TSepiCharType

Visibility
PUBLIC

Description
Valeur maximale

Source code
property ChrMaxValue : WideChar read FChrMaxValue

Read Access
FChrMaxValue

Sepi
Class Tree
Index
Previous
Next (ChrMinValue)


Sepi

Sepi
Previous (ChrMaxValue)
Next (IsUnicode)

Name
ChrMinValue

Parent
TSepiCharType

Visibility
PUBLIC

Description
Valeur minimale

Source code
property ChrMinValue : WideChar read FChrMinValue

Read Access
FChrMinValue

Sepi
Class Tree
Index
Previous (ChrMaxValue)
Next (IsUnicode)


Sepi

Sepi
Previous (ChrMinValue)
Next (NeedRangeCheck)

Name
IsUnicode

Parent
TSepiCharType

Visibility
PUBLIC

Description
Indique si le caractère est Unicode

Source code
property IsUnicode : Boolean read FIsUnicode

Read Access
FIsUnicode

Sepi
Class Tree
Index
Previous (ChrMinValue)
Next (NeedRangeCheck)


Sepi

Sepi
Previous (IsUnicode)
Next

Name
NeedRangeCheck

Parent
TSepiCharType

Visibility
PUBLIC

Description
Indique s'il faut vérifier les étendues

Source code
property NeedRangeCheck : Boolean read FNeedRangeCheck

Read Access
FNeedRangeCheck

Sepi
Class Tree
Index
Previous (IsUnicode)
Next


Sepi

Sepi
Previous
Next (Clone)

Name
CheckInRange

Parent
TSepiCharType

Visibility
PUBLIC

Description
S'assure qu'une valeur est dans l'intervalle supporté par le type

Exception
ERangeError Value n'était pas dans l'intervalle supporté

Source code
procedure CheckInRange ( Value : WideChar )

Parameters
Parameter | Description
Value : WIDECHAR | Valeur à tester

Sepi
Class Tree
Index
Previous
Next (Clone)


Sepi

Sepi
Previous (CheckInRange)
Next (Create)

Name
Clone

Parent
TSepiCharType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckInRange)
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (GetDescription)

Name
Create

Parent
TSepiCharType

Visibility
PUBLIC

Description
Crée un nouveau type caractère

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AMinValue : WideChar = # 0 ; AMaxValue : WideChar = # 255 ; AForceUnicode : Boolean = False )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AMinValue : WIDECHAR | Valeur minimale
AMaxValue : WIDECHAR | Valeur maximale
AForceUnicode : BOOLEAN | Positionné à True, force l'utilisation d'Unicode

Sepi
Class Tree
Index
Previous (Clone)
Next (GetDescription)


Sepi

Sepi
Previous (Create)
Next (InRange)

Name
GetDescription

Parent
TSepiCharType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (InRange)


Sepi

Sepi
Previous (GetDescription)
Next (SetupProperties)

Name
InRange

Parent
TSepiCharType

Visibility
PUBLIC

Description
Teste si une valeur est dans l'intervalle supporté par le type

Source code
function InRange ( Value : WideChar ) : Boolean

Parameters
Parameter | Description
Value : WIDECHAR | Valeur à tester

Return
Types | Description
BOOLEAN | True si Value est dans l'intervalle supporté, False sinon

Sepi
Class Tree
Index
Previous (GetDescription)
Next (SetupProperties)


Sepi

Sepi
Previous (InRange)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiCharType

Visibility
PROTECTED

Description
[@inheritedDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (InRange)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next

Name
ValueToString

Parent
TSepiCharType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next


Sepi

Sepi
Previous (TSepiCharType)
Next (TSepiFakeEnumType)

Name
TSepiEnumType

Parent
SepiOrdTypes

Class Hierarchy
TSepiOrdType

Visibility
PUBLIC

Description
Type énumération

Members
Fields
Field | Description
FBaseType (-) | Type de base (peut être Self)
FValueCount (-) | Nombre de valeurs
FValues (-) | Noms des valeurs

Methods
Method | Description
Clone (+) | [@inheritDoc]
CompatibleWith (+) | [@inheritDoc]
Complete (#) | [@inheritDoc]
Create (+) | Crée un nouveau type énuméré
Create (+) | Crée un nouveau type énuméré basé sur un type existant
CreateConstants (-) | Crée les constantes énumérées
Equals (+) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
GetNames (-) | Tableau des noms par leurs valeurs
GetValues (-) | Tableau des valeurs par leurs noms
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un type énuméré depuis un flux
Save (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
BaseType (+) | Type de base (peut être Self)
Names (+) | Tableau des noms par leurs valeurs
ValueCount (+) | Nombre de valeurs
Values (+) | Tableau des valeurs par leurs noms

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCharType)
Next (TSepiFakeEnumType)


Sepi

Sepi
Previous
Next (FValueCount)

Name
FBaseType

Parent
TSepiEnumType

Visibility
PRIVATE

Description
Type de base (peut être Self)

Source code
FBaseType : TSepiEnumType

Sepi
Class Tree
Index
Previous
Next (FValueCount)


Sepi

Sepi
Previous (FBaseType)
Next (FValues)

Name
FValueCount

Parent
TSepiEnumType

Visibility
PRIVATE

Description
Nombre de valeurs

Source code
FValueCount : Integer

Sepi
Class Tree
Index
Previous (FBaseType)
Next (FValues)


Sepi

Sepi
Previous (FValueCount)
Next

Name
FValues

Parent
TSepiEnumType

Visibility
PRIVATE

Description
Noms des valeurs

Source code
FValues : TStringDynArray

Sepi
Class Tree
Index
Previous (FValueCount)
Next


Sepi

Sepi
Previous
Next (Names)

Name
BaseType

Parent
TSepiEnumType

Visibility
PUBLIC

Description
Type de base (peut être Self)

Source code
property BaseType : TSepiEnumType read FBaseType

Read Access
FBaseType

Sepi
Class Tree
Index
Previous
Next (Names)


Sepi

Sepi
Previous (BaseType)
Next (ValueCount)

Name
Names

Parent
TSepiEnumType

Visibility
PUBLIC

Description
Tableau des noms par leurs valeurs

Source code
property Names [ Value : Integer ] : string read GetNames

Read Access
GetNames

Sepi
Class Tree
Index
Previous (BaseType)
Next (ValueCount)


Sepi

Sepi
Previous (Names)
Next (Values)

Name
ValueCount

Parent
TSepiEnumType

Visibility
PUBLIC

Description
Nombre de valeurs

Source code
property ValueCount : Integer read FValueCount

Read Access
FValueCount

Sepi
Class Tree
Index
Previous (Names)
Next (Values)


Sepi

Sepi
Previous (ValueCount)
Next

Name
Values

Parent
TSepiEnumType

Visibility
PUBLIC

Description
Tableau des valeurs par leurs noms

Source code
property Values [ const Name : string ] : Integer read GetValues

Read Access
GetValues

Sepi
Class Tree
Index
Previous (ValueCount)
Next


Sepi

Sepi
Previous
Next (CompatibleWith)

Name
Clone

Parent
TSepiEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Complete)

Name
CompatibleWith

Parent
TSepiEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clone)
Next (Complete)


Sepi

Sepi
Previous (CompatibleWith)
Next (Create)

Name
Complete

Parent
TSepiEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Complete ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Create)

Name
Create

Parent
TSepiEnumType

Visibility
PUBLIC

Description
Crée un nouveau type énuméré

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; const AValues : array of string ; AMinEnumSize : TSepiMinEnumSize = mesByte ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AValues : STRING | Noms des éléments de l'énumération
AMinEnumSize : TSepiMinEnumSize

Sepi
Class Tree
Index
Previous (Complete)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (CreateConstants)

Name
Create

Parent
TSepiEnumType

Visibility
PUBLIC

Description
Crée un nouveau type énuméré basé sur un type existant

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ABaseType : TSepiEnumType ; AMinValue , AMaxValue : Integer ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
ABaseType : TSepiEnumType | Type énuméré de base
AMinValue : INTEGER | Valeur minimale
AMaxValue : INTEGER | Valeur maximale

Sepi
Class Tree
Index
Previous (Create)
Next (CreateConstants)


Sepi

Sepi
Previous (Create)
Next (Equals)

Name
CreateConstants

Parent
TSepiEnumType

Visibility
PRIVATE

Description
Crée les constantes énumérées

Source code
procedure CreateConstants

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Equals)


Sepi

Sepi
Previous (CreateConstants)
Next (GetDescription)

Name
Equals

Parent
TSepiEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateConstants)
Next (GetDescription)


Sepi

Sepi
Previous (Equals)
Next (GetNames)

Name
GetDescription

Parent
TSepiEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetNames)


Sepi

Sepi
Previous (GetDescription)
Next (GetValues)

Name
GetNames

Parent
TSepiEnumType

Visibility
PRIVATE

Description
Tableau des noms par leurs valeurs

Source code
function GetNames ( Value : Integer ) : string

Parameters
Parameter | Description
Value : INTEGER | Valeur d'élément d'énumération

Return
Types | Description
STRING | Nom de la valeur Value

Sepi
Class Tree
Index
Previous (GetDescription)
Next (GetValues)


Sepi

Sepi
Previous (GetNames)
Next (ListReferences)

Name
GetValues

Parent
TSepiEnumType

Visibility
PRIVATE

Description
Tableau des valeurs par leurs noms

Source code
function GetValues ( const Name : string ) : Integer

Parameters
Parameter | Description
NAME : STRING | Nom d'élément d'énumération

Return
Types | Description
INTEGER | Valeur du nom donné

Sepi
Class Tree
Index
Previous (GetNames)
Next (ListReferences)


Sepi

Sepi
Previous (GetValues)
Next (Load)

Name
ListReferences

Parent
TSepiEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetValues)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiEnumType

Visibility
PUBLIC

Description
Charge un type énuméré depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (ValueToString)

Name
Save

Parent
TSepiEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (ValueToString)


Sepi

Sepi
Previous (Save)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiEnumType)
Next (TSepiFakeEnumValue)

Name
TSepiFakeEnumType

Parent
SepiOrdTypes

Class Hierarchy
TSepiOrdType

Visibility
PUBLIC

Description
Fausse énumération

Members
Fields
Field | Description
FValueCount (-) | Nombre de valeurs
FValues (-) | Valeurs

Methods
Method | Description
CompatibleWith (+) | [@inheritDoc]
Complete (#) | [@inheritDoc]
Create (+) | Crée un type fausse énumération
CreateConstants (-) | Crée les constantes énumérées
Equals (+) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
GetValues (-) | Tableau zero-based des valeurs de ce type fausse énumération
Load (+) | [@inheritDoc]
Save (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
ValueCount (+) | Nombre de valeurs
Values (+) | Tableau zero-based des valeurs de ce type fausse énumération

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiEnumType)
Next (TSepiFakeEnumValue)


Sepi

Sepi
Previous
Next (FValues)

Name
FValueCount

Parent
TSepiFakeEnumType

Visibility
PRIVATE

Description
Nombre de valeurs

Source code
FValueCount : Integer

Sepi
Class Tree
Index
Previous
Next (FValues)


Sepi

Sepi
Previous (FValueCount)
Next

Name
FValues

Parent
TSepiFakeEnumType

Visibility
PRIVATE

Description
Valeurs

Source code
FValues : TSepiFakeEnumValueDynArray

Sepi
Class Tree
Index
Previous (FValueCount)
Next


Sepi

Sepi
Previous
Next (Values)

Name
ValueCount

Parent
TSepiFakeEnumType

Visibility
PUBLIC

Description
Nombre de valeurs

Source code
property ValueCount : Integer read FValueCount

Read Access
FValueCount

Sepi
Class Tree
Index
Previous
Next (Values)


Sepi

Sepi
Previous (ValueCount)
Next

Name
Values

Parent
TSepiFakeEnumType

Visibility
PUBLIC

Description
Tableau zero-based des valeurs de ce type fausse énumération

Source code
property Values [ Index : Integer ] : TSepiFakeEnumValue read GetValues

Read Access
GetValues

Sepi
Class Tree
Index
Previous (ValueCount)
Next


Sepi

Sepi
Previous
Next (Complete)

Name
CompatibleWith

Parent
TSepiFakeEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Complete)


Sepi

Sepi
Previous (CompatibleWith)
Next (Create)

Name
Complete

Parent
TSepiFakeEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Complete ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (CreateConstants)

Name
Create

Parent
TSepiFakeEnumType

Visibility
PUBLIC

Description
Crée un type fausse énumération

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; const AValues : array of TSepiFakeEnumValue ; AMinEnumSize : TSepiMinEnumSize = mesByte )

Parameters
Parameter | Description
AOwner : TSepiComponent | Composant propriétaire
AName : STRING | Nom du type
AValues : TSepiFakeEnumValue | Valeurs du type
AMinEnumSize : TSepiMinEnumSize

Sepi
Class Tree
Index
Previous (Complete)
Next (CreateConstants)


Sepi

Sepi
Previous (Create)
Next (Equals)

Name
CreateConstants

Parent
TSepiFakeEnumType

Visibility
PRIVATE

Description
Crée les constantes énumérées

Source code
procedure CreateConstants

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Equals)


Sepi

Sepi
Previous (CreateConstants)
Next (GetDescription)

Name
Equals

Parent
TSepiFakeEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CreateConstants)
Next (GetDescription)


Sepi

Sepi
Previous (Equals)
Next (GetValues)

Name
GetDescription

Parent
TSepiFakeEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetValues)


Sepi

Sepi
Previous (GetDescription)
Next (Load)

Name
GetValues

Parent
TSepiFakeEnumType

Visibility
PRIVATE

Description
Tableau zero-based des valeurs de ce type fausse énumération

Source code
function GetValues ( Index : Integer ) : TSepiFakeEnumValue

Parameters
Parameter | Description
INDEX : INTEGER | Index compris entre 0 inclus et ValueCount exclu

Return
Types | Description
TSepiFakeEnumValue | La valeur à l'index spécifié

Sepi
Class Tree
Index
Previous (GetDescription)
Next (Load)


Sepi

Sepi
Previous (GetValues)
Next (Save)

Name
Load

Parent
TSepiFakeEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetValues)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (ValueToString)

Name
Save

Parent
TSepiFakeEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (ValueToString)


Sepi

Sepi
Previous (Save)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiFakeEnumType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next

Name
WriteDigestData

Parent
TSepiFakeEnumType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next


Sepi

Sepi
Previous (TSepiFakeEnumType)
Next (TSepiFloatType)

Name
TSepiFakeEnumValue

Parent
SepiOrdTypes

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Valeur d'un faux enum

Members
Fields
Field | Description
NAME (*) | Name of the value
Value (*) | Ordinal value of this value

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFakeEnumType)
Next (TSepiFloatType)


Sepi

Sepi
Previous
Next (Value)

Name
NAME

Parent
TSepiFakeEnumValue

Visibility
PUBLISHED

Description
Name of the value

Source code
Name : string

Sepi
Class Tree
Index
Previous
Next (Value)


Sepi

Sepi
Previous (NAME)
Next

Name
Value

Parent
TSepiFakeEnumValue

Visibility
PUBLISHED

Description
Ordinal value of this value

Source code
Value : Longint

Sepi
Class Tree
Index
Previous (NAME)
Next


Sepi

Sepi
Previous (TSepiFakeEnumValue)
Next (TSepiInt64Type)

Name
TSepiFloatType

Parent
SepiOrdTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type nombre à virgule flottante

Members
Fields
Field | Description
FFloatType (-) | Type de flottant

Methods
Method | Description
Clone (+) | [@inheritDoc]
Create (+) | Crée un nouveau type flottant
Equals (+) | [@inheritDoc]
GetAlignment (#) | [@inheritDoc]
Load (+) | Charge un type flottant depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
SetValueAsExtended (+) | Enregistre une valeur de ce type comme Extended
ValueAsExtended (+) | Lit une valeur de ce type comme valeur Extended
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
FloatType (+) | Type de flottant

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFakeEnumValue)
Next (TSepiInt64Type)


Sepi

Sepi
Previous
Next

Name
FFloatType

Parent
TSepiFloatType

Visibility
PRIVATE

Description
Type de flottant

Source code
FFloatType : TFloatType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
FloatType

Parent
TSepiFloatType

Visibility
PUBLIC

Description
Type de flottant

Source code
property FloatType : TFloatType read FFloatType

Read Access
FFloatType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiFloatType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Equals)

Name
Create

Parent
TSepiFloatType

Visibility
PUBLIC

Description
Crée un nouveau type flottant

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AFloatType : TFloatType = ftDouble )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AFloatType : TFloatType | Type de flottant

Sepi
Class Tree
Index
Previous (Clone)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (GetAlignment)

Name
Equals

Parent
TSepiFloatType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetAlignment)


Sepi

Sepi
Previous (Equals)
Next (Load)

Name
GetAlignment

Parent
TSepiFloatType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (Load)


Sepi

Sepi
Previous (GetAlignment)
Next (Save)

Name
Load

Parent
TSepiFloatType

Visibility
PUBLIC

Description
Charge un type flottant depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAlignment)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiFloatType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (SetValueAsExtended)

Name
SetupProperties

Parent
TSepiFloatType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (SetValueAsExtended)


Sepi

Sepi
Previous (SetupProperties)
Next (ValueAsExtended)

Name
SetValueAsExtended

Parent
TSepiFloatType

Visibility
PUBLIC

Description
Enregistre une valeur de ce type comme Extended

Source code
procedure SetValueAsExtended ( var Dest ; Source : Extended )

Parameters
Parameter | Description
Dest : Untyped | Valeur destination
Source : EXTENDED | Source

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (ValueAsExtended)


Sepi

Sepi
Previous (SetValueAsExtended)
Next (ValueToString)

Name
ValueAsExtended

Parent
TSepiFloatType

Visibility
PUBLIC

Description
Lit une valeur de ce type comme valeur Extended

Source code
function ValueAsExtended ( const Value ) : Extended

Parameters
Parameter | Description
Value : Untyped | Valeur à lire

Return
Types | Description
EXTENDED | Valeur comme Extended

Sepi
Class Tree
Index
Previous (SetValueAsExtended)
Next (ValueToString)


Sepi

Sepi
Previous (ValueAsExtended)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiFloatType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueAsExtended)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiFloatType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiFloatType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiFloatType)
Next (TSepiIntegerType)

Name
TSepiInt64Type

Parent
SepiOrdTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type entier long (64 bits)

Members
Fields
Field | Description
FMaxValue (-) | Valeur maximale
FMinValue (-) | Valeur minimale
FNeedRangeCheck (-) | Indique s'il faut vérifier les étendues

Methods
Method | Description
CheckInRange (+) | S'assure qu'une valeur est dans l'intervalle supporté par le type
Clone (+) | [@inheritDoc]
Create (+) | Crée un nouveau type entier 64 bits
GetDescription (#) | [@inheritDoc]
InRange (+) | Teste si une valeur est dans l'intervalle supporté par le type
Load (+) | Charge un type entier 64 bits depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritedDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritedDoc]

Properties
Property | Description
MaxValue (+) | Valeur maximale
MinValue (+) | Valeur minimale
NeedRangeCheck (+) | Indique s'il faut vérifier les étendues

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFloatType)
Next (TSepiIntegerType)


Sepi

Sepi
Previous
Next (FMinValue)

Name
FMaxValue

Parent
TSepiInt64Type

Visibility
PRIVATE

Description
Valeur maximale

Source code
FMaxValue : Int64

Sepi
Class Tree
Index
Previous
Next (FMinValue)


Sepi

Sepi
Previous (FMaxValue)
Next (FNeedRangeCheck)

Name
FMinValue

Parent
TSepiInt64Type

Visibility
PRIVATE

Description
Valeur minimale

Source code
FMinValue : Int64

Sepi
Class Tree
Index
Previous (FMaxValue)
Next (FNeedRangeCheck)


Sepi

Sepi
Previous (FMinValue)
Next

Name
FNeedRangeCheck

Parent
TSepiInt64Type

Visibility
PRIVATE

Description
Indique s'il faut vérifier les étendues

Source code
FNeedRangeCheck : Boolean

Sepi
Class Tree
Index
Previous (FMinValue)
Next


Sepi

Sepi
Previous
Next (MinValue)

Name
MaxValue

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
Valeur maximale

Source code
property MaxValue : Int64 read FMaxValue

Read Access
FMaxValue

Sepi
Class Tree
Index
Previous
Next (MinValue)


Sepi

Sepi
Previous (MaxValue)
Next (NeedRangeCheck)

Name
MinValue

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
Valeur minimale

Source code
property MinValue : Int64 read FMinValue

Read Access
FMinValue

Sepi
Class Tree
Index
Previous (MaxValue)
Next (NeedRangeCheck)


Sepi

Sepi
Previous (MinValue)
Next

Name
NeedRangeCheck

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
Indique s'il faut vérifier les étendues

Source code
property NeedRangeCheck : Boolean read FNeedRangeCheck

Read Access
FNeedRangeCheck

Sepi
Class Tree
Index
Previous (MinValue)
Next


Sepi

Sepi
Previous
Next (Clone)

Name
CheckInRange

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
S'assure qu'une valeur est dans l'intervalle supporté par le type

Exception
ERangeError Value n'était pas dans l'intervalle supporté

Source code
procedure CheckInRange ( Value : Int64 )

Parameters
Parameter | Description
Value : INT64 | Valeur à tester

Sepi
Class Tree
Index
Previous
Next (Clone)


Sepi

Sepi
Previous (CheckInRange)
Next (Create)

Name
Clone

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckInRange)
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (GetDescription)

Name
Create

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
Crée un nouveau type entier 64 bits

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AMinValue : Int64 = MinInt64 ; AMaxValue : Int64 = MaxInt64 )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AMinValue : INT64 | Valeur minimale
AMaxValue : INT64 | Valeur maximale

Sepi
Class Tree
Index
Previous (Clone)
Next (GetDescription)


Sepi

Sepi
Previous (Create)
Next (InRange)

Name
GetDescription

Parent
TSepiInt64Type

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (InRange)


Sepi

Sepi
Previous (GetDescription)
Next (Load)

Name
InRange

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
Teste si une valeur est dans l'intervalle supporté par le type

Source code
function InRange ( Value : Int64 ) : Boolean

Parameters
Parameter | Description
Value : INT64 | Valeur à tester

Return
Types | Description
BOOLEAN | True si Value est dans l'intervalle supporté, False sinon

Sepi
Class Tree
Index
Previous (GetDescription)
Next (Load)


Sepi

Sepi
Previous (InRange)
Next (Save)

Name
Load

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
Charge un type entier 64 bits depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InRange)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiInt64Type

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiInt64Type

Visibility
PROTECTED

Description
[@inheritedDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiInt64Type

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiInt64Type

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiInt64Type

Visibility
PROTECTED

Description
[@inheritedDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiInt64Type)
Next (TSepiOrdType)

Name
TSepiIntegerType

Parent
SepiOrdTypes

Class Hierarchy
TSepiOrdType

Visibility
PUBLIC

Description
Type entier

Members
Fields
Field | Description
FNeedRangeCheck (-) | Indique s'il faut vérifier les étendues
FSigned (-) | Indique si l'entier est signé ou non

Methods
Method | Description
CheckInRange (+) | S'assure qu'une valeur est dans l'intervalle supporté par le type
Clone (+) | [@inheritDoc]
Create (+) | Crée un nouveau type entier
GetDescription (#) | [@inheritDoc]
InRange (+) | Teste si une valeur est dans l'intervalle supporté par le type
InRange (+) | Teste si une valeur est dans l'intervalle supporté par le type
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]

Properties
Property | Description
NeedRangeCheck (+) | Indique s'il faut vérifier les étendues
Signed (+) | Indique si l'entier est signé ou non

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInt64Type)
Next (TSepiOrdType)


Sepi

Sepi
Previous
Next (FSigned)

Name
FNeedRangeCheck

Parent
TSepiIntegerType

Visibility
PRIVATE

Description
Indique s'il faut vérifier les étendues

Source code
FNeedRangeCheck : Boolean

Sepi
Class Tree
Index
Previous
Next (FSigned)


Sepi

Sepi
Previous (FNeedRangeCheck)
Next

Name
FSigned

Parent
TSepiIntegerType

Visibility
PRIVATE

Description
Indique si l'entier est signé ou non

Source code
FSigned : Boolean

Sepi
Class Tree
Index
Previous (FNeedRangeCheck)
Next


Sepi

Sepi
Previous
Next (Signed)

Name
NeedRangeCheck

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
Indique s'il faut vérifier les étendues

Source code
property NeedRangeCheck : Boolean read FNeedRangeCheck

Read Access
FNeedRangeCheck

Sepi
Class Tree
Index
Previous
Next (Signed)


Sepi

Sepi
Previous (NeedRangeCheck)
Next

Name
Signed

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
Indique si l'entier est signé ou non

Source code
property Signed : Boolean read FSigned

Read Access
FSigned

Sepi
Class Tree
Index
Previous (NeedRangeCheck)
Next


Sepi

Sepi
Previous
Next (Clone)

Name
CheckInRange

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
S'assure qu'une valeur est dans l'intervalle supporté par le type

Exception
ERangeError Value n'était pas dans l'intervalle supporté

Source code
procedure CheckInRange ( Value : Longint )

Parameters
Parameter | Description
Value : LONGINT | Valeur à tester

Sepi
Class Tree
Index
Previous
Next (Clone)


Sepi

Sepi
Previous (CheckInRange)
Next (Create)

Name
Clone

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CheckInRange)
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (GetDescription)

Name
Create

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
Crée un nouveau type entier

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AMinValue : Longint = - MaxInt - 1 ; AMaxValue : Longint = MaxInt )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AMinValue : LONGINT | Valeur minimale
AMaxValue : LONGINT | Valeur maximale

Sepi
Class Tree
Index
Previous (Clone)
Next (GetDescription)


Sepi

Sepi
Previous (Create)
Next (InRange)

Name
GetDescription

Parent
TSepiIntegerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (InRange)


Sepi

Sepi
Previous (GetDescription)
Next (InRange)

Name
InRange

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
Teste si une valeur est dans l'intervalle supporté par le type

Source code
function InRange ( Value : Int64 ) : Boolean ; overload

Parameters
Parameter | Description
Value : INT64 | Valeur à tester

Return
Types | Description
BOOLEAN | True si Value est dans l'intervalle supporté, False sinon

Sepi
Class Tree
Index
Previous (GetDescription)
Next (InRange)


Sepi

Sepi
Previous (InRange)
Next (SetupProperties)

Name
InRange

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
Teste si une valeur est dans l'intervalle supporté par le type

Source code
function InRange ( Value : Longint ) : Boolean ; overload

Parameters
Parameter | Description
Value : LONGINT | Valeur à tester

Return
Types | Description
BOOLEAN | True si Value est dans l'intervalle supporté, False sinon

Sepi
Class Tree
Index
Previous (InRange)
Next (SetupProperties)


Sepi

Sepi
Previous (InRange)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiIntegerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (InRange)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next

Name
ValueToString

Parent
TSepiIntegerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next


Sepi

Sepi
Previous (TSepiIntegerType)
Next (TSepiPointerType)

Name
TSepiOrdType

Parent
SepiOrdTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type ordinal

Members
Fields
Field | Description
FMaxValue (-) | Valeur maximale
FMinValue (-) | Valeur minimale
FOrdType (-) | Type d'ordinal

Methods
Method | Description
Create (+) | #No TAG found in source code#
Create (+) | #No TAG found in source code#
Equals (+) | [@inheritDoc]
Load (+) | [@inheritDoc]
Save (#) | [@inheritDoc]
SetupProperties (#) | Spécifie les propriétés du type
ValueAsCardinal (+) | Lit une valeur de ce type comme un Cardinal
ValueAsInteger (+) | Lit une valeur de ce type comme un Integer
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
MaxValue (+) | Valeur maximale
MinValue (+) | Valeur minimale
OrdType (+) | Type d'ordinal

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIntegerType)
Next (TSepiPointerType)


Sepi

Sepi
Previous
Next (FMinValue)

Name
FMaxValue

Parent
TSepiOrdType

Visibility
PRIVATE

Description
Valeur maximale

Source code
FMaxValue : Longint

Sepi
Class Tree
Index
Previous
Next (FMinValue)


Sepi

Sepi
Previous (FMaxValue)
Next (FOrdType)

Name
FMinValue

Parent
TSepiOrdType

Visibility
PRIVATE

Description
Valeur minimale

Source code
FMinValue : Longint

Sepi
Class Tree
Index
Previous (FMaxValue)
Next (FOrdType)


Sepi

Sepi
Previous (FMinValue)
Next

Name
FOrdType

Parent
TSepiOrdType

Visibility
PRIVATE

Description
Type d'ordinal

Source code
FOrdType : TOrdType

Sepi
Class Tree
Index
Previous (FMinValue)
Next


Sepi

Sepi
Previous
Next (MinValue)

Name
MaxValue

Parent
TSepiOrdType

Visibility
PUBLIC

Description
Valeur maximale

Source code
property MaxValue : Longint read FMaxValue

Read Access
FMaxValue

Sepi
Class Tree
Index
Previous
Next (MinValue)


Sepi

Sepi
Previous (MaxValue)
Next (OrdType)

Name
MinValue

Parent
TSepiOrdType

Visibility
PUBLIC

Description
Valeur minimale

Source code
property MinValue : Longint read FMinValue

Read Access
FMinValue

Sepi
Class Tree
Index
Previous (MaxValue)
Next (OrdType)


Sepi

Sepi
Previous (MinValue)
Next

Name
OrdType

Parent
TSepiOrdType

Visibility
PUBLIC

Description
Type d'ordinal

Source code
property OrdType : TOrdType read FOrdType

Read Access
FOrdType

Sepi
Class Tree
Index
Previous (MinValue)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TSepiOrdType

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AKind : TTypeKind ; AOrdType : TOrdType ; AMinValue , AMaxValue : Longint ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
AKind : TTypeKind | #Pas de TAG trouvé dans le code source#
AOrdType : TOrdType | #Pas de TAG trouvé dans le code source#
AMinValue : LONGINT | #Pas de TAG trouvé dans le code source#
AMaxValue : LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Equals)

Name
Create

Parent
TSepiOrdType

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AKind : TTypeKind ; AMinValue , AMaxValue : Longint ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
AKind : TTypeKind | #Pas de TAG trouvé dans le code source#
AMinValue : LONGINT | #Pas de TAG trouvé dans le code source#
AMaxValue : LONGINT | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (Load)

Name
Equals

Parent
TSepiOrdType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (Load)


Sepi

Sepi
Previous (Equals)
Next (Save)

Name
Load

Parent
TSepiOrdType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiOrdType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueAsCardinal)

Name
SetupProperties

Parent
TSepiOrdType

Visibility
PROTECTED

Description
Spécifie les propriétés du type

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueAsCardinal)


Sepi

Sepi
Previous (SetupProperties)
Next (ValueAsInteger)

Name
ValueAsCardinal

Parent
TSepiOrdType

Visibility
PUBLIC

Description
Lit une valeur de ce type comme un Cardinal

Source code
function ValueAsCardinal ( const Value ) : Cardinal

Parameters
Parameter | Description
Value : Untyped | Valeur de ce type

Return
Types | Description
CARDINAL | Value comme Cardinal

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (ValueAsInteger)


Sepi

Sepi
Previous (ValueAsCardinal)
Next (WriteDigestData)

Name
ValueAsInteger

Parent
TSepiOrdType

Visibility
PUBLIC

Description
Lit une valeur de ce type comme un Integer

Source code
function ValueAsInteger ( const Value ) : Integer

Parameters
Parameter | Description
Value : Untyped | Valeur de ce type

Return
Types | Description
INTEGER | Value comme Integer

Sepi
Class Tree
Index
Previous (ValueAsCardinal)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueAsInteger)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiOrdType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueAsInteger)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiOrdType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiOrdType)
Next (TSepiSetType)

Name
TSepiPointerType

Parent
SepiOrdTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type pointeur

Members
Fields
Field | Description
FIsUntyped (-) | Indique si c'est un pointeur non typé
FPointTo (-) | Type vers lequel pointe le pointeur

Methods
Method | Description
Clone (+) | [@inheritDoc]
Create (+) | Crée un nouveau type pointeur
Equals (+) | [@inheritDoc]
ForwardDecl (+) | Déclare un type pointeur en forward
GetDescription (#) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un type pointeur depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
IsUntyped (+) | Indique si c'est un pointeur non typé
PointTo (+) | Type vers lequel pointe le pointeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOrdType)
Next (TSepiSetType)


Sepi

Sepi
Previous
Next (FPointTo)

Name
FIsUntyped

Parent
TSepiPointerType

Visibility
PRIVATE

Description
Indique si c'est un pointeur non typé

Source code
FIsUntyped : Boolean

Sepi
Class Tree
Index
Previous
Next (FPointTo)


Sepi

Sepi
Previous (FIsUntyped)
Next

Name
FPointTo

Parent
TSepiPointerType

Visibility
PRIVATE

Description
Type vers lequel pointe le pointeur

Source code
FPointTo : TSepiType

Sepi
Class Tree
Index
Previous (FIsUntyped)
Next


Sepi

Sepi
Previous
Next (PointTo)

Name
IsUntyped

Parent
TSepiPointerType

Visibility
PUBLIC

Description
Indique si c'est un pointeur non typé

Source code
property IsUntyped : Boolean read FIsUntyped

Read Access
FIsUntyped

Sepi
Class Tree
Index
Previous
Next (PointTo)


Sepi

Sepi
Previous (IsUntyped)
Next

Name
PointTo

Parent
TSepiPointerType

Visibility
PUBLIC

Description
Type vers lequel pointe le pointeur

Source code
property PointTo : TSepiType read FPointTo

Read Access
FPointTo

Sepi
Class Tree
Index
Previous (IsUntyped)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiPointerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Equals)

Name
Create

Parent
TSepiPointerType

Visibility
PUBLIC

Description
Crée un nouveau type pointeur

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; APointTo : TSepiType )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
APointTo : TSepiType | Type vers lequel pointe le pointeur

Sepi
Class Tree
Index
Previous (Clone)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (ForwardDecl)

Name
Equals

Parent
TSepiPointerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (ForwardDecl)


Sepi

Sepi
Previous (Equals)
Next (GetDescription)

Name
ForwardDecl

Parent
TSepiPointerType

Visibility
PUBLIC

Description
Déclare un type pointeur en forward

Source code
class function ForwardDecl ( AOwner : TSepiComponent ; const AName : string ) : TSepiPointerType

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type pointeur

Return
Types | Description
TSepiPointerType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetDescription)


Sepi

Sepi
Previous (ForwardDecl)
Next (ListReferences)

Name
GetDescription

Parent
TSepiPointerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ForwardDecl)
Next (ListReferences)


Sepi

Sepi
Previous (GetDescription)
Next (Load)

Name
ListReferences

Parent
TSepiPointerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetDescription)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiPointerType

Visibility
PUBLIC

Description
Charge un type pointeur depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiPointerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiPointerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiPointerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiPointerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiPointerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiPointerType)
Next

Name
TSepiSetType

Parent
SepiOrdTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type ensemble

Members
Fields
Field | Description
FCompType (-) | Type des éléments

Methods
Method | Description
Clone (+) | [@inheritDoc]
CompatibleWith (+) | [@inheritDoc]
Create (+) | Crée un nouveau type ensemble
Equals (+) | [@inheritDoc]
GetAlignment (#) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un type ensemble depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
CompType (+) | Type des éléments

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPointerType)
Next


Sepi

Sepi
Previous
Next

Name
FCompType

Parent
TSepiSetType

Visibility
PRIVATE

Description
Type des éléments

Source code
FCompType : TSepiOrdType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CompType

Parent
TSepiSetType

Visibility
PUBLIC

Description
Type des éléments

Source code
property CompType : TSepiOrdType read FCompType

Read Access
FCompType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompatibleWith)

Name
Clone

Parent
TSepiSetType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
CompatibleWith

Parent
TSepiSetType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (Equals)

Name
Create

Parent
TSepiSetType

Visibility
PUBLIC

Description
Crée un nouveau type ensemble

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ACompType : TSepiOrdType )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
ACompType : TSepiOrdType | Type des éléments de l'ensemble

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (GetAlignment)

Name
Equals

Parent
TSepiSetType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetAlignment)


Sepi

Sepi
Previous (Equals)
Next (GetDescription)

Name
GetAlignment

Parent
TSepiSetType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetDescription)


Sepi

Sepi
Previous (GetAlignment)
Next (ListReferences)

Name
GetDescription

Parent
TSepiSetType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAlignment)
Next (ListReferences)


Sepi

Sepi
Previous (GetDescription)
Next (Load)

Name
ListReferences

Parent
TSepiSetType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetDescription)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiSetType

Visibility
PUBLIC

Description
Charge un type ensemble depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiSetType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiSetType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiSetType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiSetType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiSetType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous
Next (TSepiFakeEnumValueDynArray)

Name
TBooleanKind

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Type de booléen

Source code
TBooleanKind = ( bkBoolean , bkByteBool , bkWordBool , bkLongBool ) ;

Sepi
Class Tree
Index
Previous
Next (TSepiFakeEnumValueDynArray)


Sepi

Sepi
Previous (TBooleanKind)
Next (TSepiMinEnumSize)

Name
TSepiFakeEnumValueDynArray

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Tableau de valeurs d'un faux enum

Source code
TSepiFakeEnumValueDynArray = array of TSepiFakeEnumValue ;

Sepi
Class Tree
Index
Previous (TBooleanKind)
Next (TSepiMinEnumSize)


Sepi

Sepi
Previous (TSepiFakeEnumValueDynArray)
Next

Name
TSepiMinEnumSize

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Taille minimale d'un type énuméré

Source code
TSepiMinEnumSize = ( mesByte , mesWord , mesLongWord ) ;

Sepi
Class Tree
Index
Previous (TSepiFakeEnumValueDynArray)
Next


Sepi

Sepi
Previous
Next (MinInt64)

Name
MaxInt64

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
MaxInt64 = Int64 ( $7FFFFFFFFFFFFFFF )

Sepi
Class Tree
Index
Previous
Next (MinInt64)


Sepi

Sepi
Previous (MaxInt64)
Next (otUnknown)

Name
MinInt64

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
MinInt64 = Int64 ( $8000000000000000 )

Sepi
Class Tree
Index
Previous (MaxInt64)
Next (otUnknown)


Sepi

Sepi
Previous (MinInt64)
Next

Name
otUnknown

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
otUnknown = TOrdType ( - 1 )

Sepi
Class Tree
Index
Previous (MinInt64)
Next


Sepi

Sepi
Previous
Next (IntegerSize)

Name
CardinalSize

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Calcule la taille en octets d'un entier non signé

Source code
function CardinalSize ( Value : Cardinal ; ZeroGivesZero : Boolean = False ) : Integer

Parameters
Parameter | Description
Value : CARDINAL | Entier non signé
ZeroGivesZero : BOOLEAN | Si True, alors Value = 0 renvoie 0

Return
Types | Description
INTEGER | Taille de l'entier non signé

Sepi
Class Tree
Index
Previous
Next (IntegerSize)


Sepi

Sepi
Previous (CardinalSize)
Next (IsIntegerType)

Name
IntegerSize

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Calcule la taille en octets d'un entier signé

Source code
function IntegerSize ( Value : Integer ; ZeroGivesZero : Boolean = False ) : Integer

Parameters
Parameter | Description
Value : INTEGER | Entier signé
ZeroGivesZero : BOOLEAN | Si True, alors Value = 0 renvoie 0

Return
Types | Description
INTEGER | Taille de l'entier signé

Sepi
Class Tree
Index
Previous (CardinalSize)
Next (IsIntegerType)


Sepi

Sepi
Previous (IntegerSize)
Next (ValueAsCardinal)

Name
IsIntegerType

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Teste si un type donné est un type entier (TSepiIntegerType ou TSepiInt64Type)

Source code
function IsIntegerType ( SepiType : TSepiType ) : Boolean ; inline

Parameters
Parameter | Description
SepiType : TSepiType | Type à tester

Return
Types | Description
BOOLEAN | True si SepiType est un type entier, False sinon

Sepi
Class Tree
Index
Previous (IntegerSize)
Next (ValueAsCardinal)


Sepi

Sepi
Previous (IsIntegerType)
Next (ValueAsCardinal)

Name
ValueAsCardinal

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Lit une valeur ordinale comme un Cardinal

Source code
function ValueAsCardinal ( const Value ; Size : Integer ) : Cardinal ; overload

Parameters
Parameter | Description
Value : Untyped | Valeur de ce type
Size : INTEGER | Taille du type (1, 2 ou 4)

Return
Types | Description
CARDINAL | Value comme Cardinal

Sepi
Class Tree
Index
Previous (IsIntegerType)
Next (ValueAsCardinal)


Sepi

Sepi
Previous (ValueAsCardinal)
Next (ValueAsInteger)

Name
ValueAsCardinal

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Lit une valeur ordinale comme un Cardinal

Source code
function ValueAsCardinal ( const Value ; OrdType : TOrdType ) : Cardinal ; overload

Parameters
Parameter | Description
Value : Untyped | Valeur de ce type
OrdType : TOrdType | Type d'ordinal

Return
Types | Description
CARDINAL | Value comme Cardinal

Sepi
Class Tree
Index
Previous (ValueAsCardinal)
Next (ValueAsInteger)


Sepi

Sepi
Previous (ValueAsCardinal)
Next (ValueAsInteger)

Name
ValueAsInteger

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Lit une valeur ordinale comme un Integer

Source code
function ValueAsInteger ( const Value ; OrdType : TOrdType ) : Integer ; overload

Parameters
Parameter | Description
Value : Untyped | Valeur de ce type
OrdType : TOrdType | Type d'ordinal

Return
Types | Description
INTEGER | Value comme Integer

Sepi
Class Tree
Index
Previous (ValueAsCardinal)
Next (ValueAsInteger)


Sepi

Sepi
Previous (ValueAsInteger)
Next

Name
ValueAsInteger

Parent
SepiOrdTypes

Visibility
PUBLIC

Description
Lit une valeur ordinale comme un Integer

Source code
function ValueAsInteger ( const Value ; Size : Integer ) : Integer ; overload

Parameters
Parameter | Description
Value : Untyped | Valeur de ce type
Size : INTEGER | Taille du type (1, 2 ou 4)

Return
Types | Description
INTEGER | Value comme Integer

Sepi
Class Tree
Index
Previous (ValueAsInteger)
Next


Sepi

Sepi
Previous (SepiOrdTypes)
Next (SepiParseTrees)

Name
SepiParserUtils

Parent
Sepi

Description
Utilitaires d'analyse syntaxique Sepi

Author
sjrd

Version
1.0

Classes
Class | Description
TSepiCustomParser (+) | Classe de base pour les analyseurs syntaxiques Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiOrdTypes)
Next (SepiParseTrees)


Sepi

Sepi
Previous
Next

Name
TSepiCustomParser

Parent
SepiParserUtils

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Classe de base pour les analyseurs syntaxiques Sepi

Members
Fields
Field | Description
FErrors (-) | Erreurs de compilation
FLexer (-) | Analyseur lexical source

Methods
Method | Description
Create (+) | Crée un analyseur syntaxique
CreateDefaultLexer (#) | Crée un analyseur lexical par défaut pour cet analyseur syntaxique
Destroy (+) | [@inheritDoc]
GetCurTerminal (-) | Terminal courant
InternalParse (#) | Analyse syntaxique proprement dite
MakeSyntaxError (#) | Produit une erreur syntaxique
Parse (+) | Analyse un code source, en utilisant l'analyseur lexical par défaut
Parse (+) | Analyse un code source

Properties
Property | Description
CurTerminal (+) | Terminal courant
Errors (+) | Erreurs de compilation
Lexer (#) | Analyseur lexical source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FLexer)

Name
FErrors

Parent
TSepiCustomParser

Visibility
PRIVATE

Description
Erreurs de compilation

Source code
FErrors : TSepiCompilerErrorList

Sepi
Class Tree
Index
Previous
Next (FLexer)


Sepi

Sepi
Previous (FErrors)
Next

Name
FLexer

Parent
TSepiCustomParser

Visibility
PRIVATE

Description
Analyseur lexical source

Source code
FLexer : TSepiCustomLexer

Sepi
Class Tree
Index
Previous (FErrors)
Next


Sepi

Sepi
Previous
Next (Errors)

Name
CurTerminal

Parent
TSepiCustomParser

Visibility
PUBLIC

Description
Terminal courant

Source code
property CurTerminal : TSepiTerminal read GetCurTerminal

Read Access
GetCurTerminal

Sepi
Class Tree
Index
Previous
Next (Errors)


Sepi

Sepi
Previous (CurTerminal)
Next (Lexer)

Name
Errors

Parent
TSepiCustomParser

Visibility
PUBLIC

Description
Erreurs de compilation

Source code
property Errors : TSepiCompilerErrorList read FErrors

Read Access
FErrors

Sepi
Class Tree
Index
Previous (CurTerminal)
Next (Lexer)


Sepi

Sepi
Previous (Errors)
Next

Name
Lexer

Parent
TSepiCustomParser

Visibility
PROTECTED

Description
Analyseur lexical source

Source code
property Lexer : TSepiCustomLexer read FLexer

Read Access
FLexer

Sepi
Class Tree
Index
Previous (Errors)
Next


Sepi

Sepi
Previous
Next (CreateDefaultLexer)

Name
Create

Parent
TSepiCustomParser

Visibility
PUBLIC

Description
Crée un analyseur syntaxique

Source code
constructor Create ( ALexer : TSepiCustomLexer ) ; virtual

Parameters
Parameter | Description
ALexer : TSepiCustomLexer | Analyseur lexical source

Sepi
Class Tree
Index
Previous
Next (CreateDefaultLexer)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
CreateDefaultLexer

Parent
TSepiCustomParser

Visibility
PROTECTED

Description
Crée un analyseur lexical par défaut pour cet analyseur syntaxique

Source code
class function CreateDefaultLexer ( Errors : TSepiCompilerErrorList ; const Code : string ; const FileName : string = '' ) : TSepiCustomLexer ; virtual ; abstract

Parameters
Parameter | Description
Errors : TSepiCompilerErrorList
Code : STRING | Code à analyser
FileName : STRING | Nom du fichier

Return
Types | Description
TSepiCustomLexer | Analyseur lexical créé

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (CreateDefaultLexer)
Next (GetCurTerminal)

Name
Destroy

Parent
TSepiCustomParser

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CreateDefaultLexer)
Next (GetCurTerminal)


Sepi

Sepi
Previous (Destroy)
Next (InternalParse)

Name
GetCurTerminal

Parent
TSepiCustomParser

Visibility
PRIVATE

Description
Terminal courant

Source code
function GetCurTerminal : TSepiTerminal

Parameters
Parameter Description

Return
Types | Description
TSepiTerminal | Terminal courant

Sepi
Class Tree
Index
Previous (Destroy)
Next (InternalParse)


Sepi

Sepi
Previous (GetCurTerminal)
Next (MakeSyntaxError)

Name
InternalParse

Parent
TSepiCustomParser

Visibility
PROTECTED

Description
Analyse syntaxique proprement dite

Source code
procedure InternalParse ( RootNode : TSepiNonTerminal ) ; virtual ; abstract

Parameters
Parameter | Description
RootNode : TSepiNonTerminal | Noeud racine de l'arbre syntaxique

Sepi
Class Tree
Index
Previous (GetCurTerminal)
Next (MakeSyntaxError)


Sepi

Sepi
Previous (InternalParse)
Next (Parse)

Name
MakeSyntaxError

Parent
TSepiCustomParser

Visibility
PROTECTED

Description
Produit une erreur syntaxique

Source code
procedure MakeSyntaxError ( const Expected : string )

Parameters
Parameter | Description
Expected : STRING | Représentation de ce qui était attendu

Sepi
Class Tree
Index
Previous (InternalParse)
Next (Parse)


Sepi

Sepi
Previous (MakeSyntaxError)
Next (Parse)

Name
Parse

Parent
TSepiCustomParser

Visibility
PUBLIC

Description
Analyse un code source, en utilisant l'analyseur lexical par défaut

Source code
class procedure Parse ( RootNode : TSepiNonTerminal ; const Code : string ; const FileName : string = '' ) ; overload

Parameters
Parameter | Description
RootNode : TSepiNonTerminal | Noeud racine de l'arbre syntaxique à produire
Code : STRING | Code source à analyser
FileName : STRING

Sepi
Class Tree
Index
Previous (MakeSyntaxError)
Next (Parse)


Sepi

Sepi
Previous (Parse)
Next

Name
Parse

Parent
TSepiCustomParser

Visibility
PUBLIC

Description
Analyse un code source

Source code
class procedure Parse ( RootNode : TSepiNonTerminal ; Lexer : TSepiCustomLexer ) ; overload

Parameters
Parameter | Description
RootNode : TSepiNonTerminal | Noeud racine de l'arbre syntaxique à produire
Lexer : TSepiCustomLexer | Analyseur lexical source

Sepi
Class Tree
Index
Previous (Parse)
Next


Sepi

Sepi
Previous (SepiParserUtils)
Next (SepiPSCompiler)

Name
SepiParseTrees

Parent
Sepi

Description
Arbres syntaxiques Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TMessageHandlerRecDynArray (+) | Tableau dynamique de TMessageHandlerRec
TSepiSymbolClass (+) | Classe de symbole

Methods
Method | Description
CheckIdentFound (+) | Vérifie qu'un identificateur a bien été trouvé, et produit une erreur sinon
CheckIdentFound (+) | Vérifie qu'un identificateur a bien été trouvé, et produit une erreur sinon
CheckTypeMatch (+) | Vérifie que des types correspondent, et produit une erreur sinon

Classes
Class | Description
TMessageHandlerRec (+) | Enregistrement d'un gestionnaire de message
TSepiHiddenNonTerminal (+) | Non-terminal caché, que le parent ne connaît pas
TSepiNonTerminal (+) | Non-terminal
TSepiParseTreeNode (+) | Noeud d'un arbre syntaxique Sepi
TSepiParseTreeRootNode (+) | Noeud racine d'un arbre syntaxique Sepi
TSepiTerminal (+) | Terminal

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiParserUtils)
Next (SepiPSCompiler)


Sepi

Sepi
Previous
Next (TSepiHiddenNonTerminal)

Name
TMessageHandlerRec

Parent
SepiParseTrees

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Enregistrement d'un gestionnaire de message

Members
Fields
Field | Description
Handler (*) | Objet qui gère ce message
MsgID (*) | ID du message géré

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiHiddenNonTerminal)


Sepi

Sepi
Previous
Next (MsgID)

Name
Handler

Parent
TMessageHandlerRec

Visibility
PUBLISHED

Description
Objet qui gère ce message

Source code
Handler : TObject

Sepi
Class Tree
Index
Previous
Next (MsgID)


Sepi

Sepi
Previous (Handler)
Next

Name
MsgID

Parent
TMessageHandlerRec

Visibility
PUBLISHED

Description
ID du message géré

Source code
MsgID : Word

Sepi
Class Tree
Index
Previous (Handler)
Next


Sepi

Sepi
Previous (TMessageHandlerRec)
Next (TSepiNonTerminal)

Name
TSepiHiddenNonTerminal

Parent
SepiParseTrees

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Non-terminal caché, que le parent ne connaît pas
Attention ! Puisque le parent ne connaît pas un non-terminal caché, il n'est
pas en mesure de le libérer non plus. Tout non-terminal caché doit assurer
sa propre destruction, par exemple dans EndParsing.

Members
Fields
Field | Description
FIndexAsChild (-) | Index parmi ses frères (guess only)

Methods
Method | Description
AddToParent (#) | [@inheritDoc]
BeginParsing (+) | [@inheritDoc]
Create (+) | Crée le non-terminal
EndParsing (+) | [@inheritDoc]
RemoveFromParent (#) | [@inheritDoc]
SetIndexAsChild (#) | Modifie la valeur de la propriété IndexAsChild

Properties
Property | Description
IndexAsChild (+) | Index parmi ses frères (guess only)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TMessageHandlerRec)
Next (TSepiNonTerminal)


Sepi

Sepi
Previous
Next

Name
FIndexAsChild

Parent
TSepiHiddenNonTerminal

Visibility
PRIVATE

Description
Index parmi ses frères (guess only)

Source code
FIndexAsChild : Integer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
IndexAsChild

Parent
TSepiHiddenNonTerminal

Visibility
PUBLIC

Description
Index parmi ses frères (guess only)

Source code
property IndexAsChild : Integer read FIndexAsChild

Read Access
FIndexAsChild

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (BeginParsing)

Name
AddToParent

Parent
TSepiHiddenNonTerminal

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AddToParent ( Index : Integer ) ; override

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (BeginParsing)


Sepi

Sepi
Previous (AddToParent)
Next (Create)

Name
BeginParsing

Parent
TSepiHiddenNonTerminal

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddToParent)
Next (Create)


Sepi

Sepi
Previous (BeginParsing)
Next (EndParsing)

Name
Create

Parent
TSepiHiddenNonTerminal

Visibility
PUBLIC

Description
Crée le non-terminal

Source code
constructor Create ( AParent : TSepiNonTerminal ; AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; override

Parameters
Parameter | Description
AParent : TSepiNonTerminal | #Pas de TAG trouvé dans le code source#
AClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#
ASourcePos : TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (Create)
Next (RemoveFromParent)

Name
EndParsing

Parent
TSepiHiddenNonTerminal

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (RemoveFromParent)


Sepi

Sepi
Previous (EndParsing)
Next (SetIndexAsChild)

Name
RemoveFromParent

Parent
TSepiHiddenNonTerminal

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure RemoveFromParent ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (EndParsing)
Next (SetIndexAsChild)


Sepi

Sepi
Previous (RemoveFromParent)
Next

Name
SetIndexAsChild

Parent
TSepiHiddenNonTerminal

Visibility
PROTECTED

Description
Modifie la valeur de la propriété IndexAsChild

Source code
procedure SetIndexAsChild ( Value : Integer )

Parameters
Parameter | Description
Value : INTEGER | Nouvelle valeur

Sepi
Class Tree
Index
Previous (RemoveFromParent)
Next


Sepi

Sepi
Previous (TSepiHiddenNonTerminal)
Next (TSepiParseTreeNode)

Name
TSepiNonTerminal

Parent
SepiParseTrees

Class Hierarchy
TSepiParseTreeNode

Visibility
PUBLIC

Description
Non-terminal

Members
Fields
Field | Description
FChildren (-) | Liste des enfants

Methods
Method | Description
AddChild (#) | Ajoute un enfant
ChildBeginParsing (#) | Méthode de notification appelée lorsqu'un enfant commence son analyse
ChildEndParsing (#) | Méthode de notification appelée lorsqu'un enfant termine son analyse
Create (+) | Crée un nouveau non-terminal sans parent
Create (+) | Crée un nouveau non-terminal
Destroy (+) | [@inheritDoc]
GetAsText (#) | [@inheritDoc]
GetChildCount (#) | [@inheritDoc]
GetChildren (#) | [@inheritDoc]
IndexOf (+) | Cherche la position d'un enfant
RemoveChild (#) | Retire un enfant

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiHiddenNonTerminal)
Next (TSepiParseTreeNode)


Sepi

Sepi
Previous
Next

Name
FChildren

Parent
TSepiNonTerminal

Visibility
PRIVATE

Description
Liste des enfants

Source code
FChildren : TObjectList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
AddChild

Parent
TSepiNonTerminal

Visibility
PROTECTED

Description
Ajoute un enfant

Source code
procedure AddChild ( Index : Integer ; Child : TSepiParseTreeNode ) ; virtual

Parameters
Parameter | Description
INDEX : INTEGER
Child : TSepiParseTreeNode | Enfant à ajouter

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (AddChild)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiNonTerminal

Visibility
PROTECTED

Description
Méthode de notification appelée lorsqu'un enfant commence son analyse

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; virtual

Parameters
Parameter | Description
Child : TSepiParseTreeNode | Enfant qui commence son analyse

Sepi
Class Tree
Index
Previous (AddChild)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (Create)

Name
ChildEndParsing

Parent
TSepiNonTerminal

Visibility
PROTECTED

Description
Méthode de notification appelée lorsqu'un enfant termine son analyse

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; virtual

Parameters
Parameter | Description
Child : TSepiParseTreeNode | Enfant qui termine son analyse

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (Create)


Sepi

Sepi
Previous (ChildEndParsing)
Next (Create)

Name
Create

Parent
TSepiNonTerminal

Visibility
PUBLIC

Description
Crée un nouveau non-terminal sans parent

Source code
constructor Create ( AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; overload

Parameters
Parameter | Description
AClass : TSepiSymbolClass | Classe de symbole
ASourcePos : TSepiSourcePosition | Position dans le source

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TSepiNonTerminal

Visibility
PUBLIC

Description
Crée un nouveau non-terminal

Source code
constructor Create ( AParent : TSepiNonTerminal ; AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; overload ; virtual

Parameters
Parameter | Description
AParent : TSepiNonTerminal | Parent dans l'arbre syntaxique
AClass : TSepiSymbolClass | Classe de symbole
ASourcePos : TSepiSourcePosition | Position dans le source

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetAsText)

Name
Destroy

Parent
TSepiNonTerminal

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetAsText)


Sepi

Sepi
Previous (Destroy)
Next (GetChildCount)

Name
GetAsText

Parent
TSepiNonTerminal

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAsText : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetChildCount)


Sepi

Sepi
Previous (GetAsText)
Next (GetChildren)

Name
GetChildCount

Parent
TSepiNonTerminal

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetChildCount : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAsText)
Next (GetChildren)


Sepi

Sepi
Previous (GetChildCount)
Next (IndexOf)

Name
GetChildren

Parent
TSepiNonTerminal

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetChildren ( Index : Integer ) : TSepiParseTreeNode ; override

Parameters
Parameter | Description
INDEX : INTEGER | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetChildCount)
Next (IndexOf)


Sepi

Sepi
Previous (GetChildren)
Next (RemoveChild)

Name
IndexOf

Parent
TSepiNonTerminal

Visibility
PUBLIC

Description
Cherche la position d'un enfant

Source code
function IndexOf ( Child : TSepiParseTreeNode ) : Integer

Parameters
Parameter | Description
Child : TSepiParseTreeNode | Enfant recherché

Return
Types | Description
INTEGER | Index de l'enfant parmi ses frères, ou -1 si non trouvé

Sepi
Class Tree
Index
Previous (GetChildren)
Next (RemoveChild)


Sepi

Sepi
Previous (IndexOf)
Next

Name
RemoveChild

Parent
TSepiNonTerminal

Visibility
PROTECTED

Description
Retire un enfant

Source code
procedure RemoveChild ( Child : TSepiParseTreeNode ) ; virtual

Parameters
Parameter | Description
Child : TSepiParseTreeNode | Enfant à retirer

Sepi
Class Tree
Index
Previous (IndexOf)
Next


Sepi

Sepi
Previous (TSepiNonTerminal)
Next (TSepiParseTreeRootNode)

Name
TSepiParseTreeNode

Parent
SepiParseTrees

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Noeud d'un arbre syntaxique Sepi
TSepiParseTreeNode est la classe de base de tous les types de noeud d'un
arbre syntaxique. Ses deux classes filles TSepiTerminal et TSepiNonTerminal
implémentent les mécanismes propres aux terminaux et non-terminaux,
respectivement. Vous ne devriez normalement pas écrire d'autre classe fille
de TSepiParseTreeNode, mais plutôt de ces deux filles-là.

Members
Fields
Field | Description
FClass (-) | Classe de symbole
FParent (-) | Noeud parent dans l'arbre syntaxique
FRootNode (-) | Noeud racine de l'arbre syntaxique
FSourcePos (-) | Position dans le source
FSyntacticParent (-) | Parent syntaxique

Methods
Method | Description
AddToParent (#) | Ajoute le noeud à son parent
AfterConstruction (+) | [@inheritDoc]
AncestorChanged (#) | Méthode de notification appelée lorsqu'un ancêtre a été modifié
BeforeDestruction (+) | [@inheritDoc]
BeginParsing (+) | Commence l'analyse du noeud
Create (+) | Crée un noeud de l'arbre syntaxique sans parent
Create (+) | Crée un noeud de l'arbre syntaxique
DefaultHandler (+) | [@inheritDoc]
DoAncestorChanged (-) | Notifie qu'un ancêtre a changé
EndParsing (+) | Termine l'analyse du noeud
FindRightMost (+) | Trouve le noeud de la plus à droite de ce sous-arbre syntaxique
GetAsText (#) | Version texte du contenu du symbole grammatical
GetChildCount (#) | Nombre d'enfants
GetChildren (#) | Tableau zero-based des enfants
GetCompiler (-) | Compilateur
GetIndexAsChild (-) | Index parmi ses frères
GetLanguageRules (-) | Règles du langage utilisé
GetMethodCompiler (#) | Compilateur de méthode (peut être nil)
GetSepiContext (#) | Contexte Sepi
GetSepiRoot (-) | Racine Sepi
GetSepiUnit (-) | Unité Sepi en cours de compilation
GetSystemUnit (-) | Unité System
GetUnitCompiler (-) | Compilateur d'unité
IsAncestor (+) | Teste si ce noeud a pour ancêtre un noeud donné
IsAncestor (+) | Teste si ce noeud a pour ancêtre une classe de noeud donnée
LookFor (+) | Recherche un meta d'un type particulier dans le contexte de ce noeud
LookFor (+) | Recherche un meta dans le contexte de ce noeud
LookForOrError (+) | Recherche un meta d'un type particulier dans le contexte de ce noeud
LookForOrError (+) | Recherche un meta dans le contexte de ce noeud
LookForSelfText (+) | Recherche un meta dont le nom est le texte de ce noeud
LookForSelfText (+) | Recherche un meta d'un type particulier dont le nom est le texte de ce noeud
LookForSelfTextOrError (+) | Recherche un meta d'un type particulier dont le nom est le texte de ce noeud
LookForSelfTextOrError (+) | Recherche un meta dont le nom est le texte de ce noeud
MakeError (+) | Produit une erreur au niveau de ce noeud
MakeExpression (#) | Construit une expression, vide, dans le contexte de ce noeud
Move (+) | Déplace un noeud dans l'arbre syntaxique
RemoveFromParent (#) | Retire le noeud de son parent
ResolveIdent (+) | Résoud un identificateur dans le contexte de ce noeud
ResolveIdentOrError (+) | Résoud un identificateur dans le contexte de ce noeud
SetSymbolClass (#) | Modifie la classe de symbole
SetSyntacticParent (#) | Modifie le parent syntaxique

Properties
Property | Description
AsText (+) | Version texte du contenu du symbole grammatical
ChildCount (+) | Nombre d'enfants
Children (+) | Tableau zero-based des enfants
Col (+) | Position dans le source
Compiler (+) | Compilateur
FileName (+) | Position dans le source
IndexAsChild (+) | Index parmi ses frères
LanguageRules (+) | Règles du langage utilisé
Line (+) | Position dans le source
MethodCompiler (+) | Compilateur de méthode (peut être nil)
Parent (+) | Noeud parent dans l'arbre syntaxique
RootNode (+) | Noeud racine de l'arbre syntaxique
SepiContext (+) | Contexte Sepi
SepiRoot (+) | Racine Sepi
SepiUnit (+) | Unité Sepi en cours de compilation
SourcePos (+) | Position dans le source
SymbolClass (+) | Classe de symbole
SyntacticParent (+) | Parent syntaxique
SystemUnit (+) | Unité System
UnitCompiler (+) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiNonTerminal)
Next (TSepiParseTreeRootNode)


Sepi

Sepi
Previous
Next (FParent)

Name
FClass

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Classe de symbole

Source code
FClass : TSepiSymbolClass

Sepi
Class Tree
Index
Previous
Next (FParent)


Sepi

Sepi
Previous (FClass)
Next (FRootNode)

Name
FParent

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Noeud parent dans l'arbre syntaxique

Source code
FParent : TSepiNonTerminal

Sepi
Class Tree
Index
Previous (FClass)
Next (FRootNode)


Sepi

Sepi
Previous (FParent)
Next (FSourcePos)

Name
FRootNode

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Noeud racine de l'arbre syntaxique

Source code
FRootNode : TSepiParseTreeRootNode

Sepi
Class Tree
Index
Previous (FParent)
Next (FSourcePos)


Sepi

Sepi
Previous (FRootNode)
Next (FSyntacticParent)

Name
FSourcePos

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Position dans le source

Source code
FSourcePos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (FRootNode)
Next (FSyntacticParent)


Sepi

Sepi
Previous (FSourcePos)
Next

Name
FSyntacticParent

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Parent syntaxique

Source code
FSyntacticParent : TSepiNonTerminal

Sepi
Class Tree
Index
Previous (FSourcePos)
Next


Sepi

Sepi
Previous
Next (ChildCount)

Name
AsText

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Version texte du contenu du symbole grammatical

Source code
property AsText : string read GetAsText

Read Access
GetAsText

Sepi
Class Tree
Index
Previous
Next (ChildCount)


Sepi

Sepi
Previous (AsText)
Next (Children)

Name
ChildCount

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Nombre d'enfants

Source code
property ChildCount : Integer read GetChildCount

Read Access
GetChildCount

Sepi
Class Tree
Index
Previous (AsText)
Next (Children)


Sepi

Sepi
Previous (ChildCount)
Next (Col)

Name
Children

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Tableau zero-based des enfants

Source code
property Children [ Index : Integer ] : TSepiParseTreeNode read GetChildren

Read Access
GetChildren

Sepi
Class Tree
Index
Previous (ChildCount)
Next (Col)


Sepi

Sepi
Previous (Children)
Next (Compiler)

Name
Col

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Position dans le source

Source code
property Col : Integer read FSourcePos . Col

Read Access
FSourcePos

Sepi
Class Tree
Index
Previous (Children)
Next (Compiler)


Sepi

Sepi
Previous (Col)
Next (FileName)

Name
Compiler

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Compilateur

Source code
property Compiler : TSepiCompilerBase read GetCompiler

Read Access
GetCompiler

Sepi
Class Tree
Index
Previous (Col)
Next (FileName)


Sepi

Sepi
Previous (Compiler)
Next (IndexAsChild)

Name
FileName

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Position dans le source

Source code
property FileName : TFileName read FSourcePos . FileName

Read Access
FSourcePos

Sepi
Class Tree
Index
Previous (Compiler)
Next (IndexAsChild)


Sepi

Sepi
Previous (FileName)
Next (LanguageRules)

Name
IndexAsChild

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Index parmi ses frères

Source code
property IndexAsChild : Integer read GetIndexAsChild

Read Access
GetIndexAsChild

Sepi
Class Tree
Index
Previous (FileName)
Next (LanguageRules)


Sepi

Sepi
Previous (IndexAsChild)
Next (Line)

Name
LanguageRules

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Règles du langage utilisé

Source code
property LanguageRules : TSepiLanguageRules read GetLanguageRules

Read Access
GetLanguageRules

Sepi
Class Tree
Index
Previous (IndexAsChild)
Next (Line)


Sepi

Sepi
Previous (LanguageRules)
Next (MethodCompiler)

Name
Line

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Position dans le source

Source code
property Line : Integer read FSourcePos . Line

Read Access
FSourcePos

Sepi
Class Tree
Index
Previous (LanguageRules)
Next (MethodCompiler)


Sepi

Sepi
Previous (Line)
Next (Parent)

Name
MethodCompiler

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Compilateur de méthode (peut être nil)

Source code
property MethodCompiler : TSepiMethodCompiler read GetMethodCompiler

Read Access
GetMethodCompiler

Sepi
Class Tree
Index
Previous (Line)
Next (Parent)


Sepi

Sepi
Previous (MethodCompiler)
Next (RootNode)

Name
Parent

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Noeud parent dans l'arbre syntaxique

Source code
property Parent : TSepiNonTerminal read FParent

Read Access
FParent

Sepi
Class Tree
Index
Previous (MethodCompiler)
Next (RootNode)


Sepi

Sepi
Previous (Parent)
Next (SepiContext)

Name
RootNode

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Noeud racine de l'arbre syntaxique

Source code
property RootNode : TSepiParseTreeRootNode read FRootNode

Read Access
FRootNode

Sepi
Class Tree
Index
Previous (Parent)
Next (SepiContext)


Sepi

Sepi
Previous (RootNode)
Next (SepiRoot)

Name
SepiContext

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Contexte Sepi

Source code
property SepiContext : TSepiComponent read GetSepiContext

Read Access
GetSepiContext

Sepi
Class Tree
Index
Previous (RootNode)
Next (SepiRoot)


Sepi

Sepi
Previous (SepiContext)
Next (SepiUnit)

Name
SepiRoot

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read GetSepiRoot

Read Access
GetSepiRoot

Sepi
Class Tree
Index
Previous (SepiContext)
Next (SepiUnit)


Sepi

Sepi
Previous (SepiRoot)
Next (SourcePos)

Name
SepiUnit

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Unité Sepi en cours de compilation

Source code
property SepiUnit : TSepiUnit read GetSepiUnit

Read Access
GetSepiUnit

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (SourcePos)


Sepi

Sepi
Previous (SepiUnit)
Next (SymbolClass)

Name
SourcePos

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Position dans le source

Source code
property SourcePos : TSepiSourcePosition read FSourcePos

Read Access
FSourcePos

Sepi
Class Tree
Index
Previous (SepiUnit)
Next (SymbolClass)


Sepi

Sepi
Previous (SourcePos)
Next (SyntacticParent)

Name
SymbolClass

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Classe de symbole

Source code
property SymbolClass : TSepiSymbolClass read FClass

Read Access
FClass

Sepi
Class Tree
Index
Previous (SourcePos)
Next (SyntacticParent)


Sepi

Sepi
Previous (SymbolClass)
Next (SystemUnit)

Name
SyntacticParent

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Parent syntaxique

Source code
property SyntacticParent : TSepiNonTerminal read FSyntacticParent

Read Access
FSyntacticParent

Sepi
Class Tree
Index
Previous (SymbolClass)
Next (SystemUnit)


Sepi

Sepi
Previous (SyntacticParent)
Next (UnitCompiler)

Name
SystemUnit

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Unité System

Source code
property SystemUnit : TSepiSystemUnit read GetSystemUnit

Read Access
GetSystemUnit

Sepi
Class Tree
Index
Previous (SyntacticParent)
Next (UnitCompiler)


Sepi

Sepi
Previous (SystemUnit)
Next

Name
UnitCompiler

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read GetUnitCompiler

Read Access
GetUnitCompiler

Sepi
Class Tree
Index
Previous (SystemUnit)
Next


Sepi

Sepi
Previous
Next (AfterConstruction)

Name
AddToParent

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Ajoute le noeud à son parent

Source code
procedure AddToParent ( Index : Integer ) ; virtual

Parameters
Parameter | Description
INDEX : INTEGER | Index où l'ajouter (-1 pour l'ajouter à la fin)

Sepi
Class Tree
Index
Previous
Next (AfterConstruction)


Sepi

Sepi
Previous (AddToParent)
Next (AncestorChanged)

Name
AfterConstruction

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddToParent)
Next (AncestorChanged)


Sepi

Sepi
Previous (AfterConstruction)
Next (BeforeDestruction)

Name
AncestorChanged

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Méthode de notification appelée lorsqu'un ancêtre a été modifié
Lorsque cette méthode est appelée, RootNode a déjà été modifié pour refléter
la propriété RootNode du parent. Et après cet appel, les enfants seront
notifiés à leur tour du changement d'un ancêtre.

Source code
procedure AncestorChanged ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (BeforeDestruction)


Sepi

Sepi
Previous (AncestorChanged)
Next (BeginParsing)

Name
BeforeDestruction

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AncestorChanged)
Next (BeginParsing)


Sepi

Sepi
Previous (BeforeDestruction)
Next (Create)

Name
BeginParsing

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Commence l'analyse du noeud

Source code
procedure BeginParsing ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (Create)


Sepi

Sepi
Previous (BeginParsing)
Next (Create)

Name
Create

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Crée un noeud de l'arbre syntaxique sans parent

Source code
constructor Create ( AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; overload

Parameters
Parameter | Description
AClass : TSepiSymbolClass | Classe de symbole
ASourcePos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (DefaultHandler)

Name
Create

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Crée un noeud de l'arbre syntaxique

Source code
constructor Create ( AParent : TSepiNonTerminal ; AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; overload

Parameters
Parameter | Description
AParent : TSepiNonTerminal | Parent dans l'arbre syntaxique
AClass : TSepiSymbolClass | Classe de symbole
ASourcePos : TSepiSourcePosition

Sepi
Class Tree
Index
Previous (Create)
Next (DefaultHandler)


Sepi

Sepi
Previous (Create)
Next (DoAncestorChanged)

Name
DefaultHandler

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure DefaultHandler ( var Message ) ; override

Parameters
Parameter | Description
MESSAGE : Untyped | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (DoAncestorChanged)


Sepi

Sepi
Previous (DefaultHandler)
Next (EndParsing)

Name
DoAncestorChanged

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Notifie qu'un ancêtre a changé

Source code
procedure DoAncestorChanged

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DefaultHandler)
Next (EndParsing)


Sepi

Sepi
Previous (DoAncestorChanged)
Next (FindRightMost)

Name
EndParsing

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Termine l'analyse du noeud

Source code
procedure EndParsing ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DoAncestorChanged)
Next (FindRightMost)


Sepi

Sepi
Previous (EndParsing)
Next (GetAsText)

Name
FindRightMost

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Trouve le noeud de la plus à droite de ce sous-arbre syntaxique
Dans la plupart des analyseurs, il s'agit du dernier noeud analysé.

Source code
function FindRightMost : TSepiParseTreeNode

Parameters
Parameter Description

Return
Types | Description
TSepiParseTreeNode | Noeud le plus à droite de ce sous-arbre syntaxique

Sepi
Class Tree
Index
Previous (EndParsing)
Next (GetAsText)


Sepi

Sepi
Previous (FindRightMost)
Next (GetChildCount)

Name
GetAsText

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Version texte du contenu du symbole grammatical

Source code
function GetAsText : string ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
STRING | Contenu textuel du symbole grammatical

Sepi
Class Tree
Index
Previous (FindRightMost)
Next (GetChildCount)


Sepi

Sepi
Previous (GetAsText)
Next (GetChildren)

Name
GetChildCount

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Nombre d'enfants

Source code
function GetChildCount : Integer ; virtual

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'enfants

Sepi
Class Tree
Index
Previous (GetAsText)
Next (GetChildren)


Sepi

Sepi
Previous (GetChildCount)
Next (GetCompiler)

Name
GetChildren

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Tableau zero-based des enfants

Source code
function GetChildren ( Index : Integer ) : TSepiParseTreeNode ; virtual

Parameters
Parameter | Description
INDEX : INTEGER | Index d'un enfant

Return
Types | Description
TSepiParseTreeNode | Enfant à l'index spécifié

Sepi
Class Tree
Index
Previous (GetChildCount)
Next (GetCompiler)


Sepi

Sepi
Previous (GetChildren)
Next (GetIndexAsChild)

Name
GetCompiler

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Compilateur

Source code
function GetCompiler : TSepiCompilerBase

Parameters
Parameter Description

Return
Types | Description
TSepiCompilerBase | Compilateur, si rattaché à un noeud racine, nil sinon

Sepi
Class Tree
Index
Previous (GetChildren)
Next (GetIndexAsChild)


Sepi

Sepi
Previous (GetCompiler)
Next (GetLanguageRules)

Name
GetIndexAsChild

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Index parmi ses frères

Source code
function GetIndexAsChild : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Index parmi les enfants de son parent, ou -1 si n'a pas de parent

Sepi
Class Tree
Index
Previous (GetCompiler)
Next (GetLanguageRules)


Sepi

Sepi
Previous (GetIndexAsChild)
Next (GetMethodCompiler)

Name
GetLanguageRules

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Règles du langage utilisé

Source code
function GetLanguageRules : TSepiLanguageRules

Parameters
Parameter Description

Return
Types | Description
TSepiLanguageRules | Règles du langage utilisé, si rattaché à un noeud racine, nil sinon

Sepi
Class Tree
Index
Previous (GetIndexAsChild)
Next (GetMethodCompiler)


Sepi

Sepi
Previous (GetLanguageRules)
Next (GetSepiContext)

Name
GetMethodCompiler

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Compilateur de méthode (peut être nil)
L'implémentation par défaut, dans TSepiParseTreeNode, transfère la requête au
noeud parent.

Source code
function GetMethodCompiler : TSepiMethodCompiler ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiMethodCompiler | Compilateur de méthode (peut être nil)

Sepi
Class Tree
Index
Previous (GetLanguageRules)
Next (GetSepiContext)


Sepi

Sepi
Previous (GetMethodCompiler)
Next (GetSepiRoot)

Name
GetSepiContext

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Contexte Sepi
L'implémentation par défaut, dans TSepiParseTreeNode, transfère la requête au
noeud parent.

Source code
function GetSepiContext : TSepiComponent ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | Contexte Sepi

Sepi
Class Tree
Index
Previous (GetMethodCompiler)
Next (GetSepiRoot)


Sepi

Sepi
Previous (GetSepiContext)
Next (GetSepiUnit)

Name
GetSepiRoot

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Racine Sepi

Source code
function GetSepiRoot : TSepiRoot

Parameters
Parameter Description

Return
Types | Description
TSepiRoot | Racine Sepi, si rattaché à un noeud racine, nil sinon

Sepi
Class Tree
Index
Previous (GetSepiContext)
Next (GetSepiUnit)


Sepi

Sepi
Previous (GetSepiRoot)
Next (GetSystemUnit)

Name
GetSepiUnit

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Unité Sepi en cours de compilation

Source code
function GetSepiUnit : TSepiUnit

Parameters
Parameter Description

Return
Types | Description
TSepiUnit | Unité Sepi, si rattaché à un noeud racine, nil sinon

Sepi
Class Tree
Index
Previous (GetSepiRoot)
Next (GetSystemUnit)


Sepi

Sepi
Previous (GetSepiUnit)
Next (GetUnitCompiler)

Name
GetSystemUnit

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Unité System

Source code
function GetSystemUnit : TSepiSystemUnit

Parameters
Parameter Description

Return
Types | Description
TSepiSystemUnit | Unité System, si rattaché à un noeud racine, nil sinon

Sepi
Class Tree
Index
Previous (GetSepiUnit)
Next (GetUnitCompiler)


Sepi

Sepi
Previous (GetSystemUnit)
Next (IsAncestor)

Name
GetUnitCompiler

Parent
TSepiParseTreeNode

Visibility
PRIVATE

Description
Compilateur d'unité

Source code
function GetUnitCompiler : TSepiUnitCompiler

Parameters
Parameter Description

Return
Types | Description
TSepiUnitCompiler | Compilateur d'unité, si rattaché à un noeud racine, nil sinon

Sepi
Class Tree
Index
Previous (GetSystemUnit)
Next (IsAncestor)


Sepi

Sepi
Previous (GetUnitCompiler)
Next (IsAncestor)

Name
IsAncestor

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Teste si ce noeud a pour ancêtre un noeud donné

Source code
function IsAncestor ( Ancestor : TSepiParseTreeNode ) : Boolean ; overload

Parameters
Parameter | Description
Ancestor : TSepiParseTreeNode | Ancêtre potentiel

Return
Types | Description
BOOLEAN | True si Ancestor est un ancêtre de ce noeud, False sinon

Sepi
Class Tree
Index
Previous (GetUnitCompiler)
Next (IsAncestor)


Sepi

Sepi
Previous (IsAncestor)
Next (LookFor)

Name
IsAncestor

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Teste si ce noeud a pour ancêtre une classe de noeud donnée

Source code
function IsAncestor ( AncestorClass : TClass ) : Boolean ; overload

Parameters
Parameter Description
AncestorClass : TClass

Return
Types | Description
BOOLEAN | True si un ancêtre de ce noeud est un AncestorClass, False sinon

Sepi
Class Tree
Index
Previous (IsAncestor)
Next (LookFor)


Sepi

Sepi
Previous (IsAncestor)
Next (LookFor)

Name
LookFor

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta d'un type particulier dans le contexte de ce noeud

Source code
function LookFor ( Node : TSepiParseTreeNode ; RequiredClass : TSepiComponentClass ) : TSepiComponent ; overload

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud dont le texte est le nom du meta à rechercher
RequiredClass : TSepiComponentClass | Classe de meta requise

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé ou pas de la bonne classe

Sepi
Class Tree
Index
Previous (IsAncestor)
Next (LookFor)


Sepi

Sepi
Previous (LookFor)
Next (LookForOrError)

Name
LookFor

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta dans le contexte de ce noeud

Source code
function LookFor ( Node : TSepiParseTreeNode ) : TSepiComponent ; overload

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud dont le texte est le nom du meta à rechercher

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LookFor)
Next (LookForOrError)


Sepi

Sepi
Previous (LookFor)
Next (LookForOrError)

Name
LookForOrError

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta d'un type particulier dans le contexte de ce noeud
Émet un message d'erreur si le meta n'a pas été trouvé, ou s'il n'est pas du
type requis.

Source code
function LookForOrError ( Node : TSepiParseTreeNode ; RequiredClass : TSepiComponentClass ; const BadClassErrorMsg : string ) : TSepiComponent ; overload

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud dont le texte est le nom du meta à rechercher
RequiredClass : TSepiComponentClass | Classe de meta requise
BadClassErrorMsg : STRING | Message d'erreur si mauvaise classe de meta

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé ou pas de la bonne classe

Sepi
Class Tree
Index
Previous (LookFor)
Next (LookForOrError)


Sepi

Sepi
Previous (LookForOrError)
Next (LookForSelfText)

Name
LookForOrError

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta dans le contexte de ce noeud
Émet un message d'erreur si le meta n'a pas été trouvé.

Source code
function LookForOrError ( Node : TSepiParseTreeNode ) : TSepiComponent ; overload

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud dont le texte est le nom du meta à rechercher

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LookForOrError)
Next (LookForSelfText)


Sepi

Sepi
Previous (LookForOrError)
Next (LookForSelfText)

Name
LookForSelfText

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta dont le nom est le texte de ce noeud

Source code
function LookForSelfText : TSepiComponent ; overload

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LookForOrError)
Next (LookForSelfText)


Sepi

Sepi
Previous (LookForSelfText)
Next (LookForSelfTextOrError)

Name
LookForSelfText

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta d'un type particulier dont le nom est le texte de ce noeud

Source code
function LookForSelfText ( RequiredClass : TSepiComponentClass ) : TSepiComponent ; overload

Parameters
Parameter | Description
RequiredClass : TSepiComponentClass | Classe de meta requise

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé ou pas de la bonne classe

Sepi
Class Tree
Index
Previous (LookForSelfText)
Next (LookForSelfTextOrError)


Sepi

Sepi
Previous (LookForSelfText)
Next (LookForSelfTextOrError)

Name
LookForSelfTextOrError

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta d'un type particulier dont le nom est le texte de ce noeud
Émet un message d'erreur si le meta n'a pas été trouvé, ou s'il n'est pas du
type requis.

Source code
function LookForSelfTextOrError ( RequiredClass : TSepiComponentClass ; const BadClassErrorMsg : string ) : TSepiComponent ; overload

Parameters
Parameter | Description
RequiredClass : TSepiComponentClass | Classe de meta requise
BadClassErrorMsg : STRING | Message d'erreur si mauvaise classe de meta

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé ou pas de la bonne classe

Sepi
Class Tree
Index
Previous (LookForSelfText)
Next (LookForSelfTextOrError)


Sepi

Sepi
Previous (LookForSelfTextOrError)
Next (MakeError)

Name
LookForSelfTextOrError

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Recherche un meta dont le nom est le texte de ce noeud
Émet un message d'erreur si le meta n'a pas été trouvé.

Source code
function LookForSelfTextOrError : TSepiComponent ; overload

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | Component trouvé, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LookForSelfTextOrError)
Next (MakeError)


Sepi

Sepi
Previous (LookForSelfTextOrError)
Next (MakeExpression)

Name
MakeError

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Produit une erreur au niveau de ce noeud

Source code
procedure MakeError ( const ErrorMsg : string ; Kind : TSepiErrorKind = ekError )

Parameters
Parameter | Description
ErrorMsg : STRING | Message d'erreur
Kind : TSepiErrorKind | Type d'erreur (défaut = ekError)

Sepi
Class Tree
Index
Previous (LookForSelfTextOrError)
Next (MakeExpression)


Sepi

Sepi
Previous (MakeError)
Next (Move)

Name
MakeExpression

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Construit une expression, vide, dans le contexte de ce noeud

Source code
function MakeExpression : ISepiExpression

Parameters
Parameter Description

Return
Types | Description
ISepiExpression | Expression construite

Sepi
Class Tree
Index
Previous (MakeError)
Next (Move)


Sepi

Sepi
Previous (MakeExpression)
Next (RemoveFromParent)

Name
Move

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Déplace un noeud dans l'arbre syntaxique

Source code
procedure Move ( NewParent : TSepiNonTerminal ; Index : Integer = - 1 )

Parameters
Parameter | Description
NewParent : TSepiNonTerminal | Nouveau parent
INDEX : INTEGER | Index dans le parent (-1 pour l'ajouter à la fin)

Sepi
Class Tree
Index
Previous (MakeExpression)
Next (RemoveFromParent)


Sepi

Sepi
Previous (Move)
Next (ResolveIdent)

Name
RemoveFromParent

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Retire le noeud de son parent

Source code
procedure RemoveFromParent ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Move)
Next (ResolveIdent)


Sepi

Sepi
Previous (RemoveFromParent)
Next (ResolveIdentOrError)

Name
ResolveIdent

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Résoud un identificateur dans le contexte de ce noeud
L'implémentation par défaut dans TSepiParseTreeNode transfère la requête au
noeud parent.

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; virtual

Parameters
Parameter | Description
Identifier : STRING | Identificateur recherché

Return
Types | Description
ISepiExpression | Expression représentant l'identificateur, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (RemoveFromParent)
Next (ResolveIdentOrError)


Sepi

Sepi
Previous (ResolveIdent)
Next (SetSymbolClass)

Name
ResolveIdentOrError

Parent
TSepiParseTreeNode

Visibility
PUBLIC

Description
Résoud un identificateur dans le contexte de ce noeud
Émet un message d'erreur si l'identificateur n'a pas été trouvé.

Source code
function ResolveIdentOrError ( Node : TSepiParseTreeNode ) : ISepiExpression

Parameters
Parameter | Description
Node : TSepiParseTreeNode | Noeud dont le texte est l'identificateur à rechercher

Return
Types | Description
ISepiExpression | Expression représentant l'identificateur, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (ResolveIdent)
Next (SetSymbolClass)


Sepi

Sepi
Previous (ResolveIdentOrError)
Next (SetSyntacticParent)

Name
SetSymbolClass

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Modifie la classe de symbole

Source code
procedure SetSymbolClass ( Value : TSepiSymbolClass )

Parameters
Parameter | Description
Value : TSepiSymbolClass | Nouvelle classe de symbole

Sepi
Class Tree
Index
Previous (ResolveIdentOrError)
Next (SetSyntacticParent)


Sepi

Sepi
Previous (SetSymbolClass)
Next

Name
SetSyntacticParent

Parent
TSepiParseTreeNode

Visibility
PROTECTED

Description
Modifie le parent syntaxique

Source code
procedure SetSyntacticParent ( Value : TSepiNonTerminal )

Parameters
Parameter | Description
Value : TSepiNonTerminal | Nouveau parent syntaxique

Sepi
Class Tree
Index
Previous (SetSymbolClass)
Next


Sepi

Sepi
Previous (TSepiParseTreeNode)
Next (TSepiTerminal)

Name
TSepiParseTreeRootNode

Parent
SepiParseTrees

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud racine d'un arbre syntaxique Sepi

Members
Fields
Field | Description
FErrors (-) | Gestionnaire d'erreurs de compilation
FMessageHandlers (-) | Gestionnaires de messages
FSepiRoot (-) | Racine Sepi
FSepiUnit (-) | Unité Sepi en cours de compilation
FUnitCompiler (-) | Compilateur d'unité

Methods
Method | Description
Create (+) | Crée un noeud racine d'arbre syntaxique
DefaultHandler (+) | [@inheritDoc]
RegisterMessageHandler (+) | Enregistre un gestionnaire de message
SetSepiUnit (#) | Renseigne l'unité Sepi, et crée un compilateur d'unité
SetUnitCompiler (#) | Renseigne le compilateur d'unité, et donc aussi l'unité Sepi
UnregisterMessageHandler (+) | Enregistre un gestionnaire de message

Properties
Property | Description
Errors (+) | Gestionnaire d'erreurs de compilation
SepiRoot (+) | Racine Sepi
SepiUnit (+) | Unité Sepi en cours de compilation
UnitCompiler (+) | Compilateur d'unité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParseTreeNode)
Next (TSepiTerminal)


Sepi

Sepi
Previous
Next (FMessageHandlers)

Name
FErrors

Parent
TSepiParseTreeRootNode

Visibility
PRIVATE

Description
Gestionnaire d'erreurs de compilation

Source code
FErrors : TSepiCompilerErrorList

Sepi
Class Tree
Index
Previous
Next (FMessageHandlers)


Sepi

Sepi
Previous (FErrors)
Next (FSepiRoot)

Name
FMessageHandlers

Parent
TSepiParseTreeRootNode

Visibility
PRIVATE

Description
Gestionnaires de messages

Source code
FMessageHandlers : TMessageHandlerRecDynArray

Sepi
Class Tree
Index
Previous (FErrors)
Next (FSepiRoot)


Sepi

Sepi
Previous (FMessageHandlers)
Next (FSepiUnit)

Name
FSepiRoot

Parent
TSepiParseTreeRootNode

Visibility
PRIVATE

Description
Racine Sepi

Source code
FSepiRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FMessageHandlers)
Next (FSepiUnit)


Sepi

Sepi
Previous (FSepiRoot)
Next (FUnitCompiler)

Name
FSepiUnit

Parent
TSepiParseTreeRootNode

Visibility
PRIVATE

Description
Unité Sepi en cours de compilation

Source code
FSepiUnit : TSepiUnit

Sepi
Class Tree
Index
Previous (FSepiRoot)
Next (FUnitCompiler)


Sepi

Sepi
Previous (FSepiUnit)
Next

Name
FUnitCompiler

Parent
TSepiParseTreeRootNode

Visibility
PRIVATE

Description
Compilateur d'unité

Source code
FUnitCompiler : TSepiUnitCompiler

Sepi
Class Tree
Index
Previous (FSepiUnit)
Next


Sepi

Sepi
Previous
Next (SepiRoot)

Name
Errors

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Gestionnaire d'erreurs de compilation

Source code
property Errors : TSepiCompilerErrorList read FErrors

Read Access
FErrors

Sepi
Class Tree
Index
Previous
Next (SepiRoot)


Sepi

Sepi
Previous (Errors)
Next (SepiUnit)

Name
SepiRoot

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Racine Sepi

Source code
property SepiRoot : TSepiRoot read FSepiRoot

Read Access
FSepiRoot

Sepi
Class Tree
Index
Previous (Errors)
Next (SepiUnit)


Sepi

Sepi
Previous (SepiRoot)
Next (UnitCompiler)

Name
SepiUnit

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Unité Sepi en cours de compilation

Source code
property SepiUnit : TSepiUnit read FSepiUnit

Read Access
FSepiUnit

Sepi
Class Tree
Index
Previous (SepiRoot)
Next (UnitCompiler)


Sepi

Sepi
Previous (SepiUnit)
Next

Name
UnitCompiler

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Compilateur d'unité

Source code
property UnitCompiler : TSepiUnitCompiler read FUnitCompiler

Read Access
FUnitCompiler

Sepi
Class Tree
Index
Previous (SepiUnit)
Next


Sepi

Sepi
Previous
Next (DefaultHandler)

Name
Create

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Crée un noeud racine d'arbre syntaxique

Source code
constructor Create ( AClass : TSepiSymbolClass ; ASepiRoot : TSepiRoot ; AErrors : TSepiCompilerErrorList ) ; virtual

Parameters
Parameter | Description
AClass : TSepiSymbolClass | Classe de symbole
ASepiRoot : TSepiRoot | Racine Sepi
AErrors : TSepiCompilerErrorList | Gestionnaire d'erreurs de compilation

Sepi
Class Tree
Index
Previous
Next (DefaultHandler)


Sepi

Sepi
Previous (Create)
Next (RegisterMessageHandler)

Name
DefaultHandler

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure DefaultHandler ( var Msg ) ; override

Parameters
Parameter | Description
Msg : Untyped | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (RegisterMessageHandler)


Sepi

Sepi
Previous (DefaultHandler)
Next (SetSepiUnit)

Name
RegisterMessageHandler

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Enregistre un gestionnaire de message

Source code
procedure RegisterMessageHandler ( MsgID : Word ; Handler : TObject )

Parameters
Parameter | Description
MsgID : WORD | ID du message géré
Handler : TObject | Objet qui gère le message

Sepi
Class Tree
Index
Previous (DefaultHandler)
Next (SetSepiUnit)


Sepi

Sepi
Previous (RegisterMessageHandler)
Next (SetUnitCompiler)

Name
SetSepiUnit

Parent
TSepiParseTreeRootNode

Visibility
PROTECTED

Description
Renseigne l'unité Sepi, et crée un compilateur d'unité

Source code
procedure SetSepiUnit ( ASepiUnit : TSepiUnit ; LanguageRulesClass : TSepiLanguageRulesClass )

Parameters
Parameter | Description
ASepiUnit : TSepiUnit | Unité Sepi à compiler
LanguageRulesClass : TSepiLanguageRulesClass

Sepi
Class Tree
Index
Previous (RegisterMessageHandler)
Next (SetUnitCompiler)


Sepi

Sepi
Previous (SetSepiUnit)
Next (UnregisterMessageHandler)

Name
SetUnitCompiler

Parent
TSepiParseTreeRootNode

Visibility
PROTECTED

Description
Renseigne le compilateur d'unité, et donc aussi l'unité Sepi

Source code
procedure SetUnitCompiler ( AUnitCompiler : TSepiUnitCompiler )

Parameters
Parameter | Description
AUnitCompiler : TSepiUnitCompiler | Compilateur d'unité

Sepi
Class Tree
Index
Previous (SetSepiUnit)
Next (UnregisterMessageHandler)


Sepi

Sepi
Previous (SetUnitCompiler)
Next

Name
UnregisterMessageHandler

Parent
TSepiParseTreeRootNode

Visibility
PUBLIC

Description
Enregistre un gestionnaire de message

Source code
procedure UnregisterMessageHandler ( MsgID : Word ; Handler : TObject )

Parameters
Parameter | Description
MsgID : WORD | ID du message géré
Handler : TObject | Objet qui gère le message

Sepi
Class Tree
Index
Previous (SetUnitCompiler)
Next


Sepi

Sepi
Previous (TSepiParseTreeRootNode)
Next

Name
TSepiTerminal

Parent
SepiParseTrees

Class Hierarchy
TSepiParseTreeNode

Visibility
PUBLIC

Description
Terminal

Members
Fields
Field | Description
FRepresentation (-) | Représentation du terminal dans le source

Methods
Method | Description
Clone (+) | Clône un terminal
Create (+) | Crée un nouveau terminal sans parent
Create (+) | Crée un nouveau terminal
GetAsText (#) | [@inheritDoc]
Parse (+) | Raccourci pour appeler BeginParsing puis EndParsing

Properties
Property | Description
Representation (+) | Représentation du terminal dans le source

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParseTreeRootNode)
Next


Sepi

Sepi
Previous
Next

Name
FRepresentation

Parent
TSepiTerminal

Visibility
PRIVATE

Description
Représentation du terminal dans le source

Source code
FRepresentation : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Representation

Parent
TSepiTerminal

Visibility
PUBLIC

Description
Représentation du terminal dans le source

Source code
property Representation : string read FRepresentation

Read Access
FRepresentation

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiTerminal

Visibility
PUBLIC

Description
Clône un terminal

Source code
constructor Clone ( Source : TSepiTerminal ; AParent : TSepiNonTerminal = nil )

Parameters
Parameter | Description
Source : TSepiTerminal | Terminal à recopier
AParent : TSepiNonTerminal | Parent du nouveau terminal

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Create)

Name
Create

Parent
TSepiTerminal

Visibility
PUBLIC

Description
Crée un nouveau terminal sans parent

Source code
constructor Create ( AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ; const ARepresentation : string ) ; overload

Parameters
Parameter | Description
AClass : TSepiSymbolClass | Symbol class
ASourcePos : TSepiSourcePosition | Position dans le source
ARepresentation : STRING | Réprésentation textuelle dans le source

Sepi
Class Tree
Index
Previous (Clone)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (GetAsText)

Name
Create

Parent
TSepiTerminal

Visibility
PUBLIC

Description
Crée un nouveau terminal

Source code
constructor Create ( AParent : TSepiNonTerminal ; AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ; const ARepresentation : string ) ; overload ; virtual

Parameters
Parameter | Description
AParent : TSepiNonTerminal | Parent dans l'arbre syntaxique
AClass : TSepiSymbolClass | Symbol class
ASourcePos : TSepiSourcePosition | Position dans le source
ARepresentation : STRING | Réprésentation textuelle dans le source

Sepi
Class Tree
Index
Previous (Create)
Next (GetAsText)


Sepi

Sepi
Previous (Create)
Next (Parse)

Name
GetAsText

Parent
TSepiTerminal

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAsText : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (Parse)


Sepi

Sepi
Previous (GetAsText)
Next

Name
Parse

Parent
TSepiTerminal

Visibility
PUBLIC

Description
Raccourci pour appeler BeginParsing puis EndParsing

Source code
procedure Parse

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetAsText)
Next


Sepi

Sepi
Previous
Next (TSepiSymbolClass)

Name
TMessageHandlerRecDynArray

Parent
SepiParseTrees

Visibility
PUBLIC

Description
Tableau dynamique de TMessageHandlerRec

Source code
TMessageHandlerRecDynArray = array of TMessageHandlerRec ;

Sepi
Class Tree
Index
Previous
Next (TSepiSymbolClass)


Sepi

Sepi
Previous (TMessageHandlerRecDynArray)
Next

Name
TSepiSymbolClass

Parent
SepiParseTrees

Visibility
PUBLIC

Description
Classe de symbole

Source code
TSepiSymbolClass = type Smallint ;

Sepi
Class Tree
Index
Previous (TMessageHandlerRecDynArray)
Next


Sepi

Sepi
Previous
Next (CheckIdentFound)

Name
CheckIdentFound

Parent
SepiParseTrees

Visibility
PUBLIC

Description
Vérifie qu'un identificateur a bien été trouvé, et produit une erreur sinon

Source code
function CheckIdentFound ( Component : TSepiComponent ; const Identifier : string ; Node : TSepiParseTreeNode ) : Boolean ; overload

Parameters
Parameter | Description
Component : TSepiComponent | Component à vérifier
Identifier : STRING | Identificateur, pour le message d'erreur
Node : TSepiParseTreeNode | Symbole de grammaire, pour la position

Return
Types | Description
BOOLEAN | True si l'identificateur a été trouvé, False sinon

Sepi
Class Tree
Index
Previous
Next (CheckIdentFound)


Sepi

Sepi
Previous (CheckIdentFound)
Next (CheckTypeMatch)

Name
CheckIdentFound

Parent
SepiParseTrees

Visibility
PUBLIC

Description
Vérifie qu'un identificateur a bien été trouvé, et produit une erreur sinon

Source code
function CheckIdentFound ( const Expression : ISepiExpression ; const Identifier : string ; Node : TSepiParseTreeNode ) : Boolean ; overload

Parameters
Parameter | Description
Expression : ISepiExpression | Expression à vérifier
Identifier : STRING | Identificateur, pour le message d'erreur
Node : TSepiParseTreeNode | Symbole de grammaire, pour la position

Return
Types | Description
BOOLEAN | True si l'identificateur a été trouvé, False sinon

Sepi
Class Tree
Index
Previous (CheckIdentFound)
Next (CheckTypeMatch)


Sepi

Sepi
Previous (CheckIdentFound)
Next

Name
CheckTypeMatch

Parent
SepiParseTrees

Visibility
PUBLIC

Description
Vérifie que des types correspondent, et produit une erreur sinon

Source code
function CheckTypeMatch ( AssignedType , ExpressionType : TSepiType ; Node : TSepiParseTreeNode ) : Boolean

Parameters
Parameter | Description
AssignedType : TSepiType | Type de la variable assignée
ExpressionType : TSepiType | Type de l'expression
Node : TSepiParseTreeNode | Symbole de grammaire, pour la position

Return
Types | Description
BOOLEAN | True si les types correspondent, False sinon

Sepi
Class Tree
Index
Previous (CheckIdentFound)
Next


Sepi

Sepi
Previous (SepiParseTrees)
Next (SepiPSCompileTime)

Name
SepiPSCompiler

Parent
Sepi

Description
Compilateur d'unité Sepi-PS

Author
sjrd

Version
1.0

Types
Type Description

Constants
Constant | Description
sCantExportProc (+) | #No TAG found in source code#
sDeclDiffersFromPrevious (+) | #No TAG found in source code#

Methods
Method | Description
SepiPSCompile (+) | Compile une unité Sepi-PS
SepiPSCompile (+) | Compile une unité Sepi-PS

Classes
Class Description

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiParseTrees)
Next (SepiPSCompileTime)


Sepi

Sepi
Previous
Next (sDeclDiffersFromPrevious)

Name
sCantExportProc

Parent
SepiPSCompiler

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sCantExportProc = 'Impossible d''exporter la routine %s'

Sepi
Class Tree
Index
Previous
Next (sDeclDiffersFromPrevious)


Sepi

Sepi
Previous (sCantExportProc)
Next

Name
sDeclDiffersFromPrevious

Parent
SepiPSCompiler

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sDeclDiffersFromPrevious = 'La déclaration diffère de la précédente'

Sepi
Class Tree
Index
Previous (sCantExportProc)
Next


Sepi

Sepi
Previous
Next (SepiPSCompile)

Name
SepiPSCompile

Parent
SepiPSCompiler

Visibility
PUBLIC

Description
Compile une unité Sepi-PS

Source code
function SepiPSCompile ( const Source : string ; Output : TStream ; SepiUnit : TSepiUnit ; Errors : TStrings ; ExportUnexistingProcs : Boolean = True ) : Boolean ; overload

Parameters
Parameter | Description
Source : STRING | Code source
Output : TStream | Flux destination
SepiUnit : TSepiUnit | Unité compilée
Errors : TStrings | Liste de chaînes où enregister les erreurs
ExportUnexistingProcs : BOOLEAN

Return
Types | Description
BOOLEAN | True si la compilation s'est bien déroulée, False en cas d'erreur

Sepi
Class Tree
Index
Previous
Next (SepiPSCompile)


Sepi

Sepi
Previous (SepiPSCompile)
Next

Name
SepiPSCompile

Parent
SepiPSCompiler

Visibility
PUBLIC

Description
Compile une unité Sepi-PS

Source code
function SepiPSCompile ( const Source : string ; Output : TStream ; const UnitName : string ; Errors : TStrings ; const OnLoadUnit : TSepiLoadUnitEvent = nil ) : Boolean ; overload

Parameters
Parameter | Description
Source : STRING | Code source
Output : TStream | Flux destination
UnitName : STRING | Nom de l'unité
Errors : TStrings | Liste de chaînes où enregister les erreurs
OnLoadUnit : TSepiLoadUnitEvent | Méthode de call-back pour le chargement d'une unité

Return
Types | Description
BOOLEAN | True si la compilation s'est bien déroulée, False en cas d'erreur

Sepi
Class Tree
Index
Previous (SepiPSCompile)
Next


Sepi

Sepi
Previous (SepiPSCompiler)
Next (SepiPSExecuter)

Name
SepiPSCompileTime

Parent
Sepi

Description
Liaison Sepi-PS à la compilation

Author
sjrd

Version
1.0

Constants
Constant Description

Methods
Method | Description
SepiImportUnitInPSCompiler (+) | Importe le contenu d'une unité Sepi dans un compilateur Pascal Script
SepiImportUnitInPSCompiler (+) | Charge une unité Sepi et l'importe dans un compilateur Pascal Script

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiPSCompiler)
Next (SepiPSExecuter)


Sepi

Sepi
Previous
Next (SepiImportUnitInPSCompiler)

Name
SepiImportUnitInPSCompiler

Parent
SepiPSCompileTime

Visibility
PUBLIC

Description
Importe le contenu d'une unité Sepi dans un compilateur Pascal Script

Source code
procedure SepiImportUnitInPSCompiler ( SepiUnit : TSepiUnit ; PSCompiler : TPSPascalCompiler ) ; overload

Parameters
Parameter | Description
SepiUnit : TSepiUnit | Unité Sepi
PSCompiler : TPSPascalCompiler | Compilateur Pascal Script

Sepi
Class Tree
Index
Previous
Next (SepiImportUnitInPSCompiler)


Sepi

Sepi
Previous (SepiImportUnitInPSCompiler)
Next

Name
SepiImportUnitInPSCompiler

Parent
SepiPSCompileTime

Visibility
PUBLIC

Description
Charge une unité Sepi et l'importe dans un compilateur Pascal Script

Source code
procedure SepiImportUnitInPSCompiler ( Root : TSepiRoot ; const UnitName : string ; PSCompiler : TPSPascalCompiler ) ; overload

Parameters
Parameter | Description
Root : TSepiRoot | Racine Sepi
UnitName : STRING | Nom de l'unité Sepi
PSCompiler : TPSPascalCompiler | Compilateur Pascal Script

Sepi
Class Tree
Index
Previous (SepiImportUnitInPSCompiler)
Next


Sepi

Sepi
Previous (SepiPSCompileTime)
Next (SepiPSLoader)

Name
SepiPSExecuter

Parent
Sepi

Description
Exécuteur d'unité Sepi-PS

Author
sjrd

Version
1.0

Methods
Method | Description
SepiPSExecute (+) | Exécute un script Sepi-PS

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiPSCompileTime)
Next (SepiPSLoader)


Sepi

Sepi
Previous
Next

Name
SepiPSExecute

Parent
SepiPSExecuter

Visibility
PUBLIC

Description
Exécute un script Sepi-PS

Source code
procedure SepiPSExecute ( const UnitName : string )

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité à charger pour exécution

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiPSExecuter)
Next (SepiPSRunTime)

Name
SepiPSLoader

Parent
Sepi

Description
Chargeur d'unité Sepi-PS

Author
sjrd

Version
1.0

Constants
Constant | Description
sSepiPSExtension (+) | Extension des fichiers unité Sepi-PS

Methods
Method | Description
LoadSepiPSUnitFromFile (+) | Charge une unité Sepi-PS depuis un fichier
LoadSepiPSUnitFromName (+) | Charge une unité Sepi-PS depuis son nom
LoadSepiPSUnitFromStream (+) | Charge une unité Sepi-PS depuis un flux
SepiPSLoadUnit (+) | Routine de call-back pour l'événement OnLoadUnit de TSepiRoot

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiPSExecuter)
Next (SepiPSRunTime)


Sepi

Sepi
Previous
Next

Name
sSepiPSExtension

Parent
SepiPSLoader

Visibility
PUBLIC

Description
Extension des fichiers unité Sepi-PS

Source code
sSepiPSExtension = '.sps'

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (LoadSepiPSUnitFromName)

Name
LoadSepiPSUnitFromFile

Parent
SepiPSLoader

Visibility
PUBLIC

Description
Charge une unité Sepi-PS depuis un fichier

Source code
function LoadSepiPSUnitFromFile ( Root : TSepiRoot ; const FileName : TFileName ) : TSepiUnit

Parameters
Parameter | Description
Root : TSepiRoot | Racine Sepi
FileName : TFileName | Nom du fichier

Return
Types | Description
TSepiUnit | Unité Sepi chargée

Sepi
Class Tree
Index
Previous
Next (LoadSepiPSUnitFromName)


Sepi

Sepi
Previous (LoadSepiPSUnitFromFile)
Next (LoadSepiPSUnitFromStream)

Name
LoadSepiPSUnitFromName

Parent
SepiPSLoader

Visibility
PUBLIC

Description
Charge une unité Sepi-PS depuis son nom

Source code
function LoadSepiPSUnitFromName ( Root : TSepiRoot ; const UnitName : string ) : TSepiUnit

Parameters
Parameter | Description
Root : TSepiRoot | Racine Sepi
UnitName : STRING | Nom de l'unité

Return
Types | Description
TSepiUnit | Unité Sepi chargée

Sepi
Class Tree
Index
Previous (LoadSepiPSUnitFromFile)
Next (LoadSepiPSUnitFromStream)


Sepi

Sepi
Previous (LoadSepiPSUnitFromName)
Next (SepiPSLoadUnit)

Name
LoadSepiPSUnitFromStream

Parent
SepiPSLoader

Visibility
PUBLIC

Description
Charge une unité Sepi-PS depuis un flux

Source code
function LoadSepiPSUnitFromStream ( Root : TSepiRoot ; Stream : TStream ) : TSepiUnit

Parameters
Parameter | Description
Root : TSepiRoot | Racine Sepi
Stream : TStream | Flux source

Return
Types | Description
TSepiUnit | Unité Sepi chargée

Sepi
Class Tree
Index
Previous (LoadSepiPSUnitFromName)
Next (SepiPSLoadUnit)


Sepi

Sepi
Previous (LoadSepiPSUnitFromStream)
Next

Name
SepiPSLoadUnit

Parent
SepiPSLoader

Visibility
PUBLIC

Description
Routine de call-back pour l'événement OnLoadUnit de TSepiRoot

Source code
function SepiPSLoadUnit ( Self : TObject ; Root : TSepiRoot ; const UnitName : string ) : TSepiUnit

Parameters
Parameter | Description
Self : TObject | Objet courant, non utilisé
Root : TSepiRoot | Racine Sepi
UnitName : STRING | Nom de l'unité

Return
Types | Description
TSepiUnit | Unité Sepi chargée

Sepi
Class Tree
Index
Previous (LoadSepiPSUnitFromStream)
Next


Sepi

Sepi
Previous (SepiPSLoader)
Next (SepiPSUtils)

Name
SepiPSRunTime

Parent
Sepi

Description
Liaison Sepi-PS à l'exécution

Author
sjrd

Version
1.0

Constants
Constant Description

Methods
Method | Description
SepiLoadPSExecuter (+) | Charge complètement un script Pascal Script basé sur Sepi
SepiRegisterClassesInPSExecuter (+) | Recense les classes d'une racine Sepi dans un interpréteur Pascal Script
SepiRegisterProcsInPSExecuter (+) | Recense les routines d'une unité Sepi dans un interpréteur Pascal Script
SepiRegisterVarsInPSExecuter (+) | Recense les variables d'une unité Sepi dans un interpréteur Pascal Script

Classes
Class Description

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiPSLoader)
Next (SepiPSUtils)


Sepi

Sepi
Previous
Next (SepiRegisterClassesInPSExecuter)

Name
SepiLoadPSExecuter

Parent
SepiPSRunTime

Visibility
PUBLIC

Description
Charge complètement un script Pascal Script basé sur Sepi
Cette routine est un raccourci pour les trois autres
SepiRegisterClassesInPSExecuter, SepiRegisterProcsInPSExecuter et
SepiRegisterVarsInPSExecuter, mais elle prend en charge elle-même le
chargement de Pascal Script, ce qui empêche, ou du moins rend moins évident,
l'ajout d'autres éléments.

Source code
function SepiLoadPSExecuter ( SepiRoot : TSepiRoot ; const SepiUnits : array of TSepiUnit ; PSExecuter : TPSExec ; const Compiled : string ) : Boolean

Parameters
Parameter | Description
SepiRoot : TSepiRoot | Racine Sepi
SepiUnits : TSepiUnit | Liste des unités Sepi à importer
PSExecuter : TPSExec | Interpréteur Pascal Script
Compiled : STRING | Données compilées Pascal Script

Return
Types | Description
BOOLEAN | True si le chargement s'est bien passé, False sinon

Sepi
Class Tree
Index
Previous
Next (SepiRegisterClassesInPSExecuter)


Sepi

Sepi
Previous (SepiLoadPSExecuter)
Next (SepiRegisterProcsInPSExecuter)

Name
SepiRegisterClassesInPSExecuter

Parent
SepiPSRunTime

Visibility
PUBLIC

Description
Recense les classes d'une racine Sepi dans un interpréteur Pascal Script

Source code
procedure SepiRegisterClassesInPSExecuter ( SepiRoot : TSepiRoot ; PSExecuter : TPSExec )

Parameters
Parameter | Description
SepiRoot : TSepiRoot | Racine Sepi
PSExecuter : TPSExec | Interpréteur Pascal Script

Sepi
Class Tree
Index
Previous (SepiLoadPSExecuter)
Next (SepiRegisterProcsInPSExecuter)


Sepi

Sepi
Previous (SepiRegisterClassesInPSExecuter)
Next (SepiRegisterVarsInPSExecuter)

Name
SepiRegisterProcsInPSExecuter

Parent
SepiPSRunTime

Visibility
PUBLIC

Description
Recense les routines d'une unité Sepi dans un interpréteur Pascal Script

Source code
procedure SepiRegisterProcsInPSExecuter ( SepiUnit : TSepiUnit ; PSExecuter : TPSExec )

Parameters
Parameter | Description
SepiUnit : TSepiUnit | Unité Sepi
PSExecuter : TPSExec | Interpréteur Pascal Script

Sepi
Class Tree
Index
Previous (SepiRegisterClassesInPSExecuter)
Next (SepiRegisterVarsInPSExecuter)


Sepi

Sepi
Previous (SepiRegisterProcsInPSExecuter)
Next

Name
SepiRegisterVarsInPSExecuter

Parent
SepiPSRunTime

Visibility
PUBLIC

Description
Recense les variables d'une unité Sepi dans un interpréteur Pascal Script

Source code
procedure SepiRegisterVarsInPSExecuter ( SepiUnit : TSepiUnit ; PSExecuter : TPSExec )

Parameters
Parameter | Description
SepiUnit : TSepiUnit | Unité Sepi
PSExecuter : TPSExec | Interpréteur Pascal Script

Sepi
Class Tree
Index
Previous (SepiRegisterProcsInPSExecuter)
Next


Sepi

Sepi
Previous (SepiPSRunTime)
Next (SepiReflectionConsts)

Name
SepiPSUtils

Parent
Sepi

Description
Utilitaires pour les liaisons Sepi-PS

Author
sjrd

Version
1.0

Constants
Constant | Description
CallingConvSepiToPS (+) | Tableau de conversion des conventions d'appel Sepi vers Pascal Script

Methods
Method | Description
HandleOverloaded (+) | Gère le cas des noms de méthodes surchargées

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiPSRunTime)
Next (SepiReflectionConsts)


Sepi

Sepi
Previous
Next

Name
CallingConvSepiToPS

Parent
SepiPSUtils

Visibility
PUBLIC

Description
Tableau de conversion des conventions d'appel Sepi vers Pascal Script

Source code
CallingConvSepiToPS : array [ TCallingConvention ] of TPSCallingConvention = ( cdRegister , cdCdecl , cdPascal , cdStdCall , cdSafecall )

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
HandleOverloaded

Parent
SepiPSUtils

Visibility
PUBLIC

Description
Gère le cas des noms de méthodes surchargées

Source code
function HandleOverloaded ( const Name : string ; out PSName , SecondName : string ) : Boolean

Parameters
Parameter | Description
NAME : STRING | Nom Sepi de la méthode
PSName : STRING | Nom Pascal Script de la méthode
SecondName : STRING | Variante Pascal Script (seulement si renvoie True)

Return
Types | Description
BOOLEAN | True si SecondName doit être utilisé, False sinon

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiPSUtils)
Next (SepiReflectionCore)

Name
SepiReflectionConsts

Parent
Sepi

Description
Définit les constantes du package SepiBinaries

Author
sjrd

Version
1.0

Constants
Constant | Description
SCantCloneType (+) | #No TAG found in source code#
SOutOfBoundsEnumValue (+) | #No TAG found in source code#
SSepiBadConstType (+) | #No TAG found in source code#
SSepiCantSaveLazyLoadUnit (+) | #No TAG found in source code#
SSepiComponentAlreadyAssigned (+) | #No TAG found in source code#
SSepiComponentAlreadyCreated (+) | #No TAG found in source code#
SSepiComponentAlreadyExists (+) | #No TAG found in source code#
SSepiComponentNotFound (+) | #No TAG found in source code#
SSepiIncompatibleUsedUnitComponentNotFound (+) | #No TAG found in source code#
SSepiIncompatibleUsedUnitIncompatibleComponent (+) | #No TAG found in source code#
SSepiUnitNotFound (+) | #No TAG found in source code#
SSepiUnsupportedIntfCallConvention (+) | #No TAG found in source code#
SSignatureAlreadyCompleted (+) | #No TAG found in source code#
SUnknownValue (+) | #No TAG found in source code#
SUntypedTypeDescription (+) | #No TAG found in source code#
SUntypedTypeName (+) | Nom du type non typé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiPSUtils)
Next (SepiReflectionCore)


Sepi

Sepi
Previous
Next (SOutOfBoundsEnumValue)

Name
SCantCloneType

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SCantCloneType = 'Impossible de cloner le type %s'

Sepi
Class Tree
Index
Previous
Next (SOutOfBoundsEnumValue)


Sepi

Sepi
Previous (SCantCloneType)
Next (SSepiBadConstType)

Name
SOutOfBoundsEnumValue

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SOutOfBoundsEnumValue = 'Hors bornes (%d)'

Sepi
Class Tree
Index
Previous (SCantCloneType)
Next (SSepiBadConstType)


Sepi

Sepi
Previous (SOutOfBoundsEnumValue)
Next (SSepiCantSaveLazyLoadUnit)

Name
SSepiBadConstType

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiBadConstType = 'Impossible de créer une constante de type variant %d'

Sepi
Class Tree
Index
Previous (SOutOfBoundsEnumValue)
Next (SSepiCantSaveLazyLoadUnit)


Sepi

Sepi
Previous (SSepiBadConstType)
Next (SSepiComponentAlreadyAssigned)

Name
SSepiCantSaveLazyLoadUnit

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiCantSaveLazyLoadUnit = 'Impossible d''enregistrer une unité en mode lazy-load'

Sepi
Class Tree
Index
Previous (SSepiBadConstType)
Next (SSepiComponentAlreadyAssigned)


Sepi

Sepi
Previous (SSepiCantSaveLazyLoadUnit)
Next (SSepiComponentAlreadyCreated)

Name
SSepiComponentAlreadyAssigned

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiComponentAlreadyAssigned = 'Le composant à la position %d est déjà assigné'

Sepi
Class Tree
Index
Previous (SSepiCantSaveLazyLoadUnit)
Next (SSepiComponentAlreadyCreated)


Sepi

Sepi
Previous (SSepiComponentAlreadyAssigned)
Next (SSepiComponentAlreadyExists)

Name
SSepiComponentAlreadyCreated

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiComponentAlreadyCreated = 'Le composant de nom ''%s'' a déjà été créé'

Sepi
Class Tree
Index
Previous (SSepiComponentAlreadyAssigned)
Next (SSepiComponentAlreadyExists)


Sepi

Sepi
Previous (SSepiComponentAlreadyCreated)
Next (SSepiComponentNotFound)

Name
SSepiComponentAlreadyExists

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiComponentAlreadyExists = 'Un composant de nom ''%s'' existe déjà'

Sepi
Class Tree
Index
Previous (SSepiComponentAlreadyCreated)
Next (SSepiComponentNotFound)


Sepi

Sepi
Previous (SSepiComponentAlreadyExists)
Next (SSepiIncompatibleUsedUnitComponentNotFound)

Name
SSepiComponentNotFound

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiComponentNotFound = 'Composant %s non trouvé'

Sepi
Class Tree
Index
Previous (SSepiComponentAlreadyExists)
Next (SSepiIncompatibleUsedUnitComponentNotFound)


Sepi

Sepi
Previous (SSepiComponentNotFound)
Next (SSepiIncompatibleUsedUnitIncompatibleComponent)

Name
SSepiIncompatibleUsedUnitComponentNotFound

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiIncompatibleUsedUnitComponentNotFound = 'L''unité ''%s'' a été compilée avec une version différente de l''unité ' + 'utilisée ''%s'' (composant %s non trouvé), et doit être recompilée.'

Sepi
Class Tree
Index
Previous (SSepiComponentNotFound)
Next (SSepiIncompatibleUsedUnitIncompatibleComponent)


Sepi

Sepi
Previous (SSepiIncompatibleUsedUnitComponentNotFound)
Next (SSepiUnitNotFound)

Name
SSepiIncompatibleUsedUnitIncompatibleComponent

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiIncompatibleUsedUnitIncompatibleComponent = 'L''unité ''%s'' a été compilée avec une version différente de l''unité ' + 'utilisée ''%s'' (composant %s incompatible), et doit être recompilée.'

Sepi
Class Tree
Index
Previous (SSepiIncompatibleUsedUnitComponentNotFound)
Next (SSepiUnitNotFound)


Sepi

Sepi
Previous (SSepiIncompatibleUsedUnitIncompatibleComponent)
Next (SSepiUnsupportedIntfCallConvention)

Name
SSepiUnitNotFound

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiUnitNotFound = 'Impossible de trouver l''unité %s'

Sepi
Class Tree
Index
Previous (SSepiIncompatibleUsedUnitIncompatibleComponent)
Next (SSepiUnsupportedIntfCallConvention)


Sepi

Sepi
Previous (SSepiUnitNotFound)
Next (SSignatureAlreadyCompleted)

Name
SSepiUnsupportedIntfCallConvention

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSepiUnsupportedIntfCallConvention = 'La convention d''appel %s n''est pas encore supportée pour les interfaces'

Sepi
Class Tree
Index
Previous (SSepiUnitNotFound)
Next (SSignatureAlreadyCompleted)


Sepi

Sepi
Previous (SSepiUnsupportedIntfCallConvention)
Next (SUnknownValue)

Name
SSignatureAlreadyCompleted

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SSignatureAlreadyCompleted = 'La signature est déjà complétée'

Sepi
Class Tree
Index
Previous (SSepiUnsupportedIntfCallConvention)
Next (SUnknownValue)


Sepi

Sepi
Previous (SSignatureAlreadyCompleted)
Next (SUntypedTypeDescription)

Name
SUnknownValue

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SUnknownValue = '(%s)'

Sepi
Class Tree
Index
Previous (SSignatureAlreadyCompleted)
Next (SUntypedTypeDescription)


Sepi

Sepi
Previous (SUnknownValue)
Next (SUntypedTypeName)

Name
SUntypedTypeDescription

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
SUntypedTypeDescription = '(non typé)'

Sepi
Class Tree
Index
Previous (SUnknownValue)
Next (SUntypedTypeName)


Sepi

Sepi
Previous (SUntypedTypeDescription)
Next

Name
SUntypedTypeName

Parent
SepiReflectionConsts

Visibility
PUBLIC

Description
Nom du type non typé

Source code
SUntypedTypeName = '$Untyped'

Sepi
Class Tree
Index
Previous (SUntypedTypeDescription)
Next


Sepi

Sepi
Previous (SepiReflectionConsts)
Next (SepiRuntime)

Name
SepiReflectionCore

Parent
Sepi

Description
Définit les classes de gestion des meta-unités

Author
sjrd

Version
1.0

Types
Type | Description
TGetMethodCodeEvent (+) | Type de l'événement OnGetMethodCode de TSepiUnit
TGetTypeInfoEvent (+) | Type de l'événement OnGetTypeInfo de TSepiUnit
TGetVarAddressEvent (+) | Type de l'événement OnGetVarAddress de TSepiUnit
TMemberVisibility (+) | Visibilité d'un composant
TSepiComponentState (+) | État d'un composant
TSepiDigest (+) | Digest de compatibilité d'un composant Sepi
TSepiImportUnitFunc (+) | Type de routine call-back pour l'import d'une unité sous Sepi
TSepiLazyLoadChildKind (+) | Type d'enfant pour le lazy-load
TSepiLazyLoadChildrenData (+) | Tableau de données lazy-load pour les enfants
TSepiLoadUnitEvent (+) | Type de l'événement OnLoadUnit de TSepiRoot
TSepiTypeResultBehavior (+) | Comportement d'un type lorsqu'il est valeur de retour

Constants
Constant | Description
DefaultTypeParamBehavior (+) | Comportement par des défaut d'un type comme paramètre
SystemUnitName (+) | Nom de l'unité System.pas
VisibilityStrings (+) | Chaînes des visibilités

Variables
Variable Description

Methods
Method | Description
SepiImportedUnit (+) | Cherche une routine d'import d'une unité
SepiRegisterComponentClasses (+) | Recense des classes de composants Sepi
SepiRegisterImportedUnit (+) | Recense une routine d'import d'unité
SepiUnregisterImportedUnit (+) | Supprime un recensement d'import d'unité

Classes
Class | Description
ESepiAlreadyCompleted (+) | Déclenchée lorsqu'on tente de modifier un élément déjà complété
ESepiBadConstTypeError (+) | Déclenchée si l'on tente de créer une constante avec un mauvais type
ESepiComponentAlreadyCreated (+) | Déclenchée si l'on tente de recréer un composant
ESepiComponentNotFoundError (+) | Déclenchée lorsque la recherche d'un composant s'est soldée par un échec
ESepiIncompatibleUsedUnitError (+) | Déclenchée si une unité utilisée est incompatible avec les digests connus
ESepiUnitNotFoundError (+) | Déclenchée lorsque la recherche d'une unité s'est soldée par un échec
TSepiAsynchronousRootManager (+) | Gestionnaire asynchrone de racine Sepi
TSepiComponent (+) | Composant Sepi
TSepiComponentList (+) | Liste de composants Sepi
TSepiConstant (+) | Constante
TSepiContainerType (+) | Type conteneur
TSepiLazyLoadChildData (+) | Données de lazy-load pour un enfant
TSepiLazyLoadData (+) | Données de lazy-load
TSepiMember (+) | Membre d'un type conteneur
TSepiNamespace (+) | Espace de noms (d'étendue plus petite qu'une unité)
TSepiRoot (+) | Racine de l'arbre de réflexion
TSepiRootFork (+) | Fork d'une racine Sepi
TSepiType (+) | Type
TSepiTypeAlias (+) | Alias de type
TSepiTypeParamBehavior (+) | Comportement d'un type lorsqu'il est passé en paramètre
TSepiUnit (+) | Unité
TSepiUnitAlias (+) | Alias d'unité
TSepiUnitLoadTask (+) | Tâche de chargement/déchargement d'une unité Sepi
TSepiUntypedType (+) | Type non typé
TSepiVariable (+) | Variable (ou constante typée)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiReflectionConsts)
Next (SepiRuntime)


Sepi

Sepi
Previous
Next (ESepiBadConstTypeError)

Name
ESepiAlreadyCompleted

Parent
SepiReflectionCore

Class Hierarchy
ESepiError

Visibility
PUBLIC

Description
Déclenchée lorsqu'on tente de modifier un élément déjà complété

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (ESepiBadConstTypeError)


Sepi

Sepi
Previous (ESepiAlreadyCompleted)
Next (ESepiComponentAlreadyCreated)

Name
ESepiBadConstTypeError

Parent
SepiReflectionCore

Class Hierarchy
ESepiError

Visibility
PUBLIC

Description
Déclenchée si l'on tente de créer une constante avec un mauvais type

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiAlreadyCompleted)
Next (ESepiComponentAlreadyCreated)


Sepi

Sepi
Previous (ESepiBadConstTypeError)
Next (ESepiComponentNotFoundError)

Name
ESepiComponentAlreadyCreated

Parent
SepiReflectionCore

Class Hierarchy
ESepiError

Visibility
PUBLIC

Description
Déclenchée si l'on tente de recréer un composant
(second appel au constructeur)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiBadConstTypeError)
Next (ESepiComponentNotFoundError)


Sepi

Sepi
Previous (ESepiComponentAlreadyCreated)
Next (ESepiIncompatibleUsedUnitError)

Name
ESepiComponentNotFoundError

Parent
SepiReflectionCore

Class Hierarchy
ESepiError

Visibility
PUBLIC

Description
Déclenchée lorsque la recherche d'un composant s'est soldée par un échec

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiComponentAlreadyCreated)
Next (ESepiIncompatibleUsedUnitError)


Sepi

Sepi
Previous (ESepiComponentNotFoundError)
Next (ESepiUnitNotFoundError)

Name
ESepiIncompatibleUsedUnitError

Parent
SepiReflectionCore

Class Hierarchy
ESepiError

Visibility
PUBLIC

Description
Déclenchée si une unité utilisée est incompatible avec les digests connus

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiComponentNotFoundError)
Next (ESepiUnitNotFoundError)


Sepi

Sepi
Previous (ESepiIncompatibleUsedUnitError)
Next (TSepiAsynchronousRootManager)

Name
ESepiUnitNotFoundError

Parent
SepiReflectionCore

Class Hierarchy
ESepiComponentNotFoundError

Visibility
PUBLIC

Description
Déclenchée lorsque la recherche d'une unité s'est soldée par un échec

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiIncompatibleUsedUnitError)
Next (TSepiAsynchronousRootManager)


Sepi

Sepi
Previous (ESepiUnitNotFoundError)
Next (TSepiComponent)

Name
TSepiAsynchronousRootManager

Parent
SepiReflectionCore

Class Hierarchy
TScTaskQueue

Visibility
PUBLIC

Description
Gestionnaire asynchrone de racine Sepi

Members
Fields
Field | Description
FOwnsRoot (-) | Indique si l'on possède la racine
FRoot (-) | Component-racine gérée

Methods
Method | Description
Create (+) | Crée un nouveau gestionnaire de racine
Destroy (+) | [@inheritDoc]
LoadUnit (+) | Demande le chargement d'une unité
UnloadUnit (+) | Demande le déchargement d'une unité

Properties
Property | Description
Root (+) | Component-racine gérée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (ESepiUnitNotFoundError)
Next (TSepiComponent)


Sepi

Sepi
Previous
Next (FRoot)

Name
FOwnsRoot

Parent
TSepiAsynchronousRootManager

Visibility
PRIVATE

Description
Indique si l'on possède la racine

Source code
FOwnsRoot : Boolean

Sepi
Class Tree
Index
Previous
Next (FRoot)


Sepi

Sepi
Previous (FOwnsRoot)
Next

Name
FRoot

Parent
TSepiAsynchronousRootManager

Visibility
PRIVATE

Description
Component-racine gérée

Source code
FRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FOwnsRoot)
Next


Sepi

Sepi
Previous
Next

Name
Root

Parent
TSepiAsynchronousRootManager

Visibility
PUBLIC

Description
Component-racine gérée

Source code
property Root : TSepiRoot read FRoot

Read Access
FRoot

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiAsynchronousRootManager

Visibility
PUBLIC

Description
Crée un nouveau gestionnaire de racine

Source code
constructor Create ( ARoot : TSepiRoot = nil )

Parameters
Parameter | Description
ARoot : TSepiRoot | Racine à gérer (si nil, la racine est créée et libérée)

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (LoadUnit)

Name
Destroy

Parent
TSepiAsynchronousRootManager

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (LoadUnit)


Sepi

Sepi
Previous (Destroy)
Next (UnloadUnit)

Name
LoadUnit

Parent
TSepiAsynchronousRootManager

Visibility
PUBLIC

Description
Demande le chargement d'une unité

Source code
procedure LoadUnit ( const UnitName : string )

Parameters
Parameter | Description
UnitName : STRING | Unité à charger

Sepi
Class Tree
Index
Previous (Destroy)
Next (UnloadUnit)


Sepi

Sepi
Previous (LoadUnit)
Next

Name
UnloadUnit

Parent
TSepiAsynchronousRootManager

Visibility
PUBLIC

Description
Demande le déchargement d'une unité

Source code
procedure UnloadUnit ( const UnitName : string )

Parameters
Parameter | Description
UnitName : STRING | Unité à charger

Sepi
Class Tree
Index
Previous (LoadUnit)
Next


Sepi

Sepi
Previous (TSepiAsynchronousRootManager)
Next (TSepiComponentList)

Name
TSepiComponent

Parent
SepiReflectionCore

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Composant Sepi
Les composants Sepi forment un arbre (dont la racine est de type TSepiRoot)
de tous les éléments de réflexion connus de Sepi.

Members
Fields
Field | Description
FChildren (-) | Liste des enfants
FCurrentVisibility (-) | Visibilité avec laquelle les enfants de ce composant seront créés
FDigest (-) | Digest de compatibilité
FDigestBuilt (-) | True ssi FDigest a déjà été construit
FForwards (-) | Liste des enfants forwards
FName (-) | Nom
FObjResources (-) | Liste des ressources objet
FOwner (-) | Propriétaire
FOwningUnit (-) | Unité contenante
FPtrResources (-) | Liste des ressources pointeur
FRoot (-) | Racine
FState (-) | État
FTag (-) | Tag
FUnnamedChildCount (-) | Nombre d'enfants créés anonymes
FVisibility (-) | Visibilité

Methods
Method | Description
AcquireObjResource (+) | S'approprie une ressource objet
AcquirePtrResource (+) | S'approprie une ressource pointeur
AddChild (#) | Ajoute un enfant
AddForward (-) | Ajoute un enfant forward
AddObjResource (+) | Ajoute un objet aux ressources du composant
AddPtrResource (+) | Ajoute un pointeur aux ressources du composant
AfterConstruction (+) | [@inheritDoc]
BeforeDestruction (+) | [@inheritDoc]
CheckDigest (+) | Vérifie le digest de compatibilité
CheckDigest (+) | Vérifie le digest de compatibilité
ChildAdded (#) | Appelé lorsqu'un enfant vient d'être ajouté
ChildRemoving (#) | Appelé lorsqu'un enfant va être supprimé
Create (+) | Crée un nouveau composant
Destroy (+) | [@inheritDoc]
Destroying (#) | Appelé lorsque l'environnement Sepi est sur le point d'être détruit
EnsureDigestBuilt (-) | S'assure que le digest de compatibilité a été construit
FindComponent (+) | Cherche un composant enfant
FindContainer (+) | Trouve le conteneur de ce composnat
GetChildByName (-) | Tableau des enfants indexés par leurs noms
GetChildCount (-) | Nombre d'enfants
GetChildren (-) | Tableau zero-based des enfants
GetComponent (+) | Cherche un composant enfant
GetDigest (-) | Digest de compatibilité
GetDisplayName (#) | Nom destiné à l'affichage
GetFullName (+) | Nom qualifié du composant, depuis l'unité contenante
GetIsForward (-) | Indique si le composant est encore en forward
GetShorterNameFrom (+) | Nom le plus court possible pour être référencé depuis un autre composant
GetTypeInfoName (-) | Nom à stocker dans les RTTI
GetTypeInfoNameSize (-) | Taille du nom à stocker dans les RTTI
GetWasForward (-) | Indique si le composant a été créé forward
InternalGetComponent (#) | Cherche un composant enfant
InternalLookFor (#) | Recherche un composant à partir de son nom
IsAncestor (+) | Teste si un composant donné est un ancêtre de ce composnat
IsVisibleFrom (+) | Teste si ce composant est visible depuis un composant donné
ListReferences (#) | Liste les références auprès de l'unité contenante, pour préparer la sauvegarde
Load (+) | Charge un composant depuis un flux
LoadChild (#) | Charge un enfant depuis un flux
LoadChildren (#) | Charge les enfants depuis un flux
Loaded (#) | Appelé lorsque l'unité contenante est complètement chargée/créée
LoadForwards (#) | Charge les forwards depuis un flux
LookFor (+) | Recherche un composant à partir de son nom à partir de ce composant
LookFor (+) | Recherche un composant à partir de son nom
MakeUnnamedChildName (+) | Construit un nom pour un enfant créé anonyme
ReAddChild (#) | Ajoute de nouveau un composant à la liste des enfants
RemoveChild (#) | Supprime un enfant
Save (#) | Enregistre le composant dans un flux
SaveChild (#) | Enregistre un enfant dans un flux
SaveChildren (#) | Enregistre les enfants dans un flux
SaveForwards (#) | Enregistre les forwards dans un flux
StoreTypeInfoName (+) | Enregistre le nom de ce composant dans des RTTI
WriteDigestData (#) | Écrit les données nécessaires au digest de compatibilité dans un flux
WriteDigestToStream (+) | Écrit le digest de compatibilité dans un flux

Properties
Property | Description
ChildByName (+) | Tableau des enfants indexés par leurs noms
ChildCount (+) | Nombre d'enfants
Children (+) | Tableau zero-based des enfants
CurrentVisibility (+) | Visibilité avec laquelle les enfants de ce composant seront créés
Digest (+) | Digest de compatibilité
DisplayName (+) | Nom destiné à l'affichage
IsForward (+) | Indique si le composant est encore en forward
NAME (+) | Nom
Owner (+) | Propriétaire
OwningUnit (+) | Unité contenante
Root (+) | Racine
State (#) | État
Tag (+) | Tag
TypeInfoName (+) | Nom à stocker dans les RTTI
TypeInfoNameSize (+) | Taille du nom à stocker dans les RTTI
Visibility (+) | Visibilité
WasForward (+) | Indique si le composant a été créé forward

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsynchronousRootManager)
Next (TSepiComponentList)


Sepi

Sepi
Previous
Next (FCurrentVisibility)

Name
FChildren

Parent
TSepiComponent

Visibility
PRIVATE

Description
Liste des enfants

Source code
FChildren : TSepiComponentList

Sepi
Class Tree
Index
Previous
Next (FCurrentVisibility)


Sepi

Sepi
Previous (FChildren)
Next (FDigest)

Name
FCurrentVisibility

Parent
TSepiComponent

Visibility
PRIVATE

Description
Visibilité avec laquelle les enfants de ce composant seront créés

Source code
FCurrentVisibility : TMemberVisibility

Sepi
Class Tree
Index
Previous (FChildren)
Next (FDigest)


Sepi

Sepi
Previous (FCurrentVisibility)
Next (FDigestBuilt)

Name
FDigest

Parent
TSepiComponent

Visibility
PRIVATE

Description
Digest de compatibilité

Source code
FDigest : TSepiDigest

Sepi
Class Tree
Index
Previous (FCurrentVisibility)
Next (FDigestBuilt)


Sepi

Sepi
Previous (FDigest)
Next (FForwards)

Name
FDigestBuilt

Parent
TSepiComponent

Visibility
PRIVATE

Description
True ssi FDigest a déjà été construit

Source code
FDigestBuilt : Boolean

Sepi
Class Tree
Index
Previous (FDigest)
Next (FForwards)


Sepi

Sepi
Previous (FDigestBuilt)
Next (FName)

Name
FForwards

Parent
TSepiComponent

Visibility
PRIVATE

Description
Liste des enfants forwards

Source code
FForwards : TStrings

Sepi
Class Tree
Index
Previous (FDigestBuilt)
Next (FName)


Sepi

Sepi
Previous (FForwards)
Next (FObjResources)

Name
FName

Parent
TSepiComponent

Visibility
PRIVATE

Description
Nom

Source code
FName : string

Sepi
Class Tree
Index
Previous (FForwards)
Next (FObjResources)


Sepi

Sepi
Previous (FName)
Next (FOwner)

Name
FObjResources

Parent
TSepiComponent

Visibility
PRIVATE

Description
Liste des ressources objet

Source code
FObjResources : TObjectList

Sepi
Class Tree
Index
Previous (FName)
Next (FOwner)


Sepi

Sepi
Previous (FObjResources)
Next (FOwningUnit)

Name
FOwner

Parent
TSepiComponent

Visibility
PRIVATE

Description
Propriétaire

Source code
FOwner : TSepiComponent

Sepi
Class Tree
Index
Previous (FObjResources)
Next (FOwningUnit)


Sepi

Sepi
Previous (FOwner)
Next (FPtrResources)

Name
FOwningUnit

Parent
TSepiComponent

Visibility
PRIVATE

Description
Unité contenante

Source code
FOwningUnit : TSepiUnit

Sepi
Class Tree
Index
Previous (FOwner)
Next (FPtrResources)


Sepi

Sepi
Previous (FOwningUnit)
Next (FRoot)

Name
FPtrResources

Parent
TSepiComponent

Visibility
PRIVATE

Description
Liste des ressources pointeur

Source code
FPtrResources : TList

Sepi
Class Tree
Index
Previous (FOwningUnit)
Next (FRoot)


Sepi

Sepi
Previous (FPtrResources)
Next (FState)

Name
FRoot

Parent
TSepiComponent

Visibility
PRIVATE

Description
Racine

Source code
FRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FPtrResources)
Next (FState)


Sepi

Sepi
Previous (FRoot)
Next (FTag)

Name
FState

Parent
TSepiComponent

Visibility
PRIVATE

Description
État

Source code
FState : TSepiComponentState

Sepi
Class Tree
Index
Previous (FRoot)
Next (FTag)


Sepi

Sepi
Previous (FState)
Next (FUnnamedChildCount)

Name
FTag

Parent
TSepiComponent

Visibility
PRIVATE

Description
Tag

Source code
FTag : Integer

Sepi
Class Tree
Index
Previous (FState)
Next (FUnnamedChildCount)


Sepi

Sepi
Previous (FTag)
Next (FVisibility)

Name
FUnnamedChildCount

Parent
TSepiComponent

Visibility
PRIVATE

Description
Nombre d'enfants créés anonymes

Source code
FUnnamedChildCount : Integer

Sepi
Class Tree
Index
Previous (FTag)
Next (FVisibility)


Sepi

Sepi
Previous (FUnnamedChildCount)
Next

Name
FVisibility

Parent
TSepiComponent

Visibility
PRIVATE

Description
Visibilité

Source code
FVisibility : TMemberVisibility

Sepi
Class Tree
Index
Previous (FUnnamedChildCount)
Next


Sepi

Sepi
Previous
Next (ChildCount)

Name
ChildByName

Parent
TSepiComponent

Visibility
PUBLIC

Description
Tableau des enfants indexés par leurs noms

Source code
property ChildByName [ const ChildName : string ] : TSepiComponent read GetChildByName ; default

Read Access
GetChildByName

Sepi
Class Tree
Index
Previous
Next (ChildCount)


Sepi

Sepi
Previous (ChildByName)
Next (Children)

Name
ChildCount

Parent
TSepiComponent

Visibility
PUBLIC

Description
Nombre d'enfants

Source code
property ChildCount : Integer read GetChildCount

Read Access
GetChildCount

Sepi
Class Tree
Index
Previous (ChildByName)
Next (Children)


Sepi

Sepi
Previous (ChildCount)
Next (CurrentVisibility)

Name
Children

Parent
TSepiComponent

Visibility
PUBLIC

Description
Tableau zero-based des enfants

Source code
property Children [ Index : Integer ] : TSepiComponent read GetChildren

Read Access
GetChildren

Sepi
Class Tree
Index
Previous (ChildCount)
Next (CurrentVisibility)


Sepi

Sepi
Previous (Children)
Next (Digest)

Name
CurrentVisibility

Parent
TSepiComponent

Visibility
PUBLIC

Description
Visibilité avec laquelle les enfants de ce composant seront créés

Source code
property CurrentVisibility : TMemberVisibility read FCurrentVisibility write FCurrentVisibility

Read Access
FCurrentVisibility

Write Access
FCurrentVisibility

Sepi
Class Tree
Index
Previous (Children)
Next (Digest)


Sepi

Sepi
Previous (CurrentVisibility)
Next (DisplayName)

Name
Digest

Parent
TSepiComponent

Visibility
PUBLIC

Description
Digest de compatibilité

Source code
property Digest : TSepiDigest read GetDigest

Read Access
GetDigest

Sepi
Class Tree
Index
Previous (CurrentVisibility)
Next (DisplayName)


Sepi

Sepi
Previous (Digest)
Next (IsForward)

Name
DisplayName

Parent
TSepiComponent

Visibility
PUBLIC

Description
Nom destiné à l'affichage

Source code
property DisplayName : string read GetDisplayName

Read Access
GetDisplayName

Sepi
Class Tree
Index
Previous (Digest)
Next (IsForward)


Sepi

Sepi
Previous (DisplayName)
Next (NAME)

Name
IsForward

Parent
TSepiComponent

Visibility
PUBLIC

Description
Indique si le composant est encore en forward

Source code
property IsForward : Boolean read GetIsForward

Read Access
GetIsForward

Sepi
Class Tree
Index
Previous (DisplayName)
Next (NAME)


Sepi

Sepi
Previous (IsForward)
Next (Owner)

Name
NAME

Parent
TSepiComponent

Visibility
PUBLIC

Description
Nom

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (IsForward)
Next (Owner)


Sepi

Sepi
Previous (NAME)
Next (OwningUnit)

Name
Owner

Parent
TSepiComponent

Visibility
PUBLIC

Description
Propriétaire

Source code
property Owner : TSepiComponent read FOwner

Read Access
FOwner

Sepi
Class Tree
Index
Previous (NAME)
Next (OwningUnit)


Sepi

Sepi
Previous (Owner)
Next (Root)

Name
OwningUnit

Parent
TSepiComponent

Visibility
PUBLIC

Description
Unité contenante

Source code
property OwningUnit : TSepiUnit read FOwningUnit

Read Access
FOwningUnit

Sepi
Class Tree
Index
Previous (Owner)
Next (Root)


Sepi

Sepi
Previous (OwningUnit)
Next (State)

Name
Root

Parent
TSepiComponent

Visibility
PUBLIC

Description
Racine

Source code
property Root : TSepiRoot read FRoot

Read Access
FRoot

Sepi
Class Tree
Index
Previous (OwningUnit)
Next (State)


Sepi

Sepi
Previous (Root)
Next (Tag)

Name
State

Parent
TSepiComponent

Visibility
PROTECTED

Description
État

Source code
property State : TSepiComponentState read FState

Read Access
FState

Sepi
Class Tree
Index
Previous (Root)
Next (Tag)


Sepi

Sepi
Previous (State)
Next (TypeInfoName)

Name
Tag

Parent
TSepiComponent

Visibility
PUBLIC

Description
Tag

Source code
property Tag : Integer read FTag write FTag

Read Access
FTag

Write Access
FTag

Sepi
Class Tree
Index
Previous (State)
Next (TypeInfoName)


Sepi

Sepi
Previous (Tag)
Next (TypeInfoNameSize)

Name
TypeInfoName

Parent
TSepiComponent

Visibility
PUBLIC

Description
Nom à stocker dans les RTTI

Source code
property TypeInfoName : TypeInfoString read GetTypeInfoName

Read Access
GetTypeInfoName

Sepi
Class Tree
Index
Previous (Tag)
Next (TypeInfoNameSize)


Sepi

Sepi
Previous (TypeInfoName)
Next (Visibility)

Name
TypeInfoNameSize

Parent
TSepiComponent

Visibility
PUBLIC

Description
Taille du nom à stocker dans les RTTI

Source code
property TypeInfoNameSize : Integer read GetTypeInfoNameSize

Read Access
GetTypeInfoNameSize

Sepi
Class Tree
Index
Previous (TypeInfoName)
Next (Visibility)


Sepi

Sepi
Previous (TypeInfoNameSize)
Next (WasForward)

Name
Visibility

Parent
TSepiComponent

Visibility
PUBLIC

Description
Visibilité

Source code
property Visibility : TMemberVisibility read FVisibility write FVisibility

Read Access
FVisibility

Write Access
FVisibility

Sepi
Class Tree
Index
Previous (TypeInfoNameSize)
Next (WasForward)


Sepi

Sepi
Previous (Visibility)
Next

Name
WasForward

Parent
TSepiComponent

Visibility
PUBLIC

Description
Indique si le composant a été créé forward

Source code
property WasForward : Boolean read GetWasForward

Read Access
GetWasForward

Sepi
Class Tree
Index
Previous (Visibility)
Next


Sepi

Sepi
Previous
Next (AcquirePtrResource)

Name
AcquireObjResource

Parent
TSepiComponent

Visibility
PUBLIC

Description
S'approprie une ressource objet
L'objet est ajouté aux ressources objet du composant, puis le paramètre Obj
est mis à nil, afin qu'un Free ultérieur sur celui-ci ne fasse plus rien.

Source code
procedure AcquireObjResource ( var Obj )

Parameters
Parameter | Description
Obj : Untyped | Objet à ajouter aux ressources

Sepi
Class Tree
Index
Previous
Next (AcquirePtrResource)


Sepi

Sepi
Previous (AcquireObjResource)
Next (AddChild)

Name
AcquirePtrResource

Parent
TSepiComponent

Visibility
PUBLIC

Description
S'approprie une ressource pointeur
Le pointeur est ajouté aux ressources pointeur du composant, puis le paramètre
Ptr est mis à nil, afin que le code appelant puisse tester l'égalité à nil
avant de le libérer lui-même.

Source code
procedure AcquirePtrResource ( var Ptr )

Parameters
Parameter | Description
PTR : Untyped | Pointeur à ajouter aux ressources

Sepi
Class Tree
Index
Previous (AcquireObjResource)
Next (AddChild)


Sepi

Sepi
Previous (AcquirePtrResource)
Next (AddForward)

Name
AddChild

Parent
TSepiComponent

Visibility
PROTECTED

Description
Ajoute un enfant
AddChild est appelée dans le constructeur du meta enfant, et ne doit pas être
appelée ailleurs.

Source code
procedure AddChild ( Child : TSepiComponent ) ; virtual

Parameters
Parameter | Description
Child : TSepiComponent | Enfant à ajouter

Sepi
Class Tree
Index
Previous (AcquirePtrResource)
Next (AddForward)


Sepi

Sepi
Previous (AddChild)
Next (AddObjResource)

Name
AddForward

Parent
TSepiComponent

Visibility
PRIVATE

Description
Ajoute un enfant forward

Source code
procedure AddForward ( Child : TSepiComponent )

Parameters
Parameter | Description
Child : TSepiComponent | Enfant à ajouter

Sepi
Class Tree
Index
Previous (AddChild)
Next (AddObjResource)


Sepi

Sepi
Previous (AddForward)
Next (AddPtrResource)

Name
AddObjResource

Parent
TSepiComponent

Visibility
PUBLIC

Description
Ajoute un objet aux ressources du composant
Tous les objets ajoutés aux ressources du meta seront libérés lorsque le
composant sera libéré lui-même.

Source code
procedure AddObjResource ( Obj : TObject )

Parameters
Parameter | Description
Obj : TObject | Objet à ajouter aux ressources

Sepi
Class Tree
Index
Previous (AddForward)
Next (AddPtrResource)


Sepi

Sepi
Previous (AddObjResource)
Next (AfterConstruction)

Name
AddPtrResource

Parent
TSepiComponent

Visibility
PUBLIC

Description
Ajoute un pointeur aux ressources du composant
Tous les pointeurs ajoutés aux ressources du composant seront libérés lorsque
le composant sera libéré lui-même.

Source code
procedure AddPtrResource ( Ptr : Pointer )

Parameters
Parameter | Description
PTR : Pointer | Pointeur à ajouter aux ressources

Sepi
Class Tree
Index
Previous (AddObjResource)
Next (AfterConstruction)


Sepi

Sepi
Previous (AddPtrResource)
Next (BeforeDestruction)

Name
AfterConstruction

Parent
TSepiComponent

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddPtrResource)
Next (BeforeDestruction)


Sepi

Sepi
Previous (AfterConstruction)
Next (CheckDigest)

Name
BeforeDestruction

Parent
TSepiComponent

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (CheckDigest)


Sepi

Sepi
Previous (BeforeDestruction)
Next (CheckDigest)

Name
CheckDigest

Parent
TSepiComponent

Visibility
PUBLIC

Description
Vérifie le digest de compatibilité

Source code
function CheckDigest ( const ADigest : TSepiDigest ) : Boolean ; overload

Parameters
Parameter | Description
ADigest : TSepiDigest | Digest attendu

Return
Types | Description
BOOLEAN | True si le digest est correct, False sinon

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (CheckDigest)


Sepi

Sepi
Previous (CheckDigest)
Next (ChildAdded)

Name
CheckDigest

Parent
TSepiComponent

Visibility
PUBLIC

Description
Vérifie le digest de compatibilité

Source code
function CheckDigest ( const ADigest : string ) : Boolean ; overload

Parameters
Parameter | Description
ADigest : STRING | Digest attendu sous forme de chaîne

Return
Types | Description
BOOLEAN | True si le digest est correct, False sinon

Sepi
Class Tree
Index
Previous (CheckDigest)
Next (ChildAdded)


Sepi

Sepi
Previous (CheckDigest)
Next (ChildRemoving)

Name
ChildAdded

Parent
TSepiComponent

Visibility
PROTECTED

Description
Appelé lorsqu'un enfant vient d'être ajouté

Source code
procedure ChildAdded ( Child : TSepiComponent ) ; virtual

Parameters
Parameter | Description
Child : TSepiComponent | Enfant qui vient d'être ajouté

Sepi
Class Tree
Index
Previous (CheckDigest)
Next (ChildRemoving)


Sepi

Sepi
Previous (ChildAdded)
Next (Create)

Name
ChildRemoving

Parent
TSepiComponent

Visibility
PROTECTED

Description
Appelé lorsqu'un enfant va être supprimé

Source code
procedure ChildRemoving ( Child : TSepiComponent ) ; virtual

Parameters
Parameter | Description
Child : TSepiComponent | Enfant sur le point d'être supprimé

Sepi
Class Tree
Index
Previous (ChildAdded)
Next (Create)


Sepi

Sepi
Previous (ChildRemoving)
Next (Destroy)

Name
Create

Parent
TSepiComponent

Visibility
PUBLIC

Description
Crée un nouveau composant

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du composant
AName : STRING | Nom du composant

Sepi
Class Tree
Index
Previous (ChildRemoving)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Destroying)

Name
Destroy

Parent
TSepiComponent

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroying)


Sepi

Sepi
Previous (Destroy)
Next (EnsureDigestBuilt)

Name
Destroying

Parent
TSepiComponent

Visibility
PROTECTED

Description
Appelé lorsque l'environnement Sepi est sur le point d'être détruit

Source code
procedure Destroying ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (EnsureDigestBuilt)


Sepi

Sepi
Previous (Destroying)
Next (FindComponent)

Name
EnsureDigestBuilt

Parent
TSepiComponent

Visibility
PRIVATE

Description
S'assure que le digest de compatibilité a été construit

Source code
procedure EnsureDigestBuilt

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroying)
Next (FindComponent)


Sepi

Sepi
Previous (EnsureDigestBuilt)
Next (FindContainer)

Name
FindComponent

Parent
TSepiComponent

Visibility
PUBLIC

Description
Cherche un composant enfant

Exception
ESepiComponentNotFoundError Le composant n'a pas été trouvé

Source code
function FindComponent ( const Name : string ) : TSepiComponent

Parameters
Parameter | Description
NAME : STRING | Nom du composant à trouver

Return
Types | Description
TSepiComponent | Le composant correspondant

Sepi
Class Tree
Index
Previous (EnsureDigestBuilt)
Next (FindContainer)


Sepi

Sepi
Previous (FindComponent)
Next (GetChildByName)

Name
FindContainer

Parent
TSepiComponent

Visibility
PUBLIC

Description
Trouve le conteneur de ce composnat

Source code
function FindContainer : TSepiContainerType

Parameters
Parameter Description

Return
Types | Description
TSepiContainerType | Conteneur de ce composant, ou nil s'il n'y en a pas

Sepi
Class Tree
Index
Previous (FindComponent)
Next (GetChildByName)


Sepi

Sepi
Previous (FindContainer)
Next (GetChildCount)

Name
GetChildByName

Parent
TSepiComponent

Visibility
PRIVATE

Description
Tableau des enfants indexés par leurs noms
À l'inverse de la fonction FindComponent, les noms composés ne sont pas
acceptés.

Exception
ESepiComponentNotFoundError L'enfant n'a pas été trouvé

Source code
function GetChildByName ( const ChildName : string ) : TSepiComponent

Parameters
Parameter | Description
ChildName : STRING | Nom de l'enfant recherché

Return
Types | Description
TSepiComponent | Enfant dont le nom est ChildName

Sepi
Class Tree
Index
Previous (FindContainer)
Next (GetChildCount)


Sepi

Sepi
Previous (GetChildByName)
Next (GetChildren)

Name
GetChildCount

Parent
TSepiComponent

Visibility
PRIVATE

Description
Nombre d'enfants

Source code
function GetChildCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'enfants

Sepi
Class Tree
Index
Previous (GetChildByName)
Next (GetChildren)


Sepi

Sepi
Previous (GetChildCount)
Next (GetComponent)

Name
GetChildren

Parent
TSepiComponent

Visibility
PRIVATE

Description
Tableau zero-based des enfants

Source code
function GetChildren ( Index : Integer ) : TSepiComponent

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'enfant à récupérer

Return
Types | Description
TSepiComponent | Enfant à l'index spécifié

Sepi
Class Tree
Index
Previous (GetChildCount)
Next (GetComponent)


Sepi

Sepi
Previous (GetChildren)
Next (GetDigest)

Name
GetComponent

Parent
TSepiComponent

Visibility
PUBLIC

Description
Cherche un composant enfant

Source code
function GetComponent ( const Name : string ) : TSepiComponent

Parameters
Parameter | Description
NAME : STRING | Nom du composant à trouver

Return
Types | Description
TSepiComponent | Le composant correspondant, ou nil s'il n'a pas été trouvé

Sepi
Class Tree
Index
Previous (GetChildren)
Next (GetDigest)


Sepi

Sepi
Previous (GetComponent)
Next (GetDisplayName)

Name
GetDigest

Parent
TSepiComponent

Visibility
PRIVATE

Description
Digest de compatibilité

Source code
function GetDigest : TSepiDigest

Parameters
Parameter Description

Return
Types | Description
TSepiDigest | Digest de compatibilité

Sepi
Class Tree
Index
Previous (GetComponent)
Next (GetDisplayName)


Sepi

Sepi
Previous (GetDigest)
Next (GetFullName)

Name
GetDisplayName

Parent
TSepiComponent

Visibility
PROTECTED

Description
Nom destiné à l'affichage

Source code
function GetDisplayName : string ; virtual

Parameters
Parameter Description

Return
Types | Description
STRING | Nom destiné à l'affichage

Sepi
Class Tree
Index
Previous (GetDigest)
Next (GetFullName)


Sepi

Sepi
Previous (GetDisplayName)
Next (GetIsForward)

Name
GetFullName

Parent
TSepiComponent

Visibility
PUBLIC

Description
Nom qualifié du composant, depuis l'unité contenante

Source code
function GetFullName : string

Parameters
Parameter Description

Return
Types | Description
STRING | Nom qualifié du composant

Sepi
Class Tree
Index
Previous (GetDisplayName)
Next (GetIsForward)


Sepi

Sepi
Previous (GetFullName)
Next (GetShorterNameFrom)

Name
GetIsForward

Parent
TSepiComponent

Visibility
PRIVATE

Description
Indique si le composant est encore en forward

Source code
function GetIsForward : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si le composant est encored en forward, False sinon

Sepi
Class Tree
Index
Previous (GetFullName)
Next (GetShorterNameFrom)


Sepi

Sepi
Previous (GetIsForward)
Next (GetTypeInfoName)

Name
GetShorterNameFrom

Parent
TSepiComponent

Visibility
PUBLIC

Description
Nom le plus court possible pour être référencé depuis un autre composant

Source code
function GetShorterNameFrom ( From : TSepiComponent ) : string

Parameters
Parameter | Description
From : TSepiComponent | Composant depuis lequel être référencé

Return
Types | Description
STRING | Nom le plus court possible, ou une chaîne vide si aucun n'est possible

Sepi
Class Tree
Index
Previous (GetIsForward)
Next (GetTypeInfoName)


Sepi

Sepi
Previous (GetShorterNameFrom)
Next (GetTypeInfoNameSize)

Name
GetTypeInfoName

Parent
TSepiComponent

Visibility
PRIVATE

Description
Nom à stocker dans les RTTI

Source code
function GetTypeInfoName : TypeInfoString

Parameters
Parameter Description

Return
Types | Description
TypeInfoString | Nom à stocker dans les RTTI

Sepi
Class Tree
Index
Previous (GetShorterNameFrom)
Next (GetTypeInfoNameSize)


Sepi

Sepi
Previous (GetTypeInfoName)
Next (GetWasForward)

Name
GetTypeInfoNameSize

Parent
TSepiComponent

Visibility
PRIVATE

Description
Taille du nom à stocker dans les RTTI

Source code
function GetTypeInfoNameSize : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Taille du nom à stocker dans les RTTI

Sepi
Class Tree
Index
Previous (GetTypeInfoName)
Next (GetWasForward)


Sepi

Sepi
Previous (GetTypeInfoNameSize)
Next (InternalGetComponent)

Name
GetWasForward

Parent
TSepiComponent

Visibility
PRIVATE

Description
Indique si le composant a été créé forward

Source code
function GetWasForward : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si le composant a été créé forward, False sinon

Sepi
Class Tree
Index
Previous (GetTypeInfoNameSize)
Next (InternalGetComponent)


Sepi

Sepi
Previous (GetWasForward)
Next (InternalLookFor)

Name
InternalGetComponent

Parent
TSepiComponent

Visibility
PROTECTED

Description
Cherche un composant enfant
InternalGetComponent ne doit pas être appelée directement : passez par
GetComponent. GetComponent n'appelle InternalGetComponent qu'avec un nom
non-composé (sans .). De plus, si InternalGetComponent renvoie un
TSepiTypeAlias, GetComponent se chargera de le "déréférencer".

Source code
function InternalGetComponent ( const Name : string ) : TSepiComponent ; virtual

Parameters
Parameter | Description
NAME : STRING | Nom du composant à trouver

Return
Types | Description
TSepiComponent | Le composant correspondant, ou nil s'il n'a pas été trouvé

Sepi
Class Tree
Index
Previous (GetWasForward)
Next (InternalLookFor)


Sepi

Sepi
Previous (InternalGetComponent)
Next (IsAncestor)

Name
InternalLookFor

Parent
TSepiComponent

Visibility
PROTECTED

Description
Recherche un composant à partir de son nom
InternalLookFor ne doit pas être appelée directement : passez par LookFor.
LookFor n'appelle InternalLookFor qu'avec un nom non-composé (sans .).
InternalLookFor doit tenir compte des visibilités, en testant ses candidats
avec Candidate.IsVisibleFrom(FromComponent).

Source code
function InternalLookFor ( const Name : string ; FromComponent : TSepiComponent ) : TSepiComponent ; virtual

Parameters
Parameter | Description
NAME : STRING | Nom du meta recherché
FromComponent : TSepiComponent | Composant depuis lequel on recherche

Return
Types | Description
TSepiComponent | Le composant recherché, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (InternalGetComponent)
Next (IsAncestor)


Sepi

Sepi
Previous (InternalLookFor)
Next (IsVisibleFrom)

Name
IsAncestor

Parent
TSepiComponent

Visibility
PUBLIC

Description
Teste si un composant donné est un ancêtre de ce composnat

Source code
function IsAncestor ( Ancestor : TSepiComponent ) : Boolean

Parameters
Parameter | Description
Ancestor : TSepiComponent | Ancêtre potentiel

Return
Types | Description
BOOLEAN | True si Ancestor est un ancêtre de ce composant, False sinon

Sepi
Class Tree
Index
Previous (InternalLookFor)
Next (IsVisibleFrom)


Sepi

Sepi
Previous (IsAncestor)
Next (ListReferences)

Name
IsVisibleFrom

Parent
TSepiComponent

Visibility
PUBLIC

Description
Teste si ce composant est visible depuis un composant donné

Source code
function IsVisibleFrom ( FromComponent : TSepiComponent ) : Boolean ; virtual

Parameters
Parameter | Description
FromComponent : TSepiComponent | Composant depuis lequel on regarde

Return
Types | Description
BOOLEAN | True si le composant est visible, False sinon

Sepi
Class Tree
Index
Previous (IsAncestor)
Next (ListReferences)


Sepi

Sepi
Previous (IsVisibleFrom)
Next (Load)

Name
ListReferences

Parent
TSepiComponent

Visibility
PROTECTED

Description
Liste les références auprès de l'unité contenante, pour préparer la sauvegarde

Source code
procedure ListReferences ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (IsVisibleFrom)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (LoadChild)

Name
Load

Parent
TSepiComponent

Visibility
PUBLIC

Description
Charge un composant depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; virtual

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du composant
Stream : TStream | Flux depuis lequel charger le composant

Sepi
Class Tree
Index
Previous (ListReferences)
Next (LoadChild)


Sepi

Sepi
Previous (Load)
Next (LoadChildren)

Name
LoadChild

Parent
TSepiComponent

Visibility
PROTECTED

Description
Charge un enfant depuis un flux

Source code
function LoadChild ( Stream : TStream ) : TSepiComponent ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux source

Return
Types | Description
TSepiComponent | Enfant chargé

Sepi
Class Tree
Index
Previous (Load)
Next (LoadChildren)


Sepi

Sepi
Previous (LoadChild)
Next (Loaded)

Name
LoadChildren

Parent
TSepiComponent

Visibility
PROTECTED

Description
Charge les enfants depuis un flux

Source code
procedure LoadChildren ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux depuis lequel charger les enfants

Sepi
Class Tree
Index
Previous (LoadChild)
Next (Loaded)


Sepi

Sepi
Previous (LoadChildren)
Next (LoadForwards)

Name
Loaded

Parent
TSepiComponent

Visibility
PROTECTED

Description
Appelé lorsque l'unité contenante est complètement chargée/créée

Source code
procedure Loaded ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (LoadChildren)
Next (LoadForwards)


Sepi

Sepi
Previous (Loaded)
Next (LookFor)

Name
LoadForwards

Parent
TSepiComponent

Visibility
PROTECTED

Description
Charge les forwards depuis un flux

Source code
procedure LoadForwards ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux source

Sepi
Class Tree
Index
Previous (Loaded)
Next (LookFor)


Sepi

Sepi
Previous (LoadForwards)
Next (LookFor)

Name
LookFor

Parent
TSepiComponent

Visibility
PUBLIC

Description
Recherche un composant à partir de son nom à partir de ce composant

Source code
function LookFor ( const Name : string ) : TSepiComponent ; overload

Parameters
Parameter | Description
NAME : STRING | Nom du composant recherché

Return
Types | Description
TSepiComponent | Le composant recherché, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LoadForwards)
Next (LookFor)


Sepi

Sepi
Previous (LookFor)
Next (MakeUnnamedChildName)

Name
LookFor

Parent
TSepiComponent

Visibility
PUBLIC

Description
Recherche un composant à partir de son nom
LookFor, au contraire de GetComponent/FindComponent, tient compte des
héritages, des visibilités, des uses, etc.
Si Name est un nom composé, la première partie est recherchée selon
l'algorithme LookFor, et les suivantes selon l'algorithme GetComponent.

Source code
function LookFor ( const Name : string ; FromComponent : TSepiComponent ) : TSepiComponent ; overload

Parameters
Parameter | Description
NAME : STRING | Nom du composant recherché
FromComponent : TSepiComponent | Composant depuis lequel on regarde

Return
Types | Description
TSepiComponent | Le composant recherché, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LookFor)
Next (MakeUnnamedChildName)


Sepi

Sepi
Previous (LookFor)
Next (ReAddChild)

Name
MakeUnnamedChildName

Parent
TSepiComponent

Visibility
PUBLIC

Description
Construit un nom pour un enfant créé anonyme

Source code
function MakeUnnamedChildName : string

Parameters
Parameter Description

Return
Types | Description
STRING | Nom pour l'enfant

Sepi
Class Tree
Index
Previous (LookFor)
Next (ReAddChild)


Sepi

Sepi
Previous (MakeUnnamedChildName)
Next (RemoveChild)

Name
ReAddChild

Parent
TSepiComponent

Visibility
PROTECTED

Description
Ajoute de nouveau un composant à la liste des enfants
Cela a pour effet de replacer Child à la fin de la liste des enfants ajoutés
jusque là. Les types composites se servent de cette méthode pour se replacer
derrière les types anonymes qu'ils ont créés.

Source code
procedure ReAddChild ( Child : TSepiComponent ) ; virtual

Parameters
Parameter | Description
Child : TSepiComponent | Enfant concerné

Sepi
Class Tree
Index
Previous (MakeUnnamedChildName)
Next (RemoveChild)


Sepi

Sepi
Previous (ReAddChild)
Next (Save)

Name
RemoveChild

Parent
TSepiComponent

Visibility
PROTECTED

Description
Supprime un enfant
RemoveChild est appelée dans le destructeur du meta enfant, et ne doit pas
être appelée ailleurs.

Source code
procedure RemoveChild ( Child : TSepiComponent ) ; virtual

Parameters
Parameter | Description
Child : TSepiComponent | Enfant à supprimer

Sepi
Class Tree
Index
Previous (ReAddChild)
Next (Save)


Sepi

Sepi
Previous (RemoveChild)
Next (SaveChild)

Name
Save

Parent
TSepiComponent

Visibility
PROTECTED

Description
Enregistre le composant dans un flux

Source code
procedure Save ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel enregistrer le composant

Sepi
Class Tree
Index
Previous (RemoveChild)
Next (SaveChild)


Sepi

Sepi
Previous (Save)
Next (SaveChildren)

Name
SaveChild

Parent
TSepiComponent

Visibility
PROTECTED

Description
Enregistre un enfant dans un flux

Source code
procedure SaveChild ( Stream : TStream ; Child : TSepiComponent ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux destination
Child : TSepiComponent | Enfant à enregistrer

Sepi
Class Tree
Index
Previous (Save)
Next (SaveChildren)


Sepi

Sepi
Previous (SaveChild)
Next (SaveForwards)

Name
SaveChildren

Parent
TSepiComponent

Visibility
PROTECTED

Description
Enregistre les enfants dans un flux

Source code
procedure SaveChildren ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel enregistrer les enfants

Sepi
Class Tree
Index
Previous (SaveChild)
Next (SaveForwards)


Sepi

Sepi
Previous (SaveChildren)
Next (StoreTypeInfoName)

Name
SaveForwards

Parent
TSepiComponent

Visibility
PROTECTED

Description
Enregistre les forwards dans un flux

Source code
procedure SaveForwards ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (SaveChildren)
Next (StoreTypeInfoName)


Sepi

Sepi
Previous (SaveForwards)
Next (WriteDigestData)

Name
StoreTypeInfoName

Parent
TSepiComponent

Visibility
PUBLIC

Description
Enregistre le nom de ce composant dans des RTTI

Source code
function StoreTypeInfoName ( Dest : PTypeInfoString ) : Pointer

Parameters
Parameter | Description
Dest : PTypeInfoString | Pointeur sur la destination

Return
Types | Description
Pointer | Adresse du premier octet après la chaîne

Sepi
Class Tree
Index
Previous (SaveForwards)
Next (WriteDigestData)


Sepi

Sepi
Previous (StoreTypeInfoName)
Next (WriteDigestToStream)

Name
WriteDigestData

Parent
TSepiComponent

Visibility
PROTECTED

Description
Écrit les données nécessaires au digest de compatibilité dans un flux

Source code
procedure WriteDigestData ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (StoreTypeInfoName)
Next (WriteDigestToStream)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteDigestToStream

Parent
TSepiComponent

Visibility
PUBLIC

Description
Écrit le digest de compatibilité dans un flux

Source code
procedure WriteDigestToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiComponent)
Next (TSepiConstant)

Name
TSepiComponentList

Parent
SepiReflectionCore

Class Hierarchy
THashedStringList

Visibility
PUBLIC

Description
Liste de composants Sepi

Members
Methods
Method | Description
AddComponent (+) | Ajoute un composant
Create (+) | Crée une instance de TSepiComponentList
GetComponentFromName (-) | Liste des composants indexée par leurs noms
GetComponents (-) | Liste zero-based des composants
IndexOfComponent (+) | Cherche un composant dans la liste
InsertItem (#) | Ajoute un élément dans la liste de composants
REMOVE (+) | Supprime un composant de la liste
SetComponentFromName (-) | Assigne ou ajoute un composant par son nom
SetComponents (-) | Assigne la référence à un composant

Properties
Property | Description
ComponentFromName (+) | Liste des composants indexée par leurs noms
Components (+) | Liste zero-based des composants

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiComponent)
Next (TSepiConstant)


Sepi

Sepi
Previous
Next (Components)

Name
ComponentFromName

Parent
TSepiComponentList

Visibility
PUBLIC

Description
Liste des composants indexée par leurs noms

Source code
property ComponentFromName [ const Name : string ] : TSepiComponent read GetComponentFromName write SetComponentFromName

Read Access
GetComponentFromName

Write Access
SetComponentFromName

Sepi
Class Tree
Index
Previous
Next (Components)


Sepi

Sepi
Previous (ComponentFromName)
Next

Name
Components

Parent
TSepiComponentList

Visibility
PUBLIC

Description
Liste zero-based des composants

Source code
property Components [ Index : Integer ] : TSepiComponent read GetComponents write SetComponents ; default

Read Access
GetComponents

Write Access
SetComponents

Sepi
Class Tree
Index
Previous (ComponentFromName)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AddComponent

Parent
TSepiComponentList

Visibility
PUBLIC

Description
Ajoute un composant

Source code
function AddComponent ( Component : TSepiComponent ) : Integer

Parameters
Parameter | Description
Component : TSepiComponent | Composant à ajouter

Return
Types | Description
INTEGER | Index du composant nouvellement ajouté

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AddComponent)
Next (GetComponentFromName)

Name
Create

Parent
TSepiComponentList

Visibility
PUBLIC

Description
Crée une instance de TSepiComponentList

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddComponent)
Next (GetComponentFromName)


Sepi

Sepi
Previous (Create)
Next (GetComponents)

Name
GetComponentFromName

Parent
TSepiComponentList

Visibility
PRIVATE

Description
Liste des composants indexée par leurs noms

Source code
function GetComponentFromName ( const Name : string ) : TSepiComponent

Parameters
Parameter | Description
NAME : STRING | Nom d'un composant

Return
Types | Description
TSepiComponent | Le composant dont le nom a été spécifié, ou nil s'il n'existe pas

Sepi
Class Tree
Index
Previous (Create)
Next (GetComponents)


Sepi

Sepi
Previous (GetComponentFromName)
Next (IndexOfComponent)

Name
GetComponents

Parent
TSepiComponentList

Visibility
PRIVATE

Description
Liste zero-based des composants

Source code
function GetComponents ( Index : Integer ) : TSepiComponent

Parameters
Parameter | Description
INDEX : INTEGER | Index du composant à obtenir

Return
Types | Description
TSepiComponent | Composant à l'index spécifié

Sepi
Class Tree
Index
Previous (GetComponentFromName)
Next (IndexOfComponent)


Sepi

Sepi
Previous (GetComponents)
Next (InsertItem)

Name
IndexOfComponent

Parent
TSepiComponentList

Visibility
PUBLIC

Description
Cherche un composant dans la liste

Source code
function IndexOfComponent ( Component : TSepiComponent ) : Integer

Parameters
Parameter | Description
Component : TSepiComponent | Composant à chercher

Return
Types | Description
INTEGER | L'index du composant dans la liste, ou nil s'il n'existe pas

Sepi
Class Tree
Index
Previous (GetComponents)
Next (InsertItem)


Sepi

Sepi
Previous (IndexOfComponent)
Next (REMOVE)

Name
InsertItem

Parent
TSepiComponentList

Visibility
PROTECTED

Description
Ajoute un élément dans la liste de composants

Source code
procedure InsertItem ( Index : Integer ; const S : string ; AObject : TObject ) ; override

Parameters
Parameter | Description
INDEX : INTEGER | Index où ajouter l'élément
S : STRING | Chaîne à ajouter
AObject : TObject | Objet à ajouter

Sepi
Class Tree
Index
Previous (IndexOfComponent)
Next (REMOVE)


Sepi

Sepi
Previous (InsertItem)
Next (SetComponentFromName)

Name
REMOVE

Parent
TSepiComponentList

Visibility
PUBLIC

Description
Supprime un composant de la liste

Source code
function Remove ( Component : TSepiComponent ) : Integer

Parameters
Parameter | Description
Component : TSepiComponent | Composant à supprimer

Return
Types | Description
INTEGER | L'index auquel se trouvait le composant

Sepi
Class Tree
Index
Previous (InsertItem)
Next (SetComponentFromName)


Sepi

Sepi
Previous (REMOVE)
Next (SetComponents)

Name
SetComponentFromName

Parent
TSepiComponentList

Visibility
PRIVATE

Description
Assigne ou ajoute un composant par son nom
Un composant ne peut pas être modifé une fois assigné, il ne peut donc être
assigné qu'une et une seule fois.

Source code
procedure SetComponentFromName ( const Name : string ; Value : TSepiComponent )

Parameters
Parameter | Description
NAME : STRING | Nom du composant
Value : TSepiComponent | Référence au composant

Sepi
Class Tree
Index
Previous (REMOVE)
Next (SetComponents)


Sepi

Sepi
Previous (SetComponentFromName)
Next

Name
SetComponents

Parent
TSepiComponentList

Visibility
PRIVATE

Description
Assigne la référence à un composant
Un composant ne peut pas être modifé une fois assigné, il ne peut donc être
assigné qu'une et une seule fois.

Source code
procedure SetComponents ( Index : Integer ; Value : TSepiComponent )

Parameters
Parameter | Description
INDEX : INTEGER | Index du meta à modifier
Value : TSepiComponent | Référence au nouveau composant

Sepi
Class Tree
Index
Previous (SetComponentFromName)
Next


Sepi

Sepi
Previous (TSepiComponentList)
Next (TSepiContainerType)

Name
TSepiConstant

Parent
SepiReflectionCore

Class Hierarchy
TSepiComponent

Visibility
PUBLIC

Description
Constante

Members
Fields
Field | Description
FType (-) | Type de la constante
FValuePtr (-) | Pointeur sur la valeur

Methods
Method | Description
Create (+) | Crée une nouvelle vraie constante sans initialiser sa valeur
Create (+) | Crée une nouvelle vraie constante sans initialiser sa valeur
Create (+) | Crée une nouvelle vraie constante
Create (+) | Crée une nouvelle vraie constante
Destroy (+) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une constante depuis un flux
Save (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
ConstType (+) | Type de la constante
ValuePtr (+) | Pointeur sur la valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiComponentList)
Next (TSepiContainerType)


Sepi

Sepi
Previous
Next (FValuePtr)

Name
FType

Parent
TSepiConstant

Visibility
PRIVATE

Description
Type de la constante

Source code
FType : TSepiType

Sepi
Class Tree
Index
Previous
Next (FValuePtr)


Sepi

Sepi
Previous (FType)
Next

Name
FValuePtr

Parent
TSepiConstant

Visibility
PRIVATE

Description
Pointeur sur la valeur

Source code
FValuePtr : Pointer

Sepi
Class Tree
Index
Previous (FType)
Next


Sepi

Sepi
Previous
Next (ValuePtr)

Name
ConstType

Parent
TSepiConstant

Visibility
PUBLIC

Description
Type de la constante

Source code
property ConstType : TSepiType read FType

Read Access
FType

Sepi
Class Tree
Index
Previous
Next (ValuePtr)


Sepi

Sepi
Previous (ConstType)
Next

Name
ValuePtr

Parent
TSepiConstant

Visibility
PUBLIC

Description
Pointeur sur la valeur

Source code
property ValuePtr : Pointer read FValuePtr

Read Access
FValuePtr

Sepi
Class Tree
Index
Previous (ConstType)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TSepiConstant

Visibility
PUBLIC

Description
Crée une nouvelle vraie constante sans initialiser sa valeur

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AType : TSepiType ; const AValue ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la constante
AName : STRING | Nom de la constante
AType : TSepiType | Type de la constante
AValue : Untyped

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TSepiConstant

Visibility
PUBLIC

Description
Crée une nouvelle vraie constante sans initialiser sa valeur

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AType : TSepiType ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la constante
AName : STRING | Nom de la constante
AType : TSepiType | Type de la constante

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Create)

Name
Create

Parent
TSepiConstant

Visibility
PUBLIC

Description
Crée une nouvelle vraie constante

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; const AValue : Variant ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la constante
AName : STRING | Nom de la constante
AValue : VARIANT | Valeur de la constante

Sepi
Class Tree
Index
Previous (Create)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TSepiConstant

Visibility
PUBLIC

Description
Crée une nouvelle vraie constante

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; const AValue : Variant ; AType : TSepiType ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la constante
AName : STRING | Nom de la constante
AValue : VARIANT | Valeur de la constante
AType : TSepiType | Type de la constante

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (ListReferences)

Name
Destroy

Parent
TSepiConstant

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (ListReferences)


Sepi

Sepi
Previous (Destroy)
Next (Load)

Name
ListReferences

Parent
TSepiConstant

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiConstant

Visibility
PUBLIC

Description
Charge une constante depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (WriteDigestData)

Name
Save

Parent
TSepiConstant

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (WriteDigestData)


Sepi

Sepi
Previous (Save)
Next

Name
WriteDigestData

Parent
TSepiConstant

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next


Sepi

Sepi
Previous (TSepiConstant)
Next (TSepiLazyLoadChildData)

Name
TSepiContainerType

Parent
SepiReflectionCore

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type conteneur

Members
Fields
Field | Description
FLoadingStream (-) | Flux de chargement

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
IsComposite (#) | [@inheritDoc]
Load (+) | [@inheritDoc]
LookForMember (+) | Recherche un membre dans ce conteneur depuis celui-ci
LookForMember (+) | Recherche un membre dans ce conteneur depuis celui-ci

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiConstant)
Next (TSepiLazyLoadChildData)


Sepi

Sepi
Previous
Next

Name
FLoadingStream

Parent
TSepiContainerType

Visibility
PRIVATE

Description
Flux de chargement

Source code
FLoadingStream : TStream

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (IsComposite)

Name
AfterConstruction

Parent
TSepiContainerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (IsComposite)


Sepi

Sepi
Previous (AfterConstruction)
Next (Load)

Name
IsComposite

Parent
TSepiContainerType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function IsComposite : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Load)


Sepi

Sepi
Previous (IsComposite)
Next (LookForMember)

Name
Load

Parent
TSepiContainerType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsComposite)
Next (LookForMember)


Sepi

Sepi
Previous (Load)
Next (LookForMember)

Name
LookForMember

Parent
TSepiContainerType

Visibility
PUBLIC

Description
Recherche un membre dans ce conteneur depuis celui-ci

Source code
function LookForMember ( const MemberName : string ) : TSepiMember ; overload

Parameters
Parameter | Description
MemberName : STRING | Nom du membre recherché

Return
Types | Description
TSepiMember | Le membre correspondant, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (Load)
Next (LookForMember)


Sepi

Sepi
Previous (LookForMember)
Next

Name
LookForMember

Parent
TSepiContainerType

Visibility
PUBLIC

Description
Recherche un membre dans ce conteneur depuis celui-ci

Source code
function LookForMember ( const MemberName : string ; FromComponent : TSepiComponent ) : TSepiMember ; overload ; virtual

Parameters
Parameter | Description
MemberName : STRING | Nom du membre recherché
FromComponent : TSepiComponent | Composant depuis lequel on recherche

Return
Types | Description
TSepiMember | Le membre correspondant, ou nil si non trouvé

Sepi
Class Tree
Index
Previous (LookForMember)
Next


Sepi

Sepi
Previous (TSepiContainerType)
Next (TSepiLazyLoadData)

Name
TSepiLazyLoadChildData

Parent
SepiReflectionCore

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Données de lazy-load pour un enfant

Members
Fields
Field | Description
Inheritance (*) | Héritage d'une classe/interface
Kind (*) | Type d'enfant
NAME (*) | Nom de l'enfant
Position (*) | Position dans le flux

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiContainerType)
Next (TSepiLazyLoadData)


Sepi

Sepi
Previous
Next (Kind)

Name
Inheritance

Parent
TSepiLazyLoadChildData

Visibility
PUBLISHED

Description
Héritage d'une classe/interface

Source code
Inheritance : TStringDynArray

Sepi
Class Tree
Index
Previous
Next (Kind)


Sepi

Sepi
Previous (Inheritance)
Next (NAME)

Name
Kind

Parent
TSepiLazyLoadChildData

Visibility
PUBLISHED

Description
Type d'enfant

Source code
Kind : TSepiLazyLoadChildKind

Sepi
Class Tree
Index
Previous (Inheritance)
Next (NAME)


Sepi

Sepi
Previous (Kind)
Next (Position)

Name
NAME

Parent
TSepiLazyLoadChildData

Visibility
PUBLISHED

Description
Nom de l'enfant

Source code
Name : string

Sepi
Class Tree
Index
Previous (Kind)
Next (Position)


Sepi

Sepi
Previous (NAME)
Next

Name
Position

Parent
TSepiLazyLoadChildData

Visibility
PUBLISHED

Description
Position dans le flux

Source code
Position : Int64

Sepi
Class Tree
Index
Previous (NAME)
Next


Sepi

Sepi
Previous (TSepiLazyLoadChildData)
Next (TSepiMember)

Name
TSepiLazyLoadData

Parent
SepiReflectionCore

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Données de lazy-load

Members
Fields
Field | Description
FChildrenData (-) | Données sur les enfants
FChildrenNames (-) | Noms des enfants
FForwardClassIntfChildren (-) | Classes et interfaces forward
FLoadingClassIntfChildren (-) | Classes et interfaces en chargement
FOwner (-) | Propriétaire des enfants chargés
FStream (-) | Flux où charger les enfants

Methods
Method | Description
CanLoad (-) | Teste si un enfant peut être chargé maintenant
ChildExists (+) | Test si un enfant existe
Create (+) | Crée les données de lazy-load
Destroy (+) | [@inheritDoc]
GetChildData (-) | Récupère les informations de lazy-load pour un enfant
InternalLoadChild (-) | Charge un enfant depuis le flux
LoadChild (+) | Charge un enfant depuis son nom
LoadFromStream (+) | Charge les données depuis le flux
RetryForwards (-) | Réessaye de charger les enfants qui sont forwards
SaveToStream (+) | Enregistre les données d'un meta dans un flux

Properties
Property | Description
Owner (+) | Propriétaire des enfants chargés
Stream (+) | Flux où charger les enfants

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLazyLoadChildData)
Next (TSepiMember)


Sepi

Sepi
Previous
Next (FChildrenNames)

Name
FChildrenData

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Données sur les enfants

Source code
FChildrenData : array of TSepiLazyLoadChildData

Sepi
Class Tree
Index
Previous
Next (FChildrenNames)


Sepi

Sepi
Previous (FChildrenData)
Next (FForwardClassIntfChildren)

Name
FChildrenNames

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Noms des enfants

Source code
FChildrenNames : TStrings

Sepi
Class Tree
Index
Previous (FChildrenData)
Next (FForwardClassIntfChildren)


Sepi

Sepi
Previous (FChildrenNames)
Next (FLoadingClassIntfChildren)

Name
FForwardClassIntfChildren

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Classes et interfaces forward

Source code
FForwardClassIntfChildren : TObjectList

Sepi
Class Tree
Index
Previous (FChildrenNames)
Next (FLoadingClassIntfChildren)


Sepi

Sepi
Previous (FForwardClassIntfChildren)
Next (FOwner)

Name
FLoadingClassIntfChildren

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Classes et interfaces en chargement

Source code
FLoadingClassIntfChildren : TStrings

Sepi
Class Tree
Index
Previous (FForwardClassIntfChildren)
Next (FOwner)


Sepi

Sepi
Previous (FLoadingClassIntfChildren)
Next (FStream)

Name
FOwner

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Propriétaire des enfants chargés

Source code
FOwner : TSepiComponent

Sepi
Class Tree
Index
Previous (FLoadingClassIntfChildren)
Next (FStream)


Sepi

Sepi
Previous (FOwner)
Next

Name
FStream

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Flux où charger les enfants

Source code
FStream : TStream

Sepi
Class Tree
Index
Previous (FOwner)
Next


Sepi

Sepi
Previous
Next (Stream)

Name
Owner

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
Propriétaire des enfants chargés

Source code
property Owner : TSepiComponent read FOwner

Read Access
FOwner

Sepi
Class Tree
Index
Previous
Next (Stream)


Sepi

Sepi
Previous (Owner)
Next

Name
Stream

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
Flux où charger les enfants

Source code
property Stream : TStream read FStream

Read Access
FStream

Sepi
Class Tree
Index
Previous (Owner)
Next


Sepi

Sepi
Previous
Next (ChildExists)

Name
CanLoad

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Teste si un enfant peut être chargé maintenant

Source code
function CanLoad ( const Data : TSepiLazyLoadChildData ) : Boolean

Parameters
Parameter | Description
Data : TSepiLazyLoadChildData | Données de chargement d'un enfant

Return
Types | Description
BOOLEAN | True si l'enfant décrit par ces données peut être chargé, False sinon

Sepi
Class Tree
Index
Previous
Next (ChildExists)


Sepi

Sepi
Previous (CanLoad)
Next (Create)

Name
ChildExists

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
Test si un enfant existe

Source code
function ChildExists ( const Name : string ) : Boolean

Parameters
Parameter | Description
NAME : STRING | Nom de l'enfant recherché

Return
Types | Description
BOOLEAN | True si un enfant de ce nom existe, False sinon

Sepi
Class Tree
Index
Previous (CanLoad)
Next (Create)


Sepi

Sepi
Previous (ChildExists)
Next (Destroy)

Name
Create

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
Crée les données de lazy-load

Source code
constructor Create ( AOwner : TSepiComponent ; AStream : TStream )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire des enfants à charger
AStream : TStream | Flux depuis lequel charger les enfants

Sepi
Class Tree
Index
Previous (ChildExists)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (GetChildData)

Name
Destroy

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (GetChildData)


Sepi

Sepi
Previous (Destroy)
Next (InternalLoadChild)

Name
GetChildData

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Récupère les informations de lazy-load pour un enfant

Source code
function GetChildData ( const Name : string ) : TSepiLazyLoadChildData

Parameters
Parameter | Description
NAME : STRING | Nom de l'enfant à charger

Return
Types | Description
TSepiLazyLoadChildData | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (InternalLoadChild)


Sepi

Sepi
Previous (GetChildData)
Next (LoadChild)

Name
InternalLoadChild

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Charge un enfant depuis le flux

Source code
procedure InternalLoadChild ( const Data : TSepiLazyLoadChildData ; var Child : TSepiComponent )

Parameters
Parameter | Description
Data : TSepiLazyLoadChildData | Données sur l'enfant à charger
Child : TSepiComponent | En entrée et/ou en sortie : l'enfant à charger

Sepi
Class Tree
Index
Previous (GetChildData)
Next (LoadChild)


Sepi

Sepi
Previous (InternalLoadChild)
Next (LoadFromStream)

Name
LoadChild

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
Charge un enfant depuis son nom

Source code
function LoadChild ( const Name : string ) : TSepiComponent

Parameters
Parameter | Description
NAME : STRING | Nom de l'enfant à charger

Return
Types | Description
TSepiComponent | Enfant chargé

Sepi
Class Tree
Index
Previous (InternalLoadChild)
Next (LoadFromStream)


Sepi

Sepi
Previous (LoadChild)
Next (RetryForwards)

Name
LoadFromStream

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
Charge les données depuis le flux

Source code
procedure LoadFromStream ( SkipChildrenInfo : Boolean )

Parameters
Parameter | Description
SkipChildrenInfo : BOOLEAN | Si True, saute les définitions des enfants

Sepi
Class Tree
Index
Previous (LoadChild)
Next (RetryForwards)


Sepi

Sepi
Previous (LoadFromStream)
Next (SaveToStream)

Name
RetryForwards

Parent
TSepiLazyLoadData

Visibility
PRIVATE

Description
Réessaye de charger les enfants qui sont forwards

Source code
procedure RetryForwards

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (LoadFromStream)
Next (SaveToStream)


Sepi

Sepi
Previous (RetryForwards)
Next

Name
SaveToStream

Parent
TSepiLazyLoadData

Visibility
PUBLIC

Description
Enregistre les données d'un meta dans un flux

Source code
class procedure SaveToStream ( Owner : TSepiComponent ; Stream : TStream )

Parameters
Parameter | Description
Owner : TSepiComponent | Component propriétaire
Stream : TStream | Flux de destination

Sepi
Class Tree
Index
Previous (RetryForwards)
Next


Sepi

Sepi
Previous (TSepiLazyLoadData)
Next (TSepiNamespace)

Name
TSepiMember

Parent
SepiReflectionCore

Class Hierarchy
TSepiComponent

Visibility
PUBLIC

Description
Membre d'un type conteneur
Les classes qui héritent de TSepiMember ne sont pas nécessairement toujours
des membres. Ce sont les composants qui sont susceptibles, dans certains
circonstances, d'être des membres.

Members
Methods
Method | Description
GetContainer (-) | Conteneur de ce membre

Properties
Property | Description
Container (+) | Conteneur de ce membre

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLazyLoadData)
Next (TSepiNamespace)


Sepi

Sepi
Previous
Next

Name
Container

Parent
TSepiMember

Visibility
PUBLIC

Description
Conteneur de ce membre

Source code
property Container : TSepiContainerType read GetContainer

Read Access
GetContainer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
GetContainer

Parent
TSepiMember

Visibility
PRIVATE

Description
Conteneur de ce membre
Pour les instances de TSepiMethodBase et de TSepiVariable, GetContainer peut
renvoyer nil, si elles sont contenues dans une unité, et non dans une classe.

Source code
function GetContainer : TSepiContainerType

Parameters
Parameter Description

Return
Types | Description
TSepiContainerType | Conteneur de ce membre

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiMember)
Next (TSepiRoot)

Name
TSepiNamespace

Parent
SepiReflectionCore

Class Hierarchy
TSepiComponent

Visibility
PUBLIC

Description
Espace de noms (d'étendue plus petite qu'une unité)
Un espace de noms peut avoir un propriétaire virtuel. S'il en a, la méthode
LookFor continue sa recherche d'un identificateur via le propriétaire
virtuel, plutôt que le propriétaire réel.

Members
Fields
Field | Description
FVirtualOwner (-) | Propriétaire virtuel

Methods
Method | Description
Complete (+) | Complète l'espace de noms
Create (+) | Crée un espace de noms
InternalLookFor (#) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | [@inheritDoc]
Save (#) | [@inheritDoc]

Properties
Property | Description
VirtualOwner (+) | Propriétaire virtuel

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMember)
Next (TSepiRoot)


Sepi

Sepi
Previous
Next

Name
FVirtualOwner

Parent
TSepiNamespace

Visibility
PRIVATE

Description
Propriétaire virtuel

Source code
FVirtualOwner : TSepiComponent

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
VirtualOwner

Parent
TSepiNamespace

Visibility
PUBLIC

Description
Propriétaire virtuel

Source code
property VirtualOwner : TSepiComponent read FVirtualOwner

Read Access
FVirtualOwner

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
Complete

Parent
TSepiNamespace

Visibility
PUBLIC

Description
Complète l'espace de noms

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (InternalLookFor)

Name
Create

Parent
TSepiNamespace

Visibility
PUBLIC

Description
Crée un espace de noms

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AVirtualOwner : TSepiComponent = nil )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de l'espace de noms
AName : STRING | Nom de l'espace de noms
AVirtualOwner : TSepiComponent | Propriétaire virtuel (défaut = nil, utilise Owner)

Sepi
Class Tree
Index
Previous (Complete)
Next (InternalLookFor)


Sepi

Sepi
Previous (Create)
Next (ListReferences)

Name
InternalLookFor

Parent
TSepiNamespace

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function InternalLookFor ( const Name : string ; FromComponent : TSepiComponent ) : TSepiComponent ; override

Parameters
Parameter | Description
NAME : STRING | #Pas de TAG trouvé dans le code source#
FromComponent : TSepiComponent | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (ListReferences)


Sepi

Sepi
Previous (InternalLookFor)
Next (Load)

Name
ListReferences

Parent
TSepiNamespace

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (InternalLookFor)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiNamespace

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next

Name
Save

Parent
TSepiNamespace

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next


Sepi

Sepi
Previous (TSepiNamespace)
Next (TSepiRootFork)

Name
TSepiRoot

Parent
SepiReflectionCore

Class Hierarchy
TSepiComponent

Visibility
PUBLIC

Description
Racine de l'arbre de réflexion

Members
Fields
Field | Description
FOnLoadUnit (-) | Déclenché au chargement d'une unité
FSearchOrder (-) | Ordre de recherche

Methods
Method | Description
AddChild (#) | [@inheritDoc]
Create (+) | Crée une instance de TSepiRoot
DecUnitRefCount (#) | Décrémente le compteur de références d'une unité
Destroy (+) | [@inheritDoc]
FindClass (+) | Trouve une classe enregistrée à partir de la classe Delphi
FindType (+) | Trouve un type enregistré à partir de ses informations de type
FindType (+) | Trouve un type enregistré à partir de son nom
GetClass (+) | Trouve une classe enregistrée à partir de la classe Delphi
GetType (+) | Cherche un type enregistré à partir de son nom
GetType (+) | Cherche un type enregistré à partir de ses informations de type
GetUnitCount (-) | Nombre d'unités
GetUnits (-) | Tableau zero-based des unités
IncUnitRefCount (#) | Incrémente le compteur de références d'une unité
InternalLookFor (#) | [@inheritDoc]
LoadUnit (+) | Charge une unité
ReAddChild (#) | [@inheritDoc]
RemoveChild (#) | [@inheritDoc]
UnloadUnit (+) | Décharge une unité

Properties
Property | Description
OnLoadUnit (+) | Déclenché au chargement d'une unité
SystemUnit (+) | Unité System - devrait être du type SepiSystemUnit.TSepiSystemUnit
UnitCount (+) | Nombre d'unités
Units (+) | Tableau zero-based des unités

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiNamespace)
Next (TSepiRootFork)


Sepi

Sepi
Previous
Next (FSearchOrder)

Name
FOnLoadUnit

Parent
TSepiRoot

Visibility
PRIVATE

Description
Déclenché au chargement d'une unité

Source code
FOnLoadUnit : TSepiLoadUnitEvent

Sepi
Class Tree
Index
Previous
Next (FSearchOrder)


Sepi

Sepi
Previous (FOnLoadUnit)
Next

Name
FSearchOrder

Parent
TSepiRoot

Visibility
PRIVATE

Description
Ordre de recherche

Source code
FSearchOrder : TObjectList

Sepi
Class Tree
Index
Previous (FOnLoadUnit)
Next


Sepi

Sepi
Previous
Next (SystemUnit)

Name
OnLoadUnit

Parent
TSepiRoot

Visibility
PUBLIC

Description
Déclenché au chargement d'une unité

Source code
property OnLoadUnit : TSepiLoadUnitEvent read FOnLoadUnit write FOnLoadUnit

Read Access
FOnLoadUnit

Write Access
FOnLoadUnit

Sepi
Class Tree
Index
Previous
Next (SystemUnit)


Sepi

Sepi
Previous (OnLoadUnit)
Next (UnitCount)

Name
SystemUnit

Parent
TSepiRoot

Visibility
PUBLIC

Description
Unité System - devrait être du type SepiSystemUnit.TSepiSystemUnit

Source code
property SystemUnit : TSepiUnit index 0 read GetUnits

Read Access
GetUnits

Sepi
Class Tree
Index
Previous (OnLoadUnit)
Next (UnitCount)


Sepi

Sepi
Previous (SystemUnit)
Next (Units)

Name
UnitCount

Parent
TSepiRoot

Visibility
PUBLIC

Description
Nombre d'unités

Source code
property UnitCount : Integer read GetUnitCount

Read Access
GetUnitCount

Sepi
Class Tree
Index
Previous (SystemUnit)
Next (Units)


Sepi

Sepi
Previous (UnitCount)
Next

Name
Units

Parent
TSepiRoot

Visibility
PUBLIC

Description
Tableau zero-based des unités

Source code
property Units [ Index : Integer ] : TSepiUnit read GetUnits

Read Access
GetUnits

Sepi
Class Tree
Index
Previous (UnitCount)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AddChild

Parent
TSepiRoot

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AddChild ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AddChild)
Next (DecUnitRefCount)

Name
Create

Parent
TSepiRoot

Visibility
PUBLIC

Description
Crée une instance de TSepiRoot

Source code
constructor Create

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddChild)
Next (DecUnitRefCount)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
DecUnitRefCount

Parent
TSepiRoot

Visibility
PROTECTED

Description
Décrémente le compteur de références d'une unité

Source code
function DecUnitRefCount ( SepiUnit : TSepiUnit ) : Integer ; virtual

Parameters
Parameter | Description
SepiUnit : TSepiUnit | Unité dont décrémenter le compteur de références

Return
Types | Description
INTEGER | Nouvelle valeur du compteur de références

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (DecUnitRefCount)
Next (FindClass)

Name
Destroy

Parent
TSepiRoot

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DecUnitRefCount)
Next (FindClass)


Sepi

Sepi
Previous (Destroy)
Next (FindType)

Name
FindClass

Parent
TSepiRoot

Visibility
PUBLIC

Description
Trouve une classe enregistrée à partir de la classe Delphi
Le résultat peut toujours être *transtypé* en TSepiClass.

Source code
function FindClass ( DelphiClass : TClass ) : TSepiType

Parameters
Parameter | Description
DelphiClass : TClass | Classe Delphi recherchée

Return
Types | Description
TSepiType | Le type correspondant à la classe donnée (garanti être TSepiClass)

Sepi
Class Tree
Index
Previous (Destroy)
Next (FindType)


Sepi

Sepi
Previous (FindClass)
Next (FindType)

Name
FindType

Parent
TSepiRoot

Visibility
PUBLIC

Description
Trouve un type enregistré à partir de ses informations de type

Source code
function FindType ( TypeInfo : PTypeInfo ) : TSepiType ; overload

Parameters
Parameter | Description
TypeInfo : PTypeInfo | Informations de type du type recherché

Return
Types | Description
TSepiType | Le type correspondant aux informations de type données

Sepi
Class Tree
Index
Previous (FindClass)
Next (FindType)


Sepi

Sepi
Previous (FindType)
Next (GetClass)

Name
FindType

Parent
TSepiRoot

Visibility
PUBLIC

Description
Trouve un type enregistré à partir de son nom

Source code
function FindType ( const TypeName : string ) : TSepiType ; overload

Parameters
Parameter | Description
TypeName : STRING | Nom du type recherché

Return
Types | Description
TSepiType | Le type correspondant au nom donné

Sepi
Class Tree
Index
Previous (FindType)
Next (GetClass)


Sepi

Sepi
Previous (FindType)
Next (GetType)

Name
GetClass

Parent
TSepiRoot

Visibility
PUBLIC

Description
Trouve une classe enregistrée à partir de la classe Delphi
Le résultat peut toujours être *transtypé* en TSepiClass.
Renvoie nil si non trouvé.

Source code
function GetClass ( DelphiClass : TClass ) : TSepiType

Parameters
Parameter | Description
DelphiClass : TClass | Classe Delphi recherchée

Return
Types | Description
TSepiType | Le type correspondant à la classe donnée (garanti être TSepiClass)

Sepi
Class Tree
Index
Previous (FindType)
Next (GetType)


Sepi

Sepi
Previous (GetClass)
Next (GetType)

Name
GetType

Parent
TSepiRoot

Visibility
PUBLIC

Description
Cherche un type enregistré à partir de son nom

Source code
function GetType ( const TypeName : string ) : TSepiType ; overload

Parameters
Parameter | Description
TypeName : STRING | Nom du type recherché

Return
Types | Description
TSepiType | Le type correspondant (ou nil si non trouvé)

Sepi
Class Tree
Index
Previous (GetClass)
Next (GetType)


Sepi

Sepi
Previous (GetType)
Next (GetUnitCount)

Name
GetType

Parent
TSepiRoot

Visibility
PUBLIC

Description
Cherche un type enregistré à partir de ses informations de type

Source code
function GetType ( TypeInfo : PTypeInfo ) : TSepiType ; overload

Parameters
Parameter | Description
TypeInfo : PTypeInfo | Informations de type du type recherché

Return
Types | Description
TSepiType | Le type correspondant (nil si non trouvé)

Sepi
Class Tree
Index
Previous (GetType)
Next (GetUnitCount)


Sepi

Sepi
Previous (GetType)
Next (GetUnits)

Name
GetUnitCount

Parent
TSepiRoot

Visibility
PRIVATE

Description
Nombre d'unités

Source code
function GetUnitCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'unités

Sepi
Class Tree
Index
Previous (GetType)
Next (GetUnits)


Sepi

Sepi
Previous (GetUnitCount)
Next (IncUnitRefCount)

Name
GetUnits

Parent
TSepiRoot

Visibility
PRIVATE

Description
Tableau zero-based des unités

Source code
function GetUnits ( Index : Integer ) : TSepiUnit

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'unité à récupérer

Return
Types | Description
TSepiUnit | Unité à l'index spécifié

Sepi
Class Tree
Index
Previous (GetUnitCount)
Next (IncUnitRefCount)


Sepi

Sepi
Previous (GetUnits)
Next (InternalLookFor)

Name
IncUnitRefCount

Parent
TSepiRoot

Visibility
PROTECTED

Description
Incrémente le compteur de références d'une unité

Source code
function IncUnitRefCount ( SepiUnit : TSepiUnit ) : Integer ; virtual

Parameters
Parameter | Description
SepiUnit : TSepiUnit | Unité dont incrémenter le compteur de références

Return
Types | Description
INTEGER | Nouvelle valeur du compteur de références

Sepi
Class Tree
Index
Previous (GetUnits)
Next (InternalLookFor)


Sepi

Sepi
Previous (IncUnitRefCount)
Next (LoadUnit)

Name
InternalLookFor

Parent
TSepiRoot

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function InternalLookFor ( const Name : string ; FromComponent : TSepiComponent ) : TSepiComponent ; override

Parameters
Parameter | Description
NAME : STRING | #Pas de TAG trouvé dans le code source#
FromComponent : TSepiComponent | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IncUnitRefCount)
Next (LoadUnit)


Sepi

Sepi
Previous (InternalLookFor)
Next (ReAddChild)

Name
LoadUnit

Parent
TSepiRoot

Visibility
PUBLIC

Description
Charge une unité

Source code
function LoadUnit ( const UnitName : string ) : TSepiUnit ; virtual

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité à charger

Return
Types | Description
TSepiUnit | Unité chargée

Sepi
Class Tree
Index
Previous (InternalLookFor)
Next (ReAddChild)


Sepi

Sepi
Previous (LoadUnit)
Next (RemoveChild)

Name
ReAddChild

Parent
TSepiRoot

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ReAddChild ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadUnit)
Next (RemoveChild)


Sepi

Sepi
Previous (ReAddChild)
Next (UnloadUnit)

Name
RemoveChild

Parent
TSepiRoot

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure RemoveChild ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ReAddChild)
Next (UnloadUnit)


Sepi

Sepi
Previous (RemoveChild)
Next

Name
UnloadUnit

Parent
TSepiRoot

Visibility
PUBLIC

Description
Décharge une unité

Source code
procedure UnloadUnit ( const UnitName : string ) ; virtual

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité à charger

Sepi
Class Tree
Index
Previous (RemoveChild)
Next


Sepi

Sepi
Previous (TSepiRoot)
Next (TSepiType)

Name
TSepiRootFork

Parent
SepiReflectionCore

Class Hierarchy
TSepiRoot

Visibility
PUBLIC

Description
Fork d'une racine Sepi

Members
Fields
Field | Description
FDestroying (-) | True lorsqu'en destruction
FForeignRefCounts (-) | Ref-counts des unités étrangères
FOriginalRoot (-) | Racine de base

Methods
Method | Description
AddChild (#) | [@inheritDoc]
BeforeDestruction (+) | [@inheritDoc]
Create (+) | Crée un nouveau fork de racine Sepi
DecUnitRefCount (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
IncUnitRefCount (#) | [@inheritDoc]
LoadUnit (+) | [@inheritDoc]
LoadUnitFromOriginalRoot (-) | Charge une unité depuis la racine de base
RemoveChild (#) | [@inheritDoc]
UnloadUnit (+) | [@inheritDoc]

Properties
Property | Description
OriginalRoot (+) | Racine de base

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRoot)
Next (TSepiType)


Sepi

Sepi
Previous
Next (FForeignRefCounts)

Name
FDestroying

Parent
TSepiRootFork

Visibility
PRIVATE

Description
True lorsqu'en destruction

Source code
FDestroying : Boolean

Sepi
Class Tree
Index
Previous
Next (FForeignRefCounts)


Sepi

Sepi
Previous (FDestroying)
Next (FOriginalRoot)

Name
FForeignRefCounts

Parent
TSepiRootFork

Visibility
PRIVATE

Description
Ref-counts des unités étrangères

Source code
FForeignRefCounts : TStrings

Sepi
Class Tree
Index
Previous (FDestroying)
Next (FOriginalRoot)


Sepi

Sepi
Previous (FForeignRefCounts)
Next

Name
FOriginalRoot

Parent
TSepiRootFork

Visibility
PRIVATE

Description
Racine de base

Source code
FOriginalRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FForeignRefCounts)
Next


Sepi

Sepi
Previous
Next

Name
OriginalRoot

Parent
TSepiRootFork

Visibility
PUBLIC

Description
Racine de base

Source code
property OriginalRoot : TSepiRoot read FOriginalRoot

Read Access
FOriginalRoot

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (BeforeDestruction)

Name
AddChild

Parent
TSepiRootFork

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure AddChild ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (BeforeDestruction)


Sepi

Sepi
Previous (AddChild)
Next (Create)

Name
BeforeDestruction

Parent
TSepiRootFork

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeforeDestruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddChild)
Next (Create)


Sepi

Sepi
Previous (BeforeDestruction)
Next (DecUnitRefCount)

Name
Create

Parent
TSepiRootFork

Visibility
PUBLIC

Description
Crée un nouveau fork de racine Sepi

Source code
constructor Create ( AOriginalRoot : TSepiRoot )

Parameters
Parameter | Description
AOriginalRoot : TSepiRoot | Racine Sepi originale

Sepi
Class Tree
Index
Previous (BeforeDestruction)
Next (DecUnitRefCount)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
DecUnitRefCount

Parent
TSepiRootFork

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function DecUnitRefCount ( SepiUnit : TSepiUnit ) : Integer ; override

Parameters
Parameter | Description
SepiUnit : TSepiUnit | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (DecUnitRefCount)
Next (IncUnitRefCount)

Name
Destroy

Parent
TSepiRootFork

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DecUnitRefCount)
Next (IncUnitRefCount)


Sepi

Sepi
Previous (Destroy)
Next (LoadUnit)

Name
IncUnitRefCount

Parent
TSepiRootFork

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function IncUnitRefCount ( SepiUnit : TSepiUnit ) : Integer ; override

Parameters
Parameter | Description
SepiUnit : TSepiUnit | #Pas de TAG trouvé dans le code source#

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Destroy)
Next (LoadUnit)


Sepi

Sepi
Previous (IncUnitRefCount)
Next (LoadUnitFromOriginalRoot)

Name
LoadUnit

Parent
TSepiRootFork

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function LoadUnit ( const UnitName : string ) : TSepiUnit ; override

Parameters
Parameter | Description
UnitName : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiUnit | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IncUnitRefCount)
Next (LoadUnitFromOriginalRoot)


Sepi

Sepi
Previous (LoadUnit)
Next (RemoveChild)

Name
LoadUnitFromOriginalRoot

Parent
TSepiRootFork

Visibility
PRIVATE

Description
Charge une unité depuis la racine de base

Source code
function LoadUnitFromOriginalRoot ( const UnitName : string ) : TSepiUnit

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité

Return
Types | Description
TSepiUnit | Unité Sepi chargée, ou nil si non trouvée

Sepi
Class Tree
Index
Previous (LoadUnit)
Next (RemoveChild)


Sepi

Sepi
Previous (LoadUnitFromOriginalRoot)
Next (UnloadUnit)

Name
RemoveChild

Parent
TSepiRootFork

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure RemoveChild ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadUnitFromOriginalRoot)
Next (UnloadUnit)


Sepi

Sepi
Previous (RemoveChild)
Next

Name
UnloadUnit

Parent
TSepiRootFork

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure UnloadUnit ( const UnitName : string ) ; override

Parameters
Parameter | Description
UnitName : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (RemoveChild)
Next


Sepi

Sepi
Previous (TSepiRootFork)
Next (TSepiTypeAlias)

Name
TSepiType

Parent
SepiReflectionCore

Class Hierarchy
TSepiComponent

Visibility
PUBLIC

Description
Type

Members
Fields
Field | Description
FCompleted (-) | Indique si le type est complet
FIsReady (-) | Indique si le type est prêt
FKind (-) | Type de type
FNative (-) | Indique si le type est un type natif Delphi
FNeedInit (#) | Indique si ce type requiert une initialisation
FParamBehavior (#) | Comportement comme paramètre
FResultBehavior (#) | Comportement comme résultat
FSize (#) | Taille d'une variable de ce type
FTypeData (-) | RTTD (Runtime Type Data)
FTypeInfo (-) | RTTI (Runtime Type Information)
FTypeInfoLength (-) | Taille des RTTI créées (ou 0 si non créées)
FTypeInfoRef (-) | Référence aux RTTI

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
AlignOffset (+) | Aligne l'offset donné conformément à la propriété Alignment
Clone (+) | Clone un type
CompatibleWith (+) | Teste si un type est compatible avec un autre
Complete (#) | Complète le type
CopyData (+) | Copie des données de ce type
Create (+) | Crée un nouveau type
Destroy (+) | [@inheritDoc]
DisposeValue (+) | Libère une valeur de ce type, et la finalise si besoin
Equals (+) | Teste si un type est égal à un autre
FinalizeValue (+) | Finalise une valeur de ce type
ForwardDecl (#) | Déclare un type en forward
GetAlignment (#) | Alignement du type
GetDescription (#) | Description courte
GetDisplayName (#) | [@inheritDoc]
GetSafeResultBehavior (#) | Variante de ResultBehavior valide aussi sur un type nil
HasTypeInfo (#) | Indique si ce type a des RTTI (TypeInfo)
InitializeValue (+) | Initialise une valeur de ce type
IsComposite (#) | Indique si ce type est un type composite
IsStrongComposite (#) | Indique si ce type est un type composite fort
Load (+) | Charge un type depuis un flux
MakeRuntimeInfo (#) | Construit les données de runtime du type
MakeTypeInfo (#) | Construit les RTTI du type
NewInstance (+) | [@inheritDoc]
NewValue (+) | Alloue une nouvelle valeur de ce type, et l'initialise si besoin
Save (#) | [@inheritDoc]
SetupProperties (#) | Renseigne les propriétés de ce type
ValueToString (+) | String representation of a value of this type
WriteAttrData (#) | Écrit les données d'attribut dans un flux
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | Écrit les RTTI du type dans un flux
WriteTypeInfoRefToStream (+) | Écrit une référence aux RTTI de ce type dans un flux

Properties
Property | Description
Alignment (+) | Alignement du type
Completed (+) | Indique si le type est complet
Description (+) | Description courte
IsReady (+) | Indique si le type est prêt
Kind (+) | Type de type
Native (+) | Indique si le type est un type natif Delphi
NeedInit (+) | Indique si ce type requiert une initialisation
ParamBehavior (+) | Comportement comme paramètre
ResultBehavior (+) | Comportement comme résultat
SafeResultBehavior (+) | Variante de ResultBehavior valide aussi sur un type nil
Size (+) | Taille d'une variable de ce type
TypeData (+) | RTTD (Runtime Type Data)
TypeInfo (+) | RTTI (Runtime Type Information)
TypeInfoRef (+) | Référence aux RTTI

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRootFork)
Next (TSepiTypeAlias)


Sepi

Sepi
Previous
Next (FIsReady)

Name
FCompleted

Parent
TSepiType

Visibility
PRIVATE

Description
Indique si le type est complet

Source code
FCompleted : Boolean

Sepi
Class Tree
Index
Previous
Next (FIsReady)


Sepi

Sepi
Previous (FCompleted)
Next (FKind)

Name
FIsReady

Parent
TSepiType

Visibility
PRIVATE

Description
Indique si le type est prêt

Source code
FIsReady : Boolean

Sepi
Class Tree
Index
Previous (FCompleted)
Next (FKind)


Sepi

Sepi
Previous (FIsReady)
Next (FNative)

Name
FKind

Parent
TSepiType

Visibility
PRIVATE

Description
Type de type

Source code
FKind : TTypeKind

Sepi
Class Tree
Index
Previous (FIsReady)
Next (FNative)


Sepi

Sepi
Previous (FKind)
Next (FNeedInit)

Name
FNative

Parent
TSepiType

Visibility
PRIVATE

Description
Indique si le type est un type natif Delphi

Source code
FNative : Boolean

Sepi
Class Tree
Index
Previous (FKind)
Next (FNeedInit)


Sepi

Sepi
Previous (FNative)
Next (FParamBehavior)

Name
FNeedInit

Parent
TSepiType

Visibility
PROTECTED

Description
Indique si ce type requiert une initialisation

Source code
FNeedInit : Boolean

Sepi
Class Tree
Index
Previous (FNative)
Next (FParamBehavior)


Sepi

Sepi
Previous (FNeedInit)
Next (FResultBehavior)

Name
FParamBehavior

Parent
TSepiType

Visibility
PROTECTED

Description
Comportement comme paramètre

Source code
FParamBehavior : TSepiTypeParamBehavior

Sepi
Class Tree
Index
Previous (FNeedInit)
Next (FResultBehavior)


Sepi

Sepi
Previous (FParamBehavior)
Next (FSize)

Name
FResultBehavior

Parent
TSepiType

Visibility
PROTECTED

Description
Comportement comme résultat

Source code
FResultBehavior : TSepiTypeResultBehavior

Sepi
Class Tree
Index
Previous (FParamBehavior)
Next (FSize)


Sepi

Sepi
Previous (FResultBehavior)
Next (FTypeData)

Name
FSize

Parent
TSepiType

Visibility
PROTECTED

Description
Taille d'une variable de ce type

Source code
FSize : Integer

Sepi
Class Tree
Index
Previous (FResultBehavior)
Next (FTypeData)


Sepi

Sepi
Previous (FSize)
Next (FTypeInfo)

Name
FTypeData

Parent
TSepiType

Visibility
PRIVATE

Description
RTTD (Runtime Type Data)

Source code
FTypeData : PTypeData

Sepi
Class Tree
Index
Previous (FSize)
Next (FTypeInfo)


Sepi

Sepi
Previous (FTypeData)
Next (FTypeInfoLength)

Name
FTypeInfo

Parent
TSepiType

Visibility
PRIVATE

Description
RTTI (Runtime Type Information)

Source code
FTypeInfo : PTypeInfo

Sepi
Class Tree
Index
Previous (FTypeData)
Next (FTypeInfoLength)


Sepi

Sepi
Previous (FTypeInfo)
Next (FTypeInfoRef)

Name
FTypeInfoLength

Parent
TSepiType

Visibility
PRIVATE

Description
Taille des RTTI créées (ou 0 si non créées)

Source code
FTypeInfoLength : Integer

Sepi
Class Tree
Index
Previous (FTypeInfo)
Next (FTypeInfoRef)


Sepi

Sepi
Previous (FTypeInfoLength)
Next

Name
FTypeInfoRef

Parent
TSepiType

Visibility
PRIVATE

Description
Référence aux RTTI

Source code
FTypeInfoRef : PPTypeInfo

Sepi
Class Tree
Index
Previous (FTypeInfoLength)
Next


Sepi

Sepi
Previous
Next (Completed)

Name
Alignment

Parent
TSepiType

Visibility
PUBLIC

Description
Alignement du type

Source code
property Alignment : Integer read GetAlignment

Read Access
GetAlignment

Sepi
Class Tree
Index
Previous
Next (Completed)


Sepi

Sepi
Previous (Alignment)
Next (Description)

Name
Completed

Parent
TSepiType

Visibility
PUBLIC

Description
Indique si le type est complet

Source code
property Completed : Boolean read FCompleted

Read Access
FCompleted

Sepi
Class Tree
Index
Previous (Alignment)
Next (Description)


Sepi

Sepi
Previous (Completed)
Next (IsReady)

Name
Description

Parent
TSepiType

Visibility
PUBLIC

Description
Description courte

Source code
property Description : string read GetDescription

Read Access
GetDescription

Sepi
Class Tree
Index
Previous (Completed)
Next (IsReady)


Sepi

Sepi
Previous (Description)
Next (Kind)

Name
IsReady

Parent
TSepiType

Visibility
PUBLIC

Description
Indique si le type est prêt

Source code
property IsReady : Boolean read FIsReady

Read Access
FIsReady

Sepi
Class Tree
Index
Previous (Description)
Next (Kind)


Sepi

Sepi
Previous (IsReady)
Next (Native)

Name
Kind

Parent
TSepiType

Visibility
PUBLIC

Description
Type de type

Source code
property Kind : TTypeKind read FKind

Read Access
FKind

Sepi
Class Tree
Index
Previous (IsReady)
Next (Native)


Sepi

Sepi
Previous (Kind)
Next (NeedInit)

Name
Native

Parent
TSepiType

Visibility
PUBLIC

Description
Indique si le type est un type natif Delphi

Source code
property Native : Boolean read FNative

Read Access
FNative

Sepi
Class Tree
Index
Previous (Kind)
Next (NeedInit)


Sepi

Sepi
Previous (Native)
Next (ParamBehavior)

Name
NeedInit

Parent
TSepiType

Visibility
PUBLIC

Description
Indique si ce type requiert une initialisation

Source code
property NeedInit : Boolean read FNeedInit

Read Access
FNeedInit

Sepi
Class Tree
Index
Previous (Native)
Next (ParamBehavior)


Sepi

Sepi
Previous (NeedInit)
Next (ResultBehavior)

Name
ParamBehavior

Parent
TSepiType

Visibility
PUBLIC

Description
Comportement comme paramètre

Source code
property ParamBehavior : TSepiTypeParamBehavior read FParamBehavior

Read Access
FParamBehavior

Sepi
Class Tree
Index
Previous (NeedInit)
Next (ResultBehavior)


Sepi

Sepi
Previous (ParamBehavior)
Next (SafeResultBehavior)

Name
ResultBehavior

Parent
TSepiType

Visibility
PUBLIC

Description
Comportement comme résultat

Source code
property ResultBehavior : TSepiTypeResultBehavior read FResultBehavior

Read Access
FResultBehavior

Sepi
Class Tree
Index
Previous (ParamBehavior)
Next (SafeResultBehavior)


Sepi

Sepi
Previous (ResultBehavior)
Next (Size)

Name
SafeResultBehavior

Parent
TSepiType

Visibility
PUBLIC

Description
Variante de ResultBehavior valide aussi sur un type nil

Source code
property SafeResultBehavior : TSepiTypeResultBehavior read GetSafeResultBehavior

Read Access
GetSafeResultBehavior

Sepi
Class Tree
Index
Previous (ResultBehavior)
Next (Size)


Sepi

Sepi
Previous (SafeResultBehavior)
Next (TypeData)

Name
Size

Parent
TSepiType

Visibility
PUBLIC

Description
Taille d'une variable de ce type

Source code
property Size : Integer read FSize

Read Access
FSize

Sepi
Class Tree
Index
Previous (SafeResultBehavior)
Next (TypeData)


Sepi

Sepi
Previous (Size)
Next (TypeInfo)

Name
TypeData

Parent
TSepiType

Visibility
PUBLIC

Description
RTTD (Runtime Type Data)

Source code
property TypeData : PTypeData read FTypeData

Read Access
FTypeData

Sepi
Class Tree
Index
Previous (Size)
Next (TypeInfo)


Sepi

Sepi
Previous (TypeData)
Next (TypeInfoRef)

Name
TypeInfo

Parent
TSepiType

Visibility
PUBLIC

Description
RTTI (Runtime Type Information)

Source code
property TypeInfo : PTypeInfo read FTypeInfo

Read Access
FTypeInfo

Sepi
Class Tree
Index
Previous (TypeData)
Next (TypeInfoRef)


Sepi

Sepi
Previous (TypeInfo)
Next

Name
TypeInfoRef

Parent
TSepiType

Visibility
PUBLIC

Description
Référence aux RTTI

Source code
property TypeInfoRef : PPTypeInfo read FTypeInfoRef

Read Access
FTypeInfoRef

Sepi
Class Tree
Index
Previous (TypeInfo)
Next


Sepi

Sepi
Previous
Next (AlignOffset)

Name
AfterConstruction

Parent
TSepiType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (AlignOffset)


Sepi

Sepi
Previous (AfterConstruction)
Next (Clone)

Name
AlignOffset

Parent
TSepiType

Visibility
PUBLIC

Description
Aligne l'offset donné conformément à la propriété Alignment

Source code
procedure AlignOffset ( var Offset : Integer )

Parameters
Parameter | Description
OFFSET : INTEGER | Offset à aligner

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Clone)


Sepi

Sepi
Previous (AlignOffset)
Next (CompatibleWith)

Name
Clone

Parent
TSepiType

Visibility
PUBLIC

Description
Clone un type

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; virtual

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
Source : TSepiType | Type à cloner

Sepi
Class Tree
Index
Previous (AlignOffset)
Next (CompatibleWith)


Sepi

Sepi
Previous (Clone)
Next (Complete)

Name
CompatibleWith

Parent
TSepiType

Visibility
PUBLIC

Description
Teste si un type est compatible avec un autre
Il faut appeler CompatibleWith sur le type de la variable affectée, et avec en
paramètre le type de l'expression à droite de l'assignation.

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; virtual

Parameters
Parameter | Description
AType : TSepiType | Type avec lequel tester la compatibilité

Return
Types | Description
BOOLEAN | True si les types sont compatibles, False sinon

Sepi
Class Tree
Index
Previous (Clone)
Next (Complete)


Sepi

Sepi
Previous (CompatibleWith)
Next (CopyData)

Name
Complete

Parent
TSepiType

Visibility
PROTECTED

Description
Complète le type

Source code
procedure Complete ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (CopyData)


Sepi

Sepi
Previous (Complete)
Next (Create)

Name
CopyData

Parent
TSepiType

Visibility
PUBLIC

Description
Copie des données de ce type

Source code
procedure CopyData ( const Source ; var Dest )

Parameters
Parameter | Description
Source : Untyped | Source
Dest : Untyped | Destination

Sepi
Class Tree
Index
Previous (Complete)
Next (Create)


Sepi

Sepi
Previous (CopyData)
Next (Destroy)

Name
Create

Parent
TSepiType

Visibility
PUBLIC

Description
Crée un nouveau type

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AKind : TTypeKind )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AKind : TTypeKind | Type de type

Sepi
Class Tree
Index
Previous (CopyData)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (DisposeValue)

Name
Destroy

Parent
TSepiType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (DisposeValue)


Sepi

Sepi
Previous (Destroy)
Next (Equals)

Name
DisposeValue

Parent
TSepiType

Visibility
PUBLIC

Description
Libère une valeur de ce type, et la finalise si besoin

Source code
procedure DisposeValue ( Value : Pointer )

Parameters
Parameter | Description
Value : Pointer | Pointeur sur la valeur à libérer

Sepi
Class Tree
Index
Previous (Destroy)
Next (Equals)


Sepi

Sepi
Previous (DisposeValue)
Next (FinalizeValue)

Name
Equals

Parent
TSepiType

Visibility
PUBLIC

Description
Teste si un type est égal à un autre
Deux types sont égaux si et seulement si leurs variables ont la même structure
interne. Dans ce cas, une copie via CopyData est valide.
La relation établie avec Equals est une relation d'équivalence.

Source code
function Equals ( Other : TSepiType ) : Boolean ; reintroduce ; virtual

Parameters
Parameter | Description
Other : TSepiType | Autre type à comparer

Return
Types | Description
BOOLEAN | True si les types sont égaux, False sinon

Sepi
Class Tree
Index
Previous (DisposeValue)
Next (FinalizeValue)


Sepi

Sepi
Previous (Equals)
Next (ForwardDecl)

Name
FinalizeValue

Parent
TSepiType

Visibility
PUBLIC

Description
Finalise une valeur de ce type

Source code
procedure FinalizeValue ( var Value )

Parameters
Parameter | Description
Value : Untyped | Valeur à finaliser

Sepi
Class Tree
Index
Previous (Equals)
Next (ForwardDecl)


Sepi

Sepi
Previous (FinalizeValue)
Next (GetAlignment)

Name
ForwardDecl

Parent
TSepiType

Visibility
PROTECTED

Description
Déclare un type en forward

Source code
class function ForwardDecl ( AOwner : TSepiComponent ; const AName : string ) : TSepiType

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire
AName : STRING | Nom du type

Return
Types | Description
TSepiType | Type créé

Sepi
Class Tree
Index
Previous (FinalizeValue)
Next (GetAlignment)


Sepi

Sepi
Previous (ForwardDecl)
Next (GetDescription)

Name
GetAlignment

Parent
TSepiType

Visibility
PROTECTED

Description
Alignement du type
Les variables de ce type seront placées en mémoire à un adresse divisible par
l'alignement.

Source code
function GetAlignment : Integer ; virtual

Parameters
Parameter Description

Return
Types | Description
INTEGER | Alignement du type

Sepi
Class Tree
Index
Previous (ForwardDecl)
Next (GetDescription)


Sepi

Sepi
Previous (GetAlignment)
Next (GetDisplayName)

Name
GetDescription

Parent
TSepiType

Visibility
PROTECTED

Description
Description courte

Source code
function GetDescription : string ; virtual

Parameters
Parameter Description

Return
Types | Description
STRING | Description courte

Sepi
Class Tree
Index
Previous (GetAlignment)
Next (GetDisplayName)


Sepi

Sepi
Previous (GetDescription)
Next (GetSafeResultBehavior)

Name
GetDisplayName

Parent
TSepiType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDisplayName : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDescription)
Next (GetSafeResultBehavior)


Sepi

Sepi
Previous (GetDisplayName)
Next (HasTypeInfo)

Name
GetSafeResultBehavior

Parent
TSepiType

Visibility
PROTECTED

Description
Variante de ResultBehavior valide aussi sur un type nil

Source code
function GetSafeResultBehavior : TSepiTypeResultBehavior

Parameters
Parameter Description

Return
Types | Description
TSepiTypeResultBehavior | rbNone si le type est nil, ResultBehavior sinon

Sepi
Class Tree
Index
Previous (GetDisplayName)
Next (HasTypeInfo)


Sepi

Sepi
Previous (GetSafeResultBehavior)
Next (InitializeValue)

Name
HasTypeInfo

Parent
TSepiType

Visibility
PROTECTED

Description
Indique si ce type a des RTTI (TypeInfo)

Source code
function HasTypeInfo : Boolean ; virtual

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si ce type a des RTTI, False sinon

Sepi
Class Tree
Index
Previous (GetSafeResultBehavior)
Next (InitializeValue)


Sepi

Sepi
Previous (HasTypeInfo)
Next (IsComposite)

Name
InitializeValue

Parent
TSepiType

Visibility
PUBLIC

Description
Initialise une valeur de ce type

Source code
procedure InitializeValue ( var Value )

Parameters
Parameter | Description
Value : Untyped | Valeur à initialiser

Sepi
Class Tree
Index
Previous (HasTypeInfo)
Next (IsComposite)


Sepi

Sepi
Previous (InitializeValue)
Next (IsStrongComposite)

Name
IsComposite

Parent
TSepiType

Visibility
PROTECTED

Description
Indique si ce type est un type composite
Les types composites ne sont pas complétés automatiquement dans
AfterConstruction.

Source code
function IsComposite : Boolean ; virtual

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InitializeValue)
Next (IsStrongComposite)


Sepi

Sepi
Previous (IsComposite)
Next (Load)

Name
IsStrongComposite

Parent
TSepiType

Visibility
PROTECTED

Description
Indique si ce type est un type composite fort
Les types composites forts sont des types composites dont les propriétés
dépendent des composés. La méthode SetupProperties ne peut donc pas être
appelée tant que le type n'a pas été complété.

Source code
function IsStrongComposite : Boolean ; virtual

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (IsComposite)
Next (Load)


Sepi

Sepi
Previous (IsStrongComposite)
Next (MakeRuntimeInfo)

Name
Load

Parent
TSepiType

Visibility
PUBLIC

Description
Charge un type depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
Stream : TStream | Flux depuis lequel charger le type

Sepi
Class Tree
Index
Previous (IsStrongComposite)
Next (MakeRuntimeInfo)


Sepi

Sepi
Previous (Load)
Next (MakeTypeInfo)

Name
MakeRuntimeInfo

Parent
TSepiType

Visibility
PROTECTED

Description
Construit les données de runtime du type

Source code
procedure MakeRuntimeInfo ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Load)
Next (MakeTypeInfo)


Sepi

Sepi
Previous (MakeRuntimeInfo)
Next (NewInstance)

Name
MakeTypeInfo

Parent
TSepiType

Visibility
PROTECTED

Description
Construit les RTTI du type

Source code
procedure MakeTypeInfo

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeRuntimeInfo)
Next (NewInstance)


Sepi

Sepi
Previous (MakeTypeInfo)
Next (NewValue)

Name
NewInstance

Parent
TSepiType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
class function NewInstance : TObject ; override

Parameters
Parameter Description

Return
Types | Description
TObject | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeTypeInfo)
Next (NewValue)


Sepi

Sepi
Previous (NewInstance)
Next (Save)

Name
NewValue

Parent
TSepiType

Visibility
PUBLIC

Description
Alloue une nouvelle valeur de ce type, et l'initialise si besoin

Source code
function NewValue : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | Pointeur sur la nouvelle valeur

Sepi
Class Tree
Index
Previous (NewInstance)
Next (Save)


Sepi

Sepi
Previous (NewValue)
Next (SetupProperties)

Name
Save

Parent
TSepiType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (NewValue)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiType

Visibility
PROTECTED

Description
Renseigne les propriétés de ce type

Source code
procedure SetupProperties ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteAttrData)

Name
ValueToString

Parent
TSepiType

Visibility
PUBLIC

Description
String representation of a value of this type
This method is useful for debugging purpose

Source code
function ValueToString ( const Value ) : string ; virtual

Parameters
Parameter | Description
Value : Untyped | Value to represent

Return
Types | Description
STRING | String representation of Value

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteAttrData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteDigestData)

Name
WriteAttrData

Parent
TSepiType

Visibility
PROTECTED

Description
Écrit les données d'attribut dans un flux

Source code
procedure WriteAttrData ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteDigestData)


Sepi

Sepi
Previous (WriteAttrData)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteAttrData)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next (WriteTypeInfoRefToStream)

Name
WriteTypeInfo

Parent
TSepiType

Visibility
PROTECTED

Description
Écrit les RTTI du type dans un flux

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; virtual

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next (WriteTypeInfoRefToStream)


Sepi

Sepi
Previous (WriteTypeInfo)
Next

Name
WriteTypeInfoRefToStream

Parent
TSepiType

Visibility
PUBLIC

Description
Écrit une référence aux RTTI de ce type dans un flux

Source code
procedure WriteTypeInfoRefToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux destination

Sepi
Class Tree
Index
Previous (WriteTypeInfo)
Next


Sepi

Sepi
Previous (TSepiType)
Next (TSepiTypeParamBehavior)

Name
TSepiTypeAlias

Parent
SepiReflectionCore

Class Hierarchy
TSepiComponent

Visibility
PUBLIC

Description
Alias de type

Members
Fields
Field | Description
FDest (-) | Type destination

Methods
Method | Description
Create (+) | Crée un nouvel alias de type
ListReferences (#) | [@inheritDoc]
Load (+) | Charge un alias de type depuis un flux
Save (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
Dest (+) | Type destination

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiType)
Next (TSepiTypeParamBehavior)


Sepi

Sepi
Previous
Next

Name
FDest

Parent
TSepiTypeAlias

Visibility
PRIVATE

Description
Type destination

Source code
FDest : TSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Dest

Parent
TSepiTypeAlias

Visibility
PUBLIC

Description
Type destination

Source code
property Dest : TSepiType read FDest

Read Access
FDest

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ListReferences)

Name
Create

Parent
TSepiTypeAlias

Visibility
PUBLIC

Description
Crée un nouvel alias de type

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; ADest : TSepiType )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de l'alias de type
AName : STRING | Nom de l'alias de type
ADest : TSepiType | Destination de l'alias

Sepi
Class Tree
Index
Previous
Next (ListReferences)


Sepi

Sepi
Previous (Create)
Next (Load)

Name
ListReferences

Parent
TSepiTypeAlias

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiTypeAlias

Visibility
PUBLIC

Description
Charge un alias de type depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (WriteDigestData)

Name
Save

Parent
TSepiTypeAlias

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (WriteDigestData)


Sepi

Sepi
Previous (Save)
Next

Name
WriteDigestData

Parent
TSepiTypeAlias

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next


Sepi

Sepi
Previous (TSepiTypeAlias)
Next (TSepiUnit)

Name
TSepiTypeParamBehavior

Parent
SepiReflectionCore

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Comportement d'un type lorsqu'il est passé en paramètre

Members
Fields
Field | Description
AlwaysByAddress (*) | Le type est toujours passé par adresse
AlwaysByStack (*) | Le type est toujours passé sur la pile

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeAlias)
Next (TSepiUnit)


Sepi

Sepi
Previous
Next (AlwaysByStack)

Name
AlwaysByAddress

Parent
TSepiTypeParamBehavior

Visibility
PUBLISHED

Description
Le type est toujours passé par adresse

Source code
AlwaysByAddress : Boolean

Sepi
Class Tree
Index
Previous
Next (AlwaysByStack)


Sepi

Sepi
Previous (AlwaysByAddress)
Next

Name
AlwaysByStack

Parent
TSepiTypeParamBehavior

Visibility
PUBLISHED

Description
Le type est toujours passé sur la pile

Source code
AlwaysByStack : Boolean

Sepi
Class Tree
Index
Previous (AlwaysByAddress)
Next


Sepi

Sepi
Previous (TSepiTypeParamBehavior)
Next (TSepiUnitAlias)

Name
TSepiUnit

Parent
SepiReflectionCore

Class Hierarchy
TSepiComponent

Visibility
PUBLIC

Description
Unité

Members
Fields
Field | Description
FCurrentVisibility (-) | Visibilité courante
FLazyLoad (-) | True si mode lazy-load
FLazyLoadData (-) | Données de lazy-load
FOnGetMethodCode (-) | Déclenché pour chaque méthode au chargement, pour obtenir son code
FOnGetTypeInfo (-) | Déclenché pour chaque type au chargement, pour obtenir ses RTTI
FOnGetVarAddress (-) | Déclenché pour chaque variable au chargement, pour obtenir son adresse
FRefCount (-) | Compteur de références
FReferences (-) | Références en chargement/sauvegarde
FUsesList (-) | Liste des uses

Methods
Method | Description
AddRef (+) | Ajoute une référence qui va devoir être enregistrée
AddUses (-) | Ajoute une unité aux uses de cette unité
Complete (+) | Complète l'unité créée
Create (+) | Crée une nouvelle unité
Destroy (+) | [@inheritDoc]
FindClass (+) | Trouve une classe enregistrée à partir de la classe Delphi dans cette unité
GetClass (+) | Trouve une classe enregistrée à partir de la classe Delphi dans cette unité
GetUsedUnitCount (-) | Nombre d'unités utilisées
GetUsedUnits (-) | Tableau zero-based des unités utilisées
InternalGetComponent (#) | [@inheritDoc]
InternalLookFor (#) | [@inheritDoc]
LazyLoadChild (-) | Charge un enfant, s'il existe
Load (+) | Charge une unité depuis un flux
LoadChildren (#) | [@inheritDoc]
LoadFromStream (+) | Charge l'unité depuis un flux
MoreUses (+) | Ajoute des uses à l'unité
ReadRef (+) | Lit une référence depuis un flux
Save (#) | [@inheritDoc]
SaveChildren (#) | [@inheritDoc]
SaveToStream (+) | Enregistre l'unité dans un flux
SetCurrentVisibility (-) | Change la visibilité courante
WriteRef (+) | Écrit une référence dans un flux

Properties
Property | Description
CurrentVisibility (+) | Visibilité courante
LazyLoad (+) | True si mode lazy-load
OnGetMethodCode (+) | Déclenché pour chaque méthode au chargement, pour obtenir son code
OnGetTypeInfo (+) | Déclenché pour chaque type au chargement, pour obtenir ses RTTI
OnGetVarAddress (+) | Déclenché pour chaque variable au chargement, pour obtenir son adresse
UsedUnitCount (+) | Nombre d'unités utilisées
UsedUnits (+) | Tableau zero-based des unités utilisées

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeParamBehavior)
Next (TSepiUnitAlias)


Sepi

Sepi
Previous
Next (FLazyLoad)

Name
FCurrentVisibility

Parent
TSepiUnit

Visibility
PRIVATE

Description
Visibilité courante

Source code
FCurrentVisibility : TMemberVisibility

Sepi
Class Tree
Index
Previous
Next (FLazyLoad)


Sepi

Sepi
Previous (FCurrentVisibility)
Next (FLazyLoadData)

Name
FLazyLoad

Parent
TSepiUnit

Visibility
PRIVATE

Description
True si mode lazy-load

Source code
FLazyLoad : Boolean

Sepi
Class Tree
Index
Previous (FCurrentVisibility)
Next (FLazyLoadData)


Sepi

Sepi
Previous (FLazyLoad)
Next (FOnGetMethodCode)

Name
FLazyLoadData

Parent
TSepiUnit

Visibility
PRIVATE

Description
Données de lazy-load

Source code
FLazyLoadData : TSepiLazyLoadData

Sepi
Class Tree
Index
Previous (FLazyLoad)
Next (FOnGetMethodCode)


Sepi

Sepi
Previous (FLazyLoadData)
Next (FOnGetTypeInfo)

Name
FOnGetMethodCode

Parent
TSepiUnit

Visibility
PRIVATE

Description
Déclenché pour chaque méthode au chargement, pour obtenir son code

Source code
FOnGetMethodCode : TGetMethodCodeEvent

Sepi
Class Tree
Index
Previous (FLazyLoadData)
Next (FOnGetTypeInfo)


Sepi

Sepi
Previous (FOnGetMethodCode)
Next (FOnGetVarAddress)

Name
FOnGetTypeInfo

Parent
TSepiUnit

Visibility
PRIVATE

Description
Déclenché pour chaque type au chargement, pour obtenir ses RTTI

Source code
FOnGetTypeInfo : TGetTypeInfoEvent

Sepi
Class Tree
Index
Previous (FOnGetMethodCode)
Next (FOnGetVarAddress)


Sepi

Sepi
Previous (FOnGetTypeInfo)
Next (FRefCount)

Name
FOnGetVarAddress

Parent
TSepiUnit

Visibility
PRIVATE

Description
Déclenché pour chaque variable au chargement, pour obtenir son adresse

Source code
FOnGetVarAddress : TGetVarAddressEvent

Sepi
Class Tree
Index
Previous (FOnGetTypeInfo)
Next (FRefCount)


Sepi

Sepi
Previous (FOnGetVarAddress)
Next (FReferences)

Name
FRefCount

Parent
TSepiUnit

Visibility
PRIVATE

Description
Compteur de références

Source code
FRefCount : Integer

Sepi
Class Tree
Index
Previous (FOnGetVarAddress)
Next (FReferences)


Sepi

Sepi
Previous (FRefCount)
Next (FUsesList)

Name
FReferences

Parent
TSepiUnit

Visibility
PRIVATE

Description
Références en chargement/sauvegarde

Source code
FReferences : array of TStrings

Sepi
Class Tree
Index
Previous (FRefCount)
Next (FUsesList)


Sepi

Sepi
Previous (FReferences)
Next

Name
FUsesList

Parent
TSepiUnit

Visibility
PRIVATE

Description
Liste des uses

Source code
FUsesList : TStrings

Sepi
Class Tree
Index
Previous (FReferences)
Next


Sepi

Sepi
Previous
Next (LazyLoad)

Name
CurrentVisibility

Parent
TSepiUnit

Visibility
PUBLIC

Description
Visibilité courante

Source code
property CurrentVisibility : TMemberVisibility read FCurrentVisibility write SetCurrentVisibility

Read Access
FCurrentVisibility

Write Access
SetCurrentVisibility

Sepi
Class Tree
Index
Previous
Next (LazyLoad)


Sepi

Sepi
Previous (CurrentVisibility)
Next (OnGetMethodCode)

Name
LazyLoad

Parent
TSepiUnit

Visibility
PUBLIC

Description
True si mode lazy-load

Source code
property LazyLoad : Boolean read FLazyLoad

Read Access
FLazyLoad

Sepi
Class Tree
Index
Previous (CurrentVisibility)
Next (OnGetMethodCode)


Sepi

Sepi
Previous (LazyLoad)
Next (OnGetTypeInfo)

Name
OnGetMethodCode

Parent
TSepiUnit

Visibility
PUBLIC

Description
Déclenché pour chaque méthode au chargement, pour obtenir son code

Source code
property OnGetMethodCode : TGetMethodCodeEvent read FOnGetMethodCode

Read Access
FOnGetMethodCode

Sepi
Class Tree
Index
Previous (LazyLoad)
Next (OnGetTypeInfo)


Sepi

Sepi
Previous (OnGetMethodCode)
Next (OnGetVarAddress)

Name
OnGetTypeInfo

Parent
TSepiUnit

Visibility
PUBLIC

Description
Déclenché pour chaque type au chargement, pour obtenir ses RTTI

Source code
property OnGetTypeInfo : TGetTypeInfoEvent read FOnGetTypeInfo

Read Access
FOnGetTypeInfo

Sepi
Class Tree
Index
Previous (OnGetMethodCode)
Next (OnGetVarAddress)


Sepi

Sepi
Previous (OnGetTypeInfo)
Next (UsedUnitCount)

Name
OnGetVarAddress

Parent
TSepiUnit

Visibility
PUBLIC

Description
Déclenché pour chaque variable au chargement, pour obtenir son adresse

Source code
property OnGetVarAddress : TGetVarAddressEvent read FOnGetVarAddress

Read Access
FOnGetVarAddress

Sepi
Class Tree
Index
Previous (OnGetTypeInfo)
Next (UsedUnitCount)


Sepi

Sepi
Previous (OnGetVarAddress)
Next (UsedUnits)

Name
UsedUnitCount

Parent
TSepiUnit

Visibility
PUBLIC

Description
Nombre d'unités utilisées

Source code
property UsedUnitCount : Integer read GetUsedUnitCount

Read Access
GetUsedUnitCount

Sepi
Class Tree
Index
Previous (OnGetVarAddress)
Next (UsedUnits)


Sepi

Sepi
Previous (UsedUnitCount)
Next

Name
UsedUnits

Parent
TSepiUnit

Visibility
PUBLIC

Description
Tableau zero-based des unités utilisées

Source code
property UsedUnits [ Index : Integer ] : TSepiUnit read GetUsedUnits

Read Access
GetUsedUnits

Sepi
Class Tree
Index
Previous (UsedUnitCount)
Next


Sepi

Sepi
Previous
Next (AddUses)

Name
AddRef

Parent
TSepiUnit

Visibility
PUBLIC

Description
Ajoute une référence qui va devoir être enregistrée
Cette méthode ne peut être appelée que depuis la méthode ListReferences des
composants contenus dans cette unité. À tout autre moment, c'est la violation
d'accès assurée.

Source code
procedure AddRef ( Ref : TSepiComponent )

Parameters
Parameter | Description
Ref : TSepiComponent | Référence à ajouter

Sepi
Class Tree
Index
Previous
Next (AddUses)


Sepi

Sepi
Previous (AddRef)
Next (Complete)

Name
AddUses

Parent
TSepiUnit

Visibility
PRIVATE

Description
Ajoute une unité aux uses de cette unité

Source code
function AddUses ( AUnit : TSepiUnit ) : Integer

Parameters
Parameter | Description
AUnit : TSepiUnit | Unité à ajouter aux uses

Return
Types | Description
INTEGER | Index de la nouvelle unité dans les uses

Sepi
Class Tree
Index
Previous (AddRef)
Next (Complete)


Sepi

Sepi
Previous (AddUses)
Next (Create)

Name
Complete

Parent
TSepiUnit

Visibility
PUBLIC

Description
Complète l'unité créée

Source code
procedure Complete

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AddUses)
Next (Create)


Sepi

Sepi
Previous (Complete)
Next (Destroy)

Name
Create

Parent
TSepiUnit

Visibility
PUBLIC

Description
Crée une nouvelle unité

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; const AUses : array of string )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de l'unité (la racine)
AName : STRING | Nom de l'unité
AUses : STRING

Sepi
Class Tree
Index
Previous (Complete)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (FindClass)

Name
Destroy

Parent
TSepiUnit

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (FindClass)


Sepi

Sepi
Previous (Destroy)
Next (GetClass)

Name
FindClass

Parent
TSepiUnit

Visibility
PUBLIC

Description
Trouve une classe enregistrée à partir de la classe Delphi dans cette unité
Le résultat peut toujours être *transtypé* en TSepiClass.

Source code
function FindClass ( DelphiClass : TClass ) : TSepiType

Parameters
Parameter | Description
DelphiClass : TClass | Classe Delphi recherchée

Return
Types | Description
TSepiType | Le type correspondant à la classe donnée (garanti être TSepiClass)

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetClass)


Sepi

Sepi
Previous (FindClass)
Next (GetUsedUnitCount)

Name
GetClass

Parent
TSepiUnit

Visibility
PUBLIC

Description
Trouve une classe enregistrée à partir de la classe Delphi dans cette unité
Le résultat peut toujours être *transtypé* en TSepiClass.
Renvoie nil si non trouvé

Source code
function GetClass ( DelphiClass : TClass ) : TSepiType

Parameters
Parameter | Description
DelphiClass : TClass | Classe Delphi recherchée

Return
Types | Description
TSepiType | Le type correspondant à la classe donnée (garanti être TSepiClass)

Sepi
Class Tree
Index
Previous (FindClass)
Next (GetUsedUnitCount)


Sepi

Sepi
Previous (GetClass)
Next (GetUsedUnits)

Name
GetUsedUnitCount

Parent
TSepiUnit

Visibility
PRIVATE

Description
Nombre d'unités utilisées

Source code
function GetUsedUnitCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre d'unité utilisées

Sepi
Class Tree
Index
Previous (GetClass)
Next (GetUsedUnits)


Sepi

Sepi
Previous (GetUsedUnitCount)
Next (InternalGetComponent)

Name
GetUsedUnits

Parent
TSepiUnit

Visibility
PRIVATE

Description
Tableau zero-based des unités utilisées

Source code
function GetUsedUnits ( Index : Integer ) : TSepiUnit

Parameters
Parameter | Description
INDEX : INTEGER | Index de l'unité utilisée

Return
Types | Description
TSepiUnit | Unité utilisée dont l'index est spécifié

Sepi
Class Tree
Index
Previous (GetUsedUnitCount)
Next (InternalGetComponent)


Sepi

Sepi
Previous (GetUsedUnits)
Next (InternalLookFor)

Name
InternalGetComponent

Parent
TSepiUnit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function InternalGetComponent ( const Name : string ) : TSepiComponent ; override

Parameters
Parameter | Description
NAME : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetUsedUnits)
Next (InternalLookFor)


Sepi

Sepi
Previous (InternalGetComponent)
Next (LazyLoadChild)

Name
InternalLookFor

Parent
TSepiUnit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function InternalLookFor ( const Name : string ; FromComponent : TSepiComponent ) : TSepiComponent ; override

Parameters
Parameter | Description
NAME : STRING | #Pas de TAG trouvé dans le code source#
FromComponent : TSepiComponent | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (InternalGetComponent)
Next (LazyLoadChild)


Sepi

Sepi
Previous (InternalLookFor)
Next (Load)

Name
LazyLoadChild

Parent
TSepiUnit

Visibility
PRIVATE

Description
Charge un enfant, s'il existe

Source code
function LazyLoadChild ( const Name : string ) : TSepiComponent

Parameters
Parameter | Description
NAME : STRING | Nom de l'enfant

Return
Types | Description
TSepiComponent | Enfant chargé, ou nil si n'existe pas

Sepi
Class Tree
Index
Previous (InternalLookFor)
Next (Load)


Sepi

Sepi
Previous (LazyLoadChild)
Next (LoadChildren)

Name
Load

Parent
TSepiUnit

Visibility
PUBLIC

Description
Charge une unité depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LazyLoadChild)
Next (LoadChildren)


Sepi

Sepi
Previous (Load)
Next (LoadFromStream)

Name
LoadChildren

Parent
TSepiUnit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure LoadChildren ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (LoadFromStream)


Sepi

Sepi
Previous (LoadChildren)
Next (MoreUses)

Name
LoadFromStream

Parent
TSepiUnit

Visibility
PUBLIC

Description
Charge l'unité depuis un flux

Source code
class function LoadFromStream ( AOwner : TSepiComponent ; Stream : TStream ; ALazyLoad : Boolean = False ; const AOnGetMethodCode : TGetMethodCodeEvent = nil ; const AOnGetTypeInfo : TGetTypeInfoEvent = nil ; const AOnGetVarAddress : TGetVarAddressEvent = nil ) : TSepiUnit

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de l'unité
Stream : TStream | Flux depuis lequel charger l'unité
ALazyLoad : BOOLEAN
AOnGetMethodCode : TGetMethodCodeEvent Méthode de call-back pour récupérer le code d'une
méthode
AOnGetTypeInfo : TGetTypeInfoEvent Méthode de call-back pour récupérer les RTTI d'un
type
AOnGetVarAddress : TGetVarAddressEvent

Return
Types | Description
TSepiUnit | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (LoadChildren)
Next (MoreUses)


Sepi

Sepi
Previous (LoadFromStream)
Next (ReadRef)

Name
MoreUses

Parent
TSepiUnit

Visibility
PUBLIC

Description
Ajoute des uses à l'unité
Cette méthode ne peut être appelée que pour une unité en cours de
construction.

Source code
procedure MoreUses ( const AUses : array of string )

Parameters
Parameter | Description
AUses : STRING | Uses à ajouter

Sepi
Class Tree
Index
Previous (LoadFromStream)
Next (ReadRef)


Sepi

Sepi
Previous (MoreUses)
Next (Save)

Name
ReadRef

Parent
TSepiUnit

Visibility
PUBLIC

Description
Lit une référence depuis un flux
Cette méthode ne peut être appelée que depuis le constructeur Load des metas
contenus dans cette unité. À tout autre moment, c'est la violation d'accès
assurée.

Source code
procedure ReadRef ( Stream : TStream ; out Ref )

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel écrire la référence
Ref : Untyped | Variable de type TSepiComponent où stocker la référence lue

Sepi
Class Tree
Index
Previous (MoreUses)
Next (Save)


Sepi

Sepi
Previous (ReadRef)
Next (SaveChildren)

Name
Save

Parent
TSepiUnit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ReadRef)
Next (SaveChildren)


Sepi

Sepi
Previous (Save)
Next (SaveToStream)

Name
SaveChildren

Parent
TSepiUnit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SaveChildren ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next (SaveToStream)


Sepi

Sepi
Previous (SaveChildren)
Next (SetCurrentVisibility)

Name
SaveToStream

Parent
TSepiUnit

Visibility
PUBLIC

Description
Enregistre l'unité dans un flux

Source code
procedure SaveToStream ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SaveChildren)
Next (SetCurrentVisibility)


Sepi

Sepi
Previous (SaveToStream)
Next (WriteRef)

Name
SetCurrentVisibility

Parent
TSepiUnit

Visibility
PRIVATE

Description
Change la visibilité courante

Source code
procedure SetCurrentVisibility ( Value : TMemberVisibility )

Parameters
Parameter | Description
Value : TMemberVisibility | Nouvelle visibilité

Sepi
Class Tree
Index
Previous (SaveToStream)
Next (WriteRef)


Sepi

Sepi
Previous (SetCurrentVisibility)
Next

Name
WriteRef

Parent
TSepiUnit

Visibility
PUBLIC

Description
Écrit une référence dans un flux
Toute référence à écrire doit être ajoutée au moyen de la méthode AddRef dans
la méthode ListReferences de son référenceur.
Cette méthode ne peut être appelée que depuis la méthode Save des composants
contenus dans cette unité. À tout autre moment, c'est la violation d'accès
assurée.

Source code
procedure WriteRef ( Stream : TStream ; Ref : TSepiComponent )

Parameters
Parameter | Description
Stream : TStream | Flux dans lequel écrire la référence
Ref : TSepiComponent | Référence à écrire

Sepi
Class Tree
Index
Previous (SetCurrentVisibility)
Next


Sepi

Sepi
Previous (TSepiUnit)
Next (TSepiUnitLoadTask)

Name
TSepiUnitAlias

Parent
SepiReflectionCore

Class Hierarchy
TSepiUnit

Visibility
PUBLIC

Description
Alias d'unité
Un alias d'unité permet de regrouper une à plusieurs unités réelle sous un
même nom d'unité. Les unités réelles sont en fait stockées comme les uses de
l'alias d'unité.
Ainsi, lorsqu'on cherche un composant dans un alias d'unité, la recherche
s'effectue aussi dans les unités utilisées par cet alias, même si on vient
d'une autre unité.

Members
Methods
Method | Description
InternalLookFor (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUnit)
Next (TSepiUnitLoadTask)


Sepi

Sepi
Previous
Next

Name
InternalLookFor

Parent
TSepiUnitAlias

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function InternalLookFor ( const Name : string ; FromComponent : TSepiComponent ) : TSepiComponent ; override

Parameters
Parameter | Description
NAME : STRING | #Pas de TAG trouvé dans le code source#
FromComponent : TSepiComponent | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiUnitAlias)
Next (TSepiUntypedType)

Name
TSepiUnitLoadTask

Parent
SepiReflectionCore

Class Hierarchy
TScTask

Visibility
PUBLIC

Description
Tâche de chargement/déchargement d'une unité Sepi

Members
Fields
Field | Description
FIsLoad (-) | True pour charger, False pour décharger
FName (-) | Nom de l'unité à charger/décharger
FRoot (-) | Racine Sepi

Methods
Method | Description
Create (+) | Crée une nouvelle tâche de chargement/déchargement d'une unité Sepi
Create (+) | Crée une nouvelle tâche de chargement/déchargement d'une unité Sepi
Execute (#) | [@inheritDoc]

Properties
Property | Description
IsLoad (+) | True pour charger, False pour décharger
NAME (+) | Nom de l'unité à charger/décharger
Root (+) | Racine Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUnitAlias)
Next (TSepiUntypedType)


Sepi

Sepi
Previous
Next (FName)

Name
FIsLoad

Parent
TSepiUnitLoadTask

Visibility
PRIVATE

Description
True pour charger, False pour décharger

Source code
FIsLoad : Boolean

Sepi
Class Tree
Index
Previous
Next (FName)


Sepi

Sepi
Previous (FIsLoad)
Next (FRoot)

Name
FName

Parent
TSepiUnitLoadTask

Visibility
PRIVATE

Description
Nom de l'unité à charger/décharger

Source code
FName : string

Sepi
Class Tree
Index
Previous (FIsLoad)
Next (FRoot)


Sepi

Sepi
Previous (FName)
Next

Name
FRoot

Parent
TSepiUnitLoadTask

Visibility
PRIVATE

Description
Racine Sepi

Source code
FRoot : TSepiRoot

Sepi
Class Tree
Index
Previous (FName)
Next


Sepi

Sepi
Previous
Next (NAME)

Name
IsLoad

Parent
TSepiUnitLoadTask

Visibility
PUBLIC

Description
True pour charger, False pour décharger

Source code
property IsLoad : Boolean read FIsLoad

Read Access
FIsLoad

Sepi
Class Tree
Index
Previous
Next (NAME)


Sepi

Sepi
Previous (IsLoad)
Next (Root)

Name
NAME

Parent
TSepiUnitLoadTask

Visibility
PUBLIC

Description
Nom de l'unité à charger/décharger

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (IsLoad)
Next (Root)


Sepi

Sepi
Previous (NAME)
Next

Name
Root

Parent
TSepiUnitLoadTask

Visibility
PUBLIC

Description
Racine Sepi

Source code
property Root : TSepiRoot read FRoot

Read Access
FRoot

Sepi
Class Tree
Index
Previous (NAME)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TSepiUnitLoadTask

Visibility
PUBLIC

Description
Crée une nouvelle tâche de chargement/déchargement d'une unité Sepi

Source code
constructor Create ( AOwner : TScCustomTaskQueue ; ARoot : TSepiRoot ; const AUnitName : string ; AIsLoad : Boolean ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | Gestionnaire propriétaire
ARoot : TSepiRoot | Racine Sepi
AUnitName : STRING | Nom de l'unité à charger/décharger
AIsLoad : BOOLEAN | True pour charger, False pour décharger

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Execute)

Name
Create

Parent
TSepiUnitLoadTask

Visibility
PUBLIC

Description
Crée une nouvelle tâche de chargement/déchargement d'une unité Sepi

Source code
constructor Create ( AOwner : TScCustomTaskQueue ; ARoot : TSepiRoot ; const AUnitName : string ; AIsLoad : Boolean ; AFreeOnFinished : Boolean ) ; overload

Parameters
Parameter | Description
AOwner : TScCustomTaskQueue | Gestionnaire propriétaire
ARoot : TSepiRoot | Racine Sepi
AUnitName : STRING | Nom de l'unité à charger/décharger
AIsLoad : BOOLEAN | True pour charger, False pour décharger
AFreeOnFinished : BOOLEAN | Indique si doit se détruire automatiquement

Sepi
Class Tree
Index
Previous (Create)
Next (Execute)


Sepi

Sepi
Previous (Create)
Next

Name
Execute

Parent
TSepiUnitLoadTask

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Execute ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next


Sepi

Sepi
Previous (TSepiUnitLoadTask)
Next (TSepiVariable)

Name
TSepiUntypedType

Parent
SepiReflectionCore

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type non typé

Members
Methods
Method | Description
CompatibleWith (+) | [@inheritDoc]
Create (+) | Crée une instance de TSepiUntypedType
Equals (+) | [@inheritDoc]
GetAlignment (#) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUnitLoadTask)
Next (TSepiVariable)


Sepi

Sepi
Previous
Next (Create)

Name
CompatibleWith

Parent
TSepiUntypedType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function CompatibleWith ( AType : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
AType : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (CompatibleWith)
Next (Equals)

Name
Create

Parent
TSepiUntypedType

Visibility
PUBLIC

Description
Crée une instance de TSepiUntypedType

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire
AName : STRING | Nom du type

Sepi
Class Tree
Index
Previous (CompatibleWith)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (GetAlignment)

Name
Equals

Parent
TSepiUntypedType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetAlignment)


Sepi

Sepi
Previous (Equals)
Next (GetDescription)

Name
GetAlignment

Parent
TSepiUntypedType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetDescription)


Sepi

Sepi
Previous (GetAlignment)
Next (SetupProperties)

Name
GetDescription

Parent
TSepiUntypedType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAlignment)
Next (SetupProperties)


Sepi

Sepi
Previous (GetDescription)
Next

Name
SetupProperties

Parent
TSepiUntypedType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetDescription)
Next


Sepi

Sepi
Previous (TSepiUntypedType)
Next

Name
TSepiVariable

Parent
SepiReflectionCore

Class Hierarchy
TSepiMember

Visibility
PUBLIC

Description
Variable (ou constante typée)
TSepiVariable est aussi la classe utilisée pour les champs de classe, ce qui
explique qu'elle hérite de TSepiMember.

Members
Fields
Field | Description
FIsConst (-) | Indique si la variable est une constante typée
FOwnValue (-) | Indique si Sepi a alloué la variable
FType (-) | Type de la constante
FValue (-) | Pointeur sur la variable

Methods
Method | Description
Create (+) | Importe une variable ou constante typée native
Create (+) | Crée une nouvelle variable ou constante typée
Destroy (+) | [@inheritDoc]
Destroying (#) | [@inheritDoc]
ListReferences (#) | [@inheritDoc]
Load (+) | Charge une variable ou une constante typée depuis un flux
Save (#) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]

Properties
Property | Description
IsConst (+) | Indique si la variable est une constante typée
Value (+) | Pointeur sur la variable
VarType (+) | Type de la constante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUntypedType)
Next


Sepi

Sepi
Previous
Next (FOwnValue)

Name
FIsConst

Parent
TSepiVariable

Visibility
PRIVATE

Description
Indique si la variable est une constante typée

Source code
FIsConst : Boolean

Sepi
Class Tree
Index
Previous
Next (FOwnValue)


Sepi

Sepi
Previous (FIsConst)
Next (FType)

Name
FOwnValue

Parent
TSepiVariable

Visibility
PRIVATE

Description
Indique si Sepi a alloué la variable

Source code
FOwnValue : Boolean

Sepi
Class Tree
Index
Previous (FIsConst)
Next (FType)


Sepi

Sepi
Previous (FOwnValue)
Next (FValue)

Name
FType

Parent
TSepiVariable

Visibility
PRIVATE

Description
Type de la constante

Source code
FType : TSepiType

Sepi
Class Tree
Index
Previous (FOwnValue)
Next (FValue)


Sepi

Sepi
Previous (FType)
Next

Name
FValue

Parent
TSepiVariable

Visibility
PRIVATE

Description
Pointeur sur la variable

Source code
FValue : Pointer

Sepi
Class Tree
Index
Previous (FType)
Next


Sepi

Sepi
Previous
Next (Value)

Name
IsConst

Parent
TSepiVariable

Visibility
PUBLIC

Description
Indique si la variable est une constante typée

Source code
property IsConst : Boolean read FIsConst

Read Access
FIsConst

Sepi
Class Tree
Index
Previous
Next (Value)


Sepi

Sepi
Previous (IsConst)
Next (VarType)

Name
Value

Parent
TSepiVariable

Visibility
PUBLIC

Description
Pointeur sur la variable

Source code
property Value : Pointer read FValue

Read Access
FValue

Sepi
Class Tree
Index
Previous (IsConst)
Next (VarType)


Sepi

Sepi
Previous (Value)
Next

Name
VarType

Parent
TSepiVariable

Visibility
PUBLIC

Description
Type de la constante

Source code
property VarType : TSepiType read FType

Read Access
FType

Sepi
Class Tree
Index
Previous (Value)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Create

Parent
TSepiVariable

Visibility
PUBLIC

Description
Importe une variable ou constante typée native

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; const AValue ; AType : TSepiType ; AIsConst : Boolean = False ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la variable
AName : STRING | Nom de la variable
AValue : Untyped | Valeur de la variable
AType : TSepiType | Type de la variable
AIsConst : BOOLEAN | Indique si c'est une constante typée

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TSepiVariable

Visibility
PUBLIC

Description
Crée une nouvelle variable ou constante typée

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AType : TSepiType ; AIsConst : Boolean = False ) ; overload

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de la variable
AName : STRING | Nom de la variable
AType : TSepiType | Type de la variable
AIsConst : BOOLEAN | Indique si c'est une constante typée

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Destroying)

Name
Destroy

Parent
TSepiVariable

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Destroying)


Sepi

Sepi
Previous (Destroy)
Next (ListReferences)

Name
Destroying

Parent
TSepiVariable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Destroying ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next (ListReferences)


Sepi

Sepi
Previous (Destroying)
Next (Load)

Name
ListReferences

Parent
TSepiVariable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ListReferences ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroying)
Next (Load)


Sepi

Sepi
Previous (ListReferences)
Next (Save)

Name
Load

Parent
TSepiVariable

Visibility
PUBLIC

Description
Charge une variable ou une constante typée depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ListReferences)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (WriteDigestData)

Name
Save

Parent
TSepiVariable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (WriteDigestData)


Sepi

Sepi
Previous (Save)
Next

Name
WriteDigestData

Parent
TSepiVariable

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Save)
Next


Sepi

Sepi
Previous
Next (TGetTypeInfoEvent)

Name
TGetMethodCodeEvent

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Type de l'événement OnGetMethodCode de TSepiUnit

Source code
TGetMethodCodeEvent = procedure ( Sender : TObject ; var Code : Pointer ; var CodeHandler : TObject ) of object ;

Parameters
Parameter | Description
Sender : TObject | Méthode déclenchant l'événement (toujours TSepiMethod)
Code : Pointer | Adresse de code de la méthode
CodeHandler : TObject | Gestionnaire de code

Sepi
Class Tree
Index
Previous
Next (TGetTypeInfoEvent)


Sepi

Sepi
Previous (TGetMethodCodeEvent)
Next (TGetVarAddressEvent)

Name
TGetTypeInfoEvent

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Type de l'événement OnGetTypeInfo de TSepiUnit
Si TypeInfo est laissé à nil et si Found est laissé à False, Sepi créera
ses propres RTTI pour le type. Ce cas ne devrait se présenter que pour des
types anonymes pour lesquels le code est incapable de trouver les RTTI
natives.

Source code
TGetTypeInfoEvent = procedure ( Sender : TObject ; var TypeInfo : PTypeInfo ; var Found : Boolean ) of object ;

Parameters
Parameter | Description
Sender : TObject | Type déclenchant l'événement (toujours TSepiType)
TypeInfo : PTypeInfo | RTTI du type
Found : BOOLEAN | Positionnez à True si les RTTI ont été trouvées

Sepi
Class Tree
Index
Previous (TGetMethodCodeEvent)
Next (TGetVarAddressEvent)


Sepi

Sepi
Previous (TGetTypeInfoEvent)
Next (TMemberVisibility)

Name
TGetVarAddressEvent

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Type de l'événement OnGetVarAddress de TSepiUnit
Si VarAddress est laissée à nil, Sepi allouera lui-même un espace mémoire
pour la variable. Cela ne devrait toutefois normalement jamais arriver.

Source code
TGetVarAddressEvent = procedure ( Sender : TObject ; var VarAddress : Pointer ) of object ;

Parameters
Parameter | Description
Sender : TObject | Variable déclenchant l'événement (type TSepiVariable)
VarAddress : Pointer | Adresse de la variable

Sepi
Class Tree
Index
Previous (TGetTypeInfoEvent)
Next (TMemberVisibility)


Sepi

Sepi
Previous (TGetVarAddressEvent)
Next (TSepiComponentState)

Name
TMemberVisibility

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Visibilité d'un composant

Source code
TMemberVisibility = ( mvStrictPrivate , mvPrivate , mvStrictProtected , mvProtected , mvPublic , mvPublished ) ;

Sepi
Class Tree
Index
Previous (TGetVarAddressEvent)
Next (TSepiComponentState)


Sepi

Sepi
Previous (TMemberVisibility)
Next (TSepiDigest)

Name
TSepiComponentState

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
État d'un composant

Source code
TSepiComponentState = ( msForward , msLoading , msConstructing , msNormal , msDestroying ) ;

Sepi
Class Tree
Index
Previous (TMemberVisibility)
Next (TSepiDigest)


Sepi

Sepi
Previous (TSepiComponentState)
Next (TSepiImportUnitFunc)

Name
TSepiDigest

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Digest de compatibilité d'un composant Sepi

Source code
TSepiDigest = TMD5Digest ;

Sepi
Class Tree
Index
Previous (TSepiComponentState)
Next (TSepiImportUnitFunc)


Sepi

Sepi
Previous (TSepiDigest)
Next (TSepiLazyLoadChildKind)

Name
TSepiImportUnitFunc

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Type de routine call-back pour l'import d'une unité sous Sepi

Source code
TSepiImportUnitFunc = function ( Root : TSepiRoot ) : TSepiUnit ;

Parameters
Parameter | Description
Root : TSepiRoot | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiUnit | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (TSepiDigest)
Next (TSepiLazyLoadChildKind)


Sepi

Sepi
Previous (TSepiImportUnitFunc)
Next (TSepiLazyLoadChildrenData)

Name
TSepiLazyLoadChildKind

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Type d'enfant pour le lazy-load
- ckOther : autre
- ckClass : classe
- ckInterface : interface

Source code
TSepiLazyLoadChildKind = ( ckOther , ckClass , ckInterface ) ;

Sepi
Class Tree
Index
Previous (TSepiImportUnitFunc)
Next (TSepiLazyLoadChildrenData)


Sepi

Sepi
Previous (TSepiLazyLoadChildKind)
Next (TSepiLoadUnitEvent)

Name
TSepiLazyLoadChildrenData

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Tableau de données lazy-load pour les enfants

Source code
TSepiLazyLoadChildrenData = array of TSepiLazyLoadChildData ;

Sepi
Class Tree
Index
Previous (TSepiLazyLoadChildKind)
Next (TSepiLoadUnitEvent)


Sepi

Sepi
Previous (TSepiLazyLoadChildrenData)
Next (TSepiTypeResultBehavior)

Name
TSepiLoadUnitEvent

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Type de l'événement OnLoadUnit de TSepiRoot

Source code
TSepiLoadUnitEvent = function ( Sender : TSepiRoot ; const UnitName : string ) : TSepiUnit of object ;

Parameters
Parameter | Description
Sender : TSepiRoot | Racine Sepi qui demande le chargement d'une unité
UnitName : STRING | Nom de l'unité à charger

Return
Types | Description
TSepiUnit | L'unité chargée, ou nil si l'unité n'est pas trouvée

Sepi
Class Tree
Index
Previous (TSepiLazyLoadChildrenData)
Next (TSepiTypeResultBehavior)


Sepi

Sepi
Previous (TSepiLoadUnitEvent)
Next

Name
TSepiTypeResultBehavior

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Comportement d'un type lorsqu'il est valeur de retour
- rbNone : pas de résultat (procédure)
- rbOrdinal : renvoyé comme un ordinal, via EAX
- rbInt64 : renvoyé comme Int64, via EDX:EAX
- rbSingle : renvoyé comme Single, via ST(0)
- rbDouble : renvoyé comme Double, via ST(0)
- rbExtended : renvoyé comme Extended, via ST(0)
- rbCurrency : renvoyé comme Currency, via ST(0)
- rbParameter : l'adresse du résultat est passée en paramètre

Source code
TSepiTypeResultBehavior = ( rbNone , rbOrdinal , rbInt64 , rbSingle , rbDouble , rbExtended , rbCurrency , rbParameter ) ;

Sepi
Class Tree
Index
Previous (TSepiLoadUnitEvent)
Next


Sepi

Sepi
Previous
Next (SystemUnitName)

Name
DefaultTypeParamBehavior

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Comportement par des défaut d'un type comme paramètre

Source code
DefaultTypeParamBehavior : TSepiTypeParamBehavior = ( AlwaysByAddress : False ; AlwaysByStack : False )

Sepi
Class Tree
Index
Previous
Next (SystemUnitName)


Sepi

Sepi
Previous (DefaultTypeParamBehavior)
Next (VisibilityStrings)

Name
SystemUnitName

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Nom de l'unité System.pas

Source code
SystemUnitName = 'System'

Sepi
Class Tree
Index
Previous (DefaultTypeParamBehavior)
Next (VisibilityStrings)


Sepi

Sepi
Previous (SystemUnitName)
Next

Name
VisibilityStrings

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Chaînes des visibilités

Source code
VisibilityStrings : array [ TMemberVisibility ] of string = ( 'strict private' , 'private' , 'strict protected' , 'protected' , 'public' , 'published' )

Sepi
Class Tree
Index
Previous (SystemUnitName)
Next


Sepi

Sepi
Previous
Next (SepiRegisterComponentClasses)

Name
SepiImportedUnit

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Cherche une routine d'import d'une unité
Cette routine doit avoir été recensée au prélable avec
SepiRegisterImportedUnit.

Source code
function SepiImportedUnit ( const UnitName : string ) : TSepiImportUnitFunc

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité

Return
Types | Description
TSepiImportUnitFunc | Routine de call-back pour l'import de l'unité, ou nil si n'existe pas

Sepi
Class Tree
Index
Previous
Next (SepiRegisterComponentClasses)


Sepi

Sepi
Previous (SepiImportedUnit)
Next (SepiRegisterImportedUnit)

Name
SepiRegisterComponentClasses

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Recense des classes de composants Sepi

Source code
procedure SepiRegisterComponentClasses ( const ComponentClasses : array of TSepiComponentClass )

Parameters
Parameter | Description
ComponentClasses : TSepiComponentClass | Classes de composants à recenser

Sepi
Class Tree
Index
Previous (SepiImportedUnit)
Next (SepiRegisterImportedUnit)


Sepi

Sepi
Previous (SepiRegisterComponentClasses)
Next (SepiUnregisterImportedUnit)

Name
SepiRegisterImportedUnit

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Recense une routine d'import d'unité

Source code
procedure SepiRegisterImportedUnit ( const UnitName : string ; ImportFunc : TSepiImportUnitFunc )

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité
ImportFunc : TSepiImportUnitFunc | Routine de call-back pour l'import de l'unité

Sepi
Class Tree
Index
Previous (SepiRegisterComponentClasses)
Next (SepiUnregisterImportedUnit)


Sepi

Sepi
Previous (SepiRegisterImportedUnit)
Next

Name
SepiUnregisterImportedUnit

Parent
SepiReflectionCore

Visibility
PUBLIC

Description
Supprime un recensement d'import d'unité

Source code
procedure SepiUnregisterImportedUnit ( const UnitName : string )

Parameters
Parameter | Description
UnitName : STRING | Nom de l'unité

Sepi
Class Tree
Index
Previous (SepiRegisterImportedUnit)
Next


Sepi

Sepi
Previous (SepiReflectionCore)
Next (SepiRuntimeOperations)

Name
SepiRuntime

Parent
Sepi

Description
Interpréteur Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TLocalParams (+) | Informations de recopiage des paramètres locaux
TSepiDebugEvent (+) | Type d'un événement déclenché pour le débogage d'un code Sepi

Constants
Constant Description

Variables
Variable Description

Methods
Method Description

Classes
Class | Description
TLocalParam (+) | Informations de recopiage d'un paramètre local
TSepiRuntimeContext (+) | Contexte d'exécution Sepi
TSepiRuntimeMethod (+) | Méthode d'exécution Sepi
TSepiRuntimeUnit (+) | Unité d'exécution Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiReflectionCore)
Next (SepiRuntimeOperations)


Sepi

Sepi
Previous
Next (TSepiRuntimeContext)

Name
TLocalParam

Parent
SepiRuntime

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Informations de recopiage d'un paramètre local

Members
Fields
Field | Description
LocalOffset (*) | Offset dans les paramètres locaux
Size (*) | Taille du paramètre
StackOffset (*) | Offset dans la pile

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiRuntimeContext)


Sepi

Sepi
Previous
Next (Size)

Name
LocalOffset

Parent
TLocalParam

Visibility
PUBLISHED

Description
Offset dans les paramètres locaux

Source code
LocalOffset : Integer

Sepi
Class Tree
Index
Previous
Next (Size)


Sepi

Sepi
Previous (LocalOffset)
Next (StackOffset)

Name
Size

Parent
TLocalParam

Visibility
PUBLISHED

Description
Taille du paramètre

Source code
Size : Integer

Sepi
Class Tree
Index
Previous (LocalOffset)
Next (StackOffset)


Sepi

Sepi
Previous (Size)
Next

Name
StackOffset

Parent
TLocalParam

Visibility
PUBLISHED

Description
Offset dans la pile

Source code
StackOffset : Integer

Sepi
Class Tree
Index
Previous (Size)
Next


Sepi

Sepi
Previous (TLocalParam)
Next (TSepiRuntimeMethod)

Name
TSepiRuntimeContext

Parent
SepiRuntime

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Contexte d'exécution Sepi

Members
Fields
Field | Description
FInstructions (-) | Instructions
FLocals (-) | Variables locales
FParameters (-) | Paramètres
FRuntimeMethod (-) | Méthode d'exécution
FRuntimeUnit (-) | Unité d'exécution

Methods
Method | Description
Create (+) | Crée un contexte d'exécution Sepi
Execute (+) | Exécute les instructions jusqu'à sortir du bloc
GetNextInstruction (-) | Pointeur sur la prochaine instruction à exécuter
OpCodeAddressCall (-) | OpCode BasicCall
OpCodeAsClass (-) | OpCode AsClass
OpCodeCompare (-) | OpCode de comparaison
OpCodeConvert (-) | OpCode Convert
OpCodeDynamicCall (-) | OpCode DynamicCall
OpCodeDynArrayCopy (-) | OpCode DACP version tableau entier
OpCodeDynArrayCopyRange (-) | OpCode DACP version range
OpCodeDynArraySetLength (-) | OpCode DASL
OpCodeGetDelphiClass (-) | OpCode GetDelphiClass
OpCodeGetMethodCode (-) | OpCode GetMethodCode
OpCodeGetTypeInfo (-) | OpCode GetTypeInfo
OpCodeIsClass (-) | OpCode IsClass
OpCodeJump (-) | OpCode Jump
OpCodeJumpIf (-) | OpCode Jump If (True or False)
OpCodeLoadAddress (-) | OpCode LoadAddress
OpCodeMoveFixed (-) | OpCode MoveSome et MoveMany
OpCodeMoveOther (-) | OpCode MoveOther
OpCodeMultiOn (-) | OpCode MultiOn
OpCodeNope (-) | OpCode Nope
OpCodeOtherBinaryOp (-) | Opérations binaires sur un autre
OpCodeOtherUnaryOp (-) | Opérations unaires sur un autre
OpCodeRaise (-) | OpCode Raise
OpCodeReraise (-) | OpCode Reraise
OpCodeSelfBinaryOp (-) | Opérations binaires sur soi-même
OpCodeSelfUnaryOp (-) | Opérations unaires sur soi-même
OpCodeSetCmpOp (-) | OpCode SetEquals, SetNotEquals ou SetContained
OpCodeSetElem (-) | OpCode SetElem
OpCodeSetExpand (-) | OpCode SetExpand
OpCodeSetIn (-) | OpCode SetIn
OpCodeSetIncludeExclude (-) | OpCode SetInclude ou SetExclude
OpCodeSetOtherOp (-) | OpCode SetOtherIntersect, SetOtherUnion, SetOtherSubract
OpCodeSetRange (-) | OpCode SetRange
OpCodeSetSelfOp (-) | OpCode SetSelfIntersect, SetSelfUnion ou SetSelfSubtract
OpCodeSimpleMove (-) | OpCode Move
OpCodeStaticCall (-) | OpCode StaticCall
OpCodeStrCopy (-) | OpCode ASCP et WSCP
OpCodeStrSetLength (-) | OpCode ASSL et WSSL
OpCodeTryExcept (-) | OpCode BeginTryExcept
OpCodeTryFinally (-) | OpCode BeginTryFinally
OpCodeValueToIntStdFunction (-) | OpCode ASL, WSL, DAL et DAH
ReadAddress (-) | Lit l'adresse d'une zone mémoire depuis le flux d'instructions
ReadAddressOperation (-) | Lit une opération sur une adresse et l'applique à une adresse donnée
ReadBaseAddress (-) | Lit une adresse de base depuis les instructions
ReadClassValue (-) | Lit une valeur de type classe (TClass)
ReadParamsAndCall (-) | Lit les paramètres (et résultat) depuis les instructions et fait l'appel
UnknownOpCode (-) | OpCode inconnu

Properties
Property | Description
Instructions (-) | Instructions
Locals (+) | Variables locales
NextInstruction (+) | Pointeur sur la prochaine instruction à exécuter
Parameters (+) | Paramètres
RuntimeMethod (+) | Méthode d'exécution
RuntimeUnit (+) | Unité d'exécution

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TLocalParam)
Next (TSepiRuntimeMethod)


Sepi

Sepi
Previous
Next (FLocals)

Name
FInstructions

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Instructions

Source code
FInstructions : TAbsoluteMemoryStream

Sepi
Class Tree
Index
Previous
Next (FLocals)


Sepi

Sepi
Previous (FInstructions)
Next (FParameters)

Name
FLocals

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Variables locales

Source code
FLocals : Pointer

Sepi
Class Tree
Index
Previous (FInstructions)
Next (FParameters)


Sepi

Sepi
Previous (FLocals)
Next (FRuntimeMethod)

Name
FParameters

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Paramètres

Source code
FParameters : Pointer

Sepi
Class Tree
Index
Previous (FLocals)
Next (FRuntimeMethod)


Sepi

Sepi
Previous (FParameters)
Next (FRuntimeUnit)

Name
FRuntimeMethod

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Méthode d'exécution

Source code
FRuntimeMethod : TSepiRuntimeMethod

Sepi
Class Tree
Index
Previous (FParameters)
Next (FRuntimeUnit)


Sepi

Sepi
Previous (FRuntimeMethod)
Next

Name
FRuntimeUnit

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Unité d'exécution

Source code
FRuntimeUnit : TSepiRuntimeUnit

Sepi
Class Tree
Index
Previous (FRuntimeMethod)
Next


Sepi

Sepi
Previous
Next (Locals)

Name
Instructions

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Instructions

Source code
property Instructions : TAbsoluteMemoryStream read FInstructions

Read Access
FInstructions

Sepi
Class Tree
Index
Previous
Next (Locals)


Sepi

Sepi
Previous (Instructions)
Next (NextInstruction)

Name
Locals

Parent
TSepiRuntimeContext

Visibility
PUBLIC

Description
Variables locales

Source code
property Locals : Pointer read FLocals

Read Access
FLocals

Sepi
Class Tree
Index
Previous (Instructions)
Next (NextInstruction)


Sepi

Sepi
Previous (Locals)
Next (Parameters)

Name
NextInstruction

Parent
TSepiRuntimeContext

Visibility
PUBLIC

Description
Pointeur sur la prochaine instruction à exécuter

Source code
property NextInstruction : Pointer read GetNextInstruction

Read Access
GetNextInstruction

Sepi
Class Tree
Index
Previous (Locals)
Next (Parameters)


Sepi

Sepi
Previous (NextInstruction)
Next (RuntimeMethod)

Name
Parameters

Parent
TSepiRuntimeContext

Visibility
PUBLIC

Description
Paramètres

Source code
property Parameters : Pointer read FParameters

Read Access
FParameters

Sepi
Class Tree
Index
Previous (NextInstruction)
Next (RuntimeMethod)


Sepi

Sepi
Previous (Parameters)
Next (RuntimeUnit)

Name
RuntimeMethod

Parent
TSepiRuntimeContext

Visibility
PUBLIC

Description
Méthode d'exécution

Source code
property RuntimeMethod : TSepiRuntimeMethod read FRuntimeMethod

Read Access
FRuntimeMethod

Sepi
Class Tree
Index
Previous (Parameters)
Next (RuntimeUnit)


Sepi

Sepi
Previous (RuntimeMethod)
Next

Name
RuntimeUnit

Parent
TSepiRuntimeContext

Visibility
PUBLIC

Description
Unité d'exécution

Source code
property RuntimeUnit : TSepiRuntimeUnit read FRuntimeUnit

Read Access
FRuntimeUnit

Sepi
Class Tree
Index
Previous (RuntimeMethod)
Next


Sepi

Sepi
Previous
Next (Execute)

Name
Create

Parent
TSepiRuntimeContext

Visibility
PUBLIC

Description
Crée un contexte d'exécution Sepi

Source code
constructor Create ( ARuntimeMethod : TSepiRuntimeMethod ; AInstructions : TAbsoluteMemoryStream ; AParameters , ALocals : Pointer )

Parameters
Parameter | Description
ARuntimeMethod : TSepiRuntimeMethod
AInstructions : TAbsoluteMemoryStream | Pointeur sur le code Sepi
AParameters : Pointer | Paramètres
ALocals : Pointer | Variables locales

Sepi
Class Tree
Index
Previous
Next (Execute)


Sepi

Sepi
Previous (Create)
Next (GetNextInstruction)

Name
Execute

Parent
TSepiRuntimeContext

Visibility
PUBLIC

Description
Exécute les instructions jusqu'à sortir du bloc

Source code
procedure Execute ( BlockBegin , BlockEnd : Pointer )

Parameters
Parameter | Description
BlockBegin : Pointer | Début du bloc
BlockEnd : Pointer | Fin du bloc

Sepi
Class Tree
Index
Previous (Create)
Next (GetNextInstruction)


Sepi

Sepi
Previous (Execute)
Next (OpCodeAddressCall)

Name
GetNextInstruction

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Pointeur sur la prochaine instruction à exécuter

Source code
function GetNextInstruction : Pointer

Parameters
Parameter Description

Return
Types | Description
Pointer | Pointeur sur la prochaine instruction à exécuter

Sepi
Class Tree
Index
Previous (Execute)
Next (OpCodeAddressCall)


Sepi

Sepi
Previous (GetNextInstruction)
Next (OpCodeAsClass)

Name
OpCodeAddressCall

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode BasicCall

Source code
procedure OpCodeAddressCall ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (GetNextInstruction)
Next (OpCodeAsClass)


Sepi

Sepi
Previous (OpCodeAddressCall)
Next (OpCodeCompare)

Name
OpCodeAsClass

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode AsClass

Source code
procedure OpCodeAsClass ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeAddressCall)
Next (OpCodeCompare)


Sepi

Sepi
Previous (OpCodeAsClass)
Next (OpCodeConvert)

Name
OpCodeCompare

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode de comparaison

Source code
procedure OpCodeCompare ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeAsClass)
Next (OpCodeConvert)


Sepi

Sepi
Previous (OpCodeCompare)
Next (OpCodeDynamicCall)

Name
OpCodeConvert

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode Convert

Source code
procedure OpCodeConvert ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeCompare)
Next (OpCodeDynamicCall)


Sepi

Sepi
Previous (OpCodeConvert)
Next (OpCodeDynArrayCopy)

Name
OpCodeDynamicCall

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode DynamicCall

Source code
procedure OpCodeDynamicCall ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeConvert)
Next (OpCodeDynArrayCopy)


Sepi

Sepi
Previous (OpCodeDynamicCall)
Next (OpCodeDynArrayCopyRange)

Name
OpCodeDynArrayCopy

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode DACP version tableau entier

Source code
procedure OpCodeDynArrayCopy ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeDynamicCall)
Next (OpCodeDynArrayCopyRange)


Sepi

Sepi
Previous (OpCodeDynArrayCopy)
Next (OpCodeDynArraySetLength)

Name
OpCodeDynArrayCopyRange

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode DACP version range

Source code
procedure OpCodeDynArrayCopyRange ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeDynArrayCopy)
Next (OpCodeDynArraySetLength)


Sepi

Sepi
Previous (OpCodeDynArrayCopyRange)
Next (OpCodeGetDelphiClass)

Name
OpCodeDynArraySetLength

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode DASL

Source code
procedure OpCodeDynArraySetLength ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeDynArrayCopyRange)
Next (OpCodeGetDelphiClass)


Sepi

Sepi
Previous (OpCodeDynArraySetLength)
Next (OpCodeGetMethodCode)

Name
OpCodeGetDelphiClass

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode GetDelphiClass

Source code
procedure OpCodeGetDelphiClass ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeDynArraySetLength)
Next (OpCodeGetMethodCode)


Sepi

Sepi
Previous (OpCodeGetDelphiClass)
Next (OpCodeGetTypeInfo)

Name
OpCodeGetMethodCode

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode GetMethodCode

Source code
procedure OpCodeGetMethodCode ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeGetDelphiClass)
Next (OpCodeGetTypeInfo)


Sepi

Sepi
Previous (OpCodeGetMethodCode)
Next (OpCodeIsClass)

Name
OpCodeGetTypeInfo

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode GetTypeInfo

Source code
procedure OpCodeGetTypeInfo ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeGetMethodCode)
Next (OpCodeIsClass)


Sepi

Sepi
Previous (OpCodeGetTypeInfo)
Next (OpCodeJump)

Name
OpCodeIsClass

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode IsClass

Source code
procedure OpCodeIsClass ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeGetTypeInfo)
Next (OpCodeJump)


Sepi

Sepi
Previous (OpCodeIsClass)
Next (OpCodeJumpIf)

Name
OpCodeJump

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode Jump

Source code
procedure OpCodeJump ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeIsClass)
Next (OpCodeJumpIf)


Sepi

Sepi
Previous (OpCodeJump)
Next (OpCodeLoadAddress)

Name
OpCodeJumpIf

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode Jump If (True or False)

Source code
procedure OpCodeJumpIf ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeJump)
Next (OpCodeLoadAddress)


Sepi

Sepi
Previous (OpCodeJumpIf)
Next (OpCodeMoveFixed)

Name
OpCodeLoadAddress

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode LoadAddress

Source code
procedure OpCodeLoadAddress ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeJumpIf)
Next (OpCodeMoveFixed)


Sepi

Sepi
Previous (OpCodeLoadAddress)
Next (OpCodeMoveOther)

Name
OpCodeMoveFixed

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode MoveSome et MoveMany

Source code
procedure OpCodeMoveFixed ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeLoadAddress)
Next (OpCodeMoveOther)


Sepi

Sepi
Previous (OpCodeMoveFixed)
Next (OpCodeMultiOn)

Name
OpCodeMoveOther

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode MoveOther

Source code
procedure OpCodeMoveOther ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeMoveFixed)
Next (OpCodeMultiOn)


Sepi

Sepi
Previous (OpCodeMoveOther)
Next (OpCodeNope)

Name
OpCodeMultiOn

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode MultiOn

Source code
procedure OpCodeMultiOn ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeMoveOther)
Next (OpCodeNope)


Sepi

Sepi
Previous (OpCodeMultiOn)
Next (OpCodeOtherBinaryOp)

Name
OpCodeNope

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode Nope

Source code
procedure OpCodeNope ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeMultiOn)
Next (OpCodeOtherBinaryOp)


Sepi

Sepi
Previous (OpCodeNope)
Next (OpCodeOtherUnaryOp)

Name
OpCodeOtherBinaryOp

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Opérations binaires sur un autre

Source code
procedure OpCodeOtherBinaryOp ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeNope)
Next (OpCodeOtherUnaryOp)


Sepi

Sepi
Previous (OpCodeOtherBinaryOp)
Next (OpCodeRaise)

Name
OpCodeOtherUnaryOp

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Opérations unaires sur un autre

Source code
procedure OpCodeOtherUnaryOp ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeOtherBinaryOp)
Next (OpCodeRaise)


Sepi

Sepi
Previous (OpCodeOtherUnaryOp)
Next (OpCodeReraise)

Name
OpCodeRaise

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode Raise

Source code
procedure OpCodeRaise ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeOtherUnaryOp)
Next (OpCodeReraise)


Sepi

Sepi
Previous (OpCodeRaise)
Next (OpCodeSelfBinaryOp)

Name
OpCodeReraise

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode Reraise

Source code
procedure OpCodeReraise ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeRaise)
Next (OpCodeSelfBinaryOp)


Sepi

Sepi
Previous (OpCodeReraise)
Next (OpCodeSelfUnaryOp)

Name
OpCodeSelfBinaryOp

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Opérations binaires sur soi-même

Source code
procedure OpCodeSelfBinaryOp ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeReraise)
Next (OpCodeSelfUnaryOp)


Sepi

Sepi
Previous (OpCodeSelfBinaryOp)
Next (OpCodeSetCmpOp)

Name
OpCodeSelfUnaryOp

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Opérations unaires sur soi-même

Source code
procedure OpCodeSelfUnaryOp ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSelfBinaryOp)
Next (OpCodeSetCmpOp)


Sepi

Sepi
Previous (OpCodeSelfUnaryOp)
Next (OpCodeSetElem)

Name
OpCodeSetCmpOp

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetEquals, SetNotEquals ou SetContained

Source code
procedure OpCodeSetCmpOp ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSelfUnaryOp)
Next (OpCodeSetElem)


Sepi

Sepi
Previous (OpCodeSetCmpOp)
Next (OpCodeSetExpand)

Name
OpCodeSetElem

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetElem

Source code
procedure OpCodeSetElem ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetCmpOp)
Next (OpCodeSetExpand)


Sepi

Sepi
Previous (OpCodeSetElem)
Next (OpCodeSetIn)

Name
OpCodeSetExpand

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetExpand

Source code
procedure OpCodeSetExpand ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetElem)
Next (OpCodeSetIn)


Sepi

Sepi
Previous (OpCodeSetExpand)
Next (OpCodeSetIncludeExclude)

Name
OpCodeSetIn

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetIn

Source code
procedure OpCodeSetIn ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetExpand)
Next (OpCodeSetIncludeExclude)


Sepi

Sepi
Previous (OpCodeSetIn)
Next (OpCodeSetOtherOp)

Name
OpCodeSetIncludeExclude

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetInclude ou SetExclude

Source code
procedure OpCodeSetIncludeExclude ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetIn)
Next (OpCodeSetOtherOp)


Sepi

Sepi
Previous (OpCodeSetIncludeExclude)
Next (OpCodeSetRange)

Name
OpCodeSetOtherOp

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetOtherIntersect, SetOtherUnion, SetOtherSubract

Source code
procedure OpCodeSetOtherOp ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetIncludeExclude)
Next (OpCodeSetRange)


Sepi

Sepi
Previous (OpCodeSetOtherOp)
Next (OpCodeSetSelfOp)

Name
OpCodeSetRange

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetRange

Source code
procedure OpCodeSetRange ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetOtherOp)
Next (OpCodeSetSelfOp)


Sepi

Sepi
Previous (OpCodeSetRange)
Next (OpCodeSimpleMove)

Name
OpCodeSetSelfOp

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode SetSelfIntersect, SetSelfUnion ou SetSelfSubtract

Source code
procedure OpCodeSetSelfOp ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetRange)
Next (OpCodeSimpleMove)


Sepi

Sepi
Previous (OpCodeSetSelfOp)
Next (OpCodeStaticCall)

Name
OpCodeSimpleMove

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode Move

Source code
procedure OpCodeSimpleMove ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSetSelfOp)
Next (OpCodeStaticCall)


Sepi

Sepi
Previous (OpCodeSimpleMove)
Next (OpCodeStrCopy)

Name
OpCodeStaticCall

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode StaticCall

Source code
procedure OpCodeStaticCall ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeSimpleMove)
Next (OpCodeStrCopy)


Sepi

Sepi
Previous (OpCodeStaticCall)
Next (OpCodeStrSetLength)

Name
OpCodeStrCopy

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode ASCP et WSCP

Source code
procedure OpCodeStrCopy ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeStaticCall)
Next (OpCodeStrSetLength)


Sepi

Sepi
Previous (OpCodeStrCopy)
Next (OpCodeTryExcept)

Name
OpCodeStrSetLength

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode ASSL et WSSL

Source code
procedure OpCodeStrSetLength ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeStrCopy)
Next (OpCodeTryExcept)


Sepi

Sepi
Previous (OpCodeStrSetLength)
Next (OpCodeTryFinally)

Name
OpCodeTryExcept

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode BeginTryExcept

Source code
procedure OpCodeTryExcept ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeStrSetLength)
Next (OpCodeTryFinally)


Sepi

Sepi
Previous (OpCodeTryExcept)
Next (OpCodeValueToIntStdFunction)

Name
OpCodeTryFinally

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode BeginTryFinally

Source code
procedure OpCodeTryFinally ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeTryExcept)
Next (OpCodeValueToIntStdFunction)


Sepi

Sepi
Previous (OpCodeTryFinally)
Next (ReadAddress)

Name
OpCodeValueToIntStdFunction

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode ASL, WSL, DAL et DAH

Source code
procedure OpCodeValueToIntStdFunction ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (OpCodeTryFinally)
Next (ReadAddress)


Sepi

Sepi
Previous (OpCodeValueToIntStdFunction)
Next (ReadAddressOperation)

Name
ReadAddress

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Lit l'adresse d'une zone mémoire depuis le flux d'instructions

Source code
function ReadAddress ( Options : TSepiAddressOptions = [ ] ; ConstSize : Integer = 0 ) : Pointer

Parameters
Parameter | Description
Options : TSepiAddressOptions | Options de lecture d'addresse
ConstSize : INTEGER | Taille d'une constante dans le code

Return
Types | Description
Pointer | Adresse lue

Sepi
Class Tree
Index
Previous (OpCodeValueToIntStdFunction)
Next (ReadAddressOperation)


Sepi

Sepi
Previous (ReadAddress)
Next (ReadBaseAddress)

Name
ReadAddressOperation

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Lit une opération sur une adresse et l'applique à une adresse donnée

Source code
procedure ReadAddressOperation ( var Address : Pointer )

Parameters
Parameter | Description
Address : Pointer | Adresse à modifier

Sepi
Class Tree
Index
Previous (ReadAddress)
Next (ReadBaseAddress)


Sepi

Sepi
Previous (ReadAddressOperation)
Next (ReadClassValue)

Name
ReadBaseAddress

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Lit une adresse de base depuis les instructions

Source code
function ReadBaseAddress ( Options : TSepiAddressOptions ; ConstSize : Integer ; MemorySpace : TSepiMemorySpace ) : Pointer

Parameters
Parameter | Description
Options : TSepiAddressOptions | Options de lecture d'addresse
ConstSize : INTEGER | Taille d'une constante dans le code
MemorySpace : TSepiMemorySpace | Espace d'adressage

Return
Types | Description
Pointer | Adresse de base lue

Sepi
Class Tree
Index
Previous (ReadAddressOperation)
Next (ReadClassValue)


Sepi

Sepi
Previous (ReadBaseAddress)
Next (ReadParamsAndCall)

Name
ReadClassValue

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Lit une valeur de type classe (TClass)

Source code
function ReadClassValue : TClass

Parameters
Parameter Description

Return
Types | Description
TClass | Classe lue

Sepi
Class Tree
Index
Previous (ReadBaseAddress)
Next (ReadParamsAndCall)


Sepi

Sepi
Previous (ReadClassValue)
Next (UnknownOpCode)

Name
ReadParamsAndCall

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
Lit les paramètres (et résultat) depuis les instructions et fait l'appel

Source code
procedure ReadParamsAndCall ( Address : Pointer ; CallingConvention : TCallingConvention ; RegUsage : Byte ; ResultBehavior : TSepiTypeResultBehavior ; OrdResultSize : Byte )

Parameters
Parameter | Description
Address : Pointer | Pointeur sur le code de la procédure à appeler
CallingConvention : TCallingConvention | Convention d'appel à utiliser
RegUsage : BYTE | Nombre de registres utilsés
ResultBehavior : TSepiTypeResultBehavior | Comportement du résultat
OrdResultSize : BYTE | Si résultat ordinal, taille en octets de celui-ci

Sepi
Class Tree
Index
Previous (ReadClassValue)
Next (UnknownOpCode)


Sepi

Sepi
Previous (ReadParamsAndCall)
Next

Name
UnknownOpCode

Parent
TSepiRuntimeContext

Visibility
PRIVATE

Description
OpCode inconnu

Source code
procedure UnknownOpCode ( OpCode : TSepiOpCode )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode

Sepi
Class Tree
Index
Previous (ReadParamsAndCall)
Next


Sepi

Sepi
Previous (TSepiRuntimeContext)
Next (TSepiRuntimeUnit)

Name
TSepiRuntimeMethod

Parent
SepiRuntime

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Méthode d'exécution Sepi

Members
Fields
Field | Description
FCode (-) | Code
FCodeSize (-) | Taille du code
FFullName (-) | Nom complet
FLocalParams (-) | Infos de recopiage local des paramètres
FLocalParamsInfo (-) | Infos sur les paramètres recopiés en local
FLocalParamsSize (-) | Taille des paramètres recopiés en local
FLocalsInfo (-) | Informations sur les variables locales
FLocalsSize (-) | Taille des variables locales
FNativeCode (-) | Code natif
FParamsAddRef (-) | Infos sur les paramètres à référencer
FParamsSize (-) | Taille des paramètres
FResultSize (-) | Taille du résultat
FRuntimeUnit (-) | Unité d'exécution
FSepiMethod (-) | Méthode Sepi correspondante

Methods
Method | Description
Create (+) | Charge une méthode d'exécution depuis un flux
Destroy (+) | [@inheritDoc]
Invoke (+) | Invoque la méthode
MakeLocalParams (-) | Construit les informations de recopie locale des paramètres
MakeParamsAddRef (-) | Construit les informations de référencement des paramètres
ReadLocalsInfo (-) | Lit les informations d'init/finit des variables locales depuis un flux
SetSepiMethod (-) | Renseigne la méthode Sepi correspondante

Properties
Property | Description
Code (+) | Code
CodeSize (+) | Taille du code
FullName (+) | Nom complet
LocalsSize (+) | Taille des variables locales
NativeCode (+) | Code natif
ParamsSize (+) | Taille des paramètres
RuntimeUnit (+) | Unité d'exécution
SepiMethod (+) | Méthode Sepi correspondante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRuntimeContext)
Next (TSepiRuntimeUnit)


Sepi

Sepi
Previous
Next (FCodeSize)

Name
FCode

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Code

Source code
FCode : Pointer

Sepi
Class Tree
Index
Previous
Next (FCodeSize)


Sepi

Sepi
Previous (FCode)
Next (FFullName)

Name
FCodeSize

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Taille du code

Source code
FCodeSize : Integer

Sepi
Class Tree
Index
Previous (FCode)
Next (FFullName)


Sepi

Sepi
Previous (FCodeSize)
Next (FLocalParams)

Name
FFullName

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Nom complet

Source code
FFullName : string

Sepi
Class Tree
Index
Previous (FCodeSize)
Next (FLocalParams)


Sepi

Sepi
Previous (FFullName)
Next (FLocalParamsInfo)

Name
FLocalParams

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Infos de recopiage local des paramètres

Source code
FLocalParams : TLocalParams

Sepi
Class Tree
Index
Previous (FFullName)
Next (FLocalParamsInfo)


Sepi

Sepi
Previous (FLocalParams)
Next (FLocalParamsSize)

Name
FLocalParamsInfo

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Infos sur les paramètres recopiés en local

Source code
FLocalParamsInfo : PTypeInfo

Sepi
Class Tree
Index
Previous (FLocalParams)
Next (FLocalParamsSize)


Sepi

Sepi
Previous (FLocalParamsInfo)
Next (FLocalsInfo)

Name
FLocalParamsSize

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Taille des paramètres recopiés en local

Source code
FLocalParamsSize : Integer

Sepi
Class Tree
Index
Previous (FLocalParamsInfo)
Next (FLocalsInfo)


Sepi

Sepi
Previous (FLocalParamsSize)
Next (FLocalsSize)

Name
FLocalsInfo

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Informations sur les variables locales

Source code
FLocalsInfo : PTypeInfo

Sepi
Class Tree
Index
Previous (FLocalParamsSize)
Next (FLocalsSize)


Sepi

Sepi
Previous (FLocalsInfo)
Next (FNativeCode)

Name
FLocalsSize

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Taille des variables locales

Source code
FLocalsSize : Integer

Sepi
Class Tree
Index
Previous (FLocalsInfo)
Next (FNativeCode)


Sepi

Sepi
Previous (FLocalsSize)
Next (FParamsAddRef)

Name
FNativeCode

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Code natif

Source code
FNativeCode : Pointer

Sepi
Class Tree
Index
Previous (FLocalsSize)
Next (FParamsAddRef)


Sepi

Sepi
Previous (FNativeCode)
Next (FParamsSize)

Name
FParamsAddRef

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Infos sur les paramètres à référencer

Source code
FParamsAddRef : PTypeInfo

Sepi
Class Tree
Index
Previous (FNativeCode)
Next (FParamsSize)


Sepi

Sepi
Previous (FParamsAddRef)
Next (FResultSize)

Name
FParamsSize

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Taille des paramètres

Source code
FParamsSize : Integer

Sepi
Class Tree
Index
Previous (FParamsAddRef)
Next (FResultSize)


Sepi

Sepi
Previous (FParamsSize)
Next (FRuntimeUnit)

Name
FResultSize

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Taille du résultat

Source code
FResultSize : Integer

Sepi
Class Tree
Index
Previous (FParamsSize)
Next (FRuntimeUnit)


Sepi

Sepi
Previous (FResultSize)
Next (FSepiMethod)

Name
FRuntimeUnit

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Unité d'exécution

Source code
FRuntimeUnit : TSepiRuntimeUnit

Sepi
Class Tree
Index
Previous (FResultSize)
Next (FSepiMethod)


Sepi

Sepi
Previous (FRuntimeUnit)
Next

Name
FSepiMethod

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Méthode Sepi correspondante

Source code
FSepiMethod : TSepiMethod

Sepi
Class Tree
Index
Previous (FRuntimeUnit)
Next


Sepi

Sepi
Previous
Next (CodeSize)

Name
Code

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Code

Source code
property Code : Pointer read FCode

Read Access
FCode

Sepi
Class Tree
Index
Previous
Next (CodeSize)


Sepi

Sepi
Previous (Code)
Next (FullName)

Name
CodeSize

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Taille du code

Source code
property CodeSize : Integer read FCodeSize

Read Access
FCodeSize

Sepi
Class Tree
Index
Previous (Code)
Next (FullName)


Sepi

Sepi
Previous (CodeSize)
Next (LocalsSize)

Name
FullName

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Nom complet

Source code
property FullName : string read FFullName

Read Access
FFullName

Sepi
Class Tree
Index
Previous (CodeSize)
Next (LocalsSize)


Sepi

Sepi
Previous (FullName)
Next (NativeCode)

Name
LocalsSize

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Taille des variables locales

Source code
property LocalsSize : Integer read FLocalsSize

Read Access
FLocalsSize

Sepi
Class Tree
Index
Previous (FullName)
Next (NativeCode)


Sepi

Sepi
Previous (LocalsSize)
Next (ParamsSize)

Name
NativeCode

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Code natif

Source code
property NativeCode : Pointer read FNativeCode

Read Access
FNativeCode

Sepi
Class Tree
Index
Previous (LocalsSize)
Next (ParamsSize)


Sepi

Sepi
Previous (NativeCode)
Next (RuntimeUnit)

Name
ParamsSize

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Taille des paramètres

Source code
property ParamsSize : Integer read FParamsSize

Read Access
FParamsSize

Sepi
Class Tree
Index
Previous (NativeCode)
Next (RuntimeUnit)


Sepi

Sepi
Previous (ParamsSize)
Next (SepiMethod)

Name
RuntimeUnit

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Unité d'exécution

Source code
property RuntimeUnit : TSepiRuntimeUnit read FRuntimeUnit

Read Access
FRuntimeUnit

Sepi
Class Tree
Index
Previous (ParamsSize)
Next (SepiMethod)


Sepi

Sepi
Previous (RuntimeUnit)
Next

Name
SepiMethod

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Méthode Sepi correspondante

Source code
property SepiMethod : TSepiMethod read FSepiMethod

Read Access
FSepiMethod

Sepi
Class Tree
Index
Previous (RuntimeUnit)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
Create

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Charge une méthode d'exécution depuis un flux

Source code
constructor Create ( AUnit : TSepiRuntimeUnit ; Stream : TStream )

Parameters
Parameter | Description
AUnit : TSepiRuntimeUnit
Stream : TStream | Flux

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (Invoke)

Name
Destroy

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Invoke)


Sepi

Sepi
Previous (Destroy)
Next (MakeLocalParams)

Name
Invoke

Parent
TSepiRuntimeMethod

Visibility
PUBLIC

Description
Invoque la méthode
Le pointeur sur le résultat Result ne doit être renseigné que s'il s'agit
bien d'une fonction, et que le résultat n'est pas transmis par adresse en
tant que paramètre.

Source code
procedure Invoke ( Parameters : Pointer ; Result : Pointer = nil )

Parameters
Parameter | Description
Parameters : Pointer | Pointeur sur les paramètres
Result : Pointer | Pointeur sur le résultat (défaut = nil)

Sepi
Class Tree
Index
Previous (Destroy)
Next (MakeLocalParams)


Sepi

Sepi
Previous (Invoke)
Next (MakeParamsAddRef)

Name
MakeLocalParams

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Construit les informations de recopie locale des paramètres

Source code
procedure MakeLocalParams

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Invoke)
Next (MakeParamsAddRef)


Sepi

Sepi
Previous (MakeLocalParams)
Next (ReadLocalsInfo)

Name
MakeParamsAddRef

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Construit les informations de référencement des paramètres

Source code
procedure MakeParamsAddRef

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeLocalParams)
Next (ReadLocalsInfo)


Sepi

Sepi
Previous (MakeParamsAddRef)
Next (SetSepiMethod)

Name
ReadLocalsInfo

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Lit les informations d'init/finit des variables locales depuis un flux

Source code
procedure ReadLocalsInfo ( Stream : TStream )

Parameters
Parameter | Description
Stream : TStream | Flux source

Sepi
Class Tree
Index
Previous (MakeParamsAddRef)
Next (SetSepiMethod)


Sepi

Sepi
Previous (ReadLocalsInfo)
Next

Name
SetSepiMethod

Parent
TSepiRuntimeMethod

Visibility
PRIVATE

Description
Renseigne la méthode Sepi correspondante

Source code
procedure SetSepiMethod ( AMethod : TSepiMethod )

Parameters
Parameter | Description
AMethod : TSepiMethod | Méthode Sepi

Sepi
Class Tree
Index
Previous (ReadLocalsInfo)
Next


Sepi

Sepi
Previous (TSepiRuntimeMethod)
Next

Name
TSepiRuntimeUnit

Parent
SepiRuntime

Class Hierarchy
TObject

Visibility
PUBLIC

Description
Unité d'exécution Sepi
A sa création, une instance de TSepiRuntimeUnit crée une unité Sepi de type
TSepiUnit. Ensuite, l'unité d'exécution se lie à la l'unité Sepi, de sorte
qu'à la destruction de cette dernière, l'instance de TSepiRuntimeUnit sera
détruite également.
Ainsi, vous devez créer l'instance de TSepiRuntimeUnit, mais détruire
l'instance de TSepiUnit.

Members
Fields
Field | Description
FMethods (-) | Méthodes
FOnDebug (-) | Evénément de débogage
FReferences (-) | Références internes
FSepiUnit (-) | Unité Sepi

Methods
Method | Description
AfterConstruction (+) | [@inheritDoc]
Create (+) | Charge une unité d'exécution depuis un flux
Create (+) | Charge une unité d'exécution depuis un fichier
Destroy (+) | [@inheritDoc]
FindMethod (-) | Cherche une méthode d'exécution depuis son nom
GetMethodCode (-) | Obtient le code d'une méthode
GetMethodCount (-) | Nombre de méthodes
GetMethods (-) | Tableau zero-based des méthodes
ReadRef (+) | Lit une référence depuis un flux

Properties
Property | Description
MethodCount (+) | Nombre de méthodes
Methods (+) | Tableau zero-based des méthodes
OnDebug (+) | Evénément de débogage
SepiUnit (+) | Unité Sepi

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRuntimeMethod)
Next


Sepi

Sepi
Previous
Next (FOnDebug)

Name
FMethods

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Méthodes

Source code
FMethods : TObjectList

Sepi
Class Tree
Index
Previous
Next (FOnDebug)


Sepi

Sepi
Previous (FMethods)
Next (FReferences)

Name
FOnDebug

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Evénément de débogage

Source code
FOnDebug : TSepiDebugEvent

Sepi
Class Tree
Index
Previous (FMethods)
Next (FReferences)


Sepi

Sepi
Previous (FOnDebug)
Next (FSepiUnit)

Name
FReferences

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Références internes

Source code
FReferences : array of TSepiComponent

Sepi
Class Tree
Index
Previous (FOnDebug)
Next (FSepiUnit)


Sepi

Sepi
Previous (FReferences)
Next

Name
FSepiUnit

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Unité Sepi

Source code
FSepiUnit : TSepiUnit

Sepi
Class Tree
Index
Previous (FReferences)
Next


Sepi

Sepi
Previous
Next (Methods)

Name
MethodCount

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
Nombre de méthodes

Source code
property MethodCount : Integer read GetMethodCount

Read Access
GetMethodCount

Sepi
Class Tree
Index
Previous
Next (Methods)


Sepi

Sepi
Previous (MethodCount)
Next (OnDebug)

Name
Methods

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
Tableau zero-based des méthodes

Source code
property Methods [ Index : Integer ] : TSepiRuntimeMethod read GetMethods

Read Access
GetMethods

Sepi
Class Tree
Index
Previous (MethodCount)
Next (OnDebug)


Sepi

Sepi
Previous (Methods)
Next (SepiUnit)

Name
OnDebug

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
Evénément de débogage

Source code
property OnDebug : TSepiDebugEvent read FOnDebug write FOnDebug

Read Access
FOnDebug

Write Access
FOnDebug

Sepi
Class Tree
Index
Previous (Methods)
Next (SepiUnit)


Sepi

Sepi
Previous (OnDebug)
Next

Name
SepiUnit

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
Unité Sepi

Source code
property SepiUnit : TSepiUnit read FSepiUnit

Read Access
FSepiUnit

Sepi
Class Tree
Index
Previous (OnDebug)
Next


Sepi

Sepi
Previous
Next (Create)

Name
AfterConstruction

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure AfterConstruction ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (AfterConstruction)
Next (Create)

Name
Create

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
Charge une unité d'exécution depuis un flux

Source code
constructor Create ( SepiRoot : TSepiRoot ; Stream : TStream ) ; overload

Parameters
Parameter | Description
SepiRoot : TSepiRoot | Racine Sepi
Stream : TStream | Flux

Sepi
Class Tree
Index
Previous (AfterConstruction)
Next (Create)


Sepi

Sepi
Previous (Create)
Next (Destroy)

Name
Create

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
Charge une unité d'exécution depuis un fichier

Source code
constructor Create ( SepiRoot : TSepiRoot ; const FileName : TFileName ) ; overload

Parameters
Parameter | Description
SepiRoot : TSepiRoot | Racine Sepi
FileName : TFileName | Nom du fichier

Sepi
Class Tree
Index
Previous (Create)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (FindMethod)

Name
Destroy

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (FindMethod)


Sepi

Sepi
Previous (Destroy)
Next (GetMethodCode)

Name
FindMethod

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Cherche une méthode d'exécution depuis son nom

Exception
ESepiComponentNotFoundError La méthode n'a pas été trouvée

Source code
function FindMethod ( const QName : string ) : TSepiRuntimeMethod

Parameters
Parameter | Description
QName : STRING | Nom complètement qualifié de la méthode

Return
Types | Description
TSepiRuntimeMethod | Méthode d'exécution correspondante

Sepi
Class Tree
Index
Previous (Destroy)
Next (GetMethodCode)


Sepi

Sepi
Previous (FindMethod)
Next (GetMethodCount)

Name
GetMethodCode

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Obtient le code d'une méthode

Source code
procedure GetMethodCode ( Sender : TObject ; var Code : Pointer ; var CodeHandler : TObject )

Parameters
Parameter | Description
Sender : TObject | Méthode Sepi dont on cherche le code
Code : Pointer | En sortie : code de la méthode
CodeHandler : TObject

Sepi
Class Tree
Index
Previous (FindMethod)
Next (GetMethodCount)


Sepi

Sepi
Previous (GetMethodCode)
Next (GetMethods)

Name
GetMethodCount

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Nombre de méthodes

Source code
function GetMethodCount : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Nombre de méthodes

Sepi
Class Tree
Index
Previous (GetMethodCode)
Next (GetMethods)


Sepi

Sepi
Previous (GetMethodCount)
Next (ReadRef)

Name
GetMethods

Parent
TSepiRuntimeUnit

Visibility
PRIVATE

Description
Tableau zero-based des méthodes

Source code
function GetMethods ( Index : Integer ) : TSepiRuntimeMethod

Parameters
Parameter | Description
INDEX : INTEGER | Index d'une méthode

Return
Types | Description
TSepiRuntimeMethod | Méthode à l'index spécifié

Sepi
Class Tree
Index
Previous (GetMethodCount)
Next (ReadRef)


Sepi

Sepi
Previous (GetMethods)
Next

Name
ReadRef

Parent
TSepiRuntimeUnit

Visibility
PUBLIC

Description
Lit une référence depuis un flux

Source code
procedure ReadRef ( Stream : TStream ; out Ref )

Parameters
Parameter | Description
Stream : TStream | Flux
Ref : Untyped | En sortie : référence lue

Sepi
Class Tree
Index
Previous (GetMethods)
Next


Sepi

Sepi
Previous
Next (TSepiDebugEvent)

Name
TLocalParams

Parent
SepiRuntime

Visibility
PUBLIC

Description
Informations de recopiage des paramètres locaux

Source code
TLocalParams = array of TLocalParam ;

Sepi
Class Tree
Index
Previous
Next (TSepiDebugEvent)


Sepi

Sepi
Previous (TLocalParams)
Next

Name
TSepiDebugEvent

Parent
SepiRuntime

Visibility
PUBLIC

Description
Type d'un événement déclenché pour le débogage d'un code Sepi

Source code
TSepiDebugEvent = procedure ( Context : TSepiRuntimeContext ) of object ;

Parameters
Parameter | Description
Context : TSepiRuntimeContext | Contexte d'exécution du débogage

Sepi
Class Tree
Index
Previous (TLocalParams)
Next


Sepi

Sepi
Previous (SepiRuntime)
Next (SepiStdCompilerNodes)

Name
SepiRuntimeOperations

Parent
Sepi

Description
Opérations sur les variables à l'exécution

Author
sjrd

Version
1.0

Types
Type Description

Variables
Variable Description

Methods
Method | Description
BinaryOp (+) | Opération binaire
Compare (+) | Comparaison de valeurs
ConversionExists (+) | #No TAG found in source code#
Convert (+) | Conversion standard
UnaryOp (+) | Opération unaire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiRuntime)
Next (SepiStdCompilerNodes)


Sepi

Sepi
Previous
Next (Compare)

Name
BinaryOp

Parent
SepiRuntimeOperations

Visibility
PUBLIC

Description
Opération binaire

Source code
procedure BinaryOp ( OpCode : TSepiOpCode ; VarType : TSepiBaseType ; var Dest ; const Left , Right )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode
VarType : TSepiBaseType | Type de variable
Dest : Untyped | Destination
Left : Untyped | Partie gauche
Right : Untyped | Partie droite

Sepi
Class Tree
Index
Previous
Next (Compare)


Sepi

Sepi
Previous (BinaryOp)
Next (ConversionExists)

Name
Compare

Parent
SepiRuntimeOperations

Visibility
PUBLIC

Description
Comparaison de valeurs

Source code
procedure Compare ( OpCode : TSepiOpCode ; VarType : TSepiBaseType ; var Dest ; const Left , Right )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode
VarType : TSepiBaseType | Type des valeurs
Dest : Untyped | Destination
Left : Untyped | Partie gauche de la comparaison
Right : Untyped | Partie droite de la comparaison

Sepi
Class Tree
Index
Previous (BinaryOp)
Next (ConversionExists)


Sepi

Sepi
Previous (Compare)
Next (Convert)

Name
ConversionExists

Parent
SepiRuntimeOperations

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function ConversionExists ( SrcBaseType , DestBaseType : TSepiBaseType ) : Boolean

Parameters
Parameter | Description
SrcBaseType : TSepiBaseType | #Pas de TAG trouvé dans le code source#
DestBaseType : TSepiBaseType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Compare)
Next (Convert)


Sepi

Sepi
Previous (ConversionExists)
Next (UnaryOp)

Name
Convert

Parent
SepiRuntimeOperations

Visibility
PUBLIC

Description
Conversion standard

Source code
procedure Convert ( ToType , FromType : TSepiBaseType ; var Dest ; const Source )

Parameters
Parameter | Description
ToType : TSepiBaseType | Type de destination
FromType : TSepiBaseType | Type source
Dest : Untyped | Destination
Source : Untyped | Source

Sepi
Class Tree
Index
Previous (ConversionExists)
Next (UnaryOp)


Sepi

Sepi
Previous (Convert)
Next

Name
UnaryOp

Parent
SepiRuntimeOperations

Visibility
PUBLIC

Description
Opération unaire

Source code
procedure UnaryOp ( OpCode : TSepiOpCode ; VarType : TSepiBaseType ; var Dest ; const Source )

Parameters
Parameter | Description
OpCode : TSepiOpCode | OpCode
VarType : TSepiBaseType | Type de variable
Dest : Untyped | Destination
Source : Untyped | Source

Sepi
Class Tree
Index
Previous (Convert)
Next


Sepi

Sepi
Previous (SepiRuntimeOperations)
Next (SepiStrTypes)

Name
SepiStdCompilerNodes

Parent
Sepi

Description
Classes de compilation standard d'une unité Sepi

Author
sjrd

Version
1.0

Types
Type | Description
TSepiBinaryOpDirection (+) | Sens d'évaluation d'un opérateur binaire

Constants
Constant | Description
CM_NOTIFYTYPECREATED (+) | #No TAG found in source code#

Classes
Class | Description
TCMNotifyTypeCreated (+) | #No TAG found in source code#
TSepiAbstractMarkerNode (+) | Marqueur abstract
TSepiAddressOfOpNode (+) | Noeud représentant un opérateur unaire d'adressage
TSepiArrayIndicesModifierNode (+) | Noeud index de tableau ou de propriété tableau
TSepiAsOperationNode (+) | Noeud représentant un opérateur as
TSepiAssignmentOpNode (+) | Noeud représentant un opérateur binaire d'assignation
TSepiBeginEndBlockNode (+) | Bloc begin..end
TSepiBinaryOpNode (+) | Noeud représentant un opérateur binaire
TSepiBinaryOpTreeNode (+) | Noeud expression calculé par un arbre d'opérations binaires
TSepiCallingConventionNode (+) | Noeud représentant la convention d'appel d'une signature
TSepiCaseOfClauseNode (+) | Clause on d'un case of
TSepiCaseOfInstructionNode (+) | Instruction case of
TSepiChangeVisibilityNode (+) | Noeud représentant un changement de visibilité
TSepiClassFieldNode (+) | Noeud d'un champ d'une classe
TSepiClassMemberDefinitionNode (+) | Noeud marqueur que ses enfants sont déclarés comme membres de classe
TSepiConstExpressionNode (+) | Noeud expression constante
TSepiConstFloatNode (+) | Noeud représentant une constante littérale flottante
TSepiConstIntegerNode (+) | Noeud représentant une constante littérale entière
TSepiConstStringNode (+) | Noeud représentant une constante littérale chaîne de caractères
TSepiDelphiLikeBinaryOpNode (+) | Noeud représentant un opérateur binaire du style Delphi
TSepiDelphiLikeParametersNode (+) | Noeud paramètres réels de style Delphi
TSepiDelphiLikeUnaryOpNode (+) | Noeud représentant un opérateur unaire du style Delphi
TSepiDereferenceOpNode (+) | Noeud représentant un opérateur unaire de déréférencement
TSepiDoWhileInstructionNode (+) | Instruction do..while
TSepiExceptClauseNode (+) | Clause except d'un try..except.end
TSepiExceptFinallyClauseNode (+) | Suite d'une instruction try..except..end ou try..finally..end
TSepiExceptionVarAndTypeNode (+) | Noeud représentant le nom et le type de la variable exception d'un 'on'
TSepiExecuteExpressionInstructionNode (+) | Instruction d'exécution d'une expression (exécutable)
TSepiExpressionModifierNode (+) | Noeud modifieur d'expression
TSepiExpressionNode (+) | Noeud expression
TSepiExpressionWithModifiersNode (+) | Noeud représentant une expression avec des modificateurs
TSepiFieldSelectionModifierNode (+) | Noeud sélection de champ
TSepiFinallyClauseNode (+) | Clause finally d'un try..except.end
TSepiForControlVarNode (+) | Noeud représentant la variable de contrôle d'une boucle for
TSepiForDownToNode (+) | Noeud indiquant que le for englobant est 'downto'
TSepiForInstructionNode (+) | Instruction for..do
TSepiForToDownToNode (+) | Classe de base pour des noeuds indiquant qu'un for est 'to' ou 'downto'
TSepiForToNode (+) | Noeud indiquant que le for englobant est 'to'
TSepiForwardMarkerNode (+) | Marqueur forward
TSepiIdentifierDeclarationNode (+) | Noeud représentant une déclaration d'un identificateur
TSepiIdentifierDeclListNode (+) | Noeud représentant une liste de déclarations d'identificateurs
TSepiIdentifierExpressionNode (+) | Noeud représentant un identificateur à résoudre
TSepiIfThenElseInstructionNode (+) | Instruction if..then..else
TSepiInheritedExpressionNode (+) | Noeud représentant une expression d'appel inherited
TSepiInitializationExpressionNode (+) | Noeud d'expression d'initialisation
TSepiInSetOperationNode (+) | Noeud représentant un opérateur in
TSepiInstructionListNode (+) | Liste d'instructions
TSepiInstructionNode (+) | Classe de base pour les noeuds instruction
TSepiIntfMethodRedirectorNode (+) | Noeud redirecteur de méthode d'interface
TSepiIsOperationNode (+) | Noeud représentant un opérateur is
TSepiLiteralConstNode (+) | Noeud représentant une constante littérale
TSepiLocalVarNameNode (+) | Noeud représentant le nom d'une variable locale à rechercher
TSepiLocalVarNode (+) | Noeud déclaration de variable locale
TSepiMaybeIdentAndTypeNode (+) | Noeud avec éventuellement un identificateur, mais toujours un type
TSepiMethodBodyNode (+) | Noeud du corps d'une méthode
TSepiMethodDeclarationNode (+) | Noeud déclaration de méthode
TSepiMethodImplementationNode (+) | Noeud méthode dans l'implémentation
TSepiMethodImplHeaderNode (+) | Noeud signature dans l'implémentation
TSepiMethodLinkKindNode (+) | Noeud représentant le type de liaison d'une méthode
TSepiMultiOnElseClauseNode (+) | Clause else d'un multi-on
TSepiMultiOnNode (+) | Instruction multi-on (valide uniquement dans un except)
TSepiNilValueNode (+) | Noeud représentant la valeur spéciale nil
TSepiNoInstructionNode (+) | Noeud "pas d'instruction"
TSepiOnClauseNode (+) | Clause on d'un multi-on
TSepiOverloadMarkerNode (+) | Marqueur overload
TSepiParametersNode (+) | Noeud paramètres réels
TSepiParamIsArrayMarkerNode (+) | Noeud marqueur qu'un paramètre est un tableau ouvert
TSepiParamKindNode (+) | Noeud type de paramètre
TSepiParamNameNode (+) | Noeud nom d'un paramètre
TSepiParamNode (+) | Noeud paramètre
TSepiPropDefaultMarkerNode (+) | Noeud marqueur qu'une propriété est la propriété par défaut
TSepiPropDefaultValueNode (+) | Noeud valeur par défaut d'une propriété
TSepiPropertyBuilderNode (+) | Classe de base pour les noeuds qui construisent une propriété
TSepiPropertyKindNode (+) | Noeud représentant un type de signature pour une propriété
TSepiPropertyNode (+) | Noeud propriété
TSepiPropIndexNode (+) | Noeud index d'une propriété
TSepiPropReadAccessNode (+) | Noeud accesseur en lecture d'une propriété
TSepiPropRedefineMarkerNode (+) | Noeud marqueur qu'une propriété est redéfinie
TSepiPropStorageNode (+) | Noeud spécificateur de stockage d'une propriété
TSepiPropWriteAccessNode (+) | Noeud accesseur en écriture d'une propriété
TSepiPureInheritedExpressionNode (+) | Noeud représentant une expression d'appel inherited pur
TSepiQualifiedIdentNode (+) | Identificateur qualifié
TSepiRaiseInstructionNode (+) | Instruction raise
TSepiRecordCaseHeaderNode (+) | Noeud header de case dans un record
TSepiRecordContentsNode (+) | Noeud descripteur de contenu de record
TSepiRecordFieldNode (+) | Noeud d'un champ de record
TSepiRepeatUntilInstructionNode (+) | Instruction repeat..until (comme do..while mais avec un test inversé)
TSepiSameAsChildExpressionNode (+) | Noeud expression qui vaut la même expression que son unique fils
TSepiSetOrOpenArrayBuilderNode (+) | Noeud constructeur d'ensemble ou de tableau ouvert
TSepiSetValueNode (+) | Noeud valeur ensemble
TSepiSignatureBuilderNode (+) | Classe de base pour les noeuds qui doivent construire une signature
TSepiSignatureKindNode (+) | Noeud représentant un type de signature
TSepiSignatureReturnTypeNode (+) | Noeud représentant le type de retour d'une signature
TSepiStaticMarkerNode (+) | Marqueur static
TSepiTryInstructionNode (+) | Instruction try..except..end ou try..finally..end
TSepiTypeDefinitionNode (+) | Noeud représentant une définition de type
TSepiTypeNameNode (+) | Noeud identifiant un type par son nom
TSepiTypeNode (+) | Noeud représentant un type
TSepiUnaryOperationNode (+) | Noeud expression calculé par une opération unaire
TSepiUnaryOpModifierNode (+) | Noeud modificateur d'expression sur base d'un opérateur unaire
TSepiUnaryOpNode (+) | Noeud représentant un opérateur unaire
TSepiUncheckedIdentifierDeclNode (+) | Noeud représentant une déclaration d'un identificateur non vérifié
TSepiUsesNode (+) | Noeud section uses
TSepiValueNode (+) | Noeud valeur
TSepiWhileInstructionNode (+) | Instruction while..do ou similaire
TSepiWithInstructionNode (+) | Instruction with

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiRuntimeOperations)
Next (SepiStrTypes)


Sepi

Sepi
Previous
Next (TSepiAbstractMarkerNode)

Name
TCMNotifyTypeCreated

Parent
SepiStdCompilerNodes

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Members
Fields
Field | Description
MsgID (*) | ID du message - CM_NOTIFYTYPECREATED
SepiType (*) | Type créé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiAbstractMarkerNode)


Sepi

Sepi
Previous
Next (SepiType)

Name
MsgID

Parent
TCMNotifyTypeCreated

Visibility
PUBLISHED

Description
ID du message - CM_NOTIFYTYPECREATED

Source code
MsgID : Word

Sepi
Class Tree
Index
Previous
Next (SepiType)


Sepi

Sepi
Previous (MsgID)
Next

Name
SepiType

Parent
TCMNotifyTypeCreated

Visibility
PUBLISHED

Description
Type créé

Source code
SepiType : TSepiType

Sepi
Class Tree
Index
Previous (MsgID)
Next


Sepi

Sepi
Previous (TCMNotifyTypeCreated)
Next (TSepiAddressOfOpNode)

Name
TSepiAbstractMarkerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Marqueur abstract

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TCMNotifyTypeCreated)
Next (TSepiAddressOfOpNode)


Sepi

Sepi
Previous (TSepiAbstractMarkerNode)
Next (TSepiArrayIndicesModifierNode)

Name
TSepiAddressOfOpNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiUnaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur unaire d'adressage

Members
Methods
Method | Description
MakeOperation (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAbstractMarkerNode)
Next (TSepiArrayIndicesModifierNode)


Sepi

Sepi
Previous
Next

Name
MakeOperation

Parent
TSepiAddressOfOpNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Operand : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Operand : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiAddressOfOpNode)
Next (TSepiAsOperationNode)

Name
TSepiArrayIndicesModifierNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionModifierNode

Visibility
PUBLIC

Description
Noeud index de tableau ou de propriété tableau

Members
Methods
Method | Description
CompileArrayItem (#) | Compile l'accès à un élément de tableau
CompileDefaultProperty (#) | Compile les indices de la propriété par défaut d'un objet
CompileProperty (#) | Compile les indices d'une propriété de type tableau
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAddressOfOpNode)
Next (TSepiAsOperationNode)


Sepi

Sepi
Previous
Next (CompileDefaultProperty)

Name
CompileArrayItem

Parent
TSepiArrayIndicesModifierNode

Visibility
PROTECTED

Description
Compile l'accès à un élément de tableau

Source code
procedure CompileArrayItem ( const BaseValue : ISepiValue ) ; virtual

Parameters
Parameter | Description
BaseValue : ISepiValue | Valeur tableau de base

Sepi
Class Tree
Index
Previous
Next (CompileDefaultProperty)


Sepi

Sepi
Previous (CompileArrayItem)
Next (CompileProperty)

Name
CompileDefaultProperty

Parent
TSepiArrayIndicesModifierNode

Visibility
PROTECTED

Description
Compile les indices de la propriété par défaut d'un objet

Source code
procedure CompileDefaultProperty ( const ObjectValue : ISepiReadableValue ) ; virtual

Parameters
Parameter | Description
ObjectValue : ISepiReadableValue | Valeur objet

Sepi
Class Tree
Index
Previous (CompileArrayItem)
Next (CompileProperty)


Sepi

Sepi
Previous (CompileDefaultProperty)
Next (EndParsing)

Name
CompileProperty

Parent
TSepiArrayIndicesModifierNode

Visibility
PROTECTED

Description
Compile les indices d'une propriété de type tableau

Source code
procedure CompileProperty ( const Prop : ISepiProperty ) ; virtual

Parameters
Parameter | Description
Prop : ISepiProperty | Propriété

Sepi
Class Tree
Index
Previous (CompileDefaultProperty)
Next (EndParsing)


Sepi

Sepi
Previous (CompileProperty)
Next

Name
EndParsing

Parent
TSepiArrayIndicesModifierNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileProperty)
Next


Sepi

Sepi
Previous (TSepiArrayIndicesModifierNode)
Next (TSepiAssignmentOpNode)

Name
TSepiAsOperationNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiBinaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur as

Members
Methods
Method | Description
GetPriority (#) | [@inheritDoc]
MakeOperation (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiArrayIndicesModifierNode)
Next (TSepiAssignmentOpNode)


Sepi

Sepi
Previous
Next (MakeOperation)

Name
GetPriority

Parent
TSepiAsOperationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetPriority : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (MakeOperation)


Sepi

Sepi
Previous (GetPriority)
Next

Name
MakeOperation

Parent
TSepiAsOperationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Left , Right : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Left : ISepiExpression | #Pas de TAG trouvé dans le code source#
Right : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetPriority)
Next


Sepi

Sepi
Previous (TSepiAsOperationNode)
Next (TSepiBeginEndBlockNode)

Name
TSepiAssignmentOpNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiBinaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur binaire d'assignation

Members
Methods
Method | Description
GetPriority (#) | [@inheritDoc]
MakeOperation (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAsOperationNode)
Next (TSepiBeginEndBlockNode)


Sepi

Sepi
Previous
Next (MakeOperation)

Name
GetPriority

Parent
TSepiAssignmentOpNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetPriority : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (MakeOperation)


Sepi

Sepi
Previous (GetPriority)
Next

Name
MakeOperation

Parent
TSepiAssignmentOpNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Left , Right : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Left : ISepiExpression | #Pas de TAG trouvé dans le code source#
Right : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetPriority)
Next


Sepi

Sepi
Previous (TSepiAssignmentOpNode)
Next (TSepiBinaryOpNode)

Name
TSepiBeginEndBlockNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionListNode

Visibility
PUBLIC

Description
Bloc begin..end

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiAssignmentOpNode)
Next (TSepiBinaryOpNode)


Sepi

Sepi
Previous (TSepiBeginEndBlockNode)
Next (TSepiBinaryOpTreeNode)

Name
TSepiBinaryOpNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant un opérateur binaire

Members
Methods
Method | Description
GetDirection (#) | Direction d'évaluation de cet opérateur
GetPriority (#) | Priorité de cet opérateur
MakeOperation (+) | #No TAG found in source code#

Properties
Property | Description
Direction (+) | Direction d'évaluation de cet opérateur
Priority (+) | Priorité de cet opérateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBeginEndBlockNode)
Next (TSepiBinaryOpTreeNode)


Sepi

Sepi
Previous
Next (Priority)

Name
Direction

Parent
TSepiBinaryOpNode

Visibility
PUBLIC

Description
Direction d'évaluation de cet opérateur

Source code
property Direction : TSepiBinaryOpDirection read GetDirection

Read Access
GetDirection

Sepi
Class Tree
Index
Previous
Next (Priority)


Sepi

Sepi
Previous (Direction)
Next

Name
Priority

Parent
TSepiBinaryOpNode

Visibility
PUBLIC

Description
Priorité de cet opérateur

Source code
property Priority : Integer read GetPriority

Read Access
GetPriority

Sepi
Class Tree
Index
Previous (Direction)
Next


Sepi

Sepi
Previous
Next (GetPriority)

Name
GetDirection

Parent
TSepiBinaryOpNode

Visibility
PROTECTED

Description
Direction d'évaluation de cet opérateur
Afin que l'évaluation d'expressions soit cohérente, tous les opérateurs
possédant la même priorité doivent également être évalués dans la même
direction.

Source code
function GetDirection : TSepiBinaryOpDirection ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiBinaryOpDirection | Direction d'évaluation de cet opérateur

Sepi
Class Tree
Index
Previous
Next (GetPriority)


Sepi

Sepi
Previous (GetDirection)
Next (MakeOperation)

Name
GetPriority

Parent
TSepiBinaryOpNode

Visibility
PROTECTED

Description
Priorité de cet opérateur

Source code
function GetPriority : Integer ; virtual

Parameters
Parameter Description

Return
Types | Description
INTEGER | Priorité de cet opérateur

Sepi
Class Tree
Index
Previous (GetDirection)
Next (MakeOperation)


Sepi

Sepi
Previous (GetPriority)
Next

Name
MakeOperation

Parent
TSepiBinaryOpNode

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function MakeOperation ( const Left , Right : ISepiExpression ) : ISepiExpression ; virtual ; abstract

Parameters
Parameter | Description
Left : ISepiExpression | #Pas de TAG trouvé dans le code source#
Right : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetPriority)
Next


Sepi

Sepi
Previous (TSepiBinaryOpNode)
Next (TSepiCallingConventionNode)

Name
TSepiBinaryOpTreeNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud expression calculé par un arbre d'opérations binaires

Members
Methods
Method | Description
CompileSubTree (-) | Compile un sous-arbre de l'expression
CompileTree (#) | Compile l'arbre de l'expression
EndParsing (+) | [@inheritDoc]
FindSubTreeOpIndex (-) | Trouve l'opérateur majeur d'un sous-arbre

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBinaryOpNode)
Next (TSepiCallingConventionNode)


Sepi

Sepi
Previous
Next (CompileTree)

Name
CompileSubTree

Parent
TSepiBinaryOpTreeNode

Visibility
PRIVATE

Description
Compile un sous-arbre de l'expression

Source code
function CompileSubTree ( Lower , Higher : Integer ) : ISepiExpression

Parameters
Parameter | Description
Lower : INTEGER | Index bas des symboles du sous-arbre
Higher : INTEGER | Index haut des symboles du sous-arbre

Return
Types | Description
ISepiExpression | Expression représentant le sous-arbre

Sepi
Class Tree
Index
Previous
Next (CompileTree)


Sepi

Sepi
Previous (CompileSubTree)
Next (EndParsing)

Name
CompileTree

Parent
TSepiBinaryOpTreeNode

Visibility
PROTECTED

Description
Compile l'arbre de l'expression

Source code
function CompileTree : ISepiExpression

Parameters
Parameter Description

Return
Types | Description
ISepiExpression | Expression représentant l'arbre

Sepi
Class Tree
Index
Previous (CompileSubTree)
Next (EndParsing)


Sepi

Sepi
Previous (CompileTree)
Next (FindSubTreeOpIndex)

Name
EndParsing

Parent
TSepiBinaryOpTreeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileTree)
Next (FindSubTreeOpIndex)


Sepi

Sepi
Previous (EndParsing)
Next

Name
FindSubTreeOpIndex

Parent
TSepiBinaryOpTreeNode

Visibility
PRIVATE

Description
Trouve l'opérateur majeur d'un sous-arbre
L'opérateur majeur est celui de plus basse priorité dans le sous-arbre. En cas
d'égalité, c'est celui de droite pour une évaluation left-to-right ; et c'est
celui de gauche pour une évaluation right-to-left.

Source code
function FindSubTreeOpIndex ( Lower , Higher : Integer ) : Integer

Parameters
Parameter | Description
Lower : INTEGER | Index bas des symboles du sous-arbre
Higher : INTEGER | Index haut des symboles du sous-arbre

Return
Types | Description
INTEGER | Index de l'opérateur majeur parmi les enfants de ce noeud

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiBinaryOpTreeNode)
Next (TSepiCaseOfClauseNode)

Name
TSepiCallingConventionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiSignatureBuilderNode

Visibility
PUBLIC

Description
Noeud représentant la convention d'appel d'une signature
Cette classe admet que Signature ne soit pas renseignée.

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]
GetCallingConvention (#) | Type de signature représentée par ce noeud

Properties
Property | Description
CallingConvention (+) | Type de signature représentée par ce noeud

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiBinaryOpTreeNode)
Next (TSepiCaseOfClauseNode)


Sepi

Sepi
Previous
Next

Name
CallingConvention

Parent
TSepiCallingConventionNode

Visibility
PUBLIC

Description
Type de signature représentée par ce noeud

Source code
property CallingConvention : TCallingConvention read GetCallingConvention

Read Access
GetCallingConvention

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetCallingConvention)

Name
EndParsing

Parent
TSepiCallingConventionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetCallingConvention)


Sepi

Sepi
Previous (EndParsing)
Next

Name
GetCallingConvention

Parent
TSepiCallingConventionNode

Visibility
PROTECTED

Description
Type de signature représentée par ce noeud

Source code
function GetCallingConvention : TCallingConvention ; virtual

Parameters
Parameter Description

Return
Types | Description
TCallingConvention | Type de signature représentée par ce noeud

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiCallingConventionNode)
Next (TSepiCaseOfInstructionNode)

Name
TSepiCaseOfClauseNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Clause on d'un case of
Le parent d'un noeud de ce type doit toujours être une instance de
TSepiCaseOfNode.

Members
Fields
Field | Description
FClause (-) | Clause représentée par ce noeud
FInstruction (-) | Instruction case of contenante

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]

Properties
Property | Description
Clause (+) | Clause représentée par ce noeud
Instruction (+) | Instruction case of contenante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCallingConventionNode)
Next (TSepiCaseOfInstructionNode)


Sepi

Sepi
Previous
Next (FInstruction)

Name
FClause

Parent
TSepiCaseOfClauseNode

Visibility
PRIVATE

Description
Clause représentée par ce noeud

Source code
FClause : TSepiCaseOfClause

Sepi
Class Tree
Index
Previous
Next (FInstruction)


Sepi

Sepi
Previous (FClause)
Next

Name
FInstruction

Parent
TSepiCaseOfClauseNode

Visibility
PRIVATE

Description
Instruction case of contenante

Source code
FInstruction : TSepiCaseOf

Sepi
Class Tree
Index
Previous (FClause)
Next


Sepi

Sepi
Previous
Next (Instruction)

Name
Clause

Parent
TSepiCaseOfClauseNode

Visibility
PUBLIC

Description
Clause représentée par ce noeud

Source code
property Clause : TSepiCaseOfClause read FClause

Read Access
FClause

Sepi
Class Tree
Index
Previous
Next (Instruction)


Sepi

Sepi
Previous (Clause)
Next

Name
Instruction

Parent
TSepiCaseOfClauseNode

Visibility
PUBLIC

Description
Instruction case of contenante

Source code
property Instruction : TSepiCaseOf read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous (Clause)
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiCaseOfClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiCaseOfClauseNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
ChildEndParsing

Parent
TSepiCaseOfClauseNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TSepiCaseOfClauseNode)
Next (TSepiChangeVisibilityNode)

Name
TSepiCaseOfInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction case of

Members
Fields
Field | Description
FInstruction (-) | Instruction

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Instruction (+) | Instruction

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCaseOfClauseNode)
Next (TSepiChangeVisibilityNode)


Sepi

Sepi
Previous
Next

Name
FInstruction

Parent
TSepiCaseOfInstructionNode

Visibility
PRIVATE

Description
Instruction

Source code
FInstruction : TSepiCaseOf

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Instruction

Parent
TSepiCaseOfInstructionNode

Visibility
PUBLIC

Description
Instruction

Source code
property Instruction : TSepiCaseOf read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiCaseOfInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiCaseOfInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (EndParsing)

Name
ChildEndParsing

Parent
TSepiCaseOfInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
EndParsing

Parent
TSepiCaseOfInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiCaseOfInstructionNode)
Next (TSepiClassFieldNode)

Name
TSepiChangeVisibilityNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant un changement de visibilité

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]
GetVisibility (#) | Nouvelle visibilité

Properties
Property | Description
Visibility (+) | Nouvelle visibilité

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiCaseOfInstructionNode)
Next (TSepiClassFieldNode)


Sepi

Sepi
Previous
Next

Name
Visibility

Parent
TSepiChangeVisibilityNode

Visibility
PUBLIC

Description
Nouvelle visibilité

Source code
property Visibility : TMemberVisibility read GetVisibility

Read Access
GetVisibility

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetVisibility)

Name
EndParsing

Parent
TSepiChangeVisibilityNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetVisibility)


Sepi

Sepi
Previous (EndParsing)
Next

Name
GetVisibility

Parent
TSepiChangeVisibilityNode

Visibility
PROTECTED

Description
Nouvelle visibilité

Source code
function GetVisibility : TMemberVisibility ; virtual

Parameters
Parameter Description

Return
Types | Description
TMemberVisibility | Nouvelle visibilité

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiChangeVisibilityNode)
Next (TSepiClassMemberDefinitionNode)

Name
TSepiClassFieldNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud d'un champ d'une classe

Members
Fields
Field | Description
FFieldType (-) | Type des champs
FLastField (-) | Dernier champ compilé

Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
FieldType (+) | Type des champs
LastField (+) | Dernier champ compilé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiChangeVisibilityNode)
Next (TSepiClassMemberDefinitionNode)


Sepi

Sepi
Previous
Next (FLastField)

Name
FFieldType

Parent
TSepiClassFieldNode

Visibility
PRIVATE

Description
Type des champs

Source code
FFieldType : TSepiType

Sepi
Class Tree
Index
Previous
Next (FLastField)


Sepi

Sepi
Previous (FFieldType)
Next

Name
FLastField

Parent
TSepiClassFieldNode

Visibility
PRIVATE

Description
Dernier champ compilé

Source code
FLastField : TSepiField

Sepi
Class Tree
Index
Previous (FFieldType)
Next


Sepi

Sepi
Previous
Next (LastField)

Name
FieldType

Parent
TSepiClassFieldNode

Visibility
PUBLIC

Description
Type des champs

Source code
property FieldType : TSepiType read FFieldType

Read Access
FFieldType

Sepi
Class Tree
Index
Previous
Next (LastField)


Sepi

Sepi
Previous (FieldType)
Next

Name
LastField

Parent
TSepiClassFieldNode

Visibility
PUBLIC

Description
Dernier champ compilé

Source code
property LastField : TSepiField read FLastField

Read Access
FLastField

Sepi
Class Tree
Index
Previous (FieldType)
Next


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiClassFieldNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiClassFieldNode)
Next (TSepiConstExpressionNode)

Name
TSepiClassMemberDefinitionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud marqueur que ses enfants sont déclarés comme membres de classe

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiClassFieldNode)
Next (TSepiConstExpressionNode)


Sepi

Sepi
Previous (TSepiClassMemberDefinitionNode)
Next (TSepiConstFloatNode)

Name
TSepiConstExpressionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiSameAsChildExpressionNode

Visibility
PUBLIC

Description
Noeud expression constante

Members
Fields
Field | Description
FValueType (-) | Type de valeur censée être contenue dans ce noeud

Methods
Method | Description
AsInteger (+) | Lit l'expression en tant que valeur entière constante
CompileConst (+) | Compile une valeur constante
MakeErroneousExpression (#) | Construit une expression erronée
ValidateExpression (#) | [@inheritDoc]

Properties
Property | Description
ValueType (+) | Type de valeur censée être contenue dans ce noeud

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiClassMemberDefinitionNode)
Next (TSepiConstFloatNode)


Sepi

Sepi
Previous
Next

Name
FValueType

Parent
TSepiConstExpressionNode

Visibility
PRIVATE

Description
Type de valeur censée être contenue dans ce noeud

Source code
FValueType : TSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
ValueType

Parent
TSepiConstExpressionNode

Visibility
PUBLIC

Description
Type de valeur censée être contenue dans ce noeud

Source code
property ValueType : TSepiType read FValueType write FValueType

Read Access
FValueType

Write Access
FValueType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileConst)

Name
AsInteger

Parent
TSepiConstExpressionNode

Visibility
PUBLIC

Description
Lit l'expression en tant que valeur entière constante

Source code
function AsInteger ( DefaultValue : Integer = 0 ) : Integer

Parameters
Parameter | Description
DefaultValue : INTEGER | Valeur par défaut

Return
Types | Description
INTEGER | L'expression comme valeur entière, ou DefaultValue en cas d'erreur

Sepi
Class Tree
Index
Previous
Next (CompileConst)


Sepi

Sepi
Previous (AsInteger)
Next (MakeErroneousExpression)

Name
CompileConst

Parent
TSepiConstExpressionNode

Visibility
PUBLIC

Description
Compile une valeur constante

Source code
function CompileConst ( var Value ; ValueType : TSepiType = nil ) : Boolean ; virtual

Parameters
Parameter | Description
Value : Untyped | En sortie : valeur compilée
ValueType : TSepiType | Type de la valeur (si nil, utilise la propriété ValueType)

Return
Types | Description
BOOLEAN | True si la compilation est réussie, False en cas d'erreur

Sepi
Class Tree
Index
Previous (AsInteger)
Next (MakeErroneousExpression)


Sepi

Sepi
Previous (CompileConst)
Next (ValidateExpression)

Name
MakeErroneousExpression

Parent
TSepiConstExpressionNode

Visibility
PROTECTED

Description
Construit une expression erronée

Source code
procedure MakeErroneousExpression ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileConst)
Next (ValidateExpression)


Sepi

Sepi
Previous (MakeErroneousExpression)
Next

Name
ValidateExpression

Parent
TSepiConstExpressionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function ValidateExpression : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (MakeErroneousExpression)
Next


Sepi

Sepi
Previous (TSepiConstExpressionNode)
Next (TSepiConstIntegerNode)

Name
TSepiConstFloatNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiLiteralConstNode

Visibility
PUBLIC

Description
Noeud représentant une constante littérale flottante

Members
Methods
Method | Description
CompileAsExtended (#) | Compile la valeur sous forme de nombre à virgule flottante
CompileAsValue (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiConstExpressionNode)
Next (TSepiConstIntegerNode)


Sepi

Sepi
Previous
Next (CompileAsValue)

Name
CompileAsExtended

Parent
TSepiConstFloatNode

Visibility
PROTECTED

Description
Compile la valeur sous forme de nombre à virgule flottante
En cas d'erreur, peut renvoyer une valeur arbitraire, 0 le plus souvent.

Source code
function CompileAsExtended : Extended ; virtual

Parameters
Parameter Description

Return
Types | Description
EXTENDED | Valeur représentée par le littéral

Sepi
Class Tree
Index
Previous
Next (CompileAsValue)


Sepi

Sepi
Previous (CompileAsExtended)
Next

Name
CompileAsValue

Parent
TSepiConstFloatNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsValue : ISepiValue ; override

Parameters
Parameter Description

Return
Types | Description
ISepiValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileAsExtended)
Next


Sepi

Sepi
Previous (TSepiConstFloatNode)
Next (TSepiConstStringNode)

Name
TSepiConstIntegerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiLiteralConstNode

Visibility
PUBLIC

Description
Noeud représentant une constante littérale entière

Members
Methods
Method | Description
CompileAsInteger (#) | Compile la valeur sous forme d'entier
CompileAsValue (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiConstFloatNode)
Next (TSepiConstStringNode)


Sepi

Sepi
Previous
Next (CompileAsValue)

Name
CompileAsInteger

Parent
TSepiConstIntegerNode

Visibility
PROTECTED

Description
Compile la valeur sous forme d'entier
En cas d'erreur, peut renvoyer une valeur arbitraire, 0 le plus souvent.

Source code
function CompileAsInteger : Int64 ; virtual

Parameters
Parameter Description

Return
Types | Description
INT64 | Valeur représentée par le littéral

Sepi
Class Tree
Index
Previous
Next (CompileAsValue)


Sepi

Sepi
Previous (CompileAsInteger)
Next

Name
CompileAsValue

Parent
TSepiConstIntegerNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsValue : ISepiValue ; override

Parameters
Parameter Description

Return
Types | Description
ISepiValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileAsInteger)
Next


Sepi

Sepi
Previous (TSepiConstIntegerNode)
Next (TSepiDelphiLikeBinaryOpNode)

Name
TSepiConstStringNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiLiteralConstNode

Visibility
PUBLIC

Description
Noeud représentant une constante littérale chaîne de caractères

Members
Methods
Method | Description
CompileAsString (#) | Compile la valeur sous forme de chaîne de caractères
CompileAsValue (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiConstIntegerNode)
Next (TSepiDelphiLikeBinaryOpNode)


Sepi

Sepi
Previous
Next (CompileAsValue)

Name
CompileAsString

Parent
TSepiConstStringNode

Visibility
PROTECTED

Description
Compile la valeur sous forme de chaîne de caractères
En cas d'erreur, peut renvoyer une valeur arbitraire, '' le plus souvent.

Source code
function CompileAsString : string ; virtual

Parameters
Parameter Description

Return
Types | Description
STRING | Valeur représentée par le littéral

Sepi
Class Tree
Index
Previous
Next (CompileAsValue)


Sepi

Sepi
Previous (CompileAsString)
Next

Name
CompileAsValue

Parent
TSepiConstStringNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function CompileAsValue : ISepiValue ; override

Parameters
Parameter Description

Return
Types | Description
ISepiValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (CompileAsString)
Next


Sepi

Sepi
Previous (TSepiConstStringNode)
Next (TSepiDelphiLikeParametersNode)

Name
TSepiDelphiLikeBinaryOpNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiBinaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur binaire du style Delphi

Members
Methods
Method | Description
GetOperation (#) | #No TAG found in source code#
GetPriority (#) | [@inheritDoc]
HandleIntDivIntTrick (#) | Gère le cas spécial du Int/Int avec au moins une constante
MakeOperation (+) | [@inheritDoc]
TryAndHandlePointerArithm (#) | Essaie d'appliquer une opération d'arithmétique des pointeurs

Properties
Property | Description
Operation (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiConstStringNode)
Next (TSepiDelphiLikeParametersNode)


Sepi

Sepi
Previous
Next

Name
Operation

Parent
TSepiDelphiLikeBinaryOpNode

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Operation : TSepiOperation read GetOperation

Read Access
GetOperation

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetPriority)

Name
GetOperation

Parent
TSepiDelphiLikeBinaryOpNode

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetOperation : TSepiOperation ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
TSepiOperation | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (GetPriority)


Sepi

Sepi
Previous (GetOperation)
Next (HandleIntDivIntTrick)

Name
GetPriority

Parent
TSepiDelphiLikeBinaryOpNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetPriority : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetOperation)
Next (HandleIntDivIntTrick)


Sepi

Sepi
Previous (GetPriority)
Next (MakeOperation)

Name
HandleIntDivIntTrick

Parent
TSepiDelphiLikeBinaryOpNode

Visibility
PROTECTED

Description
Gère le cas spécial du Int/Int avec au moins une constante

Source code
procedure HandleIntDivIntTrick ( var LeftValue , RightValue : ISepiReadableValue ) ; virtual

Parameters
Parameter | Description
LeftValue : ISepiReadableValue | Valeur gauche
RightValue : ISepiReadableValue | Valeur droite

Sepi
Class Tree
Index
Previous (GetPriority)
Next (MakeOperation)


Sepi

Sepi
Previous (HandleIntDivIntTrick)
Next (TryAndHandlePointerArithm)

Name
MakeOperation

Parent
TSepiDelphiLikeBinaryOpNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Left , Right : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Left : ISepiExpression | #Pas de TAG trouvé dans le code source#
Right : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (HandleIntDivIntTrick)
Next (TryAndHandlePointerArithm)


Sepi

Sepi
Previous (MakeOperation)
Next

Name
TryAndHandlePointerArithm

Parent
TSepiDelphiLikeBinaryOpNode

Visibility
PROTECTED

Description
Essaie d'appliquer une opération d'arithmétique des pointeurs

Source code
function TryAndHandlePointerArithm ( const PtrValue , IntValue : ISepiReadableValue ; out Expression : ISepiExpression ) : Boolean ; virtual

Parameters
Parameter | Description
PtrValue : ISepiReadableValue | Valeur supposée pointeur
IntValue : ISepiReadableValue | Valeur supposée entière
Expression : ISepiExpression | En sortie : résultat, si réussi

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (MakeOperation)
Next


Sepi

Sepi
Previous (TSepiDelphiLikeBinaryOpNode)
Next (TSepiDelphiLikeUnaryOpNode)

Name
TSepiDelphiLikeParametersNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiParametersNode

Visibility
PUBLIC

Description
Noeud paramètres réels de style Delphi

Members
Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
Compile (#) | [@inheritDoc]
CompileIdentifierTest (#) | Compile une pseudo-routine de test d'identificateur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDelphiLikeBinaryOpNode)
Next (TSepiDelphiLikeUnaryOpNode)


Sepi

Sepi
Previous
Next (Compile)

Name
BeginParsing

Parent
TSepiDelphiLikeParametersNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Compile)


Sepi

Sepi
Previous (BeginParsing)
Next (CompileIdentifierTest)

Name
Compile

Parent
TSepiDelphiLikeParametersNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Compile ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (CompileIdentifierTest)


Sepi

Sepi
Previous (Compile)
Next

Name
CompileIdentifierTest

Parent
TSepiDelphiLikeParametersNode

Visibility
PROTECTED

Description
Compile une pseudo-routine de test d'identificateur

Source code
procedure CompileIdentifierTest ( const PseudoRoutine : ISepiIdentifierTestPseudoRoutine )

Parameters
Parameter | Description
PseudoRoutine : ISepiIdentifierTestPseudoRoutine | Pseudo-routine à compiler

Sepi
Class Tree
Index
Previous (Compile)
Next


Sepi

Sepi
Previous (TSepiDelphiLikeParametersNode)
Next (TSepiDereferenceOpNode)

Name
TSepiDelphiLikeUnaryOpNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiUnaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur unaire du style Delphi

Members
Methods
Method | Description
GetOperation (#) | #No TAG found in source code#
MakeOperation (+) | [@inheritDoc]

Properties
Property | Description
Operation (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDelphiLikeParametersNode)
Next (TSepiDereferenceOpNode)


Sepi

Sepi
Previous
Next

Name
Operation

Parent
TSepiDelphiLikeUnaryOpNode

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Operation : TSepiOperation read GetOperation

Read Access
GetOperation

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (MakeOperation)

Name
GetOperation

Parent
TSepiDelphiLikeUnaryOpNode

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function GetOperation : TSepiOperation ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
TSepiOperation | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (MakeOperation)


Sepi

Sepi
Previous (GetOperation)
Next

Name
MakeOperation

Parent
TSepiDelphiLikeUnaryOpNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Operand : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Operand : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetOperation)
Next


Sepi

Sepi
Previous (TSepiDelphiLikeUnaryOpNode)
Next (TSepiDoWhileInstructionNode)

Name
TSepiDereferenceOpNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiUnaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur unaire de déréférencement

Members
Methods
Method | Description
MakeOperation (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDelphiLikeUnaryOpNode)
Next (TSepiDoWhileInstructionNode)


Sepi

Sepi
Previous
Next

Name
MakeOperation

Parent
TSepiDereferenceOpNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Operand : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Operand : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiDereferenceOpNode)
Next (TSepiExceptClauseNode)

Name
TSepiDoWhileInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiWhileInstructionNode

Visibility
PUBLIC

Description
Instruction do..while

Members
Methods
Method | Description
Create (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDereferenceOpNode)
Next (TSepiExceptClauseNode)


Sepi

Sepi
Previous
Next

Name
Create

Parent
TSepiDoWhileInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AParent : TSepiNonTerminal ; AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; override

Parameters
Parameter | Description
AParent : TSepiNonTerminal | #Pas de TAG trouvé dans le code source#
AClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#
ASourcePos : TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiDoWhileInstructionNode)
Next (TSepiExceptFinallyClauseNode)

Name
TSepiExceptClauseNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExceptFinallyClauseNode

Visibility
PUBLIC

Description
Clause except d'un try..except.end

Members
Fields
Field | Description
FInstruction (-) | Instruction

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Instruction (+) | Instruction

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiDoWhileInstructionNode)
Next (TSepiExceptFinallyClauseNode)


Sepi

Sepi
Previous
Next

Name
FInstruction

Parent
TSepiExceptClauseNode

Visibility
PRIVATE

Description
Instruction

Source code
FInstruction : TSepiTryExcept

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Instruction

Parent
TSepiExceptClauseNode

Visibility
PUBLIC

Description
Instruction

Source code
property Instruction : TSepiTryExcept read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiExceptClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (EndParsing)

Name
ChildBeginParsing

Parent
TSepiExceptClauseNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
EndParsing

Parent
TSepiExceptClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TSepiExceptClauseNode)
Next (TSepiExceptionVarAndTypeNode)

Name
TSepiExceptFinallyClauseNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Suite d'une instruction try..except..end ou try..finally..end

Members
Fields
Field | Description
FTryInstructions (-) | Instructions dans le try

Methods
Method | Description
SetTryInstructions (+) | Spécifie la liste des instructions dans le try

Properties
Property | Description
TryInstructions (#) | Instructions dans le try

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExceptClauseNode)
Next (TSepiExceptionVarAndTypeNode)


Sepi

Sepi
Previous
Next

Name
FTryInstructions

Parent
TSepiExceptFinallyClauseNode

Visibility
PRIVATE

Description
Instructions dans le try

Source code
FTryInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
TryInstructions

Parent
TSepiExceptFinallyClauseNode

Visibility
PROTECTED

Description
Instructions dans le try

Source code
property TryInstructions : TSepiInstructionList read FTryInstructions

Read Access
FTryInstructions

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SetTryInstructions

Parent
TSepiExceptFinallyClauseNode

Visibility
PUBLIC

Description
Spécifie la liste des instructions dans le try

Source code
procedure SetTryInstructions ( ATryInstructions : TSepiInstructionList )

Parameters
Parameter | Description
ATryInstructions : TSepiInstructionList | Liste des instructions dans le try

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiExceptFinallyClauseNode)
Next (TSepiExecuteExpressionInstructionNode)

Name
TSepiExceptionVarAndTypeNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiMaybeIdentAndTypeNode

Visibility
PUBLIC

Description
Noeud représentant le nom et le type de la variable exception d'un 'on'

Members
Methods
Method | Description
CompileType (#) | [@inheritDoc]
MakeErroneousType (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExceptFinallyClauseNode)
Next (TSepiExecuteExpressionInstructionNode)


Sepi

Sepi
Previous
Next (MakeErroneousType)

Name
CompileType

Parent
TSepiExceptionVarAndTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure CompileType ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (MakeErroneousType)


Sepi

Sepi
Previous (CompileType)
Next

Name
MakeErroneousType

Parent
TSepiExceptionVarAndTypeNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure MakeErroneousType ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileType)
Next


Sepi

Sepi
Previous (TSepiExceptionVarAndTypeNode)
Next (TSepiExpressionModifierNode)

Name
TSepiExecuteExpressionInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction d'exécution d'une expression (exécutable)

Members
Methods
Method | Description
ChildEndParsing (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExceptionVarAndTypeNode)
Next (TSepiExpressionModifierNode)


Sepi

Sepi
Previous
Next

Name
ChildEndParsing

Parent
TSepiExecuteExpressionInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiExecuteExpressionInstructionNode)
Next (TSepiExpressionNode)

Name
TSepiExpressionModifierNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud modifieur d'expression
Une modifieur d'expression est un noeud qui part d'une expression existante
et la modifie. L'expression de base doit être renseignée avec SetBase avant
BeginParsing.

Members
Fields
Field | Description
FBase (-) | Expression de base à modifier

Methods
Method | Description
SetBase (+) | Spécifie l'expression de base à modifier

Properties
Property | Description
Base (#) | Expression de base à modifier

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExecuteExpressionInstructionNode)
Next (TSepiExpressionNode)


Sepi

Sepi
Previous
Next

Name
FBase

Parent
TSepiExpressionModifierNode

Visibility
PRIVATE

Description
Expression de base à modifier

Source code
FBase : ISepiExpression

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Base

Parent
TSepiExpressionModifierNode

Visibility
PROTECTED

Description
Expression de base à modifier

Source code
property Base : ISepiExpression read FBase

Read Access
FBase

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SetBase

Parent
TSepiExpressionModifierNode

Visibility
PUBLIC

Description
Spécifie l'expression de base à modifier

Source code
procedure SetBase ( const ABase : ISepiExpression )

Parameters
Parameter | Description
ABase : ISepiExpression | Expression de base à modifier

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiExpressionModifierNode)
Next (TSepiExpressionWithModifiersNode)

Name
TSepiExpressionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud expression

Members
Fields
Field | Description
FExpression (-) | Expression compilée

Methods
Method | Description
AsComponent (+) | Lit l'expression en tant que meta
AsExpressionPart (+) | Lit l'expression comme un type donné de partie d'expression
AsReadableValue (+) | Lit l'expression en tant que valeur qui peut être lue
AsType (+) | Lit l'expression en tant que type
AsValue (+) | Lit l'expression en tant que valeur
EndParsing (+) | [@inheritDoc]
MakeErroneousExpression (#) | Construit une expression erronée
MakeErroneousValue (#) | Construit une valeur erronée
RequireType (-) | Exige qu'une variable ait un type donné
SetExpression (#) | Modifie l'expression
SetExpressionPart (#) | Modifie l'expression comme nouvelle expression partielle
TryAndConvert (-) | Tente de convertir une valeur en un type donné
TryAndForceType (-) | Tente de forcer le type d'une valeur
TryAndMatchType (-) | Tente de faire conrrespondre le type d'une valeur à un type donné
ValidateExpression (#) | Vérifie la validité de l'expression compilée

Properties
Property | Description
Expression (+) | Expression compilée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExpressionModifierNode)
Next (TSepiExpressionWithModifiersNode)


Sepi

Sepi
Previous
Next

Name
FExpression

Parent
TSepiExpressionNode

Visibility
PRIVATE

Description
Expression compilée

Source code
FExpression : ISepiExpression

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Expression

Parent
TSepiExpressionNode

Visibility
PUBLIC

Description
Expression compilée

Source code
property Expression : ISepiExpression read FExpression

Read Access
FExpression

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (AsExpressionPart)

Name
AsComponent

Parent
TSepiExpressionNode

Visibility
PUBLIC

Description
Lit l'expression en tant que meta

Source code
function AsComponent : TSepiComponent

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | Component représenté par l'expression (ou nil en cas d'erreur)

Sepi
Class Tree
Index
Previous
Next (AsExpressionPart)


Sepi

Sepi
Previous (AsComponent)
Next (AsReadableValue)

Name
AsExpressionPart

Parent
TSepiExpressionNode

Visibility
PUBLIC

Description
Lit l'expression comme un type donné de partie d'expression
Si l'expression n'est du type requis, et si ErrorMsg est non vide, un message
d'erreur est émis, et AsExpressionPart renvoie False.

Source code
function AsExpressionPart ( const IID : TGUID ; out Intf ; const ErrorMsg : string = '' ) : Boolean

Parameters
Parameter | Description
IID : TGUID | Type de partie d'expression requis
Intf : Untyped | En sortie : partie d'expression demandée, si succès
ErrorMsg : STRING | Message d'erreur en cas d'échec

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (AsComponent)
Next (AsReadableValue)


Sepi

Sepi
Previous (AsExpressionPart)
Next (AsType)

Name
AsReadableValue

Parent
TSepiExpressionNode

Visibility
PUBLIC

Description
Lit l'expression en tant que valeur qui peut être lue

Source code
function AsReadableValue ( ValueType : TSepiType = nil ; AllowConvertion : Boolean = True ) : ISepiReadableValue

Parameters
Parameter | Description
ValueType : TSepiType | Type de valeur attendu (nil = tout type)
AllowConvertion : BOOLEAN | Autoriser des conversion pour obtenir le type requis

Return
Types | Description
ISepiReadableValue | Valeur représentée par l'expression (ou nil en cas d'erreur)

Sepi
Class Tree
Index
Previous (AsExpressionPart)
Next (AsType)


Sepi

Sepi
Previous (AsReadableValue)
Next (AsValue)

Name
AsType

Parent
TSepiExpressionNode

Visibility
PUBLIC

Description
Lit l'expression en tant que type

Source code
function AsType : TSepiType

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type représenté par l'expression (ou System.Integer en cas d'erreur)

Sepi
Class Tree
Index
Previous (AsReadableValue)
Next (AsValue)


Sepi

Sepi
Previous (AsType)
Next (EndParsing)

Name
AsValue

Parent
TSepiExpressionNode

Visibility
PUBLIC

Description
Lit l'expression en tant que valeur

Source code
function AsValue ( ValueType : TSepiType = nil ; AllowConvertion : Boolean = True ) : ISepiValue

Parameters
Parameter | Description
ValueType : TSepiType | Type de valeur attendu (nil = tout type)
AllowConvertion : BOOLEAN | Autoriser des conversion pour obtenir le type requis

Return
Types | Description
ISepiValue | Valeur représentée par l'expression (ou nil en cas d'erreur)

Sepi
Class Tree
Index
Previous (AsType)
Next (EndParsing)


Sepi

Sepi
Previous (AsValue)
Next (MakeErroneousExpression)

Name
EndParsing

Parent
TSepiExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AsValue)
Next (MakeErroneousExpression)


Sepi

Sepi
Previous (EndParsing)
Next (MakeErroneousValue)

Name
MakeErroneousExpression

Parent
TSepiExpressionNode

Visibility
PROTECTED

Description
Construit une expression erronée

Source code
procedure MakeErroneousExpression ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (EndParsing)
Next (MakeErroneousValue)


Sepi

Sepi
Previous (MakeErroneousExpression)
Next (RequireType)

Name
MakeErroneousValue

Parent
TSepiExpressionNode

Visibility
PROTECTED

Description
Construit une valeur erronée

Source code
function MakeErroneousValue ( ValueType : TSepiType = nil ) : ISepiReadableValue

Parameters
Parameter | Description
ValueType : TSepiType | Type de valeur erronée (peut être nil)

Return
Types | Description
ISepiReadableValue | Valeur construite

Sepi
Class Tree
Index
Previous (MakeErroneousExpression)
Next (RequireType)


Sepi

Sepi
Previous (MakeErroneousValue)
Next (SetExpression)

Name
RequireType

Parent
TSepiExpressionNode

Visibility
PRIVATE

Description
Exige qu'une variable ait un type donné

Source code
procedure RequireType ( var Value : ISepiValue ; ValueType : TSepiType ; AllowConvertion : Boolean )

Parameters
Parameter | Description
Value : ISepiValue | Valeur à convertir
ValueType : TSepiType | Type requis
AllowConvertion : BOOLEAN | Autoriser des conversion pour obtenir le type requis

Sepi
Class Tree
Index
Previous (MakeErroneousValue)
Next (SetExpression)


Sepi

Sepi
Previous (RequireType)
Next (SetExpressionPart)

Name
SetExpression

Parent
TSepiExpressionNode

Visibility
PROTECTED

Description
Modifie l'expression

Source code
procedure SetExpression ( const AExpression : ISepiExpression )

Parameters
Parameter | Description
AExpression : ISepiExpression | Nouvelle expression

Sepi
Class Tree
Index
Previous (RequireType)
Next (SetExpressionPart)


Sepi

Sepi
Previous (SetExpression)
Next (TryAndConvert)

Name
SetExpressionPart

Parent
TSepiExpressionNode

Visibility
PROTECTED

Description
Modifie l'expression comme nouvelle expression partielle

Source code
procedure SetExpressionPart ( const ExpressionPart : ISepiExpressionPart )

Parameters
Parameter | Description
ExpressionPart : ISepiExpressionPart | Nouvelle expression partielle

Sepi
Class Tree
Index
Previous (SetExpression)
Next (TryAndConvert)


Sepi

Sepi
Previous (SetExpressionPart)
Next (TryAndForceType)

Name
TryAndConvert

Parent
TSepiExpressionNode

Visibility
PRIVATE

Description
Tente de convertir une valeur en un type donné

Source code
function TryAndConvert ( var Value : ISepiValue ; ValueType : TSepiType ) : Boolean

Parameters
Parameter | Description
Value : ISepiValue | Valeur à convertir
ValueType : TSepiType | Type requis

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (SetExpressionPart)
Next (TryAndForceType)


Sepi

Sepi
Previous (TryAndConvert)
Next (TryAndMatchType)

Name
TryAndForceType

Parent
TSepiExpressionNode

Visibility
PRIVATE

Description
Tente de forcer le type d'une valeur

Source code
function TryAndForceType ( var Value : ISepiValue ; ValueType : TSepiType ) : Boolean

Parameters
Parameter | Description
Value : ISepiValue | Valeur dont forcer le type
ValueType : TSepiType | Type requis

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (TryAndConvert)
Next (TryAndMatchType)


Sepi

Sepi
Previous (TryAndForceType)
Next (ValidateExpression)

Name
TryAndMatchType

Parent
TSepiExpressionNode

Visibility
PRIVATE

Description
Tente de faire conrrespondre le type d'une valeur à un type donné

Source code
function TryAndMatchType ( var Value : ISepiValue ; ValueType : TSepiType ; AllowConvertion : Boolean ) : Boolean

Parameters
Parameter | Description
Value : ISepiValue | Valeur à convertir
ValueType : TSepiType | Type requis
AllowConvertion : BOOLEAN | Autoriser des conversion pour obtenir le type requis

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (TryAndForceType)
Next (ValidateExpression)


Sepi

Sepi
Previous (TryAndMatchType)
Next

Name
ValidateExpression

Parent
TSepiExpressionNode

Visibility
PROTECTED

Description
Vérifie la validité de l'expression compilée
ValidateExpression n'est appelée que si Expression <> nil.

Source code
function ValidateExpression : Boolean ; virtual

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si l'expression est valide, False sinon

Sepi
Class Tree
Index
Previous (TryAndMatchType)
Next


Sepi

Sepi
Previous (TSepiExpressionNode)
Next (TSepiFieldSelectionModifierNode)

Name
TSepiExpressionWithModifiersNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud représentant une expression avec des modificateurs
Le premier enfant d'un noeud de ce type est une expression classique, de
type TSepiExpressionNode. Les suivants sont des "modifieurs", de type
TSepiExpressionModifierNode, qui modifient successivement les expressions
intermédiaire.
Par exemple, s'il y a trois enfants, le résultat est l'application du
modifieur 2 sur une expression intermédiaire, qui est l'application du
modifieur 1 sur l'expression de l'enfant 0.
Des modifieurs courants sont des indices de tableaux, des paramètres d'appel
de méthode ou une sélection d'un champ.

Members
Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExpressionNode)
Next (TSepiFieldSelectionModifierNode)


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiExpressionWithModifiersNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (EndParsing)

Name
ChildEndParsing

Parent
TSepiExpressionWithModifiersNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
EndParsing

Parent
TSepiExpressionWithModifiersNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiExpressionWithModifiersNode)
Next (TSepiFinallyClauseNode)

Name
TSepiFieldSelectionModifierNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionModifierNode

Visibility
PUBLIC

Description
Noeud sélection de champ

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]
MakeFieldSelection (#) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiExpressionWithModifiersNode)
Next (TSepiFinallyClauseNode)


Sepi

Sepi
Previous
Next (MakeFieldSelection)

Name
EndParsing

Parent
TSepiFieldSelectionModifierNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (MakeFieldSelection)


Sepi

Sepi
Previous (EndParsing)
Next

Name
MakeFieldSelection

Parent
TSepiFieldSelectionModifierNode

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function MakeFieldSelection : ISepiExpression ; virtual

Parameters
Parameter Description

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiFieldSelectionModifierNode)
Next (TSepiForControlVarNode)

Name
TSepiFinallyClauseNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExceptFinallyClauseNode

Visibility
PUBLIC

Description
Clause finally d'un try..except.end

Members
Fields
Field | Description
FInstruction (-) | Instruction

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Instruction (+) | Instruction

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFieldSelectionModifierNode)
Next (TSepiForControlVarNode)


Sepi

Sepi
Previous
Next

Name
FInstruction

Parent
TSepiFinallyClauseNode

Visibility
PRIVATE

Description
Instruction

Source code
FInstruction : TSepiTryFinally

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Instruction

Parent
TSepiFinallyClauseNode

Visibility
PUBLIC

Description
Instruction

Source code
property Instruction : TSepiTryFinally read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiFinallyClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (EndParsing)

Name
ChildBeginParsing

Parent
TSepiFinallyClauseNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
EndParsing

Parent
TSepiFinallyClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TSepiFinallyClauseNode)
Next (TSepiForDownToNode)

Name
TSepiForControlVarNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiLocalVarNameNode

Visibility
PUBLIC

Description
Noeud représentant la variable de contrôle d'une boucle for
Le parent d'un noeud ce type doit être une instance de
TSepiForInstructionNode.

Members
Methods
Method | Description
MakeErroneousLocalVar (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiFinallyClauseNode)
Next (TSepiForDownToNode)


Sepi

Sepi
Previous
Next

Name
MakeErroneousLocalVar

Parent
TSepiForControlVarNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure MakeErroneousLocalVar ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiForControlVarNode)
Next (TSepiForInstructionNode)

Name
TSepiForDownToNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiForToDownToNode

Visibility
PUBLIC

Description
Noeud indiquant que le for englobant est 'downto'

Members
Methods
Method | Description
GetIsDownTo (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiForControlVarNode)
Next (TSepiForInstructionNode)


Sepi

Sepi
Previous
Next

Name
GetIsDownTo

Parent
TSepiForDownToNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsDownTo : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiForDownToNode)
Next (TSepiForToDownToNode)

Name
TSepiForInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction for..do

Members
Fields
Field | Description
FInstruction (-) | Instruction

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
MakeErroneousBoundValue (#) | Construit une valeur de borne erronée

Properties
Property | Description
Instruction (+) | Instruction

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiForDownToNode)
Next (TSepiForToDownToNode)


Sepi

Sepi
Previous
Next

Name
FInstruction

Parent
TSepiForInstructionNode

Visibility
PRIVATE

Description
Instruction

Source code
FInstruction : TSepiFor

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Instruction

Parent
TSepiForInstructionNode

Visibility
PUBLIC

Description
Instruction

Source code
property Instruction : TSepiFor read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiForInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiForInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (EndParsing)

Name
ChildEndParsing

Parent
TSepiForInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next (MakeErroneousBoundValue)

Name
EndParsing

Parent
TSepiForInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (MakeErroneousBoundValue)


Sepi

Sepi
Previous (EndParsing)
Next

Name
MakeErroneousBoundValue

Parent
TSepiForInstructionNode

Visibility
PROTECTED

Description
Construit une valeur de borne erronée

Source code
function MakeErroneousBoundValue : ISepiReadableValue ; virtual

Parameters
Parameter Description

Return
Types | Description
ISepiReadableValue | Valeur construite

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiForInstructionNode)
Next (TSepiForToNode)

Name
TSepiForToDownToNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Classe de base pour des noeuds indiquant qu'un for est 'to' ou 'downto'

Members
Methods
Method | Description
GetIsDownTo (#) | Indique si le for englobant est 'to' ou 'downto'

Properties
Property | Description
IsDownTo (+) | Indique si le for englobant est 'to' ou 'downto'

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiForInstructionNode)
Next (TSepiForToNode)


Sepi

Sepi
Previous
Next

Name
IsDownTo

Parent
TSepiForToDownToNode

Visibility
PUBLIC

Description
Indique si le for englobant est 'to' ou 'downto'

Source code
property IsDownTo : Boolean read GetIsDownTo

Read Access
GetIsDownTo

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
GetIsDownTo

Parent
TSepiForToDownToNode

Visibility
PROTECTED

Description
Indique si le for englobant est 'to' ou 'downto'

Source code
function GetIsDownTo : Boolean ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il est 'downto', False s'il est 'to'

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiForToDownToNode)
Next (TSepiForwardMarkerNode)

Name
TSepiForToNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiForToDownToNode

Visibility
PUBLIC

Description
Noeud indiquant que le for englobant est 'to'

Members
Methods
Method | Description
GetIsDownTo (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiForToDownToNode)
Next (TSepiForwardMarkerNode)


Sepi

Sepi
Previous
Next

Name
GetIsDownTo

Parent
TSepiForToNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetIsDownTo : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiForToNode)
Next (TSepiIdentifierDeclarationNode)

Name
TSepiForwardMarkerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Marqueur forward

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiForToNode)
Next (TSepiIdentifierDeclarationNode)


Sepi

Sepi
Previous (TSepiForwardMarkerNode)
Next (TSepiIdentifierDeclListNode)

Name
TSepiIdentifierDeclarationNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant une déclaration d'un identificateur
TSepiIdentifierDeclarationNode prend en charge la vérification de l'unicité
de l'identificateur, et son remplacement en cas d'erreur.
La vérification se fait au moyen de IsRedeclared. De plus, si le parent d'un
tel noeud est une instance de TSepiIdentifierDeclListNode, sont considérés
les identificateurs déjà déclarés dans la liste, tels que testés avec la
fonction TSepiIdentifierDeclListNode.IsDeclared.

Members
Fields
Field | Description
FIdentifier (-) | Identificateur (si vide, AsText est utilisé)

Methods
Method | Description
EndParsing (+) | [@inheritDoc]
GetIdentifier (-) | Identificateur représenté par ce noeud
IsRedeclared (#) | Teste si cet identificateur est redéclaré
IsRedeclaredInCurrentList (-) | Teste si cet identificateur est redéclaré dans sa liste courante
MakeErroneousName (#) | Construit un identificateur erroné
SetIdentifier (#) | Modifie l'identificateur représenté par ce noeud

Properties
Property | Description
Identifier (+) | Identificateur représenté par ce noeud

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiForwardMarkerNode)
Next (TSepiIdentifierDeclListNode)


Sepi

Sepi
Previous
Next

Name
FIdentifier

Parent
TSepiIdentifierDeclarationNode

Visibility
PRIVATE

Description
Identificateur (si vide, AsText est utilisé)

Source code
FIdentifier : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Identifier

Parent
TSepiIdentifierDeclarationNode

Visibility
PUBLIC

Description
Identificateur représenté par ce noeud

Source code
property Identifier : string read GetIdentifier

Read Access
GetIdentifier

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetIdentifier)

Name
EndParsing

Parent
TSepiIdentifierDeclarationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetIdentifier)


Sepi

Sepi
Previous (EndParsing)
Next (IsRedeclared)

Name
GetIdentifier

Parent
TSepiIdentifierDeclarationNode

Visibility
PRIVATE

Description
Identificateur représenté par ce noeud

Source code
function GetIdentifier : string

Parameters
Parameter Description

Return
Types | Description
STRING | Identificateur représenté par ce noeud

Sepi
Class Tree
Index
Previous (EndParsing)
Next (IsRedeclared)


Sepi

Sepi
Previous (GetIdentifier)
Next (IsRedeclaredInCurrentList)

Name
IsRedeclared

Parent
TSepiIdentifierDeclarationNode

Visibility
PROTECTED

Description
Teste si cet identificateur est redéclaré

Source code
function IsRedeclared : Boolean ; virtual

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il est redéclaré, False sinon

Sepi
Class Tree
Index
Previous (GetIdentifier)
Next (IsRedeclaredInCurrentList)


Sepi

Sepi
Previous (IsRedeclared)
Next (MakeErroneousName)

Name
IsRedeclaredInCurrentList

Parent
TSepiIdentifierDeclarationNode

Visibility
PRIVATE

Description
Teste si cet identificateur est redéclaré dans sa liste courante

Source code
function IsRedeclaredInCurrentList : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il est redéclaré, False sinon

Sepi
Class Tree
Index
Previous (IsRedeclared)
Next (MakeErroneousName)


Sepi

Sepi
Previous (IsRedeclaredInCurrentList)
Next (SetIdentifier)

Name
MakeErroneousName

Parent
TSepiIdentifierDeclarationNode

Visibility
PROTECTED

Description
Construit un identificateur erroné

Source code
procedure MakeErroneousName ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (IsRedeclaredInCurrentList)
Next (SetIdentifier)


Sepi

Sepi
Previous (MakeErroneousName)
Next

Name
SetIdentifier

Parent
TSepiIdentifierDeclarationNode

Visibility
PROTECTED

Description
Modifie l'identificateur représenté par ce noeud

Source code
procedure SetIdentifier ( const AIdentifier : string )

Parameters
Parameter | Description
AIdentifier : STRING | Nouvel identificateur

Sepi
Class Tree
Index
Previous (MakeErroneousName)
Next


Sepi

Sepi
Previous (TSepiIdentifierDeclarationNode)
Next (TSepiIdentifierExpressionNode)

Name
TSepiIdentifierDeclListNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant une liste de déclarations d'identificateurs
Tous les enfants d'une instance de TSepiIdentifierDeclListNode doivent être
des instances de TSepiIdentifierDeclarationNode.

Members
Fields
Field | Description
FIdentifierCount (-) | Nombre d'identificateurs

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
GetIdentifierList (+) | Obtient une liste des identificateurs
GetIdentifiers (-) | Tableau zero-based des identificateurs
IsDeclared (+) | Teste si un identificateur donné est déclaré dans cette liste

Properties
Property | Description
IdentifierCount (+) | Nombre d'identificateurs
Identifiers (+) | Tableau zero-based des identificateurs

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIdentifierDeclarationNode)
Next (TSepiIdentifierExpressionNode)


Sepi

Sepi
Previous
Next

Name
FIdentifierCount

Parent
TSepiIdentifierDeclListNode

Visibility
PRIVATE

Description
Nombre d'identificateurs

Source code
FIdentifierCount : Integer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Identifiers)

Name
IdentifierCount

Parent
TSepiIdentifierDeclListNode

Visibility
PUBLIC

Description
Nombre d'identificateurs

Source code
property IdentifierCount : Integer read FIdentifierCount

Read Access
FIdentifierCount

Sepi
Class Tree
Index
Previous
Next (Identifiers)


Sepi

Sepi
Previous (IdentifierCount)
Next

Name
Identifiers

Parent
TSepiIdentifierDeclListNode

Visibility
PUBLIC

Description
Tableau zero-based des identificateurs

Source code
property Identifiers [ Index : Integer ] : string read GetIdentifiers

Read Access
GetIdentifiers

Sepi
Class Tree
Index
Previous (IdentifierCount)
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiIdentifierDeclListNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (GetIdentifierList)

Name
ChildEndParsing

Parent
TSepiIdentifierDeclListNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (GetIdentifierList)


Sepi

Sepi
Previous (ChildEndParsing)
Next (GetIdentifiers)

Name
GetIdentifierList

Parent
TSepiIdentifierDeclListNode

Visibility
PUBLIC

Description
Obtient une liste des identificateurs

Source code
procedure GetIdentifierList ( out IdentifierList : TStringDynArray )

Parameters
Parameter | Description
IdentifierList : TStringDynArray | En sortie : liste des identificateurs

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (GetIdentifiers)


Sepi

Sepi
Previous (GetIdentifierList)
Next (IsDeclared)

Name
GetIdentifiers

Parent
TSepiIdentifierDeclListNode

Visibility
PRIVATE

Description
Tableau zero-based des identificateurs

Source code
function GetIdentifiers ( Index : Integer ) : string

Parameters
Parameter | Description
INDEX : INTEGER | Index d'un identificateur

Return
Types | Description
STRING | L'identificateur à l'index donné

Sepi
Class Tree
Index
Previous (GetIdentifierList)
Next (IsDeclared)


Sepi

Sepi
Previous (GetIdentifiers)
Next

Name
IsDeclared

Parent
TSepiIdentifierDeclListNode

Visibility
PUBLIC

Description
Teste si un identificateur donné est déclaré dans cette liste

Source code
function IsDeclared ( const Identifier : string ) : Boolean ; virtual

Parameters
Parameter | Description
Identifier : STRING | Identificateur à tester

Return
Types | Description
BOOLEAN | True si l'identificateur est déclaré, False sinon

Sepi
Class Tree
Index
Previous (GetIdentifiers)
Next


Sepi

Sepi
Previous (TSepiIdentifierDeclListNode)
Next (TSepiIfThenElseInstructionNode)

Name
TSepiIdentifierExpressionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud représentant un identificateur à résoudre

Members
Methods
Method | Description
CompileIdentifier (#) | Compile l'identificateur dans Expression
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIdentifierDeclListNode)
Next (TSepiIfThenElseInstructionNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
CompileIdentifier

Parent
TSepiIdentifierExpressionNode

Visibility
PROTECTED

Description
Compile l'identificateur dans Expression

Source code
procedure CompileIdentifier ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (CompileIdentifier)
Next

Name
EndParsing

Parent
TSepiIdentifierExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileIdentifier)
Next


Sepi

Sepi
Previous (TSepiIdentifierExpressionNode)
Next (TSepiInheritedExpressionNode)

Name
TSepiIfThenElseInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction if..then..else

Members
Fields
Field | Description
FInstruction (-) | Instruction

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Instruction (+) | Instruction

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIdentifierExpressionNode)
Next (TSepiInheritedExpressionNode)


Sepi

Sepi
Previous
Next

Name
FInstruction

Parent
TSepiIfThenElseInstructionNode

Visibility
PRIVATE

Description
Instruction

Source code
FInstruction : TSepiIfThenElse

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Instruction

Parent
TSepiIfThenElseInstructionNode

Visibility
PUBLIC

Description
Instruction

Source code
property Instruction : TSepiIfThenElse read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiIfThenElseInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiIfThenElseInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (EndParsing)

Name
ChildEndParsing

Parent
TSepiIfThenElseInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
EndParsing

Parent
TSepiIfThenElseInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiIfThenElseInstructionNode)
Next (TSepiInitializationExpressionNode)

Name
TSepiInheritedExpressionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud représentant une expression d'appel inherited

Members
Methods
Method | Description
CompileMethodCall (#) | Compile l'appel inherited comme un wanting-params
EndParsing (+) | [@inheritDoc]
FindMethod (#) | Trouve la méthode héritée à appeler
GetMethodName (#) | Nom de la méthode héritée à appeler
MakeMethodCall (#) | Construit l'appel de la méthode
RequireClassOrObjectMethod (#) | Vérifie qu'on est bien en train de compiler une méthode

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIfThenElseInstructionNode)
Next (TSepiInitializationExpressionNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
CompileMethodCall

Parent
TSepiInheritedExpressionNode

Visibility
PROTECTED

Description
Compile l'appel inherited comme un wanting-params

Source code
function CompileMethodCall : ISepiWantingParams ; virtual

Parameters
Parameter Description

Return
Types | Description
ISepiWantingParams | Appel de méthode inherited (ou nil en cas d'erreur)

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (CompileMethodCall)
Next (FindMethod)

Name
EndParsing

Parent
TSepiInheritedExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileMethodCall)
Next (FindMethod)


Sepi

Sepi
Previous (EndParsing)
Next (GetMethodName)

Name
FindMethod

Parent
TSepiInheritedExpressionNode

Visibility
PROTECTED

Description
Trouve la méthode héritée à appeler

Source code
function FindMethod : TSepiMethodBase ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiMethodBase | Méthode à appeler, ou nil en cas d'erreur

Sepi
Class Tree
Index
Previous (EndParsing)
Next (GetMethodName)


Sepi

Sepi
Previous (FindMethod)
Next (MakeMethodCall)

Name
GetMethodName

Parent
TSepiInheritedExpressionNode

Visibility
PROTECTED

Description
Nom de la méthode héritée à appeler

Source code
function GetMethodName : string ; virtual

Parameters
Parameter Description

Return
Types | Description
STRING | Nom de la méthode héritée à appeler

Sepi
Class Tree
Index
Previous (FindMethod)
Next (MakeMethodCall)


Sepi

Sepi
Previous (GetMethodName)
Next (RequireClassOrObjectMethod)

Name
MakeMethodCall

Parent
TSepiInheritedExpressionNode

Visibility
PROTECTED

Description
Construit l'appel de la méthode

Source code
function MakeMethodCall ( SepiMethod : TSepiMethodBase ; const SelfParam : ISepiReadableValue ) : ISepiWantingParams ; virtual

Parameters
Parameter | Description
SepiMethod : TSepiMethodBase | Méthode à appeler
SelfParam : ISepiReadableValue

Return
Types | Description
ISepiWantingParams | Appel de la méthode, ou nil en cas d'erreur

Sepi
Class Tree
Index
Previous (GetMethodName)
Next (RequireClassOrObjectMethod)


Sepi

Sepi
Previous (MakeMethodCall)
Next

Name
RequireClassOrObjectMethod

Parent
TSepiInheritedExpressionNode

Visibility
PROTECTED

Description
Vérifie qu'on est bien en train de compiler une méthode

Source code
function RequireClassOrObjectMethod : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True en cas de succès, False sinon

Sepi
Class Tree
Index
Previous (MakeMethodCall)
Next


Sepi

Sepi
Previous (TSepiInheritedExpressionNode)
Next (TSepiInSetOperationNode)

Name
TSepiInitializationExpressionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud d'expression d'initialisation
Une expression d'initialisation est une expression constante qui initialise
une valeur connue à la compilation, et dont le type est déjà connu.
Avant son BeginParsing, la méthode SetValueTypeAndPtr doit être appelée pour
spécifier quel est le type de valeur attendu, et où placer le résultat.
Les types acceptés par une instance particulière de
TSepiInitializationExpressionNode peuvent être testés avec IsValidType. Par
défaut, TSepiInitializationExpressionNode accepte tous les types non-nil.

Members
Fields
Field | Description
FOwnsValue (-) | True si possède la valeur dans FValuePtr
FValuePtr (-) | Pointeur sur la valeur à initialiser
FValueType (-) | Type de valeur

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
IsValidType (+) | Teste si un type est valide pour cet initialiseur
SetValueTypeAndPtr (+) | Indique le type de valeur attendu, et où stocker le résultat

Properties
Property | Description
ValuePtr (+) | Pointeur sur la valeur à initialiser
ValueType (+) | Type de valeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInheritedExpressionNode)
Next (TSepiInSetOperationNode)


Sepi

Sepi
Previous
Next (FValuePtr)

Name
FOwnsValue

Parent
TSepiInitializationExpressionNode

Visibility
PRIVATE

Description
True si possède la valeur dans FValuePtr

Source code
FOwnsValue : Boolean

Sepi
Class Tree
Index
Previous
Next (FValuePtr)


Sepi

Sepi
Previous (FOwnsValue)
Next (FValueType)

Name
FValuePtr

Parent
TSepiInitializationExpressionNode

Visibility
PRIVATE

Description
Pointeur sur la valeur à initialiser

Source code
FValuePtr : Pointer

Sepi
Class Tree
Index
Previous (FOwnsValue)
Next (FValueType)


Sepi

Sepi
Previous (FValuePtr)
Next

Name
FValueType

Parent
TSepiInitializationExpressionNode

Visibility
PRIVATE

Description
Type de valeur

Source code
FValueType : TSepiType

Sepi
Class Tree
Index
Previous (FValuePtr)
Next


Sepi

Sepi
Previous
Next (ValueType)

Name
ValuePtr

Parent
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Pointeur sur la valeur à initialiser

Source code
property ValuePtr : Pointer read FValuePtr

Read Access
FValuePtr

Sepi
Class Tree
Index
Previous
Next (ValueType)


Sepi

Sepi
Previous (ValuePtr)
Next

Name
ValueType

Parent
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Type de valeur

Source code
property ValueType : TSepiType read FValueType

Read Access
FValueType

Sepi
Class Tree
Index
Previous (ValuePtr)
Next


Sepi

Sepi
Previous
Next (Destroy)

Name
BeginParsing

Parent
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Destroy)


Sepi

Sepi
Previous (BeginParsing)
Next (IsValidType)

Name
Destroy

Parent
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (IsValidType)


Sepi

Sepi
Previous (Destroy)
Next (SetValueTypeAndPtr)

Name
IsValidType

Parent
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Teste si un type est valide pour cet initialiseur

Source code
function IsValidType ( AValueType : TSepiType ) : Boolean ; virtual

Parameters
Parameter | Description
AValueType : TSepiType | Type à tester

Return
Types | Description
BOOLEAN | True si le type est valide, False sinon

Sepi
Class Tree
Index
Previous (Destroy)
Next (SetValueTypeAndPtr)


Sepi

Sepi
Previous (IsValidType)
Next

Name
SetValueTypeAndPtr

Parent
TSepiInitializationExpressionNode

Visibility
PUBLIC

Description
Indique le type de valeur attendu, et où stocker le résultat
Si AValuePtr vaut nil, une nouvelle valeur du type AValueType sera créée, et
libérée à la destruction de cet objet.
Cette méthode doit être appelée exactement une fois, avant BeginParsing.

Source code
procedure SetValueTypeAndPtr ( AValueType : TSepiType ; AValuePtr : Pointer = nil )

Parameters
Parameter | Description
AValueType : TSepiType | Type de valeur attendu (doit être valide)
AValuePtr : Pointer | Pointeur où stocker le résultat (peut être nil)

Sepi
Class Tree
Index
Previous (IsValidType)
Next


Sepi

Sepi
Previous (TSepiInitializationExpressionNode)
Next (TSepiInstructionListNode)

Name
TSepiInSetOperationNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiBinaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur in

Members
Methods
Method | Description
GetPriority (#) | [@inheritDoc]
MakeOperation (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInitializationExpressionNode)
Next (TSepiInstructionListNode)


Sepi

Sepi
Previous
Next (MakeOperation)

Name
GetPriority

Parent
TSepiInSetOperationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetPriority : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (MakeOperation)


Sepi

Sepi
Previous (GetPriority)
Next

Name
MakeOperation

Parent
TSepiInSetOperationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Left , Right : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Left : ISepiExpression | #Pas de TAG trouvé dans le code source#
Right : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetPriority)
Next


Sepi

Sepi
Previous (TSepiInSetOperationNode)
Next (TSepiInstructionNode)

Name
TSepiInstructionListNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Liste d'instructions

Members
Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInSetOperationNode)
Next (TSepiInstructionNode)


Sepi

Sepi
Previous
Next

Name
ChildBeginParsing

Parent
TSepiInstructionListNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiInstructionListNode)
Next (TSepiIntfMethodRedirectorNode)

Name
TSepiInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Classe de base pour les noeuds instruction

Members
Fields
Field | Description
FInstructionList (-) | Liste d'instructions contenante

Properties
Property | Description
InstructionList (+) | Liste d'instructions contenante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInstructionListNode)
Next (TSepiIntfMethodRedirectorNode)


Sepi

Sepi
Previous
Next

Name
FInstructionList

Parent
TSepiInstructionNode

Visibility
PRIVATE

Description
Liste d'instructions contenante

Source code
FInstructionList : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
InstructionList

Parent
TSepiInstructionNode

Visibility
PUBLIC

Description
Liste d'instructions contenante

Source code
property InstructionList : TSepiInstructionList read FInstructionList write FInstructionList

Read Access
FInstructionList

Write Access
FInstructionList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiInstructionNode)
Next (TSepiIsOperationNode)

Name
TSepiIntfMethodRedirectorNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud redirecteur de méthode d'interface
Ce type de noeud doit toujours avoir en contexte une classe

Members
Fields
Field | Description
FSepiClass (-) | Classe englobante

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
CompileInterface (#) | Compile l'interface concernée
CompileIntfMethod (#) | Compile la méthode d'interface à rediriger
CompileMethodRedirector (#) | Compile le redirecteur
EndParsing (+) | [@inheritDoc]
GetRedirectorName (#) | Nom de la méthode destination

Properties
Property | Description
SepiClass (#) | Classe englobante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiInstructionNode)
Next (TSepiIsOperationNode)


Sepi

Sepi
Previous
Next

Name
FSepiClass

Parent
TSepiIntfMethodRedirectorNode

Visibility
PRIVATE

Description
Classe englobante

Source code
FSepiClass : TSepiClass

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SepiClass

Parent
TSepiIntfMethodRedirectorNode

Visibility
PROTECTED

Description
Classe englobante

Source code
property SepiClass : TSepiClass read FSepiClass

Read Access
FSepiClass

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileInterface)

Name
BeginParsing

Parent
TSepiIntfMethodRedirectorNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileInterface)


Sepi

Sepi
Previous (BeginParsing)
Next (CompileIntfMethod)

Name
CompileInterface

Parent
TSepiIntfMethodRedirectorNode

Visibility
PROTECTED

Description
Compile l'interface concernée

Source code
function CompileInterface : TSepiInterface ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiInterface | Interface concernée

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (CompileIntfMethod)


Sepi

Sepi
Previous (CompileInterface)
Next (CompileMethodRedirector)

Name
CompileIntfMethod

Parent
TSepiIntfMethodRedirectorNode

Visibility
PROTECTED

Description
Compile la méthode d'interface à rediriger

Source code
function CompileIntfMethod ( SepiIntf : TSepiInterface ) : TSepiMethod ; virtual

Parameters
Parameter | Description
SepiIntf : TSepiInterface | #Pas de TAG trouvé dans le code source#

Return
Types | Description
TSepiMethod | Méthode d'interface à rediriger

Sepi
Class Tree
Index
Previous (CompileInterface)
Next (CompileMethodRedirector)


Sepi

Sepi
Previous (CompileIntfMethod)
Next (EndParsing)

Name
CompileMethodRedirector

Parent
TSepiIntfMethodRedirectorNode

Visibility
PROTECTED

Description
Compile le redirecteur

Source code
procedure CompileMethodRedirector ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileIntfMethod)
Next (EndParsing)


Sepi

Sepi
Previous (CompileMethodRedirector)
Next (GetRedirectorName)

Name
EndParsing

Parent
TSepiIntfMethodRedirectorNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileMethodRedirector)
Next (GetRedirectorName)


Sepi

Sepi
Previous (EndParsing)
Next

Name
GetRedirectorName

Parent
TSepiIntfMethodRedirectorNode

Visibility
PROTECTED

Description
Nom de la méthode destination

Source code
function GetRedirectorName : string ; virtual

Parameters
Parameter Description

Return
Types | Description
STRING | Nom de la méthode destination

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiIntfMethodRedirectorNode)
Next (TSepiLiteralConstNode)

Name
TSepiIsOperationNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiBinaryOpNode

Visibility
PUBLIC

Description
Noeud représentant un opérateur is

Members
Methods
Method | Description
GetPriority (#) | [@inheritDoc]
MakeOperation (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIntfMethodRedirectorNode)
Next (TSepiLiteralConstNode)


Sepi

Sepi
Previous
Next (MakeOperation)

Name
GetPriority

Parent
TSepiIsOperationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetPriority : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (MakeOperation)


Sepi

Sepi
Previous (GetPriority)
Next

Name
MakeOperation

Parent
TSepiIsOperationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function MakeOperation ( const Left , Right : ISepiExpression ) : ISepiExpression ; override

Parameters
Parameter | Description
Left : ISepiExpression | #Pas de TAG trouvé dans le code source#
Right : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetPriority)
Next


Sepi

Sepi
Previous (TSepiIsOperationNode)
Next (TSepiLocalVarNameNode)

Name
TSepiLiteralConstNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud représentant une constante littérale

Members
Methods
Method | Description
CompileAsValue (#) | #No TAG found in source code#
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiIsOperationNode)
Next (TSepiLocalVarNameNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
CompileAsValue

Parent
TSepiLiteralConstNode

Visibility
PROTECTED

Description
#Pas de TAG trouvé dans le code source#

Source code
function CompileAsValue : ISepiValue ; virtual ; abstract

Parameters
Parameter Description

Return
Types | Description
ISepiValue | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (CompileAsValue)
Next

Name
EndParsing

Parent
TSepiLiteralConstNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileAsValue)
Next


Sepi

Sepi
Previous (TSepiLiteralConstNode)
Next (TSepiLocalVarNode)

Name
TSepiLocalVarNameNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant le nom d'une variable locale à rechercher

Members
Fields
Field | Description
FLocalVar (-) | Variable locale

Methods
Method | Description
CompileLocalVar (#) | Compile la variable locale
EndParsing (+) | [@inheritDoc]
GetLocalVarName (#) | Nom de la variable locale
MakeErroneousLocalVar (#) | Construit une variable erronée
SetLocalVar (#) | Modifie la variable locale

Properties
Property | Description
LocalVar (+) | Variable locale
LocalVarName (+) | Nom de la variable locale

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLiteralConstNode)
Next (TSepiLocalVarNode)


Sepi

Sepi
Previous
Next

Name
FLocalVar

Parent
TSepiLocalVarNameNode

Visibility
PRIVATE

Description
Variable locale

Source code
FLocalVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (LocalVarName)

Name
LocalVar

Parent
TSepiLocalVarNameNode

Visibility
PUBLIC

Description
Variable locale

Source code
property LocalVar : TSepiLocalVar read FLocalVar

Read Access
FLocalVar

Sepi
Class Tree
Index
Previous
Next (LocalVarName)


Sepi

Sepi
Previous (LocalVar)
Next

Name
LocalVarName

Parent
TSepiLocalVarNameNode

Visibility
PUBLIC

Description
Nom de la variable locale

Source code
property LocalVarName : string read GetLocalVarName

Read Access
GetLocalVarName

Sepi
Class Tree
Index
Previous (LocalVar)
Next


Sepi

Sepi
Previous
Next (EndParsing)

Name
CompileLocalVar

Parent
TSepiLocalVarNameNode

Visibility
PROTECTED

Description
Compile la variable locale

Source code
function CompileLocalVar : TSepiLocalVar ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiLocalVar | Variable locale

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (CompileLocalVar)
Next (GetLocalVarName)

Name
EndParsing

Parent
TSepiLocalVarNameNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileLocalVar)
Next (GetLocalVarName)


Sepi

Sepi
Previous (EndParsing)
Next (MakeErroneousLocalVar)

Name
GetLocalVarName

Parent
TSepiLocalVarNameNode

Visibility
PROTECTED

Description
Nom de la variable locale

Source code
function GetLocalVarName : string ; virtual

Parameters
Parameter Description

Return
Types | Description
STRING | Nom de la variable locale

Sepi
Class Tree
Index
Previous (EndParsing)
Next (MakeErroneousLocalVar)


Sepi

Sepi
Previous (GetLocalVarName)
Next (SetLocalVar)

Name
MakeErroneousLocalVar

Parent
TSepiLocalVarNameNode

Visibility
PROTECTED

Description
Construit une variable erronée

Source code
procedure MakeErroneousLocalVar ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetLocalVarName)
Next (SetLocalVar)


Sepi

Sepi
Previous (MakeErroneousLocalVar)
Next

Name
SetLocalVar

Parent
TSepiLocalVarNameNode

Visibility
PROTECTED

Description
Modifie la variable locale

Source code
procedure SetLocalVar ( ALocalVar : TSepiLocalVar )

Parameters
Parameter | Description
ALocalVar : TSepiLocalVar | Variable locale

Sepi
Class Tree
Index
Previous (MakeErroneousLocalVar)
Next


Sepi

Sepi
Previous (TSepiLocalVarNameNode)
Next (TSepiMaybeIdentAndTypeNode)

Name
TSepiLocalVarNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud déclaration de variable locale

Members
Fields
Field | Description
FNamesNode (-) | Noeud des noms de variables
FVarType (-) | Type des variables

Methods
Method | Description
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
NamesNode (#) | Noeud des noms de variables
VarType (#) | Type des variables

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLocalVarNameNode)
Next (TSepiMaybeIdentAndTypeNode)


Sepi

Sepi
Previous
Next (FVarType)

Name
FNamesNode

Parent
TSepiLocalVarNode

Visibility
PRIVATE

Description
Noeud des noms de variables

Source code
FNamesNode : TSepiIdentifierDeclListNode

Sepi
Class Tree
Index
Previous
Next (FVarType)


Sepi

Sepi
Previous (FNamesNode)
Next

Name
FVarType

Parent
TSepiLocalVarNode

Visibility
PRIVATE

Description
Type des variables

Source code
FVarType : TSepiType

Sepi
Class Tree
Index
Previous (FNamesNode)
Next


Sepi

Sepi
Previous
Next (VarType)

Name
NamesNode

Parent
TSepiLocalVarNode

Visibility
PROTECTED

Description
Noeud des noms de variables

Source code
property NamesNode : TSepiIdentifierDeclListNode read FNamesNode

Read Access
FNamesNode

Sepi
Class Tree
Index
Previous
Next (VarType)


Sepi

Sepi
Previous (NamesNode)
Next

Name
VarType

Parent
TSepiLocalVarNode

Visibility
PROTECTED

Description
Type des variables

Source code
property VarType : TSepiType read FVarType

Read Access
FVarType

Sepi
Class Tree
Index
Previous (NamesNode)
Next


Sepi

Sepi
Previous
Next (EndParsing)

Name
ChildEndParsing

Parent
TSepiLocalVarNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
EndParsing

Parent
TSepiLocalVarNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiLocalVarNode)
Next (TSepiMethodBodyNode)

Name
TSepiMaybeIdentAndTypeNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiTypeNode

Visibility
PUBLIC

Description
Noeud avec éventuellement un identificateur, mais toujours un type

Members
Fields
Field | Description
FIdentifier (-) | Identificateur (peut être '')

Methods
Method | Description
CompileIdentifier (#) | Compile le noeud identificateur
CompileType (#) | Compile le noeud type
EndParsing (+) | [@inheritDoc]
SetIdentifier (#) | Modifie l'identificateur

Properties
Property | Description
Identifier (+) | Identificateur (peut être '')

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiLocalVarNode)
Next (TSepiMethodBodyNode)


Sepi

Sepi
Previous
Next

Name
FIdentifier

Parent
TSepiMaybeIdentAndTypeNode

Visibility
PRIVATE

Description
Identificateur (peut être '')

Source code
FIdentifier : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Identifier

Parent
TSepiMaybeIdentAndTypeNode

Visibility
PUBLIC

Description
Identificateur (peut être '')

Source code
property Identifier : string read FIdentifier

Read Access
FIdentifier

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (CompileType)

Name
CompileIdentifier

Parent
TSepiMaybeIdentAndTypeNode

Visibility
PROTECTED

Description
Compile le noeud identificateur

Source code
procedure CompileIdentifier ( Child : TSepiParseTreeNode ) ; virtual

Parameters
Parameter | Description
Child : TSepiParseTreeNode | Noeud identificateur

Sepi
Class Tree
Index
Previous
Next (CompileType)


Sepi

Sepi
Previous (CompileIdentifier)
Next (EndParsing)

Name
CompileType

Parent
TSepiMaybeIdentAndTypeNode

Visibility
PROTECTED

Description
Compile le noeud type

Source code
procedure CompileType ( Child : TSepiParseTreeNode ) ; virtual

Parameters
Parameter | Description
Child : TSepiParseTreeNode | Noeud type

Sepi
Class Tree
Index
Previous (CompileIdentifier)
Next (EndParsing)


Sepi

Sepi
Previous (CompileType)
Next (SetIdentifier)

Name
EndParsing

Parent
TSepiMaybeIdentAndTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileType)
Next (SetIdentifier)


Sepi

Sepi
Previous (EndParsing)
Next

Name
SetIdentifier

Parent
TSepiMaybeIdentAndTypeNode

Visibility
PROTECTED

Description
Modifie l'identificateur

Source code
procedure SetIdentifier ( const AIdentifier : string )

Parameters
Parameter | Description
AIdentifier : STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiMaybeIdentAndTypeNode)
Next (TSepiMethodDeclarationNode)

Name
TSepiMethodBodyNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud du corps d'une méthode

Members
Fields
Field | Description
FCompiler (-) | Compilateur de la méthode
FSepiMethod (-) | Méthode Sepi implémentée dans ce corps

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]
GetMethodCompiler (#) | [@inheritDoc]
GetSepiContext (#) | [@inheritDoc]
ResolveIdent (+) | [@inheritDoc]
SetSepiMethod (+) | Spécifie la méthode Sepi dont le corps est compilé dans ce noeud

Properties
Property | Description
SepiMethod (+) | Méthode Sepi implémentée dans ce corps

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMaybeIdentAndTypeNode)
Next (TSepiMethodDeclarationNode)


Sepi

Sepi
Previous
Next (FSepiMethod)

Name
FCompiler

Parent
TSepiMethodBodyNode

Visibility
PRIVATE

Description
Compilateur de la méthode

Source code
FCompiler : TSepiMethodCompiler

Sepi
Class Tree
Index
Previous
Next (FSepiMethod)


Sepi

Sepi
Previous (FCompiler)
Next

Name
FSepiMethod

Parent
TSepiMethodBodyNode

Visibility
PRIVATE

Description
Méthode Sepi implémentée dans ce corps

Source code
FSepiMethod : TSepiMethod

Sepi
Class Tree
Index
Previous (FCompiler)
Next


Sepi

Sepi
Previous
Next

Name
SepiMethod

Parent
TSepiMethodBodyNode

Visibility
PUBLIC

Description
Méthode Sepi implémentée dans ce corps

Source code
property SepiMethod : TSepiMethod read FSepiMethod

Read Access
FSepiMethod

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (EndParsing)

Name
ChildBeginParsing

Parent
TSepiMethodBodyNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (GetMethodCompiler)

Name
EndParsing

Parent
TSepiMethodBodyNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (GetMethodCompiler)


Sepi

Sepi
Previous (EndParsing)
Next (GetSepiContext)

Name
GetMethodCompiler

Parent
TSepiMethodBodyNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetMethodCompiler : TSepiMethodCompiler ; override

Parameters
Parameter Description

Return
Types | Description
TSepiMethodCompiler | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (EndParsing)
Next (GetSepiContext)


Sepi

Sepi
Previous (GetMethodCompiler)
Next (ResolveIdent)

Name
GetSepiContext

Parent
TSepiMethodBodyNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetSepiContext : TSepiComponent ; override

Parameters
Parameter Description

Return
Types | Description
TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetMethodCompiler)
Next (ResolveIdent)


Sepi

Sepi
Previous (GetSepiContext)
Next (SetSepiMethod)

Name
ResolveIdent

Parent
TSepiMethodBodyNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetSepiContext)
Next (SetSepiMethod)


Sepi

Sepi
Previous (ResolveIdent)
Next

Name
SetSepiMethod

Parent
TSepiMethodBodyNode

Visibility
PUBLIC

Description
Spécifie la méthode Sepi dont le corps est compilé dans ce noeud
Cette méthode doit être appelée une fois avant BeginParsing.

Source code
procedure SetSepiMethod ( ASepiMethod : TSepiMethod )

Parameters
Parameter | Description
ASepiMethod : TSepiMethod | Méthode à compiler

Sepi
Class Tree
Index
Previous (ResolveIdent)
Next


Sepi

Sepi
Previous (TSepiMethodBodyNode)
Next (TSepiMethodImplementationNode)

Name
TSepiMethodDeclarationNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud déclaration de méthode

Members
Fields
Field | Description
FAbstract (-) | Indique si la méthode est abstraite
FIsOverloaded (-) | True si surchargée
FLinkKind (-) | Type de liaison
FMsgID (-) | Message intercepté
FName (-) | Nom de la méthode
FSignature (-) | Signature

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
IsAbstract (+) | Indique si la méthode est abstraite
IsOverloaded (+) | True si surchargée
LinkKind (+) | Type de liaison
MsgID (+) | Message intercepté
NAME (+) | Nom de la méthode
Signature (+) | Signature

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodBodyNode)
Next (TSepiMethodImplementationNode)


Sepi

Sepi
Previous
Next (FIsOverloaded)

Name
FAbstract

Parent
TSepiMethodDeclarationNode

Visibility
PRIVATE

Description
Indique si la méthode est abstraite

Source code
FAbstract : Boolean

Sepi
Class Tree
Index
Previous
Next (FIsOverloaded)


Sepi

Sepi
Previous (FAbstract)
Next (FLinkKind)

Name
FIsOverloaded

Parent
TSepiMethodDeclarationNode

Visibility
PRIVATE

Description
True si surchargée

Source code
FIsOverloaded : Boolean

Sepi
Class Tree
Index
Previous (FAbstract)
Next (FLinkKind)


Sepi

Sepi
Previous (FIsOverloaded)
Next (FMsgID)

Name
FLinkKind

Parent
TSepiMethodDeclarationNode

Visibility
PRIVATE

Description
Type de liaison

Source code
FLinkKind : TMethodLinkKind

Sepi
Class Tree
Index
Previous (FIsOverloaded)
Next (FMsgID)


Sepi

Sepi
Previous (FLinkKind)
Next (FName)

Name
FMsgID

Parent
TSepiMethodDeclarationNode

Visibility
PRIVATE

Description
Message intercepté

Source code
FMsgID : Integer

Sepi
Class Tree
Index
Previous (FLinkKind)
Next (FName)


Sepi

Sepi
Previous (FMsgID)
Next (FSignature)

Name
FName

Parent
TSepiMethodDeclarationNode

Visibility
PRIVATE

Description
Nom de la méthode

Source code
FName : string

Sepi
Class Tree
Index
Previous (FMsgID)
Next (FSignature)


Sepi

Sepi
Previous (FName)
Next

Name
FSignature

Parent
TSepiMethodDeclarationNode

Visibility
PRIVATE

Description
Signature

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous (FName)
Next


Sepi

Sepi
Previous
Next (IsOverloaded)

Name
IsAbstract

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
Indique si la méthode est abstraite

Source code
property IsAbstract : Boolean read FAbstract

Read Access
FAbstract

Sepi
Class Tree
Index
Previous
Next (IsOverloaded)


Sepi

Sepi
Previous (IsAbstract)
Next (LinkKind)

Name
IsOverloaded

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
True si surchargée

Source code
property IsOverloaded : Boolean read FIsOverloaded

Read Access
FIsOverloaded

Sepi
Class Tree
Index
Previous (IsAbstract)
Next (LinkKind)


Sepi

Sepi
Previous (IsOverloaded)
Next (MsgID)

Name
LinkKind

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
Type de liaison

Source code
property LinkKind : TMethodLinkKind read FLinkKind

Read Access
FLinkKind

Sepi
Class Tree
Index
Previous (IsOverloaded)
Next (MsgID)


Sepi

Sepi
Previous (LinkKind)
Next (NAME)

Name
MsgID

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
Message intercepté

Source code
property MsgID : Integer read FMsgID

Read Access
FMsgID

Sepi
Class Tree
Index
Previous (LinkKind)
Next (NAME)


Sepi

Sepi
Previous (MsgID)
Next (Signature)

Name
NAME

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
Nom de la méthode

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (MsgID)
Next (Signature)


Sepi

Sepi
Previous (NAME)
Next

Name
Signature

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
Signature

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous (NAME)
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiMethodDeclarationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (Destroy)

Name
ChildEndParsing

Parent
TSepiMethodDeclarationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (Destroy)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
Destroy

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (Destroy)
Next

Name
EndParsing

Parent
TSepiMethodDeclarationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (TSepiMethodDeclarationNode)
Next (TSepiMethodImplHeaderNode)

Name
TSepiMethodImplementationNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud méthode dans l'implémentation

Members
Fields
Field | Description
FJustDeclared (-) | Indique si déclaré dans ce noeud
FSepiMethod (-) | Méthode correspondante

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]

Properties
Property | Description
JustDeclared (+) | Indique si déclaré dans ce noeud
SepiMethod (+) | Méthode correspondante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodDeclarationNode)
Next (TSepiMethodImplHeaderNode)


Sepi

Sepi
Previous
Next (FSepiMethod)

Name
FJustDeclared

Parent
TSepiMethodImplementationNode

Visibility
PRIVATE

Description
Indique si déclaré dans ce noeud

Source code
FJustDeclared : Boolean

Sepi
Class Tree
Index
Previous
Next (FSepiMethod)


Sepi

Sepi
Previous (FJustDeclared)
Next

Name
FSepiMethod

Parent
TSepiMethodImplementationNode

Visibility
PRIVATE

Description
Méthode correspondante

Source code
FSepiMethod : TSepiMethod

Sepi
Class Tree
Index
Previous (FJustDeclared)
Next


Sepi

Sepi
Previous
Next (SepiMethod)

Name
JustDeclared

Parent
TSepiMethodImplementationNode

Visibility
PUBLIC

Description
Indique si déclaré dans ce noeud

Source code
property JustDeclared : Boolean read FJustDeclared

Read Access
FJustDeclared

Sepi
Class Tree
Index
Previous
Next (SepiMethod)


Sepi

Sepi
Previous (JustDeclared)
Next

Name
SepiMethod

Parent
TSepiMethodImplementationNode

Visibility
PUBLIC

Description
Méthode correspondante

Source code
property SepiMethod : TSepiMethod read FSepiMethod

Read Access
FSepiMethod

Sepi
Class Tree
Index
Previous (JustDeclared)
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiMethodImplementationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
ChildEndParsing

Parent
TSepiMethodImplementationNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TSepiMethodImplementationNode)
Next (TSepiMethodLinkKindNode)

Name
TSepiMethodImplHeaderNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud signature dans l'implémentation

Members
Fields
Field | Description
FIsOverloaded (-) | True si surchargée
FJustDeclared (-) | True si la méthode a été déclarée par ce noeud
FName (-) | Nom de la routine
FOverloaded (-) | Méthode surchargée correspondante
FSepiMethod (-) | Méthode Sepi
FSignature (-) | Signature

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
DeclareMethod (#) | Déclare la méthode (si autorisé)
Destroy (+) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
IsOverloaded (#) | True si surchargée
JustDeclared (+) | True si la méthode a été déclarée par ce noeud
NAME (#) | Nom de la routine
Overloaded (#) | Méthode surchargée correspondante
SepiMethod (+) | Méthode Sepi
Signature (#) | Signature

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodImplementationNode)
Next (TSepiMethodLinkKindNode)


Sepi

Sepi
Previous
Next (FJustDeclared)

Name
FIsOverloaded

Parent
TSepiMethodImplHeaderNode

Visibility
PRIVATE

Description
True si surchargée

Source code
FIsOverloaded : Boolean

Sepi
Class Tree
Index
Previous
Next (FJustDeclared)


Sepi

Sepi
Previous (FIsOverloaded)
Next (FName)

Name
FJustDeclared

Parent
TSepiMethodImplHeaderNode

Visibility
PRIVATE

Description
True si la méthode a été déclarée par ce noeud

Source code
FJustDeclared : Boolean

Sepi
Class Tree
Index
Previous (FIsOverloaded)
Next (FName)


Sepi

Sepi
Previous (FJustDeclared)
Next (FOverloaded)

Name
FName

Parent
TSepiMethodImplHeaderNode

Visibility
PRIVATE

Description
Nom de la routine

Source code
FName : string

Sepi
Class Tree
Index
Previous (FJustDeclared)
Next (FOverloaded)


Sepi

Sepi
Previous (FName)
Next (FSepiMethod)

Name
FOverloaded

Parent
TSepiMethodImplHeaderNode

Visibility
PRIVATE

Description
Méthode surchargée correspondante

Source code
FOverloaded : TSepiOverloadedMethod

Sepi
Class Tree
Index
Previous (FName)
Next (FSepiMethod)


Sepi

Sepi
Previous (FOverloaded)
Next (FSignature)

Name
FSepiMethod

Parent
TSepiMethodImplHeaderNode

Visibility
PRIVATE

Description
Méthode Sepi

Source code
FSepiMethod : TSepiMethod

Sepi
Class Tree
Index
Previous (FOverloaded)
Next (FSignature)


Sepi

Sepi
Previous (FSepiMethod)
Next

Name
FSignature

Parent
TSepiMethodImplHeaderNode

Visibility
PRIVATE

Description
Signature

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous (FSepiMethod)
Next


Sepi

Sepi
Previous
Next (JustDeclared)

Name
IsOverloaded

Parent
TSepiMethodImplHeaderNode

Visibility
PROTECTED

Description
True si surchargée

Source code
property IsOverloaded : Boolean read FIsOverloaded

Read Access
FIsOverloaded

Sepi
Class Tree
Index
Previous
Next (JustDeclared)


Sepi

Sepi
Previous (IsOverloaded)
Next (NAME)

Name
JustDeclared

Parent
TSepiMethodImplHeaderNode

Visibility
PUBLIC

Description
True si la méthode a été déclarée par ce noeud

Source code
property JustDeclared : Boolean read FJustDeclared

Read Access
FJustDeclared

Sepi
Class Tree
Index
Previous (IsOverloaded)
Next (NAME)


Sepi

Sepi
Previous (JustDeclared)
Next (Overloaded)

Name
NAME

Parent
TSepiMethodImplHeaderNode

Visibility
PROTECTED

Description
Nom de la routine

Source code
property Name : string read FName

Read Access
FName

Sepi
Class Tree
Index
Previous (JustDeclared)
Next (Overloaded)


Sepi

Sepi
Previous (NAME)
Next (SepiMethod)

Name
Overloaded

Parent
TSepiMethodImplHeaderNode

Visibility
PROTECTED

Description
Méthode surchargée correspondante

Source code
property Overloaded : TSepiOverloadedMethod read FOverloaded

Read Access
FOverloaded

Sepi
Class Tree
Index
Previous (NAME)
Next (SepiMethod)


Sepi

Sepi
Previous (Overloaded)
Next (Signature)

Name
SepiMethod

Parent
TSepiMethodImplHeaderNode

Visibility
PUBLIC

Description
Méthode Sepi

Source code
property SepiMethod : TSepiMethod read FSepiMethod

Read Access
FSepiMethod

Sepi
Class Tree
Index
Previous (Overloaded)
Next (Signature)


Sepi

Sepi
Previous (SepiMethod)
Next

Name
Signature

Parent
TSepiMethodImplHeaderNode

Visibility
PROTECTED

Description
Signature

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous (SepiMethod)
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiMethodImplHeaderNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiMethodImplHeaderNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (DeclareMethod)

Name
ChildEndParsing

Parent
TSepiMethodImplHeaderNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (DeclareMethod)


Sepi

Sepi
Previous (ChildEndParsing)
Next (Destroy)

Name
DeclareMethod

Parent
TSepiMethodImplHeaderNode

Visibility
PROTECTED

Description
Déclare la méthode (si autorisé)

Source code
procedure DeclareMethod ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (Destroy)


Sepi

Sepi
Previous (DeclareMethod)
Next (EndParsing)

Name
Destroy

Parent
TSepiMethodImplHeaderNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (DeclareMethod)
Next (EndParsing)


Sepi

Sepi
Previous (Destroy)
Next

Name
EndParsing

Parent
TSepiMethodImplHeaderNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (TSepiMethodImplHeaderNode)
Next (TSepiMultiOnElseClauseNode)

Name
TSepiMethodLinkKindNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant le type de liaison d'une méthode

Members
Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
GetLinkKind (#) | Type de liaison
GetMessageID (#) | ID du message intercepté

Properties
Property | Description
LinkKind (+) | Type de liaison
MessageID (+) | ID du message intercepté

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodImplHeaderNode)
Next (TSepiMultiOnElseClauseNode)


Sepi

Sepi
Previous
Next (MessageID)

Name
LinkKind

Parent
TSepiMethodLinkKindNode

Visibility
PUBLIC

Description
Type de liaison

Source code
property LinkKind : TMethodLinkKind read GetLinkKind

Read Access
GetLinkKind

Sepi
Class Tree
Index
Previous
Next (MessageID)


Sepi

Sepi
Previous (LinkKind)
Next

Name
MessageID

Parent
TSepiMethodLinkKindNode

Visibility
PUBLIC

Description
ID du message intercepté

Source code
property MessageID : Integer read GetMessageID

Read Access
GetMessageID

Sepi
Class Tree
Index
Previous (LinkKind)
Next


Sepi

Sepi
Previous
Next (GetLinkKind)

Name
ChildBeginParsing

Parent
TSepiMethodLinkKindNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (GetLinkKind)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (GetMessageID)

Name
GetLinkKind

Parent
TSepiMethodLinkKindNode

Visibility
PROTECTED

Description
Type de liaison

Source code
function GetLinkKind : TMethodLinkKind ; virtual

Parameters
Parameter Description

Return
Types | Description
TMethodLinkKind | Type de liaison

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (GetMessageID)


Sepi

Sepi
Previous (GetLinkKind)
Next

Name
GetMessageID

Parent
TSepiMethodLinkKindNode

Visibility
PROTECTED

Description
ID du message intercepté

Source code
function GetMessageID : Integer ; virtual

Parameters
Parameter Description

Return
Types | Description
INTEGER | ID du message intercepté

Sepi
Class Tree
Index
Previous (GetLinkKind)
Next


Sepi

Sepi
Previous (TSepiMethodLinkKindNode)
Next (TSepiMultiOnNode)

Name
TSepiMultiOnElseClauseNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionListNode

Visibility
PUBLIC

Description
Clause else d'un multi-on

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMethodLinkKindNode)
Next (TSepiMultiOnNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiMultiOnElseClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiMultiOnElseClauseNode)
Next (TSepiNilValueNode)

Name
TSepiMultiOnNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction multi-on (valide uniquement dans un except)

Members
Fields
Field | Description
FInstruction (-) | Instruction

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Instruction (+) | Instruction

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMultiOnElseClauseNode)
Next (TSepiNilValueNode)


Sepi

Sepi
Previous
Next

Name
FInstruction

Parent
TSepiMultiOnNode

Visibility
PRIVATE

Description
Instruction

Source code
FInstruction : TSepiMultiOn

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Instruction

Parent
TSepiMultiOnNode

Visibility
PUBLIC

Description
Instruction

Source code
property Instruction : TSepiMultiOn read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiMultiOnNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (EndParsing)

Name
ChildBeginParsing

Parent
TSepiMultiOnNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
EndParsing

Parent
TSepiMultiOnNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TSepiMultiOnNode)
Next (TSepiNoInstructionNode)

Name
TSepiNilValueNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud représentant la valeur spéciale nil

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiMultiOnNode)
Next (TSepiNoInstructionNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiNilValueNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiNilValueNode)
Next (TSepiOnClauseNode)

Name
TSepiNoInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Noeud "pas d'instruction"

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiNilValueNode)
Next (TSepiOnClauseNode)


Sepi

Sepi
Previous (TSepiNoInstructionNode)
Next (TSepiOverloadMarkerNode)

Name
TSepiOnClauseNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Clause on d'un multi-on
Le parent d'un noeud de ce type doit toujours être une instance de
TSepiMultiOnNode.

Members
Fields
Field | Description
FExceptObjectClass (-) | Classe d'exception capturée
FExceptObjectVar (-) | Variable objet exception du bon type
FExceptObjectVarName (-) | Nom de la variable objet exception
FInstruction (-) | Instruction multi-on contenante

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
ResolveIdent (+) | [@inheritDoc]

Properties
Property | Description
ExceptObjectClass (+) | Classe d'exception capturée
ExceptObjectVar (+) | Variable objet exception du bon type
ExceptObjectVarName (+) | Nom de la variable objet exception
Instruction (+) | Instruction multi-on contenante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiNoInstructionNode)
Next (TSepiOverloadMarkerNode)


Sepi

Sepi
Previous
Next (FExceptObjectVar)

Name
FExceptObjectClass

Parent
TSepiOnClauseNode

Visibility
PRIVATE

Description
Classe d'exception capturée

Source code
FExceptObjectClass : TSepiClass

Sepi
Class Tree
Index
Previous
Next (FExceptObjectVar)


Sepi

Sepi
Previous (FExceptObjectClass)
Next (FExceptObjectVarName)

Name
FExceptObjectVar

Parent
TSepiOnClauseNode

Visibility
PRIVATE

Description
Variable objet exception du bon type

Source code
FExceptObjectVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous (FExceptObjectClass)
Next (FExceptObjectVarName)


Sepi

Sepi
Previous (FExceptObjectVar)
Next (FInstruction)

Name
FExceptObjectVarName

Parent
TSepiOnClauseNode

Visibility
PRIVATE

Description
Nom de la variable objet exception

Source code
FExceptObjectVarName : string

Sepi
Class Tree
Index
Previous (FExceptObjectVar)
Next (FInstruction)


Sepi

Sepi
Previous (FExceptObjectVarName)
Next

Name
FInstruction

Parent
TSepiOnClauseNode

Visibility
PRIVATE

Description
Instruction multi-on contenante

Source code
FInstruction : TSepiMultiOn

Sepi
Class Tree
Index
Previous (FExceptObjectVarName)
Next


Sepi

Sepi
Previous
Next (ExceptObjectVar)

Name
ExceptObjectClass

Parent
TSepiOnClauseNode

Visibility
PUBLIC

Description
Classe d'exception capturée

Source code
property ExceptObjectClass : TSepiClass read FExceptObjectClass

Read Access
FExceptObjectClass

Sepi
Class Tree
Index
Previous
Next (ExceptObjectVar)


Sepi

Sepi
Previous (ExceptObjectClass)
Next (ExceptObjectVarName)

Name
ExceptObjectVar

Parent
TSepiOnClauseNode

Visibility
PUBLIC

Description
Variable objet exception du bon type

Source code
property ExceptObjectVar : TSepiLocalVar read FExceptObjectVar

Read Access
FExceptObjectVar

Sepi
Class Tree
Index
Previous (ExceptObjectClass)
Next (ExceptObjectVarName)


Sepi

Sepi
Previous (ExceptObjectVar)
Next (Instruction)

Name
ExceptObjectVarName

Parent
TSepiOnClauseNode

Visibility
PUBLIC

Description
Nom de la variable objet exception

Source code
property ExceptObjectVarName : string read FExceptObjectVarName

Read Access
FExceptObjectVarName

Sepi
Class Tree
Index
Previous (ExceptObjectVar)
Next (Instruction)


Sepi

Sepi
Previous (ExceptObjectVarName)
Next

Name
Instruction

Parent
TSepiOnClauseNode

Visibility
PUBLIC

Description
Instruction multi-on contenante

Source code
property Instruction : TSepiMultiOn read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous (ExceptObjectVarName)
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiOnClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiOnClauseNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (ResolveIdent)

Name
ChildEndParsing

Parent
TSepiOnClauseNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (ResolveIdent)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
ResolveIdent

Parent
TSepiOnClauseNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiOnClauseNode)
Next (TSepiParametersNode)

Name
TSepiOverloadMarkerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Marqueur overload

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOnClauseNode)
Next (TSepiParametersNode)


Sepi

Sepi
Previous (TSepiOverloadMarkerNode)
Next (TSepiParamIsArrayMarkerNode)

Name
TSepiParametersNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionModifierNode

Visibility
PUBLIC

Description
Noeud paramètres réels

Members
Methods
Method | Description
Compile (#) | Compile les paramètres
CompileParams (#) | Compile les paramètres d'une expression requérant des paramètres
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiOverloadMarkerNode)
Next (TSepiParamIsArrayMarkerNode)


Sepi

Sepi
Previous
Next (CompileParams)

Name
Compile

Parent
TSepiParametersNode

Visibility
PROTECTED

Description
Compile les paramètres

Source code
procedure Compile ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (CompileParams)


Sepi

Sepi
Previous (Compile)
Next (EndParsing)

Name
CompileParams

Parent
TSepiParametersNode

Visibility
PROTECTED

Description
Compile les paramètres d'une expression requérant des paramètres

Source code
procedure CompileParams ( const WantingParams : ISepiWantingParams ) ; virtual

Parameters
Parameter | Description
WantingParams : ISepiWantingParams | Expression requérant des paramètres

Sepi
Class Tree
Index
Previous (Compile)
Next (EndParsing)


Sepi

Sepi
Previous (CompileParams)
Next

Name
EndParsing

Parent
TSepiParametersNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileParams)
Next


Sepi

Sepi
Previous (TSepiParametersNode)
Next (TSepiParamKindNode)

Name
TSepiParamIsArrayMarkerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud marqueur qu'un paramètre est un tableau ouvert

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParametersNode)
Next (TSepiParamKindNode)


Sepi

Sepi
Previous (TSepiParamIsArrayMarkerNode)
Next (TSepiParamNameNode)

Name
TSepiParamKindNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud type de paramètre

Members
Methods
Method | Description
GetKind (#) | Type de paramètre

Properties
Property | Description
Kind (+) | Type de paramètre

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParamIsArrayMarkerNode)
Next (TSepiParamNameNode)


Sepi

Sepi
Previous
Next

Name
Kind

Parent
TSepiParamKindNode

Visibility
PUBLIC

Description
Type de paramètre

Source code
property Kind : TSepiParamKind read GetKind

Read Access
GetKind

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
GetKind

Parent
TSepiParamKindNode

Visibility
PROTECTED

Description
Type de paramètre

Source code
function GetKind : TSepiParamKind ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiParamKind | Type de paramètre

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiParamKindNode)
Next (TSepiParamNode)

Name
TSepiParamNameNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiIdentifierDeclarationNode

Visibility
PUBLIC

Description
Noeud nom d'un paramètre

Members
Fields
Field | Description
FSignature (-) | Signature

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
IsRedeclared (#) | [@inheritDoc]
MakeErroneousName (#) | [@inheritDoc]

Properties
Property | Description
Signature (#) | Signature

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParamKindNode)
Next (TSepiParamNode)


Sepi

Sepi
Previous
Next

Name
FSignature

Parent
TSepiParamNameNode

Visibility
PRIVATE

Description
Signature

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Signature

Parent
TSepiParamNameNode

Visibility
PROTECTED

Description
Signature

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (IsRedeclared)

Name
BeginParsing

Parent
TSepiParamNameNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (IsRedeclared)


Sepi

Sepi
Previous (BeginParsing)
Next (MakeErroneousName)

Name
IsRedeclared

Parent
TSepiParamNameNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function IsRedeclared : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (MakeErroneousName)


Sepi

Sepi
Previous (IsRedeclared)
Next

Name
MakeErroneousName

Parent
TSepiParamNameNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure MakeErroneousName ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (IsRedeclared)
Next


Sepi

Sepi
Previous (TSepiParamNameNode)
Next (TSepiPropDefaultMarkerNode)

Name
TSepiParamNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiSignatureBuilderNode

Visibility
PUBLIC

Description
Noeud paramètre

Members
Fields
Field | Description
FDefaultValuePtr (-) | Pointeur sur la valeur par défaut
FKind (-) | Type de paramètre
FNames (-) | Noms des paramètres
FOpenArray (-) | True si c'est un tableau ouvert
FType (-) | Type du paramètre

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Kind (+) | Type de paramètre
Names (+) | Noms des paramètres
OpenArray (+) | True si c'est un tableau ouvert
ParamType (+) | Type du paramètre

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParamNameNode)
Next (TSepiPropDefaultMarkerNode)


Sepi

Sepi
Previous
Next (FKind)

Name
FDefaultValuePtr

Parent
TSepiParamNode

Visibility
PRIVATE

Description
Pointeur sur la valeur par défaut

Source code
FDefaultValuePtr : Pointer

Sepi
Class Tree
Index
Previous
Next (FKind)


Sepi

Sepi
Previous (FDefaultValuePtr)
Next (FNames)

Name
FKind

Parent
TSepiParamNode

Visibility
PRIVATE

Description
Type de paramètre

Source code
FKind : TSepiParamKind

Sepi
Class Tree
Index
Previous (FDefaultValuePtr)
Next (FNames)


Sepi

Sepi
Previous (FKind)
Next (FOpenArray)

Name
FNames

Parent
TSepiParamNode

Visibility
PRIVATE

Description
Noms des paramètres

Source code
FNames : TStringDynArray

Sepi
Class Tree
Index
Previous (FKind)
Next (FOpenArray)


Sepi

Sepi
Previous (FNames)
Next (FType)

Name
FOpenArray

Parent
TSepiParamNode

Visibility
PRIVATE

Description
True si c'est un tableau ouvert

Source code
FOpenArray : Boolean

Sepi
Class Tree
Index
Previous (FNames)
Next (FType)


Sepi

Sepi
Previous (FOpenArray)
Next

Name
FType

Parent
TSepiParamNode

Visibility
PRIVATE

Description
Type du paramètre

Source code
FType : TSepiType

Sepi
Class Tree
Index
Previous (FOpenArray)
Next


Sepi

Sepi
Previous
Next (Names)

Name
Kind

Parent
TSepiParamNode

Visibility
PUBLIC

Description
Type de paramètre

Source code
property Kind : TSepiParamKind read FKind

Read Access
FKind

Sepi
Class Tree
Index
Previous
Next (Names)


Sepi

Sepi
Previous (Kind)
Next (OpenArray)

Name
Names

Parent
TSepiParamNode

Visibility
PUBLIC

Description
Noms des paramètres

Source code
property Names : TStringDynArray read FNames

Read Access
FNames

Sepi
Class Tree
Index
Previous (Kind)
Next (OpenArray)


Sepi

Sepi
Previous (Names)
Next (ParamType)

Name
OpenArray

Parent
TSepiParamNode

Visibility
PUBLIC

Description
True si c'est un tableau ouvert

Source code
property OpenArray : Boolean read FOpenArray

Read Access
FOpenArray

Sepi
Class Tree
Index
Previous (Names)
Next (ParamType)


Sepi

Sepi
Previous (OpenArray)
Next

Name
ParamType

Parent
TSepiParamNode

Visibility
PUBLIC

Description
Type du paramètre

Source code
property ParamType : TSepiType read FType

Read Access
FType

Sepi
Class Tree
Index
Previous (OpenArray)
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiParamNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (Destroy)

Name
ChildEndParsing

Parent
TSepiParamNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (Destroy)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
Destroy

Parent
TSepiParamNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (Destroy)
Next

Name
EndParsing

Parent
TSepiParamNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (TSepiParamNode)
Next (TSepiPropDefaultValueNode)

Name
TSepiPropDefaultMarkerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Noeud marqueur qu'une propriété est la propriété par défaut

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiParamNode)
Next (TSepiPropDefaultValueNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiPropDefaultMarkerNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropDefaultMarkerNode)
Next (TSepiPropertyBuilderNode)

Name
TSepiPropDefaultValueNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Noeud valeur par défaut d'une propriété

Members
Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropDefaultMarkerNode)
Next (TSepiPropertyBuilderNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
ChildBeginParsing

Parent
TSepiPropDefaultValueNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
EndParsing

Parent
TSepiPropDefaultValueNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TSepiPropDefaultValueNode)
Next (TSepiPropertyKindNode)

Name
TSepiPropertyBuilderNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiSignatureBuilderNode

Visibility
PUBLIC

Description
Classe de base pour les noeuds qui construisent une propriété

Members
Fields
Field | Description
FBuilder (-) | Noeud propriété

Methods
Method | Description
SetBuilder (+) | Spécifie le constructeur de propriété

Properties
Property | Description
Builder (#) | Noeud propriété

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropDefaultValueNode)
Next (TSepiPropertyKindNode)


Sepi

Sepi
Previous
Next

Name
FBuilder

Parent
TSepiPropertyBuilderNode

Visibility
PRIVATE

Description
Noeud propriété

Source code
FBuilder : TSepiPropertyBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Builder

Parent
TSepiPropertyBuilderNode

Visibility
PROTECTED

Description
Noeud propriété

Source code
property Builder : TSepiPropertyBuilder read FBuilder

Read Access
FBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SetBuilder

Parent
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Spécifie le constructeur de propriété

Source code
procedure SetBuilder ( ABuilder : TSepiPropertyBuilder )

Parameters
Parameter | Description
ABuilder : TSepiPropertyBuilder | Constructeur de propriété

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropertyBuilderNode)
Next (TSepiPropertyNode)

Name
TSepiPropertyKindNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiSignatureKindNode

Visibility
PUBLIC

Description
Noeud représentant un type de signature pour une propriété
Cette classe admet que Signature ne soit pas renseignée.

Members
Methods
Method | Description
GetKind (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropertyBuilderNode)
Next (TSepiPropertyNode)


Sepi

Sepi
Previous
Next

Name
GetKind

Parent
TSepiPropertyKindNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetKind : TSepiSignatureKind ; override

Parameters
Parameter Description

Return
Types | Description
TSepiSignatureKind | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropertyKindNode)
Next (TSepiPropIndexNode)

Name
TSepiPropertyNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud propriété

Members
Fields
Field | Description
FBuilder (-) | Constructeur de propriété

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
Destroy (+) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Builder (+) | Constructeur de propriété

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropertyKindNode)
Next (TSepiPropIndexNode)


Sepi

Sepi
Previous
Next

Name
FBuilder

Parent
TSepiPropertyNode

Visibility
PRIVATE

Description
Constructeur de propriété

Source code
FBuilder : TSepiPropertyBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Builder

Parent
TSepiPropertyNode

Visibility
PUBLIC

Description
Constructeur de propriété

Source code
property Builder : TSepiPropertyBuilder read FBuilder

Read Access
FBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiPropertyNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiPropertyNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (Destroy)

Name
ChildEndParsing

Parent
TSepiPropertyNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (Destroy)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
Destroy

Parent
TSepiPropertyNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (Destroy)
Next

Name
EndParsing

Parent
TSepiPropertyNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Destroy)
Next


Sepi

Sepi
Previous (TSepiPropertyNode)
Next (TSepiPropReadAccessNode)

Name
TSepiPropIndexNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Noeud index d'une propriété

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropertyNode)
Next (TSepiPropReadAccessNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiPropIndexNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropIndexNode)
Next (TSepiPropRedefineMarkerNode)

Name
TSepiPropReadAccessNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Noeud accesseur en lecture d'une propriété

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropIndexNode)
Next (TSepiPropRedefineMarkerNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiPropReadAccessNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropReadAccessNode)
Next (TSepiPropStorageNode)

Name
TSepiPropRedefineMarkerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Noeud marqueur qu'une propriété est redéfinie

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropReadAccessNode)
Next (TSepiPropStorageNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiPropRedefineMarkerNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropRedefineMarkerNode)
Next (TSepiPropWriteAccessNode)

Name
TSepiPropStorageNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Noeud spécificateur de stockage d'une propriété

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropRedefineMarkerNode)
Next (TSepiPropWriteAccessNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiPropStorageNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropStorageNode)
Next (TSepiPureInheritedExpressionNode)

Name
TSepiPropWriteAccessNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiPropertyBuilderNode

Visibility
PUBLIC

Description
Noeud accesseur en écriture d'une propriété

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropStorageNode)
Next (TSepiPureInheritedExpressionNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiPropWriteAccessNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPropWriteAccessNode)
Next (TSepiQualifiedIdentNode)

Name
TSepiPureInheritedExpressionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud représentant une expression d'appel inherited pur

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPropWriteAccessNode)
Next (TSepiQualifiedIdentNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiPureInheritedExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiPureInheritedExpressionNode)
Next (TSepiRaiseInstructionNode)

Name
TSepiQualifiedIdentNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Identificateur qualifié
Chaque enfant d'un identificateur qualifié est un des qualificateurs. Le
AsText d'un TSepiQualifiedIdent est la liaison des AsText de ses enfants,
avec des '.' entre chaque.

Members
Methods
Method | Description
GetAsText (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiPureInheritedExpressionNode)
Next (TSepiRaiseInstructionNode)


Sepi

Sepi
Previous
Next

Name
GetAsText

Parent
TSepiQualifiedIdentNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAsText : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiQualifiedIdentNode)
Next (TSepiRecordCaseHeaderNode)

Name
TSepiRaiseInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction raise

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]
MakeRaiseInstruction (-) | Construit l'instruction raise avec un objet
MakeReraiseInstruction (-) | Construit l'instruction raise sans objet (reraise)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiQualifiedIdentNode)
Next (TSepiRecordCaseHeaderNode)


Sepi

Sepi
Previous
Next (MakeRaiseInstruction)

Name
EndParsing

Parent
TSepiRaiseInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (MakeRaiseInstruction)


Sepi

Sepi
Previous (EndParsing)
Next (MakeReraiseInstruction)

Name
MakeRaiseInstruction

Parent
TSepiRaiseInstructionNode

Visibility
PRIVATE

Description
Construit l'instruction raise avec un objet

Source code
procedure MakeRaiseInstruction

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (EndParsing)
Next (MakeReraiseInstruction)


Sepi

Sepi
Previous (MakeRaiseInstruction)
Next

Name
MakeReraiseInstruction

Parent
TSepiRaiseInstructionNode

Visibility
PRIVATE

Description
Construit l'instruction raise sans objet (reraise)

Source code
procedure MakeReraiseInstruction

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (MakeRaiseInstruction)
Next


Sepi

Sepi
Previous (TSepiRaiseInstructionNode)
Next (TSepiRecordContentsNode)

Name
TSepiRecordCaseHeaderNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiRecordContentsNode

Visibility
PUBLIC

Description
Noeud header de case dans un record
Le contexte Sepi d'un tel noeud doit toujours être de type TSepiRecordType.

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRaiseInstructionNode)
Next (TSepiRecordContentsNode)


Sepi

Sepi
Previous (TSepiRecordCaseHeaderNode)
Next (TSepiRecordFieldNode)

Name
TSepiRecordContentsNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud descripteur de contenu de record
Le contexte Sepi d'un tel noeud doit toujours être de type TSepiRecordType.

Members
Fields
Field | Description
FAfterField (-) | Nom du champ après lequel se placer

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
SetAfterField (+) | Spécifie le nom du champ après lequel placer les champs enfants de ce noeud

Properties
Property | Description
AfterField (#) | Nom du champ après lequel se placer

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRecordCaseHeaderNode)
Next (TSepiRecordFieldNode)


Sepi

Sepi
Previous
Next

Name
FAfterField

Parent
TSepiRecordContentsNode

Visibility
PRIVATE

Description
Nom du champ après lequel se placer

Source code
FAfterField : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
AfterField

Parent
TSepiRecordContentsNode

Visibility
PROTECTED

Description
Nom du champ après lequel se placer

Source code
property AfterField : string read FAfterField

Read Access
FAfterField

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiRecordContentsNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiRecordContentsNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (SetAfterField)

Name
ChildEndParsing

Parent
TSepiRecordContentsNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (SetAfterField)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
SetAfterField

Parent
TSepiRecordContentsNode

Visibility
PUBLIC

Description
Spécifie le nom du champ après lequel placer les champs enfants de ce noeud

Source code
procedure SetAfterField ( const AAfterField : string )

Parameters
Parameter | Description
AAfterField : STRING | Nom du champ

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiRecordContentsNode)
Next (TSepiRepeatUntilInstructionNode)

Name
TSepiRecordFieldNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud d'un champ de record
Le contexte Sepi d'un tel noeud doit toujours être de type TSepiRecordType.

Members
Fields
Field | Description
FAfterField (-) | Champ après lequel se placer
FLastField (-) | Dernier champ compilé

Methods
Method | Description
EndParsing (+) | [@inheritDoc]
SetAfterField (+) | Spécifie le nom du champ après lequel placer les champs enfants de ce noeud

Properties
Property | Description
AfterField (#) | Champ après lequel se placer
LastField (+) | Dernier champ compilé

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRecordContentsNode)
Next (TSepiRepeatUntilInstructionNode)


Sepi

Sepi
Previous
Next (FLastField)

Name
FAfterField

Parent
TSepiRecordFieldNode

Visibility
PRIVATE

Description
Champ après lequel se placer

Source code
FAfterField : string

Sepi
Class Tree
Index
Previous
Next (FLastField)


Sepi

Sepi
Previous (FAfterField)
Next

Name
FLastField

Parent
TSepiRecordFieldNode

Visibility
PRIVATE

Description
Dernier champ compilé

Source code
FLastField : TSepiField

Sepi
Class Tree
Index
Previous (FAfterField)
Next


Sepi

Sepi
Previous
Next (LastField)

Name
AfterField

Parent
TSepiRecordFieldNode

Visibility
PROTECTED

Description
Champ après lequel se placer

Source code
property AfterField : string read FAfterField

Read Access
FAfterField

Sepi
Class Tree
Index
Previous
Next (LastField)


Sepi

Sepi
Previous (AfterField)
Next

Name
LastField

Parent
TSepiRecordFieldNode

Visibility
PUBLIC

Description
Dernier champ compilé

Source code
property LastField : TSepiField read FLastField

Read Access
FLastField

Sepi
Class Tree
Index
Previous (AfterField)
Next


Sepi

Sepi
Previous
Next (SetAfterField)

Name
EndParsing

Parent
TSepiRecordFieldNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (SetAfterField)


Sepi

Sepi
Previous (EndParsing)
Next

Name
SetAfterField

Parent
TSepiRecordFieldNode

Visibility
PUBLIC

Description
Spécifie le nom du champ après lequel placer les champs enfants de ce noeud

Source code
procedure SetAfterField ( const AAfterField : string )

Parameters
Parameter | Description
AAfterField : STRING | Nom du champ

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiRecordFieldNode)
Next (TSepiSameAsChildExpressionNode)

Name
TSepiRepeatUntilInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiWhileInstructionNode

Visibility
PUBLIC

Description
Instruction repeat..until (comme do..while mais avec un test inversé)

Members
Methods
Method | Description
Create (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRecordFieldNode)
Next (TSepiSameAsChildExpressionNode)


Sepi

Sepi
Previous
Next

Name
Create

Parent
TSepiRepeatUntilInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Create ( AParent : TSepiNonTerminal ; AClass : TSepiSymbolClass ; const ASourcePos : TSepiSourcePosition ) ; override

Parameters
Parameter | Description
AParent : TSepiNonTerminal | #Pas de TAG trouvé dans le code source#
AClass : TSepiSymbolClass | #Pas de TAG trouvé dans le code source#
ASourcePos : TSepiSourcePosition | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiRepeatUntilInstructionNode)
Next (TSepiSetOrOpenArrayBuilderNode)

Name
TSepiSameAsChildExpressionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud expression qui vaut la même expression que son unique fils
Un exemple d'un tel noeud est l'expression parenthésée, qui se décrit comme
'('* Expression ')'*
Sa fonction est uniquement syntaxique, et sa valeur se récupère directement
de son unique fils.

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiRepeatUntilInstructionNode)
Next (TSepiSetOrOpenArrayBuilderNode)


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiSameAsChildExpressionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiSameAsChildExpressionNode)
Next (TSepiSetValueNode)

Name
TSepiSetOrOpenArrayBuilderNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud constructeur d'ensemble ou de tableau ouvert

Members
Fields
Field | Description
FBuilder (-) | Constructeur

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Builder (#) | Constructeur

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSameAsChildExpressionNode)
Next (TSepiSetValueNode)


Sepi

Sepi
Previous
Next

Name
FBuilder

Parent
TSepiSetOrOpenArrayBuilderNode

Visibility
PRIVATE

Description
Constructeur

Source code
FBuilder : ISepiSetOrOpenArrayBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Builder

Parent
TSepiSetOrOpenArrayBuilderNode

Visibility
PROTECTED

Description
Constructeur

Source code
property Builder : ISepiSetOrOpenArrayBuilder read FBuilder

Read Access
FBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
BeginParsing

Parent
TSepiSetOrOpenArrayBuilderNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (EndParsing)

Name
ChildEndParsing

Parent
TSepiSetOrOpenArrayBuilderNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
EndParsing

Parent
TSepiSetOrOpenArrayBuilderNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiSetOrOpenArrayBuilderNode)
Next (TSepiSignatureBuilderNode)

Name
TSepiSetValueNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud valeur ensemble

Members
Fields
Field | Description
FSetBuilder (-) | Constructeur d'ensemble

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
SetBuilder (#) | Constructeur d'ensemble

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSetOrOpenArrayBuilderNode)
Next (TSepiSignatureBuilderNode)


Sepi

Sepi
Previous
Next

Name
FSetBuilder

Parent
TSepiSetValueNode

Visibility
PRIVATE

Description
Constructeur d'ensemble

Source code
FSetBuilder : ISepiSetBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SetBuilder

Parent
TSepiSetValueNode

Visibility
PROTECTED

Description
Constructeur d'ensemble

Source code
property SetBuilder : ISepiSetBuilder read FSetBuilder

Read Access
FSetBuilder

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
BeginParsing

Parent
TSepiSetValueNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (EndParsing)

Name
ChildEndParsing

Parent
TSepiSetValueNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (EndParsing)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
EndParsing

Parent
TSepiSetValueNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiSetValueNode)
Next (TSepiSignatureKindNode)

Name
TSepiSignatureBuilderNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Classe de base pour les noeuds qui doivent construire une signature
TSepiSignatureBuilderNode ne crée pas elle-même d'instance de
TSepiSignature. Elle est prévue pour construire une signature créée par un
noeud parent, et renseignée au moyen de SetSignature (avant BeginParsing).
Certaines sous-classes de TSepiSignatureBuilderNode acceptent que Signature
ne soit pas renseignée. Dans ce cas, elles n'ont aucun effet en elles-mêmes,
mais proposent souvent des propriétés permettant de savoir quel aurait été
son effet si Signature avait été renseigné.
TSepiSignatureBuilderNode transfère aussi sa signature à tous ses enfants
qui sont des instances de TSepiSignatureBuilderNode.
leur effet.

Members
Fields
Field | Description
FSignature (-) | Signature à construire

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
SetSignature (+) | Renseigne la signature à construire

Properties
Property | Description
Signature (#) | Signature à construire

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSetValueNode)
Next (TSepiSignatureKindNode)


Sepi

Sepi
Previous
Next

Name
FSignature

Parent
TSepiSignatureBuilderNode

Visibility
PRIVATE

Description
Signature à construire

Source code
FSignature : TSepiSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
Signature

Parent
TSepiSignatureBuilderNode

Visibility
PROTECTED

Description
Signature à construire

Source code
property Signature : TSepiSignature read FSignature

Read Access
FSignature

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (SetSignature)

Name
ChildBeginParsing

Parent
TSepiSignatureBuilderNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (SetSignature)


Sepi

Sepi
Previous (ChildBeginParsing)
Next

Name
SetSignature

Parent
TSepiSignatureBuilderNode

Visibility
PUBLIC

Description
Renseigne la signature à construire

Source code
procedure SetSignature ( ASignature : TSepiSignature )

Parameters
Parameter | Description
ASignature : TSepiSignature | Signature à construire

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next


Sepi

Sepi
Previous (TSepiSignatureBuilderNode)
Next (TSepiSignatureReturnTypeNode)

Name
TSepiSignatureKindNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiSignatureBuilderNode

Visibility
PUBLIC

Description
Noeud représentant un type de signature
Cette classe admet que Signature ne soit pas renseignée.

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]
GetKind (#) | Type de signature représentée par ce noeud

Properties
Property | Description
Kind (+) | Type de signature représentée par ce noeud

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSignatureBuilderNode)
Next (TSepiSignatureReturnTypeNode)


Sepi

Sepi
Previous
Next

Name
Kind

Parent
TSepiSignatureKindNode

Visibility
PUBLIC

Description
Type de signature représentée par ce noeud

Source code
property Kind : TSepiSignatureKind read GetKind

Read Access
GetKind

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (GetKind)

Name
EndParsing

Parent
TSepiSignatureKindNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetKind)


Sepi

Sepi
Previous (EndParsing)
Next

Name
GetKind

Parent
TSepiSignatureKindNode

Visibility
PROTECTED

Description
Type de signature représentée par ce noeud

Source code
function GetKind : TSepiSignatureKind ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiSignatureKind | Type de signature représentée par ce noeud

Sepi
Class Tree
Index
Previous (EndParsing)
Next


Sepi

Sepi
Previous (TSepiSignatureKindNode)
Next (TSepiStaticMarkerNode)

Name
TSepiSignatureReturnTypeNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiSignatureBuilderNode

Visibility
PUBLIC

Description
Noeud représentant le type de retour d'une signature

Members
Methods
Method | Description
AdaptSignatureKindIfNeeded (-) | Adapte le type de signature si nécessaire
AdaptSignatureKindToFunction (-) | Adapte le type de signature en fonction (avec valeur de retour)
AdaptSignatureKindToProcedure (-) | Adapte le type de signature en procédure (sans valeur de retour)
CompileNoReturnType (#) | Compile le fait qu'il n'y a pas de type de retour
CompileReturnType (#) | Compile le type de retour qui doit être présent
EndParsing (+) | [@inheritDoc]
GetTypeName (#) | Nom du type de retour
MustAdaptSignatureKind (#) | Si True, adapte Signature.Kind en fonction la présence d'un type de retour

Properties
Property | Description
TypeName (#) | Nom du type de retour

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSignatureKindNode)
Next (TSepiStaticMarkerNode)


Sepi

Sepi
Previous
Next

Name
TypeName

Parent
TSepiSignatureReturnTypeNode

Visibility
PROTECTED

Description
Nom du type de retour

Source code
property TypeName : string read GetTypeName

Read Access
GetTypeName

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (AdaptSignatureKindToFunction)

Name
AdaptSignatureKindIfNeeded

Parent
TSepiSignatureReturnTypeNode

Visibility
PRIVATE

Description
Adapte le type de signature si nécessaire

Source code
procedure AdaptSignatureKindIfNeeded

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (AdaptSignatureKindToFunction)


Sepi

Sepi
Previous (AdaptSignatureKindIfNeeded)
Next (AdaptSignatureKindToProcedure)

Name
AdaptSignatureKindToFunction

Parent
TSepiSignatureReturnTypeNode

Visibility
PRIVATE

Description
Adapte le type de signature en fonction (avec valeur de retour)

Source code
procedure AdaptSignatureKindToFunction

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AdaptSignatureKindIfNeeded)
Next (AdaptSignatureKindToProcedure)


Sepi

Sepi
Previous (AdaptSignatureKindToFunction)
Next (CompileNoReturnType)

Name
AdaptSignatureKindToProcedure

Parent
TSepiSignatureReturnTypeNode

Visibility
PRIVATE

Description
Adapte le type de signature en procédure (sans valeur de retour)

Source code
procedure AdaptSignatureKindToProcedure

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AdaptSignatureKindToFunction)
Next (CompileNoReturnType)


Sepi

Sepi
Previous (AdaptSignatureKindToProcedure)
Next (CompileReturnType)

Name
CompileNoReturnType

Parent
TSepiSignatureReturnTypeNode

Visibility
PROTECTED

Description
Compile le fait qu'il n'y a pas de type de retour
S'il y a un type de retour, émet une erreur.

Source code
procedure CompileNoReturnType ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (AdaptSignatureKindToProcedure)
Next (CompileReturnType)


Sepi

Sepi
Previous (CompileNoReturnType)
Next (EndParsing)

Name
CompileReturnType

Parent
TSepiSignatureReturnTypeNode

Visibility
PROTECTED

Description
Compile le type de retour qui doit être présent
Si le type de retour est absent ou invalide, émet une erreur.

Source code
function CompileReturnType : TSepiType ; virtual

Parameters
Parameter Description

Return
Types | Description
TSepiType | Type de retour

Sepi
Class Tree
Index
Previous (CompileNoReturnType)
Next (EndParsing)


Sepi

Sepi
Previous (CompileReturnType)
Next (GetTypeName)

Name
EndParsing

Parent
TSepiSignatureReturnTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileReturnType)
Next (GetTypeName)


Sepi

Sepi
Previous (EndParsing)
Next (MustAdaptSignatureKind)

Name
GetTypeName

Parent
TSepiSignatureReturnTypeNode

Visibility
PROTECTED

Description
Nom du type de retour
Le nom du type de retour est toujours la valeur de AsText. Si vous voulez
modifier ce comportement dans une classe de base, surchargez AsText.

Source code
function GetTypeName : string

Parameters
Parameter Description

Return
Types | Description
STRING | Nom du type de retour, ou '' si absent

Sepi
Class Tree
Index
Previous (EndParsing)
Next (MustAdaptSignatureKind)


Sepi

Sepi
Previous (GetTypeName)
Next

Name
MustAdaptSignatureKind

Parent
TSepiSignatureReturnTypeNode

Visibility
PROTECTED

Description
Si True, adapte Signature.Kind en fonction la présence d'un type de retour
Si False, la présence d'un type de retour doit se conformer à la valeur
courante de Signature.Kind.
Par défaut, AdaptSignatureKind renvoie False, ce qui correspond au
comportement du langage Delphi.

Source code
function MustAdaptSignatureKind : Boolean ; virtual

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True s'il faut adapter Signature.Kind, False sinon.

Sepi
Class Tree
Index
Previous (GetTypeName)
Next


Sepi

Sepi
Previous (TSepiSignatureReturnTypeNode)
Next (TSepiTryInstructionNode)

Name
TSepiStaticMarkerNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Marqueur static

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSignatureReturnTypeNode)
Next (TSepiTryInstructionNode)


Sepi

Sepi
Previous (TSepiStaticMarkerNode)
Next (TSepiTypeDefinitionNode)

Name
TSepiTryInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction try..except..end ou try..finally..end

Members
Fields
Field | Description
FTryInstructions (-) | Instructions dans le try

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]

Properties
Property | Description
TryInstructions (+) | Instructions dans le try

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiStaticMarkerNode)
Next (TSepiTypeDefinitionNode)


Sepi

Sepi
Previous
Next

Name
FTryInstructions

Parent
TSepiTryInstructionNode

Visibility
PRIVATE

Description
Instructions dans le try

Source code
FTryInstructions : TSepiInstructionList

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
TryInstructions

Parent
TSepiTryInstructionNode

Visibility
PUBLIC

Description
Instructions dans le try

Source code
property TryInstructions : TSepiInstructionList read FTryInstructions

Read Access
FTryInstructions

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiTryInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next

Name
ChildBeginParsing

Parent
TSepiTryInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next


Sepi

Sepi
Previous (TSepiTryInstructionNode)
Next (TSepiTypeNameNode)

Name
TSepiTypeDefinitionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiTypeNode

Visibility
PUBLIC

Description
Noeud représentant une définition de type

Members
Fields
Field | Description
FTypeName (-) | Nom du type à définir (peut être '')

Methods
Method | Description
EndParsing (+) | [@inheritDoc]
GetIsAnonymous (-) | Indique si le type à définir est anonyme
MakeErroneousType (#) | [@inheritDoc]
SetTypeName (+) | Spécifie le nom type à définir

Properties
Property | Description
IsAnonymous (+) | Indique si le type à définir est anonyme
TypeName (+) | Nom du type à définir (peut être '')

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTryInstructionNode)
Next (TSepiTypeNameNode)


Sepi

Sepi
Previous
Next

Name
FTypeName

Parent
TSepiTypeDefinitionNode

Visibility
PRIVATE

Description
Nom du type à définir (peut être '')

Source code
FTypeName : string

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (TypeName)

Name
IsAnonymous

Parent
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Indique si le type à définir est anonyme

Source code
property IsAnonymous : Boolean read GetIsAnonymous

Read Access
GetIsAnonymous

Sepi
Class Tree
Index
Previous
Next (TypeName)


Sepi

Sepi
Previous (IsAnonymous)
Next

Name
TypeName

Parent
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Nom du type à définir (peut être '')

Source code
property TypeName : string read FTypeName

Read Access
FTypeName

Sepi
Class Tree
Index
Previous (IsAnonymous)
Next


Sepi

Sepi
Previous
Next (GetIsAnonymous)

Name
EndParsing

Parent
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (GetIsAnonymous)


Sepi

Sepi
Previous (EndParsing)
Next (MakeErroneousType)

Name
GetIsAnonymous

Parent
TSepiTypeDefinitionNode

Visibility
PRIVATE

Description
Indique si le type à définir est anonyme

Source code
function GetIsAnonymous : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si le type est anonyme, False sinon

Sepi
Class Tree
Index
Previous (EndParsing)
Next (MakeErroneousType)


Sepi

Sepi
Previous (GetIsAnonymous)
Next (SetTypeName)

Name
MakeErroneousType

Parent
TSepiTypeDefinitionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure MakeErroneousType ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (GetIsAnonymous)
Next (SetTypeName)


Sepi

Sepi
Previous (MakeErroneousType)
Next

Name
SetTypeName

Parent
TSepiTypeDefinitionNode

Visibility
PUBLIC

Description
Spécifie le nom type à définir

Source code
procedure SetTypeName ( const ATypeName : string )

Parameters
Parameter | Description
ATypeName : STRING | Nom du type à définir

Sepi
Class Tree
Index
Previous (MakeErroneousType)
Next


Sepi

Sepi
Previous (TSepiTypeDefinitionNode)
Next (TSepiTypeNode)

Name
TSepiTypeNameNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiTypeNode

Visibility
PUBLIC

Description
Noeud identifiant un type par son nom

Members
Methods
Method | Description
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
TypeName (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeDefinitionNode)
Next (TSepiTypeNode)


Sepi

Sepi
Previous
Next

Name
TypeName

Parent
TSepiTypeNameNode

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property TypeName : string read GetAsText

Read Access
GetAsText

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
EndParsing

Parent
TSepiTypeNameNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiTypeNameNode)
Next (TSepiUnaryOperationNode)

Name
TSepiTypeNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant un type

Members
Fields
Field | Description
FSepiType (-) | Type représenté

Methods
Method | Description
EndParsing (+) | [@inheritDoc]
MakeErroneousType (#) | Construit un type erroné
SetSepiType (#) | Renseigne le type représenté

Properties
Property | Description
SepiType (+) | Type représenté

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeNameNode)
Next (TSepiUnaryOperationNode)


Sepi

Sepi
Previous
Next

Name
FSepiType

Parent
TSepiTypeNode

Visibility
PRIVATE

Description
Type représenté

Source code
FSepiType : TSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
SepiType

Parent
TSepiTypeNode

Visibility
PUBLIC

Description
Type représenté

Source code
property SepiType : TSepiType read FSepiType

Read Access
FSepiType

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (MakeErroneousType)

Name
EndParsing

Parent
TSepiTypeNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (MakeErroneousType)


Sepi

Sepi
Previous (EndParsing)
Next (SetSepiType)

Name
MakeErroneousType

Parent
TSepiTypeNode

Visibility
PROTECTED

Description
Construit un type erroné

Source code
procedure MakeErroneousType ; virtual

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (EndParsing)
Next (SetSepiType)


Sepi

Sepi
Previous (MakeErroneousType)
Next

Name
SetSepiType

Parent
TSepiTypeNode

Visibility
PROTECTED

Description
Renseigne le type représenté

Source code
procedure SetSepiType ( ASepiType : TSepiType )

Parameters
Parameter | Description
ASepiType : TSepiType | Type représenté

Sepi
Class Tree
Index
Previous (MakeErroneousType)
Next


Sepi

Sepi
Previous (TSepiTypeNode)
Next (TSepiUnaryOpModifierNode)

Name
TSepiUnaryOperationNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud expression calculé par une opération unaire
Un noeud de ce type doit posséder exactement deux enfants. L'un des deux
doit être de type TSepiUnaryOpNode et l'autre de type TSepiExpressionNode.

Members
Methods
Method | Description
CompileOperation (#) | Compile l'arbre de l'expression
EndParsing (+) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiTypeNode)
Next (TSepiUnaryOpModifierNode)


Sepi

Sepi
Previous
Next (EndParsing)

Name
CompileOperation

Parent
TSepiUnaryOperationNode

Visibility
PROTECTED

Description
Compile l'arbre de l'expression

Source code
function CompileOperation ( OperatorNode : TSepiUnaryOpNode ; OperandNode : TSepiExpressionNode ) : ISepiExpression

Parameters
Parameter | Description
OperatorNode : TSepiUnaryOpNode | #Pas de TAG trouvé dans le code source#
OperandNode : TSepiExpressionNode | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | Expression représentant l'arbre

Sepi
Class Tree
Index
Previous
Next (EndParsing)


Sepi

Sepi
Previous (CompileOperation)
Next

Name
EndParsing

Parent
TSepiUnaryOperationNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (CompileOperation)
Next


Sepi

Sepi
Previous (TSepiUnaryOperationNode)
Next (TSepiUnaryOpNode)

Name
TSepiUnaryOpModifierNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionModifierNode

Visibility
PUBLIC

Description
Noeud modificateur d'expression sur base d'un opérateur unaire
Un noeud de ce type doit avoir un unique enfant de type TSepiUnaryOpNode.

Members
Methods
Method | Description
ChildEndParsing (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUnaryOperationNode)
Next (TSepiUnaryOpNode)


Sepi

Sepi
Previous
Next

Name
ChildEndParsing

Parent
TSepiUnaryOpModifierNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiUnaryOpModifierNode)
Next (TSepiUncheckedIdentifierDeclNode)

Name
TSepiUnaryOpNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud représentant un opérateur unaire

Members
Methods
Method | Description
MakeOperation (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUnaryOpModifierNode)
Next (TSepiUncheckedIdentifierDeclNode)


Sepi

Sepi
Previous
Next

Name
MakeOperation

Parent
TSepiUnaryOpNode

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
function MakeOperation ( const Operand : ISepiExpression ) : ISepiExpression ; virtual ; abstract

Parameters
Parameter | Description
Operand : ISepiExpression | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiUnaryOpNode)
Next (TSepiUsesNode)

Name
TSepiUncheckedIdentifierDeclNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiIdentifierDeclarationNode

Visibility
PUBLIC

Description
Noeud représentant une déclaration d'un identificateur non vérifié

Members
Methods
Method | Description
IsRedeclared (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUnaryOpNode)
Next (TSepiUsesNode)


Sepi

Sepi
Previous
Next

Name
IsRedeclared

Parent
TSepiUncheckedIdentifierDeclNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function IsRedeclared : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiUncheckedIdentifierDeclNode)
Next (TSepiValueNode)

Name
TSepiUsesNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiNonTerminal

Visibility
PUBLIC

Description
Noeud section uses
Chaque enfant d'un noeud section uses doit être un noeud dont le AsText est
un nom d'unité. Chaque unité ainsi référencée est ajoutée aux uses de
l'unité en cours de compilation.

Members
Methods
Method | Description
ChildEndParsing (#) | [@inheritDoc]
IsRedeclared (#) | Teste si un nom d'unité est redéclaré

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUncheckedIdentifierDeclNode)
Next (TSepiValueNode)


Sepi

Sepi
Previous
Next (IsRedeclared)

Name
ChildEndParsing

Parent
TSepiUsesNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (IsRedeclared)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
IsRedeclared

Parent
TSepiUsesNode

Visibility
PROTECTED

Description
Teste si un nom d'unité est redéclaré

Source code
function IsRedeclared ( const UnitName : string ) : Boolean ; virtual

Parameters
Parameter | Description
UnitName : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous (TSepiUsesNode)
Next (TSepiWhileInstructionNode)

Name
TSepiValueNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiExpressionNode

Visibility
PUBLIC

Description
Noeud valeur

Members
Methods
Method | Description
ValidateExpression (#) | [@inheritDoc]

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiUsesNode)
Next (TSepiWhileInstructionNode)


Sepi

Sepi
Previous
Next

Name
ValidateExpression

Parent
TSepiValueNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function ValidateExpression : Boolean ; override

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (TSepiValueNode)
Next (TSepiWithInstructionNode)

Name
TSepiWhileInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction while..do ou similaire

Members
Fields
Field | Description
FInstruction (-) | Instruction
FInvertTest (-) | True si le test doit être inversé (not Test)
FTestAtEnd (-) | True si le test est à la fin

Methods
Method | Description
BeginParsing (+) | [@inheritDoc]
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
Configure (#) | Configure le type de boucle
EndParsing (+) | [@inheritDoc]

Properties
Property | Description
Instruction (+) | Instruction
InvertTest (+) | True si le test doit être inversé (not Test)
TestAtEnd (+) | True si le test est à la fin

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiValueNode)
Next (TSepiWithInstructionNode)


Sepi

Sepi
Previous
Next (FInvertTest)

Name
FInstruction

Parent
TSepiWhileInstructionNode

Visibility
PRIVATE

Description
Instruction

Source code
FInstruction : TSepiWhile

Sepi
Class Tree
Index
Previous
Next (FInvertTest)


Sepi

Sepi
Previous (FInstruction)
Next (FTestAtEnd)

Name
FInvertTest

Parent
TSepiWhileInstructionNode

Visibility
PRIVATE

Description
True si le test doit être inversé (not Test)

Source code
FInvertTest : Boolean

Sepi
Class Tree
Index
Previous (FInstruction)
Next (FTestAtEnd)


Sepi

Sepi
Previous (FInvertTest)
Next

Name
FTestAtEnd

Parent
TSepiWhileInstructionNode

Visibility
PRIVATE

Description
True si le test est à la fin

Source code
FTestAtEnd : Boolean

Sepi
Class Tree
Index
Previous (FInvertTest)
Next


Sepi

Sepi
Previous
Next (InvertTest)

Name
Instruction

Parent
TSepiWhileInstructionNode

Visibility
PUBLIC

Description
Instruction

Source code
property Instruction : TSepiWhile read FInstruction

Read Access
FInstruction

Sepi
Class Tree
Index
Previous
Next (InvertTest)


Sepi

Sepi
Previous (Instruction)
Next (TestAtEnd)

Name
InvertTest

Parent
TSepiWhileInstructionNode

Visibility
PUBLIC

Description
True si le test doit être inversé (not Test)

Source code
property InvertTest : Boolean read FInvertTest

Read Access
FInvertTest

Sepi
Class Tree
Index
Previous (Instruction)
Next (TestAtEnd)


Sepi

Sepi
Previous (InvertTest)
Next

Name
TestAtEnd

Parent
TSepiWhileInstructionNode

Visibility
PUBLIC

Description
True si le test est à la fin

Source code
property TestAtEnd : Boolean read FTestAtEnd

Read Access
FTestAtEnd

Sepi
Class Tree
Index
Previous (InvertTest)
Next


Sepi

Sepi
Previous
Next (ChildBeginParsing)

Name
BeginParsing

Parent
TSepiWhileInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure BeginParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (ChildBeginParsing)


Sepi

Sepi
Previous (BeginParsing)
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiWhileInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (BeginParsing)
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (Configure)

Name
ChildEndParsing

Parent
TSepiWhileInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (Configure)


Sepi

Sepi
Previous (ChildEndParsing)
Next (EndParsing)

Name
Configure

Parent
TSepiWhileInstructionNode

Visibility
PROTECTED

Description
Configure le type de boucle

Source code
procedure Configure ( ATestAtEnd , AInvertTest : Boolean )

Parameters
Parameter | Description
ATestAtEnd : BOOLEAN | True si le test est à la fin
AInvertTest : BOOLEAN | True si le test doit être inverté (not Test)

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next (EndParsing)


Sepi

Sepi
Previous (Configure)
Next

Name
EndParsing

Parent
TSepiWhileInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
procedure EndParsing ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Configure)
Next


Sepi

Sepi
Previous (TSepiWhileInstructionNode)
Next

Name
TSepiWithInstructionNode

Parent
SepiStdCompilerNodes

Class Hierarchy
TSepiInstructionNode

Visibility
PUBLIC

Description
Instruction with

Members
Fields
Field | Description
FWithValue (-) | Valeur de la variable with
FWithVar (-) | Variable with

Methods
Method | Description
ChildBeginParsing (#) | [@inheritDoc]
ChildEndParsing (#) | [@inheritDoc]
ResolveIdent (+) | [@inheritDoc]

Properties
Property | Description
WithValue (+) | Valeur de la variable with
WithVar (+) | Variable with

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiWhileInstructionNode)
Next


Sepi

Sepi
Previous
Next (FWithVar)

Name
FWithValue

Parent
TSepiWithInstructionNode

Visibility
PRIVATE

Description
Valeur de la variable with

Source code
FWithValue : ISepiReadableValue

Sepi
Class Tree
Index
Previous
Next (FWithVar)


Sepi

Sepi
Previous (FWithValue)
Next

Name
FWithVar

Parent
TSepiWithInstructionNode

Visibility
PRIVATE

Description
Variable with

Source code
FWithVar : TSepiLocalVar

Sepi
Class Tree
Index
Previous (FWithValue)
Next


Sepi

Sepi
Previous
Next (WithVar)

Name
WithValue

Parent
TSepiWithInstructionNode

Visibility
PUBLIC

Description
Valeur de la variable with

Source code
property WithValue : ISepiReadableValue read FWithValue

Read Access
FWithValue

Sepi
Class Tree
Index
Previous
Next (WithVar)


Sepi

Sepi
Previous (WithValue)
Next

Name
WithVar

Parent
TSepiWithInstructionNode

Visibility
PUBLIC

Description
Variable with

Source code
property WithVar : TSepiLocalVar read FWithVar

Read Access
FWithVar

Sepi
Class Tree
Index
Previous (WithValue)
Next


Sepi

Sepi
Previous
Next (ChildEndParsing)

Name
ChildBeginParsing

Parent
TSepiWithInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildBeginParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (ChildEndParsing)


Sepi

Sepi
Previous (ChildBeginParsing)
Next (ResolveIdent)

Name
ChildEndParsing

Parent
TSepiWithInstructionNode

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildEndParsing ( Child : TSepiParseTreeNode ) ; override

Parameters
Parameter | Description
Child : TSepiParseTreeNode | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildBeginParsing)
Next (ResolveIdent)


Sepi

Sepi
Previous (ChildEndParsing)
Next

Name
ResolveIdent

Parent
TSepiWithInstructionNode

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ResolveIdent ( const Identifier : string ) : ISepiExpression ; override

Parameters
Parameter | Description
Identifier : STRING | #Pas de TAG trouvé dans le code source#

Return
Types | Description
ISepiExpression | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ChildEndParsing)
Next


Sepi

Sepi
Previous
Next

Name
TSepiBinaryOpDirection

Parent
SepiStdCompilerNodes

Visibility
PUBLIC

Description
Sens d'évaluation d'un opérateur binaire
- bodLeftToRight : évalué de gauche à droite (comme la soustraction) ;
- bodRightToLeft : évalué de droite à gauche (comme le = du C).

Source code
TSepiBinaryOpDirection = ( bodLeftToRight , bodRightToLeft ) ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
CM_NOTIFYTYPECREATED

Parent
SepiStdCompilerNodes

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
CM_NOTIFYTYPECREATED = $11

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SepiStdCompilerNodes)
Next (SepiSystemUnit)

Name
SepiStrTypes

Parent
Sepi

Description
Définit les classes de gestion des types chaîne

Author
sjrd

Version
1.0

Types
Type | Description
TSepiStringKind (+) | Type de chaîne longue

Constants
Constant | Description
DefaultStringKind (+) | Type de chaîne de string
RawByteCodePage (+) | Code page de RawByteString
StringKindToTypeKind (+) | String kind to type kind

Classes
Class | Description
TSepiShortStringType (+) | Type chaîne de caractères courte
TSepiStringType (+) | Type chaîne de caractères longue

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiStdCompilerNodes)
Next (SepiSystemUnit)


Sepi

Sepi
Previous
Next (TSepiStringType)

Name
TSepiShortStringType

Parent
SepiStrTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type chaîne de caractères courte

Members
Fields
Field | Description
FMaxLength (-) | Longueur maximale

Methods
Method | Description
Clone (+) | [@inheritDoc]
Create (+) | Crée un nouveau type chaîne courte
Equals (+) | [@inheritDoc]
GetAlignment (#) | [@inheritDoc]
GetDescription (#) | [@inheritDoc]
Load (+) | Charge un type chaîne courte depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
MaxLength (+) | Longueur maximale

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiStringType)


Sepi

Sepi
Previous
Next

Name
FMaxLength

Parent
TSepiShortStringType

Visibility
PRIVATE

Description
Longueur maximale

Source code
FMaxLength : Integer

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next

Name
MaxLength

Parent
TSepiShortStringType

Visibility
PUBLIC

Description
Longueur maximale

Source code
property MaxLength : Integer read FMaxLength

Read Access
FMaxLength

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiShortStringType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Equals)

Name
Create

Parent
TSepiShortStringType

Visibility
PUBLIC

Description
Crée un nouveau type chaîne courte

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AMaxLength : Integer = 255 )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AMaxLength : INTEGER | Longueur maximale

Sepi
Class Tree
Index
Previous (Clone)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (GetAlignment)

Name
Equals

Parent
TSepiShortStringType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (GetAlignment)


Sepi

Sepi
Previous (Equals)
Next (GetDescription)

Name
GetAlignment

Parent
TSepiShortStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetAlignment : Integer ; override

Parameters
Parameter Description

Return
Types | Description
INTEGER | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (GetDescription)


Sepi

Sepi
Previous (GetAlignment)
Next (Load)

Name
GetDescription

Parent
TSepiShortStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
function GetDescription : string ; override

Parameters
Parameter Description

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetAlignment)
Next (Load)


Sepi

Sepi
Previous (GetDescription)
Next (Save)

Name
Load

Parent
TSepiShortStringType

Visibility
PUBLIC

Description
Charge un type chaîne courte depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetDescription)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiShortStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiShortStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiShortStringType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiShortStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiShortStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous (TSepiShortStringType)
Next

Name
TSepiStringType

Parent
SepiStrTypes

Class Hierarchy
TSepiType

Visibility
PUBLIC

Description
Type chaîne de caractères longue

Members
Fields
Field | Description
FCodePage (-) | Code de page pour une chaîne Ansi
FStringKind (-) | Type de chaîne longue

Methods
Method | Description
Clone (+) | [@inheritDoc]
Create (+) | Crée un nouveau type chaîne longue
Equals (+) | [@inheritDoc]
HasCodePage (-) | Teste si ce type de chaîne possède une code page
Load (+) | Charge un type chaîne longue depuis un flux
Save (#) | [@inheritDoc]
SetupProperties (#) | [@inheritDoc]
ValueToString (+) | [@inheritDoc]
WriteDigestData (#) | [@inheritDoc]
WriteTypeInfo (#) | [@inheritDoc]

Properties
Property | Description
CodePage (+) | Code de page pour une chaîne Ansi
StringKind (+) | Type de chaîne longue

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiShortStringType)
Next


Sepi

Sepi
Previous
Next (FStringKind)

Name
FCodePage

Parent
TSepiStringType

Visibility
PRIVATE

Description
Code de page pour une chaîne Ansi

Source code
FCodePage : Word

Sepi
Class Tree
Index
Previous
Next (FStringKind)


Sepi

Sepi
Previous (FCodePage)
Next

Name
FStringKind

Parent
TSepiStringType

Visibility
PRIVATE

Description
Type de chaîne longue

Source code
FStringKind : TSepiStringKind

Sepi
Class Tree
Index
Previous (FCodePage)
Next


Sepi

Sepi
Previous
Next (StringKind)

Name
CodePage

Parent
TSepiStringType

Visibility
PUBLIC

Description
Code de page pour une chaîne Ansi

Source code
property CodePage : Word read FCodePage

Read Access
FCodePage

Sepi
Class Tree
Index
Previous
Next (StringKind)


Sepi

Sepi
Previous (CodePage)
Next

Name
StringKind

Parent
TSepiStringType

Visibility
PUBLIC

Description
Type de chaîne longue

Source code
property StringKind : TSepiStringKind read FStringKind

Read Access
FStringKind

Sepi
Class Tree
Index
Previous (CodePage)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Clone

Parent
TSepiStringType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Clone ( AOwner : TSepiComponent ; const AName : string ; Source : TSepiType ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
AName : STRING | #Pas de TAG trouvé dans le code source#
Source : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Clone)
Next (Equals)

Name
Create

Parent
TSepiStringType

Visibility
PUBLIC

Description
Crée un nouveau type chaîne longue

Source code
constructor Create ( AOwner : TSepiComponent ; const AName : string ; AStringKind : TSepiStringKind = DefaultStringKind ; ACodePage : Integer = - 1 )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire du type
AName : STRING | Nom du type
AStringKind : TSepiStringKind | Type de chaîne longue
ACodePage : INTEGER | Code page pour les chaînes Ansi sous Delphi 2009+

Sepi
Class Tree
Index
Previous (Clone)
Next (Equals)


Sepi

Sepi
Previous (Create)
Next (HasCodePage)

Name
Equals

Parent
TSepiStringType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function Equals ( Other : TSepiType ) : Boolean ; override

Parameters
Parameter | Description
Other : TSepiType | #Pas de TAG trouvé dans le code source#

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Create)
Next (HasCodePage)


Sepi

Sepi
Previous (Equals)
Next (Load)

Name
HasCodePage

Parent
TSepiStringType

Visibility
PRIVATE

Description
Teste si ce type de chaîne possède une code page

Source code
function HasCodePage : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Equals)
Next (Load)


Sepi

Sepi
Previous (HasCodePage)
Next (Save)

Name
Load

Parent
TSepiStringType

Visibility
PUBLIC

Description
Charge un type chaîne longue depuis un flux

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (HasCodePage)
Next (Save)


Sepi

Sepi
Previous (Load)
Next (SetupProperties)

Name
Save

Parent
TSepiStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure Save ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (Load)
Next (SetupProperties)


Sepi

Sepi
Previous (Save)
Next (ValueToString)

Name
SetupProperties

Parent
TSepiStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure SetupProperties ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Save)
Next (ValueToString)


Sepi

Sepi
Previous (SetupProperties)
Next (WriteDigestData)

Name
ValueToString

Parent
TSepiStringType

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
function ValueToString ( const Value ) : string ; override

Parameters
Parameter | Description
Value : Untyped | #Pas de TAG trouvé dans le code source#

Return
Types | Description
STRING | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (SetupProperties)
Next (WriteDigestData)


Sepi

Sepi
Previous (ValueToString)
Next (WriteTypeInfo)

Name
WriteDigestData

Parent
TSepiStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteDigestData ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (ValueToString)
Next (WriteTypeInfo)


Sepi

Sepi
Previous (WriteDigestData)
Next

Name
WriteTypeInfo

Parent
TSepiStringType

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure WriteTypeInfo ( Stream : TStream ) ; override

Parameters
Parameter | Description
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (WriteDigestData)
Next


Sepi

Sepi
Previous
Next

Name
TSepiStringKind

Parent
SepiStrTypes

Visibility
PUBLIC

Description
Type de chaîne longue
- skAnsiString : chaîne Ansi
- skWideString : chaîne Wide
- skUnicodeString : chaîne Unicode (Delphi 2009 et supérieur)

Source code
TSepiStringKind = ( skAnsiString , skWideString , skUnicodeString ) ;

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (RawByteCodePage)

Name
DefaultStringKind

Parent
SepiStrTypes

Visibility
PUBLIC

Description
Type de chaîne de string

Source code
DefaultStringKind = skUnicodeString

Sepi
Class Tree
Index
Previous
Next (RawByteCodePage)


Sepi

Sepi
Previous (DefaultStringKind)
Next (StringKindToTypeKind)

Name
RawByteCodePage

Parent
SepiStrTypes

Visibility
PUBLIC

Description
Code page de RawByteString

Source code
RawByteCodePage = $FFFF

Sepi
Class Tree
Index
Previous (DefaultStringKind)
Next (StringKindToTypeKind)


Sepi

Sepi
Previous (RawByteCodePage)
Next

Name
StringKindToTypeKind

Parent
SepiStrTypes

Visibility
PUBLIC

Description
String kind to type kind

Source code
StringKindToTypeKind : array [ TSepiStringKind ] of TTypeKind = ( tkLString , tkWString , tkUStringOrUnknown )

Sepi
Class Tree
Index
Previous (RawByteCodePage)
Next


Sepi

Sepi
Previous (SepiStrTypes)
Next (SvEdits)

Name
SepiSystemUnit

Parent
Sepi

Description
Définit les classes de gestion de l'unité System

Author
sjrd

Version
1.0

Constants
Constant Description

Methods
Method Description

Classes
Class | Description
TSepiSystemTypes (+) | Types de base de l'unité System
TSepiSystemUnit (+) | Unité System

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiStrTypes)
Next (SvEdits)


Sepi

Sepi
Previous
Next (TSepiSystemUnit)

Name
TSepiSystemTypes

Parent
SepiSystemUnit

Class Hierarchy
No Parent

Visibility
PUBLIC

Description
Types de base de l'unité System

Members
Fields
Field | Description
AnsiChar (*) | #No TAG found in source code#
ANSISTRING (*) | #No TAG found in source code#
BOOLEAN (*) | #No TAG found in source code#
BYTE (*) | #No TAG found in source code#
BYTEBOOL (*) | #No TAG found in source code#
CARDINAL (*) | #No TAG found in source code#
CHAR (*) | #No TAG found in source code#
COMP (*) | #No TAG found in source code#
CURRENCY (*) | #No TAG found in source code#
DOUBLE (*) | #No TAG found in source code#
EXTENDED (*) | #No TAG found in source code#
HRESULT (*) | #No TAG found in source code#
IDispatch (*) | #No TAG found in source code#
IInterface (*) | #No TAG found in source code#
INT64 (*) | #No TAG found in source code#
INTEGER (*) | #No TAG found in source code#
IUnknown (*) | #No TAG found in source code#
LONGBOOL (*) | #No TAG found in source code#
LONGINT (*) | #No TAG found in source code#
LongString (*) | #No TAG found in source code#
LONGWORD (*) | #No TAG found in source code#
OLEVARIANT (*) | #No TAG found in source code#
PAnsiChar (*) | #No TAG found in source code#
PByte (*) | #No TAG found in source code#
PCHAR (*) | #No TAG found in source code#
Pointer (*) | #No TAG found in source code#
PWideChar (*) | #No TAG found in source code#
SHORTINT (*) | #No TAG found in source code#
ShortString (*) | #No TAG found in source code#
SINGLE (*) | #No TAG found in source code#
SMALLINT (*) | #No TAG found in source code#
TClass (*) | #No TAG found in source code#
TDateTime (*) | #No TAG found in source code#
TGUID (*) | #No TAG found in source code#
TMethod (*) | #No TAG found in source code#
TObject (*) | #No TAG found in source code#
TVarRec (*) | #No TAG found in source code#
UInt64 (*) | #No TAG found in source code#
UnicodeString (*) | #No TAG found in source code#
Untyped (*) | #No TAG found in source code#
VARIANT (*) | #No TAG found in source code#
WIDECHAR (*) | #No TAG found in source code#
WIDESTRING (*) | #No TAG found in source code#
WORD (*) | #No TAG found in source code#
WORDBOOL (*) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSepiSystemUnit)


Sepi

Sepi
Previous
Next (ANSISTRING)

Name
AnsiChar

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
AnsiChar : TSepiCharType

Sepi
Class Tree
Index
Previous
Next (ANSISTRING)


Sepi

Sepi
Previous (AnsiChar)
Next (BOOLEAN)

Name
ANSISTRING

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
AnsiString : TSepiStringType

Sepi
Class Tree
Index
Previous (AnsiChar)
Next (BOOLEAN)


Sepi

Sepi
Previous (ANSISTRING)
Next (BYTE)

Name
BOOLEAN

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Boolean : TSepiBooleanType

Sepi
Class Tree
Index
Previous (ANSISTRING)
Next (BYTE)


Sepi

Sepi
Previous (BOOLEAN)
Next (BYTEBOOL)

Name
BYTE

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Byte : TSepiOrdType

Sepi
Class Tree
Index
Previous (BOOLEAN)
Next (BYTEBOOL)


Sepi

Sepi
Previous (BYTE)
Next (CARDINAL)

Name
BYTEBOOL

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ByteBool : TSepiBooleanType

Sepi
Class Tree
Index
Previous (BYTE)
Next (CARDINAL)


Sepi

Sepi
Previous (BYTEBOOL)
Next (CHAR)

Name
CARDINAL

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Cardinal : TSepiOrdType

Sepi
Class Tree
Index
Previous (BYTEBOOL)
Next (CHAR)


Sepi

Sepi
Previous (CARDINAL)
Next (COMP)

Name
CHAR

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Char : TSepiCharType

Sepi
Class Tree
Index
Previous (CARDINAL)
Next (COMP)


Sepi

Sepi
Previous (CHAR)
Next (CURRENCY)

Name
COMP

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Comp : TSepiFloatType

Sepi
Class Tree
Index
Previous (CHAR)
Next (CURRENCY)


Sepi

Sepi
Previous (COMP)
Next (DOUBLE)

Name
CURRENCY

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Currency : TSepiFloatType

Sepi
Class Tree
Index
Previous (COMP)
Next (DOUBLE)


Sepi

Sepi
Previous (CURRENCY)
Next (EXTENDED)

Name
DOUBLE

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Double : TSepiFloatType

Sepi
Class Tree
Index
Previous (CURRENCY)
Next (EXTENDED)


Sepi

Sepi
Previous (DOUBLE)
Next (HRESULT)

Name
EXTENDED

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Extended : TSepiFloatType

Sepi
Class Tree
Index
Previous (DOUBLE)
Next (HRESULT)


Sepi

Sepi
Previous (EXTENDED)
Next (IDispatch)

Name
HRESULT

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
HRESULT : TSepiIntegerType

Sepi
Class Tree
Index
Previous (EXTENDED)
Next (IDispatch)


Sepi

Sepi
Previous (HRESULT)
Next (IInterface)

Name
IDispatch

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
IDispatch : TSepiInterface

Sepi
Class Tree
Index
Previous (HRESULT)
Next (IInterface)


Sepi

Sepi
Previous (IDispatch)
Next (INT64)

Name
IInterface

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
IInterface : TSepiInterface

Sepi
Class Tree
Index
Previous (IDispatch)
Next (INT64)


Sepi

Sepi
Previous (IInterface)
Next (INTEGER)

Name
INT64

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Int64 : TSepiInt64Type

Sepi
Class Tree
Index
Previous (IInterface)
Next (INTEGER)


Sepi

Sepi
Previous (INT64)
Next (IUnknown)

Name
INTEGER

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Integer : TSepiOrdType

Sepi
Class Tree
Index
Previous (INT64)
Next (IUnknown)


Sepi

Sepi
Previous (INTEGER)
Next (LONGBOOL)

Name
IUnknown

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
IUnknown : TSepiInterface

Sepi
Class Tree
Index
Previous (INTEGER)
Next (LONGBOOL)


Sepi

Sepi
Previous (IUnknown)
Next (LONGINT)

Name
LONGBOOL

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
LongBool : TSepiBooleanType

Sepi
Class Tree
Index
Previous (IUnknown)
Next (LONGINT)


Sepi

Sepi
Previous (LONGBOOL)
Next (LongString)

Name
LONGINT

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Longint : TSepiOrdType

Sepi
Class Tree
Index
Previous (LONGBOOL)
Next (LongString)


Sepi

Sepi
Previous (LONGINT)
Next (LONGWORD)

Name
LongString

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
LongString : TSepiStringType

Sepi
Class Tree
Index
Previous (LONGINT)
Next (LONGWORD)


Sepi

Sepi
Previous (LongString)
Next (OLEVARIANT)

Name
LONGWORD

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
LongWord : TSepiOrdType

Sepi
Class Tree
Index
Previous (LongString)
Next (OLEVARIANT)


Sepi

Sepi
Previous (LONGWORD)
Next (PAnsiChar)

Name
OLEVARIANT

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
OleVariant : TSepiVariantType

Sepi
Class Tree
Index
Previous (LONGWORD)
Next (PAnsiChar)


Sepi

Sepi
Previous (OLEVARIANT)
Next (PByte)

Name
PAnsiChar

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
PAnsiChar : TSepiPointerType

Sepi
Class Tree
Index
Previous (OLEVARIANT)
Next (PByte)


Sepi

Sepi
Previous (PAnsiChar)
Next (PCHAR)

Name
PByte

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
PByte : TSepiPointerType

Sepi
Class Tree
Index
Previous (PAnsiChar)
Next (PCHAR)


Sepi

Sepi
Previous (PByte)
Next (Pointer)

Name
PCHAR

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
PChar : TSepiPointerType

Sepi
Class Tree
Index
Previous (PByte)
Next (Pointer)


Sepi

Sepi
Previous (PCHAR)
Next (PWideChar)

Name
Pointer

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Pointer : TSepiPointerType

Sepi
Class Tree
Index
Previous (PCHAR)
Next (PWideChar)


Sepi

Sepi
Previous (Pointer)
Next (SHORTINT)

Name
PWideChar

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
PWideChar : TSepiPointerType

Sepi
Class Tree
Index
Previous (Pointer)
Next (SHORTINT)


Sepi

Sepi
Previous (PWideChar)
Next (ShortString)

Name
SHORTINT

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Shortint : TSepiOrdType

Sepi
Class Tree
Index
Previous (PWideChar)
Next (ShortString)


Sepi

Sepi
Previous (SHORTINT)
Next (SINGLE)

Name
ShortString

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
ShortString : TSepiShortStringType

Sepi
Class Tree
Index
Previous (SHORTINT)
Next (SINGLE)


Sepi

Sepi
Previous (ShortString)
Next (SMALLINT)

Name
SINGLE

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Single : TSepiFloatType

Sepi
Class Tree
Index
Previous (ShortString)
Next (SMALLINT)


Sepi

Sepi
Previous (SINGLE)
Next (TClass)

Name
SMALLINT

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Smallint : TSepiOrdType

Sepi
Class Tree
Index
Previous (SINGLE)
Next (TClass)


Sepi

Sepi
Previous (SMALLINT)
Next (TDateTime)

Name
TClass

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
TClass : TSepiMetaClass

Sepi
Class Tree
Index
Previous (SMALLINT)
Next (TDateTime)


Sepi

Sepi
Previous (TClass)
Next (TGUID)

Name
TDateTime

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
TDateTime : TSepiFloatType

Sepi
Class Tree
Index
Previous (TClass)
Next (TGUID)


Sepi

Sepi
Previous (TDateTime)
Next (TMethod)

Name
TGUID

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
TGUID : TSepiRecordType

Sepi
Class Tree
Index
Previous (TDateTime)
Next (TMethod)


Sepi

Sepi
Previous (TGUID)
Next (TObject)

Name
TMethod

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
TMethod : TSepiRecordType

Sepi
Class Tree
Index
Previous (TGUID)
Next (TObject)


Sepi

Sepi
Previous (TMethod)
Next (TVarRec)

Name
TObject

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
TObject : TSepiClass

Sepi
Class Tree
Index
Previous (TMethod)
Next (TVarRec)


Sepi

Sepi
Previous (TObject)
Next (UInt64)

Name
TVarRec

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
TVarRec : TSepiRecordType

Sepi
Class Tree
Index
Previous (TObject)
Next (UInt64)


Sepi

Sepi
Previous (TVarRec)
Next (UnicodeString)

Name
UInt64

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
UInt64 : TSepiInt64Type

Sepi
Class Tree
Index
Previous (TVarRec)
Next (UnicodeString)


Sepi

Sepi
Previous (UInt64)
Next (Untyped)

Name
UnicodeString

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
UnicodeString : TSepiStringType

Sepi
Class Tree
Index
Previous (UInt64)
Next (Untyped)


Sepi

Sepi
Previous (UnicodeString)
Next (VARIANT)

Name
Untyped

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Untyped : TSepiUntypedType

Sepi
Class Tree
Index
Previous (UnicodeString)
Next (VARIANT)


Sepi

Sepi
Previous (Untyped)
Next (WIDECHAR)

Name
VARIANT

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Variant : TSepiVariantType

Sepi
Class Tree
Index
Previous (Untyped)
Next (WIDECHAR)


Sepi

Sepi
Previous (VARIANT)
Next (WIDESTRING)

Name
WIDECHAR

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
WideChar : TSepiCharType

Sepi
Class Tree
Index
Previous (VARIANT)
Next (WIDESTRING)


Sepi

Sepi
Previous (WIDECHAR)
Next (WORD)

Name
WIDESTRING

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
WideString : TSepiStringType

Sepi
Class Tree
Index
Previous (WIDECHAR)
Next (WORD)


Sepi

Sepi
Previous (WIDESTRING)
Next (WORDBOOL)

Name
WORD

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
Word : TSepiOrdType

Sepi
Class Tree
Index
Previous (WIDESTRING)
Next (WORDBOOL)


Sepi

Sepi
Previous (WORD)
Next

Name
WORDBOOL

Parent
TSepiSystemTypes

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
WordBool : TSepiBooleanType

Sepi
Class Tree
Index
Previous (WORD)
Next


Sepi

Sepi
Previous (TSepiSystemTypes)
Next

Name
TSepiSystemUnit

Parent
SepiSystemUnit

Class Hierarchy
TSepiUnit

Visibility
PUBLIC

Description
Unité System

Members
Fields
Field | Description
FRemainingUnknownTypeCount (-) | Nombre de types encore inconnus
FTypes (-) | Types système

Methods
Method | Description
ChildAdded (#) | [@inheritDoc]
Create (+) | Crée l'unité System
CreateBuiltins (+) | Create builtins - components that are not even written in the System.pas file
Get (+) | Obtient l'unité System pour un composant Sepi donné
GetSystemType (+) | Trouve le type ordinal par défaut pour un type d'ordinal donné
GetSystemType (+) | Trouve le type flottant par défaut pour un type de flottant donné
GetSystemType (+) | Trouve le type système par défaut correspondant à un type donné
GetSystemType (+) | Trouve le type système par défaut pour un type de type donné
Load (+) | [@inheritDoc]

Properties
Property | Description
AnsiChar (+) | Types système
ANSISTRING (+) | Types système
BOOLEAN (+) | Types système
BYTE (+) | Types système
BYTEBOOL (+) | Types système
CARDINAL (+) | Types système
CHAR (+) | Types système
COMP (+) | Types système
CURRENCY (+) | Types système
DOUBLE (+) | Types système
EXTENDED (+) | Types système
HRESULT (+) | Types système
IDispatch (+) | Types système
IInterface (+) | Types système
INT64 (+) | Types système
INTEGER (+) | Types système
IUnknown (+) | Types système
LONGBOOL (+) | Types système
LONGINT (+) | Types système
LongString (+) | Types système
LONGWORD (+) | Types système
OLEVARIANT (+) | Types système
PAnsiChar (+) | Types système
PByte (+) | Types système
PCHAR (+) | Types système
Pointer (+) | Types système
PWideChar (+) | Types système
SHORTINT (+) | Types système
ShortString (+) | Types système
SINGLE (+) | Types système
SMALLINT (+) | Types système
TClass (+) | Types système
TDateTime (+) | Types système
TGUID (+) | Types système
TMethod (+) | Types système
TObject (+) | Types système
TVarRec (+) | Types système
Types (+) | Types système
UInt64 (+) | Types système
UnicodeString (+) | Types système
Untyped (+) | Types système
VARIANT (+) | Types système
WIDECHAR (+) | Types système
WIDESTRING (+) | Types système
WORD (+) | Types système
WORDBOOL (+) | Types système

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSepiSystemTypes)
Next


Sepi

Sepi
Previous
Next (FTypes)

Name
FRemainingUnknownTypeCount

Parent
TSepiSystemUnit

Visibility
PRIVATE

Description
Nombre de types encore inconnus

Source code
FRemainingUnknownTypeCount : Integer

Sepi
Class Tree
Index
Previous
Next (FTypes)


Sepi

Sepi
Previous (FRemainingUnknownTypeCount)
Next

Name
FTypes

Parent
TSepiSystemUnit

Visibility
PRIVATE

Description
Types système

Source code
FTypes : TSepiSystemTypes

Sepi
Class Tree
Index
Previous (FRemainingUnknownTypeCount)
Next


Sepi

Sepi
Previous
Next (ANSISTRING)

Name
AnsiChar

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property AnsiChar : TSepiCharType read FTypes . AnsiChar

Read Access
FTypes

Sepi
Class Tree
Index
Previous
Next (ANSISTRING)


Sepi

Sepi
Previous (AnsiChar)
Next (BOOLEAN)

Name
ANSISTRING

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property AnsiString : TSepiStringType read FTypes . AnsiString

Read Access
FTypes

Sepi
Class Tree
Index
Previous (AnsiChar)
Next (BOOLEAN)


Sepi

Sepi
Previous (ANSISTRING)
Next (BYTE)

Name
BOOLEAN

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Boolean : TSepiBooleanType read FTypes . Boolean

Read Access
FTypes

Sepi
Class Tree
Index
Previous (ANSISTRING)
Next (BYTE)


Sepi

Sepi
Previous (BOOLEAN)
Next (BYTEBOOL)

Name
BYTE

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Byte : TSepiOrdType read FTypes . Byte

Read Access
FTypes

Sepi
Class Tree
Index
Previous (BOOLEAN)
Next (BYTEBOOL)


Sepi

Sepi
Previous (BYTE)
Next (CARDINAL)

Name
BYTEBOOL

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property ByteBool : TSepiBooleanType read FTypes . ByteBool

Read Access
FTypes

Sepi
Class Tree
Index
Previous (BYTE)
Next (CARDINAL)


Sepi

Sepi
Previous (BYTEBOOL)
Next (CHAR)

Name
CARDINAL

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Cardinal : TSepiOrdType read FTypes . Cardinal

Read Access
FTypes

Sepi
Class Tree
Index
Previous (BYTEBOOL)
Next (CHAR)


Sepi

Sepi
Previous (CARDINAL)
Next (COMP)

Name
CHAR

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Char : TSepiCharType read FTypes . Char

Read Access
FTypes

Sepi
Class Tree
Index
Previous (CARDINAL)
Next (COMP)


Sepi

Sepi
Previous (CHAR)
Next (CURRENCY)

Name
COMP

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Comp : TSepiFloatType read FTypes . Comp

Read Access
FTypes

Sepi
Class Tree
Index
Previous (CHAR)
Next (CURRENCY)


Sepi

Sepi
Previous (COMP)
Next (DOUBLE)

Name
CURRENCY

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Currency : TSepiFloatType read FTypes . Currency

Read Access
FTypes

Sepi
Class Tree
Index
Previous (COMP)
Next (DOUBLE)


Sepi

Sepi
Previous (CURRENCY)
Next (EXTENDED)

Name
DOUBLE

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Double : TSepiFloatType read FTypes . Double

Read Access
FTypes

Sepi
Class Tree
Index
Previous (CURRENCY)
Next (EXTENDED)


Sepi

Sepi
Previous (DOUBLE)
Next (HRESULT)

Name
EXTENDED

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Extended : TSepiFloatType read FTypes . Extended

Read Access
FTypes

Sepi
Class Tree
Index
Previous (DOUBLE)
Next (HRESULT)


Sepi

Sepi
Previous (EXTENDED)
Next (IDispatch)

Name
HRESULT

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property HRESULT : TSepiIntegerType read FTypes . HRESULT

Read Access
FTypes

Sepi
Class Tree
Index
Previous (EXTENDED)
Next (IDispatch)


Sepi

Sepi
Previous (HRESULT)
Next (IInterface)

Name
IDispatch

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property IDispatch : TSepiInterface read FTypes . IDispatch

Read Access
FTypes

Sepi
Class Tree
Index
Previous (HRESULT)
Next (IInterface)


Sepi

Sepi
Previous (IDispatch)
Next (INT64)

Name
IInterface

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property IInterface : TSepiInterface read FTypes . IInterface

Read Access
FTypes

Sepi
Class Tree
Index
Previous (IDispatch)
Next (INT64)


Sepi

Sepi
Previous (IInterface)
Next (INTEGER)

Name
INT64

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Int64 : TSepiInt64Type read FTypes . Int64

Read Access
FTypes

Sepi
Class Tree
Index
Previous (IInterface)
Next (INTEGER)


Sepi

Sepi
Previous (INT64)
Next (IUnknown)

Name
INTEGER

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Integer : TSepiOrdType read FTypes . Integer

Read Access
FTypes

Sepi
Class Tree
Index
Previous (INT64)
Next (IUnknown)


Sepi

Sepi
Previous (INTEGER)
Next (LONGBOOL)

Name
IUnknown

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property IUnknown : TSepiInterface read FTypes . IUnknown

Read Access
FTypes

Sepi
Class Tree
Index
Previous (INTEGER)
Next (LONGBOOL)


Sepi

Sepi
Previous (IUnknown)
Next (LONGINT)

Name
LONGBOOL

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property LongBool : TSepiBooleanType read FTypes . LongBool

Read Access
FTypes

Sepi
Class Tree
Index
Previous (IUnknown)
Next (LONGINT)


Sepi

Sepi
Previous (LONGBOOL)
Next (LongString)

Name
LONGINT

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Longint : TSepiOrdType read FTypes . Longint

Read Access
FTypes

Sepi
Class Tree
Index
Previous (LONGBOOL)
Next (LongString)


Sepi

Sepi
Previous (LONGINT)
Next (LONGWORD)

Name
LongString

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property LongString : TSepiStringType read FTypes . LongString

Read Access
FTypes

Sepi
Class Tree
Index
Previous (LONGINT)
Next (LONGWORD)


Sepi

Sepi
Previous (LongString)
Next (OLEVARIANT)

Name
LONGWORD

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property LongWord : TSepiOrdType read FTypes . LongWord

Read Access
FTypes

Sepi
Class Tree
Index
Previous (LongString)
Next (OLEVARIANT)


Sepi

Sepi
Previous (LONGWORD)
Next (PAnsiChar)

Name
OLEVARIANT

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property OleVariant : TSepiVariantType read FTypes . OleVariant

Read Access
FTypes

Sepi
Class Tree
Index
Previous (LONGWORD)
Next (PAnsiChar)


Sepi

Sepi
Previous (OLEVARIANT)
Next (PByte)

Name
PAnsiChar

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property PAnsiChar : TSepiPointerType read FTypes . PAnsiChar

Read Access
FTypes

Sepi
Class Tree
Index
Previous (OLEVARIANT)
Next (PByte)


Sepi

Sepi
Previous (PAnsiChar)
Next (PCHAR)

Name
PByte

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property PByte : TSepiPointerType read FTypes . PByte

Read Access
FTypes

Sepi
Class Tree
Index
Previous (PAnsiChar)
Next (PCHAR)


Sepi

Sepi
Previous (PByte)
Next (Pointer)

Name
PCHAR

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property PChar : TSepiPointerType read FTypes . PChar

Read Access
FTypes

Sepi
Class Tree
Index
Previous (PByte)
Next (Pointer)


Sepi

Sepi
Previous (PCHAR)
Next (PWideChar)

Name
Pointer

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Pointer : TSepiPointerType read FTypes . Pointer

Read Access
FTypes

Sepi
Class Tree
Index
Previous (PCHAR)
Next (PWideChar)


Sepi

Sepi
Previous (Pointer)
Next (SHORTINT)

Name
PWideChar

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property PWideChar : TSepiPointerType read FTypes . PWideChar

Read Access
FTypes

Sepi
Class Tree
Index
Previous (Pointer)
Next (SHORTINT)


Sepi

Sepi
Previous (PWideChar)
Next (ShortString)

Name
SHORTINT

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Shortint : TSepiOrdType read FTypes . Shortint

Read Access
FTypes

Sepi
Class Tree
Index
Previous (PWideChar)
Next (ShortString)


Sepi

Sepi
Previous (SHORTINT)
Next (SINGLE)

Name
ShortString

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property ShortString : TSepiShortStringType read FTypes . ShortString

Read Access
FTypes

Sepi
Class Tree
Index
Previous (SHORTINT)
Next (SINGLE)


Sepi

Sepi
Previous (ShortString)
Next (SMALLINT)

Name
SINGLE

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Single : TSepiFloatType read FTypes . Single

Read Access
FTypes

Sepi
Class Tree
Index
Previous (ShortString)
Next (SMALLINT)


Sepi

Sepi
Previous (SINGLE)
Next (TClass)

Name
SMALLINT

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Smallint : TSepiOrdType read FTypes . Smallint

Read Access
FTypes

Sepi
Class Tree
Index
Previous (SINGLE)
Next (TClass)


Sepi

Sepi
Previous (SMALLINT)
Next (TDateTime)

Name
TClass

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property TClass : TSepiMetaClass read FTypes . TClass

Read Access
FTypes

Sepi
Class Tree
Index
Previous (SMALLINT)
Next (TDateTime)


Sepi

Sepi
Previous (TClass)
Next (TGUID)

Name
TDateTime

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property TDateTime : TSepiFloatType read FTypes . TDateTime

Read Access
FTypes

Sepi
Class Tree
Index
Previous (TClass)
Next (TGUID)


Sepi

Sepi
Previous (TDateTime)
Next (TMethod)

Name
TGUID

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property TGUID : TSepiRecordType read FTypes . TGUID

Read Access
FTypes

Sepi
Class Tree
Index
Previous (TDateTime)
Next (TMethod)


Sepi

Sepi
Previous (TGUID)
Next (TObject)

Name
TMethod

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property TMethod : TSepiRecordType read FTypes . TMethod

Read Access
FTypes

Sepi
Class Tree
Index
Previous (TGUID)
Next (TObject)


Sepi

Sepi
Previous (TMethod)
Next (TVarRec)

Name
TObject

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property TObject : TSepiClass read FTypes . TObject

Read Access
FTypes

Sepi
Class Tree
Index
Previous (TMethod)
Next (TVarRec)


Sepi

Sepi
Previous (TObject)
Next (Types)

Name
TVarRec

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property TVarRec : TSepiRecordType read FTypes . TVarRec

Read Access
FTypes

Sepi
Class Tree
Index
Previous (TObject)
Next (Types)


Sepi

Sepi
Previous (TVarRec)
Next (UInt64)

Name
Types

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Types : TSepiSystemTypes read FTypes

Read Access
FTypes

Sepi
Class Tree
Index
Previous (TVarRec)
Next (UInt64)


Sepi

Sepi
Previous (Types)
Next (UnicodeString)

Name
UInt64

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property UInt64 : TSepiInt64Type read FTypes . UInt64

Read Access
FTypes

Sepi
Class Tree
Index
Previous (Types)
Next (UnicodeString)


Sepi

Sepi
Previous (UInt64)
Next (Untyped)

Name
UnicodeString

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property UnicodeString : TSepiStringType read FTypes . UnicodeString

Read Access
FTypes

Sepi
Class Tree
Index
Previous (UInt64)
Next (Untyped)


Sepi

Sepi
Previous (UnicodeString)
Next (VARIANT)

Name
Untyped

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Untyped : TSepiUntypedType read FTypes . Untyped

Read Access
FTypes

Sepi
Class Tree
Index
Previous (UnicodeString)
Next (VARIANT)


Sepi

Sepi
Previous (Untyped)
Next (WIDECHAR)

Name
VARIANT

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Variant : TSepiVariantType read FTypes . Variant

Read Access
FTypes

Sepi
Class Tree
Index
Previous (Untyped)
Next (WIDECHAR)


Sepi

Sepi
Previous (VARIANT)
Next (WIDESTRING)

Name
WIDECHAR

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property WideChar : TSepiCharType read FTypes . WideChar

Read Access
FTypes

Sepi
Class Tree
Index
Previous (VARIANT)
Next (WIDESTRING)


Sepi

Sepi
Previous (WIDECHAR)
Next (WORD)

Name
WIDESTRING

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property WideString : TSepiStringType read FTypes . WideString

Read Access
FTypes

Sepi
Class Tree
Index
Previous (WIDECHAR)
Next (WORD)


Sepi

Sepi
Previous (WIDESTRING)
Next (WORDBOOL)

Name
WORD

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property Word : TSepiOrdType read FTypes . Word

Read Access
FTypes

Sepi
Class Tree
Index
Previous (WIDESTRING)
Next (WORDBOOL)


Sepi

Sepi
Previous (WORD)
Next

Name
WORDBOOL

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Types système

Source code
property WordBool : TSepiBooleanType read FTypes . WordBool

Read Access
FTypes

Sepi
Class Tree
Index
Previous (WORD)
Next


Sepi

Sepi
Previous
Next (Create)

Name
ChildAdded

Parent
TSepiSystemUnit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
procedure ChildAdded ( Child : TSepiComponent ) ; override

Parameters
Parameter | Description
Child : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (ChildAdded)
Next (CreateBuiltins)

Name
Create

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Crée l'unité System

Source code
constructor Create ( AOwner : TSepiComponent )

Parameters
Parameter | Description
AOwner : TSepiComponent | Propriétaire de l'unité

Sepi
Class Tree
Index
Previous (ChildAdded)
Next (CreateBuiltins)


Sepi

Sepi
Previous (Create)
Next (Get)

Name
CreateBuiltins

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Create builtins - components that are not even written in the System.pas file

Source code
procedure CreateBuiltins

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (Get)


Sepi

Sepi
Previous (CreateBuiltins)
Next (GetSystemType)

Name
Get

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Obtient l'unité System pour un composant Sepi donné

Source code
class function Get ( Component : TSepiComponent ) : TSepiSystemUnit ; static

Parameters
Parameter | Description
Component : TSepiComponent | Composant

Return
Types | Description
TSepiSystemUnit | Unité System correspondant au composant spécifié

Sepi
Class Tree
Index
Previous (CreateBuiltins)
Next (GetSystemType)


Sepi

Sepi
Previous (Get)
Next (GetSystemType)

Name
GetSystemType

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Trouve le type ordinal par défaut pour un type d'ordinal donné

Source code
function GetSystemType ( OrdType : TOrdType ) : TSepiOrdType ; overload

Parameters
Parameter | Description
OrdType : TOrdType | Type d'ordinal attendu

Return
Types | Description
TSepiOrdType | Type ordinal par défaut du type attendu

Sepi
Class Tree
Index
Previous (Get)
Next (GetSystemType)


Sepi

Sepi
Previous (GetSystemType)
Next (GetSystemType)

Name
GetSystemType

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Trouve le type flottant par défaut pour un type de flottant donné

Source code
function GetSystemType ( FloatType : TFloatType ) : TSepiFloatType ; overload

Parameters
Parameter | Description
FloatType : TFloatType | Type de flottant attendu

Return
Types | Description
TSepiFloatType | Type flottant par défaut du type attendu

Sepi
Class Tree
Index
Previous (GetSystemType)
Next (GetSystemType)


Sepi

Sepi
Previous (GetSystemType)
Next (GetSystemType)

Name
GetSystemType

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Trouve le type système par défaut correspondant à un type donné

Source code
function GetSystemType ( TypeInfo : PTypeInfo ) : TSepiType ; overload

Parameters
Parameter | Description
TypeInfo : PTypeInfo | RTTI d'un type

Return
Types | Description
TSepiType | Type système par défaut correspondant au type spécifié

Sepi
Class Tree
Index
Previous (GetSystemType)
Next (GetSystemType)


Sepi

Sepi
Previous (GetSystemType)
Next (Load)

Name
GetSystemType

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
Trouve le type système par défaut pour un type de type donné

Source code
function GetSystemType ( TypeKind : TTypeKind ) : TSepiType ; overload

Parameters
Parameter | Description
TypeKind : TTypeKind | Type de type attendu

Return
Types | Description
TSepiType | Type système par défaut du type attendu

Sepi
Class Tree
Index
Previous (GetSystemType)
Next (Load)


Sepi

Sepi
Previous (GetSystemType)
Next

Name
Load

Parent
TSepiSystemUnit

Visibility
PUBLIC

Description
[@inheritDoc]

Source code
constructor Load ( AOwner : TSepiComponent ; Stream : TStream ) ; override

Parameters
Parameter | Description
AOwner : TSepiComponent | #Pas de TAG trouvé dans le code source#
Stream : TStream | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (GetSystemType)
Next


Sepi

Sepi
Previous (SepiSystemUnit)
Next (SvImages)

Name
SvEdits

Parent
Sepi

Description
Composants de type Edit

Author
sjrd

Version
1.0

Classes
Class | Description
TSvCustomNumberEdit (+) | Classe de base pour les éditeurs de nombres
TSvNumberEdit (+) | Edit pour les nombres

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SepiSystemUnit)
Next (SvImages)


Sepi

Sepi
Previous
Next (TSvNumberEdit)

Name
TSvCustomNumberEdit

Parent
SvEdits

Class Hierarchy
TCustomEdit

Visibility
PUBLIC

Description
Classe de base pour les éditeurs de nombres
TSvCustomNumberEdit peut bloquer la saisie de nombres flottants ou de
nombres négatifs selon des propriétés. Il peut forcer le caractère de
séparations des décimales, une valeur minimum et une valeur maximum. Il peut
aussi assurer un préfixe et/ou un suffixe textuels sur le nombre.

Members
Fields
Field | Description
FAllowFrac (-) | Indique si les décimaux sont autorisés
FAllowNegative (-) | Indique si les négatifs sont autorisés
FHasMaxValue (-) | Indique si une valeur maximale est imposée
FHasMinValue (-) | Indique si une valeur minimale est imposée
FMaxValue (-) | Valeur maximale
FMinValue (-) | Valeur minimale
FPrefix (-) | Préfixe textuel
FReadingValue (-) | Valeur lue durant un chargement depuis dfm
FSeparator (-) | Caractère des séparation des décimales
FSuffix (-) | Suffixe textuel

Methods
Method | Description
Create (+) | Crée une instance de TSvCustomNumberEdit
GetInt (-) | Valeur courante sous forme entière
GetValue (-) | Valeur courante
KeyDown (#) | Exécuté lorsque l'utilisateur enfonce une touche
KeyPress (#) | Exécuté lorsque l'utilisateur presse une touche
Loaded (#) | Exécuté lorsque le composant a été chargé depuis un flux dfm
SelEnd (-) | Détermine la position de la fin de la sélection
SetAllowFrac (-) | Modifie l'autorisation des nombres décimaux
SetAllowNegative (-) | Modifie l'autorisation des nombres négatifs
SetHasMaxValue (-) | Modifie la prise en compte de la valeur maximale
SetHasMinValue (-) | Modifie la prise en compte de la valeur minimale
SetInt (-) | Modifie la valeur courante
SetMaxValue (-) | Modifie la valeur maximale
SetMinValue (-) | Modifie la valeur minimale
SetPrefix (-) | Modifie le préfixe textuel
SetSeparator (-) | Modifie le caractère de séparation des décimales
SetSuffix (-) | Modifie le suffixe textuel
SetValue (-) | Modifie la valeur courante

Properties
Property | Description
AllowFrac (#) | Indique si les décimaux sont autorisés
AllowNegative (#) | Indique si les négatifs sont autorisés
AutoSelect (#) | [@inheritDoc]
HasMaxValue (#) | Indique si une valeur maximale est imposée
HasMinValue (#) | Indique si une valeur minimale est imposée
Int (#) | Valeur courante sous forme entière
MaxValue (#) | Valeur maximale
MinValue (#) | Valeur minimale
Prefix (#) | Préfixe textuel
Separator (#) | Caractère des séparation des décimales
Suffix (#) | Suffixe textuel
Value (#) | Valeur courante

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSvNumberEdit)


Sepi

Sepi
Previous
Next (FAllowNegative)

Name
FAllowFrac

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Indique si les décimaux sont autorisés

Source code
FAllowFrac : Boolean

Sepi
Class Tree
Index
Previous
Next (FAllowNegative)


Sepi

Sepi
Previous (FAllowFrac)
Next (FHasMaxValue)

Name
FAllowNegative

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Indique si les négatifs sont autorisés

Source code
FAllowNegative : Boolean

Sepi
Class Tree
Index
Previous (FAllowFrac)
Next (FHasMaxValue)


Sepi

Sepi
Previous (FAllowNegative)
Next (FHasMinValue)

Name
FHasMaxValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Indique si une valeur maximale est imposée

Source code
FHasMaxValue : Boolean

Sepi
Class Tree
Index
Previous (FAllowNegative)
Next (FHasMinValue)


Sepi

Sepi
Previous (FHasMaxValue)
Next (FMaxValue)

Name
FHasMinValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Indique si une valeur minimale est imposée

Source code
FHasMinValue : Boolean

Sepi
Class Tree
Index
Previous (FHasMaxValue)
Next (FMaxValue)


Sepi

Sepi
Previous (FHasMinValue)
Next (FMinValue)

Name
FMaxValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Valeur maximale

Source code
FMaxValue : Double

Sepi
Class Tree
Index
Previous (FHasMinValue)
Next (FMinValue)


Sepi

Sepi
Previous (FMaxValue)
Next (FPrefix)

Name
FMinValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Valeur minimale

Source code
FMinValue : Double

Sepi
Class Tree
Index
Previous (FMaxValue)
Next (FPrefix)


Sepi

Sepi
Previous (FMinValue)
Next (FReadingValue)

Name
FPrefix

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Préfixe textuel

Source code
FPrefix : string

Sepi
Class Tree
Index
Previous (FMinValue)
Next (FReadingValue)


Sepi

Sepi
Previous (FPrefix)
Next (FSeparator)

Name
FReadingValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Valeur lue durant un chargement depuis dfm

Source code
FReadingValue : Double

Sepi
Class Tree
Index
Previous (FPrefix)
Next (FSeparator)


Sepi

Sepi
Previous (FReadingValue)
Next (FSuffix)

Name
FSeparator

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Caractère des séparation des décimales

Source code
FSeparator : Char

Sepi
Class Tree
Index
Previous (FReadingValue)
Next (FSuffix)


Sepi

Sepi
Previous (FSeparator)
Next

Name
FSuffix

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Suffixe textuel

Source code
FSuffix : string

Sepi
Class Tree
Index
Previous (FSeparator)
Next


Sepi

Sepi
Previous
Next (AllowNegative)

Name
AllowFrac

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Indique si les décimaux sont autorisés

Source code
property AllowFrac : Boolean read FAllowFrac write SetAllowFrac default False

Read Access
FAllowFrac

Write Access
SetAllowFrac

Sepi
Class Tree
Index
Previous
Next (AllowNegative)


Sepi

Sepi
Previous (AllowFrac)
Next (AutoSelect)

Name
AllowNegative

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Indique si les négatifs sont autorisés

Source code
property AllowNegative : Boolean read FAllowNegative write SetAllowNegative default False

Read Access
FAllowNegative

Write Access
SetAllowNegative

Sepi
Class Tree
Index
Previous (AllowFrac)
Next (AutoSelect)


Sepi

Sepi
Previous (AllowNegative)
Next (HasMaxValue)

Name
AutoSelect

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property AutoSelect default False

Sepi
Class Tree
Index
Previous (AllowNegative)
Next (HasMaxValue)


Sepi

Sepi
Previous (AutoSelect)
Next (HasMinValue)

Name
HasMaxValue

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Indique si une valeur maximale est imposée

Source code
property HasMaxValue : Boolean read FHasMaxValue write SetHasMaxValue default False

Read Access
FHasMaxValue

Write Access
SetHasMaxValue

Sepi
Class Tree
Index
Previous (AutoSelect)
Next (HasMinValue)


Sepi

Sepi
Previous (HasMaxValue)
Next (Int)

Name
HasMinValue

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Indique si une valeur minimale est imposée

Source code
property HasMinValue : Boolean read FHasMinValue write SetHasMinValue default False

Read Access
FHasMinValue

Write Access
SetHasMinValue

Sepi
Class Tree
Index
Previous (HasMaxValue)
Next (Int)


Sepi

Sepi
Previous (HasMinValue)
Next (MaxValue)

Name
Int

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Valeur courante sous forme entière

Source code
property Int : Integer read GetInt write SetInt

Read Access
GetInt

Write Access
SetInt

Sepi
Class Tree
Index
Previous (HasMinValue)
Next (MaxValue)


Sepi

Sepi
Previous (Int)
Next (MinValue)

Name
MaxValue

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Valeur maximale

Source code
property MaxValue : Double read FMaxValue write SetMaxValue

Read Access
FMaxValue

Write Access
SetMaxValue

Sepi
Class Tree
Index
Previous (Int)
Next (MinValue)


Sepi

Sepi
Previous (MaxValue)
Next (Prefix)

Name
MinValue

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Valeur minimale

Source code
property MinValue : Double read FMinValue write SetMinValue

Read Access
FMinValue

Write Access
SetMinValue

Sepi
Class Tree
Index
Previous (MaxValue)
Next (Prefix)


Sepi

Sepi
Previous (MinValue)
Next (Separator)

Name
Prefix

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Préfixe textuel

Source code
property Prefix : string read FPrefix write SetPrefix

Read Access
FPrefix

Write Access
SetPrefix

Sepi
Class Tree
Index
Previous (MinValue)
Next (Separator)


Sepi

Sepi
Previous (Prefix)
Next (Suffix)

Name
Separator

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Caractère des séparation des décimales

Source code
property Separator : Char read FSeparator write SetSeparator default ','

Read Access
FSeparator

Write Access
SetSeparator

Sepi
Class Tree
Index
Previous (Prefix)
Next (Suffix)


Sepi

Sepi
Previous (Separator)
Next (Value)

Name
Suffix

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Suffixe textuel

Source code
property Suffix : string read FSuffix write SetSuffix

Read Access
FSuffix

Write Access
SetSuffix

Sepi
Class Tree
Index
Previous (Separator)
Next (Value)


Sepi

Sepi
Previous (Suffix)
Next

Name
Value

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Valeur courante

Source code
property Value : Double read GetValue write SetValue

Read Access
GetValue

Write Access
SetValue

Sepi
Class Tree
Index
Previous (Suffix)
Next


Sepi

Sepi
Previous
Next (GetInt)

Name
Create

Parent
TSvCustomNumberEdit

Visibility
PUBLIC

Description
Crée une instance de TSvCustomNumberEdit

Source code
constructor Create ( AOwner : TComponent ) ; override

Parameters
Parameter | Description
AOwner : TComponent | Propriétaire

Sepi
Class Tree
Index
Previous
Next (GetInt)


Sepi

Sepi
Previous (Create)
Next (GetValue)

Name
GetInt

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Valeur courante sous forme entière

Source code
function GetInt : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Valeur courante

Sepi
Class Tree
Index
Previous (Create)
Next (GetValue)


Sepi

Sepi
Previous (GetInt)
Next (KeyDown)

Name
GetValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Valeur courante

Source code
function GetValue : Double

Parameters
Parameter Description

Return
Types | Description
DOUBLE | Valeur courante

Sepi
Class Tree
Index
Previous (GetInt)
Next (KeyDown)


Sepi

Sepi
Previous (GetValue)
Next (KeyPress)

Name
KeyDown

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Exécuté lorsque l'utilisateur enfonce une touche

Source code
procedure KeyDown ( var Key : Word ; Shift : TShiftState ) ; override

Parameters
Parameter | Description
Key : WORD | Code de la touche enfoncée
Shift : TShiftState | État des touches système et des boutons de souris

Sepi
Class Tree
Index
Previous (GetValue)
Next (KeyPress)


Sepi

Sepi
Previous (KeyDown)
Next (Loaded)

Name
KeyPress

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Exécuté lorsque l'utilisateur presse une touche

Source code
procedure KeyPress ( var Key : Char ) ; override

Parameters
Parameter | Description
Key : CHAR | Code ASCII de la touche pressée

Sepi
Class Tree
Index
Previous (KeyDown)
Next (Loaded)


Sepi

Sepi
Previous (KeyPress)
Next (SelEnd)

Name
Loaded

Parent
TSvCustomNumberEdit

Visibility
PROTECTED

Description
Exécuté lorsque le composant a été chargé depuis un flux dfm

Source code
procedure Loaded ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (KeyPress)
Next (SelEnd)


Sepi

Sepi
Previous (Loaded)
Next (SetAllowFrac)

Name
SelEnd

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Détermine la position de la fin de la sélection

Source code
function SelEnd : Integer

Parameters
Parameter Description

Return
Types | Description
INTEGER | Position de la fin de la sélection

Sepi
Class Tree
Index
Previous (Loaded)
Next (SetAllowFrac)


Sepi

Sepi
Previous (SelEnd)
Next (SetAllowNegative)

Name
SetAllowFrac

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie l'autorisation des nombres décimaux

Source code
procedure SetAllowFrac ( New : Boolean )

Parameters
Parameter | Description
New : BOOLEAN | True pour autoriser les nombres décimaux, False pour interdire

Sepi
Class Tree
Index
Previous (SelEnd)
Next (SetAllowNegative)


Sepi

Sepi
Previous (SetAllowFrac)
Next (SetHasMaxValue)

Name
SetAllowNegative

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie l'autorisation des nombres négatifs

Source code
procedure SetAllowNegative ( New : Boolean )

Parameters
Parameter | Description
New : BOOLEAN | True pour autoriser les nombres négatifs, False pour interdire

Sepi
Class Tree
Index
Previous (SetAllowFrac)
Next (SetHasMaxValue)


Sepi

Sepi
Previous (SetAllowNegative)
Next (SetHasMinValue)

Name
SetHasMaxValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie la prise en compte de la valeur maximale

Source code
procedure SetHasMaxValue ( New : Boolean )

Parameters
Parameter | Description
New : BOOLEAN | True pour la prendre en compte, False pour ne pas le faire

Sepi
Class Tree
Index
Previous (SetAllowNegative)
Next (SetHasMinValue)


Sepi

Sepi
Previous (SetHasMaxValue)
Next (SetInt)

Name
SetHasMinValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie la prise en compte de la valeur minimale

Source code
procedure SetHasMinValue ( New : Boolean )

Parameters
Parameter | Description
New : BOOLEAN | True pour la prendre en compte, False pour ne pas le faire

Sepi
Class Tree
Index
Previous (SetHasMaxValue)
Next (SetInt)


Sepi

Sepi
Previous (SetHasMinValue)
Next (SetMaxValue)

Name
SetInt

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie la valeur courante

Source code
procedure SetInt ( New : Integer )

Parameters
Parameter | Description
New : INTEGER | Nouvelle valeur

Sepi
Class Tree
Index
Previous (SetHasMinValue)
Next (SetMaxValue)


Sepi

Sepi
Previous (SetInt)
Next (SetMinValue)

Name
SetMaxValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie la valeur maximale

Source code
procedure SetMaxValue ( New : Double )

Parameters
Parameter | Description
New : DOUBLE | Nouvelle valeur maximale

Sepi
Class Tree
Index
Previous (SetInt)
Next (SetMinValue)


Sepi

Sepi
Previous (SetMaxValue)
Next (SetPrefix)

Name
SetMinValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie la valeur minimale

Source code
procedure SetMinValue ( New : Double )

Parameters
Parameter | Description
New : DOUBLE | Nouvelle valeur minimale

Sepi
Class Tree
Index
Previous (SetMaxValue)
Next (SetPrefix)


Sepi

Sepi
Previous (SetMinValue)
Next (SetSeparator)

Name
SetPrefix

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie le préfixe textuel

Source code
procedure SetPrefix ( New : string )

Parameters
Parameter | Description
New : STRING | Nouveau préfixe textuel

Sepi
Class Tree
Index
Previous (SetMinValue)
Next (SetSeparator)


Sepi

Sepi
Previous (SetPrefix)
Next (SetSuffix)

Name
SetSeparator

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie le caractère de séparation des décimales

Source code
procedure SetSeparator ( New : Char )

Parameters
Parameter | Description
New : CHAR | Nouveau caractère de séparation

Sepi
Class Tree
Index
Previous (SetPrefix)
Next (SetSuffix)


Sepi

Sepi
Previous (SetSeparator)
Next (SetValue)

Name
SetSuffix

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie le suffixe textuel

Source code
procedure SetSuffix ( New : string )

Parameters
Parameter | Description
New : STRING | Nouveau suffixe textuel

Sepi
Class Tree
Index
Previous (SetSeparator)
Next (SetValue)


Sepi

Sepi
Previous (SetSuffix)
Next

Name
SetValue

Parent
TSvCustomNumberEdit

Visibility
PRIVATE

Description
Modifie la valeur courante

Source code
procedure SetValue ( New : Double )

Parameters
Parameter | Description
New : DOUBLE | Nouvelle valeur

Sepi
Class Tree
Index
Previous (SetSuffix)
Next


Sepi

Sepi
Previous (TSvCustomNumberEdit)
Next

Name
TSvNumberEdit

Parent
SvEdits

Class Hierarchy
TSvCustomNumberEdit

Visibility
PUBLIC

Description
Edit pour les nombres
TSvCustomNumberEdit peut bloquer la saisie de nombres flottants ou de
nombres négatifs selon des propriétés. Il peut forcer le caractère de
séparations des décimales, une valeur minimum et une valeur maximum. Il peut
aussi assurer un préfixe et/ou un suffixe textuels sur le nombre.

Members
Properties
Property | Description
Action (*) | #No TAG found in source code#
Align (*) | #No TAG found in source code#
AllowFrac (*) | #No TAG found in source code#
AllowNegative (*) | #No TAG found in source code#
Anchors (*) | #No TAG found in source code#
AutoSelect (*) | #No TAG found in source code#
AutoSize (*) | #No TAG found in source code#
BiDiMode (*) | #No TAG found in source code#
BorderStyle (*) | #No TAG found in source code#
Constraints (*) | #No TAG found in source code#
DockOrientation (*) | #No TAG found in source code#
Enabled (*) | #No TAG found in source code#
FloatingDockSiteClass (*) | #No TAG found in source code#
HasMaxValue (*) | #No TAG found in source code#
HasMinValue (*) | #No TAG found in source code#
HideSelection (*) | #No TAG found in source code#
Int (+) | #No TAG found in source code#
MaxValue (*) | #No TAG found in source code#
MinValue (*) | #No TAG found in source code#
OnCanResize (*) | #No TAG found in source code#
OnChange (*) | #No TAG found in source code#
OnClick (*) | #No TAG found in source code#
OnConstrainedResize (*) | #No TAG found in source code#
OnContextPopup (*) | #No TAG found in source code#
OnDblClick (*) | #No TAG found in source code#
OnDockDrop (*) | #No TAG found in source code#
OnDockOver (*) | #No TAG found in source code#
OnDragDrop (*) | #No TAG found in source code#
OnDragOver (*) | #No TAG found in source code#
OnEndDock (*) | #No TAG found in source code#
OnEndDrag (*) | #No TAG found in source code#
OnEnter (*) | #No TAG found in source code#
OnExit (*) | #No TAG found in source code#
OnGetSiteInfo (*) | #No TAG found in source code#
OnKeyDown (*) | #No TAG found in source code#
OnKeyPress (*) | #No TAG found in source code#
OnKeyUp (*) | #No TAG found in source code#
OnMouseDown (*) | #No TAG found in source code#
OnMouseMove (*) | #No TAG found in source code#
OnMouseUp (*) | #No TAG found in source code#
OnMouseWheel (*) | #No TAG found in source code#
OnMouseWheelDown (*) | #No TAG found in source code#
OnMouseWheelUp (*) | #No TAG found in source code#
OnResize (*) | #No TAG found in source code#
OnStartDock (*) | #No TAG found in source code#
OnStartDrag (*) | #No TAG found in source code#
OnUnDock (*) | #No TAG found in source code#
ParentColor (*) | #No TAG found in source code#
Prefix (*) | #No TAG found in source code#
READONLY (*) | #No TAG found in source code#
Separator (*) | #No TAG found in source code#
ShowHint (*) | #No TAG found in source code#
Suffix (*) | #No TAG found in source code#
TabOrder (*) | #No TAG found in source code#
Value (*) | #No TAG found in source code#
Visible (*) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSvCustomNumberEdit)
Next


Sepi

Sepi
Previous
Next (Align)

Name
Action

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Action

Sepi
Class Tree
Index
Previous
Next (Align)


Sepi

Sepi
Previous (Action)
Next (AllowFrac)

Name
Align

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Align

Sepi
Class Tree
Index
Previous (Action)
Next (AllowFrac)


Sepi

Sepi
Previous (Align)
Next (AllowNegative)

Name
AllowFrac

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property AllowFrac

Sepi
Class Tree
Index
Previous (Align)
Next (AllowNegative)


Sepi

Sepi
Previous (AllowFrac)
Next (Anchors)

Name
AllowNegative

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property AllowNegative

Sepi
Class Tree
Index
Previous (AllowFrac)
Next (Anchors)


Sepi

Sepi
Previous (AllowNegative)
Next (AutoSelect)

Name
Anchors

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Anchors

Sepi
Class Tree
Index
Previous (AllowNegative)
Next (AutoSelect)


Sepi

Sepi
Previous (Anchors)
Next (AutoSize)

Name
AutoSelect

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property AutoSelect

Sepi
Class Tree
Index
Previous (Anchors)
Next (AutoSize)


Sepi

Sepi
Previous (AutoSelect)
Next (BiDiMode)

Name
AutoSize

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property AutoSize

Sepi
Class Tree
Index
Previous (AutoSelect)
Next (BiDiMode)


Sepi

Sepi
Previous (AutoSize)
Next (BorderStyle)

Name
BiDiMode

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property BiDiMode

Sepi
Class Tree
Index
Previous (AutoSize)
Next (BorderStyle)


Sepi

Sepi
Previous (BiDiMode)
Next (Constraints)

Name
BorderStyle

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property BorderStyle

Sepi
Class Tree
Index
Previous (BiDiMode)
Next (Constraints)


Sepi

Sepi
Previous (BorderStyle)
Next (DockOrientation)

Name
Constraints

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Constraints

Sepi
Class Tree
Index
Previous (BorderStyle)
Next (DockOrientation)


Sepi

Sepi
Previous (Constraints)
Next (Enabled)

Name
DockOrientation

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property DockOrientation

Sepi
Class Tree
Index
Previous (Constraints)
Next (Enabled)


Sepi

Sepi
Previous (DockOrientation)
Next (FloatingDockSiteClass)

Name
Enabled

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Enabled

Sepi
Class Tree
Index
Previous (DockOrientation)
Next (FloatingDockSiteClass)


Sepi

Sepi
Previous (Enabled)
Next (HasMaxValue)

Name
FloatingDockSiteClass

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property FloatingDockSiteClass

Sepi
Class Tree
Index
Previous (Enabled)
Next (HasMaxValue)


Sepi

Sepi
Previous (FloatingDockSiteClass)
Next (HasMinValue)

Name
HasMaxValue

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property HasMaxValue

Sepi
Class Tree
Index
Previous (FloatingDockSiteClass)
Next (HasMinValue)


Sepi

Sepi
Previous (HasMaxValue)
Next (HideSelection)

Name
HasMinValue

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property HasMinValue

Sepi
Class Tree
Index
Previous (HasMaxValue)
Next (HideSelection)


Sepi

Sepi
Previous (HasMinValue)
Next (Int)

Name
HideSelection

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property HideSelection

Sepi
Class Tree
Index
Previous (HasMinValue)
Next (Int)


Sepi

Sepi
Previous (HideSelection)
Next (MaxValue)

Name
Int

Parent
TSvNumberEdit

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
property Int

Sepi
Class Tree
Index
Previous (HideSelection)
Next (MaxValue)


Sepi

Sepi
Previous (Int)
Next (MinValue)

Name
MaxValue

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property MaxValue

Sepi
Class Tree
Index
Previous (Int)
Next (MinValue)


Sepi

Sepi
Previous (MaxValue)
Next (OnCanResize)

Name
MinValue

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property MinValue

Sepi
Class Tree
Index
Previous (MaxValue)
Next (OnCanResize)


Sepi

Sepi
Previous (MinValue)
Next (OnChange)

Name
OnCanResize

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnCanResize

Sepi
Class Tree
Index
Previous (MinValue)
Next (OnChange)


Sepi

Sepi
Previous (OnCanResize)
Next (OnClick)

Name
OnChange

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnChange

Sepi
Class Tree
Index
Previous (OnCanResize)
Next (OnClick)


Sepi

Sepi
Previous (OnChange)
Next (OnConstrainedResize)

Name
OnClick

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnClick

Sepi
Class Tree
Index
Previous (OnChange)
Next (OnConstrainedResize)


Sepi

Sepi
Previous (OnClick)
Next (OnContextPopup)

Name
OnConstrainedResize

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnConstrainedResize

Sepi
Class Tree
Index
Previous (OnClick)
Next (OnContextPopup)


Sepi

Sepi
Previous (OnConstrainedResize)
Next (OnDblClick)

Name
OnContextPopup

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnContextPopup

Sepi
Class Tree
Index
Previous (OnConstrainedResize)
Next (OnDblClick)


Sepi

Sepi
Previous (OnContextPopup)
Next (OnDockDrop)

Name
OnDblClick

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDblClick

Sepi
Class Tree
Index
Previous (OnContextPopup)
Next (OnDockDrop)


Sepi

Sepi
Previous (OnDblClick)
Next (OnDockOver)

Name
OnDockDrop

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDockDrop

Sepi
Class Tree
Index
Previous (OnDblClick)
Next (OnDockOver)


Sepi

Sepi
Previous (OnDockDrop)
Next (OnDragDrop)

Name
OnDockOver

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDockOver

Sepi
Class Tree
Index
Previous (OnDockDrop)
Next (OnDragDrop)


Sepi

Sepi
Previous (OnDockOver)
Next (OnDragOver)

Name
OnDragDrop

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDragDrop

Sepi
Class Tree
Index
Previous (OnDockOver)
Next (OnDragOver)


Sepi

Sepi
Previous (OnDragDrop)
Next (OnEndDock)

Name
OnDragOver

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDragOver

Sepi
Class Tree
Index
Previous (OnDragDrop)
Next (OnEndDock)


Sepi

Sepi
Previous (OnDragOver)
Next (OnEndDrag)

Name
OnEndDock

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnEndDock

Sepi
Class Tree
Index
Previous (OnDragOver)
Next (OnEndDrag)


Sepi

Sepi
Previous (OnEndDock)
Next (OnEnter)

Name
OnEndDrag

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnEndDrag

Sepi
Class Tree
Index
Previous (OnEndDock)
Next (OnEnter)


Sepi

Sepi
Previous (OnEndDrag)
Next (OnExit)

Name
OnEnter

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnEnter

Sepi
Class Tree
Index
Previous (OnEndDrag)
Next (OnExit)


Sepi

Sepi
Previous (OnEnter)
Next (OnGetSiteInfo)

Name
OnExit

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnExit

Sepi
Class Tree
Index
Previous (OnEnter)
Next (OnGetSiteInfo)


Sepi

Sepi
Previous (OnExit)
Next (OnKeyDown)

Name
OnGetSiteInfo

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnGetSiteInfo

Sepi
Class Tree
Index
Previous (OnExit)
Next (OnKeyDown)


Sepi

Sepi
Previous (OnGetSiteInfo)
Next (OnKeyPress)

Name
OnKeyDown

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnKeyDown

Sepi
Class Tree
Index
Previous (OnGetSiteInfo)
Next (OnKeyPress)


Sepi

Sepi
Previous (OnKeyDown)
Next (OnKeyUp)

Name
OnKeyPress

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnKeyPress

Sepi
Class Tree
Index
Previous (OnKeyDown)
Next (OnKeyUp)


Sepi

Sepi
Previous (OnKeyPress)
Next (OnMouseDown)

Name
OnKeyUp

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnKeyUp

Sepi
Class Tree
Index
Previous (OnKeyPress)
Next (OnMouseDown)


Sepi

Sepi
Previous (OnKeyUp)
Next (OnMouseMove)

Name
OnMouseDown

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseDown

Sepi
Class Tree
Index
Previous (OnKeyUp)
Next (OnMouseMove)


Sepi

Sepi
Previous (OnMouseDown)
Next (OnMouseUp)

Name
OnMouseMove

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseMove

Sepi
Class Tree
Index
Previous (OnMouseDown)
Next (OnMouseUp)


Sepi

Sepi
Previous (OnMouseMove)
Next (OnMouseWheel)

Name
OnMouseUp

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseUp

Sepi
Class Tree
Index
Previous (OnMouseMove)
Next (OnMouseWheel)


Sepi

Sepi
Previous (OnMouseUp)
Next (OnMouseWheelDown)

Name
OnMouseWheel

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseWheel

Sepi
Class Tree
Index
Previous (OnMouseUp)
Next (OnMouseWheelDown)


Sepi

Sepi
Previous (OnMouseWheel)
Next (OnMouseWheelUp)

Name
OnMouseWheelDown

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseWheelDown

Sepi
Class Tree
Index
Previous (OnMouseWheel)
Next (OnMouseWheelUp)


Sepi

Sepi
Previous (OnMouseWheelDown)
Next (OnResize)

Name
OnMouseWheelUp

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseWheelUp

Sepi
Class Tree
Index
Previous (OnMouseWheelDown)
Next (OnResize)


Sepi

Sepi
Previous (OnMouseWheelUp)
Next (OnStartDock)

Name
OnResize

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnResize

Sepi
Class Tree
Index
Previous (OnMouseWheelUp)
Next (OnStartDock)


Sepi

Sepi
Previous (OnResize)
Next (OnStartDrag)

Name
OnStartDock

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnStartDock

Sepi
Class Tree
Index
Previous (OnResize)
Next (OnStartDrag)


Sepi

Sepi
Previous (OnStartDock)
Next (OnUnDock)

Name
OnStartDrag

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnStartDrag

Sepi
Class Tree
Index
Previous (OnStartDock)
Next (OnUnDock)


Sepi

Sepi
Previous (OnStartDrag)
Next (ParentColor)

Name
OnUnDock

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnUnDock

Sepi
Class Tree
Index
Previous (OnStartDrag)
Next (ParentColor)


Sepi

Sepi
Previous (OnUnDock)
Next (Prefix)

Name
ParentColor

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParentColor

Sepi
Class Tree
Index
Previous (OnUnDock)
Next (Prefix)


Sepi

Sepi
Previous (ParentColor)
Next (READONLY)

Name
Prefix

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Prefix

Sepi
Class Tree
Index
Previous (ParentColor)
Next (READONLY)


Sepi

Sepi
Previous (Prefix)
Next (Separator)

Name
READONLY

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ReadOnly

Sepi
Class Tree
Index
Previous (Prefix)
Next (Separator)


Sepi

Sepi
Previous (READONLY)
Next (ShowHint)

Name
Separator

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Separator

Sepi
Class Tree
Index
Previous (READONLY)
Next (ShowHint)


Sepi

Sepi
Previous (Separator)
Next (Suffix)

Name
ShowHint

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ShowHint

Sepi
Class Tree
Index
Previous (Separator)
Next (Suffix)


Sepi

Sepi
Previous (ShowHint)
Next (TabOrder)

Name
Suffix

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Suffix

Sepi
Class Tree
Index
Previous (ShowHint)
Next (TabOrder)


Sepi

Sepi
Previous (Suffix)
Next (Value)

Name
TabOrder

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property TabOrder

Sepi
Class Tree
Index
Previous (Suffix)
Next (Value)


Sepi

Sepi
Previous (TabOrder)
Next (Visible)

Name
Value

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Value

Sepi
Class Tree
Index
Previous (TabOrder)
Next (Visible)


Sepi

Sepi
Previous (Value)
Next

Name
Visible

Parent
TSvNumberEdit

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Visible

Sepi
Class Tree
Index
Previous (Value)
Next


Sepi

Sepi
Previous (SvEdits)
Next (SvLabels)

Name
SvImages

Parent
Sepi

Description
Composants de type Image

Author
sjrd

Version
1.0

Types
Type | Description
TDropImageEvent (+) | Type de l'événement TSvDropImage.OnDrop

Classes
Class | Description
TSvDropImage (+) | Image pouvant être « prise » et déposée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SvEdits)
Next (SvLabels)


Sepi

Sepi
Previous
Next

Name
TSvDropImage

Parent
SvImages

Class Hierarchy
TImage

Visibility
PUBLIC

Description
Image pouvant être « prise » et déposée
TSvDropImage est une image qui peut être « prise » au moyen d'un clic de
souris et déposée par glisser-déposer soit sur le parent, soit sur un autre
contrôle. Ce composant permet de constituer de façon très simple une palette
de glisser-déposer.

Members
Fields
Field | Description
FDropControl (-) | Contrôle sur lequel il faut déposer l'image
FOnDrop (-) | Exécuté lorsque l'image a été déposée
ImageBis (-) | Copie de l'image en train d'être glissée

Methods
Method | Description
Create (+) | Crée une instance de TSvDropImage
MouseDown (#) | Exécuté lorsque l'utilisateur enfonce le bouton de la souris
MouseMove (#) | Exécuté lorsque l'utilisateur déplace la souris
MouseUp (#) | Exécuté lorsque l'utilisateur relâche le bouton de la souris
MoveBisAt (-) | Déplace la copie en déplacement de l'image à des coordonnées spécifiées

Properties
Property | Description
DropControl (*) | Contrôle sur lequel il faut déposer l'image
OnDrop (*) | Exécuté lorsque l'image a été déposée

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous
Next (FOnDrop)

Name
FDropControl

Parent
TSvDropImage

Visibility
PRIVATE

Description
Contrôle sur lequel il faut déposer l'image

Source code
FDropControl : TControl

Sepi
Class Tree
Index
Previous
Next (FOnDrop)


Sepi

Sepi
Previous (FDropControl)
Next (ImageBis)

Name
FOnDrop

Parent
TSvDropImage

Visibility
PRIVATE

Description
Exécuté lorsque l'image a été déposée

Source code
FOnDrop : TDropImageEvent

Sepi
Class Tree
Index
Previous (FDropControl)
Next (ImageBis)


Sepi

Sepi
Previous (FOnDrop)
Next

Name
ImageBis

Parent
TSvDropImage

Visibility
PRIVATE

Description
Copie de l'image en train d'être glissée

Source code
ImageBis : TImage

Sepi
Class Tree
Index
Previous (FOnDrop)
Next


Sepi

Sepi
Previous
Next (OnDrop)

Name
DropControl

Parent
TSvDropImage

Visibility
PUBLISHED

Description
Contrôle sur lequel il faut déposer l'image

Source code
property DropControl : TControl read FDropControl write FDropControl

Read Access
FDropControl

Write Access
FDropControl

Sepi
Class Tree
Index
Previous
Next (OnDrop)


Sepi

Sepi
Previous (DropControl)
Next

Name
OnDrop

Parent
TSvDropImage

Visibility
PUBLISHED

Description
Exécuté lorsque l'image a été déposée

Source code
property OnDrop : TDropImageEvent read FOnDrop write FOnDrop

Read Access
FOnDrop

Write Access
FOnDrop

Sepi
Class Tree
Index
Previous (DropControl)
Next


Sepi

Sepi
Previous
Next (MouseDown)

Name
Create

Parent
TSvDropImage

Visibility
PUBLIC

Description
Crée une instance de TSvDropImage

Source code
constructor Create ( AOwner : TComponent ) ; override

Parameters
Parameter | Description
AOwner : TComponent | Propriétaire

Sepi
Class Tree
Index
Previous
Next (MouseDown)


Sepi

Sepi
Previous (Create)
Next (MouseMove)

Name
MouseDown

Parent
TSvDropImage

Visibility
PROTECTED

Description
Exécuté lorsque l'utilisateur enfonce le bouton de la souris

Source code
procedure MouseDown ( Button : TMouseButton ; Shift : TShiftState ; X , Y : Integer ) ; override

Parameters
Parameter | Description
Button : TMouseButton | Bouton de souris enfoncé
Shift : TShiftState | État des touches système et des boutons de souris
X : INTEGER | Coordonnée X du point de clic
Y : INTEGER | Coordonnée Y du point de clic

Sepi
Class Tree
Index
Previous (Create)
Next (MouseMove)


Sepi

Sepi
Previous (MouseDown)
Next (MouseUp)

Name
MouseMove

Parent
TSvDropImage

Visibility
PROTECTED

Description
Exécuté lorsque l'utilisateur déplace la souris

Source code
procedure MouseMove ( Shift : TShiftState ; X , Y : Integer ) ; override

Parameters
Parameter | Description
Shift : TShiftState | État des touches système et des boutons de souris
X : INTEGER | Coordonnée X de la souris
Y : INTEGER | Coordonnée Y de la souris

Sepi
Class Tree
Index
Previous (MouseDown)
Next (MouseUp)


Sepi

Sepi
Previous (MouseMove)
Next (MoveBisAt)

Name
MouseUp

Parent
TSvDropImage

Visibility
PROTECTED

Description
Exécuté lorsque l'utilisateur relâche le bouton de la souris

Source code
procedure MouseUp ( Button : TMouseButton ; Shift : TShiftState ; X , Y : Integer ) ; override

Parameters
Parameter | Description
Button : TMouseButton | Bouton de souris relâché
Shift : TShiftState | État des touches système et des boutons de souris
X : INTEGER | Coordonnée X du point de relâche
Y : INTEGER | Coordonnée Y du point de relâche

Sepi
Class Tree
Index
Previous (MouseMove)
Next (MoveBisAt)


Sepi

Sepi
Previous (MouseUp)
Next

Name
MoveBisAt

Parent
TSvDropImage

Visibility
PRIVATE

Description
Déplace la copie en déplacement de l'image à des coordonnées spécifiées

Source code
procedure MoveBisAt ( X , Y : Integer )

Parameters
Parameter | Description
X : INTEGER | Coordonnée X du point sur lequel centrer la copie de l'image
Y : INTEGER | Coordonnée Y du point sur lequel centrer la copie de l'image

Sepi
Class Tree
Index
Previous (MouseUp)
Next


Sepi

Sepi
Previous
Next

Name
TDropImageEvent

Parent
SvImages

Visibility
PUBLIC

Description
Type de l'événement TSvDropImage.OnDrop

Source code
TDropImageEvent = procedure ( Sender : TObject ; X , Y : Integer ) of object ;

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement
X : INTEGER | Coordonnée X de dépôt de l'image
Y : INTEGER | Coordonnée Y de dépôt de l'image

Sepi
Class Tree
Index
Previous
Next


Sepi

Sepi
Previous (SvImages)
Next (TypesInfo)

Name
SvLabels

Parent
Sepi

Description
Composants de type Label

Author
sjrd

Version
1.0

Constants
Constant | Description
sCopyCaption (+) | #No TAG found in source code#
sCopyHint (+) | #No TAG found in source code#
sRunCaption (+) | #No TAG found in source code#
sRunHint (+) | #No TAG found in source code#

Classes
Class | Description
TSvCustomURLLabel (+) | Classe de base pour les label renvoyant à une URL
TSvURLLabel (+) | Label renvoyant à une URL

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SvImages)
Next (TypesInfo)


Sepi

Sepi
Previous
Next (TSvURLLabel)

Name
TSvCustomURLLabel

Parent
SvLabels

Class Hierarchy
TCustomLabel

Visibility
PUBLIC

Description
Classe de base pour les label renvoyant à une URL

Members
Fields
Field | Description
FURL (-) | URL vers laquelle renvoyer (vide utilise Caption)
Menu (-) | Menu contextuel par défaut

Methods
Method | Description
Click (+) | Exécuté lorsque l'utilisateur clique sur le lien
Create (+) | Crée une instance de TSvCustomURLLabel
Destroy (+) | Détruit l'instance
IsFontStored (-) | Indique si la fonte doit être stockée dans un flux dfm
IsPopupMenuStored (-) | Indique si le menu popup doit être stocké dans un flux dfm
MenuCopyClick (-) | Exécuté lorsque le menu Copier a été sélectionné
MenuRunClick (-) | Exécuté lorsque le menu Lancher a été sélectionné
RealURL (-) | Détermine l'URL exacte vers laquelle renvoyer

Properties
Property | Description
Cursor (#) | [@inheritDoc]
Font (#) | [@inheritDoc]
PopupMenu (#) | [@inheritDoc]
URL (#) | URL vers laquelle renvoyer (vide utilise Caption)

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous
Next (TSvURLLabel)


Sepi

Sepi
Previous
Next (Menu)

Name
FURL

Parent
TSvCustomURLLabel

Visibility
PRIVATE

Description
URL vers laquelle renvoyer (vide utilise Caption)

Source code
FURL : string

Sepi
Class Tree
Index
Previous
Next (Menu)


Sepi

Sepi
Previous (FURL)
Next

Name
Menu

Parent
TSvCustomURLLabel

Visibility
PRIVATE

Description
Menu contextuel par défaut

Source code
Menu : TPopupMenu

Sepi
Class Tree
Index
Previous (FURL)
Next


Sepi

Sepi
Previous
Next (Font)

Name
Cursor

Parent
TSvCustomURLLabel

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property Cursor default crHandPoint

Sepi
Class Tree
Index
Previous
Next (Font)


Sepi

Sepi
Previous (Cursor)
Next (PopupMenu)

Name
Font

Parent
TSvCustomURLLabel

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property Font stored IsFontStored

Sepi
Class Tree
Index
Previous (Cursor)
Next (PopupMenu)


Sepi

Sepi
Previous (Font)
Next (URL)

Name
PopupMenu

Parent
TSvCustomURLLabel

Visibility
PROTECTED

Description
[@inheritDoc]

Source code
property PopupMenu stored IsPopupMenuStored

Sepi
Class Tree
Index
Previous (Font)
Next (URL)


Sepi

Sepi
Previous (PopupMenu)
Next

Name
URL

Parent
TSvCustomURLLabel

Visibility
PROTECTED

Description
URL vers laquelle renvoyer (vide utilise Caption)

Source code
property URL : string read FURL write FURL

Read Access
FURL

Write Access
FURL

Sepi
Class Tree
Index
Previous (PopupMenu)
Next


Sepi

Sepi
Previous
Next (Create)

Name
Click

Parent
TSvCustomURLLabel

Visibility
PUBLIC

Description
Exécuté lorsque l'utilisateur clique sur le lien

Source code
procedure Click ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous
Next (Create)


Sepi

Sepi
Previous (Click)
Next (Destroy)

Name
Create

Parent
TSvCustomURLLabel

Visibility
PUBLIC

Description
Crée une instance de TSvCustomURLLabel

Source code
constructor Create ( AOwner : TComponent ) ; override

Parameters
Parameter | Description
AOwner : TComponent | Propriétaire

Sepi
Class Tree
Index
Previous (Click)
Next (Destroy)


Sepi

Sepi
Previous (Create)
Next (IsFontStored)

Name
Destroy

Parent
TSvCustomURLLabel

Visibility
PUBLIC

Description
Détruit l'instance

Source code
destructor Destroy ; override

Parameters
Parameter Description

Sepi
Class Tree
Index
Previous (Create)
Next (IsFontStored)


Sepi

Sepi
Previous (Destroy)
Next (IsPopupMenuStored)

Name
IsFontStored

Parent
TSvCustomURLLabel

Visibility
PRIVATE

Description
Indique si la fonte doit être stockée dans un flux dfm

Source code
function IsFontStored : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True : il faut toujours sauvegarder la fonte

Sepi
Class Tree
Index
Previous (Destroy)
Next (IsPopupMenuStored)


Sepi

Sepi
Previous (IsFontStored)
Next (MenuCopyClick)

Name
IsPopupMenuStored

Parent
TSvCustomURLLabel

Visibility
PRIVATE

Description
Indique si le menu popup doit être stocké dans un flux dfm

Source code
function IsPopupMenuStored : Boolean

Parameters
Parameter Description

Return
Types | Description
BOOLEAN | True si le menu popup est différent de celui par défaut, False sinon

Sepi
Class Tree
Index
Previous (IsFontStored)
Next (MenuCopyClick)


Sepi

Sepi
Previous (IsPopupMenuStored)
Next (MenuRunClick)

Name
MenuCopyClick

Parent
TSvCustomURLLabel

Visibility
PRIVATE

Description
Exécuté lorsque le menu Copier a été sélectionné

Source code
procedure MenuCopyClick ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement

Sepi
Class Tree
Index
Previous (IsPopupMenuStored)
Next (MenuRunClick)


Sepi

Sepi
Previous (MenuCopyClick)
Next (RealURL)

Name
MenuRunClick

Parent
TSvCustomURLLabel

Visibility
PRIVATE

Description
Exécuté lorsque le menu Lancher a été sélectionné

Source code
procedure MenuRunClick ( Sender : TObject )

Parameters
Parameter | Description
Sender : TObject | Objet qui a déclenché l'événement

Sepi
Class Tree
Index
Previous (MenuCopyClick)
Next (RealURL)


Sepi

Sepi
Previous (MenuRunClick)
Next

Name
RealURL

Parent
TSvCustomURLLabel

Visibility
PRIVATE

Description
Détermine l'URL exacte vers laquelle renvoyer

Source code
function RealURL : string

Parameters
Parameter Description

Return
Types | Description
STRING | URL exacte vers laquelle renvoyer

Sepi
Class Tree
Index
Previous (MenuRunClick)
Next


Sepi

Sepi
Previous (TSvCustomURLLabel)
Next

Name
TSvURLLabel

Parent
SvLabels

Class Hierarchy
TSvCustomURLLabel

Visibility
PUBLIC

Description
Label renvoyant à une URL

Members
Properties
Property | Description
Align (*) | #No TAG found in source code#
Alignment (*) | #No TAG found in source code#
Anchors (*) | #No TAG found in source code#
AutoSize (*) | #No TAG found in source code#
BiDiMode (*) | #No TAG found in source code#
Caption (*) | #No TAG found in source code#
Color (*) | #No TAG found in source code#
Constraints (*) | #No TAG found in source code#
DragCursor (*) | #No TAG found in source code#
DragKind (*) | #No TAG found in source code#
DragMode (*) | #No TAG found in source code#
EllipsisPosition (*) | #No TAG found in source code#
Enabled (*) | #No TAG found in source code#
FocusControl (*) | #No TAG found in source code#
Font (*) | #No TAG found in source code#
Layout (*) | #No TAG found in source code#
OnClick (*) | #No TAG found in source code#
OnContextPopup (*) | #No TAG found in source code#
OnDblClick (*) | #No TAG found in source code#
OnDragDrop (*) | #No TAG found in source code#
OnDragOver (*) | #No TAG found in source code#
OnEndDock (*) | #No TAG found in source code#
OnEndDrag (*) | #No TAG found in source code#
OnMouseActivate (*) | #No TAG found in source code#
OnMouseDown (*) | #No TAG found in source code#
OnMouseEnter (*) | #No TAG found in source code#
OnMouseLeave (*) | #No TAG found in source code#
OnMouseMove (*) | #No TAG found in source code#
OnMouseUp (*) | #No TAG found in source code#
OnStartDock (*) | #No TAG found in source code#
OnStartDrag (*) | #No TAG found in source code#
ParentBiDiMode (*) | #No TAG found in source code#
ParentColor (*) | #No TAG found in source code#
ParentFont (*) | #No TAG found in source code#
ParentShowHint (*) | #No TAG found in source code#
PopupMenu (*) | #No TAG found in source code#
ShowAccelChar (*) | #No TAG found in source code#
ShowHint (*) | #No TAG found in source code#
Transparent (*) | #No TAG found in source code#
URL (*) | #No TAG found in source code#
Visible (*) | #No TAG found in source code#
WordWrap (*) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (TSvCustomURLLabel)
Next


Sepi

Sepi
Previous
Next (Alignment)

Name
Align

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Align

Sepi
Class Tree
Index
Previous
Next (Alignment)


Sepi

Sepi
Previous (Align)
Next (Anchors)

Name
Alignment

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Alignment

Sepi
Class Tree
Index
Previous (Align)
Next (Anchors)


Sepi

Sepi
Previous (Alignment)
Next (AutoSize)

Name
Anchors

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Anchors

Sepi
Class Tree
Index
Previous (Alignment)
Next (AutoSize)


Sepi

Sepi
Previous (Anchors)
Next (BiDiMode)

Name
AutoSize

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property AutoSize

Sepi
Class Tree
Index
Previous (Anchors)
Next (BiDiMode)


Sepi

Sepi
Previous (AutoSize)
Next (Caption)

Name
BiDiMode

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property BiDiMode

Sepi
Class Tree
Index
Previous (AutoSize)
Next (Caption)


Sepi

Sepi
Previous (BiDiMode)
Next (Color)

Name
Caption

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Caption

Sepi
Class Tree
Index
Previous (BiDiMode)
Next (Color)


Sepi

Sepi
Previous (Caption)
Next (Constraints)

Name
Color

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Color nodefault

Sepi
Class Tree
Index
Previous (Caption)
Next (Constraints)


Sepi

Sepi
Previous (Color)
Next (DragCursor)

Name
Constraints

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Constraints

Sepi
Class Tree
Index
Previous (Color)
Next (DragCursor)


Sepi

Sepi
Previous (Constraints)
Next (DragKind)

Name
DragCursor

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property DragCursor

Sepi
Class Tree
Index
Previous (Constraints)
Next (DragKind)


Sepi

Sepi
Previous (DragCursor)
Next (DragMode)

Name
DragKind

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property DragKind

Sepi
Class Tree
Index
Previous (DragCursor)
Next (DragMode)


Sepi

Sepi
Previous (DragKind)
Next (EllipsisPosition)

Name
DragMode

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property DragMode

Sepi
Class Tree
Index
Previous (DragKind)
Next (EllipsisPosition)


Sepi

Sepi
Previous (DragMode)
Next (Enabled)

Name
EllipsisPosition

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property EllipsisPosition

Sepi
Class Tree
Index
Previous (DragMode)
Next (Enabled)


Sepi

Sepi
Previous (EllipsisPosition)
Next (FocusControl)

Name
Enabled

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Enabled

Sepi
Class Tree
Index
Previous (EllipsisPosition)
Next (FocusControl)


Sepi

Sepi
Previous (Enabled)
Next (Font)

Name
FocusControl

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property FocusControl

Sepi
Class Tree
Index
Previous (Enabled)
Next (Font)


Sepi

Sepi
Previous (FocusControl)
Next (Layout)

Name
Font

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Font

Sepi
Class Tree
Index
Previous (FocusControl)
Next (Layout)


Sepi

Sepi
Previous (Font)
Next (OnClick)

Name
Layout

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Layout

Sepi
Class Tree
Index
Previous (Font)
Next (OnClick)


Sepi

Sepi
Previous (Layout)
Next (OnContextPopup)

Name
OnClick

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnClick

Sepi
Class Tree
Index
Previous (Layout)
Next (OnContextPopup)


Sepi

Sepi
Previous (OnClick)
Next (OnDblClick)

Name
OnContextPopup

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnContextPopup

Sepi
Class Tree
Index
Previous (OnClick)
Next (OnDblClick)


Sepi

Sepi
Previous (OnContextPopup)
Next (OnDragDrop)

Name
OnDblClick

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDblClick

Sepi
Class Tree
Index
Previous (OnContextPopup)
Next (OnDragDrop)


Sepi

Sepi
Previous (OnDblClick)
Next (OnDragOver)

Name
OnDragDrop

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDragDrop

Sepi
Class Tree
Index
Previous (OnDblClick)
Next (OnDragOver)


Sepi

Sepi
Previous (OnDragDrop)
Next (OnEndDock)

Name
OnDragOver

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnDragOver

Sepi
Class Tree
Index
Previous (OnDragDrop)
Next (OnEndDock)


Sepi

Sepi
Previous (OnDragOver)
Next (OnEndDrag)

Name
OnEndDock

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnEndDock

Sepi
Class Tree
Index
Previous (OnDragOver)
Next (OnEndDrag)


Sepi

Sepi
Previous (OnEndDock)
Next (OnMouseActivate)

Name
OnEndDrag

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnEndDrag

Sepi
Class Tree
Index
Previous (OnEndDock)
Next (OnMouseActivate)


Sepi

Sepi
Previous (OnEndDrag)
Next (OnMouseDown)

Name
OnMouseActivate

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseActivate

Sepi
Class Tree
Index
Previous (OnEndDrag)
Next (OnMouseDown)


Sepi

Sepi
Previous (OnMouseActivate)
Next (OnMouseEnter)

Name
OnMouseDown

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseDown

Sepi
Class Tree
Index
Previous (OnMouseActivate)
Next (OnMouseEnter)


Sepi

Sepi
Previous (OnMouseDown)
Next (OnMouseLeave)

Name
OnMouseEnter

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseEnter

Sepi
Class Tree
Index
Previous (OnMouseDown)
Next (OnMouseLeave)


Sepi

Sepi
Previous (OnMouseEnter)
Next (OnMouseMove)

Name
OnMouseLeave

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseLeave

Sepi
Class Tree
Index
Previous (OnMouseEnter)
Next (OnMouseMove)


Sepi

Sepi
Previous (OnMouseLeave)
Next (OnMouseUp)

Name
OnMouseMove

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseMove

Sepi
Class Tree
Index
Previous (OnMouseLeave)
Next (OnMouseUp)


Sepi

Sepi
Previous (OnMouseMove)
Next (OnStartDock)

Name
OnMouseUp

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnMouseUp

Sepi
Class Tree
Index
Previous (OnMouseMove)
Next (OnStartDock)


Sepi

Sepi
Previous (OnMouseUp)
Next (OnStartDrag)

Name
OnStartDock

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnStartDock

Sepi
Class Tree
Index
Previous (OnMouseUp)
Next (OnStartDrag)


Sepi

Sepi
Previous (OnStartDock)
Next (ParentBiDiMode)

Name
OnStartDrag

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property OnStartDrag

Sepi
Class Tree
Index
Previous (OnStartDock)
Next (ParentBiDiMode)


Sepi

Sepi
Previous (OnStartDrag)
Next (ParentColor)

Name
ParentBiDiMode

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParentBiDiMode

Sepi
Class Tree
Index
Previous (OnStartDrag)
Next (ParentColor)


Sepi

Sepi
Previous (ParentBiDiMode)
Next (ParentFont)

Name
ParentColor

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParentColor

Sepi
Class Tree
Index
Previous (ParentBiDiMode)
Next (ParentFont)


Sepi

Sepi
Previous (ParentColor)
Next (ParentShowHint)

Name
ParentFont

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParentFont

Sepi
Class Tree
Index
Previous (ParentColor)
Next (ParentShowHint)


Sepi

Sepi
Previous (ParentFont)
Next (PopupMenu)

Name
ParentShowHint

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ParentShowHint

Sepi
Class Tree
Index
Previous (ParentFont)
Next (PopupMenu)


Sepi

Sepi
Previous (ParentShowHint)
Next (ShowAccelChar)

Name
PopupMenu

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property PopupMenu

Sepi
Class Tree
Index
Previous (ParentShowHint)
Next (ShowAccelChar)


Sepi

Sepi
Previous (PopupMenu)
Next (ShowHint)

Name
ShowAccelChar

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ShowAccelChar

Sepi
Class Tree
Index
Previous (PopupMenu)
Next (ShowHint)


Sepi

Sepi
Previous (ShowAccelChar)
Next (Transparent)

Name
ShowHint

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property ShowHint

Sepi
Class Tree
Index
Previous (ShowAccelChar)
Next (Transparent)


Sepi

Sepi
Previous (ShowHint)
Next (URL)

Name
Transparent

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Transparent

Sepi
Class Tree
Index
Previous (ShowHint)
Next (URL)


Sepi

Sepi
Previous (Transparent)
Next (Visible)

Name
URL

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property URL

Sepi
Class Tree
Index
Previous (Transparent)
Next (Visible)


Sepi

Sepi
Previous (URL)
Next (WordWrap)

Name
Visible

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property Visible

Sepi
Class Tree
Index
Previous (URL)
Next (WordWrap)


Sepi

Sepi
Previous (Visible)
Next

Name
WordWrap

Parent
TSvURLLabel

Visibility
PUBLISHED

Description
#Pas de TAG trouvé dans le code source#

Source code
property WordWrap

Sepi
Class Tree
Index
Previous (Visible)
Next


Sepi

Sepi
Previous
Next (sCopyHint)

Name
sCopyCaption

Parent
SvLabels

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sCopyCaption = 'Copier'

Sepi
Class Tree
Index
Previous
Next (sCopyHint)


Sepi

Sepi
Previous (sCopyCaption)
Next (sRunCaption)

Name
sCopyHint

Parent
SvLabels

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sCopyHint = 'Copier l''URL dans le presse-papier'

Sepi
Class Tree
Index
Previous (sCopyCaption)
Next (sRunCaption)


Sepi

Sepi
Previous (sCopyHint)
Next (sRunHint)

Name
sRunCaption

Parent
SvLabels

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sRunCaption = 'Lancer'

Sepi
Class Tree
Index
Previous (sCopyHint)
Next (sRunHint)


Sepi

Sepi
Previous (sRunCaption)
Next

Name
sRunHint

Parent
SvLabels

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
sRunHint = 'Lancer l''URL'

Sepi
Class Tree
Index
Previous (sRunCaption)
Next


Sepi

Sepi
Previous (SvLabels)
Next

Name
TypesInfo

Parent
Sepi

Description
Informations sur les types Sepi

Author
sjrd

Version
1.0

Methods
Method | Description
PrintComponentInfo (+) | #No TAG found in source code#
PrintConstInfo (+) | #No TAG found in source code#
PrintTypeInfo (+) | #No TAG found in source code#
PrintValue (+) | #No TAG found in source code#
PrintVarInfo (+) | #No TAG found in source code#

Legend
Symbol | Visibility
- Private
# Protected
+ Public
* Published
A | Automated
S | Strict

Sepi
Class Tree
Index
Previous (SvLabels)
Next


Sepi

Sepi
Previous
Next (PrintConstInfo)

Name
PrintComponentInfo

Parent
TypesInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintComponentInfo ( Output : TOutputWriter ; Component : TSepiComponent )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Component : TSepiComponent | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous
Next (PrintConstInfo)


Sepi

Sepi
Previous (PrintComponentInfo)
Next (PrintTypeInfo)

Name
PrintConstInfo

Parent
TypesInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintConstInfo ( Output : TOutputWriter ; Constant : TSepiConstant )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Constant : TSepiConstant | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrintComponentInfo)
Next (PrintTypeInfo)


Sepi

Sepi
Previous (PrintConstInfo)
Next (PrintValue)

Name
PrintTypeInfo

Parent
TypesInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintTypeInfo ( Output : TOutputWriter ; SepiType : TSepiType )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
SepiType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrintConstInfo)
Next (PrintValue)


Sepi

Sepi
Previous (PrintTypeInfo)
Next (PrintVarInfo)

Name
PrintValue

Parent
TypesInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintValue ( Output : TOutputWriter ; Value : Pointer ; ValueType : TSepiType )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Value : Pointer | #Pas de TAG trouvé dans le code source#
ValueType : TSepiType | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrintTypeInfo)
Next (PrintVarInfo)


Sepi

Sepi
Previous (PrintValue)
Next

Name
PrintVarInfo

Parent
TypesInfo

Visibility
PUBLIC

Description
#Pas de TAG trouvé dans le code source#

Source code
procedure PrintVarInfo ( Output : TOutputWriter ; Variable : TSepiVariable )

Parameters
Parameter | Description
Output : TOutputWriter | #Pas de TAG trouvé dans le code source#
Variable : TSepiVariable | #Pas de TAG trouvé dans le code source#

Sepi
Class Tree
Index
Previous (PrintValue)
Next